New Control Set V1.0.6 API Reference: mAbstractList

  • Main Page
  • Modules
  • Data Structures
  • Files
  • Directories

mAbstractList

Data Structures

  • struct mAbstractList
    The structure of mAbstractList, which derived from mScrollWidget. It is the abstract superclass of all classes which represent controls that have nodes. More...
  • struct mAbstractListClass
    The virtual function table of mAbstractList, which derived from mScrollWidgetClass. More...
  • struct mAbstractListRenderer
    The structure of mAbstractList renderer, which inheried from mScrollWidgetRenderer. More...

Defines

  • #define NCSS_ASTLST_AUTOSORT (0x0001<<NCSS_SWGT_SHIFT)
    Sort nodes automatically.
  • #define NCSS_ASTLST_SHIFT (NCSS_SWGT_SHIFT+1)
    The bits used by mAbstractList in style.

Enumerations

  • enum mAbstractListNotify { NCSN_ASTLST_MAX = NCSN_SWGT_MAX + 1 }
    The notification id of mAbstractList. More...
  • enum mAbstractListProperty {
    NCSP_ASTLST_DEFNODEHEIGHT = NCSP_SWGT_MAX + 1, NCSP_ASTLST_FONTSIZE, NCSP_ASTLST_AUTOSORT, NCSP_ASTLST_TRANSPARENT,
    NCSP_ASTLST_CMPNODEFUNC, NCSP_ASTLST_ROOTNODE , NCSP_ASTLST_MAX
    }
    The properties id of mAbstractList. More...

Functions

  • mAbstractList * mAbstractList_getControl (mNode *node)
    Get the associated control handle of the specified node.

Variables

  • MGNCS_EXPORT mAbstractListClass g_stmAbstractListCls
    The instance of mAbstractListClass.

Detailed Description

Id
mabstractlist.h 1803 2010-03-19 02:21:53Z dongjunjie

Copyright (C) 2009 Feynman Software.

Define Documentation

#define NCSS_ASTLST_AUTOSORT (0x0001<<NCSS_SWGT_SHIFT)

Sort nodes automatically.

Definition at line 56 of file mabstractlist.h.

#define NCSS_ASTLST_SHIFT (NCSS_SWGT_SHIFT+1)

The bits used by mAbstractList in style.

Definition at line 62 of file mabstractlist.h.

Enumeration Type Documentation

enum mAbstractListNotify

The notification id of mAbstractList.

Enumerator:
NCSN_ASTLST_MAX The maximum value of mAbstractList notification code id.

Definition at line 219 of file mabstractlist.h.

enum mAbstractListProperty

The properties id of mAbstractList.

Enumerator:
NCSP_ASTLST_DEFNODEHEIGHT | The default node height. It should be implemented by subclass.
NCSP_ASTLST_FONTSIZE | The window font size. RO.
NCSP_ASTLST_AUTOSORT | Whether the window sorts nodes automatically or not. RO.
NCSP_ASTLST_TRANSPARENT | Whether the window is transparent or not. RO.
NCSP_ASTLST_CMPNODEFUNC | The node comparision function. (NCS_CB_CMPNODE)
NCSP_ASTLST_ROOTNODE | The root node. RO.
NCSP_ASTLST_MAX | The maximum value of mAbstractList properties id.

Definition at line 231 of file mabstractlist.h.

Function Documentation

mAbstractList * mAbstractList_getControl ( mNode * node )

Get the associated control handle of the specified node.

Parameters:
node The specified node.
Returns:
The handle of associated control, otherwise NULL.

Variable Documentation

g_stmAbstractListCls

The instance of mAbstractListClass.

See also:
mAbstractListClass

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mAbstractList Struct Reference

  • Files
  • Directories
  • Alphabetical List
  • Data Structures
  • Data Fields

mAbstractList Struct Reference
[mAbstractList]

The structure of mAbstractList, which derived from mScrollWidget. It is the abstract superclass of all classes which represent controls that have nodes. More...

#include <mabstractlist.h>

Detailed Description

The structure of mAbstractList, which derived from mScrollWidget. It is the abstract superclass of all classes which represent controls that have nodes.

  • root
    The root node.

  • defNodeH
    The default height of node.

  • flags
    Internal used.
The documentation for this struct was generated from the following file:
  • mabstractlist.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mAbstractListClass Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mAbstractListClass Struct Reference
[mAbstractList]

The virtual function table of mAbstractList, which derived from mScrollWidgetClass. More...

#include <mabstractlist.h>

Detailed Description

The virtual function table of mAbstractList, which derived from mScrollWidgetClass.

  • int (*addNode)(mAbstractList *self, mNode *node);
    Add a new node. Please used by subclass directly.
    Parameters:
    node The pointer to new node.
    Returns:
    The index of new node in parent.
  • int (*insertNode)(mAbstractList *self, mNode *node, mNode *prev,mNode *next, int index);
    Insert a node. Please used by subclass directly.
    Parameters:
    node | The pointer to new node.
    prev | The specified previous sibling node. It has the highest priority.
    prev | The specified next sibling node. The priority is less than prev.
    index | The specified insert position. It has the lowest priority.
    Returns:
    The position in which item has been inserted on success, otherwise -1.
  • int (*removeNode)(mAbstractList *self, mNode *node);
    Remove a child node. It deletes all chilren nodes of the specified node. Please used by subclass directly.
    Parameters:
    node The pointer to child node.
    Returns:
    0 on success, otherwise -1.
  • mNode* (*getNode)(mAbstractList *self, int index);
    Get the specified node. Please used by subclass directly.
    Parameters:
    index The specified index.
    Returns:
    The pointer to the specified node.
  • int (*indexOf)(mAbstractList *self, mNode *node);
    Get the index of the specified node in parent node. Please used by subclass directly.
    Returns:
    The index of the specified node.
  • BOOL (*isFrozen)(mAbstractList *self);
    The function determines whether control is frozen. If frozen, control will not refresh nodes until unfrozen it. Please used by subclass directly.

  • BOOL (*showNode)(mAbstractList *self, mNode *node);
    Refresh the specified node and make it visible. Please used directly by subclass.

  • void (*refreshNode)(mAbstractList *self, mNode *node, const RECT *rcInv);
    Refresh the specified node. Please used by subclass directly.

  • mNode* (*findNode)(mAbstractList *self, DWORD info, int type, BOOL recursion, int startIndex);
    Find the node which contains the specified information from start index to end of nodes. Please used by subclass directly.
    Parameters:
    info | The valid information.
    type | The type of valid information.
    recursion | Whether find in children or not.
    startIndex | The started index.
    Returns:
    The pointer to found node.
  • int (*getRect)(mAbstractList *self, mNode *node, RECT *rcNode, BOOL bConv);
    Get the specified node's rectangle. It should be implemented by subclass.
    Parameters:
    node | The specified node.
    rcNode | The node's rectangle.
    bConv | Whether transform content to window coordinate or not.
    Returns:
    Zero on success, otherwise -1.
  • void (*freeze)(mAbstractList *self, BOOL locked);
    Freeze the control or not. It should be implemented by subclass.

  • void (*sortNodes)(mAbstractList *self, NCS_CB_CMPNODE func, mNode *parentNode);
    Sort all children of specified node using the specified function. Please used by subclass directly.
    Parameters:
    func | The node comparision function.
    parentNode | The parent node.
  • void (*notifyEvent)(mAbstractList *self, int eventId, DWORD eventInfo);
    Process the event from the node. It should be implemented by subclass.
    Parameters:
    eventId | The event id.
    eventInfo | The event information.
The documentation for this struct was generated from the following file:
  • mabstractlist.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mAbstractListRenderer Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mAbstractListRenderer Struct Reference
[mAbstractList]

The structure of mAbstractList renderer, which inheried from mScrollWidgetRenderer. More...

#include <mabstractlist.h>

Detailed Description

The structure of mAbstractList renderer, which inheried from mScrollWidgetRenderer.
The documentation for this struct was generated from the following file:
  • mabstractlist.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mButton

mButton

Data Structures

  • struct mButton
    Button class, derived from mWidget. More...
  • struct mButtonClass
    button struct of button control, derived from mWidgetClass More...
  • struct mButtonRenderer
    Button class renderer interface, derived from mWidgetRenderer. More...

Defines

  • #define NCSCTRL_BUTTON NCSCLASSNAME("button")
    the name of button control
  • #define NCSS_BUTTON_IMAGE (1<<NCSS_WIDGET_SHIFT)
    indicate a image button
  • #define NCSS_BUTTON_CHECKABLE (2<<NCSS_WIDGET_SHIFT)
    indicate a chackable button
  • #define NCSS_BUTTON_AUTOCHECK (4<<NCSS_WIDGET_SHIFT)
    indicate a auto check button
  • #define NCSS_BUTTON_3DCHECK (8<<NCSS_WIDGET_SHIFT)
    indicate a three type (unchecked-halfchekced-checked) check button
  • #define NCSS_BUTTON_IMAGELABEL (0x10<<NCSS_WIDGET_SHIFT)
    indicate a button with image and label
  • #define NCSS_BUTTON_VERTIMAGELABEL (0x20<<NCSS_WIDGET_SHIFT)
    indicate a button with vertical image and label

Enumerations

  • enum mButtonCheckState { NCS_BUTTON_UNCHECKED = 0, NCS_BUTTON_HALFCHECKED, NCS_BUTTON_CHECKED }
    define the check state of button More...
  • enum mButtonProp {
    NCSP_BUTTON_ALIGN = NCSP_WIDGET_MAX + 1, NCSP_BUTTON_VALIGN, NCSP_BUTTON_WORDWRAP, NCSP_BUTTON_IMAGE,
    NCSP_BUTTON_CHECKSTATE, NCSP_BUTTON_IMAGE_SIZE_PERCENT, NCSP_BUTTON_GROUPID, NCSP_BUTTON_GROUP
    }
    the properties id of mButton More...
  • enum eButtonNotify { NCSN_BUTTON_PUSHED = NCSN_WIDGET_MAX + 1, NCSN_BUTTON_STATE_CHANGED }
    the notification code of mButton More...

Variables

  • MGNCS_EXPORT mButtonClass g_stmButtonCls
    global mButtonClass

Define Documentation

#define NCSCTRL_BUTTON NCSCLASSNAME("button")

the name of button control

Definition at line 18 of file mbutton.h.

#define NCSS_BUTTON_3DCHECK (8<<NCSS_WIDGET_SHIFT)

indicate a three type (unchecked-halfchekced-checked) check button

Note:
This style must combine with NCSS_BUTTON_3DCHECK

Definition at line 245 of file mbutton.h.

#define NCSS_BUTTON_AUTOCHECK (4<<NCSS_WIDGET_SHIFT)

indicate a auto check button

Note:
This style must combine with NCSS_BUTTON_CHECKABLE

Definition at line 239 of file mbutton.h.

#define NCSS_BUTTON_CHECKABLE (2<<NCSS_WIDGET_SHIFT)

indicate a chackable button

Definition at line 233 of file mbutton.h.

#define NCSS_BUTTON_IMAGE (1<<NCSS_WIDGET_SHIFT)

indicate a image button

Definition at line 228 of file mbutton.h.

#define NCSS_BUTTON_IMAGELABEL (0x10<<NCSS_WIDGET_SHIFT)

indicate a button with image and label

Note:
by default, image and label are lined up horizontal

Definition at line 251 of file mbutton.h.

#define NCSS_BUTTON_VERTIMAGELABEL (0x20<<NCSS_WIDGET_SHIFT)

indicate a button with vertical image and label

Note:
This sytle must combine with NCSS_BUTTON_IMAGELABEL

Definition at line 257 of file mbutton.h.

Enumeration Type Documentation

enum eButtonNotify

the notification code of mButton

Enumerator:
NCSN_BUTTON_PUSHED button pushed
NCSN_BUTTON_STATE_CHANGED button check state changed

Parameters:
the new check state
See also:
NCSP_BUTTON_CHECKSTATE

Definition at line 208 of file mbutton.h.

enum mButtonCheckState

define the check state of button

Enumerator:
NCS_BUTTON_UNCHECKED | button unchecked state, the button is not pushed down
NCS_BUTTON_HALFCHECKED | button halfchecked state, it is a state between checked and unchecked, halfchecked state is valid if the button is a 3-state button
NCS_BUTTON_CHECKED | button checked state, the button is pushed down

Definition at line 29 of file mbutton.h.

enum mButtonProp

the properties id of mButton

Enumerator:
NCSP_BUTTON_ALIGN Set the button text horizontal align
  • Type enumNCSAlign
  • Read Write
  • set the horizontal align value of the text on button.
NCSP_BUTTON_VALIGN Set the button text vertical align
  • Type enumNCSVAlign
  • Read Write
  • set the vertical align value of the text on button.
NCSP_BUTTON_WORDWRAP Set the button text to autowrap mode
  • Type int
  • Read Write
  • turn on/off the autowrap mode of button text.
NCSP_BUTTON_IMAGE Set the button image pointer
  • Type PBITMAP
  • Read Write
  • Set the image pointer for the image displayed on button.
NCSP_BUTTON_CHECKSTATE Set the check state of button
  • Type mButtonCheckState
  • Read Write
  • set the check state of button to checked/half-checked/unchecked.
NCSP_BUTTON_IMAGE_SIZE_PERCENT Set the image size
  • Type int
  • Read Write
  • Set the image size percent on button, it should be >=15 and <=85, this property works when the button has NCSS_BUTTON_IMAGELABEL style.
NCSP_BUTTON_GROUPID Set the button group id
  • Type int
  • Read Write
  • Set the the button group id.
NCSP_BUTTON_GROUP Set the button group
  • Type mButtonGroup*
  • Read Write
  • Set the button group pointer.

Definition at line 135 of file mbutton.h.

Variable Documentation

g_stmButtonCls

global mButtonClass

global mToolBarClass

global mStaticClass

global mLEDLabelClass

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mButton Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mButton Struct Reference
[mButton]

Button class, derived from mWidget. More...

#include <mbutton.h>

Detailed Description

Button class, derived from mWidget.

  • mWidget * group - the pointer of button group

See also:
mWidget
The documentation for this struct was generated from the following file:
  • mbutton.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mButtonClass Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mButtonClass Struct Reference
[mButton]

button struct of button control, derived from mWidgetClass More...

#include <mbutton.h>

Detailed Description

button struct of button control, derived from mWidgetClass

See also:
mWidgetClass
  • mObject * (*createContent)( clsName *self, DWORD dwStyle);
    create button content based on button style
    Parameters:
    *self | - this pointer of button
    dwStyle | - the style of button
    Returns:
    mObject * the button content
  • mObject * (*createButtonBody)( clsName *self, DWORD dwStyle, mObject * content);
    create button body
    Parameters:
    *self | - this pointer of button
    dwStyle | - the style of button
    *content | - the content of button
    Returns:
    mObject * the button body
The documentation for this struct was generated from the following file:
  • mbutton.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mButtonRenderer Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mButtonRenderer Struct Reference
[mButton]

Button class renderer interface, derived from mWidgetRenderer. More...

#include <mbutton.h>

Detailed Description

Button class renderer interface, derived from mWidgetRenderer.

See also:
mButton, mButtonClass, mWidgetRenderer
  • void (*drawPushButton)( clsName *self, HDC hdc, const RECT *rect, DWORD color1, DWORD color2, int status);
    draw button using diffrent renderer
    Parameters:
    *self | - this pointer of button
    hdc | - DC of control
    *rect | - the rectangle to draw button frame
    color1 | - the color 1 for renderer
    color2 | - the color 2 for renderer
    status | - the button state
The documentation for this struct was generated from the following file:
  • mbutton.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mButtonGroup

mButtonGroup

Data Structures

  • struct _mButtonNode
    the list node include member button More...
  • struct mButtonGroup
    A group control, mamanger a list of buttons, in which only one button can be selected. Derived from mGroupBox. More...
  • struct mButtonGroupClass
    struct of mButtonGroupClass control, derived from mGroupBoxClass More...
  • struct mButtonGroupRenderer
    mButtonGroup renderer interface, derived from mGroupBoxRenderer More...

Defines

  • #define NCSCTRL_BUTTONGROUP NCSCLASSNAME("buttongroup")
    name of buttongroup control

Enumerations

  • enum mButtonGroupProp { NCSP_BTNGRP_SELID = NCSP_GRPBOX_MAX + 1, NCSP_BTNGRP_SELIDX, NCSP_BTNGRP_SELOBJ }
    properties of mButtonGroup More...
  • enum enumButtonGroupNotify { NCSN_BTNGRP_SELCHANGED = NCSN_GRPBOX_MAX + 1 }
    notification code of mButtonGroup More...

Variables

  • MGNCS_EXPORT mButtonGroupClass g_stmButtonGroupCls
    global mButtonGroupClass

Define Documentation

#define NCSCTRL_BUTTONGROUP NCSCLASSNAME("buttongroup")

name of buttongroup control

Definition at line 18 of file mbuttongroup.h.

Enumeration Type Documentation

enum enumButtonGroupNotify

notification code of mButtonGroup

Enumerator:
NCSN_BTNGRP_SELCHANGED raised when the current button changed

Parameters:
the id of new selected button
See also:
NCSP_BTNGRP_SELID

Definition at line 152 of file mbuttongroup.h.

enum mButtonGroupProp

properties of mButtonGroup

Enumerator:
NCSP_BTNGRP_SELID get/set selected id of button
  • Type: int
  • Read Write
  • Change the state of buttons

See also:
NCSP_BTNGRP_SELIDX, NCSP_BTNGRP_SELOBJ
NCSP_BTNGRP_SELIDX set/set selected index
  • Type: idx
  • Read Write
  • Change the state of buttons

See also:
NCSP_BTNGRP_SELID, NCSP_BTNGRP_SELOBJ
NCSP_BTNGRP_SELOBJ set/get selected object
  • Type: mWidget* (mButton*)
  • Read Write
  • Change the state of button

See also:
NCSP_BTNGRP_SELID, NCSP_BTNGRP_SELIDX

Definition at line 117 of file mbuttongroup.h.

Variable Documentation

g_stmButtonGroupCls

global mButtonGroupClass

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: _mButtonNode Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_mButtonNode Struct Reference
[mButtonGroup]

the list node include member button More...

#include <mbuttongroup.h>

Detailed Description

the list node include member button

  • mWidget *pbtn
    button pointer
  • mButtonNode *next
    pointer to next button node

Definition at line 35 of file mbuttongroup.h.

The documentation for this struct was generated from the following file:
  • mbuttongroup.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mButtonGroup Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mButtonGroup Struct Reference
[mButtonGroup]

A group control, mamanger a list of buttons, in which only one button can be selected. Derived from mGroupBox. More...

#include <mbuttongroup.h>

Detailed Description

A group control, mamanger a list of buttons, in which only one button can be selected. Derived from mGroupBox.

  • mButtonNode *pBtnList
    button list
The documentation for this struct was generated from the following file:
  • mbuttongroup.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mButtonGroupClass Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mButtonGroupClass Struct Reference
[mButtonGroup]

struct of mButtonGroupClass control, derived from mGroupBoxClass More...

#include <mbuttongroup.h>

Detailed Description

struct of mButtonGroupClass control, derived from mGroupBoxClass

  • BOOL (*addButton)(clsName *group, mWidget *button);
    add a button to the list
    Parameters:
    *group | - pointer of the mButtonGroup
    *button | - pointer of the button to add
    Returns:
    TRUE - button added, FALSE - failed to add button
  • BOOL (*checkBtn)(clsName *group, mWidget *btn_to_check);
    change the check state of button
    Parameters:
    *group | - the pointer of button group
    *btn_to_check | - the pointer of button
    Returns:
    TRUE - button checked, FALSE - fail to check button:w
The documentation for this struct was generated from the following file:
  • mbuttongroup.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mButtonGroupRenderer Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mButtonGroupRenderer Struct Reference
[mButtonGroup]

mButtonGroup renderer interface, derived from mGroupBoxRenderer More...

#include <mbuttongroup.h>

Detailed Description

mButtonGroup renderer interface, derived from mGroupBoxRenderer

  • void (*drawButtongroup)(clsName *self, HDC hdc, const RECT *pRect);
    draw buttongroup using renderer
    Parameters:
    *self | - this pointer of buttongroup
    hdc | - dc of control
    *pRect | - pointer of the rectangle to draw the buttongroup
The documentation for this struct was generated from the following file:
  • mbuttongroup.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mCheckButton

mCheckButton

Data Structures

  • struct mCheckButton
    CheckButton, derived from mButton. More...
  • struct mCheckButtonClass
    checkbutton class struct of button control, derived from mButtonClass More...
  • struct mCheckButtonRenderer
    Checkbutton class renderer interface, derived from mButtonRenderer. More...

Defines

  • #define NCSCTRL_CHECKBUTTON NCSCLASSNAME("checkbutton")
    the name of checkbutton class

Enumerations

  • enum mCheckButtonProp
    the properties id of mCheckButton, derived from mButtonProp More...
  • enum mCheckButtonNotify
    the notification id of mCheckButton More...

Variables

  • MGNCS_EXPORT mCheckButtonClass g_stmCheckButtonCls
    global mCheckButtonClass

Define Documentation

#define NCSCTRL_CHECKBUTTON NCSCLASSNAME("checkbutton")

the name of checkbutton class

Definition at line 20 of file mcheckbutton.h.

Enumeration Type Documentation

enum mCheckButtonNotify

the notification id of mCheckButton

Definition at line 95 of file mcheckbutton.h.

enum mCheckButtonProp

the properties id of mCheckButton, derived from mButtonProp

Definition at line 86 of file mcheckbutton.h.

Variable Documentation

g_stmCheckButtonCls

global mCheckButtonClass

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mCheckButton Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mCheckButton Struct Reference
[mCheckButton]

CheckButton, derived from mButton. More...

#include <mcheckbutton.h>

Detailed Description

CheckButton, derived from mButton.
The documentation for this struct was generated from the following file:
  • mcheckbutton.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mCheckButtonClass Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mCheckButtonClass Struct Reference
[mCheckButton]

checkbutton class struct of button control, derived from mButtonClass More...

#include <mcheckbutton.h>

Detailed Description

checkbutton class struct of button control, derived from mButtonClass
The documentation for this struct was generated from the following file:
  • mcheckbutton.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mCheckButtonRenderer Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mCheckButtonRenderer Struct Reference
[mCheckButton]

Checkbutton class renderer interface, derived from mButtonRenderer. More...

#include <mcheckbutton.h>

Detailed Description

Checkbutton class renderer interface, derived from mButtonRenderer.

See also:
mCheckButton, mCheckButtonClass, mButton, mButtonClass
  • void (*drawCheckbutton)( clsName *self, HDC hdc, const Rect *pRect, int status); draw checkbutton using renderer
    Parameters:
    *self | - this pointer of checkbutton
    hdc | - DC of control
    *pRect | - the rectangle of checkbutton frame
    status | - the button state
The documentation for this struct was generated from the following file:
  • mcheckbutton.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mColorButton

mColorButton

Data Structures

  • struct mColorButton
    A Button used to select a color, derived from mWidget. More...
  • struct mColorButtonClass
    struct of colorbutton control class, derived from mWidgetClass More...
  • struct mColorButtonRenderer
    colorbutton renderer interface, derived from mWidgetRenderer More...

Defines

  • #define NCSCTRL_COLORBUTTON NCSCLASSNAME("colorbutton")
    the name of colorbutton control

Enumerations

  • enum mColorButtonProp { NCSP_CLRBTN_CURCOLOR = NCSP_WIDGET_MAX + 1 }
    properties id of mColorButton More...
  • enum enumColorButtonNotify { NCSN_CLRBTN_COLORCHANGED = NCSN_WIDGET_MAX + 1 }
    notification code of mColorButton More...

Variables

  • MGNCS_EXPORT mColorButtonClass g_stmColorButtonCls
    global mColorButtonClass

Define Documentation

#define NCSCTRL_COLORBUTTON NCSCLASSNAME("colorbutton")

the name of colorbutton control

Definition at line 19 of file mcolorbutton.h.

Enumeration Type Documentation

enum enumColorButtonNotify

notification code of mColorButton

Enumerator:
NCSN_CLRBTN_COLORCHANGED raised when user select color

Parameters:
the value of the selected color (ARGB)
See also:
NCSP_CLRBTN_CURCOLOR

Definition at line 94 of file mcolorbutton.h.

enum mColorButtonProp

properties id of mColorButton

Enumerator:
NCSP_CLRBTN_CURCOLOR set/get the color value of referred controller
  • Type: DWORD(ARGB)
  • Read Write
  • Change the color value of referred controller

Definition at line 76 of file mcolorbutton.h.

Variable Documentation

g_stmColorButtonCls

global mColorButtonClass

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mColorButton Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mColorButton Struct Reference
[mColorButton]

A Button used to select a color, derived from mWidget. More...

#include <mcolorbutton.h>

Detailed Description

A Button used to select a color, derived from mWidget.

See also:
mWidget
The documentation for this struct was generated from the following file:
  • mcolorbutton.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mColorButtonClass Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mColorButtonClass Struct Reference
[mColorButton]

struct of colorbutton control class, derived from mWidgetClass More...

#include <mcolorbutton.h>

Detailed Description

struct of colorbutton control class, derived from mWidgetClass

See also:
mWidgetClass
The documentation for this struct was generated from the following file:
  • mcolorbutton.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mColorButtonRenderer Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mColorButtonRenderer Struct Reference
[mColorButton]

colorbutton renderer interface, derived from mWidgetRenderer More...

#include <mcolorbutton.h>

Detailed Description

colorbutton renderer interface, derived from mWidgetRenderer
The documentation for this struct was generated from the following file:
  • mcolorbutton.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mCombobox

mCombobox

Data Structures

  • struct mCombobox
    the struct of combobox control, derived from mPanel. More...
  • struct mComboboxClass
    the VTable of mCombobox, derived from mPanelClass. More...
  • struct mComboboxRenderer
    Combobox class's Renderer interface, derived from mPanelRenderer. More...

Defines

  • #define NCSCTRL_COMBOBOX NCSCLASSNAME("combobox")
    the name of combobox control
  • #define NCSS_CMBOX_SIMPLE 0x0000L
    simle combobox, the list box is always show.
  • #define NCSS_CMBOX_DROPDOWNLIST (0x0001L<<NCSS_PANEL_SHIFT)
    dropdownlist combobox, the list box will be shown when user click the dropdown button.
  • #define NCSS_CMBOX_SORT (0x0002L<<NCSS_PANEL_SHIFT)
    combobox with the auto sort list.
  • #define NCSS_CMBOX_EDITNOBORDER (0x0004L<<NCSS_PANEL_SHIFT)
    combobox with no-border edit.
  • #define NCSS_CMBOX_EDITBASELINE (0x0008L<<NCSS_PANEL_SHIFT)
    combobox with base-line edit.
  • #define NCSS_CMBOX_READONLY (0x0010L<<NCSS_PANEL_SHIFT)
    combobox with read-only edit.
  • #define NCSS_CMBOX_UPPERCASE (0x0020L<<NCSS_PANEL_SHIFT)
    combobox with upper-case edit.
  • #define NCSS_CMBOX_LOWERCASE (0x0040L<<NCSS_PANEL_SHIFT)
    combobox with lower-case edit.
  • #define NCSS_CMBOX_AUTOFOCUS (0x0080L<<NCSS_PANEL_SHIFT)
    combobox with auto focus edit.

Enumerations

  • enum mComboboxProp {
    NCSP_COMB_ITEMHEIGHT = NCSP_LSTBOX_ITEMHEIGHT, NCSP_COMB_ITEMCOUNT = NCSP_LSTBOX_ITEMCOUNT, NCSP_COMB_DROPDOWNHEIGHT = NCSP_PANEL_MAX + 1, NCSP_COMB_TEXTLIMIT,
    NCSP_COMB_SELECT
    }
    the properties id of mCombobox More...
  • enum enumComboboxNotify {
    NCSN_CMBOX_SELCHANGE = NCSN_PANEL_MAX + 1, NCSN_CMBOX_SETFOCUS, NCSN_CMBOX_KILLFOCUS, NCSN_CMBOX_EDITCHANGE,
    NCSN_CMBOX_DROPDOWN, NCSN_CMBOX_CLOSEUP, NCSN_CMBOX_SELECTOK, NCSN_CMBOX_SELECTCANCEL
    }

Define Documentation

#define NCSCTRL_COMBOBOX NCSCLASSNAME("combobox")

the name of combobox control

Definition at line 37 of file mcombobox.h.

#define NCSS_CMBOX_AUTOFOCUS (0x0080L<<NCSS_PANEL_SHIFT)

combobox with auto focus edit.

Definition at line 234 of file mcombobox.h.

#define NCSS_CMBOX_DROPDOWNLIST (0x0001L<<NCSS_PANEL_SHIFT)

dropdownlist combobox, the list box will be shown when user click the dropdown button.

Definition at line 192 of file mcombobox.h.

#define NCSS_CMBOX_EDITBASELINE (0x0008L<<NCSS_PANEL_SHIFT)

combobox with base-line edit.

Definition at line 210 of file mcombobox.h.

#define NCSS_CMBOX_EDITNOBORDER (0x0004L<<NCSS_PANEL_SHIFT)

combobox with no-border edit.

Definition at line 204 of file mcombobox.h.

#define NCSS_CMBOX_LOWERCASE (0x0040L<<NCSS_PANEL_SHIFT)

combobox with lower-case edit.

Definition at line 228 of file mcombobox.h.

#define NCSS_CMBOX_READONLY (0x0010L<<NCSS_PANEL_SHIFT)

combobox with read-only edit.

Definition at line 216 of file mcombobox.h.

#define NCSS_CMBOX_SIMPLE 0x0000L

simle combobox, the list box is always show.

Definition at line 186 of file mcombobox.h.

#define NCSS_CMBOX_SORT (0x0002L<<NCSS_PANEL_SHIFT)

combobox with the auto sort list.

Definition at line 198 of file mcombobox.h.

#define NCSS_CMBOX_UPPERCASE (0x0020L<<NCSS_PANEL_SHIFT)

combobox with upper-case edit.

Definition at line 222 of file mcombobox.h.

Enumeration Type Documentation

enum enumComboboxNotify

Combobox Notify Codes:

Enumerator:
NCSN_CMBOX_SELCHANGE | selected item have been changed
NCSN_CMBOX_SETFOCUS | control have gaint the focus
NCSN_CMBOX_KILLFOCUS | control have lost the focue
NCSN_CMBOX_EDITCHANGE | the content of edit have been changed
NCSN_CMBOX_DROPDOWN | the dropdown list have been shown
NCSN_CMBOX_CLOSEUP | the dropdown list have been hiden
NCSN_CMBOX_SELECTOK | an item have been selected
NCSN_CMBOX_SELECTCANCEL | an item have been canceled its selected state

Definition at line 240 of file mcombobox.h.

enum mComboboxProp

the properties id of mCombobox

Enumerator:
NCSP_COMB_ITEMHEIGHT Set/Get height of list item
  • Type int
  • Read Write.
NCSP_COMB_ITEMCOUNT Get the count of list items
  • Type int
  • ReadOnly.
NCSP_COMB_DROPDOWNHEIGHT Get/Set the height of dropdown list
  • Type int
  • Read Write
  • the dropdown list height.
NCSP_COMB_TEXTLIMIT Get/Set the Text limit of edit
  • Type int
  • Read Write
  • the max length of edit accepted.

the text limit of edit

NCSP_COMB_SELECT Get/Set the selected item of list
  • Type int
  • Read Write
  • The selected item index.

the the selected item

Definition at line 144 of file mcombobox.h.

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mCombobox Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mCombobox Struct Reference
[mCombobox]

the struct of combobox control, derived from mPanel. More...

#include <mcombobox.h>

Detailed Description

the struct of combobox control, derived from mPanel.

  • listbox
    The listbox control.
  • edit
    The edit control.
  • rcList
    The Rectangle of the listbox control.
  • rcEdit
    The Rectangle of the edit control.
  • rcBtn
    The Rectangle of the button.(only used by dropdown style one)
  • flag
    The flag mark for status
  • dropWidth
    The width of the dropdown list

See also:
mComboboxRenderer, mComboboxClass
The documentation for this struct was generated from the following file:
  • mcombobox.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mComboboxClass Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mComboboxClass Struct Reference
[mCombobox]

the VTable of mCombobox, derived from mPanelClass. More...

#include <mcombobox.h>

Detailed Description

the VTable of mCombobox, derived from mPanelClass.

See also:
mPanelClass
  • BOOL addItem(mCombobox *self, char *item, DWORD addData);
    add a item to the list
    Parameters:
    item | - the item to add
    addData | - the additional data
  • BOOL removeItem(mCombobox *self, int index);
    remove a item from the list
    Parameters:
    index - the item index to remove
  • BOOL setItem(mCombobox *self, int index, const char *item);
    set the content of one item
    Parameters:
    index | - the item index to set
    item | - the content to set
  • char * getItem(mCombobox *self, int index);
    get the content of one item
    Parameters:
    index - the item index to get
The documentation for this struct was generated from the following file:
  • mcombobox.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mComboboxRenderer Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mComboboxRenderer Struct Reference
[mCombobox]

Combobox class's Renderer interface, derived from mPanelRenderer. More...

#include <mcombobox.h>

Detailed Description

Combobox class's Renderer interface, derived from mPanelRenderer.

See also:
mCombobox, mComboboxClass
  • void drawDropDownBtn(mCombobox *self, HDC hdc, const RECT *rc);
    draw the drop down button
    Parameters:
    hdc | - the DC in which draw button
    rc- | the Rectange of the button
The documentation for this struct was generated from the following file:
  • mcombobox.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mComponent

mComponent

Data Structures

  • struct _NCS_EVENT_HANDLER_NODE
  • struct mComponentClass
    the basic class of components, windows. Drived by mObjectClass More...
  • struct mComponent
    the component member define More...

Defines

  • #define MAXLEN_CLASSNAME 15
    the max length of class name
  • #define NCSCLASSNAME(name) name _MGNCS_CLASS_SUFFIX
    the NCS class name surfix, (_MGNCS_CLASS_SUFFIX ("_")), distinguish from old constrol set

Enumerations

  • enum ncsComponentReleated { NCS_CMPT_NEXT = 0, NCS_CMPT_PREV, NCS_CMPT_PARENT, NCS_CMPT_CHILDREN }
    The releation between components. More...
  • enum mComponentQueryCmd {
    QPC_SET_PROP = 0, QPC_GET_PROP, QPC_ADD_EVENT, QPC_ADD_BIND,
    QPC_USER
    }
    queryByPath and vqueryByPath's cmd_id More...

Variables

  • MGNCS_EXPORT mComponentClass g_stmComponentCls
    the singleton of mComponentClass

Define Documentation

#define MAXLEN_CLASSNAME 15

the max length of class name

Definition at line 34 of file mcomponent.h.

#define NCSCLASSNAME ( name ) name _MGNCS_CLASS_SUFFIX

the NCS class name surfix, (_MGNCS_CLASS_SUFFIX ("_")), distinguish from old constrol set

Definition at line 39 of file mcomponent.h.

Enumeration Type Documentation

enum mComponentQueryCmd

queryByPath and vqueryByPath's cmd_id

Enumerator:
QPC_SET_PROP | setPropertyByPath
QPC_GET_PROP | getPropertyByPath
QPC_ADD_EVENT | addEventListenerByPath
QPC_ADD_BIND | addBindPropByPath
QPC_USER | user

Definition at line 190 of file mcomponent.h.

enum ncsComponentReleated

The releation between components.

Enumerator:
NCS_CMPT_NEXT | next sliding component
NCS_CMPT_PREV | prev sliding component
NCS_CMPT_PARENT | the parent component
NCS_CMPT_CHILDREN | the first child component

Definition at line 162 of file mcomponent.h.

Variable Documentation

g_stmComponentCls

the singleton of mComponentClass

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: _NCS_EVENT_HANDLER_NODE Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_NCS_EVENT_HANDLER_NODE Struct Reference
[mComponent]

#include <mcomponent.h>

Data Fields

  • int message
  • void * handler
  • struct _NCS_EVENT_HANDLER_NODE * next

Detailed Description

A struct include a event mapping node

Note:
only used by mComponent

Definition at line 273 of file mcomponent.h.

Field Documentation

int message

The event code

Definition at line 277 of file mcomponent.h.

void* handler

A callback of event

Note:
diffrent event has diffrent callback, so we use void * to make all the pointer of callback can be saved.

Definition at line 285 of file mcomponent.h.

struct _NCS_EVENT_HANDLER_NODE* next [read]

next node

Definition at line 289 of file mcomponent.h.

The documentation for this struct was generated from the following file:
  • mcomponent.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mComponentClass Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mComponentClass Struct Reference
[mComponent]

the basic class of components, windows. Drived by mObjectClass More...

#include <mcomponent.h>

Detailed Description

the basic class of components, windows. Drived by mObjectClass

  • const char* className - the class name of component,
    See also:
    NCSCLASSNAME
  • mComponent * createComponent(mComponent* parent, mComponentClass * the_class, DWORD addData);
    create a mComponent instance, see Design Patterns : Factroy Method
    Parameters:
    parent | - the parent recieve the new created component
    the_class | - the class of new created component
    addData - param to new compont's construct function: mObjectClass .construct
    Returns:
    mComponent * the new instance pointer of component
  • WNDPROC _window_proc - window proc, used for registering,
    See also:
    ncsRegisterComponent
  • BOOL setProperty(mComponent *self, int id, DWORD value);
    Set the property of component
    Parameters:
    self | - this pointer
    id | - the id of property
    value - the value of property
    Returns:
    TRUE - sucessfull , FALSE - failed
  • DWORD getProperty (mComponent * self, int id);
    Get the property value of component
    Parameters:
    self - this pointer
    id - the id of property
    Returns:
    DWORD - value of property or (DWORD)-1 if failed
  • int setId (mComponent *self, int id);
    Set the Id of this component
    Parameters:
    self | - this pointer
    id | - the new id of component
    Returns:
    old id.
  • int getId (mComponent *self);
    Get the Id of this component
    Parameters:
    self - this pointer
    Returns:
    the Id of component
  • mComponent* getReleated(mComponent* self, int releated);
    Get Releated components, such as parent, children, next sliding, prev sliding
    Parameters:
    self | - this pointer
    releated | - the releated type, ncsComponentReleated
    Returns:
    the releated component pointer if found, NULL otherwise
  • mComponent* setReleated(mComponent* self,mComponent *comp, int releated);
    Set Releated components
    Parameters:
    self | - this pointer
    releated | - the releated type, ncsComponentReleated
    comp | - the component to set
    Returns:
    the param comp pointer if success, or NULL otherwise
  • mComponent* getChild(mComponent* self, int id);
    Get a child by id
    Parameters:
    self | - this pointer
    id | - the child id
    Returns:
    the pointer of children, or NULL if failed
  • BOOL setSpecificData (mObject* self, DWORD key, DWORD value, PFreeSpecificData freeSpecific = NULL) set the sepcific data to an object
    Parameters:
    self | - this pointer
    key | - the key of data
    value | - the value of data
    freeSpecific | - the free function to the value, called when object will be destroied
    Returns:
    TRUE/FALSE
  • DWORD getSpecificData(mComponent* self, DWORD key, BOOL *pOk = NULL) get the specific data has been set
    Parameters:
    self | - this pointer
    key | - the key of specific data
    pOk | - get the data sucesses or not
    Returns:
    The data value or zero (when pOk is FALSE)
The documentation for this struct was generated from the following file:
  • mcomponent.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mComponent Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mComponent Struct Reference
[mComponent]

the component member define More...

#include <mcomponent.h>

Detailed Description

the component member define

  • NCS_EVENT_HANDLER_NODE * event_handlers - the head of handler table

See also:
mComponentClass
The documentation for this struct was generated from the following file:
  • mcomponent.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mContainer

mContainer

Data Structures

  • struct mContainer
    The structure of mContainer, which derived from mScrollWidget. It is a control with scrollbars which is capable of containing other controls. When the user uses the scrollbars, it will scroll its content automatically. More...
  • struct mContainerClass
    The virtual function table of mContainer, which derived from mScrollWidgetClass. More...
  • struct mContainerRenderer
    The renderer structure of mContainer, which inheried from mScrollWidgetRenderer. More...

Defines

  • #define NCSCTRL_CONTAINER NCSCLASSNAME("container")
    The control class name of mContainer.
  • #define NCSS_CTNR_SHIFT NCSS_SWGT_SHIFT
    The bits used by mContainer in style.

Enumerations

  • enum mContainerNotify { NCSN_CTNR_MAX = NCSN_SWGT_MAX + 1 }
    The notification code id of mContainer. More...

Variables

  • MGNCS_EXPORT mContainerClass g_stmContainerCls
    The instance of mContainerClass.

Detailed Description

Id
mcontainer.h 844 2010-02-26 03:05:57Z dongjunjie

Copyright (C) 2009 Feynman Software.

Define Documentation

#define NCSCTRL_CONTAINER NCSCLASSNAME("container")

The control class name of mContainer.

Definition at line 45 of file mcontainer.h.

#define NCSS_CTNR_SHIFT NCSS_SWGT_SHIFT

The bits used by mContainer in style.

Definition at line 135 of file mcontainer.h.

Enumeration Type Documentation

enum mContainerNotify

The notification code id of mContainer.

Enumerator:
NCSN_CTNR_MAX The maximum value of mContainer notification code id.

Definition at line 141 of file mcontainer.h.

Variable Documentation

g_stmContainerCls

The instance of mContainerClass.

See also:
mContainerClass

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mContainer Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mContainer Struct Reference
[mContainer]

The structure of mContainer, which derived from mScrollWidget. It is a control with scrollbars which is capable of containing other controls. When the user uses the scrollbars, it will scroll its content automatically. More...

#include <mcontainer.h>

Detailed Description

The structure of mContainer, which derived from mScrollWidget. It is a control with scrollbars which is capable of containing other controls. When the user uses the scrollbars, it will scroll its content automatically.

  • hPanel
    The handle of panel in scrollcontainer.
The documentation for this struct was generated from the following file:
  • mcontainer.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mContainerClass Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mContainerClass Struct Reference
[mContainer]

The virtual function table of mContainer, which derived from mScrollWidgetClass. More...

#include <mcontainer.h>

Detailed Description

The virtual function table of mContainer, which derived from mScrollWidgetClass.

  • BOOL (*addIntrinsicControls)(mContainer *self, const PCTRLDATA pCtrl, int nCount);
    Add intrinsic controls in MiniGUI to container.
    Parameters:
    pCtrl | The pointer to control data in MiniGUI V3.0.x.
    nCount | The number of controls.
    Returns:
    TRUE for success, otherwise FALSE.
  • HWND (* setFocus)(mContainer *self, int id);
    Set focus control.
    Parameters:
    id The identifier of active child.
    Returns:
    The handle to the old active child of its parent.
  • HWND (*getFocus)(mContainer *self);
    Get focus control.
    Returns:
    The handle to the active child.
  • HWND (*getPanel)(mContainer *self);
    Get the panel handle.
    Returns:
    The panel handler of container.
  • void (*adjustContent)(mContainer *self);
    Adjust the content size.
The documentation for this struct was generated from the following file:
  • mcontainer.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mContainerRenderer Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mContainerRenderer Struct Reference
[mContainer]

The renderer structure of mContainer, which inheried from mScrollWidgetRenderer. More...

#include <mcontainer.h>

Detailed Description

The renderer structure of mContainer, which inheried from mScrollWidgetRenderer.
The documentation for this struct was generated from the following file:
  • mcontainer.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mDialogBox

mDialogBox

Data Structures

  • struct mDialogBoxRenderer
    the renerer interface of mDialogBox, inherit from mMainWndRenderer More...
  • struct mDialogBox
    the members of mDialogBox, inherit from mMainWnd More...
  • struct mDialogBoxClass
    the VTable of mDialogBox, inherit from mMainWndClass More...

Defines

  • #define NCSCTRL_DIALOGBOX NCSCLASSNAME("dialogbox")
    the name of mDialogBox control

Variables

  • MGNCS_EXPORT mDialogBoxClass g_stmDialogBoxCls
    the singleton of mDialogBoxClass

Define Documentation

#define NCSCTRL_DIALOGBOX NCSCLASSNAME("dialogbox")

the name of mDialogBox control

Definition at line 32 of file mdialog.h.

Variable Documentation

g_stmDialogBoxCls

the singleton of mDialogBoxClass

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mDialogBoxRenderer Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mDialogBoxRenderer Struct Reference
[mDialogBox]

the renerer interface of mDialogBox, inherit from mMainWndRenderer More...

#include <mdialog.h>

Detailed Description

the renerer interface of mDialogBox, inherit from mMainWndRenderer

See also:
mDialogBox, mDialogBoxClass
The documentation for this struct was generated from the following file:
  • mdialog.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mDialogBox Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mDialogBox Struct Reference
[mDialogBox]

the members of mDialogBox, inherit from mMainWnd More...

#include <mdialog.h>

Detailed Description

the members of mDialogBox, inherit from mMainWnd

  • DWORD modeRetValue;
    The return value after a dialog leave Mode state, return by doModal

See also:
mDialogBoxClass
The documentation for this struct was generated from the following file:
  • mdialog.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mDialogBoxClass Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mDialogBoxClass Struct Reference
[mDialogBox]

the VTable of mDialogBox, inherit from mMainWndClass More...

#include <mdialog.h>

Detailed Description

the VTable of mDialogBox, inherit from mMainWndClass

See also:
mDialogBox
The documentation for this struct was generated from the following file:
  • mdialog.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mEdit

mEdit

Data Structures

  • struct mEdit
    the edit struct of edit control, derived from mScrollView. More...
  • struct mEditClass
    the VTable of mEdit, derived from mScrollViewClass. More...
  • struct mEditRenderer
    Edit class's Renderer interface, derived from mScrollViewRenderer. More...

Defines

  • #define NCSS_EDIT_LEFT (0x0000L<<NCSS_SCRLV_SHIFT)
    left align edit
  • #define NCSS_EDIT_CENTER (0x0001L<<NCSS_SCRLV_SHIFT)
    center align edit
  • #define NCSS_EDIT_RIGHT (0x0002L<<NCSS_SCRLV_SHIFT)
    right align edit
  • #define NCSS_EDIT_UPPERCASE (0x0004L<<NCSS_SCRLV_SHIFT)
    uppercase edit
  • #define NCSS_EDIT_LOWERCASE (0x0008L<<NCSS_SCRLV_SHIFT)
    lowercase edit
  • #define NCSS_EDIT_NOHIDESEL (0x0010L<<NCSS_SCRLV_SHIFT)
    When lose the focus, it is still selected.
  • #define NCSS_EDIT_READONLY (0x0020L<<NCSS_SCRLV_SHIFT)
    readonly
  • #define NCSS_EDIT_BASELINE (0x0040L<<NCSS_SCRLV_SHIFT)
    show text with base line.

Enumerations

  • enum mEditProp { NCSP_EDIT_LIMITTEXT = NCSP_SCRLV_MAX + 1, NCSP_EDIT_CARETPOS }
    the Property of edit More...
  • enum mEditNotify {
    NCSN_EDIT_SETFOCUS = NCSN_ITEMV_SETFOCUS, NCSN_EDIT_KILLFOCUS = NCSN_ITEMV_KILLFOCUS, NCSN_EDIT_CHANGE = NCSN_SCRLV_MAX + 1, NCSN_EDIT_CONTCHANGED,
    NCSN_EDIT_UPDATE, NCSN_EDIT_SELCHANGED, NCSN_EDIT_MAXTEXT
    }

Variables

  • MGNCS_EXPORT mEditClass g_stmEditCls
    the instance of mEditClass

Define Documentation

#define NCSS_EDIT_BASELINE (0x0040L<<NCSS_SCRLV_SHIFT)

show text with base line.

Definition at line 413 of file medit.h.

#define NCSS_EDIT_CENTER (0x0001L<<NCSS_SCRLV_SHIFT)

center align edit

Definition at line 377 of file medit.h.

#define NCSS_EDIT_LEFT (0x0000L<<NCSS_SCRLV_SHIFT)

left align edit

Definition at line 371 of file medit.h.

#define NCSS_EDIT_LOWERCASE (0x0008L<<NCSS_SCRLV_SHIFT)

lowercase edit

Definition at line 395 of file medit.h.

#define NCSS_EDIT_NOHIDESEL (0x0010L<<NCSS_SCRLV_SHIFT)

When lose the focus, it is still selected.

Definition at line 401 of file medit.h.

#define NCSS_EDIT_READONLY (0x0020L<<NCSS_SCRLV_SHIFT)

readonly

Definition at line 407 of file medit.h.

#define NCSS_EDIT_RIGHT (0x0002L<<NCSS_SCRLV_SHIFT)

right align edit

Definition at line 383 of file medit.h.

#define NCSS_EDIT_UPPERCASE (0x0004L<<NCSS_SCRLV_SHIFT)

uppercase edit

Definition at line 389 of file medit.h.

Enumeration Type Documentation

enum mEditNotify

Edit Notify Code :

Enumerator:
NCSN_EDIT_SETFOCUS | control have gaint the input focus
NCSN_EDIT_KILLFOCUS | control have lost the input focus
NCSN_EDIT_CHANGE | content of text is changed by inputing user
NCSN_EDIT_CONTCHANGED | content of text changed when kill focus
NCSN_EDIT_UPDATE | text update
NCSN_EDIT_SELCHANGED | selection changed
NCSN_EDIT_MAXTEXT | the count of text reach maximum length

Definition at line 444 of file medit.h.

enum mEditProp

the Property of edit

Enumerator:
NCSP_EDIT_LIMITTEXT Get/Set the maximum length of text
  • Type int
  • Read Write
  • the max length of text.
NCSP_EDIT_CARETPOS Get/Set the position of charactor
  • Type int
  • Read Write
  • The postion begin from first charactor , include the CR.

Definition at line 423 of file medit.h.

Variable Documentation

g_stmEditCls

the instance of mEditClass

See also:
mEditClass

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mEdit Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mEdit Struct Reference
[mEdit]

the edit struct of edit control, derived from mScrollView. More...

#include <medit.h>

Detailed Description

the edit struct of edit control, derived from mScrollView.

See also:
mEditClass
The documentation for this struct was generated from the following file:
  • medit.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mEditClass Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mEditClass Struct Reference
[mEdit]

the VTable of mEdit, derived from mScrollViewClass. More...

#include <medit.h>

Detailed Description

the VTable of mEdit, derived from mScrollViewClass.

See also:
mScrollViewClass
  • void setContent (mEdit *self, const char *str, int start, int len);
    set the text content of the edit.
    Parameters:
    str | - the text to be shown on edit.
    start | - the start of the text to be shown on edit.
    len | - length of the text to be shown on edit.
    Returns:
    void
  • void replaceText (mEdit *self, const char* str, int start, int len, int replace_start, int replace_end);
    replace text.
    Parameters:
    str | - the new text
    start | - the start of the str to be used
    len | - the length of the str to be used
    replace_start | - the start of the text to be replaced in the edit.
    replace_end | - the end of the text to be repalced in the edit.
    Returns:
    void
  • void insert (mEdit *self, const char* str, int start, int len, int start_at);
    insert text.
    Parameters:
    str | - the new text
    start | - the start of the str to be inserted
    len | - the length of the str to be inserted
    start_at | - insert position.
    Returns:
    void
  • void append (mEdit *self, const char* str, int start, int len);
    append the str into the edit text.
    Parameters:
    str | - The new text
    start | - The start of the str to be appended
    len | - The length of the str to be appended
    Returns:
    void
  • int getTextLength (mEdit *self);
    get the count of the edit text.
    Returns:
    The count of the text
  • int getContent (mEdit *self, char *strbuff, int buf_len, int start, int end);
    get the text of the edit.
    Parameters:
    strbuff | - The string buffer to save the return string
    buf_len | - The size of strbuff
    start | - Start position to get text
    end | - End position to get text
    Returns:
    The real count of text in strbuff.
  • int setTextAttr (mEdit *self, int start, int end, TextAttribute *attr);
    unimplemented.

  • TextAttribute* getTextAttr (mEdit *self, int start, int end, int *p_end);
    unimplemented.

  • int setSel (mEdit *self, int start, int end);
    set the selected position.
    Parameters:
    start | - The start of the selected position
    end | - The end of the selected position
    Returns:
    The length of selected text , -1 for Failed.
  • int getSel (mEdit *self, int *pstart, int *pend);
    get the selected position.
    Parameters:
    pstart | - The start of the selected position
    pend | - The end of the selected position
    Returns:
    0 for Succeed , -1 for Failed.
  • void setMargin (mEdit *self, int left, int top, int right, int bottom);
    set the margin
    Parameters:
    left | - the new margin left value
    top | - the new margin top value
    right | - the new margin right value
    bottom | - the new margin bottom value
  • void copy (mEdit *self);
    copy the selected text to clip board.

  • void cut (mEdit *self);
    cut the selected text to clip board.

  • void paste (mEdit *self);
    paste the text in clip board into edit.

  • TextCopyPaste* setCopyPaste (mEdit *self, TextCopyPaste* cp);
    set a new copyPaste instance create by user.
    Parameters:
    cp - Pointer of the new copyPaste instance
    Returns:
    The old one.
  • void undo (mEdit *self);
    unimplemented

  • void redo (mEdit *self);
    unimplemented

  • TextUndoRedoInfo* setUndoRedo (mEdit *self, TextUndoRedoInfo* ur);
    unimplemented

  • BOOL makevisible (mEdit *self, int pos);
    make the position visible
    Parameters:
    pos - the position to be visible.
    Returns:
    TRUE for succeed, FALSE for failed.
The documentation for this struct was generated from the following file:
  • medit.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mEditRenderer Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mEditRenderer Struct Reference
[mEdit]

Edit class's Renderer interface, derived from mScrollViewRenderer. More...

#include <medit.h>

Detailed Description

Edit class's Renderer interface, derived from mScrollViewRenderer.

See also:
mEdit, mEditClass
The documentation for this struct was generated from the following file:
  • medit.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mGroupBox

mGroupBox

Data Structures

  • struct mGroupBox
    groupbox class, derived from mStatic More...
  • struct mGroupBoxClass
    struct of groupbox control, derived from mStaticClass More...
  • struct mGroupBoxRenderer
    groupbox class renderer interface, derived from mStaticRenderer More...

Defines

  • #define NCSCTRL_GROUPBOX NCSCLASSNAME("groupbox")
    the name of groupbox control

Enumerations

  • enum mGroupBoxProp
    the properties id of mGroupBox More...
  • enum enumGroupBoxNotify
    the notification code of mGroupBox More...

Variables

  • MGNCS_EXPORT mGroupBoxClass g_stmGroupBoxCls
    global mGroupBoxClass

Define Documentation

#define NCSCTRL_GROUPBOX NCSCLASSNAME("groupbox")

the name of groupbox control

Definition at line 20 of file mgroupbox.h.

Enumeration Type Documentation

enum enumGroupBoxNotify

the notification code of mGroupBox

Definition at line 103 of file mgroupbox.h.

enum mGroupBoxProp

the properties id of mGroupBox

Definition at line 93 of file mgroupbox.h.

Variable Documentation

g_stmGroupBoxCls

global mGroupBoxClass

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mGroupBox Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mGroupBox Struct Reference
[mGroupBox]

groupbox class, derived from mStatic More...

#include <mgroupbox.h>

Detailed Description

groupbox class, derived from mStatic
The documentation for this struct was generated from the following file:
  • mgroupbox.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mGroupBoxClass Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mGroupBoxClass Struct Reference
[mGroupBox]

struct of groupbox control, derived from mStaticClass More...

#include <mgroupbox.h>

Detailed Description

struct of groupbox control, derived from mStaticClass

  • int (*hitTest)(clsName *self, int x, int y);
    test mouse hit position
    Parameters:
    *self | - this pointer of groupbox
    x | - x value of mouse position
    y | - y value of mouse position
    Returns:
    HT_OUT - mouse hit out of groupbox, HT_TRANSPARENT - mouse hit inside the controlset area of groupbox, HT_CLIENT - mouse hit in groupbox
The documentation for this struct was generated from the following file:
  • mgroupbox.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mGroupBoxRenderer Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mGroupBoxRenderer Struct Reference
[mGroupBox]

groupbox class renderer interface, derived from mStaticRenderer More...

#include <mgroupbox.h>

Detailed Description

groupbox class renderer interface, derived from mStaticRenderer

  • void (*drawGroupbox)(clsName *self, HDC hdc, const RECT *pRect);
    draw groupbox using renderer
    Parameters:
    *self | - this pointer of groupbox
    hdc | - dc of groupbox control
    *pRect | - rectangle to draw groupbox
The documentation for this struct was generated from the following file:
  • mgroupbox.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mIconView

mIconView

Data Structures

  • struct _NCS_ICONV_ITEMINFO
  • struct mIconView
    The structure of mItemView control, which derived from mScrollWidget. It is the abstract superclass of all classes which represent controls that have items. More...
  • struct mIconViewClass
    The virtual function table of mIconView, which derived from mItemViewClass. More...
  • struct mIconViewRenderer
    The structure of mIconView renderer, which derived from mItemViewRenderer. More...

Defines

  • #define NCSCTRL_ICONVIEW NCSCLASSNAME("iconview")
    The control class name of mIconView.
  • #define NCSS_ICONV_SHIFT (NCSS_SCRLV_SHIFT)
    The bits used by mIconView in style.
  • #define NCSS_ICONV_SORT NCSS_ITEMV_AUTOSORT
  • #define NCSS_ICONV_LOOP NCSS_ITEMV_LOOP

Enumerations

  • enum mIconViewProp { NCSP_ICONV_DEFICONHEIGHT = NCSP_ITEMV_DEFITEMHEIGHT, NCSP_ICONV_DEFICONWIDTH = NCSP_ITEMV_MAX + 1, NCSP_ICONV_MAX }
    The properties id of mIconView. More...
  • enum mIconViewNotify { , NCSN_ICONV_MAX = NCSN_ITEMV_MAX + 1 }
    The notification code id of mIconView. More...

Variables

  • MGNCS_EXPORT mIconViewClass g_stmIconViewCls
    The instance of mIconViewClass.

Detailed Description

Id
miconview.h 726 2009-12-21 01:57:37Z xwyan

Copyright (C) 2009 Feynman Software.

Define Documentation

#define NCSCTRL_ICONVIEW NCSCLASSNAME("iconview")

The control class name of mIconView.

Definition at line 72 of file miconview.h.

#define NCSS_ICONV_LOOP NCSS_ITEMV_LOOP

See also:
NCSS_ITEMV_LOOP

Definition at line 90 of file miconview.h.

#define NCSS_ICONV_SHIFT (NCSS_SCRLV_SHIFT)

The bits used by mIconView in style.

Definition at line 78 of file miconview.h.

#define NCSS_ICONV_SORT NCSS_ITEMV_AUTOSORT

See also:
NCSS_ITEMV_AUTOSORT

Definition at line 84 of file miconview.h.

Enumeration Type Documentation

enum mIconViewNotify

The notification code id of mIconView.

Enumerator:
NCSN_ICONV_MAX The maximum value of mIconView notification code id.

Definition at line 180 of file miconview.h.

enum mIconViewProp

The properties id of mIconView.

Enumerator:
NCSP_ICONV_DEFICONHEIGHT | The default icon height.
NCSP_ICONV_DEFICONWIDTH | The default icon width.
NCSP_ICONV_MAX | The maximum value of mIconView properties id.

Definition at line 159 of file miconview.h.

Variable Documentation

g_stmIconViewCls

The instance of mIconViewClass.

See also:
mIconViewClass

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: _NCS_ICONV_ITEMINFO Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_NCS_ICONV_ITEMINFO Struct Reference
[mIconView]

#include <miconview.h>

Data Fields

  • int index
  • PBITMAP bmp
  • const char * label
  • DWORD addData

Detailed Description

Structure of the iconview item info, contains information about an item. This structure is used for creating or retrieving an item.

Definition at line 43 of file miconview.h.

Field Documentation

int index

The index of the item

Definition at line 48 of file miconview.h.

PBITMAP bmp

The bitmap icon of the item

Definition at line 53 of file miconview.h.

const char* label

The text label of the item

Definition at line 58 of file miconview.h.

DWORD addData

Attached additional data of this item

Definition at line 61 of file miconview.h.

The documentation for this struct was generated from the following file:
  • miconview.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mIconView Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mIconView Struct Reference
[mIconView]

The structure of mItemView control, which derived from mScrollWidget. It is the abstract superclass of all classes which represent controls that have items. More...

#include <miconview.h>

Detailed Description

The structure of mItemView control, which derived from mScrollWidget. It is the abstract superclass of all classes which represent controls that have items.

  • defItemWidth
    The default icon width.

  • nrCol
    The number of column.

  • flags
    The iconview flags.
The documentation for this struct was generated from the following file:
  • miconview.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mIconViewClass Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mIconViewClass Struct Reference
[mIconView]

The virtual function table of mIconView, which derived from mItemViewClass. More...

#include <miconview.h>

Detailed Description

The virtual function table of mIconView, which derived from mItemViewClass.

  • void (*setIconSize)(mIconView *self, int width, int height);
    Sets the icon size.

  • HITEM (*addItem)(mIconView *self, NCS_ICONV_ITEMINFO *info, int *pos);
    Add a new item according to info to iconview.
    Parameters:
    info | The item information.
    pos | The position in which item has been inserted. It can be NULL.
    Returns:
    The handle to new item.
The documentation for this struct was generated from the following file:
  • miconview.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mIconViewRenderer Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mIconViewRenderer Struct Reference
[mIconView]

The structure of mIconView renderer, which derived from mItemViewRenderer. More...

#include <miconview.h>

Detailed Description

The structure of mIconView renderer, which derived from mItemViewRenderer.
The documentation for this struct was generated from the following file:
  • miconview.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mImage

mImage

Data Structures

  • struct mImage
    static control can show a image, derived from mStatic More...
  • struct mImageClass
    ImageClass struct of image control, derived from mStaticClass. More...
  • struct mImageRenderer
    image class renderer interface, derived from mStaticRenderer More...

Defines

  • #define NCSCTRL_IMAGE NCSCLASSNAME("image")
    the name of image control

Enumerations

  • enum mImageProp { NCSP_IMAGE_IMAGE = NCSP_STATIC_MAX + 1, NCSP_IMAGE_IMAGEFILE, NCSP_IMAGE_DRAWMODE }
    the properties id of mImage More...
  • enum enumImageNotify
    the notification code of mImage More...

Variables

  • MGNCS_EXPORT mImageClass g_stmImageCls
    global mImageClass

Define Documentation

#define NCSCTRL_IMAGE NCSCLASSNAME("image")

the name of image control

Definition at line 20 of file mimage.h.

Enumeration Type Documentation

enum enumImageNotify

the notification code of mImage

Definition at line 108 of file mimage.h.

enum mImageProp

the properties id of mImage

Enumerator:
NCSP_IMAGE_IMAGE Set the image content
  • Type PBITMAP
  • Read Write
  • set the pointer to image content.
NCSP_IMAGE_IMAGEFILE Set the image content
  • Type char*
  • Read Write
  • set the image file name pointer.
NCSP_IMAGE_DRAWMODE Set image draw mode
  • Type enumNCSImageDrawMode
  • Read Write
  • set the image draw mode to NCS_DM_NORMAL/NCS_DM_SCALED/NCS_DM_TILED.

Definition at line 74 of file mimage.h.

Variable Documentation

g_stmImageCls

global mImageClass

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mImage Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mImage Struct Reference
[mImage]

static control can show a image, derived from mStatic More...

#include <mimage.h>

Detailed Description

static control can show a image, derived from mStatic
The documentation for this struct was generated from the following file:
  • mimage.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mImageClass Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mImageClass Struct Reference
[mImage]

ImageClass struct of image control, derived from mStaticClass. More...

#include <mimage.h>

Detailed Description

ImageClass struct of image control, derived from mStaticClass.
The documentation for this struct was generated from the following file:
  • mimage.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mImageRenderer Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mImageRenderer Struct Reference
[mImage]

image class renderer interface, derived from mStaticRenderer More...

#include <mimage.h>

Detailed Description

image class renderer interface, derived from mStaticRenderer
The documentation for this struct was generated from the following file:
  • mimage.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mInvisibleComponent

mInvisibleComponent

Data Structures

  • struct mInvsbCompClass
    define the VTable of mInvsbComp, inherit mComponentClass More...
  • struct mInvsbComp
    define the mInvsbComp members , inherit from mComponent. An Invisible Component is a Component only support some functions, and user cannot see them More...

Enumerations

  • enum ncsInvsbCompProp
    the invisible component property define More...

Variables

  • MGNCS_EXPORT mInvsbCompClass g_stmInvsbCompCls
    the singleton mInvsbCompClass

Enumeration Type Documentation

enum ncsInvsbCompProp

the invisible component property define

Definition at line 77 of file minvisible-component.h.

Variable Documentation

g_stmInvsbCompCls

the singleton mInvsbCompClass

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mInvsbCompClass Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mInvsbCompClass Struct Reference
[mInvisibleComponent]

define the VTable of mInvsbComp, inherit mComponentClass More...

#include <minvisible-component.h>

Detailed Description

define the VTable of mInvsbComp, inherit mComponentClass

See also:
mComponentClass, mInvsbComp
The documentation for this struct was generated from the following file:
  • minvisible-component.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mInvsbComp Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mInvsbComp Struct Reference
[mInvisibleComponent]

define the mInvsbComp members , inherit from mComponent. An Invisible Component is a Component only support some functions, and user cannot see them More...

#include <minvisible-component.h>

Detailed Description

define the mInvsbComp members , inherit from mComponent. An Invisible Component is a Component only support some functions, and user cannot see them

  • int id - the id of an invisible component
  • mComponent * parant - the parent of invsible component
  • mComponent * prev - the prev sliding component of invsible component
  • mComponent * next - the next sliding component of invsible component
The documentation for this struct was generated from the following file:
  • minvisible-component.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mItem

mItem

Data Structures

  • struct mItem
    The structure of mItem. It is the abstract superclass of all items occur within specific controls. For example, a listbox will contain string or bitmap items. More...
  • struct mItemClass
    The virtual function table of mItemClass. More...

Defines

  • #define hEditor HWND
    The handle of item editor.
  • #define NCSF_ITEM_SHIFT 4
    The bits used by mItem in flags.
  • #define NCSF_ITEM_MASK 0xFFFF
    The mask of item flags.
  • #define NCSF_ITEM_NORMAL 0x0000
    Normal item.
  • #define NCSF_ITEM_SELECTED 0x0001
    Selected item.
  • #define NCSF_ITEM_DISABLED 0x0002
    Disabled item.
  • #define NCSF_ITEM_USEBITMAP 0x0004
    The item with bitmap.
  • #define NCSF_ITEM_USEICON 0x0008
    The item with icon.
  • #define NCSF_ITEM_IMAGEMASK (NCSF_ITEM_USEBITMAP | NCSF_ITEM_USEICON)
    The mask of item image/icon style.

Typedefs

  • typedef GHANDLE HITEM
    The handle of item widget.

Enumerations

  • enum mItemProp { NCSP_ITEM_HEIGHT = 1, NCSP_ITEM_FLAGS, NCSP_ITEM_MAX }
    The properties id of mItem. More...

Variables

  • MGNCS_EXPORT mItemClass g_stmItemCls
    The instance of mItemClass.

Detailed Description

Id
mitem.h 641 2009-11-10 01:48:49Z xwyan

Copyright (C) 2009 Feynman Software.

Define Documentation

#define hEditor HWND

The handle of item editor.

Definition at line 52 of file mitem.h.

#define NCSF_ITEM_DISABLED 0x0002

Disabled item.

Definition at line 82 of file mitem.h.

#define NCSF_ITEM_IMAGEMASK (NCSF_ITEM_USEBITMAP | NCSF_ITEM_USEICON)

The mask of item image/icon style.

Definition at line 100 of file mitem.h.

#define NCSF_ITEM_MASK 0xFFFF

The mask of item flags.

Definition at line 64 of file mitem.h.

#define NCSF_ITEM_NORMAL 0x0000

Normal item.

Definition at line 70 of file mitem.h.

#define NCSF_ITEM_SELECTED 0x0001

Selected item.

Definition at line 76 of file mitem.h.

#define NCSF_ITEM_SHIFT 4

The bits used by mItem in flags.

Definition at line 58 of file mitem.h.

#define NCSF_ITEM_USEBITMAP 0x0004

The item with bitmap.

Definition at line 88 of file mitem.h.

#define NCSF_ITEM_USEICON 0x0008

The item with icon.

Definition at line 94 of file mitem.h.

Typedef Documentation

HITEM

The handle of item widget.

Definition at line 46 of file mitem.h.

Enumeration Type Documentation

enum mItemProp

The properties id of mItem.

Enumerator:
NCSP_ITEM_HEIGHT | The height of item.
NCSP_ITEM_FLAGS | The flags of item.
NCSP_ITEM_MAX | The maximum value of mItem properties id.

Definition at line 254 of file mitem.h.

Variable Documentation

g_stmItemCls

The instance of mItemClass.

See also:
mItemClass

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mItem Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mItem Struct Reference
[mItem]

The structure of mItem. It is the abstract superclass of all items occur within specific controls. For example, a listbox will contain string or bitmap items. More...

#include <mitem.h>

Detailed Description

The structure of mItem. It is the abstract superclass of all items occur within specific controls. For example, a listbox will contain string or bitmap items.

  • list
    The item list header.

  • selList
    The selected item list header.

  • string
    The pointer of string.

  • image
    The pointer of image.

  • editor
    The handle of item editor.

  • flags
    The flags of item. It can be OR'ed by the following values:
    • NCSF_ITEM_NORMAL
      Normal status.
    • NCSF_ITEM_SELECTED
      Selected status.
    • NCSF_ITEM_DISABLED
      Disabled status.
    • NCSF_ITEM_USEBITMAP
      Use bitmap.
    • NCSF_ITEM_USEICON
      Use icon.

  • addData
    The additional data.
The documentation for this struct was generated from the following file:
  • mitem.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mItemClass Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mItemClass Struct Reference
[mItem]

The virtual function table of mItemClass. More...

#include <mitem.h>

Detailed Description

The virtual function table of mItemClass.

  • BOOL (*setProperty)(mItem *self, int id, DWORD value);
    The function sets the value of the specified properties.
    Parameters:
    id | The property id.
    value | The property value.
    Returns:
    TRUE on success, otherwise FALSE.
  • DWORD (*getProperty)(mItem *self, int id);
    The function gets the value of the specified properties.
    Parameters:
    id The property id.
    Returns:
    the property value on success, otherwise -1.
  • BOOL (*isSelectedItem)(mItem *self);
    The function is used to decide whether the item is selected or not.
    Returns:
    TRUE for selected status, otherwise FALSE.
  • BOOL (*isEnabledItem)(mItem *self);
    The function is used to terminate whether the item is enabled or not.
    Returns:
    TRUE for enabled status, otherwise FALSE.
  • void (*setItemEditor)(mItem *self, hEditor editor);
    The function is used to set the item editor.
    Parameters:
    editor The handle of editor.
  • hEditor (*getItemEditor)(mItem *self);
    The function is used to get the item editor.
    Returns:
    The editor handle on success, otherwise HWND_NULL.
  • void (*setItemAddData)(mItem *self, DWORD addData);
    The function is used to set the addtional data.
    Parameters:
    addData The additional data.
  • DWORD (*getItemAddData)(mItem *self);
    The function is used to get the additional data.
    Returns:
    The additional data.
  • void (*setItemImage)(mItem *self, DWORD image);
    The function is used to set the item image.
    Parameters:
    addData The handle of image.
  • DWORD (*getItemImage)(mItem *self);
    The function is used to get the item image.
    Returns:
    The pointer of image, otherwise 0.
  • BOOL (*setItemString)(mItem *self, char* string);
    The function is used to set the item string.
    Parameters:
    string The item text.
    Returns:
    TRUE on success, otherwise FALSE.
  • char* (*getItemString)(mItem *self);
    The function is used to get the item string.
    Returns:
    The item text, otherwise NULL.
  • void (*setItemFlags)(mItem *self, DWORD flags);
    The function is used to set the item flags.
    Parameters:
    flags The item flags.
  • DWORD (*getItemFlags)(mItem *self);
    The function is used to get the item flags.

  • BOOL (*setItemHeight)(mItem *self, int height);
    The function is used to set the item height.
    Parameters:
    height The item height.
    Returns:
    TRUE on success, otherwise FALSE.
  • int (*getItemHeight)(mItem *self);
    The function is used to get the item height.
The documentation for this struct was generated from the following file:
  • mitem.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mItemManager

mItemManager

Data Structures

  • struct mItemManager
    The structure of mItemManager control, which derived from mItem. It is the abstract superclass of all classes which managers items. More...
  • struct mItemManagerClass
    The virtual function table of mItemManager, which derived from mItemClass. More...

Defines

  • #define NCSF_ITMMNG_AUTOSORT (0x01<<NCSF_ITEM_SHIFT)
    Sort items automatically.
  • #define NCSF_ITMMNG_FROZEN (0x02<<NCSF_ITEM_SHIFT)
    Allow manager to refresh items or not.
  • #define NCSF_ITMMNG_SHIFT (NCSF_ITEM_SHIFT+2)
    The bits used by mItemManager in flags.

Typedefs

  • typedef int(* NCS_CB_CMPITEM )(mItemManager *manager, HITEM hItem1, HITEM hItem2)
    The callback of item compare function.
  • typedef int(* NCS_CB_CMPSTR )(const char *s1, const char *s2, size_t n)
    The Callback of general string compare function.

Enumerations

  • enum mItemManagerProp { NCSP_ITMMNG_FLAGS = NCSP_ITEM_FLAGS, NCSP_ITMMNG_ITEMCOUNT = NCSP_ITEM_MAX + 1, NCSP_ITMMNG_TOTALHEIGHT, NCSP_ITMMNG_MAX }
    The properties id of mItemManager. More...

Variables

  • MGNCS_EXPORT mItemManagerClass g_stmItemManagerCls
    The instance of mItemManagerClass.

Detailed Description

Id
mitem_manager.h 844 2010-02-26 03:05:57Z dongjunjie

Copyright (C) 2009 Feynman Software.

Define Documentation

#define NCSF_ITMMNG_AUTOSORT (0x01<<NCSF_ITEM_SHIFT)

Sort items automatically.

Definition at line 64 of file mitem_manager.h.

#define NCSF_ITMMNG_FROZEN (0x02<<NCSF_ITEM_SHIFT)

Allow manager to refresh items or not.

Definition at line 70 of file mitem_manager.h.

#define NCSF_ITMMNG_SHIFT (NCSF_ITEM_SHIFT+2)

The bits used by mItemManager in flags.

Definition at line 76 of file mitem_manager.h.

Typedef Documentation

typedef int(* NCS_CB_CMPITEM)(mItemManager *manager, HITEM hItem1, HITEM hItem2)

The callback of item compare function.

Definition at line 46 of file mitem_manager.h.

typedef int(* NCS_CB_CMPSTR)(const char *s1, const char *s2, size_t n)

The Callback of general string compare function.

The function compares the two strings s1 and s2. It returns an integer less than, equal to, or greater than zero if s1 is found, respectively, to be less than, to match, or be greater than s2.

Note:
It only compares the first (at most) n characters of s1 and s2.

Definition at line 58 of file mitem_manager.h.

Enumeration Type Documentation

enum mItemManagerProp

The properties id of mItemManager.

Enumerator:
NCSP_ITMMNG_FLAGS | The flags of item manager.
NCSP_ITMMNG_ITEMCOUNT | The number of items. Read only.
NCSP_ITMMNG_TOTALHEIGHT | The total height. Read only.
NCSP_ITMMNG_MAX | The maximum value of mItemManager properties id.

Definition at line 404 of file mitem_manager.h.

Variable Documentation

g_stmItemManagerCls

The instance of mItemManagerClass.

See also:
mItemManagerClass

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mItemManager Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mItemManager Struct Reference
[mItemManager]

The structure of mItemManager control, which derived from mItem. It is the abstract superclass of all classes which managers items. More...

#include <mitem_manager.h>

Detailed Description

The structure of mItemManager control, which derived from mItem. It is the abstract superclass of all classes which managers items.

  • host
    The window handle which own the item manager.

  • itemCmp
    The pointer to item comparison function.

  • strCmp
    The pointer to string comparison funciton.

  • totalHeight
    The total height of items.

  • pItemHilighted
    The pointer to the hilighted item.

  • queue
    The list of items.

  • selQueue
    The list of selected items.

  • count
    The count of item.
The documentation for this struct was generated from the following file:
  • mitem_manager.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mItemManagerClass Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mItemManagerClass Struct Reference
[mItemManager]

The virtual function table of mItemManager, which derived from mItemClass. More...

#include <mitem_manager.h>

Detailed Description

The virtual function table of mItemManager, which derived from mItemClass.

  • NCS_CB_CMPITEM (*setItemCmpFunc)(mItemManager *self, NCS_CB_CMPITEM func);
    The function set item's comparison function.
    Parameters:
    func The new item's comparison function.
    Returns:
    The old item's comparison function.
  • int (*moveItem)(mItemManager *self, mItem *curItem, int count, mItem* prevItem);
    The function move the specified items to the specified position.
    Parameters:
    curItem | The handle to first moved item.
    count | The count of moved items.
    prevItem | The handle to target item.
    Returns:
    The old comparison function.
  • int (*insertItem)(mItemManager *self, HITEM hItem, HITEM prev, HITEM next, int index, int *pos);
    The function is used to insert a item to mItemManager. If has NCSF_ITMMNG_AUTOSORT flag, will insert item to sort position. Otherwise, the priority of prev is higher than next, the next is higher than index.
    Parameters:
    hItem | The item handle.
    prev | The specified previous position.
    next | The specified next position.
    index | The specified insert position.
    pos | The position in which item has been inserted. It can be NULL.
    Returns:
    0 on success, otherwise -1.
  • HITEM (*createItem)(mItemManager *self, HITEM prev, HITEM next, int index, int *pos);
    The function creates a new item and inserts it to specified position.
    Parameters:
    prev | The specified previous position.
    next | The specified next position.
    index | The specified insert position.
    pos | The position in which item has been inserted. It can be NULL.
    Returns:
    The handle to new item.
  • int (*inItem)(mItemManager *self, int mouseX, int mouseY, HITEM *pRet, POINT *pt);
    The function gets the item that mouse is in it.
    Parameters:
    mouesX | The mouse x position.
    mouseY | The mouse y position.
    pRet | The handle to current item.
    pt | The left-top point of item.
    Returns:
    The index of item on success, otherwise -1.
  • NCS_CB_CMPSTR (*setStrCmpFunc)(mItemManager *self, NCS_CB_CMPSTR func);
    The function sets string comparison function.
    Parameters:
    func The new string comparison function.
    Returns:
    The old string comparison function.
  • NCS_CB_CMPSTR (*getStrCmpFunc)(mItemManager *self);
    The function gets current string comparison function.

  • int (*getItemYPos)(mItemManager *self, HITEM hItem);
    The function gets the specified item's starting y position.

  • void (*setAutoSortItem) (mItemManager *self, BOOL sort);
    The function sets or cancels the NCSF_ITMMNG_AUTOSORT style.

  • int (*getTotalHeight)(mItemManager *self);
    The function gets the item's total height.

  • int (*adjustItemsHeight)(mItemManager *self, int diff);
    The function offsets the total height.

  • BOOL (*freeze)(mItemManager *self, BOOL lock);
    The function is used to freeze the item manager or not. If manager is frozen, it will not refresh items until unfroze it.

  • BOOL (*isFrozen)(mItemManager *self);
    The function determines whether manager is frozen.

  • HITEM (*getFirstItem)(mItemManager *self);
    The function is used to get first item.

  • list_t* (*getQueue)(mItemManager *self);
    The function is used to get the header of item list.

  • HITEM (*getListEntry)(list_t* entry);
    The function is used to get item handle by list entry.

  • int (*isEmpty)(mItemManager *self);
    The function determines whether manager is empty.

  • int (*removeItem)(mItemManager *self, HITEM hItem);
    The function is used to remove a item from manager.
    Parameters:
    hItem The handle to item.
    Returns:
    0 on success, otherwise -1.
  • int (*sortItems)(mItemManager *self, NCS_CB_CMPITEM pfn);
    The function sorts items that uses the specified comparison function.

  • BOOL (*removeAll)(mItemManager *self);
    The function deletes all items.

  • int (*indexOf)(mItemManager *self, HITEM hItem);
    The function gets the index of the specifed item.
    Parameters:
    hItem The handle to item.
    Returns:
    The item index on success, otherwise -1.
  • int (*setHeight)(mItemManager *self, HITEM hItem, int height);
    The function sets the height of the specified item.
    Parameters:
    hItem | The handle to item.
    height | The new height of item.
    Returns:
    The difference value in old and new height on success, otherwise -1.
  • int (*getHeight)(mItemManager *self, HITEM hItem);
    The function gets the height of the specified item.

  • HITEM (*getItem)(mItemManager *self, int index);
    The function gets the item handle of the specified index.
    Parameters:
    index The specified index.
    Returns:
    The handle to item on success, otherwise NULL.
  • HITEM (*getNext)(mItemManager *self, HITEM hItem);
    The function gets the previous item.
    Parameters:
    hItem The handle to the specified item.
    Returns:
    The handle to previous item on success, otherwise NULL.
  • HITEM (*getPrev)(mItemManager *self, HITEM hItem);
    The function gets the next item.
    Parameters:
    hItem The handle to the specified item.
    Returns:
    The handle to next item on success, otherwise NULL.
  • BOOL (*isSelected)(mItemManager *self, HITEM hItem);
    The function determines whether the specified item is selected or not.

  • BOOL (*isEnabled)(mItemManager *self, HITEM hItem);
    The function determines whether the specified item is enabled or not.

  • BOOL (*enable)(mItemManager *self, HITEM hItem, BOOL enable);
    The function enables the specified item or not.
    Parameters:
    hItem | The handle to the specified item.
    enable | The enable status:TRUE for enable, FALSE for disable.
    Returns:
    TRUE on success, otherwise FALSE.
  • void (*selectAll)(mItemManager *self);
    The function selects all items.

  • void (*deselectAll)(mItemManager *self);
    The function deselects all items.

  • BOOL (*select)(mItemManager *self, HITEM hItem, BOOL sel);
    The function selects the specified item or not.
    Parameters:
    hItem | The handle to the specified item.
    sel | The selected status:TRUE for select, FALSE for deselect.
    Returns:
    TRUE on success, otherwise FALSE.
  • HITEM (*hilight)(mItemManager *self, HITEM hItem);
    The function hilights the specified item.

  • HITEM (*getHilight)(mItemManager *self);
    The function gets the hilighted item.
    Returns:
    The handle to old hilighted item on success, otherwise 0.
  • BOOL (*isHilight)(mItemManager *self, HITEM hItem);
    The function determines whether the specified item is hilighted or not.

  • int (*getItemCount)(mItemManager *self);
    The function is used to get the number of items.
    Returns:
    The number of items.
  • void (*setAddData)(mItemManager *self, HITEM hItem, DWORD addData);
    The function sets the additional data of the specified item.
    Parameters:
    hItem | The handle to the specified item.
    addData | The new additional data.
  • void (*setImage)(mItemManager *self, HITEM hItem, DWORD image);
    The function sets the image of the specified item.
    Parameters:
    hItem | The handle to the specified item.
    image | The new image.
  • DWORD (*getAddData)(mItemManager *self, HITEM hItem);
    The function gets the additional data of the specified item.

  • DWORD (*getImage)(mItemManager *self, HITEM hItem);
    The function gets the image of the specified item.

  • void (*setFlags)(mItemManager *self, HITEM hItem, DWORD flags);
    The function sets the flags of the specified item.
    Parameters:
    hItem | The handle to the specified item.
    flags | The new flags.
  • DWORD (*getFlags)(mItemManager *self, HITEM hItem);
    The function gets the flags of the specified item.

  • BOOL (*setText)(mItemManager *self, HITEM hItem, const char* text);
    The function sets the text of the specified item.
    Parameters:
    hItem | The handle to item.
    text | The next text.
    Returns:
    TRUE on success, otherwise FALSE.
  • const char* (*getText)(mItemManager *self, HITEM hItem);
    The function gets the text of the specified item.
    Parameters:
    hItem The handle to item.
    Returns:
    The text.
  • int (*getTextLen)(mItemManager *self, HITEM hItem);
    The function gets the text length of the specified item.
    Parameters:
    hItem The handle to item.
    Returns:
    The text length.
  • BOOL (*getSelection)(mItemManager *self, HITEM *pRet, int count);
    Get the array of item handles for the selected items.
    Parameters:
    pRet | The array of handles.
    count | The maximum size of array.
    Returns:
    TRUE on success, otherwise FALSE.
  • int (*getSelectionCount)(mItemManager *self);
    The function gets the number of selected items.
The documentation for this struct was generated from the following file:
  • mitem_manager.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mItemView

mItemView

Data Structures

  • struct NCS_CB_ITEMOPS
    The structure of NCS_CB_ITEMOPS. The Item operations interface. More...
  • struct mItemView
    The structure of mItemView control, which derived from mScrollWidget. It is the abstract superclass of all classes which represent controls that have items. More...
  • struct mItemViewClass
    The virtual function table of mItemView, which derived from mScrollWidgetClass. More...
  • struct mItemViewRenderer
    The structure of mItemView renderer, which inheried from mScrollWidgetRenderer. More...

Defines

  • #define NCSCTRL_ITEMVIEW NCSCLASSNAME("itemview")
    The name of mItemView control.
  • #define NCSS_ITEMV_AUTOSORT (0x0002<<NCSS_SWGT_SHIFT)
    Sort items automatically.
  • #define NCSS_ITEMV_LOOP (0x0004<<NCSS_SWGT_SHIFT)
    Travel all items circularly.
  • #define NCSS_ITEMV_SINGLE (0x0000<<NCSS_SWGT_SHIFT)
    Only have a selected item simultaneously.
  • #define NCSS_ITEMV_MULTIPLE (0x0008<<NCSS_SWGT_SHIFT)
    Allow user to select multiple items. Reserved.
  • #define NCSS_ITEMV_SHIFT (NCSS_SWGT_SHIFT+4)
    The bits used by mItemView in style.

Typedefs

  • typedef int(* NCS_CB_INITITEM )(mItemView *self, HITEM hItem)
    The callback of initializing item.
  • typedef void(* NCS_CB_DSTRITEM )(mItemView *self, HITEM hItem)
    The callback of destroying item.
  • typedef void(* NCS_CB_DRAWITEM )(mItemView *self, HITEM hItem, HDC hdc, RECT *rcDraw)
    The callback of drawing item.

Enumerations

  • enum mItemViewProp { NCSP_ITEMV_DEFITEMHEIGHT = NCSP_SWGT_MAX + 1, NCSP_ITEMV_ITEMCOUNT, NCSP_ITEMV_MAX }
    The properties id of mItemView. More...
  • enum mItemViewNotify {
    NCSN_ITEMV_CLICKED = NCSN_WIDGET_CLICKED, NCSN_ITEMV_SELCHANGING = NCSN_SWGT_MAX + 1, NCSN_ITEMV_SELCHANGED, NCSN_ITEMV_ENTER,
    NCSN_ITEMV_SETFOCUS, NCSN_ITEMV_KILLFOCUS, NCSN_ITEMV_MAX
    }
    The notification code id of mItemView. More...

Variables

  • MGNCS_EXPORT mItemViewClass g_stmItemViewCls
    The instance of mItemViewClass.

Detailed Description

Id
mitemview.h 1111 2010-11-29 03:16:54Z xwyan

Copyright (C) 2009 Feynman Software.

Define Documentation

#define NCSCTRL_ITEMVIEW NCSCLASSNAME("itemview")

The name of mItemView control.

Definition at line 43 of file mitemview.h.

#define NCSS_ITEMV_AUTOSORT (0x0002<<NCSS_SWGT_SHIFT)

Sort items automatically.

Definition at line 91 of file mitemview.h.

#define NCSS_ITEMV_LOOP (0x0004<<NCSS_SWGT_SHIFT)

Travel all items circularly.

Definition at line 97 of file mitemview.h.

#define NCSS_ITEMV_MULTIPLE (0x0008<<NCSS_SWGT_SHIFT)

Allow user to select multiple items. Reserved.

Definition at line 109 of file mitemview.h.

#define NCSS_ITEMV_SHIFT (NCSS_SWGT_SHIFT+4)

The bits used by mItemView in style.

Definition at line 115 of file mitemview.h.

#define NCSS_ITEMV_SINGLE (0x0000<<NCSS_SWGT_SHIFT)

Only have a selected item simultaneously.

Definition at line 103 of file mitemview.h.

Typedef Documentation

typedef void(* NCS_CB_DRAWITEM)(mItemView *self, HITEM hItem, HDC hdc, RECT *rcDraw)

The callback of drawing item.

Definition at line 65 of file mitemview.h.

typedef void(* NCS_CB_DSTRITEM)(mItemView *self, HITEM hItem)

The callback of destroying item.

Definition at line 59 of file mitemview.h.

typedef int(* NCS_CB_INITITEM)(mItemView *self, HITEM hItem)

The callback of initializing item.

Definition at line 53 of file mitemview.h.

Enumeration Type Documentation

enum mItemViewNotify

The notification code id of mItemView.

Enumerator:
NCSN_ITEMV_CLICKED | Mouse click.
NCSN_ITEMV_SELCHANGING | Changing selected item.
NCSN_ITEMV_SELCHANGED | Selected item changed.
NCSN_ITEMV_ENTER | ENTER pressed.
NCSN_ITEMV_SETFOCUS | Get focus.
NCSN_ITEMV_KILLFOCUS | Lost focus.
NCSN_ITEMV_MAX | The maximum value of mItemView notification code id.

Definition at line 553 of file mitemview.h.

enum mItemViewProp

The properties id of mItemView.

Enumerator:
NCSP_ITEMV_DEFITEMHEIGHT | The default item height.
NCSP_ITEMV_ITEMCOUNT | The number of items.
NCSP_ITEMV_MAX | The maximum value of mItemView properties id.

Definition at line 532 of file mitemview.h.

Variable Documentation

g_stmItemViewCls

The instance of mItemViewClass.

See also:
mItemViewClass

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: NCS_CB_ITEMOPS Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

NCS_CB_ITEMOPS Struct Reference
[mItemView]

The structure of NCS_CB_ITEMOPS. The Item operations interface. More...

#include <mitemview.h>

Detailed Description

The structure of NCS_CB_ITEMOPS. The Item operations interface.
The documentation for this struct was generated from the following file:
  • mitemview.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mItemView Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mItemView Struct Reference
[mItemView]

The structure of mItemView control, which derived from mScrollWidget. It is the abstract superclass of all classes which represent controls that have items. More...

#include <mitemview.h>

Detailed Description

The structure of mItemView control, which derived from mScrollWidget. It is the abstract superclass of all classes which represent controls that have items.

  • itemOps
    User-defined operations for items, NCS_CB_ITEMOPS.

  • itemList
    The pointer of item manager, mItemManager.

  • defItemHeight
    The default height of item.
The documentation for this struct was generated from the following file:
  • mitemview.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mItemViewClass Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mItemViewClass Struct Reference
[mItemView]

The virtual function table of mItemView, which derived from mScrollWidgetClass. More...

#include <mitemview.h>

Detailed Description

The virtual function table of mItemView, which derived from mScrollWidgetClass.

  • NCS_CB_CMPITEM (*setItemCmpFunc)(mItemView *self, NCS_CB_CMPITEM func);
    The function set item's compare function.
    Parameters:
    func The new item's compare function.
    Returns:
    The old item's compare function.
  • int (*moveItem)(mItemView *self, mItem *curItem, int count, mItem *prevItem);
    The function move the specified items to the specified position.
    Parameters:
    curItem | The handle to first moved item.
    count | The count of moved items.
    prevItem | The handle to target item.
    Returns:
    The old compare function.
  • int (*insertItem)(mItemView *self, HITEM hItem, HITEM prev, HITEM next, int index, int *pos);
    The function is used to insert a item to mItemView. If has NCSF_ITMMNG_AUTOSORT flag, will insert item to sort position. Otherwise, the priority of prev is higher than next, the next is higher than index.
    Parameters:
    hItem | The item handle.
    prev | The specified previous position.
    next | The specified next position.
    index | The specified insert position.
    pos | The position in which item has been inserted. It can be NULL.
    Returns:
    0 on success, otherwise -1.
  • HITEM (*createItem)(mItemView *self, HITEM prev, HITEM next, int index, int height, const char* text, DWORD addData, int *pos, BOOL adjust);
    The function creates a new item and inserts it to specified position.
    Parameters:
    prev | The specified previous position.
    next | The specified next position.
    index | The specified insert position.
    pos | The position in which item has been inserted. It can be NULL.
    adjust | Whether adjust total height or not.
    Returns:
    The handle to new item.
  • int (*inItem)(mItemView *self, int mouseX, int mouseY, HITEM *pRet, POINT *pt);
    The function gets the item that mouse is in it.
    Parameters:
    mouesX | The mouse x position.
    mouseY | The mouse y position.
    pRet | The handle to current item.
    pt | The left-top point of item.
    Returns:
    The index of item on success, otherwise -1.
  • NCS_CB_CMPSTR (*setStrCmpFunc)(mItemView *self, NCS_CB_CMPSTR func);
    The function sets string compare function.
    Parameters:
    func The new string compare function.
    Returns:
    The old string compare function.
  • NCS_CB_CMPSTR (*getStrCmpFunc)(mItemView *self);
    The function gets current string compare function.

  • int (*getItemYPos)(mItemView *self, HITEM hItem);
    The function gets the specified item's starting y position.

  • void (*setAutoSortItem) (mItemView *self, BOOL sort);
    The function sets or cancels the NCSF_ITMMNG_AUTOSORT style.

  • int (*getTotalHeight)(mItemView *self);
    The function gets the item's total height.

  • int (*adjustItemsHeight)(mItemView *self, int diff);
    The function offsets the total height.

  • BOOL (*freeze)(mItemView *self, BOOL lock);
    The function is used to freeze the item manager or not. If manager is frozen, it will not refresh items until unfroze it.

  • BOOL (*isFrozen)(mItemView *self);
    The function determines whether manager is frozen.

  • HITEM (*getFirstItem)(mItemView *self);
    The function is used to get first item.

  • list_t* (*getQueue)(mItemView *self);
    The function is used to get the header of item list.

  • HITEM (*getListEntry)(list_t* entry);
    The function is used to get item handle by list entry.

  • int (*isEmpty)(mItemView *self);
    The function determines whether manager is empty.

  • int (*removeItem)(mItemView *self, HITEM hItem);
    The function is used to remove a item from manager.
    Parameters:
    hItem The handle to item.
    Returns:
    0 on success, otherwise -1.
  • int (*sortItems)(mItemView *self, NCS_CB_CMPITEM pfn);
    The function sorts items that uses the specified compare function.

  • BOOL (*removeAll)(mItemView *self);
    The function deletes all items.

  • int (*indexOf)(mItemView *self, HITEM hItem);
    The function gets the index of the specifed item.
    Parameters:
    hItem The handle to item.
    Returns:
    The item index on success, otherwise -1.
  • int (*setHeight)(mItemView *self, HITEM hItem, int height);
    The function sets the height of the specified item.
    Parameters:
    hItem | The handle to item.
    height | The new height of item.
    Returns:
    The difference value in old and new height on success, otherwise -1.
  • int (*getHeight)(mItemView *self, HITEM hItem);
    The function gets the height of the specified item.

  • HITEM (*getItem)(mItemView *self, int index);
    The function gets the item handle of the specified index.
    Parameters:
    index The specified index.
    Returns:
    The handle to item on success, otherwise NULL.
  • HITEM (*getPrev)(mItemView *self, HITEM hItem);
    The function gets the previous item.
    Parameters:
    hItem The handle to the specified item.
    Returns:
    The handle to previous item on success, otherwise NULL.
  • HITEM (*getNext)(mItemView *self, HITEM hItem);
    The function gets the next item.
    Parameters:
    hItem The handle to the specified item.
    Returns:
    The handle to next item on success, otherwise NULL.
  • BOOL (*isSelected)(mItemView *self, HITEM hItem);
    The function determines whether the specified item is selected or not.

  • BOOL (*isEnabled)(mItemView *self, HITEM hItem);
    The function determines whether the specified item is enabled or not.

  • BOOL (*enable)(mItemView *self, HITEM hItem, BOOL enable);
    The function enables the specified item or not.
    Parameters:
    hItem | The handle to the specified item.
    enable | The enable status:TRUE for enable, FALSE for disable.
    Returns:
    TRUE on success, otherwise FALSE.
  • void (*selectAll)(mItemView *self);
    The function selects all items.

  • void (*deselectAll)(mItemView *self);
    The function deselects all items.

  • int (*hilight)(mItemView *self, HITEM hItem);
    The function hilights the specified item.

  • HITEM (*getHilight)(mItemView *self);
    The function gets the hilighted item.
    Returns:
    The handle to old hilighted item on success, otherwise 0.
  • BOOL (*isHilight)(mItemView *self, HITEM hItem);
    The function determines whether the specified item is hilighted or not.

  • int (*getItemCount)(mItemView *self);
    The function is used to get the number of items.
    Returns:
    The number of items.
  • void (*setAddData)(mItemView *self, HITEM hItem, DWORD addData);
    The function sets the additional data of the specified item.
    Parameters:
    hItem | The handle to the specified item.
    addData | The new additional data.
  • void (*setImage)(mItemView *self, HITEM hItem, DWORD image);
    The function sets the image of the specified item.
    Parameters:
    hItem | The handle to the specified item.
    image | The new image.
  • DWORD (*getAddData)(mItemView *self, HITEM hItem);
    The function gets the additional data of the specified item.

  • DWORD (*getImage)(mItemView *self, HITEM hItem);
    The function gets the image of the specified item.

  • void (*setFlags)(mItemView *self, HITEM hItem, DWORD flags);
    The function sets the flags of the specified item.
    Parameters:
    hItem | The handle to the specified item.
    flags | The new flags.
  • DWORD (*getFlags)(mItemView *self, HITEM hItem);
    The function gets the flags of the specified item.

  • BOOL (*setText)(mItemView *self, HITEM hItem, const char* text);
    The function sets the text of the specified item.
    Parameters:
    hItem | The handle to item.
    text | The next text.
    Returns:
    TRUE on success, otherwise FALSE.
  • const char* (*getText)(mItemView *self, HITEM hItem);
    The function gets the text of the specified item.
    Parameters:
    hItem The handle to item.
    Returns:
    The text.
  • int (*getTextLen)(mItemView *self, HITEM hItem);
    The function gets the text length of the specified item.
    Parameters:
    hItem The handle to item.
    Returns:
    The text length.
  • BOOL (*getSelection)(mItemView *self, HITEM *pRet, int count);
    Get the array of item handles for the selected items.
    Parameters:
    pRet | The array of handles.
    count | The maximum size of array.
    Returns:
    TRUE on success, otherwise FALSE.
  • int (*getSelectionCount)(mItemView *self);
    The function gets the number of selected items.

  • BOOL (*select)(mItemView *self, HITEM hItem);
    The function selects the specified item.
    Parameters:
    hItem The handle to the specified item.
    Returns:
    TRUE on success, otherwise FALSE.
  • BOOL (*deselect)(mItemView *self, HITEM hItem);
    The function deselects the specified item.
    Parameters:
    hItem The handle to the specified item.
    Returns:
    TRUE on success, otherwise FALSE.
  • NCS_CB_DRAWITEM (*setItemDraw)(mItemView *self, NCS_CB_DRAWITEM func);
    Sets the user-defined function of drawing item.
    Parameters:
    func The new funciton.
    Returns:
    The old function.
  • NCS_CB_INITITEM (*setItemInit)(mItemView *self, NCS_CB_INITITEM func);
    Sets the user-defined function of initializing item.
    Parameters:
    func The new funciton.
    Returns:
    The old function.
  • NCS_CB_DSTRITEM (*setItemDestroy)(mItemView *self, NCS_CB_DSTRITEM func);
    Sets the user-defined function of destroying item.
    Parameters:
    func The new funciton.
    Returns:
    The old function.
  • int (*getFirstVisItem)(mItemView *self);
    Gets the first visible item index.

  • BOOL (*setTextByIdx)(mItemView *self, int index, const char* text);
    Sets text of item by index.
    Parameters:
    index The index of item.
    Returns:
    TRUE on success, FALSE for failure.
  • const char* (*getTextByIdx)(mItemView *self, int index);
    Gets text of item by index.
    Parameters:
    index The index of item.
    Returns:
    The string of item on success, otherwise NULL.
  • int (*getRect)(mItemView *self, HITEM hItem, RECT *rcItem, BOOL bConv);
    Get the specified item's rectangle.
    Parameters:
    hItem | The handle to the specified item.
    index | The index of item.
    Returns:
    0 on success, otherwise -1.
  • void (*refreshItem)(mItemView *self, HITEM hItem, const RECT *rcInv);
    Refresh the specified item.
    Parameters:
    hItem | The handle to the specified item.
    rcInv | The pointer to a RECT structure which defines the invalid rectangle. NULL for the whole item.
  • BOOL (*showItemByIdx)(mItemView *self, int index);
    Show item by index.

  • BOOL (*showItem)(mItemView *self, HITEM hItem);
    Shows the specified item.

  • int (*setCurSel)(mItemView *self, int newSel);
    Selects an item in a multiple-selection list box and scroll it into viewport.
    Parameters:
    newSel The index of the item.
    flag Indicates the changes to be made to the listbox item, can be one of the following values:
    • -1
      If the item has been selected, makes it unselected, vice versa.
    • 0
      Makes the item unselected.
    • other
      Makes the item selected.
    Returns:
    0 on success, else -1 to indicates you passed an invalid index or the list box has no NCSS_ITEMV_MULTIPLE style.
  • int (*getCurSel)(mItemView *self);
    Get the index of current selected item.
    Returns:
    The index of current selected item on success, otherwise -1.
  • void (*resetContent)(mItemView *self);
    Reset all property and remove all items.
The documentation for this struct was generated from the following file:
  • mitemview.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mItemViewRenderer Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mItemViewRenderer Struct Reference
[mItemView]

The structure of mItemView renderer, which inheried from mScrollWidgetRenderer. More...

#include <mitemview.h>

Detailed Description

The structure of mItemView renderer, which inheried from mScrollWidgetRenderer.
The documentation for this struct was generated from the following file:
  • mitemview.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mLEDLabel

mLEDLabel

Data Structures

  • struct mLEDLabel
    LedLabel class, derived from mStatic. More...
  • struct mLEDLabelClass
    VTable of mLEDLabel, derived from mStaticClass. More...
  • struct mLEDLabelRenderer
    mLEDLabel renderer interface, derived from mStaticRenderer More...

Defines

  • #define NCSCTRL_LEDLABEL NCSCLASSNAME("ledlabel")
    the name of mLEDLabel

Enumerations

  • enum mLEDLabelProp
    the properties id of mLEDLabel More...
  • enum enumLEDLabelNotify
    the notification code of mLEDLabel More...

Define Documentation

#define NCSCTRL_LEDLABEL NCSCLASSNAME("ledlabel")

the name of mLEDLabel

Definition at line 21 of file mledstatic.h.

Enumeration Type Documentation

enum enumLEDLabelNotify

the notification code of mLEDLabel

Definition at line 94 of file mledstatic.h.

enum mLEDLabelProp

the properties id of mLEDLabel

Definition at line 82 of file mledstatic.h.

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mLEDLabel Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mLEDLabel Struct Reference
[mLEDLabel]

LedLabel class, derived from mStatic. More...

#include <mledstatic.h>

Detailed Description

LedLabel class, derived from mStatic.
The documentation for this struct was generated from the following file:
  • mledstatic.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mLEDLabelClass Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mLEDLabelClass Struct Reference
[mLEDLabel]

VTable of mLEDLabel, derived from mStaticClass. More...

#include <mledstatic.h>

Detailed Description

VTable of mLEDLabel, derived from mStaticClass.
The documentation for this struct was generated from the following file:
  • mledstatic.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mLEDLabelRenderer Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mLEDLabelRenderer Struct Reference
[mLEDLabel]

mLEDLabel renderer interface, derived from mStaticRenderer More...

#include <mledstatic.h>

Detailed Description

mLEDLabel renderer interface, derived from mStaticRenderer
The documentation for this struct was generated from the following file:
  • mledstatic.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mList

mList

Data Structures

  • struct mList
    The structure of mList, which derived from mAbstractList. It is the normal list control that can show nodes in different layout. More...
  • struct mListClass
    The virtual function table of mList, which derived from mAbstractListClass. More...
  • struct mListRenderer
    The structure of mList renderer, which inheried from mAbstractListRenderer. More...

Defines

  • #define NCSCTRL_LIST NCSCLASSNAME("list")
    the name of mList
  • #define NCSS_LIST_LOOP (0x0001<<NCSS_ASTLST_SHIFT)
    Travel all items circularly.
  • #define NCSS_LIST_MULTIPLE (0x0002<<NCSS_ASTLST_SHIFT)
    Allow user to select multiple items. Reserved.
  • #define NCSS_LIST_SHIFT (NCSS_ASTLST_SHIFT+2)
    The bits used by mList in style.

Enumerations

  • enum ncsListLayoutID { NCS_LIST_LLIST = 0, NCS_LIST_LICONV , NCS_LIST_MAX }
    The layout id of mList. More...
  • enum mListProp { NCSP_LIST_LAYOUT = NCSP_ASTLST_MAX + 1, NCSP_LIST_DEFNODEWIDTH, NCSP_LIST_DEFNODEHEIGHT, NCSP_LIST_MAX }
    The properties id of mList. More...
  • enum mListNotify {
    NCSN_LIST_SELCHANGED = NCSN_ASTLST_MAX + 1, NCSN_LIST_ENTER, NCSN_LIST_BACKSPACE, NCSN_LIST_ENTERSUBLIST,
    NCSN_LIST_BACKUPLIST , NCSN_LIST_MAX
    }
    The notification id of mList. More...

Variables

  • MGNCS_EXPORT mListClass g_stmListCls
    The instance of mListClass.

Detailed Description

Id
mlist.h 1803 2010-03-19 02:21:53Z dongjunjie

Copyright (C) 2009~2010 Feynman Software.

Define Documentation

#define NCSCTRL_LIST NCSCLASSNAME("list")

the name of mList

Definition at line 43 of file mlist.h.

#define NCSS_LIST_LOOP (0x0001<<NCSS_ASTLST_SHIFT)

Travel all items circularly.

Definition at line 53 of file mlist.h.

#define NCSS_LIST_MULTIPLE (0x0002<<NCSS_ASTLST_SHIFT)

Allow user to select multiple items. Reserved.

Definition at line 59 of file mlist.h.

#define NCSS_LIST_SHIFT (NCSS_ASTLST_SHIFT+2)

The bits used by mList in style.

Definition at line 65 of file mlist.h.

Enumeration Type Documentation

enum mListNotify

The notification id of mList.

Enumerator:
NCSN_LIST_SELCHANGED Selected node changed.
  • param : mNode*, the pointer to selected node.
NCSN_LIST_ENTER User has pressed the ENTER key.
  • param : mNode*, current selected node.
NCSN_LIST_BACKSPACE User has pressed the BackSpace key.
  • param : mNode*, current selected node.
NCSN_LIST_ENTERSUBLIST It will enter sub list.
  • param : mNode*, current selected node.
NCSN_LIST_BACKUPLIST It will back upper list.
  • param : mNode*, current selected node.
NCSN_LIST_MAX The maximum value of mAbstractList notification code id.

Definition at line 232 of file mlist.h.

enum mListProp

The properties id of mList.

Enumerator:
NCSP_LIST_LAYOUT | The layout id. ncsListLayoutID
NCSP_LIST_DEFNODEWIDTH | The default node width.
NCSP_LIST_DEFNODEHEIGHT | The default node height.
NCSP_LIST_MAX | The maximum value of mList properties id.

Definition at line 205 of file mlist.h.

enum ncsListLayoutID

The layout id of mList.

Enumerator:
NCS_LIST_LLIST | The default layout. List.
NCS_LIST_LICONV | The iconview layout.
NCS_LIST_MAX | The maximum value of mList layout id.

Definition at line 158 of file mlist.h.

Variable Documentation

g_stmListCls

The instance of mListClass.

See also:
mListClass

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mList Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mList Struct Reference
[mList]

The structure of mList, which derived from mAbstractList. It is the normal list control that can show nodes in different layout. More...

#include <mlist.h>

Detailed Description

The structure of mList, which derived from mAbstractList. It is the normal list control that can show nodes in different layout.

  • hiliteNode
    The high lighted node.

  • layout
    The layout function ops.

  • nodesHeight
    The total height of children directly.
The documentation for this struct was generated from the following file:
  • mlist.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mListClass Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mListClass Struct Reference
[mList]

The virtual function table of mList, which derived from mAbstractListClass. More...

#include <mlist.h>

Detailed Description

The virtual function table of mList, which derived from mAbstractListClass.

  • void (*resetContent)(mList *self);
    Reset all property and remove all nodes.

  • void (*removeAll)(mList *self);
    Remove all nodes.

  • BOOL (*selectNode)(mList *self, mNode *node, BOOL select);
    Select of deselect the specified nodes.
    Parameters:
    node | The specified node.
    select | Whether select node or not.
    Returns:
    TRUE on success, otherwise FALSE.
  • BOOL (*setCurSel)(mList *self, int index);
    Hilight the specified node.
    Parameters:
    index The index of the specified node.
    Returns:
    TRUE on success, otherwise FALSE.
  • mNode* (*getCurSel)(mList *self);
    Get the hilight node.

  • void (*enterSubList)(mList *self, mNode *selNode);
    Enter sub list.

  • void (*backUpList)(mList *self, mNode *selNode);
    Back upper list.
The documentation for this struct was generated from the following file:
  • mlist.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mListRenderer Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mListRenderer Struct Reference
[mList]

The structure of mList renderer, which inheried from mAbstractListRenderer. More...

#include <mlist.h>

Detailed Description

The structure of mList renderer, which inheried from mAbstractListRenderer.
The documentation for this struct was generated from the following file:
  • mlist.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mListLayout

mListLayout

Enumerations

  • enum mListLayoutProp { , NCSP_LIST_LAYOUT_MAX }
    The properties id of mListLayout. More...

Variables

  • MGNCS_EXPORT mListLayoutClass g_stmListLayoutCls
    The instance of mListLayoutClass.

Detailed Description

$Id$

Copyright (C) 2009~2010 Feynman Software.

Enumeration Type Documentation

enum mListLayoutProp

The properties id of mListLayout.

Enumerator:
NCSP_LIST_LAYOUT_MAX The maximum value of mListLayout properties id.

Definition at line 80 of file mlist_layout.h.

Variable Documentation

g_stmListLayoutCls

The instance of mListLayoutClass.

See also:
mListLayoutClass

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mListBox

mListBox

Data Structures

  • struct _NCS_LSTBOX_ITEMINFO
  • struct mListBox
    The structure of mListBox control, which derived from mItemView. More...
  • struct mListBoxClass
    The virtual function table of mListBox, which derived from mItemViewClass. More...
  • struct mListBoxRenderer
    The structure of mListBox renderer, which derived from mWidgetRenderer. More...

Defines

  • #define NCSCTRL_LISTBOX NCSCLASSNAME("listbox")
    The control class name of mListBox.
  • #define NCSS_LSTBOX_SHIFT (NCSS_ITEMV_SHIFT+4)
    The bits used by mListBox in style.
  • #define NCSS_LSTBOX_SINGLE NCSS_ITEMV_SINGLE
    Only have a selected item simultaneously.
  • #define NCSS_LSTBOX_MULTIPLE NCSS_ITEMV_MULTIPLE
    Allow user to select multiple items.
  • #define NCSS_LSTBOX_SORT NCSS_ITEMV_AUTOSORT
    Sort strings alphabetically.
  • #define NCSS_LSTBOX_MOUSEFOLLOW (0x0001<<NCSS_ITEMV_SHIFT)
    When mouse moved, change the selected item. Only for NCSS_LSTBOX_SINGLE.
  • #define NCSS_LSTBOX_STRING (0x0000<<NCSS_ITEMV_SHIFT)
    Display a string in an item.
  • #define NCSS_LSTBOX_USEBITMAP (0x0002<<NCSS_ITEMV_SHIFT)
    Display a icon or bitmap in an item.
  • #define NCSS_LSTBOX_CHECKBOX (0x0004<<NCSS_ITEMV_SHIFT)
    Display a check box in an item.
  • #define NCSS_LSTBOX_AUTOCHECK (0x0008<<NCSS_ITEMV_SHIFT)
    Auto-switch the check box between checked or un-checked when the user click the check mark box of an item.
  • #define NCSS_LSTBOX_AUTOCHECKBOX (NCSS_LSTBOX_CHECKBOX | NCSS_LSTBOX_AUTOCHECK)
    Set the style NCSS_LSTBOX_CHECKBOX and NCSS_LSTBOX_AUTOCHECK.
  • #define NCSF_LSTBOX_CMBLANK (0x0000<<NCSF_ITEM_SHIFT)
    The item is blank.
  • #define NCSF_LSTBOX_CMCHECKED (0x0001<<NCSF_ITEM_SHIFT)
    The flag of checked item.
  • #define NCSF_LSTBOX_CMPARTCHECKED (0x0002<<NCSF_ITEM_SHIFT)
    The flag is partly checked item.
  • #define NCSF_LSTBOX_CHECKMASK (NCSF_LSTBOX_CMBLANK | NCSF_LSTBOX_CMCHECKED | NCSF_LSTBOX_CMPARTCHECKED)
    The flag mask of check mark or image.
  • #define NCSF_LSTBOX_BOLD (0x0004<<NCSF_ITEM_SHIFT)
    The flag of bold item.
  • #define NCSF_LSTBOX_SIGNIFICANT (0x0008<<NCSF_ITEM_SHIFT)
    The flag of significant item.

Enumerations

  • enum mListBoxProp {
    NCSP_LSTBOX_ITEMWIDTH = NCSP_SWGT_CONTWIDTH, NCSP_LSTBOX_ITEMCOUNT = NCSP_ITEMV_ITEMCOUNT, NCSP_LSTBOX_ITEMHEIGHT = NCSP_ITEMV_MAX + 1, NCSP_LSTBOX_TOPITEM,
    NCSP_LSTBOX_HILIGHTEDITEM, NCSP_LSTBOX_MAX
    }
    The properties id of mListBox. More...
  • enum mListBoxNotify {
    NCSN_LSTBOX_CLICKED = NCSN_ITEMV_CLICKED, NCSN_LSTBOX_SELCHANGED = NCSN_ITEMV_SELCHANGED, NCSN_LSTBOX_ENTER = NCSN_ITEMV_ENTER, NCSN_LSTBOX_SETFOCUS = NCSN_ITEMV_SETFOCUS,
    NCSN_LSTBOX_KILLFOCUS = NCSN_ITEMV_KILLFOCUS, NCSN_LSTBOX_ERRSPACE = NCSN_ITEMV_MAX + 1, NCSN_LSTBOX_DBCLK, NCSN_LSTBOX_CMCANCEL ,
    NCSN_LSTBOX_CLKCHKMARK, NCSN_LSTBOX_MAX
    }
    The notification code id of mListBox. More...

Variables

  • MGNCS_EXPORT mListBoxClass g_stmListBoxCls
    The instance of mListBoxClass.

Detailed Description

Id
mlistbox.h 1058 2010-10-28 05:40:27Z xwyan

Copyright (C) 2009 Feynman Software.

Define Documentation

#define NCSCTRL_LISTBOX NCSCLASSNAME("listbox")

The control class name of mListBox.

Definition at line 88 of file mlistbox.h.

#define NCSF_LSTBOX_BOLD (0x0004<<NCSF_ITEM_SHIFT)

The flag of bold item.

Definition at line 186 of file mlistbox.h.

#define NCSF_LSTBOX_CHECKMASK (NCSF_LSTBOX_CMBLANK | NCSF_LSTBOX_CMCHECKED | NCSF_LSTBOX_CMPARTCHECKED)

The flag mask of check mark or image.

Definition at line 179 of file mlistbox.h.

#define NCSF_LSTBOX_CMBLANK (0x0000<<NCSF_ITEM_SHIFT)

The item is blank.

Definition at line 161 of file mlistbox.h.

#define NCSF_LSTBOX_CMCHECKED (0x0001<<NCSF_ITEM_SHIFT)

The flag of checked item.

Definition at line 167 of file mlistbox.h.

#define NCSF_LSTBOX_CMPARTCHECKED (0x0002<<NCSF_ITEM_SHIFT)

The flag is partly checked item.

Definition at line 173 of file mlistbox.h.

#define NCSF_LSTBOX_SIGNIFICANT (0x0008<<NCSF_ITEM_SHIFT)

The flag of significant item.

Definition at line 192 of file mlistbox.h.

#define NCSS_LSTBOX_AUTOCHECK (0x0008<<NCSS_ITEMV_SHIFT)

Auto-switch the check box between checked or un-checked when the user click the check mark box of an item.

Definition at line 144 of file mlistbox.h.

#define NCSS_LSTBOX_AUTOCHECKBOX (NCSS_LSTBOX_CHECKBOX | NCSS_LSTBOX_AUTOCHECK)

Set the style NCSS_LSTBOX_CHECKBOX and NCSS_LSTBOX_AUTOCHECK.

Definition at line 150 of file mlistbox.h.

#define NCSS_LSTBOX_CHECKBOX (0x0004<<NCSS_ITEMV_SHIFT)

Display a check box in an item.

Definition at line 137 of file mlistbox.h.

#define NCSS_LSTBOX_MOUSEFOLLOW (0x0001<<NCSS_ITEMV_SHIFT)

When mouse moved, change the selected item. Only for NCSS_LSTBOX_SINGLE.

Definition at line 119 of file mlistbox.h.

#define NCSS_LSTBOX_MULTIPLE NCSS_ITEMV_MULTIPLE

Allow user to select multiple items.

Definition at line 106 of file mlistbox.h.

#define NCSS_LSTBOX_SHIFT (NCSS_ITEMV_SHIFT+4)

The bits used by mListBox in style.

Definition at line 94 of file mlistbox.h.

#define NCSS_LSTBOX_SINGLE NCSS_ITEMV_SINGLE

Only have a selected item simultaneously.

Definition at line 100 of file mlistbox.h.

#define NCSS_LSTBOX_SORT NCSS_ITEMV_AUTOSORT

Sort strings alphabetically.

Definition at line 112 of file mlistbox.h.

#define NCSS_LSTBOX_STRING (0x0000<<NCSS_ITEMV_SHIFT)

Display a string in an item.

Definition at line 125 of file mlistbox.h.

#define NCSS_LSTBOX_USEBITMAP (0x0002<<NCSS_ITEMV_SHIFT)

Display a icon or bitmap in an item.

Definition at line 131 of file mlistbox.h.

Enumeration Type Documentation

enum mListBoxNotify

The notification code id of mListBox.

Enumerator:
NCSN_LSTBOX_CLICKED | Click on the string.
NCSN_LSTBOX_SELCHANGED | Selected item changed.
NCSN_LSTBOX_ENTER | User has pressed the ENTER key.
NCSN_LSTBOX_SETFOCUS | Get input focus.
NCSN_LSTBOX_KILLFOCUS | Lost input focus.
NCSN_LSTBOX_ERRSPACE | No enough memory.
NCSN_LSTBOX_DBCLK | Double click on an item.
NCSN_LSTBOX_CMCANCEL The checkbox selection is cancelled in ListBox.
  • param: int, The index of list item.
NCSN_LSTBOX_CLKCHKMARK | Click on the check mark.
NCSN_LSTBOX_MAX | The maximum value of mListBox notification code id.

Definition at line 390 of file mlistbox.h.

enum mListBoxProp

The properties id of mListBox.

Enumerator:
NCSP_LSTBOX_ITEMWIDTH | The maximum width of item.
NCSP_LSTBOX_ITEMCOUNT | The number of items. Read only.
NCSP_LSTBOX_ITEMHEIGHT | The height of item.
NCSP_LSTBOX_TOPITEM | The index of top item.
NCSP_LSTBOX_HILIGHTEDITEM | The index of hilighted item. Note:It has different meaning in different selection style. In single selected mode, it is same as selected item. But in multiply selected mode, it stands for current focus item which can be changed by mouse or keyboard.
NCSP_LSTBOX_MAX | The maximum value of mListBox properties id.

Definition at line 349 of file mlistbox.h.

Variable Documentation

g_stmListBoxCls

The instance of mListBoxClass.

See also:
mListBoxClass

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: _NCS_LSTBOX_ITEMINFO Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_NCS_LSTBOX_ITEMINFO Struct Reference
[mListBox]

#include <mlistbox.h>

Data Fields

  • char * string
  • DWORD flag
  • DWORD image
  • DWORD addData

Detailed Description

The structure of listbox item information.

Definition at line 45 of file mlistbox.h.

Field Documentation

char* string

The text string.

Definition at line 50 of file mlistbox.h.

DWORD flag

Check mark and image flag. It can be one of the following values:

  • NCSF_LSTBOX_CMBLANK The item is blank.
  • NCSF_LSTBOX_CMCHECKED The item is checked.
  • NCSF_LSTBOX_CMPARTCHECKED The item is partly checked.

If you want to significant the item which to be rendered, you can OR'd flag with NCSF_LSTBOX_SIGNIFICANT.

For NCSS_LSTBOX_USEBITMAP list box, if you want to display bitmap other than icon, you can OR'd flag with NCSF_ITEM_USEBITMAP.

Definition at line 67 of file mlistbox.h.

DWORD image

The handle to icon or pointer to image object of the item.

Definition at line 72 of file mlistbox.h.

DWORD addData

The Additional Data of the item

Definition at line 77 of file mlistbox.h.

The documentation for this struct was generated from the following file:
  • mlistbox.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mListBox Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mListBox Struct Reference
[mListBox]

The structure of mListBox control, which derived from mItemView. More...

#include <mlistbox.h>

Detailed Description

The structure of mListBox control, which derived from mItemView.

  • font
    Logic font for bold display.

  • itemVisibles
    The number of visible items.

  • itemHilighted
    Current hilighted item.

  • selItem
    Record last selected item when use NCSS_LSTBOX_MOUSEFOLLOW style.

  • listFlag
    The flags of listbox.
The documentation for this struct was generated from the following file:
  • mlistbox.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mListBoxClass Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mListBoxClass Struct Reference
[mListBox]

The virtual function table of mListBox, which derived from mItemViewClass. More...

#include <mlistbox.h>

Detailed Description

The virtual function table of mListBox, which derived from mItemViewClass.

  • int (*setSel)(mListBox *self, int newSel, int flag);
    Selects an item in a multiple-selection list box and scroll it into viewport.
    Parameters:
    newSel The index of the item.
    flag Indicates the changes to be made to the listbox item, can be one of the following values:
    • -1
      If the item has been selected, makes it unselected, vice versa.
    • 0
      Makes the item unselected.
    • other
      Makes the item selected.
    Returns:
    0 on success, else -1 to indicates you passed an invalid index or the list box has no NCSS_LSTBOX_MULTIPLE style.
  • int (*addString)(mListBox *self, const char* string, DWORD addData);
    Add a new item to listbox.
    Parameters:
    string | The string information of new item.
    addData | The additional data of new item.
    Returns:
    The index of item on success, otherwise -1.
  • int (*findString)(mListBox *self, int start, char* string, BOOL bExact);
    Find the index of item which uses string as text from start index to end of items.
    Parameters:
    start | The start index.
    string | The string text.
    bExact | Whether exactly found or not.
    Returns:
    The index of item on success, otherwise -1.
  • int (*insertString)(mListBox *self, const char* string, DWORD addData, int index);
    Insert a new item to specified position index.
    Parameters:
    string | The string information of new item.
    addData | The additional data of new item.
    index | The index of item.
    Returns:
    The index of item on success, otherwise -1.
  • BOOL (*delString)(mListBox *self, int index);
    Delete the specified item.
    Parameters:
    index The index of item.
    Returns:
    TRUE on success, otherwise FALSE.
  • void (*addItems)(mListBox *self, NCS_LSTBOX_ITEMINFO *info, int count);
    Add a series of items to listbox.
    Parameters:
    info | The information of new items.
    count | The number of items.
  • int (*removeItemByIdx)(clsName*, int index); Remove an item in listbox.

  • BOOL (*bold)(mListBox *self, int index, BOOL bold);
    Bold the specified item or not.
    Parameters:
    index | The index of item.
    bold | Whether bold or not.
    Returns:
    TRUE on success, otherwise FALSE.
  • BOOL (*isHilightByIdx)(mListBox *self, int index);
    Determines whehter the specified item by index is hilighted or not.

  • BOOL (*enableByIdx)(mListBox *self, int index, BOOL benable);
    Enable the specified item by index or not.

  • int (*selectByIdx)(mListBox *self, int index);
    Select the specified item by index.

  • int (*deselectByIdx)(mListBox *self, int index);
    Deselect the specified item by index or not.

  • BOOL (*setCheckMark)(mListBox *self, int index, DWORD mark);
    Set checkmark status of the specified item.
    Parameters:
    index The index of item.
    mark The mark flag, can be one of the follwing values:
    • NCSF_LSTBOX_CMBLANK
    • NCSF_LSTBOX_CMCHECKED
    • NCSF_LSTBOX_CMPARTCHECKED
    Returns:
    TRUE on success, otherwise FALSE.
  • DWORD (*getCheckMark)(mListBox *self, int index);
    Get the checkmark status of the specified item.
    Parameters:
    index The index of item.
    Returns:
    The flag of checkmark on success, otherwise 0.
The documentation for this struct was generated from the following file:
  • mlistbox.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mListBoxRenderer Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mListBoxRenderer Struct Reference
[mListBox]

The structure of mListBox renderer, which derived from mWidgetRenderer. More...

#include <mlistbox.h>

Detailed Description

The structure of mListBox renderer, which derived from mWidgetRenderer.
The documentation for this struct was generated from the following file:
  • mlistbox.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mListColumn

mListColumn

Data Structures

  • struct NCS_LSTCLM_SORTDATA
    The sort type. More...
  • struct mListColumn
    The structure of mListColumn. It's used as header by mListView. More...
  • struct mListColumnClass
    The virtual function table of mListColumn, which derived from mItemClass. More...

Defines

  • #define NCSF_LSTCLM_LEFTALIGN (0x00<<NCSF_ITEM_SHIFT)
    Horizontal left align.
  • #define NCSF_LSTCLM_RIGHTALIGN (0x01<<NCSF_ITEM_SHIFT)
    Horizontal right align.
  • #define NCSF_LSTCLM_CENTERALIGN (0x02<<NCSF_ITEM_SHIFT)
    Horizontal center align.
  • #define NCSF_LSTCLM_TOPALIGN (0x00<<NCSF_ITEM_SHIFT)
    Vertical top align.
  • #define NCSF_LSTCLM_BOTTOMALIGN (0x04<<NCSF_ITEM_SHIFT)
    Vertical bottom align.
  • #define NCSF_LSTCLM_VCENTERALIGN (0x08<<NCSF_ITEM_SHIFT)
    Vertical center align.
  • #define NCSF_LSTCLM_VALIGNMASK (0x0C<<NCSF_ITEM_SHIFT)
    The mask of vertical align.
  • #define NCSF_LSTCLM_SHIFT (NCSF_ITEM_SHIFT+4)
    The bits used by mListColumn in flags.

Typedefs

  • typedef int(* NCS_CB_LISTV_CMPCLM )(HITEM nItem1, HITEM nItem2, NCS_LSTCLM_SORTDATA *sortData)
    The callback of comparison column function.

Enumerations

  • enum ncsLstClmSortType { NCSID_LSTCLM_NOTSORTED = 0, NCSID_LSTCLM_HISORTED, NCSID_LSTCLM_LOSORTED }
    The sort type. More...
  • enum mListColumnProp {
    NCSP_LSTCLM_POSX = NCSP_ITEM_MAX + 1, NCSP_LSTCLM_WIDTH, NCSP_LSTCLM_SORTTYPE, NCSP_LSTCLM_CMPFUNC,
    NCSP_LSTCLM_MAX
    }
    The properties id of mListColumn. More...

Variables

  • MGNCS_EXPORT mListColumnClass g_stmListColumnCls
    The instance of mListColumnClass.

Detailed Description

Id
mlistcolumn.h 1072 2010-11-05 06:39:58Z xwyan

Copyright (C) 2009 Feynman Software.

Define Documentation

#define NCSF_LSTCLM_BOTTOMALIGN (0x04<<NCSF_ITEM_SHIFT)

Vertical bottom align.

Definition at line 122 of file mlistcolumn.h.

#define NCSF_LSTCLM_CENTERALIGN (0x02<<NCSF_ITEM_SHIFT)

Horizontal center align.

Definition at line 110 of file mlistcolumn.h.

#define NCSF_LSTCLM_LEFTALIGN (0x00<<NCSF_ITEM_SHIFT)

Horizontal left align.

Definition at line 98 of file mlistcolumn.h.

#define NCSF_LSTCLM_RIGHTALIGN (0x01<<NCSF_ITEM_SHIFT)

Horizontal right align.

Definition at line 104 of file mlistcolumn.h.

#define NCSF_LSTCLM_SHIFT (NCSF_ITEM_SHIFT+4)

The bits used by mListColumn in flags.

Definition at line 140 of file mlistcolumn.h.

#define NCSF_LSTCLM_TOPALIGN (0x00<<NCSF_ITEM_SHIFT)

Vertical top align.

Definition at line 116 of file mlistcolumn.h.

#define NCSF_LSTCLM_VALIGNMASK (0x0C<<NCSF_ITEM_SHIFT)

The mask of vertical align.

Definition at line 134 of file mlistcolumn.h.

#define NCSF_LSTCLM_VCENTERALIGN (0x08<<NCSF_ITEM_SHIFT)

Vertical center align.

Definition at line 128 of file mlistcolumn.h.

Typedef Documentation

typedef int(* NCS_CB_LISTV_CMPCLM)(HITEM nItem1, HITEM nItem2, NCS_LSTCLM_SORTDATA *sortData)

The callback of comparison column function.

Definition at line 92 of file mlistcolumn.h.

Enumeration Type Documentation

enum mListColumnProp

The properties id of mListColumn.

Enumerator:
NCSP_LSTCLM_POSX | The start x coordination.
NCSP_LSTCLM_WIDTH | The column width.
NCSP_LSTCLM_SORTTYPE | The sort type.
NCSP_LSTCLM_CMPFUNC | The comparison function.
NCSP_LSTCLM_MAX | The maximum value of ListColumn properties id.

Definition at line 187 of file mlistcolumn.h.

enum ncsLstClmSortType

The sort type.

Enumerator:
NCSID_LSTCLM_NOTSORTED | No sort.
NCSID_LSTCLM_HISORTED | Sort ascending.
NCSID_LSTCLM_LOSORTED | Sort descending.

Definition at line 46 of file mlistcolumn.h.

Variable Documentation

g_stmListColumnCls

The instance of mListColumnClass.

See also:
mListColumnClass

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: NCS_LSTCLM_SORTDATA Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

NCS_LSTCLM_SORTDATA Struct Reference
[mListColumn]

The sort type. More...

#include <mlistcolumn.h>

Detailed Description

The sort type.
The documentation for this struct was generated from the following file:
  • mlistcolumn.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mListColumn Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mListColumn Struct Reference
[mListColumn]

The structure of mListColumn. It's used as header by mListView. More...

#include <mlistcolumn.h>

Detailed Description

The structure of mListColumn. It's used as header by mListView.

  • startX
    The start x coordination.

  • width
    The column width.

  • sort
    The sort type.

  • pfnCmp
    The comparison function.
The documentation for this struct was generated from the following file:
  • mlistcolumn.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mListColumnClass Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mListColumnClass Struct Reference
[mListColumn]

The virtual function table of mListColumn, which derived from mItemClass. More...

#include <mlistcolumn.h>

Detailed Description

The virtual function table of mListColumn, which derived from mItemClass.
The documentation for this struct was generated from the following file:
  • mlistcolumn.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mListItem

mListItem

Data Structures

  • struct mListItem
    The structure of mListItem. It's used as item by mListView. More...
  • struct mListItemClass
    The virtual function table of mListItem, which derived from mItemManagerClass. More...

Defines

  • #define NCSF_LSTITM_FOLD (0x0001<<NCSF_ITMMNG_SHIFT)
    fold item.
  • #define NCSF_LSTITM_PRIVBKCOL (0x0002<<NCSF_ITMMNG_SHIFT)
    background for item.
  • #define NCSF_LSTITM_PRIVFGCOL (0x0004<<NCSF_ITMMNG_SHIFT)
    foreground for item.
  • #define NCSF_LSTITM_SHIFT (NCSF_ITMMNG_SHIFT + 3)
    The bits used by mListItem in flags.

Enumerations

  • enum mListItemProp { NCSP_LSTITM_NRCHILD = NCSP_ITMMNG_MAX + 1, NCSP_LSTITM_DEPTH, NCSP_LSTITM_RHEIGHT, NCSP_LSTITM_MAX }
    The properties id of mListItem. More...

Variables

  • MGNCS_EXPORT mListItemClass g_stmListItemCls
    The instance of mListItemClass.

Detailed Description

Id
mlistitem.h 635 2009-10-28 02:19:04Z wangjian

Copyright (C) 2009 Feynman Software.

Define Documentation

#define NCSF_LSTITM_FOLD (0x0001<<NCSF_ITMMNG_SHIFT)

fold item.

Definition at line 46 of file mlistitem.h.

#define NCSF_LSTITM_PRIVBKCOL (0x0002<<NCSF_ITMMNG_SHIFT)

background for item.

Definition at line 52 of file mlistitem.h.

#define NCSF_LSTITM_PRIVFGCOL (0x0004<<NCSF_ITMMNG_SHIFT)

foreground for item.

Definition at line 58 of file mlistitem.h.

#define NCSF_LSTITM_SHIFT (NCSF_ITMMNG_SHIFT + 3)

The bits used by mListItem in flags.

Definition at line 64 of file mlistitem.h.

Enumeration Type Documentation

enum mListItemProp

The properties id of mListItem.

Enumerator:
NCSP_LSTITM_NRCHILD | The number of children.
NCSP_LSTITM_DEPTH | The depth.
NCSP_LSTITM_RHEIGHT | The height when item can be visible.
NCSP_LSTITM_MAX | The maximum value of listitem properties id.

Definition at line 178 of file mlistitem.h.

Variable Documentation

g_stmListItemCls

The instance of mListItemClass.

See also:
mListItemClass

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mListItem Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mListItem Struct Reference
[mListItem]

The structure of mListItem. It's used as item by mListView. More...

#include <mlistitem.h>

Detailed Description

The structure of mListItem. It's used as item by mListView.

  • parent
    The pointer to parent item.

  • foldIcon
    The icon used when item is folded.

  • unfoldIcon
    The icon used when item is unfolded.

  • showHeight
    The height when item can be visible.

  • depth
    The depth.

  • bkColor
    The background color.

  • fgColor
    The foreground color.

  • nrChild
    The number of children.
The documentation for this struct was generated from the following file:
  • mlistitem.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mListItemClass Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mListItemClass Struct Reference
[mListItem]

The virtual function table of mListItem, which derived from mItemManagerClass. More...

#include <mlistitem.h>

Detailed Description

The virtual function table of mListItem, which derived from mItemManagerClass.

  • void (*setBackground)(mListItem *self, int index, int* color);
    Set the background of the specified index item. If the specfied index is invalid, it will set the item's background. When color is NULL, it will cancel previous setting.

  • void (*setForeground)(mListItem *self, int index, int* color);
    Set the foreground of the specified index item. If the specfied index is invalid, it will set the item's background. When color is NULL, it will cancel previous setting.

  • int (*getBackground)(mListItem *self, int index, int* color);
    Get the background of the specified index item. If the specified index is invalid, it will return the item's background.

  • int (*getForeground)(mListItem *self, int index, int* color);
    Get the foreground of the specified index item. If the specified index is invalid, it will return the item's foreground.

  • mListItem* (*getParent)(mListItem *self);
    Get the pointer to parent.

  • int (*getChildCount)(mListItem *self);
    Get the number of children.

  • int (*getDepth)(mListItem *self);
    Get depth.

  • BOOL (*isFold)(mListItem *self);
    Get whether folded or not.

  • BOOL (*setFold)(mListItem *self, BOOL fold);
    Fold item.

  • BOOL (*addChild)(mListItem *self, mListItem *child);
    Add the specified child.

  • BOOL (*delChild)(mListItem *self, mListItem *child);
    Delete the specified child.
The documentation for this struct was generated from the following file:
  • mlistitem.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mListView

mListView

Data Structures

  • struct _NCS_LISTV_FINDINFO
  • struct _NCS_LISTV_CLMINFO
  • struct _NCS_LISTV_ITEMDATA
  • struct _NCS_LISTV_ITEMINFO
  • struct _NCS_CB_LISTV_CSTMHDROPS
  • struct mListView
    The structure of mListView control, which derived from mItemView.
    • drawHdrBk
      User-defined function to draw header background.
    • drawHdrItem
      User-defined function to draw header item.
    • hdrList
      The header list.
    • rootItem
      Root item.
    • sort
      Current sort type.
    • curCol
      The index of current sort column.
    • gridLineWidth
      The width of grid line.
    • gridLineColor
      The color of grid line.
    • pfnSort
      The callback of sort function.
    • hdrH
      The height of header.
    • hdrW
      The width of header.
    • dragedHead
      The index of current draged header.
    • drawX
      The x coordinate when dragging header.
    • clickedHead
      The pointer to current clicked header.
    • status
      .
    More...
  • struct mListViewClass
    The virtual function table of mListView, which derived from mItemViewClass. More...
  • struct mListViewRenderer
    The structure of mListView renderer, which derived from mItemViewRenderer. More...

Defines

  • #define NCSF_LSTHDR_LEFTALIGN (0x00<<NCSF_LSTCLM_SHIFT)
    Horizontal left align.
  • #define NCSF_LSTHDR_TOPALIGN (0x00<<NCSF_LSTCLM_SHIFT)
    Vertical top align.
  • #define NCSF_LSTHDR_RIGHTALIGN (0x01<<NCSF_LSTCLM_SHIFT)
    Horizontal right align.
  • #define NCSF_LSTHDR_CENTERALIGN (0x02<<NCSF_LSTCLM_SHIFT)
    Horizontal center align.
  • #define NCSF_LSTHDR_BOTTOMALIGN (0x04<<NCSF_LSTCLM_SHIFT)
    Vertical bottom align.
  • #define NCSF_LSTHDR_VCENTERALIGN (0x08<<NCSF_LSTCLM_SHIFT)
    Vertical center align.
  • #define NCSF_LSTHDR_VALIGNMASK (0x0C<<NCSF_LSTCLM_SHIFT)
    The mask of vertical align.
  • #define NCSF_LSTHDR_SHIFT (NCSF_LSTCLM_SHIFT+4)
    The bits used by header in flags.
  • #define NCSCTRL_LISTVIEW NCSCLASSNAME("listview")
    The control class name of mListView.
  • #define NCSS_LISTV_NOTIFY NCSS_NOTIFY
  • #define NCSS_LISTV_LOOP NCSS_ITEMV_LOOP
  • #define NCSS_LISTV_MULTIPLE NCSS_ITEMV_MULTIPLE
  • #define NCSS_LISTV_SINGLE NCSS_ITEMV_SINGLE
  • #define NCSS_LISTV_CHECKBOX (0x0001<<NCSS_ITEMV_SHIFT)
    Display a check box in an item. Reserved.
  • #define NCSS_LISTV_AUTOCHECK (0x0002<<NCSS_ITEMV_SHIFT)
    Auto-switch the check box between checked or un-checked when the user click the check mark box of an item. Reserved.
  • #define NCSS_LISTV_AUTOCHECKBOX (NCSS_LISTV_CHECKBOX | NCSS_LISTV_AUTOCHECK)
    Set the style NCSS_LISTV_CHECKBOX and NCSS_LISTV_AUTOCHECK. Reserved.
  • #define NCSS_LISTV_TREE (0x0004<<NCSS_ITEMV_SHIFT)
    Uses listview in a treeview style.
  • #define NCSS_LISTV_WITHICON (0x0008<<NCSS_ITEMV_SHIFT)
    Use icons to indicate folded or unfolded status.
  • #define NCSS_LISTV_SORT (0x0010<<NCSS_ITEMV_SHIFT)
    Sort items automatically.
  • #define NCSS_LISTV_NOHDRDRAG (0x0020<<NCSS_ITEMV_SHIFT)
    User cann't change column width by dragging header's border.
  • #define NCSS_LISTV_SHIFT (NCSS_ITEMV_SHIFT + 6)
    The bits used by mListView in style.

Typedefs

  • typedef void(* NCS_CB_LISTV_DRAWHDRBK )(mListView *self, HITEM hHdr, HDC hdc, RECT *rcDraw)
  • typedef void(* NCS_CB_LISTV_DRAWHDR )(mListView *self, HITEM hHdr, HDC hdc, RECT *rcDraw)

Enumerations

  • enum ncsListVIRType {
    NCSID_LISTV_IR_PARENT, NCSID_LISTV_IR_FIRSTCHILD, NCSID_LISTV_IR_LASTCHILD, NCSID_LISTV_IR_NEXTSIBLING,
    NCSID_LISTV_IR_PREVSIBLING
    }
    The relationship between items. More...
  • enum ncsListVFindType { NCSID_LISTV_FT_ADDDATA, NCSID_LISTV_FT_TEXT }
    The found type. More...
  • enum mListViewProp {
    NCSP_LISTV_DEFITEMHEIGHT = NCSP_ITEMV_DEFITEMHEIGHT, NCSP_LISTV_ROWCOUNT = NCSP_ITEMV_ITEMCOUNT, NCSP_LISTV_HDRHEIGHT = NCSP_ITEMV_MAX + 1, NCSP_LISTV_HDRWIDTH,
    NCSP_LISTV_HDRVISIBLE, NCSP_LISTV_SORTCOLUMN, NCSP_LISTV_GRIDLINEWIDTH, NCSP_LISTV_GRIDLINECOLOR,
    NCSP_LISTV_COLCOUNT, NCSP_LISTV_MAX
    }
    The properties id of mListView. More...
  • enum mListViewNotify {
    NCSN_LISTV_CLICKED = NCSN_ITEMV_CLICKED, NCSN_LISTV_SELCHANGED = NCSN_ITEMV_SELCHANGED, NCSN_LISTV_ITEMRDOWN = NCSN_ITEMV_MAX + 1, NCSN_LISTV_ITEMRUP,
    NCSN_LISTV_HDRRDOWN, NCSN_LISTV_HDRRUP, NCSN_LISTV_ITEMDBCLK, NCSN_LISTV_FOLDITEM,
    NCSN_LISTV_UNFOLDITEM, NCSN_LISTV_MAX
    }
    The notification code id of mListView. More...

Variables

  • MGNCS_EXPORT mListViewClass g_stmListViewCls
    The instance of mListViewClass.

Detailed Description

Id
mlistview.h 1072 2010-11-05 06:39:58Z xwyan

Copyright (C) 2009 Feynman Software.

Define Documentation

#define NCSCTRL_LISTVIEW NCSCLASSNAME("listview")

The control class name of mListView.

Definition at line 273 of file mlistview.h.

#define NCSF_LSTHDR_BOTTOMALIGN (0x04<<NCSF_LSTCLM_SHIFT)

Vertical bottom align.

Definition at line 89 of file mlistview.h.

#define NCSF_LSTHDR_CENTERALIGN (0x02<<NCSF_LSTCLM_SHIFT)

Horizontal center align.

Definition at line 83 of file mlistview.h.

#define NCSF_LSTHDR_LEFTALIGN (0x00<<NCSF_LSTCLM_SHIFT)

Horizontal left align.

Definition at line 65 of file mlistview.h.

#define NCSF_LSTHDR_RIGHTALIGN (0x01<<NCSF_LSTCLM_SHIFT)

Horizontal right align.

Definition at line 77 of file mlistview.h.

#define NCSF_LSTHDR_SHIFT (NCSF_LSTCLM_SHIFT+4)

The bits used by header in flags.

Definition at line 107 of file mlistview.h.

#define NCSF_LSTHDR_TOPALIGN (0x00<<NCSF_LSTCLM_SHIFT)

Vertical top align.

Definition at line 71 of file mlistview.h.

#define NCSF_LSTHDR_VALIGNMASK (0x0C<<NCSF_LSTCLM_SHIFT)

The mask of vertical align.

Definition at line 101 of file mlistview.h.

#define NCSF_LSTHDR_VCENTERALIGN (0x08<<NCSF_LSTCLM_SHIFT)

Vertical center align.

Definition at line 95 of file mlistview.h.

#define NCSS_LISTV_AUTOCHECK (0x0002<<NCSS_ITEMV_SHIFT)

Auto-switch the check box between checked or un-checked when the user click the check mark box of an item. Reserved.

Definition at line 309 of file mlistview.h.

#define NCSS_LISTV_AUTOCHECKBOX (NCSS_LISTV_CHECKBOX | NCSS_LISTV_AUTOCHECK)

Set the style NCSS_LISTV_CHECKBOX and NCSS_LISTV_AUTOCHECK. Reserved.

Definition at line 315 of file mlistview.h.

#define NCSS_LISTV_CHECKBOX (0x0001<<NCSS_ITEMV_SHIFT)

Display a check box in an item. Reserved.

Definition at line 302 of file mlistview.h.

#define NCSS_LISTV_LOOP NCSS_ITEMV_LOOP

See also:
NCSS_ITEMV_LOOP

Definition at line 285 of file mlistview.h.

#define NCSS_LISTV_MULTIPLE NCSS_ITEMV_MULTIPLE

See also:
NCSS_ITEMV_MULTIPLE. Reserved.

Definition at line 290 of file mlistview.h.

#define NCSS_LISTV_NOHDRDRAG (0x0020<<NCSS_ITEMV_SHIFT)

User cann't change column width by dragging header's border.

Definition at line 340 of file mlistview.h.

#define NCSS_LISTV_NOTIFY NCSS_NOTIFY

See also:
NCSS_NOTIFY

Definition at line 279 of file mlistview.h.

#define NCSS_LISTV_SHIFT (NCSS_ITEMV_SHIFT + 6)

The bits used by mListView in style.

Definition at line 346 of file mlistview.h.

#define NCSS_LISTV_SINGLE NCSS_ITEMV_SINGLE

See also:
NCSS_ITEMV_SINGLE

Definition at line 296 of file mlistview.h.

#define NCSS_LISTV_SORT (0x0010<<NCSS_ITEMV_SHIFT)

Sort items automatically.

Definition at line 334 of file mlistview.h.

#define NCSS_LISTV_TREE (0x0004<<NCSS_ITEMV_SHIFT)

Uses listview in a treeview style.

Definition at line 322 of file mlistview.h.

#define NCSS_LISTV_WITHICON (0x0008<<NCSS_ITEMV_SHIFT)

Use icons to indicate folded or unfolded status.

Definition at line 328 of file mlistview.h.

Typedef Documentation

typedef void(* NCS_CB_LISTV_DRAWHDR)(mListView *self, HITEM hHdr, HDC hdc, RECT *rcDraw)

Type of drawing header item.

Definition at line 245 of file mlistview.h.

typedef void(* NCS_CB_LISTV_DRAWHDRBK)(mListView *self, HITEM hHdr, HDC hdc, RECT *rcDraw)

Type of drawing header background.

Definition at line 243 of file mlistview.h.

Enumeration Type Documentation

enum mListViewNotify

The notification code id of mListView.

Enumerator:
NCSN_LISTV_CLICKED | Mouse click.
NCSN_LISTV_SELCHANGED | Selected item has changed.
NCSN_LISTV_ITEMRDOWN | Right mouse down in item.
NCSN_LISTV_ITEMRUP | Right mouse up in item.
NCSN_LISTV_HDRRDOWN | Right mouse down in header.
NCSN_LISTV_HDRRUP | Right mouse up in header.
NCSN_LISTV_ITEMDBCLK | Double click in item.
NCSN_LISTV_FOLDITEM | Fold item.
NCSN_LISTV_UNFOLDITEM | Unfold item.
NCSN_LISTV_MAX | The maximum value of mListView notification code id.

Definition at line 643 of file mlistview.h.

enum mListViewProp

The properties id of mListView.

Enumerator:
NCSP_LISTV_DEFITEMHEIGHT | The default item height.
NCSP_LISTV_ROWCOUNT | The number of row. RO
NCSP_LISTV_HDRHEIGHT | The height of header.
NCSP_LISTV_HDRWIDTH | The width of header. Read only.
NCSP_LISTV_HDRVISIBLE | The flag of header visible.
NCSP_LISTV_SORTCOLUMN | The sorted column index.
NCSP_LISTV_GRIDLINEWIDTH | The width of grid line.
NCSP_LISTV_GRIDLINECOLOR | The color of grid line.
NCSP_LISTV_COLCOUNT | The number of column. Read only.
NCSP_LISTV_MAX | The maximum value of mListView properties id.

Definition at line 615 of file mlistview.h.

enum ncsListVFindType

The found type.

Enumerator:
NCSID_LISTV_FT_ADDDATA | According to additional data to find item.
NCSID_LISTV_FT_TEXT | According to item text to find item.

Definition at line 113 of file mlistview.h.

enum ncsListVIRType

The relationship between items.

Enumerator:
NCSID_LISTV_IR_PARENT | Parent
NCSID_LISTV_IR_FIRSTCHILD | First child
NCSID_LISTV_IR_LASTCHILD | Last child
NCSID_LISTV_IR_NEXTSIBLING | next
NCSID_LISTV_IR_PREVSIBLING | previous

Definition at line 47 of file mlistview.h.

Variable Documentation

g_stmListViewCls

The instance of mListViewClass.

See also:
mListViewClass

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: _NCS_LISTV_FINDINFO Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_NCS_LISTV_FINDINFO Struct Reference
[mListView]

#include <mlistview.h>

Data Fields

  • ncsListVFindType type
  • HITEM parent
  • int startIdx
  • DWORD addData

Detailed Description

The structure of searching item information.

Definition at line 124 of file mlistview.h.

Field Documentation

ncsListVFindType type

The found type.

See also:
ncsListVFindType

Definition at line 127 of file mlistview.h.

HITEM parent

The searching start item.

Definition at line 130 of file mlistview.h.

int startIdx

The searching start item index. Note when parent is null, use it as start searching position.

Definition at line 133 of file mlistview.h.

DWORD addData

The additional data.

Definition at line 145 of file mlistview.h.

The documentation for this struct was generated from the following file:
  • mlistview.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: _NCS_LISTV_CLMINFO Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_NCS_LISTV_CLMINFO Struct Reference
[mListView]

#include <mlistview.h>

Data Fields

  • int index
  • int width
  • char * text
  • DWORD image
  • DWORD flags

Detailed Description

The structure of list column information.

Definition at line 152 of file mlistview.h.

Field Documentation

int index

The column index

Definition at line 155 of file mlistview.h.

int width

The column width

Definition at line 157 of file mlistview.h.

char* text

The column text

Definition at line 159 of file mlistview.h.

DWORD image

The column image

Definition at line 161 of file mlistview.h.

DWORD flags

The column flag, it can be OR'ed the following values:

  • NCSF_LSTCLM_LEFTALIGN
    Current column text is left align. Default value.
  • NCSF_LSTCLM_CENTERALIGN
    Current column text is center align.
  • NCSF_LSTCLM_RIGHTALIGN
    Current column text is right align.
  • NCSF_LSTHDR_LEFTALIGN
    The header text is left align. Default value.
  • NCSF_LSTHDR_CENTERALIGN
    The header text is center align.
  • NCSF_LSTHDR_RIGHTALIGN
    The header text is right align.

Definition at line 176 of file mlistview.h.

The documentation for this struct was generated from the following file:
  • mlistview.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: _NCS_LISTV_ITEMDATA Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_NCS_LISTV_ITEMDATA Struct Reference
[mListView]

#include <mlistview.h>

Data Fields

  • int row
  • int col
  • char * text
  • int textColor
  • DWORD flags
  • DWORD image

Detailed Description

The data information of item in specified row and column.

Definition at line 188 of file mlistview.h.

Field Documentation

int row

The row index.

Definition at line 191 of file mlistview.h.

int col

The column index.

Definition at line 193 of file mlistview.h.

char* text

The text.

Definition at line 195 of file mlistview.h.

int textColor

The text foreground color.

Definition at line 197 of file mlistview.h.

DWORD flags

The item flags. It can be one of the following values:

  • NCSF_ITEM_USEBITMAP
    The item image is BITMAP.
  • NCSF_ITEM_USEICON
    The item image is icon.

Definition at line 205 of file mlistview.h.

DWORD image

The pointer to BITMAP ro ICON.

Definition at line 207 of file mlistview.h.

The documentation for this struct was generated from the following file:
  • mlistview.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: _NCS_LISTV_ITEMINFO Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_NCS_LISTV_ITEMINFO Struct Reference
[mListView]

#include <mlistview.h>

Data Fields

  • int index
  • int retPos
  • HITEM parent
  • int height
  • int flags
  • HICON foldIcon
  • HICON unfoldIcon
  • int dataSize
  • NCS_LISTV_ITEMDATA * data
  • DWORD addData

Detailed Description

The structure of listitem information.

Definition at line 213 of file mlistview.h.

Field Documentation

int index

The item index.

Definition at line 216 of file mlistview.h.

int retPos

The postion which item has been inserted in.

Definition at line 218 of file mlistview.h.

HITEM parent

The parent, can be null. If null, the item will act as first-level node.

Definition at line 220 of file mlistview.h.

int height

The visible height

Definition at line 222 of file mlistview.h.

int flags

The flags, can be one of the following values:

  • NCSF_ITEM_NORMAL
  • NCSF_ITEM_SELECTED
  • NCSF_ITEM_DISABLED
  • NCSF_LSTITM_FOLD

Definition at line 229 of file mlistview.h.

HICON foldIcon

The folded icon

Definition at line 231 of file mlistview.h.

HICON unfoldIcon

The unfolded icon

Definition at line 233 of file mlistview.h.

int dataSize

The number of item data.

Definition at line 235 of file mlistview.h.

NCS_LISTV_ITEMDATA* data

The item data

Definition at line 237 of file mlistview.h.

DWORD addData

user additonal data

Definition at line 239 of file mlistview.h.

The documentation for this struct was generated from the following file:
  • mlistview.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: _NCS_CB_LISTV_CSTMHDROPS Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_NCS_CB_LISTV_CSTMHDROPS Struct Reference
[mListView]

#include <mlistview.h>

Data Fields

  • NCS_CB_LISTV_DRAWHDRBK pfnDrawHdrBk
  • NCS_CB_LISTV_DRAWHDR pfnDrawHdrItem

Detailed Description

Contains function pointers for customized drawing

Definition at line 249 of file mlistview.h.

Field Documentation

NCS_CB_LISTV_DRAWHDRBK pfnDrawHdrBk

Colunm header background drawing function

Definition at line 252 of file mlistview.h.

NCS_CB_LISTV_DRAWHDR pfnDrawHdrItem

Colunm header item drawing function

Definition at line 254 of file mlistview.h.

The documentation for this struct was generated from the following file:
  • mlistview.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mListView Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mListView Struct Reference
[mListView]

The structure of mListView control, which derived from mItemView.
  • drawHdrBk
    User-defined function to draw header background.
  • drawHdrItem
    User-defined function to draw header item.
  • hdrList
    The header list.
  • rootItem
    Root item.
  • sort
    Current sort type.
  • curCol
    The index of current sort column.
  • gridLineWidth
    The width of grid line.
  • gridLineColor
    The color of grid line.
  • pfnSort
    The callback of sort function.
  • hdrH
    The height of header.
  • hdrW
    The width of header.
  • dragedHead
    The index of current draged header.
  • drawX
    The x coordinate when dragging header.
  • clickedHead
    The pointer to current clicked header.
  • status
    .
More...

#include <mlistview.h>

Detailed Description

The structure of mListView control, which derived from mItemView.
  • drawHdrBk
    User-defined function to draw header background.
  • drawHdrItem
    User-defined function to draw header item.
  • hdrList
    The header list.
  • rootItem
    Root item.
  • sort
    Current sort type.
  • curCol
    The index of current sort column.
  • gridLineWidth
    The width of grid line.
  • gridLineColor
    The color of grid line.
  • pfnSort
    The callback of sort function.
  • hdrH
    The height of header.
  • hdrW
    The width of header.
  • dragedHead
    The index of current draged header.
  • drawX
    The x coordinate when dragging header.
  • clickedHead
    The pointer to current clicked header.
  • status
    .
The documentation for this struct was generated from the following file:
  • mlistview.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mListViewClass Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mListViewClass Struct Reference
[mListView]

The virtual function table of mListView, which derived from mItemViewClass. More...

#include <mlistview.h>

Detailed Description

The virtual function table of mListView, which derived from mItemViewClass.

  • NCS_CB_DRAWITEMBK (*setItemBkDraw)(mListView *self, NCS_CB_DRAWITEMBK func);
    Set the user-defined function of drawing item background.
    Parameters:
    func The new funciton.
    Returns:
    The old function.
  • NCS_CB_DRAWITEM (*setSubItemDraw)(mListView *self, NCS_CB_DRAWITEM func);
    Set the user-defined function of drawing subitem.
    Parameters:
    func The new funciton.
    Returns:
    The old function.
  • BOOL (*setItemInfo)(mListView *self, NCS_LISTV_ITEMDATA *info);
    Set item information.
    Parameters:
    info The new information of item.
    Returns:
    TRUE on success, otherwise FALSE.
  • BOOL (*getItemInfo)(mListView *self, NCS_LISTV_ITEMDATA *info);
    Get item information.

  • BOOL (*setItemText)(clsName*, int row, int col, const char* str);
    Set the text for item.

  • const char* (*getItemText)(mListView *self, int row, int col);
    Get the text in specified row and column.
    Parameters:
    row | The row index. If rowItem is non-zero, needn't it.
    col | The column index.
    Returns:
    the text on success, otherwise "".
  • int (*getItemTextLen)(mListView *self, int row, int col);
    Get the text length in specified row and column.
    Parameters:
    row | The row index. If rowItem is non-zero, needn't it.
    col | The column index.
    Returns:
    the text length on success, otherwise -1.
  • mListColumn * (*getColumn)(mListView *self, int index);
    Get the pointer to the specified column.

  • int (*getColumnIndex)(mListView *self, mListColumn *column);
    Get the index of column.

  • int (*getColumnWidth)(mListView *self, int index);
    Get the width of column.

  • void (*setColumnWidth)(mListView *self, int index, int width);
    Set the width of column.

  • int (*getColumnCount)(mListView *self);
    Get the number of column.

  • void (*setSortDirection)(mListView *self, ncsLstClmSortType direction);
    Set sorted type.

  • ncsLstClmSortType (*getSortDirection)(mListView *self);
    Get sorted type.

  • mListColumn * (*getSortColumn)(mListView *self);
    Get sorted column.

  • void (*setSortColumn)(mListView *self, mListColumn *column);
    Set sorted column.

  • void (*showColumn)(mListView *self, mListColumn *column);
    Show the specified column.

  • BOOL (*delColumn)(mListView *self, int index);
    Delete the specified column.

  • BOOL (*addColumn)(mListView *self, NCS_LISTV_CLMINFO *info);
    Add a new column.

  • HITEM (*addItem)(clsName*, NCS_LISTV_ITEMINFO *info);
    Add a new item.

  • void (*setBackground)(mListView *self, int row, int col, int *color);
    Set the background. If color is NULL, it will cancel previous setting.

  • void (*setForeground)(mListView *self, int row, int col, int *color);
    Set the foreground. If color is NULL, it will cancel previous setting.

  • int (*getBackground)(mListView *self, int row, int col, int *color);
    Get the background.

  • int (*getForeground)(mListView *self, int row, int col, int *color);
    Get the foreground.

  • HITEM (*findItem)(mListView *self, NCS_LISTV_FINDINFO *info);
    Find a item.

  • HITEM (*getRelatedItem)(mListView *self, HITEM hItem, ncsListVIRType type);
    Get the related item.
    Parameters:
    type The relationship, can be one of the following values:
    • NCSID_LISTV_IR_PARENT
    • NCSID_LISTV_IR_FIRSTCHILD
    • NCSID_LISTV_IR_LASTCHILD
      If no children, will return itself.
    • NCSID_LISTV_IR_NEXTSIBLING
    • NCSID_LISTV_IR_PREVSIBLING
  • HITEM (*getChildItem)(mListView *self, HITEM parent, int index);
    Get the specified item according to parent and index.

  • int (*getChildCount)(mListView *self, HITEM hItem);
    Get the child number of the specified item.

  • int (*foldItem)(mListView *self, HITEM hItem, BOOL fold);
    Fold or unfold the specified item.
    Parameters:
    fold whether folded or not.
    Returns:
    0 on success, otherwise -1.
  • BOOL (*setHeadText)(mListView *self, int col, const char* text);
    Set the header text of specified column.

  • void (*sort)(mListView *self, NCS_CB_LISTV_CMPCLM func, int col, ncsLstClmSortType sort);
    Sort items.
    Parameters:
    func | The comparison function.
    col | The index of sorted column.
    sort | The sort type.
  • void (*setCustomDrawHeader)(mListView *self, NCS_CB_LISTV_CSTMHDROPS *func);
    Set the custom drawing header functions.
The documentation for this struct was generated from the following file:
  • mlistview.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mListViewRenderer Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mListViewRenderer Struct Reference
[mListView]

The structure of mListView renderer, which derived from mItemViewRenderer. More...

#include <mlistview.h>

Detailed Description

The structure of mListView renderer, which derived from mItemViewRenderer.

  • void (*drawHeader) (clsName *self, HDC hdc, const RECT* pRect, DWORD color, int flag);
    Draw header.

  • void (*drawFold) (clsName *self, HDC hdc, const RECT* pRect, DWORD color, HICON icon, int status, int next);
    Draw folded or unfoded status.
The documentation for this struct was generated from the following file:
  • mlistview.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mMainWnd

mMainWnd

Data Structures

  • struct mMainWndRenderer
    the mMainWnd renderer interface, inherit from mPanelRenderer More...
  • struct mMainWnd
    define the memders of mMainWnd, inherit from mPanel More...
  • struct mMainWndClass
    the VTable of mMainWnd, inherit from mPanelClass More...

Defines

  • #define NCSCTRL_MAINWND NCSCLASSNAME("mainwnd")
    the name of mMainWnd control
  • #define NCSS_MNWND_MODE (1<<NCSS_PANEL_SHIFT)
    indicate the main window is mode or not

Variables

  • MGNCS_EXPORT mMainWndClass g_stmMainWndCls
    the singleton of mMainWndClass

Define Documentation

#define NCSCTRL_MAINWND NCSCLASSNAME("mainwnd")

the name of mMainWnd control

Definition at line 32 of file mmainwnd.h.

#define NCSS_MNWND_MODE (1<<NCSS_PANEL_SHIFT)

indicate the main window is mode or not

Note:
this style is used by inner, you can read this style to know the main window is mode or not , it's READONLY

Definition at line 120 of file mmainwnd.h.

Variable Documentation

g_stmMainWndCls

the singleton of mMainWndClass

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mMainWndRenderer Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mMainWndRenderer Struct Reference
[mMainWnd]

the mMainWnd renderer interface, inherit from mPanelRenderer More...

#include <mmainwnd.h>

Detailed Description

the mMainWnd renderer interface, inherit from mPanelRenderer

See also:
mMainWnd, mMainWndClass
The documentation for this struct was generated from the following file:
  • mmainwnd.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mMainWnd Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mMainWnd Struct Reference
[mMainWnd]

define the memders of mMainWnd, inherit from mPanel More...

#include <mmainwnd.h>

Detailed Description

define the memders of mMainWnd, inherit from mPanel

See also:
mMainWndClass
The documentation for this struct was generated from the following file:
  • mmainwnd.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mMainWndClass Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mMainWndClass Struct Reference
[mMainWnd]

the VTable of mMainWnd, inherit from mPanelClass More...

#include <mmainwnd.h>

Detailed Description

the VTable of mMainWnd, inherit from mPanelClass

  • DWORD (*doModal)(mMainWnd *self, BOOL bAutoDestroy) Show a Model MainWindow.
    Parameters:
    bAutoDestroy auto destroy the main window when mode exit.
    Returns:
    DWORD the value send by endDialog.
  • BOOL (*endDialog)(mMainWnd *self, DWORD code) End the model window.
    Parameters:
    code the End code send to main window, would be returned by doModal.
    Returns:
    BOOL Sucessed or Failed.
The documentation for this struct was generated from the following file:
  • mmainwnd.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mMenuButton

mMenuButton

Data Structures

  • struct mMenuButton
    MenuButton member defintion, derived from mButton. More...
  • struct mMenuButtonClass
    MenuButton class , derived from mButtonClass. More...
  • struct mMenuButtonRenderer
    MenuButton class renderer interface, derived from mButtonRenderer. More...

Defines

  • #define NCSCTRL_MENUBUTTON NCSCLASSNAME("menubutton")
    the name of menubutton class

Enumerations

  • enum mMenuButtonProp { NCSP_MNUBTN_POPMENU = NCSP_BUTTON_MAX + 1, NCSP_MNUBTN_CURITEM }
    the properties id of mMenuButton, derived from mButtonProp More...
  • enum eMenuButtonNotify { NCSN_MNUBTN_ITEMCHANGED = NCSN_BUTTON_MAX + 1 }
    the notification id of mMenuButton More...

Variables

  • MGNCS_EXPORT mMenuButtonClass g_stmMenuButtonCls
    global mMenuButtonClass

Define Documentation

#define NCSCTRL_MENUBUTTON NCSCLASSNAME("menubutton")

the name of menubutton class

Definition at line 20 of file mmenubutton.h.

Enumeration Type Documentation

enum eMenuButtonNotify

the notification id of mMenuButton

Enumerator:
NCSN_MNUBTN_ITEMCHANGED Event raised when MenuButton's item changed.

Parameters:
the new menu item id

Definition at line 109 of file mmenubutton.h.

enum mMenuButtonProp

the properties id of mMenuButton, derived from mButtonProp

Enumerator:
NCSP_MNUBTN_POPMENU Set the PopMenu, the Value Must be mPopMenuMgr pointer
  • Type mPopMenuMgr*
  • Read Write
  • set the PopMenu pointer.
NCSP_MNUBTN_CURITEM Set the current menu item id
  • Type int
  • Read Write
  • set/get the current menu item id.

Definition at line 84 of file mmenubutton.h.

Variable Documentation

g_stmMenuButtonCls

global mMenuButtonClass

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mMenuButton Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mMenuButton Struct Reference
[mMenuButton]

MenuButton member defintion, derived from mButton. More...

#include <mmenubutton.h>

Detailed Description

MenuButton member defintion, derived from mButton.

  • popmenu the popmenu pointer used by MenuButton,
    See also:
    mPopMenuMgr
  • cur_item the current item of MenuButton
The documentation for this struct was generated from the following file:
  • mmenubutton.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mMenuButtonClass Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mMenuButtonClass Struct Reference
[mMenuButton]

MenuButton class , derived from mButtonClass. More...

#include <mmenubutton.h>

Detailed Description

MenuButton class , derived from mButtonClass.
The documentation for this struct was generated from the following file:
  • mmenubutton.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mMenuButtonRenderer Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mMenuButtonRenderer Struct Reference
[mMenuButton]

MenuButton class renderer interface, derived from mButtonRenderer. More...

#include <mmenubutton.h>

Detailed Description

MenuButton class renderer interface, derived from mButtonRenderer.

See also:
mMenuButton, mMenuButtonClass, mButton, mButtonClass
The documentation for this struct was generated from the following file:
  • mmenubutton.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mMlEdit

mMlEdit

Data Structures

  • struct mMlEdit
    the multiline edit control, derived from mEdit. More...
  • struct mMlEditClass
    the VTable of mMlEdit, derived from mEditClass. More...
  • struct mMlEditRenderer
    MlEdit class's Renderer interface, derived from mEditRenderer. More...

Defines

  • #define NCSS_MLEDIT_AUTOWRAP (0x0001<<NCSS_EDIT_SHIFT)
    Automatically wraps against border when inputting.
  • #define NCSS_MLEDIT_TITLE (0x0002<<NCSS_EDIT_SHIFT)
    Shows specified title texts.

Enumerations

  • enum mMlEditProp {
    NCSP_MLEDIT_LINECOUNT = NCSP_EDIT_MAX + 1, NCSP_MLEDIT_LINEHEIGHT, NCSP_MLEDIT_LINEFEEDISPCHAR, NCSP_MLEDIT_LINESEP,
    NCSP_MLEDIT_CARETSHAPE, NCSP_MLEDIT_NUMOFPARAGRAPHS
    }
  • enum ncsCaretShape { NCS_CARETSHAPE_LINE = 0, NCS_CARETSHAPE_BLOCK }

Variables

  • MGNCS_EXPORT mMlEditClass g_stmMlEditCls
    the instance of mMlEditClass

Define Documentation

#define NCSS_MLEDIT_AUTOWRAP (0x0001<<NCSS_EDIT_SHIFT)

Automatically wraps against border when inputting.

Definition at line 298 of file mmledit.h.

#define NCSS_MLEDIT_TITLE (0x0002<<NCSS_EDIT_SHIFT)

Shows specified title texts.

Definition at line 304 of file mmledit.h.

Enumeration Type Documentation

enum mMlEditProp

MlEdit Property define :

Enumerator:
NCSP_MLEDIT_LINECOUNT | Count of line, Type: int, Read-Only
NCSP_MLEDIT_LINEHEIGHT | Height of line, Type: int
NCSP_MLEDIT_LINEFEEDISPCHAR | Line feed display charater, Type : unsigned char
NCSP_MLEDIT_LINESEP | Line separater, Type : unsigned char
NCSP_MLEDIT_CARETSHAPE | Caret shape, Type : ncsCaretShape
NCSP_MLEDIT_NUMOFPARAGRAPHS | Count of paragraphs Type : int , Read-Only

Definition at line 309 of file mmledit.h.

enum ncsCaretShape

Caret Shapes define:

Enumerator:
NCS_CARETSHAPE_LINE | Line-shaped caret
NCS_CARETSHAPE_BLOCK | Block-shaped caret

Definition at line 326 of file mmledit.h.

Variable Documentation

g_stmMlEditCls

the instance of mMlEditClass

See also:
mMlEditClass

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mMlEdit Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mMlEdit Struct Reference
[mMlEdit]

the multiline edit control, derived from mEdit. More...

#include <mmledit.h>

Detailed Description

the multiline edit control, derived from mEdit.

  • txtDoc
    text document object.
  • teBuff
    tmp text content.
  • nrDiffLine
    first different line.
  • wNoChanged
    width not changed of first different line.
  • wLastLine
    width of last line.
  • hardLimit
    hard limit.
  • curLen
    current tedata's len, does not include char '\n'.
  • nLineHeight
    line height.
  • nLineAboveH
    height of above-line area.
  • nLineBaseH
    height of base-line area.
  • lnChar
    the char used to represent line seperator.
  • caretShape
    shape of the caret.
  • title
    title text displayed before content text.
  • titleIndent
    title indent.
  • flags
    editor status.
  • exFlags
    editor extends status.
  • contDirty
    content changed flags in text field.
  • desCaretX
    the desired caret x position, changed by mouse and <- , ->
  • caretX
    caret x position in the virtual content window.
  • caretY
    caret y position in the virtual content window.
  • selX
    selection point x position in the virtual content window.
  • selY
    selection point y position in the virtual content window.
  • maxNode
    node with the max length.
  • maxLen
    max line length.
  • secNode
    node with the second max length.
  • secLen
    seconde max line length
  • curItemY
    y position of the current insertion node.
  • selItemY
    y position of the selection node.
  • cp
    Copy & Paste operators

See also:
mMlEditClass
The documentation for this struct was generated from the following file:
  • mmledit.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mMlEditClass Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mMlEditClass Struct Reference
[mMlEdit]

the VTable of mMlEdit, derived from mEditClass. More...

#include <mmledit.h>

Detailed Description

the VTable of mMlEdit, derived from mEditClass.

  • int (* setTitle)(mMlEdit* self, const char* title, int len);
    Set the title of mMlEdit
    Parameters:
    title | - the string of title
    len | - the length of title
    Returns:
    length has been set or -1 if faield
  • int (* getTitle)(mMlEdit* self, char* buffer, int len);
    Get the title text
    Parameters:
    buffer | - buffer to recieve the titile string
    len | - the length of buffer
    Returns:
    the length of string saved in buffer
    See also:
    mEditClass
The documentation for this struct was generated from the following file:
  • mmledit.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mMlEditRenderer Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mMlEditRenderer Struct Reference
[mMlEdit]

MlEdit class's Renderer interface, derived from mEditRenderer. More...

#include <mmledit.h>

Detailed Description

MlEdit class's Renderer interface, derived from mEditRenderer.

See also:
mMlEdit, mMlEditClass
The documentation for this struct was generated from the following file:
  • mmledit.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mMonthCalendar

mMonthCalendar

Data Structures

  • struct _mMonthCalendarClass
    mMonthCalendar class, derived from mWidget More...
  • struct mMonthCalender
    the member of mMonthCalendar Control derived from mWidget More...

Defines

  • #define NCSCTRL_MONTHCALENDAR NCSCLASSNAME("monthcal")
    the name of month calendar control

Enumerations

  • enum mMonthCalendarProps { NCSP_CDR_YEAR = NCSP_WIDGET_MAX + 1, NCSP_CDR_MONTH, NCSP_CDR_DAY }
    the properies id of mMonthCalendar More...
  • enum mMonthCalendarEvents { NCSN_CDR_YEAR_CHANGED = NCSN_WIDGET_MAX + 1, NCSN_CDR_MONTH_CHANGED, NCSN_CDR_DAY_CHANGED }
    the events of mMonthCalendar More...

Define Documentation

#define NCSCTRL_MONTHCALENDAR NCSCLASSNAME("monthcal")

the name of month calendar control

Definition at line 18 of file mmonthcalendar.h.

Enumeration Type Documentation

enum mMonthCalendarEvents

the events of mMonthCalendar

Enumerator:
NCSN_CDR_YEAR_CHANGED When year changed
  • param : int , new current year
NCSN_CDR_MONTH_CHANGED When month changed
  • param : int , new current month
NCSN_CDR_DAY_CHANGED When Day changed
  • param : int, new current day

Definition at line 91 of file mmonthcalendar.h.

enum mMonthCalendarProps

the properies id of mMonthCalendar

Enumerator:
NCSP_CDR_YEAR The current year
  • Type : int 1970 ~ 2030
    • ReandWrite
    • Reset the current Year
NCSP_CDR_MONTH The current month
  • Type : int 1~12
  • ReadWrite
NCSP_CDR_DAY The current day
  • Type : int 1~31
  • ReadWrite

Definition at line 64 of file mmonthcalendar.h.

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: _mMonthCalendarClass Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_mMonthCalendarClass Struct Reference
[mMonthCalendar]

mMonthCalendar class, derived from mWidget More...

#include <mmonthcalendar.h>

Detailed Description

mMonthCalendar class, derived from mWidget

struct mMonthCalendarClass

Definition at line 40 of file mmonthcalendar.h.

The documentation for this struct was generated from the following file:
  • mmonthcalendar.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mMonthCalender Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mMonthCalender Struct Reference
[mMonthCalendar]

the member of mMonthCalendar Control derived from mWidget More...

#include <mmonthcalendar.h>

Detailed Description

the member of mMonthCalendar Control derived from mWidget
The documentation for this struct was generated from the following file:
  • mmonthcalendar.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mNode

mNode

Data Structures

  • struct mNode
    The structure of mNode. It is the basic class of all nodes occur within specific controls. For example, a list can contain it. More...
  • struct mNodeClass
    The virtual function table of mNodeClass. More...

Defines

  • #define NCSS_NODE_LTEXTRS 0x0000
    Image on the left and text on the right. default style.
  • #define NCSS_NODE_SMALLICON 0x0001
    Small icon mode. Show small icon in normal status, or enlarge icon in selected status.
  • #define NCSS_NODE_LTEXTBS 0x0002
    Large Icon mode. Image on the top and text on the bottom.
  • #define NCSS_NODE_TICTACTOEMIDLET 0x0004
    tictactoemidlet mode. Image includes normal and selected status.
  • #define NCSS_NODE_HIDETEXT 0x0010
    Don't show text.
  • #define NCSS_NODE_HIDEIMAGE 0x0020
    Don't show image.
  • #define NCSS_NODE_DISABLED 0x0040
    Disabled Node.
  • #define NCSS_NODE_SHIFT 7
    The bits used by mNode in style.

Typedefs

  • typedef int(* NCS_CB_CMPNODE )(mNode *node1, mNode *node2)
    The callback of node comparison function.

Enumerations

  • enum ncsNodeFindType { NCS_NODE_FTSTRING, NCS_NODE_FTDATA, NCS_NODE_FTIMAGE }
    The found information type used by findNode. More...
  • enum mNodeEvent {
    NCSE_NODE_CONTENTCHANGED = 1, NCSE_NODE_HEIGHTCHANGED, NCSE_NODE_REFRESH, NCSE_NODE_NODEADDED,
    NCSE_NODE_NODEDELETED
    }
    The event id of mNode. More...
  • enum mNodeProp {
    NCSP_NODE_HEIGHT = 1, NCSP_NODE_TEXT, NCSP_NODE_IMAGE, NCSP_NODE_ADDDATA,
    NCSP_NODE_ENABLED, NCSP_NODE_SELECTED, NCSP_NODE_PARENTNODE, NCSP_NODE_FIRSTCHILD,
    NCSP_NODE_LASTCHILD, NCSP_NODE_CHILDRENCOUNT, NCSP_NODE_LAYOUT, NCSP_NODE_HIDETEXT,
    NCSP_NODE_HIDEIMAGE, NCSP_NODE_MAX
    }
    The properties id of mNode. More...

Functions

  • MGNCS_EXPORT mNode * ncsCreateNode (mObject *parent, const char *text, PBITMAP image, int height, int style, DWORD addData)
    Create a new node according to parameter information.
  • MGNCS_EXPORT mNode * ncsAddNode (mObject *parent, const char *text, PBITMAP image, int height, int style, DWORD addData)
    Create and add a new node to control according to parameter information.

Variables

  • MGNCS_EXPORT mNodeClass g_stmNodeCls
    The instance of mNodeClass.
  • MGNCS_EXPORT mGroupNodeClass g_stmGroupNodeCls
    The instance of mGroupNodeClass.

Detailed Description

Id
mnode.h 1838 2010-04-08 08:19:34Z xwyan

Copyright (C) 2009 Feynman Software.

Define Documentation

#define NCSS_NODE_DISABLED 0x0040

Disabled Node.

Definition at line 85 of file mnode.h.

#define NCSS_NODE_HIDEIMAGE 0x0020

Don't show image.

Definition at line 79 of file mnode.h.

#define NCSS_NODE_HIDETEXT 0x0010

Don't show text.

Definition at line 73 of file mnode.h.

#define NCSS_NODE_LTEXTBS 0x0002

Large Icon mode. Image on the top and text on the bottom.

Definition at line 59 of file mnode.h.

#define NCSS_NODE_LTEXTRS 0x0000

Image on the left and text on the right. default style.

Definition at line 46 of file mnode.h.

#define NCSS_NODE_SHIFT 7

The bits used by mNode in style.

Definition at line 91 of file mnode.h.

#define NCSS_NODE_SMALLICON 0x0001

Small icon mode. Show small icon in normal status, or enlarge icon in selected status.

Definition at line 53 of file mnode.h.

#define NCSS_NODE_TICTACTOEMIDLET 0x0004

tictactoemidlet mode. Image includes normal and selected status.

Definition at line 65 of file mnode.h.

Typedef Documentation

typedef int(* NCS_CB_CMPNODE)(mNode *node1, mNode *node2)

The callback of node comparison function.

Definition at line 98 of file mnode.h.

Enumeration Type Documentation

enum mNodeEvent

The event id of mNode.

Enumerator:
NCSE_NODE_CONTENTCHANGED The content has been changed.
  • param : mNode*, the pointer to changed node.
NCSE_NODE_HEIGHTCHANGED The height of node has been changed.
  • param : mNodeEventData*, the data is the different value of height.
NCSE_NODE_REFRESH Refresh node.
  • param : mNode*, the pointer to refresh node.
NCSE_NODE_NODEADDED The node has been added.
  • param : mNode*, the pointer to added node.
NCSE_NODE_NODEDELETED The content has been deleted, Only have removed from sibling list.
  • param : mNode*, the pointer to deleted node.

Definition at line 401 of file mnode.h.

enum mNodeProp

The properties id of mNode.

Enumerator:
NCSP_NODE_HEIGHT | The height.(Uint16)
NCSP_NODE_TEXT | The text string.(char*)
NCSP_NODE_IMAGE | The image. (PBITMAP)
NCSP_NODE_ADDDATA | The additional data. (DWORD)
NCSP_NODE_ENABLED | The enabled status of node. RW.
NCSP_NODE_SELECTED | The selected status of node. RO.
NCSP_NODE_PARENTNODE | The parent node.(mObject*). RO.
NCSP_NODE_FIRSTCHILD | The first child node.(mNode*). RO.
NCSP_NODE_LASTCHILD | The last child node. (mNode*). RO.
NCSP_NODE_CHILDRENCOUNT | The number of children. (int). RO.
NCSP_NODE_LAYOUT | The layout information.
NCSP_NODE_HIDETEXT | Whether hides text or not.
NCSP_NODE_HIDEIMAGE | Whether hides image or not.
NCSP_NODE_MAX | The maximum value of mNode properties id.

Definition at line 438 of file mnode.h.

enum ncsNodeFindType

The found information type used by findNode.

Enumerator:
NCS_NODE_FTSTRING | According to text string.
NCS_NODE_FTDATA | According to additional data.
NCS_NODE_FTIMAGE | According to image.

Definition at line 238 of file mnode.h.

Function Documentation

mNode * ncsAddNode | ( | mObject * | parent,
 |  | const char * | text,
 |  | PBITMAP | image,
 |  | int | height,
 |  | int | style,
 |  | DWORD | addData
 | ) |  |

Create and add a new node to control according to parameter information.

Parameters:
parent | The pointer to parent object.
text | The text string.
image | PBITMAP structure, the pointer to image.
height | The height. If height < 0, it will use the default height of node in associated control.
style | The style of node.
addData | The additional data.
Returns:
The new pointer to node.
See also:
ncsCreateNode

mNode * ncsCreateNode | ( | mObject * | parent,
 |  | const char * | text,
 |  | PBITMAP | image,
 |  | int | height,
 |  | int | style,
 |  | DWORD | addData
 | ) |  |

Create a new node according to parameter information.

Parameters:
parent | The pointer to parent object.
text | The text string.
image | PBITMAP structure, the pointer to image.
height | The height. If height < 0, it will use the default height of node in associated control.
style | The style of node.
addData | The additional data.
Returns:
The new pointer to node.

Variable Documentation

g_stmGroupNodeCls

The instance of mGroupNodeClass.

See also:
mGroupNodeClass

g_stmNodeCls

The instance of mNodeClass.

See also:
mNodeClass

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mNode Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mNode Struct Reference
[mNode]

The structure of mNode. It is the basic class of all nodes occur within specific controls. For example, a list can contain it. More...

#include <mnode.h>

Detailed Description

The structure of mNode. It is the basic class of all nodes occur within specific controls. For example, a list can contain it.

  • parent
    The pointer to parent node or control.

  • children
    The list of children.

  • sibling
    The list of sibling.

  • text
    The text string.

  • image
    The PBITMAP pointer to image.

  • addData
    The additional data.

  • height
    The height of node. If node uses default height, this value is invalid.

  • count
    The number of children.
The documentation for this struct was generated from the following file:
  • mnode.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mNodeClass Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mNodeClass Struct Reference
[mNode]

The virtual function table of mNodeClass. More...

#include <mnode.h>

Detailed Description

The virtual function table of mNodeClass.

  • BOOL (*setProperty)(mNode *self, int id, DWORD value);
    The function sets the value of the specified properties.
    Parameters:
    id | The property id.
    value | The property value.
    Returns:
    TRUE on success, otherwise FALSE.
  • DWORD (*getProperty)(mNode *self, int id);
    The function gets the value of the specified properties.
    Parameters:
    id The property id.
    Returns:
    the property value on success, otherwise -1.
  • int (*addNode)(mNode *self, mNode *node);
    Add a new node.
    Parameters:
    node The pointer to new node.
    Returns:
    The index of new node in parent.
  • int (*removeNode)(mNode *self, mNode *node);
    Remove a child node. It deletes all chilren nodes of the specified node.
    Parameters:
    node The pointer to child node.
    Returns:
    0 on success, otherwise -1.
  • int (*insertNode)(mNode *self, mNode *node, mNode *prev, mNode *next, int index);
    Insert a node.
    Parameters:
    node | The pointer to new node.
    prev | The specified previous sibling node. It has the highest priority.
    next | The specified next sibling node. The priority is less than prev.
    index | The specified insert position. It has the lowest priority.
    Returns:
    The position in which item has been inserted on success, otherwise -1.
  • int (*moveNode)(mNode *self, mNode *curNode, int count, mNode *prevNode);
    Move the specfied nodes to the specified position.
    Parameters:
    curNode | The pointer to first moved node.
    count | The count of moved nodes.
    prevNode | The pointer to target previous sibling node.
    Returns:
    Zero on success, otherwise -1.
  • mNode* (*findNode)(mNode *self, DWORD info, int type, BOOL recursion, int startIndex);
    Find the node which contains the specified information from start index to end of nodes.
    Parameters:
    info | The valid information.
    type | The type of valid information.
    recursion | Whether find in children or not.
    startIndex | The started index.
    Returns:
    The pointer to found node.
  • void (*removeAll)(mNode *self);
    Remove all nodes.

  • void (*sendEvent)(mNode *self, int eventId);
    Send event to associated control.

  • mNode* (*getNode)(mNode *self, int index);
    Get the specified node.
    Parameters:
    index The specified index.
    Returns:
    The pointer to the specified node.
  • int (*indexOf)(mNode *self);
    Get the index of the specified node in parent node.
    Returns:
    The index of the specified node.
  • mNode* (*getPrev)(mNode *self);
    Get the privous sibling node.

  • mNode* (*getNext)(mNode *self);
    Get the next sibling node.

  • BOOL (*isEnabled)(mNode *self);
    Whether the current node is enabled or not.

  • BOOL (*isSelected)(mNode *self);
    Whether the current node is selected or not.

  • BOOL (*hasChildren)(mNode *self);
    Whether the current node has children node or not.

  • BOOL (*setText)(mNode *self, const char* text);
    Set the text of the current node.
    Parameters:
    text The new text.
    Returns:
    TRUE on success, otherwise FALSE.
  • BOOL (*setImage)(mNode *self, const PBITMAP image);
    Set the image of the current node.
    Parameters:
    text The new image.
    Returns:
    TRUE on success, otherwise FALSE.
  • const char* (*getText)(mNode *self);
    Get the text of the current node.

  • PBITMAP (*getImage)(mNode *self);
    Get the image of the current node.

  • void (*paint)(mNode *self, HDC hdc, const RECT *rect, mObject *owner);
    Paint the content of the current node in specified region.

  • int (*msgHandler)(mNode *self, int msg, WPARAM wParam, LPARAM lParam, mObject *owner);
    Process the messge.
The documentation for this struct was generated from the following file:
  • mnode.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mObject

mObject

Data Structures

  • struct mObjectClass
    the basic object class of NCS More...
  • struct mObject
    the Object struct More...

Defines

  • #define _c(ths) (ths)->_class
    the marco get the class of a object
  • #define _IM(piobj, method,...) (piobj)->_vtable->method(INTEFACE_ADJUST(piobj), ##__VA_ARGS__)
    call the interface object

Typedefs

  • typedef mObjectClass *(* PClassConstructor )(mObjectClass *)
    the Class initialize callback
  • typedef void(* PCONSTRUCT_DWORD )(void *self, DWORD addData)

Functions

  • static mObject * _initObject (mObject *pobj, mObjectClass *_class, DWORD param)
  • static mObject * initObjectArgs (mObject *pobj, mObjectClass *_class,...)

Variables

  • MGNCS_EXPORT mObjectClass g_stmObjectCls
    the singleton of mObjectClass, represent a class object

Define Documentation

#define _c ( ths ) (ths)->_class

the marco get the class of a object

Definition at line 34 of file mobject.h.

Referenced by ncsGetChildObj(), and ncsGetDlgCode().

#define _IM | ( | piobj,
 |  | method,
 |  | ... | ) | (piobj)->_vtable->method(INTEFACE_ADJUST(piobj), ##__VA_ARGS__)

call the interface object

Definition at line 155 of file mobject.h.

Typedef Documentation

mObjectClass *(* PClassConstructor)(mObjectClass *cls)

the Class initialize callback

Parameters:
cls - the class pointer to initialize
Returns:
mObjectClass* - the initialized class pointer, equal param cls

Definition at line 172 of file mobject.h.

typedef void(* PCONSTRUCT_DWORD)(void *self, DWORD addData)

We support two kind of construct: one is the old construct, uses DWORD to pass the user params; the other is new construct, use the va_list to pass the params

mgncs don't known which construct of an object use, we just pass them by diffrent wrapper

the caller must known which wrapper should be used.

if you use the wrong wrapper, the system may be CRASH

Definition at line 184 of file mobject.h.

Function Documentation

static mObject* _initObject | ( | mObject * | pobj,
 |  | mObjectClass * | _class,
 |  | DWORD | param |
 | ) |  |  | [inline, static]

init an object with DWORD param

Definition at line 279 of file mobject.h.

static mObject* initObjectArgs | ( | mObject * | pobj,
 |  | mObjectClass * | _class,
 |  |  | ... |
 | ) |  |  | [inline, static]

init an object with va_list params first param is the construct param count

Definition at line 290 of file mobject.h.

Variable Documentation

g_stmObjectCls

the singleton of mObjectClass, represent a class object

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mObjectClass Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mObjectClass Struct Reference
[mObject]

the basic object class of NCS More...

#include <mobject.h>

Detailed Description

the basic object class of NCS

  • PClassConstruct classConstructor
    the class intialize callback

  • mObjectClass * super
    the super class pointer

  • const char* typeName
    the class name, for example, "Object"

  • unsigned int objSize
    the size of corresponding object, used to create a object

  • void construct(mObject *self, DWORD addData);
    the construct method of mObject
    Parameters:
    self | - this pointer
    addData | - the initialize data, depend on derived class
  • void destroy (mObject* self);
    Destroy a mObject object
    Parameters:
    self - this pointer
    See also:
    mObject
The documentation for this struct was generated from the following file:
  • mobject.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mObject Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mObject Struct Reference
[mObject]

the Object struct More...

#include <mobject.h>

Detailed Description

the Object struct

  • mObjectClass * _class
    the class pointer of this Object

See also:
mObjectClass
The documentation for this struct was generated from the following file:
  • mobject.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mPage

mPage

Data Structures

  • struct mPage
    The control structure of mPage, which derived from mContainer. It is a control which will be used as page in mPage. Please don't use it separately. More...
  • struct mPageClass
    The virtual function table of mPage, which derived from mContainerClass. More...
  • struct mPageRenderer
    The renderer structure of mPage, which inheried from mContainerRenderer. More...

Defines

  • #define NCSCTRL_PAGE NCSCLASSNAME("page")
    The control class name of mPage.
  • #define NCSS_PAGE_SHIFT NCSS_CTNR_SHIFT
    The bits used by mPage in style.

Typedefs

  • typedef void(* NCS_CB_ONINITPAGE )(mPage *self, DWORD addData)
    the callback of the event MSG_INITPAGE. Initialize the controls in page.
  • typedef int(* NCS_CB_ONSHOWPAGE )(mPage *self, HWND focusChild, int showCmd)
    the callback of the event MSG_SHOWPAGE. Shows or hides page.
  • typedef int(* NCS_CB_ONSHEETCMD )(mPage *self, DWORD param1, DWORD param2)
    the callback of the MSG_SHEETCMD. Process broadcast message.

Variables

  • MGNCS_EXPORT mPageClass g_stmPageCls
    The instance of mPageClass.

Detailed Description

Id
mpage.h 635 2009-10-28 02:19:04Z wangjian

Copyright (C) 2009 Feynman Software.

Define Documentation

#define NCSCTRL_PAGE NCSCLASSNAME("page")

The control class name of mPage.

Definition at line 42 of file mpage.h.

#define NCSS_PAGE_SHIFT NCSS_CTNR_SHIFT

The bits used by mPage in style.

Definition at line 52 of file mpage.h.

Typedef Documentation

typedef void(* NCS_CB_ONINITPAGE)(mPage *self, DWORD addData)

the callback of the event MSG_INITPAGE. Initialize the controls in page.

Parameters:
self | The pointer to mContainer.
addData | The additional data in DLGTEMPLATE structure passed through addPage in mPageClass.
Note:
It need to be implemented by user.

Definition at line 140 of file mpage.h.

typedef int(* NCS_CB_ONSHEETCMD)(mPage *self, DWORD param1, DWORD param2)

the callback of the MSG_SHEETCMD. Process broadcast message.

Parameters:
self | The pointer to mContainer.
param1 | The param info1 of function broadCastMsg in mPageClass.
param2 | The param info2 of function broadCastMsg in mPageClass.
Returns:
zero for broadcasting message for other pages continuing, Nonzero for end of broadcasting message.
Note:
It need to be implemented by user.

Definition at line 171 of file mpage.h.

typedef int(* NCS_CB_ONSHOWPAGE)(mPage *self, HWND focusChild, int showCmd)

the callback of the event MSG_SHOWPAGE. Shows or hides page.

Parameters:
self | The pointer to mContainer.
focusChild | The handle to the child which will gain the input focus when showing the page.
showCmd The show command, can be one of the following values:
  • SW_SHOW
    The page will be shown.
  • SW_HIDE
    The page will be hidden.
Returns:
Nonzero for success, zero for failure.
Note:
It need to be implemented by user.

Definition at line 156 of file mpage.h.

Variable Documentation

g_stmPageCls

The instance of mPageClass.

See also:
mPageClass

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mPage Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mPage Struct Reference
[mPage]

The control structure of mPage, which derived from mContainer. It is a control which will be used as page in mPage. Please don't use it separately. More...

#include <mpage.h>

Detailed Description

The control structure of mPage, which derived from mContainer. It is a control which will be used as page in mPage. Please don't use it separately.

  • titleWidth
    The width of page title.

  • hIcon
    The handle of icon.
The documentation for this struct was generated from the following file:
  • mpage.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mPageClass Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mPageClass Struct Reference
[mPage]

The virtual function table of mPage, which derived from mContainerClass. More...

#include <mpage.h>

Detailed Description

The virtual function table of mPage, which derived from mContainerClass.

  • const char* (*getTitle)(mPage *self);
    Get the title of page.
    Returns:
    The pointer to the title of page.
  • BOOL (*setTitle)(mPage *self, const char* title);
    Set the title of specified page self.
    Parameters:
    title The pointer to the new title of page.
    Returns:
    TRUE for success, otherwise FALSE.
  • int (*getTitleLength)(mPage *self);
    Get the length of a page title.
    Returns:
    The length of the page title.
  • int (*getTitleWidth)(mPage *self, HDC hdc);
    Get the width of a page title in specified device context.
    Parameters:
    hdc The device context.
    Returns:
    The width of the page title.
  • void (*showPage) (mPage *self, int showCmd);
    Shows or hides a page.
    Parameters:
    showCmd The show command, can be one of the following values:
    • SW_SHOW
      The page will be shown.
    • SW_HIDE
      The page will be hidden.
  • BOOL (*setIcon)(mPage *self, HICON icon);
    Set the handle of page icon.
    Parameters:
    icon The handle of ICON.
    Returns:
    TRUE for success, otherwise FALSE.
  • HICON (*getIcon)(mPage *self);
    Get the handle of page icon.
    Returns:
    The handle of ICON.
The documentation for this struct was generated from the following file:
  • mpage.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mPageRenderer Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mPageRenderer Struct Reference
[mPage]

The renderer structure of mPage, which inheried from mContainerRenderer. More...

#include <mpage.h>

Detailed Description

The renderer structure of mPage, which inheried from mContainerRenderer.
The documentation for this struct was generated from the following file:
  • mpage.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mPanel

mPanel

Data Structures

  • struct mPanel
    The structure of mPanel control, which derived from mWidget. It is a control which is capable of containing other controls. More...
  • struct mPanelClass
    The virtual function table of mPanelClass, which derived from mWidgetClass. More...
  • struct mPanelRenderer
    The structure of mPanel renderer, which derived from mWidgetRenderer. More...

Defines

  • #define NCSCTRL_PANEL NCSCLASSNAME("panel")
    The control class name of mPanel.
  • #define NCSS_PANEL_SHIFT NCSS_WIDGET_SHIFT
    The bits used by mPanel in style.

Enumerations

  • enum mPanelProp { NCSP_PANEL_MAX = NCSP_WIDGET_MAX + 1 }
    The properties id of mPanel. More...
  • enum mPanelNotify { NCSN_PANEL_MAX = NCSN_WIDGET_MAX + 1 }
    The notification code id of mPanel. More...

Variables

  • MGNCS_EXPORT mPanelClass g_stmPanelCls
    The instance of mPanelClass.

Detailed Description

Id
mpanel.h 635 2009-10-28 02:19:04Z wangjian

Copyright (C) 2009 Feynman Software.

Define Documentation

#define NCSCTRL_PANEL NCSCLASSNAME("panel")

The control class name of mPanel.

Definition at line 43 of file mpanel.h.

#define NCSS_PANEL_SHIFT NCSS_WIDGET_SHIFT

The bits used by mPanel in style.

Definition at line 111 of file mpanel.h.

Enumeration Type Documentation

enum mPanelNotify

The notification code id of mPanel.

Enumerator:
NCSN_PANEL_MAX The maximum value of mPanel notification code id.

Definition at line 117 of file mpanel.h.

enum mPanelProp

The properties id of mPanel.

Enumerator:
NCSP_PANEL_MAX The maximum value of mPanel properties.

Definition at line 100 of file mpanel.h.

Variable Documentation

g_stmPanelCls

The instance of mPanelClass.

See also:
mPanelClass

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mPanel Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mPanel Struct Reference
[mPanel]

The structure of mPanel control, which derived from mWidget. It is a control which is capable of containing other controls. More...

#include <mpanel.h>

Detailed Description

The structure of mPanel control, which derived from mWidget. It is a control which is capable of containing other controls.
The documentation for this struct was generated from the following file:
  • mpanel.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mPanelClass Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mPanelClass Struct Reference
[mPanel]

The virtual function table of mPanelClass, which derived from mWidgetClass. More...

#include <mpanel.h>

Detailed Description

The virtual function table of mPanelClass, which derived from mWidgetClass.
The documentation for this struct was generated from the following file:
  • mpanel.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mPanelRenderer Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mPanelRenderer Struct Reference
[mPanel]

The structure of mPanel renderer, which derived from mWidgetRenderer. More...

#include <mpanel.h>

Detailed Description

The structure of mPanel renderer, which derived from mWidgetRenderer.
The documentation for this struct was generated from the following file:
  • mpanel.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mPopMenuMgrClass Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mPopMenuMgrClass Struct Reference
[mPopMenuMgr]

mPopMenuMgr class, derived from mObject More...

#include <mpopmenumgr.h>

Detailed Description

mPopMenuMgr class, derived from mObject

  • BOOL addItem(mPopMenuMgr *self, int type, const char *str, \ PBITMAP bmp, int id, int state, \ mPopMenuMgr *subMenu, DWORD add_data);
    add a menu item
    Parameters:
    type - menu item type, same as MiniGUI MENUITEMINFO :
    • MTF_STRING a menu item with string only
    • MTF_BITMAP a menu item with bitmap only
    • MTF_BMPSTRING a menu item with string and bitmap
    • MTF_RADIOCHECK a menu item with a radio button
    • MTF_MARKCHECK a menu item with a check button
    • MTF_SEPARATOR a seprator item
    str | - the string of menu item, when type is MTF_STRING or MTF_BMPSTRING
    bmp | - the bitmap pointer of menu item, when type is MTF_BITMAP or MTF_BMPSTRING
    id | - the id of menu item
    state - the state of menu item, same as MiniGIUI MENUITEMINFO, by default it is MFS_ENABLED
    • MFS_GRAYED the menu item is disabled
    • MFS_DISABLED the menu item is disabled
    • MFS_CHECKED the menu item is checked
    • MFS_ENABLED the menu item is enabled , default value
    • MFS_UNCHECKED the menu item is unchecked
    subMenu | - the sub menu of this menu item, by default is NULL
    add_data | - the additional data of menu item, by default is 0
    Returns:
    TRUE - sucessed, FALSE - failed
  • HMENU createMenu(mPopMenuMgr *self);
    create a pop menu handle from itself
    Returns:
    the pop menu handle
  • void popMenu(mPopMenuMgr *self, mObject *owner);
    pop itself
    Parameters:
    owner - it should be a mWidget pointer, indicate the owner who want a pop menu
  • BOOL addSeparator(mPopMenuMgr *self);
    add a seprator for menu item
    Returns:
    TRUE -sucessed; FALSE -failed
  • BOOL getMenuItem(mPopMenuMgr *self, int idx, MENUITEMINFO *pmii, BOOL byCommand);
    store a menu item info into MENUITEMINFO
    Parameters:
    idx | - the index(byCommand==FALSE) or id of menu item
    pmii | - Out param, store the menu item info
    byCommand | - indiate the param idx is the index or id of menu item. TRUE for id, FALSE for index.
    Returns:
    TRUE -sucessed, FALSE - failed
    See also:
    mPopMenuMgr
The documentation for this struct was generated from the following file:
  • mpopmenumgr.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mPopMenuMgr Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mPopMenuMgr Struct Reference
[mPopMenuMgr]

the members of mPropMenuMgr More...

#include <mpopmenumgr.h>

Detailed Description

the members of mPropMenuMgr
The documentation for this struct was generated from the following file:
  • mpopmenumgr.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mProgressBar

mProgressBar

Data Structures

  • struct mProgressBar
    the control to indicate the processing of a work, derived from mWidget. More...
  • struct mProgressBarClass
    the VTable of mProgressBar, derived from mWidgetClass. More...
  • struct mProgressBarRenderer
    ProgressBar class's Renderer interface, derived from mWidgetRenderer. More...

Defines

  • #define NCSS_PRGBAR_HORIZONTAL 0x0000L
    horizontal progressbar
  • #define NCSS_PRGBAR_VERTICAL (0x0001L<<NCSS_WIDGET_SHIFT)
    vertical progressbar
  • #define NCSS_PRGBAR_BLOCKS (0x0002L<<NCSS_WIDGET_SHIFT)
    progressbar show with blocks
  • #define NCSS_PRGBAR_SMOOTH (0x0000L<<NCSS_WIDGET_SHIFT)
    progressbar show smooth
  • #define NCSS_PRGBAR_SHOWPERCENT (0x0004L<<NCSS_WIDGET_SHIFT)
    progressbar with percentage "0%~100%"

Enumerations

  • enum mProgressBarProp { NCSP_PROG_MAXPOS = NCSP_WIDGET_MAX + 1, NCSP_PROG_MINPOS, NCSP_PROG_CURPOS, NCSP_PROG_LINESTEP }
    ProgressBar Properties define. More...

Variables

  • MGNCS_EXPORT mProgressBarClass g_stmProgressBarCls
    the instance of mProgressBarClass

Define Documentation

#define NCSS_PRGBAR_BLOCKS (0x0002L<<NCSS_WIDGET_SHIFT)

progressbar show with blocks

Definition at line 170 of file mprogressbar.h.

#define NCSS_PRGBAR_HORIZONTAL 0x0000L

horizontal progressbar

Definition at line 158 of file mprogressbar.h.

#define NCSS_PRGBAR_SHOWPERCENT (0x0004L<<NCSS_WIDGET_SHIFT)

progressbar with percentage "0%~100%"

Definition at line 182 of file mprogressbar.h.

#define NCSS_PRGBAR_SMOOTH (0x0000L<<NCSS_WIDGET_SHIFT)

progressbar show smooth

Definition at line 176 of file mprogressbar.h.

#define NCSS_PRGBAR_VERTICAL (0x0001L<<NCSS_WIDGET_SHIFT)

vertical progressbar

Definition at line 164 of file mprogressbar.h.

Enumeration Type Documentation

enum mProgressBarProp

ProgressBar Properties define.

Enumerator:
NCSP_PROG_MAXPOS The max pos of progress
  • Type int
  • ReadWrite value for maximum position
NCSP_PROG_MINPOS The min pos of progress
  • Type int
  • ReadWrite value for minimum position
NCSP_PROG_CURPOS The current position of progress
  • Type int
  • ReadWrite value for current position
NCSP_PROG_LINESTEP The line step length of progress
  • Type int
  • ReadWrite step length

Definition at line 125 of file mprogressbar.h.

Variable Documentation

g_stmProgressBarCls

the instance of mProgressBarClass

See also:
mProgressBarClass

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mProgressBar Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mProgressBar Struct Reference
[mProgressBar]

the control to indicate the processing of a work, derived from mWidget. More...

#include <mprogressbar.h>

Detailed Description

the control to indicate the processing of a work, derived from mWidget.

See also:
mProgressBarRenderer, mProgressBarClass
The documentation for this struct was generated from the following file:
  • mprogressbar.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mProgressBarClass Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mProgressBarClass Struct Reference
[mProgressBar]

the VTable of mProgressBar, derived from mWidgetClass. More...

#include <mprogressbar.h>

Detailed Description

the VTable of mProgressBar, derived from mWidgetClass.

See also:
mWidgetClass
  • int increase (mProgressBar *self, int delta);
    increase the progressbar position.
    Parameters:
    delta - the increase value
    Returns:
    0 for succeed, other for failed.
  • int stepIncrease (mProgressBar *self);
    increase the progressbar position by step.
    Returns:
    0 for succeed, other for failed.
The documentation for this struct was generated from the following file:
  • mprogressbar.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mProgressBarRenderer Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mProgressBarRenderer Struct Reference
[mProgressBar]

ProgressBar class's Renderer interface, derived from mWidgetRenderer. More...

#include <mprogressbar.h>

Detailed Description

ProgressBar class's Renderer interface, derived from mWidgetRenderer.

See also:
mProgressBar, mProgressBarClass
  • void drawProgress(mProgressBar *self, HDC hdc, const RECT *rc);
    draw progressbar
    Parameters:
    hdc | - the DC in which draw progressbar
    rc- | the Rectange of the progressbar
The documentation for this struct was generated from the following file:
  • mprogressbar.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mPropSheet

mPropSheet

Data Structures

  • struct mPropSheet
    propsheet control mananager a group of mPage, inherited from mWidget. More...
  • struct mPropSheetClass
    The virtual function table of mPropSheet. More...
  • struct mPropSheetRenderer
    The structure of mPropSheet renderer, which inheried from mWidgetRenderer. More...

Defines

  • #define NCSCTRL_PROPSHEET NCSCLASSNAME("propsheet")
    The control class name of mPropSheet.
  • #define NCSS_PRPSHT_SHIFT NCSS_WIDGET_SHIFT+3
    The bits used by mPropSheet in style.
  • #define NCSS_PRPSHT_COMPACTTAB (0x0001<<NCSS_WIDGET_SHIFT)
    A simple property sheet control. All tabs of the controls will have the same width.
  • #define NCSS_PRPSHT_SCROLLABLE (0x0002<<NCSS_WIDGET_SHIFT)
    Tab can be scrolled by scrolled button.
  • #define NCSS_PRPSHT_TOP (0x0000<<NCSS_WIDGET_SHIFT)
    Top tab style. Tabs will be located at the top of the propsheet.
  • #define NCSS_PRPSHT_BOTTOM (0x0004<<NCSS_WIDGET_SHIFT)
    Bottom tab style. Tabs will be located at the bottom of the propsheet.

Enumerations

  • enum ncsPrpShtFlags {
    NCSF_PRPSHT_BORDER, NCSF_PRPSHT_TAB, NCSF_PRPSHT_LEFT, NCSF_PRPSHT_RIGHT,
    NCSF_PRPSHT_PAGE, NCSF_PRPSHT_MAX
    }
    The flag of mPropSheet. It is used by mPropSheetRenderer. More...
  • enum mPropSheetNotify { NCSN_PRPSHT_ACTIVECHANGED = NCSN_WIDGET_MAX + 1, NCSN_PRPSHT_MAX }
    The notification code id of mPropSheet. More...
  • enum mPropSheetProp {
    NCSP_PRPSHT_MINTABWIDTH = NCSP_WIDGET_MAX + 1, NCSP_PRPSHT_TABMARGIN, NCSP_PRPSHT_ACTIVEPAGE, NCSP_PRPSHT_ACTIVEPAGEIDX,
    NCSP_PRPSHT_FIRSTVIEWPAGE, NCSP_PRPSHT_FIRSTVIEWPAGEIDX, NCSP_PRPSHT_PAGECOUNT
    }
    The properties of mPropSheet. More...

Variables

  • MGNCS_EXPORT mPropSheetClass g_stmPropSheetCls
    The instance of mPropSheetClass.

Detailed Description

Id
mpropsheet.h 844 2010-02-26 03:05:57Z dongjunjie

Copyright (C) 2009 Feynman Software.

Define Documentation

#define NCSCTRL_PROPSHEET NCSCLASSNAME("propsheet")

The control class name of mPropSheet.

Definition at line 43 of file mpropsheet.h.

#define NCSS_PRPSHT_BOTTOM (0x0004<<NCSS_WIDGET_SHIFT)

Bottom tab style. Tabs will be located at the bottom of the propsheet.

Definition at line 84 of file mpropsheet.h.

#define NCSS_PRPSHT_COMPACTTAB (0x0001<<NCSS_WIDGET_SHIFT)

A simple property sheet control. All tabs of the controls will have the same width.

Compact tab style. The width of a tab is adaptive to the tab title.

Definition at line 65 of file mpropsheet.h.

#define NCSS_PRPSHT_SCROLLABLE (0x0002<<NCSS_WIDGET_SHIFT)

Tab can be scrolled by scrolled button.

Definition at line 71 of file mpropsheet.h.

#define NCSS_PRPSHT_SHIFT NCSS_WIDGET_SHIFT+3

The bits used by mPropSheet in style.

Definition at line 49 of file mpropsheet.h.

#define NCSS_PRPSHT_TOP (0x0000<<NCSS_WIDGET_SHIFT)

Top tab style. Tabs will be located at the top of the propsheet.

Definition at line 77 of file mpropsheet.h.

Enumeration Type Documentation

enum mPropSheetNotify

The notification code id of mPropSheet.

Enumerator:
NCSN_PRPSHT_ACTIVECHANGED | the active page changed
NCSN_PRPSHT_MAX | The maximum value of mPropSheet notification code id.

Definition at line 307 of file mpropsheet.h.

enum mPropSheetProp

The properties of mPropSheet.

Enumerator:
NCSP_PRPSHT_MINTABWIDTH Set the minimum width of tab
  • Type int
  • Read Write
  • set the minimum width of tab.
NCSP_PRPSHT_TABMARGIN Set the tab margin
  • Type int
  • Read Write
  • set the margin of tab.
NCSP_PRPSHT_ACTIVEPAGE Set the active page
  • Type mPage*
  • Read Write
  • set the active page pointer.
NCSP_PRPSHT_ACTIVEPAGEIDX Set the active page id
  • Type int
  • Read Write
  • set the active page id.
NCSP_PRPSHT_FIRSTVIEWPAGE Set the first view page
  • Type mPage*
  • Read
  • set the first view page pointer.
NCSP_PRPSHT_FIRSTVIEWPAGEIDX Set the first visible page
  • Type int
  • Read
  • set the index of first visible page.
NCSP_PRPSHT_PAGECOUNT Set the number of pages
  • Type int
  • Read
  • set the number of pages.

Definition at line 325 of file mpropsheet.h.

enum ncsPrpShtFlags

The flag of mPropSheet. It is used by mPropSheetRenderer.

Enumerator:
NCSF_PRPSHT_BORDER | The flag of border.
NCSF_PRPSHT_TAB | The flag of tab.
NCSF_PRPSHT_LEFT | The flag of left scrollable button.
NCSF_PRPSHT_RIGHT | The flag of right scrollable button.
NCSF_PRPSHT_PAGE | The flag of page.
NCSF_PRPSHT_MAX | The maximum value of flags.

Definition at line 207 of file mpropsheet.h.

Variable Documentation

g_stmPropSheetCls

The instance of mPropSheetClass.

See also:
mPropSheetClass

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mPropSheet Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mPropSheet Struct Reference
[mPropSheet]

propsheet control mananager a group of mPage, inherited from mWidget. More...

#include <mpropsheet.h>

Detailed Description

propsheet control mananager a group of mPage, inherited from mWidget.

  • minTabWidth
    The minimum width of tab.

  • maxTabWidth
    The maximum width of tab.

  • scrollTabWidth
    The effective width of tabs.

  • headRect
    The rectange of header, which is used to show all tabs.

  • pageCount
    The number of pages.

  • btnShow
    The flag whether show scrollable button or not.

  • active
    The pointer to active page mPage.

  • firstView
    The pointer to first view page mPage.

  • tabMargin
    The intervals between current and next tab.
The documentation for this struct was generated from the following file:
  • mpropsheet.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mPropSheetClass Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mPropSheetClass Struct Reference
[mPropSheet]

The virtual function table of mPropSheet. More...

#include <mpropsheet.h>

Detailed Description

The virtual function table of mPropSheet.

  • int (*getPageIndex)(mPropSheet *self, mPage* page);
    Get the index of specified page.
    Parameters:
    page The pointer to mPage.
    Returns:
    The index of page for success, otherwise -1.
  • mPage* (*getPageByIndex)(mPropSheet *self, int pageIndex);
    Get the pointer of page according to page index pageIndex.
    Parameters:
    pageIndex The index of page.
    Returns:
    The pointer to page for success, otherwise NULL.
  • mPage* (*addPage)(mPropSheet *self, const PDLGTEMPLATE dlgTemplate, const NCS_EVENT_HANDLER* handlers);
    Add a page to propsheet according to DLGTEMPLATE and handlers.
    Parameters:
    dlgTemplate | The pointer to dialog template.
    handlers | The pointer to event handlers.
    Returns:
    The pointer to page for success, otherwise NULL.
    See also:
    NCS_EVENT_HANDLER
  • BOOL (*removePageByIndex)(mPropSheet *self, int pageIndex);
    Remove a page according to page index pageIndex.
    Parameters:
    pageIndex The index of page.
    Returns:
    TRUE for success, otherwise FALSE.
  • BOOL (*removePage)(mPropSheet *self, mPage* page);
    Remove a page according to the pointer to page.
    Parameters:
    page The pointer to mPage.
    Returns:
    TRUE for success, otherwise FALSE.
  • mPage* (*getNextPage)(mPropSheet *self, mPage* page);
    Get the next page.
    Parameters:
    page The pointer to mPage.
    Returns:
    The pointer to next page.
  • mPage* (*getPrevPage)(mPropSheet *self, mPage* page);
    Get the previous page.
    Parameters:
    page The pointer to mPage.
    Returns:
    The pointer to previous page.
  • int (*broadCastMsg)(mPropSheet *self, DWORD param1, DWORD param2);
    Broadcast message to all pages.
    Parameters:
    param1 | The first parameter of broadcast message.
    param2 | The second parameter of broadcast message.
    Returns:
    The index + 1 of page which has been broken the message, Zero indicates no page asserts an error.
The documentation for this struct was generated from the following file:
  • mpropsheet.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mPropSheetRenderer Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mPropSheetRenderer Struct Reference
[mPropSheet]

The structure of mPropSheet renderer, which inheried from mWidgetRenderer. More...

#include <mpropsheet.h>

Detailed Description

The structure of mPropSheet renderer, which inheried from mWidgetRenderer.

  • void (*resetHeadArea) (mPropSheet *self, RECT* rcClient, DWORD style);
    According to client area and control style, reset the rectangle of header which is used to show all tabs.
    Parameters:
    rcClient | The pointer to a RECT strucutre which contains the client area.
    style | The style of control.
  • void (*getRect)(mPropSheet *self, RECT* rcClient, RECT *rcResult, int which);
    Get the rectangle of specified region which.
    Parameters:
    rcClient | The pointer to a RECT strucutre which contains the client area.
    rcResult | The pointer to a RECT strucutre which contains the result area.
    which The flag of area, can be one of the following values:
    • NCSF_PRPSHT_BORDER
      Border.
    • NCSF_PRPSHT_TAB
      Tab.
    • NCSF_PRPSHT_LEFT
      Left scrollable button.
    • NCSF_PRPSHT_RIGHT
      Right scrollable button.
    • NCSF_PRPSHT_PAGE
      Page.
  • void (*drawBorder)(mPropSheet *self, HDC hdc, RECT *rcBorder);
    Draw border.
    Parameters:
    hdc | The device context.
    rcBorder | The pointer to a RECT strucutre which contains the border area.
  • void (*drawScrollBtn)(mPropSheet *self, HDC hdc, RECT *rcBtn, int which);
    Draw scrollable button.
    Parameters:
    hdc | The device context.
    rcBtn | The pointer to a RECT strucutre which contains the button area.
    which The status of scrollable button, can be one of the following values:
    • NCSR_ARROW_LEFT
    • NCSR_ARROW_RIGHT
  • void (*drawTab)(mPropSheet *self, HDC hdc, RECT* rcTab, const char* title, HICON hIcon, BOOL active);
    Draw tab.
    Parameters:
    hdc | The device context.
    rcTab | The pointer to a RECT strucutre which contains the tab area.
    title | The pointer to the tab title.
    hIcon | The handle of the tab icon.
    active | The status of tab.
The documentation for this struct was generated from the following file:
  • mpropsheet.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mRadioButton

mRadioButton

Data Structures

  • struct mRadioButton
    define the member of Radiobutton, derived from mCheckButton More...
  • struct mRadioButtonClass
    Radiobutton struct of control, derived from mCheckButtonClass. More...
  • struct mRadioButtonRender
    Radiobutton renderer interface, derived from mCheckButtonRenderer. More...

Defines

  • #define NCSCTRL_RADIOBUTTON NCSCLASSNAME("radiobutton")
    the name of Radiobutton control

Enumerations

  • enum mRadioButtonProp
    the properties id of mRadioButton More...
  • enum enumRadioButtonNotify
    the notification id of mRadioButton More...

Variables

  • MGNCS_EXPORT mRadioButtonClass g_stmRadioButtonCls
    global mRadioButtonClass

Define Documentation

#define NCSCTRL_RADIOBUTTON NCSCLASSNAME("radiobutton")

the name of Radiobutton control

Definition at line 19 of file mradiobutton.h.

Enumeration Type Documentation

enum enumRadioButtonNotify

the notification id of mRadioButton

Definition at line 95 of file mradiobutton.h.

enum mRadioButtonProp

the properties id of mRadioButton

Definition at line 84 of file mradiobutton.h.

Variable Documentation

g_stmRadioButtonCls

global mRadioButtonClass

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mRadioButton Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mRadioButton Struct Reference
[mRadioButton]

define the member of Radiobutton, derived from mCheckButton More...

#include <mradiobutton.h>

Detailed Description

define the member of Radiobutton, derived from mCheckButton
The documentation for this struct was generated from the following file:
  • mradiobutton.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mRadioButtonClass Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mRadioButtonClass Struct Reference
[mRadioButton]

Radiobutton struct of control, derived from mCheckButtonClass. More...

#include <mradiobutton.h>

Detailed Description

Radiobutton struct of control, derived from mCheckButtonClass.
The documentation for this struct was generated from the following file:
  • mradiobutton.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mRadioButtonRender Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mRadioButtonRender Struct Reference
[mRadioButton]

Radiobutton renderer interface, derived from mCheckButtonRenderer. More...

#include <mradiobutton.h>

Detailed Description

Radiobutton renderer interface, derived from mCheckButtonRenderer.

See also:
mCheckButton, mCheckButtonRenderer
  • void (*drawRadiobutton)( clsName *self, HDC hdc, const Rect *pRect, int status); draw Radiobutton using renderer
    Parameters:
    *self | - this pointer of Radiobutton
    hdc | - DC of control
    *pRect | - the rectangle of Radiobutton frame
    status | - the Radiobutton state
The documentation for this struct was generated from the following file:
  • mradiobutton.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mRectangle

mRectangle

Data Structures

  • struct mRectangle
    The control show a rectangle or round rectangle, derived from mWidget. More...
  • struct mRectangleClass
    struct of rectangle control, derived from mWidgetClass More...
  • struct mRectangleRenderer
    rectangle renderer interface, derived from mWidgetRenderer More...

Defines

  • #define NCSCTRL_RECTANGLE NCSCLASSNAME("rectangle")
    the name of rectangle control

Enumerations

  • enum mRectangleProp {
    NCSP_RECTANGLE_BORDERSIZE = NCSP_WIDGET_MAX + 1, NCSP_RECTANGLE_BORDERCOLOR, NCSP_RECTANGLE_FILLCOLOR, NCSP_RECTANGLE_XRADIUS,
    NCSP_RECTANGLE_YRADIUS, NCSP_RECTANGLE_FILLCLR_RED, NCSP_RECTANGLE_FILLCLR_GREEN, NCSP_RECTANGLE_FILLCLR_BLUE,
    NCSP_RECTANGLE_FILLCLR_ALPHA, NCSP_RECTANGLE_BRDCLR_RED, NCSP_RECTANGLE_BRDCLR_GREEN, NCSP_RECTANGLE_BRDCLR_BLUE,
    NCSP_RECTANGLE_BRDCLR_ALPHA
    }
    properties id of rectangle More...
  • enum enumRectNotify
    notification code of mRectangle More...

Variables

  • MGNCS_EXPORT mRectangleClass g_stmRectangleCls
    global mRectangleClass

Define Documentation

#define NCSCTRL_RECTANGLE NCSCLASSNAME("rectangle")

the name of rectangle control

Definition at line 19 of file mrect.h.

Enumeration Type Documentation

enum enumRectNotify

notification code of mRectangle

Definition at line 190 of file mrect.h.

enum mRectangleProp

properties id of rectangle

Enumerator:
NCSP_RECTANGLE_BORDERSIZE Set the size of rect border
  • Type int
  • Read Write
  • set the size of rectangle border.
NCSP_RECTANGLE_BORDERCOLOR Set the color of rect border
  • Type DWORD(ARGB)
  • Read Write
  • set the color value of rect border.
NCSP_RECTANGLE_FILLCOLOR Set the color to fill in rect
  • Type DWORD(ARGB)
  • Read Write
  • set the color value to fill in rect.
NCSP_RECTANGLE_XRADIUS Set the x radius
  • Type int
  • Read Write
  • set x radius of rectangle corner.
NCSP_RECTANGLE_YRADIUS Set the y radius
  • Type int
  • Read Write
  • set y radius of rectangle corner.
NCSP_RECTANGLE_FILLCLR_RED Set the red color to fill in rect
  • Type int (0 - 255)
  • Read Write
  • set the color value to fill in rect.
NCSP_RECTANGLE_FILLCLR_GREEN Set the green color to fill in rect
  • Type int (0 - 255)
  • Read Write
  • set the color value to fill in rect.
NCSP_RECTANGLE_FILLCLR_BLUE Set the blue color to fill in rect
  • Type int (0 - 255)
  • Read Write
  • set the color value to fill in rect.
NCSP_RECTANGLE_FILLCLR_ALPHA Set the alpha value to fill in rect
  • Type int (0 - 255)
  • Read Write
  • set the color value to fill in rect.
NCSP_RECTANGLE_BRDCLR_RED Set the red color value of the border
  • Type int (0 - 255)
  • Read Write
  • set the color value to fill in rect.
NCSP_RECTANGLE_BRDCLR_GREEN Set the green color value of the border
  • Type int (0 - 255)
  • Read Write
  • set the color value to fill in rect.
NCSP_RECTANGLE_BRDCLR_BLUE Set the blue color value of the border
  • Type int (0 - 255)
  • Read Write
  • set the color value to fill in rect.
NCSP_RECTANGLE_BRDCLR_ALPHA Set the alpha value of the border
  • Type int (0 - 255)
  • Read Write
  • set the color value to fill in rect.

Definition at line 76 of file mrect.h.

Variable Documentation

g_stmRectangleCls

global mRectangleClass

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mRectangle Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mRectangle Struct Reference
[mRectangle]

The control show a rectangle or round rectangle, derived from mWidget. More...

#include <mrect.h>

Detailed Description

The control show a rectangle or round rectangle, derived from mWidget.
The documentation for this struct was generated from the following file:
  • mrect.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mRectangleClass Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mRectangleClass Struct Reference
[mRectangle]

struct of rectangle control, derived from mWidgetClass More...

#include <mrect.h>

Detailed Description

struct of rectangle control, derived from mWidgetClass
The documentation for this struct was generated from the following file:
  • mrect.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mRectangleRenderer Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mRectangleRenderer Struct Reference
[mRectangle]

rectangle renderer interface, derived from mWidgetRenderer More...

#include <mrect.h>

Detailed Description

rectangle renderer interface, derived from mWidgetRenderer
The documentation for this struct was generated from the following file:
  • mrect.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: Resource Managerment

Resource Managerment

Data Structures

  • struct _NCSRM_HEADER
  • struct _NCSRM_TYPEITEM
  • struct _NCSRM_IDITEM
  • struct _NCSRM_WINHEADER
  • struct _NCSRM_SECTHEADER
  • struct _NCSRM_DEFLOCALE_INFO
  • struct _NCSRM_LOCALEITEM
  • struct _NCSRM_INCORE_IMAGE
  • struct _NCSRM_RDRINFO
  • struct _NCSRM_RDRHEADER
  • struct _NCSRM_PROP

Defines

  • #define HPACKAGE_NULL 0
    Null resource package handle.
  • #define NCSRM_SYSSTR_BASEID 1
    Base value of system string id.
  • #define NCSRM_SYSSTR_DEFRDR (NCSRT_STRING << 16) |NCSRM_SYSSTR_BASEID
    The system string id of default renderer.
  • #define NCSRT_EXT_LEN 15
    The maximum length of resource extension.
  • #define NCSRM_VERSION_LEN 4
    The maximum length of resource package version.
  • #define NCSRM_VENDOR_LEN 16
    The maximum length of vendor.
  • #define NCSRM_ENCODING_LEN 16
    The maximum length of encoding.
  • #define ncsLoadResPackage ncsLoadResPackageFromFile
    An alias of ncsLoadResPackageFromFile.

Typedefs

  • typedef unsigned int HPACKAGE
    Handle to resource package.

Enumerations

  • enum ncsRMRdrResType {
    NCSRM_RDRTYPE_COLOR = 0, NCSRM_RDRTYPE_METRIC, NCSRM_RDRTYPE_IMAGE, NCSRM_RDRTYPE_FONT,
    NCSRM_RDRTYPE_BINARY, NCSRM_RDRTYPE_STRING, NCSRM_RDRTYPE_FILE, NCSRM_RDRTYPE_TEXT,
    NCSRM_RDRTYPE_MAX
    }
    Renderer resource type. More...

Functions

  • MGNCS_EXPORT const char * ncsSetDefaultLocale (char *language, char *country)
    Set default locale information.
  • MGNCS_EXPORT const char * ncsGetDefaultLocale (void)
    Get default locale information.
  • MGNCS_EXPORT HPACKAGE ncsLoadResPackageFromFile (const char *fileName)
    Load a resource package from resource package file.
  • MGNCS_EXPORT int ncsAddRefResPackage (HPACKAGE package)
    add the reference count for resource package
  • MGNCS_EXPORT void ncsUnloadResPackage (HPACKAGE package)
    Unload a resource package.
  • MGNCS_EXPORT HPACKAGE ncsLoadResPackageFromMem (const void *mem, int size)
    Load a resource package from memory. User get the information of incore resource package by getIncoreResPackInfo firstly, then call this function to load resource package.
  • MGNCS_EXPORT const char * ncsGetImageFileName (HPACKAGE package, Uint32 resId)
    Get the name of image file.
  • MGNCS_EXPORT int ncsGetBitmap (HDC hdc, HPACKAGE package, Uint32 resId, PBITMAP pBitmap)
    Load a device-dependent bitmap from resource id.
  • MGNCS_EXPORT void ncsReleaseBitmap (PBITMAP pBitmap)
    Releases a bitmap.
  • MGNCS_EXPORT int ncsGetMyBitmap (HPACKAGE package, Uint32 resId, PMYBITMAP myBmp, RGB *pal)
    Load a device-independent bitmap from resource id.
  • MGNCS_EXPORT void ncsReleaseMyBitmap (PMYBITMAP myBmp)
    Releases a bitmap.
  • MGNCS_EXPORT const char * ncsGetString (HPACKAGE package, Uint32 resId)
    Get string.
  • MGNCS_EXPORT BOOL ncsSetSysRdr (HPACKAGE package, Uint32 rdrSetId)
    Set system renderer.
  • MGNCS_EXPORT BOOL ncsSetWinRdr (HWND hWnd, HPACKAGE package, Uint32 rdrId)
    Set window renderer.
  • MGNCS_EXPORT mMainWnd * ncsCreateMainWindowIndirectFromID (HPACKAGE package, Uint32 wndId, HWND owner, HICON hIcon, HMENU hMenu, NCS_EVENT_HANDLER_INFO *handlers, NCS_EVENT_CONNECT_INFO *connects, DWORD user_data)
    Create main window.
  • MGNCS_EXPORT int ncsCreateModalDialogFromID (HPACKAGE package, Uint32 dlgId, HWND owner, HICON hIcon, HMENU hMenu, NCS_EVENT_HANDLER_INFO *handlers, NCS_EVENT_CONNECT_INFO *connects)
    Create modal dialog.
  • MGNCS_EXPORT BOOL ncsGetWndTemplFromID (HPACKAGE package, Uint32 wndId, NCS_MNWND_TEMPLATE *ptempl, NCS_EVENT_HANDLER_INFO *handlers)
    get the window template from package
  • MGNCS_EXPORT void ncsFreeWndTemplate (NCS_MNWND_TEMPLATE *ptempl)
    free the window template create by ncsGetWndTemplFromID

Detailed Description

Id
mresmgr.h 977 2010-08-31 07:36:13Z dongjunjie

Copyright (C) 2009 Feynman Software.

Define Documentation

#define HPACKAGE_NULL 0

Null resource package handle.

Definition at line 48 of file mresmgr.h.

#define ncsLoadResPackage ncsLoadResPackageFromFile

An alias of ncsLoadResPackageFromFile.

See also:
ncsLoadResPackageFromFile

Definition at line 377 of file mresmgr.h.

#define NCSRM_ENCODING_LEN 16

The maximum length of encoding.

Definition at line 100 of file mresmgr.h.

#define NCSRM_SYSSTR_BASEID 1

Base value of system string id.

Maximum value of system string id.

#define NCSRM_SYSSTR_DEFRDR (NCSRT_STRING << 16) |NCSRM_SYSSTR_BASEID

The system string id of default renderer.

Definition at line 76 of file mresmgr.h.

#define NCSRM_VENDOR_LEN 16

The maximum length of vendor.

Definition at line 94 of file mresmgr.h.

#define NCSRM_VERSION_LEN 4

The maximum length of resource package version.

Definition at line 88 of file mresmgr.h.

#define NCSRT_EXT_LEN 15

The maximum length of resource extension.

Definition at line 82 of file mresmgr.h.

Typedef Documentation

typedef unsigned int HPACKAGE

Handle to resource package.

Definition at line 42 of file mresmgr.h.

Enumeration Type Documentation

enum ncsRMRdrResType

Renderer resource type.

Enumerator:
NCSRM_RDRTYPE_COLOR | Color
NCSRM_RDRTYPE_METRIC | Metric
NCSRM_RDRTYPE_IMAGE | Image
NCSRM_RDRTYPE_FONT | Font
NCSRM_RDRTYPE_BINARY | Binary
NCSRM_RDRTYPE_STRING | String
NCSRM_RDRTYPE_FILE | File
NCSRM_RDRTYPE_TEXT | Text
NCSRM_RDRTYPE_MAX | Maximum value

Definition at line 285 of file mresmgr.h.

Function Documentation

int ncsAddRefResPackage ( HPACKAGE package )

add the reference count for resource package

See also:
ncsLoadResPackage

mMainWnd * ncsCreateMainWindowIndirectFromID | ( | HPACKAGE | package,
 |  | Uint32 | wndId,
 |  | HWND | owner,
 |  | HICON | hIcon,
 |  | HMENU | hMenu,
 |  | NCS_EVENT_HANDLER_INFO * | handlers,
 |  | NCS_EVENT_CONNECT_INFO * | connects,
 |  | DWORD | user_data
 | ) |  |

Create main window.

This function create main window according to UI resource ID, parent handle, and other informations.

Parameters:
package | The handle of resource package.
wndId | The UI resource id.
owner | The handle of parent window.
hIcon | The handle of icon.
hMenu | The handle of menu.
handlers | The handler set.
connects | The handler set of connect
user_data | The user_data
Returns:
window class on success, otherwise NULL.

int ncsCreateModalDialogFromID | ( | HPACKAGE | package,
 |  | Uint32 | dlgId,
 |  | HWND | owner,
 |  | HICON | hIcon,
 |  | HMENU | hMenu,
 |  | NCS_EVENT_HANDLER_INFO * | handlers,
 |  | NCS_EVENT_CONNECT_INFO * | connects
 | ) |  |

Create modal dialog.

This function create modal dialog according to UI resource ID, parent handle, and other informations.

Parameters:
package | The handle of resource package.
dlgId | The UI resource id.
owner | The handle of parent window.
hIcon | The handle of icon.
hMenu | The handle of menu.
handlers | The handler set.
connects | The event connect info.
Returns:
If success, the value of the dialog box, i.e., the second argument passed to EndDialog function which closes the dialog box. Otherwise -1.

void ncsFreeWndTemplate ( NCS_MNWND_TEMPLATE * ptempl )

free the window template create by ncsGetWndTemplFromID

free the content of window template, but don't free itself

Parameters:
ptempl the template to be free
Returns:
void
See also:
ncsGetWndTemplFromID

int ncsGetBitmap | ( | HDC | hdc,
 |  | HPACKAGE | package,
 |  | Uint32 | resId,
 |  | PBITMAP | pBitmap
 | ) |  |

Load a device-dependent bitmap from resource id.

Parameters:
hdc | The device context.
package | The handle of resource package.
resId | The resource id.
pBitmap | The pointer to the BITMAP object.
Returns:
0 on success, otherwise failure.

const char * ncsGetDefaultLocale ( void )

Get default locale information.

Returns:
Locale value.

const char * ncsGetImageFileName | ( | HPACKAGE | package,
 |  | Uint32 | resId
 | ) |  |

Get the name of image file.

Parameters:
package | The handle of resource package.
resId | The resource id.
Returns:
string on success, otherwise NULL.

int ncsGetMyBitmap | ( | HPACKAGE | package,
 |  | Uint32 | resId,
 |  | PMYBITMAP | myBmp,
 |  | RGB * | pal
 | ) |  |

Load a device-independent bitmap from resource id.

Parameters:
package | The handle of resource package.
resId | The resource id.
myBmp | The pointer to the MYBITMAP object.
pal | The palette will be returned through this pointer.
Returns:
0 on success, otherwise failure.

const char * ncsGetString | ( | HPACKAGE | package,
 |  | Uint32 | resId
 | ) |  |

Get string.

This function gets string according to the specified id resId.

Parameters:
package | The handle of resource package.
resId | The string resource id.
Returns:
string on success, otherwise NULL.

BOOL ncsGetWndTemplFromID | ( | HPACKAGE | package,
 |  | Uint32 | wndId,
 |  | NCS_MNWND_TEMPLATE * | ptempl,
 |  | NCS_EVENT_HANDLER_INFO * | handlers
 | ) |  |

get the window template from package

This function get the info from package. It will create the memory to save the children controls and properties.

Parameters:
package | The handler of resource package
wndId | The window template id in resource
ptempl | The template buffer
handlers | The event handlers of window
Returns:
If success, return TRUE, or Failed return FALSE

HPACKAGE ncsLoadResPackageFromFile ( const char * fileName )

Load a resource package from resource package file.

Parameters:
fileName The name of resource package.
Returns:
Nonzero on success, otherwize HPACKAGE_NULL.

HPACKAGE ncsLoadResPackageFromMem | ( | const void * | mem,
 |  | int | size
 | ) |  |

Load a resource package from memory. User get the information of incore resource package by getIncoreResPackInfo firstly, then call this function to load resource package.

Parameters:
mem | The memory address.
size | The size of memory.
Returns:
Nonzero on success, otherwize HPACKAGE_NULL.

void ncsReleaseBitmap ( PBITMAP pBitmap )

Releases a bitmap.

This function unloads the specified bitmap pBitmap. It will free the private pixel format and the bits of the bitmap.

Parameters:
pBitmap The BITMAP object.
See also:
ncsGetBitmapFromID

void ncsReleaseMyBitmap ( PMYBITMAP myBmp )

Releases a bitmap.

This function releases the specified MYBITMAP object myBmp.

Parameters:
myBmp The MYBITMAP object.
See also:
ncsGetMyBitmapFromID

const char * ncsSetDefaultLocale | ( | char * | language,
 |  | char * | country
 | ) |  |

Set default locale information.

Parameters:
language | The system language environment.
country | The country environment.
Returns:
Locale value.

BOOL ncsSetSysRdr | ( | HPACKAGE | package,
 |  | Uint32 | rdrSetId
 | ) |  |

Set system renderer.

This function set system renderer according to the specified renderer set id rdrSetId.

Parameters:
package | The handle of resource package.
rdrSetId | The renderer set resource id.
Returns:
TRUE on success, otherwise FALSE.

BOOL ncsSetWinRdr | ( | HWND | hWnd,
 |  | HPACKAGE | package,
 |  | Uint32 | rdrId
 | ) |  |

Set window renderer.

This function set window renderer according to the specified renderer id rdrId.

Parameters:
hWnd | The handle of window.
package | The handle of resource package.
rdrId | The renderer resource id.
Returns:
TRUE on success, otherwise FALSE.

void ncsUnloadResPackage ( HPACKAGE package )

Unload a resource package.

Parameters:
package The handle of resource package.

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: _NCSRM_HEADER Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_NCSRM_HEADER Struct Reference
[Resource Managerment]

#include <mresmgr.h>

Data Fields

  • Uint32 magic
  • char package_version [NCSRM_VERSION_LEN]
  • char format_version [NCSRM_VERSION_LEN]
  • char vendor [NCSRM_VENDOR_LEN]
  • Uint32 nr_sect

Detailed Description

Structure defines MiniGUI resource package header.

Definition at line 103 of file mresmgr.h.

Field Documentation

Uint32 magic

The magic number(MGRP).

Definition at line 106 of file mresmgr.h.

char package_version[NCSRM_VERSION_LEN]

The default package version: 1.0.

See also:
NCSRM_VERSION_LEN

Definition at line 109 of file mresmgr.h.

char format_version[NCSRM_VERSION_LEN]

The default version: 1.0.

See also:
NCSRM_VERSION_LEN

Definition at line 112 of file mresmgr.h.

char vendor[NCSRM_VENDOR_LEN]

The vendor of resource package.

See also:
NCSRM_VENDOR_LEN

Definition at line 117 of file mresmgr.h.

Uint32 nr_sect

The number of resource section.

Definition at line 120 of file mresmgr.h.

The documentation for this struct was generated from the following file:
  • mresmgr.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: _NCSRM_TYPEITEM Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_NCSRM_TYPEITEM Struct Reference
[Resource Managerment]

#include <mresmgr.h>

Data Fields

  • Uint32 type
  • Uint32 filename_id
  • Uint32 offset

Detailed Description

Structure defines resouce type information.

Definition at line 124 of file mresmgr.h.

Field Documentation

Uint32 type

The resouce type. It can be one of the following values:

  • NCSRT_STRING
    The string resource type.
  • NCSRT_TEXT
    The string text resource type.
  • NCSRT_IMAGE
    The image resource type.
  • NCSRT_UI
    The UI resource type.
  • NCSRT_RDR
    The renderer resource type.
  • NCSRT_RDRSET
    The NCSRT_RDR set resource type.
  • NCSRT_BINARY
    The user-defined data resource type.

Definition at line 142 of file mresmgr.h.

Uint32 filename_id

The ID of file name.

Definition at line 145 of file mresmgr.h.

Uint32 offset

The offset of the resource type section. relative to the resource package header.

Definition at line 150 of file mresmgr.h.

The documentation for this struct was generated from the following file:
  • mresmgr.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: _NCSRM_IDITEM Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_NCSRM_IDITEM Struct Reference
[Resource Managerment]

#include <mresmgr.h>

Data Fields

  • Uint32 id
  • Uint32 filename_id
  • Uint32 offset

Detailed Description

Structure defines resource ID item information.

Definition at line 154 of file mresmgr.h.

Field Documentation

Uint32 id

The resource ID

Definition at line 157 of file mresmgr.h.

Uint32 filename_id

The ID of file name.

Definition at line 160 of file mresmgr.h.

Uint32 offset

The offset of incore resource data in data section.

Definition at line 163 of file mresmgr.h.

The documentation for this struct was generated from the following file:
  • mresmgr.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: _NCSRM_WINHEADER Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_NCSRM_WINHEADER Struct Reference
[Resource Managerment]

#include <mresmgr.h>

Data Fields

  • Uint32 class_id
  • Uint32 wnd_id
  • Uint32 serial_num
  • Uint32 caption_id
  • Uint32 rdr_id
  • Sint32 x
  • Sint32 y
  • Uint32 w
  • Uint32 h
  • DWORD style
  • DWORD ex_style
  • DWORD bk_color
  • Uint32 font_id
  • Uint32 size
  • Uint32 offset_props
  • Uint32 offset_ctrls
  • Uint32 nr_props
  • Uint32 nr_ctrls
  • Uint32 offset_adddata
  • Uint32 size_adddata

Detailed Description

Structure defines UI resource header.

Definition at line 168 of file mresmgr.h.

Field Documentation

Uint32 class_id

The class id.

Definition at line 171 of file mresmgr.h.

Uint32 wnd_id

The window id.

Definition at line 174 of file mresmgr.h.

Uint32 serial_num

The serial number of window.

Definition at line 177 of file mresmgr.h.

Uint32 caption_id

The window caption id.

Definition at line 180 of file mresmgr.h.

Uint32 rdr_id

The window renderer resource id.

Definition at line 183 of file mresmgr.h.

Sint32 x

The x coordinate of the window.

Definition at line 187 of file mresmgr.h.

Sint32 y

The y coordinate of the window.

Definition at line 190 of file mresmgr.h.

Uint32 w

The width of the window.

Definition at line 193 of file mresmgr.h.

Uint32 h

The height of the window.

Definition at line 196 of file mresmgr.h.

DWORD style

The style of the window.

Definition at line 199 of file mresmgr.h.

DWORD ex_style

The extended style of the window.

Definition at line 202 of file mresmgr.h.

DWORD bk_color

The back color of window.

Definition at line 205 of file mresmgr.h.

Uint32 font_id

Reserved. The font id of window.

Definition at line 208 of file mresmgr.h.

Uint32 size

The size of window information, which contains properties, additional data and sub controls.

Definition at line 212 of file mresmgr.h.

Uint32 offset_props

The offset of window properties.

Definition at line 215 of file mresmgr.h.

Uint32 offset_ctrls

The offset of controls.

Definition at line 218 of file mresmgr.h.

Uint32 nr_props

The number of window properties.

Definition at line 221 of file mresmgr.h.

Uint32 nr_ctrls

The number of controls.

Definition at line 224 of file mresmgr.h.

Uint32 offset_adddata

The offset of window additional data.

Definition at line 227 of file mresmgr.h.

Uint32 size_adddata

The size of window additional data.

Definition at line 230 of file mresmgr.h.

The documentation for this struct was generated from the following file:
  • mresmgr.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: _NCSRM_SECTHEADER Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_NCSRM_SECTHEADER Struct Reference
[Resource Managerment]

#include <mresmgr.h>

Data Fields

  • Uint32 sect_size
  • Uint32 size_maps

Detailed Description

Structure defines the header of section.

Definition at line 235 of file mresmgr.h.

Field Documentation

Uint32 sect_size

The size of section.

Definition at line 238 of file mresmgr.h.

Uint32 size_maps

The size of id maps.

Definition at line 241 of file mresmgr.h.

The documentation for this struct was generated from the following file:
  • mresmgr.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: _NCSRM_DEFLOCALE_INFO Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_NCSRM_DEFLOCALE_INFO Struct Reference
[Resource Managerment]

#include <mresmgr.h>

Data Fields

  • char language [4]
  • char country [4]

Detailed Description

Structure defines default locale information.

Definition at line 245 of file mresmgr.h.

Field Documentation

char language[4]

The language code.

Definition at line 248 of file mresmgr.h.

char country[4]

The country code.

Definition at line 250 of file mresmgr.h.

The documentation for this struct was generated from the following file:
  • mresmgr.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: _NCSRM_LOCALEITEM Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_NCSRM_LOCALEITEM Struct Reference
[Resource Managerment]

#include <mresmgr.h>

Data Fields

  • char language [4]
  • char country [4]
  • Uint32 filename_id
  • Uint32 offset

Detailed Description

Structure defines locale item information.

Definition at line 254 of file mresmgr.h.

Field Documentation

char language[4]

The language code.

Definition at line 257 of file mresmgr.h.

char country[4]

The country code.

Definition at line 259 of file mresmgr.h.

Uint32 filename_id

The ID of file name.

Definition at line 262 of file mresmgr.h.

Uint32 offset

The offset of incore resource data.

Definition at line 265 of file mresmgr.h.

The documentation for this struct was generated from the following file:
  • mresmgr.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: _NCSRM_INCORE_IMAGE Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_NCSRM_INCORE_IMAGE Struct Reference
[Resource Managerment]

#include <mresmgr.h>

Data Fields

  • int size
  • char ext [NCSRT_EXT_LEN+1]
  • void * data

Detailed Description

Structure defines the header of incore image resource.

Definition at line 269 of file mresmgr.h.

Field Documentation

int size

The size of incore real image data, not include header.

Definition at line 272 of file mresmgr.h.

char ext[NCSRT_EXT_LEN+1]

The extended name of image data.

See also:
NCSRT_EXT_LEN

Definition at line 275 of file mresmgr.h.

void* data

The pointer to real image data.

Definition at line 278 of file mresmgr.h.

The documentation for this struct was generated from the following file:
  • mresmgr.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: _NCSRM_RDRINFO Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_NCSRM_RDRINFO Struct Reference
[Resource Managerment]

#include <mresmgr.h>

Data Fields

  • Uint32 id
  • Uint32 value

Detailed Description

Strucutre defines window renderer information.

Definition at line 310 of file mresmgr.h.

Field Documentation

Uint32 id

The identifier of renderer.

Definition at line 313 of file mresmgr.h.

Uint32 value

The value of renderer.

Definition at line 315 of file mresmgr.h.

The documentation for this struct was generated from the following file:
  • mresmgr.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: _NCSRM_RDRHEADER Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_NCSRM_RDRHEADER Struct Reference
[Resource Managerment]

#include <mresmgr.h>

Data Fields

  • Uint32 rdrname_id
  • Uint32 clsname_id

Detailed Description

Strucutre defines the header of renderer information.

Definition at line 321 of file mresmgr.h.

Field Documentation

Uint32 rdrname_id

The identifier of renderer name.

Definition at line 324 of file mresmgr.h.

Uint32 clsname_id

The identifier of class name.

Definition at line 326 of file mresmgr.h.

The documentation for this struct was generated from the following file:
  • mresmgr.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: _NCSRM_PROP Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_NCSRM_PROP Struct Reference
[Resource Managerment]

#include <mresmgr.h>

Data Fields

  • Sint32 type
  • Sint32 id
  • DWORD value

Detailed Description

Strucutre defines properties information.

Definition at line 332 of file mresmgr.h.

Field Documentation

Sint32 type

The type of property.

Definition at line 335 of file mresmgr.h.

Sint32 id

The identifier of property.

Definition at line 337 of file mresmgr.h.

DWORD value

The value of property.

Definition at line 339 of file mresmgr.h.

The documentation for this struct was generated from the following file:
  • mresmgr.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mScrollWidget

mScrollWidget

Data Structures

  • struct mScrollWidget
    The structure of mScrollWidget control, which derived from mWidget. It is the abstract superclass of all classes which represent controls that have standard scroll bars. More...
  • struct mScrollWidgetClass
    The virtual function table of mScrollWidget, which derived from mWidgetClass. More...
  • struct mScrollWidgetRenderer
    The structure of mScrollWidget renderer, which inheried from mWidgetRenderer. More...

Defines

  • #define NCSCTRL_SCROLLWIDGET NCSCLASSNAME("scrollwidget")
    the name of mScrollWidget control
  • #define NCSS_SWGT_SHIFT NCSS_WIDGET_SHIFT
    The bits used by mScrollWidget in style.

Enumerations

  • enum ncsSwgtDrawMode { NCSID_SWGT_AUTO = 0, NCSID_SWGT_ALWAYS, NCSID_SWGT_NEVER }
    Scroll bar drawing mode in ScrollWidget. More...
  • enum mScrollWidgetProp {
    NCSP_SWGT_CONTWIDTH = NCSP_WIDGET_MAX + 1, NCSP_SWGT_CONTHEIGHT, NCSP_SWGT_CONTX, NCSP_SWGT_CONTY,
    NCSP_SWGT_HSTEPVALUE, NCSP_SWGT_VSTEPVALUE, NCSP_SWGT_VISWIDTH, NCSP_SWGT_VISHEIGHT,
    NCSP_SWGT_MARGINRECT, NCSP_SWGT_DRAWMODE, NCSP_SWGT_MAX
    }
    The properties id of mScrollWidget. More...
  • enum mScrollWidgetNotify { NCSN_SWGT_MAX = NCSN_WIDGET_MAX + 1 }
    The notification code id of mScrollWidget. More...

Variables

  • MGNCS_EXPORT mScrollWidgetClass g_stmScrollWidgetCls
    The instance of mScrollWidgetClass.

Detailed Description

Id
mscroll_widget.h 642 2009-11-10 02:58:43Z xwyan

Copyright (C) 2009 Feynman Software.

Define Documentation

#define NCSCTRL_SCROLLWIDGET NCSCLASSNAME("scrollwidget")

the name of mScrollWidget control

Definition at line 44 of file mscroll_widget.h.

#define NCSS_SWGT_SHIFT NCSS_WIDGET_SHIFT

The bits used by mScrollWidget in style.

Definition at line 301 of file mscroll_widget.h.

Enumeration Type Documentation

enum mScrollWidgetNotify

The notification code id of mScrollWidget.

Enumerator:
NCSN_SWGT_MAX The maximum value of mScrollWidget notification code id.

Definition at line 307 of file mscroll_widget.h.

enum mScrollWidgetProp

The properties id of mScrollWidget.

Enumerator:
NCSP_SWGT_CONTWIDTH | The content width.
NCSP_SWGT_CONTHEIGHT | The content height.
NCSP_SWGT_CONTX | The x coordination of current content.
NCSP_SWGT_CONTY | The y coordination of current content.
NCSP_SWGT_HSTEPVALUE | The horizontal step value.
NCSP_SWGT_VSTEPVALUE | The vertical step value.
NCSP_SWGT_VISWIDTH | The visual width of content.
NCSP_SWGT_VISHEIGHT | The visual height of content.
NCSP_SWGT_MARGINRECT | The rectangle information of margins.
NCSP_SWGT_DRAWMODE | The scrollbar drawing mode.
NCSP_SWGT_MAX | The maximum value of mScrollWidget properties id.

Definition at line 249 of file mscroll_widget.h.

enum ncsSwgtDrawMode

Scroll bar drawing mode in ScrollWidget.

Enumerator:
NCSID_SWGT_AUTO | The scroll bar is shown or hidded automatically.
NCSID_SWGT_ALWAYS | The scroll bar is always visible.
NCSID_SWGT_NEVER | The scroll bar is never visbile.

Definition at line 54 of file mscroll_widget.h.

Variable Documentation

g_stmScrollWidgetCls

The instance of mScrollWidgetClass.

See also:
mScrollWidgetClass

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mScrollWidget Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mScrollWidget Struct Reference
[mScrollWidget]

The structure of mScrollWidget control, which derived from mWidget. It is the abstract superclass of all classes which represent controls that have standard scroll bars. More...

#include <mscroll_widget.h>

Detailed Description

The structure of mScrollWidget control, which derived from mWidget. It is the abstract superclass of all classes which represent controls that have standard scroll bars.

  • stepHVal
    The horizontal step value.

  • stepVVal
    The vertical step value.

  • contX
    The x position of current content.

  • contY
    The y position of current content.

  • contWidth
    The content width.

  • contHeight
    The content height.

  • visWidth
    The visible content width.

  • visHeight
    The visible content height.

  • leftMargin
    The value of left margin.

  • topMargin
    The value of top margin.

  • rightMargin
    The value of right margin.

  • bottomMargin
    The value of bottom margin.

  • drawMode
    The scrollbar drawing mode. It can be one of the following values:
    • NCSID_SWGT_AUTO
      The scroll bar is shown or hided automatically.
    • NCSID_SWGT_ALWAYS
      The scroll bar is always visible.
    • NCSID_SWGT_NEVER
      The scroll bar is never visbile.
The documentation for this struct was generated from the following file:
  • mscroll_widget.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mScrollWidgetClass Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mScrollWidgetClass Struct Reference
[mScrollWidget]

The virtual function table of mScrollWidget, which derived from mWidgetClass. More...

#include <mscroll_widget.h>

Detailed Description

The virtual function table of mScrollWidget, which derived from mWidgetClass.

  • void (*initMargins)(mScrollWidget *self, int l, int t, int r, int b);
    Initialize margin rectangle.

  • void (*moveContent)(mScrollWidget *self);
    The function is used to move content. It can be implemented by subclass.

  • void (*resetViewPort)(mScrollWidget *self, unsigned int visW, unsigned int visH);
    The function is used to reset viewport.
    Parameters:
    visW | The width of viewport.
    visH | The height of viewport.
  • void (*setScrollInfo)(mScrollWidget *self, BOOL reDraw);
    The function is used to set scrollbar information.
    Parameters:
    reDraw Whether draw scrollbar or not.
  • BOOL (*makePosVisible)(mScrollWidget *self, int x, int y);
    The function makes the specified position can be seen.
    Parameters:
    x | The x coordination of the specified position.
    y | The y coordination of the specified position.
    Returns:
    TRUE for success, otherwise FALSE.
  • BOOL (*isVisible)(mScrollWidget *self, int x, int y);
    The function is used to decide whether the specified position is visible.
    Parameters:
    x | The x coordination of the specified position.
    y | The y coordination of the specified position.
    Returns:
    TRUE for visible, otherwise FALSE.
  • void (*getVisRect)(mScrollWidget *self, RECT *rcVis);
    Get visible rectangle.

  • void (*viewportToWindow)(mScrollWidget *self, int *x, int *y);
    The visible to window coordinate's transformation.

  • void (*viewportToContent)(mScrollWidget *self, int *x, int *y);
    The visible to content coordinate's transformation.

  • void (*contentToViewport)(mScrollWidget *self, int *x, int *y);
    The content to visible coordinate's transformation.

  • void (*contentToWindow)(mScrollWidget *self, int *x, int *y);
    The content to window coordinate's transformation.

  • void (*windowToViewport)(mScrollWidget *self, int *x, int *y);
    The window to visible coordinate's transformation.

  • void (*windowToContent)(mScrollWidget *self, int *x, int *y);
    The window to content coordinate's transformation.

  • void (*refreshRect)(mScrollWidget *self, const RECT *rc);
    Refresh the content in specified region.
The documentation for this struct was generated from the following file:
  • mscroll_widget.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mScrollWidgetRenderer Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mScrollWidgetRenderer Struct Reference
[mScrollWidget]

The structure of mScrollWidget renderer, which inheried from mWidgetRenderer. More...

#include <mscroll_widget.h>

Detailed Description

The structure of mScrollWidget renderer, which inheried from mWidgetRenderer.
The documentation for this struct was generated from the following file:
  • mscroll_widget.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mScrollBar

mScrollBar

Data Structures

  • struct mScrollBar
    the scrollbar struct of scrollbar control, derived from mSlider. More...
  • struct mScrollBarClass
    the VTable of mScrollBar, derived from mSliderClass. More...
  • struct mScrollBarRenderer
    ScrollBar class's Renderer interface, derived from mSliderRenderer. More...

Defines

  • #define NCSP_SCRLBR_MAXPOS NCSP_SLIDER_MAXPOS
    The value of the maximum position.
  • #define NCSP_SCRLBR_MINPOS NCSP_SLIDER_MINPOS
    The value of the minimum position.
  • #define NCSP_SCRLBR_CURPOS NCSP_SLIDER_CURPOS
    The value of the current position.
  • #define NCSP_SCRLBR_LINESTEP NCSP_SLIDER_LINESTEP
    The line step length.
  • #define NCSP_SCRLBR_PAGESTEP NCSP_SLIDER_PAGESTEP
    The page step length.
  • #define NCSS_SCRLBR_HORIZONTAL NCSS_SLIDER_HORIZONTAL
    horizontal scrollbar.
  • #define NCSS_SCRLBR_ARROWS (1<<NCSS_SLIDER_SHIFT)
    indicate that the scrollbar has arrows or doesn't
  • #define NCSS_SCRLBR_LEFTDBLARROWS (2<<NCSS_SLIDER_SHIFT)
    indicate that the scrollbar has two arrows in the left side
  • #define NCSS_SCRLBR_UPDBLARROWS NCSS_SCRLBR_LEFTDBLARROWS
    indicate that the scrollbar has two arrows in the up side
  • #define NCSS_SCRLBR_RIGHTDBLARROWS (4<<NCSS_SLIDER_SHIFT)
    indicate that the scrollbar has two arrows in the right side
  • #define NCSS_SCRLBR_DOWNDBLARROWS NCSS_SCRLBR_RIGHTDBLARROWS
    indicate that the scrollbar has two arrows in the down side
  • #define NCSS_SCRLBR_VERTICAL NCSS_SLIDER_VERTICAL
    vertical scrollbar.
  • #define NCSN_SCRLBR_CHANGED NCSN_SLIDER_CHANGED
    positon changed notify code.
  • #define NCSN_SCRLBR_REACHMAX NCSN_SLIDER_REACHMAX
    reached the maximum position notify code.
  • #define NCSN_SCRLBR_REACHMIN NCSN_SLIDER_REACHMIN
    reached the minimum position notify code.

Variables

  • MGNCS_EXPORT mScrollBarClass g_stmScrollBarCls
    the instance of mScrollBarClass

Define Documentation

#define NCSN_SCRLBR_CHANGED NCSN_SLIDER_CHANGED

positon changed notify code.

Definition at line 176 of file mscrollbar.h.

#define NCSN_SCRLBR_REACHMAX NCSN_SLIDER_REACHMAX

reached the maximum position notify code.

Definition at line 182 of file mscrollbar.h.

#define NCSN_SCRLBR_REACHMIN NCSN_SLIDER_REACHMIN

reached the minimum position notify code.

Definition at line 188 of file mscrollbar.h.

#define NCSP_SCRLBR_CURPOS NCSP_SLIDER_CURPOS

The value of the current position.

Definition at line 115 of file mscrollbar.h.

#define NCSP_SCRLBR_LINESTEP NCSP_SLIDER_LINESTEP

The line step length.

Definition at line 120 of file mscrollbar.h.

#define NCSP_SCRLBR_MAXPOS NCSP_SLIDER_MAXPOS

The value of the maximum position.

Definition at line 105 of file mscrollbar.h.

#define NCSP_SCRLBR_MINPOS NCSP_SLIDER_MINPOS

The value of the minimum position.

Definition at line 110 of file mscrollbar.h.

#define NCSP_SCRLBR_PAGESTEP NCSP_SLIDER_PAGESTEP

The page step length.

Definition at line 125 of file mscrollbar.h.

#define NCSS_SCRLBR_ARROWS (1<<NCSS_SLIDER_SHIFT)

indicate that the scrollbar has arrows or doesn't

Definition at line 139 of file mscrollbar.h.

#define NCSS_SCRLBR_DOWNDBLARROWS NCSS_SCRLBR_RIGHTDBLARROWS

indicate that the scrollbar has two arrows in the down side

Note:
don't use the style with NCSS_SCRLBR_UPDBLARROWS

Definition at line 163 of file mscrollbar.h.

#define NCSS_SCRLBR_HORIZONTAL NCSS_SLIDER_HORIZONTAL

horizontal scrollbar.

Definition at line 134 of file mscrollbar.h.

#define NCSS_SCRLBR_LEFTDBLARROWS (2<<NCSS_SLIDER_SHIFT)

indicate that the scrollbar has two arrows in the left side

Note:
don't use the style with NCSS_SCRLBR_RIGHTDBLARROWS

Definition at line 145 of file mscrollbar.h.

#define NCSS_SCRLBR_RIGHTDBLARROWS (4<<NCSS_SLIDER_SHIFT)

indicate that the scrollbar has two arrows in the right side

Note:
don't use the style with NCSS_SCRLBR_LEFTDBLARROWS

Definition at line 157 of file mscrollbar.h.

#define NCSS_SCRLBR_UPDBLARROWS NCSS_SCRLBR_LEFTDBLARROWS

indicate that the scrollbar has two arrows in the up side

Note:
don't use the style with NCSS_SCRLBR_DOWNDBLARROWS

Definition at line 151 of file mscrollbar.h.

#define NCSS_SCRLBR_VERTICAL NCSS_SLIDER_VERTICAL

vertical scrollbar.

Definition at line 170 of file mscrollbar.h.

Variable Documentation

g_stmScrollBarCls

the instance of mScrollBarClass

See also:
mScrollBarClass

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mScrollBar Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mScrollBar Struct Reference
[mScrollBar]

the scrollbar struct of scrollbar control, derived from mSlider. More...

#include <mscrollbar.h>

Detailed Description

the scrollbar struct of scrollbar control, derived from mSlider.

See also:
mScrollBarRenderer, mScrollBarClass
The documentation for this struct was generated from the following file:
  • mscrollbar.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mScrollBarClass Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mScrollBarClass Struct Reference
[mScrollBar]

the VTable of mScrollBar, derived from mSliderClass. More...

#include <mscrollbar.h>

Detailed Description

the VTable of mScrollBar, derived from mSliderClass.

See also:
mSliderClass
The documentation for this struct was generated from the following file:
  • mscrollbar.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mScrollBarRenderer Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mScrollBarRenderer Struct Reference
[mScrollBar]

ScrollBar class's Renderer interface, derived from mSliderRenderer. More...

#include <mscrollbar.h>

Detailed Description

ScrollBar class's Renderer interface, derived from mSliderRenderer.

See also:
mScrollBar, mScrollBarClass
The documentation for this struct was generated from the following file:
  • mscrollbar.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mScrollView

mScrollView

Data Structures

  • struct _NCS_SCRLV_ITEMINFO
  • struct mScrollView
    The structure of mScrollView control, which derived from mItemView. More...
  • struct mScrollViewClass
    The virtual function table of mScrollView, which derived from mItemViewClass. More...
  • struct mScrollViewRenderer
    The structure of mScrollView renderer, which inheried from mItemViewRenderer. More...

Defines

  • #define NCSCTRL_SCROLLVIEW NCSCLASSNAME("scrollview")
    The control class name of mScrollView.
  • #define NCSS_SCRLV_SHIFT (NCSS_ITEMV_SHIFT)
    The bits used by mScrollView in style.
  • #define NCSS_SCRLV_UPNOTIFY NCSS_ITEMV_UPNOTIFY
  • #define NCSS_SCRLV_LOOP NCSS_ITEMV_LOOP
  • #define NCSS_SCRLV_SORT NCSS_ITEMV_AUTOSORT

Enumerations

  • enum mScrollViewProp { NCSP_SCRLV_MAX = NCSP_ITEMV_MAX + 1 }
    The properties id of mScrollView. More...
  • enum mScrollViewNotify { NCSN_SCRLV_CLICKED = NCSN_ITEMV_CLICKED, NCSN_SCRLV_SELCHANGED = NCSN_ITEMV_SELCHANGED, NCSN_SCRLV_SELCHANGING = NCSN_ITEMV_SELCHANGING, NCSN_SCRLV_MAX = NCSN_ITEMV_MAX + 1 }
    The notification code id of mScrollView. More...

Variables

  • MGNCS_EXPORT mScrollViewClass g_stmScrollViewCls
    The instance of mScrollViewClass.

Detailed Description

Id
mscrollview.h 635 2009-10-28 02:19:04Z wangjian

Copyright (C) 2009 Feynman Software.

Define Documentation

#define NCSCTRL_SCROLLVIEW NCSCLASSNAME("scrollview")

The control class name of mScrollView.

Definition at line 60 of file mscrollview.h.

#define NCSS_SCRLV_LOOP NCSS_ITEMV_LOOP

See also:
NCSS_ITEMV_LOOP

Definition at line 78 of file mscrollview.h.

#define NCSS_SCRLV_SHIFT (NCSS_ITEMV_SHIFT)

The bits used by mScrollView in style.

Definition at line 66 of file mscrollview.h.

#define NCSS_SCRLV_SORT NCSS_ITEMV_AUTOSORT

See also:
NCSS_ITEMV_AUTOSORT

Definition at line 84 of file mscrollview.h.

#define NCSS_SCRLV_UPNOTIFY NCSS_ITEMV_UPNOTIFY

See also:
NCSS_ITEMV_UPNOTIFY

Definition at line 72 of file mscrollview.h.

Enumeration Type Documentation

enum mScrollViewNotify

The notification code id of mScrollView.

Enumerator:
NCSN_SCRLV_CLICKED | Mouse clicked
NCSN_SCRLV_SELCHANGED | Selected item changed.
NCSN_SCRLV_SELCHANGING | Selected item is changing.
NCSN_SCRLV_MAX | The maximum value of mScrollView notification code id.

Definition at line 145 of file mscrollview.h.

enum mScrollViewProp

The properties id of mScrollView.

Enumerator:
NCSP_SCRLV_MAX The maximum value of mScrollView properties id.

Definition at line 133 of file mscrollview.h.

Variable Documentation

g_stmScrollViewCls

The instance of mScrollViewClass.

See also:
mScrollViewClass

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: _NCS_SCRLV_ITEMINFO Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_NCS_SCRLV_ITEMINFO Struct Reference
[mScrollView]

#include <mscrollview.h>

Data Fields

  • int index
  • int height
  • DWORD addData

Detailed Description

The structure of scrollview item information.

Definition at line 42 of file mscrollview.h.

Field Documentation

int index

The index of item.

Definition at line 45 of file mscrollview.h.

int height

The height of item.

Definition at line 47 of file mscrollview.h.

DWORD addData

The additional data of item.

Definition at line 49 of file mscrollview.h.

The documentation for this struct was generated from the following file:
  • mscrollview.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mScrollView Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mScrollView Struct Reference
[mScrollView]

The structure of mScrollView control, which derived from mItemView. More...

#include <mscrollview.h>

Detailed Description

The structure of mScrollView control, which derived from mItemView.
The documentation for this struct was generated from the following file:
  • mscrollview.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mScrollViewClass Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mScrollViewClass Struct Reference
[mScrollView]

The virtual function table of mScrollView, which derived from mItemViewClass. More...

#include <mscrollview.h>

Detailed Description

The virtual function table of mScrollView, which derived from mItemViewClass.

  • HITEM (*addItem)(mIconView *self, NCS_SCRLV_ITEMINFO *info, int *pos);
    Add a new item according to info.
    Parameters:
    info | The item information for iconview.
    pos | the position in which item is inserted.
The documentation for this struct was generated from the following file:
  • mscrollview.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mScrollViewRenderer Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mScrollViewRenderer Struct Reference
[mScrollView]

The structure of mScrollView renderer, which inheried from mItemViewRenderer. More...

#include <mscrollview.h>

Detailed Description

The structure of mScrollView renderer, which inheried from mItemViewRenderer.
The documentation for this struct was generated from the following file:
  • mscrollview.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mSeparator

mSeparator

Data Structures

  • struct mSeparator
    separator class, derived from mStatic More...
  • struct mSeparatorClass
    struct of separator control, derived from mStaticClass More...
  • struct mSeparatorRenderer
    separator class renderer interface, derived from mStaticRenderer More...

Defines

  • #define NCSCTRL_SEPARATOR NCSCLASSNAME("separator")
    the name of separator control
  • #define NCSS_SPRTR_VERT (0x1<<NCSS_STATIC_SHIFT)
    indicate a vertical separator

Enumerations

  • enum mSeparatorProp
    the properties id of mSeparator More...
  • enum enumSeparatorNotify
    the notification code of mSeparator More...

Variables

  • MGNCS_EXPORT mSeparatorClass g_stmSeparatorCls
    global mSeparatorClass

Define Documentation

#define NCSCTRL_SEPARATOR NCSCLASSNAME("separator")

the name of separator control

Definition at line 20 of file mseparator.h.

#define NCSS_SPRTR_VERT (0x1<<NCSS_STATIC_SHIFT)

indicate a vertical separator

Definition at line 93 of file mseparator.h.

Enumeration Type Documentation

enum enumSeparatorNotify

the notification code of mSeparator

Definition at line 100 of file mseparator.h.

enum mSeparatorProp

the properties id of mSeparator

Definition at line 85 of file mseparator.h.

Variable Documentation

g_stmSeparatorCls

global mSeparatorClass

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mSeparator Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mSeparator Struct Reference
[mSeparator]

separator class, derived from mStatic More...

#include <mseparator.h>

Detailed Description

separator class, derived from mStatic
The documentation for this struct was generated from the following file:
  • mseparator.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mSeparatorClass Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mSeparatorClass Struct Reference
[mSeparator]

struct of separator control, derived from mStaticClass More...

#include <mseparator.h>

Detailed Description

struct of separator control, derived from mStaticClass
The documentation for this struct was generated from the following file:
  • mseparator.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mSeparatorRenderer Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mSeparatorRenderer Struct Reference
[mSeparator]

separator class renderer interface, derived from mStaticRenderer More...

#include <mseparator.h>

Detailed Description

separator class renderer interface, derived from mStaticRenderer
The documentation for this struct was generated from the following file:
  • mseparator.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mSlEdit

mSlEdit

Data Structures

  • struct mSlEdit
    the single line control, derived from mEdit. More...
  • struct mSlEditClass
    the VTable of mSlEdit, derived from mEditClass. More...
  • struct mSlEditRenderer
    SlEdit class's Renderer interface, derived from mEditRenderer. More...

Defines

  • #define NCSS_SLEDIT_PASSWORD (0x0001L<<NCSS_EDIT_SHIFT)
    Displays an asterisk (*) for each character typed into the edit control.
  • #define NCSS_SLEDIT_AUTOSELECT (0x0002L<<NCSS_EDIT_SHIFT)
    Selects all text when getting focus.

Enumerations

  • enum mSlEditProp { NCSP_SLEDIT_TIPTEXT = NCSP_EDIT_MAX + 1, NCSP_SLEDIT_PWDCHAR }
  • enum mSlEditNotify { NCSN_SLEDIT_CHANGE = NCSN_EDIT_CHANGE, NCSN_SLEDIT_ENTER = NCSN_ITEMV_ENTER }

Variables

  • MGNCS_EXPORT mSlEditClass g_stmSlEditCls
    the instance of mSlEditClass

Define Documentation

#define NCSS_SLEDIT_AUTOSELECT (0x0002L<<NCSS_EDIT_SHIFT)

Selects all text when getting focus.

Definition at line 158 of file msledit.h.

#define NCSS_SLEDIT_PASSWORD (0x0001L<<NCSS_EDIT_SHIFT)

Displays an asterisk (*) for each character typed into the edit control.

Definition at line 152 of file msledit.h.

Enumeration Type Documentation

enum mSlEditNotify

SlEdit Notify Code :

Enumerator:
NCSN_SLEDIT_CHANGE | content changed
NCSN_SLEDIT_ENTER | enter key pressed

Definition at line 177 of file msledit.h.

enum mSlEditProp

SlEdit Property define :

Enumerator:
NCSP_SLEDIT_TIPTEXT | tip text , Type : char*
NCSP_SLEDIT_PWDCHAR | password character , Type : char

Definition at line 169 of file msledit.h.

Variable Documentation

g_stmSlEditCls

the instance of mSlEditClass

See also:
mSlEditClass

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mSlEdit Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mSlEdit Struct Reference
[mSlEdit]

the single line control, derived from mEdit. More...

#include <msledit.h>

Detailed Description

the single line control, derived from mEdit.

  • status
    The status of the sledit. the value may be:
    • NCST_SLEDIT_FOCUSED
    • NCST_SLEDIT_MODIFY
    • NCST_SLEDIT_TMP
    • NCST_SLEDIT_REPLACE
  • editPos
    The modify position,(the position of the caret)
  • selStart
    The start of the selected text
  • selEnd
    The end of the selected text
  • nContX
    Content x offset position
  • nContW
    Content width
  • rcVis
    Content rect
  • nVisW
    Visible area width
  • startX
    Text x display position
  • startY
    Text y display position
  • nBlockSize
    String buffer block size
  • content
    String text buffer
  • tipText
    Tip text
  • hardLimit
    Hard limit
  • passwdChar
    Password character
  • changed
    Change flag
  • cp
    Copy & Paste operators

See also:
mSlEditClass
The documentation for this struct was generated from the following file:
  • msledit.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mSlEditClass Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mSlEditClass Struct Reference
[mSlEdit]

the VTable of mSlEdit, derived from mEditClass. More...

#include <msledit.h>

Detailed Description

the VTable of mSlEdit, derived from mEditClass.

See also:
mSlEdit
The documentation for this struct was generated from the following file:
  • msledit.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mSlEditRenderer Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mSlEditRenderer Struct Reference
[mSlEdit]

SlEdit class's Renderer interface, derived from mEditRenderer. More...

#include <msledit.h>

Detailed Description

SlEdit class's Renderer interface, derived from mEditRenderer.

See also:
mSlEdit, mSlEditClass
The documentation for this struct was generated from the following file:
  • msledit.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mSlider

mSlider

Data Structures

  • struct mSlider
    the slider struct of slider control, derived from mWidget. More...
  • struct mSliderClass
    the VTable of mSlider, derived from mWidgetClass. More...
  • struct mSliderRenderer
    Slider class's Renderer interface, derived from mWidgetRenderer. More...

Defines

  • #define NCSS_SLIDER_HORIZONTAL 0x0000L
    horizontal slider
  • #define NCSS_SLIDER_VERTICAL (0x0001L<<NCSS_WIDGET_SHIFT)
    vertical slider

Enumerations

  • enum mSliderProp {
    NCSP_SLIDER_MAXPOS = NCSP_WIDGET_MAX + 1, NCSP_SLIDER_MINPOS, NCSP_SLIDER_CURPOS, NCSP_SLIDER_LINESTEP,
    NCSP_SLIDER_PAGESTEP
    }
  • enum enumSliderNotify { NCSN_SLIDER_CHANGED = NCSN_WIDGET_MAX, NCSN_SLIDER_REACHMAX, NCSN_SLIDER_REACHMIN }

Variables

  • MGNCS_EXPORT mSliderClass g_stmSliderCls
    the instance of mSliderClass

Define Documentation

#define NCSS_SLIDER_HORIZONTAL 0x0000L

horizontal slider

Definition at line 148 of file mslider.h.

#define NCSS_SLIDER_VERTICAL (0x0001L<<NCSS_WIDGET_SHIFT)

vertical slider

Definition at line 154 of file mslider.h.

Enumeration Type Documentation

enum enumSliderNotify

Slider Notify Codes

Enumerator:
NCSN_SLIDER_CHANGED When current position canged
  • param : new current pos position changed
NCSN_SLIDER_REACHMAX | When the current position reach max pos reached the max value
NCSN_SLIDER_REACHMIN | When the current positon reach min pos reached the min value

Definition at line 163 of file mslider.h.

enum mSliderProp

Slider Properties define

Enumerator:
NCSP_SLIDER_MAXPOS The max pos of slider
  • Type : int
  • ReadWrite value for maximum position
NCSP_SLIDER_MINPOS The min pos of slider
  • Type : int
  • ReadWrite value for minimum position
NCSP_SLIDER_CURPOS The current position of slider
  • Type : int
  • ReadWrite value for current position
NCSP_SLIDER_LINESTEP The line step length of slider
  • Type : int
  • ReadWirte line step length
NCSP_SLIDER_PAGESTEP The page step length of slider
  • Type : int
  • ReadWrite page step length

Definition at line 110 of file mslider.h.

Variable Documentation

g_stmSliderCls

the instance of mSliderClass

See also:
mSliderClass

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mSlider Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mSlider Struct Reference
[mSlider]

the slider struct of slider control, derived from mWidget. More...

#include <mslider.h>

Detailed Description

the slider struct of slider control, derived from mWidget.

See also:
mSliderClass
The documentation for this struct was generated from the following file:
  • mslider.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mSliderClass Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mSliderClass Struct Reference
[mSlider]

the VTable of mSlider, derived from mWidgetClass. More...

#include <mslider.h>

Detailed Description

the VTable of mSlider, derived from mWidgetClass.

See also:
mWidgetClass
The documentation for this struct was generated from the following file:
  • mslider.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mSliderRenderer Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mSliderRenderer Struct Reference
[mSlider]

Slider class's Renderer interface, derived from mWidgetRenderer. More...

#include <mslider.h>

Detailed Description

Slider class's Renderer interface, derived from mWidgetRenderer.

See also:
mSlider, mSliderClass
The documentation for this struct was generated from the following file:
  • mslider.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mSpinBox

mSpinBox

Data Structures

  • struct mSpinBox
    the spinbox struct of spinbox control, derived from mSpinner. More...
  • struct mSpinBoxClass
    the VTable of mSpinBox, derived from mSpinnerClass. More...
  • struct mSpinBoxRenderer
    Spinner class's Renderer interface, derived from mSpinnerRenderer. More...

Defines

  • #define NCSS_SPNBOX_VERTICAL (NCSS_SPNR_VERTICAL)
    vertical spinbox
  • #define NCSS_SPNBOX_HORIZONTAL (NCSS_SPNR_HORIZONTAL)
    horizontal spinbox
  • #define NCSS_SPNBOX_AUTOLOOP (NCSS_SPNR_AUTOLOOP)
    the value of spinbox auto loop
  • #define NCSS_SPNBOX_NUMBER (0x0000L<<NCSS_SPNR_SHIFT)
    spinbox show number
  • #define NCSS_SPNBOX_STRING (0x0001L<<NCSS_SPNR_SHIFT)
    spinbox shown strings
  • #define NCSS_SPNBOX_SORT (0x0002L<<NCSS_SPNR_SHIFT)
    auto sort spinbox
  • #define NCSS_SPNBOX_EDITNOBORDER (0x0004L<<NCSS_SPNR_SHIFT)
    spinbox with no-border edit
  • #define NCSS_SPNBOX_EDITBASELINE (0x0008L<<NCSS_SPNR_SHIFT)
    spinbox with base-line edit
  • #define NCSS_SPNBOX_READONLY (0x0010L<<NCSS_SPNR_SHIFT)
    spinbox with read-only edit
  • #define NCSS_SPNBOX_UPPERCASE (0x0020L<<NCSS_SPNR_SHIFT)
    spinbox show uppercase
  • #define NCSS_SPNBOX_LOWERCASE (0x0040L<<NCSS_SPNR_SHIFT)
    spinbox show lowercase
  • #define NCSS_SPNBOX_AUTOFOCUS (0x0080L<<NCSS_SPNR_SHIFT)
    spinbox with auto-focus edit

Enumerations

  • enum mSpinBoxProp { NCSP_SPNBOX_MAXPOS =  NCSP_SPNR_MAXPOS,
NCSP_SPNBOX_MINPOS =  NCSP_SPNR_MINPOS,
NCSP_SPNBOX_CURPOS =  NCSP_SPNR_CURPOS,
NCSP_SPNBOX_LINESTEP =  NCSP_SPNR_LINESTEP
 }
  • enum mSpinBoxNotify { NCSN_SPNBOX_CHANGED =  NCSN_SPNR_CHANGED,
NCSN_SPNBOX_REACHMAX =  NCSN_SPNR_REACHMAX,
NCSN_SPNBOX_REACHMIN =  NCSN_SPNR_REACHMIN
 }

Define Documentation

#define NCSS_SPNBOX_AUTOFOCUS (0x0080L<<NCSS_SPNR_SHIFT)

spinbox with auto-focus edit

Definition at line 195 of file mspinbox.h.

#define NCSS_SPNBOX_AUTOLOOP (NCSS_SPNR_AUTOLOOP)

the value of spinbox auto loop

Definition at line 141 of file mspinbox.h.

#define NCSS_SPNBOX_EDITBASELINE (0x0008L<<NCSS_SPNR_SHIFT)

spinbox with base-line edit

Definition at line 171 of file mspinbox.h.

#define NCSS_SPNBOX_EDITNOBORDER (0x0004L<<NCSS_SPNR_SHIFT)

spinbox with no-border edit

Definition at line 165 of file mspinbox.h.

#define NCSS_SPNBOX_HORIZONTAL (NCSS_SPNR_HORIZONTAL)

horizontal spinbox

Definition at line 135 of file mspinbox.h.

#define NCSS_SPNBOX_LOWERCASE (0x0040L<<NCSS_SPNR_SHIFT)

spinbox show lowercase

Definition at line 189 of file mspinbox.h.

#define NCSS_SPNBOX_NUMBER (0x0000L<<NCSS_SPNR_SHIFT)

spinbox show number

Definition at line 147 of file mspinbox.h.

#define NCSS_SPNBOX_READONLY (0x0010L<<NCSS_SPNR_SHIFT)

spinbox with read-only edit

Definition at line 177 of file mspinbox.h.

#define NCSS_SPNBOX_SORT (0x0002L<<NCSS_SPNR_SHIFT)

auto sort spinbox

Definition at line 159 of file mspinbox.h.

#define NCSS_SPNBOX_STRING (0x0001L<<NCSS_SPNR_SHIFT)

spinbox shown strings

Definition at line 153 of file mspinbox.h.

#define NCSS_SPNBOX_UPPERCASE (0x0020L<<NCSS_SPNR_SHIFT)

spinbox show uppercase

Definition at line 183 of file mspinbox.h.

#define NCSS_SPNBOX_VERTICAL (NCSS_SPNR_VERTICAL)

vertical spinbox

Definition at line 129 of file mspinbox.h.

Enumeration Type Documentation

enum mSpinBoxNotify

Spinner Notify Codes:

Enumerator:
NCSN_SPNBOX_CHANGED | value changed
NCSN_SPNBOX_REACHMAX | reached the max value
NCSN_SPNBOX_REACHMIN | reached the min value

Definition at line 201 of file mspinbox.h.

enum mSpinBoxProp

Spinner Property define:

Enumerator:
NCSP_SPNBOX_MAXPOS | the maximum value
NCSP_SPNBOX_MINPOS | the minimum value
NCSP_SPNBOX_CURPOS | the current value
NCSP_SPNBOX_LINESTEP | the line step length

Definition at line 116 of file mspinbox.h.

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mSpinBox Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mSpinBox Struct Reference
[mSpinBox]

the spinbox struct of spinbox control, derived from mSpinner. More...

#include <mspinbox.h>

Detailed Description

the spinbox struct of spinbox control, derived from mSpinner.

See also:
mSpinBoxClass
The documentation for this struct was generated from the following file:
  • mspinbox.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mSpinBoxClass Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mSpinBoxClass Struct Reference
[mSpinBox]

the VTable of mSpinBox, derived from mSpinnerClass. More...

#include <mspinbox.h>

Detailed Description

the VTable of mSpinBox, derived from mSpinnerClass.

See also:
mSpinnerClass
  • BOOL addItem(mSpinBox *self, char *item);
    add a item to the list
    Parameters:
    item - the item to add
  • BOOL removeItem(mSpinBox *self, int index);
    remove a item from the list
    Parameters:
    index - the item index to remove
  • BOOL setItem(mSpinBox *self, int index, const char *item);
    set the content of one item
    Parameters:
    index | - the item index to set
    item | - the content to set
  • char * getItem(mSpinBox *self, int index);
    get the content of one item
    Parameters:
    index - the item index to get
The documentation for this struct was generated from the following file:
  • mspinbox.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mSpinBoxRenderer Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mSpinBoxRenderer Struct Reference
[mSpinBox]

Spinner class's Renderer interface, derived from mSpinnerRenderer. More...

#include <mspinbox.h>

Detailed Description

Spinner class's Renderer interface, derived from mSpinnerRenderer.

See also:
mSpinBox, mSpinBoxClass
The documentation for this struct was generated from the following file:
  • mspinbox.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mSpinner

mSpinner

Data Structures

  • struct mSpinner
    the spinner struct of spinner control, derived from mWidget. More...
  • struct mSpinnerClass
    the VTable of mSpinner, derived from mWidgetClass. More...
  • struct mSpinnerRenderer
    SpinBox class's Renderer interface, derived from mWidgetRenderer. More...

Defines

  • #define NCSS_SPNR_VERTICAL 0x0000L
    vertical spinner
  • #define NCSS_SPNR_HORIZONTAL ((0x0001L)<<(NCSS_WIDGET_SHIFT))
    horizontal spinner
  • #define NCSS_SPNR_AUTOLOOP ((0x0002L)<<(NCSS_WIDGET_SHIFT))
    auto loop spinner

Enumerations

  • enum mSpinnerProp {
    NCSP_SPNR_MAXPOS = NCSP_WIDGET_MAX + 1, NCSP_SPNR_MINPOS, NCSP_SPNR_CURPOS, NCSP_SPNR_LINESTEP,
    NCSP_SPNR_TARGET
    }
  • enum mSpinnerNotify { NCSN_SPNR_CHANGED = NCSN_WIDGET_MAX + 1, NCSN_SPNR_REACHMAX, NCSN_SPNR_REACHMIN }

Define Documentation

#define NCSS_SPNR_AUTOLOOP ((0x0002L)<<(NCSS_WIDGET_SHIFT))

auto loop spinner

Definition at line 128 of file mspinner.h.

#define NCSS_SPNR_HORIZONTAL ((0x0001L)<<(NCSS_WIDGET_SHIFT))

horizontal spinner

Definition at line 122 of file mspinner.h.

#define NCSS_SPNR_VERTICAL 0x0000L

vertical spinner

Definition at line 116 of file mspinner.h.

Enumeration Type Documentation

enum mSpinnerNotify

SpinBox Notify Codes:

Enumerator:
NCSN_SPNR_CHANGED | value changed
NCSN_SPNR_REACHMAX | reached maximum value
NCSN_SPNR_REACHMIN | reached minimum value

Definition at line 134 of file mspinner.h.

enum mSpinnerProp

SpinBox Property define:

Enumerator:
NCSP_SPNR_MAXPOS | maximum value
NCSP_SPNR_MINPOS | minimum value
NCSP_SPNR_CURPOS | current value
NCSP_SPNR_LINESTEP | line step length
NCSP_SPNR_TARGET | target window's handler

Definition at line 100 of file mspinner.h.

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mSpinner Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mSpinner Struct Reference
[mSpinner]

the spinner struct of spinner control, derived from mWidget. More...

#include <mspinner.h>

Detailed Description

the spinner struct of spinner control, derived from mWidget.

  • h_target

See also:
mSpinnerClass
The documentation for this struct was generated from the following file:
  • mspinner.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mSpinnerClass Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mSpinnerClass Struct Reference
[mSpinner]

the VTable of mSpinner, derived from mWidgetClass. More...

#include <mspinner.h>

Detailed Description

the VTable of mSpinner, derived from mWidgetClass.

See also:
mWidgetClass
The documentation for this struct was generated from the following file:
  • mspinner.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mSpinnerRenderer Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mSpinnerRenderer Struct Reference
[mSpinner]

SpinBox class's Renderer interface, derived from mWidgetRenderer. More...

#include <mspinner.h>

Detailed Description

SpinBox class's Renderer interface, derived from mWidgetRenderer.

See also:
mSpinner, mSpinnerClass
The documentation for this struct was generated from the following file:
  • mspinner.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mStatic

mStatic

Data Structures

  • struct mStatic
    Static class, derived from mWidget. More...
  • struct mStaticClass
    struct of Static control, derived from mWidgetClass More...
  • struct mStaticRenderer
    Static class renderer interface, derived from mWidgetRenderer. More...

Defines

  • #define NCSCTRL_STATIC NCSCLASSNAME("static")
    the name of mStatic
  • #define NCSS_STATIC_PREFIX (0x1<<(NCSS_WIDGET_SHIFT))
    static prefix
  • #define NCSS_STATIC_SHIFT (NCSS_WIDGET_SHIFT + 1)
    static shift

Enumerations

  • enum mStaticProp { NCSP_STATIC_ALIGN = NCSP_WIDGET_MAX + 1, NCSP_STATIC_VALIGN, NCSP_STATIC_AUTOWRAP }
    the properties id of mStatic More...
  • enum enumStaticNotify
    the notification code of mStatic More...

Define Documentation

#define NCSCTRL_STATIC NCSCLASSNAME("static")

the name of mStatic

Definition at line 21 of file mstatic.h.

#define NCSS_STATIC_PREFIX (0x1<<(NCSS_WIDGET_SHIFT))

static prefix

Definition at line 114 of file mstatic.h.

#define NCSS_STATIC_SHIFT (NCSS_WIDGET_SHIFT + 1)

static shift

Definition at line 120 of file mstatic.h.

Enumeration Type Documentation

enum enumStaticNotify

the notification code of mStatic

Definition at line 126 of file mstatic.h.

enum mStaticProp

the properties id of mStatic

Enumerator:
NCSP_STATIC_ALIGN Align the content of static controller in horizontal mode
  • Type enumNCSAlign
  • Read Write
  • set the horizontal mode of static controller.
NCSP_STATIC_VALIGN Align the content of static controller in vertical mode
  • Type enumNCSVAlign
  • Read Write
  • set the vertical mode of static controller.
NCSP_STATIC_AUTOWRAP Set the content of static controller to autowrap mode
  • Type int
  • Read Write
  • turn on/off the autowrap mode of static content.

Definition at line 81 of file mstatic.h.

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mStatic Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mStatic Struct Reference
[mStatic]

Static class, derived from mWidget. More...

#include <mstatic.h>

Detailed Description

Static class, derived from mWidget.
The documentation for this struct was generated from the following file:
  • mstatic.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mStaticClass Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mStaticClass Struct Reference
[mStatic]

struct of Static control, derived from mWidgetClass More...

#include <mstatic.h>

Detailed Description

struct of Static control, derived from mWidgetClass
The documentation for this struct was generated from the following file:
  • mstatic.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mStaticRenderer Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mStaticRenderer Struct Reference
[mStatic]

Static class renderer interface, derived from mWidgetRenderer. More...

#include <mstatic.h>

Detailed Description

Static class renderer interface, derived from mWidgetRenderer.
The documentation for this struct was generated from the following file:
  • mstatic.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mTextEditor

mTextEditor

Data Structures

  • struct mTextEditor
    The structure of mTextEditor, which derived from mWidget. It is the new multiline edit control. More...
  • struct mTextEditorClass
    the VTable of mTextEditor, derived from mWidget. More...

Defines

  • #define NCSCTRL_TEXTEDITOR NCSCLASSNAME("texteditor")
    the name of mTextEditor
  • #define NCSS_TE_READONLY (1<<NCSS_WIDGET_SHIFT)
    The object is read-only.
  • #define NCSS_TE_UPPERCASE (2<<NCSS_WIDGET_SHIFT)
    The text is upper case.
  • #define NCSS_TE_LOWERCASE (4<<NCSS_WIDGET_SHIFT)
    The text is lower case.
  • #define NCSS_TE_NOHIDESEL (8<<NCSS_WIDGET_SHIFT)
    When lost the focus, it is still selected.
  • #define NCSS_TE_AUTOWRAP (0x10<<NCSS_WIDGET_SHIFT)
    Wrap text automatically.
  • #define NCSS_TE_BASELINE (0x20<<NCSS_WIDGET_SHIFT)
    Draw the base line.
  • #define NCSS_TE_OWNERBKGND (0x40<<NCSS_WIDGET_SHIFT)
    bkground is ower draw

Enumerations

  • enum ncsTEScrollMode { NCS_TEF_SCROLLBAR_NEVER = 0, NCS_TEF_SCROLLBAR_AUTO, NCS_TEF_SCROLLBAR_ALWAYS }
    Scroll bar drawing mode in TextEditor. More...
  • enum mTextEditorProp {
    NCSP_TE_READONLY = NCSP_WIDGET_MAX + 1, NCSP_TE_SCROLL_MODE, NCSP_TE_SCROLL_HSTEP, NCSP_TE_SCROLL_VSTEP,
    NCSP_TE_TEXTLIMIT, NCSP_TE_LINECOUNT, NCSP_TE_PARAGRAPHCOUNT, NCSP_TE_MARGINRECT,
    NCSP_TE_MAX
    }
    The properties id of mTextEditor. More...
  • enum mTextEditorNotify {
    NCSN_TE_CONTENTCHANGED = NCSN_WIDGET_MAX + 1, NCSN_TE_SETFOCUS, NCSN_TE_KILLFOCUS, NCSN_TE_MAXTEXT,
    NCSN_TE_CHANGE, NCSN_TE_UPDATE, NCSN_TE_SELCHANGED, NCSN_TE_MAX
    }
    The notification code id of mTextEditor. More...

Define Documentation

#define NCSCTRL_TEXTEDITOR NCSCLASSNAME("texteditor")

the name of mTextEditor

Definition at line 154 of file mtextedit.h.

#define NCSS_TE_AUTOWRAP (0x10<<NCSS_WIDGET_SHIFT)

Wrap text automatically.

Definition at line 390 of file mtextedit.h.

#define NCSS_TE_BASELINE (0x20<<NCSS_WIDGET_SHIFT)

Draw the base line.

Definition at line 396 of file mtextedit.h.

#define NCSS_TE_LOWERCASE (4<<NCSS_WIDGET_SHIFT)

The text is lower case.

Definition at line 378 of file mtextedit.h.

#define NCSS_TE_NOHIDESEL (8<<NCSS_WIDGET_SHIFT)

When lost the focus, it is still selected.

Definition at line 384 of file mtextedit.h.

#define NCSS_TE_OWNERBKGND (0x40<<NCSS_WIDGET_SHIFT)

bkground is ower draw

Definition at line 402 of file mtextedit.h.

#define NCSS_TE_READONLY (1<<NCSS_WIDGET_SHIFT)

The object is read-only.

Definition at line 366 of file mtextedit.h.

#define NCSS_TE_UPPERCASE (2<<NCSS_WIDGET_SHIFT)

The text is upper case.

Definition at line 372 of file mtextedit.h.

Enumeration Type Documentation

enum mTextEditorNotify

The notification code id of mTextEditor.

Enumerator:
NCSN_TE_CONTENTCHANGED | Notifies that content has changed when it lost focus.
NCSN_TE_SETFOCUS | Notifies the receipt of the input focus.
NCSN_TE_KILLFOCUS | Notifies the lost of the input focus.
NCSN_TE_MAXTEXT | Notifies reach of maximum content byte length.
NCSN_TE_CHANGE | Notifies that the text is altered by the user.
NCSN_TE_UPDATE | Notifies that the text is altered by sending setText to it.
NCSN_TE_SELCHANGED | Notifies that the selected text has been changed.
NCSN_TE_MAX | The maximum value of mTextEditor notification code id.

Definition at line 514 of file mtextedit.h.

enum mTextEditorProp

The properties id of mTextEditor.

Enumerator:
NCSP_TE_READONLY | Read-Only content.
NCSP_TE_SCROLL_MODE | The scrollbar drawing mode.
NCSP_TE_SCROLL_HSTEP | The horizontal step value.
NCSP_TE_SCROLL_VSTEP | The vertical step value.
NCSP_TE_TEXTLIMIT | Maximum text byte length.
NCSP_TE_LINECOUNT | Total line count. RO.
NCSP_TE_PARAGRAPHCOUNT | The number of paragraphs. RO.
NCSP_TE_MARGINRECT | The rectangle information of margins. param RECT*.
NCSP_TE_MAX | The maximum value of mTextEditor properties id.

Definition at line 460 of file mtextedit.h.

enum ncsTEScrollMode

Scroll bar drawing mode in TextEditor.

Enumerator:
NCS_TEF_SCROLLBAR_NEVER | The scroll bar is never visbile.
NCS_TEF_SCROLLBAR_AUTO | The scroll bar is shown or hidded automatically.
NCS_TEF_SCROLLBAR_ALWAYS | The scroll bar is always visible.

Definition at line 438 of file mtextedit.h.

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mTextEditor Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mTextEditor Struct Reference
[mTextEditor]

The structure of mTextEditor, which derived from mWidget. It is the new multiline edit control. More...

#include <mtextedit.h>

Detailed Description

The structure of mTextEditor, which derived from mWidget. It is the new multiline edit control.

  • textBuffer
    The text buffer.

  • textLayout
    The text layout.

  • visWidth, visHeight
    The text visible width and height.

  • offX, offY
    The text offset value.

  • caretWidth, caretHeight
    The width and height of caret.

  • scrollHStep, scrollVStep
    The horizontal and vertical scroll step of scrollbar.

  • scrollBarMode
    The scroll mode of scrollbar.
The documentation for this struct was generated from the following file:
  • mtextedit.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mTextEditorClass Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mTextEditorClass Struct Reference
[mTextEditor]

the VTable of mTextEditor, derived from mWidget. More...

#include <mtextedit.h>

Detailed Description

the VTable of mTextEditor, derived from mWidget.

  • int (*getParaText)(mTextEditor*, int index, int start, int len, char* buffer);
    The function gets the specified paragraph text.
    Parameters:
    index | - The index of paragraph.
    start | - The start byte index in specified paragraph.
    len | - The copied byte length of content.
    buffer- | The string buffer.
    Returns:
    copied string length.
  • int (*getParaLength)(mTextEditor*, int index, int *startPos);
    The function gets the specified paragraph length, it includes unvisible character.
    Parameters:
    index | - The index of paragraph.
    startPos(Out) | - The start byte index of paragraph.
    Returns:
    length of specified paragraph on success, otherwise return -1.
  • int (*getParaNum)(mTextEditor*);
    The function gets the total number of paragraphs.

  • int (*setText)(mTextEditor*, const char* text);
    The function sets new text content.
    Parameters:
    text - the new text.
    Returns:
    length has been setted, otherwise return -1.
  • int (*insertText)(mTextEditor*, const char* text, int len);
    The function inserts the specified text to current caret position.

  • int (*getText)(mTextEditor*, char* text, int len);
    The function gets the specifed length of content to specified buffer.

  • int (*getTextLen)(mTextEditor*);
    The function gets the content length.

  • BOOL (*enableCaret)(mTextEditor*, BOOL enable);
    The function enables or disables caret.

  • int (*setCaretPosByPara)(mTextEditor*, int paraIdx, int offChar, BOOL isSel);
    The function sets caret position by paragraph information.
    Parameters:
    paraIdx | - The index of paragraph.
    offChar | - The offset of character.
    isSel | - Whether is selected or not.
    Returns:
    the byte index of specified caret on success, otherwise return -1.
  • int (*getCaretParaPos)(mTextEditor*, int *paraIdx, int *offChar, int *height, BOOL isSel);
    The function gets the current caret paragraph information.
    Parameters:
    paraIdx(Out) | - The index of paragraph.
    offChar(Out) | - The offset of character.
    height(Out) | - The height of caret.
    isSel(In) | - Whether is selected or not.
    Returns:
    the character index in current caret position on success, otherwise return -1.
  • int (*setCaretPosByLine)(mTextEditor*, int lineIdx, int offChar, BOOL isSel);
    The function sets caret position according line information.
    Parameters:
    lineIdx | - The index of line.
    offChar | - The offset of character.
    isSel | - Whether is selected or not.
    Returns:
    the character index in current caret position on success, otherwise return -1.
  • int (*getLineCount)(mTextEditor*);
    The function gets the number of text lines.

  • void (*selectAll)(mTextEditor*);
    The function selects all content.

  • int (*getSel)(mTextEditor*, char *buffer, int len);
    The function gets selected string to user-defined text buffer.
    Parameters:
    buffer | - The pointer to the string buffer.
    len | - The length of buffer.
    Returns:
    length has been copied to string buffer on success, otherwise return -1.
  • int (*setSel)(mTextEditor*, unsigned int startParaIdx, unsigned int startOffChar, \ unsigned int endParaIdx, unsigned int endOffChar);
    The function sets selected region according to specified position information.
    Parameters:
    startParaIdx | The start index of paragraph.
    startOffChar | The start offset of character.
    endParaIdx | The end index of paragraph.
    endOffChar | The end offset of character.
    Returns:
    zero on success, otherwise return -1.
The documentation for this struct was generated from the following file:
  • mtextedit.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mTimer

mTimer

Data Structures

  • struct mTimerClass
    the class of Timer object More...
  • struct mTimer
    the timer member define More...

Defines

  • #define NCSCTRL_TIMER NCSCLASSNAME("timer")
    the class name of mTimer

Typedefs

  • typedef BOOL(* NCS_CB_ONTIMER )(mTimer *timer, DWORD total_count)
    the callback of event MSG_TIMER

Enumerations

  • enum ncsTimerProp { NCSP_TIMER_INTERVAL = NCSP_IVCMPT_MAX + 1 }
    the mTimer's property define More...

Variables

  • MGNCS_EXPORT mTimerClass g_stmTimerCls
    the singleton of mTimerClass

Define Documentation

#define NCSCTRL_TIMER NCSCLASSNAME("timer")

the class name of mTimer

Definition at line 32 of file mtimer.h.

Typedef Documentation

BOOL(* NCS_CB_ONTIMER)(mTimer *timer, DWORD total_count)

the callback of event MSG_TIMER

Parameters:
timer | the sender of timer
total_count | the total tick count from timer started
Returns:
TRUE - continue timer, FALSE - stop the timer

Definition at line 112 of file mtimer.h.

Enumeration Type Documentation

enum ncsTimerProp

the mTimer's property define

Enumerator:
NCSP_TIMER_INTERVAL the interval of timer
  • Type : DWORD
  • ReadWrite
  • Restart the timer when set it

Definition at line 91 of file mtimer.h.

Variable Documentation

g_stmTimerCls

the singleton of mTimerClass

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mTimerClass Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mTimerClass Struct Reference
[mTimer]

the class of Timer object More...

#include <mtimer.h>

Detailed Description

the class of Timer object

  • BOOL start (mTimer * self);
    Start the timer
    Parameters:
    self - the this pointer
    Returns:
    TRUE - timer started sucess, FALSE - failed
  • void stop (mTimer * self);
    Parameters:
    self - the this pointer
  • HWND getParent (mTimer * self);
    Get the handle of window who owner this timer
    Parameters:
    self - the this pointer
    Returns:
    the owner's handle
The documentation for this struct was generated from the following file:
  • mtimer.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mTimer Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mTimer Struct Reference
[mTimer]

the timer member define More...

#include <mtimer.h>

Detailed Description

the timer member define

  • DWORD interval - the interval of timer

See also:
mInvsbComp, mTimerClass
The documentation for this struct was generated from the following file:
  • mtimer.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mToolBar

mToolBar

Data Structures

  • struct mToolBar
    ToolBar class, derived from mWidget. More...
  • struct mToolBarClass
    struct of ToolBar control, derived from mWidgetClass More...
  • struct mToolBarRenderer
    ToolBar class renderer interface, derived from mWidgetRenderer. More...

Defines

  • #define NCSCTRL_TOOLBAR NCSCLASSNAME("toolbar")
    the name of mToolBar
  • #define NCSS_TLBAR_SHIFT (NCSS_WIDGET_SHIFT + 1)
    static shift

Enumerations

  • enum mToolBarProp
    the properties id of mToolBar More...
  • enum enumToolBarNotify { NCSN_TLBAR_ITEMCHAGED = NCSN_WIDGET_MAX + 1 }
    the notification code of mToolBar More...

Define Documentation

#define NCSCTRL_TOOLBAR NCSCLASSNAME("toolbar")

the name of mToolBar

Definition at line 21 of file mtoolbar.h.

#define NCSS_TLBAR_SHIFT (NCSS_WIDGET_SHIFT + 1)

static shift

Definition at line 120 of file mtoolbar.h.

Enumeration Type Documentation

enum enumToolBarNotify

the notification code of mToolBar

Enumerator:
NCSN_TLBAR_ITEMCHAGED when a item changed

Definition at line 126 of file mtoolbar.h.

enum mToolBarProp

the properties id of mToolBar

Definition at line 111 of file mtoolbar.h.

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mToolBar Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mToolBar Struct Reference
[mToolBar]

ToolBar class, derived from mWidget. More...

#include <mtoolbar.h>

Detailed Description

ToolBar class, derived from mWidget.
The documentation for this struct was generated from the following file:
  • mtoolbar.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mToolBarClass Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mToolBarClass Struct Reference
[mToolBar]

struct of ToolBar control, derived from mWidgetClass More...

#include <mtoolbar.h>

Detailed Description

struct of ToolBar control, derived from mWidgetClass

  • BOOL addItem(mToolBar *self, void * item, int type, int min_size, int max_size);
    add an toolitem into toolbar
    Parameters:
    item - the toolitem pointer, create by
    • ncsCreatePushToolItem
    • ncsCreateSeparatorItem
    • ncsCreateMenuToolItem
    • ncsCreateCheckToolItem
    • ncsCreateWidgetToolItem
    type | - the indicate the size type of the toolitem, 0 - fixed, 1 - the size is auto resize
    min_size | - the min size of toolitem, when type == 1
    max_size | - the max size of toolitem, when type == 1
    Returns:
    Sucessed or failed
  • int isItemChecked(mToolBar *self, int id);
    get the check state of a item
    Parameters:
    id - the id of toolitem
    Returns:
    the check state of toolitem
    • NCS_TOOLITEM_CHECKED
    • NCS_TOOLITEM_UNCHECKED
  • int checkItem(mToolBar*self, int id, int state);
    set the check state of a item
    Parameters:
    id | - the id of toolitem
    state | - the new state of toolitem
    Returns:
    old state
The documentation for this struct was generated from the following file:
  • mtoolbar.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mToolBarRenderer Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mToolBarRenderer Struct Reference
[mToolBar]

ToolBar class renderer interface, derived from mWidgetRenderer. More...

#include <mtoolbar.h>

Detailed Description

ToolBar class renderer interface, derived from mWidgetRenderer.
The documentation for this struct was generated from the following file:
  • mtoolbar.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mToolItem

mToolItem

Defines

  • #define NCS_TOOLITEM_FLAG_TEXT_LEFT 0x01
    indicate that create a tool item whoes text at left. default is in the right
  • #define NCS_TOOLITEM_FLAG_TEXT_UP NCS_TOOLITEM_FLAG_TEXT_LEFT
    indicate that create a tool item whoes text at up
  • #define NCS_TOOLITEM_FLAG_VERT 0x02
    indicate that create a tool item whoes text and image arranged vertically
  • #define NCS_TOOLITEM_UNCHECKED 0x00
    tool item state unckecked
  • #define NCS_TOOLITEM_CHECKED 0x01
    tool item state checked

Enumerations

  • enum mToolItemType
    define the type of toolitem More...
  • enum mToolItemEvent { NCSN_TOOLITEM_CLICKED = 1, NCSN_TOOLITEM_PUSHED, NCSN_TOOLITEM_SHOWMENU, NCSN_TOOLITEM_STATE_CHANGED }
    define the event code of tool item More...

Functions

  • MGNCS_EXPORT mToolImage * ncsNewToolImage (PBITMAP pbmp, int cell_count, BOOL autoUnload, BOOL bVert)
    create a tool image for tool item
  • MGNCS_EXPORT mToolImage * ncsNewToolImageFromFile (const char *fileName, int cell_count, BOOL autoUnload, BOOL bVert)
    create a tool image from file,
  • MGNCS_EXPORT void ncsFreeToolImage (mToolImage *mti)
    free the toolimage
  • MGNCS_EXPORT BOOL ncsDrawToolImageCell (mToolImage *mti, HDC hdc, int idx, const RECT *prc)
    draw a sub image from toolimage to hdc
  • MGNCS_EXPORT void * ncsCreatePushToolItem (int id, mToolImage *img, const char *str, UINT flags)
    create push tool item. a push tool item like a push button
  • MGNCS_EXPORT BOOL ncsInitToolItems (void)
    initialize tool items
  • MGNCS_EXPORT void * ncsCreateMenuToolItem (int id, mToolImage *img, const char *str, UINT flags, mPopMenuMgr *menu)
    create mnue tool item, like a mMenuButton
  • MGNCS_EXPORT void * ncsCreateCheckToolItem (int id, mToolImage *img, const char *str, UINT flags, int state)
    create a check able tool item, like mCheckButton
  • MGNCS_EXPORT void * ncsCreateRadioToolItem (int id, mToolImage *img, const char *str, UINT flags)
    create a check able tool item, like mRadioButton
  • MGNCS_EXPORT void * ncsCreateWidgetToolItem (mWidget *widget)
    create a toolitem which include a mWidget object
  • MGNCS_EXPORT void * ncsCreateSeparatorItem (void)
    create separator item
  • MGNCS_EXPORT int ncsGetToolItemType (void *toolitem)
    get the type of item
  • MGNCS_EXPORT BOOL ncsIsPushToolItem (void *toolitem)
    check the toolitem is push item or not
  • MGNCS_EXPORT BOOL ncsIsMenuToolItem (void *toolitem)
    check the toolitem is menu tool item or not
  • MGNCS_EXPORT BOOL ncsIsSeparatorToolItem (void *toolitem)
    check the toolitem is separator tool item or not
  • MGNCS_EXPORT BOOL ncsIsWidgetToolItem (void *toolitem)
    check the toolitem is widget tool item or not
  • MGNCS_EXPORT int ncsToolItem_getId (void *self)
    get the id of toolitem
  • MGNCS_EXPORT int ncsToolItem_setId (void *self, int id)
    get the id of toolitem
  • MGNCS_EXPORT BOOL ncsToolItem_setCheck (void *self, int check_state)
    set the check state of toolitem
  • MGNCS_EXPORT int ncsToolItem_getCheck (void *self)
    get the check state of toolitem
  • MGNCS_EXPORT BOOL ncsToolItem_showMenu (void *self, mObject *owner)
    show the menu of MenuToolItem
  • MGNCS_EXPORT mObject * ncsNewToolItem (int id, mObjectClass *_class, DWORD param)
    new a tool item object
  • MGNCS_EXPORT void ncsFreeToolItem (mObject *obj)
    free the tool item object

Define Documentation

#define NCS_TOOLITEM_CHECKED 0x01

tool item state checked

Definition at line 178 of file mtoolitem.h.

#define NCS_TOOLITEM_FLAG_TEXT_LEFT 0x01

indicate that create a tool item whoes text at left. default is in the right

Definition at line 110 of file mtoolitem.h.

#define NCS_TOOLITEM_FLAG_TEXT_UP NCS_TOOLITEM_FLAG_TEXT_LEFT

indicate that create a tool item whoes text at up

Note:
must combine with NCS_TOOLITEM_FLAG_VERT

Definition at line 116 of file mtoolitem.h.

#define NCS_TOOLITEM_FLAG_VERT 0x02

indicate that create a tool item whoes text and image arranged vertically

Definition at line 121 of file mtoolitem.h.

#define NCS_TOOLITEM_UNCHECKED 0x00

tool item state unckecked

Definition at line 173 of file mtoolitem.h.

Enumeration Type Documentation

enum mToolItemEvent

define the event code of tool item

Enumerator:
NCSN_TOOLITEM_CLICKED | When a tool item is checked
NCSN_TOOLITEM_PUSHED | When a tool item is pushed
NCSN_TOOLITEM_SHOWMENU | When a tool item want show a menu
NCSN_TOOLITEM_STATE_CHANGED | When a tool item has changed its state

Definition at line 87 of file mtoolitem.h.

enum mToolItemType

define the type of toolitem

Definition at line 25 of file mtoolitem.h.

Function Documentation

void * ncsCreateCheckToolItem | ( | int | id,
 |  | mToolImage * | img,
 |  | const char * | str,
 |  | UINT | flags,
 |  | int | state
 | ) |  |

create a check able tool item, like mCheckButton

Parameters:
id | - the id of toolitem
img | - the mToolItem image used by this item
str | - the text of tool item, can be NULL
flags - the flags of tool item,
  • NCS_TOOLITEM_FLAG_TEXT_LEFT
  • NCS_TOOLITEM_FLAG_TEXT_UP
  • NCS_TOOLITEM_FLAG_VERT
state | - the state of tool item
Returns:
the object pointer

void * ncsCreateMenuToolItem | ( | int | id,
 |  | mToolImage * | img,
 |  | const char * | str,
 |  | UINT | flags,
 |  | mPopMenuMgr * | menu
 | ) |  |

create mnue tool item, like a mMenuButton

Parameters:
id | - the id of toolitem
img | - the mToolItem image used by this item
str | - the text of tool item, can be NULL
flags - the flags of tool item,
  • NCS_TOOLITEM_FLAG_TEXT_LEFT
  • NCS_TOOLITEM_FLAG_TEXT_UP
  • NCS_TOOLITEM_FLAG_VERT
menu | - the popmenu pointer
See also:
mPopMenuMgr
Returns:
the object pointer

void * ncsCreatePushToolItem | ( | int | id,
 |  | mToolImage * | img,
 |  | const char * | str,
 |  | UINT | flags
 | ) |  |

create push tool item. a push tool item like a push button

Parameters:
id | - the id of toolitem
img | - the mToolItem image used by this item
str | - the text of tool item, can be NULL
flags - the flags of tool item,
  • NCS_TOOLITEM_FLAG_TEXT_LEFT
  • NCS_TOOLITEM_FLAG_TEXT_UP
  • NCS_TOOLITEM_FLAG_VERT
Returns:
the object pointer

void * ncsCreateRadioToolItem | ( | int | id,
 |  | mToolImage * | img,
 |  | const char * | str,
 |  | UINT | flags
 | ) |  |

create a check able tool item, like mRadioButton

Parameters:
id | - the id of toolitem
img | - the mToolItem image used by this item
str | - the text of tool item, can be NULL
flags - the flags of tool item,
  • NCS_TOOLITEM_FLAG_TEXT_LEFT
  • NCS_TOOLITEM_FLAG_TEXT_UP
  • NCS_TOOLITEM_FLAG_VERT
Returns:
the object pointer
Note:
RadioToolItem auto group between two SeparatorItem

void * ncsCreateSeparatorItem ( void )

create separator item

Returns:
the object pointer

void * ncsCreateWidgetToolItem ( mWidget * widget )

create a toolitem which include a mWidget object

Parameters:
widget the widget object, its parant must be a mToolBar
Returns:
the object pointer

BOOL ncsDrawToolImageCell | ( | mToolImage * | mti,
 |  | HDC | hdc,
 |  | int | idx,
 |  | const RECT * | prc
 | ) |  |

draw a sub image from toolimage to hdc

Parameters:
mti | - the mToolImage object
hdc | - the destination dc handle
idx | - the index of sub image
prc | - the area to draw bitmap

void ncsFreeToolImage ( mToolImage * mti )

free the toolimage

void ncsFreeToolItem ( mObject * obj )

free the tool item object

Parameters:
obj -- the object want to free
Returns:
void

int ncsGetToolItemType ( void * toolitem )

get the type of item

Parameters:
toolitem - the pointer of toolitem
Returns:
the type of tool item
See also:
mToolItemType

BOOL ncsInitToolItems ( void )

initialize tool items

BOOL ncsIsMenuToolItem ( void * toolitem )

check the toolitem is menu tool item or not

Parameters:
toolitem - the pointer of toolitem
Returns:
TRUE or FALSE

BOOL ncsIsPushToolItem ( void * toolitem )

check the toolitem is push item or not

Parameters:
toolitem - the pointer of toolitem
Returns:
TRUE or FALSE

BOOL ncsIsSeparatorToolItem ( void * toolitem )

check the toolitem is separator tool item or not

Parameters:
toolitem - the pointer of toolitem
Returns:
TRUE or FALSE

BOOL ncsIsWidgetToolItem ( void * toolitem )

check the toolitem is widget tool item or not

Parameters:
toolitem - the pointer of toolitem
Returns:
TRUE or FALSE

mToolImage * ncsNewToolImage | ( | PBITMAP | pbmp,
 |  | int | cell_count,
 |  | BOOL | autoUnload,
 |  | BOOL | bVert
 | ) |  |

create a tool image for tool item

Parameters:
pbmp | - the bitmap pointer used by toolitem
cell_count | - the count of sub bitmaps in the pbmp
autoUnload | - unload the pbmp when toolimage is deleted
bVert | - the sub bitmaps is arranged vertically
Returns:
a mToolIamge object

mToolImage * ncsNewToolImageFromFile | ( | const char * | fileName,
 |  | int | cell_count,
 |  | BOOL | autoUnload,
 |  | BOOL | bVert
 | ) |  |

create a tool image from file,

See also:
ncsNewToolImage
Parameters:
fileName | - the image file name
cell_count | - the count of sub bitmaps in the pbmp
autoUnload | - unload the pbmp when toolimage is deleted
bVert | - the sub bitmaps is arranged vertically
Returns:
a mToolIamge object

mObject * ncsNewToolItem | ( | int | id,
 |  | mObjectClass * | _class,
 |  | DWORD | param
 | ) |  |

new a tool item object

Parameters:
id | -- the id of toolid
_class | -- the class of toolitem implememnted, should be a mHotPiece class
param | -- the construct param of class
Returns:
return a new item

int ncsToolItem_getCheck ( void * self )

get the check state of toolitem

Parameters:
self - the toolitem pointer
Returns:
check state

int ncsToolItem_getId ( void * self )

get the id of toolitem

Parameters:
self - the toolitem pointer
Returns:
id of toolitem

BOOL ncsToolItem_setCheck | ( | void * | self,
 |  | int | check_state
 | ) |  |

set the check state of toolitem

Parameters:
self | - the toolitem pointer
check_state | - the state of check
Returns:
TRUE or FALSE

int ncsToolItem_setId | ( | void * | self,
 |  | int | id
 | ) |  |

get the id of toolitem

Parameters:
self | - the toolitem pointer
id | - the new id of toolitem
Returns:
old id of toolitem

BOOL ncsToolItem_showMenu | ( | void * | self,
 |  | mObject * | owner
 | ) |  |

show the menu of MenuToolItem

Parameters:
self | - the pointer of Menu Tool Item
owner | - the owner of the menu
Returns:
TRUE or FALSE

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mTrackBar

mTrackBar

Data Structures

  • struct mTrackBar
    the TrackBar struct of TrackBar control, derived from mSlider. More...
  • struct mTrackBarClass
    the VTable of mTrackBar, derived from mSliderClass. More...
  • struct mTrackBarRenderer
    TrackBar class's Renderer interface, derived from mSliderRenderer. More...

Defines

  • #define NCSP_TRKBAR_MAXPOS NCSP_SLIDER_MAXPOS
    The value of the maximum position.
  • #define NCSP_TRKBAR_MINPOS NCSP_SLIDER_MINPOS
    The value of the minimum position.
  • #define NCSP_TRKBAR_CURPOS NCSP_SLIDER_CURPOS
    The value of the current position.
  • #define NCSP_TRKBAR_LINESTEP NCSP_SLIDER_LINESTEP
    The line step length.
  • #define NCSP_TRKBAR_PAGESTEP NCSP_SLIDER_PAGESTEP
    The page step length.
  • #define NCSS_TRKBAR_HORIZONTAL NCSS_SLIDER_HORIZONTAL
    horizontal TrackBar.
  • #define NCSS_TRKBAR_VERTICAL NCSS_SLIDER_VERTICAL
    vertical TrackBar.
  • #define NCSS_TRKBAR_NOTICK (0x0001L<<NCSS_SLIDER_SHIFT)
    TrackBar without tick.
  • #define NCSN_TRKBAR_CHANGED NCSN_SLIDER_CHANGED
    positon changed notify code.
  • #define NCSN_TRKBAR_REACHMAX NCSN_SLIDER_REACHMAX
    reached the maximum position notify code.
  • #define NCSN_TRKBAR_REACHMIN NCSN_SLIDER_REACHMIN
    reached the minimum position notify code.

Enumerations

  • enum mTrackBarProp { NCSP_TRKBAR_THUMB_WIDTH = NCSP_SLIDER_MAX + 1, NCSP_TRKBAR_THUMB_HEIGHT, NCSP_TRKBAR_MAX }
    The properties of mTrackBar. More...

Variables

  • MGNCS_EXPORT mTrackBarClass g_stmTrackBarCls
    the instance of mTrackBarClass

Define Documentation

#define NCSN_TRKBAR_CHANGED NCSN_SLIDER_CHANGED

positon changed notify code.

Definition at line 180 of file mtrackbar.h.

#define NCSN_TRKBAR_REACHMAX NCSN_SLIDER_REACHMAX

reached the maximum position notify code.

Definition at line 186 of file mtrackbar.h.

#define NCSN_TRKBAR_REACHMIN NCSN_SLIDER_REACHMIN

reached the minimum position notify code.

Definition at line 192 of file mtrackbar.h.

#define NCSP_TRKBAR_CURPOS NCSP_SLIDER_CURPOS

The value of the current position.

Definition at line 118 of file mtrackbar.h.

#define NCSP_TRKBAR_LINESTEP NCSP_SLIDER_LINESTEP

The line step length.

Definition at line 123 of file mtrackbar.h.

#define NCSP_TRKBAR_MAXPOS NCSP_SLIDER_MAXPOS

The value of the maximum position.

Definition at line 108 of file mtrackbar.h.

#define NCSP_TRKBAR_MINPOS NCSP_SLIDER_MINPOS

The value of the minimum position.

Definition at line 113 of file mtrackbar.h.

#define NCSP_TRKBAR_PAGESTEP NCSP_SLIDER_PAGESTEP

The page step length.

Definition at line 128 of file mtrackbar.h.

#define NCSS_TRKBAR_HORIZONTAL NCSS_SLIDER_HORIZONTAL

horizontal TrackBar.

Definition at line 160 of file mtrackbar.h.

#define NCSS_TRKBAR_NOTICK (0x0001L<<NCSS_SLIDER_SHIFT)

TrackBar without tick.

Definition at line 172 of file mtrackbar.h.

#define NCSS_TRKBAR_VERTICAL NCSS_SLIDER_VERTICAL

vertical TrackBar.

Definition at line 166 of file mtrackbar.h.

Enumeration Type Documentation

enum mTrackBarProp

The properties of mTrackBar.

Enumerator:
NCSP_TRKBAR_THUMB_WIDTH the width of thumb

NCSP_TRKBAR_THUMB_HEIGHT the height of thumb

NCSP_TRKBAR_MAX The maximum value of mTrackBar properties.

Definition at line 134 of file mtrackbar.h.

Variable Documentation

g_stmTrackBarCls

the instance of mTrackBarClass

See also:
mTrackBarClass

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mTrackBar Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mTrackBar Struct Reference
[mTrackBar]

the TrackBar struct of TrackBar control, derived from mSlider. More...

#include <mtrackbar.h>

Detailed Description

the TrackBar struct of TrackBar control, derived from mSlider.

See also:
mTrackBarRenderer, mTrackBarClass
The documentation for this struct was generated from the following file:
  • mtrackbar.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mTrackBarClass Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mTrackBarClass Struct Reference
[mTrackBar]

the VTable of mTrackBar, derived from mSliderClass. More...

#include <mtrackbar.h>

Detailed Description

the VTable of mTrackBar, derived from mSliderClass.

See also:
mSliderClass
The documentation for this struct was generated from the following file:
  • mtrackbar.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mTrackBarRenderer Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mTrackBarRenderer Struct Reference
[mTrackBar]

TrackBar class's Renderer interface, derived from mSliderRenderer. More...

#include <mtrackbar.h>

Detailed Description

TrackBar class's Renderer interface, derived from mSliderRenderer.

See also:
mTrackBar, mTrackBarClass
The documentation for this struct was generated from the following file:
  • mtrackbar.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mWidget

mWidget

Data Structures

  • struct mWidgetRenderer
    Widget class's Renderer interface. More...
  • struct mWidget
    define the mWidget members, inherit from mComponent More...
  • struct mWidgetClass
    the VTable of mWidget, drived from mComponentClass More...

Defines

  • #define NCSCTRL_WIDGET NCSCLASSNAME("widget")
    the name of widget control
  • #define NCSR_CONTINUE_MSG FALSE
    return value, pass the message to the default window process
  • #define NCSR_STOP_MSG TRUE
    return value, return directly, don't pass the message to default window process
  • #define NCS_NOTIFY_CODE(code) (0xFFFF0000 | (code))
  • #define NCS_MAP_NOTIFY(code, handler) { NCS_NOTIFY_CODE(code), (void*)(handler) }

Typedefs

  • typedef struct _NCS_WND_TEMPLATE NCS_WND_TEMPLATE
  • typedef void(* NCS_CB_ONNCCREATE )(mWidget *)
    the Callback of Event MSG_NCCREATE, which is the first message of a control
  • typedef BOOL(* NCS_CB_ONCREATE )(mWidget *, DWORD dwAddData)
    the callback of event MSG_CREATE
  • typedef BOOL(* NCS_CB_ONINITDLG )(mWidget *, HWND hFocus, DWORD dwAddData)
    the callback of event MSG_INITDIALOG, only valid in mDialogBox, when a dialog is created
  • typedef BOOL(* NCS_CB_ONVOID )(mWidget *, int message)
    the callback of events MSG_ACTIVE MSG_FONTCHANGED MSG_KEYLONGPRESS MSG_KEYALWAYSPRESS MSG_DESTROY
  • typedef void(* NCS_CB_ONSZCHGING )(mWidget *, const PRECT prcExpect, PRECT prcResult)
    the callback of event MSG_SIZECHANGING, when a widget's bound is changing. If you want change the widget bounds, set the prcResult, by default, copy prcExpect to prcResult
  • typedef BOOL(* NCS_CB_ONSZCHGED )(mWidget *, PRECT prcClient)
    the callback of event MSG_SIZECHANGED
  • typedef void(* NCS_CB_ONCSZCHGED )(mWidget *, int clientWidth, int clientHeight)
    the callbace of event MSG_CSIZECHANGED
  • typedef BOOL(* NCS_CB_ONFONTCHGING )(mWidget *, PLOGFONT logFont)
    the callback of event MSG_FONTCHANGING
  • typedef BOOL(* NCS_CB_ONERASEBKGND )(mWidget *, HDC hdc, const PRECT clip)
    the callback of event MSG_ERASEBKGND
  • typedef void(* NCS_CB_ONPAINT )(mWidget *, HDC hdc, const PCLIPRGN clipRgn)
    the callback of event MSG_PAINT
  • typedef BOOL(* NCS_CB_ONCLOSE )(mWidget *)
    the callback of event MSG_CLOSE
  • typedef BOOL(* NCS_CB_ONKEY )(mWidget *, int message, int code, DWORD keyStatus)
    the callback of event MSG_KEYDOWN MSG_KEYUP MSG_CHAR MSG_SYSKEYDOWN MSG_SYSKEYUP MSG_SYSCHAR
  • typedef BOOL(* NCS_CB_ONMOUSE )(mWidget *, int message, int x, int y, DWORD keyStatus)
    the callback of events MSG_LBUTTONDOWN MSG_LBUTTONUP MSG_LBUTTONDBCLK MSG_MOUSEMOVE MSG_RBUTTONDOWN MSG_RBUTTONUP MSG_RBUTTONDBCLK
  • typedef BOOL(* NCS_CB_ONNCMOUSE )(mWidget *, int message, int x, int y, int hitCode)
    the callback of events MSG_NCLBUTTONDOWN MSG_NCLBUTTONUP MSG_NCLBUTTONDBCLK MSG_NCMOUSEMOVE MSG_NCRBUTTONDOWN MSG_NCRBUTTONUP MSG_NCRBUTTONDBCLK
  • typedef int(* NCS_CB_ONHITTEST )(mWidget *, int message, int x, int y)
    the callback of events MSG_HITTEST MSG_NCHITTEST
  • typedef void(* NCS_CB_ONSCROLL )(mWidget *, int message, int code, int pos)
    the callback of events MSG_HSCROLL , MSG_VSCROLL
  • typedef BOOL(* NCS_CB_ONCMD )(mWidget *, int id, int nc, HWND hCtrl)
    the callback of event MSG_COMMAND
  • typedef void(* NCS_CB_WIDGET_ONTIMER )(mWidget *, int id, DWORD count)
    the callback of event MSG_TIMER
  • typedef int(* NCS_CB_ONMSG )(mWidget *, int message, WPARAM wParam, LPARAM lParam)
    the callback of a common message event
  • typedef void(* NCS_CB_NOTIFY )(mWidget *, int id, int ncCode, DWORD addData)
    the callback of all notification event

Enumerations

  • enum ncsRendererState {
    NCSRS_NORMAL = 0x00, NCSRS_HIGHLIGHT = 0x01, NCSRS_SIGNIFICANT = 0x02, NCSRS_SELECTED = 0x04,
    NCSRS_HALFSELECTED = 0x10, NCSRS_DISABLE = 0x08
    }
    define the renderer state of widget More...
  • enum ncsRendererFlag { NCSRF_INNERFRAME = 0x010000, NCSRF_FILL = 0x020000, NCSRF_FRAME = 0x040000 }
    the flag defines of renderer More...
  • enum ncsRDRArrow { NCSR_ARROW_LEFT = 0, NCSR_ARROW_RIGHT, NCSR_ARROW_UP, NCSR_ARROW_DOWN }
    the arrow define of renderer More...
  • enum mWidgetProp {
    NCSP_WIDGET_RDR = 1, NCSP_WIDGET_TEXT, NCSP_WIDGET_BKIMAGE, NCSP_WIDGET_BKIMAGE_MODE,
    NCSP_WIDGET_BKIMAGE_FILE
    }
    the properties id of mWidget More...
  • enum mWidgetNotify { NCSN_WIDGET_CLICKED = 1, NCSN_WIDGET_DBCLICKED, NCSN_WIDGET_ENABLED, NCSN_WIDGET_DISABLED }
    the notification code of mWidget More...

Functions

  • void mWidget_captureHotPiece (mWidget *self, mObject *hotpice)

Variables

  • MGNCS_EXPORT mWidgetClass g_stmWidgetCls
    the instance of mWigetClass

Define Documentation

#define NCS_MAP_NOTIFY | ( | code,
 |  | handler | ) | { NCS_NOTIFY_CODE(code), (void*)(handler) }

Map a notification event into a handler

Definition at line 743 of file mwidget.h.

#define NCS_NOTIFY_CODE ( code ) (0xFFFF0000 | (code))

Add a speical flags into a notification code, so that the NCS can distinguish notification events from message events

Definition at line 738 of file mwidget.h.

#define NCSCTRL_WIDGET NCSCLASSNAME("widget")

the name of widget control

Definition at line 46 of file mwidget.h.

#define NCSR_CONTINUE_MSG FALSE

return value, pass the message to the default window process

See also:
NCSR_STOP_MSG

Definition at line 471 of file mwidget.h.

#define NCSR_STOP_MSG TRUE

return value, return directly, don't pass the message to default window process

See also:
NCSR_CONTINUE_MSG

Definition at line 479 of file mwidget.h.

Typedef Documentation

void(* NCS_CB_NOTIFY)(mWidget *, int id, int ncCode, DWORD param)

the callback of all notification event

Parameters:
mWidget | * the sender pointer
ncCode | the notification code of event
param | the param of notify message

Definition at line 730 of file mwidget.h.

BOOL(* NCS_CB_ONCLOSE)(mWidget *)

the callback of event MSG_CLOSE

Parameters:
mWidget* the sender pointer
Returns:
NCSR_CONTINUE_MSG, NCSR_STOP_MSG

Definition at line 619 of file mwidget.h.

BOOL(* NCS_CB_ONCMD)(mWidget *, int id, int nc, HWND hCtrl)

the callback of event MSG_COMMAND

Parameters:
mWidget* | the sender pointer
id | the child(control or menuitem) id
nc | the notification code of child
hCtrl | the child's handle ( or 0 if child is a menuitem)
Returns:
NCSR_CONTINUE_MSG, NCSR_STOP_MSG

Definition at line 698 of file mwidget.h.

BOOL(* NCS_CB_ONCREATE)(mWidget *, DWORD dwAddData)

the callback of event MSG_CREATE

Parameters:
mWidget | * the event sender's pointer
dwAddData | the additional data when create this window, passed by ncscreatewindow, ncscreatewindowindirect, ncscreatemainwindow ncscreatemainwindowindirect
Returns:
True - allow NCS create control continue; FALSE - abort the creating
See also:
ncsCreateWindow, ncsCreateWindowIndirect, ncsCreateMainWindow, ncsCreateMainWindowIndirect

Definition at line 507 of file mwidget.h.

void(* NCS_CB_ONCSZCHGED)(mWidget *, int clientWidth, int clientHeight)

the callbace of event MSG_CSIZECHANGED

This is the last message when changing a widget bounds

Parameters:
mWidget | * sender pointer
clientWidth | the new width of sender's client
clientHeight | the new height of sender's client

Definition at line 574 of file mwidget.h.

BOOL(* NCS_CB_ONERASEBKGND)(mWidget *, HDC hdc, const PRECT clip)

the callback of event MSG_ERASEBKGND

Parameters:
mWidget | * the sender pointer
hdc | the DC of background, hdc may be 0, so you shoud check it, and call GetClientDC or GetDC when hdc == 0
clip | the area should to be erased. clip may be equal NULL, so, call GetWindowRect, or GetClientRect when clip == NULL
Returns:
NCSR_CONTINUE_MSG, NCSR_STOP_MSG

Definition at line 600 of file mwidget.h.

BOOL(* NCS_CB_ONFONTCHGING)(mWidget *, PLOGFONT logFont)

the callback of event MSG_FONTCHANGING

This event is called when SetWindowFont is called

Parameters:
mWidget | * then sender pointer
logFont | the logic font would be set to sender
Returns:
TRUE - tell the SetWindowFont continue set the font, FALSE - abort SetWindowFont

Definition at line 587 of file mwidget.h.

int(* NCS_CB_ONHITTEST)(mWidget *, int message, int x, int y)

the callback of events MSG_HITTEST MSG_NCHITTEST

Parameters:
mWidget | * the sender pointer
message | the event code
x | the x-coordinate of hit point
y | the y-coordinate of hit point
Returns:
int hit code

Definition at line 675 of file mwidget.h.

BOOL(* NCS_CB_ONINITDLG)(mWidget *, HWND hFocus, DWORD dwAddData)

the callback of event MSG_INITDIALOG, only valid in mDialogBox, when a dialog is created

Parameters:
mWidget | * the sender pointer of event
hFocus | the focus window when dialog is created
dwAddData | the additional data passed by ncscreatewindow, ncscreatewindowindirect, ncscreatemainwindow ncscreatemainwindowindirect
Returns:
True - allow dialog continue; FALSE - abort the dialog
See also:
ncsCreateWindow, ncsCreateWindowIndirect, ncsCreateMainWindow, ncsCreateMainWindowIndirect

Definition at line 522 of file mwidget.h.

BOOL(* NCS_CB_ONKEY)(mWidget *, int message, int code, DWORD keyStatus)

the callback of event MSG_KEYDOWN MSG_KEYUP MSG_CHAR MSG_SYSKEYDOWN MSG_SYSKEYUP MSG_SYSCHAR

Parameters:
mWidget | * the sender pointer
message | event code, distinguish the events
code | the scancode (MSG_KEYDOWN MSG_KEYUP MSG_SYSKEYDOWN MSG_SYSKEYUP) or ascii code (MSG_CHAR MSG_SYSCHAR)
keyStatus | The shift key status when this message occurred
Returns:
NCSR_CONTINUE_MSG, NCSR_STOP_MSG

Definition at line 634 of file mwidget.h.

BOOL(* NCS_CB_ONMOUSE)(mWidget *, int message, int x, int y, DWORD keyStatus)

the callback of events MSG_LBUTTONDOWN MSG_LBUTTONUP MSG_LBUTTONDBCLK MSG_MOUSEMOVE MSG_RBUTTONDOWN MSG_RBUTTONUP MSG_RBUTTONDBCLK

Parameters:
mWidget | * sender pointer
message | the event code
x | the x-coordinate of mouse
y | the y-coordinate of mouse
keyStatus | The shift key status when this message occurred.
Returns:
NCSR_CONTINUE_MSG, NCSR_STOP_MSG

Definition at line 649 of file mwidget.h.

int(* NCS_CB_ONMSG)(mWidget *, int message, WPARAM wParam, LPARAM lParam)

the callback of a common message event

Parameters:
mWidget | * sender pointer
message | the event code
wParam | the wParam of message event
lParam | the lParam of message event
Returns:
int - this value will be as the finally return value of event, and none default processing would be called

Definition at line 720 of file mwidget.h.

typedef void(* NCS_CB_ONNCCREATE)(mWidget *)

the Callback of Event MSG_NCCREATE, which is the first message of a control

Parameters:
mWidget* the event sender's pointer
Returns:
none

Definition at line 491 of file mwidget.h.

BOOL(* NCS_CB_ONNCMOUSE)(mWidget *, int message, int x, int y, int hitCode)

the callback of events MSG_NCLBUTTONDOWN MSG_NCLBUTTONUP MSG_NCLBUTTONDBCLK MSG_NCMOUSEMOVE MSG_NCRBUTTONDOWN MSG_NCRBUTTONUP MSG_NCRBUTTONDBCLK

Parameters:
mWidget | * the sender pointer
message | the event code
x | the x-coordinate of mouse
y | the y-coordinate of mouse
hitCode | the hit code
Returns:
NCSR_CONTINUE_MSG, NCSR_STOP_MSG

Definition at line 663 of file mwidget.h.

void(* NCS_CB_ONPAINT)(mWidget *, HDC hdc, const PCLIPRGN clip_rgn)

the callback of event MSG_PAINT

Parameters:
mWidget | * sender pointer
hdc | the DC for painting
clip_rgn | invlidate region

Definition at line 610 of file mwidget.h.

void(* NCS_CB_ONSCROLL)(mWidget *, int message, int code, int pos)

the callback of events MSG_HSCROLL , MSG_VSCROLL

Parameters:
mWidget | * the sender pointer
message | the event code
nc | the scrolling code, see MSG_HSCROLL and MSG_VSCROOL in MiniGUI

Definition at line 686 of file mwidget.h.

BOOL(* NCS_CB_ONSZCHGED)(mWidget *, PRECT prcClient)

the callback of event MSG_SIZECHANGED

This callback is called after a widget's bound changed if you want change the client size of the sender, reset the prcClient

Parameters:
mWidget | * the sender pointer
prcClient | IN & OUT param, the client bound of the sender
Returns:
TRUE - the prcClient is changed, FALSE - prcClient is not changed

Definition at line 561 of file mwidget.h.

void(* NCS_CB_ONSZCHGING)(mWidget *, const PRECT prcExpect, PRECT prcResult)

the callback of event MSG_SIZECHANGING, when a widget's bound is changing. If you want change the widget bounds, set the prcResult, by default, copy prcExpect to prcResult

Parameters:
mWidget | * the sender pointer
prcExpect | the excepted bound, IN param
prcResult | the resulted bound, OUT param,

Definition at line 546 of file mwidget.h.

BOOL(* NCS_CB_ONVOID)(mWidget *, int message)

the callback of events MSG_ACTIVE MSG_FONTCHANGED MSG_KEYLONGPRESS MSG_KEYALWAYSPRESS MSG_DESTROY

Parameters:
mWidget | * the pointer of sender
message | the event code, indicate the event
Returns:
NCSR_CONTINUE_MSG, NCSR_STOP_MSG except MSG_DESTROY, the return value woulbe be ignored

Definition at line 534 of file mwidget.h.

void(* NCS_CB_WIDGET_ONTIMER)(mWidget *, int id, DWORD count)

the callback of event MSG_TIMER

Parameters:
mWidget* | the sender pointer
id | the id of timer
count | the total tick count of timer

Definition at line 707 of file mwidget.h.

struct _NCS_WND_TEMPLATE NCS_WND_TEMPLATE

See also:
_NCS_WND_TEMPLATE

Definition at line 55 of file mwidget.h.

Enumeration Type Documentation

enum mWidgetNotify

the notification code of mWidget

Enumerator:
NCSN_WIDGET_CLICKED | send by a widget is cliced by left button
NCSN_WIDGET_DBCLICKED | send by a widget is double cliced by left button
NCSN_WIDGET_ENABLED | send by a widget is enabled
NCSN_WIDGET_DISABLED | send by a widget is disabled

Definition at line 435 of file mwidget.h.

enum mWidgetProp

the properties id of mWidget

Enumerator:
NCSP_WIDGET_RDR Set the renderer class name
  • Type : const char*
  • WriteOnly
  • Repaint all the control.
NCSP_WIDGET_TEXT Set the widget 's text, same as SetWindowText
  • Type : const char*
  • WritedOnly
  • Repaint the text of widget.
NCSP_WIDGET_BKIMAGE Set the widget's back image
  • Type : PBITMAP
  • ReadWirte
  • Repaint the background when set it.
NCSP_WIDGET_BKIMAGE_MODE Set the widget's back image mode
  • Type : int
    • NCS_DM_NORMAL
    • NCS_DM_SCALED
    • DrawMode_Title
  • ReadWrite
  • Repaint the background when set it.
NCSP_WIDGET_BKIMAGE_FILE Set the widget's back image from file
  • Type : const char*, file name of image
  • WriteOnly
  • Repaint the background when set it.

Note:
widget will load a PBITMAP from the file, and release it automatically

Definition at line 363 of file mwidget.h.

enum ncsRDRArrow

the arrow define of renderer

Enumerator:
NCSR_ARROW_LEFT | indiate a left arrow
NCSR_ARROW_RIGHT | indiate a right arrow
NCSR_ARROW_UP | indiate a up arrow
NCSR_ARROW_DOWN | indiate a down arrow

Definition at line 145 of file mwidget.h.

enum ncsRendererFlag

the flag defines of renderer

Enumerator:
NCSRF_INNERFRAME | indicate that draw a inner frame box or shape
NCSRF_FILL | indicate that fill a box or other shape
NCSRF_FRAME | indicate that draw a box or other shape with a frame

Definition at line 123 of file mwidget.h.

enum ncsRendererState

define the renderer state of widget

Enumerator:
NCSRS_NORMAL | normal state
NCSRS_HIGHLIGHT | higlight state
NCSRS_SIGNIFICANT | significant state
NCSRS_SELECTED | a box or item is selected
NCSRS_HALFSELECTED | half selected state
NCSRS_DISABLE | disable state

Definition at line 83 of file mwidget.h.

Function Documentation

void mWidget_captureHotPiece | ( | mWidget * | self,
 |  | mObject * | hotpice
 | ) |  |

public static function

Variable Documentation

g_stmWidgetCls

the instance of mWigetClass

See also:
mWidgetClass

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mWidgetRenderer Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mWidgetRenderer Struct Reference
[mWidget]

Widget class's Renderer interface. More...

#include <mwidget.h>

Detailed Description

Widget class's Renderer interface.

  • const char* rdr_name
    The Name of the Renderer

  • void class_init(mWidgetRenderer* rdr);
    init the the renderer class members

  • mWidgetRenderer * ptrParentClass
    Supper class pointer

  • BOOL init_self(mWidgetRenderer *rdr);
    init the prv_data for a special mWidgetRenderer object

  • void uninit_self(mWidgetRenderer *rdr);
    uninitialize the prv_data for the special mWidgetRenderer object

  • DWORD setElement(mWidgetRenderer * rdr, int id, DWORD value); set the element by id and value
    Parameters:
    id | the id of Renderer element
    value | the value of Renderer element
    Returns:
    old value or (DWORD)-1 (failed)
  • DWORD getElement(mWidgetRenderer *rdr,int id);
    get the element from renderer
    Parameters:
    id - the id of renderer element
    Returns:
    DWORD - the value of speical element
  • void * prv_data - the private data used by renderer object

  • BOOL transIdValue(mWidgetRenderer* rdr, int id, DWORD *value);
    Translate from value from use type to inner type. e.g. translate image name(const char*) into res key (RES_KEY)
    Parameters:
    id - the id of the element
    * value - in and out param, the value pointer of element
    Returns:
    BOOL - True or False
  • void drawFocusFrame(mWidget *, HWND, HDC, const RECT*);
    draw focus frame when control get focus
    Parameters:
    - handle of control
    - DC of control
    RECT * - the Rectangle to draw focus frame
  • BOOL drawBkground(mWidget * ,HWND, HDC, const RECT*)
    draw background when control erase background
    Parameters:
    - DC of background, may be 0, user should get dc by GetClientDC
    RECT* - invalidat Rectangle of background
    Returns:
    BOOL - if the background has been drawed or not
  • void draw3dbox(mWidgetRenderer* , HDC hdc, const RECT *, DWORD color DWORD flag);
    draw 3d box
    Parameters:
    hdc | - the DC in which draw 3d box
    RECT | * - the Rectange of the box
    color | - the frame color of box
    flag | - the state (ncsRendererState) and flag (ncsRendererFlag) of 3dbox
  • void drawCheckbox( mWidget *, HDC hdc, const RECT *, DWORD flag);
    draw a checkbox into a DC
    Parameters:
    hdc | - the DC in which draw checkbox
    RECT | * - the location and size of checkbox
    \b | flag - the flag of check box (ncsRendererFlag)
  • void drawRadio (mWidget *, HDC hdc, const RECT *rc, DWORD flag);
    draw a radio box into a DC
    Parameters:
    hdc | - the DC in which draw radiobox
    rc | - the location and size of radio box
    \b | flag - the flag of radiobox (ncsRendererFlag)
  • void drawArrow(mWidget *, HDC hdc, const RECT * , int arrow, DWORD color, DWORD flag);
    draw a arrow for dc
    Parameters:
    hdc
    RECT | * - the Rectangle around arrow, its size bigger than arrow
    arrow | - arrow type (ncsRDRArrow)
    color | - the filling color of arrow
    flag | - the flag of arrow (ncsRendererFlag)
  • void drawItem (mWidget*, HDC , const RECT *, DWORD color);
    draw a item
    Parameters:
    RECT | * - the Rectanle of item
    color | - the filling color of item
    See also:
    mWidget, mWidgetClass
The documentation for this struct was generated from the following file:
  • mwidget.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mWidget Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mWidget Struct Reference
[mWidget]

define the mWidget members, inherit from mComponent More...

#include <mwidget.h>

Detailed Description

define the mWidget members, inherit from mComponent

  • HWND hwnd
    The handle of Control who own this object

  • mWidgetRenderer * renderer
    The Renderer pointer of the widget

  • mComponent * comps
    the children component (mInvisibleComponent)

  • ImageDrawInfo bkimg
    The back image drawing info

See also:
mWidgetRenderer, mWidgetClass
The documentation for this struct was generated from the following file:
  • mwidget.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mWidgetClass Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

mWidgetClass Struct Reference
[mWidget]

the VTable of mWidget, drived from mComponentClass More...

#include <mwidget.h>

Detailed Description

the VTable of mWidget, drived from mComponentClass

  • DWORD dlgCode
    The Dialog Code of this widget, return When the widget recieve the message MSG_GETDLGCODE

  • int wndProc (mWidgetClass *self, int message, WPARAM wParam, LPARAM lParam);
    The Window Proc which is used to dispatch message
    Parameters:
    self | - this pointer
    message | - the code of message
    wParam | - the wparam of message
    lParam | - the lParam of message
    Returns:
    int, by message
  • BOOL callUserHandler (mWidget *self, void *handler, \ int message, WPARAM wParam, LPARAM lParam, int *pRet);
    call the user defined handlers, PRIVATE METHOD
    Parameters:
    handler | - the handler defined by user
    message | - the message processing
    wParam | - the wParam of message
    lParam | - the lParam of message
    pret | - the pointer of return code, OUT Params
    Returns:
    BOOL - continue the default processing (TRUE) or return directly (FALSE)
The documentation for this struct was generated from the following file:
  • mwidget.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: Global Component Functions

Global Component Functions
[Global defines]

Data Structures

  • struct _NCS_EVENT_HANDLER
  • struct _NCS_EVENT_CONNECT_INFO

Defines

  • #define ISCLASS(class_name, clssName) ncsIsClass((const char*)(class_name), (mComponentClass*)(&Class(clssName)))
    the wrapper of ncsIsClass, test a one component class is special one.

Functions

  • MGNCS_EXPORT void * ncsSetComponentHandler (mComponent *comp, int message, void *handler)
    set the component handler
  • MGNCS_EXPORT void ncsSetComponentHandlers (mComponent *comp, NCS_EVENT_HANDLER *handlers, int count)
    set an array of event handlers
  • MGNCS_EXPORT void * ncsGetComponentHandler (mComponent *comp, int message)
    get an event callback
  • MGNCS_EXPORT BOOL ncsComponentConnectEvents (mComponent *comps, NCS_EVENT_CONNECT_INFO *connects, int counts)
    connect the events between parent and its children, used by ncsCreateMainWindowIndirectFromID
  • MGNCS_EXPORT BOOL ncsIsClass (const char *className, mComponentClass *clss)
    check a class name is a special class type or not
  • MGNCS_EXPORT BOOL ncsIsChildClass (const char *childClassName, const char *parentClassName)
    check a class name is derived class of a special class
  • MGNCS_EXPORT BOOL ncsRegisterComponent (mComponentClass *compCls, DWORD dwStyle, DWORD dwExStyle, int idCursor, int idBkColor)
    register a component class into MiniGUI, so that ncsCreateWindow and ncsCreateWindow can find a mComponentClass instance
  • MGNCS_EXPORT mComponentClass * ncsGetComponentClass (const char *className, BOOL check)
    Get a mComponentClass instance from MiniGUI.

Define Documentation

#define ISCLASS | ( | class_name,
 |  | clssName | ) | ncsIsClass((const char*)(class_name), (mComponentClass*)(&Class(clssName)))

the wrapper of ncsIsClass, test a one component class is special one.

Note:
class_name is a string indicating the component class name, such as NCSCTRL_STATIC; the clssName is an identifier of a class, such as mStatic.
See also:
ncsIsClass

Definition at line 443 of file mcomponent.h.

Function Documentation

BOOL ncsComponentConnectEvents | ( | mComponent * | comps,
 |  | NCS_EVENT_CONNECT_INFO * | connects,
 |  | int | counts = -1
 | ) |  |

connect the events between parent and its children, used by ncsCreateMainWindowIndirectFromID

Parameters:
comps | the mComponent object pointer, it's the parent of the senders and listeners in NCS_EVENT_CONNECT_INFO
connects | the connection information array
counts | the count of connects array, if it's -1, the array must end by {0, 0, -1, NULL}
See also:
NCS_EVENT_CONNECT_INFO, ncsComponentConnectEvents

mComponentClass * ncsGetComponentClass | ( | const char * | className,
 |  | BOOL | check
 | ) |  |

Get a mComponentClass instance from MiniGUI.

Note:
the class_name must be registered into MiniGUI by calling ncsRegisterComponent
Parameters:
className | the class name to find
check | check the class name with found mComponentClass instance, to ensure that we found the right class
Returns:
the mComponentClass pointer if sucess, NULL otherwise

void * ncsGetComponentHandler | ( | mComponent * | comp,
 |  | int | message
 | ) |  |

get an event callback

Parameters:
comp
message - event code
Returns:
void * the handler of message, or NULL if not set

BOOL ncsIsChildClass | ( | const char * | childClassName,
 |  | const char * | parentClassName
 | ) |  |

check a class name is derived class of a special class

Parameters:
childClassName | - the class name to be checked, the component class name, not the typeName of mObject
parentClassName | - the class name expected as child class's ancestor, the component class name, not the typeName of mObject
Returns:
TRUE - check sucess, FALSE -failed

BOOL ncsIsClass | ( | const char * | class_name,
 |  | mComponentClass * | clss
 | ) |  |

check a class name is a special class type or not

Parameters:
class_name | the class name to check, this is the component class Name, not the typeName of mObject.
clss | the expected class type pointer
Returns:
TRUE - check success, FALSE -failed

BOOL ncsRegisterComponent | ( | mComponentClass * | compCls,
 |  | DWORD | dwStyle,
 |  | DWORD | dwExStyle,
 |  | int | idCursor,
 |  | int | idBkColor
 | ) |  |

register a component class into MiniGUI, so that ncsCreateWindow and ncsCreateWindow can find a mComponentClass instance

Parameters:
compCls | the mComponentClass to be registered
dwStyle | the default style
dwExStyle | the default extend style
idCursor | the default cursor
idBkColor | the default background color
Returns:
TRUE - success, FALSE - failed
See also:
ncsGetComponentClass, ncsCreateWindow, ncsCreateWindowIndirect, ncsCreateMainWindow, ncsCreateMainWindowIndirect

void * ncsSetComponentHandler | ( | mComponent * | comp,
 |  | int | message,
 |  | void * | handler
 | ) |  |

set the component handler

Parameters:
comp | the compont to set
message | the event code
handler | the event callback pointer
Returns:
old event callback if it has been set
See also:
ncsSetComponentHandlers

void ncsSetComponentHandlers | ( | mComponent * | comp,
 |  | NCS_EVENT_HANDLER * | handlers,
 |  | int | count
 | ) |  |

set an array of event handlers

Parameters:
comp | - the component to set
handlers | - the array of NCS_EVENT_HANDLER
count | - the count of array handlers.
Note:
if count == -1, handlers must end by {-1, NULL}; anywhere, ncsSetComponentHandlers would stop if it find an element of array handlers is equal {-1, NULL}, whether count is equal -1 or not
See also:
ncsSetComponentHandler

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: _NCS_EVENT_HANDLER Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_NCS_EVENT_HANDLER Struct Reference
[Global Component Functions]

#include <mcomponent.h>

Data Fields

  • int message
  • void * handler

Detailed Description

A struct of event-handler mapping

Note:
only used for param
See also:
NCS_EVENT_HANDLER_NODE

Definition at line 338 of file mcomponent.h.

Field Documentation

int message

The event code

Definition at line 342 of file mcomponent.h.

void* handler

The event callback pointer

Definition at line 346 of file mcomponent.h.

The documentation for this struct was generated from the following file:
  • mcomponent.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: _NCS_EVENT_CONNECT_INFO Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_NCS_EVENT_CONNECT_INFO Struct Reference
[Global Component Functions]

#include <mcomponent.h>

Data Fields

  • int id_sender
  • int id_listener
  • int event_id
  • NCS_CB_ONOBJEVENT event

Detailed Description

A struct of connection map
Note:
used for ncsComponentConnectEvents, in resmanager
See also:
ncsComponentConnectEvents

Definition at line 395 of file mcomponent.h.

Field Documentation

int id_sender

The id of sender, must be a child or itself of a component

Definition at line 399 of file mcomponent.h.

int id_listener

The id of listener, must be a child or itself of a component

Definition at line 403 of file mcomponent.h.

int event_id

The event id of sender

Definition at line 407 of file mcomponent.h.

NCS_CB_ONOBJEVENT event

The callback for processing event

Definition at line 411 of file mcomponent.h.

The documentation for this struct was generated from the following file:
  • mcomponent.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: Gloal InvisibleComponent Functions

Gloal InvisibleComponent Functions
[Global defines]

Data Structures

  • struct _NCS_INVSB_CREATE_INFO

Functions

  • MGNCS_EXPORT mInvsbComp * ncsCreateInvsbComp (const char *class_name, mComponent *parent, int id, NCS_PROP_ENTRY *props, NCS_EVENT_HANDLER *handlers, DWORD user_data)
    create an Invisible Component
  • MGNCS_EXPORT mInvsbComp * ncsCreateInvsbCompIndirect (const char *class_name, NCS_INVSB_CREATE_INFO *create_info)
    create an Invisible Component from creating info

Function Documentation

mInvsbComp * ncsCreateInvsbComp | ( | const char * | class_name,
 |  | mComponent * | parent,
 |  | int | id,
 |  | NCS_PROP_ENTRY * | props,
 |  | NCS_EVENT_HANDLER * | handlers,
 |  | DWORD | user_data
 | ) |  |

create an Invisible Component

Parameters:
class_name | the class name of Invisible Component
parent | the parent of creating Invisible Component
id | the id of Invisible Component
props | the properties array of Invisible Component
handlers | the event handler array of Invisible Component
user_data | user data
Returns:
mInvsbComp * - the new created Invisible Component pointer, NULL or failed
See also:
NCS_INVSB_CREATE_INFO, ncsCreateInvsbCompIndirect

mInvsbComp * ncsCreateInvsbCompIndirect | ( | const char * | class_name,
 |  | NCS_INVSB_CREATE_INFO * | create_info
 | ) |  |

create an Invisible Component from creating info

Parameters:
class_name | the class name of Invisible Component
create_info | the creating information pointer
Returns:
mInvsbComp * - the Invisible Component pointer if success, NULL or failed
See also:
NCS_INVSB_CREATE_INFO, ncsCreateInvsbComp

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: _NCS_INVSB_CREATE_INFO Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_NCS_INVSB_CREATE_INFO Struct Reference
[Gloal InvisibleComponent Functions]

#include <minvisible-component.h>

Data Fields

  • mComponent * parent
  • int id
  • NCS_PROP_ENTRY * props
  • NCS_EVENT_HANDLER * handlers
  • DWORD user_data

Detailed Description

A struct include Invisible Component Create info

See also:
ncsCreateInvsbCompIndirect

Definition at line 101 of file minvisible-component.h.

Field Documentation

mComponent* parent

The parent Component

Definition at line 105 of file minvisible-component.h.

int id

The id of component

Definition at line 109 of file minvisible-component.h.

NCS_PROP_ENTRY* props

The property of Component

See also:
NCS_PROP_ENTRY

Definition at line 115 of file minvisible-component.h.

NCS_EVENT_HANDLER* handlers

The event handlers array

See also:
NCS_EVENT_HANDLER

Definition at line 121 of file minvisible-component.h.

DWORD user_data

Use defined data

Definition at line 126 of file minvisible-component.h.

The documentation for this struct was generated from the following file:
  • minvisible-component.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: Global Object Functions

Global Object Functions
[Global defines]

Defines

  • #define TYPENAME(obj) ((obj)?(((obj)->_class)?((obj)->_class)->typeName:""):"")
    Get the class name form a Object pointer.
  • #define INSTANCEOF(obj, clss) ncsInstanceOf((mObject*)(obj), (mObjectClass*)(void*)(&Class(clss)))
    A wrapper of ncsInstanceOf, just like java's instanceof.
  • #define CHECKOBJ(obj) ncsIsValidObj((mObject*)obj)
    the wrapper of ncsIsValidObj
  • #define TYPE_CAST(Type, obj) ((Type*)(obj))
    unsafe cast. donot check the type of class
  • #define SAFE_CAST(Type, obj) TYPE_CAST(Type, ncsSafeCast((mObject*)obj,(mObjectClass*)(void*)(&(Class(Type)))))
    wrapper of ncsSafeCast, check the class type before cast.
  • #define SAFE_CAST_CLASS(Clss, ClssCast) ((ClassType(ClssCast)*)(ncsSafeCastClass((mObjectClass*)Clss, (mObjectClass*)(void*)(&Class(ClssCast)))))
    the wrapper of ncsSafeCastClass

Typedefs

  • typedef BOOL(* NCS_CB_ONOBJEVENT )(mObject *self, mObject *sender, int eventId, DWORD param)
    The Callback of connection.

Functions

  • MGNCS_EXPORT mObject * newObject (mObjectClass *_class)
    new a object instance, like new operator in C++
  • MGNCS_EXPORT void deleteObject (mObject *obj)
    delete a object intance, like delete operator in C++
  • MGNCS_EXPORT BOOL ncsInstanceOf (mObject *object, mObjectClass *clss)
    check an object is the class instance or not, same as instanceof operator in Java
  • static mObject * ncsIsValidObj (mObject *obj)
    Check a pointer is a valid mObject or not.
  • MGNCS_EXPORT mObject * ncsSafeCast (mObject *obj, mObjectClass *clss)
    safe type cast function, like the dynamic_cast operator in C++
  • MGNCS_EXPORT mObjectClass * ncsSafeCastClass (mObjectClass *clss, mObjectClass *castCls)
    cast from a supper class to derived class type safely
  • MGNCS_EXPORT BOOL ncsAddEventListener (mObject *sender, mObject *listener, NCS_CB_ONOBJEVENT eventProc, int eventId)
    connect sender object to listener object
  • MGNCS_EXPORT BOOL ncsAddEventListeners (mObject *sender, mObject *listener, NCS_CB_ONOBJEVENT eventProc, int *eventIds)
    connect a group of events from sender to listener
  • MGNCS_EXPORT BOOL ncsRemoveEventListener (mObject *listener)
    remove the connections which are listened by the object
  • MGNCS_EXPORT BOOL ncsRemoveEventConnect (mObject *listener, mObject *source, int eventId)
    remove a special event connect
  • MGNCS_EXPORT BOOL ncsRemoveEventSource (mObject *sender)
    remove the connections when a sender is destroied
  • MGNCS_EXPORT void ncsRaiseEvent (mObject *sender, int eventId, DWORD param)
    raise an event to listeners

Define Documentation

#define CHECKOBJ ( obj ) ncsIsValidObj((mObject*)obj)

the wrapper of ncsIsValidObj

See also:
ncsIsValidObj

Definition at line 422 of file mobject.h.

#define INSTANCEOF | ( | obj,
 |  | clss | ) | ncsInstanceOf((mObject*)(obj), (mObjectClass*)(void*)(&Class(clss)))

A wrapper of ncsInstanceOf, just like java's instanceof.

Example: Test a object is mComponentClass: INSTANCEOF(obj, mComponent)

Definition at line 402 of file mobject.h.

Referenced by ncsIsValidObj().

#define SAFE_CAST | ( | Type,
 |  | obj | ) | TYPE_CAST(Type, ncsSafeCast((mObject*)obj,(mObjectClass*)(void*)(&(Class(Type)))))

wrapper of ncsSafeCast, check the class type before cast.

Note:
this macro is same as dynamic_cast in C++
See also:
ncsSafeCast

Definition at line 450 of file mobject.h.

#define SAFE_CAST_CLASS | ( | Clss,
 |  | ClssCast | ) | ((ClassType(ClssCast)*)(ncsSafeCastClass((mObjectClass*)Clss, (mObjectClass*)(void*)(&Class(ClssCast)))))

the wrapper of ncsSafeCastClass

Definition at line 468 of file mobject.h.

#define TYPE_CAST | ( | Type,
 |  | obj | ) | ((Type*)(obj))

unsafe cast. donot check the type of class

Definition at line 441 of file mobject.h.

#define TYPENAME ( obj ) ((obj)?(((obj)->_class)?((obj)->_class)->typeName:""):"")

Get the class name form a Object pointer.

Definition at line 379 of file mobject.h.

Typedef Documentation

typedef BOOL(* NCS_CB_ONOBJEVENT)(mObject *self, mObject *sender, int eventId, DWORD param)

The Callback of connection.

Note:
For widgets, only support notification
Parameters:
self | The listener pointer
sender | The sender of event
eventId | the id of event
param | the param of event
Returns:
TRUE - continue dispatch the event; FALSE - stop the event.

Definition at line 485 of file mobject.h.

Function Documentation

void deleteObject ( mObject * obj )

delete a object intance, like delete operator in C++

Parameters:
obj - the object want to delete

BOOL ncsAddEventListener | ( | mObject * | sender,
 |  | mObject * | listener,
 |  | NCS_CB_ONOBJEVENT | eventProc,
 |  | int | eventId
 | ) |  |

connect sender object to listener object

Parameters:
sender | The sender of event
listener | The listener of event
eventProc | The processing callback of event
eventId | The id of event
Returns:
TRUE - Sucessed, FALSE - Failed
See also:
ncsAddEventListener, ncsAddEventListeners, NCS_CB_ONOBJEVENT

MGNCS_EXPORT BOOL ncsAddEventListeners | ( | mObject * | sender,
 |  | mObject * | listener,
 |  | NCS_CB_ONOBJEVENT | eventProc,
 |  | int * | eventIds
 | ) |  |

connect a group of events from sender to listener

BOOL ncsAddEventListeners(mObject *sender, \ mObject* listener, \ NCS_CB_ONOBJEVENT eventProc, \ int* eventIds);

Parameters:
sender | The sender of events
listener | The listener of events
eventProc | The processing callback of events
eventIds | The id array of events, end by 0
Returns:
TRUE - Sucessed, FALSE - Failed
See also:
ncsAddEventListener, ncsAddEventListeners, NCS_CB_ONOBJEVENT

BOOL ncsInstanceOf | ( | mObject * | object,
 |  | mObjectClass * | clss
 | ) |  |

check an object is the class instance or not, same as instanceof operator in Java

Parameters:
object | - the pointer of object being to test
clss | - the pointer of class for test
Returns:
TRUE - object is instance of clss, FALSE - not

static inline mObject * ncsIsValidObj ( mObject * obj ) [inline, static]

Check a pointer is a valid mObject or not.

Parameters:
obj - the excpeted object pointer
Returns:
mObject * the pointer of obj or other NULL if obj is an invalid mObject pointer

Definition at line 412 of file mobject.h.

References INSTANCEOF.

void ncsRaiseEvent | ( | mObject * | sender,
 |  | int | event_id,
 |  | DWORD | param
 | ) |  |

raise an event to listeners

Note:
it will call the callback of NCS_CB_ONOBJEVENT add by ncsAddEventListeners, or ncsAddEventListener
Parameters:
sender | event sender
event_id | the id of event
param | the event param
See also:
NCS_CB_ONOBJEVENT, ncsAddEventListener, ncsAddEventListeners

BOOL ncsRemoveEventConnect | ( | mObject * | listener,
 |  | mObject * | source,
 |  | int | event
 | ) |  |

remove a special event connect

Parameters:
listener | the listener object
source | the source object
event | the special event want to remove

BOOL ncsRemoveEventListener ( mObject * listener )

remove the connections which are listened by the object

Note:
this function is called when a listener is destroied
Parameters:
listener the object pointer of listener
Returns:
TRUE - sucessed; FALSE - failed

BOOL ncsRemoveEventSource ( mObject * sender )

remove the connections when a sender is destroied

Note:
this function is called when a sender is destroied
Parameters:
sender the sender of events
Returns:
TRUE - sucessed; FALSE - failed

mObject * ncsSafeCast | ( | mObject * | obj,
 |  | mObjectClass * | clss
 | ) |  |

safe type cast function, like the dynamic_cast operator in C++

Parameters:
obj | - the mObject pointer being casted
clss | - the target type to cast
Returns:
mObject * - the object pointer if cast safe, NULL otherwise
See also:
ncsInstanceOf

mObjectClass * ncsSafeCastClass | ( | mObjectClass * | clss,
 |  | mObjectClass * | castCls
 | ) |  |

cast from a supper class to derived class type safely

Parameters:
clss | - the supper type class pointer
castCls | - the derived class type pointer
Note:
use SAFE_CAST_CLASS
Returns:
mObjectClass * - the pointer of clss if cast safe, otherwise NULL

mObject * newObject ( mObjectClass * _class )

new a object instance, like new operator in C++

Parameters:
_class - the class of the object
Returns:
the new pointer of object

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: Global Control function

Global Control function
[Global defines]

Data Structures

  • struct _NCS_PROP_ENTRY
  • struct _NCS_RDR_ELEMENT
  • struct _NCS_RDR_INFO
  • struct _NCS_CREATE_NOTIFY_INFO
  • struct _NCS_MAIN_CREATE_INFO
  • struct _NCS_WND_TEMPLATE
  • struct _NCS_MNWND_TEMPLATE

Functions

  • MGNCS_EXPORT BOOL ncsSetFont (HWND hWnd, const char *fontName)
    set control's font
  • MGNCS_EXPORT BOOL ncsSetProperty (HWND hWnd, int id, DWORD value)
    set control's property
  • MGNCS_EXPORT DWORD ncsGetProperty (HWND hWnd, int id)
    get control's property
  • MGNCS_EXPORT mWidget * ncsCreateWindow (const char *className, const char *caption, DWORD style, DWORD exStyle, int id, int x, int y, int w, int h, HWND parent, NCS_PROP_ENTRY *props, NCS_RDR_INFO *rdrInfo, NCS_EVENT_HANDLER *handlers, DWORD addData)
    create a NCS widget
  • MGNCS_EXPORT mWidget * ncsCreateMainWindow (const char *className, const char *caption, DWORD style, DWORD exStyle, int id, int x, int y, int w, int h, HWND host, HICON hIcon, HMENU hMenu, NCS_PROP_ENTRY *props, NCS_RDR_INFO *rdrInfo, NCS_EVENT_HANDLER *handlers, DWORD addData)
    create a NCS main window
  • MGNCS_EXPORT mWidget * ncsCreateWindowIndirect (const NCS_WND_TEMPLATE *tmpl, HWND hParent)
    create a mComponent by NCS_WND_TEMPLATE,
  • MGNCS_EXPORT mWidget * ncsCreateMainWindowIndirect (const NCS_MNWND_TEMPLATE *tmpl, HWND hHost)
    create a main window from a template
  • MGNCS_EXPORT mWidgetClass * ncsGetMainWndClass (const char *className)
    Get a Main window Class by className.
  • MGNCS_EXPORT void ncsNotifyParentEx (mWidget *self, int code, DWORD addData)
    raise a notification event
  • static mWidget * ncsObjFromHandle (HWND hwnd)
    Get a Object from window handle.
  • static mWidget * ncsGetChildObj (HWND hwnd, int id)
    Get the child object pointer of window.
  • static mWidget * ncsGetParentObj (HWND hwnd)
    Get the parent object pointer of window.
  • static DWORD ncsGetDlgCode (HWND hwnd)
    Get the dialog code of a NCS window.
  • MGNCS_EXPORT void ncsDestroyWindow (mWidget *self, DWORD endCode)
    delete the widget window created by ncs.

Function Documentation

mWidget * ncsCreateMainWindow | ( | const char * | className,
 |  | const char * | caption,
 |  | DWORD | style,
 |  | DWORD | exStyle,
 |  | int | id,
 |  | int | x,
 |  | int | y,
 |  | int | w,
 |  | int | h,
 |  | HWND | host,
 |  | HICON | hIcon,
 |  | HMENU | hMenu,
 |  | NCS_PROP_ENTRY * | props,
 |  | NCS_RDR_INFO * | rdrInfo,
 |  | NCS_EVENT_HANDLER * | handlers,
 |  | DWORD | addData
 | ) |  |

create a NCS main window

Parameters:
className | the class name of widget. the class name must be register by ncsRegisterComponent. And must be NCSCTRL_MAINWND or its dirved class.
caption | the caption of the main window
style | the style of main window
exStyle | the extend style of main window
id | the id of main window
x | the x position of main window
y | the y position of main window
w | the width of main window
h | the height of main window
host | the handle of host window, can be NULL
hIcon | the icon of main window
hMenu | the menu bar handle
props | the properties array pointer, end by {-1, 0} if it's not NULL
rdrInfo | the renderer info pointer
handlers | the handlers of event array pointer, end by {-1, NULL}, if it's not NULL
addData | the additional data send to callback NCS_CB_ONCREATE and NCS_CB_ONINITDLG
Returns:
mWidget* - a mWidget pointer, must be a mMainWnd instance
See also:
ncsCreateWindow,ncsCreateWindowIndirect, nscCreateMainWindowIndirect, NCS_PROP_ENTRY, NCS_RDR_INFO, NCS_EVENT_HANDLER, NCS_CB_ONCREATE, mWidget, mInvisibleComponent , mMainWnd

mWidget * ncsCreateMainWindowIndirect | ( | const NCS_MNWND_TEMPLATE * | tmpl,
 |  | HWND | hHost
 | ) |  |

create a main window from a template

Parameters:
tmpl | - the template of main window
hHost | - the host window handler of the main window
Returns:
mWidget * - the Instance of mMainWnd or NULL
See also:
ncsCreateMainWindow, NCS_MNWND_TEMPLATE

mWidget * ncsCreateWindow | ( | const char * | className,
 |  | const char * | caption,
 |  | DWORD | style,
 |  | DWORD | exStyle,
 |  | int | id,
 |  | int | x,
 |  | int | y,
 |  | int | w,
 |  | int | h,
 |  | HWND | parent,
 |  | NCS_PROP_ENTRY * | props,
 |  | NCS_RDR_INFO * | rdrInfo,
 |  | NCS_EVENT_HANDLER * | handlers,
 |  | DWORD | addData
 | ) |  |

create a NCS widget

Parameters:
className | the class name of widget. the class name must be register by ncsRegisterComponent. Any drived from mComponent and registered component is validate
caption | the caption of the widget, ignored if class_name is a mInvsbComp
style | the style of widget, ignored if class_name is a mInvsbComp
exStyle | the extend style of widget, ignored if class_name is a mInvsbComp
id | the id of component
x | the x position of widget, ignored if class_name is a mInvsbComp
y | the y position of widget, ignored if class_name is a mInvsbComp
w | the width of widget ,ignored if class_name is a mInvsbComp
h | the height of widget , ignored if class_name is a mInvsbComp
parent | the handle of parent, if class_name is a mInvsbComp, the parent must releated a mWidget object
props | the properties array pointer, end by {-1, 0} if it's not NULL
rdrInfo | the renderer info pointer
handlers | the handlers of event array pointer, end by {-1, NULL}, if it's not NULL
addData | the additional data send to callback NCS_CB_ONCREATE
Returns:
mWidget* - a mWidget pointer, if class_name is a mInvsbComp, it's a mInvisibleComponent* pointer
See also:
ncsCreateMainWindow, nscCreateWindowIndirect, NCS_PROP_ENTRY, NCS_RDR_INFO, NCS_EVENT_HANDLER, NCS_CB_ONCREATE, mWidget, mInvisibleComponent

mWidget * ncsCreateWindowIndirect | ( | const NCS_WND_TEMPLATE * | tmpl,
 |  | HWND | hParent
 | ) |  |

create a mComponent by NCS_WND_TEMPLATE,

Parameters:
tmpl | the template pointer
hParent | the parent handle, if NCS_WND_TEMPLATE.class_name is a mInvsbComp, hParent must releated a mWidget object
Returns:
mWidget* - then pointer of object or NULL if failed
See also:
ncsCreateWindow, NCS_WND_TEMPLATE

void ncsDestroyWindow | ( | mWidget * | self,
 |  | DWORD | endCode
 | ) |  |

delete the widget window created by ncs.

static inline mWidget * ncsGetChildObj | ( | HWND | hwnd,
 |  | int | id |
 | ) |  |  | [inline, static]

Get the child object pointer of window.

Parameters:
hwnd | - the handle of window, which can be a normal MiniGUI window or a NCS window
id | - the child id. The child must be a NCS window
Returns:
mWidget * the instance releated id, or NULL

Definition at line 1227 of file mwidget.h.

References _c, and ncsObjFromHandle().

static inline DWORD ncsGetDlgCode ( HWND hwnd ) [inline, static]

Get the dialog code of a NCS window.

Parameters:
hwnd - the handle of NCS window
Returns:
DWORD - the dialog code or 0

Definition at line 1255 of file mwidget.h.

References _c, and ncsObjFromHandle().

mWidgetClass * ncsGetMainWndClass ( const char * className )

Get a Main window Class by className.

Note:
this function is used to develop a drived class of mMainWnd
Parameters:
className - the class name of main window , if className == NULL or invalidate name, the function return mMainWnd's class
Returns:
mWidgetClass* - the mMainWndClass pointer or its drived class pointer

static inline mWidget * ncsGetParentObj ( HWND hwnd ) [inline, static]

Get the parent object pointer of window.

Parameters:
hwnd - the handle of child window, which can be a normal MiniGUI window or a NCS window
Returns:
mWidget * the instance of parent of hwnd

Definition at line 1241 of file mwidget.h.

References ncsObjFromHandle().

void * ncsGetProperty | ( | HWND | hWnd,
 |  | int | id
 | ) |  |

get control's property

Parameters:
hWnd | - the handle of control
id | - the property id
Returns:
the value of property
See also:
ncsSetProperty

void ncsNotifyParentEx | ( | mWidget * | self,
 |  | int | code,
 |  | DWORD | addData
 | ) |  |

raise a notification event

Note:
this function is used to develop a drived class of mWidget
Parameters:
self | - the mWidget object who want to raise a event
code | - the notification event code
addData | - the additional data.

static inline mWidget * ncsObjFromHandle ( HWND hwnd ) [inline, static]

Get a Object from window handle.

Parameters:
hwnd - the handle of window
Returns:
mWidget * the instance releated this handle, or NULL

Definition at line 1211 of file mwidget.h.

Referenced by ncsGetChildObj(), ncsGetDlgCode(), and ncsGetParentObj().

BOOL ncsSetFont | ( | HWND | hWnd,
 |  | const char * | fontName
 | ) |  |

set control's font

Parameters:
hWnd | - the handle of control
fontName | - the name of a logical font
Returns:
suceess or not

BOOL ncsSetProperty | ( | HWND | hWnd,
 |  | int | id,
 |  | DWORD | value
 | ) |  |

set control's property

Parameters:
hWnd | - the handle of control
id | - the property id of control
value | - the value of property
Returns:
suceess or not
See also:
ncsGetProperty

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: _NCS_PROP_ENTRY Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_NCS_PROP_ENTRY Struct Reference
[Global Control function]

#include <mwidget.h>

Data Fields

  • int id
  • DWORD value

Detailed Description

A property entry

Note:
this struct is used when calling ncsCreateXXX functions
See also:
NCS_CREATE_INFO NCS_WND_TEMPLATE NCS_MNWND_TEMPLATE

Definition at line 824 of file mwidget.h.

Field Documentation

int id

The property id

Definition at line 828 of file mwidget.h.

DWORD value

The property value

Definition at line 832 of file mwidget.h.

The documentation for this struct was generated from the following file:
  • mwidget.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: _NCS_RDR_ELEMENT Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_NCS_RDR_ELEMENT Struct Reference
[Global Control function]

#include <mwidget.h>

Data Fields

  • int id
  • DWORD value

Detailed Description

A renderer element struct

Note:
This struct is used by NCS_RDR_INFO when create a NCS widget
See also:
NCS_RDR_INFO

Definition at line 842 of file mwidget.h.

Field Documentation

int id

The renderer element id

Definition at line 846 of file mwidget.h.

DWORD value

The remderer element value

Definition at line 850 of file mwidget.h.

The documentation for this struct was generated from the following file:
  • mwidget.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: _NCS_RDR_INFO Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_NCS_RDR_INFO Struct Reference
[Global Control function]

#include <mwidget.h>

Data Fields

  • const char * glb_rdr
  • const char * ctl_rdr
  • NCS_RDR_ELEMENT * elements

Detailed Description

A struct used to include all the renderer info when create a widget

See also:
NCS_CREATE_INFO, NCS_MAIN_CREATE_INFO, NCS_WND_TEMPLATE, NCS_MNWND_TEMPLATE

Definition at line 858 of file mwidget.h.

Field Documentation

const char* glb_rdr

The global renderer, the minigui 3.0 defined renderer

Definition at line 862 of file mwidget.h.

const char* ctl_rdr

The control renderer, defined by NCS

Definition at line 866 of file mwidget.h.

NCS_RDR_ELEMENT* elements

The Renderer element array, end by { -1, 0}

Definition at line 870 of file mwidget.h.

The documentation for this struct was generated from the following file:
  • mwidget.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: _NCS_CREATE_NOTIFY_INFO Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_NCS_CREATE_NOTIFY_INFO Struct Reference
[Global Control function]

#include <mwidget.h>

Detailed Description

A struct include the creating info for creating window

Note:
This struct is used by ncsCreateWindow, donot use it directly. If you want to create a NCS widget by MiniGUI API CreateWindow, pass the NCS_CREATE_INFO* as Additional data

Definition at line 883 of file mwidget.h.

The documentation for this struct was generated from the following file:
  • mwidget.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: _NCS_MAIN_CREATE_INFO Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_NCS_MAIN_CREATE_INFO Struct Reference
[Global Control function]

#include <mwidget.h>

Data Fields

  • const char * className
  • NCS_CREATE_INFO * create_info

Detailed Description

A struct wrap the NCS_CREATE_INFO

Note:
only allowed using in ncsCreateMainWindow Don't use it directly
See also:
NCS_CREATE_INFO, ncsCreateMainWindow , ncsCreateMainWindowIndirect

Definition at line 992 of file mwidget.h.

Field Documentation

const char* className

The class name of a mMainWnd or its child class

Note:
if className is NULL or an invalidate class name ncsCreateMainWindow and ncsCreateMainWindowIndirect use NCSCTRL_MAINWND replaced
See also:
NCSCTRL_MAINWND

Definition at line 1002 of file mwidget.h.

NCS_CREATE_INFO* create_info

NCS_CREATE_INFO pointer

Definition at line 1006 of file mwidget.h.

The documentation for this struct was generated from the following file:
  • mwidget.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: _NCS_WND_TEMPLATE Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_NCS_WND_TEMPLATE Struct Reference
[Global Control function]

#include <mwidget.h>

Data Fields

  • const char * class_name
  • int id
  • int x
  • DWORD style
  • DWORD ex_style
  • const char * caption
  • NCS_PROP_ENTRY * props

Detailed Description

A struct include all the creating info, used by ncsCreateWindowIndirect

See also:
NCS_CREATE_INFO

Definition at line 1059 of file mwidget.h.

Field Documentation

const char* class_name

The class name of mComponent, must be registered by ncsRegisterComponent

Note:
support mInvsbComp class

Definition at line 1065 of file mwidget.h.

int id

The id of commponet

Definition at line 1069 of file mwidget.h.

int x

The Location and Size of mWidget, ignored if class_name is a mInvsbComp

Definition at line 1073 of file mwidget.h.

DWORD style

The style of mWidget, ignored if class_name is a mInvsbComp

Definition at line 1077 of file mwidget.h.

DWORD ex_style

The extend style of mWidget, ignored if class_name is a mInvsbComp

Definition at line 1081 of file mwidget.h.

const char* caption

The caption of mWidget, ignored if class_name is a mInvsbComp

Definition at line 1085 of file mwidget.h.

NCS_PROP_ENTRY* props

Same as NCS_CREATE_INFO

See also:
NCS_CREATE_INFO

Definition at line 1093 of file mwidget.h.

The documentation for this struct was generated from the following file:
  • mwidget.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: _NCS_MNWND_TEMPLATE Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_NCS_MNWND_TEMPLATE Struct Reference
[Global Control function]

#include <mwidget.h>

Detailed Description

A struct include all the creating info for ncsCreateMainWindowIndirect,

Note:
same as ncsCreateMainWindow 's params
See also:
NCS_WND_TEMPLATE, ncsCreateMainWindow

Definition at line 1134 of file mwidget.h.

The documentation for this struct was generated from the following file:
  • mwidget.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: Global defines

Global defines

Modules

  • Global Component Functions
  • Gloal InvisibleComponent Functions
  • Global Object Functions
  • Global Control function

Data Structures

  • struct _NCS_RDR_ENTRY
  • MGNCS_EXPORT DWORD ncsGetElementEx (mWidget *self, const char *rdrName, int id)
    Get the value of element id in specified window or renderer.
  • MGNCS_EXPORT DWORD ncsSetElementEx (mWidget *self, const char *rdrName, int id, DWORD value)
    Set the value of element id in specified window or renderer.
  • MGNCS_EXPORT GHANDLE ncsLoadRdrEtcFile (const char *etcfile, const char **rdrName, int count)
    Load renderer configure file from file system or incore mode.
  • MGNCS_EXPORT int ncsUnloadRdrEtcFile (GHANDLE hEtcFile)
    Unload renderer configuration file.
  • MGNCS_EXPORT mWidgetRenderer * ncsRetriveCtrlRDR (const char *rendererName, const char *className)
    get a renderer of special control
  • MGNCS_EXPORT BOOL ncsRegisterCtrlRDR (const char *rendererName, const char *className, mWidgetRenderer *renderer)
    register one of implemention of a special control into system
  • MGNCS_EXPORT void ncsUnregisterCtrlRDRs (const char *rdrName, const char *className)
    unregister a special rdr
  • MGNCS_EXPORT BOOL ncsRegisterCtrlRDRs (const char *rendererName, NCS_RDR_ENTRY *entries, int count)
    register a group of renderers into system
  • MGNCS_EXPORT BOOL ncsSetSystemRenderer (const char *name)
    Set the System renderer. If a system renderer would be used by all the controls who haven't been set the property "renderer", see mWidget and mWidgetRenderer.
  • MGNCS_EXPORT const char * ncsGetSystemRenderer (void)
    get the system renderer name
  • #define NCS_TYPE_MASK WE_ATTR_TYPE_MASK
  • #define ncsGetElement(self, id) ncsGetElementEx((mWidget*)self, NULL, id)
    Get the value of element id in specified window.
  • #define ncsSetElement(self, id, value) ncsSetElementEx((mWidget*)self, NULL, id, value)
    Set the value of element id in specified window.

Detailed Description

$Id:$

Copyright (C) 2009 Feynman Software.

Define Documentation

#define NCS_TYPE_MASK WE_ATTR_TYPE_MASK

defgroup Renderer_functions Global Renderer function

Definition at line 38 of file mrdr.h.

#define ncsGetElement | ( | self,
 |  | id | ) | ncsGetElementEx((mWidget*)self, NULL, id)

Get the value of element id in specified window.

Definition at line 247 of file mrdr.h.

#define ncsSetElement | ( | self,
 |  | id,
 |  | value | ) | ncsSetElementEx((mWidget*)self, NULL, id, value)

Set the value of element id in specified window.

Definition at line 254 of file mrdr.h.

Function Documentation

DWORD ncsGetElementEx | ( | mWidget * | self,
 |  | const char * | rdrName,
 |  | int | id
 | ) |  |

Get the value of element id in specified window or renderer.

When the window class is valid, it will return the element id value in current window. Otherwise return the value in specifed renderer.

Parameters:
self | The instance.
rdrName | The renderer name.
id The window element id number, can be one of the following value:
  • NCS_FGC_3DBODY
  • NCS_BGC_3DBODY
  • NCS_FGC_WINDOW
  • NCS_BGC_WINDOW
  • NCS_FGC_SELECTED_ITEM
  • NCS_BGC_SELECTED_ITEM
  • NCS_FGC_HILIGHT_ITEM
  • NCS_BGC_HILIGHT_ITEM
  • NCS_FGC_DISABLED_ITEM
  • NCS_BGC_DISABLED_ITEM
  • NCS_BGC_SELITEM_NOFOCUS
  • NCS_METRICS_3DBODY_ROUNDX
  • NCS_METRICS_3DBODY_ROUNDY

  • NCS_MODE_BGC
  • NCS_MODE_FGC
  • NCS_MODE_ITEM
  • NCS_MODE_USEFLAT

  • NCS_BGC_PRGBAR_CHUNK
  • NCS_BGC_TRKBAR_SLIDER
  • NCS_BGC_TRKBAR_THUMB

  • NCS_IMAGE_ARROWS
  • NCS_IMAGE_ARROWSHELL
  • NCS_IMAGE_BUTTON
  • NCS_IMAGE_CHKBTN
  • NCS_IMAGE_RDOBTN
  • NCS_IMAGE_LISTV_TREE
  • NCS_IMAGE_LISTV_HDR
  • NCS_IMAGE_PRPSHT_TAB
  • NCS_IMAGE_PRGBAR_HCHUNK
  • NCS_IMAGE_PRGBAR_VCHUNK
  • NCS_IMAGE_PRGBAR_HSLIDER
  • NCS_IMAGE_PRGBAR_VSLIDER
  • NCS_IMAGE_TRKBAR_HTHUMB
  • NCS_IMAGE_TRKBAR_VTHUMB
  • NCS_IMAGE_TRKBAR_HSLIDER
  • NCS_IMAGE_TRKBAR_VSLIDER

See also:
ncsSetElementEx

const char * ncsGetSystemRenderer ( void )

get the system renderer name

Returns:
return the current system renderer name or "\0";

GHANDLE ncsLoadRdrEtcFile | ( | const char * | etcfile,
 |  | const char ** | rdrName,
 |  | int | count
 | ) |  |

Load renderer configure file from file system or incore mode.

Parameters:
etcfile | The name of configuration file.
rdrName | The renderer name set.
count | The array size of rdrName.

BOOL ncsRegisterCtrlRDR | ( | const char * | rendererName,
 |  | const char * | className,
 |  | mWidgetRenderer * | renderer
 | ) |  |

register one of implemention of a special control into system

Parameters:
rendererName | - the name of renderer, eg. skin, classic, fashion, flat, and so on
className | - the control's classname
renderer | - the renderer which would be rensigered
Note:
if the system have not any renderer of special "rendererName", system will create a renderer table to recieve it
Returns:
sucesses or not
See also:
ncsRegisterCtrlRDRs, ncsRetriveCtrlRDR, ncsUnregisterCtrlRDRs

BOOL ncsRegisterCtrlRDRs | ( | const char * | rendererName,
 |  | NCS_RDR_ENTRY * | entries,
 |  | int | count
 | ) |  |

register a group of renderers into system

Parameters:
rendererName | - the name of special renderer
entries | - the table of renderers,
See also:
NCS_RDR_ENTRY
Parameters:
count - the table size of entries
Returns:
sucess or not
See also:
ncsRegisterCtrlRDR, NCS_RDR_ENTRY, ncsRetriveCtrlRDR

mWidgetRenderer * ncsRetriveCtrlRDR | ( | const char * | rendererName,
 |  | const char * | className
 | ) |  |

get a renderer of special control

Parameters:
rendererName | - the renderer name , eg. classic, skin, fashion, flat, and so
className | - the control's className
Returns:
the implemention of renderer
See also:
ncsRegisterCtrlRDR, ncsRegisterCtrlRDRs

DWORD ncsSetElementEx | ( | mWidget * | self,
 |  | const char * | rdrName,
 |  | int | id,
 |  | DWORD | value
 | ) |  |

Set the value of element id in specified window or renderer.

When the window class is valid, it will set the element id value in current window. Otherwise set the value in specifed renderer.

Parameters:
self | The instance.
rdrName | The renderer name.
id | The element id.
value | The new value.
Returns:
The old value.
See also:
ncsGetElementEx

BOOL ncsSetSystemRenderer ( const char * name )

Set the System renderer. If a system renderer would be used by all the controls who haven't been set the property "renderer", see mWidget and mWidgetRenderer.

Parameters:
name - The name of system renderer.
Returns:
TRUE - sucess, FALSE - failed
Note:
same as basic renderer. If the renderer specialed by param name is not exist, it will be store the name, and wait user call ncsRegisterCtrlRDR or ncsRegisterCtrlRDRs; the new registered renderer would be set as new system renderer if the thir renderer name are same.

int ncsUnloadRdrEtcFile ( GHANDLE hEtcFile )

Unload renderer configuration file.

Returns:
0 on success, otherwise -1.

void ncsUnregisterCtrlRDRs | ( | const char * | rdrName = NULL,
 |  | const char * | className = NULL
 | ) |  |

unregister a special rdr

Parameters:
rdrName | the name of the unregistering renender
className | the special class of the render
See also:
ncsRegisterCtrlRDRs

Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: _NCS_RDR_ENTRY Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_NCS_RDR_ENTRY Struct Reference
[Global defines]

#include <mrdr.h>

Data Fields

  • const char * className
  • mWidgetRenderer * renderer

Detailed Description

A struct to include a Renderer register info

See also:
ncsRegisterCtrlRDRs

Definition at line 304 of file mrdr.h.

Field Documentation

const char* className

class name of a mWidget Control

Definition at line 309 of file mrdr.h.

mWidgetRenderer* renderer

An implemention of interface of mWidget whose name is className

Definition at line 313 of file mrdr.h.

The documentation for this struct was generated from the following file:
  • mrdr.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: Common Renderer Elements

Common Renderer Elements
[Renderer Elements]

Defines

  • #define INVALID_RDR_VALUE ((DWORD)-1)
    invalid renderer element value

Define Documentation

#define INVALID_RDR_VALUE ((DWORD)-1)

invalid renderer element value

Definition at line 379 of file mrdr.h.

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: list_head Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

list_head Struct Reference

The structure of double linked list. More...

#include <mdblist.h>

Detailed Description

The structure of double linked list.

Id
mdblist.h 906 2010-06-01 02:43:04Z xwyan

Copyright (C) 2009 Feynman Software.

  • next
    The next pointer.

  • prev
    The previous pointer.

Definition at line 45 of file mdblist.h.

The documentation for this struct was generated from the following file:
  • mdblist.h
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: Data Fields

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- a -

  • addData : _NCS_ICONV_ITEMINFO , _NCS_SCRLV_ITEMINFO , _NCS_LISTV_ITEMINFO , _NCS_LISTV_FINDINFO , _NCS_LSTBOX_ITEMINFO

- b -

  • bk_color : _NCSRM_WINHEADER
  • bmp : _NCS_ICONV_ITEMINFO

- c -

  • caption : _NCS_WND_TEMPLATE
  • caption_id : _NCSRM_WINHEADER
  • class_id : _NCSRM_WINHEADER
  • class_name : _NCS_WND_TEMPLATE
  • className : _NCS_RDR_ENTRY , _NCS_MAIN_CREATE_INFO
  • clsname_id : _NCSRM_RDRHEADER
  • col : _NCS_LISTV_ITEMDATA
  • country : _NCSRM_LOCALEITEM , _NCSRM_DEFLOCALE_INFO
  • create_info : _NCS_MAIN_CREATE_INFO
  • ctl_rdr : _NCS_RDR_INFO

- d -

  • data : _NCS_LISTV_ITEMINFO , _NCSRM_INCORE_IMAGE
  • dataSize : _NCS_LISTV_ITEMINFO

- e -

  • elements : _NCS_RDR_INFO
  • event : _NCS_EVENT_CONNECT_INFO
  • event_id : _NCS_EVENT_CONNECT_INFO
  • ex_style : _NCSRM_WINHEADER , _NCS_WND_TEMPLATE
  • ext : _NCSRM_INCORE_IMAGE

- f -

  • filename_id : _NCSRM_TYPEITEM , _NCSRM_IDITEM , _NCSRM_LOCALEITEM
  • flag : _NCS_LSTBOX_ITEMINFO
  • flags : _NCS_LISTV_ITEMINFO , _NCS_LISTV_CLMINFO , _NCS_LISTV_ITEMDATA
  • foldIcon : _NCS_LISTV_ITEMINFO
  • font_id : _NCSRM_WINHEADER
  • format_version : _NCSRM_HEADER

- g -

  • glb_rdr : _NCS_RDR_INFO

- h -

  • h : _NCSRM_WINHEADER
  • handler : _NCS_EVENT_HANDLER_NODE , _NCS_EVENT_HANDLER
  • handlers : _NCS_INVSB_CREATE_INFO
  • height : _NCS_LISTV_ITEMINFO , _NCS_SCRLV_ITEMINFO

- i -

  • id : _NCS_INVSB_CREATE_INFO , _NCSRM_IDITEM , _NCSRM_PROP , _NCS_PROP_ENTRY , _NCSRM_RDRINFO , _NCS_RDR_ELEMENT , _NCS_WND_TEMPLATE
  • id_listener : _NCS_EVENT_CONNECT_INFO
  • id_sender : _NCS_EVENT_CONNECT_INFO
  • image : _NCS_LSTBOX_ITEMINFO , _NCS_LISTV_CLMINFO , _NCS_LISTV_ITEMDATA
  • index : _NCS_LISTV_CLMINFO , _NCS_LISTV_ITEMINFO , _NCS_ICONV_ITEMINFO , _NCS_SCRLV_ITEMINFO

- l -

  • label : _NCS_ICONV_ITEMINFO
  • language : _NCSRM_LOCALEITEM , _NCSRM_DEFLOCALE_INFO

- m -

  • magic : _NCSRM_HEADER
  • message : _NCS_EVENT_HANDLER , _NCS_EVENT_HANDLER_NODE

- n -

  • next : _NCS_EVENT_HANDLER_NODE
  • nr_ctrls : _NCSRM_WINHEADER
  • nr_props : _NCSRM_WINHEADER
  • nr_sect : _NCSRM_HEADER

- o -

  • offset : _NCSRM_TYPEITEM , _NCSRM_IDITEM , _NCSRM_LOCALEITEM
  • offset_adddata : _NCSRM_WINHEADER
  • offset_ctrls : _NCSRM_WINHEADER
  • offset_props : _NCSRM_WINHEADER

- p -

  • package_version : _NCSRM_HEADER
  • parent : _NCS_INVSB_CREATE_INFO , _NCS_LISTV_ITEMINFO , _NCS_LISTV_FINDINFO
  • pfnDrawHdrBk : _NCS_CB_LISTV_CSTMHDROPS
  • pfnDrawHdrItem : _NCS_CB_LISTV_CSTMHDROPS
  • props : _NCS_WND_TEMPLATE , _NCS_INVSB_CREATE_INFO

- r -

  • rdr_id : _NCSRM_WINHEADER
  • rdrname_id : _NCSRM_RDRHEADER
  • renderer : _NCS_RDR_ENTRY
  • retPos : _NCS_LISTV_ITEMINFO
  • row : _NCS_LISTV_ITEMDATA

- s -

  • sect_size : _NCSRM_SECTHEADER
  • serial_num : _NCSRM_WINHEADER
  • size : _NCSRM_INCORE_IMAGE , _NCSRM_WINHEADER
  • size_adddata : _NCSRM_WINHEADER
  • size_maps : _NCSRM_SECTHEADER
  • startIdx : _NCS_LISTV_FINDINFO
  • string : _NCS_LSTBOX_ITEMINFO
  • style : _NCS_WND_TEMPLATE , _NCSRM_WINHEADER

- t -

  • text : _NCS_LISTV_CLMINFO , _NCS_LISTV_ITEMDATA
  • textColor : _NCS_LISTV_ITEMDATA
  • type : _NCS_LISTV_FINDINFO , _NCSRM_TYPEITEM , _NCSRM_PROP

- u -

  • unfoldIcon : _NCS_LISTV_ITEMINFO
  • user_data : _NCS_INVSB_CREATE_INFO

- v -

  • value : _NCSRM_RDRINFO , _NCSRM_PROP , _NCS_RDR_ELEMENT , _NCS_PROP_ENTRY
  • vendor : _NCSRM_HEADER

- w -

  • w : _NCSRM_WINHEADER
  • width : _NCS_LISTV_CLMINFO
  • wnd_id : _NCSRM_WINHEADER

- x -

  • x : _NCSRM_WINHEADER , _NCS_WND_TEMPLATE

- y -

  • y : _NCSRM_WINHEADER
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mabstractlist.h File Reference

include

mabstractlist.h File Reference

Go to the source code of this file.

Defines

  • #define NCSS_ASTLST_AUTOSORT (0x0001<<NCSS_SWGT_SHIFT)
    Sort nodes automatically.
  • #define NCSS_ASTLST_SHIFT (NCSS_SWGT_SHIFT+1)
    The bits used by mAbstractList in style.

Enumerations

  • enum mAbstractListNotify { NCSN_ASTLST_MAX = NCSN_SWGT_MAX + 1 }
    The notification id of mAbstractList. More...
  • enum mAbstractListProperty {
    NCSP_ASTLST_DEFNODEHEIGHT = NCSP_SWGT_MAX + 1, NCSP_ASTLST_FONTSIZE, NCSP_ASTLST_AUTOSORT, NCSP_ASTLST_TRANSPARENT,
    NCSP_ASTLST_CMPNODEFUNC, NCSP_ASTLST_ROOTNODE , NCSP_ASTLST_MAX
    }
    The properties id of mAbstractList. More...

Functions

  • mAbstractList * mAbstractList_getControl (mNode *node)
    Get the associated control handle of the specified node.

Variables

  • MGNCS_EXPORT mAbstractListClass g_stmAbstractListCls
    The instance of mAbstractListClass.

Detailed Description

Author:
XiaoweiYan
Date:
2009/11/10
This file includes the definition of mAbstractList.

    Copyright (C) 2009~2010 Feynman Software.

    All rights reserved by Feynman Software.

    This file is part of mgncs, which is new control
    set of MiniGUI.

Definition in file mabstractlist.h.

Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mchecknode.h File Reference

include

mchecknode.h File Reference

Go to the source code of this file.

Typedefs

  • typedef struct _mCheckNode mCheckNode

Detailed Description

Author:
WangJian
Date:
2010/01/26
This file includes the definition of mCheckNode.

    Copyright (C) 2009~2010 Feynman Software.

    All rights reserved by Feynman Software.

    This file is part of mgncs, which is new control
    set of MiniGUI.

Author:
WangJian
Date:
2010/01/26
This file includes the definition of mRadioNode.

    Copyright (C) 2009~2010 Feynman Software.

    All rights reserved by Feynman Software.

    This file is part of mgncs, which is new control
    set of MiniGUI.

Definition in file mchecknode.h.

Typedef Documentation

typedef struct _mCheckNode mCheckNode

$Id$

Copyright (C) 2009 Feynman Software.

Definition at line 29 of file mchecknode.h.

Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mcombobox.h File Reference

include

mcombobox.h File Reference

Go to the source code of this file.

Defines

  • #define NCSCTRL_COMBOBOX NCSCLASSNAME("combobox")
    the name of combobox control
  • #define NCSS_CMBOX_SIMPLE 0x0000L
    simle combobox, the list box is always show.
  • #define NCSS_CMBOX_DROPDOWNLIST (0x0001L<<NCSS_PANEL_SHIFT)
    dropdownlist combobox, the list box will be shown when user click the dropdown button.
  • #define NCSS_CMBOX_SORT (0x0002L<<NCSS_PANEL_SHIFT)
    combobox with the auto sort list.
  • #define NCSS_CMBOX_EDITNOBORDER (0x0004L<<NCSS_PANEL_SHIFT)
    combobox with no-border edit.
  • #define NCSS_CMBOX_EDITBASELINE (0x0008L<<NCSS_PANEL_SHIFT)
    combobox with base-line edit.
  • #define NCSS_CMBOX_READONLY (0x0010L<<NCSS_PANEL_SHIFT)
    combobox with read-only edit.
  • #define NCSS_CMBOX_UPPERCASE (0x0020L<<NCSS_PANEL_SHIFT)
    combobox with upper-case edit.
  • #define NCSS_CMBOX_LOWERCASE (0x0040L<<NCSS_PANEL_SHIFT)
    combobox with lower-case edit.
  • #define NCSS_CMBOX_AUTOFOCUS (0x0080L<<NCSS_PANEL_SHIFT)
    combobox with auto focus edit.

Enumerations

  • enum mComboboxProp {
    NCSP_COMB_ITEMHEIGHT = NCSP_LSTBOX_ITEMHEIGHT, NCSP_COMB_ITEMCOUNT = NCSP_LSTBOX_ITEMCOUNT, NCSP_COMB_DROPDOWNHEIGHT = NCSP_PANEL_MAX + 1, NCSP_COMB_TEXTLIMIT,
    NCSP_COMB_SELECT
    }
    the properties id of mCombobox More...
  • enum enumComboboxNotify {
    NCSN_CMBOX_SELCHANGE = NCSN_PANEL_MAX + 1, NCSN_CMBOX_SETFOCUS, NCSN_CMBOX_KILLFOCUS, NCSN_CMBOX_EDITCHANGE,
    NCSN_CMBOX_DROPDOWN, NCSN_CMBOX_CLOSEUP, NCSN_CMBOX_SELECTOK, NCSN_CMBOX_SELECTCANCEL
    }

Detailed Description

Author:
Wangjian<wangjian@minigui.org>
Date:
2009/03/01
This file includes the definition of mCombobox control.

    Copyright (C) 2009 Feynman Software.

    All rights reserved by Feynman Software.

    This file is part of mgncs, which is new control set of MiniGUI.

Definition in file mcombobox.h.

Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mcomponent.h File Reference

include

mcomponent.h File Reference

Go to the source code of this file.

Data Structures

  • struct _NCS_EVENT_HANDLER_NODE
  • struct _NCS_EVENT_HANDLER
  • struct _NCS_EVENT_CONNECT_INFO

Defines

  • #define MAXLEN_CLASSNAME 15
    the max length of class name
  • #define NCSCLASSNAME(name) name _MGNCS_CLASS_SUFFIX
    the NCS class name surfix, (_MGNCS_CLASS_SUFFIX ("_")), distinguish from old constrol set
  • #define ISCLASS(class_name, clssName) ncsIsClass((const char*)(class_name), (mComponentClass*)(&Class(clssName)))
    the wrapper of ncsIsClass, test a one component class is special one.

Enumerations

  • enum ncsComponentReleated { NCS_CMPT_NEXT = 0, NCS_CMPT_PREV, NCS_CMPT_PARENT, NCS_CMPT_CHILDREN }
    The releation between components. More...
  • enum mComponentQueryCmd {
    QPC_SET_PROP = 0, QPC_GET_PROP, QPC_ADD_EVENT, QPC_ADD_BIND,
    QPC_USER
    }
    queryByPath and vqueryByPath's cmd_id More...

Functions

  • MGNCS_EXPORT void * ncsSetComponentHandler (mComponent *comp, int message, void *handler)
    set the component handler
  • MGNCS_EXPORT void ncsSetComponentHandlers (mComponent *comp, NCS_EVENT_HANDLER *handlers, int count)
    set an array of event handlers
  • MGNCS_EXPORT void * ncsGetComponentHandler (mComponent *comp, int message)
    get an event callback
  • MGNCS_EXPORT BOOL ncsComponentConnectEvents (mComponent *comps, NCS_EVENT_CONNECT_INFO *connects, int counts)
    connect the events between parent and its children, used by ncsCreateMainWindowIndirectFromID
  • MGNCS_EXPORT BOOL ncsIsClass (const char *className, mComponentClass *clss)
    check a class name is a special class type or not
  • MGNCS_EXPORT BOOL ncsIsChildClass (const char *childClassName, const char *parentClassName)
    check a class name is derived class of a special class
  • MGNCS_EXPORT BOOL ncsRegisterComponent (mComponentClass *compCls, DWORD dwStyle, DWORD dwExStyle, int idCursor, int idBkColor)
    register a component class into MiniGUI, so that ncsCreateWindow and ncsCreateWindow can find a mComponentClass instance
  • MGNCS_EXPORT mComponentClass * ncsGetComponentClass (const char *className, BOOL check)
    Get a mComponentClass instance from MiniGUI.

Variables

  • MGNCS_EXPORT mComponentClass g_stmComponentCls
    the singleton of mComponentClass

Detailed Description

Author:
dongjunjie
Date:
2009/04/16
This file include the base object defines

 *
 * 	This file is part of mgncs, new control of MiniGUI
 *
 *

Definition in file mcomponent.h.

Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mcontainer.h File Reference

include

mcontainer.h File Reference

Go to the source code of this file.

Defines

  • #define NCSCTRL_CONTAINER NCSCLASSNAME("container")
    The control class name of mContainer.
  • #define NCSS_CTNR_SHIFT NCSS_SWGT_SHIFT
    The bits used by mContainer in style.

Enumerations

  • enum mContainerNotify { NCSN_CTNR_MAX = NCSN_SWGT_MAX + 1 }
    The notification code id of mContainer. More...

Variables

  • MGNCS_EXPORT mContainerClass g_stmContainerCls
    The instance of mContainerClass.

Detailed Description

Author:
XiaoweiYan
Date:
2009/02/24
This file includes the definition of mContainer control.

    Copyright (C) 2009 Feynman Software.

    All rights reserved by Feynman Software.

    This file is part of mgncs, which is new control
    set of MiniGUI.

Definition in file mcontainer.h.

Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mdblist.h File Reference

include

mdblist.h File Reference

Go to the source code of this file.

Data Structures

  • struct list_head
    The structure of double linked list. More...

Defines

  • #define list_entry(ptr, type, member) ((type *)((char *)(ptr)-(unsigned long)(&((type *)0)->member)))
    Get the struct for this entry.
  • #define list_for_each(pos, head) for (pos = (head)->next; pos != (head); pos = pos->next)
    Iterate over a list.
  • #define list_for_each_safe(pos, n, head)
    Iterate over a list safe against removal of list entry.
  • #define list_for_each_ex(pos, head, begin) for (pos = (begin)->next; pos != (head); pos = (pos)->next)
    Iterate over a list.
  • #define list_for_index(pos, i, head, index) for (pos = (head)->next, i=0; (pos != (head) && i < index); pos = pos->next,i++)
    Iterate over a list for index.

Typedefs

  • typedef struct list_head list_t
    The structure of double linked list.

Functions

  • static void list_add (struct list_head *_new, struct list_head *head)
    Add a _new entry, insert a _new entry after the specified head. This is good for implementing stacks.
  • static void list_add_tail (struct list_head *_new, struct list_head *head)
    Add a _new entry, insert a _new entry before the specified head. This is useful for implementing queues.
  • static void list_del (struct list_head *entry)
    Deletes entry from list. Note: list_empty on entry does not return true after this, the entry is in an undefined state.
  • static void list_del_init (struct list_head *entry)
    Deletes entry from list and reinitialize it.
  • static int list_empty (struct list_head *head)
    Tests whether a list is empty.

Detailed Description

Author:
Date:
This file includes the list operations.

    Copyright (C) 2009 Feynman Software.

    All rights reserved by Feynman Software.

    This file is part of mgncs, which is new control
    set of MiniGUI.

Definition in file mdblist.h.

Define Documentation

#define list_entry | ( | ptr,
 |  | type,
 |  | member | ) | ((type *)((char *)(ptr)-(unsigned long)(&((type *)0)->member)))

Get the struct for this entry.

Parameters:
ptr | The &struct list_head pointer.
type | The type of the struct this is embedded in.
member | The name of the list_struct within the struct.

Definition at line 172 of file mdblist.h.

#define list_for_each | ( | pos,
 |  | head | ) | for (pos = (head)->next; pos != (head); pos = pos->next)

Iterate over a list.

Parameters:
pos | The &struct list_head to use as a loop counter.
head | The head for your list.

Definition at line 181 of file mdblist.h.

#define list_for_each_ex | ( | pos,
 |  | head,
 |  | begin | ) | for (pos = (begin)->next; pos != (head); pos = (pos)->next)

Iterate over a list.

Parameters:
pos | The &struct list_head to use as a loop counter.
head | The head for your list.
begin | The previous item of the begining item

Definition at line 202 of file mdblist.h.

#define list_for_each_safe | ( | pos,
 |  | n,
 |  | head | )

Value:

for (pos = (head)->next, n = pos->next; pos != (head); \
        pos = n, n = pos->next)
Iterate over a list safe against removal of list entry.

Parameters:
pos | The &struct list_head to use as a loop counter.
n | Another &struct list_head to use as temporary storage
head | The head for your list.

Definition at line 191 of file mdblist.h.

#define list_for_index | ( | pos,
 |  | i,
 |  | head,
 |  | index | ) | for (pos = (head)->next, i=0; (pos != (head) && i < index); pos = pos->next,i++)

Iterate over a list for index.

Parameters:
pos | The &struct list_head to use as a loop counter.
i | The index used to record current position.
head | The head for your list.
index | The maximum index for your list.

Definition at line 214 of file mdblist.h.

Typedef Documentation

list_t

The structure of double linked list.

Definition at line 53 of file mdblist.h.

Function Documentation

void list_add | ( | struct list_head * | _new,
 |  | struct list_head * | head |
 | ) |  |  | [inline, static]

Add a _new entry, insert a _new entry after the specified head. This is good for implementing stacks.

Parameters:
_new | _new entry to be added
head | list head to add it after
Insert a _new entry after the specified head. This is good for implementing stacks.

Definition at line 95 of file mdblist.h.

References list_head::next.

void list_add_tail | ( | struct list_head * | _new,
 |  | struct list_head * | head |
 | ) |  |  | [inline, static]

Add a _new entry, insert a _new entry before the specified head. This is useful for implementing queues.

Parameters:
_new | _new entry to be added
head | list head to add it before
Insert a _new entry before the specified head. This is useful for implementing queues.

Definition at line 110 of file mdblist.h.

References list_head::prev.

void list_del ( struct list_head * entry ) [inline, static]

Deletes entry from list. Note: list_empty on entry does not return true after this, the entry is in an undefined state.

Definition at line 136 of file mdblist.h.

References list_head::next, and list_head::prev.

void list_del_init ( struct list_head * entry ) [inline, static]

Deletes entry from list and reinitialize it.

Parameters:
entry The element to delete from the list.

Definition at line 147 of file mdblist.h.

References list_head::next, and list_head::prev.

int list_empty ( struct list_head * head ) [inline, static]

Tests whether a list is empty.

Parameters:
head The list to test.

Definition at line 159 of file mdblist.h.

References list_head::next.

Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: medit.h File Reference

include

medit.h File Reference

Go to the source code of this file.

Defines

  • #define NCSS_EDIT_LEFT (0x0000L<<NCSS_SCRLV_SHIFT)
    left align edit
  • #define NCSS_EDIT_CENTER (0x0001L<<NCSS_SCRLV_SHIFT)
    center align edit
  • #define NCSS_EDIT_RIGHT (0x0002L<<NCSS_SCRLV_SHIFT)
    right align edit
  • #define NCSS_EDIT_UPPERCASE (0x0004L<<NCSS_SCRLV_SHIFT)
    uppercase edit
  • #define NCSS_EDIT_LOWERCASE (0x0008L<<NCSS_SCRLV_SHIFT)
    lowercase edit
  • #define NCSS_EDIT_NOHIDESEL (0x0010L<<NCSS_SCRLV_SHIFT)
    When lose the focus, it is still selected.
  • #define NCSS_EDIT_READONLY (0x0020L<<NCSS_SCRLV_SHIFT)
    readonly
  • #define NCSS_EDIT_BASELINE (0x0040L<<NCSS_SCRLV_SHIFT)
    show text with base line.

Enumerations

  • enum mEditProp { NCSP_EDIT_LIMITTEXT = NCSP_SCRLV_MAX + 1, NCSP_EDIT_CARETPOS }
    the Property of edit More...
  • enum mEditNotify {
    NCSN_EDIT_SETFOCUS = NCSN_ITEMV_SETFOCUS, NCSN_EDIT_KILLFOCUS = NCSN_ITEMV_KILLFOCUS, NCSN_EDIT_CHANGE = NCSN_SCRLV_MAX + 1, NCSN_EDIT_CONTCHANGED,
    NCSN_EDIT_UPDATE, NCSN_EDIT_SELCHANGED, NCSN_EDIT_MAXTEXT
    }

Variables

  • MGNCS_EXPORT mEditClass g_stmEditCls
    the instance of mEditClass

Detailed Description

Author:
Wangjian<wangjian@minigui.org>
Date:
2009/07/13
This file includes the definition of mEdit control.

    Copyright (C) 2009 Feynman Software.

    All rights reserved by Feynman Software.

    This file is part of mgncs, which is new control set of MiniGUI.

Definition in file medit.h.

Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mgncs.h File Reference

include

mgncs.h File Reference

Go to the source code of this file.

Typedefs

  • typedef mMainWnd *(* PNCS_CREATE_MAIN )(HPACKAGE, HWND hParent, HICON h_icon, HMENU h_menu, DWORD)

Functions

  • MGNCS_EXPORT BOOL ncsInitialize (void)
    Register all controls and other classes in the MGNCS.

Detailed Description

Author:
Date:
2009/02
This file includes the common structure and API of ncs.

    Copyright (C) 2009 Feynman Software.

    All rights reserved by Feynman Software.

    This file is part of mgncs, which is new control
    set of MiniGUI.

Definition in file mgncs.h.

Typedef Documentation

typedef mMainWnd*(* PNCS_CREATE_MAIN)(HPACKAGE, HWND hParent, HICON h_icon, HMENU h_menu, DWORD)

$Id:$

Copyright (C) 2009 Feynman Software.

Definition at line 141 of file mgncs.h.

Function Documentation

BOOL ncsInitialize ( void )

Register all controls and other classes in the MGNCS.

Unregister all controls and other classes in the MGNCS.

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: miconview.h File Reference

include

miconview.h File Reference

Go to the source code of this file.

Data Structures

  • struct _NCS_ICONV_ITEMINFO

Defines

  • #define NCSCTRL_ICONVIEW NCSCLASSNAME("iconview")
    The control class name of mIconView.
  • #define NCSS_ICONV_SHIFT (NCSS_SCRLV_SHIFT)
    The bits used by mIconView in style.
  • #define NCSS_ICONV_SORT NCSS_ITEMV_AUTOSORT
  • #define NCSS_ICONV_LOOP NCSS_ITEMV_LOOP

Enumerations

  • enum mIconViewProp { NCSP_ICONV_DEFICONHEIGHT = NCSP_ITEMV_DEFITEMHEIGHT, NCSP_ICONV_DEFICONWIDTH = NCSP_ITEMV_MAX + 1, NCSP_ICONV_MAX }
    The properties id of mIconView. More...
  • enum mIconViewNotify { , NCSN_ICONV_MAX = NCSN_ITEMV_MAX + 1 }
    The notification code id of mIconView. More...

Variables

  • MGNCS_EXPORT mIconViewClass g_stmIconViewCls
    The instance of mIconViewClass.

Detailed Description

Author:
XiaoweiYan
Date:
2009/06/13
This file includes the definition of IconView.

    Copyright (C) 2009 Feynman Software.

    All rights reserved by Feynman Software.

    This file is part of mgncs, which is new control
    set of MiniGUI.

Definition in file miconview.h.

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: minvisible-component.h File Reference

include

minvisible-component.h File Reference

Go to the source code of this file.

Data Structures

  • struct _NCS_INVSB_CREATE_INFO

Enumerations

  • enum ncsInvsbCompProp
    the invisible component property define More...

Functions

  • MGNCS_EXPORT mInvsbComp * ncsCreateInvsbComp (const char *class_name, mComponent *parent, int id, NCS_PROP_ENTRY *props, NCS_EVENT_HANDLER *handlers, DWORD user_data)
    create an Invisible Component
  • MGNCS_EXPORT mInvsbComp * ncsCreateInvsbCompIndirect (const char *class_name, NCS_INVSB_CREATE_INFO *create_info)
    create an Invisible Component from creating info

Variables

  • MGNCS_EXPORT mInvsbCompClass g_stmInvsbCompCls
    the singleton mInvsbCompClass

Detailed Description

Author:
dongjunjie
Date:
2009/04/19
This file include the base object defines

 *
 * 	This file is part of mgncs, new control of MiniGUI
 *
 *

Definition in file minvisible-component.h.

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mitem.h File Reference

include

mitem.h File Reference

Go to the source code of this file.

Defines

  • #define hEditor HWND
    The handle of item editor.
  • #define NCSF_ITEM_SHIFT 4
    The bits used by mItem in flags.
  • #define NCSF_ITEM_MASK 0xFFFF
    The mask of item flags.
  • #define NCSF_ITEM_NORMAL 0x0000
    Normal item.
  • #define NCSF_ITEM_SELECTED 0x0001
    Selected item.
  • #define NCSF_ITEM_DISABLED 0x0002
    Disabled item.
  • #define NCSF_ITEM_USEBITMAP 0x0004
    The item with bitmap.
  • #define NCSF_ITEM_USEICON 0x0008
    The item with icon.
  • #define NCSF_ITEM_IMAGEMASK (NCSF_ITEM_USEBITMAP | NCSF_ITEM_USEICON)
    The mask of item image/icon style.

Typedefs

  • typedef GHANDLE HITEM
    The handle of item widget.

Enumerations

  • enum mItemProp { NCSP_ITEM_HEIGHT = 1, NCSP_ITEM_FLAGS, NCSP_ITEM_MAX }
    The properties id of mItem. More...

Variables

  • MGNCS_EXPORT mItemClass g_stmItemCls
    The instance of mItemClass.

Detailed Description

Author:
XiaoweiYan
Date:
2009/02/24
This file includes the definition of mItem.

    Copyright (C) 2009 Feynman Software.

    All rights reserved by Feynman Software.

    This file is part of mgncs, which is new control
    set of MiniGUI.

Definition in file mitem.h.

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mitem_manager.h File Reference

include

mitem_manager.h File Reference

Go to the source code of this file.

Defines

  • #define NCSF_ITMMNG_AUTOSORT (0x01<<NCSF_ITEM_SHIFT)
    Sort items automatically.
  • #define NCSF_ITMMNG_FROZEN (0x02<<NCSF_ITEM_SHIFT)
    Allow manager to refresh items or not.
  • #define NCSF_ITMMNG_SHIFT (NCSF_ITEM_SHIFT+2)
    The bits used by mItemManager in flags.

Typedefs

  • typedef int(* NCS_CB_CMPITEM )(mItemManager *manager, HITEM hItem1, HITEM hItem2)
    The callback of item compare function.
  • typedef int(* NCS_CB_CMPSTR )(const char *s1, const char *s2, size_t n)
    The Callback of general string compare function.

Enumerations

  • enum mItemManagerProp { NCSP_ITMMNG_FLAGS = NCSP_ITEM_FLAGS, NCSP_ITMMNG_ITEMCOUNT = NCSP_ITEM_MAX + 1, NCSP_ITMMNG_TOTALHEIGHT, NCSP_ITMMNG_MAX }
    The properties id of mItemManager. More...

Variables

  • MGNCS_EXPORT mItemManagerClass g_stmItemManagerCls
    The instance of mItemManagerClass.

Detailed Description

Author:
XiaoweiYan
Date:
2009/02/24
This file includes the definition of ItemManager.

    Copyright (C) 2009 Feynman Software.

    All rights reserved by Feynman Software.

    This file is part of mgncs, which is new control
    set of MiniGUI.

Definition in file mitem_manager.h.

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mitemview.h File Reference

include

mitemview.h File Reference

Go to the source code of this file.

Defines

  • #define NCSCTRL_ITEMVIEW NCSCLASSNAME("itemview")
    The name of mItemView control.
  • #define NCSS_ITEMV_AUTOSORT (0x0002<<NCSS_SWGT_SHIFT)
    Sort items automatically.
  • #define NCSS_ITEMV_LOOP (0x0004<<NCSS_SWGT_SHIFT)
    Travel all items circularly.
  • #define NCSS_ITEMV_SINGLE (0x0000<<NCSS_SWGT_SHIFT)
    Only have a selected item simultaneously.
  • #define NCSS_ITEMV_MULTIPLE (0x0008<<NCSS_SWGT_SHIFT)
    Allow user to select multiple items. Reserved.
  • #define NCSS_ITEMV_SHIFT (NCSS_SWGT_SHIFT+4)
    The bits used by mItemView in style.

Typedefs

  • typedef int(* NCS_CB_INITITEM )(mItemView *self, HITEM hItem)
    The callback of initializing item.
  • typedef void(* NCS_CB_DSTRITEM )(mItemView *self, HITEM hItem)
    The callback of destroying item.
  • typedef void(* NCS_CB_DRAWITEM )(mItemView *self, HITEM hItem, HDC hdc, RECT *rcDraw)
    The callback of drawing item.

Enumerations

  • enum mItemViewProp { NCSP_ITEMV_DEFITEMHEIGHT = NCSP_SWGT_MAX + 1, NCSP_ITEMV_ITEMCOUNT, NCSP_ITEMV_MAX }
    The properties id of mItemView. More...
  • enum mItemViewNotify {
    NCSN_ITEMV_CLICKED = NCSN_WIDGET_CLICKED, NCSN_ITEMV_SELCHANGING = NCSN_SWGT_MAX + 1, NCSN_ITEMV_SELCHANGED, NCSN_ITEMV_ENTER,
    NCSN_ITEMV_SETFOCUS, NCSN_ITEMV_KILLFOCUS, NCSN_ITEMV_MAX
    }
    The notification code id of mItemView. More...

Variables

  • MGNCS_EXPORT mItemViewClass g_stmItemViewCls
    The instance of mItemViewClass.

Detailed Description

Author:
XiaoweiYan
Date:
2009/06/15
This file includes the definition of mItemView.

    Copyright (C) 2009 Feynman Software.

    All rights reserved by Feynman Software.

    This file is part of mgncs, which is new control
    set of MiniGUI.

Definition in file mitemview.h.

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mlist.h File Reference

include

mlist.h File Reference

Go to the source code of this file.

Defines

  • #define NCSCTRL_LIST NCSCLASSNAME("list")
    the name of mList
  • #define NCSS_LIST_LOOP (0x0001<<NCSS_ASTLST_SHIFT)
    Travel all items circularly.
  • #define NCSS_LIST_MULTIPLE (0x0002<<NCSS_ASTLST_SHIFT)
    Allow user to select multiple items. Reserved.
  • #define NCSS_LIST_SHIFT (NCSS_ASTLST_SHIFT+2)
    The bits used by mList in style.

Enumerations

  • enum ncsListLayoutID { NCS_LIST_LLIST = 0, NCS_LIST_LICONV , NCS_LIST_MAX }
    The layout id of mList. More...
  • enum mListProp { NCSP_LIST_LAYOUT = NCSP_ASTLST_MAX + 1, NCSP_LIST_DEFNODEWIDTH, NCSP_LIST_DEFNODEHEIGHT, NCSP_LIST_MAX }
    The properties id of mList. More...
  • enum mListNotify {
    NCSN_LIST_SELCHANGED = NCSN_ASTLST_MAX + 1, NCSN_LIST_ENTER, NCSN_LIST_BACKSPACE, NCSN_LIST_ENTERSUBLIST,
    NCSN_LIST_BACKUPLIST , NCSN_LIST_MAX
    }
    The notification id of mList. More...

Variables

  • MGNCS_EXPORT mListClass g_stmListCls
    The instance of mListClass.

Detailed Description

Author:
XiaoweiYan
Date:
2009/11/10
This file includes the definition of mList.

    Copyright (C) 2009~2010 Feynman Software.

    All rights reserved by Feynman Software.

    This file is part of mgncs, which is new control
    set of MiniGUI.

Definition in file mlist.h.

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mlist_layout.h File Reference

include

mlist_layout.h File Reference

Go to the source code of this file.

Enumerations

  • enum mListLayoutProp { , NCSP_LIST_LAYOUT_MAX }
    The properties id of mListLayout. More...
  • enum mLHCenterBoxLayoutProp { NCSP_HCBOX_LAYOUT_OFFX = NCSP_LIST_LAYOUT_MAX + 1, NCSP_HCBOX_LAYOUT_MAX }
    The properties id of mLHCenterBoxLayoutProp. More...
  • enum mLGroupLayoutProp { , NCSP_LGROUP_LAYOUT_MAX }
    The properties id of mLGroupLayout. More...

Variables

  • MGNCS_EXPORT mListLayoutClass g_stmListLayoutCls
    The instance of mListLayoutClass.

Detailed Description

Author:
XiaoweiYan
Date:
2009/11/10
This file includes the definition of mListLayout.

    Copyright (C) 2009~2010 Feynman Software.

    All rights reserved by Feynman Software.

    This file is part of mgncs, which is new control
    set of MiniGUI.

Definition in file mlist_layout.h.

Enumeration Type Documentation

enum mLGroupLayoutProp

The properties id of mLGroupLayout.

Enumerator:
NCSP_LGROUP_LAYOUT_MAX The maximum value of mLGroupLayout properties id.

Definition at line 233 of file mlist_layout.h.

enum mLHCenterBoxLayoutProp

The properties id of mLHCenterBoxLayoutProp.

Enumerator:
NCSP_HCBOX_LAYOUT_OFFX | The x offset value.
NCSP_HCBOX_LAYOUT_MAX | The maximum value of mHCenterBoxLayout properties id.

Definition at line 172 of file mlist_layout.h.

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mlistbox.h File Reference

include

mlistbox.h File Reference

Go to the source code of this file.

Data Structures

  • struct _NCS_LSTBOX_ITEMINFO

Defines

  • #define NCSCTRL_LISTBOX NCSCLASSNAME("listbox")
    The control class name of mListBox.
  • #define NCSS_LSTBOX_SHIFT (NCSS_ITEMV_SHIFT+4)
    The bits used by mListBox in style.
  • #define NCSS_LSTBOX_SINGLE NCSS_ITEMV_SINGLE
    Only have a selected item simultaneously.
  • #define NCSS_LSTBOX_MULTIPLE NCSS_ITEMV_MULTIPLE
    Allow user to select multiple items.
  • #define NCSS_LSTBOX_SORT NCSS_ITEMV_AUTOSORT
    Sort strings alphabetically.
  • #define NCSS_LSTBOX_MOUSEFOLLOW (0x0001<<NCSS_ITEMV_SHIFT)
    When mouse moved, change the selected item. Only for NCSS_LSTBOX_SINGLE.
  • #define NCSS_LSTBOX_STRING (0x0000<<NCSS_ITEMV_SHIFT)
    Display a string in an item.
  • #define NCSS_LSTBOX_USEBITMAP (0x0002<<NCSS_ITEMV_SHIFT)
    Display a icon or bitmap in an item.
  • #define NCSS_LSTBOX_CHECKBOX (0x0004<<NCSS_ITEMV_SHIFT)
    Display a check box in an item.
  • #define NCSS_LSTBOX_AUTOCHECK (0x0008<<NCSS_ITEMV_SHIFT)
    Auto-switch the check box between checked or un-checked when the user click the check mark box of an item.
  • #define NCSS_LSTBOX_AUTOCHECKBOX (NCSS_LSTBOX_CHECKBOX | NCSS_LSTBOX_AUTOCHECK)
    Set the style NCSS_LSTBOX_CHECKBOX and NCSS_LSTBOX_AUTOCHECK.
  • #define NCSF_LSTBOX_CMBLANK (0x0000<<NCSF_ITEM_SHIFT)
    The item is blank.
  • #define NCSF_LSTBOX_CMCHECKED (0x0001<<NCSF_ITEM_SHIFT)
    The flag of checked item.
  • #define NCSF_LSTBOX_CMPARTCHECKED (0x0002<<NCSF_ITEM_SHIFT)
    The flag is partly checked item.
  • #define NCSF_LSTBOX_CHECKMASK (NCSF_LSTBOX_CMBLANK | NCSF_LSTBOX_CMCHECKED | NCSF_LSTBOX_CMPARTCHECKED)
    The flag mask of check mark or image.
  • #define NCSF_LSTBOX_BOLD (0x0004<<NCSF_ITEM_SHIFT)
    The flag of bold item.
  • #define NCSF_LSTBOX_SIGNIFICANT (0x0008<<NCSF_ITEM_SHIFT)
    The flag of significant item.

Enumerations

  • enum mListBoxProp {
    NCSP_LSTBOX_ITEMWIDTH = NCSP_SWGT_CONTWIDTH, NCSP_LSTBOX_ITEMCOUNT = NCSP_ITEMV_ITEMCOUNT, NCSP_LSTBOX_ITEMHEIGHT = NCSP_ITEMV_MAX + 1, NCSP_LSTBOX_TOPITEM,
    NCSP_LSTBOX_HILIGHTEDITEM, NCSP_LSTBOX_MAX
    }
    The properties id of mListBox. More...
  • enum mListBoxNotify {
    NCSN_LSTBOX_CLICKED = NCSN_ITEMV_CLICKED, NCSN_LSTBOX_SELCHANGED = NCSN_ITEMV_SELCHANGED, NCSN_LSTBOX_ENTER = NCSN_ITEMV_ENTER, NCSN_LSTBOX_SETFOCUS = NCSN_ITEMV_SETFOCUS,
    NCSN_LSTBOX_KILLFOCUS = NCSN_ITEMV_KILLFOCUS, NCSN_LSTBOX_ERRSPACE = NCSN_ITEMV_MAX + 1, NCSN_LSTBOX_DBCLK, NCSN_LSTBOX_CMCANCEL ,
    NCSN_LSTBOX_CLKCHKMARK, NCSN_LSTBOX_MAX
    }
    The notification code id of mListBox. More...

Variables

  • MGNCS_EXPORT mListBoxClass g_stmListBoxCls
    The instance of mListBoxClass.

Detailed Description

Author:
XiaoweiYan
Date:
2009/02/24
This file includes the definition of ListBox.

    Copyright (C) 2009 Feynman Software.

    All rights reserved by Feynman Software.

    This file is part of mgncs, which is new control
    set of MiniGUI.

Definition in file mlistbox.h.

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mlistcolumn.h File Reference

include

mlistcolumn.h File Reference

Go to the source code of this file.

Defines

  • #define NCSF_LSTCLM_LEFTALIGN (0x00<<NCSF_ITEM_SHIFT)
    Horizontal left align.
  • #define NCSF_LSTCLM_RIGHTALIGN (0x01<<NCSF_ITEM_SHIFT)
    Horizontal right align.
  • #define NCSF_LSTCLM_CENTERALIGN (0x02<<NCSF_ITEM_SHIFT)
    Horizontal center align.
  • #define NCSF_LSTCLM_TOPALIGN (0x00<<NCSF_ITEM_SHIFT)
    Vertical top align.
  • #define NCSF_LSTCLM_BOTTOMALIGN (0x04<<NCSF_ITEM_SHIFT)
    Vertical bottom align.
  • #define NCSF_LSTCLM_VCENTERALIGN (0x08<<NCSF_ITEM_SHIFT)
    Vertical center align.
  • #define NCSF_LSTCLM_VALIGNMASK (0x0C<<NCSF_ITEM_SHIFT)
    The mask of vertical align.
  • #define NCSF_LSTCLM_SHIFT (NCSF_ITEM_SHIFT+4)
    The bits used by mListColumn in flags.

Typedefs

  • typedef int(* NCS_CB_LISTV_CMPCLM )(HITEM nItem1, HITEM nItem2, NCS_LSTCLM_SORTDATA *sortData)
    The callback of comparison column function.

Enumerations

  • enum ncsLstClmSortType { NCSID_LSTCLM_NOTSORTED = 0, NCSID_LSTCLM_HISORTED, NCSID_LSTCLM_LOSORTED }
    The sort type. More...
  • enum mListColumnProp {
    NCSP_LSTCLM_POSX = NCSP_ITEM_MAX + 1, NCSP_LSTCLM_WIDTH, NCSP_LSTCLM_SORTTYPE, NCSP_LSTCLM_CMPFUNC,
    NCSP_LSTCLM_MAX
    }
    The properties id of mListColumn. More...

Variables

  • MGNCS_EXPORT mListColumnClass g_stmListColumnCls
    The instance of mListColumnClass.

Detailed Description

Author:
XiaoweiYan
Date:
2009/02/24
This file includes the definition of mListColumn.

    Copyright (C) 2009 Feynman Software.

    All rights reserved by Feynman Software.

    This file is part of mgncs, which is new control
    set of MiniGUI.

Definition in file mlistcolumn.h.

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mlistitem.h File Reference

include

mlistitem.h File Reference

Go to the source code of this file.

Defines

  • #define NCSF_LSTITM_FOLD (0x0001<<NCSF_ITMMNG_SHIFT)
    fold item.
  • #define NCSF_LSTITM_PRIVBKCOL (0x0002<<NCSF_ITMMNG_SHIFT)
    background for item.
  • #define NCSF_LSTITM_PRIVFGCOL (0x0004<<NCSF_ITMMNG_SHIFT)
    foreground for item.
  • #define NCSF_LSTITM_SHIFT (NCSF_ITMMNG_SHIFT + 3)
    The bits used by mListItem in flags.

Enumerations

  • enum mListItemProp { NCSP_LSTITM_NRCHILD = NCSP_ITMMNG_MAX + 1, NCSP_LSTITM_DEPTH, NCSP_LSTITM_RHEIGHT, NCSP_LSTITM_MAX }
    The properties id of mListItem. More...

Variables

  • MGNCS_EXPORT mListItemClass g_stmListItemCls
    The instance of mListItemClass.

Detailed Description

Author:
XiaoweiYan
Date:
2009/02/24
This file includes the definition of mListItem.

    Copyright (C) 2009 Feynman Software.

    All rights reserved by Feynman Software.

    This file is part of mgncs, which is new control
    set of MiniGUI.

Definition in file mlistitem.h.

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mlistview.h File Reference

include

mlistview.h File Reference

Go to the source code of this file.

Data Structures

  • struct _NCS_LISTV_FINDINFO
  • struct _NCS_LISTV_CLMINFO
  • struct _NCS_LISTV_ITEMDATA
  • struct _NCS_LISTV_ITEMINFO
  • struct _NCS_CB_LISTV_CSTMHDROPS

Defines

  • #define NCSF_LSTHDR_LEFTALIGN (0x00<<NCSF_LSTCLM_SHIFT)
    Horizontal left align.
  • #define NCSF_LSTHDR_TOPALIGN (0x00<<NCSF_LSTCLM_SHIFT)
    Vertical top align.
  • #define NCSF_LSTHDR_RIGHTALIGN (0x01<<NCSF_LSTCLM_SHIFT)
    Horizontal right align.
  • #define NCSF_LSTHDR_CENTERALIGN (0x02<<NCSF_LSTCLM_SHIFT)
    Horizontal center align.
  • #define NCSF_LSTHDR_BOTTOMALIGN (0x04<<NCSF_LSTCLM_SHIFT)
    Vertical bottom align.
  • #define NCSF_LSTHDR_VCENTERALIGN (0x08<<NCSF_LSTCLM_SHIFT)
    Vertical center align.
  • #define NCSF_LSTHDR_VALIGNMASK (0x0C<<NCSF_LSTCLM_SHIFT)
    The mask of vertical align.
  • #define NCSF_LSTHDR_SHIFT (NCSF_LSTCLM_SHIFT+4)
    The bits used by header in flags.
  • #define NCSCTRL_LISTVIEW NCSCLASSNAME("listview")
    The control class name of mListView.
  • #define NCSS_LISTV_NOTIFY NCSS_NOTIFY
  • #define NCSS_LISTV_LOOP NCSS_ITEMV_LOOP
  • #define NCSS_LISTV_MULTIPLE NCSS_ITEMV_MULTIPLE
  • #define NCSS_LISTV_SINGLE NCSS_ITEMV_SINGLE
  • #define NCSS_LISTV_CHECKBOX (0x0001<<NCSS_ITEMV_SHIFT)
    Display a check box in an item. Reserved.
  • #define NCSS_LISTV_AUTOCHECK (0x0002<<NCSS_ITEMV_SHIFT)
    Auto-switch the check box between checked or un-checked when the user click the check mark box of an item. Reserved.
  • #define NCSS_LISTV_AUTOCHECKBOX (NCSS_LISTV_CHECKBOX | NCSS_LISTV_AUTOCHECK)
    Set the style NCSS_LISTV_CHECKBOX and NCSS_LISTV_AUTOCHECK. Reserved.
  • #define NCSS_LISTV_TREE (0x0004<<NCSS_ITEMV_SHIFT)
    Uses listview in a treeview style.
  • #define NCSS_LISTV_WITHICON (0x0008<<NCSS_ITEMV_SHIFT)
    Use icons to indicate folded or unfolded status.
  • #define NCSS_LISTV_SORT (0x0010<<NCSS_ITEMV_SHIFT)
    Sort items automatically.
  • #define NCSS_LISTV_NOHDRDRAG (0x0020<<NCSS_ITEMV_SHIFT)
    User cann't change column width by dragging header's border.
  • #define NCSS_LISTV_SHIFT (NCSS_ITEMV_SHIFT + 6)
    The bits used by mListView in style.

Typedefs

  • typedef void(* NCS_CB_LISTV_DRAWHDRBK )(mListView *self, HITEM hHdr, HDC hdc, RECT *rcDraw)
  • typedef void(* NCS_CB_LISTV_DRAWHDR )(mListView *self, HITEM hHdr, HDC hdc, RECT *rcDraw)

Enumerations

  • enum ncsListVIRType {
    NCSID_LISTV_IR_PARENT, NCSID_LISTV_IR_FIRSTCHILD, NCSID_LISTV_IR_LASTCHILD, NCSID_LISTV_IR_NEXTSIBLING,
    NCSID_LISTV_IR_PREVSIBLING
    }
    The relationship between items. More...
  • enum ncsListVFindType { NCSID_LISTV_FT_ADDDATA, NCSID_LISTV_FT_TEXT }
    The found type. More...
  • enum mListViewProp {
    NCSP_LISTV_DEFITEMHEIGHT = NCSP_ITEMV_DEFITEMHEIGHT, NCSP_LISTV_ROWCOUNT = NCSP_ITEMV_ITEMCOUNT, NCSP_LISTV_HDRHEIGHT = NCSP_ITEMV_MAX + 1, NCSP_LISTV_HDRWIDTH,
    NCSP_LISTV_HDRVISIBLE, NCSP_LISTV_SORTCOLUMN, NCSP_LISTV_GRIDLINEWIDTH, NCSP_LISTV_GRIDLINECOLOR,
    NCSP_LISTV_COLCOUNT, NCSP_LISTV_MAX
    }
    The properties id of mListView. More...
  • enum mListViewNotify {
    NCSN_LISTV_CLICKED = NCSN_ITEMV_CLICKED, NCSN_LISTV_SELCHANGED = NCSN_ITEMV_SELCHANGED, NCSN_LISTV_ITEMRDOWN = NCSN_ITEMV_MAX + 1, NCSN_LISTV_ITEMRUP,
    NCSN_LISTV_HDRRDOWN, NCSN_LISTV_HDRRUP, NCSN_LISTV_ITEMDBCLK, NCSN_LISTV_FOLDITEM,
    NCSN_LISTV_UNFOLDITEM, NCSN_LISTV_MAX
    }
    The notification code id of mListView. More...

Variables

  • MGNCS_EXPORT mListViewClass g_stmListViewCls
    The instance of mListViewClass.

Detailed Description

Author:
XiaoweiYan
Date:
2009/06/13
This file includes the definition of ListView.

    Copyright (C) 2009 Feynman Software.

    All rights reserved by Feynman Software.

    This file is part of mgncs, which is new control
    set of MiniGUI.

Definition in file mlistview.h.

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mmledit.h File Reference

include

mmledit.h File Reference

Go to the source code of this file.

Defines

  • #define NCSS_MLEDIT_AUTOWRAP (0x0001<<NCSS_EDIT_SHIFT)
    Automatically wraps against border when inputting.
  • #define NCSS_MLEDIT_TITLE (0x0002<<NCSS_EDIT_SHIFT)
    Shows specified title texts.

Enumerations

  • enum mMlEditProp {
    NCSP_MLEDIT_LINECOUNT = NCSP_EDIT_MAX + 1, NCSP_MLEDIT_LINEHEIGHT, NCSP_MLEDIT_LINEFEEDISPCHAR, NCSP_MLEDIT_LINESEP,
    NCSP_MLEDIT_CARETSHAPE, NCSP_MLEDIT_NUMOFPARAGRAPHS
    }
  • enum ncsCaretShape { NCS_CARETSHAPE_LINE = 0, NCS_CARETSHAPE_BLOCK }

Variables

  • MGNCS_EXPORT mMlEditClass g_stmMlEditCls
    the instance of mMlEditClass

Detailed Description

Author:
Wangjian<wangjian@minigui.org>
Date:
2009/07/13
This file includes the definition of mMlEdit control.

    Copyright (C) 2009 Feynman Software.

    All rights reserved by Feynman Software.

    This file is part of mgncs, which is new control set of MiniGUI.

Definition in file mmledit.h.

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mnode.h File Reference

include

mnode.h File Reference

Go to the source code of this file.

Defines

  • #define NCSS_NODE_LTEXTRS 0x0000
    Image on the left and text on the right. default style.
  • #define NCSS_NODE_SMALLICON 0x0001
    Small icon mode. Show small icon in normal status, or enlarge icon in selected status.
  • #define NCSS_NODE_LTEXTBS 0x0002
    Large Icon mode. Image on the top and text on the bottom.
  • #define NCSS_NODE_TICTACTOEMIDLET 0x0004
    tictactoemidlet mode. Image includes normal and selected status.
  • #define NCSS_NODE_HIDETEXT 0x0010
    Don't show text.
  • #define NCSS_NODE_HIDEIMAGE 0x0020
    Don't show image.
  • #define NCSS_NODE_DISABLED 0x0040
    Disabled Node.
  • #define NCSS_NODE_SHIFT 7
    The bits used by mNode in style.

Typedefs

  • typedef int(* NCS_CB_CMPNODE )(mNode *node1, mNode *node2)
    The callback of node comparison function.

Enumerations

  • enum ncsNodeFindType { NCS_NODE_FTSTRING, NCS_NODE_FTDATA, NCS_NODE_FTIMAGE }
    The found information type used by findNode. More...
  • enum mNodeEvent {
    NCSE_NODE_CONTENTCHANGED = 1, NCSE_NODE_HEIGHTCHANGED, NCSE_NODE_REFRESH, NCSE_NODE_NODEADDED,
    NCSE_NODE_NODEDELETED
    }
    The event id of mNode. More...
  • enum mNodeProp {
    NCSP_NODE_HEIGHT = 1, NCSP_NODE_TEXT, NCSP_NODE_IMAGE, NCSP_NODE_ADDDATA,
    NCSP_NODE_ENABLED, NCSP_NODE_SELECTED, NCSP_NODE_PARENTNODE, NCSP_NODE_FIRSTCHILD,
    NCSP_NODE_LASTCHILD, NCSP_NODE_CHILDRENCOUNT, NCSP_NODE_LAYOUT, NCSP_NODE_HIDETEXT,
    NCSP_NODE_HIDEIMAGE, NCSP_NODE_MAX
    }
    The properties id of mNode. More...

Functions

  • MGNCS_EXPORT mNode * ncsCreateNode (mObject *parent, const char *text, PBITMAP image, int height, int style, DWORD addData)
    Create a new node according to parameter information.
  • MGNCS_EXPORT mNode * ncsAddNode (mObject *parent, const char *text, PBITMAP image, int height, int style, DWORD addData)
    Create and add a new node to control according to parameter information.

Variables

  • MGNCS_EXPORT mNodeClass g_stmNodeCls
    The instance of mNodeClass.
  • MGNCS_EXPORT mGroupNodeClass g_stmGroupNodeCls
    The instance of mGroupNodeClass.

Detailed Description

Author:
XiaoweiYan
Date:
2009/11/10
This file includes the definition of mNode.

    Copyright (C) 2009~2010 Feynman Software.

    All rights reserved by Feynman Software.

    This file is part of mgncs, which is new control
    set of MiniGUI.

Definition in file mnode.h.

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mobject.h File Reference

include

mobject.h File Reference

Go to the source code of this file.

Defines

  • #define _c(ths) (ths)->_class
    the marco get the class of a object
  • #define _IM(piobj, method,...) (piobj)->_vtable->method(INTEFACE_ADJUST(piobj), ##__VA_ARGS__)
    call the interface object
  • #define TYPENAME(obj) ((obj)?(((obj)->_class)?((obj)->_class)->typeName:""):"")
    Get the class name form a Object pointer.
  • #define INSTANCEOF(obj, clss) ncsInstanceOf((mObject*)(obj), (mObjectClass*)(void*)(&Class(clss)))
    A wrapper of ncsInstanceOf, just like java's instanceof.
  • #define CHECKOBJ(obj) ncsIsValidObj((mObject*)obj)
    the wrapper of ncsIsValidObj
  • #define TYPE_CAST(Type, obj) ((Type*)(obj))
    unsafe cast. donot check the type of class
  • #define SAFE_CAST(Type, obj) TYPE_CAST(Type, ncsSafeCast((mObject*)obj,(mObjectClass*)(void*)(&(Class(Type)))))
    wrapper of ncsSafeCast, check the class type before cast.
  • #define SAFE_CAST_CLASS(Clss, ClssCast) ((ClassType(ClssCast)*)(ncsSafeCastClass((mObjectClass*)Clss, (mObjectClass*)(void*)(&Class(ClssCast)))))
    the wrapper of ncsSafeCastClass

Typedefs

  • typedef mObjectClass *(* PClassConstructor )(mObjectClass *)
    the Class initialize callback
  • typedef void(* PCONSTRUCT_DWORD )(void *self, DWORD addData)
  • typedef BOOL(* NCS_CB_ONOBJEVENT )(mObject *self, mObject *sender, int eventId, DWORD param)
    The Callback of connection.

Functions

  • static mObject * _initObject (mObject *pobj, mObjectClass *_class, DWORD param)
  • static mObject * initObjectArgs (mObject *pobj, mObjectClass *_class,...)
  • MGNCS_EXPORT mObject * newObject (mObjectClass *_class)
    new a object instance, like new operator in C++
  • MGNCS_EXPORT void deleteObject (mObject *obj)
    delete a object intance, like delete operator in C++
  • MGNCS_EXPORT BOOL ncsInstanceOf (mObject *object, mObjectClass *clss)
    check an object is the class instance or not, same as instanceof operator in Java
  • static mObject * ncsIsValidObj (mObject *obj)
    Check a pointer is a valid mObject or not.
  • MGNCS_EXPORT mObject * ncsSafeCast (mObject *obj, mObjectClass *clss)
    safe type cast function, like the dynamic_cast operator in C++
  • MGNCS_EXPORT mObjectClass * ncsSafeCastClass (mObjectClass *clss, mObjectClass *castCls)
    cast from a supper class to derived class type safely
  • MGNCS_EXPORT BOOL ncsAddEventListener (mObject *sender, mObject *listener, NCS_CB_ONOBJEVENT eventProc, int eventId)
    connect sender object to listener object
  • MGNCS_EXPORT BOOL ncsAddEventListeners (mObject *sender, mObject *listener, NCS_CB_ONOBJEVENT eventProc, int *eventIds)
    connect a group of events from sender to listener
  • MGNCS_EXPORT BOOL ncsRemoveEventListener (mObject *listener)
    remove the connections which are listened by the object
  • MGNCS_EXPORT BOOL ncsRemoveEventConnect (mObject *listener, mObject *source, int eventId)
    remove a special event connect
  • MGNCS_EXPORT BOOL ncsRemoveEventSource (mObject *sender)
    remove the connections when a sender is destroied
  • MGNCS_EXPORT void ncsRaiseEvent (mObject *sender, int eventId, DWORD param)
    raise an event to listeners

Variables

  • MGNCS_EXPORT mObjectClass g_stmObjectCls
    the singleton of mObjectClass, represent a class object

Detailed Description

Author:
dongjunjie
Date:
2009/04/16
This file include the basic object defines

 *
 * 	This file is part of mgncs, new control of MiniGUI
 *
 *

Definition in file mobject.h.

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mpage.h File Reference

include

mpage.h File Reference

Go to the source code of this file.

Defines

  • #define NCSCTRL_PAGE NCSCLASSNAME("page")
    The control class name of mPage.
  • #define NCSS_PAGE_SHIFT NCSS_CTNR_SHIFT
    The bits used by mPage in style.

Typedefs

  • typedef void(* NCS_CB_ONINITPAGE )(mPage *self, DWORD addData)
    the callback of the event MSG_INITPAGE. Initialize the controls in page.
  • typedef int(* NCS_CB_ONSHOWPAGE )(mPage *self, HWND focusChild, int showCmd)
    the callback of the event MSG_SHOWPAGE. Shows or hides page.
  • typedef int(* NCS_CB_ONSHEETCMD )(mPage *self, DWORD param1, DWORD param2)
    the callback of the MSG_SHEETCMD. Process broadcast message.

Variables

  • MGNCS_EXPORT mPageClass g_stmPageCls
    The instance of mPageClass.

Detailed Description

Author:
XiaoweiYan
Date:
2009/03/05
This file includes the definition of mPage control.

    Copyright (C) 2009 Feynman Software.

    All rights reserved by Feynman Software.

    This file is part of mgncs, which is new control
    set of MiniGUI.

Definition in file mpage.h.

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mpanel.h File Reference

include

mpanel.h File Reference

Go to the source code of this file.

Defines

  • #define NCSCTRL_PANEL NCSCLASSNAME("panel")
    The control class name of mPanel.
  • #define NCSS_PANEL_SHIFT NCSS_WIDGET_SHIFT
    The bits used by mPanel in style.

Enumerations

  • enum mPanelProp { NCSP_PANEL_MAX = NCSP_WIDGET_MAX + 1 }
    The properties id of mPanel. More...
  • enum mPanelNotify { NCSN_PANEL_MAX = NCSN_WIDGET_MAX + 1 }
    The notification code id of mPanel. More...

Variables

  • MGNCS_EXPORT mPanelClass g_stmPanelCls
    The instance of mPanelClass.

Detailed Description

Author:
XiaoweiYan
Date:
2009/02/24
This file includes the definition of mPanel control.

    Copyright (C) 2009 Feynman Software.

    All rights reserved by Feynman Software.

    This file is part of mgncs, which is new control
    set of MiniGUI.

Definition in file mpanel.h.

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mprogressbar.h File Reference

include

mprogressbar.h File Reference

Go to the source code of this file.

Defines

  • #define NCSS_PRGBAR_HORIZONTAL 0x0000L
    horizontal progressbar
  • #define NCSS_PRGBAR_VERTICAL (0x0001L<<NCSS_WIDGET_SHIFT)
    vertical progressbar
  • #define NCSS_PRGBAR_BLOCKS (0x0002L<<NCSS_WIDGET_SHIFT)
    progressbar show with blocks
  • #define NCSS_PRGBAR_SMOOTH (0x0000L<<NCSS_WIDGET_SHIFT)
    progressbar show smooth
  • #define NCSS_PRGBAR_SHOWPERCENT (0x0004L<<NCSS_WIDGET_SHIFT)
    progressbar with percentage "0%~100%"

Enumerations

  • enum mProgressBarProp { NCSP_PROG_MAXPOS = NCSP_WIDGET_MAX + 1, NCSP_PROG_MINPOS, NCSP_PROG_CURPOS, NCSP_PROG_LINESTEP }
    ProgressBar Properties define. More...

Variables

  • MGNCS_EXPORT mProgressBarClass g_stmProgressBarCls
    the instance of mProgressBarClass

Detailed Description

Author:
Wangjian<wangjian@minigui.org>
Date:
2009/03/01
This file includes the definition of mProgressBar control.

    Copyright (C) 2009 Feynman Software.

    All rights reserved by Feynman Software.

    This file is part of mgncs, which is new control set of MiniGUI.

Definition in file mprogressbar.h.

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mpropsheet.h File Reference

include

mpropsheet.h File Reference

Go to the source code of this file.

Defines

  • #define NCSCTRL_PROPSHEET NCSCLASSNAME("propsheet")
    The control class name of mPropSheet.
  • #define NCSS_PRPSHT_SHIFT NCSS_WIDGET_SHIFT+3
    The bits used by mPropSheet in style.
  • #define NCSS_PRPSHT_COMPACTTAB (0x0001<<NCSS_WIDGET_SHIFT)
    A simple property sheet control. All tabs of the controls will have the same width.
  • #define NCSS_PRPSHT_SCROLLABLE (0x0002<<NCSS_WIDGET_SHIFT)
    Tab can be scrolled by scrolled button.
  • #define NCSS_PRPSHT_TOP (0x0000<<NCSS_WIDGET_SHIFT)
    Top tab style. Tabs will be located at the top of the propsheet.
  • #define NCSS_PRPSHT_BOTTOM (0x0004<<NCSS_WIDGET_SHIFT)
    Bottom tab style. Tabs will be located at the bottom of the propsheet.

Enumerations

  • enum ncsPrpShtFlags {
    NCSF_PRPSHT_BORDER, NCSF_PRPSHT_TAB, NCSF_PRPSHT_LEFT, NCSF_PRPSHT_RIGHT,
    NCSF_PRPSHT_PAGE, NCSF_PRPSHT_MAX
    }
    The flag of mPropSheet. It is used by mPropSheetRenderer. More...
  • enum mPropSheetNotify { NCSN_PRPSHT_ACTIVECHANGED = NCSN_WIDGET_MAX + 1, NCSN_PRPSHT_MAX }
    The notification code id of mPropSheet. More...
  • enum mPropSheetProp {
    NCSP_PRPSHT_MINTABWIDTH = NCSP_WIDGET_MAX + 1, NCSP_PRPSHT_TABMARGIN, NCSP_PRPSHT_ACTIVEPAGE, NCSP_PRPSHT_ACTIVEPAGEIDX,
    NCSP_PRPSHT_FIRSTVIEWPAGE, NCSP_PRPSHT_FIRSTVIEWPAGEIDX, NCSP_PRPSHT_PAGECOUNT
    }
    The properties of mPropSheet. More...

Variables

  • MGNCS_EXPORT mPropSheetClass g_stmPropSheetCls
    The instance of mPropSheetClass.

Detailed Description

Author:
XiaoweiYan
Date:
2009/02/26
This file includes the definition of mPropSheet control.

    Copyright (C) 2009 Feynman Software.

    All rights reserved by Feynman Software.

    This file is part of mgncs, which is new control
    set of MiniGUI.

Definition in file mpropsheet.h.

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mrdr.h File Reference

include

mrdr.h File Reference

Go to the source code of this file.

Data Structures

  • struct _NCS_RDR_ENTRY
  • #define NCS_TYPE_MASK WE_ATTR_TYPE_MASK
  • #define ncsGetElement(self, id) ncsGetElementEx((mWidget*)self, NULL, id)
    Get the value of element id in specified window.
  • #define ncsSetElement(self, id, value) ncsSetElementEx((mWidget*)self, NULL, id, value)
    Set the value of element id in specified window.
  • MGNCS_EXPORT DWORD ncsGetElementEx (mWidget *self, const char *rdrName, int id)
    Get the value of element id in specified window or renderer.
  • MGNCS_EXPORT DWORD ncsSetElementEx (mWidget *self, const char *rdrName, int id, DWORD value)
    Set the value of element id in specified window or renderer.
  • MGNCS_EXPORT GHANDLE ncsLoadRdrEtcFile (const char *etcfile, const char **rdrName, int count)
    Load renderer configure file from file system or incore mode.
  • MGNCS_EXPORT int ncsUnloadRdrEtcFile (GHANDLE hEtcFile)
    Unload renderer configuration file.
  • MGNCS_EXPORT mWidgetRenderer * ncsRetriveCtrlRDR (const char *rendererName, const char *className)
    get a renderer of special control
  • MGNCS_EXPORT BOOL ncsRegisterCtrlRDR (const char *rendererName, const char *className, mWidgetRenderer *renderer)
    register one of implemention of a special control into system
  • MGNCS_EXPORT void ncsUnregisterCtrlRDRs (const char *rdrName, const char *className)
    unregister a special rdr
  • MGNCS_EXPORT BOOL ncsRegisterCtrlRDRs (const char *rendererName, NCS_RDR_ENTRY *entries, int count)
    register a group of renderers into system
  • MGNCS_EXPORT BOOL ncsSetSystemRenderer (const char *name)
    Set the System renderer. If a system renderer would be used by all the controls who haven't been set the property "renderer", see mWidget and mWidgetRenderer.
  • MGNCS_EXPORT const char * ncsGetSystemRenderer (void)
    get the system renderer name

Defines

  • #define INVALID_RDR_VALUE ((DWORD)-1)
    invalid renderer element value

Detailed Description

Author:
dongjunjie
Date:
2009/02/13
This file include the base renderer information of ncs.

 *
 *  This file is part of ncs, define the interface of LF Renderer
 *
 *

Definition in file mrdr.h.

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mresmgr.h File Reference

include

mresmgr.h File Reference

Go to the source code of this file.

Data Structures

  • struct _NCSRM_HEADER
  • struct _NCSRM_TYPEITEM
  • struct _NCSRM_IDITEM
  • struct _NCSRM_WINHEADER
  • struct _NCSRM_SECTHEADER
  • struct _NCSRM_DEFLOCALE_INFO
  • struct _NCSRM_LOCALEITEM
  • struct _NCSRM_INCORE_IMAGE
  • struct _NCSRM_RDRINFO
  • struct _NCSRM_RDRHEADER
  • struct _NCSRM_PROP

Defines

  • #define HPACKAGE_NULL 0
    Null resource package handle.
  • #define NCSRM_SYSSTR_BASEID 1
    Base value of system string id.
  • #define NCSRM_SYSSTR_DEFRDR (NCSRT_STRING << 16) |NCSRM_SYSSTR_BASEID
    The system string id of default renderer.
  • #define NCSRT_EXT_LEN 15
    The maximum length of resource extension.
  • #define NCSRM_VERSION_LEN 4
    The maximum length of resource package version.
  • #define NCSRM_VENDOR_LEN 16
    The maximum length of vendor.
  • #define NCSRM_ENCODING_LEN 16
    The maximum length of encoding.
  • #define ncsLoadResPackage ncsLoadResPackageFromFile
    An alias of ncsLoadResPackageFromFile.

Typedefs

  • typedef unsigned int HPACKAGE
    Handle to resource package.

Enumerations

  • enum ncsRMRdrResType {
    NCSRM_RDRTYPE_COLOR = 0, NCSRM_RDRTYPE_METRIC, NCSRM_RDRTYPE_IMAGE, NCSRM_RDRTYPE_FONT,
    NCSRM_RDRTYPE_BINARY, NCSRM_RDRTYPE_STRING, NCSRM_RDRTYPE_FILE, NCSRM_RDRTYPE_TEXT,
    NCSRM_RDRTYPE_MAX
    }
    Renderer resource type. More...

Functions

  • MGNCS_EXPORT const char * ncsSetDefaultLocale (char *language, char *country)
    Set default locale information.
  • MGNCS_EXPORT const char * ncsGetDefaultLocale (void)
    Get default locale information.
  • MGNCS_EXPORT HPACKAGE ncsLoadResPackageFromFile (const char *fileName)
    Load a resource package from resource package file.
  • MGNCS_EXPORT int ncsAddRefResPackage (HPACKAGE package)
    add the reference count for resource package
  • MGNCS_EXPORT void ncsUnloadResPackage (HPACKAGE package)
    Unload a resource package.
  • MGNCS_EXPORT HPACKAGE ncsLoadResPackageFromMem (const void *mem, int size)
    Load a resource package from memory. User get the information of incore resource package by getIncoreResPackInfo firstly, then call this function to load resource package.
  • MGNCS_EXPORT const char * ncsGetImageFileName (HPACKAGE package, Uint32 resId)
    Get the name of image file.
  • MGNCS_EXPORT int ncsGetBitmap (HDC hdc, HPACKAGE package, Uint32 resId, PBITMAP pBitmap)
    Load a device-dependent bitmap from resource id.
  • MGNCS_EXPORT void ncsReleaseBitmap (PBITMAP pBitmap)
    Releases a bitmap.
  • MGNCS_EXPORT int ncsGetMyBitmap (HPACKAGE package, Uint32 resId, PMYBITMAP myBmp, RGB *pal)
    Load a device-independent bitmap from resource id.
  • MGNCS_EXPORT void ncsReleaseMyBitmap (PMYBITMAP myBmp)
    Releases a bitmap.
  • MGNCS_EXPORT const char * ncsGetString (HPACKAGE package, Uint32 resId)
    Get string.
  • MGNCS_EXPORT BOOL ncsSetSysRdr (HPACKAGE package, Uint32 rdrSetId)
    Set system renderer.
  • MGNCS_EXPORT BOOL ncsSetWinRdr (HWND hWnd, HPACKAGE package, Uint32 rdrId)
    Set window renderer.
  • MGNCS_EXPORT mMainWnd * ncsCreateMainWindowIndirectFromID (HPACKAGE package, Uint32 wndId, HWND owner, HICON hIcon, HMENU hMenu, NCS_EVENT_HANDLER_INFO *handlers, NCS_EVENT_CONNECT_INFO *connects, DWORD user_data)
    Create main window.
  • MGNCS_EXPORT int ncsCreateModalDialogFromID (HPACKAGE package, Uint32 dlgId, HWND owner, HICON hIcon, HMENU hMenu, NCS_EVENT_HANDLER_INFO *handlers, NCS_EVENT_CONNECT_INFO *connects)
    Create modal dialog.
  • MGNCS_EXPORT BOOL ncsGetWndTemplFromID (HPACKAGE package, Uint32 wndId, NCS_MNWND_TEMPLATE *ptempl, NCS_EVENT_HANDLER_INFO *handlers)
    get the window template from package
  • MGNCS_EXPORT void ncsFreeWndTemplate (NCS_MNWND_TEMPLATE *ptempl)
    free the window template create by ncsGetWndTemplFromID

Detailed Description

Author:
XiaoweiYan
Date:
2009/04/01
This file includes the definition of resource managerment.

    Copyright (C) 2009 Feynman Software.

    All rights reserved by Feynman Software.

    This file is part of mgncs, which is new control
    set of MiniGUI.

Definition in file mresmgr.h.

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mscroll_widget.h File Reference

include

mscroll_widget.h File Reference

Go to the source code of this file.

Defines

  • #define NCSCTRL_SCROLLWIDGET NCSCLASSNAME("scrollwidget")
    the name of mScrollWidget control
  • #define NCSS_SWGT_SHIFT NCSS_WIDGET_SHIFT
    The bits used by mScrollWidget in style.

Enumerations

  • enum ncsSwgtDrawMode { NCSID_SWGT_AUTO = 0, NCSID_SWGT_ALWAYS, NCSID_SWGT_NEVER }
    Scroll bar drawing mode in ScrollWidget. More...
  • enum mScrollWidgetProp {
    NCSP_SWGT_CONTWIDTH = NCSP_WIDGET_MAX + 1, NCSP_SWGT_CONTHEIGHT, NCSP_SWGT_CONTX, NCSP_SWGT_CONTY,
    NCSP_SWGT_HSTEPVALUE, NCSP_SWGT_VSTEPVALUE, NCSP_SWGT_VISWIDTH, NCSP_SWGT_VISHEIGHT,
    NCSP_SWGT_MARGINRECT, NCSP_SWGT_DRAWMODE, NCSP_SWGT_MAX
    }
    The properties id of mScrollWidget. More...
  • enum mScrollWidgetNotify { NCSN_SWGT_MAX = NCSN_WIDGET_MAX + 1 }
    The notification code id of mScrollWidget. More...

Variables

  • MGNCS_EXPORT mScrollWidgetClass g_stmScrollWidgetCls
    The instance of mScrollWidgetClass.

Detailed Description

Author:
XiaoweiYan
Date:
2009/02/24
This file includes the definition of ScrollWidget.

    Copyright (C) 2009 Feynman Software.

    All rights reserved by Feynman Software.

    This file is part of ncs, which is new control
    set of MiniGUI.

Definition in file mscroll_widget.h.

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mscrollbar.h File Reference

include

mscrollbar.h File Reference

Go to the source code of this file.

Defines

  • #define NCSP_SCRLBR_MAXPOS NCSP_SLIDER_MAXPOS
    The value of the maximum position.
  • #define NCSP_SCRLBR_MINPOS NCSP_SLIDER_MINPOS
    The value of the minimum position.
  • #define NCSP_SCRLBR_CURPOS NCSP_SLIDER_CURPOS
    The value of the current position.
  • #define NCSP_SCRLBR_LINESTEP NCSP_SLIDER_LINESTEP
    The line step length.
  • #define NCSP_SCRLBR_PAGESTEP NCSP_SLIDER_PAGESTEP
    The page step length.
  • #define NCSS_SCRLBR_HORIZONTAL NCSS_SLIDER_HORIZONTAL
    horizontal scrollbar.
  • #define NCSS_SCRLBR_ARROWS (1<<NCSS_SLIDER_SHIFT)
    indicate that the scrollbar has arrows or doesn't
  • #define NCSS_SCRLBR_LEFTDBLARROWS (2<<NCSS_SLIDER_SHIFT)
    indicate that the scrollbar has two arrows in the left side
  • #define NCSS_SCRLBR_UPDBLARROWS NCSS_SCRLBR_LEFTDBLARROWS
    indicate that the scrollbar has two arrows in the up side
  • #define NCSS_SCRLBR_RIGHTDBLARROWS (4<<NCSS_SLIDER_SHIFT)
    indicate that the scrollbar has two arrows in the right side
  • #define NCSS_SCRLBR_DOWNDBLARROWS NCSS_SCRLBR_RIGHTDBLARROWS
    indicate that the scrollbar has two arrows in the down side
  • #define NCSS_SCRLBR_VERTICAL NCSS_SLIDER_VERTICAL
    vertical scrollbar.
  • #define NCSN_SCRLBR_CHANGED NCSN_SLIDER_CHANGED
    positon changed notify code.
  • #define NCSN_SCRLBR_REACHMAX NCSN_SLIDER_REACHMAX
    reached the maximum position notify code.
  • #define NCSN_SCRLBR_REACHMIN NCSN_SLIDER_REACHMIN
    reached the minimum position notify code.

Variables

  • MGNCS_EXPORT mScrollBarClass g_stmScrollBarCls
    the instance of mScrollBarClass

Detailed Description

Author:
Wangjian<wangjian@minigui.org>
Date:
2009/03/01
This file includes the definition of mScrollBar control.

    Copyright (C) 2009 Feynman Software.

    All rights reserved by Feynman Software.

    This file is part of mgncs, which is new control set of MiniGUI.

Definition in file mscrollbar.h.

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mscrollview.h File Reference

include

mscrollview.h File Reference

Go to the source code of this file.

Data Structures

  • struct _NCS_SCRLV_ITEMINFO

Defines

  • #define NCSCTRL_SCROLLVIEW NCSCLASSNAME("scrollview")
    The control class name of mScrollView.
  • #define NCSS_SCRLV_SHIFT (NCSS_ITEMV_SHIFT)
    The bits used by mScrollView in style.
  • #define NCSS_SCRLV_UPNOTIFY NCSS_ITEMV_UPNOTIFY
  • #define NCSS_SCRLV_LOOP NCSS_ITEMV_LOOP
  • #define NCSS_SCRLV_SORT NCSS_ITEMV_AUTOSORT

Enumerations

  • enum mScrollViewProp { NCSP_SCRLV_MAX = NCSP_ITEMV_MAX + 1 }
    The properties id of mScrollView. More...
  • enum mScrollViewNotify { NCSN_SCRLV_CLICKED = NCSN_ITEMV_CLICKED, NCSN_SCRLV_SELCHANGED = NCSN_ITEMV_SELCHANGED, NCSN_SCRLV_SELCHANGING = NCSN_ITEMV_SELCHANGING, NCSN_SCRLV_MAX = NCSN_ITEMV_MAX + 1 }
    The notification code id of mScrollView. More...

Variables

  • MGNCS_EXPORT mScrollViewClass g_stmScrollViewCls
    The instance of mScrollViewClass.

Detailed Description

Author:
XiaoweiYan
Date:
2009/06/13
This file includes the definition of ScrollView.

    Copyright (C) 2009 Feynman Software.

    All rights reserved by Feynman Software.

    This file is part of mgncs, which is new control
    set of MiniGUI.

Definition in file mscrollview.h.

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: msledit.h File Reference

include

msledit.h File Reference

Go to the source code of this file.

Defines

  • #define NCSS_SLEDIT_PASSWORD (0x0001L<<NCSS_EDIT_SHIFT)
    Displays an asterisk (*) for each character typed into the edit control.
  • #define NCSS_SLEDIT_AUTOSELECT (0x0002L<<NCSS_EDIT_SHIFT)
    Selects all text when getting focus.

Enumerations

  • enum mSlEditProp { NCSP_SLEDIT_TIPTEXT = NCSP_EDIT_MAX + 1, NCSP_SLEDIT_PWDCHAR }
  • enum mSlEditNotify { NCSN_SLEDIT_CHANGE = NCSN_EDIT_CHANGE, NCSN_SLEDIT_ENTER = NCSN_ITEMV_ENTER }

Variables

  • MGNCS_EXPORT mSlEditClass g_stmSlEditCls
    the instance of mSlEditClass

Detailed Description

Author:
Wangjian<wangjian@minigui.org>
Date:
2009/07/14
This file includes the definition of mSlEdit control.

    Copyright (C) 2009 Feynman Software.

    All rights reserved by Feynman Software.

    This file is part of mgncs, which is new control set of MiniGUI.

Definition in file msledit.h.

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mslider.h File Reference

include

mslider.h File Reference

Go to the source code of this file.

Defines

  • #define NCSS_SLIDER_HORIZONTAL 0x0000L
    horizontal slider
  • #define NCSS_SLIDER_VERTICAL (0x0001L<<NCSS_WIDGET_SHIFT)
    vertical slider

Enumerations

  • enum mSliderProp {
    NCSP_SLIDER_MAXPOS = NCSP_WIDGET_MAX + 1, NCSP_SLIDER_MINPOS, NCSP_SLIDER_CURPOS, NCSP_SLIDER_LINESTEP,
    NCSP_SLIDER_PAGESTEP
    }
  • enum enumSliderNotify { NCSN_SLIDER_CHANGED = NCSN_WIDGET_MAX, NCSN_SLIDER_REACHMAX, NCSN_SLIDER_REACHMIN }
  • enum mSliderHitTest

Variables

  • MGNCS_EXPORT mSliderClass g_stmSliderCls
    the instance of mSliderClass

Detailed Description

Author:
Wangjian<wangjian@minigui.org>
Date:
2009/03/01
This file includes the definition of mSlider control.

    Copyright (C) 2009 Feynman Software.

    All rights reserved by Feynman Software.

    This file is part of mgncs, which is new control set of MiniGUI.

Definition in file mslider.h.

Enumeration Type Documentation

enum mSliderHitTest

slider proctected function

Definition at line 186 of file mslider.h.

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mspinbox.h File Reference

include

mspinbox.h File Reference

Go to the source code of this file.

Defines

  • #define NCSS_SPNBOX_VERTICAL (NCSS_SPNR_VERTICAL)
    vertical spinbox
  • #define NCSS_SPNBOX_HORIZONTAL (NCSS_SPNR_HORIZONTAL)
    horizontal spinbox
  • #define NCSS_SPNBOX_AUTOLOOP (NCSS_SPNR_AUTOLOOP)
    the value of spinbox auto loop
  • #define NCSS_SPNBOX_NUMBER (0x0000L<<NCSS_SPNR_SHIFT)
    spinbox show number
  • #define NCSS_SPNBOX_STRING (0x0001L<<NCSS_SPNR_SHIFT)
    spinbox shown strings
  • #define NCSS_SPNBOX_SORT (0x0002L<<NCSS_SPNR_SHIFT)
    auto sort spinbox
  • #define NCSS_SPNBOX_EDITNOBORDER (0x0004L<<NCSS_SPNR_SHIFT)
    spinbox with no-border edit
  • #define NCSS_SPNBOX_EDITBASELINE (0x0008L<<NCSS_SPNR_SHIFT)
    spinbox with base-line edit
  • #define NCSS_SPNBOX_READONLY (0x0010L<<NCSS_SPNR_SHIFT)
    spinbox with read-only edit
  • #define NCSS_SPNBOX_UPPERCASE (0x0020L<<NCSS_SPNR_SHIFT)
    spinbox show uppercase
  • #define NCSS_SPNBOX_LOWERCASE (0x0040L<<NCSS_SPNR_SHIFT)
    spinbox show lowercase
  • #define NCSS_SPNBOX_AUTOFOCUS (0x0080L<<NCSS_SPNR_SHIFT)
    spinbox with auto-focus edit

Enumerations

  • enum mSpinBoxProp { NCSP_SPNBOX_MAXPOS =  NCSP_SPNR_MAXPOS,
NCSP_SPNBOX_MINPOS =  NCSP_SPNR_MINPOS,
NCSP_SPNBOX_CURPOS =  NCSP_SPNR_CURPOS,
NCSP_SPNBOX_LINESTEP =  NCSP_SPNR_LINESTEP
 }
  • enum mSpinBoxNotify { NCSN_SPNBOX_CHANGED =  NCSN_SPNR_CHANGED,
NCSN_SPNBOX_REACHMAX =  NCSN_SPNR_REACHMAX,
NCSN_SPNBOX_REACHMIN =  NCSN_SPNR_REACHMIN
 }

Detailed Description

Author:
Wangjian<wangjian@minigui.org>
Date:
2009/03/01
This file includes the definition of mSpinBox control.

    Copyright (C) 2009 Feynman Software.

    All rights reserved by Feynman Software.

    This file is part of mgncs, which is new control set of MiniGUI.

Definition in file mspinbox.h.

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mspinner.h File Reference

include

mspinner.h File Reference

Go to the source code of this file.

Defines

  • #define NCSS_SPNR_VERTICAL 0x0000L
    vertical spinner
  • #define NCSS_SPNR_HORIZONTAL ((0x0001L)<<(NCSS_WIDGET_SHIFT))
    horizontal spinner
  • #define NCSS_SPNR_AUTOLOOP ((0x0002L)<<(NCSS_WIDGET_SHIFT))
    auto loop spinner

Enumerations

  • enum mSpinnerProp {
    NCSP_SPNR_MAXPOS = NCSP_WIDGET_MAX + 1, NCSP_SPNR_MINPOS, NCSP_SPNR_CURPOS, NCSP_SPNR_LINESTEP,
    NCSP_SPNR_TARGET
    }
  • enum mSpinnerNotify { NCSN_SPNR_CHANGED = NCSN_WIDGET_MAX + 1, NCSN_SPNR_REACHMAX, NCSN_SPNR_REACHMIN }

Detailed Description

Author:
Wangjian<wangjian@minigui.org>
Date:
2009/03/01
This file includes the definition of mSpinner control.

    Copyright (C) 2009 Feynman Software.

    All rights reserved by Feynman Software.

    This file is part of mgncs, which is new control set of MiniGUI.

Definition in file mspinner.h.

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mtextedit.h File Reference

include

mtextedit.h File Reference

Go to the source code of this file.

Defines

  • #define _MGHAVE_TEXTEDITTITLE 1
  • #define NCSCTRL_TEXTEDITOR NCSCLASSNAME("texteditor")
    the name of mTextEditor
  • #define NCSS_TE_READONLY (1<<NCSS_WIDGET_SHIFT)
    The object is read-only.
  • #define NCSS_TE_UPPERCASE (2<<NCSS_WIDGET_SHIFT)
    The text is upper case.
  • #define NCSS_TE_LOWERCASE (4<<NCSS_WIDGET_SHIFT)
    The text is lower case.
  • #define NCSS_TE_NOHIDESEL (8<<NCSS_WIDGET_SHIFT)
    When lost the focus, it is still selected.
  • #define NCSS_TE_AUTOWRAP (0x10<<NCSS_WIDGET_SHIFT)
    Wrap text automatically.
  • #define NCSS_TE_BASELINE (0x20<<NCSS_WIDGET_SHIFT)
    Draw the base line.
  • #define NCSS_TE_OWNERBKGND (0x40<<NCSS_WIDGET_SHIFT)
    bkground is ower draw

Enumerations

  • enum ncsTEScrollMode { NCS_TEF_SCROLLBAR_NEVER = 0, NCS_TEF_SCROLLBAR_AUTO, NCS_TEF_SCROLLBAR_ALWAYS }
    Scroll bar drawing mode in TextEditor. More...
  • enum mTextEditorProp {
    NCSP_TE_READONLY = NCSP_WIDGET_MAX + 1, NCSP_TE_SCROLL_MODE, NCSP_TE_SCROLL_HSTEP, NCSP_TE_SCROLL_VSTEP,
    NCSP_TE_TEXTLIMIT, NCSP_TE_LINECOUNT, NCSP_TE_PARAGRAPHCOUNT, NCSP_TE_MARGINRECT,
    NCSP_TE_MAX
    }
    The properties id of mTextEditor. More...
  • enum mTextEditorNotify {
    NCSN_TE_CONTENTCHANGED = NCSN_WIDGET_MAX + 1, NCSN_TE_SETFOCUS, NCSN_TE_KILLFOCUS, NCSN_TE_MAXTEXT,
    NCSN_TE_CHANGE, NCSN_TE_UPDATE, NCSN_TE_SELCHANGED, NCSN_TE_MAX
    }
    The notification code id of mTextEditor. More...

Detailed Description

Author:
XiaoweiYan
Date:
2010/03/10
This file includes the definition of TextEditor.

    Copyright (C) 2010 Feynman Software.

    All rights reserved by Feynman Software.

    This file is part of mgncs, which is new control
    set of MiniGUI.

Definition in file mtextedit.h.

Define Documentation

#define _MGHAVE_TEXTEDITTITLE 1

Id
mtextedit.h 1096 2010-11-23 01:54:15Z dongjunjie

textedit.h: header for new text edit module.

Copyright (C) 2010 Feynman Software.

Create date: 2010/03/10

Definition at line 38 of file mtextedit.h.

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mtimer.h File Reference

include

mtimer.h File Reference

Go to the source code of this file.

Defines

  • #define NCSCTRL_TIMER NCSCLASSNAME("timer")
    the class name of mTimer

Typedefs

  • typedef BOOL(* NCS_CB_ONTIMER )(mTimer *timer, DWORD total_count)
    the callback of event MSG_TIMER

Enumerations

  • enum ncsTimerProp { NCSP_TIMER_INTERVAL = NCSP_IVCMPT_MAX + 1 }
    the mTimer's property define More...

Variables

  • MGNCS_EXPORT mTimerClass g_stmTimerCls
    the singleton of mTimerClass

Detailed Description

Author:
dongjunjie
Date:
2009/04/19
This file include the base object defines

 *
 * 	This file is part of mgncs, new control of MiniGUI
 *
 *

Definition in file mtimer.h.

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mtrackbar.h File Reference

include

mtrackbar.h File Reference

Go to the source code of this file.

Defines

  • #define NCSP_TRKBAR_MAXPOS NCSP_SLIDER_MAXPOS
    The value of the maximum position.
  • #define NCSP_TRKBAR_MINPOS NCSP_SLIDER_MINPOS
    The value of the minimum position.
  • #define NCSP_TRKBAR_CURPOS NCSP_SLIDER_CURPOS
    The value of the current position.
  • #define NCSP_TRKBAR_LINESTEP NCSP_SLIDER_LINESTEP
    The line step length.
  • #define NCSP_TRKBAR_PAGESTEP NCSP_SLIDER_PAGESTEP
    The page step length.
  • #define NCSS_TRKBAR_HORIZONTAL NCSS_SLIDER_HORIZONTAL
    horizontal TrackBar.
  • #define NCSS_TRKBAR_VERTICAL NCSS_SLIDER_VERTICAL
    vertical TrackBar.
  • #define NCSS_TRKBAR_NOTICK (0x0001L<<NCSS_SLIDER_SHIFT)
    TrackBar without tick.
  • #define NCSN_TRKBAR_CHANGED NCSN_SLIDER_CHANGED
    positon changed notify code.
  • #define NCSN_TRKBAR_REACHMAX NCSN_SLIDER_REACHMAX
    reached the maximum position notify code.
  • #define NCSN_TRKBAR_REACHMIN NCSN_SLIDER_REACHMIN
    reached the minimum position notify code.

Enumerations

  • enum mTrackBarProp { NCSP_TRKBAR_THUMB_WIDTH = NCSP_SLIDER_MAX + 1, NCSP_TRKBAR_THUMB_HEIGHT, NCSP_TRKBAR_MAX }
    The properties of mTrackBar. More...

Variables

  • MGNCS_EXPORT mTrackBarClass g_stmTrackBarCls
    the instance of mTrackBarClass

Detailed Description

Author:
Wangjian<wangjian@minigui.org>
Date:
2009/03/01
This file includes the definition of mTrackBar control.

    Copyright (C) 2009 Feynman Software.

    All rights reserved by Feynman Software.

    This file is part of mgncs, which is new control set of MiniGUI.

Definition in file mtrackbar.h.

Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • c
  • d
  • e
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • q
  • s
  • t

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- _ -

  • _c : mobject.h
  • _IM : mobject.h
  • _initObject() : mobject.h
  • _MGHAVE_TEXTEDITTITLE : mtextedit.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: Data Structures

  • Alphabetical List
  • Data Structures
  • Data Fields

Data Structures

Here are the data structures with brief descriptions:
_mButtonNode | List node include member button
_mMonthCalendarClass | MMonthCalendar class, derived from mWidget
_NCS_CB_LISTV_CSTMHDROPS
_NCS_CREATE_NOTIFY_INFO
_NCS_EVENT_CONNECT_INFO
_NCS_EVENT_HANDLER
_NCS_EVENT_HANDLER_NODE
_NCS_ICONV_ITEMINFO
_NCS_INVSB_CREATE_INFO
_NCS_LISTV_CLMINFO
_NCS_LISTV_FINDINFO
_NCS_LISTV_ITEMDATA
_NCS_LISTV_ITEMINFO
_NCS_LSTBOX_ITEMINFO
_NCS_MAIN_CREATE_INFO
_NCS_MNWND_TEMPLATE
_NCS_PROP_ENTRY
_NCS_RDR_ELEMENT
_NCS_RDR_ENTRY
_NCS_RDR_INFO
_NCS_SCRLV_ITEMINFO
_NCS_WND_TEMPLATE
_NCSRM_DEFLOCALE_INFO
_NCSRM_HEADER
_NCSRM_IDITEM
_NCSRM_INCORE_IMAGE
_NCSRM_LOCALEITEM
_NCSRM_PROP
_NCSRM_RDRHEADER
_NCSRM_RDRINFO
_NCSRM_SECTHEADER
_NCSRM_TYPEITEM
_NCSRM_WINHEADER
list_head | The structure of double linked list
mAbstractList | The structure of mAbstractList, which derived from mScrollWidget. It is the abstract superclass of all classes which represent controls that have nodes
mAbstractListClass | The virtual function table of mAbstractList, which derived from mScrollWidgetClass
mAbstractListRenderer | The structure of mAbstractList renderer, which inheried from mScrollWidgetRenderer
mButton | Button class, derived from mWidget
mButtonClass | Button struct of button control, derived from mWidgetClass
mButtonGroup | A group control, mamanger a list of buttons, in which only one button can be selected. Derived from mGroupBox
mButtonGroupClass | Struct of mButtonGroupClass control, derived from mGroupBoxClass
mButtonGroupRenderer | MButtonGroup renderer interface, derived from mGroupBoxRenderer
mButtonRenderer | Button class renderer interface, derived from mWidgetRenderer
mCheckButton | CheckButton, derived from mButton
mCheckButtonClass | Checkbutton class struct of button control, derived from mButtonClass
mCheckButtonRenderer | Checkbutton class renderer interface, derived from mButtonRenderer
mColorButton | A Button used to select a color, derived from mWidget
mColorButtonClass | Struct of colorbutton control class, derived from mWidgetClass
mColorButtonRenderer | Colorbutton renderer interface, derived from mWidgetRenderer
mCombobox | Struct of combobox control, derived from mPanel
mComboboxClass | VTable of mCombobox, derived from mPanelClass
mComboboxRenderer | Combobox class's Renderer interface, derived from mPanelRenderer
mComponent | Component member define
mComponentClass | Basic class of components, windows. Drived by mObjectClass
mContainer | The structure of mContainer, which derived from mScrollWidget. It is a control with scrollbars which is capable of containing other controls. When the user uses the scrollbars, it will scroll its content automatically
mContainerClass | The virtual function table of mContainer, which derived from mScrollWidgetClass
mContainerRenderer | The renderer structure of mContainer, which inheried from mScrollWidgetRenderer
mDialogBox | Members of mDialogBox, inherit from mMainWnd
mDialogBoxClass | VTable of mDialogBox, inherit from mMainWndClass
mDialogBoxRenderer | Renerer interface of mDialogBox, inherit from mMainWndRenderer
mEdit | Edit struct of edit control, derived from mScrollView
mEditClass | VTable of mEdit, derived from mScrollViewClass
mEditRenderer | Edit class's Renderer interface, derived from mScrollViewRenderer
mGroupBox | Groupbox class, derived from mStatic
mGroupBoxClass | Struct of groupbox control, derived from mStaticClass
mGroupBoxRenderer | Groupbox class renderer interface, derived from mStaticRenderer
mIconView | The structure of mItemView control, which derived from mScrollWidget. It is the abstract superclass of all classes which represent controls that have items
mIconViewClass | The virtual function table of mIconView, which derived from mItemViewClass
mIconViewRenderer | The structure of mIconView renderer, which derived from mItemViewRenderer
mImage | Static control can show a image, derived from mStatic
mImageClass | ImageClass struct of image control, derived from mStaticClass
mImageRenderer | Image class renderer interface, derived from mStaticRenderer
mInvsbComp | Define the mInvsbComp members , inherit from mComponent. An Invisible Component is a Component only support some functions, and user cannot see them
mInvsbCompClass | Define the VTable of mInvsbComp, inherit mComponentClass
mItem | The structure of mItem. It is the abstract superclass of all items occur within specific controls. For example, a listbox will contain string or bitmap items
mItemClass | The virtual function table of mItemClass
mItemManager | The structure of mItemManager control, which derived from mItem. It is the abstract superclass of all classes which managers items
mItemManagerClass | The virtual function table of mItemManager, which derived from mItemClass
mItemView | The structure of mItemView control, which derived from mScrollWidget. It is the abstract superclass of all classes which represent controls that have items
mItemViewClass | The virtual function table of mItemView, which derived from mScrollWidgetClass
mItemViewRenderer | The structure of mItemView renderer, which inheried from mScrollWidgetRenderer
mLEDLabel | LedLabel class, derived from mStatic
mLEDLabelClass | VTable of mLEDLabel, derived from mStaticClass
mLEDLabelRenderer | MLEDLabel renderer interface, derived from mStaticRenderer
mList | The structure of mList, which derived from mAbstractList. It is the normal list control that can show nodes in different layout
mListBox | The structure of mListBox control, which derived from mItemView
mListBoxClass | The virtual function table of mListBox, which derived from mItemViewClass
mListBoxRenderer | The structure of mListBox renderer, which derived from mWidgetRenderer
mListClass | The virtual function table of mList, which derived from mAbstractListClass
mListColumn | The structure of mListColumn. It's used as header by mListView
mListColumnClass | The virtual function table of mListColumn, which derived from mItemClass
mListItem | The structure of mListItem. It's used as item by mListView
mListItemClass | The virtual function table of mListItem, which derived from mItemManagerClass
mListRenderer | The structure of mList renderer, which inheried from mAbstractListRenderer
mListView The structure of mListView control, which derived from mItemView.
  • drawHdrBk
    User-defined function to draw header background.
  • drawHdrItem
    User-defined function to draw header item.
  • hdrList
    The header list.
  • rootItem
    Root item.
  • sort
    Current sort type.
  • curCol
    The index of current sort column.
  • gridLineWidth
    The width of grid line.
  • gridLineColor
    The color of grid line.
  • pfnSort
    The callback of sort function.
  • hdrH
    The height of header.
  • hdrW
    The width of header.
  • dragedHead
    The index of current draged header.
  • drawX
    The x coordinate when dragging header.
  • clickedHead
    The pointer to current clicked header.
  • status
mListViewClass | The virtual function table of mListView, which derived from mItemViewClass
mListViewRenderer | The structure of mListView renderer, which derived from mItemViewRenderer
mMainWnd | Define the memders of mMainWnd, inherit from mPanel
mMainWndClass | VTable of mMainWnd, inherit from mPanelClass
mMainWndRenderer | mMainWnd renderer interface, inherit from mPanelRenderer
mMenuButton | MenuButton member defintion, derived from mButton
mMenuButtonClass | MenuButton class , derived from mButtonClass
mMenuButtonRenderer | MenuButton class renderer interface, derived from mButtonRenderer
mMlEdit | Multiline edit control, derived from mEdit
mMlEditClass | VTable of mMlEdit, derived from mEditClass
mMlEditRenderer | MlEdit class's Renderer interface, derived from mEditRenderer
mMonthCalender | Member of mMonthCalendar Control derived from mWidget
mNode | The structure of mNode. It is the basic class of all nodes occur within specific controls. For example, a list can contain it
mNodeClass | The virtual function table of mNodeClass
mObject | Object struct
mObjectClass | Basic object class of NCS
mPage | The control structure of mPage, which derived from mContainer. It is a control which will be used as page in mPage. Please don't use it separately
mPageClass | The virtual function table of mPage, which derived from mContainerClass
mPageRenderer | The renderer structure of mPage, which inheried from mContainerRenderer
mPanel | The structure of mPanel control, which derived from mWidget. It is a control which is capable of containing other controls
mPanelClass | The virtual function table of mPanelClass, which derived from mWidgetClass
mPanelRenderer | The structure of mPanel renderer, which derived from mWidgetRenderer
mPopMenuMgr | Members of mPropMenuMgr
mPopMenuMgrClass | MPopMenuMgr class, derived from mObject
mProgressBar | Control to indicate the processing of a work, derived from mWidget
mProgressBarClass | VTable of mProgressBar, derived from mWidgetClass
mProgressBarRenderer | ProgressBar class's Renderer interface, derived from mWidgetRenderer
mPropSheet | Propsheet control mananager a group of mPage, inherited from mWidget
mPropSheetClass | The virtual function table of mPropSheet
mPropSheetRenderer | The structure of mPropSheet renderer, which inheried from mWidgetRenderer
mRadioButton | Define the member of Radiobutton, derived from mCheckButton
mRadioButtonClass | Radiobutton struct of control, derived from mCheckButtonClass
mRadioButtonRender | Radiobutton renderer interface, derived from mCheckButtonRenderer
mRectangle | The control show a rectangle or round rectangle, derived from mWidget
mRectangleClass | Struct of rectangle control, derived from mWidgetClass
mRectangleRenderer | Rectangle renderer interface, derived from mWidgetRenderer
mScrollBar | Scrollbar struct of scrollbar control, derived from mSlider
mScrollBarClass | VTable of mScrollBar, derived from mSliderClass
mScrollBarRenderer | ScrollBar class's Renderer interface, derived from mSliderRenderer
mScrollView | The structure of mScrollView control, which derived from mItemView
mScrollViewClass | The virtual function table of mScrollView, which derived from mItemViewClass
mScrollViewRenderer | The structure of mScrollView renderer, which inheried from mItemViewRenderer
mScrollWidget | The structure of mScrollWidget control, which derived from mWidget. It is the abstract superclass of all classes which represent controls that have standard scroll bars
mScrollWidgetClass | The virtual function table of mScrollWidget, which derived from mWidgetClass
mScrollWidgetRenderer | The structure of mScrollWidget renderer, which inheried from mWidgetRenderer
mSeparator | Separator class, derived from mStatic
mSeparatorClass | Struct of separator control, derived from mStaticClass
mSeparatorRenderer | Separator class renderer interface, derived from mStaticRenderer
mSlEdit | Single line control, derived from mEdit
mSlEditClass | VTable of mSlEdit, derived from mEditClass
mSlEditRenderer | SlEdit class's Renderer interface, derived from mEditRenderer
mSlider | Slider struct of slider control, derived from mWidget
mSliderClass | VTable of mSlider, derived from mWidgetClass
mSliderRenderer | Slider class's Renderer interface, derived from mWidgetRenderer
mSpinBox | Spinbox struct of spinbox control, derived from mSpinner
mSpinBoxClass | VTable of mSpinBox, derived from mSpinnerClass
mSpinBoxRenderer | Spinner class's Renderer interface, derived from mSpinnerRenderer
mSpinner | Spinner struct of spinner control, derived from mWidget
mSpinnerClass | VTable of mSpinner, derived from mWidgetClass
mSpinnerRenderer | SpinBox class's Renderer interface, derived from mWidgetRenderer
mStatic | Static class, derived from mWidget
mStaticClass | Struct of Static control, derived from mWidgetClass
mStaticRenderer | Static class renderer interface, derived from mWidgetRenderer
mTextEditor | The structure of mTextEditor, which derived from mWidget. It is the new multiline edit control
mTextEditorClass | VTable of mTextEditor, derived from mWidget
mTimer | Timer member define
mTimerClass | Class of Timer object
mToolBar | ToolBar class, derived from mWidget
mToolBarClass | Struct of ToolBar control, derived from mWidgetClass
mToolBarRenderer | ToolBar class renderer interface, derived from mWidgetRenderer
mTrackBar | TrackBar struct of TrackBar control, derived from mSlider
mTrackBarClass | VTable of mTrackBar, derived from mSliderClass
mTrackBarRenderer | TrackBar class's Renderer interface, derived from mSliderRenderer
mWidget | Define the mWidget members, inherit from mComponent
mWidgetClass | VTable of mWidget, drived from mComponentClass
mWidgetRenderer | Widget class's Renderer interface
NCS_CB_ITEMOPS | The structure of NCS_CB_ITEMOPS. The Item operations interface
NCS_LSTCLM_SORTDATA | The sort type
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: Alphabetical List

  • Alphabetical List
  • Data Structures
  • Data Fields

Data Structure Index

L | M | N | _

L
mIconViewClass mMlEdit mScrollWidgetClass NCS_LSTCLM_SORTDATA
list_head mIconViewRenderer mMlEditClass mScrollWidgetRenderer
_
M
mImage mMlEditRenderer mSeparator _mButtonNode
mAbstractList mImageClass mMonthCalender mSeparatorClass _mMonthCalendarClass
mAbstractListClass mImageRenderer mNode mSeparatorRenderer _NCS_CB_LISTV_CSTMHDROPS
mAbstractListRenderer mInvsbComp mNodeClass mSlEdit _NCS_CREATE_NOTIFY_INFO
mButton mInvsbCompClass mObject mSlEditClass _NCS_EVENT_CONNECT_INFO
mButtonClass mItem mObjectClass mSlEditRenderer _NCS_EVENT_HANDLER
mButtonGroup mItemClass mPage mSlider _NCS_EVENT_HANDLER_NODE
mButtonGroupClass mItemManager mPageClass mSliderClass _NCS_ICONV_ITEMINFO
mButtonGroupRenderer mItemManagerClass mPageRenderer mSliderRenderer _NCS_INVSB_CREATE_INFO
mButtonRenderer mItemView mPanel mSpinBox _NCS_LISTV_CLMINFO
mCheckButton mItemViewClass mPanelClass mSpinBoxClass _NCS_LISTV_FINDINFO
mCheckButtonClass mItemViewRenderer mPanelRenderer mSpinBoxRenderer _NCS_LISTV_ITEMDATA
mCheckButtonRenderer mLEDLabel mPopMenuMgr mSpinner _NCS_LISTV_ITEMINFO
mColorButton mLEDLabelClass mPopMenuMgrClass mSpinnerClass _NCS_LSTBOX_ITEMINFO
mColorButtonClass mLEDLabelRenderer mProgressBar mSpinnerRenderer _NCS_MAIN_CREATE_INFO
mColorButtonRenderer mList mProgressBarClass mStatic _NCS_MNWND_TEMPLATE
mCombobox mListBox mProgressBarRenderer mStaticClass _NCS_PROP_ENTRY
mComboboxClass mListBoxClass mPropSheet mStaticRenderer _NCS_RDR_ELEMENT
mComboboxRenderer mListBoxRenderer mPropSheetClass mTextEditor _NCS_RDR_ENTRY
mComponent mListClass mPropSheetRenderer mTextEditorClass _NCS_RDR_INFO
mComponentClass mListColumn mRadioButton mTimer _NCS_SCRLV_ITEMINFO
mContainer mListColumnClass mRadioButtonClass mTimerClass _NCS_WND_TEMPLATE
mContainerClass mListItem mRadioButtonRender mToolBar _NCSRM_DEFLOCALE_INFO
mContainerRenderer mListItemClass mRectangle mToolBarClass _NCSRM_HEADER
mDialogBox mListRenderer mRectangleClass mToolBarRenderer _NCSRM_IDITEM
mDialogBoxClass mListView mRectangleRenderer mTrackBar _NCSRM_INCORE_IMAGE
mDialogBoxRenderer mListViewClass mScrollBar mTrackBarClass _NCSRM_LOCALEITEM
mEdit mListViewRenderer mScrollBarClass mTrackBarRenderer _NCSRM_PROP
mEditClass mMainWnd mScrollBarRenderer mWidget _NCSRM_RDRHEADER
mEditRenderer mMainWndClass mScrollView mWidgetClass _NCSRM_RDRINFO
mGroupBox mMainWndRenderer mScrollViewClass mWidgetRenderer _NCSRM_SECTHEADER
mGroupBoxClass mMenuButton mScrollViewRenderer
N
_NCSRM_TYPEITEM
mGroupBoxRenderer mMenuButtonClass mScrollWidget NCS_CB_ITEMOPS _NCSRM_WINHEADER
mIconView mMenuButtonRenderer

L | M | N | _

Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: include/pieces/ Directory Reference

include » pieces

pieces Directory Reference

Files

  • file mabstractbuttonpiece.h [code]
  • file manimatepiece.h [code]
  • file marrowbuttonpiece.h [code]
  • file marrowpiece.h [code]
  • file mboxlayoutpiece.h [code]
  • file mbuttonboxpiece.h [code]
  • file mcheckboxpiece.h [code]
  • file mcheckbuttonpiece.h [code]
  • file mcontainerpiece.h [code]
  • file mdaygridpiece.h [code]
  • file mdownarrowpiece.h [code]
  • file mgridboxpiece.h [code]
  • file mhboxlayoutpiece.h [code]
  • file mhotpiece.h [code]
  • file mhspinboxpiece.h [code]
  • file mimagelabelpiece.h [code]
  • file mimagepiece.h [code]
  • file mlabelpiece.h [code]
  • file mlayoutpiece.h [code]
  • file mledstaticpiece.h [code]
  • file mleftarrowpiece.h [code]
  • file mlinelayoutpiece.h [code]
  • file mlistspinnedpiece.h [code]
  • file mmonthpiece.h [code]
  • file mnumspinnedpiece.h [code]
  • file mpairpiece.h [code]
  • file mprogresspiece.h [code]
  • file mpushbuttonpiece.h [code]
  • file mradioboxpiece.h [code]
  • file mradiobuttonpiece.h [code]
  • file mrectpiece.h [code]
  • file mrenderablepiece.h [code]
  • file mrightarrowpiece.h [code]
  • file mscrollbarpiece.h [code]
  • file mscrollthumbboxpiece.h [code]
  • file mseparatorpiece.h [code]
  • file msimplelistpiece.h [code]
  • file msliderpiece.h [code]
  • file mspinboxpiece.h [code]
  • file mspinnerpiece.h [code]
  • file mstaticpiece.h [code]
  • file mthumbboxpiece.h [code]
  • file mtoolimgpiece.h [code]
  • file mtrackbarpiece.h [code]
  • file muparrowpiece.h [code]
  • file mvboxlayoutpiece.h [code]
  • file mvspinboxpiece.h [code]
  • file mweekheadpiece.h [code]
  • file mwidgetwrapperpiece.h [code]
  • file piece-id.h [code]
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: include/ Directory Reference

include

include Directory Reference

Directories

  • directory pieces

Files

  • file hashtable.h [code]
  • file mabstractlist.h [code]
  • file manimate.h [code]
  • file manimateframes.h [code]
  • file mbmparrayanimateframes.h [code]
  • file mbtree.h [code]
  • file mbutton.h [code]
  • file mbuttongroup.h [code]
  • file mcheckbutton.h [code]
  • file mchecknode.h [code]
  • file mcolorbutton.h [code]
  • file mcombobox.h [code]
  • file mcommon.h [code]
  • file mcomponent.h [code]
  • file mcontainer.h [code]
  • file mdatabinding.h [code]
  • file mdatasource.h [code]
  • file mdblist.h [code]
  • file mdialog.h [code]
  • file medit.h [code]
  • file mem-slab.h [code]
  • file mgifanimateframes.h [code]
  • file mgncs.h [code]
  • file mgroupbox.h [code]
  • file miconview.h [code]
  • file mimage.h [code]
  • file mime-wordsel.h [code]
  • file mime.h [code]
  • file minvisible-component.h [code]
  • file mitem.h [code]
  • file mitem_manager.h [code]
  • file mitemview.h [code]
  • file mledstatic.h [code]
  • file mlist.h [code]
  • file mlist_layout.h [code]
  • file mlistbox.h [code]
  • file mlistcolumn.h [code]
  • file mlistitem.h [code]
  • file mlistview.h [code]
  • file mmainwnd.h [code]
  • file mmemanimateframes.h [code]
  • file mmenubutton.h [code]
  • file mmledit.h [code]
  • file mmonthcalendar.h [code]
  • file mnode.h [code]
  • file mobject.h [code]
  • file mpage.h [code]
  • file mpanel.h [code]
  • file mpopmenumgr.h [code]
  • file mprogressbar.h [code]
  • file mpropsheet.h [code]
  • file mradiobutton.h [code]
  • file mradionode.h [code]
  • file mrdr.h [code]
  • file mrect.h [code]
  • file mresmgr.h [code]
  • file mscroll_widget.h [code]
  • file mscrollbar.h [code]
  • file mscrollview.h [code]
  • file mseparator.h [code]
  • file msledit.h [code]
  • file mslider.h [code]
  • file mspinbox.h [code]
  • file mspinner.h [code]
  • file mstatic.h [code]
  • file mtextedit.h [code]
  • file mtexteditbase.h [code]
  • file mtimer.h [code]
  • file mtoolbar.h [code]
  • file mtoolbaritems.h [code]
  • file mtoolitem.h [code]
  • file mtrackbar.h [code]
  • file mtype.h [code]
  • file mwidget.h [code]
  • file piece.h [code]
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: Directory Hierarchy

Directories

This directory hierarchy is sorted roughly, but not completely, alphabetically:
  • include
    • pieces
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: File Index

  • File List
  • Globals

File List

Here is a list of all documented files with brief descriptions:
hashtable.h [code]
mabstractbuttonpiece.h [code]
mabstractlist.h [code]
manimate.h [code]
manimateframes.h [code]
manimatepiece.h [code]
marrowbuttonpiece.h [code]
marrowpiece.h [code]
mbmparrayanimateframes.h [code]
mboxlayoutpiece.h [code]
mbtree.h [code]
mbutton.h [code]
mbuttonboxpiece.h [code]
mbuttongroup.h [code]
mcheckboxpiece.h [code]
mcheckbutton.h [code]
mcheckbuttonpiece.h [code]
mchecknode.h [code]
mcolorbutton.h [code]
mcombobox.h [code]
mcommon.h [code]
mcomponent.h [code]
mcontainer.h [code]
mcontainerpiece.h [code]
mdatabinding.h [code]
mdatasource.h [code]
mdaygridpiece.h [code]
mdblist.h [code]
mdialog.h [code]
mdownarrowpiece.h [code]
medit.h [code]
mem-slab.h [code]
mgifanimateframes.h [code]
mgncs.h [code]
mgridboxpiece.h [code]
mgroupbox.h [code]
mhboxlayoutpiece.h [code]
mhotpiece.h [code]
mhspinboxpiece.h [code]
miconview.h [code]
mimage.h [code]
mimagelabelpiece.h [code]
mimagepiece.h [code]
mime-wordsel.h [code]
mime.h [code]
minvisible-component.h [code]
mitem.h [code]
mitem_manager.h [code]
mitemview.h [code]
mlabelpiece.h [code]
mlayoutpiece.h [code]
mledstatic.h [code]
mledstaticpiece.h [code]
mleftarrowpiece.h [code]
mlinelayoutpiece.h [code]
mlist.h [code]
mlist_layout.h [code]
mlistbox.h [code]
mlistcolumn.h [code]
mlistitem.h [code]
mlistspinnedpiece.h [code]
mlistview.h [code]
mmainwnd.h [code]
mmemanimateframes.h [code]
mmenubutton.h [code]
mmledit.h [code]
mmonthcalendar.h [code]
mmonthpiece.h [code]
mnode.h [code]
mnumspinnedpiece.h [code]
mobject.h [code]
mpage.h [code]
mpairpiece.h [code]
mpanel.h [code]
mpopmenumgr.h [code]
mprogressbar.h [code]
mprogresspiece.h [code]
mpropsheet.h [code]
mpushbuttonpiece.h [code]
mradioboxpiece.h [code]
mradiobutton.h [code]
mradiobuttonpiece.h [code]
mradionode.h [code]
mrdr.h [code]
mrect.h [code]
mrectpiece.h [code]
mrenderablepiece.h [code]
mresmgr.h [code]
mrightarrowpiece.h [code]
mscroll_widget.h [code]
mscrollbar.h [code]
mscrollbarpiece.h [code]
mscrollthumbboxpiece.h [code]
mscrollview.h [code]
mseparator.h [code]
mseparatorpiece.h [code]
msimplelistpiece.h [code]
msledit.h [code]
mslider.h [code]
msliderpiece.h [code]
mspinbox.h [code]
mspinboxpiece.h [code]
mspinner.h [code]
mspinnerpiece.h [code]
mstatic.h [code]
mstaticpiece.h [code]
mtextedit.h [code]
mtexteditbase.h [code]
mthumbboxpiece.h [code]
mtimer.h [code]
mtoolbar.h [code]
mtoolbaritems.h [code]
mtoolimgpiece.h [code]
mtoolitem.h [code]
mtrackbar.h [code]
mtrackbarpiece.h [code]
mtype.h [code]
muparrowpiece.h [code]
mvboxlayoutpiece.h [code]
mvspinboxpiece.h [code]
mweekheadpiece.h [code]
mwidget.h [code]
mwidgetwrapperpiece.h [code]
piece-id.h [code]
piece.h [code]
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- a -

  • addData : _NCS_ICONV_ITEMINFO , _NCS_SCRLV_ITEMINFO , _NCS_LISTV_ITEMINFO , _NCS_LISTV_FINDINFO , _NCS_LSTBOX_ITEMINFO

- b -

  • bk_color : _NCSRM_WINHEADER
  • bmp : _NCS_ICONV_ITEMINFO

- c -

  • caption : _NCS_WND_TEMPLATE
  • caption_id : _NCSRM_WINHEADER
  • class_id : _NCSRM_WINHEADER
  • class_name : _NCS_WND_TEMPLATE
  • className : _NCS_RDR_ENTRY , _NCS_MAIN_CREATE_INFO
  • clsname_id : _NCSRM_RDRHEADER
  • col : _NCS_LISTV_ITEMDATA
  • country : _NCSRM_LOCALEITEM , _NCSRM_DEFLOCALE_INFO
  • create_info : _NCS_MAIN_CREATE_INFO
  • ctl_rdr : _NCS_RDR_INFO

- d -

  • data : _NCS_LISTV_ITEMINFO , _NCSRM_INCORE_IMAGE
  • dataSize : _NCS_LISTV_ITEMINFO

- e -

  • elements : _NCS_RDR_INFO
  • event : _NCS_EVENT_CONNECT_INFO
  • event_id : _NCS_EVENT_CONNECT_INFO
  • ex_style : _NCSRM_WINHEADER , _NCS_WND_TEMPLATE
  • ext : _NCSRM_INCORE_IMAGE

- f -

  • filename_id : _NCSRM_TYPEITEM , _NCSRM_IDITEM , _NCSRM_LOCALEITEM
  • flag : _NCS_LSTBOX_ITEMINFO
  • flags : _NCS_LISTV_ITEMINFO , _NCS_LISTV_CLMINFO , _NCS_LISTV_ITEMDATA
  • foldIcon : _NCS_LISTV_ITEMINFO
  • font_id : _NCSRM_WINHEADER
  • format_version : _NCSRM_HEADER

- g -

  • glb_rdr : _NCS_RDR_INFO

- h -

  • h : _NCSRM_WINHEADER
  • handler : _NCS_EVENT_HANDLER_NODE , _NCS_EVENT_HANDLER
  • handlers : _NCS_INVSB_CREATE_INFO
  • height : _NCS_LISTV_ITEMINFO , _NCS_SCRLV_ITEMINFO

- i -

  • id : _NCS_INVSB_CREATE_INFO , _NCSRM_IDITEM , _NCSRM_PROP , _NCS_PROP_ENTRY , _NCSRM_RDRINFO , _NCS_RDR_ELEMENT , _NCS_WND_TEMPLATE
  • id_listener : _NCS_EVENT_CONNECT_INFO
  • id_sender : _NCS_EVENT_CONNECT_INFO
  • image : _NCS_LSTBOX_ITEMINFO , _NCS_LISTV_CLMINFO , _NCS_LISTV_ITEMDATA
  • index : _NCS_LISTV_CLMINFO , _NCS_LISTV_ITEMINFO , _NCS_ICONV_ITEMINFO , _NCS_SCRLV_ITEMINFO

- l -

  • label : _NCS_ICONV_ITEMINFO
  • language : _NCSRM_LOCALEITEM , _NCSRM_DEFLOCALE_INFO

- m -

  • magic : _NCSRM_HEADER
  • message : _NCS_EVENT_HANDLER , _NCS_EVENT_HANDLER_NODE

- n -

  • next : _NCS_EVENT_HANDLER_NODE
  • nr_ctrls : _NCSRM_WINHEADER
  • nr_props : _NCSRM_WINHEADER
  • nr_sect : _NCSRM_HEADER

- o -

  • offset : _NCSRM_TYPEITEM , _NCSRM_IDITEM , _NCSRM_LOCALEITEM
  • offset_adddata : _NCSRM_WINHEADER
  • offset_ctrls : _NCSRM_WINHEADER
  • offset_props : _NCSRM_WINHEADER

- p -

  • package_version : _NCSRM_HEADER
  • parent : _NCS_INVSB_CREATE_INFO , _NCS_LISTV_ITEMINFO , _NCS_LISTV_FINDINFO
  • pfnDrawHdrBk : _NCS_CB_LISTV_CSTMHDROPS
  • pfnDrawHdrItem : _NCS_CB_LISTV_CSTMHDROPS
  • props : _NCS_WND_TEMPLATE , _NCS_INVSB_CREATE_INFO

- r -

  • rdr_id : _NCSRM_WINHEADER
  • rdrname_id : _NCSRM_RDRHEADER
  • renderer : _NCS_RDR_ENTRY
  • retPos : _NCS_LISTV_ITEMINFO
  • row : _NCS_LISTV_ITEMDATA

- s -

  • sect_size : _NCSRM_SECTHEADER
  • serial_num : _NCSRM_WINHEADER
  • size : _NCSRM_INCORE_IMAGE , _NCSRM_WINHEADER
  • size_adddata : _NCSRM_WINHEADER
  • size_maps : _NCSRM_SECTHEADER
  • startIdx : _NCS_LISTV_FINDINFO
  • string : _NCS_LSTBOX_ITEMINFO
  • style : _NCS_WND_TEMPLATE , _NCSRM_WINHEADER

- t -

  • text : _NCS_LISTV_CLMINFO , _NCS_LISTV_ITEMDATA
  • textColor : _NCS_LISTV_ITEMDATA
  • type : _NCS_LISTV_FINDINFO , _NCSRM_TYPEITEM , _NCSRM_PROP

- u -

  • unfoldIcon : _NCS_LISTV_ITEMINFO
  • user_data : _NCS_INVSB_CREATE_INFO

- v -

  • value : _NCSRM_RDRINFO , _NCSRM_PROP , _NCS_RDR_ELEMENT , _NCS_PROP_ENTRY
  • vendor : _NCSRM_HEADER

- w -

  • w : _NCSRM_WINHEADER
  • width : _NCS_LISTV_CLMINFO
  • wnd_id : _NCSRM_WINHEADER

- x -

  • x : _NCSRM_WINHEADER , _NCS_WND_TEMPLATE

- y -

  • y : _NCSRM_WINHEADER
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • c
  • d
  • e
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • q
  • s
  • t

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- l -

  • list_add() : mdblist.h
  • list_add_tail() : mdblist.h
  • list_del() : mdblist.h
  • list_del_init() : mdblist.h
  • list_empty() : mdblist.h
  • list_entry : mdblist.h
  • list_for_each : mdblist.h
  • list_for_each_ex : mdblist.h
  • list_for_each_safe : mdblist.h
  • list_for_index : mdblist.h
  • list_t : mdblist.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • c
  • d
  • e
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • q
  • s
  • t

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- m -

  • mAbstractList_getControl() : mabstractlist.h
  • mAbstractListNotify : mabstractlist.h
  • mAbstractListProperty : mabstractlist.h
  • MAXLEN_CLASSNAME : mcomponent.h
  • mCheckNode : mchecknode.h
  • mComboboxProp : mcombobox.h
  • mComponentQueryCmd : mcomponent.h
  • mContainerNotify : mcontainer.h
  • mEditNotify : medit.h
  • mEditProp : medit.h
  • mIconViewNotify : miconview.h
  • mIconViewProp : miconview.h
  • mItemManagerProp : mitem_manager.h
  • mItemProp : mitem.h
  • mItemViewNotify : mitemview.h
  • mItemViewProp : mitemview.h
  • mLGroupLayoutProp : mlist_layout.h
  • mLHCenterBoxLayoutProp : mlist_layout.h
  • mListBoxNotify : mlistbox.h
  • mListBoxProp : mlistbox.h
  • mListColumnProp : mlistcolumn.h
  • mListItemProp : mlistitem.h
  • mListLayoutProp : mlist_layout.h
  • mListNotify : mlist.h
  • mListProp : mlist.h
  • mListViewNotify : mlistview.h
  • mListViewProp : mlistview.h
  • mMlEditProp : mmledit.h
  • mNodeEvent : mnode.h
  • mNodeProp : mnode.h
  • mPanelNotify : mpanel.h
  • mPanelProp : mpanel.h
  • mProgressBarProp : mprogressbar.h
  • mPropSheetNotify : mpropsheet.h
  • mPropSheetProp : mpropsheet.h
  • mScrollViewNotify : mscrollview.h
  • mScrollViewProp : mscrollview.h
  • mScrollWidgetNotify : mscroll_widget.h
  • mScrollWidgetProp : mscroll_widget.h
  • mSlEditNotify : msledit.h
  • mSlEditProp : msledit.h
  • mSliderHitTest : mslider.h
  • mSliderProp : mslider.h
  • mSpinBoxNotify : mspinbox.h
  • mSpinBoxProp : mspinbox.h
  • mSpinnerNotify : mspinner.h
  • mSpinnerProp : mspinner.h
  • mTextEditorNotify : mtextedit.h
  • mTextEditorProp : mtextedit.h
  • mTrackBarProp : mtrackbar.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • c
  • d
  • e
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • q
  • s
  • t

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- n -

  • NCS_CARETSHAPE_BLOCK : mmledit.h
  • NCS_CARETSHAPE_LINE : mmledit.h
  • NCS_CB_CMPITEM : mitem_manager.h
  • NCS_CB_CMPNODE : mnode.h
  • NCS_CB_CMPSTR : mitem_manager.h
  • NCS_CB_DRAWITEM : mitemview.h
  • NCS_CB_DSTRITEM : mitemview.h
  • NCS_CB_INITITEM : mitemview.h
  • NCS_CB_LISTV_CMPCLM : mlistcolumn.h
  • NCS_CB_LISTV_DRAWHDR : mlistview.h
  • NCS_CB_LISTV_DRAWHDRBK : mlistview.h
  • NCS_CB_ONINITPAGE : mpage.h
  • NCS_CB_ONOBJEVENT : mobject.h
  • NCS_CB_ONSHEETCMD : mpage.h
  • NCS_CB_ONSHOWPAGE : mpage.h
  • NCS_CB_ONTIMER : mtimer.h
  • NCS_CMPT_CHILDREN : mcomponent.h
  • NCS_CMPT_NEXT : mcomponent.h
  • NCS_CMPT_PARENT : mcomponent.h
  • NCS_CMPT_PREV : mcomponent.h
  • NCS_LIST_LICONV : mlist.h
  • NCS_LIST_LLIST : mlist.h
  • NCS_LIST_MAX : mlist.h
  • NCS_NODE_FTDATA : mnode.h
  • NCS_NODE_FTIMAGE : mnode.h
  • NCS_NODE_FTSTRING : mnode.h
  • NCS_TEF_SCROLLBAR_ALWAYS : mtextedit.h
  • NCS_TEF_SCROLLBAR_AUTO : mtextedit.h
  • NCS_TEF_SCROLLBAR_NEVER : mtextedit.h
  • NCS_TYPE_MASK : mrdr.h
  • ncsAddEventListener() : mobject.h
  • ncsAddEventListeners() : mobject.h
  • ncsAddNode() : mnode.h
  • ncsAddRefResPackage() : mresmgr.h
  • ncsCaretShape : mmledit.h
  • NCSCLASSNAME : mcomponent.h
  • ncsComponentConnectEvents() : mcomponent.h
  • ncsComponentReleated : mcomponent.h
  • ncsCreateInvsbComp() : minvisible-component.h
  • ncsCreateInvsbCompIndirect() : minvisible-component.h
  • ncsCreateMainWindowIndirectFromID() : mresmgr.h
  • ncsCreateModalDialogFromID() : mresmgr.h
  • ncsCreateNode() : mnode.h
  • NCSCTRL_COMBOBOX : mcombobox.h
  • NCSCTRL_CONTAINER : mcontainer.h
  • NCSCTRL_ICONVIEW : miconview.h
  • NCSCTRL_ITEMVIEW : mitemview.h
  • NCSCTRL_LIST : mlist.h
  • NCSCTRL_LISTBOX : mlistbox.h
  • NCSCTRL_LISTVIEW : mlistview.h
  • NCSCTRL_PAGE : mpage.h
  • NCSCTRL_PANEL : mpanel.h
  • NCSCTRL_PROPSHEET : mpropsheet.h
  • NCSCTRL_SCROLLVIEW : mscrollview.h
  • NCSCTRL_SCROLLWIDGET : mscroll_widget.h
  • NCSCTRL_TEXTEDITOR : mtextedit.h
  • NCSCTRL_TIMER : mtimer.h
  • NCSE_NODE_CONTENTCHANGED : mnode.h
  • NCSE_NODE_HEIGHTCHANGED : mnode.h
  • NCSE_NODE_NODEADDED : mnode.h
  • NCSE_NODE_NODEDELETED : mnode.h
  • NCSE_NODE_REFRESH : mnode.h
  • NCSF_ITEM_DISABLED : mitem.h
  • NCSF_ITEM_IMAGEMASK : mitem.h
  • NCSF_ITEM_MASK : mitem.h
  • NCSF_ITEM_NORMAL : mitem.h
  • NCSF_ITEM_SELECTED : mitem.h
  • NCSF_ITEM_SHIFT : mitem.h
  • NCSF_ITEM_USEBITMAP : mitem.h
  • NCSF_ITEM_USEICON : mitem.h
  • NCSF_ITMMNG_AUTOSORT : mitem_manager.h
  • NCSF_ITMMNG_FROZEN : mitem_manager.h
  • NCSF_ITMMNG_SHIFT : mitem_manager.h
  • NCSF_LSTBOX_BOLD : mlistbox.h
  • NCSF_LSTBOX_CHECKMASK : mlistbox.h
  • NCSF_LSTBOX_CMBLANK : mlistbox.h
  • NCSF_LSTBOX_CMCHECKED : mlistbox.h
  • NCSF_LSTBOX_CMPARTCHECKED : mlistbox.h
  • NCSF_LSTBOX_SIGNIFICANT : mlistbox.h
  • NCSF_LSTCLM_BOTTOMALIGN : mlistcolumn.h
  • NCSF_LSTCLM_CENTERALIGN : mlistcolumn.h
  • NCSF_LSTCLM_LEFTALIGN : mlistcolumn.h
  • NCSF_LSTCLM_RIGHTALIGN : mlistcolumn.h
  • NCSF_LSTCLM_SHIFT : mlistcolumn.h
  • NCSF_LSTCLM_TOPALIGN : mlistcolumn.h
  • NCSF_LSTCLM_VALIGNMASK : mlistcolumn.h
  • NCSF_LSTCLM_VCENTERALIGN : mlistcolumn.h
  • NCSF_LSTHDR_BOTTOMALIGN : mlistview.h
  • NCSF_LSTHDR_CENTERALIGN : mlistview.h
  • NCSF_LSTHDR_LEFTALIGN : mlistview.h
  • NCSF_LSTHDR_RIGHTALIGN : mlistview.h
  • NCSF_LSTHDR_SHIFT : mlistview.h
  • NCSF_LSTHDR_TOPALIGN : mlistview.h
  • NCSF_LSTHDR_VALIGNMASK : mlistview.h
  • NCSF_LSTHDR_VCENTERALIGN : mlistview.h
  • NCSF_LSTITM_FOLD : mlistitem.h
  • NCSF_LSTITM_PRIVBKCOL : mlistitem.h
  • NCSF_LSTITM_PRIVFGCOL : mlistitem.h
  • NCSF_LSTITM_SHIFT : mlistitem.h
  • NCSF_PRPSHT_BORDER : mpropsheet.h
  • NCSF_PRPSHT_LEFT : mpropsheet.h
  • NCSF_PRPSHT_MAX : mpropsheet.h
  • NCSF_PRPSHT_PAGE : mpropsheet.h
  • NCSF_PRPSHT_RIGHT : mpropsheet.h
  • NCSF_PRPSHT_TAB : mpropsheet.h
  • ncsFreeWndTemplate() : mresmgr.h
  • ncsGetBitmap() : mresmgr.h
  • ncsGetComponentClass() : mcomponent.h
  • ncsGetComponentHandler() : mcomponent.h
  • ncsGetDefaultLocale() : mresmgr.h
  • ncsGetElement : mrdr.h
  • ncsGetElementEx() : mrdr.h
  • ncsGetImageFileName() : mresmgr.h
  • ncsGetMyBitmap() : mresmgr.h
  • ncsGetString() : mresmgr.h
  • ncsGetSystemRenderer() : mrdr.h
  • ncsGetWndTemplFromID() : mresmgr.h
  • NCSID_LISTV_FT_ADDDATA : mlistview.h
  • NCSID_LISTV_FT_TEXT : mlistview.h
  • NCSID_LISTV_IR_FIRSTCHILD : mlistview.h
  • NCSID_LISTV_IR_LASTCHILD : mlistview.h
  • NCSID_LISTV_IR_NEXTSIBLING : mlistview.h
  • NCSID_LISTV_IR_PARENT : mlistview.h
  • NCSID_LISTV_IR_PREVSIBLING : mlistview.h
  • NCSID_LSTCLM_HISORTED : mlistcolumn.h
  • NCSID_LSTCLM_LOSORTED : mlistcolumn.h
  • NCSID_LSTCLM_NOTSORTED : mlistcolumn.h
  • NCSID_SWGT_ALWAYS : mscroll_widget.h
  • NCSID_SWGT_AUTO : mscroll_widget.h
  • NCSID_SWGT_NEVER : mscroll_widget.h
  • ncsInitialize() : mgncs.h
  • ncsInstanceOf() : mobject.h
  • ncsInvsbCompProp : minvisible-component.h
  • ncsIsChildClass() : mcomponent.h
  • ncsIsClass() : mcomponent.h
  • ncsIsValidObj() : mobject.h
  • ncsListLayoutID : mlist.h
  • ncsListVFindType : mlistview.h
  • ncsListVIRType : mlistview.h
  • ncsLoadRdrEtcFile() : mrdr.h
  • ncsLoadResPackage : mresmgr.h
  • ncsLoadResPackageFromFile() : mresmgr.h
  • ncsLoadResPackageFromMem() : mresmgr.h
  • ncsLstClmSortType : mlistcolumn.h
  • NCSN_ASTLST_MAX : mabstractlist.h
  • NCSN_CMBOX_CLOSEUP : mcombobox.h
  • NCSN_CMBOX_DROPDOWN : mcombobox.h
  • NCSN_CMBOX_EDITCHANGE : mcombobox.h
  • NCSN_CMBOX_KILLFOCUS : mcombobox.h
  • NCSN_CMBOX_SELCHANGE : mcombobox.h
  • NCSN_CMBOX_SELECTCANCEL : mcombobox.h
  • NCSN_CMBOX_SELECTOK : mcombobox.h
  • NCSN_CMBOX_SETFOCUS : mcombobox.h
  • NCSN_CTNR_MAX : mcontainer.h
  • NCSN_EDIT_CHANGE : medit.h
  • NCSN_EDIT_CONTCHANGED : medit.h
  • NCSN_EDIT_KILLFOCUS : medit.h
  • NCSN_EDIT_MAXTEXT : medit.h
  • NCSN_EDIT_SELCHANGED : medit.h
  • NCSN_EDIT_SETFOCUS : medit.h
  • NCSN_EDIT_UPDATE : medit.h
  • NCSN_ICONV_MAX : miconview.h
  • NCSN_ITEMV_CLICKED : mitemview.h
  • NCSN_ITEMV_ENTER : mitemview.h
  • NCSN_ITEMV_KILLFOCUS : mitemview.h
  • NCSN_ITEMV_MAX : mitemview.h
  • NCSN_ITEMV_SELCHANGED : mitemview.h
  • NCSN_ITEMV_SELCHANGING : mitemview.h
  • NCSN_ITEMV_SETFOCUS : mitemview.h
  • NCSN_LIST_BACKSPACE : mlist.h
  • NCSN_LIST_BACKUPLIST : mlist.h
  • NCSN_LIST_ENTER : mlist.h
  • NCSN_LIST_ENTERSUBLIST : mlist.h
  • NCSN_LIST_MAX : mlist.h
  • NCSN_LIST_SELCHANGED : mlist.h
  • NCSN_LISTV_CLICKED : mlistview.h
  • NCSN_LISTV_FOLDITEM : mlistview.h
  • NCSN_LISTV_HDRRDOWN : mlistview.h
  • NCSN_LISTV_HDRRUP : mlistview.h
  • NCSN_LISTV_ITEMDBCLK : mlistview.h
  • NCSN_LISTV_ITEMRDOWN : mlistview.h
  • NCSN_LISTV_ITEMRUP : mlistview.h
  • NCSN_LISTV_MAX : mlistview.h
  • NCSN_LISTV_SELCHANGED : mlistview.h
  • NCSN_LISTV_UNFOLDITEM : mlistview.h
  • NCSN_LSTBOX_CLICKED : mlistbox.h
  • NCSN_LSTBOX_CLKCHKMARK : mlistbox.h
  • NCSN_LSTBOX_CMCANCEL : mlistbox.h
  • NCSN_LSTBOX_DBCLK : mlistbox.h
  • NCSN_LSTBOX_ENTER : mlistbox.h
  • NCSN_LSTBOX_ERRSPACE : mlistbox.h
  • NCSN_LSTBOX_KILLFOCUS : mlistbox.h
  • NCSN_LSTBOX_MAX : mlistbox.h
  • NCSN_LSTBOX_SELCHANGED : mlistbox.h
  • NCSN_LSTBOX_SETFOCUS : mlistbox.h
  • NCSN_PANEL_MAX : mpanel.h
  • NCSN_PRPSHT_ACTIVECHANGED : mpropsheet.h
  • NCSN_PRPSHT_MAX : mpropsheet.h
  • NCSN_SCRLBR_CHANGED : mscrollbar.h
  • NCSN_SCRLBR_REACHMAX : mscrollbar.h
  • NCSN_SCRLBR_REACHMIN : mscrollbar.h
  • NCSN_SCRLV_CLICKED : mscrollview.h
  • NCSN_SCRLV_MAX : mscrollview.h
  • NCSN_SCRLV_SELCHANGED : mscrollview.h
  • NCSN_SCRLV_SELCHANGING : mscrollview.h
  • NCSN_SLEDIT_CHANGE : msledit.h
  • NCSN_SLEDIT_ENTER : msledit.h
  • NCSN_SLIDER_CHANGED : mslider.h
  • NCSN_SLIDER_REACHMAX : mslider.h
  • NCSN_SLIDER_REACHMIN : mslider.h
  • NCSN_SPNBOX_CHANGED : mspinbox.h
  • NCSN_SPNBOX_REACHMAX : mspinbox.h
  • NCSN_SPNBOX_REACHMIN : mspinbox.h
  • NCSN_SPNR_CHANGED : mspinner.h
  • NCSN_SPNR_REACHMAX : mspinner.h
  • NCSN_SPNR_REACHMIN : mspinner.h
  • NCSN_SWGT_MAX : mscroll_widget.h
  • NCSN_TE_CHANGE : mtextedit.h
  • NCSN_TE_CONTENTCHANGED : mtextedit.h
  • NCSN_TE_KILLFOCUS : mtextedit.h
  • NCSN_TE_MAX : mtextedit.h
  • NCSN_TE_MAXTEXT : mtextedit.h
  • NCSN_TE_SELCHANGED : mtextedit.h
  • NCSN_TE_SETFOCUS : mtextedit.h
  • NCSN_TE_UPDATE : mtextedit.h
  • NCSN_TRKBAR_CHANGED : mtrackbar.h
  • NCSN_TRKBAR_REACHMAX : mtrackbar.h
  • NCSN_TRKBAR_REACHMIN : mtrackbar.h
  • ncsNodeFindType : mnode.h
  • NCSP_ASTLST_AUTOSORT : mabstractlist.h
  • NCSP_ASTLST_CMPNODEFUNC : mabstractlist.h
  • NCSP_ASTLST_DEFNODEHEIGHT : mabstractlist.h
  • NCSP_ASTLST_FONTSIZE : mabstractlist.h
  • NCSP_ASTLST_MAX : mabstractlist.h
  • NCSP_ASTLST_ROOTNODE : mabstractlist.h
  • NCSP_ASTLST_TRANSPARENT : mabstractlist.h
  • NCSP_COMB_DROPDOWNHEIGHT : mcombobox.h
  • NCSP_COMB_ITEMCOUNT : mcombobox.h
  • NCSP_COMB_ITEMHEIGHT : mcombobox.h
  • NCSP_COMB_SELECT : mcombobox.h
  • NCSP_COMB_TEXTLIMIT : mcombobox.h
  • NCSP_EDIT_CARETPOS : medit.h
  • NCSP_EDIT_LIMITTEXT : medit.h
  • NCSP_HCBOX_LAYOUT_MAX : mlist_layout.h
  • NCSP_HCBOX_LAYOUT_OFFX : mlist_layout.h
  • NCSP_ICONV_DEFICONHEIGHT : miconview.h
  • NCSP_ICONV_DEFICONWIDTH : miconview.h
  • NCSP_ICONV_MAX : miconview.h
  • NCSP_ITEM_FLAGS : mitem.h
  • NCSP_ITEM_HEIGHT : mitem.h
  • NCSP_ITEM_MAX : mitem.h
  • NCSP_ITEMV_DEFITEMHEIGHT : mitemview.h
  • NCSP_ITEMV_ITEMCOUNT : mitemview.h
  • NCSP_ITEMV_MAX : mitemview.h
  • NCSP_ITMMNG_FLAGS : mitem_manager.h
  • NCSP_ITMMNG_ITEMCOUNT : mitem_manager.h
  • NCSP_ITMMNG_MAX : mitem_manager.h
  • NCSP_ITMMNG_TOTALHEIGHT : mitem_manager.h
  • NCSP_LGROUP_LAYOUT_MAX : mlist_layout.h
  • NCSP_LIST_DEFNODEHEIGHT : mlist.h
  • NCSP_LIST_DEFNODEWIDTH : mlist.h
  • NCSP_LIST_LAYOUT : mlist.h
  • NCSP_LIST_LAYOUT_MAX : mlist_layout.h
  • NCSP_LIST_MAX : mlist.h
  • NCSP_LISTV_COLCOUNT : mlistview.h
  • NCSP_LISTV_DEFITEMHEIGHT : mlistview.h
  • NCSP_LISTV_GRIDLINECOLOR : mlistview.h
  • NCSP_LISTV_GRIDLINEWIDTH : mlistview.h
  • NCSP_LISTV_HDRHEIGHT : mlistview.h
  • NCSP_LISTV_HDRVISIBLE : mlistview.h
  • NCSP_LISTV_HDRWIDTH : mlistview.h
  • NCSP_LISTV_MAX : mlistview.h
  • NCSP_LISTV_ROWCOUNT : mlistview.h
  • NCSP_LISTV_SORTCOLUMN : mlistview.h
  • NCSP_LSTBOX_HILIGHTEDITEM : mlistbox.h
  • NCSP_LSTBOX_ITEMCOUNT : mlistbox.h
  • NCSP_LSTBOX_ITEMHEIGHT : mlistbox.h
  • NCSP_LSTBOX_ITEMWIDTH : mlistbox.h
  • NCSP_LSTBOX_MAX : mlistbox.h
  • NCSP_LSTBOX_TOPITEM : mlistbox.h
  • NCSP_LSTCLM_CMPFUNC : mlistcolumn.h
  • NCSP_LSTCLM_MAX : mlistcolumn.h
  • NCSP_LSTCLM_POSX : mlistcolumn.h
  • NCSP_LSTCLM_SORTTYPE : mlistcolumn.h
  • NCSP_LSTCLM_WIDTH : mlistcolumn.h
  • NCSP_LSTITM_DEPTH : mlistitem.h
  • NCSP_LSTITM_MAX : mlistitem.h
  • NCSP_LSTITM_NRCHILD : mlistitem.h
  • NCSP_LSTITM_RHEIGHT : mlistitem.h
  • NCSP_MLEDIT_CARETSHAPE : mmledit.h
  • NCSP_MLEDIT_LINECOUNT : mmledit.h
  • NCSP_MLEDIT_LINEFEEDISPCHAR : mmledit.h
  • NCSP_MLEDIT_LINEHEIGHT : mmledit.h
  • NCSP_MLEDIT_LINESEP : mmledit.h
  • NCSP_MLEDIT_NUMOFPARAGRAPHS : mmledit.h
  • NCSP_NODE_ADDDATA : mnode.h
  • NCSP_NODE_CHILDRENCOUNT : mnode.h
  • NCSP_NODE_ENABLED : mnode.h
  • NCSP_NODE_FIRSTCHILD : mnode.h
  • NCSP_NODE_HEIGHT : mnode.h
  • NCSP_NODE_HIDEIMAGE : mnode.h
  • NCSP_NODE_HIDETEXT : mnode.h
  • NCSP_NODE_IMAGE : mnode.h
  • NCSP_NODE_LASTCHILD : mnode.h
  • NCSP_NODE_LAYOUT : mnode.h
  • NCSP_NODE_MAX : mnode.h
  • NCSP_NODE_PARENTNODE : mnode.h
  • NCSP_NODE_SELECTED : mnode.h
  • NCSP_NODE_TEXT : mnode.h
  • NCSP_PANEL_MAX : mpanel.h
  • NCSP_PROG_CURPOS : mprogressbar.h
  • NCSP_PROG_LINESTEP : mprogressbar.h
  • NCSP_PROG_MAXPOS : mprogressbar.h
  • NCSP_PROG_MINPOS : mprogressbar.h
  • NCSP_PRPSHT_ACTIVEPAGE : mpropsheet.h
  • NCSP_PRPSHT_ACTIVEPAGEIDX : mpropsheet.h
  • NCSP_PRPSHT_FIRSTVIEWPAGE : mpropsheet.h
  • NCSP_PRPSHT_FIRSTVIEWPAGEIDX : mpropsheet.h
  • NCSP_PRPSHT_MINTABWIDTH : mpropsheet.h
  • NCSP_PRPSHT_PAGECOUNT : mpropsheet.h
  • NCSP_PRPSHT_TABMARGIN : mpropsheet.h
  • NCSP_SCRLBR_CURPOS : mscrollbar.h
  • NCSP_SCRLBR_LINESTEP : mscrollbar.h
  • NCSP_SCRLBR_MAXPOS : mscrollbar.h
  • NCSP_SCRLBR_MINPOS : mscrollbar.h
  • NCSP_SCRLBR_PAGESTEP : mscrollbar.h
  • NCSP_SCRLV_MAX : mscrollview.h
  • NCSP_SLEDIT_PWDCHAR : msledit.h
  • NCSP_SLEDIT_TIPTEXT : msledit.h
  • NCSP_SLIDER_CURPOS : mslider.h
  • NCSP_SLIDER_LINESTEP : mslider.h
  • NCSP_SLIDER_MAXPOS : mslider.h
  • NCSP_SLIDER_MINPOS : mslider.h
  • NCSP_SLIDER_PAGESTEP : mslider.h
  • NCSP_SPNBOX_CURPOS : mspinbox.h
  • NCSP_SPNBOX_LINESTEP : mspinbox.h
  • NCSP_SPNBOX_MAXPOS : mspinbox.h
  • NCSP_SPNBOX_MINPOS : mspinbox.h
  • NCSP_SPNR_CURPOS : mspinner.h
  • NCSP_SPNR_LINESTEP : mspinner.h
  • NCSP_SPNR_MAXPOS : mspinner.h
  • NCSP_SPNR_MINPOS : mspinner.h
  • NCSP_SPNR_TARGET : mspinner.h
  • NCSP_SWGT_CONTHEIGHT : mscroll_widget.h
  • NCSP_SWGT_CONTWIDTH : mscroll_widget.h
  • NCSP_SWGT_CONTX : mscroll_widget.h
  • NCSP_SWGT_CONTY : mscroll_widget.h
  • NCSP_SWGT_DRAWMODE : mscroll_widget.h
  • NCSP_SWGT_HSTEPVALUE : mscroll_widget.h
  • NCSP_SWGT_MARGINRECT : mscroll_widget.h
  • NCSP_SWGT_MAX : mscroll_widget.h
  • NCSP_SWGT_VISHEIGHT : mscroll_widget.h
  • NCSP_SWGT_VISWIDTH : mscroll_widget.h
  • NCSP_SWGT_VSTEPVALUE : mscroll_widget.h
  • NCSP_TE_LINECOUNT : mtextedit.h
  • NCSP_TE_MARGINRECT : mtextedit.h
  • NCSP_TE_MAX : mtextedit.h
  • NCSP_TE_PARAGRAPHCOUNT : mtextedit.h
  • NCSP_TE_READONLY : mtextedit.h
  • NCSP_TE_SCROLL_HSTEP : mtextedit.h
  • NCSP_TE_SCROLL_MODE : mtextedit.h
  • NCSP_TE_SCROLL_VSTEP : mtextedit.h
  • NCSP_TE_TEXTLIMIT : mtextedit.h
  • NCSP_TIMER_INTERVAL : mtimer.h
  • NCSP_TRKBAR_CURPOS : mtrackbar.h
  • NCSP_TRKBAR_LINESTEP : mtrackbar.h
  • NCSP_TRKBAR_MAX : mtrackbar.h
  • NCSP_TRKBAR_MAXPOS : mtrackbar.h
  • NCSP_TRKBAR_MINPOS : mtrackbar.h
  • NCSP_TRKBAR_PAGESTEP : mtrackbar.h
  • NCSP_TRKBAR_THUMB_HEIGHT : mtrackbar.h
  • NCSP_TRKBAR_THUMB_WIDTH : mtrackbar.h
  • ncsPrpShtFlags : mpropsheet.h
  • ncsRaiseEvent() : mobject.h
  • ncsRegisterComponent() : mcomponent.h
  • ncsRegisterCtrlRDR() : mrdr.h
  • ncsRegisterCtrlRDRs() : mrdr.h
  • ncsReleaseBitmap() : mresmgr.h
  • ncsReleaseMyBitmap() : mresmgr.h
  • ncsRemoveEventConnect() : mobject.h
  • ncsRemoveEventListener() : mobject.h
  • ncsRemoveEventSource() : mobject.h
  • ncsRetriveCtrlRDR() : mrdr.h
  • NCSRM_ENCODING_LEN : mresmgr.h
  • NCSRM_RDRTYPE_BINARY : mresmgr.h
  • NCSRM_RDRTYPE_COLOR : mresmgr.h
  • NCSRM_RDRTYPE_FILE : mresmgr.h
  • NCSRM_RDRTYPE_FONT : mresmgr.h
  • NCSRM_RDRTYPE_IMAGE : mresmgr.h
  • NCSRM_RDRTYPE_MAX : mresmgr.h
  • NCSRM_RDRTYPE_METRIC : mresmgr.h
  • NCSRM_RDRTYPE_STRING : mresmgr.h
  • NCSRM_RDRTYPE_TEXT : mresmgr.h
  • NCSRM_SYSSTR_BASEID : mresmgr.h
  • NCSRM_SYSSTR_DEFRDR : mresmgr.h
  • NCSRM_VENDOR_LEN : mresmgr.h
  • NCSRM_VERSION_LEN : mresmgr.h
  • ncsRMRdrResType : mresmgr.h
  • NCSRT_EXT_LEN : mresmgr.h
  • NCSS_ASTLST_AUTOSORT : mabstractlist.h
  • NCSS_ASTLST_SHIFT : mabstractlist.h
  • NCSS_CMBOX_AUTOFOCUS : mcombobox.h
  • NCSS_CMBOX_DROPDOWNLIST : mcombobox.h
  • NCSS_CMBOX_EDITBASELINE : mcombobox.h
  • NCSS_CMBOX_EDITNOBORDER : mcombobox.h
  • NCSS_CMBOX_LOWERCASE : mcombobox.h
  • NCSS_CMBOX_READONLY : mcombobox.h
  • NCSS_CMBOX_SIMPLE : mcombobox.h
  • NCSS_CMBOX_SORT : mcombobox.h
  • NCSS_CMBOX_UPPERCASE : mcombobox.h
  • NCSS_CTNR_SHIFT : mcontainer.h
  • NCSS_EDIT_BASELINE : medit.h
  • NCSS_EDIT_CENTER : medit.h
  • NCSS_EDIT_LEFT : medit.h
  • NCSS_EDIT_LOWERCASE : medit.h
  • NCSS_EDIT_NOHIDESEL : medit.h
  • NCSS_EDIT_READONLY : medit.h
  • NCSS_EDIT_RIGHT : medit.h
  • NCSS_EDIT_UPPERCASE : medit.h
  • NCSS_ICONV_LOOP : miconview.h
  • NCSS_ICONV_SHIFT : miconview.h
  • NCSS_ICONV_SORT : miconview.h
  • NCSS_ITEMV_AUTOSORT : mitemview.h
  • NCSS_ITEMV_LOOP : mitemview.h
  • NCSS_ITEMV_MULTIPLE : mitemview.h
  • NCSS_ITEMV_SHIFT : mitemview.h
  • NCSS_ITEMV_SINGLE : mitemview.h
  • NCSS_LIST_LOOP : mlist.h
  • NCSS_LIST_MULTIPLE : mlist.h
  • NCSS_LIST_SHIFT : mlist.h
  • NCSS_LISTV_AUTOCHECK : mlistview.h
  • NCSS_LISTV_AUTOCHECKBOX : mlistview.h
  • NCSS_LISTV_CHECKBOX : mlistview.h
  • NCSS_LISTV_LOOP : mlistview.h
  • NCSS_LISTV_MULTIPLE : mlistview.h
  • NCSS_LISTV_NOHDRDRAG : mlistview.h
  • NCSS_LISTV_NOTIFY : mlistview.h
  • NCSS_LISTV_SHIFT : mlistview.h
  • NCSS_LISTV_SINGLE : mlistview.h
  • NCSS_LISTV_SORT : mlistview.h
  • NCSS_LISTV_TREE : mlistview.h
  • NCSS_LISTV_WITHICON : mlistview.h
  • NCSS_LSTBOX_AUTOCHECK : mlistbox.h
  • NCSS_LSTBOX_AUTOCHECKBOX : mlistbox.h
  • NCSS_LSTBOX_CHECKBOX : mlistbox.h
  • NCSS_LSTBOX_MOUSEFOLLOW : mlistbox.h
  • NCSS_LSTBOX_MULTIPLE : mlistbox.h
  • NCSS_LSTBOX_SHIFT : mlistbox.h
  • NCSS_LSTBOX_SINGLE : mlistbox.h
  • NCSS_LSTBOX_SORT : mlistbox.h
  • NCSS_LSTBOX_STRING : mlistbox.h
  • NCSS_LSTBOX_USEBITMAP : mlistbox.h
  • NCSS_MLEDIT_AUTOWRAP : mmledit.h
  • NCSS_MLEDIT_TITLE : mmledit.h
  • NCSS_NODE_DISABLED : mnode.h
  • NCSS_NODE_HIDEIMAGE : mnode.h
  • NCSS_NODE_HIDETEXT : mnode.h
  • NCSS_NODE_LTEXTBS : mnode.h
  • NCSS_NODE_LTEXTRS : mnode.h
  • NCSS_NODE_SHIFT : mnode.h
  • NCSS_NODE_SMALLICON : mnode.h
  • NCSS_NODE_TICTACTOEMIDLET : mnode.h
  • NCSS_PAGE_SHIFT : mpage.h
  • NCSS_PANEL_SHIFT : mpanel.h
  • NCSS_PRGBAR_BLOCKS : mprogressbar.h
  • NCSS_PRGBAR_HORIZONTAL : mprogressbar.h
  • NCSS_PRGBAR_SHOWPERCENT : mprogressbar.h
  • NCSS_PRGBAR_SMOOTH : mprogressbar.h
  • NCSS_PRGBAR_VERTICAL : mprogressbar.h
  • NCSS_PRPSHT_BOTTOM : mpropsheet.h
  • NCSS_PRPSHT_COMPACTTAB : mpropsheet.h
  • NCSS_PRPSHT_SCROLLABLE : mpropsheet.h
  • NCSS_PRPSHT_SHIFT : mpropsheet.h
  • NCSS_PRPSHT_TOP : mpropsheet.h
  • NCSS_SCRLBR_ARROWS : mscrollbar.h
  • NCSS_SCRLBR_DOWNDBLARROWS : mscrollbar.h
  • NCSS_SCRLBR_HORIZONTAL : mscrollbar.h
  • NCSS_SCRLBR_LEFTDBLARROWS : mscrollbar.h
  • NCSS_SCRLBR_RIGHTDBLARROWS : mscrollbar.h
  • NCSS_SCRLBR_UPDBLARROWS : mscrollbar.h
  • NCSS_SCRLBR_VERTICAL : mscrollbar.h
  • NCSS_SCRLV_LOOP : mscrollview.h
  • NCSS_SCRLV_SHIFT : mscrollview.h
  • NCSS_SCRLV_SORT : mscrollview.h
  • NCSS_SCRLV_UPNOTIFY : mscrollview.h
  • NCSS_SLEDIT_AUTOSELECT : msledit.h
  • NCSS_SLEDIT_PASSWORD : msledit.h
  • NCSS_SLIDER_HORIZONTAL : mslider.h
  • NCSS_SLIDER_VERTICAL : mslider.h
  • NCSS_SPNBOX_AUTOFOCUS : mspinbox.h
  • NCSS_SPNBOX_AUTOLOOP : mspinbox.h
  • NCSS_SPNBOX_EDITBASELINE : mspinbox.h
  • NCSS_SPNBOX_EDITNOBORDER : mspinbox.h
  • NCSS_SPNBOX_HORIZONTAL : mspinbox.h
  • NCSS_SPNBOX_LOWERCASE : mspinbox.h
  • NCSS_SPNBOX_NUMBER : mspinbox.h
  • NCSS_SPNBOX_READONLY : mspinbox.h
  • NCSS_SPNBOX_SORT : mspinbox.h
  • NCSS_SPNBOX_STRING : mspinbox.h
  • NCSS_SPNBOX_UPPERCASE : mspinbox.h
  • NCSS_SPNBOX_VERTICAL : mspinbox.h
  • NCSS_SPNR_AUTOLOOP : mspinner.h
  • NCSS_SPNR_HORIZONTAL : mspinner.h
  • NCSS_SPNR_VERTICAL : mspinner.h
  • NCSS_SWGT_SHIFT : mscroll_widget.h
  • NCSS_TE_AUTOWRAP : mtextedit.h
  • NCSS_TE_BASELINE : mtextedit.h
  • NCSS_TE_LOWERCASE : mtextedit.h
  • NCSS_TE_NOHIDESEL : mtextedit.h
  • NCSS_TE_OWNERBKGND : mtextedit.h
  • NCSS_TE_READONLY : mtextedit.h
  • NCSS_TE_UPPERCASE : mtextedit.h
  • NCSS_TRKBAR_HORIZONTAL : mtrackbar.h
  • NCSS_TRKBAR_NOTICK : mtrackbar.h
  • NCSS_TRKBAR_VERTICAL : mtrackbar.h
  • ncsSafeCast() : mobject.h
  • ncsSafeCastClass() : mobject.h
  • ncsSetComponentHandler() : mcomponent.h
  • ncsSetComponentHandlers() : mcomponent.h
  • ncsSetDefaultLocale() : mresmgr.h
  • ncsSetElement : mrdr.h
  • ncsSetElementEx() : mrdr.h
  • ncsSetSysRdr() : mresmgr.h
  • ncsSetSystemRenderer() : mrdr.h
  • ncsSetWinRdr() : mresmgr.h
  • ncsSwgtDrawMode : mscroll_widget.h
  • ncsTEScrollMode : mtextedit.h
  • ncsTimerProp : mtimer.h
  • ncsUnloadRdrEtcFile() : mrdr.h
  • ncsUnloadResPackage() : mresmgr.h
  • ncsUnregisterCtrlRDRs() : mrdr.h
  • newObject() : mobject.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • c
  • d
  • e
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • q
  • s
  • t

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- c -

  • CHECKOBJ : mobject.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • c
  • d
  • e
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • q
  • s
  • t

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- d -

  • deleteObject() : mobject.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • c
  • d
  • e
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • q
  • s
  • t

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- e -

  • enumComboboxNotify : mcombobox.h
  • enumSliderNotify : mslider.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • c
  • d
  • e
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • q
  • s
  • t

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- g -

  • g_stmAbstractListCls : mabstractlist.h
  • g_stmComponentCls : mcomponent.h
  • g_stmContainerCls : mcontainer.h
  • g_stmEditCls : medit.h
  • g_stmGroupNodeCls : mnode.h
  • g_stmIconViewCls : miconview.h
  • g_stmInvsbCompCls : minvisible-component.h
  • g_stmItemCls : mitem.h
  • g_stmItemManagerCls : mitem_manager.h
  • g_stmItemViewCls : mitemview.h
  • g_stmListBoxCls : mlistbox.h
  • g_stmListCls : mlist.h
  • g_stmListColumnCls : mlistcolumn.h
  • g_stmListItemCls : mlistitem.h
  • g_stmListLayoutCls : mlist_layout.h
  • g_stmListViewCls : mlistview.h
  • g_stmMlEditCls : mmledit.h
  • g_stmNodeCls : mnode.h
  • g_stmObjectCls : mobject.h
  • g_stmPageCls : mpage.h
  • g_stmPanelCls : mpanel.h
  • g_stmProgressBarCls : mprogressbar.h
  • g_stmPropSheetCls : mpropsheet.h
  • g_stmScrollBarCls : mscrollbar.h
  • g_stmScrollViewCls : mscrollview.h
  • g_stmScrollWidgetCls : mscroll_widget.h
  • g_stmSlEditCls : msledit.h
  • g_stmSliderCls : mslider.h
  • g_stmTimerCls : mtimer.h
  • g_stmTrackBarCls : mtrackbar.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • c
  • d
  • e
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • q
  • s
  • t

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- h -

  • hEditor : mitem.h
  • HITEM : mitem.h
  • HPACKAGE : mresmgr.h
  • HPACKAGE_NULL : mresmgr.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • c
  • d
  • e
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • q
  • s
  • t

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- i -

  • initObjectArgs() : mobject.h
  • INSTANCEOF : mobject.h
  • INVALID_RDR_VALUE : mrdr.h
  • ISCLASS : mcomponent.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • c
  • d
  • e
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • q
  • s
  • t

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- p -

  • PClassConstructor : mobject.h
  • PCONSTRUCT_DWORD : mobject.h
  • PNCS_CREATE_MAIN : mgncs.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • c
  • d
  • e
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • q
  • s
  • t

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- q -

  • QPC_ADD_BIND : mcomponent.h
  • QPC_ADD_EVENT : mcomponent.h
  • QPC_GET_PROP : mcomponent.h
  • QPC_SET_PROP : mcomponent.h
  • QPC_USER : mcomponent.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • c
  • d
  • e
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • q
  • s
  • t

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- s -

  • SAFE_CAST : mobject.h
  • SAFE_CAST_CLASS : mobject.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • c
  • d
  • e
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • q
  • s
  • t

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- t -

  • TYPE_CAST : mobject.h
  • TYPENAME : mobject.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • c
  • h
  • i
  • l
  • m
  • n
  • s
  • t

- _ -

  • _c : mobject.h
  • _IM : mobject.h
  • _MGHAVE_TEXTEDITTITLE : mtextedit.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • c
  • h
  • i
  • l
  • m
  • n
  • s
  • t

- l -

  • list_entry : mdblist.h
  • list_for_each : mdblist.h
  • list_for_each_ex : mdblist.h
  • list_for_each_safe : mdblist.h
  • list_for_index : mdblist.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • c
  • h
  • i
  • l
  • m
  • n
  • s
  • t

- m -

  • MAXLEN_CLASSNAME : mcomponent.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • c
  • h
  • i
  • l
  • m
  • n
  • s
  • t

- n -

  • NCS_TYPE_MASK : mrdr.h
  • NCSCLASSNAME : mcomponent.h
  • NCSCTRL_COMBOBOX : mcombobox.h
  • NCSCTRL_CONTAINER : mcontainer.h
  • NCSCTRL_ICONVIEW : miconview.h
  • NCSCTRL_ITEMVIEW : mitemview.h
  • NCSCTRL_LIST : mlist.h
  • NCSCTRL_LISTBOX : mlistbox.h
  • NCSCTRL_LISTVIEW : mlistview.h
  • NCSCTRL_PAGE : mpage.h
  • NCSCTRL_PANEL : mpanel.h
  • NCSCTRL_PROPSHEET : mpropsheet.h
  • NCSCTRL_SCROLLVIEW : mscrollview.h
  • NCSCTRL_SCROLLWIDGET : mscroll_widget.h
  • NCSCTRL_TEXTEDITOR : mtextedit.h
  • NCSCTRL_TIMER : mtimer.h
  • NCSF_ITEM_DISABLED : mitem.h
  • NCSF_ITEM_IMAGEMASK : mitem.h
  • NCSF_ITEM_MASK : mitem.h
  • NCSF_ITEM_NORMAL : mitem.h
  • NCSF_ITEM_SELECTED : mitem.h
  • NCSF_ITEM_SHIFT : mitem.h
  • NCSF_ITEM_USEBITMAP : mitem.h
  • NCSF_ITEM_USEICON : mitem.h
  • NCSF_ITMMNG_AUTOSORT : mitem_manager.h
  • NCSF_ITMMNG_FROZEN : mitem_manager.h
  • NCSF_ITMMNG_SHIFT : mitem_manager.h
  • NCSF_LSTBOX_BOLD : mlistbox.h
  • NCSF_LSTBOX_CHECKMASK : mlistbox.h
  • NCSF_LSTBOX_CMBLANK : mlistbox.h
  • NCSF_LSTBOX_CMCHECKED : mlistbox.h
  • NCSF_LSTBOX_CMPARTCHECKED : mlistbox.h
  • NCSF_LSTBOX_SIGNIFICANT : mlistbox.h
  • NCSF_LSTCLM_BOTTOMALIGN : mlistcolumn.h
  • NCSF_LSTCLM_CENTERALIGN : mlistcolumn.h
  • NCSF_LSTCLM_LEFTALIGN : mlistcolumn.h
  • NCSF_LSTCLM_RIGHTALIGN : mlistcolumn.h
  • NCSF_LSTCLM_SHIFT : mlistcolumn.h
  • NCSF_LSTCLM_TOPALIGN : mlistcolumn.h
  • NCSF_LSTCLM_VALIGNMASK : mlistcolumn.h
  • NCSF_LSTCLM_VCENTERALIGN : mlistcolumn.h
  • NCSF_LSTHDR_BOTTOMALIGN : mlistview.h
  • NCSF_LSTHDR_CENTERALIGN : mlistview.h
  • NCSF_LSTHDR_LEFTALIGN : mlistview.h
  • NCSF_LSTHDR_RIGHTALIGN : mlistview.h
  • NCSF_LSTHDR_SHIFT : mlistview.h
  • NCSF_LSTHDR_TOPALIGN : mlistview.h
  • NCSF_LSTHDR_VALIGNMASK : mlistview.h
  • NCSF_LSTHDR_VCENTERALIGN : mlistview.h
  • NCSF_LSTITM_FOLD : mlistitem.h
  • NCSF_LSTITM_PRIVBKCOL : mlistitem.h
  • NCSF_LSTITM_PRIVFGCOL : mlistitem.h
  • NCSF_LSTITM_SHIFT : mlistitem.h
  • ncsGetElement : mrdr.h
  • ncsLoadResPackage : mresmgr.h
  • NCSN_SCRLBR_CHANGED : mscrollbar.h
  • NCSN_SCRLBR_REACHMAX : mscrollbar.h
  • NCSN_SCRLBR_REACHMIN : mscrollbar.h
  • NCSN_TRKBAR_CHANGED : mtrackbar.h
  • NCSN_TRKBAR_REACHMAX : mtrackbar.h
  • NCSN_TRKBAR_REACHMIN : mtrackbar.h
  • NCSP_SCRLBR_CURPOS : mscrollbar.h
  • NCSP_SCRLBR_LINESTEP : mscrollbar.h
  • NCSP_SCRLBR_MAXPOS : mscrollbar.h
  • NCSP_SCRLBR_MINPOS : mscrollbar.h
  • NCSP_SCRLBR_PAGESTEP : mscrollbar.h
  • NCSP_TRKBAR_CURPOS : mtrackbar.h
  • NCSP_TRKBAR_LINESTEP : mtrackbar.h
  • NCSP_TRKBAR_MAXPOS : mtrackbar.h
  • NCSP_TRKBAR_MINPOS : mtrackbar.h
  • NCSP_TRKBAR_PAGESTEP : mtrackbar.h
  • NCSRM_ENCODING_LEN : mresmgr.h
  • NCSRM_SYSSTR_BASEID : mresmgr.h
  • NCSRM_SYSSTR_DEFRDR : mresmgr.h
  • NCSRM_VENDOR_LEN : mresmgr.h
  • NCSRM_VERSION_LEN : mresmgr.h
  • NCSRT_EXT_LEN : mresmgr.h
  • NCSS_ASTLST_AUTOSORT : mabstractlist.h
  • NCSS_ASTLST_SHIFT : mabstractlist.h
  • NCSS_CMBOX_AUTOFOCUS : mcombobox.h
  • NCSS_CMBOX_DROPDOWNLIST : mcombobox.h
  • NCSS_CMBOX_EDITBASELINE : mcombobox.h
  • NCSS_CMBOX_EDITNOBORDER : mcombobox.h
  • NCSS_CMBOX_LOWERCASE : mcombobox.h
  • NCSS_CMBOX_READONLY : mcombobox.h
  • NCSS_CMBOX_SIMPLE : mcombobox.h
  • NCSS_CMBOX_SORT : mcombobox.h
  • NCSS_CMBOX_UPPERCASE : mcombobox.h
  • NCSS_CTNR_SHIFT : mcontainer.h
  • NCSS_EDIT_BASELINE : medit.h
  • NCSS_EDIT_CENTER : medit.h
  • NCSS_EDIT_LEFT : medit.h
  • NCSS_EDIT_LOWERCASE : medit.h
  • NCSS_EDIT_NOHIDESEL : medit.h
  • NCSS_EDIT_READONLY : medit.h
  • NCSS_EDIT_RIGHT : medit.h
  • NCSS_EDIT_UPPERCASE : medit.h
  • NCSS_ICONV_LOOP : miconview.h
  • NCSS_ICONV_SHIFT : miconview.h
  • NCSS_ICONV_SORT : miconview.h
  • NCSS_ITEMV_AUTOSORT : mitemview.h
  • NCSS_ITEMV_LOOP : mitemview.h
  • NCSS_ITEMV_MULTIPLE : mitemview.h
  • NCSS_ITEMV_SHIFT : mitemview.h
  • NCSS_ITEMV_SINGLE : mitemview.h
  • NCSS_LIST_LOOP : mlist.h
  • NCSS_LIST_MULTIPLE : mlist.h
  • NCSS_LIST_SHIFT : mlist.h
  • NCSS_LISTV_AUTOCHECK : mlistview.h
  • NCSS_LISTV_AUTOCHECKBOX : mlistview.h
  • NCSS_LISTV_CHECKBOX : mlistview.h
  • NCSS_LISTV_LOOP : mlistview.h
  • NCSS_LISTV_MULTIPLE : mlistview.h
  • NCSS_LISTV_NOHDRDRAG : mlistview.h
  • NCSS_LISTV_NOTIFY : mlistview.h
  • NCSS_LISTV_SHIFT : mlistview.h
  • NCSS_LISTV_SINGLE : mlistview.h
  • NCSS_LISTV_SORT : mlistview.h
  • NCSS_LISTV_TREE : mlistview.h
  • NCSS_LISTV_WITHICON : mlistview.h
  • NCSS_LSTBOX_AUTOCHECK : mlistbox.h
  • NCSS_LSTBOX_AUTOCHECKBOX : mlistbox.h
  • NCSS_LSTBOX_CHECKBOX : mlistbox.h
  • NCSS_LSTBOX_MOUSEFOLLOW : mlistbox.h
  • NCSS_LSTBOX_MULTIPLE : mlistbox.h
  • NCSS_LSTBOX_SHIFT : mlistbox.h
  • NCSS_LSTBOX_SINGLE : mlistbox.h
  • NCSS_LSTBOX_SORT : mlistbox.h
  • NCSS_LSTBOX_STRING : mlistbox.h
  • NCSS_LSTBOX_USEBITMAP : mlistbox.h
  • NCSS_MLEDIT_AUTOWRAP : mmledit.h
  • NCSS_MLEDIT_TITLE : mmledit.h
  • NCSS_NODE_DISABLED : mnode.h
  • NCSS_NODE_HIDEIMAGE : mnode.h
  • NCSS_NODE_HIDETEXT : mnode.h
  • NCSS_NODE_LTEXTBS : mnode.h
  • NCSS_NODE_LTEXTRS : mnode.h
  • NCSS_NODE_SHIFT : mnode.h
  • NCSS_NODE_SMALLICON : mnode.h
  • NCSS_NODE_TICTACTOEMIDLET : mnode.h
  • NCSS_PAGE_SHIFT : mpage.h
  • NCSS_PANEL_SHIFT : mpanel.h
  • NCSS_PRGBAR_BLOCKS : mprogressbar.h
  • NCSS_PRGBAR_HORIZONTAL : mprogressbar.h
  • NCSS_PRGBAR_SHOWPERCENT : mprogressbar.h
  • NCSS_PRGBAR_SMOOTH : mprogressbar.h
  • NCSS_PRGBAR_VERTICAL : mprogressbar.h
  • NCSS_PRPSHT_BOTTOM : mpropsheet.h
  • NCSS_PRPSHT_COMPACTTAB : mpropsheet.h
  • NCSS_PRPSHT_SCROLLABLE : mpropsheet.h
  • NCSS_PRPSHT_SHIFT : mpropsheet.h
  • NCSS_PRPSHT_TOP : mpropsheet.h
  • NCSS_SCRLBR_ARROWS : mscrollbar.h
  • NCSS_SCRLBR_DOWNDBLARROWS : mscrollbar.h
  • NCSS_SCRLBR_HORIZONTAL : mscrollbar.h
  • NCSS_SCRLBR_LEFTDBLARROWS : mscrollbar.h
  • NCSS_SCRLBR_RIGHTDBLARROWS : mscrollbar.h
  • NCSS_SCRLBR_UPDBLARROWS : mscrollbar.h
  • NCSS_SCRLBR_VERTICAL : mscrollbar.h
  • NCSS_SCRLV_LOOP : mscrollview.h
  • NCSS_SCRLV_SHIFT : mscrollview.h
  • NCSS_SCRLV_SORT : mscrollview.h
  • NCSS_SCRLV_UPNOTIFY : mscrollview.h
  • NCSS_SLEDIT_AUTOSELECT : msledit.h
  • NCSS_SLEDIT_PASSWORD : msledit.h
  • NCSS_SLIDER_HORIZONTAL : mslider.h
  • NCSS_SLIDER_VERTICAL : mslider.h
  • NCSS_SPNBOX_AUTOFOCUS : mspinbox.h
  • NCSS_SPNBOX_AUTOLOOP : mspinbox.h
  • NCSS_SPNBOX_EDITBASELINE : mspinbox.h
  • NCSS_SPNBOX_EDITNOBORDER : mspinbox.h
  • NCSS_SPNBOX_HORIZONTAL : mspinbox.h
  • NCSS_SPNBOX_LOWERCASE : mspinbox.h
  • NCSS_SPNBOX_NUMBER : mspinbox.h
  • NCSS_SPNBOX_READONLY : mspinbox.h
  • NCSS_SPNBOX_SORT : mspinbox.h
  • NCSS_SPNBOX_STRING : mspinbox.h
  • NCSS_SPNBOX_UPPERCASE : mspinbox.h
  • NCSS_SPNBOX_VERTICAL : mspinbox.h
  • NCSS_SPNR_AUTOLOOP : mspinner.h
  • NCSS_SPNR_HORIZONTAL : mspinner.h
  • NCSS_SPNR_VERTICAL : mspinner.h
  • NCSS_SWGT_SHIFT : mscroll_widget.h
  • NCSS_TE_AUTOWRAP : mtextedit.h
  • NCSS_TE_BASELINE : mtextedit.h
  • NCSS_TE_LOWERCASE : mtextedit.h
  • NCSS_TE_NOHIDESEL : mtextedit.h
  • NCSS_TE_OWNERBKGND : mtextedit.h
  • NCSS_TE_READONLY : mtextedit.h
  • NCSS_TE_UPPERCASE : mtextedit.h
  • NCSS_TRKBAR_HORIZONTAL : mtrackbar.h
  • NCSS_TRKBAR_NOTICK : mtrackbar.h
  • NCSS_TRKBAR_VERTICAL : mtrackbar.h
  • ncsSetElement : mrdr.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • c
  • h
  • i
  • l
  • m
  • n
  • s
  • t

- c -

  • CHECKOBJ : mobject.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • c
  • h
  • i
  • l
  • m
  • n
  • s
  • t

- h -

  • hEditor : mitem.h
  • HPACKAGE_NULL : mresmgr.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • c
  • h
  • i
  • l
  • m
  • n
  • s
  • t

- i -

  • INSTANCEOF : mobject.h
  • INVALID_RDR_VALUE : mrdr.h
  • ISCLASS : mcomponent.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • c
  • h
  • i
  • l
  • m
  • n
  • s
  • t

- s -

  • SAFE_CAST : mobject.h
  • SAFE_CAST_CLASS : mobject.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • c
  • h
  • i
  • l
  • m
  • n
  • s
  • t

- t -

  • TYPE_CAST : mobject.h
  • TYPENAME : mobject.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • e
  • m
  • n

- e -

  • enumComboboxNotify : mcombobox.h
  • enumSliderNotify : mslider.h

- m -

  • mAbstractListNotify : mabstractlist.h
  • mAbstractListProperty : mabstractlist.h
  • mComboboxProp : mcombobox.h
  • mComponentQueryCmd : mcomponent.h
  • mContainerNotify : mcontainer.h
  • mEditNotify : medit.h
  • mEditProp : medit.h
  • mIconViewNotify : miconview.h
  • mIconViewProp : miconview.h
  • mItemManagerProp : mitem_manager.h
  • mItemProp : mitem.h
  • mItemViewNotify : mitemview.h
  • mItemViewProp : mitemview.h
  • mLGroupLayoutProp : mlist_layout.h
  • mLHCenterBoxLayoutProp : mlist_layout.h
  • mListBoxNotify : mlistbox.h
  • mListBoxProp : mlistbox.h
  • mListColumnProp : mlistcolumn.h
  • mListItemProp : mlistitem.h
  • mListLayoutProp : mlist_layout.h
  • mListNotify : mlist.h
  • mListProp : mlist.h
  • mListViewNotify : mlistview.h
  • mListViewProp : mlistview.h
  • mMlEditProp : mmledit.h
  • mNodeEvent : mnode.h
  • mNodeProp : mnode.h
  • mPanelNotify : mpanel.h
  • mPanelProp : mpanel.h
  • mProgressBarProp : mprogressbar.h
  • mPropSheetNotify : mpropsheet.h
  • mPropSheetProp : mpropsheet.h
  • mScrollViewNotify : mscrollview.h
  • mScrollViewProp : mscrollview.h
  • mScrollWidgetNotify : mscroll_widget.h
  • mScrollWidgetProp : mscroll_widget.h
  • mSlEditNotify : msledit.h
  • mSlEditProp : msledit.h
  • mSliderHitTest : mslider.h
  • mSliderProp : mslider.h
  • mSpinBoxNotify : mspinbox.h
  • mSpinBoxProp : mspinbox.h
  • mSpinnerNotify : mspinner.h
  • mSpinnerProp : mspinner.h
  • mTextEditorNotify : mtextedit.h
  • mTextEditorProp : mtextedit.h
  • mTrackBarProp : mtrackbar.h

- n -

  • ncsCaretShape : mmledit.h
  • ncsComponentReleated : mcomponent.h
  • ncsInvsbCompProp : minvisible-component.h
  • ncsListLayoutID : mlist.h
  • ncsListVFindType : mlistview.h
  • ncsListVIRType : mlistview.h
  • ncsLstClmSortType : mlistcolumn.h
  • ncsNodeFindType : mnode.h
  • ncsPrpShtFlags : mpropsheet.h
  • ncsRMRdrResType : mresmgr.h
  • ncsSwgtDrawMode : mscroll_widget.h
  • ncsTEScrollMode : mtextedit.h
  • ncsTimerProp : mtimer.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • n
  • q

- n -

  • NCS_CARETSHAPE_BLOCK : mmledit.h
  • NCS_CARETSHAPE_LINE : mmledit.h
  • NCS_CMPT_CHILDREN : mcomponent.h
  • NCS_CMPT_NEXT : mcomponent.h
  • NCS_CMPT_PARENT : mcomponent.h
  • NCS_CMPT_PREV : mcomponent.h
  • NCS_LIST_LICONV : mlist.h
  • NCS_LIST_LLIST : mlist.h
  • NCS_LIST_MAX : mlist.h
  • NCS_NODE_FTDATA : mnode.h
  • NCS_NODE_FTIMAGE : mnode.h
  • NCS_NODE_FTSTRING : mnode.h
  • NCS_TEF_SCROLLBAR_ALWAYS : mtextedit.h
  • NCS_TEF_SCROLLBAR_AUTO : mtextedit.h
  • NCS_TEF_SCROLLBAR_NEVER : mtextedit.h
  • NCSE_NODE_CONTENTCHANGED : mnode.h
  • NCSE_NODE_HEIGHTCHANGED : mnode.h
  • NCSE_NODE_NODEADDED : mnode.h
  • NCSE_NODE_NODEDELETED : mnode.h
  • NCSE_NODE_REFRESH : mnode.h
  • NCSF_PRPSHT_BORDER : mpropsheet.h
  • NCSF_PRPSHT_LEFT : mpropsheet.h
  • NCSF_PRPSHT_MAX : mpropsheet.h
  • NCSF_PRPSHT_PAGE : mpropsheet.h
  • NCSF_PRPSHT_RIGHT : mpropsheet.h
  • NCSF_PRPSHT_TAB : mpropsheet.h
  • NCSID_LISTV_FT_ADDDATA : mlistview.h
  • NCSID_LISTV_FT_TEXT : mlistview.h
  • NCSID_LISTV_IR_FIRSTCHILD : mlistview.h
  • NCSID_LISTV_IR_LASTCHILD : mlistview.h
  • NCSID_LISTV_IR_NEXTSIBLING : mlistview.h
  • NCSID_LISTV_IR_PARENT : mlistview.h
  • NCSID_LISTV_IR_PREVSIBLING : mlistview.h
  • NCSID_LSTCLM_HISORTED : mlistcolumn.h
  • NCSID_LSTCLM_LOSORTED : mlistcolumn.h
  • NCSID_LSTCLM_NOTSORTED : mlistcolumn.h
  • NCSID_SWGT_ALWAYS : mscroll_widget.h
  • NCSID_SWGT_AUTO : mscroll_widget.h
  • NCSID_SWGT_NEVER : mscroll_widget.h
  • NCSN_ASTLST_MAX : mabstractlist.h
  • NCSN_CMBOX_CLOSEUP : mcombobox.h
  • NCSN_CMBOX_DROPDOWN : mcombobox.h
  • NCSN_CMBOX_EDITCHANGE : mcombobox.h
  • NCSN_CMBOX_KILLFOCUS : mcombobox.h
  • NCSN_CMBOX_SELCHANGE : mcombobox.h
  • NCSN_CMBOX_SELECTCANCEL : mcombobox.h
  • NCSN_CMBOX_SELECTOK : mcombobox.h
  • NCSN_CMBOX_SETFOCUS : mcombobox.h
  • NCSN_CTNR_MAX : mcontainer.h
  • NCSN_EDIT_CHANGE : medit.h
  • NCSN_EDIT_CONTCHANGED : medit.h
  • NCSN_EDIT_KILLFOCUS : medit.h
  • NCSN_EDIT_MAXTEXT : medit.h
  • NCSN_EDIT_SELCHANGED : medit.h
  • NCSN_EDIT_SETFOCUS : medit.h
  • NCSN_EDIT_UPDATE : medit.h
  • NCSN_ICONV_MAX : miconview.h
  • NCSN_ITEMV_CLICKED : mitemview.h
  • NCSN_ITEMV_ENTER : mitemview.h
  • NCSN_ITEMV_KILLFOCUS : mitemview.h
  • NCSN_ITEMV_MAX : mitemview.h
  • NCSN_ITEMV_SELCHANGED : mitemview.h
  • NCSN_ITEMV_SELCHANGING : mitemview.h
  • NCSN_ITEMV_SETFOCUS : mitemview.h
  • NCSN_LIST_BACKSPACE : mlist.h
  • NCSN_LIST_BACKUPLIST : mlist.h
  • NCSN_LIST_ENTER : mlist.h
  • NCSN_LIST_ENTERSUBLIST : mlist.h
  • NCSN_LIST_MAX : mlist.h
  • NCSN_LIST_SELCHANGED : mlist.h
  • NCSN_LISTV_CLICKED : mlistview.h
  • NCSN_LISTV_FOLDITEM : mlistview.h
  • NCSN_LISTV_HDRRDOWN : mlistview.h
  • NCSN_LISTV_HDRRUP : mlistview.h
  • NCSN_LISTV_ITEMDBCLK : mlistview.h
  • NCSN_LISTV_ITEMRDOWN : mlistview.h
  • NCSN_LISTV_ITEMRUP : mlistview.h
  • NCSN_LISTV_MAX : mlistview.h
  • NCSN_LISTV_SELCHANGED : mlistview.h
  • NCSN_LISTV_UNFOLDITEM : mlistview.h
  • NCSN_LSTBOX_CLICKED : mlistbox.h
  • NCSN_LSTBOX_CLKCHKMARK : mlistbox.h
  • NCSN_LSTBOX_CMCANCEL : mlistbox.h
  • NCSN_LSTBOX_DBCLK : mlistbox.h
  • NCSN_LSTBOX_ENTER : mlistbox.h
  • NCSN_LSTBOX_ERRSPACE : mlistbox.h
  • NCSN_LSTBOX_KILLFOCUS : mlistbox.h
  • NCSN_LSTBOX_MAX : mlistbox.h
  • NCSN_LSTBOX_SELCHANGED : mlistbox.h
  • NCSN_LSTBOX_SETFOCUS : mlistbox.h
  • NCSN_PANEL_MAX : mpanel.h
  • NCSN_PRPSHT_ACTIVECHANGED : mpropsheet.h
  • NCSN_PRPSHT_MAX : mpropsheet.h
  • NCSN_SCRLV_CLICKED : mscrollview.h
  • NCSN_SCRLV_MAX : mscrollview.h
  • NCSN_SCRLV_SELCHANGED : mscrollview.h
  • NCSN_SCRLV_SELCHANGING : mscrollview.h
  • NCSN_SLEDIT_CHANGE : msledit.h
  • NCSN_SLEDIT_ENTER : msledit.h
  • NCSN_SLIDER_CHANGED : mslider.h
  • NCSN_SLIDER_REACHMAX : mslider.h
  • NCSN_SLIDER_REACHMIN : mslider.h
  • NCSN_SPNBOX_CHANGED : mspinbox.h
  • NCSN_SPNBOX_REACHMAX : mspinbox.h
  • NCSN_SPNBOX_REACHMIN : mspinbox.h
  • NCSN_SPNR_CHANGED : mspinner.h
  • NCSN_SPNR_REACHMAX : mspinner.h
  • NCSN_SPNR_REACHMIN : mspinner.h
  • NCSN_SWGT_MAX : mscroll_widget.h
  • NCSN_TE_CHANGE : mtextedit.h
  • NCSN_TE_CONTENTCHANGED : mtextedit.h
  • NCSN_TE_KILLFOCUS : mtextedit.h
  • NCSN_TE_MAX : mtextedit.h
  • NCSN_TE_MAXTEXT : mtextedit.h
  • NCSN_TE_SELCHANGED : mtextedit.h
  • NCSN_TE_SETFOCUS : mtextedit.h
  • NCSN_TE_UPDATE : mtextedit.h
  • NCSP_ASTLST_AUTOSORT : mabstractlist.h
  • NCSP_ASTLST_CMPNODEFUNC : mabstractlist.h
  • NCSP_ASTLST_DEFNODEHEIGHT : mabstractlist.h
  • NCSP_ASTLST_FONTSIZE : mabstractlist.h
  • NCSP_ASTLST_MAX : mabstractlist.h
  • NCSP_ASTLST_ROOTNODE : mabstractlist.h
  • NCSP_ASTLST_TRANSPARENT : mabstractlist.h
  • NCSP_COMB_DROPDOWNHEIGHT : mcombobox.h
  • NCSP_COMB_ITEMCOUNT : mcombobox.h
  • NCSP_COMB_ITEMHEIGHT : mcombobox.h
  • NCSP_COMB_SELECT : mcombobox.h
  • NCSP_COMB_TEXTLIMIT : mcombobox.h
  • NCSP_EDIT_CARETPOS : medit.h
  • NCSP_EDIT_LIMITTEXT : medit.h
  • NCSP_HCBOX_LAYOUT_MAX : mlist_layout.h
  • NCSP_HCBOX_LAYOUT_OFFX : mlist_layout.h
  • NCSP_ICONV_DEFICONHEIGHT : miconview.h
  • NCSP_ICONV_DEFICONWIDTH : miconview.h
  • NCSP_ICONV_MAX : miconview.h
  • NCSP_ITEM_FLAGS : mitem.h
  • NCSP_ITEM_HEIGHT : mitem.h
  • NCSP_ITEM_MAX : mitem.h
  • NCSP_ITEMV_DEFITEMHEIGHT : mitemview.h
  • NCSP_ITEMV_ITEMCOUNT : mitemview.h
  • NCSP_ITEMV_MAX : mitemview.h
  • NCSP_ITMMNG_FLAGS : mitem_manager.h
  • NCSP_ITMMNG_ITEMCOUNT : mitem_manager.h
  • NCSP_ITMMNG_MAX : mitem_manager.h
  • NCSP_ITMMNG_TOTALHEIGHT : mitem_manager.h
  • NCSP_LGROUP_LAYOUT_MAX : mlist_layout.h
  • NCSP_LIST_DEFNODEHEIGHT : mlist.h
  • NCSP_LIST_DEFNODEWIDTH : mlist.h
  • NCSP_LIST_LAYOUT : mlist.h
  • NCSP_LIST_LAYOUT_MAX : mlist_layout.h
  • NCSP_LIST_MAX : mlist.h
  • NCSP_LISTV_COLCOUNT : mlistview.h
  • NCSP_LISTV_DEFITEMHEIGHT : mlistview.h
  • NCSP_LISTV_GRIDLINECOLOR : mlistview.h
  • NCSP_LISTV_GRIDLINEWIDTH : mlistview.h
  • NCSP_LISTV_HDRHEIGHT : mlistview.h
  • NCSP_LISTV_HDRVISIBLE : mlistview.h
  • NCSP_LISTV_HDRWIDTH : mlistview.h
  • NCSP_LISTV_MAX : mlistview.h
  • NCSP_LISTV_ROWCOUNT : mlistview.h
  • NCSP_LISTV_SORTCOLUMN : mlistview.h
  • NCSP_LSTBOX_HILIGHTEDITEM : mlistbox.h
  • NCSP_LSTBOX_ITEMCOUNT : mlistbox.h
  • NCSP_LSTBOX_ITEMHEIGHT : mlistbox.h
  • NCSP_LSTBOX_ITEMWIDTH : mlistbox.h
  • NCSP_LSTBOX_MAX : mlistbox.h
  • NCSP_LSTBOX_TOPITEM : mlistbox.h
  • NCSP_LSTCLM_CMPFUNC : mlistcolumn.h
  • NCSP_LSTCLM_MAX : mlistcolumn.h
  • NCSP_LSTCLM_POSX : mlistcolumn.h
  • NCSP_LSTCLM_SORTTYPE : mlistcolumn.h
  • NCSP_LSTCLM_WIDTH : mlistcolumn.h
  • NCSP_LSTITM_DEPTH : mlistitem.h
  • NCSP_LSTITM_MAX : mlistitem.h
  • NCSP_LSTITM_NRCHILD : mlistitem.h
  • NCSP_LSTITM_RHEIGHT : mlistitem.h
  • NCSP_MLEDIT_CARETSHAPE : mmledit.h
  • NCSP_MLEDIT_LINECOUNT : mmledit.h
  • NCSP_MLEDIT_LINEFEEDISPCHAR : mmledit.h
  • NCSP_MLEDIT_LINEHEIGHT : mmledit.h
  • NCSP_MLEDIT_LINESEP : mmledit.h
  • NCSP_MLEDIT_NUMOFPARAGRAPHS : mmledit.h
  • NCSP_NODE_ADDDATA : mnode.h
  • NCSP_NODE_CHILDRENCOUNT : mnode.h
  • NCSP_NODE_ENABLED : mnode.h
  • NCSP_NODE_FIRSTCHILD : mnode.h
  • NCSP_NODE_HEIGHT : mnode.h
  • NCSP_NODE_HIDEIMAGE : mnode.h
  • NCSP_NODE_HIDETEXT : mnode.h
  • NCSP_NODE_IMAGE : mnode.h
  • NCSP_NODE_LASTCHILD : mnode.h
  • NCSP_NODE_LAYOUT : mnode.h
  • NCSP_NODE_MAX : mnode.h
  • NCSP_NODE_PARENTNODE : mnode.h
  • NCSP_NODE_SELECTED : mnode.h
  • NCSP_NODE_TEXT : mnode.h
  • NCSP_PANEL_MAX : mpanel.h
  • NCSP_PROG_CURPOS : mprogressbar.h
  • NCSP_PROG_LINESTEP : mprogressbar.h
  • NCSP_PROG_MAXPOS : mprogressbar.h
  • NCSP_PROG_MINPOS : mprogressbar.h
  • NCSP_PRPSHT_ACTIVEPAGE : mpropsheet.h
  • NCSP_PRPSHT_ACTIVEPAGEIDX : mpropsheet.h
  • NCSP_PRPSHT_FIRSTVIEWPAGE : mpropsheet.h
  • NCSP_PRPSHT_FIRSTVIEWPAGEIDX : mpropsheet.h
  • NCSP_PRPSHT_MINTABWIDTH : mpropsheet.h
  • NCSP_PRPSHT_PAGECOUNT : mpropsheet.h
  • NCSP_PRPSHT_TABMARGIN : mpropsheet.h
  • NCSP_SCRLV_MAX : mscrollview.h
  • NCSP_SLEDIT_PWDCHAR : msledit.h
  • NCSP_SLEDIT_TIPTEXT : msledit.h
  • NCSP_SLIDER_CURPOS : mslider.h
  • NCSP_SLIDER_LINESTEP : mslider.h
  • NCSP_SLIDER_MAXPOS : mslider.h
  • NCSP_SLIDER_MINPOS : mslider.h
  • NCSP_SLIDER_PAGESTEP : mslider.h
  • NCSP_SPNBOX_CURPOS : mspinbox.h
  • NCSP_SPNBOX_LINESTEP : mspinbox.h
  • NCSP_SPNBOX_MAXPOS : mspinbox.h
  • NCSP_SPNBOX_MINPOS : mspinbox.h
  • NCSP_SPNR_CURPOS : mspinner.h
  • NCSP_SPNR_LINESTEP : mspinner.h
  • NCSP_SPNR_MAXPOS : mspinner.h
  • NCSP_SPNR_MINPOS : mspinner.h
  • NCSP_SPNR_TARGET : mspinner.h
  • NCSP_SWGT_CONTHEIGHT : mscroll_widget.h
  • NCSP_SWGT_CONTWIDTH : mscroll_widget.h
  • NCSP_SWGT_CONTX : mscroll_widget.h
  • NCSP_SWGT_CONTY : mscroll_widget.h
  • NCSP_SWGT_DRAWMODE : mscroll_widget.h
  • NCSP_SWGT_HSTEPVALUE : mscroll_widget.h
  • NCSP_SWGT_MARGINRECT : mscroll_widget.h
  • NCSP_SWGT_MAX : mscroll_widget.h
  • NCSP_SWGT_VISHEIGHT : mscroll_widget.h
  • NCSP_SWGT_VISWIDTH : mscroll_widget.h
  • NCSP_SWGT_VSTEPVALUE : mscroll_widget.h
  • NCSP_TE_LINECOUNT : mtextedit.h
  • NCSP_TE_MARGINRECT : mtextedit.h
  • NCSP_TE_MAX : mtextedit.h
  • NCSP_TE_PARAGRAPHCOUNT : mtextedit.h
  • NCSP_TE_READONLY : mtextedit.h
  • NCSP_TE_SCROLL_HSTEP : mtextedit.h
  • NCSP_TE_SCROLL_MODE : mtextedit.h
  • NCSP_TE_SCROLL_VSTEP : mtextedit.h
  • NCSP_TE_TEXTLIMIT : mtextedit.h
  • NCSP_TIMER_INTERVAL : mtimer.h
  • NCSP_TRKBAR_MAX : mtrackbar.h
  • NCSP_TRKBAR_THUMB_HEIGHT : mtrackbar.h
  • NCSP_TRKBAR_THUMB_WIDTH : mtrackbar.h
  • NCSRM_RDRTYPE_BINARY : mresmgr.h
  • NCSRM_RDRTYPE_COLOR : mresmgr.h
  • NCSRM_RDRTYPE_FILE : mresmgr.h
  • NCSRM_RDRTYPE_FONT : mresmgr.h
  • NCSRM_RDRTYPE_IMAGE : mresmgr.h
  • NCSRM_RDRTYPE_MAX : mresmgr.h
  • NCSRM_RDRTYPE_METRIC : mresmgr.h
  • NCSRM_RDRTYPE_STRING : mresmgr.h
  • NCSRM_RDRTYPE_TEXT : mresmgr.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • n
  • q

- q -

  • QPC_ADD_BIND : mcomponent.h
  • QPC_ADD_EVENT : mcomponent.h
  • QPC_GET_PROP : mcomponent.h
  • QPC_SET_PROP : mcomponent.h
  • QPC_USER : mcomponent.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • d
  • i
  • l
  • m
  • n

- _ -

  • _initObject() : mobject.h

- d -

  • deleteObject() : mobject.h

- i -

  • initObjectArgs() : mobject.h

- l -

  • list_add() : mdblist.h
  • list_add_tail() : mdblist.h
  • list_del() : mdblist.h
  • list_del_init() : mdblist.h
  • list_empty() : mdblist.h

- m -

  • mAbstractList_getControl() : mabstractlist.h

- n -

  • ncsAddEventListener() : mobject.h
  • ncsAddEventListeners() : mobject.h
  • ncsAddNode() : mnode.h
  • ncsAddRefResPackage() : mresmgr.h
  • ncsComponentConnectEvents() : mcomponent.h
  • ncsCreateInvsbComp() : minvisible-component.h
  • ncsCreateInvsbCompIndirect() : minvisible-component.h
  • ncsCreateMainWindowIndirectFromID() : mresmgr.h
  • ncsCreateModalDialogFromID() : mresmgr.h
  • ncsCreateNode() : mnode.h
  • ncsFreeWndTemplate() : mresmgr.h
  • ncsGetBitmap() : mresmgr.h
  • ncsGetComponentClass() : mcomponent.h
  • ncsGetComponentHandler() : mcomponent.h
  • ncsGetDefaultLocale() : mresmgr.h
  • ncsGetElementEx() : mrdr.h
  • ncsGetImageFileName() : mresmgr.h
  • ncsGetMyBitmap() : mresmgr.h
  • ncsGetString() : mresmgr.h
  • ncsGetSystemRenderer() : mrdr.h
  • ncsGetWndTemplFromID() : mresmgr.h
  • ncsInitialize() : mgncs.h
  • ncsInstanceOf() : mobject.h
  • ncsIsChildClass() : mcomponent.h
  • ncsIsClass() : mcomponent.h
  • ncsIsValidObj() : mobject.h
  • ncsLoadRdrEtcFile() : mrdr.h
  • ncsLoadResPackageFromFile() : mresmgr.h
  • ncsLoadResPackageFromMem() : mresmgr.h
  • ncsRaiseEvent() : mobject.h
  • ncsRegisterComponent() : mcomponent.h
  • ncsRegisterCtrlRDR() : mrdr.h
  • ncsRegisterCtrlRDRs() : mrdr.h
  • ncsReleaseBitmap() : mresmgr.h
  • ncsReleaseMyBitmap() : mresmgr.h
  • ncsRemoveEventConnect() : mobject.h
  • ncsRemoveEventListener() : mobject.h
  • ncsRemoveEventSource() : mobject.h
  • ncsRetriveCtrlRDR() : mrdr.h
  • ncsSafeCast() : mobject.h
  • ncsSafeCastClass() : mobject.h
  • ncsSetComponentHandler() : mcomponent.h
  • ncsSetComponentHandlers() : mcomponent.h
  • ncsSetDefaultLocale() : mresmgr.h
  • ncsSetElementEx() : mrdr.h
  • ncsSetSysRdr() : mresmgr.h
  • ncsSetSystemRenderer() : mrdr.h
  • ncsSetWinRdr() : mresmgr.h
  • ncsUnloadRdrEtcFile() : mrdr.h
  • ncsUnloadResPackage() : mresmgr.h
  • ncsUnregisterCtrlRDRs() : mrdr.h
  • newObject() : mobject.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines

  • HITEM : mitem.h
  • HPACKAGE : mresmgr.h
  • list_t : mdblist.h
  • mCheckNode : mchecknode.h
  • NCS_CB_CMPITEM : mitem_manager.h
  • NCS_CB_CMPNODE : mnode.h
  • NCS_CB_CMPSTR : mitem_manager.h
  • NCS_CB_DRAWITEM : mitemview.h
  • NCS_CB_DSTRITEM : mitemview.h
  • NCS_CB_INITITEM : mitemview.h
  • NCS_CB_LISTV_CMPCLM : mlistcolumn.h
  • NCS_CB_LISTV_DRAWHDR : mlistview.h
  • NCS_CB_LISTV_DRAWHDRBK : mlistview.h
  • NCS_CB_ONINITPAGE : mpage.h
  • NCS_CB_ONOBJEVENT : mobject.h
  • NCS_CB_ONSHEETCMD : mpage.h
  • NCS_CB_ONSHOWPAGE : mpage.h
  • NCS_CB_ONTIMER : mtimer.h
  • PClassConstructor : mobject.h
  • PCONSTRUCT_DWORD : mobject.h
  • PNCS_CREATE_MAIN : mgncs.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines

  • g_stmAbstractListCls : mabstractlist.h
  • g_stmComponentCls : mcomponent.h
  • g_stmContainerCls : mcontainer.h
  • g_stmEditCls : medit.h
  • g_stmGroupNodeCls : mnode.h
  • g_stmIconViewCls : miconview.h
  • g_stmInvsbCompCls : minvisible-component.h
  • g_stmItemCls : mitem.h
  • g_stmItemManagerCls : mitem_manager.h
  • g_stmItemViewCls : mitemview.h
  • g_stmListBoxCls : mlistbox.h
  • g_stmListCls : mlist.h
  • g_stmListColumnCls : mlistcolumn.h
  • g_stmListItemCls : mlistitem.h
  • g_stmListLayoutCls : mlist_layout.h
  • g_stmListViewCls : mlistview.h
  • g_stmMlEditCls : mmledit.h
  • g_stmNodeCls : mnode.h
  • g_stmObjectCls : mobject.h
  • g_stmPageCls : mpage.h
  • g_stmPanelCls : mpanel.h
  • g_stmProgressBarCls : mprogressbar.h
  • g_stmPropSheetCls : mpropsheet.h
  • g_stmScrollBarCls : mscrollbar.h
  • g_stmScrollViewCls : mscrollview.h
  • g_stmScrollWidgetCls : mscroll_widget.h
  • g_stmSlEditCls : msledit.h
  • g_stmSliderCls : mslider.h
  • g_stmTimerCls : mtimer.h
  • g_stmTrackBarCls : mtrackbar.h
Generated on Mon Dec 13 11:32:19 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: Renderer Elements

Renderer Elements

Modules

  • Common Renderer Elements
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mPopMenuMgr

mPopMenuMgr

Data Structures

  • struct mPopMenuMgrClass
    mPopMenuMgr class, derived from mObject More...
  • struct mPopMenuMgr
    the members of mPropMenuMgr More...
Generated on Mon Dec 13 11:32:17 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: hashtable.h Source File

include

hashtable.h

00001 #ifndef HASHTABLE_H
00002 #define HASHTABLE_H
00003
00004 //typedef unsigned int ht_key_t;
00005
00006 #define INVALID_KEY 0u
00007
00008 #define HTE_OK 0
00009 #define HTE_EXIST 1
00010 #define HTE_NOTEXIST 2
00011 #define HTE_INVALID_KEY 3
00012
00013 typedef unsigned long ht_key_t;
00014
00015 typedef struct _HashEntry{
00016         ht_key_t key;
00017         void *data;
00018         struct _HashEntry *next;
00019 }HashEntry;
00020
00021 typedef void (*freeObj)(void* obj);
00022 typedef struct _HashTable{
00023         int count;
00024         HashEntry ** entries;
00025     freeObj      free_obj;
00026 }HashTable;
00027
00028 MGNCS_EXPORT int hash_insert(HashTable* ht,ht_key_t key, void *data);
00029
00030 MGNCS_EXPORT int hash_delete(HashTable* ht,ht_key_t key);
00031
00032 MGNCS_EXPORT void * hash_get(HashTable* ht,ht_key_t key);
00033
00034 MGNCS_EXPORT HashTable * hash_new(int count, freeObj func);
00035
00036 MGNCS_EXPORT void hash_free(HashTable *ht);
00037
00038 #define HT_FOR_EACH_CONTINUE 0
00039 #define HT_FOR_EACH_DELETE   0x1
00040 #define HT_FOR_EACH_BREAK    0x02
00041 typedef int(*eachObj)(void*, void*);
00042 MGNCS_EXPORT void hash_for_each(HashTable *ht, eachObj each, void* user);
00043
00044 #endif
00045
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: Main Page

New Control Set V1.0.6 API Reference Documentation

Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mabstractbuttonpiece.h Source File

include » pieces

mabstractbuttonpiece.h

00001
00002 #ifndef _MGUI_NCSCTRL_ABSTRACTBUTTONPIECEPIECE_H
00003 #define _MGUI_NCSCTRL_ABSTRACTBUTTONPIECEPIECE_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif
00008
00009 typedef struct _mAbstractButtonPieceClass mAbstractButtonPieceClass;
00010 typedef struct _mAbstractButtonPiece mAbstractButtonPiece;
00011
00012 #define mAbstractButtonPieceClassHeader(clss, superCls) \
00013         mContainerPieceClassHeader(clss, superCls)
00014
00015 struct _mAbstractButtonPieceClass
00016 {
00017         mAbstractButtonPieceClassHeader(mAbstractButtonPiece, mContainerPiece)
00018 };
00019
00020 MGNCS_EXPORT extern mAbstractButtonPieceClass g_stmAbstractButtonPieceCls;
00021
00022 #define mAbstractButtonPieceHeader(clss) \
00023         mContainerPieceHeader(clss)  \
00024         unsigned char flags; \
00025         unsigned char state; \
00026         unsigned char check_state; \
00027         unsigned char revert;
00028
00029 struct _mAbstractButtonPiece
00030 {
00031         mAbstractButtonPieceHeader(mAbstractButtonPiece)
00032 };
00033
00034 enum mAbstractButtonPieceStates{
00035         NCS_ABP_NORMAL = 0,
00036         NCS_ABP_HILIGHT,
00037         NCS_ABP_PUSHED,
00038         NCS_ABP_CAPTURED,
00039         NCS_ABP_DISABLED
00040 };
00041
00042 enum mAbstractButtonPieceCheckStates {
00043         NCS_ABP_UNCHECKED = 0,
00044         NCS_ABP_HALFCHECKED ,
00045         NCS_ABP_CHECKED
00046 };
00047
00048 #define NCSS_ABP_CHECKABLE      0x01
00049 #define NCSS_ABP_AUTOCHECK      0x02
00050 #define NCSS_ABP_3DCHECK        0x04
00051 #define NCSS_ABP_DISABLE        0x08
00052 #define NCSS_ABP_FLAT           0x10 // show button's as flat
00053 #define NCSS_ABP_NOREPEATMSG    0x20 // disbale the auto repeat message
00054
00055
00056 #define  mAbstractButtonPiece_isCheckable(self)  \
00057         IS_BIT_SET((self)->flags, NCSS_ABP_CHECKABLE)
00058 #define mAbstractButtonPiece_setCheckable(self, bcheckable)  \
00059         ((bcheckable)?SET_BIT((self)->flags, NCSS_ABP_CHECKABLE):CLEAR_BIT((self)->flags, NCSS_ABP_CHECKABLE))
00060
00061 #define  mAbstractButtonPiece_isAutoCheck(self)  \
00062         IS_BIT_SET((self)->flags, NCSS_ABP_AUTOCHECK)
00063 #define mAbstractButtonPiece_setAutoCheck(self, bautocheck)  \
00064         ((bautocheck)?SET_BIT((self)->flags, NCSS_ABP_AUTOCHECK):CLEAR_BIT((self)->flags, NCSS_ABP_AUTOCHECK))
00065
00066 #define  mAbstractButtonPiece_is3DCheck(self)  \
00067         IS_BIT_SET((self)->flags, NCSS_ABP_3DCHECK)
00068 #define mAbstractButtonPiece_set3DCheck(self, b3dcheck)  \
00069         ((b3dcheck)?SET_BIT((self)->flags, NCSS_ABP_3DCHECK):CLEAR_BIT((self)->flags, NCSS_ABP_3DCHECK))
00070
00071 #define  mAbstractButtonPiece_needRepeatMsg(self)  \
00072         !(IS_BIT_SET((self)->flags, NCSS_ABP_NOREPEATMSG))
00073 #define mAbstractButtonPiece_setNoRepeatMsg(self, norepeat)  \
00074         ((norepeat)?SET_BIT((self)->flags, NCSS_ABP_NOREPEATMSG):CLEAR_BIT((self)->flags, NCSS_ABP_NOREPEATMSG))
00075
00076 #define mAbstractButtonPiece_isEnableFlag(self)  \
00077         (!IS_BIT_SET((self)->flags, NCSS_ABP_DISABLE))
00078
00079 #define mAbstractButtonPiece_setEnable(self, benable) \
00080         ((benable)?CLEAR_BIT((self)->flags,NCSS_ABP_DISABLE):SET_BIT((self)->flags, NCSS_ABP_DISABLE))
00081
00082 enum mAbstractButtonPieceProps{
00083         NCSP_ABP_CHECKABLE = ABP_PROP_BEGIN,
00084         NCSP_ABP_AUTOCHECK,
00085         NCSP_ABP_3DCHECK,
00086         NCSP_ABP_CHECKSTATE,
00087         NCSP_ABP_STATE,
00088         NCSP_ABP_DISABLE,
00089         NCSP_ABP_FLAT,
00090         NCSP_ABP_NOREPEATMSG,
00091 };
00092
00093 enum mAbstractButtonPieceEvent {
00094         NCSN_ABP_CLICKED = ABP_EVENT_BEGIN,
00095         NCSN_ABP_STATE_CHANGED,
00096         NCSN_ABP_PUSHED,
00097         NCSN_ABP_DISABLED //param = 0, diabled, 1 enabled
00098 };
00099
00100 #ifdef __cplusplus
00101 }
00102 #endif
00103
00104 #endif
00105
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mabstractlist.h Source File

include

mabstractlist.h

Go to the documentation of this file.
00001
00026 #ifndef _MGUI_NCSCTRL_ASTLST_H
00027 #define _MGUI_NCSCTRL_ASTLST_H
00028
00029
00030 #ifdef __cplusplus
00031 extern "C" {
00032 #endif  /* __cplusplus */
00033
00039 typedef struct _mAbstractList mAbstractList;
00040 typedef struct _mAbstractListClass mAbstractListClass;
00041 typedef struct _mAbstractListRenderer mAbstractListRenderer;
00042
00050 mAbstractList* mAbstractList_getControl(mNode *node);
00051
00056 #define NCSS_ASTLST_AUTOSORT        (0x0001<<NCSS_SWGT_SHIFT)
00057
00062 #define NCSS_ASTLST_SHIFT           (NCSS_SWGT_SHIFT+1)
00063
00064 static inline int _ncs_defcmp_node(mNode *node1, mNode *node2)
00065 {
00066     const char* str1 = _c(node1)->getText(node1);
00067     const char* str2 = _c(node2)->getText(node2);
00068
00069     return strcasecmp(str1, str2);
00070 }
00071
00072 #define mAbstractListHeader(clsName)\
00073         mScrollWidgetHeader(clsName)    \
00074     NCS_CB_CMPNODE  nodeCmp;        \
00075     mNode   *root;                  \
00076     int     textIndent;             \
00077     int     imageIndent;            \
00078     Uint16  flags;
00079
00096 struct _mAbstractList
00097 {
00098         mAbstractListHeader(mAbstractList)
00099 };
00100
00101 #define mAbstractListClassHeader(clsName, superCls) \
00102         mScrollWidgetClassHeader(clsName, superCls)     \
00103     int (*addNode)(clsName*, mNode *node);          \
00104     int (*insertNode)(clsName*, mNode *node, mNode *prev,mNode *next, int index);\
00105     int (*removeNode)(clsName*, mNode *node);       \
00106     mNode* (*getNode)(clsName*, int index);         \
00107     int (*indexOf)(clsName*, mNode *node);          \
00108     BOOL (*isFrozen)(clsName*);                     \
00109     BOOL (*showNode)(clsName*, mNode *node);        \
00110     void (*refreshNode)(clsName*, mNode *node, const RECT *rcInv);  \
00111     mNode* (*findNode)(clsName*, DWORD info, int type, BOOL recursion, int startIndex); \
00112     \
00113     BOOL (*setCurSel)(clsName*, int index);                 \
00114     mNode* (*getCurSel)(clsName*);                          \
00115     BOOL (*selectNode)(clsName*, mNode *node, BOOL select); \
00116     \
00117     int (*getRect)(clsName*, mNode *node, RECT *rcNode, BOOL bConv);    \
00118     void (*freeze)(clsName*, BOOL locked);                              \
00119     void (*sortNodes)(clsName*, NCS_CB_CMPNODE func, mNode *parentNode);\
00120     void (*notifyEvent)(clsName*, int eventId, DWORD eventInfo);
00121
00198 struct _mAbstractListClass
00199 {
00200         mAbstractListClassHeader(mAbstractList, mScrollWidget)
00201 };
00202
00203 #define mAbstractListRendererHeader(clsName, parentClass) \
00204         mScrollWidgetRendererHeader(clsName, parentClass)
00205
00211 struct  _mAbstractListRenderer {
00212         mAbstractListRendererHeader(mAbstractList, mScrollWidget)
00213 };
00214
00219 enum mAbstractListNotify
00220 {
00224     NCSN_ASTLST_MAX = NCSN_SWGT_MAX + 1,
00225 };
00226
00231 enum mAbstractListProperty
00232 {
00236     NCSP_ASTLST_DEFNODEHEIGHT = NCSP_SWGT_MAX + 1,
00237
00241     NCSP_ASTLST_FONTSIZE,
00242
00246     NCSP_ASTLST_AUTOSORT,
00247
00251     NCSP_ASTLST_TRANSPARENT,
00252
00256     NCSP_ASTLST_CMPNODEFUNC,
00257
00261     NCSP_ASTLST_ROOTNODE,
00262
00263     NCSP_ASTLST_TEXTINDENT,
00264
00265     NCSP_ASTLST_IMAGEINDENT,
00269     NCSP_ASTLST_MAX,
00270 };
00271
00278 MGNCS_EXPORT extern mAbstractListClass g_stmAbstractListCls;
00279
00281 #ifdef __cplusplus
00282 }
00283 #endif  /* __cplusplus */
00284
00285 #endif /* _MGUI_NCSCTRL_ASTLST_H */
00286
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: manimate.h Source File

include

manimate.h

00001
00002 #ifndef _MGUI_NCSCTRL_ANIMATESTATIC_H
00003 #define _MGUI_NCSCTRL_ANIMATESTATIC_H
00004
00005
00006 #ifdef __cplusplus
00007 extern "C" {
00008 #endif  /* __cplusplus */
00009
00010 #define NCSCTRL_ANIMATE        NCSCLASSNAME("animate")
00011
00012 typedef struct _mAnimate mAnimate;
00013 typedef struct _mAnimateClass mAnimateClass;
00014 typedef struct _mAnimateRenderer mAnimateRenderer;
00015
00016
00017 #define mAnimateHeader(clsName) \
00018         mStaticHeader(clsName)  \
00019         unsigned int state:4;  \
00020         unsigned int paint_flag; \
00021         unsigned int interval:24; \
00022         char *path;     \
00023         HDC  mem_dc;
00024
00025 struct _mAnimate
00026 {
00027         mAnimateHeader(mAnimate)
00028 };
00029
00030 #define mAnimateClassHeader(clsName, parentClass) \
00031         mStaticClassHeader(clsName, parentClass) \
00032         BOOL (*play)(clsName*); \
00033         BOOL (*pauseResume)(clsName*); \
00034         BOOL (*stop)(clsName*);
00035
00036 struct _mAnimateClass
00037 {
00038         mAnimateClassHeader(mAnimate, mStatic)
00039 };
00040
00041 #define mAnimateRendererHeader(clsName, parentClass) \
00042         mStaticRendererHeader(clsName, parentClass)
00043
00044 struct _mAnimateRenderer {
00045         mAnimateRendererHeader(mAnimate, mStatic)
00046 };
00047
00048 MGNCS_EXPORT extern mAnimateClass g_stmAnimateCls;
00049
00050 enum mAnimateProp {
00051         NCSP_ANMT_GIFFILE = NCSP_STATIC_MAX + 1,
00052         NCSP_ANMT_DIR,
00053         NCSP_ANMT_INTERVAL,
00054         NCSP_ANMT_MEM, //gif memory
00055         NCSP_ANMT_BMPARRAY, //bmp array end by NULL, e.g PBITMAP bmps={&bmp1, &bmp2, ..., NULL}
00056         NCSP_ANMT_AFRAME, //set the animate frame object
00057         NCSP_ANMT_MAX,
00058 };
00059
00060 #define NCSS_ANMT_SHIFT  (NCSS_STATIC_SHIFT + 1)
00061
00062 #define NCSS_ANMT_AUTOLOOP (0x1<<NCSS_ANMT_SHIFT)
00063
00064 #define NCSS_ANMT_SCALE (0x2<<NCSS_ANMT_SHIFT)
00065
00066 #define NCSS_ANMT_AUTOFIT       (0x4<<NCSS_ANMT_SHIFT)
00067
00068 #define NCSS_ANMT_AUTOPLAY   (0x8<<NCSS_ANMT_SHIFT)
00069
00070 enum enumAnimateNotify{
00071         NCSN_ANMT_MAX = NCSN_STATIC_MAX + 1
00072 };
00073
00074 #define ANIM_PLAY 0x01
00075 #define ANIM_PAUSE 0x02
00076 #define ANIM_STOP 0x04
00077 #define ANIM_STARTPLAY 0xF112
00078 #define ANIM_PAUSE_RESUME 0xF113
00079 #define ANIM_STOPPLAY 0xF114
00080
00081 #define ncsAnimateStart(self)  ((self)?_c(self)->play(self):FALSE)
00082
00083 #define ncsAnimatePauseResume(self)  ((self)?_c(self)->pauseResume(self):FALSE)
00084
00085 #define ncsAnimateStop(self) ((self)?_c(self)->stop(self):FALSE)
00086
00087 #ifdef __cplusplus
00088 }
00089 #endif  /* __cplusplus */
00090
00091 #endif
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: manimateframes.h Source File

include

manimateframes.h

00001 #ifndef _MGUI_NCSCTRL_ANIMATEFRAMES_H
00002 #define _MGUI_NCSCTRL_ANIMATEFRAMES_H
00003
00004 #ifdef _cplusplus
00005 extern "C"{
00006 #endif
00007
00008 #define NCSCTRL_ANIMATEFRAMES NCSCLASSNAME("animateframes")
00009
00010 typedef struct _mAnimateFrames mAnimateFrames;
00011 typedef struct _mAnimateFramesClass mAnimateFramesClass;
00012
00013 #define mAnimateFramesHeader(clss) \
00014         mObjectHeader(clss) \
00015         int max_width; \
00016         int max_height; \
00017         int nr_frames; \
00018         void * cur_frame;
00019
00020 struct _mAnimateFrames{
00021         mAnimateFramesHeader(mAnimateFrames)
00022 };
00023
00024 #define NCSR_ANIMATEFRAME_OK 0
00025 #define NCSR_ANIMATEFRAME_LASTFRAME 1
00026 #define NCSR_ANIMATEFRAME_FAILED -1
00027
00028 #define mAnimateFramesClassHeader(clss, superCls) \
00029         mObjectClassHeader(clss, superCls) \
00030         BOOL (*getMaxFrameSize)(mAnimateFrames* self, int *pwidth, int *pheight); \
00031         int (*drawFrame)(mAnimateFrames* self, HDC hdc, mObject *owner, RECT *pRect, int align, int valign, BOOL bScale); \
00032         int (*nextFrame)(mAnimateFrames* self);
00033
00034 struct _mAnimateFramesClass{
00035         mAnimateFramesClassHeader(mAnimateFrames, mObject)
00036 };
00037
00038 MGNCS_EXPORT extern mAnimateFramesClass g_stmAnimateFramesCls;
00039
00040 #ifdef _cplusplus
00041 }
00042 #endif
00043
00044 #endif
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: manimatepiece.h Source File

include » pieces

manimatepiece.h

00001 #ifndef _MGNCS_ANIMATEPIECE_H
00002 #define _MGNCS_ANIMATEPIECE_H
00003
00004 #ifdef __cplusplus
00005 extern "C" {
00006 #endif
00007
00008 typedef struct _mAnimatePiece mAnimatePiece;
00009 typedef struct _mAnimatePieceClass mAnimatePieceClass;
00010
00011 #define mAnimatePieceHeader(clss) \
00012         mStaticPieceHeader(clss) \
00013         unsigned char flags;    \
00014         unsigned char align:4;  \
00015         unsigned char valign:4; \
00016         mAnimateFrames *frame;
00017
00018 struct _mAnimatePiece
00019 {
00020         mAnimatePieceHeader(mAnimatePiece)
00021 };
00022
00023 #define mAnimatePieceClassHeader(clss, superCls) \
00024         mStaticPieceClassHeader(clss, superCls) \
00025         void (*reset)(mAnimatePiece *self); \
00026         void (*autofit)(mAnimatePiece *self, int *width, int *height); \
00027
00028 struct _mAnimatePieceClass
00029 {
00030         mAnimatePieceClassHeader(mAnimatePiece, mStaticPiece)
00031 };
00032
00033 MGNCS_EXPORT extern mAnimatePieceClass g_stmAnimatePieceCls;
00034
00035 enum mAnimatePieceProps {
00036         NCSP_ANIMATEPIECE_GIFFILE = ANIMATEPIECE_PROP_BEGIN,
00037         NCSP_ANIMATEPIECE_DIR,
00038         NCSP_ANIMATEPIECE_MEM,
00039         NCSP_ANIMATEPIECE_AUTOLOOP,
00040         NCSP_ANIMATEPIECE_SCALE,
00041         NCSP_ANIMATEPIECE_AUTOFIT,
00042         NCSP_ANIMATEPIECE_AUTOPLAY,
00043         NCSP_ANIMATEPIECE_BMPARRAY,
00044         NCSP_ANIMATEPIECE_AFRAME,
00045         NCSP_ANIMATEPIECE_ALIGN = PIECECOMM_PROP_ALIGN,
00046         NCSP_ANIMATEPIECE_VALIGN = PIECECOMM_PROP_VALIGN
00047 };
00048
00049 #define NCSS_AF_AUTOLOOP 0x01
00050 #define NCSS_AF_PLAY 0x02
00051 #define NCSS_AF_SCALE 0x04
00052 #define NCSS_AF_AUTOFIT 0x08
00053 #define NCSS_AF_AUTOPLAY 0x10
00054
00055 #define mAnimatePiece_setAutoloop(self, bautoloop) \
00056         ((bautoloop)?SET_BIT((self)->flags, NCSS_AF_AUTOLOOP):CLEAR_BIT((self)->flags, NCSS_AF_AUTOLOOP))
00057
00058 #define mAnimatePiece_isAutoloop(self)  \
00059         IS_BIT_SET((self)->flags, NCSS_AF_AUTOLOOP)
00060
00061 #define mAnimatePiece_setScale(self, bscale) \
00062         ((bscale)?SET_BIT((self)->flags, NCSS_AF_SCALE):CLEAR_BIT((self)->flags, NCSS_AF_SCALE))
00063
00064 #define mAnimatePiece_isScale(self)     \
00065         IS_BIT_SET((self)->flags, NCSS_AF_SCALE)
00066
00067 #define mAnimatePiece_setAutofit(self, bautofit) \
00068         ((bautofit)?SET_BIT((self)->flags, NCSS_AF_AUTOFIT):CLEAR_BIT((self)->flags, NCSS_AF_AUTOFIT))
00069
00070 #define mAnimatePiece_isAutofit(self)   \
00071         IS_BIT_SET((self)->flags, NCSS_AF_AUTOFIT)
00072
00073 #define mAnimatePiece_setPlay(self, bplay) \
00074         ((bplay)?SET_BIT((self)->flags, NCSS_AF_PLAY):CLEAR_BIT((self)->flags, NCSS_AF_PLAY))
00075
00076 #define mAnimatePiece_isPlay(self)      \
00077         IS_BIT_SET((self)->flags, NCSS_AF_PLAY)
00078
00079 #define mAnimatePiece_setAutoplay(self, bautoplay) \
00080         ((bautoplay)?SET_BIT((self)->flags, NCSS_AF_AUTOPLAY):CLEAR_BIT((self)->flags, NCSS_AF_AUTOPLAY))
00081
00082 #define mAnimatePiece_isAutoplay(self)  \
00083         IS_BIT_SET((self)->flags, NCSS_AF_AUTOPLAY)
00084
00085 #ifdef __cplusplus
00086 }
00087 #endif
00088
00089 #endif
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: marrowbuttonpiece.h Source File

include » pieces

marrowbuttonpiece.h

00001
00002 #ifndef _MGUI_NCSCTRL_ARROWBUTTONPIECE_H
00003 #define _MGUI_NCSCTRL_ARROWBUTTONPIECE_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif
00008
00009 typedef struct _mArrowButtonPieceClass mArrowButtonPieceClass;
00010 typedef struct _mArrowButtonPiece mArrowButtonPiece;
00011
00012 #define mArrowButtonPieceClassHeader(clss, superCls) \
00013         mAbstractButtonPieceClassHeader(clss, superCls)
00014
00015 struct _mArrowButtonPieceClass
00016 {
00017         mArrowButtonPieceClassHeader(mArrowButtonPiece, mAbstractButtonPiece)
00018 };
00019
00020 MGNCS_EXPORT extern mArrowButtonPieceClass g_stmArrowButtonPieceCls;
00021
00022 #define mArrowButtonPieceHeader(clss) \
00023         mAbstractButtonPieceHeader(clss)
00024
00025 struct _mArrowButtonPiece
00026 {
00027         mArrowButtonPieceHeader(mArrowButtonPiece)
00028 };
00029
00030 /*
00031 #define mArrowButtonPiece_setArrow(self, arrow) \
00032         ((self)->revert = ((arrow)>>NCS_PIECE_PAINT_ARROW_SHIFT))
00033 #define mArrowButtonPiece_getArrow(self) \
00034         ((self)->revert<<NCS_PIECE_PAINT_ARROW_SHIFT)
00035 */
00036
00037 #ifdef __cplusplus
00038 }
00039 #endif
00040
00041 #endif
00042
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: marrowpiece.h Source File

include » pieces

marrowpiece.h

00001
00002 #ifndef _MGUI_NCSCTRL_ARROWPIECE_H
00003 #define _MGUI_NCSCTRL_ARROWPIECE_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif
00008
00009 typedef struct _mArrowPieceClass mArrowPieceClass;
00010 typedef struct _mArrowPiece mArrowPiece;
00011
00012 #define mArrowPieceClassHeader(clss, superCls) \
00013         mRenderablePieceClassHeader(clss, superCls)
00014
00015 struct _mArrowPieceClass
00016 {
00017         mArrowPieceClassHeader(mArrowPiece, mRenderablePiece)
00018 };
00019
00020 MGNCS_EXPORT extern mArrowPieceClass g_stmArrowPieceCls;
00021
00022 #define mArrowPieceHeader(clss) \
00023         mRenderablePieceHeader(clss)
00024
00025 struct _mArrowPiece
00026 {
00027         mArrowPieceHeader(mArrowPiece)
00028 };
00029
00030 #ifdef __cplusplus
00031 }
00032 #endif
00033
00034 #endif
00035
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mbmparrayanimateframes.h Source File

include

mbmparrayanimateframes.h

00001 #ifndef _MGUI_NCSCTRL_BMPARRAYANIMATEFRAMES_H
00002 #define _MGUI_NCSCTRL_BMPARRAYANIMATEFRAMES_H
00003
00004 #ifdef _cplusplus
00005 extern "C"{
00006 #endif
00007
00008 typedef struct _mBmpArrayAnimateFrames mBmpArrayAnimateFrames;
00009 typedef struct _mBmpArrayAnimateFramesClass mBmpArrayAnimateFramesClass;
00010
00011 typedef struct _mBmpArrayAnimateFrame{
00012         PBITMAP bmp;
00013         struct _mBmpArrayAnimateFrame* next;
00014         struct _mBmpArrayAnimateFrame* prev;
00015 }mBmpArrayAnimateFrame;
00016
00017 #define mBmpArrayAnimateFramesHeader(clsName) \
00018         mAnimateFramesHeader(clsName) \
00019         mBmpArrayAnimateFrame *frames; \
00020         PRIVATE DWORD flags;
00021
00022 struct _mBmpArrayAnimateFrames{
00023         mBmpArrayAnimateFramesHeader(mAnimateFrames)
00024 };
00025
00026 #define mBmpArrayAnimateFramesClassHeader(clss, superCls) \
00027         mAnimateFramesClassHeader(clss, superCls) \
00028
00029 struct _mBmpArrayAnimateFramesClass{
00030         mBmpArrayAnimateFramesClassHeader(mBmpArrayAnimateFrames, mAnimateFrames)
00031 };
00032
00033 MGNCS_EXPORT extern mBmpArrayAnimateFramesClass g_stmBmpArrayAnimateFramesCls;
00034
00035 MGNCS_EXPORT mBmpArrayAnimateFrames * ncsCreateAnimateFramesFromDIR(const char* dir);
00036
00037 MGNCS_EXPORT mBmpArrayAnimateFrames * ncsCreateAnimateFramesFromImageList(const char ** file_list, int count);
00038
00039 MGNCS_EXPORT mBmpArrayAnimateFrames * ncsCreateAnimateFramesFromBmpArray(PBITMAP * bmps, int count, BOOL auto_delete);
00040
00041 #define ncsCreateAnimateFramesFromMEM(bmps, count) \
00042         ncsCreateAnimateFramesFromBmpArray(bmps, count, FALSE)
00043
00044
00045 #ifdef _cplusplus
00046 }
00047 #endif
00048
00049 #endif
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mboxlayoutpiece.h Source File

include » pieces

mboxlayoutpiece.h

00001
00002 #ifndef _MGUI_NCSCTRL_BOXLAYOUTPIECE_H
00003 #define _MGUI_NCSCTRL_BOXLAYOUTPIECE_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif
00008
00009 typedef struct _mBoxLayoutPieceClass mBoxLayoutPieceClass;
00010 typedef struct _mBoxLayoutPiece mBoxLayoutPiece;
00011
00012 #define mBoxLayoutPieceClassHeader(clss, superCls) \
00013         mLayoutPieceClassHeader(clss, superCls) \
00014  \
00015         void (*recalcBox)(clss *); \
00016         int  (*getCellAutoSize)(clss *, int i); \
00017  \
00018         int (*setCellInfo)(clss *, int idx, int size, int type/*=NCS_BOXLAYOUTPIECE_ST_FIXED*/, BOOL bupdate/*=FALSE*/); \
00019         mHotPiece* (*setCell)(clss *, int idx, mHotPiece *cell); \
00020         mHotPiece* (*getCell)(clss *, int idx);
00021
00022 struct _mBoxLayoutPieceClass
00023 {
00024         mBoxLayoutPieceClassHeader(mBoxLayoutPiece, mLayoutPiece)
00025 };
00026
00027 MGNCS_EXPORT extern mBoxLayoutPieceClass g_stmBoxLayoutPieceCls;
00028
00029 #define mBoxLayoutPieceHeader(clss) \
00030         mLayoutPieceHeader(clss)  \
00031         int left:16; \
00032         int top:16; \
00033         int right:16; \
00034         int bottom:16; \
00035         unsigned short count; \
00036         unsigned char  margin; \
00037         unsigned char  space; \
00038         unsigned short * cell_info; \
00039         mHotPiece ** cells;
00040
00041
00042 struct _mBoxLayoutPiece
00043 {
00044         mBoxLayoutPieceHeader(mBoxLayoutPiece)
00045 };
00046
00047 #define mBoxLayoutPiece_getSizeType(size)  mLayoutPiece_getSizeType(size)
00048 #define mBoxLayoutPiece_setSizeType(size, type) mLayoutPiece_setSizeType(size, type)
00049 #define mBoxLayoutPiece_setSize(size, value)    mLayoutPiece_setSize(size, value)
00050 #define mBoxLayoutPiece_getSize(size) mLayoutPiece_getSize(size)
00051
00052
00053 enum mBoxLayoutPieceProps{
00054         NCSP_BOXLAYOUTPIECE_COUNT = BOXLAYOUTPIECE_PROP_BEGIN,
00055         NCSP_BOXLAYOUTPIECE_SPACE     = PIECECOMM_PROP_SPACE,
00056         NCSP_BOXLAYOUTPIECE_MARGIN    = PIECECOMM_PROP_MARGIN
00057 };
00058
00061 BOOL mBoxLayoutPiece_calcSize(mBoxLayoutPiece *self, int total_size, int *sizes);
00062
00063 #ifdef __cplusplus
00064 }
00065 #endif
00066
00067 #endif
00068
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mbtree.h Source File

include

mbtree.h

00001 /*
00002 ** $Id: btree.h 13036 2010-07-13 12:49:37Z dongjunjie $
00003 **
00004 ** btree.h: this head file declares btree structure.
00005 **
00006 ** Copyright (C) 2010 Feynman Software.
00007 **
00008 ** Create date: 2010/03/10
00009 */
00010
00011 #ifndef _COMM_BTREE_H
00012 #define _COMM_BTREE_H
00013
00014 #define BTREE_ERRNO_SCHILD  1
00015 #define BTREE_ERRNO_SNEXT   0
00016 #define BTREE_ERRNO_SNULL  -1
00017
00018 DECLARE_OBJECT(mCommBTreeNode)
00019 DECLARE_OBJECT(mCommBTree)
00020 DECLARE_OBJECT(mCommBTreeLeafIterator)
00021
00022 #define mCommBTreeLeafIteratorHeader(Clss)       \
00023     mObjectHeader(Clss)                         \
00024     mCommBTree       *tree;                      \
00025     mCommBTreeNode   *current;
00026
00027 #define mCommBTreeLeafIteratorClassHeader(Clss, Super)\
00028     mObjectClassHeader(Clss, Super)             \
00029     mCommBTreeNode* (*getCurrent)(Clss *self);   \
00030     BOOL (*hasNext)(Clss *self);                 \
00031     mCommBTreeNode* (*next)(Clss *self);         \
00032     void (*remove)(Clss *self);                 \
00033     void (*insert)(Clss *self, mCommBTreeNode *leaf);
00034
00035
00036 #define mCommBTreeNodeHeader(Clss)               \
00037     mObjectHeader(Clss)                         \
00038     Clss    *parent;                            \
00039     Clss    *next;                              \
00040     Clss    *children;                          \
00041     unsigned int level:16;                      \
00042     /* Number of children of this node. */      \
00043     unsigned int numChildren:16;                \
00044     /* Total number of leaves in the subtree rooted here. */\
00045     unsigned int numLeaves;
00046
00047
00048 #define mCommBTreeNodeClassHeader(Clss, Super)       \
00049     mObjectClassHeader(Clss, Super)                 \
00050     void (*resetKey)(Clss *self);                   \
00051     int (*compareNode)(Clss *self, void *cmpInfo);  \
00052     void (*recompute)(Clss *self, Clss *child);     \
00053     void (*changeKey)(Clss *self, void *diffInfo, int deltaChild); \
00054     BOOL (*isNullKey)(Clss *self);
00055
00056 #define mCommBTreeHeader(Clss)   \
00057         mObjectHeader(Clss)         \
00058     mCommBTreeNode *rootNode;    \
00059     int minChildrenNum;         \
00060     int maxChildrenNum;         \
00061     int refCount;
00062
00063 #define mCommBTreeClassHeader(Clss, Super)       \
00064     mObjectClassHeader(Clss, Super)             \
00065     void (*ref)(Clss *self);                    \
00066     void (*unref)(Clss *self);                  \
00067     mCommBTreeNode* (*getRoot)(Clss *self);      \
00068     void (*rebalanceNode)(Clss *self, mCommBTreeNode *node);     \
00069     void (*recomputeNodeInfo)(Clss *self, mCommBTreeNode *node); \
00070     void (*deleteNode)(Clss *self, mCommBTreeNode *node);        \
00071     BOOL (*insertLeaf)(Clss *self, mCommBTreeNode *parent,       \
00072             mCommBTreeNode *sibLeaf, mCommBTreeNode *leaf);       \
00073     mCommBTreeNode* (*search)(Clss *self, void* searchInfo, int flags);     \
00074     mCommBTreeNode* (*newNode)(Clss *self);                      \
00075     mCommBTreeNode* (*newLeaf)(Clss *self);
00076
00077 //search flags
00078 enum {
00079         BTSF_RETLAST_IF_OUTOFRANGE = 0x1
00080 };
00081
00082 DEFINE_OBJECT(mCommBTreeNode, mObject)
00083 DEFINE_OBJECT(mCommBTree, mObject)
00084 DEFINE_OBJECT(mCommBTreeLeafIterator, mObject)
00085 #endif
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mbutton.h Source File

include

mbutton.h

00001
00002 #ifndef _MGUI_NCSCTRL_BUTTON_H
00003 #define _MGUI_NCSCTRL_BUTTON_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif  /* __cplusplus */
00008
00018 #define NCSCTRL_BUTTON   NCSCLASSNAME("button")
00019
00020 typedef struct _mButton mButton;
00021 typedef struct _mButtonClass mButtonClass;
00022 typedef struct _mButtonRenderer mButtonRenderer;
00023
00029 enum mButtonCheckState{
00030         NCS_BUTTON_UNCHECKED = 0,
00031         NCS_BUTTON_HALFCHECKED,
00032         NCS_BUTTON_CHECKED
00033 };
00034
00048 #define mButtonHeader(clsName)  \
00049         mWidgetHeader(clsName) \
00050         mWidget* group;
00051
00061 struct _mButton
00062 {
00063         mButtonHeader(mButton)
00064 };
00065
00066 #define mButtonClassHeader(clsName, parentClass)        \
00067         mWidgetClassHeader(clsName, parentClass) \
00068         mObject * (*createContent)(clsName *self, DWORD dwStyle); \
00069         mObject * (*createButtonBody)(clsName *self, DWORD dwStyle, mObject * content);
00070
00092 struct _mButtonClass
00093 {
00094         mButtonClassHeader(mButton, mWidget)
00095 };
00096
00097 #define mButtonRendererHeader(clsName, parentClass)     \
00098         mWidgetRendererHeader(clsName, parentClass)         \
00099     void (*drawPushButton)(clsName *self, HDC hdc,     \
00100             const RECT *rect, \
00101                         DWORD color1, DWORD color2, int status);
00102
00120 struct _mButtonRenderer
00121 {
00122         mButtonRendererHeader(mButton, mWidget)
00123 };
00124
00129 MGNCS_EXPORT extern mButtonClass g_stmButtonCls;
00130
00135 enum mButtonProp {
00143         NCSP_BUTTON_ALIGN = NCSP_WIDGET_MAX + 1,
00151         NCSP_BUTTON_VALIGN,
00159         NCSP_BUTTON_WORDWRAP,
00167         NCSP_BUTTON_IMAGE,
00175         NCSP_BUTTON_CHECKSTATE,
00183         NCSP_BUTTON_IMAGE_SIZE_PERCENT,
00191         NCSP_BUTTON_GROUPID,
00199         NCSP_BUTTON_GROUP,
00200         NCSP_BUTTON_MAX
00201 };
00202
00208 enum eButtonNotify {
00213         NCSN_BUTTON_PUSHED = NCSN_WIDGET_MAX + 1,
00220         NCSN_BUTTON_STATE_CHANGED,
00221         NCSN_BUTTON_MAX
00222 };
00223
00228 #define NCSS_BUTTON_IMAGE        (1<<NCSS_WIDGET_SHIFT)
00229
00233 #define NCSS_BUTTON_CHECKABLE    (2<<NCSS_WIDGET_SHIFT)
00234
00239 #define NCSS_BUTTON_AUTOCHECK    (4<<NCSS_WIDGET_SHIFT)
00240
00245 #define NCSS_BUTTON_3DCHECK      (8<<NCSS_WIDGET_SHIFT)
00246
00251 #define NCSS_BUTTON_IMAGELABEL   (0x10<<NCSS_WIDGET_SHIFT)
00252
00257 #define NCSS_BUTTON_VERTIMAGELABEL (0x20<<NCSS_WIDGET_SHIFT)
00258 #define NCSS_BUTTON_SHIFT        (NCSS_WIDGET_SHIFT + 6)
00259
00265 #ifdef __cplusplus
00266 }
00267 #endif  /* __cplusplus */
00268
00269 #endif /* _MGUI_NCSCTRL_BUTTON_H */
00270
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mbuttonboxpiece.h Source File

include » pieces

mbuttonboxpiece.h

00001
00002 #ifndef _MGUI_NCSCTRL_BUTTONBOXPIECE_H
00003 #define _MGUI_NCSCTRL_BUTTONBOXPIECE_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif
00008
00009 typedef struct _mButtonBoxPieceClass mButtonBoxPieceClass;
00010 typedef struct _mButtonBoxPiece mButtonBoxPiece;
00011
00012 #define mButtonBoxPieceClassHeader(clss, superCls) \
00013         mRenderablePieceClassHeader(clss, superCls)
00014
00015 struct _mButtonBoxPieceClass
00016 {
00017         mButtonBoxPieceClassHeader(mButtonBoxPiece, mRenderablePiece)
00018 };
00019
00020 MGNCS_EXPORT extern mButtonBoxPieceClass g_stmButtonBoxPieceCls;
00021
00022 #define mButtonBoxPieceHeader(clss) \
00023         mRenderablePieceHeader(clss)
00024
00025 struct _mButtonBoxPiece
00026 {
00027         mButtonBoxPieceHeader(mButtonBoxPiece)
00028 };
00029
00030
00031 #ifdef __cplusplus
00032 }
00033 #endif
00034
00035 #endif
00036
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mbuttongroup.h Source File

include

mbuttongroup.h

00001
00002 #ifndef _MGUI_NCSCTRL_BTNGRP_H
00003 #define _MGUI_NCSCTRL_BTNGRP_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif  /* __cplusplus */
00008
00018 #define NCSCTRL_BUTTONGROUP        NCSCLASSNAME("buttongroup")
00019
00020 typedef struct _mButtonGroup mButtonGroup;
00021 typedef struct _mButtonGroupClass mButtonGroupClass;
00022 typedef struct _mButtonGroupRenderer mButtonGroupRenderer;
00023
00024 typedef struct _mButtonNode mButtonNode;
00035 struct _mButtonNode
00036 {
00037         mWidget         *pbtn;
00038         mButtonNode     *next;
00039 };
00040
00041 #define mButtonGroupHeader(clsName) \
00042         mGroupBoxHeader(clsName) \
00043     mButtonNode *pBtnList;
00044
00053 struct _mButtonGroup
00054 {
00055         mButtonGroupHeader(mButtonGroup)
00056 };
00057
00058 #define mButtonGroupClassHeader(clsName, parentClass) \
00059         mGroupBoxClassHeader(clsName, parentClass) \
00060 /*private*/ \
00061     BOOL (*addButton)(clsName *group, mWidget *button); \
00062         BOOL (*checkBtn)(clsName *group, mWidget *btn_to_check);
00063
00082 struct _mButtonGroupClass
00083 {
00084         mButtonGroupClassHeader(mButtonGroup, mGroupBox)
00085 };
00086
00087 #define mButtonGroupRendererHeader(clsName, parentClass) \
00088         mGroupBoxRendererHeader(clsName, parentClass) \
00089     void (*drawButtongroup)(clsName *self, HDC, const RECT*);
00090
00102 /* define the render of image static */
00103 struct _mButtonGroupRenderer {
00104         mButtonGroupRendererHeader(mButtonGroup, mGroupBox)
00105 };
00106
00111 MGNCS_EXPORT extern mButtonGroupClass g_stmButtonGroupCls;
00112
00117 enum mButtonGroupProp {
00125         NCSP_BTNGRP_SELID = NCSP_GRPBOX_MAX + 1,
00134         NCSP_BTNGRP_SELIDX,
00142         NCSP_BTNGRP_SELOBJ,
00143         NCSP_BTNGRP_MAX
00144 };
00145
00146 #define NCSS_BTNGRP_SHIFT NCSS_GRPBOX_SHIFT
00147
00152 enum enumButtonGroupNotify{
00159         NCSN_BTNGRP_SELCHANGED = NCSN_GRPBOX_MAX + 1,
00160         NCSN_BTNGRP_MAX
00161 };
00162
00166 #ifdef __cplusplus
00167 }
00168 #endif  /* __cplusplus */
00169
00170 #endif /* _MGUI_NCSCTRL_BTNGRP_H */
00171
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mcheckboxpiece.h Source File

include » pieces

mcheckboxpiece.h

00001
00002 #ifndef _MGUI_NCSCTRL_CHECKBOXPIECE_H
00003 #define _MGUI_NCSCTRL_CHECKBOXPIECE_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif
00008
00009 typedef struct _mCheckBoxPieceClass mCheckBoxPieceClass;
00010 typedef struct _mCheckBoxPiece mCheckBoxPiece;
00011
00012 #define mCheckBoxPieceClassHeader(clss, superCls) \
00013         mRenderablePieceClassHeader(clss, superCls)
00014
00015 struct _mCheckBoxPieceClass
00016 {
00017         mCheckBoxPieceClassHeader(mCheckBoxPiece, mRenderablePiece)
00018 };
00019
00020 MGNCS_EXPORT extern mCheckBoxPieceClass g_stmCheckBoxPieceCls;
00021
00022 #define mCheckBoxPieceHeader(clss) \
00023         mRenderablePieceHeader(clss)
00024
00025 struct _mCheckBoxPiece
00026 {
00027         mCheckBoxPieceHeader(mCheckBoxPiece)
00028 };
00029
00030 enum mCheckBoxPieceProps{
00031         NCSP_CHECKBUTTONPIECE_CONTENT = CHECKBUTTONPIECE_PROP_BEGIN
00032 };
00033
00034
00035 #ifdef __cplusplus
00036 }
00037 #endif
00038
00039 #endif
00040
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mcheckbutton.h Source File

include

mcheckbutton.h

00001
00002 #ifndef _MGUI_NCSCTRL_CHKBTN_H
00003 #define _MGUI_NCSCTRL_CHKBTN_H
00004
00005
00006 #ifdef __cplusplus
00007 extern "C" {
00008 #endif  /* __cplusplus */
00009
00020 #define NCSCTRL_CHECKBUTTON        NCSCLASSNAME("checkbutton")
00021
00022 typedef struct _mCheckButton mCheckButton;
00023 typedef struct _mCheckButtonClass mCheckButtonClass;
00024 typedef struct _mCheckButtonRenderer mCheckButtonRenderer;
00025
00026 #define mCheckButtonHeader(className) \
00027         mButtonHeader(className)
00028
00034 struct _mCheckButton
00035 {
00036         mCheckButtonHeader(mCheckButton)
00037 };
00038
00039 #define mCheckButtonClassHeader(className, parentClass) \
00040         mButtonClassHeader(className, parentClass)
00041
00047 struct _mCheckButtonClass
00048 {
00049         mCheckButtonClassHeader(mCheckButton, mButton)
00050 };
00051
00052 #define mCheckButtonRendererHeader(clsName, parentClass) \
00053         mButtonRendererHeader(clsName, parentClass) \
00054     void (*drawCheckbutton)(clsName *self, HDC hdc, const RECT* pRect, int status);
00055
00071 /* define the render of image static */
00072 struct _mCheckButtonRenderer {
00073         mCheckButtonRendererHeader(mCheckButton, mButton)
00074 };
00075
00080 MGNCS_EXPORT extern mCheckButtonClass g_stmCheckButtonCls;
00081
00086 enum mCheckButtonProp{
00087         NCSP_CHKBTN_MAX = NCSP_BUTTON_MAX + 1
00088 };
00089
00095 enum mCheckButtonNotify{
00096         NCSN_CHKBTN_MAX = NCSN_BUTTON_MAX + 1
00097 };
00098
00099 #define NCSS_CHKBTN_SHIFT NCSS_BUTTON_SHIFT
00100
00104 #ifdef __cplusplus
00105 }
00106 #endif  /* __cplusplus */
00107
00108 #endif /* _MGUI_NCSCTRL_RECTANGLE_H */
00109
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mcheckbuttonpiece.h Source File

include » pieces

mcheckbuttonpiece.h

00001
00002 #ifndef _MGUI_NCSCTRL_CHECKBUTTONPIECE_H
00003 #define _MGUI_NCSCTRL_CHECKBUTTONPIECE_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif
00008
00009 typedef struct _mCheckButtonPieceClass mCheckButtonPieceClass;
00010 typedef struct _mCheckButtonPiece mCheckButtonPiece;
00011
00012 #define mCheckButtonPieceClassHeader(clss, superCls) \
00013         mAbstractButtonPieceClassHeader(clss, superCls)
00014
00015 struct _mCheckButtonPieceClass
00016 {
00017         mCheckButtonPieceClassHeader(mCheckButtonPiece, mAbstractButtonPiece)
00018 };
00019
00020 MGNCS_EXPORT extern mCheckButtonPieceClass g_stmCheckButtonPieceCls;
00021
00022 #define mCheckButtonPieceHeader(clss) \
00023         mAbstractButtonPieceHeader(clss)
00024
00025 struct _mCheckButtonPiece
00026 {
00027         mCheckButtonPieceHeader(mCheckButtonPiece)
00028 };
00029
00030 #ifdef __cplusplus
00031 }
00032 #endif
00033
00034 #endif
00035
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mchecknode.h Source File

include

mchecknode.h

Go to the documentation of this file.
00001
00026 #ifndef _MGUI_WIDGET_CHECKNODE_H
00027 #define _MGUI_WIDGET_CHECKNODE_H
00028
00029 typedef struct _mCheckNode  mCheckNode;
00030 typedef struct _mCheckNodeClass mCheckNodeClass;
00031
00032 #define mCheckNodeHeader(className)  \
00033     mNodeHeader(className)  \
00034     BOOL isChecked;
00035
00036 struct _mCheckNode
00037 {
00038         mCheckNodeHeader(mCheckNode)
00039 };
00040
00041 #define mCheckNodeClassHeader(clsName, superCls)    \
00042         mNodeClassHeader(clsName, superCls)             \
00043     BOOL (*setCheck)(clsName* , BOOL isCheck);
00044
00045 struct _mCheckNodeClass
00046 {
00047         mCheckNodeClassHeader(mCheckNode, mNode)
00048 };
00049
00050 MGNCS_EXPORT extern mCheckNodeClass g_stmCheckNodeCls;
00051
00052 #ifdef __cplusplus
00053 extern "C" {
00054 #endif  /* __cplusplus */
00055
00056 #ifdef __cplusplus
00057 }
00058 #endif  /* __cplusplus */
00059
00060 #endif /* _MGUI_WIDGET_CHECKNODE_H */
00061
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mcolorbutton.h Source File

include

mcolorbutton.h

00001
00002 #ifndef _MGUI_NCSCTRL_CLRBTN_H
00003 #define _MGUI_NCSCTRL_CLRBTN_H
00004
00005
00006 #ifdef __cplusplus
00007 extern "C" {
00008 #endif  /* __cplusplus */
00009
00019 #define NCSCTRL_COLORBUTTON        NCSCLASSNAME("colorbutton")
00020
00021 typedef struct _mColorButton mColorButton;
00022 typedef struct _mColorButtonClass mColorButtonClass;
00023 typedef struct _mColorButtonRenderer mColorButtonRenderer;
00024
00025 #define mColorButtonHeader(clsName)   \
00026         mWidgetHeader(clsName)
00027
00034 struct _mColorButton
00035 {
00036         mColorButtonHeader(mColorButton)
00037 };
00038
00039 #define mColorButtonClassHeader(clsName, parentClass) \
00040         mWidgetClassHeader(clsName, parentClass)
00041
00049 struct _mColorButtonClass
00050 {
00051         mColorButtonClassHeader(mColorButton, mWidget)
00052 };
00053
00054 #define mColorButtonRendererHeader(clsName, parentClass) \
00055         mWidgetRendererHeader(clsName, parentClass)
00056
00061 /* define the render of colorbutton */
00062 struct _mColorButtonRenderer {
00063         mColorButtonRendererHeader(mColorButton, mWidget)
00064 };
00065
00070 MGNCS_EXPORT extern mColorButtonClass g_stmColorButtonCls;
00071
00076 enum mColorButtonProp {
00083         NCSP_CLRBTN_CURCOLOR = NCSP_WIDGET_MAX + 1,
00084         NCSP_CLRBTN_MAX
00085 };
00086
00087 #define NCSS_CLRBTN_SHIFT NCSS_WIDGET_SHIFT
00088 #define NCSS_CLRBTN_FLAT  (1<<NCSS_WIDGET_SHIFT)
00089
00094 enum enumColorButtonNotify{
00101         NCSN_CLRBTN_COLORCHANGED = NCSN_WIDGET_MAX + 1,
00102         NCSN_CLRBTN_MAX
00103 };
00104
00108 #ifdef __cplusplus
00109 }
00110 #endif  /* __cplusplus */
00111
00112 #endif /* _MGUI_NCSCTRL_CLRBTN_H */
00113
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mcombobox.h Source File

include

mcombobox.h

Go to the documentation of this file.
00001
00020 #ifndef _MGUI_PANEL_COMBOBOX_H
00021 #define _MGUI_PANEL_COMBOBOX_H
00022
00023
00024 #ifdef __cplusplus
00025 extern "C" {
00026 #endif  /* __cplusplus */
00027
00037 #define NCSCTRL_COMBOBOX        NCSCLASSNAME("combobox")
00038
00039 typedef struct _mCombobox           mCombobox;
00040 typedef struct _mComboboxClass      mComboboxClass;
00041 typedef struct _mComboboxRenderer   mComboboxRenderer;
00042
00043 #define mComboboxHeader(clsName) \
00044         mPanelHeader(clsName) \
00045     mListBox *listbox; \
00046     mSlEdit *edit; \
00047     RECT rcList; \
00048     RECT rcEdit; \
00049     RECT rcBtn; \
00050     unsigned int flag; \
00051     int dropWidth;
00052
00074 struct _mCombobox
00075 {
00076         mComboboxHeader(mCombobox)
00077 };
00078
00079 #define mComboboxClassHeader(clsName, parentClass) \
00080         mPanelClassHeader(clsName, parentClass) \
00081     BOOL (*addItem)(clsName *self, const char *item, DWORD addData); \
00082     BOOL (*removeItem)(clsName *self, int index); \
00083     BOOL (*setItem)(clsName *self, int index, const char *item); \
00084     const char* (*getItem)(clsName *self, int index); \
00085     void (*setAddData)(clsName *self, int index, DWORD addData); \
00086     DWORD (*getAddData)(clsName *self, int index);
00087
00113 struct _mComboboxClass
00114 {
00115         mComboboxClassHeader(mCombobox, mPanel)
00116 };
00117
00118 MGNCS_EXPORT extern mComboboxClass g_stmComboboxCls;
00119
00120 #define mComboboxRendererHeader(clsName, parentClass) \
00121         mPanelRendererHeader(clsName, parentClass) \
00122         void (*drawDropDownBtn)(clsName* self, HDC, const RECT*);
00123
00136 struct  _mComboboxRenderer {
00137         mComboboxRendererHeader(mCombobox, mPanel)
00138 };
00139
00144 enum mComboboxProp {
00150     NCSP_COMB_ITEMHEIGHT = NCSP_LSTBOX_ITEMHEIGHT,
00156     NCSP_COMB_ITEMCOUNT = NCSP_LSTBOX_ITEMCOUNT,
00163         NCSP_COMB_DROPDOWNHEIGHT = NCSP_PANEL_MAX + 1,
00170         NCSP_COMB_TEXTLIMIT,
00177     NCSP_COMB_SELECT,
00178     NCSP_COMB_MAX
00179 };
00180
00181
00186 #define NCSS_CMBOX_SIMPLE          0x0000L
00187
00192 #define NCSS_CMBOX_DROPDOWNLIST    (0x0001L<<NCSS_PANEL_SHIFT)
00193
00198 #define NCSS_CMBOX_SORT            (0x0002L<<NCSS_PANEL_SHIFT)
00199
00204 #define NCSS_CMBOX_EDITNOBORDER    (0x0004L<<NCSS_PANEL_SHIFT)
00205
00210 #define NCSS_CMBOX_EDITBASELINE    (0x0008L<<NCSS_PANEL_SHIFT)
00211
00216 #define NCSS_CMBOX_READONLY        (0x0010L<<NCSS_PANEL_SHIFT)
00217
00222 #define NCSS_CMBOX_UPPERCASE       (0x0020L<<NCSS_PANEL_SHIFT)
00223
00228 #define NCSS_CMBOX_LOWERCASE       (0x0040L<<NCSS_PANEL_SHIFT)
00229
00234 #define NCSS_CMBOX_AUTOFOCUS       (0x0080L<<NCSS_PANEL_SHIFT)
00235
00236 #define NCSS_CMBOX_SHIFT (NCSS_PANEL_SHIFT + 9)
00237
00238
00240 enum enumComboboxNotify {
00241         NCSN_CMBOX_SELCHANGE = NCSN_PANEL_MAX + 1,
00242         NCSN_CMBOX_SETFOCUS,
00243         NCSN_CMBOX_KILLFOCUS,
00244         NCSN_CMBOX_EDITCHANGE,
00245         NCSN_CMBOX_DROPDOWN,
00246         NCSN_CMBOX_CLOSEUP,
00247         NCSN_CMBOX_SELECTOK,
00248         NCSN_CMBOX_SELECTCANCEL,
00249         NCSN_CMBOX_MAX
00250 };
00251
00252
00256
00257 #define NCSF_CMBOX_BUTTONDOWN         0x0001
00258 #define NCSF_CMBOX_BUTTONUP           0x0002
00259 #define NCSF_CMBOX_DROPPED            0x0004
00260 #define NCSF_CMBOX_HILIGHT            0x0008
00261
00262 #define SET_STATE(lp, mask)   (lp->flag |= (mask))
00263 #define CLEAR_STATE(lp, mask) (lp->flag &= ~(mask))
00264 #define IS_SET(lp, mask)      (lp->flag & (mask))
00265
00268 #ifdef __cplusplus
00269 }
00270 #endif  /* __cplusplus */
00271
00272 #endif /* _MGUI_PANEL_COMBOBOX_H */
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mcommon.h Source File

include

mcommon.h

00001
00002 #ifndef MINICOMMON_H
00003 #define MINICOMMON_H
00004
00005 #if defined (WIN32)
00006
00007 #ifdef __MGNCS_LIB__
00008         #define MGNCS_EXPORT       __declspec(dllexport)
00009 #else
00010         #define MGNCS_EXPORT       __declspec(dllimport)
00011 #endif
00012 #else
00013         #define MGNCS_EXPORT
00014 #endif
00015
00016 typedef struct Allocator{
00017         void *(*alloc)(void* pold, size_t new_size);
00018         size_t (*getsize)(void* p);
00019         void (*free)(void* p);
00020 }Allocator;
00021
00022 Allocator * ncsGetDefaultAllocator(void);
00023
00024
00028 enum enumNCSAlign{
00029         NCS_ALIGN_LEFT = 0,
00030         NCS_ALIGN_RIGHT,
00031         NCS_ALIGN_CENTER
00032 };
00033
00037 enum enumNCSVAlign{
00038         NCS_VALIGN_TOP = 0,
00039         NCS_VALIGN_BOTTOM,
00040         NCS_VALIGN_CENTER
00041 };
00042
00046 enum enumNCSImageDrawMode{
00047         NCS_DM_NORMAL = 0,
00048         NCS_DM_SCALED,
00049         NCS_DM_TILED
00050 };
00051
00052 //support alloca
00053 #ifdef HAVE_ALLOCA
00054 #define ALLOCA(size)  alloca(size)
00055 #define FREEA(p)
00056 #else
00057 #define ALLOCA(size) malloc(size)
00058 #define FREEA(p) free(p)
00059 #endif
00060
00061 MGNCS_EXPORT void ncsDrawImage(HDC hdc, PBITMAP pbmp, const RECT * rc, int mode, int align, int valign);
00062
00063 #define IMG_TYPE_UNKNOWN  0
00064 #define IMG_TYPE_BITMAP   1
00065 #define IMG_TYPE_ICON     2
00066 #define IMG_TYPE_MYBITMAP 4
00067
00068 #define IMG_FLAG_IGNORE   0
00069 #define IMG_FLAG_UNLOAD   1
00070 #define IMG_FLAG_RELEASE_RES  2
00071 typedef struct _ImageDrawInfo{
00072         unsigned char img_type;
00073         unsigned char flag;
00074         unsigned char drawMode;
00075         unsigned char revert;
00076         union{
00077                 PBITMAP pbmp;
00078                 HICON hIcon;
00079                 PMYBITMAP pmybmp;
00080                 RES_KEY key;
00081         }img;
00082 }ImageDrawInfo;
00083
00084 MGNCS_EXPORT void ncsInitDrawInfo(ImageDrawInfo *idi);
00085
00086 MGNCS_EXPORT void ncsCleanImageDrawInfo(ImageDrawInfo * idi);
00087
00088 MGNCS_EXPORT BOOL ncsSetImageDrawInfoByFile(ImageDrawInfo *idi, const char* image_file, int drawMode, BOOL bas_mybitmp);
00089
00090 MGNCS_EXPORT BOOL ncsSetImageDrawInfoByRes(ImageDrawInfo *idi, RES_KEY key, int drawMode, int res_type);
00091
00092 MGNCS_EXPORT BOOL ncsSetImageDrawInfo(ImageDrawInfo *idi, void* pimg, int drawMode, int img_type);
00093
00094
00095 MGNCS_EXPORT void ncsImageDrawInfoDraw(ImageDrawInfo *idi, HDC hdc, const RECT* prc, int align, int valign);
00096
00097 MGNCS_EXPORT BOOL ncsImageDrawInfoGetImageSize(ImageDrawInfo *idi, int *px, int *py);
00098
00099 #endif
00100
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mcomponent.h Source File

include

mcomponent.h

Go to the documentation of this file.
00001
00016 #ifndef _MGUI_NCSCTRL_CMPT_H
00017 #define _MGUI_NCSCTRL_CMPT_H
00018
00019 #ifdef __cplusplus
00020 extern "C"{
00021 #endif
00022
00023 #include <stdarg.h>
00024
00034 #define MAXLEN_CLASSNAME    15
00035
00039 #define NCSCLASSNAME(name)     name _MGNCS_CLASS_SUFFIX
00040
00041 #define BEGIN_CMPT_CLASS(clss, superCls) \
00042         static const char comp_##clss##_class_name[] = (#clss _MGNCS_CLASS_SUFFIX) ; \
00043         BEGIN_MINI_CLASS(clss, superCls) \
00044         _class->className = comp_##clss##_class_name + 1;
00045
00046 #define END_CMPT_CLASS END_MINI_CLASS
00047
00048 #ifndef BIND_PROP
00049 #define BIND_PROP
00050 typedef struct _mBindProp mBindProp;
00051 #endif
00052
00053 typedef void (*PFreeSpecificData)(DWORD key, DWORD value);
00054
00055 #define MAX_USER_SPECIAL_KEY   0x80000000L
00056
00057 typedef struct _mComponentClass mComponentClass;
00058 typedef struct _mComponent mComponent;
00059
00060 #define mComponentClassHeader(clss, superCls) \
00061         mObjectClassHeader(clss, superCls) \
00062         const char* className; \
00063         clss * (*createComponent)(mComponent* parent, ClassType(clss)*, DWORD addValue); \
00064         WNDPROC _window_proc ; \
00065         BOOL (*setProperty)(clss *self, int id, DWORD value); \
00066         DWORD (*getProperty)(clss *self, int id); \
00067         int (*setId)(clss *self, int id); \
00068         int (*getId)(clss *self); \
00069         mComponent* (*getReleated)(clss*self, int releated); \
00070         mComponent* (*setReleated)(clss *self, mComponent* comp,  int releated); \
00071         mComponent* (*getChild)(clss* self, int id);  \
00072         void        (*removeChild)(clss* self, mComponent* child);  \
00073         PUBLIC DWORD (*getPropertyByPath)(clss* self, int *id_path); \
00074         PUBLIC BOOL  (*setPropertyByPath)(clss* self, int *id_path, DWORD value); \
00075         PUBLIC BOOL  (*addEventListenerByPath)(clss* self, int *id_path, mObject* listener, NCS_CB_ONOBJEVENT on_event); \
00076         PUBLIC BOOL  (*addBindPropByPath)(clss* self, int *id_path, int event_id, int prop_type, int flags, mBindProp *prop, int bind_type); \
00077         PUBLIC BOOL  (*queryByPath)(clss* self, int *id_path, DWORD *pret, ...); \
00078         PUBLIC BOOL  (*vqueryByPath)(clss* self, int *id_path, DWORD* pret, va_list va); \
00079         PUBLIC BOOL  (*isMainObj)(clss* self);  \
00080         BOOL  (*setSpecificData)(clss* self, DWORD key, DWORD value, PFreeSpecificData freeSpecific); \
00081         DWORD (*getSpecificData)(clss* self, DWORD key, BOOL *pOk);
00082
00162 enum ncsComponentReleated{
00163         NCS_CMPT_NEXT = 0,
00164         NCS_CMPT_PREV,
00165         NCS_CMPT_PARENT,
00166         NCS_CMPT_CHILDREN
00167 };
00190 enum mComponentQueryCmd{
00194         QPC_SET_PROP = 0,
00198         QPC_GET_PROP,
00202         QPC_ADD_EVENT,
00206         QPC_ADD_BIND,
00210         QPC_USER
00211 };
00212
00213 struct _mComponentClass {
00214         mComponentClassHeader(mComponent, mObject)
00215 };
00216
00217 MGNCS_EXPORT mComponent *ncsCompGetMainParent(mComponent*self);
00218
00219 MGNCS_EXPORT mComponent *ncsCompGetRoot(mComponent* self);
00220
00221 #define IDPATH_END -1
00222
00223 #define IDPATH_ME     -2
00224 #define IDPATH_PARENT -3
00225 #define IDPATH_MAINPARENT -4
00226 #define IDPATH_ROOT -5
00227
00228 #define ISVALID_IDPATH(id_path) \
00229         ((id_path) && (id_path)[0] != IDPATH_END)
00230
00231 #define IDPATH_ISOBJ(id_path) \
00232         ((id_path)[1] != IDPATH_END)
00233
00234 #define BYPATHFUNCEX(baseclass, base_check, err_ret, func, finaly_func_ex, ...) do{ \
00235         mComponent* cmp; \
00236         if(!ISVALID_IDPATH(id_path)) \
00237                 return 0;  \
00238         while(IDPATH_ISOBJ(id_path)) { \
00239                 if(id_path[0] == IDPATH_ME){ \
00240                         id_path ++; \
00241                         continue; \
00242                 } else if(id_path[0] == IDPATH_PARENT) \
00243                         cmp = _c(self)->getReleated(self, NCS_CMPT_PARENT); \
00244                 else if(id_path[0] == IDPATH_MAINPARENT) \
00245                         cmp = ncsCompGetMainParent((mComponent*)self); \
00246                 else if(id_path[0] == IDPATH_ROOT) \
00247                         cmp = ncsCompGetRoot((mComponent*)self); \
00248                 else  \
00249                         cmp = _c(self)->getChild(self, id_path[0]); \
00250                 if(!cmp && base_check(cmp,baseclass)) return err_ret; \
00251                 return _c(baseclass*)->cmp(baseclass*, func, ++id_path, ##__VA_ARGS__); \
00252         } \
00253         finaly_func_ex(self, id_path[0], ##__VA_ARGS__); \
00254 }while(0)
00255
00256 #define BYPATHFUNC(baseclass, base_check,err_ret, func, final_func, ...) \
00257         BYPATHFUNCEX(baseclass, base_check,err_ret, func, return (_c(self)->final_func), ##__VA_ARGS__)
00258
00259 #define IDPATH_NOBASECHECK(cmp, baseclass)   1
00260
00265 MGNCS_EXPORT extern mComponentClass g_stmComponentCls; //Class(mComponent);
00266
00273 typedef struct _NCS_EVENT_HANDLER_NODE {
00277         int message;
00285         void *handler;
00289         struct _NCS_EVENT_HANDLER_NODE *next;
00290 }NCS_EVENT_HANDLER_NODE;
00291
00292 typedef struct _mSpecificDataNode {
00293         DWORD key;
00294         DWORD value;
00295         PFreeSpecificData freeSpecific;
00296         struct _mSpecificDataNode* next;
00297 }mSpecificDataNode;
00298
00299 #define mComponentHeader(clss) \
00300         mObjectHeader(clss) \
00301         NCS_EVENT_HANDLER_NODE * event_handlers; \
00302         mSpecificDataNode* specificHead;
00303
00314 struct _mComponent {
00315         mComponentHeader(mComponent)
00316 };
00317
00330
00331
00338 typedef struct _NCS_EVENT_HANDLER {
00342         int message;
00346         void *handler;
00347 }NCS_EVENT_HANDLER;
00348
00361 MGNCS_EXPORT void * ncsSetComponentHandler(mComponent* comp, int message, void *handler);
00362
00376 MGNCS_EXPORT void ncsSetComponentHandlers(mComponent* comp, NCS_EVENT_HANDLER* handlers, int count);
00377
00387 MGNCS_EXPORT void* ncsGetComponentHandler(mComponent* comp, int message);
00388
00395 typedef struct _NCS_EVENT_CONNECT_INFO {
00399         int id_sender;
00403         int id_listener;
00407         int event_id;
00411         NCS_CB_ONOBJEVENT event;
00412 }NCS_EVENT_CONNECT_INFO;
00413
00424 MGNCS_EXPORT BOOL ncsComponentConnectEvents(mComponent* comps, NCS_EVENT_CONNECT_INFO *connects, int counts/*=-1*/);
00425
00435 MGNCS_EXPORT BOOL ncsIsClass(const char* className, mComponentClass* clss);
00436
00443 #define ISCLASS(class_name, clssName) ncsIsClass((const char*)(class_name), (mComponentClass*)(&Class(clssName)))
00444
00454 MGNCS_EXPORT BOOL ncsIsChildClass(const char* childClassName, const char* parentClassName);
00455
00470 MGNCS_EXPORT BOOL ncsRegisterComponent(mComponentClass *compCls, DWORD dwStyle, DWORD dwExStyle, int idCursor, int idBkColor);
00471
00483 MGNCS_EXPORT mComponentClass * ncsGetComponentClass(const char* className, BOOL check);
00484
00485 MGNCS_EXPORT mComponentClass * ncsClassFromMagicNum(DWORD magic_num, BOOL check, const char* class_name);
00486
00489 #define MGNCS_REGISTER_COMPONENT_EX(className, dwStyle, dwExStyle, idCursor, idBkColor) \
00490         do {if(!ncsRegisterComponent((mComponentClass*)MGNCS_INIT_CLASS(className), \
00491                 dwStyle, dwExStyle, idCursor, idBkColor)) \
00492                 return FALSE;}while(0)
00493
00494 #define MGNCS_REGISTER_COMPONENT(className) \
00495         MGNCS_REGISTER_COMPONENT_EX(className, \
00496                 WS_NONE, WS_EX_NONE, IDC_ARROW, WE_MAINC_THREED_BODY)
00497
00498 #define MGNCS_UNREG_COMPONENT(clssName) \
00499         UnregisterWindowClass(Class(clssName).className)
00500
00501 #define NCS_SET_PROP(self, id, value) \
00502         _c(self)->setProperty(self, (id), (value))
00503 #define NCS_GET_PROP(self, id)        \
00504         _c(self)->getProperty(self, (id))
00505
00508 #ifdef __cplusplus
00509 }
00510 #endif
00511
00512 #endif
00513
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mcontainer.h Source File

include

mcontainer.h

Go to the documentation of this file.
00001
00028 #ifndef _MGUI_WIDGET_CTNR_H
00029 #define _MGUI_WIDGET_CTNR_H
00030
00031
00032 #ifdef __cplusplus
00033 extern "C" {
00034 #endif  /* __cplusplus */
00035
00045 #define NCSCTRL_CONTAINER        NCSCLASSNAME("container")
00046
00047 typedef struct _mContainer mContainer;
00048 typedef struct _mContainerClass mContainerClass;
00049 typedef struct _mContainerRenderer mContainerRenderer;
00050
00051 #define mContainerHeader(className) \
00052         mScrollWidgetHeader(className) \
00053     HWND hPanel;
00054
00065 struct _mContainer
00066 {
00067         mContainerHeader(mContainer)
00068 };
00069
00070 #define mContainerClassHeader(clsName, parentClass)                   \
00071         mScrollWidgetClassHeader(clsName, parentClass)                    \
00072     BOOL (*addIntrinsicControls)(clsName* self, const PCTRLDATA pCtrl, int nCount); \
00073     HWND (*setFocus)(clsName* self, int id); \
00074     HWND (*getFocus)(clsName* self); \
00075         HWND (*getPanel)(clsName* self); \
00076         void (*adjustContent)(clsName *self);
00077
00105 struct _mContainerClass
00106 {
00107         mContainerClassHeader(mContainer, mScrollWidget)
00108 };
00109
00110 #define mContainerRendererHeader(clsName, parentClass) \
00111         mScrollWidgetRendererHeader(clsName, parentClass)
00112
00118 struct  _mContainerRenderer {
00119         mContainerRendererHeader(mContainer, mScrollWidget)
00120 };
00121
00122
00129 MGNCS_EXPORT extern mContainerClass g_stmContainerCls;
00130
00135 #define NCSS_CTNR_SHIFT NCSS_SWGT_SHIFT
00136
00141 enum mContainerNotify {
00145         NCSN_CTNR_MAX = NCSN_SWGT_MAX + 1
00146 };
00147
00149 #ifdef __cplusplus
00150 }
00151 #endif  /* __cplusplus */
00152
00153 #endif /* _MGUI_WIDGET_CTNR_H */
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mcontainerpiece.h Source File

include » pieces

mcontainerpiece.h

00001
00002 #ifndef _MGUI_NCSCTRL_PANELPIECE_H
00003 #define _MGUI_NCSCTRL_PANELPIECE_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif
00008
00009 typedef struct _mContainerPieceClass mContainerPieceClass;
00010 typedef struct _mContainerPiece mContainerPiece;
00011
00012 #define mContainerPieceClassHeader(clss, superCls) \
00013         mHotPieceClassHeader(clss, superCls) \
00014         void (*raiseEvent)(clss *, int event, DWORD param);
00015
00016 struct _mContainerPieceClass
00017 {
00018         mContainerPieceClassHeader(mContainerPiece, mHotPiece)
00019 };
00020
00021 MGNCS_EXPORT extern mContainerPieceClass g_stmContainerPieceCls;
00022
00023 #define mContainerPieceHeader(clss) \
00024         mHotPieceHeader(clss)  \
00025         mHotPiece * body;
00026
00027 struct _mContainerPiece
00028 {
00029         mContainerPieceHeader(mContainerPiece)
00030 };
00031
00032 #define RAISE_EVENT(obj,id, param)  _c(obj)->raiseEvent(obj, id, param)
00033
00034 #ifdef __cplusplus
00035 }
00036 #endif
00037
00038 #endif
00039
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mdatabinding.h Source File

include

mdatabinding.h

00001
00002 #ifndef MINICTRL_DATA_BINDING_H
00003 #define MINICTRL_DATA_BINDING_H
00004
00005 #ifdef __cplusplus
00006 extern "C"{
00007 #endif
00008
00009 typedef struct _mBindPropClass mBindPropClass;
00010 #ifndef BIND_PROP
00011 #define BIND_PROP
00012 typedef struct _mBindProp mBindProp;
00013 #endif
00014
00015 #define mBindPropClassHeader(clss, superCls) \
00016         mObjectClassHeader(clss, superCls) \
00017         DWORD (* get)(clss *); \
00018         BOOL (* set)(clss *, DWORD newdata);
00019
00020 struct _mBindPropClass{
00021         mBindPropClassHeader(mBindProp, mObject)
00022 };
00023
00024 MGNCS_EXPORT extern mBindPropClass g_stmBindPropCls;
00025
00026 typedef struct _mBindPropListNode{
00027         mBindProp * p;
00028         struct _mBindPropListNode * next;
00029 }mBindPropListNode;
00030
00031 #define NCS_PROP_FLAG_READ  0x01
00032 #define NCS_PROP_FLAG_WRITE 0x02
00033 #define mBindPropHeader(clss) \
00034         mObjectHeader(clss) \
00035         int read:1; \
00036         int write:1; \
00037         int vtype:14; \
00038         int ref:16; \
00039         mBindPropListNode * listens; \
00040         mBindProp * next;
00041
00042 #define MAKE_BINDPROP_INFO(br, bw, type) \
00043         (((br)?NCS_PROP_FLAG_READ:0)|((bw)?NCS_PROP_FLAG_WRITE:0)|((type)<<16))
00044
00045 struct _mBindProp{
00046         mBindPropHeader(mBindProp)
00047 };
00049 MGNCS_EXPORT void ncsBindPropRasieChanged(mBindProp *bprop);
00050
00051 MGNCS_EXPORT int  ncsBindPropAddRef(mBindProp *bprop);
00052 MGNCS_EXPORT int  ncsBindPropRelease(mBindProp *bprop);
00053 MGNCS_EXPORT void ncsBindPropAutoRelfect(mBindProp *bprop);
00054
00055 MGNCS_EXPORT BOOL ncsConnectBindProps(mBindProp * psource, mBindProp* plistener, int type);
00056
00057 enum ncsBindPropType{
00058         NCS_BPT_SINGLE = 0,
00059         NCS_BPT_DBL
00060 };
00061
00063 MGNCS_EXPORT BOOL ncsAutoReflectObjectBindProps(mObject * obj);
00064 MGNCS_EXPORT BOOL ncsRemoveObjectBindProps(mObject *obj);
00065
00066 MGNCS_EXPORT BOOL ncsAddObjectBindProps(mObject *obj, mBindProp *bprop);
00067
00068 typedef BOOL (*NCS_TEST_BINDPROP)(mBindProp*, void *param);
00069 typedef mBindProp* (*NCS_NEW_BINDPROP)(void* param);
00070
00071 MGNCS_EXPORT mBindProp* ncsRegisterBindProp(mObject* obj,
00072                 NCS_TEST_BINDPROP test_exist,
00073                 NCS_NEW_BINDPROP  new_prop,
00074                 void *param);
00075
00076 typedef BOOL (*NCS_RAISE_TEST)(mBindProp* prop, DWORD param);
00077 MGNCS_EXPORT void ncsRaiseObjectBindProps(mObject *obj, NCS_RAISE_TEST  raise_test, DWORD param);
00078
00080 MGNCS_EXPORT void *ncsNewBindPropsObjGroup(void);
00081 MGNCS_EXPORT void ncsDeleteBindPropsGroup(void*);
00082 MGNCS_EXPORT void ncsAutoReflexBindPropsGroup(void* group);
00083 MGNCS_EXPORT void ncsAddBindPropsObj(void *group, mObject *obj);
00084
00086 // component
00087
00088 typedef struct _mCompBindPropClass mCompBindPropClass;
00089 typedef struct _mCompBindProp mCompBindProp;
00090
00091 #define mCompBindPropClassHeader(clss, superCls) \
00092         mBindPropClassHeader(clss, superCls)
00093
00094 struct _mCompBindPropClass{
00095         mCompBindPropClassHeader(mCompBindProp, mBindProp)
00096 };
00097
00098 MGNCS_EXPORT extern mCompBindPropClass g_stmCompBindPropCls;
00099
00100 #define mCompBindPropHeader(clss) \
00101         mBindPropHeader(clss) \
00102         mComponent * host; \
00103         int  prop_id; \
00104         int  event_id;
00105
00106 struct _mCompBindProp{
00107         mCompBindPropHeader(mCompBindProp)
00108 };
00109
00110
00111 MGNCS_EXPORT void ncsRaiseComponentBindProps(mComponent *comp, int event_id);
00112
00113 MGNCS_EXPORT mBindProp * ncsRegisterComponentBindProp(mComponent* comp, int event_id, int prop_id, int data_type, DWORD flags);
00114 #define NCS_CMPT_PROP(comp, event_id, prop_id, data_type, flags) \
00115         ncsRegisterComponentBindProp((mComponent*)(comp), (event_id), (prop_id), (data_type), flags)
00116
00117
00119 // simple value data
00120
00121 typedef struct _mVariableBindPropClass mVariableBindPropClass;
00122 typedef struct _mVariableBindProp mVariableBindProp;
00123
00124 #define mVariableBindPropClassHeader(clss, super) \
00125         mBindPropClassHeader(clss, super)
00126
00127 struct _mVariableBindPropClass{
00128         mVariableBindPropClassHeader(mVariableBindProp, mBindProp)
00129 };
00130
00131 MGNCS_EXPORT extern mVariableBindPropClass g_stmVariableBindPropCls;
00132
00133 #define mVariableBindPropHeader(clss) \
00134         mBindPropHeader(clss) \
00135         void *p;
00136
00137 struct _mVariableBindProp{
00138         mVariableBindPropHeader(mVariableBindProp)
00139 };
00140
00141 #define _SET_VAR(type, left, right) \
00142         *((type*)(left)) = ((type)(right))
00143
00144
00145 MGNCS_EXPORT mBindProp * ncsRegisterVariableBindProp(void *pvalue, int data_type, DWORD flags);
00146 #define VAR_PROP(value, data_type, flags) \
00147         ncsRegisterVariableBindProp((void*)(&(value)), (data_type), (flags))
00148
00149 #define INT_PROP(value, flags)  VAR_PROP(value, NCS_BT_INT, flags)
00150 #define STRPTR_PROP(value, flags) VAR_PROP(value, NCS_BT_STR_PTR, flags)
00151
00152 #define ncsRaiseVariableBindProp(pvalue) \
00153         ncsRaiseObjectBindProps((mObject*)(pvalue),NULL, 0)
00154
00155
00156 MGNCS_EXPORT BOOL ncsInitDataBinding(void);
00157
00158 #ifdef __cplusplus
00159 }
00160 #endif
00161
00162 #endif
00163
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mdatasource.h Source File

include

mdatasource.h

00001 #ifndef _MGNCS_DATA_SOURCE_H
00002 #define _MGNCS_DATA_SOURCE_H
00003
00004 #ifdef __cplusplus
00005 extern "C"{
00006 #endif
00007
00008 typedef struct _mRecordSetClass mRecordSetClass;
00009 typedef struct _mRecordSet mRecordSet;
00010
00011 typedef struct _mDataSourceClass mDataSourceClass;
00012 typedef struct _mDataSource mDataSource;
00013
00014 #define NCS_DS_SELECT_READ  0x01
00015 #define NCS_DS_SELECT_WRITE 0x02
00016
00017 #define MSQLITE_READONLY                0x00000001
00018 #define MSQLITE_READWRITE               0x00000002
00019 #define MSQLITE_CREATE                  0x00000004
00020
00021 #define mDataSourceClassHeader(clss, superCls) \
00022         mObjectClassHeader(clss, superCls) \
00023         mRecordSet * (*selectRecordSet)(clss *, const char* select, int select_type);  \
00024         DWORD (*getValue)(clss*, const char* mql,BOOL *bok); \
00025         BOOL  (*setValue)(clss*, const char* mql, DWORD value); \
00026         mBindProp * (*getBindProp)(clss*, const char* mql, int bp_type); \
00027         BOOL  (*createValue)(clss*, const char* ql, DWORD init_value); \
00028         BOOL  (*removeValue)(clss*, const char* ql);                   \
00029         BOOL  (*execute)(clss*, const char* mql); /*execute the query language*/
00030
00031 struct _mDataSourceClass {
00032         mDataSourceClassHeader(mDataSource, mObject)
00033 };
00034
00035 #define mDataSourceHeader(clss) \
00036         mObjectHeader(clss)
00037
00038 struct _mDataSource {
00039         mDataSourceHeader(mDataSource)
00040 };
00041
00042 MGNCS_EXPORT extern mDataSourceClass g_stmDataSourceCls;
00043
00045 #define NCS_RS_CURSOR_BEGIN 0
00046 #define NCS_RS_CURSOR_CUR   1
00047 #define NCS_RS_CURSOR_END   2
00048
00049 #define NCS_RS_INSERT_AFTER  0
00050 #define NCS_RS_INSERT_APPEND 1
00051 #define NCS_RS_INSERT_BEFORE 2
00052
00053 #define NCS_RSE_CURSOR_UPDATE 0x01
00054 #define NCS_RSE_VALUE_UPATED  0x02
00055 #define NCS_RSE_VALUE_CREATE  0x04
00056 #define NCS_RSE_VALUE_REMOVED 0x08
00057
00058 #define mRecordSetClassHeader(clss, superCls) \
00059         mObjectClassHeader(clss, superCls) \
00060         int (*getFieldCount)(clss*); \
00061         int (*getRecordCount)(clss*); \
00062         int (*getFieldType)(clss*, int filed_idx); \
00063         DWORD (*getCursor)(clss *); \
00064         BOOL  (*setCursor)(clss *, DWORD cursor); \
00065         DWORD (*seekCursor)(clss *, int seek, int offset); \
00066         DWORD (*getField)(clss *, int idx); \
00067         BOOL  (*setField)(clss *, int idx, DWORD value); \
00068         BOOL  (*newRecord)(clss *, int insert_type);  \
00069         BOOL  (*deleteRecord)(clss *); \
00070         BOOL  (*update)(clss *); \
00071         BOOL  (*cancel)(clss *); \
00072         BOOL  (*isEnd)(clss *); \
00073         mBindProp * (*getFieldBind)(clss *, int field_idx, int event_filter, int bp_type); \
00074         mBindProp * (*getCursorBind)(clss *, int bp_type);
00075
00076 struct _mRecordSetClass{
00077         mRecordSetClassHeader(mRecordSet, mObject)
00078 };
00079
00080 #define mRecordSetHeader(clss) \
00081         mObjectHeader(clss)
00082
00083 struct _mRecordSet{
00084         mRecordSetHeader(mRecordSet)
00085 };
00086
00087 MGNCS_EXPORT extern mRecordSetClass g_stmRecordSetCls;
00088
00090 // Bind Prop
00091
00092 typedef struct _mDataBindPropClass mDataBindPropClass;
00093 typedef struct _mDataBindProp mDataBindProp;
00094
00095 #define mDataBindPropClassHeader(clss, supper) \
00096         mBindPropClassHeader(clss,  supper) \
00097
00098 struct _mDataBindPropClass{
00099         mDataBindPropClassHeader(mDataBindProp, mBindProp)
00100 };
00101
00102 MGNCS_EXPORT extern mDataBindPropClass g_stmDataBindPropCls;
00103
00104 #define mDataBindPropHeader(clss) \
00105         mBindPropHeader(clss) \
00106         unsigned int event_filter:16; \
00107         unsigned int revert:16;
00108
00109 struct _mDataBindProp {
00110         mDataBindPropHeader(mDataBindProp)
00111 };
00112
00113 typedef struct _mDataValueBindPropClass mDataValueBindPropClass;
00114 typedef struct _mDataValueBindProp mDataValueBindProp;
00115
00116 #define mDataValueBindPropClassHeader(clss, super) \
00117         mDataBindPropClassHeader(clss, super)
00118
00119 struct _mDataValueBindPropClass{
00120         mDataValueBindPropClassHeader(mDataValueBindProp, mDataBindProp)
00121 };
00122
00123 #define mDataValueBindPropHeader(clss) \
00124         mDataBindPropHeader(clss) \
00125         DWORD *pvalue;
00126
00127 struct _mDataValueBindProp{
00128         mDataValueBindPropHeader(mDataValueBindProp)
00129 };
00130
00131
00132 typedef struct _mDataFieldBindPropClass mDataFieldBindPropClass;
00133 typedef struct _mDataFieldBindProp mDataFieldBindProp;
00134
00135 #define mDataFieldBindPropClassHeader(clss, super) \
00136         mDataBindPropClassHeader(clss, super)
00137
00138 struct _mDataFieldBindPropClass {
00139         mDataFieldBindPropClassHeader(mDataFieldBindProp, mDataBindProp)
00140 };
00141
00142 #define mDataFieldBindPropHeader(clss) \
00143         mDataBindPropHeader(clss) \
00144         mRecordSet * recordSet;
00145
00146 //user mDataBindProp::revert as field_idx
00147
00148 struct _mDataFieldBindProp {
00149         mDataFieldBindPropHeader(mDataFieldBindProp)
00150 };
00151
00152
00153 MGNCS_EXPORT void ncsRaiseDataSourceBindProps(mObject *obj, int event_filter);
00154
00155 MGNCS_EXPORT mBindProp * ncsRegisterDataValueBindProp(mDataSource *obj, DWORD *pvalue, int type, int flags, int event_filter);
00156
00157 MGNCS_EXPORT mBindProp * ncsRegisterDataFieldBindProp(mRecordSet *rs, int field_idx, int flags, int event_filter);
00158
00159 #define DATA_VAR_PROP(owner, pvalue ,data_type, flags, event_filter) \
00160         ncsRegisterDataValueBindProp((mDataSource*)(owner), (DWORD*)(pvalue), (int)(data_type), (int)(flags), (int)(event_filter));
00161
00162 #define DATA_FIELD_PROP(rs, field, flags, event_filer) \
00163         ncsRegisterDataFieldBindProp((mRecordSet*)(rs), (int)(field), (int)(flags), (int)(event_filter))
00164
00165
00167 // Default DataSource
00168
00169 BOOL ncsInitDefaultDataSource(void);
00170 //mStaticDataSource
00171 MGNCS_EXPORT extern mDataSource* g_pStaticDS;
00172
00173 MGNCS_EXPORT BOOL ncsRegisterStaticData(const char* pvalue_path, void ** array, int array_count, int field_count, int filed_width, const unsigned char* field_types);
00174
00175 MGNCS_EXPORT BOOL ncsRegisterStaticValue(const char* pvalue_path, DWORD value, int type);
00176 #define ncsRegisterStaticString(pvalue_path, str) do{ \
00177         static char _str[] = str; \
00178         ncsRegisterStaticValue(pvalue_path, _str, NCS_BT_STR; \
00179 }while(0)
00180
00181
00182 //mTextDataSource
00183 MGNCS_EXPORT mDataSource* ncsCreateTextDataSource(const char* source_file, int spliter, int mode);
00184
00185 //mEtcDataSource
00186 MGNCS_EXPORT mDataSource* ncsCreateEtcDataSource(const char* etc_file, int mode);
00187
00188 MGNCS_EXPORT mDataSource* ncsCreateEtcDataSourceByHandle(GHANDLE hEtc, int mode);
00189
00190 //mSQLiteDataSource
00191 #ifdef _MGNCS_SQLITE
00192 MGNCS_EXPORT mDataSource* ncsCreateSQLiteDataSource(const char* sqlite_file, int mode);
00193 #endif
00194
00196
00197
00198 #ifdef __cplusplus
00199 }
00200 #endif
00201
00202 #endif
00203
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mdaygridpiece.h Source File

include » pieces

mdaygridpiece.h

00001
00002 #ifndef _MGUI_NCSCTRL_DAYGRIDPIECE_H
00003 #define _MGUI_NCSCTRL_DAYGRIDPIECE_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif
00008
00009 typedef struct _mDayGridPieceClass mDayGridPieceClass;
00010 typedef struct _mDayGridPiece mDayGridPiece;
00011
00012 #define mDayGridPieceClassHeader(clss, superCls) \
00013         mGridBoxPieceClassHeader(clss, superCls)  \
00014         CELL_POINT (*day2Cell)(clss*, int day); \
00015         int (*cell2Day)(clss *, int row, int col);
00016
00017
00018 struct _mDayGridPieceClass
00019 {
00020         mDayGridPieceClassHeader(mDayGridPiece, mGridBoxPiece)
00021 };
00022
00023 MGNCS_EXPORT extern mDayGridPieceClass g_stmDayGridPieceCls;
00024
00025 #define mDayGridPieceHeader(clss) \
00026         mGridBoxPieceHeader(clss)  \
00027         unsigned char month_days; \
00028         unsigned char last_month_days; \
00029         unsigned char weekday_of_first_day;
00030
00031 struct _mDayGridPiece
00032 {
00033         mDayGridPieceHeader(mDayGridPiece)
00034 };
00035
00036 enum mDayGridPieceProps{
00037         NCSP_DAYGRIDPIECE_MONTH_DAYS = DAYGRIDPIECE_PROP_BEGIN,
00038         NCSP_DAYGRIDPIECE_LASTMONTH_DAYS,
00039         NCSP_DAYGRIDPIECE_WEEKDAY_OF_FIRSTDAY
00040 };
00041
00042 enum WeekDays{
00043         Sunday = 0,
00044         Monday,
00045         Tuesday,
00046         Wednesday,
00047         Thursday,
00048         Friday,
00049         Saturday
00050 };
00051
00052
00053 #ifdef __cplusplus
00054 }
00055 #endif
00056
00057 #endif
00058
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mdblist.h Source File

include

mdblist.h

Go to the documentation of this file.
00001
00028 #ifndef _NCS_DBLIST_H
00029 #define _NCS_DBLIST_H
00030
00031 #ifdef __cplusplus
00032 extern "C" {
00033 #endif
00034
00045 struct list_head {
00046     struct list_head *next, *prev;
00047 };
00048
00053 typedef struct list_head list_t;
00054
00055 #define LIST_HEAD_INIT(name) { &(name), &(name) }
00056
00057 /* define and init a list head */
00058 #define LIST_HEAD(name) \
00059     struct list_head name = LIST_HEAD_INIT(name)
00060
00061 /* init a list head */
00062 #define INIT_LIST_HEAD(ptr) do { \
00063     (ptr)->next = (ptr); (ptr)->prev = (ptr); \
00064 } while (0)
00065
00066 /*
00067  * \fn void __list_add(struct list_head * _new, \
00068                 struct list_head * prev, \
00069                 struct list_head * next)
00070  * \brief Insert a _new entry between two known consecutive entries.
00071  *
00072  * This is only for internal list manipulation where we know
00073  * the prev/next entries already!
00074  */
00075 static inline void __list_add(struct list_head * _new,
00076     struct list_head * prev,
00077     struct list_head * next)
00078 {
00079     next->prev = _new;
00080     _new->next = next;
00081     _new->prev = prev;
00082     prev->next = _new;
00083 }
00084
00095 static inline void list_add(struct list_head *_new, struct list_head *head)
00096 {
00097     __list_add(_new, head, head->next);
00098 }
00099
00110 static inline void list_add_tail(struct list_head *_new, struct list_head *head)
00111 {
00112     __list_add(_new, head->prev, head);
00113 }
00114
00115 /*
00116  * \fn  void __list_del(struct list_head * prev, \
00117                   struct list_head * next)
00118  * \brief Delete a list entry by making the prev/next entries
00119  * point to each other.
00120  *
00121  * This is only for internal list manipulation where we know
00122  * the prev/next entries already!
00123  */
00124 static inline void __list_del(struct list_head * prev,
00125                   struct list_head * next)
00126 {
00127     next->prev = prev;
00128     prev->next = next;
00129 }
00130
00136 static inline void list_del(struct list_head *entry)
00137 {
00138     __list_del(entry->prev, entry->next);
00139 }
00140
00147 static inline void list_del_init(struct list_head *entry)
00148 {
00149     __list_del(entry->prev, entry->next);
00150     INIT_LIST_HEAD(entry);
00151 }
00152
00159 static inline int list_empty(struct list_head *head)
00160 {
00161     return head->next == head;
00162 }
00163
00172 #define list_entry(ptr, type, member) \
00173     ((type *)((char *)(ptr)-(unsigned long)(&((type *)0)->member)))
00174
00181 #define list_for_each(pos, head) \
00182     for (pos = (head)->next; pos != (head); pos = pos->next)
00183
00191 #define list_for_each_safe(pos, n, head) \
00192     for (pos = (head)->next, n = pos->next; pos != (head); \
00193         pos = n, n = pos->next)
00194
00202 #define list_for_each_ex(pos, head, begin) \
00203     for (pos = (begin)->next; pos != (head); pos = (pos)->next)
00204
00214 #define list_for_index(pos, i, head, index) \
00215     for (pos = (head)->next, i=0; (pos != (head) && i < index); pos = pos->next,i++)
00216
00217
00218 static inline int list_add_by_index(struct list_head *_new, struct list_head *head, int index)
00219 {
00220     list_t *pos = head;
00221     int i = -1;
00222
00223     if (index >= 0) {
00224         for (pos = (head)->next, i=0; (pos != (head) && i < index); pos = pos->next,i++);
00225     }
00226     list_add_tail (_new, pos);
00227     return i;
00228 }
00229
00230
00231 /* added for normal list operations */
00232 #define GETBY_EX(func, head, entrytype, member, datatype, ret, equal_cond) \
00233         void* func (datatype data) \
00234         { \
00235             list_t *me; \
00236             entrytype *pdata; \
00237             int i = 0; \
00238             \
00239             list_for_each(me, head) { \
00240                 pdata = list_entry(me, entrytype, member); \
00241                 if (equal_cond) \
00242                     return ret; \
00243             } \
00244             return NULL; \
00245         }
00246
00247 #define GET_LIST_BY_DATA(func, head, entrytype, member, datamember, datatype) \
00248         GETBY_EX(func, head, entrytype, member, datatype, me, (pdata->datamember == data))
00249
00250 #define GET_ENTRY_BY_DATA(func, head, entrytype, member, datamember, datatype) \
00251         GETBY_EX(func, head, entrytype, member, datatype, pdata, (pdata->datamember == data))
00252
00253 /* for string */
00254 #define GET_LIST_BY_STRING(func, head, entrytype, member, datamember, datatype) \
00255         GETBY_EX(func, head, entrytype, member, datatype, me, (strcmp(pdata->datamember,data)==0))
00256
00257 #define GET_ENTRY_BY_STRING(func, head, entrytype, member, datamember, datatype) \
00258         GETBY_EX(func, head, entrytype, member, datatype, pdata, (strcmp(pdata->datamember,data)==0))
00259
00260 /* for index */
00261 #define GET_ENTRY_BY_INDEX(func, entrytype, member) \
00262         static inline entrytype* func (list_t *head, int index) \
00263         { \
00264             list_t *me; \
00265             int i = 0; \
00266             \
00267             list_for_each(me, head) { \
00268                 if (i++ == index) \
00269                     return list_entry(me, entrytype, member); \
00270             } \
00271             return NULL; \
00272         }
00273
00274 #define GET_ENTRY_INDEX(func, entrytype, member) \
00275         static inline int func (list_t *head, entrytype* entry) \
00276         { \
00277             list_t *me; \
00278             int i = 0; \
00279             \
00280             list_for_each(me, head) { \
00281                 if (entry == list_entry(me, entrytype, member)) \
00282                     return i; \
00283                 i++; \
00284             } \
00285             return -1; \
00286         }
00287
00288 #ifdef __cplusplus
00289 }
00290 #endif
00291
00292 #endif /* _NCS_DBLIST_H */
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mdialog.h Source File

include

mdialog.h

00001 /*
00002 * \file mmainwnd.h
00003 * \author dongjunjie
00004 * \date 2009/01/01
00005 *
00006 * This file include the dialog defines
00007 *
00008 * \verbatim
00009 *
00010 *       This file is part of mgncs, new control of MiniGUI
00011 *
00012 *       \endverbatim
00013 *
00014 */
00015
00016 #ifndef _MGUI_CTRL_DLGBOX_H
00017 #define _MGUI_CTRL_DLGBOX_H
00018
00019 #ifdef __cplusplus
00020 extern "C" {
00021 #endif
00022
00032 #define NCSCTRL_DIALOGBOX NCSCLASSNAME("dialogbox")
00033
00034 typedef struct _mDialogBox mDialogBox;
00035 typedef struct _mDialogBoxClass mDialogBoxClass;
00036 typedef struct _mDialogBoxRenderer mDialogBoxRenderer;
00037
00038 /* define mDialogBoxRenderer */
00039 #define mDialogBoxRendererHeader(clsName, parentClass) \
00040         mMainWndRendererHeader(clsName, parentClass)
00041
00049 struct _mDialogBoxRenderer {
00050         mDialogBoxRendererHeader(mDialogBox, mMainWnd)
00051 };
00052
00053 /* define mDialogBox */
00054 #define mDialogBoxHeader(className) \
00055         mMainWndHeader(className)
00056
00066 struct _mDialogBox{
00067         mDialogBoxHeader(mDialogBox)
00068 };
00069
00070 /* define mDialogBoxClass */
00071 #define mDialogBoxClassHeader(clsName, parentClass)    \
00072         mMainWndClassHeader(clsName, parentClass)
00073
00082 struct _mDialogBoxClass
00083 {
00084         mDialogBoxClassHeader(mDialogBox, mMainWnd)
00085 };
00086
00091 MGNCS_EXPORT extern mDialogBoxClass g_stmDialogBoxCls; //Class(mDialogBox);
00092
00093
00094 #define NCSS_DLGBOX_SHIFT  NCSS_MNWND_SHIFT
00095
00096 enum enumDialogBoxNotify {
00097         NCSN_DLGBOX_MAX = NCSN_MNWND_MAX + 1
00098 };
00099
00102 #ifdef __cplusplus
00103 }
00104 #endif
00105
00106 #endif
00107
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mdownarrowpiece.h Source File

include » pieces

mdownarrowpiece.h

00001
00002 #ifndef _MGUI_NCSCTRL_DOWNARROWPIECE_H
00003 #define _MGUI_NCSCTRL_DOWNARROWPIECE_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif
00008
00009 typedef struct _mDownArrowPieceClass mDownArrowPieceClass;
00010 typedef struct _mDownArrowPiece mDownArrowPiece;
00011
00012 #define mDownArrowPieceClassHeader(clss, superCls) \
00013         mArrowPieceClassHeader(clss, superCls)
00014
00015 struct _mDownArrowPieceClass
00016 {
00017         mDownArrowPieceClassHeader(mDownArrowPiece, mArrowPiece)
00018 };
00019
00020 MGNCS_EXPORT extern mDownArrowPieceClass g_stmDownArrowPieceCls;
00021
00022 #define mDownArrowPieceHeader(clss) \
00023         mArrowPieceHeader(clss)
00024
00025 struct _mDownArrowPiece
00026 {
00027         mDownArrowPieceHeader(mDownArrowPiece)
00028 };
00029
00030
00031 #ifdef __cplusplus
00032 }
00033 #endif
00034
00035 #endif
00036
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: medit.h Source File

include

medit.h

Go to the documentation of this file.
00001
00019 #ifndef _MGUI_NCSCTRL_EDIT_H
00020 #define _MGUI_NCSCTRL_EDIT_H
00021
00022 #ifdef __cplusplus
00023 extern "C" {
00024 #endif  /* __cplusplus */
00025
00026 /* structure to represent a text string */
00027 typedef struct strbuffer_s
00028 {
00029     unsigned char *string;     /* text string content */
00030     unsigned int  txtlen;      /* text len or buffer used size */
00031     unsigned int  blocksize;   /* block size, a block is an allocate unit */
00032     unsigned int  buffsize;    /* buffer size */
00033 } StrBuffer;
00034
00035 /* ------------------------- memory and struct alloc ------------------------ */
00036
00037 #define te_alloc                         malloc
00038 #define te_free                          free
00039 #define te_realloc(ptr, size, cpysize)   realloc(ptr, size)
00040
00041 /* alloc with a unit of blocksize */
00042 static inline void* testr_alloc (StrBuffer *txtbuff, size_t len, size_t blocksize)
00043 {
00044     txtbuff->buffsize = (len + 1) + (blocksize - (len + 1)%blocksize);
00045     txtbuff->string = (unsigned char *)te_alloc (txtbuff->buffsize);
00046     txtbuff->blocksize = blocksize;
00047     //txtbuff->txtlen = len;
00048     return txtbuff->string;
00049 }
00050
00051 static inline void* testr_realloc (StrBuffer *txtbuff, size_t len)
00052 {
00053     if (len + 1 > txtbuff->buffsize ||
00054              len + 1 < txtbuff->buffsize - txtbuff->blocksize) {
00055         /* really realloc */
00056         size_t old_size;
00057         old_size  = txtbuff->buffsize;
00058         txtbuff->buffsize = (len + 1) + (txtbuff->blocksize -
00059                             (len + 1)%txtbuff->blocksize);
00060         txtbuff->string = (unsigned char *)te_realloc (txtbuff->string, txtbuff->buffsize, old_size);
00061     }
00062
00063     return txtbuff->string;
00064 }
00065
00066 static inline void testr_free (StrBuffer *txtbuff)
00067 {
00068     if (txtbuff) {
00069         te_free (txtbuff->string);
00070     }
00071 }
00072
00073 static inline void testr_setstr (StrBuffer *txtbuff, const char *newstring, unsigned int len)
00074 {
00075     int datalen;
00076
00077     if (len < 0 && !newstring) return;
00078
00079     datalen = MIN(len, txtbuff->buffsize-1);
00080     memcpy (txtbuff->string, newstring, datalen);
00081     txtbuff->string[datalen] = '\0';
00082     txtbuff->txtlen = datalen;
00083 }
00084
00085 /* copy a string buffer */
00086 static inline StrBuffer* testr_copy (StrBuffer *des, StrBuffer *src)
00087 {
00088     if (!des || !src)
00089         return NULL;
00090
00091     testr_free (des);
00092     testr_alloc (des, src->txtlen, des->blocksize);
00093     testr_setstr (des, (const char *)src->string, src->txtlen);
00094     return des;
00095 }
00096
00097 /* duplicates a string buffer */
00098 static inline StrBuffer* testr_dup (StrBuffer *s1)
00099 {
00100     StrBuffer *s2;
00101
00102     if (!s1)
00103         return NULL;
00104
00105     s2 = (StrBuffer *)malloc (sizeof(s1));
00106     if (s2) {
00107         testr_alloc (s2, s1->txtlen, s1->blocksize);
00108         testr_setstr (s2, (const char *)s1->string, s1->txtlen);
00109     }
00110     return s2;
00111 }
00112
00113 /* duplicates a string buffer */
00114 static inline StrBuffer* testr_dup2 (StrBuffer *s2, StrBuffer *s1)
00115 {
00116     if (!s1 || !s2)
00117         return NULL;
00118
00119     testr_alloc (s2, s1->txtlen, s1->blocksize);
00120     testr_setstr (s2, (const char *)s1->string, s1->txtlen);
00121     return s2;
00122 }
00123
00124 /* -------------------------------------------------------------------------- */
00125
00126
00132 /*
00133  * \def NCSCTRL_EDIT
00134  * \brief the name of edit control
00135 */
00136 #define NCSCTRL_EDIT   NCSCLASSNAME("edit")
00137
00138 #ifdef _MGNCS_USE_DBEDIT
00139 #define DOUBLE_DC HDC   db_dc;
00140 #else
00141 #define DOUBLE_DC
00142 #endif
00143
00144 typedef struct _mEdit mEdit;
00145 typedef struct _mEditClass mEditClass;
00146 typedef struct _mEditRenderer    mEditRenderer;
00147
00148 #define mEditHeader(Class)   \
00149     mScrollViewHeader(Class) \
00150         DOUBLE_DC
00151
00158 struct _mEdit
00159 {
00160     mEditHeader(mEdit)
00161 };
00162
00163
00164 typedef struct _TextAttribute
00165 {
00166     struct _TextAttribute* (*clone)(void);
00167     void (*destroy)(void);
00168 }TextAttribute;
00169
00170 typedef struct _PasteInfo {
00171     char          *str;
00172     int            len;
00173     TextAttribute *attr;
00174     void          *user_info;
00175     struct _PasteInfo *next;
00176 }PasteInfo;
00177
00178 typedef struct _TextCopyPaste
00179 {
00180     void (*addCopyInfo)(const char* str, int len, TextAttribute *atrr, void *user_info);
00181     void (*endCopyInfo)(void);
00182     BOOL (*isEmpty)(void);
00183     PasteInfo* (*getPasteInfo)(void);
00184 }TextCopyPaste;
00185
00186 typedef struct _UndoRedoInfo
00187 {
00188     char           *text;
00189     int             start;
00190     int             end;
00191     TextAttribute  *attr;
00192     void           *user_data;
00193     struct _UndoRedoInfo * next;
00194 } UndoRedoInfo;
00195
00196 typedef struct _TextUndoRedoInfo
00197 {
00198     BOOL (*pushText)(const char* text, int start, int end, TextAttribute *attr, void *user_data);
00199     BOOL (*endPush)(void);
00200
00201     UndoRedoInfo* (*getUndoTop)(void);
00202     UndoRedoInfo* (*getRedoTop)(void);
00203
00204     void (*popUndo)(void);
00205     void (*popRedo)(void);
00206
00207     BOOL (*isUndoEmpty)(void);
00208     BOOL (*isRedoEmpty)(void);
00209
00210     void (*empty)(void);
00211 }TextUndoRedoInfo;
00212
00213 #define mEditClassHeader(clsName, parentClass) \
00214     mScrollViewClassHeader(clsName, parentClass)    \
00215     int (*onChar)(clsName* self, int asciiCode, DWORD keyFlags);           \
00216     int (*setContent)(clsName *self, const char* str, int start, int len);   \
00217     void (*replaceText)(clsName *self, const char* str, int start, int len, int replaceStart, int replaceEnd);    \
00218     void (*insert)(clsName *self, const char* str, int start, int len, int insertStart);    \
00219     void (*append)(clsName *self, const char* str, int start, int len);            \
00220     int (*getTextLength)(clsName *self);                                           \
00221     int (*getContent)(clsName *self, char *strBuff, int bufLen, int start, int end); \
00222     int (*setTextAttr)(clsName *self, int start, int end, TextAttribute *attr);    \
00223     TextAttribute* (*getTextAttr)(clsName *self, int start, int end, int *pEnd);   \
00224     int (*setSel)(clsName *self, int start, int end);                              \
00225     int (*getSel)(clsName *self, int *pStart, int *pEnd);                          \
00226     void (*setMargin)(clsName *self, int left, int top, int right, int bottom);    \
00227     void (*copy)(clsName *self);                                                   \
00228     void (*cut)(clsName *self);                                                    \
00229     void (*paste)(clsName *self);                                                  \
00230     TextCopyPaste * (*setCopyPaste)(clsName *self, TextCopyPaste* cp);             \
00231     void (*undo)(clsName *self);                                                   \
00232     void (*redo)(clsName *self);                                                   \
00233     TextUndoRedoInfo * (*setUndoRedo)(clsName *self, TextUndoRedoInfo* ur);        \
00234     BOOL (*makevisible)(clsName *self, int pos);
00235
00339 struct _mEditClass
00340 {
00341     mEditClassHeader(mEdit, mScrollView)
00342 };
00343
00350 MGNCS_EXPORT extern mEditClass g_stmEditCls;
00351
00352
00353 #define mEditRendererHeader(clsName, parentClass) \
00354         mScrollViewRendererHeader(clsName, parentClass)
00355
00362 struct _mEditRenderer
00363 {
00364         mEditRendererHeader(mEdit, mScrollView)
00365 };
00366
00371 #define NCSS_EDIT_LEFT        (0x0000L<<NCSS_SCRLV_SHIFT)
00372
00377 #define NCSS_EDIT_CENTER      (0x0001L<<NCSS_SCRLV_SHIFT)
00378
00383 #define NCSS_EDIT_RIGHT       (0x0002L<<NCSS_SCRLV_SHIFT)
00384
00389 #define NCSS_EDIT_UPPERCASE   (0x0004L<<NCSS_SCRLV_SHIFT)
00390
00395 #define NCSS_EDIT_LOWERCASE   (0x0008L<<NCSS_SCRLV_SHIFT)
00396
00401 #define NCSS_EDIT_NOHIDESEL   (0x0010L<<NCSS_SCRLV_SHIFT)
00402
00407 #define NCSS_EDIT_READONLY    (0x0020L<<NCSS_SCRLV_SHIFT)
00408
00413 #define NCSS_EDIT_BASELINE    (0x0040L<<NCSS_SCRLV_SHIFT)
00414
00415 #define NCSS_EDIT_SHIFT  (NCSS_SCRLV_SHIFT+8)
00416
00417
00418
00423 enum mEditProp
00424 {
00431     NCSP_EDIT_LIMITTEXT = NCSP_SCRLV_MAX + 1,
00438     NCSP_EDIT_CARETPOS ,
00439     NCSP_EDIT_MAX
00440 };
00441
00442
00444 enum mEditNotify
00445 {
00446     NCSN_EDIT_SETFOCUS = NCSN_ITEMV_SETFOCUS,
00447     NCSN_EDIT_KILLFOCUS = NCSN_ITEMV_KILLFOCUS,
00448     NCSN_EDIT_CHANGE = NCSN_SCRLV_MAX + 1,
00449     NCSN_EDIT_CONTCHANGED,
00450     NCSN_EDIT_UPDATE,
00451     NCSN_EDIT_SELCHANGED,
00452     NCSN_EDIT_MAXTEXT,
00453     NCSN_EDIT_MAX
00454 };
00455
00456 #ifdef _MGNCS_USE_DBEDIT
00457 static inline HDC mEdit_getDC(mEdit *self)
00458 {
00459     if (self->db_dc) {
00460         SelectClipRect(self->db_dc, NULL);
00461                 SelectFont(self->db_dc, GetWindowFont(self->hwnd));
00462         return self->db_dc;
00463     }
00464     else
00465         return GetClientDC(self->hwnd);
00466 }
00467
00468 static inline void mEdit_releaseDC(mEdit *self, HDC hdc)
00469 {
00470     if (self->db_dc == 0 || self->db_dc != hdc)
00471         ReleaseDC(hdc);
00472 }
00473 #else
00474 static inline HDC mEdit_getDC(mEdit *self)
00475 {
00476     return GetClientDC(self->hwnd);
00477 }
00478
00479 static inline void mEdit_releaseDC(mEdit *self, HDC hdc)
00480 {
00481     ReleaseDC(hdc);
00482 }
00483 #endif
00484 #define GETDC(self)             mEdit_getDC((mEdit*)self)
00485 #define RELEASEDC(self, hdc)    mEdit_releaseDC((mEdit*)self, hdc)
00486
00489 #ifdef __cplusplus
00490 }
00491 #endif  /* __cplusplus */
00492
00493 #endif /* _MGUI_NCSCTRL_EDIT_H */
00494
00495
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mem-slab.h Source File

include

mem-slab.h

00001
00002 #ifndef MEM_SLAB_H
00003 #define MEM_SLAB_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif
00008
00009 MGNCS_EXPORT void* slab_new_heap(int min_size, int max_size);
00010
00011 MGNCS_EXPORT void slab_free_heap(void *heap);
00012
00013 MGNCS_EXPORT void* slab_new_mem(void *heap, int size, int padding);
00014
00015 MGNCS_EXPORT void slab_free_mem(void *heap, void *p);
00016
00017 MGNCS_EXPORT int slab_init_default_heap(void);
00018
00019 MGNCS_EXPORT void slab_unit_default_heap(void);
00020
00021 #define _SLAB_ALLOC(size)  slab_new_mem(NULL, (size), 0)
00022 #define _SLAB_FREE(p)   slab_free_mem(NULL, p)
00023
00024 #ifdef __cplusplus
00025 }
00026 #endif
00027
00028 #endif
00029
00030
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mgifanimateframes.h Source File

include

mgifanimateframes.h

00001 #ifndef _MGUI_NCSCTRL_GIFANIMATEFRAMES_H
00002 #define _MGUI_NCSCTRL_GIFANIMATEFRAMES_H
00003
00004 #ifdef _cplusplus
00005 extern "C"{
00006 #endif
00007
00008 typedef struct _mGIFAnimateFrames mGIFAnimateFrames;
00009 typedef struct _mGIFAnimateFramesClass mGIFAnimateFramesClass;
00010
00011 typedef struct _mGIFAnimateFrame{
00012         int off_x;
00013         int off_y;
00014         int disposal;
00015         unsigned int delay_time;
00016         BITMAP bmp;
00017         struct _mGIFAnimateFrame* next;
00018         struct _mGIFAnimateFrame* prev;
00019 }mGIFAnimateFrame;
00020
00021
00022 #define mGIFAnimateFramesHeader(clsName) \
00023         mAnimateFramesHeader(clsName) \
00024         /*RGB bk;*/     \
00025         mGIFAnimateFrame *frames;  \
00026         HDC mem_dc;
00027
00028 struct _mGIFAnimateFrames{
00029         mGIFAnimateFramesHeader(mAnimateFrames)
00030 };
00031
00032 #define mGIFAnimateFramesClassHeader(clss, superCls) \
00033         mAnimateFramesClassHeader(clss, superCls)
00034
00035 struct _mGIFAnimateFramesClass{
00036         mGIFAnimateFramesClassHeader(mGIFAnimateFrames, mAnimateFrames)
00037 };
00038
00039 MGNCS_EXPORT extern mGIFAnimateFramesClass g_stmGIFAnimateFramesCls;
00040
00041 MGNCS_EXPORT mGIFAnimateFrames * ncsCreateAnimateFramesFromGIFFile(const char* gif_file);
00042
00043 MGNCS_EXPORT mGIFAnimateFrames * ncsCreateAnimateFramesFromGIFMem(const void* mem, int size);
00044
00045 #ifdef _cplusplus
00046 }
00047 #endif
00048
00049 #endif
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mgncs.h Source File

include

mgncs.h

Go to the documentation of this file.
00001
00027 #ifndef _MGNCS_H
00028 #define _MGNCS_H
00029
00030 #ifdef __cplusplus
00031 extern "C" {
00032 #endif
00033
00034 #include <stdarg.h>
00035
00036 #ifndef MGNCS_MAJOR_VERSION
00037 # ifdef __MGNCS_LIB__
00038 # if defined(__CMAKE_PROJECT__) || defined(WIN32)
00039 #    include "mgncsconfig.h"
00040 # else
00041 #    include "../mgncsconfig.h"
00042 # endif
00043 #else
00044 #    include "mgncsconfig.h"
00045 #    undef PACKAGE_BUGREPORT
00046 #    undef PACKAGE_NAME
00047 #    undef PACKAGE_STRING
00048 #    undef PACKAGE_TARNAME
00049 #    undef PACKAGE_VERSION
00050 #endif
00051 #endif
00052
00053 #include "mdblist.h"
00054 #include "mcommon.h"
00055 #include "mtype.h"
00056 #include "mem-slab.h"
00057 #include "hashtable.h"
00058 #include "mobject.h"
00059
00060 #include "mcomponent.h"
00061 #include "mwidget.h"
00062 #include "mpopmenumgr.h"
00063 #include "mtoolitem.h"
00064
00065 #include "piece.h"
00066 #include "mtoolbaritems.h"
00067
00068 #include "mscroll_widget.h"
00069 #include "mpanel.h"
00070 #include "mcontainer.h"
00071 #include "mstatic.h"
00072 #include "mimage.h"
00073 #include "mrect.h"
00074 #include "mgroupbox.h"
00075 #include "mbuttongroup.h"
00076 #include "mbutton.h"
00077 #include "mcheckbutton.h"
00078 #include "mradiobutton.h"
00079 #include "mmenubutton.h"
00080 #include "mprogressbar.h"
00081 #include "mspinner.h"
00082 #include "mspinbox.h"
00083 #include "mslider.h"
00084 #include "mtrackbar.h"
00085 #include "mpage.h"
00086 #include "mpropsheet.h"
00087 #include "mmainwnd.h"
00088 #include "mdialog.h"
00089 #include "mdblist.h"
00090 #include "mitem.h"
00091 #include "mitem_manager.h"
00092 #include "mitemview.h"
00093 #include "miconview.h"
00094 #include "mscrollview.h"
00095 #include "mlistcolumn.h"
00096 #include "mlistitem.h"
00097 #include "mlistview.h"
00098 #include "mlistbox.h"
00099 #include "mscrollbar.h"
00100 #include "mmonthcalendar.h"
00101 #include "mtoolbar.h"
00102
00103 #include "minvisible-component.h"
00104 #include "mtimer.h"
00105
00106 #include "medit.h"
00107 #include "msledit.h"
00108 #include "manimate.h"
00109 #include "mmledit.h"
00110 #include "mcombobox.h"
00111 #include "mledstatic.h"
00112 #include "mcolorbutton.h"
00113
00114 #include "mseparator.h"
00115
00116 #include "mnode.h"
00117 #include "mchecknode.h"
00118 #include "mradionode.h"
00119 #include "mabstractlist.h"
00120 #include "mlist_layout.h"
00121 #include "mlist.h"
00122
00123 #include "mrdr.h"
00124
00125 #ifdef _MGNCS_DATASOURCE
00126 #include "mdatabinding.h"
00127 #include "mdatasource.h"
00128 #endif
00129
00130 #ifdef _MGNCS_TEXTEDITOR
00131 #include "mbtree.h"
00132 #include "mtexteditbase.h"
00133 #include "mtextedit.h"
00134 #endif
00135
00136 #include "mresmgr.h"
00137
00138 #include "mime.h"
00139 #include "mime-wordsel.h"
00140
00141 typedef  mMainWnd* (*PNCS_CREATE_MAIN)(HPACKAGE, HWND hParent, HICON h_icon, HMENU h_menu, DWORD);
00142
00143 #ifdef _MGRM_THREADS
00144
00145 MGNCS_EXPORT mMainWnd* ncsSyncCallCreate(HWND host, PNCS_CREATE_MAIN pCreateMain, \
00146                 HPACKAGE hPack, \
00147                 HICON h_icon, \
00148                 HMENU h_menu, \
00149                 DWORD user);
00150
00151 #else
00152
00153 #define ncsSyncCallCreate(host, pCreate, hPack, h_icon, h_menu, user) \
00154         ((PNCS_CREATE_MAIN)(pCreate))(hPack, host, h_icon, h_menu, user)
00155
00156 #endif
00157
00158
00159
00164 MGNCS_EXPORT BOOL ncsInitialize(void);
00165
00170 MGNCS_EXPORT void ncsUninitialize(void);
00171
00172 #ifdef __cplusplus
00173 }
00174 #endif
00175
00176 #endif
00177
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mgridboxpiece.h Source File

include » pieces

mgridboxpiece.h

00001
00002 #ifndef _MGUI_NCSCTRL_GRIDBOXPIECE_H
00003 #define _MGUI_NCSCTRL_GRIDBOXPIECE_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif
00008
00009 typedef struct _mGridBoxPieceClass mGridBoxPieceClass;
00010 typedef struct _mGridBoxPiece mGridBoxPiece;
00011
00012 #define CELL_POINT_ISNULL(cp)   ((cp).row == 0xFFFF || (cp).col == 0xFFFF)
00013 #define NULL_CELL_POINT  { 0xFFFF, 0xFFFF}
00014 typedef struct _CELL_POINT{
00015         unsigned short row;
00016         unsigned short col;
00017 }CELL_POINT;
00018
00019 #define mGridBoxPieceClassHeader(clss, superCls) \
00020         mRenderablePieceClassHeader(clss, superCls)  \
00021         CELL_POINT (* hitCell)(clss *, int x, int y);  \
00022         RECT * (*getCellRect)(clss *, int row, int col, RECT *prc); \
00023         void (*updateNewCell)(clss *, CELL_POINT old_cell, CELL_POINT new_cell, int old_mask, int new_mask, mWidget *owner);
00024
00025 struct _mGridBoxPieceClass
00026 {
00027         mGridBoxPieceClassHeader(mGridBoxPiece, mRenderablePiece)
00028 };
00029
00030 MGNCS_EXPORT extern mGridBoxPieceClass g_stmGridBoxPieceCls;
00031
00032 #define mGridBoxPieceHeader(clss) \
00033         mRenderablePieceHeader(clss)  \
00034         unsigned short rows; \
00035         unsigned short cols;
00036
00037 struct _mGridBoxPiece
00038 {
00039         mGridBoxPieceHeader(mGridBoxPiece)
00040 };
00041
00042
00043 #define NCS_GRIDBOXPIECE_PAINT_MASK_DRAWSEL 0x01
00044 #define NCS_GRIDBOXPIECE_PAINT_MASK_HOT     0x02
00045 #define NCS_GRIDBOXPIECE_PAINT_MASK_REDRAW  0x04
00046 #define NCS_GRIDBOXPIECE_PAINT_MASK_ALL_CELLS 0x10
00047 typedef struct mGridBoxPiecePaintData{
00048         DWORD mask;
00049         CELL_POINT  hot_cell;
00050         CELL_POINT  sel_cell;
00051         DWORD add_data;
00052 }mGridBoxPiecePaintData;
00053
00054 enum mGridBoxPieceProps{
00055         NCSP_GRIDBOXPIECE_ROWS = GRIDBOXPIECE_PROP_BEGIN,
00056         NCSP_GRIDBOXPIECE_COLS
00057 };
00058
00059 #define mGridBoxPiece_makeCell(col, row)  (DWORD)(((col)&0xFF)|(((row)&0xFF)<<8))
00060 #define mGridBoxPiece_getRow(cell)   (((cell)&0xFF00)>>8)
00061 #define mGridBoxPiece_getCol(cell)   ((cell)&0xFF)
00062
00063
00064 #ifdef __cplusplus
00065 }
00066 #endif
00067
00068 #endif
00069
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mgroupbox.h Source File

include

mgroupbox.h

00001
00002 #ifndef _MGUI_NCSCTRL_GRPBOX_H
00003 #define _MGUI_NCSCTRL_GRPBOX_H
00004
00005
00006 #ifdef __cplusplus
00007 extern "C" {
00008 #endif  /* __cplusplus */
00009
00020 #define NCSCTRL_GROUPBOX        NCSCLASSNAME("groupbox")
00021
00022 typedef struct _mGroupBox mGroupBox;
00023 typedef struct _mGroupBoxClass mGroupBoxClass;
00024 typedef struct _mGroupBoxRenderer mGroupBoxRenderer;
00025
00026 #define mGroupBoxHeader(clsName) \
00027         mStaticHeader(clsName)
00028
00034 struct _mGroupBox
00035 {
00036         mGroupBoxHeader(mGroupBox)
00037 };
00038
00039 #define mGroupBoxClassHeader(clsName, parentClass)  \
00040         mStaticClassHeader(clsName, parentClass)        \
00041     int (*hitTest)(clsName *self, int x, int y);
00042
00055 struct _mGroupBoxClass
00056 {
00057         mGroupBoxClassHeader(mGroupBox, mStatic)
00058 };
00059
00060 #define mGroupBoxRendererHeader(clsName, parentClass) \
00061         mStaticRendererHeader(clsName, parentClass) \
00062     void (*drawGroupbox)(clsName *self, HDC hdc, const RECT *pRect);
00063
00075 /* define the render of image static */
00076 struct _mGroupBoxRenderer {
00077         mGroupBoxRendererHeader(mGroupBox, mStatic)
00078 };
00079
00085 MGNCS_EXPORT extern mGroupBoxClass g_stmGroupBoxCls;
00086
00092 /* property */
00093 enum mGroupBoxProp {
00094         NCSP_GRPBOX_MAX = NCSP_STATIC_MAX + 1
00095 };
00096
00097 #define NCSS_GRPBOX_SHIFT NCSS_STATIC_SHIFT
00098
00103 enum enumGroupBoxNotify{
00104         NCSN_GRPBOX_MAX = NCSN_STATIC_MAX + 1
00105 };
00106
00110 #ifdef __cplusplus
00111 }
00112 #endif  /* __cplusplus */
00113
00114 #endif /* _MGUI_NCSCTRL_GRPBOX_H */
00115
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mhboxlayoutpiece.h Source File

include » pieces

mhboxlayoutpiece.h

00001
00002 #ifndef _MGUI_NCSCTRL_HBOXLAYOUTPIECE_H
00003 #define _MGUI_NCSCTRL_HBOXLAYOUTPIECE_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif
00008
00009 typedef struct _mHBoxLayoutPieceClass mHBoxLayoutPieceClass;
00010 typedef struct _mHBoxLayoutPiece mHBoxLayoutPiece;
00011
00012 #define mHBoxLayoutPieceClassHeader(clss, superCls) \
00013         mBoxLayoutPieceClassHeader(clss, superCls)
00014
00015 struct _mHBoxLayoutPieceClass
00016 {
00017         mHBoxLayoutPieceClassHeader(mHBoxLayoutPiece, mBoxLayoutPiece)
00018 };
00019
00020 MGNCS_EXPORT extern mHBoxLayoutPieceClass g_stmHBoxLayoutPieceCls;
00021
00022 #define mHBoxLayoutPieceHeader(clss) \
00023         mBoxLayoutPieceHeader(clss)
00024
00025 struct _mHBoxLayoutPiece
00026 {
00027         mHBoxLayoutPieceHeader(mHBoxLayoutPiece)
00028 };
00029
00030
00031 #ifdef __cplusplus
00032 }
00033 #endif
00034
00035 #endif
00036
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mhotpiece.h Source File

include » pieces

mhotpiece.h

00001
00002 #ifndef _MGNCS_HOT_PIECEC_H
00003 #define _MGNCS_HOT_PIECEC_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif
00008
00009 #include "piece-id.h"
00010
00011 typedef struct _mHotPieceClass mHotPieceClass;
00012 typedef struct _mHotPiece mHotPiece;
00013
00014 #define mHotPieceClassHeader(clss, superCls) \
00015         mObjectClassHeader(clss, superCls) \
00016         mHotPiece* (*hitTest)(clss *,  int x, int y); \
00017         void (*paint)(clss *, HDC hdc, mObject * owner, DWORD add_data); \
00018         int (*processMessage)(clss *, int message, WPARAM, LPARAM, mObject *owner); \
00019         BOOL (*setProperty)(clss *, int id, DWORD value); \
00020         DWORD(*getProperty)(clss *, int id); \
00021         BOOL (*enable)(clss *, BOOL benable); \
00022         BOOL (*isEnabled)(clss *); \
00023         BOOL (*setRenderer)(clss *, const char* rdr_name); \
00024         BOOL (*setRect)(clss *, const RECT * prc); \
00025         BOOL (*getRect)(clss *, RECT * prc);  \
00026         BOOL (*autoSize)(clss *, mObject *owner, const SIZE *pszMin, const SIZE *pszMax);
00027
00028 struct _mHotPieceClass
00029 {
00030         mHotPieceClassHeader(mHotPiece, mObject)
00031 };
00032
00033 MGNCS_EXPORT extern mHotPieceClass g_stmHotPieceCls;
00034
00035 #define mHotPieceHeader(clss) \
00036         mObjectHeader(clss)
00037
00038 struct _mHotPiece
00039 {
00040         mHotPieceHeader(mHotPiece)
00041 };
00042
00043 typedef void (*PHotPieceRdrFunc)(mHotPiece*, HDC hdc, mObject* owner, DWORD add_data);
00044
00045
00046 #define SET_BIT(flag, mask)         ((flag)|=(mask))
00047 #define IS_BIT_SET(flag, mask)      (((flag)&(mask)) == (mask))
00048 #define CLEAR_BIT(flag, mask)       ((flag)&=~(mask))
00049
00050
00051 MGNCS_EXPORT mHotPiece * ncsNewPiece(mHotPieceClass *_class, DWORD add_data);
00052 #define NEWPIECEEX(Piece,add_data)   (Piece*)(ncsNewPiece((mHotPieceClass*)((void *)&(Class(Piece))),(DWORD)(add_data)))
00053 #define NEWPIECE(Piece)  NEWPIECEEX(Piece, 0)
00054 MGNCS_EXPORT void ncsDelPiece(mHotPiece* piece);
00055 #define DELPIECE(p)  ncsDelPiece((mHotPiece*)p)
00056
00057
00058 MGNCS_EXPORT void mHotPiece_update(mHotPiece *self, mObject *onwer, BOOL bUpdate);
00059
00060
00061 #ifdef __cplusplus
00062 }
00063 #endif
00064
00065 #endif
00066
00067
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mhspinboxpiece.h Source File

include » pieces

mhspinboxpiece.h

00001
00002 #ifndef _MGUI_NCSCTRL_HSPINBOXPIECE_H
00003 #define _MGUI_NCSCTRL_HSPINBOXPIECE_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif
00008
00009 typedef struct _mHSpinBoxPieceClass mHSpinBoxPieceClass;
00010 typedef struct _mHSpinBoxPiece mHSpinBoxPiece;
00011
00012 #define mHSpinBoxPieceClassHeader(clss, superCls) \
00013         mSpinBoxPieceClassHeader(clss, superCls)
00014
00015 struct _mHSpinBoxPieceClass
00016 {
00017         mHSpinBoxPieceClassHeader(mHSpinBoxPiece, mSpinBoxPiece)
00018 };
00019
00020 MGNCS_EXPORT extern mHSpinBoxPieceClass g_stmHSpinBoxPieceCls;
00021
00022 #define mHSpinBoxPieceHeader(clss) \
00023         mSpinBoxPieceHeader(clss)
00024
00025 struct _mHSpinBoxPiece
00026 {
00027         mHSpinBoxPieceHeader(mHSpinBoxPiece)
00028 };
00029
00030 #ifdef __cplusplus
00031 }
00032 #endif
00033
00034 #endif
00035
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: miconview.h Source File

include

miconview.h

Go to the documentation of this file.
00001
00026 #ifndef _MGUI_CTRL_ICONV_H
00027 #define _MGUI_CTRL_ICONV_H
00028
00029
00030 #ifdef __cplusplus
00031 extern "C" {
00032 #endif  /* __cplusplus */
00033
00043 typedef struct _NCS_ICONV_ITEMINFO
00044 {
00048     int index;
00049
00053     PBITMAP bmp;
00054
00058     const char *label;
00059
00061     DWORD addData;
00062 }NCS_ICONV_ITEMINFO;
00063
00064 typedef struct _mIconView mIconView;
00065 typedef struct _mIconViewClass mIconViewClass;
00066 typedef struct _mIconViewRenderer mIconViewRenderer;
00067
00072 #define NCSCTRL_ICONVIEW NCSCLASSNAME("iconview")
00073
00078 #define NCSS_ICONV_SHIFT     (NCSS_SCRLV_SHIFT)
00079
00084 #define NCSS_ICONV_SORT      NCSS_ITEMV_AUTOSORT
00085
00090 #define NCSS_ICONV_LOOP      NCSS_ITEMV_LOOP
00091
00092 #define mIconViewHeader(className)  \
00093     mItemViewHeader(className)      \
00094     int defItemWidth;               \
00095     int nrCol;                      \
00096     DWORD flags;
00097
00113 struct _mIconView
00114 {
00115         mIconViewHeader(mIconView)
00116 };
00117
00118 #define mIconViewClassHeader(clsName, parentClass)          \
00119     mItemViewClassHeader(clsName, parentClass)              \
00120     void (*setIconSize)(clsName*, int width, int height);   \
00121     HITEM (*addItem)(clsName*, NCS_ICONV_ITEMINFO *info, int *pos);
00122
00123
00124 struct _mIconViewClass
00125 {
00126         mIconViewClassHeader(mIconView, mItemView)
00127 };
00128
00143 #define mIconViewRendererHeader(clsName, parentClass) \
00144         mItemViewRendererHeader(clsName, parentClass)
00145
00151 struct  _mIconViewRenderer {
00152         mIconViewRendererHeader(mIconView, mItemView)
00153 };
00154
00159 enum mIconViewProp
00160 {
00164         NCSP_ICONV_DEFICONHEIGHT = NCSP_ITEMV_DEFITEMHEIGHT,
00165
00169         NCSP_ICONV_DEFICONWIDTH = NCSP_ITEMV_MAX + 1,
00173     NCSP_ICONV_MAX,
00174 };
00175
00180 enum mIconViewNotify
00181 {
00182     NCSN_ICONV_CLICKED = NCSN_ITEMV_CLICKED,
00183     NCSN_ICONV_SELCHANGED = NCSN_ITEMV_SELCHANGED,
00187     NCSN_ICONV_MAX = NCSN_ITEMV_MAX + 1,
00188 };
00189
00196 MGNCS_EXPORT extern mIconViewClass g_stmIconViewCls;
00199 #ifdef __cplusplus
00200 }
00201 #endif  /* __cplusplus */
00202
00203 #endif /* _MGUI_CTRL_ICONV_H */
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mimage.h Source File

include

mimage.h

00001
00002 #ifndef _MGUI_NCSCTRL_IMAGESTATIC_H
00003 #define _MGUI_NCSCTRL_IMAGESTATIC_H
00004
00005
00006 #ifdef __cplusplus
00007 extern "C" {
00008 #endif  /* __cplusplus */
00009 #include "mstatic.h"
00010
00020 #define NCSCTRL_IMAGE        NCSCLASSNAME("image")
00021
00022 typedef struct _mImage mImage;
00023 typedef struct _mImageClass mImageClass;
00024 typedef struct _mImageRenderer mImageRenderer;
00025
00026 #define mImageHeader(clsName)   \
00027         mStaticHeader(clsName)
00028
00033 struct _mImage
00034 {
00035         mImageHeader(mImage)
00036 };
00037
00038 #define mImageClassHeader(clsName, parentClass) \
00039         mStaticClassHeader(clsName, parentClass)
00040
00045 struct _mImageClass
00046 {
00047         mImageClassHeader(mImage, mStatic)
00048 };
00049
00050 #define mImageRendererHeader(clsName, parentClass) \
00051         mStaticRendererHeader(clsName, parentClass)
00052
00056 /* define the render of image static */
00057 struct _mImageRenderer {
00058         mImageRendererHeader(mImage, mStatic)
00059 };
00060
00066 MGNCS_EXPORT extern mImageClass g_stmImageCls;
00067
00073 /* property */
00074 enum mImageProp {
00082         NCSP_IMAGE_IMAGE = NCSP_STATIC_MAX + 1,
00090         NCSP_IMAGE_IMAGEFILE,
00098         NCSP_IMAGE_DRAWMODE,
00099         NCSP_IMAGE_MAX
00100 };
00101
00102 #define NCSS_IMAGE_SHIFT  NCSS_STATIC_SHIFT
00103
00108 enum enumImageNotify{
00109         NCSN_IMAGE_MAX = NCSN_STATIC_MAX + 1
00110 };
00111
00116 #ifdef __cplusplus
00117 }
00118 #endif  /* __cplusplus */
00119
00120 #endif /* _MGUI_NCSCTRL_STATIC_H */
00121
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mimagelabelpiece.h Source File

include » pieces

mimagelabelpiece.h

00001
00002 #ifndef _MGUI_NCSCTRL_IMAGELABELPIECE_H
00003 #define _MGUI_NCSCTRL_IMAGELABELPIECE_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif
00008
00009 typedef struct _mImageLabelPieceClass mImageLabelPieceClass;
00010 typedef struct _mImageLabelPiece mImageLabelPiece;
00011
00012 #define mImageLabelPieceClassHeader(clss, superCls) \
00013         mPairPieceClassHeader(clss, superCls)
00014
00015 struct _mImageLabelPieceClass
00016 {
00017         mImageLabelPieceClassHeader(mImageLabelPiece, mPairPiece)
00018 };
00019
00020 MGNCS_EXPORT extern mImageLabelPieceClass g_stmImageLabelPieceCls;
00021
00022 #define mImageLabelPieceHeader(clss) \
00023         mPairPieceHeader(clss)
00024
00025 struct _mImageLabelPiece
00026 {
00027         mImageLabelPieceHeader(mImageLabelPiece)
00028 };
00029
00030 enum mImageLabelPieceProp{
00031         NCSP_IMAGELABELPIECE_IMAGE_SIZE = IMAGELABELPIECE_PROP_BEGIN,
00032         NCSP_IMAGELABELPIECE_IMAGE_SIZETYPE
00033 };
00034
00035 #ifdef __cplusplus
00036 }
00037 #endif
00038
00039 #endif
00040
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mimagepiece.h Source File

include » pieces

mimagepiece.h

00001 #ifndef _MGNCS_IMAGEPIECE_H
00002 #define _MGNCS_IMAGEPIECE_H
00003
00004 #ifdef __cplusplus
00005 extern "C" {
00006 #endif
00007
00008 typedef struct _mImagePieceClass mImagePieceClass;
00009 typedef struct _mImagePiece mImagePiece;
00010
00011 #define mImagePieceClassHeader(clss, superCls) \
00012         mStaticPieceClassHeader(clss, superCls)
00013
00014 struct _mImagePieceClass
00015 {
00016         mImagePieceClassHeader(mImagePiece, mStaticPiece)
00017 };
00018
00019 MGNCS_EXPORT extern mImagePieceClass g_stmImagePieceCls;
00020
00021 #define mImagePieceHeader(clss) \
00022         mStaticPieceHeader(clss) \
00023         ImageDrawInfo img;
00024
00025 struct _mImagePiece
00026 {
00027         mImagePieceHeader(mImagePiece)
00028 };
00029
00030 #define mImagePiece_setAlign(self, align) ((self)->img.revert=((((self)->img.revert)&0xF0)|((align)&0xF)))
00031 #define mImagePiece_getAlign(self)   ((self)->img.revert&0xF)
00032
00033 #define mImagePiece_setVAlign(self, valign) ((self)->img.revert=(((self)->img.revert&0x0F)|(((valign)&0xF)<<4)))
00034 #define mImagePiece_getVAlign(self)  (((self)->img.revert&0xF0)>>4)
00035
00036 enum mImagePieceProps {
00037         NCSP_IMAGEPIECE_IMAGE = IMAGEPIECE_PROP_BEGIN,
00038         NCSP_IMAGEPIECE_ICON,
00039         NCSP_IMAGEPIECE_MYBITMAP,
00040         NCSP_IMAGEPIECE_IMAGEFILE,
00041         NCSP_IMAGEPIECE_ALIGN    = PIECECOMM_PROP_ALIGN,
00042         NCSP_IMAGEPIECE_VALIGN   = PIECECOMM_PROP_VALIGN,
00043         NCSP_IMAGEPIECE_DRAWMODE = PIECECOMM_PROP_DRAWMOD
00044 };
00045
00046
00047
00048 #ifdef __cplusplus
00049 }
00050 #endif
00051
00052 #endif
00053
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mime-wordsel.h Source File

include

mime-wordsel.h

00001
00002 #ifndef _MGUI_IM_WORDSEL_H
00003 #define _MGUI_IM_WORDSEL_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif
00008
00009 #define NCSCTRL_IMWORDSEL  NCSCLASSNAME("imwordsel")
00010
00011 typedef struct _mIMWordSelClass mIMWordSelClass;
00012 typedef struct _mIMWordSel      mIMWordSel;
00013 typedef struct _mIMWordSelRenderer mIMWordSelRenderer;
00014
00015 #define mIMWordSelClassHeader(clss, super)                  \
00016         mWidgetClassHeader(clss, super)                     \
00017         BOOL  (*nextPage)(clss*);                           \
00018         BOOL  (*prevPage)(clss*);                           \
00019         BOOL  (*selNext)(clss*);                            \
00020         BOOL  (*selPrev)(clss*);
00021
00022 #define mIMWordSelHeader(clss)                              \
00023         mWidgetHeader(clss)                                 \
00024         mIMIterator*  ime_it;                               \
00025     BOOL          isactive;                             \
00026         int           cur_sel;                              \
00027         int           page_start:16;                        \
00028         int           page_end:16;                          \
00029 //      CHARSET_CONVERTER * charset_converter;
00030
00031 struct _mIMWordSelClass {
00032         mIMWordSelClassHeader(mIMWordSel, mWidget)
00033 };
00034
00035 struct _mIMWordSel {
00036         mIMWordSelHeader(mIMWordSel)
00037 };
00038
00039 MGNCS_EXPORT extern mIMWordSelClass g_stmIMWordSelCls;
00040
00041 #define mIMWordSelRendererHeader(clss, super)         \
00042         mWidgetRendererHeader(clss, super)
00043
00044 struct _mIMWordSelRenderer {
00045         mIMWordSelRendererHeader(mIMWordSel, mWidget)
00046 };
00047
00048 enum mIMWordSelProp {
00049         NCSP_IMWS_ITERATOR  = NCSP_WIDGET_MAX + 1,
00050         NCSP_IMWS_CURSEL,
00051         NCSP_IMWS_CURWORD, //return mIMIterator*, whose current value is the word selected
00052         NCSP_IMWS_CURRAWWORD, //raw word, not convert it to the encoding need by application
00053 //      NCSP_IMWS_CHARSETCONVERTER,
00054         NCSP_IMWS_ISEMPTY,
00055     NCSP_IMWS_ISACTIVE,
00056         NCSP_IMWS_MAX
00057 };
00058
00059 #define mIMWordSel_isEmpty(self)  \
00060         (BOOL)(_c((mIMWordSel*)(self))->getProperty((mIMWordSel*)(self), NCSP_IMWS_ISEMPTY))
00061
00062 #define mIMWordSel_getCurSel(self)  \
00063         ((int)(NCS_GET_PROP(self, NCSP_IMWS_CURSEL)))
00064 #define mIMWordSel_setCurSel(self, int_v)  \
00065          NCS_SET_PROP(self, NCSP_IMWS_CURSEL,(DWORD)(int_v))
00066
00067 #define mIMWordSel_getCurWord(self)  \
00068         ((const char*)(NCS_GET_PROP(self, NCSP_IMWS_CURWORD)))
00069 #define mIMWordSel_setCurWord(self, const_char_v) \
00070         NCS_SET_PROP(self, NCSP_IMWS_CURWORD, (DWORD)(const_char_v))
00071
00072 enum mIMWordSelEvent {
00073         NCSN_IMWS_SELCHANGED = NCSN_WIDGET_MAX + 1,
00074         NCSN_IMWS_MAX
00075 };
00076
00077 #ifdef __cplusplus
00078 }
00079 #endif
00080
00081 #endif
00082
00083
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mime.h Source File

include

mime.h

00001
00002 #ifndef _MGUI_IME_H
00003 #define _MGUI_IME_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif
00008
00009 #define IME_STOP_MSG      1
00010 #define IME_CONTINUE_MSG  0
00011
00012 typedef int (*NCSCB_LEN_FIRST_CHAR)(const  unsigned char*, int len);
00013
00014 typedef int (*NCSCB_RETRIEVE_CHAR)(const char*);
00015 typedef struct _CHARSET_CONVERTER
00016 {
00017         //get a char who has a special code
00018         NCSCB_RETRIEVE_CHAR retrieve_char;
00019         void * conv_info;
00020     void * reserved;
00021 }CHARSET_CONVERTER;
00022
00023 MGNCS_EXPORT BOOL ncsIMInitCharsetConv(CHARSET_CONVERTER* conv, const char* from_charset, const char* to_charset, NCSCB_RETRIEVE_CHAR retrieve_char);
00024 MGNCS_EXPORT void ncsIMFreeCharsetConv(CHARSET_CONVERTER* conv);
00025 MGNCS_EXPORT unsigned int ncsIMCharsetConv(CHARSET_CONVERTER* conv, const char ** pwords);
00026 MGNCS_EXPORT char*  ncsIMConvertWord(CHARSET_CONVERTER* conv, const char* word, char* out, int len);
00027
00028 MGNCS_EXPORT NCSCB_LEN_FIRST_CHAR ncsIMGetFirstCharCallback(const char* encoding);
00029
00030 typedef struct _mIMEngineClass mIMEngineClass;
00031 typedef struct _mIMEngine      mIMEngine;
00032 typedef struct _mIMIteratorClass mIMIteratorClass;
00033 typedef struct _mIMIterator      mIMIterator;
00034
00035 #define NCS_IM_SCANCODE_ISDIGIT(s)   ((s) >= SCANCODE_1 && (s) <= SCANCODE_0)
00036 #define NCS_IM_SCANCODE_ISALPHA(s)  \
00037         (   ((s) >= SCANCODE_Q && (s) <= SCANCODE_P)   \
00038          || ((s) >= SCANCODE_A && (s) <= SCANCODE_L)   \
00039          || ((s) >= SCANCODE_Z && (s) <= SCANCODE_M)   \
00040         )
00041
00042 enum mIMIteratorProp{
00043     NCSP_IMEIT_CHARTYPE
00044 };
00045
00046 #define mIMIteratorClassHeader(clss, super)              \
00047         mObjectClassHeader(clss, super)                  \
00048         PUBLIC void  (*empty)(clss*);                    \
00049         PUBLIC int   (*count)(clss*);                    \
00050         PUBLIC int   (*next)(clss*);                     \
00051         PUBLIC int   (*prev)(clss*);                     \
00052         PUBLIC int   (*locate)(clss*,int off, int type); \
00053         PUBLIC int   (*curIndex)(clss*);                 \
00054     PUBLIC DWORD (*setProperty)(clss*, int id, DWORD valude);   \
00055     PUBLIC DWORD (*getProperty)(clss*, int id);   \
00056         PUBLIC const char*(*word)(clss*);
00057
00058 #define mIMIteratorHeader(clss)                          \
00059         mObjectHeader(clss)                              \
00060         CHARSET_CONVERTER *charset_converter;
00061
00062
00063 struct _mIMIteratorClass {
00064         mIMIteratorClassHeader(mIMIterator, mObject)
00065 };
00066
00067 struct _mIMIterator {
00068         mIMIteratorHeader(mIMIterator)
00069 };
00070
00071 MGNCS_EXPORT extern mIMIteratorClass g_stmIMIteratorCls;
00072
00073 #define MAX_IME_NAME_LEN  16
00074 #define mIMEngineClassHeader(clss, super)                      \
00075         mObjectClassHeader(clss, super)                        \
00076     const char*  (*imeName)(clss*);                      \
00077         mIMEngine *  (*create)(const char* pdict, DWORD add_data);             \
00078         const char*  (*getEncoding)(clss*);                    \
00079         PROTECTED NCSCB_RETRIEVE_CHAR (*getRetrieveChar)(clss*);\
00080         mIMIterator* (*newIterator)(clss*);                    \
00081         mIMIterator* (*newAssocIterator)(clss*);               \
00082         /* find words */                                       \
00083         BOOL         (*findWords)(clss*, mIMIterator* it, const char* input, int start);     \
00084         BOOL         (*findAssociate)(clss*, mIMIterator* it, const char* input);
00085
00086 #define mIMEngineHeader(clss)                                  \
00087         mObjectHeader(clss)
00088
00089 struct _mIMEngineClass{
00090         mIMEngineClassHeader(mIMEngine, mObject)
00091 };
00092
00093 struct _mIMEngine {
00094         mIMEngineHeader(mIMEngine)
00095 };
00096
00097 MGNCS_EXPORT extern mIMEngineClass g_stmIMEngineCls;
00098
00099 typedef struct _mIMEClass mIMEClass;
00100 typedef struct _mIME      mIME;
00101
00102 typedef struct _mIMManagerClass mIMManagerClass;
00103 typedef struct _mIMManager      mIMManager;
00104
00105
00106 #define NCS_MAX_INPUT            128
00107 #define NCS_IME_UPDATE_KEY       0x01
00108 #define NCS_IME_UPDATE_WORDS     0x02
00109 #define NCS_IME_UPDATE_FEEDBACK  0x04
00110 #define NCS_IME_UPDATE_CURSOR    0x08
00111 #define NCS_IME_UPDATE_ALL       0xFFFF
00112
00113 #define NCS_IMM_BEGIN            (MSG_USER + 100)
00114 #define NCS_IMM_UPDATE           (NCS_IMM_BEGIN + 1)
00115 // int update_code = wParam
00116 #define NCS_IMM_GETSELWORD       (NCS_IMM_BEGIN + 2)
00117 // BOOL braw = wParam
00118 #define NCS_IMM_ISSELWORDCTRLACTIVE       (NCS_IMM_BEGIN + 3)
00119 #define NCS_IMM_SETSELWORDACTIVE       (NCS_IMM_BEGIN + 4)
00120
00121 #define mIMEClassHeader(clss, super)                            \
00122         mObjectClassHeader(clss, super)                         \
00123                        \
00124         PROTECTED  BOOL (*showIME)(clss*);                      \
00125         PROTECTED  void (*hideIME)(clss*);                      \
00126         PROTECTED  void (*update)(clss*, DWORD flfags);         \
00127         PROTECTED  const char* (*getSelWord)(clss*, BOOL braw); \
00128         PROTECTED  DWORD (*getIMStatus)(clss*, int);            \
00129         PROTECTED  BOOL  (*setIMStatus)(clss*,int, DWORD);      \
00130         PROTECTED  BOOL  (*onCaretPos)(clss*, int,int);         \
00131         PROTECTED  BOOL  (*findWords)(clss*, const char* input, int start, int len); \
00132         PROTECTED  BOOL  (*findAssociate)(clss*, const char* words);                 \
00133         PROTECTED  BOOL  (*emptyKey)(clss*);                    \
00134         PROTECTED  BOOL  (*setEncoding)(clss*, const char*);    \
00135         PROTECTED BOOL (*addChar)(clss*, int ch);               \
00136         PROTECTED BOOL (*delChar)(clss*,BOOL bback);            \
00137         PROTECTED BOOL (*setInsert)(clss*, int pos, int type);  \
00138         PROTECTED BOOL (*clearInput)(clss*);                    \
00139         PROTECTED int  (*onChar)(clss*, int ch,DWORD keyflags); \
00140         PROTECTED int  (*onKeyDown)(clss*,int scancode, DWORD keyflags);  \
00141         PUBLIC void (*setIMEngine)(clss*, mIMEngine*);          \
00142         PUBLIC void (*empty)(clss*, BOOL bUpdate);
00143
00144
00145 #define mIMEHeader(clss)                                        \
00146         mObjectHeader(clss)                                     \
00147         mIME* next;                                             \
00148         char  input[NCS_MAX_INPUT];                             \
00149         int   len;                                              \
00150         int   start:16;                                         \
00151         int   insert:16;                                        \
00152         mIMManager  *ime_manager;                               \
00153         mIMEngine   *ime_engine;                                \
00154         mIMIterator *key_it;                                    \
00155         mIMIterator *assoc_it;                                  \
00156         CHARSET_CONVERTER charset_conv;                         \
00157         HWND         hwnd_view;  \
00158         WNDPROC      old_view_proc;
00159
00160 struct _mIMEClass {
00161         mIMEClassHeader(mIME, mObject)
00162 };
00163
00164 struct _mIME {
00165         mIMEHeader(mIME)
00166 };
00167
00168 MGNCS_EXPORT extern mIMEClass g_stmIMECls;
00169
00170 #define mIME_sendWords(ime)  (_c(ime->ime_manager)->sendWords(ime->ime_manager))
00171 #define mIME_sendKeys(ime)   (_c(ime->ime_manager)->sendKeys(ime->ime_manager))
00172
00173 #define mIME_FromView(hwnd)  ((mIME*)GetWindowAdditionalData(hwnd))
00174 MGNCS_EXPORT void mIME_attach(mIME *ime, HWND hwnd);
00175
00176 MGNCS_EXPORT void mIME_passMessage(mIME* ime, int message, WPARAM wParam, LPARAM lParam);
00177 #define mIMView_passMessage(hwnd, message, wParam, lParam) \
00178         mIME_passMessage(mIME_FromView(hwnd), (message), (wParam), (lParam))
00179
00180 #define mIMManagerClassHeader(clss, super)                     \
00181         mObjectClassHeader(clss, super)                        \
00182         PROTECTED int (*procIMMsg)(clss*,int,WPARAM,LPARAM,int*); \
00183         PROTECTED BOOL (*nextIME)(clss*);                      \
00184         PROTECTED BOOL (*setIME)(clss*, const char*);          \
00185         PUBLIC BOOL (*addIME)(clss*, mIME *ime);               \
00186         PROTECTED BOOL (*sendWords)(clss*);                    \
00187         PROTECTED BOOL (*sendKeys)(clss*);                     \
00188         PUBLIC void (*setEncoding)(clss*, const char*);
00189
00190 #define mIMManagerHeader(clss)                                 \
00191         mObjectHeader(clss)                                    \
00192         NCSCB_LEN_FIRST_CHAR len_first_char;                   \
00193         HWND   hwnd;                                           \
00194         HWND   hwnd_target;                                    \
00195         mIME * header;                                         \
00196         mIME * cur_ime;                                        \
00197         DWORD  flags;                                          \
00198         int    ime_x:16;                                       \
00199         int    ime_y:16;
00200
00201 #define NCSF_IMM_DISABLE  0x01
00202 #define NCSF_IMM_ACTIVED  0x02
00203 #define NCSF_IMM_NULLIME  0x04
00204 #define NCSF_IMM_SETTING_IME 0x80000000
00205
00206 enum NCSIMMEvent {
00207     NCSN_IMM_IMEOPEN = 5678,
00208     NCSN_IMM_IMECHANGED,
00209     NCSN_IMM_IMECLOSE,
00210 };
00211
00212 struct _mIMManagerClass {
00213         mIMManagerClassHeader(mIMManager, mObject)
00214 };
00215 struct _mIMManager {
00216         mIMManagerHeader(mIMManager)
00217 };
00218
00219 MGNCS_EXPORT extern mIMManagerClass g_stmIMManagerCls;
00220
00225 #define NCS_DIGIT_MAX_FINDS   32
00226
00227 #define mDigitIteratorClassHeader(clss, super)                 \
00228         mIMIteratorClassHeader(clss, super)                    \
00229         PUBLIC mIMIterator* (*subIterator)(clss*);
00231 #define mDigitIteratorHeader(clss)                             \
00232         mIMIteratorHeader(clss)                                \
00233         int           count;                                   \
00234         int           cur;                                     \
00235         mIMIterator * sub_it;                                  \
00236         const char**  words;                                   \
00237         int           finds[NCS_DIGIT_MAX_FINDS][2]; /*begin and end */
00238
00239 DECLARE_CLASS(mDigitIterator, mIMIterator)
00240
00241 #define mDigitIMEClassHeader(clss, super)                      \
00242         mIMEClassHeader(clss, super)
00243
00244 #define mDigitIMEHeader(clss)                                  \
00245         mIMEHeader(clss)                                       \
00246         CHARSET_CONVERTER sub_conv;
00247
00248 DECLARE_CLASS(mDigitIME, mIME)
00249
00250 // digital engine
00251 #define mDigitEngineClassHeader(clss, super)                 \
00252         mIMEngineClassHeader(clss, super)                    \
00253         PROTECTED BOOL (*findRange)(clss*,                   \
00254                         const char* input,                   \
00255                         int start, int len,                  \
00256                         int *pbegin, int *pend);
00257
00258 #define mDigitEngineHeader(clss)                             \
00259         mIMEngineHeader(clss)                                \
00260         mIMEngine*     sub_engine;
00261
00262 DECLARE_CLASS(mDigitEngine, mIMEngine)
00263
00264
00265 //digitpti
00266 #define mDigitPtiEngineClassHeader(clss, super)              \
00267         mDigitEngineClassHeader(clss, super)
00268
00269 #define mDigitPtiEngineHeader(clss)                          \
00270         mDigitEngineHeader(clss)    \
00271     int case_type;
00272
00273 DECLARE_CLASS(mDigitPtiEngine, mDigitEngine)
00274
00275 #define mDigitPtiIteratorClassHeader(clss, super)           \
00276         mDigitIteratorClassHeader(clss, super)
00277
00278 #define mDigitPtiIteratorHeader(clss)                       \
00279         mDigitIteratorHeader(clss)                          \
00280         char* letters; //only for signle letters, for example "a\0b\0\c\0"
00281
00282 DECLARE_CLASS(mDigitPtiIterator, mDigitIterator)
00283
00284
00285 //digit pinyin
00286
00287 #define mDigitPyEngineClassHeader(clss, super)             \
00288         mDigitEngineClassHeader(clss, super)
00289
00290 #define mDigitPyEngineHeader(clss)                          \
00291         mDigitEngineHeader(clss)                            \
00292         int               py_count;                         \
00293         unsigned int *    keys;                             \
00294         const char**      pinyins;
00295
00296 DECLARE_CLASS(mDigitPyEngine, mDigitEngine)
00297
00298 #define mDigitPyIteratorClassHeader(clss, super)           \
00299         mDigitIteratorClassHeader(clss, super)
00300
00301
00302 #define mDigitPyIteratorHeader(clss)                       \
00303         mDigitIteratorHeader(clss)                       \
00304         mIMEngine*     py_engine;
00305
00306 DECLARE_CLASS(mDigitPyIterator, mDigitIterator)
00307
00308
00309
00310
00311
00312 // pti engine
00313 #define mPtiIteratorClassHeader(clss, super)                  \
00314         mIMIteratorClassHeader(clss, super)
00315
00316 #define mPtiIteratorHeader(clss)                              \
00317         mIMIteratorHeader(clss)                               \
00318         int          cur;                                     \
00319         const char** words;                                   \
00320         int          count;                                   \
00321         int          begin;                                   \
00322     char upper_buffer[128];                             \
00323     int char_type;                                      \
00324         const char*  lead_letter;
00325
00326 DECLARE_CLASS(mPtiIterator, mIMIterator)
00327
00328 #define mPtiEngineClassHeader(clss, super)                    \
00329         mIMEngineClassHeader(clss, super)
00330
00331 #define MGPTI_2ND_HASH_TABLE_SIZE   100
00332
00333 enum {
00334     MGPTI_LOWER = 100,
00335     MGPTI_UPPER
00336 };
00337
00338 typedef struct _MGPTI_2ND_HASH_BUCKET {
00339         int nr_words;
00340         int* word_indices;
00341 } MGPTI_2ND_HASH_BUCKET;
00342
00343 typedef struct _MGPTI_1ST_HASH_BUCKET {
00344         int indices [26];
00345         MGPTI_2ND_HASH_BUCKET* buckets;
00346 } MGPTI_1ST_HASH_BUCKET;
00347
00348
00349 #define mPtiEngineHeader(clss)                                \
00350         mIMEngineHeader(clss)                                 \
00351         char  **sorted_words;                                 \
00352         int     max_index;                                    \
00353         MGPTI_1ST_HASH_BUCKET *buckets[26];
00354
00355
00356 DECLARE_CLASS(mPtiEngine, mIMEngine)
00357
00358 MGNCS_EXPORT BOOL mPtiEngine_findWordRange(mPtiEngine* self, int* pbegin, int* pend, const char* input, int start, int len);
00359
00360
00362 // pinyin engine
00363 #define PINYIN_MAGIC_NUMBER          "CCEGB"
00364 #define PINYIN_ENAME_LENGTH          24
00365 #define PINYIN_CNAME_LENGTH          16
00366 #define PINYIN_WORD_LENGTH           16
00367 #define PINYIN_SELECT_KEY_LENGTH     16
00368 #define PINYIN_KEY_LENGTH            16
00369 #define PINYIN_SEL_LENGTH            58
00370
00371
00372 typedef struct {
00373         unsigned long key1;
00374         unsigned long key2;
00375         unsigned short word_offset_idx;    //pharse_offset table index
00376         unsigned short frequency;
00377 }NCS_PINYIN_ITEM;
00378
00379 typedef struct {
00380         unsigned int off_begin; //begin offset
00381         unsigned int off_end;   //end offset
00382 }NCS_PINYIN_PHOFFSET;
00383
00384 typedef struct {
00385         char magic_number[sizeof(PINYIN_MAGIC_NUMBER)];
00386         char ename[PINYIN_ENAME_LENGTH];                  //ascii name
00387         char cname[PINYIN_CNAME_LENGTH];                  //promt
00388         char selkey[PINYIN_SELECT_KEY_LENGTH];            //select keys
00389
00390         char last_full;
00391         int  totalKey;
00392         int  maxPress;
00393         int  maxDupSel;
00394         int  totalChar;
00395
00396         unsigned char  keyMap[128];
00397         unsigned char  keyName[64];
00398         unsigned short keyIndex[64];
00399
00400         int    wordNum;
00401         char*  wordFile;
00402         char*  assocFile;
00403         NCS_PINYIN_ITEM * item;
00404 }NCS_PINYIN_IME_TABLE;
00405
00406
00407 #define mPinyinEngineClassHeader(clss, super)                 \
00408         mIMEngineClassHeader(clss, super)
00409
00410 #define mPinyinEngineHeader(clss)                             \
00411         mIMEngineHeader(clss)                                 \
00412         NCS_PINYIN_IME_TABLE * ime_table;
00413
00414 DECLARE_CLASS(mPinyinEngine, mIMEngine)
00415
00416 #define PINYIN_MAX_WORD    64
00417 #define PINYIN_MAX_WORDLEN 64
00418 #define PINYIN_INPUT_MAX     32
00419 typedef struct {
00420         union {
00421                 char chars[4];
00422                 const char* word;
00423         }word;
00424         int         len;
00425 }NCS_PINYIN_WORD_INFO;
00426
00427
00428 #define mPinyinIteratorClassHeader(clss, super)               \
00429         mIMIteratorClassHeader(clss, super)
00430
00431 #define mPinyinIteratorHeader(clss)                           \
00432         mIMIteratorHeader(clss)                               \
00433         int           count;                                  \
00434         int           cur;                                    \
00435         unsigned int charIndex[PINYIN_INPUT_MAX];             \
00436         unsigned int  startKey;                               \
00437         unsigned int  endKey;                                 \
00438         unsigned long matched_key1;                           \
00439         unsigned long matched_key2;                           \
00440         NCS_PINYIN_WORD_INFO words[PINYIN_MAX_WORD];          \
00441         char          word[PINYIN_MAX_WORDLEN];               \
00442         BOOL          isAssociate;
00443
00444 DECLARE_CLASS(mPinyinIterator, mIMIterator)
00445
00446 #if MGUI_BYTEORDER == MGUI_BIG_ENDIAN
00447 #define ARCH_SWAP16(v16)  ArchSwap16(v16)
00448 #define ARCH_SWAP32(v32)  ArchSwap32(v32)
00449 #else
00450 #define ARCH_SWAP16(v16)  (v16)
00451 #define ARCH_SWAP32(v32)  (v32)
00452 #endif
00453
00454 #ifdef __cplusplus
00455 }
00456 #endif
00457
00458 #endif
00459
00460
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: minvisible-component.h Source File

include

minvisible-component.h

Go to the documentation of this file.
00001
00016 #ifndef _MGUI_NCSCTRL_INVISIBLECOMP_H
00017 #define _MGUI_NCSCTRL_INVISIBLECOMP_H
00018
00019 #ifdef __cplusplus
00020 extern "C"{
00021 #endif
00022
00027 typedef struct _mInvsbCompClass mInvsbCompClass;
00028 typedef struct _mInvsbComp mInvsbComp;
00029
00030
00031 #define mInvsbCompClassHeader(clss, superCls) \
00032         mComponentClassHeader(clss, superCls)
00033
00042 struct _mInvsbCompClass {
00043         mInvsbCompClassHeader(mInvsbComp, mComponent)
00044 };
00045
00050 MGNCS_EXPORT extern mInvsbCompClass g_stmInvsbCompCls; //Class(mInvsbComp);
00051
00052
00053 #define mInvsbCompHeader(clss) \
00054         mComponentHeader(clss) \
00055         int id; \
00056         mComponent* parent, *prev, *next;
00057
00069 struct _mInvsbComp {
00070         mInvsbCompHeader(mInvsbComp)
00071 };
00072
00077 enum ncsInvsbCompProp {
00078         NCSP_IVCMPT_MAX  = 0
00079 };
00080
00083
00084
00085
00101 typedef struct _NCS_INVSB_CREATE_INFO {
00105         mComponent        * parent;
00109         int                 id;
00115         NCS_PROP_ENTRY    * props;
00121         NCS_EVENT_HANDLER * handlers;
00122
00126         DWORD               user_data;
00127 }NCS_INVSB_CREATE_INFO;
00128
00144 MGNCS_EXPORT mInvsbComp * ncsCreateInvsbComp(const char* class_name, mComponent* parent, int id, NCS_PROP_ENTRY *props, NCS_EVENT_HANDLER * handlers, DWORD user_data);
00145
00157 MGNCS_EXPORT mInvsbComp * ncsCreateInvsbCompIndirect(const char* class_name, NCS_INVSB_CREATE_INFO *create_info);
00158
00159
00164 #ifdef __cplusplus
00165 }
00166 #endif
00167
00168
00169 #endif
00170
00171
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mitem.h Source File

include

mitem.h

Go to the documentation of this file.
00001
00026 #ifndef _MGUI_WIDGET_ITEM_H
00027 #define _MGUI_WIDGET_ITEM_H
00028
00029
00030 #ifdef __cplusplus
00031 extern "C" {
00032 #endif  /* __cplusplus */
00033
00039 typedef struct _mItem mItem;
00040 typedef struct _mItemClass mItemClass;
00041
00046 typedef GHANDLE HITEM;
00047
00052 #define hEditor HWND
00053
00058 #define NCSF_ITEM_SHIFT             4
00059
00064 #define NCSF_ITEM_MASK              0xFFFF
00065
00070 #define NCSF_ITEM_NORMAL            0x0000
00071
00076 #define NCSF_ITEM_SELECTED          0x0001
00077
00082 #define NCSF_ITEM_DISABLED          0x0002
00083
00088 #define NCSF_ITEM_USEBITMAP         0x0004
00089
00094 #define NCSF_ITEM_USEICON           0x0008
00095
00100 #define NCSF_ITEM_IMAGEMASK         (NCSF_ITEM_USEBITMAP | NCSF_ITEM_USEICON)
00101
00102 #define mItemHeader(className)  \
00103         mObjectHeader(className)    \
00104     list_t  list;               \
00105     list_t  selList;            \
00106     DWORD   flags;              \
00107     char    *string;            \
00108     DWORD   image;              \
00109     hEditor editor;             \
00110     int     height;             \
00111     DWORD   addData;
00112
00150 struct _mItem
00151 {
00152         mItemHeader(mItem)
00153 };
00154
00155 #define mItemClassHeader(clsName, superCls)             \
00156         mObjectClassHeader(clsName, superCls)               \
00157         BOOL (*setProperty)(clsName*, int id, DWORD value); \
00158         DWORD (*getProperty)(clsName*, int id);             \
00159     BOOL (*isSelectedItem)(clsName*);                   \
00160     BOOL (*isEnabledItem)(clsName*);                    \
00161     void (*setItemEditor)(clsName*, hEditor editor);    \
00162     hEditor (*getItemEditor)(clsName*);                 \
00163     void (*setItemAddData)(clsName*, DWORD addData);    \
00164     DWORD (*getItemAddData)(clsName*);                  \
00165     void (*setItemImage)(clsName*, DWORD image);        \
00166     DWORD (*getItemImage)(clsName*);                    \
00167     void (*setItemFlags)(clsName*, DWORD flags);        \
00168     DWORD (*getItemFlags)(clsName*);                    \
00169     BOOL (*setItemHeight)(clsName*, int height);        \
00170     int (*getItemHeight)(clsName*);                     \
00171     BOOL (*setItemString)(clsName*, const char* string);\
00172     char* (*getItemString)(clsName*);
00173
00245 struct _mItemClass
00246 {
00247         mItemClassHeader(mItem, mObject)
00248 };
00249
00254 enum mItemProp
00255 {
00259     NCSP_ITEM_HEIGHT = 1,
00260
00264     NCSP_ITEM_FLAGS,
00265
00269         NCSP_ITEM_MAX,
00270 };
00271
00278 MGNCS_EXPORT extern mItemClass g_stmItemCls;
00279
00282 #ifdef __cplusplus
00283 }
00284 #endif  /* __cplusplus */
00285
00286 #endif /* _MGUI_WIDGET_ITEM_H */
00287
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mitem_manager.h Source File

include

mitem_manager.h

Go to the documentation of this file.
00001
00026 #ifndef _MGUI_CTRL_ITEMMANAGER_H
00027 #define _MGUI_CTRL_ITEMMANAGER_H
00028
00029 #ifdef __cplusplus
00030 extern "C" {
00031 #endif  /* __cplusplus */
00032
00037 typedef struct _mItemManager mItemManager;
00038 typedef struct _mItemManagerClass mItemManagerClass;
00039 typedef struct _mItemManagerRenderer mItemManagerRenderer;
00040
00046 typedef int (*NCS_CB_CMPITEM) (mItemManager *manager, HITEM hItem1, HITEM hItem2);
00047
00058 typedef int (*NCS_CB_CMPSTR) (const char* s1, const char* s2, size_t n);
00059
00064 #define NCSF_ITMMNG_AUTOSORT        (0x01<<NCSF_ITEM_SHIFT)
00065
00070 #define NCSF_ITMMNG_FROZEN          (0x02<<NCSF_ITEM_SHIFT)
00071
00076 #define NCSF_ITMMNG_SHIFT           (NCSF_ITEM_SHIFT+2)
00077
00078
00079 #define mItemManagerHeader(className)   \
00080     mItemHeader(className)              \
00081     NCS_CB_CMPITEM  itemCmp;            \
00082     mWidget *obj;                       \
00083     int     count;                      \
00084     int     totalHeight;                \
00085     HITEM   pItemHilighted;             \
00086     list_t  queue;                      \
00087     list_t  selQueue;                   \
00088     NCS_CB_CMPSTR  strCmp;
00089
00119 struct _mItemManager
00120 {
00121         mItemManagerHeader(mItemManager)
00122 };
00123
00124 #define mItemManagerClassHeader(clsName, superCls) \
00125         mItemClassHeader(clsName, superCls)            \
00126     NCS_CB_CMPITEM (*setItemCmpFunc)(clsName*, NCS_CB_CMPITEM func);        \
00127     int (*moveItem)(clsName*, mItem *curItem, int count, mItem* prevItem);  \
00128     int (*insertItem)(clsName*, HITEM hItem, HITEM prev, HITEM next, int index, int *pos);  \
00129     HITEM (*createItem)(clsName*, HITEM prev, HITEM next, int index, int *pos); \
00130     int (*inItem)(clsName*, int mouseX, int mouseY, HITEM *pRet, POINT *pt);    \
00131     NCS_CB_CMPSTR (*setStrCmpFunc)(clsName*, NCS_CB_CMPSTR func);               \
00132     NCS_CB_CMPSTR (*getStrCmpFunc)(clsName*);                   \
00133     int (*getItemYPos)(clsName*, HITEM hItem);                  \
00134     void (*setAutoSortItem) (clsName*, BOOL sort);              \
00135     int (*getTotalHeight)(clsName*);                            \
00136     int (*adjustItemsHeight)(clsName*, int diff);               \
00137     BOOL (*freeze)(clsName*, BOOL lock);                        \
00138     BOOL (*isFrozen)(clsName*);                                 \
00139     HITEM (*getFirstItem)(clsName*);                            \
00140     list_t* (*getQueue)(clsName*);                              \
00141     HITEM (*getListEntry)(list_t* entry);                       \
00142     int (*isEmpty)(clsName*);                                   \
00143     int (*removeItem)(clsName*, HITEM hItem);                   \
00144     int (*sortItems)(clsName*, NCS_CB_CMPITEM pfn);             \
00145     BOOL (*removeAll)(clsName*);                                \
00146     int (*indexOf)(clsName*, HITEM hItem);                      \
00147     int (*setHeight)(clsName*, HITEM hItem, int height);        \
00148     int (*getHeight)(clsName*, HITEM hItem);                    \
00149     HITEM (*getItem)(clsName*, int index);                      \
00150     HITEM (*getNext)(clsName*, HITEM hItem);                    \
00151     HITEM (*getPrev)(clsName*, HITEM hItem);                    \
00152     BOOL (*isSelected)(clsName*, HITEM hItem);                  \
00153     BOOL (*isEnabled)(clsName*, HITEM hItem);                   \
00154     BOOL (*enable)(clsName*, HITEM hItem, BOOL enable);         \
00155     void (*selectAll)(clsName*);                                \
00156     void (*deselectAll)(clsName*);                              \
00157     BOOL (*select)(clsName*, HITEM hItem, BOOL sel);            \
00158     HITEM (*hilight)(clsName*, HITEM hItem);                    \
00159     HITEM (*getHilight)(clsName*);                              \
00160     BOOL (*isHilight)(clsName*, HITEM hItem);                   \
00161     int (*getItemCount)(clsName*);                              \
00162     void (*setAddData)(clsName*, HITEM hItem, DWORD addData);   \
00163     void (*setImage)(clsName*, HITEM hItem, DWORD image);       \
00164     DWORD (*getAddData)(clsName*, HITEM hItem);                 \
00165     DWORD (*getImage)(clsName*, HITEM hItem);                   \
00166     void (*setFlags)(clsName*, HITEM hItem, DWORD flags);       \
00167     DWORD (*getFlags)(clsName*, HITEM hItem);                   \
00168     BOOL (*setText)(clsName*, HITEM hItem, const char* text);   \
00169     const char* (*getText)(clsName*, HITEM hItem);              \
00170     int (*getTextLen)(clsName*, HITEM hItem);                   \
00171     BOOL (*getSelection)(clsName*, HITEM *pRet, int count);     \
00172     int (*getSelectionCount)(clsName*);
00173
00387 struct _mItemManagerClass
00388 {
00389         mItemManagerClassHeader(mItemManager, mItem)
00390 };
00391
00398 MGNCS_EXPORT extern mItemManagerClass g_stmItemManagerCls;
00399
00404 enum mItemManagerProp
00405 {
00409     NCSP_ITMMNG_FLAGS = NCSP_ITEM_FLAGS,
00410
00414     NCSP_ITMMNG_ITEMCOUNT = NCSP_ITEM_MAX + 1,
00415
00419     NCSP_ITMMNG_TOTALHEIGHT,
00420
00424         NCSP_ITMMNG_MAX,
00425 };
00428 #ifdef __cplusplus
00429 }
00430 #endif  /* __cplusplus */
00431
00432 #endif /* _MGUI_CTRL_ITEMMANAGER_H */
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mitemview.h Source File

include

mitemview.h

Go to the documentation of this file.
00001
00026 #ifndef _MGUI_CTRL_ITEMVIEW_H
00027 #define _MGUI_CTRL_ITEMVIEW_H
00028
00029 #ifdef __cplusplus
00030 extern "C" {
00031 #endif  /* __cplusplus */
00032
00043 #define NCSCTRL_ITEMVIEW   NCSCLASSNAME("itemview")
00044
00045 typedef struct _mItemView mItemView;
00046 typedef struct _mItemViewClass mItemViewClass;
00047 typedef struct _mItemViewRenderer mItemViewRenderer;
00048
00053 typedef int  (*NCS_CB_INITITEM)(mItemView *self, HITEM hItem);
00054
00059 typedef void (*NCS_CB_DSTRITEM)(mItemView *self, HITEM hItem);
00060
00065 typedef void (*NCS_CB_DRAWITEM)(mItemView *self, HITEM hItem, HDC hdc, RECT *rcDraw);
00066
00071 typedef struct _NCS_CB_ITEMOPS
00072 {
00076     NCS_CB_INITITEM     initItem;
00080     NCS_CB_DSTRITEM  destroyItem;
00084     NCS_CB_DRAWITEM     drawItem;
00085 } NCS_CB_ITEMOPS;
00086
00091 #define NCSS_ITEMV_AUTOSORT    (0x0002<<NCSS_SWGT_SHIFT)
00092
00097 #define NCSS_ITEMV_LOOP        (0x0004<<NCSS_SWGT_SHIFT)
00098
00103 #define NCSS_ITEMV_SINGLE      (0x0000<<NCSS_SWGT_SHIFT)
00104
00109 #define NCSS_ITEMV_MULTIPLE    (0x0008<<NCSS_SWGT_SHIFT)
00110
00115 #define NCSS_ITEMV_SHIFT   (NCSS_SWGT_SHIFT+4)
00116
00117 #define pItemList (self->itemList)
00118
00119 #define mItemViewHeader(className)  \
00120         mScrollWidgetHeader(className)  \
00121     NCS_CB_ITEMOPS   itemOps;        \
00122     mItemManager    *itemList;      \
00123     int             defItemHeight;
00124
00140 struct _mItemView
00141 {
00142         mItemViewHeader(mItemView)
00143 };
00144
00145 #define mItemViewClassHeader(clsName, parentClass)                          \
00146         mScrollWidgetClassHeader(clsName, parentClass)                          \
00147         int (*onRButtonDown)(clsName*, int x, int y, DWORD keyFlags);           \
00148         int (*onRButtonUp)(clsName*, int x, int y, DWORD keyFlags);             \
00149         int (*onLButtonDBClk)(clsName*, int x, int y, DWORD keyFlags);          \
00150     NCS_CB_DRAWITEM (*setItemDraw)(clsName*, NCS_CB_DRAWITEM func);         \
00151     NCS_CB_INITITEM (*setItemInit)(clsName*, NCS_CB_INITITEM func);         \
00152     NCS_CB_DSTRITEM (*setItemDestroy)(clsName*,                             \
00153             NCS_CB_DSTRITEM func);                                          \
00154     \
00155     NCS_CB_CMPITEM (*setItemCmpFunc)(clsName*, NCS_CB_CMPITEM func);        \
00156     HWND (*createItem)(clsName*, HITEM prev, HITEM next, int index,         \
00157             int height, const char* text, DWORD addData, int *pos, BOOL adjust);              \
00158     int (*insertItem)(clsName*, HITEM hItem, HITEM prev, HITEM next,        \
00159             int index, int *pos);                                           \
00160     int (*removeItem)(clsName*, HITEM hItem);                               \
00161     int (*inItem)(clsName*, int mouseX, int mouseY, HITEM *pRet, POINT *pt);\
00162     NCS_CB_CMPSTR (*setStrCmpFunc)(clsName*, NCS_CB_CMPSTR func);           \
00163     NCS_CB_CMPSTR (*getStrCmpFunc)(clsName*);                               \
00164     void (*setAutoSortItem)(clsName*, BOOL sort);                           \
00165     int (*getTotalHeight)(clsName*);                                        \
00166     int (*adjustItemsHeight)(clsName*, int diff);                           \
00167     void (*freeze)(clsName*, BOOL lock);                                    \
00168     BOOL (*isFrozen)(clsName*);                                             \
00169     list_t* (*getQueue)(clsName*);                                          \
00170     HITEM (*getListEntry)(clsName*, list_t* entry);                         \
00171     HITEM (*getFirstItem)(clsName*);                                        \
00172     int (*isEmpty)(clsName*);                                               \
00173     void (*sortItems)(clsName*, NCS_CB_CMPITEM func);                       \
00174     BOOL (*removeAll)(clsName*);                                            \
00175     int (*indexOf)(clsName*, HITEM hItem);                                  \
00176     int (*setItemHeight)(clsName*, HITEM hItem, int height);                \
00177     int (*getItemHeight)(clsName*, HITEM hItem);                            \
00178     HITEM (*getNext)(clsName*, HITEM hItem);                                \
00179     HITEM (*getPrev)(clsName*, HITEM hItem);                                \
00180     HITEM (*getItem)(clsName*, int index);                                  \
00181     BOOL (*isSelected)(clsName*, HITEM hItem);                              \
00182     BOOL (*isEnabled)(clsName*, HITEM hItem);                               \
00183     BOOL (*enable)(clsName*, HITEM hItem, BOOL enable);                     \
00184     void (*selectAll)(clsName*);                                            \
00185     void (*deselectAll)(clsName*);                                          \
00186     int (*hilight)(clsName*, HITEM hItem);                                  \
00187     HITEM (*getHilight)(clsName*);                                          \
00188     BOOL (*isHilight)(clsName*, HITEM hItem);                               \
00189     int (*getItemCount)(clsName*);                                          \
00190     DWORD (*getAddData)(clsName*, HITEM hItem);                             \
00191     void (*setAddData)(clsName*, HITEM hItem, DWORD addData);               \
00192     void (*setImage)(clsName*, HITEM hItem, DWORD image);                   \
00193     DWORD (*getImage)(clsName*, HITEM hItem);                               \
00194     void (*setFlags)(clsName*, HITEM hItem, DWORD flags);                   \
00195     DWORD (*getFlags)(clsName*, HITEM hItem);                               \
00196     BOOL (*setText)(clsName*, HITEM hItem, const char* text);               \
00197     const char* (*getText)(clsName*, HITEM hItem);                          \
00198     int (*getTextLen)(clsName*, HITEM hItem);                               \
00199     int (*getSelectionCount)(clsName*);                                     \
00200     BOOL (*getSelection)(clsName*, HITEM *pRet, int count);                 \
00201     \
00202     BOOL (*select)(clsName*, HITEM hItem);                                  \
00203     BOOL (*deselect)(clsName*, HITEM hItem);                                \
00204     BOOL (*setTextByIdx)(clsName*, int index, const char* text);            \
00205     const char* (*getTextByIdx)(clsName*, int index);                       \
00206     \
00207     int (*getFirstVisItem)(clsName*);                                       \
00208     void (*resetContent)(clsName*);                                         \
00209     int (*getRect)(clsName*, HITEM hItem, RECT *rcItem, BOOL bConv);        \
00210     int (*getCurSel)(clsName*);                                             \
00211     int (*setCurSel)(clsName*, int newSel);                                 \
00212     void (*refreshItem)(clsName*, HITEM hItem, const RECT *rcInv);          \
00213     BOOL (*showItemByIdx)(clsName*, int index);             \
00214     BOOL (*showItem)(clsName*, HITEM hItem);
00215
00503 struct _mItemViewClass
00504 {
00505         mItemViewClassHeader(mItemView, mScrollWidget)
00506 };
00507
00508 #define mItemViewRendererHeader(clsName, parentClass) \
00509         mScrollWidgetRendererHeader(clsName, parentClass)
00510
00516 struct  _mItemViewRenderer {
00517         mItemViewRendererHeader(mItemView, mScrollWidget)
00518 };
00519
00526 MGNCS_EXPORT extern mItemViewClass g_stmItemViewCls;
00527
00532 enum mItemViewProp
00533 {
00537         NCSP_ITEMV_DEFITEMHEIGHT = NCSP_SWGT_MAX + 1,
00538
00542     NCSP_ITEMV_ITEMCOUNT,
00546     NCSP_ITEMV_MAX,
00547 };
00548
00553 enum mItemViewNotify {
00557     NCSN_ITEMV_CLICKED = NCSN_WIDGET_CLICKED,
00558
00562     NCSN_ITEMV_SELCHANGING = NCSN_SWGT_MAX + 1,
00563
00567     NCSN_ITEMV_SELCHANGED,
00568
00572     NCSN_ITEMV_ENTER,
00573
00577     NCSN_ITEMV_SETFOCUS,
00578
00582     NCSN_ITEMV_KILLFOCUS,
00583
00587     NCSN_ITEMV_MAX
00588 };
00589
00591 #ifdef __cplusplus
00592 }
00593 #endif  /* __cplusplus */
00594
00595 #endif /* _MGUI_CTRL_ITEMVIEW_H */
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mlabelpiece.h Source File

include » pieces

mlabelpiece.h

00001 #ifndef _MGNCS_LABELPIECE_H
00002 #define _MGNCS_LABELPIECE_H
00003
00004 #ifdef __cplusplus
00005 extern "C" {
00006 #endif
00007
00008 typedef struct _mLabelPieceClass mLabelPieceClass;
00009 typedef struct _mLabelPiece mLabelPiece;
00010
00011 #define mLabelPieceClassHeader(clss, superCls) \
00012         mStaticPieceClassHeader(clss, superCls)
00013
00014 struct _mLabelPieceClass
00015 {
00016         mLabelPieceClassHeader(mLabelPiece, mStaticPiece)
00017 };
00018
00019 MGNCS_EXPORT extern mLabelPieceClass g_stmLabelPieceCls;
00020
00021 #define mLabelPieceHeader(clss) \
00022         mStaticPieceHeader(clss) \
00023         const char* str; \
00024         char align; \
00025         char valign; \
00026         unsigned char flag;
00027
00028 struct _mLabelPiece
00029 {
00030         mLabelPieceHeader(mLabelPiece)
00031 };
00032
00033 #define mLabelPiece_setFlag(self, bitmask) (((self)->flag)|=(bitmask))
00034 #define mLabelPiece_clearFlag(self, bitmask) (((self)->flag)&=(~(bitmask)))
00035 #define mLabelPiece_isFlag(self, bitmask) (((self->flag)&(bitmask)) == (bitmask))
00036
00037 #define mLabelPiece_setAutoWrap(self, autoWrap) ((autoWrap)?mLabelPiece_setFlag(self, 0x1):mLabelPiece_clearFlag(self, 0x1))
00038 #define mLabelPiece_isAutoWrap(self)  mLabelPiece_isFlag(self, 0x1)
00039
00040 #define mLabelPiece_setPrefix(self, prefix) ((prefix)?mLabelPiece_setFlag(self, 0x2):mLabelPiece_clearFlag(self, 0x2))
00041 #define mLabelPiece_isPrefix(self)  mLabelPiece_isFlag(self, 0x2)
00042
00043 #define mLabelPiece_setWordBreak(self, wordbreak) ((wordbreak)?mLabelPiece_setFlag(self, 0x4):mLabelPiece_clearFlag(self, 0x4))
00044 #define mLabelPiece_isWordBreak(self)  mLabelPiece_isFlag(self, 0x4)
00045
00046 #define mLabelPiece_setSelected(self, selected) ((selected)?mLabelPiece_setFlag(self, 0x8):mLabelPiece_clearFlag(self, 0x8))
00047 #define mLabelPiece_isSelected(self) mLabelPiece_isFlag(self, 0x8)
00048
00049 enum mLabelPieceProps {
00050         NCSP_LABELPIECE_LABEL    = LABELPIECE_PROP_BEGIN,
00051         NCSP_LABELPIECE_PREFIX,
00052         NCSP_LABELPIECE_SELECT   = PIECECOMM_PROP_SELECT,
00053         NCSP_LABELPIECE_ALIGN    = PIECECOMM_PROP_ALIGN,
00054         NCSP_LABELPIECE_VALIGN   = PIECECOMM_PROP_VALIGN,
00055         NCSP_LABELPIECE_AUTOWRAP = PIECECOMM_PROP_AUTOWRAP,
00056         NCSP_LABELPIECE_WORDBREAK = PIECECOMM_PROP_WORDBREAK
00057 };
00058
00059
00060 #ifdef __cplusplus
00061 }
00062 #endif
00063
00064 #endif
00065
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mlayoutpiece.h Source File

include » pieces

mlayoutpiece.h

00001
00002 #ifndef _MGUI_NCSCTRL_LAYOUTPIECE_H
00003 #define _MGUI_NCSCTRL_LAYOUTPIECE_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif
00008
00009 typedef struct _mLayoutPieceClass mLayoutPieceClass;
00010 typedef struct _mLayoutPiece mLayoutPiece;
00011
00012 #define mLayoutPieceClassHeader(clss, superCls) \
00013         mHotPieceClassHeader(clss, superCls)
00014
00015 struct _mLayoutPieceClass
00016 {
00017         mLayoutPieceClassHeader(mLayoutPiece, mHotPiece)
00018 };
00019
00020 MGNCS_EXPORT extern mLayoutPieceClass g_stmLayoutPieceCls;
00021
00022 #define mLayoutPieceHeader(clss) \
00023         mHotPieceHeader(clss)
00024
00025 struct _mLayoutPiece
00026 {
00027         mLayoutPieceHeader(mLayoutPiece)
00028 };
00029
00030
00031 #ifdef __cplusplus
00032 }
00033 #endif
00034
00035 #endif
00036
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mledstatic.h Source File

include

mledstatic.h

00001
00002 #ifndef _MGUI_NCSCTRL_LEDLABEL_H
00003 #define _MGUI_NCSCTRL_LEDLABEL_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif  /* __cplusplus */
00008
00014 #include "mwidget.h"
00015
00021 #define NCSCTRL_LEDLABEL   NCSCLASSNAME("ledlabel")
00022
00023
00024 typedef struct _mLEDLabel mLEDLabel;
00025 typedef struct _mLEDLabelClass mLEDLabelClass;
00026 typedef struct _mLEDLabelRenderer mLEDLabelRenderer;
00027
00028 /* define mLEDLabel */
00029 #define mLEDLabelHeader(clsName)  \
00030         mStaticHeader(clsName)
00031
00037 struct _mLEDLabel
00038 {
00039         mLEDLabelHeader(mLEDLabel)
00040 };
00041
00042 /* define mLEDLabelClass */
00043 #define mLEDLabelClassHeader(clsName, parentClass)    \
00044         mStaticClassHeader(clsName, parentClass)
00045
00051 struct _mLEDLabelClass
00052 {
00053         mLEDLabelClassHeader(mLEDLabel, mStatic)
00054 };
00055
00056
00057 /* define IRendererStatic */
00058 #define mLEDLabelRendererHeader(clsName, parentClass) \
00059         mStaticRendererHeader(clsName, parentClass)
00060
00065 struct  _mLEDLabelRenderer {
00066         mLEDLabelRendererHeader(mLEDLabel, mStatic)
00067 };
00068
00073 MGNCS_EXPORT extern mLEDLabelClass g_stmLEDLabelCls;
00074
00075 /* define property of static */
00076
00082 enum mLEDLabelProp {
00083         NCSP_LEDLBL_COLOR = NCSP_STATIC_MAX + 1,
00084         NCSP_LEDLBL_WIDTH,
00085         NCSP_LEDLBL_HEIGHT,
00086         NCSP_LEDLBL_GAP,
00087         NCSP_LEDLBL_MAX,
00088 };
00089
00094 enum enumLEDLabelNotify {
00095         NCSN_LEDLBL_MAX = NCSN_STATIC_MAX + 1
00096 };
00097
00098 // BOOL ncsLedDrawText(HDC hdc, char *str, int len, const RECT *rect, DWORD uflag, int width, int height);
00099
00103 #ifdef __cplusplus
00104 }
00105 #endif  /* __cplusplus */
00106
00107 #endif /* _MGUI_NCSCTRL_LEDLABEL_H */
00108
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mledstaticpiece.h Source File

include » pieces

mledstaticpiece.h

00001
00002 #ifndef _MGUI_NCSCTRL_LEDLABELPIECE_H
00003 #define _MGUI_NCSCTRL_LEDLABELPIECE_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif
00008
00009 typedef struct _mLedstaticPieceClass mLedstaticPieceClass;
00010 typedef struct _mLedstaticPiece mLedstaticPiece;
00011
00012 #define mLedstaticPieceClassHeader(clss, superCls) \
00013         mStaticPieceClassHeader(clss, superCls)
00014
00015 struct _mLedstaticPieceClass
00016 {
00017         mLedstaticPieceClassHeader(mLedstaticPiece, mStaticPiece)
00018 };
00019
00020 MGNCS_EXPORT extern mLedstaticPieceClass g_stmLedstaticPieceCls;
00021
00022 #define mLedstaticPieceHeader(clss) \
00023         mStaticPieceHeader(clss)   \
00024         char *text;             \
00025         unsigned int width:16;          \
00026         unsigned int height:16; \
00027         DWORD color;    \
00028         unsigned int format;
00029
00030 struct _mLedstaticPiece
00031 {
00032         mLedstaticPieceHeader(mLedstaticPiece)
00033 };
00034
00035 #define mLedstaticPiece_setFlag(self, bitmask) ((self)->format = (((bitmask) << 8) | (self->format & 0xFFFF00FF)))
00036 #define mLedstaticPiece_clearFlag(self, bitmask) (((self)->format) &= (~(bitmask << 8)))
00037 #define mLedstaticPiece_isFlag(self, bitmask) (((self->format) & (bitmask << 8)))
00038
00039 #define mLedstaticPiece_setAutoWrap(self, autoWrap) ((autoWrap)?mLedstaticPiece_setFlag(self, 0x1):mLedstaticPiece_clearFlag(self, 0x1))
00040 #define mLedstaticPiece_isAutoWrap(self)  mLedstaticPiece_isFlag(self, 0x1)
00041
00042 enum mLedstaticPieceProps {
00043         NCSP_LEDLBLPIECE_TEXT = LEDLBLPIECE_PROP_BEGIN,
00044         NCSP_LEDLBLPIECE_COLOR,
00045         NCSP_LEDLBLPIECE_ALIGN = PIECECOMM_PROP_ALIGN,
00046         NCSP_LEDLBLPIECE_VALIGN = PIECECOMM_PROP_VALIGN,
00047         NCSP_LEDLBLPIECE_AUTOWRAP = PIECECOMM_PROP_AUTOWRAP,
00048         NCSP_LEDLBLPIECE_WIDTH,
00049         NCSP_LEDLBLPIECE_HEIGHT,
00050         NCSP_LEDLBLPIECE_GAP,
00051 };
00052
00053 #ifdef __cplusplus
00054 }
00055 #endif
00056
00057 #endif
00058
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mleftarrowpiece.h Source File

include » pieces

mleftarrowpiece.h

00001
00002 #ifndef _MGUI_NCSCTRL_LEFTARROWPIECE_H
00003 #define _MGUI_NCSCTRL_LEFTARROWPIECE_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif
00008
00009 typedef struct _mLeftArrowPieceClass mLeftArrowPieceClass;
00010 typedef struct _mLeftArrowPiece mLeftArrowPiece;
00011
00012 #define mLeftArrowPieceClassHeader(clss, superCls) \
00013         mArrowPieceClassHeader(clss, superCls)
00014
00015 struct _mLeftArrowPieceClass
00016 {
00017         mLeftArrowPieceClassHeader(mLeftArrowPiece, mArrowPiece)
00018 };
00019
00020 MGNCS_EXPORT extern mLeftArrowPieceClass g_stmLeftArrowPieceCls;
00021
00022 #define mLeftArrowPieceHeader(clss) \
00023         mArrowPieceHeader(clss)
00024
00025 struct _mLeftArrowPiece
00026 {
00027         mLeftArrowPieceHeader(mLeftArrowPiece)
00028 };
00029
00030
00031 #ifdef __cplusplus
00032 }
00033 #endif
00034
00035 #endif
00036
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mlinelayoutpiece.h Source File

include » pieces

mlinelayoutpiece.h

00001
00002 #ifndef _MGUI_NCSCTRL_LINELAYOUTPIECE_H
00003 #define _MGUI_NCSCTRL_LINELAYOUTPIECE_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif
00008
00009 typedef struct _mLineLayoutPieceClass mLineLayoutPieceClass;
00010 typedef struct _mLineLayoutPiece mLineLayoutPiece;
00011
00012 #define NCS_LINELAYOUTPIECENODE_FLAG_FIXED 0x00 //the size of piece is fixed
00013 #define NCS_LINELAYOUTPIECENODE_FLAG_AUTO   0x01 //the size of piece must bigger than def_size
00014 typedef struct _mLineLayoutPieceNode {
00015         mHotPiece * piece;
00016         struct _mLineLayoutPieceNode * next, *prev;
00017         unsigned int flags:8;
00018         unsigned int def_min_size:12;
00019         unsigned int def_max_size:12;
00020 }mLineLayoutPieceNode;
00021
00022 #define mLineLayoutPieceClassHeader(clss, superCls) \
00023         mLayoutPieceClassHeader(clss, superCls) \
00024         BOOL (*addPiece)(clss*, mHotPiece *piece, int type, int min_size, int max_size); \
00025         BOOL (*appendPiece)(clss*, mHotPiece *piece, int type, int min_size, int max_size); \
00026         void (*recalc)(clss*); \
00027         mLineLayoutPieceNode * (*find)(clss *,mHotPiece *piece); \
00028         void (*reset)(clss*, void (*free_piece)(mHotPiece*));
00029
00030 struct _mLineLayoutPieceClass
00031 {
00032         mLineLayoutPieceClassHeader(mLineLayoutPiece, mLayoutPiece)
00033 };
00034
00035 extern mLineLayoutPieceClass g_stmLineLayoutPieceCls;
00036
00037 #define mLineLayoutPieceHeader(clss) \
00038         mLayoutPieceHeader(clss)  \
00039         int left:16; \
00040         int top:16; \
00041         int right:16; \
00042         int bottom:16; \
00043         unsigned short direction:1; \
00044         unsigned short autoWrap:1; \
00045         unsigned short line_height:14; \
00046         unsigned char  margin; \
00047         unsigned char  space; \
00048         mLineLayoutPieceNode *node; \
00049         mLineLayoutPieceNode *tail_node;
00050
00051
00052 struct _mLineLayoutPiece
00053 {
00054         mLineLayoutPieceHeader(mLineLayoutPiece)
00055 };
00056
00057 enum mLineLayoutPieceProps{
00058         NCSP_LINELAYOUTPIECE_COUNT = LINELAYOUTPIECE_PROP_BEGIN,
00059         NCSP_LINELAYOUTPIECE_LINE_HEIGHT,
00060         NCSP_LINELAYOUTPiECE_AUTOWRAP  = PIECECOMM_PROP_AUTOWRAP,
00061         NCSP_LINELAYOUTPIECE_DIRECTION = PIECECOMM_PROP_DIRECTION,
00062         NCSP_LINELAYOUTPIECE_SPACE     = PIECECOMM_PROP_SPACE,
00063         NCSP_LINELAYOUTPIECE_MARGIN    = PIECECOMM_PROP_MARGIN
00064 };
00065
00066 #ifdef __cplusplus
00067 }
00068 #endif
00069
00070 #endif
00071
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mlist.h Source File

include

mlist.h

Go to the documentation of this file.
00001
00026 #ifndef _MGUI_NCSCTRL_LIST_H
00027 #define _MGUI_NCSCTRL_LIST_H
00028
00029
00030 #ifdef __cplusplus
00031 extern "C" {
00032 #endif  /* __cplusplus */
00033
00043 #define NCSCTRL_LIST                NCSCLASSNAME("list")
00044
00045 typedef struct _mList mList;
00046 typedef struct _mListClass mListClass;
00047 typedef struct _mListRenderer mListRenderer;
00048
00053 #define NCSS_LIST_LOOP              (0x0001<<NCSS_ASTLST_SHIFT)
00054
00059 #define NCSS_LIST_MULTIPLE          (0x0002<<NCSS_ASTLST_SHIFT)
00060
00065 #define NCSS_LIST_SHIFT             (NCSS_ASTLST_SHIFT+2)
00066
00067 #define mListHeader(clsName)        \
00068         mAbstractListHeader(clsName)    \
00069     list_t  selList;                \
00070     mListLayout *layout;            \
00071     mNode   *hiliteNode;            \
00072     Uint16  nodesHeight;
00073
00090 struct _mList
00091 {
00092         mListHeader(mList)
00093 };
00094
00095 #define mListClassHeader(clsName, superCls)             \
00096         mAbstractListClassHeader(clsName, superCls)         \
00097     void (*resetContent)(clsName*);                     \
00098     void (*removeAll)(clsName*);                        \
00099     void (*enterSubList)(clsName*, mNode* selNode);     \
00100     void (*backUpList)(clsName*, mNode* selNode);       \
00101     BOOL (*setNodeDefSize)(clsName*, int defW,int defH);\
00102     BOOL (*setLayout)(clsName*, mListLayout* layout, int defNodeW, int defNodeH); \
00103     mListLayout* (*getLayout)(clsName*);
00104
00136 struct _mListClass
00137 {
00138         mListClassHeader(mList, mAbstractList)
00139 };
00140
00141 #define mListRendererHeader(clsName, parentClass) \
00142         mAbstractListRendererHeader(clsName, parentClass)
00143
00149 struct  _mListRenderer {
00150         mListRendererHeader(mList, mAbstractList)
00151 };
00152
00153
00158 enum ncsListLayoutID
00159 {
00163     NCS_LIST_LLIST = 0,
00164
00168     NCS_LIST_LICONV,
00169
00170     NCS_LIST_LICONH,
00171
00172     NCS_LIST_LCBOXH,
00173
00174     NCS_LIST_LGROUP,
00175
00176     NCS_LIST_LUSERDEFINED,
00180     NCS_LIST_MAX,
00181 };
00182
00183 enum mListEvent
00184 {
00185     NCSE_LIST_FONTCHANGED = 100,
00186     NCSE_LIST_SIZECHANGED,
00187     NCSE_LIST_ROOTCHANGING, //new root
00188     NCSE_LIST_ROOTCHANGED,  //new root
00189 };
00190
00191 enum mListDirKeyFlags{
00192     NCSF_LIST_UP     = 0x01,
00193     NCSF_LIST_DOWN   = 0x02,
00194     NCSF_LIST_LEFT   = 0x04,
00195     NCSF_LIST_RIGHT  = 0x08,
00196     NCSF_LIST_HOME   = 0x10,
00197     NCSF_LIST_END    = 0x20,
00198     NCSF_LIST_LOOP   = 0x100,
00199     NCSF_LIST_DIRMASK= 0xFF,
00200 };
00205 enum mListProp
00206 {
00210     NCSP_LIST_LAYOUT = NCSP_ASTLST_MAX + 1,
00211
00215     NCSP_LIST_DEFNODEWIDTH,
00216
00220     NCSP_LIST_DEFNODEHEIGHT,
00221
00225     NCSP_LIST_MAX,
00226 };
00227
00232 enum mListNotify
00233 {
00238     NCSN_LIST_SELCHANGED = NCSN_ASTLST_MAX + 1,
00239
00244     NCSN_LIST_ENTER,
00245
00250     NCSN_LIST_BACKSPACE,
00251
00256     NCSN_LIST_ENTERSUBLIST,
00257
00262     NCSN_LIST_BACKUPLIST,
00263
00264     NCSN_LIST_ROOTNODECHANGED,
00268     NCSN_LIST_MAX,
00269 };
00270
00277 MGNCS_EXPORT extern mListClass g_stmListCls;
00278
00283 MGNCS_EXPORT void mList_foreachNode(mList *list, void (*foreach)(mNode *node, void* param), void* param);
00284
00287 #ifdef __cplusplus
00288 }
00289 #endif  /* __cplusplus */
00290
00291 #endif /* _MGUI_NCSCTRL_LIST_H */
00292
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mlist_layout.h Source File

include

mlist_layout.h

Go to the documentation of this file.
00001
00026 #ifndef _MGUI_WIDGET_LAYOUT_H
00027 #define _MGUI_WIDGET_LAYOUT_H
00028
00029
00030 #ifdef __cplusplus
00031 extern "C" {
00032 #endif  /* __cplusplus */
00033
00039 typedef struct _mListLayout mListLayout;
00040 typedef struct _mListLayoutClass mListLayoutClass;
00041
00042 #define mListLayoutHeader(className)\
00043         mObjectHeader(className) \
00044     mAbstractList *list;            \
00045     Uint16  itemHeight;             \
00046     Uint16  itemWidth;
00047
00048 struct _mListLayout
00049 {
00050         mListLayoutHeader(mListLayout)
00051 };
00052
00053 #define mListLayoutClassHeader(clsName, superCls)           \
00054         mObjectClassHeader(clsName, superCls)            \
00055         BOOL (*setProperty)(clsName*, int id, DWORD value);     \
00056         DWORD (*getProperty)(clsName*, int id);                 \
00057     mNode* (*onDirKey)(clsName*,mNode* refNode, int direct);\
00058     mNode* (*onMouseHit)(clsName*, int mouseX, int mouseY); \
00059     int (*getNodeRect)(clsName*, mNode *node, RECT *rcNode);\
00060     BOOL (*recalcContSize)(clsName*, int flags);            \
00061     void (*init)(clsName*, mAbstractList *list, int defItemW, int defItemH);\
00062     void (*update)(clsName*, HDC hdc, const RECT* rcVis, RECT *rcCont);     \
00063     void (*nodeEvent)(clsName*, int eventId, DWORD eventInfo);
00064
00065 struct _mListLayoutClass
00066 {
00067         mListLayoutClassHeader(mListLayout, mObject)
00068 };
00069
00070 enum mListLayoutStatus
00071 {
00072      NCSF_LIST_LAYOUT_ITEMHCHANGED = 0x01,
00073      NCSF_LIST_LAYOUT_ITEMWCHANGED = 0x02,
00074 };
00075
00080 enum mListLayoutProp
00081 {
00082
00083     NCSP_LIST_LAYOUT_DEFITEMHEIGHT = 10,//RW
00084     NCSP_LIST_LAYOUT_DEFITEMWIDTH, //RW
00088         NCSP_LIST_LAYOUT_MAX,
00089 };
00090
00097 MGNCS_EXPORT extern mListLayoutClass g_stmListLayoutCls;
00098
00101 /*=========================================================*/
00102 typedef struct _mLVIconLayout mLVIconLayout;
00103 typedef struct _mLVIconLayoutClass mLVIconLayoutClass;
00104
00105 #define mLVIconLayoutHeader(className)  \
00106     mListLayoutHeader(className)        \
00107     int nrCol;
00108
00109 struct _mLVIconLayout
00110 {
00111         mLVIconLayoutHeader(mLVIconLayout)
00112 };
00113
00114 #define mLVIconLayoutClassHeader(clsName, superCls) \
00115         mListLayoutClassHeader(clsName, superCls)
00116
00117 struct _mLVIconLayoutClass
00118 {
00119         mLVIconLayoutClassHeader(mLVIconLayout, mListLayout)
00120 };
00121
00122 MGNCS_EXPORT extern mLVIconLayoutClass g_stmLVIconLayoutCls;
00123
00124 /*=========================================================*/
00125 typedef struct _mLHIconLayout mLHIconLayout;
00126 typedef struct _mLHIconLayoutClass mLHIconLayoutClass;
00127
00128 #define mLHIconLayoutHeader(className)  \
00129     mListLayoutHeader(className)        \
00130     Uint16 nrRow;
00131
00132 struct _mLHIconLayout
00133 {
00134         mLHIconLayoutHeader(mLHIconLayout)
00135 };
00136
00137 #define mLHIconLayoutClassHeader(clsName, superCls) \
00138         mListLayoutClassHeader(clsName, superCls)
00139
00140 struct _mLHIconLayoutClass
00141 {
00142         mLHIconLayoutClassHeader(mLHIconLayout, mListLayout)
00143 };
00144
00145 MGNCS_EXPORT extern mLHIconLayoutClass g_stmLHIconLayoutCls;
00146
00147 /*=========================================================*/
00148 typedef struct _mLHCenterBoxLayout mLHCenterBoxLayout;
00149 typedef struct _mLHCenterBoxLayoutClass mLHCenterBoxLayoutClass;
00150
00151 #define mLHCenterBoxLayoutHeader(className)     \
00152     mLHIconLayoutHeader(className)              \
00153     int offx;
00154
00155 struct _mLHCenterBoxLayout
00156 {
00157         mLHCenterBoxLayoutHeader(mLHIconLayout)
00158 };
00159
00160 #define mLHCenterBoxLayoutClassHeader(clsName, superCls) \
00161         mLHIconLayoutClassHeader(clsName, superCls)
00162
00163 struct _mLHCenterBoxLayoutClass
00164 {
00165         mLHCenterBoxLayoutClassHeader(mLHCenterBoxLayout, mLHIconLayout)
00166 };
00167
00172 enum mLHCenterBoxLayoutProp
00173 {
00177     NCSP_HCBOX_LAYOUT_OFFX = NCSP_LIST_LAYOUT_MAX + 1, //RO
00181         NCSP_HCBOX_LAYOUT_MAX,
00182 };
00183
00184 MGNCS_EXPORT extern mLHCenterBoxLayoutClass g_stmLHCenterBoxLayoutCls;
00185
00186 /*=========================================================*/
00187 typedef struct _NCS_GROUP_INFO
00188 {
00189     int id;
00190     char *text;
00191     DWORD addData;
00192 }NCS_GROUP_INFO;
00193
00194 typedef struct _mLGroupLayout mLGroupLayout;
00195 typedef struct _mLGroupLayoutClass mLGroupLayoutClass;
00196
00197 #define NCSID_UNNAMED_GROUP         0
00198 #define NCSID_UNNAMED_GROUPTEXT     "Unnamed"
00199 //return group id, if no group return NCSID_UNNAMED_GROUP
00200 typedef int (*NCS_CB_INGROUP)(mNode *node);
00201
00202 #define mLGroupLayoutHeader(className)  \
00203     mLVIconLayoutHeader(className)      \
00204     NCS_CB_CMPNODE  cbCmpNode;          \
00205     NCS_CB_CMPNODE  cbCmpGroup;         \
00206     NCS_CB_INGROUP  cbInGroup;          \
00207     BOOL            defaultGroup;       \
00208     mNode           *groupRoot;         \
00209     int             defGroupH;
00210
00211 struct _mLGroupLayout
00212 {
00213         mLGroupLayoutHeader(mLGroupLayout)
00214 };
00215
00216 #define mLGroupLayoutClassHeader(clsName, superCls) \
00217         mLVIconLayoutClassHeader(clsName, superCls)       \
00218     void (*setGroupInfo)(clsName*, NCS_CB_INGROUP inGroup, NCS_GROUP_INFO *groupInfo, int groupSize);\
00219     NCS_CB_CMPNODE (*decorateNodeCmp)(clsName*, NCS_CB_CMPNODE func);   \
00220     NCS_CB_INGROUP (*setInGroupFunc)(clsName*, NCS_CB_INGROUP func);    \
00221     BOOL (*resetGroup)(clsName*, NCS_GROUP_INFO *groupInfo, int groupSize);
00222
00223 struct _mLGroupLayoutClass
00224 {
00225         mLGroupLayoutClassHeader(mLGroupLayout, mLVIconLayout)
00226 };
00227
00228
00233 enum mLGroupLayoutProp
00234 {
00235
00236     NCSP_LGROUP_LAYOUT_NODECMPFUNC = NCSP_LIST_LAYOUT_MAX + 1, //RO
00237
00238     NCSP_LGROUP_LAYOUT_GROUPCMPFUNC,//RW
00242         NCSP_LGROUP_LAYOUT_MAX,
00243 };
00244
00245 MGNCS_EXPORT extern mLGroupLayoutClass g_stmLGroupLayoutCls;
00246
00247 #ifdef __cplusplus
00248 }
00249 #endif  /* __cplusplus */
00250
00251 #endif /* _MGUI_WIDGET_LAYOUT_H */
00252
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mlistbox.h Source File

include

mlistbox.h

Go to the documentation of this file.
00001
00026 #ifndef _MGUI_CTRL_LSTBOX_H
00027 #define _MGUI_CTRL_LSTBOX_H
00028
00029
00030 #ifdef __cplusplus
00031 extern "C" {
00032 #endif  /* __cplusplus */
00033
00034 #include "mitem.h"
00035 #include "mitem_manager.h"
00036 #include "mitemview.h"
00045 typedef struct _NCS_LSTBOX_ITEMINFO
00046 {
00050     char*   string;
00051
00067     DWORD   flag;
00068
00072     DWORD   image;
00073
00077         DWORD addData;
00078 }NCS_LSTBOX_ITEMINFO;
00079
00080 typedef struct _mListBox mListBox;
00081 typedef struct _mListBoxClass mListBoxClass;
00082 typedef struct _mListBoxRenderer mListBoxRenderer;
00083
00088 #define NCSCTRL_LISTBOX             NCSCLASSNAME("listbox")
00089
00094 #define NCSS_LSTBOX_SHIFT           (NCSS_ITEMV_SHIFT+4)
00095
00100 #define NCSS_LSTBOX_SINGLE          NCSS_ITEMV_SINGLE
00101
00106 #define NCSS_LSTBOX_MULTIPLE        NCSS_ITEMV_MULTIPLE
00107
00112 #define NCSS_LSTBOX_SORT            NCSS_ITEMV_AUTOSORT
00113
00119 #define NCSS_LSTBOX_MOUSEFOLLOW     (0x0001<<NCSS_ITEMV_SHIFT)
00120
00125 #define NCSS_LSTBOX_STRING          (0x0000<<NCSS_ITEMV_SHIFT)
00126
00131 #define NCSS_LSTBOX_USEBITMAP       (0x0002<<NCSS_ITEMV_SHIFT)
00132
00137 #define NCSS_LSTBOX_CHECKBOX        (0x0004<<NCSS_ITEMV_SHIFT)
00138
00144 #define NCSS_LSTBOX_AUTOCHECK       (0x0008<<NCSS_ITEMV_SHIFT)
00145
00150 #define NCSS_LSTBOX_AUTOCHECKBOX  \
00151     (NCSS_LSTBOX_CHECKBOX | NCSS_LSTBOX_AUTOCHECK)
00152
00153 //for list flags
00154 #define NCSF_LSTBOX_SHIFT           (NCSF_ITEM_SHIFT + 4)
00155
00156 /* check mark, for NCSS_LSTBOX_CHECKBOX*/
00161 #define NCSF_LSTBOX_CMBLANK         (0x0000<<NCSF_ITEM_SHIFT)
00162
00167 #define NCSF_LSTBOX_CMCHECKED       (0x0001<<NCSF_ITEM_SHIFT)
00168
00173 #define NCSF_LSTBOX_CMPARTCHECKED   (0x0002<<NCSF_ITEM_SHIFT)
00174
00179 #define NCSF_LSTBOX_CHECKMASK     \
00180     (NCSF_LSTBOX_CMBLANK | NCSF_LSTBOX_CMCHECKED | NCSF_LSTBOX_CMPARTCHECKED)
00181
00186 #define NCSF_LSTBOX_BOLD            (0x0004<<NCSF_ITEM_SHIFT)
00187
00192 #define NCSF_LSTBOX_SIGNIFICANT     (0x0008<<NCSF_ITEM_SHIFT)
00193
00194 #define mListBoxHeader(className)   \
00195     mItemViewHeader(className)      \
00196     PLOGFONT font;                  \
00197     int     itemVisibles;           \
00198     int     itemHilighted;          \
00199     int     selItem;                \
00200     DWORD   listFlag;
00201
00222 struct _mListBox
00223 {
00224         mListBoxHeader(mListBox)
00225 };
00226
00227 #define mListBoxClassHeader(clsName, parentClass)                       \
00228     mItemViewClassHeader(clsName, parentClass)                          \
00229     int (*onChar)(clsName*, int asciiCode, DWORD keyFlags);             \
00230     int (*setSel)(clsName*, int newSel, int flag);                      \
00231     int (*addString)(clsName*, const char* string, DWORD addData);      \
00232     int (*insertString)(clsName*, const char* string, DWORD addData, int index);\
00233     int (*findString)(clsName*, int start, char* string, BOOL bExact);  \
00234     BOOL (*delString) (clsName*, int index);                            \
00235     void (*addItems)(clsName*, NCS_LSTBOX_ITEMINFO *info, int count);   \
00236     int (*removeItemByIdx)(clsName*, int index);                        \
00237     BOOL (*bold)(clsName*, int index, BOOL bold);                       \
00238     BOOL (*isHilightByIdx)(clsName*, int index);                        \
00239     BOOL (*enableByIdx)(clsName*, int index, BOOL enable);              \
00240     int (*selectByIdx)(clsName*, int index);                            \
00241     int (*deselectByIdx)(clsName*, int index);                          \
00242     BOOL (*setCheckMark)(clsName*, int index, DWORD mark);              \
00243     DWORD (*getCheckMark)(clsName*, int index);
00244
00328 struct _mListBoxClass
00329 {
00330         mListBoxClassHeader(mListBox, mItemView)
00331 };
00332
00333 #define mListBoxRendererHeader(clsName, parentClass) \
00334         mItemViewRendererHeader(clsName, parentClass)
00335
00341 struct  _mListBoxRenderer {
00342         mListBoxRendererHeader(mListBox, mItemView)
00343 };
00344
00349 enum mListBoxProp
00350 {
00354     NCSP_LSTBOX_ITEMWIDTH = NCSP_SWGT_CONTWIDTH,
00355
00359     NCSP_LSTBOX_ITEMCOUNT = NCSP_ITEMV_ITEMCOUNT,
00360
00364     NCSP_LSTBOX_ITEMHEIGHT = NCSP_ITEMV_MAX + 1,
00365
00369     NCSP_LSTBOX_TOPITEM,
00370
00378     NCSP_LSTBOX_HILIGHTEDITEM,
00379
00383         NCSP_LSTBOX_MAX,
00384 };
00385
00390 enum mListBoxNotify
00391 {
00395     NCSN_LSTBOX_CLICKED = NCSN_ITEMV_CLICKED,
00396
00400     NCSN_LSTBOX_SELCHANGED = NCSN_ITEMV_SELCHANGED,
00401
00405     NCSN_LSTBOX_ENTER = NCSN_ITEMV_ENTER,
00406
00410     NCSN_LSTBOX_SETFOCUS = NCSN_ITEMV_SETFOCUS,
00411
00415     NCSN_LSTBOX_KILLFOCUS = NCSN_ITEMV_KILLFOCUS,
00416
00420     NCSN_LSTBOX_ERRSPACE = NCSN_ITEMV_MAX + 1,
00421
00425     NCSN_LSTBOX_DBCLK,
00426
00431     NCSN_LSTBOX_CMCANCEL,
00432     // Obsolete.
00433     NCSN_LSTBOX_SELCANCEL = NCSN_LSTBOX_CMCANCEL,
00434
00438     NCSN_LSTBOX_CLKCHKMARK,
00439
00443     NCSN_LSTBOX_MAX,
00444 };
00445
00452 MGNCS_EXPORT extern mListBoxClass g_stmListBoxCls;
00455 #ifdef __cplusplus
00456 }
00457 #endif  /* __cplusplus */
00458
00459 #endif /* _MGUI_CTRL_LSTBOX_H */
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mlistcolumn.h Source File

include

mlistcolumn.h

Go to the documentation of this file.
00001
00026 #ifndef _MGUI_WIDGET_LSTCLM_H
00027 #define _MGUI_WIDGET_LSTCLM_H
00028
00029
00030 #ifdef __cplusplus
00031 extern "C" {
00032 #endif  /* __cplusplus */
00033
00039 typedef struct _mListColumn mListColumn;
00040 typedef struct _mListColumnClass mListColumnClass;
00041
00046 typedef enum
00047 {
00051     NCSID_LSTCLM_NOTSORTED = 0,
00052
00056     NCSID_LSTCLM_HISORTED,
00057
00061     NCSID_LSTCLM_LOSORTED,
00062
00063     NCSID_LSTCLM_MAXVALUE
00064 }ncsLstClmSortType;
00065
00070 typedef struct _NCS_LSTCLM_SORTDATA
00071 {
00075     int     column;
00076
00080     int     losorted;
00081
00085     mWidget *obj;
00086 }NCS_LSTCLM_SORTDATA;
00087
00092 typedef int (*NCS_CB_LISTV_CMPCLM)(HITEM nItem1, HITEM nItem2, NCS_LSTCLM_SORTDATA *sortData);
00093
00098 #define NCSF_LSTCLM_LEFTALIGN       (0x00<<NCSF_ITEM_SHIFT)
00099
00104 #define NCSF_LSTCLM_RIGHTALIGN      (0x01<<NCSF_ITEM_SHIFT)
00105
00110 #define NCSF_LSTCLM_CENTERALIGN     (0x02<<NCSF_ITEM_SHIFT)
00111
00116 #define NCSF_LSTCLM_TOPALIGN        (0x00<<NCSF_ITEM_SHIFT)
00117
00122 #define NCSF_LSTCLM_BOTTOMALIGN     (0x04<<NCSF_ITEM_SHIFT)
00123
00128 #define NCSF_LSTCLM_VCENTERALIGN    (0x08<<NCSF_ITEM_SHIFT)
00129
00134 #define NCSF_LSTCLM_VALIGNMASK      (0x0C<<NCSF_ITEM_SHIFT)
00135
00140 #define NCSF_LSTCLM_SHIFT           (NCSF_ITEM_SHIFT+4)
00141
00142 #define mListColumnHeader(className)\
00143         mItemHeader(className)          \
00144     int startX;                     \
00145     int width;                      \
00146     ncsLstClmSortType       sort;   \
00147     NCS_CB_LISTV_CMPCLM     pfnCmp;
00148
00165 struct _mListColumn
00166 {
00167         mListColumnHeader(mListColumn)
00168 };
00169
00170 #define mListColumnClassHeader(clsName, superCls)   \
00171         mItemClassHeader(clsName, superCls)
00172
00178 struct _mListColumnClass
00179 {
00180         mListColumnClassHeader(mListColumn, mItem)
00181 };
00182
00187 typedef enum
00188 {
00192     NCSP_LSTCLM_POSX = NCSP_ITEM_MAX + 1,
00193
00197     NCSP_LSTCLM_WIDTH,
00198
00202     NCSP_LSTCLM_SORTTYPE,
00203
00207     NCSP_LSTCLM_CMPFUNC,
00208
00212         NCSP_LSTCLM_MAX,
00213 }mListColumnProp;
00214
00221 MGNCS_EXPORT extern mListColumnClass g_stmListColumnCls;
00222
00225 #ifdef __cplusplus
00226 }
00227 #endif  /* __cplusplus */
00228
00229 #endif /* _MGUI_WIDGET_LSTCLM_H */
00230
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mlistitem.h Source File

include

mlistitem.h

Go to the documentation of this file.
00001
00026 #ifndef _MGUI_WIDGET_LSTITM_H
00027 #define _MGUI_WIDGET_LSTITM_H
00028
00029
00030 #ifdef __cplusplus
00031 extern "C" {
00032 #endif  /* __cplusplus */
00033
00039 typedef struct _mListItem mListItem;
00040 typedef struct _mListItemClass mListItemClass;
00041
00046 #define NCSF_LSTITM_FOLD          (0x0001<<NCSF_ITMMNG_SHIFT)
00047
00052 #define NCSF_LSTITM_PRIVBKCOL     (0x0002<<NCSF_ITMMNG_SHIFT)
00053
00058 #define NCSF_LSTITM_PRIVFGCOL     (0x0004<<NCSF_ITMMNG_SHIFT)
00059
00064 #define NCSF_LSTITM_SHIFT         (NCSF_ITMMNG_SHIFT + 3)
00065
00066 #define mListItemHeader(className)  \
00067         mItemManagerHeader(className)   \
00068     mListItem *parent;      \
00069     HICON   foldIcon;       \
00070     HICON   unfoldIcon;     \
00071     int     showHeight;     \
00072     int     depth;          \
00073     int     bkColor;        \
00074     int     fgColor;        \
00075     int     nrChild;
00076
00105 struct _mListItem
00106 {
00107         mListItemHeader(mListItem)
00108 };
00109
00110 #define mListItemClassHeader(clsName, superCls)             \
00111         mItemManagerClassHeader(clsName, superCls)              \
00112     void (*setBackground)(clsName*, int index, int* color); \
00113     void (*setForeground)(clsName*, int index, int* color); \
00114     int (*getBackground)(clsName*, int index, int* color);  \
00115     int (*getForeground)(clsName*, int index, int* color);  \
00116     BOOL (*addChild)(clsName*, clsName *child);             \
00117     BOOL (*delChild)(clsName*, clsName *child);             \
00118     BOOL (*setFold)(clsName*, BOOL fold);                   \
00119     mListItem* (*getParent)(clsName*);                      \
00120     int (*getChildCount)(clsName*);                         \
00121     int (*getDepth)(clsName*);                              \
00122     BOOL (*isFold)(clsName*);                               \
00123
00124
00169 struct _mListItemClass
00170 {
00171         mListItemClassHeader(mListItem, mItemManager)
00172 };
00173
00178 enum mListItemProp
00179 {
00183     NCSP_LSTITM_NRCHILD = NCSP_ITMMNG_MAX + 1,
00184
00188     NCSP_LSTITM_DEPTH,
00189
00193     NCSP_LSTITM_RHEIGHT,
00194
00198         NCSP_LSTITM_MAX,
00199 };
00200
00207 MGNCS_EXPORT extern mListItemClass g_stmListItemCls;
00208
00211 #ifdef __cplusplus
00212 }
00213 #endif  /* __cplusplus */
00214
00215 #endif /* _MGUI_WIDGET_LSTITM_H */
00216
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mlistspinnedpiece.h Source File

include » pieces

mlistspinnedpiece.h

00001 #ifndef _MGNCS_LISTSPINNEDPIECE_H
00002 #define _MGNCS_LISTSPINNEDPIECE_H
00003
00004 #ifdef __cplusplus
00005 extern "C" {
00006 #endif
00007
00008 typedef struct _mListSpinnedPieceClass mListSpinnedPieceClass;
00009 typedef struct _mListSpinnedPiece mListSpinnedPiece;
00010
00011 #define mListSpinnedPieceClassHeader(clss, superCls) \
00012         mLabelPieceClassHeader(clss, superCls)
00013
00014 struct _mListSpinnedPieceClass
00015 {
00016         mListSpinnedPieceClassHeader(mListSpinnedPiece, mLabelPiece)
00017 };
00018
00019 extern mListSpinnedPieceClass g_stmListSpinnedPieceCls;
00020
00021 #define mListSpinnedPieceHeader(clss) \
00022         mLabelPieceHeader(clss) \
00023         const char ** list;
00024
00025 struct _mListSpinnedPiece
00026 {
00027         mListSpinnedPieceHeader(mListSpinnedPiece)
00028 };
00029
00030
00031 enum mListSpinnedPieceProps{
00032         NCSP_MLISTSPINNEDPIECE_LIST = MLISTSPINNEDPIECE_PROP_BEGIN
00033 };
00034
00035 #ifdef __cplusplus
00036 }
00037 #endif
00038
00039 #endif
00040
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mlistview.h Source File

include

mlistview.h

Go to the documentation of this file.
00001
00026 #ifndef _MGUI_CTRL_LISTV_H
00027 #define _MGUI_CTRL_LISTV_H
00028
00029
00030 #ifdef __cplusplus
00031 extern "C" {
00032 #endif  /* __cplusplus */
00033
00039 typedef struct _mListView mListView;
00040 typedef struct _mListViewClass mListViewClass;
00041 typedef struct _mListViewRenderer mListViewRenderer;
00042
00047 typedef enum
00048 {
00050     NCSID_LISTV_IR_PARENT,
00052     NCSID_LISTV_IR_FIRSTCHILD,
00054     NCSID_LISTV_IR_LASTCHILD,
00056     NCSID_LISTV_IR_NEXTSIBLING,
00058     NCSID_LISTV_IR_PREVSIBLING,
00059 }ncsListVIRType;
00060
00065 #define NCSF_LSTHDR_LEFTALIGN       (0x00<<NCSF_LSTCLM_SHIFT)
00066
00071 #define NCSF_LSTHDR_TOPALIGN        (0x00<<NCSF_LSTCLM_SHIFT)
00072
00077 #define NCSF_LSTHDR_RIGHTALIGN      (0x01<<NCSF_LSTCLM_SHIFT)
00078
00083 #define NCSF_LSTHDR_CENTERALIGN     (0x02<<NCSF_LSTCLM_SHIFT)
00084
00089 #define NCSF_LSTHDR_BOTTOMALIGN     (0x04<<NCSF_LSTCLM_SHIFT)
00090
00095 #define NCSF_LSTHDR_VCENTERALIGN    (0x08<<NCSF_LSTCLM_SHIFT)
00096
00101 #define NCSF_LSTHDR_VALIGNMASK      (0x0C<<NCSF_LSTCLM_SHIFT)
00102
00107 #define NCSF_LSTHDR_SHIFT           (NCSF_LSTCLM_SHIFT+4)
00108
00113 typedef enum
00114 {
00116     NCSID_LISTV_FT_ADDDATA,
00118     NCSID_LISTV_FT_TEXT,
00119 }ncsListVFindType;
00120
00124 typedef struct _NCS_LISTV_FINDINFO
00125 {
00127     ncsListVFindType type;
00128
00130     HITEM   parent;
00131
00133     int     startIdx;
00134
00136     union {
00138         struct {
00139             /* The number of searching column. */
00140             int     size;
00141             /* The text of searching column */
00142             char    **text;
00143         }string;
00145         DWORD   addData;
00146     }data;
00147 }NCS_LISTV_FINDINFO;
00148
00152 typedef struct _NCS_LISTV_CLMINFO
00153 {
00155     int     index;
00157     int     width;
00159     char    *text;
00161     DWORD   image;
00176     DWORD   flags;
00177     NCS_CB_LISTV_CMPCLM pfnCmp;
00178
00179     /*
00180      * \sa ncsLstClmSortType
00181      */
00182     ncsLstClmSortType sort;
00183 } NCS_LISTV_CLMINFO;
00184
00188 typedef struct _NCS_LISTV_ITEMDATA
00189 {
00191     int     row;
00193     int     col;
00195     char*   text;
00197     int     textColor;
00198
00205     DWORD   flags;
00207     DWORD   image;
00208 }NCS_LISTV_ITEMDATA;
00209
00213 typedef struct _NCS_LISTV_ITEMINFO
00214 {
00216     int     index;
00218     int     retPos;
00220     HITEM   parent;
00222     int     height;
00229     int     flags;
00231     HICON   foldIcon;
00233     HICON   unfoldIcon;
00235     int     dataSize;
00237     NCS_LISTV_ITEMDATA *data;
00239         DWORD   addData;
00240 }NCS_LISTV_ITEMINFO;
00241
00243 typedef void (*NCS_CB_LISTV_DRAWHDRBK)(mListView *self, HITEM hHdr, HDC hdc, RECT *rcDraw);
00245 typedef void (*NCS_CB_LISTV_DRAWHDR)(mListView *self, HITEM hHdr, HDC hdc, RECT *rcDraw);
00246
00247 typedef void (*NCS_CB_DRAWITEMBK)(mListView *self, HITEM hItem, HDC hdc, RECT *rcDraw);
00249 typedef struct _NCS_CB_LISTV_CSTMHDROPS
00250 {
00252     NCS_CB_LISTV_DRAWHDRBK pfnDrawHdrBk;
00254     NCS_CB_LISTV_DRAWHDR   pfnDrawHdrItem;
00255 } NCS_CB_LISTV_CSTMHDROPS;
00256
00257
00258 #define NCSSPEC_LISTV_HDR   MAX_USER_SPECIAL_KEY + 2000
00259
00260 typedef struct _NCS_LISTV_CLMRD{
00261         const char* text;
00262         const char* image_file;
00263         DWORD       width;
00264         DWORD       flags;
00265 }NCS_LISTV_CLMRD;
00266
00267 MGNCS_EXPORT extern const unsigned char gListVColumnRecordTypes[];
00268
00273 #define NCSCTRL_LISTVIEW NCSCLASSNAME("listview")
00274
00279 #define NCSS_LISTV_NOTIFY    NCSS_NOTIFY
00280
00285 #define NCSS_LISTV_LOOP      NCSS_ITEMV_LOOP
00286
00290 #define NCSS_LISTV_MULTIPLE     NCSS_ITEMV_MULTIPLE
00291
00296 #define NCSS_LISTV_SINGLE     NCSS_ITEMV_SINGLE
00297
00302 #define NCSS_LISTV_CHECKBOX  (0x0001<<NCSS_ITEMV_SHIFT)
00303
00309 #define NCSS_LISTV_AUTOCHECK (0x0002<<NCSS_ITEMV_SHIFT)
00310
00315 #define NCSS_LISTV_AUTOCHECKBOX \
00316     (NCSS_LISTV_CHECKBOX | NCSS_LISTV_AUTOCHECK)
00317
00322 #define NCSS_LISTV_TREE      (0x0004<<NCSS_ITEMV_SHIFT)
00323
00328 #define NCSS_LISTV_WITHICON  (0x0008<<NCSS_ITEMV_SHIFT)
00329
00334 #define NCSS_LISTV_SORT      (0x0010<<NCSS_ITEMV_SHIFT)
00335
00340 #define NCSS_LISTV_NOHDRDRAG (0x0020<<NCSS_ITEMV_SHIFT)
00341
00346 #define NCSS_LISTV_SHIFT     (NCSS_ITEMV_SHIFT + 6)
00347
00348 #define mListViewHeader(className)  \
00349     mItemViewHeader(className)      \
00350     NCS_CB_LISTV_DRAWHDRBK  drawHdrBk;  \
00351     NCS_CB_LISTV_DRAWHDR    drawHdrItem;\
00352     NCS_CB_DRAWITEMBK   drawItemBk; \
00353     NCS_CB_DRAWITEM     drawSubItem;\
00354     mItemManager *hdrList;          \
00355     mListItem *rootItem;            \
00356     ncsLstClmSortType sort;         \
00357     int curCol;                     \
00358     int gridLineWidth;              \
00359     int gridLineColor;              \
00360     NCS_CB_LISTV_CMPCLM pfnSort;    \
00361     int hdrH;                       \
00362     int hdrW;                       \
00363     int dragedHead;                 \
00364     int dragX;                      \
00365     mListColumn *clickedHead;       \
00366     DWORD status;
00367
00402 struct _mListView
00403 {
00404         mListViewHeader(mListView)
00405 };
00406
00407 #define mListViewClassHeader(clsName, parentClass)  \
00408     mItemViewClassHeader(clsName, parentClass)      \
00409     NCS_CB_DRAWITEMBK (*setItemBkDraw)(clsName*, NCS_CB_DRAWITEMBK func);\
00410     NCS_CB_DRAWITEM (*setSubItemDraw)(clsName*, NCS_CB_DRAWITEM func);  \
00411     HITEM (*getRelatedItem)(clsName*,HITEM hItem,ncsListVIRType type);  \
00412     void (*setBackground)(clsName*,int row,int col,int *color);         \
00413     void (*setForeground)(clsName*,int row,int col,int *color);         \
00414     int (*getBackground)(clsName*,int row,int col,int *color);          \
00415     int (*getForeground)(clsName*,int row,int col,int *color);          \
00416     void (*sort)(clsName*, NCS_CB_LISTV_CMPCLM func, int col, ncsLstClmSortType sort);\
00417     void (*setCustomDrawHeader)(clsName*, NCS_CB_LISTV_CSTMHDROPS *func);\
00418     BOOL (*setItemInfo)(clsName*, NCS_LISTV_ITEMDATA *info);            \
00419     BOOL (*getItemInfo)(clsName*, NCS_LISTV_ITEMDATA *info);            \
00420     const char* (*getItemText)(clsName*, int row, int col);             \
00421     int (*getItemTextLen)(clsName*, int row, int col);                  \
00422         BOOL (*setItemText)(clsName*, int row, int col, const char* str);   \
00423     void (*setSortDirection)(clsName*, ncsLstClmSortType direction);    \
00424     ncsLstClmSortType (*getSortDirection)(clsName*);                    \
00425     HITEM (*findItem)(clsName*, NCS_LISTV_FINDINFO *info);              \
00426     mListColumn* (*getColumn)(clsName*, int index);                     \
00427     int (*getColumnIndex)(clsName*, mListColumn *column);               \
00428     int (*getColumnWidth)(clsName*, int index);                         \
00429     void (*setColumnWidth)(clsName*, int index, int width);             \
00430     int (*getColumnCount)(clsName*);                                    \
00431     mListColumn* (*getSortColumn)(clsName*);                            \
00432     void (*setSortColumn)(clsName*, mListColumn* column);               \
00433     void (*showColumn)(clsName*, mListColumn *column);                  \
00434     BOOL (*delColumn)(clsName*, int index);                             \
00435     BOOL (*addColumn)(clsName*, NCS_LISTV_CLMINFO *info);               \
00436     HITEM (*addItem)(clsName*, NCS_LISTV_ITEMINFO *info);               \
00437     BOOL (*setHeadText)(clsName*, int col, const char* text);           \
00438     HITEM (*getChildItem)(clsName*, HITEM parent,int index);            \
00439     int (*getChildCount)(clsName*, HITEM hItem);                        \
00440     int (*foldItem)(clsName*, HITEM hItem, BOOL fold);
00441
00442
00582 struct _mListViewClass
00583 {
00584         mListViewClassHeader(mListView, mItemView)
00585 };
00586
00587 #define mListViewRendererHeader(clsName, parentClass)               \
00588         mItemViewRendererHeader(clsName, parentClass)                   \
00589     void (*drawHeader) (clsName *self, HDC hdc, const RECT* pRect,  \
00590             DWORD color, int flag);                                 \
00591     void (*drawFold) (clsName *self, HDC hdc, const RECT* pRect,    \
00592             DWORD color, HICON icon, int status, int next);
00593
00607 struct  _mListViewRenderer {
00608         mListViewRendererHeader(mListView, mItemView)
00609 };
00610
00615 enum mListViewProp
00616 {
00618     NCSP_LISTV_DEFITEMHEIGHT = NCSP_ITEMV_DEFITEMHEIGHT,
00620     NCSP_LISTV_ROWCOUNT = NCSP_ITEMV_ITEMCOUNT,
00622     NCSP_LISTV_HDRHEIGHT = NCSP_ITEMV_MAX + 1,
00624     NCSP_LISTV_HDRWIDTH,
00626     NCSP_LISTV_HDRVISIBLE,
00628     NCSP_LISTV_SORTCOLUMN,
00630     NCSP_LISTV_GRIDLINEWIDTH,
00632     NCSP_LISTV_GRIDLINECOLOR,
00634     NCSP_LISTV_COLCOUNT,
00636         NCSP_LISTV_MAX,
00637 };
00638
00643 enum mListViewNotify
00644 {
00646     NCSN_LISTV_CLICKED = NCSN_ITEMV_CLICKED,
00648     NCSN_LISTV_SELCHANGED = NCSN_ITEMV_SELCHANGED,
00650     NCSN_LISTV_ITEMRDOWN = NCSN_ITEMV_MAX + 1,
00652     NCSN_LISTV_ITEMRUP,
00654     NCSN_LISTV_HDRRDOWN,
00656     NCSN_LISTV_HDRRUP,
00658     NCSN_LISTV_ITEMDBCLK,
00660     NCSN_LISTV_FOLDITEM,
00662     NCSN_LISTV_UNFOLDITEM,
00664         NCSN_LISTV_MAX
00665 };
00666
00673 MGNCS_EXPORT extern mListViewClass g_stmListViewCls;
00676 #ifdef __cplusplus
00677 }
00678 #endif  /* __cplusplus */
00679
00680 #endif /* _MGUI_CTRL_LISTV_H */
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mmainwnd.h Source File

include

mmainwnd.h

00001 /*
00002  * \file mmainwnd.h
00003  * \author dongjunjie
00004  * \date 2009/01/01
00005  *
00006  * This file include the main window defines
00007  *
00008  * \verbatim
00009  *
00010  *      This file is part of mgncs, new control of MiniGUI
00011  *
00012  *      \endverbatim
00013  *
00014  */
00015
00016 #ifndef _MGUI_CTRL_MNWND_H
00017 #define _MGUI_CTRL_MNWND_H
00018
00019 #ifdef __cplusplus
00020 extern "C" {
00021 #endif
00022
00032 #define NCSCTRL_MAINWND NCSCLASSNAME("mainwnd")
00033
00034 typedef struct _mMainWnd mMainWnd;
00035 typedef struct _mMainWndClass mMainWndClass;
00036 typedef struct _mMainWndRenderer mMainWndRenderer;
00037
00038 /*define mMainWndRender */
00039 #define mMainWndRendererHeader(clsName, parentClass) \
00040         mPanelRendererHeader(clsName, parentClass)
00041
00049 struct _mMainWndRenderer
00050 {
00051         mMainWndRendererHeader(mMainWnd, mPanel)
00052 };
00053
00054 /* define mMainWnd */
00055 #define mMainWndHeader(className) \
00056         mPanelHeader(className) \
00057         mComponent* parentCmp; \
00058         mComponent* nextCmp, *prevCmp;
00059
00066 struct _mMainWnd {
00067         mMainWndHeader(mMainWnd)
00068 };
00069
00070 #define MSG_MNWND_ENDDIALOG   MSG_LASTUSERMSG + 4
00071 //lParam is exit code
00072 //wParam is the special flag, used by interal
00073
00074 /* define mMainWndClass */
00075 #define mMainWndClassHeader(clsName, parentClass) \
00076         mPanelClassHeader(clsName, parentClass) \
00077         DWORD (*doModal)(clsName*,BOOL AutoDestroy);    \
00078         BOOL (*endDialog)(clsName*, DWORD code);
00079
00094 struct _mMainWndClass
00095 {
00096         mMainWndClassHeader(mMainWnd, mPanel)
00097 };
00098
00099 #define DECLARE_MAINWND_CLASS(clss, clssSuper)      \
00100         typedef mMainWndRenderer clss##Renderer;        \
00101         DECLARE_CLASS(clss, clssSuper)
00102
00103 #define NCS_MAINWND_ISMODE(obj)  (INSTANCEOF(obj, mMainWnd) && (GetWindowStyle(obj->hwnd) & NCSS_MNWND_MODE))
00104
00108 MGNCS_EXPORT extern mMainWndClass g_stmMainWndCls; //Class(mMainWnd);
00109
00110 enum enumMainWndProp {
00111         NCSP_MNWND_MAX = NCSP_PANEL_MAX + 1
00112 };
00113
00120 #define NCSS_MNWND_MODE  (1<<NCSS_PANEL_SHIFT)
00121 #define NCSS_MNWND_SHIFT (NCSS_PANEL_SHIFT+1)
00122 enum enumMainWndNotify{
00123         NCSN_MNWND_MAX = NCSN_PANEL_MAX + 1
00124 };
00125
00128 #ifdef __cplusplus
00129 }
00130 #endif
00131
00132 #endif
00133
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mmemanimateframes.h Source File

include

mmemanimateframes.h

00001 #ifndef _MGUI_NCS_CTRLMEMANIMATEFRAMES_H
00002 #define _MGUI_NCS_CTRLMEMANIMATEFRAMES_H
00003
00004 #ifdef _cplusplus
00005 extern "C"{
00006 #endif
00007
00008 typedef struct _mMemAnimateFrames mMemAnimateFrames;
00009 typedef struct _mMemAnimateFramesClass mMemAnimateFramesClass;
00010
00011 typedef struct _mMemAnimateFrame{
00012         PBITMAP pbmp;
00013         struct _mMemAnimateFrame* next;
00014         struct _mMemAnimateFrame* prev;
00015 }mMemAnimateFrame;
00016
00017 #define mMemAnimateFramesHeader(clsName) \
00018         mAnimateFramesHeader(clsName) \
00019         mMemAnimateFrame *frames;
00020
00021 struct _mMemAnimateFrames{
00022         mMemAnimateFramesHeader(mAnimateFrames)
00023 };
00024
00025 #define mMemAnimateFramesClassHeader(clss, superCls) \
00026         mAnimateFramesClassHeader(clss, superCls) \
00027
00028 struct _mMemAnimateFramesClass{
00029         mMemAnimateFramesClassHeader(mMemAnimateFrames, mAnimateFrames)
00030 };
00031
00032 MGNCS_EXPORT extern mMemAnimateFramesClass g_stmMemAnimateFramesCls;
00033
00034 //MGNCS_EXPORT mMemAnimateFrames * ncsCreateAnimateFramesFromMEM(PBITMAP * bmps, int count);
00035
00036 #ifdef _cplusplus
00037 }
00038 #endif
00039
00040 #endif
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mmenubutton.h Source File

include

mmenubutton.h

00001
00002 #ifndef _MGUI_NCSCTRL_MNUBTN_H
00003 #define _MGUI_NCSCTRL_MNUBTN_H
00004
00005
00006 #ifdef __cplusplus
00007 extern "C" {
00008 #endif  /* __cplusplus */
00009
00020 #define NCSCTRL_MENUBUTTON        NCSCLASSNAME("menubutton")
00021
00022 typedef struct _mMenuButton mMenuButton;
00023 typedef struct _mMenuButtonClass mMenuButtonClass;
00024 typedef struct _mMenuButtonRenderer mMenuButtonRenderer;
00025
00026 #define mMenuButtonHeader(className) \
00027         mButtonHeader(className)  \
00028         mPopMenuMgr * popmenu; \
00029         int cur_item;
00030
00040 struct _mMenuButton
00041 {
00042         mMenuButtonHeader(mMenuButton)
00043 };
00044
00045 #define mMenuButtonClassHeader(className, parentClass) \
00046         mButtonClassHeader(className, parentClass)
00047
00053 struct _mMenuButtonClass
00054 {
00055         mMenuButtonClassHeader(mMenuButton, mButton)
00056 };
00057
00058 #define mMenuButtonRendererHeader(clsName, parentClass) \
00059         mButtonRendererHeader(clsName, parentClass)
00060
00069 /* define the render of image static */
00070 struct _mMenuButtonRenderer {
00071         mMenuButtonRendererHeader(mMenuButton, mButton)
00072 };
00073
00078 MGNCS_EXPORT extern mMenuButtonClass g_stmMenuButtonCls;
00079
00084 enum mMenuButtonProp{
00092         NCSP_MNUBTN_POPMENU = NCSP_BUTTON_MAX + 1,
00100         NCSP_MNUBTN_CURITEM,
00101         NCSP_MNUBTN_MAX
00102 };
00103
00109 enum eMenuButtonNotify{
00115         NCSN_MNUBTN_ITEMCHANGED = NCSN_BUTTON_MAX + 1,
00116         NCSN_MNUBTN_MAX
00117 };
00118
00119 #define NCSS_MNUBTN_SHIFT NCSS_BUTTON_SHIFT
00120
00121
00125 #ifdef __cplusplus
00126 }
00127 #endif  /* __cplusplus */
00128
00129 #endif /* _MGUI_NCSCTRL_RECTANGLE_H */
00130
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mmledit.h Source File

include

mmledit.h

Go to the documentation of this file.
00001
00019 #ifndef _MGUI_NCSCTRL_MLEDIT_H
00020 #define _MGUI_NCSCTRL_MLEDIT_H
00021
00022 #ifdef __cplusplus
00023 extern "C" {
00024 #endif  /* __cplusplus */
00025
00026 /* ------------------------------- text document/buffer ------------------------ */
00027
00028 /* content type, reserved */
00029 typedef enum {
00030     CT_TEXT,
00031     CT_BMP,
00032     CT_ICON
00033 } ContentType;
00034
00035 /* text format, reserved */
00036 typedef enum {
00037     TF_PLAINTEXT,
00038     TF_RICHTEXT,
00039     TF_MEDIATEXT
00040 } TextFormat;
00041
00042 /* one text line (end with '\n') is a scrollview item */
00043 /* structure of text node/line */
00044 typedef struct _textnode
00045 {
00046     list_t    list;            /* list element */
00047     StrBuffer content;
00048     DWORD     addData;         /* for storing scrollview item handle */
00049 } TextNode;
00050
00051 /* structure of a text mark, recording insert position or selection range */
00052 typedef struct _textmark
00053 {
00054     int       pos_lnOff;       /* mark offset in the text node*/
00055     TextNode  *curNode;        /* text node containing the mark*/
00056 } TextMark;
00057
00058 /* structure of text document data */
00059 typedef struct _textdoc
00060 {
00061     list_t    queue;           /* text line/node head */
00062
00063     /* setup field */
00064     unsigned char lnsep;       /* line seperator (default is "\n") */
00065     int       nDefLineSize;    /* default line buffer size*/
00066     int       nBlockSize;      /* line buffer block size */
00067
00068     /* node init function executed when creating node */
00069     void      (*init_fn)     (struct _textdoc *, TextNode *, TextNode *);
00070     /* node change function executed when changing current insertion/selection node */
00071     void      (*change_fn)   (struct _textdoc *, BOOL bSel);
00072     /* node content change function executed when string content of a node is changed */
00073     void      (*change_cont) (struct _textdoc *, TextNode *node);
00074     /* node destroy function */
00075     void      (*del_fn)      (struct _textdoc *, TextNode *);
00076     void       *fn_data;       /* data passed to init_fn */
00077
00078     /* status field */
00079     TextMark  insert;          /* cursor/insertion mark */
00080     TextMark  selection;       /* selection mark */
00081
00082 } TextDoc;
00083
00084 /* -------------------------------------------------------------------------- */
00085
00086 /* backup data struct */
00087 typedef struct _status_data
00088 {
00089     DWORD     flags;        /* editor status */
00090
00091     int       desCaretX;  /* the desired caret x position, changed by mouse and <- , -> */
00092
00093     int       caretX;      /* caret x position in the virtual content window */
00094     int       caretY;      /* caret y position in the virtual content window */
00095     int       selX;        /* selection point x position in the virtual content window */
00096     int       selY;        /* selection point y position in the virtual content window */
00097
00098     TextNode  *maxNode;     /* node with the max length */
00099     int       maxLen;       /* max line length */
00100     TextNode  *secNode;     /* node with the second max length */
00101     int       secLen;       /* seconde max line length */
00102
00103     int       curItemY;     /* y position of the current insertion node */
00104     int       selItemY;     /* y position of the selection node */
00105 } STATDATA;
00106 typedef STATDATA* PSTATDATA;
00107
00108 /* structure of backup text node/line */
00109 typedef struct _bk_textnode
00110 {
00111     list_t    list;         /* list element */
00112     StrBuffer content;      /* text content */
00113 } BkNode;
00114
00115 typedef struct _backup_data
00116 {
00117     STATDATA  statData;
00118     TextMark  bkIns;        /* backup insertion point */
00119     TextMark  bkSel;        /* backup selection point */
00120     int       opType;       /* operation type */
00121     list_t    bkQueue;      /* backup text nodes */
00122 } BKDATA;
00123 typedef BKDATA* PBKDATA;
00124
00130 /*
00131  * \def NCSCTRL_MLEDIT
00132  * \brief the name of mledit control
00133 */
00134 #define NCSCTRL_MLEDIT   NCSCLASSNAME("mledit")
00135
00136 typedef struct _mMlEdit         mMlEdit;
00137 typedef struct _mMlEditClass    mMlEditClass;
00138 typedef struct _mMlEditRenderer mMlEditRenderer;
00139
00140
00141 #define mMlEditHeader(Class)        \
00142         mEditHeader(Class)          \
00143         TextDoc   txtDoc;           \
00144         StrBuffer teBuff;           \
00145         int       nrDiffLine;       \
00146         int       wNoChanged;       \
00147         int       wLastLine;        \
00148         int       hardLimit;        \
00149         int       curLen;           \
00150         int       nLineHeight;      \
00151         int       nLineAboveH;      \
00152         int       nLineBaseH;       \
00153         unsigned char lnChar;       \
00154         unsigned char caretShape;   \
00155         char      *title;           \
00156         int       titleIndent;      \
00157         DWORD     flags;            \
00158         DWORD     exFlags;          \
00159         BOOL      contDirty;        \
00160         int       desCaretX;        \
00161         int       caretX;           \
00162         int       caretY;           \
00163         int       selX;             \
00164         int       selY;             \
00165         TextNode  *maxNode;         \
00166         int       maxLen;           \
00167         TextNode  *secNode;         \
00168         int       secLen;           \
00169         int       curItemY;         \
00170         int       selItemY;         \
00171         TextCopyPaste *cp;
00172
00238 struct _mMlEdit
00239 {
00240     mMlEditHeader(mMlEdit)
00241 };
00242
00243 #define mMlEditClassHeader(clsName, parentClass)                   \
00244     mEditClassHeader (clsName, parentClass)                        \
00245     int (*setTitle)(clsName *self, const char *title, int len);    \
00246     int (*getTitle)(clsName *self, char *buffer, int len);
00247
00266 struct _mMlEditClass
00267 {
00268     mMlEditClassHeader(mMlEdit, mEdit)
00269 };
00270
00277 MGNCS_EXPORT extern mMlEditClass g_stmMlEditCls;
00278
00279
00280 #define mMlEditRendererHeader(clsName, parentClass) \
00281         mEditRendererHeader(clsName, parentClass)       \
00282
00283
00289 struct _mMlEditRenderer
00290 {
00291         mMlEditRendererHeader(mMlEdit, mEdit)
00292 };
00293
00298 #define NCSS_MLEDIT_AUTOWRAP   (0x0001<<NCSS_EDIT_SHIFT)
00299
00304 #define NCSS_MLEDIT_TITLE      (0x0002<<NCSS_EDIT_SHIFT)
00305
00306 #define NCSS_MLEDIT_SHIFT  (NCSS_EDIT_SHIFT+2)
00307
00309 enum mMlEditProp
00310 {
00311     NCSP_MLEDIT_LINECOUNT = NCSP_EDIT_MAX + 1,
00312     NCSP_MLEDIT_LINEHEIGHT,
00313     NCSP_MLEDIT_LINEFEEDISPCHAR,
00314     NCSP_MLEDIT_LINESEP,
00315     NCSP_MLEDIT_CARETSHAPE,
00316     NCSP_MLEDIT_NUMOFPARAGRAPHS,
00317     NCSP_MLEDIT_MAX
00318 };
00319
00320 enum mMlEditNotify
00321 {
00322     NCSN_MLEDIT_MAX = NCSN_EDIT_MAX + 1,
00323 };
00324
00326 enum ncsCaretShape
00327 {
00328     NCS_CARETSHAPE_LINE = 0,
00329     NCS_CARETSHAPE_BLOCK
00330 };
00331
00332
00333 /* internal status flags */
00334 #define NCSF_MLEDIT_SELECT         0x0001
00335 #define NCSF_MLEDIT_FOCUSED        0x0002
00336 #define NCSF_MLEDIT_TMP            0x0004
00337 #define NCSF_MLEDIT_REPLACE        0x0008
00338 #define NCSF_MLEDIT_MOVE           0x0010
00339 #define NCSF_MLEDIT_NOCARET        0x0020
00340 #define NCSF_MLEDIT_EX_SETFOCUS    0x0040
00341 #define NCSF_MLEDIT_EX_KILLFOCUS   0x0080
00342
00345 #ifdef __cplusplus
00346 }
00347 #endif  /* __cplusplus */
00348
00349 #endif /* _MGUI_NCSCTRL_MLEDIT_H */
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mmonthcalendar.h Source File

include

mmonthcalendar.h

00001
00002 #ifndef _MGUI_NCSCTRL_CDR_H
00003 #define _MGUI_NCSCTRL_CDR_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif
00008
00018 #define NCSCTRL_MONTHCALENDAR NCSCLASSNAME("monthcal")
00019
00020 typedef struct _mMonthCalendarClass mMonthCalendarClass;
00021 typedef struct _mMonthCalendar mMonthCalendar;
00022 typedef struct _mMonthCalendarRenderer mMonthCalendarRenderer;
00023
00024 #define mMonthCalendarRendererHeader(clss, superCls) \
00025    mWidgetRendererHeader(clss, superCls)
00026
00027 struct _mMonthCalendarRenderer
00028 {
00029         mMonthCalendarRendererHeader(mMonthCalendar, mWidget)
00030 };
00031
00032 #define mMonthCalendarClassHeader(clss, superCls) \
00033         mWidgetClassHeader(clss, superCls)
00034
00040 struct _mMonthCalendarClass
00041 {
00042         mMonthCalendarClassHeader(mMonthCalendar, mWidget)
00043 };
00044
00045 MGNCS_EXPORT extern mMonthCalendarClass g_stmMonthCalendarCls;
00046
00047 #define mMonthCalendarHeader(clss) \
00048         mWidgetHeader(clss)
00049
00055 struct _mMonthCalendar
00056 {
00057         mMonthCalendarHeader(mMonthCalendar)
00058 };
00059
00064 enum mMonthCalendarProps{
00071         NCSP_CDR_YEAR = NCSP_WIDGET_MAX + 1,
00077         NCSP_CDR_MONTH,
00083         NCSP_CDR_DAY,
00084         NCSP_CDR_MAX
00085 };
00086
00091 enum mMonthCalendarEvents{
00096         NCSN_CDR_YEAR_CHANGED = NCSN_WIDGET_MAX + 1,
00101         NCSN_CDR_MONTH_CHANGED,
00106         NCSN_CDR_DAY_CHANGED,
00107         NCSN_CDR_MAX
00108 };
00109
00114 #ifdef __cplusplus
00115 }
00116 #endif
00117
00118 #endif
00119
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mmonthpiece.h Source File

include » pieces

mmonthpiece.h

00001
00002 #ifndef _MGUI_NCSCTRL_MONTHPIECEPIECE_H
00003 #define _MGUI_NCSCTRL_MONTHPIECEPIECE_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif
00008
00009 typedef struct _mMonthPieceClass mMonthPieceClass;
00010 typedef struct _mMonthPiece mMonthPiece;
00011
00012 #define mMonthPieceClassHeader(clss, superCls) \
00013         mContainerPieceClassHeader(clss, superCls)
00014
00015 struct _mMonthPieceClass
00016 {
00017         mMonthPieceClassHeader(mMonthPiece, mContainerPiece)
00018 };
00019
00020 MGNCS_EXPORT extern mMonthPieceClass g_stmMonthPieceCls;
00021
00022 #define mMonthPieceHeader(clss) \
00023         mContainerPieceHeader(clss)  \
00024         unsigned char cur_day; \
00025         unsigned char hot_row; \
00026         unsigned char hot_col;
00027
00028 struct _mMonthPiece
00029 {
00030         mMonthPieceHeader(mMonthPiece)
00031 };
00032
00033 enum mMonthPieceProps{
00034         NCSP_MONTHPIECE_CURDAY = MONTHPIECE_PROP_BEGIN,
00035 };
00036
00037 enum mMonthPieceEvent {
00038         NCSN_MONTHPIECE_PREVMONTH = MONTHPIECE_EVENT_BEGIN,
00039         NCSN_MONTHPIECE_NEXTMONTH,
00040         NCSN_MONTHPIECE_DAYCHANGED
00041 };
00042
00043 #ifdef __cplusplus
00044 }
00045 #endif
00046
00047 #endif
00048
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mnode.h Source File

include

mnode.h

Go to the documentation of this file.
00001
00026 #ifndef _MGUI_WIDGET_NODE_H
00027 #define _MGUI_WIDGET_NODE_H
00028
00029
00030 #ifdef __cplusplus
00031 extern "C" {
00032 #endif  /* __cplusplus */
00033
00039 typedef struct _mNode mNode;
00040 typedef struct _mNodeClass mNodeClass;
00041
00046 #define NCSS_NODE_LTEXTRS           0x0000
00047
00053 #define NCSS_NODE_SMALLICON         0x0001
00054
00059 #define NCSS_NODE_LTEXTBS           0x0002
00060
00065 #define NCSS_NODE_TICTACTOEMIDLET   0x0004
00066
00067 #define NCSS_NODE_LAYOUT_MASK       0x00FF
00068
00073 #define NCSS_NODE_HIDETEXT          0x0010
00074
00079 #define NCSS_NODE_HIDEIMAGE         0x0020
00080
00085 #define NCSS_NODE_DISABLED          0x0040
00086
00091 #define NCSS_NODE_SHIFT             7
00092
00098 typedef int (*NCS_CB_CMPNODE) (mNode *node1, mNode *node2);
00099
00100 #define mNodeDataInfoHeader \
00101     int     style;      \
00102     char    *text;      \
00103     PBITMAP image;      \
00104     int     height;     \
00105     DWORD   addData;    \
00106     mObject *parent;    \
00107
00108
00109 typedef struct _NCS_NODE_DATA
00110 {
00111     mNodeDataInfoHeader
00112 }NCS_NODE_DATA;
00113
00114 //status flags
00115 #define NCSF_NODE_MASK              0xFFFF
00116 #define NCSF_NODE_NORMAL            0x0000
00117 #define NCSF_NODE_SELECTED          0x0001
00118 #define NCSF_NODE_DISABLED          0x0002
00119 #define NCSF_NODE_INVISIBLE         0x0004
00120 #define NCSF_NODE_DEFHEIGHT         0x0008
00121
00122 #define NCSF_NODE_HIDETEXT          0x0010
00123 #define NCSF_NODE_HIDEIMAGE         0x0020
00124
00125 typedef struct _NCS_NODE_LAYOUTOPS
00126 {
00127     const char name[16];
00128     int style;
00129     void (*paint)(mNode *self, HDC hdc, const RECT *rect, mObject *owner);
00130 }NCS_NODE_LAYOUTOPS;
00131
00132 #define mNodeHeader(className)  \
00133         mObjectHeader(className)    \
00134     NCS_NODE_LAYOUTOPS *layout; \
00135     list_t  children;           \
00136     list_t  sibling;            \
00137     Uint16  flags;              \
00138     Uint16  count;              \
00139     mNodeDataInfoHeader
00140
00172 struct _mNode
00173 {
00174         mNodeHeader(mNode)
00175 };
00176
00177 typedef struct _NCS_MENU_DATA
00178 {
00179     int     nr_child;
00180     struct _NCS_MENU_DATA   *child;
00181
00182     mNodeDataInfoHeader
00183 }NCS_MENU_DATA;
00184 MGNCS_EXPORT void ncsSetMenuData(mObject *self, NCS_MENU_DATA *pMenuData, int count);
00185
00186 typedef struct _NCS_MENU_INFO
00187 {
00188     int     count;
00189     char    *caption;
00190     NCS_MENU_DATA *data;
00191 }NCS_MENU_INFO;
00192 MGNCS_EXPORT void ncsSetMenu(mObject *self, NCS_MENU_INFO *pMenuInfo);
00193
00209 MGNCS_EXPORT mNode* ncsCreateNode(mObject *parent, const char* text,
00210         PBITMAP image, int height, int style, DWORD addData);
00211
00231 MGNCS_EXPORT mNode* ncsAddNode(mObject *parent, const char* text,
00232         PBITMAP image, int height, int style, DWORD addData);
00233
00238 enum ncsNodeFindType
00239 {
00243     NCS_NODE_FTSTRING,
00244
00248     NCS_NODE_FTDATA,
00249
00253     NCS_NODE_FTIMAGE,
00254
00255     NCS_NODE_FTOTHER,
00256 };
00257
00258 #define mNodeClassHeader(clsName, superCls)             \
00259         mObjectClassHeader(clsName, superCls)               \
00260         BOOL (*setProperty)(clsName*, int id, DWORD value); \
00261         DWORD (*getProperty)(clsName*, int id);             \
00262     BOOL (*computeSize)(clsName*, HDC hdc, SIZE *size); \
00263     BOOL (*canAsRoot)(clsName*);                        \
00264     int (*addNode)(clsName*, mNode *node);              \
00265     int (*removeNode)(clsName*, mNode *node);           \
00266     int (*insertNode)(clsName*, mNode *node, mNode *prev, mNode *next, int index);\
00267     int (*moveNode)(clsName*, mNode *curNode, int count, mNode *prevNode);  \
00268     mNode* (*findNode)(mNode *self, DWORD info, int type, BOOL recursion, int startIndex);\
00269     mNode* (*findNodeEx)(mNode *self, DWORD info, int type, BOOL recursion, int startIndex, \
00270             int (*cb)(mNode *node, DWORD info));        \
00271     void (*removeAll)(clsName*);                        \
00272     void (*sendEvent)(clsName*, int eventId);           \
00273     mNode* (*getNode)(clsName*, int index);             \
00274     int (*indexOf)(clsName*);                           \
00275     mNode* (*getPrev)(clsName*);                        \
00276     mNode* (*getNext)(clsName*);                        \
00277     BOOL (*isEnabled)(clsName*);                        \
00278     BOOL (*isSelected)(clsName*);                       \
00279     BOOL (*hasChildren)(clsName*);                      \
00280     BOOL (*setText)(clsName*, const char* text);        \
00281     BOOL (*setImage)(clsName*, const PBITMAP image);    \
00282     const char* (*getText)(clsName*);                   \
00283     PBITMAP (*getImage)(clsName*);                      \
00284     void (*paint)(clsName*, HDC hdc, const RECT *rect, mObject *owner);  \
00285         int (*msgHandler)(clsName*, int msg, WPARAM wParam, LPARAM lParam, mObject *owner);
00286
00387 struct _mNodeClass
00388 {
00389         mNodeClassHeader(mNode, mObject)
00390 };
00391
00392 typedef struct _mNodeEventData
00393 {
00394     mNode *source;
00395     DWORD data;
00396 }mNodeEventData;
00401 enum mNodeEvent
00402 {
00407     NCSE_NODE_CONTENTCHANGED = 1,
00408
00413     NCSE_NODE_HEIGHTCHANGED,
00414
00419     NCSE_NODE_REFRESH,
00420
00425     NCSE_NODE_NODEADDED,
00426
00431     NCSE_NODE_NODEDELETED,
00432 };
00433
00438 enum mNodeProp
00439 {
00443     NCSP_NODE_HEIGHT = 1,
00444
00448     NCSP_NODE_TEXT,
00449
00453     NCSP_NODE_IMAGE,
00454
00458     NCSP_NODE_ADDDATA,
00459
00463     NCSP_NODE_ENABLED,
00464
00468     NCSP_NODE_SELECTED,
00469
00473     NCSP_NODE_PARENTNODE,
00474
00478     NCSP_NODE_FIRSTCHILD,
00479
00483     NCSP_NODE_LASTCHILD,
00484
00488     NCSP_NODE_CHILDRENCOUNT,
00489
00493     NCSP_NODE_LAYOUT,
00494
00498     NCSP_NODE_HIDETEXT,
00499
00503     NCSP_NODE_HIDEIMAGE,
00504
00508         NCSP_NODE_MAX,
00509 };
00510
00517 MGNCS_EXPORT extern mNodeClass g_stmNodeCls;
00518
00519 /*============================================*/
00520 typedef struct _mGroupNode mGroupNode;
00521 typedef struct _mGroupNodeClass mGroupNodeClass;
00522
00523 typedef struct _NCS_GROUPNODE_DATA
00524 {
00525     mNodeDataInfoHeader
00526     int id;
00527 }NCS_GROUPNODE_DATA;
00528
00529 #define mGroupNodeHeader(className)  \
00530         mNodeHeader(className)      \
00531     int id;
00532 struct _mGroupNode
00533 {
00534         mGroupNodeHeader(mGroupNode)
00535 };
00536
00537 #define mGroupNodeClassHeader(clsName, superCls)    \
00538         mNodeClassHeader(clsName, superCls)
00539 struct _mGroupNodeClass
00540 {
00541         mGroupNodeClassHeader(mGroupNode, mNode)
00542 };
00543
00550 MGNCS_EXPORT extern mGroupNodeClass g_stmGroupNodeCls;
00551
00552 MGNCS_EXPORT mNode* ncsAddGroupNode(mObject *parent, const char* text,
00553         PBITMAP image, int height, int style, DWORD addData, int id);
00554
00555
00556 #define NCS_CREATE_NODE(_retnode, _clstype, _parent, _text, _image, _height, _style, _add_data)\
00557 do{\
00558     NCS_NODE_DATA data;         \
00559     if (!_parent || (!INSTANCEOF(_parent, mNode) && !INSTANCEOF(_parent, mAbstractList))){  \
00560         _retnode = NULL;        \
00561     }\
00562     data.text = (char*)_text;   \
00563     data.image = _image;        \
00564     data.height = _height;      \
00565     data.style = _style;        \
00566     data.addData = _add_data;   \
00567     data.parent = _parent;      \
00568     _retnode = NEWEX(_clstype, (DWORD)&data);  \
00569 }while(0)
00570
00571 #define NCS_ADD_NODE(_retnode, _clstype, _parent, text, image, height, style, _add_data)\
00572 do {\
00573     NCS_CREATE_NODE(_retnode, _clstype, _parent, text, image, height, style, _add_data);\
00574     int ret = -1;               \
00575     if (_retnode && _parent && INSTANCEOF(_parent, mAbstractList)) {\
00576         mAbstractList *list = (mAbstractList*)_parent;              \
00577         if (_c(list)->addNode)                                      \
00578             ret = _c(list)->addNode(list, (mNode*)_retnode);              \
00579     }                           \
00580     else if (_retnode && _parent && INSTANCEOF(_parent, mNode)) {   \
00581         mNode *list = (mNode *)_parent;                             \
00582         if (_c(list)->addNode)                                      \
00583             ret = _c(list)->addNode(list, (mNode*)_retnode);              \
00584     }                           \
00585     if (ret < 0) {              \
00586         DELETE(_retnode);        \
00587         _retnode = NULL;         \
00588     }\
00589 }while(0)
00590
00593 #ifdef __cplusplus
00594 }
00595 #endif  /* __cplusplus */
00596
00597 #endif /* _MGUI_WIDGET_NODE_H */
00598
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mnumspinnedpiece.h Source File

include » pieces

mnumspinnedpiece.h

00001 #ifndef _MGNCS_NUMSPINNEDPIECE_H
00002 #define _MGNCS_NUMSPINNEDPIECE_H
00003
00004 #ifdef __cplusplus
00005 extern "C" {
00006 #endif
00007
00008 typedef struct _mNumSpinnedPieceClass mNumSpinnedPieceClass;
00009 typedef struct _mNumSpinnedPiece mNumSpinnedPiece;
00010
00011 #define mNumSpinnedPieceClassHeader(clss, superCls) \
00012         mLabelPieceClassHeader(clss, superCls)
00013
00014 struct _mNumSpinnedPieceClass
00015 {
00016         mNumSpinnedPieceClassHeader(mNumSpinnedPiece, mLabelPiece)
00017 };
00018
00019 MGNCS_EXPORT extern mNumSpinnedPieceClass g_stmNumSpinnedPieceCls;
00020
00021 #define mNumSpinnedPieceHeader(clss) \
00022         mLabelPieceHeader(clss)
00023
00024 struct _mNumSpinnedPiece
00025 {
00026         mNumSpinnedPieceHeader(mNumSpinnedPiece)
00027 };
00028
00029
00030 #ifdef __cplusplus
00031 }
00032 #endif
00033
00034 #endif
00035
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mobject.h Source File

include

mobject.h

Go to the documentation of this file.
00001
00016 #ifndef _MGUI_NCSCTRL_OBJECT_H
00017 #define _MGUI_NCSCTRL_OBJECT_H
00018
00019 #ifdef __cplusplus
00020 extern "C"{
00021 #endif
00022
00028 #define MGNCS_INIT_CLASS(clss) \
00029         Class(clss).classConstructor((mObjectClass*)(void*)(&(Class(clss))))
00030
00034 #define _c(ths)                 (ths)->_class
00035 #define ClassType(className)    className##Class
00036 #define Class(className)        g_st##className##Cls
00037 #define ObjectType(className)   className
00038
00039 #ifdef  WIN32
00040 #define _TYPEOF(x)  void* //__typeof(x)
00041 #else
00042 #define _TYPEOF(x)  typeof(x)
00043 #endif
00044
00045 #define BEGIN_MINI_CLASS(clss, superCls) \
00046 static ClassType(clss) * clss##ClassConstructor(ClassType(clss)* _class); \
00047 ClassType(clss) Class(clss) = { (PClassConstructor)clss##ClassConstructor }; \
00048 static const char* clss##_type_name = #clss; \
00049 static ClassType(clss) * clss##ClassConstructor(ClassType(clss)* _class) { \
00050         unsigned short * _pintfOffset;                                         \
00051         _class = (ClassType(clss)*)((PClassConstructor)(Class(superCls).classConstructor))((mObjectClass*)_class); \
00052         _class->super = &Class(superCls); \
00053         _class->typeName = clss##_type_name; \
00054         _class->objSize = sizeof(clss);      \
00055         _pintfOffset = &_class->intfOffset;
00056
00057 #define END_MINI_CLASS return _class; }
00058
00059 #define CLASS_METHOD_MAP(clss, name) \
00060                 _class->name = (_TYPEOF(_class->name))(clss##_##name);
00061
00062
00063 #define NEED_CHECK
00064
00065 #ifdef NEED_CHECK
00066 #define CHECK_METHOD(cls, mth)  ((cls) && (cls)->mth)
00067 #else
00068 #define CHECK_METHOD(cls, mth)  (1)
00069 #endif
00070
00071
00072 #define PUBLIC
00073 #define PRIVATE
00074 #define PROTECTED
00075 #define STATIC
00076
00077 #define _M(pobj, method, ...)  _c(pobj)->method((pobj), ##__VA_ARGS__)
00078
00079 #define DECLARE_CLASSEX(EXPORT, clss, clssSuper) \
00080         typedef struct _##clss##Class clss##Class; \
00081         typedef struct _##clss clss; \
00082         struct _##clss##Class{ \
00083                 clss##ClassHeader(clss, clssSuper) \
00084         }; \
00085         struct _##clss { \
00086                 clss##Header(clss) \
00087         }; \
00088         EXPORT extern clss##Class g_st##clss##Cls;
00089
00090 #define DECLARE_CLASS(clss, clssSuper) DECLARE_CLASSEX(MGNCS_EXPORT, clss, clssSuper)
00091 #define NONE_EXPORT
00092
00093 #define _SUPER(super,self,method, ...)  Class(super).method((super*)(self), ##__VA_ARGS__)
00094
00095 #define DECLARE_OBJECT(Clss)  \
00096         typedef struct _##Clss##Class Clss##Class;  \
00097         typedef struct _##Clss Clss;  \
00098         MGNCS_EXPORT extern Clss##Class g_st##Clss##Cls;
00099
00100 #define DEFINE_OBJECT(Clss, ClssSuper)  \
00101         struct _##Clss##Class { Clss##ClassHeader(Clss, ClssSuper) }; \
00102         struct _##Clss { Clss##Header(Clss) };
00103
00105 #define INTERFACE(Interface)  \
00106         Interface##VTable * Interface##_; /*Interface vtable*/
00107
00108 #define DECLARE_INTERFACE(Interface)  \
00109         typedef struct _##Interface##VTable Interface##VTable; \
00110         typedef struct _##Interface Interface;
00111
00112 #define DEFINE_INTERFACE(Interface)          \
00113         struct _##Interface##VTable {                             \
00114                 Interface##Header(Interface, Interface)         \
00115         };                                                        \
00116         struct _##Interface { Interface##VTable *_vtable; };
00117
00118 #define IMPLEMENT(Clss,Interface) \
00119         _class->_##Interface##_obj_offset = (unsigned int)(void*)&(((Clss*)0)->Interface##_); \
00120         _class->_##Interface##_next_offset = 0;                                                \
00121         *_pintfOffset =  (unsigned short)(unsigned int)(void*)&(((ClassType(Clss)*)0)->_##Interface##_obj_offset); \
00122         _pintfOffset = &_class->_##Interface##_next_offset;
00123
00124 #define INTERFACE_CAST(Interface, pobj)  \
00125         ((Interface*)((unsigned char*)(pobj) + (_c(pobj)->_##Interface##_obj_offset)))
00126
00127 //the basic interface
00128 DECLARE_INTERFACE(IInterface)
00129 struct _IInterfaceVTable{
00130         unsigned short _obj_offset;
00131         unsigned short _next_offset;
00132 };
00133
00134 struct _IInterface {
00135         IInterfaceVTable * _vtable;
00136 };
00137
00138 #define IInterfaceHeader(Interface, ClssImpl)  \
00139         unsigned short _##Interface##_obj_offset; \
00140         unsigned short _##Interface##_next_offset; \
00141
00142
00146 #define INTEFACE_ADJUST(piobj)  (_TYPEOF(piobj))((unsigned char*)(piobj) -  \
00147                 ((IInterfaceVTable*)((piobj))->_vtable)->_obj_offset)
00148
00149 #define INTERFACE2OBJECT(type, piobj)  (type*)((unsigned char*)(piobj) - ((IInterfaceVTable*)((piobj))->_vtable)->_obj_offset)
00150
00155 #define _IM(piobj, method, ...) \
00156         (piobj)->_vtable->method(INTEFACE_ADJUST(piobj), ##__VA_ARGS__)
00157 #define _I(piobj)  (piobj)->_vtable
00158
00159
00160
00161 typedef struct _mObjectClass mObjectClass;
00162 typedef struct _mObject mObject;
00163
00172 typedef mObjectClass* (*PClassConstructor)(mObjectClass *);
00173
00184 typedef void (*PCONSTRUCT_DWORD)(void* self, DWORD addData);
00185 #include <stdarg.h>
00186 typedef void (*PCONSTRUCT_VALIST)(void* self, va_list va);
00187
00188 #define mObjectClassHeader(clss, superCls) \
00189         PClassConstructor classConstructor; \
00190         ClassType(superCls) * super; \
00191         const char* typeName; \
00192         unsigned short objSize; \
00193         unsigned short intfOffset;  \
00194         void (*construct)(clss *self, DWORD addData); \
00195         void (*destroy)(clss *self); \
00196         DWORD (*hash)(clss *self); \
00197         const char* (*toString)(clss *self, char* str, int max);  \
00198     int (*addRef)(clss*); \
00199     int (*release)(clss*);
00200
00201
00202
00203
00233 struct _mObjectClass {
00234         mObjectClassHeader(mObject, mObject)
00235 };
00236
00241 MGNCS_EXPORT extern mObjectClass g_stmObjectCls; //Class(mObject);
00242
00243 enum mObjectStatus
00244 {
00245     NCSF_OBJECT_TODEL = 0x1000,
00246 };
00247 #define NCS_OBJ_TODEL(self) (self->objStatus & NCSF_OBJECT_TODEL)
00248
00249 #define mObjectHeader(clss) \
00250         ClassType(clss) * _class; \
00251     short objRefCount; \
00252     short objStatus;
00253
00264 struct _mObject {
00265         mObjectHeader(mObject)
00266 };
00267
00268
00272 MGNCS_EXPORT void ncsRefObjFreeSpecificData(DWORD key, DWORD value);
00273
00274 MGNCS_EXPORT mObject* initObject(mObject* pobj, mObjectClass* _class);
00275
00279 static inline mObject* _initObject(mObject* pobj, mObjectClass* _class,DWORD param) {
00280         memset(pobj, 0, _class->objSize);
00281         initObject(pobj, _class);
00282         ((PCONSTRUCT_DWORD)(_class->construct))(pobj, param);
00283         return pobj;
00284 }
00285
00290 static inline mObject* initObjectArgs(mObject* pobj, mObjectClass* _class, ...)
00291 {
00292         va_list va;
00293         va_start(va, _class);
00294         memset(pobj, 0, _class->objSize);
00295         initObject(pobj, _class);
00296         ((PCONSTRUCT_VALIST)(_class->construct))(pobj, va);
00297         va_end(va);
00298         return pobj;
00299 }
00300
00301 #define INIT_OBJEX(Clss, pobj, param)  ((Clss* )_initObject((mObject*)(pobj), (mObjectClass*)&Class(Clss), (DWORD)(param)))
00302 #define INIT_OBJ(Clss, pobj)  INIT_OBJEX(Clss, pobj, 0)
00303 #define INIT_OBJV(Clss, pobj, ...) ((Clss* )initObjectArgs((mObject*)(pobj), (mObjectClass*)&Class(Clss), ##__VA_ARGS__))
00304 static inline int GET_ARG_COUNT(va_list va){
00305         union {
00306                 va_list va;
00307                 DWORD   dva;
00308         }_va;
00309         _va.va = va;
00310         if(_va.dva == 0)
00311                 return 0;
00312     return 1;
00313 }
00314 #define UNIT_OBJ(pobj)  (_c(pobj)->destroy(pobj))
00315
00316
00317
00318
00340 MGNCS_EXPORT mObject * newObject(mObjectClass *_class);
00341 static inline mObject * ncsNewObject(mObjectClass *_class,DWORD addData){
00342         mObject * obj = newObject(_class);
00343         if(!obj)
00344                 return NULL;
00345
00346         _class->construct(obj, addData);
00347         return obj;
00348 }
00349
00350 #define NEWEX(classType, addData)  (classType*)ncsNewObject((mObjectClass*)(void *)(&Class(classType)), addData)
00351 #define NEW(classType)  NEWEX(classType, 0)
00352 static inline mObject * _newobject_args(mObjectClass* _class, ...)
00353 {
00354         va_list va;
00355         mObject * obj;
00356         va_start(va, _class);
00357         obj = newObject(_class);
00358         if(obj)
00359                 ((PCONSTRUCT_VALIST)(_class->construct))(obj, va);
00360         va_end(va);
00361         return obj;
00362 }
00363 #define NEWV(Clss, ...)  ((Clss*)_newobject_args((mObjectClass*)&(Class(Clss)), ##__VA_ARGS__))
00364
00372 MGNCS_EXPORT void deleteObject(mObject *obj);
00373 #define DELETE(obj)   deleteObject((mObject*)(obj))
00374
00379 #define TYPENAME(obj)  ((obj)?(((obj)->_class)?((obj)->_class)->typeName:""):"")
00380
00382
00392 MGNCS_EXPORT BOOL ncsInstanceOf(mObject* object, mObjectClass* clss);
00393
00402 #define INSTANCEOF(obj, clss)  ncsInstanceOf((mObject*)(obj), (mObjectClass*)(void*)(&Class(clss)))
00403
00412 static inline mObject*  ncsIsValidObj(mObject* obj){
00413         return (INSTANCEOF(obj, mObject)?(obj):NULL);
00414 }
00415
00422 #define CHECKOBJ(obj)  ncsIsValidObj((mObject*)obj)
00423
00435 MGNCS_EXPORT mObject* ncsSafeCast(mObject* obj, mObjectClass *clss);
00436
00441 #define TYPE_CAST(Type, obj)  ((Type*)(obj))
00442
00450 #define SAFE_CAST(Type, obj)  TYPE_CAST(Type, ncsSafeCast((mObject*)obj,(mObjectClass*)(void*)(&(Class(Type)))))
00451
00463 MGNCS_EXPORT mObjectClass *ncsSafeCastClass(mObjectClass* clss, mObjectClass* castCls);
00468 #define SAFE_CAST_CLASS(Clss, ClssCast) ((ClassType(ClssCast)*)(ncsSafeCastClass((mObjectClass*)Clss, (mObjectClass*)(void*)(&Class(ClssCast)))))
00469
00470 int ncsParseConstructParams(va_list args, const char* signature, ...);
00471
00485 typedef BOOL (*NCS_CB_ONOBJEVENT)(mObject* self, mObject *sender, int eventId, DWORD param);
00486
00487 #define NCS_CB_ONPIECEEVENT NCS_CB_ONOBJEVENT
00488
00505 MGNCS_EXPORT BOOL ncsAddEventListener(mObject *sender,
00506         mObject* listener,
00507         NCS_CB_ONOBJEVENT eventProc,
00508         int eventId);
00509
00526 MGNCS_EXPORT BOOL ncsAddEventListeners(mObject *sender,
00527         mObject* listener,
00528         NCS_CB_ONOBJEVENT eventProc,
00529         int* eventIds);
00530
00541 MGNCS_EXPORT BOOL ncsRemoveEventListener(mObject * listener);
00542
00552 MGNCS_EXPORT BOOL ncsRemoveEventConnect(mObject* listener, mObject* source, int eventId);
00553
00564 MGNCS_EXPORT BOOL ncsRemoveEventSource(mObject *sender);
00565
00578 MGNCS_EXPORT void ncsRaiseEvent(mObject *sender, int eventId, DWORD param);
00579
00580
00585 #ifdef __cplusplus
00586 }
00587 #endif
00588
00589
00590 #endif
00591
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: Module Index

Modules

Here is a list of all modules:
  • mAbstractList
  • mButton
  • mButtonGroup
  • mCheckButton
  • mColorButton
  • mCombobox
  • mComponent
  • mContainer
  • mDialogBox
  • mEdit
  • mGroupBox
  • mIconView
  • mImage
  • mInvisibleComponent
  • mItem
  • mItemManager
  • mItemView
  • mLEDLabel
  • mList
  • mListLayout
  • mListBox
  • mListColumn
  • mListItem
  • mListView
  • mMainWnd
  • mMenuButton
  • mMlEdit
  • mMonthCalendar
  • mNode
  • mObject
  • mPage
  • mPanel
  • mPopMenuMgr
  • mProgressBar
  • mPropSheet
  • mRadioButton
  • mRectangle
  • Resource Managerment
  • mScrollWidget
  • mScrollBar
  • mScrollView
  • mSeparator
  • mSlEdit
  • mSlider
  • mSpinBox
  • mSpinner
  • mStatic
  • mTextEditor
  • mTimer
  • mToolBar
  • mToolItem
  • mTrackBar
  • mWidget
  • Global defines
    • Global Component Functions
    • Gloal InvisibleComponent Functions
    • Global Object Functions
    • Global Control function
  • Renderer Elements
    • Common Renderer Elements
Generated on Mon Dec 13 11:32:18 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mpage.h Source File

include

mpage.h

Go to the documentation of this file.
00001
00026 #ifndef _MGUI_NCSCTRL_PAGE_H
00027 #define _MGUI_NCSCTRL_PAGE_H
00028
00029 #ifdef __cplusplus
00030 extern "C" {
00031 #endif  /* __cplusplus */
00032
00042 #define NCSCTRL_PAGE           NCSCLASSNAME("page")
00043
00044 typedef struct _mPage mPage;
00045 typedef struct _mPageClass mPageClass;
00046 typedef struct _mPageRenderer mPageRenderer;
00047
00052 #define NCSS_PAGE_SHIFT NCSS_CTNR_SHIFT
00053
00054 #define mPageHeader(className)  \
00055         mContainerHeader(className) \
00056     int     titleWidth;         \
00057     HICON   hIcon;
00058
00059
00072 struct _mPage
00073 {
00074         mPageHeader(mPage)
00075 };
00076
00077 #define mPageClassHeader(clsName, parentClass)         \
00078         mContainerClassHeader(clsName, parentClass)        \
00079     const char* (*getTitle)(clsName* self);            \
00080     BOOL (*setTitle)(clsName* self, const char* title);\
00081     int (*getTitleLength)(clsName* self);              \
00082     int (*getTitleWidth)(clsName* self, HDC hdc);      \
00083     BOOL (*setIcon)(clsName* self, HICON icon);        \
00084     HICON (*getIcon)(clsName* self);                   \
00085     void (*showPage)(clsName* self, int showCmd);
00086
00124 struct _mPageClass
00125 {
00126         mPageClassHeader(mPage, mContainer)
00127 };
00128
00140 typedef void (*NCS_CB_ONINITPAGE)(mPage *self, DWORD addData);
00141
00156 typedef int (*NCS_CB_ONSHOWPAGE)(mPage *self, HWND focusChild, int showCmd);
00157
00171 typedef int (*NCS_CB_ONSHEETCMD)(mPage *self, DWORD param1, DWORD param2);
00172
00173 #define mPageRendererHeader(clsName, parentClass) \
00174         mContainerRendererHeader(clsName, parentClass)
00175
00180 struct  _mPageRenderer {
00181          mPageRendererHeader(mPage, mContainer)
00182 };
00183
00184
00191 MGNCS_EXPORT extern mPageClass g_stmPageCls;
00192
00194 #ifdef __cplusplus
00195 }
00196 #endif  /* __cplusplus */
00197
00198 #endif /* _MGUI_NCSCTRL_PAGE_H */
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mpairpiece.h Source File

include » pieces

mpairpiece.h

00001
00002 #ifndef _MGUI_NCSCTRL_PAIRPIECE_H
00003 #define _MGUI_NCSCTRL_PAIRPIECE_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif
00008
00009 typedef struct _mPairPieceClass mPairPieceClass;
00010 typedef struct _mPairPiece mPairPiece;
00011
00012 #define mPairPieceClassHeader(clss, superCls) \
00013         mLayoutPieceClassHeader(clss, superCls)
00014
00015 struct _mPairPieceClass
00016 {
00017         mPairPieceClassHeader(mPairPiece, mLayoutPiece)
00018 };
00019
00020 MGNCS_EXPORT extern mPairPieceClass g_stmPairPieceCls;
00021
00022 #define mPairPieceHeader(clss) \
00023         mLayoutPieceHeader(clss)  \
00024         DWORD flags; \
00025         mHotPiece *first; \
00026         mHotPiece *second;
00027
00028 struct _mPairPiece
00029 {
00030         mPairPieceHeader(mPairPiece)
00031 };
00032
00033 #define NCS_PAIRPIECE_DIRECTION_MASK 0x80000000
00034 #define NCS_PAIRPIECE_FIRST_MASK     0x40000000
00035 #define NCS_PAIRPIECE_SIZE_TYPE_MASK 0x30000000
00036 #define NCS_PAIRPIECE_SIZE_MASK      0x00000FFF
00037 #define NCS_PAIRPIECE_SPACE_MASK     0x0FF00000
00038 #define NCS_PAIRPIECE_MARGIN_MASK    0x000FF000
00039
00040 #define mPairPiece_setVert(self)   ((self)->flags |= NCS_PAIRPIECE_DIRECTION_MASK)
00041 #define mPairPiece_setHorz(self)   ((self)->flags &= ~NCS_PAIRPIECE_DIRECTION_MASK)
00042 #define mPairPiece_isVert(self)    ((self)->flags & NCS_PAIRPIECE_DIRECTION_MASK)
00043
00044 #define mPairPiece_setReverse(self)      ((self)->flags |= NCS_PAIRPIECE_FIRST_MASK)
00045 #define mPairPiece_cancelReverse(self)   ((self)->flags &= ~NCS_PAIRPIECE_FIRST_MASK)
00046 #define mPairPiece_reversed(self)        ((self)->flags & NCS_PAIRPIECE_FIRST_MASK)
00047 //#define mPairPiece_getFirst(self)   (((self)->flags&NCS_PAIRPIECE_FIRST_MASK)?self->second:self->first)
00048 #define mPairPiece_getFirst(self)   ((self)->first)
00049 //#define mPairPiece_getSecond(self)   (((self)->flags&NCS_PAIRPIECE_FIRST_MASK)?self->first:self->second)
00050 #define mPairPiece_getSecond(self)  ((self)->second)
00051 #define mPairPiece_setFirst(self, piece)   do{ \
00052         if(((self)->flags&NCS_PAIRPIECE_FIRST_MASK)) \
00053                 (self)->second=(piece); \
00054         else \
00055                 (self)->first=(piece); \
00056 }while(0)
00057
00058 #define mPairPiece_setSecond(self, piece)   do{ \
00059         if(((self)->flags&NCS_PAIRPIECE_FIRST_MASK)) \
00060                 (self)->first=(piece); \
00061         else \
00062                 (self)->second=(piece); \
00063 }while(0)
00064
00065
00066
00067 enum mPairPieceSizeType{
00068         NCS_PAIRPIECE_ST_FIXED = NCS_LAYOUTPIECE_ST_FIXED,
00069         NCS_PAIRPIECE_ST_PERCENT = NCS_LAYOUTPIECE_ST_PERCENT,
00070         NCS_PAIRPIECE_ST_AUTO = NCS_LAYOUTPIECE_ST_AUTO
00071 };
00072
00073 #define SET_BIT_VALUE(dword, value, mask,offset)  ((dword) = ((dword)& (~(mask))) | (((value)<<(offset))&mask))
00074 #define GET_BIT_VALUE(dword, mask, offset)   (((dword)&(mask))>>(offset))
00075
00076 #define mPairPiece_setFirstSizeType(self, type)  SET_BIT_VALUE(self->flags, type, NCS_PAIRPIECE_SIZE_TYPE_MASK,28)
00077 #define mPairPiece_getFirstSizeType(self)        GET_BIT_VALUE(self->flags, NCS_PAIRPIECE_SIZE_TYPE_MASK, 28)
00078 #define mPairPiece_setFirstSize(self, size)      (self->flags = (self->flags&(~NCS_PAIRPIECE_SIZE_MASK))|((size)&NCS_PAIRPIECE_SIZE_MASK))
00079 #define mPairPiece_getFirstSize(self)            (int)(self->flags&NCS_PAIRPIECE_SIZE_MASK)
00080
00081 #define mPairPiece_setSpace(self, space)         SET_BIT_VALUE(self->flags, space, NCS_PAIRPIECE_SPACE_MASK, 20)
00082 #define mPairPiece_getSpace(self)                (int)GET_BIT_VALUE(self->flags, NCS_PAIRPIECE_SPACE_MASK, 20)
00083
00084 #define mPairPiece_setMargin(self, margin)       SET_BIT_VALUE(self->flags, margin, NCS_PAIRPIECE_MARGIN_MASK, 12)
00085 #define mPairPiece_getMargin(self)               (int)GET_BIT_VALUE(self->flags, NCS_PAIRPIECE_MARGIN_MASK, 12)
00086
00087 enum mPairPieceProps{
00088         NCSP_PAIRPIECE_SECOND_AS_FIRST = PAIRPIECE_PROP_BEGIN,
00089         NCSP_PAIRPIECE_FIRST_SIZE_TYPE,
00090         NCSP_PAIRPIECE_FIRST_SIZE,
00091         NCSP_PAIRPIECE_FIRST,
00092         NCSP_PAIRPIECE_SECOND,
00093         NCSP_PAIRPIECE_DIRECTION = PIECECOMM_PROP_DIRECTION,
00094         NCSP_PAIRPIECE_SPACE     = PIECECOMM_PROP_SPACE,
00095         NCSP_PAIRPIECE_MARGIN    = PIECECOMM_PROP_MARGIN
00096 };
00097
00098 #ifdef __cplusplus
00099 }
00100 #endif
00101
00102 #endif
00103
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mpanel.h Source File

include

mpanel.h

Go to the documentation of this file.
00001
00026 #ifndef _MGUI_NCSCTRL_PANEL_H
00027 #define _MGUI_NCSCTRL_PANEL_H
00028
00029
00030 #ifdef __cplusplus
00031 extern "C" {
00032 #endif  /* __cplusplus */
00033
00043 #define NCSCTRL_PANEL   NCSCLASSNAME("panel")
00044
00045 typedef struct _mPanel mPanel;
00046 typedef struct _mPanelClass mPanelClass;
00047 typedef struct _mPanelRenderer mPanelRenderer;
00048
00049 #define mPanelHeader(className) \
00050         mWidgetHeader(className)
00051
00057 struct _mPanel
00058 {
00059         mPanelHeader(mPanel)
00060 };
00061
00062 #define mPanelClassHeader(clsName, parentClass) \
00063         mWidgetClassHeader(clsName, parentClass)
00064
00070 struct _mPanelClass
00071 {
00072         mPanelClassHeader(mPanel, mWidget)
00073 };
00074
00075 #define mPanelRendererHeader(clsName, parentClass) \
00076         mWidgetRendererHeader(clsName, parentClass)
00077
00083 struct  _mPanelRenderer {
00084         mPanelRendererHeader(mPanel, mWidget)
00085 };
00086
00087
00094 MGNCS_EXPORT extern mPanelClass g_stmPanelCls;
00095
00100 enum mPanelProp {
00104     NCSP_PANEL_MAX = NCSP_WIDGET_MAX + 1
00105 };
00106
00111 #define NCSS_PANEL_SHIFT NCSS_WIDGET_SHIFT
00112
00117 enum mPanelNotify {
00121         NCSN_PANEL_MAX = NCSN_WIDGET_MAX + 1
00122 };
00123
00126 #ifdef __cplusplus
00127 }
00128 #endif  /* __cplusplus */
00129
00130 #endif /* _MGUI_NCSCTRL_PANEL_H */
00131
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mpopmenumgr.h Source File

include

mpopmenumgr.h

00001
00002 #ifndef _MG_MINIPOPMENUMGR_H
00003 #define _MG_MINIPOPMENUMGR_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif
00008
00014 typedef struct _mPopMenuMgrClass mPopMenuMgrClass;
00015 typedef struct _mPopMenuMgr mPopMenuMgr;
00016
00017 #define mPopMenuMgrClassHeader(clss, clsSuper) \
00018         mObjectClassHeader(clss, clsSuper) \
00019         BOOL (*addItem)(clss *, int type, const char* str, PBITMAP bmp, int id, int state,  mPopMenuMgr *subMenu, DWORD add_data); \
00020         HMENU (*createMenu)(clss *); \
00021         void (*popMenu)(clss *, mObject *owner); \
00022         BOOL (*addSeparator)(clss *); \
00023         BOOL (*getMenuItem)(clss *, int idx, MENUITEMINFO *pmii, BOOL byCommand);
00024
00076 struct _mPopMenuMgrClass {
00077         mPopMenuMgrClassHeader(mPopMenuMgr, mObject)
00078 };
00079
00080 MGNCS_EXPORT extern mPopMenuMgrClass g_stmPopMenuMgrCls;
00081
00082
00083 typedef struct mPopMenuItem mPopMenuItem;
00084
00085 #define mPopMenuMgrHeader(clss) \
00086         mObjectHeader(clss) \
00087         mPopMenuItem *head;
00088
00095 struct _mPopMenuMgr {
00096         mPopMenuMgrHeader(mPopMenuMgr)
00097 };
00098
00103 #ifdef __cplusplus
00104 }
00105 #endif
00106
00107 #endif
00108
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mprogressbar.h Source File

include

mprogressbar.h

Go to the documentation of this file.
00001
00020 #ifndef _MGUI_NCSCTRL_PROGRESSBAR_H
00021 #define _MGUI_NCSCTRL_PROGRESSBAR_H
00022
00023 #ifdef __cplusplus
00024 extern "C" {
00025 #endif  /* __cplusplus */
00026
00032 /*
00033  * \def NCSCTRL_PROGRESSBAR
00034  * \brief the name of progressbar control
00035 */
00036
00037 #define NCSCTRL_PROGRESSBAR   NCSCLASSNAME("progressbar")
00038
00039 typedef struct _mProgressBar            mProgressBar;
00040 typedef struct _mProgressBarClass       mProgressBarClass;
00041 typedef struct _mProgressBarRenderer    mProgressBarRenderer;
00042
00043 #define mProgressBarHeader(Class)   \
00044     mWidgetHeader(Class)
00045
00052 struct _mProgressBar
00053 {
00054         mProgressBarHeader(mProgressBar)
00055 };
00056
00057 #define mProgressBarClassHeader(clsName, parentClass) \
00058         mWidgetClassHeader(clsName, parentClass)          \
00059     int (*increase)(clsName *self, int delta);       \
00060     int (*stepIncrease)(clsName *self);
00061
00078 struct _mProgressBarClass
00079 {
00080         mProgressBarClassHeader(mProgressBar, mWidget)
00081 };
00082
00089 MGNCS_EXPORT extern mProgressBarClass g_stmProgressBarCls;
00090
00091 #define mProgressBarRendererHeader(clsName, parentClass) \
00092         mWidgetRendererHeader(clsName, parentClass) \
00093     void (*drawProgress)(clsName* self, HDC hdc, const RECT *rc);
00094
00107 struct _mProgressBarRenderer
00108 {
00109         mProgressBarRendererHeader(mProgressBar, mWidget)
00110 };
00111
00112 #define mHProgressBar mProgressBar
00113 #define mHProgressBarClass mProgressBarClass
00114 #define g_stmHProgressBarCls  g_stmProgressBarCls
00115
00116 #define mVProgressBar mProgressBar
00117 #define mVProgressBarClass mProgressBarClass
00118 #define g_stmVProgressBarCls  g_stmProgressBarCls
00119
00125 enum mProgressBarProp
00126 {
00132     NCSP_PROG_MAXPOS = NCSP_WIDGET_MAX + 1,
00138     NCSP_PROG_MINPOS,
00144     NCSP_PROG_CURPOS,
00150     NCSP_PROG_LINESTEP,
00151     NCSP_PROG_MAX
00152 };
00153
00158 #define NCSS_PRGBAR_HORIZONTAL          0x0000L
00159
00164 #define NCSS_PRGBAR_VERTICAL            (0x0001L<<NCSS_WIDGET_SHIFT)
00165
00170 #define NCSS_PRGBAR_BLOCKS              (0x0002L<<NCSS_WIDGET_SHIFT)
00171
00176 #define NCSS_PRGBAR_SMOOTH              (0x0000L<<NCSS_WIDGET_SHIFT)
00177
00182 #define NCSS_PRGBAR_SHOWPERCENT         (0x0004L<<NCSS_WIDGET_SHIFT)
00183
00184 #define NCSS_PRGBAR_SHIFT  (NCSS_WIDGET_SHIFT+5)
00185
00188 #ifdef __cplusplus
00189 }
00190 #endif  /* __cplusplus */
00191
00192 #endif /* _MGUI_NCSCTRL_PROGRESSBAR_H */
00193
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mprogresspiece.h Source File

include » pieces

mprogresspiece.h

00001
00002 #ifndef _MGUI_NCSCTRL_PROGRESSPIECE_H
00003 #define _MGUI_NCSCTRL_PROGRESSPIECE_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif
00008
00009 typedef struct _mProgressPieceClass mProgressPieceClass;
00010 typedef struct _mProgressPiece mProgressPiece;
00011
00012 #define mProgressPieceClassHeader(clss, superCls) \
00013         mRenderablePieceClassHeader(clss, superCls)  \
00014         int (*step)(clss *self, int offset/*=0*/, BOOL bdec);
00015
00016 struct _mProgressPieceClass
00017 {
00018         mProgressPieceClassHeader(mProgressPiece, mRenderablePiece)
00019 };
00020
00021 extern mProgressPieceClass g_stmProgressPieceCls;
00022
00023 #define mProgressPieceHeader(clss) \
00024         mRenderablePieceHeader(clss)  \
00025         int max; \
00026         int min; \
00027         int cur; \
00028         int step;
00029
00030 struct _mProgressPiece
00031 {
00032         mProgressPieceHeader(mProgressPiece)
00033 };
00034
00035 enum mProgressPieceProp{
00036         NCSP_PROGRESSPIECE_MAXPOS = PIECECOMM_PROP_MAX,
00037         NCSP_PROGRESSPIECE_MINPOS = PIECECOMM_PROP_MIN,
00038         NCSP_PROGRESSPIECE_LINESTEP = PIECECOMM_PROP_LINESTEP,
00039         NCSP_PROGRESSPIECE_CURPOS   = PIECECOMM_PROP_POS
00040 };
00041
00042
00043 #ifdef __cplusplus
00044 }
00045 #endif
00046
00047 #endif
00048
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mpropsheet.h Source File

include

mpropsheet.h

Go to the documentation of this file.
00001
00027 #ifndef _MGUI_NCSCTRL_PROPSHEET_H
00028 #define _MGUI_NCSCTRL_PROPSHEET_H
00029
00030 #ifdef __cplusplus
00031 extern "C" {
00032 #endif  /* __cplusplus */
00033
00043 #define NCSCTRL_PROPSHEET        NCSCLASSNAME("propsheet")
00044
00049 #define NCSS_PRPSHT_SHIFT  NCSS_WIDGET_SHIFT+3
00050
00051 #define NCSS_PRPSHT_BTNMASK         (0x0003<<NCSS_WIDGET_SHIFT)
00052 #define NCSS_PRPSHT_TABMASK         (0x0004<<NCSS_WIDGET_SHIFT)
00053
00059 #define NCSS_PRPSHT_SIMPLE          (0x0000<<NCSS_WIDGET_SHIFT)
00060
00065 #define NCSS_PRPSHT_COMPACTTAB      (0x0001<<NCSS_WIDGET_SHIFT)
00066
00071 #define NCSS_PRPSHT_SCROLLABLE      (0x0002<<NCSS_WIDGET_SHIFT)
00072
00077 #define NCSS_PRPSHT_TOP             (0x0000<<NCSS_WIDGET_SHIFT)
00078
00084 #define NCSS_PRPSHT_BOTTOM          (0x0004<<NCSS_WIDGET_SHIFT)
00085
00086 typedef struct _mPropSheet mPropSheet;
00087 typedef struct _mPropSheetClass mPropSheetClass;
00088 typedef struct _mPropSheetRenderer mPropSheetRenderer;
00089
00090 #define mPropSheetHeader(className) \
00091         mWidgetHeader(className)        \
00092     int     minTabWidth;            \
00093     int     maxTabWidth;            \
00094     int     scrollTabWidth;         \
00095     RECT    headRect;               \
00096     int     pageCount;              \
00097     BOOL    btnShow;                \
00098     mPage*  active;                 \
00099     mPage*  firstView;              \
00100     int     tabMargin;
00101
00133 struct _mPropSheet
00134 {
00135         mPropSheetHeader(mPropSheet)
00136 };
00137
00138 #define mPropSheetClassHeader(clsName, parentClass)    \
00139         mWidgetClassHeader(clsName, parentClass)           \
00140     int (*getPageIndex)(clsName*, mPage* page);        \
00141     mPage* (*getPageByIndex)(clsName*, int pageIndex); \
00142     mPage* (*addPage)(clsName*, const PDLGTEMPLATE dlgTemplate, const NCS_EVENT_HANDLER* handlers);\
00143     BOOL (*removePageByIndex)(clsName*, int pageIndex);\
00144     BOOL (*removePage)(clsName*, mPage* page);         \
00145     mPage* (*getNextPage)(clsName*, mPage* page);      \
00146     mPage* (*getPrevPage)(clsName*, mPage* page);      \
00147     int (*broadCastMsg)(clsName*, DWORD param1, DWORD param2);
00148
00198 struct _mPropSheetClass
00199 {
00200         mPropSheetClassHeader(mPropSheet, mWidget)
00201 };
00202
00207 enum ncsPrpShtFlags
00208 {
00212     NCSF_PRPSHT_BORDER,
00213
00217     NCSF_PRPSHT_TAB,
00218
00222     NCSF_PRPSHT_LEFT,
00223
00227     NCSF_PRPSHT_RIGHT,
00228
00232     NCSF_PRPSHT_PAGE,
00233
00237     NCSF_PRPSHT_MAX,
00238 };
00239
00240 #define mPropSheetRendererHeader(clsName, parentClass)                      \
00241         mWidgetRendererHeader(clsName, parentClass)                             \
00242     void (*resetHeadArea) (clsName*, RECT* rcClient, DWORD style);          \
00243     void (*getRect)(clsName*, RECT* rcClient, RECT *rcResult, int which);   \
00244     void (*drawBorder)(clsName*, HDC hdc, RECT *rcBorder);                  \
00245     void (*drawScrollBtn)(clsName*, HDC hdc, RECT *rcBtn, int which);       \
00246     void (*drawTab)(clsName*, HDC hdc, RECT* rcTab, const char* title, HICON hIcon, BOOL active);
00247
00291 struct  _mPropSheetRenderer {
00292         mPropSheetRendererHeader(mPropSheet, mWidget)
00293 };
00294
00301 MGNCS_EXPORT extern mPropSheetClass g_stmPropSheetCls;
00302
00307 enum mPropSheetNotify
00308 {
00313     NCSN_PRPSHT_ACTIVECHANGED = NCSN_WIDGET_MAX + 1,
00317     NCSN_PRPSHT_MAX
00318 };
00319
00320
00325 enum mPropSheetProp
00326 {
00334         NCSP_PRPSHT_MINTABWIDTH = NCSP_WIDGET_MAX + 1,
00342         NCSP_PRPSHT_TABMARGIN,
00350     NCSP_PRPSHT_ACTIVEPAGE,
00358     NCSP_PRPSHT_ACTIVEPAGEIDX,
00366     NCSP_PRPSHT_FIRSTVIEWPAGE,
00374     NCSP_PRPSHT_FIRSTVIEWPAGEIDX,
00382         NCSP_PRPSHT_PAGECOUNT,
00383         NCSP_PRPSHT_MAX
00384 };
00385
00387 #ifdef __cplusplus
00388 }
00389 #endif  /* __cplusplus */
00390
00391 #endif /* _MGUI_NCSCTRL_PROPSHEET_H */
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mpushbuttonpiece.h Source File

include » pieces

mpushbuttonpiece.h

00001
00002 #ifndef _MGUI_NCSCTRL_PUSHBUTTONPIECE_H
00003 #define _MGUI_NCSCTRL_PUSHBUTTONPIECE_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif
00008
00009 typedef struct _mPushButtonPieceClass mPushButtonPieceClass;
00010 typedef struct _mPushButtonPiece mPushButtonPiece;
00011
00012 #define mPushButtonPieceClassHeader(clss, superCls) \
00013         mAbstractButtonPieceClassHeader(clss, superCls)
00014
00015 struct _mPushButtonPieceClass
00016 {
00017         mPushButtonPieceClassHeader(mPushButtonPiece, mAbstractButtonPiece)
00018 };
00019
00020 MGNCS_EXPORT extern mPushButtonPieceClass g_stmPushButtonPieceCls;
00021
00022 #define mPushButtonPieceHeader(clss) \
00023         mAbstractButtonPieceHeader(clss) \
00024         mHotPiece * content;
00025
00026 struct _mPushButtonPiece
00027 {
00028         mPushButtonPieceHeader(mPushButtonPiece)
00029 };
00030
00031 #ifdef __cplusplus
00032 }
00033 #endif
00034
00035 #endif
00036
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mradioboxpiece.h Source File

include » pieces

mradioboxpiece.h

00001
00002 #ifndef _MGUI_NCSCTRL_RADIOBOXPIECE_H
00003 #define _MGUI_NCSCTRL_RADIOBOXPIECE_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif
00008
00009 typedef struct _mRadioBoxPieceClass mRadioBoxPieceClass;
00010 typedef struct _mRadioBoxPiece mRadioBoxPiece;
00011
00012 #define mRadioBoxPieceClassHeader(clss, superCls) \
00013         mRenderablePieceClassHeader(clss, superCls)
00014
00015 struct _mRadioBoxPieceClass
00016 {
00017         mRadioBoxPieceClassHeader(mRadioBoxPiece, mRenderablePiece)
00018 };
00019
00020 MGNCS_EXPORT extern mRadioBoxPieceClass g_stmRadioBoxPieceCls;
00021
00022 #define mRadioBoxPieceHeader(clss) \
00023         mRenderablePieceHeader(clss)
00024
00025 struct _mRadioBoxPiece
00026 {
00027         mRadioBoxPieceHeader(mRadioBoxPiece)
00028 };
00029
00030
00031 //enum mCheckBoxPieceProps{
00032 //      NCSP_CHECKBUTTONPIECE_CONTENT = CHECKBUTTONPIECE_PROP_BEGIN
00033 //};
00034
00035 #ifdef __cplusplus
00036 }
00037 #endif
00038
00039 #endif
00040
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mradiobutton.h Source File

include

mradiobutton.h

00001
00002 #ifndef _MGUI_NCSCTRL_RDOBTN_H
00003 #define _MGUI_NCSCTRL_RDOBTN_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif  /* __cplusplus */
00008
00019 #define NCSCTRL_RADIOBUTTON        NCSCLASSNAME("radiobutton")
00020
00021 typedef struct _mRadioButton mRadioButton;
00022 typedef struct _mRadioButtonClass mRadioButtonClass;
00023 typedef struct _mRadioButtonRenderer mRadioButtonRenderer;
00024
00025 #define mRadioButtonHeader(className) \
00026         mCheckButtonHeader(className)
00027
00032 struct _mRadioButton
00033 {
00034         mRadioButtonHeader(mRadioButton)
00035 };
00036
00037 #define mRadioButtonClassHeader(className, parentClass) \
00038         mCheckButtonClassHeader(className, parentClass)
00039
00044 struct _mRadioButtonClass
00045 {
00046         mRadioButtonClassHeader(mRadioButton, mCheckButton)
00047 };
00048
00049 #define mRadioButtonRendererHeader(clsName, parentClass) \
00050         mCheckButtonRendererHeader(clsName, parentClass) \
00051     void (*drawRadiobutton)(clsName* self,HDC hdc, const RECT* pRect, int status);
00052
00067 /* define the render of image static */
00068 struct _mRadioButtonRenderer {
00069         mRadioButtonRendererHeader(mRadioButton, mCheckButton)
00070 };
00071
00076 MGNCS_EXPORT extern mRadioButtonClass g_stmRadioButtonCls;
00077
00083 /*property*/
00084 enum mRadioButtonProp {
00085         NCSP_RDOBTN_MAX = NCSP_CHKBTN_MAX + 1,
00086 };
00087
00088 #define NCSS_RDOBTN_SHIFT NCSS_CHKBTN_SHIFT
00089
00095 enum enumRadioButtonNotify{
00096         NCSN_RDOBTN_MAX = NCSN_CHKBTN_MAX + 1
00097 };
00098
00103 #ifdef __cplusplus
00104 }
00105 #endif  /* __cplusplus */
00106
00107 #endif /* _MGUI_NCSCTRL_RDOBTN_H */
00108
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mradiobuttonpiece.h Source File

include » pieces

mradiobuttonpiece.h

00001
00002 #ifndef _MGUI_NCSCTRL_RADIOBUTTONPIECE_H
00003 #define _MGUI_NCSCTRL_RADIOBUTTONPIECE_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif
00008
00009 typedef struct _mRadioButtonPieceClass mRadioButtonPieceClass;
00010 typedef struct _mRadioButtonPiece mRadioButtonPiece;
00011
00012 #define mRadioButtonPieceClassHeader(clss, superCls) \
00013         mCheckButtonPieceClassHeader(clss, superCls)
00014
00015 struct _mRadioButtonPieceClass
00016 {
00017         mRadioButtonPieceClassHeader(mRadioButtonPiece, mCheckButtonPiece)
00018 };
00019
00020 MGNCS_EXPORT extern mRadioButtonPieceClass g_stmRadioButtonPieceCls;
00021
00022 #define mRadioButtonPieceHeader(clss) \
00023         mCheckButtonPieceHeader(clss)
00024
00025 struct _mRadioButtonPiece
00026 {
00027         mRadioButtonPieceHeader(mRadioButtonPiece)
00028 };
00029
00030 #ifdef __cplusplus
00031 }
00032 #endif
00033
00034 #endif
00035
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mradionode.h Source File

include

mradionode.h

00001
00026 #ifndef _MGUI_WIDGET_RADIONODE_H
00027 #define _MGUI_WIDGET_RADIONODE_H
00028
00029 typedef struct _mRadioNode  mRadioNode;
00030 typedef struct _mRadioNodeClass mRadioNodeClass;
00031
00032 #define mRadioNodeHeader(className)  \
00033     mNodeHeader(className)  \
00034     mNode *selNode;
00035
00036 struct _mRadioNode
00037 {
00038         mRadioNodeHeader(mRadioNode)
00039 };
00040
00041 #define mRadioNodeClassHeader(clsName, superCls)        \
00042         mNodeClassHeader(clsName, superCls)                 \
00043     BOOL (*setRadioNode)(clsName*, mCheckNode *node);   \
00044     BOOL (*setRadioNodeByIndex)(clsName*, int idx);
00045
00046
00047 struct _mRadioNodeClass
00048 {
00049         mRadioNodeClassHeader(mRadioNode, mNode)
00050 };
00051
00052 MGNCS_EXPORT extern mRadioNodeClass g_stmRadioNodeCls;
00053
00054 #ifdef __cplusplus
00055 extern "C" {
00056 #endif  /* __cplusplus */
00057
00058 #ifdef __cplusplus
00059 }
00060 #endif  /* __cplusplus */
00061
00062 #endif /* _MGUI_WIDGET_RADIONODE_H */
00063
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mrdr.h Source File

include

mrdr.h

Go to the documentation of this file.
00001
00021 #ifndef _MGNCS_RENDER_H
00022 #define _MGNCS_RENDER_H
00023
00024 #ifdef __cplusplus
00025 extern "C" {
00026 #endif
00027
00028
00038 #define NCS_TYPE_MASK               WE_ATTR_TYPE_MASK
00039 #define NCS_TYPE_COLOR_MASK         WE_ATTR_TYPE_COLOR_MASK
00040 #define NCS_TYPE_INDEX_MASK         WE_ATTR_TYPE_INDEX_MASK
00041
00042 #define NCS_TYPE_METRICS            0x6000
00043 #define NCS_TYPE_COLOR              0x7000
00044 #define NCS_TYPE_IMAGE              0x8000
00045 #define NCS_TYPE_INT                0x9000
00046 #define NCS_TYPE_FGC                NCS_TYPE_COLOR
00047 #define NCS_TYPE_BGC                (NCS_TYPE_COLOR | 0x0100)
00048
00049 #define NCS_TYPE_IS_IMAGE(id)       (((id) & NCS_TYPE_MASK) == NCS_TYPE_IMAGE)
00050
00051 #define NCS_METRICS_BASEID          (NCS_TYPE_METRICS | 0)
00052 #define NCS_FGC_BASEID              (NCS_TYPE_FGC | 0)
00053 #define NCS_BGC_BASEID              (NCS_TYPE_BGC | 0)
00054 #define NCS_INT_BASEID              (NCS_TYPE_INT | 0)
00055 #define NCS_IMAGE_BASEID            (NCS_TYPE_IMAGE | 0)
00056
00057 #define NCS_FONT_NUMBER             0
00058 #define NCS_METRICS_NUMBER          2
00059 #define NCS_COLORS_NUMBER           9
00060 #define NCS_IMAGE_NUMBER            17
00061 #define NCS_INT_NUMBER              5
00062
00063 //common for all renderer
00064 #define NCS_FGC_3DBODY              NCS_FGC_BASEID
00065 #define NCS_BGC_3DBODY              NCS_BGC_BASEID
00066
00067 #define NCS_FGC_WINDOW              NCS_FGC_BASEID  + 1
00068 #define NCS_BGC_WINDOW              NCS_BGC_BASEID  + 1
00069
00070 #define NCS_FGC_SELECTED_ITEM       NCS_FGC_BASEID  + 2
00071 #define NCS_BGC_SELECTED_ITEM       NCS_BGC_BASEID  + 2
00072
00073 #define NCS_FGC_HILIGHT_ITEM        NCS_FGC_BASEID  + 3
00074 #define NCS_BGC_HILIGHT_ITEM        NCS_BGC_BASEID  + 3
00075
00076 #define NCS_FGC_DISABLED_ITEM       NCS_FGC_BASEID  + 4
00077 #define NCS_BGC_DISABLED_ITEM       NCS_BGC_BASEID  + 4
00078
00079 #define NCS_BGC_SELITEM_NOFOCUS     NCS_BGC_BASEID  + 5
00080
00081 #define NCS_IMAGE_BKGND             NCS_IMAGE_BASEID
00082 #define NCS_MODE_BKIMAGE            NCS_INT_BASEID
00083
00084 #define NCS_METRICS_3DBODY_ROUND_RADIUS (NCS_METRICS_BASEID)
00085
00086 //fashion
00087 #define NCS_METRICS_3DBODY_ROUNDX   (NCS_METRICS_BASEID)
00088 #define NCS_METRICS_3DBODY_ROUNDY   (NCS_METRICS_BASEID + 1)
00089 #define NCS_MODE_BGC                NCS_INT_BASEID  + 1
00090 #define NCS_MODE_FGC                NCS_INT_BASEID  + 2
00091 #define NCS_MODE_ITEM               NCS_INT_BASEID  + 3
00092 #define NCS_MODE_USEFLAT            NCS_INT_BASEID  + 4
00093
00094 //fashion.ProgressBar
00095 #define NCS_BGC_PRGBAR_CHUNK        NCS_BGC_BASEID  + 6
00096 //fashion.TrackBar
00097 #define NCS_BGC_TRKBAR_SLIDER       NCS_BGC_BASEID  + 7
00098 #define NCS_BGC_TRKBAR_THUMB        NCS_BGC_BASEID  + 8
00099
00100 //flat
00101 #define NCS_BGC_PRPSHT_NMLTAB       NCS_BGC_BASEID  + 9
00102
00103 //skin
00104 #define NCS_IMAGE_ARROWS            NCS_IMAGE_BASEID + 1
00105 #define NCS_IMAGE_ARROWSHELL        NCS_IMAGE_BASEID + 2
00106 //skin.Button
00107 #define NCS_IMAGE_BUTTON            NCS_IMAGE_BASEID + 3
00108 //skin.CheckButton
00109 #define NCS_IMAGE_CHKBTN            NCS_IMAGE_BASEID + 4
00110 //skin.RadioButton
00111 #define NCS_IMAGE_RDOBTN            NCS_IMAGE_BASEID + 5
00112 //skin.ListView
00113 #define NCS_IMAGE_LISTV_TREE        NCS_IMAGE_BASEID + 6
00114 #define NCS_IMAGE_LISTV_HDR         NCS_IMAGE_BASEID + 7
00115 //skin.PropSheet
00116 #define NCS_IMAGE_PRPSHT_TAB        NCS_IMAGE_BASEID + 8
00117 //skin.ProgressBar
00118 #define NCS_IMAGE_PRGBAR_HCHUNK     NCS_IMAGE_BASEID + 9
00119 #define NCS_IMAGE_PRGBAR_VCHUNK     NCS_IMAGE_BASEID + 10
00120 #define NCS_IMAGE_PRGBAR_HSLIDER    NCS_IMAGE_BASEID + 11
00121 #define NCS_IMAGE_PRGBAR_VSLIDER    NCS_IMAGE_BASEID + 12
00122 //skin.TrackBar
00123 #define NCS_IMAGE_TRKBAR_HSLIDER    NCS_IMAGE_BASEID + 13
00124 #define NCS_IMAGE_TRKBAR_VSLIDER    NCS_IMAGE_BASEID + 14
00125 #define NCS_IMAGE_TRKBAR_HTHUMB     NCS_IMAGE_BASEID + 15
00126 #define NCS_IMAGE_TRKBAR_VTHUMB     NCS_IMAGE_BASEID + 16
00127
00182 MGNCS_EXPORT DWORD ncsGetElementEx (mWidget *self, const char* rdrName, int id);
00183
00199 MGNCS_EXPORT DWORD ncsSetElementEx (mWidget* self, const char* rdrName, int id, DWORD value);
00200
00201 MGNCS_EXPORT BOOL ncsLoadRdrElementsFromEtcFile(const char* etcfile, const char** rdrNames, int count);
00202
00203 MGNCS_EXPORT BOOL ncsLoadRdrElementsFromEtcHandle(GHANDLE hEtc, const char** rdrNames, int count);
00204
00213 MGNCS_EXPORT GHANDLE ncsLoadRdrEtcFile (const char* etcfile, const char** rdrName, int count);
00214
00221 MGNCS_EXPORT int ncsUnloadRdrEtcFile(GHANDLE hEtcFile);
00222
00223 /*
00224  * \def var g_ncsEtcHandle
00225  * \breif the MGNCS configuration handle
00226  */
00227 MGNCS_EXPORT extern GHANDLE g_ncsEtcHandle;
00228
00229 /*
00230  * \fn ncsSetEtcHandler(GHANDLE hEtc);
00231  * \brief set the outside of etc handler of mgnc.cfg.
00232  * can used for incore resource
00233  *
00234  * \sa g_ncsEtcHandler
00235  */
00236 static inline void ncsSetEtcHandle(GHANDLE hEtc)
00237 {
00238     g_ncsEtcHandle = hEtc;
00239 }
00240
00241
00242
00247 #define ncsGetElement(self, id) \
00248     ncsGetElementEx((mWidget*)self, NULL, id)
00249
00254 #define ncsSetElement(self, id, value) \
00255     ncsSetElementEx((mWidget*)self, NULL, id, value)
00256
00268 MGNCS_EXPORT mWidgetRenderer *ncsRetriveCtrlRDR (const char *rendererName, const char *className);
00269
00285 MGNCS_EXPORT BOOL ncsRegisterCtrlRDR (const char *rendererName, const char *className,
00286                           mWidgetRenderer *renderer);
00287
00297 MGNCS_EXPORT void ncsUnregisterCtrlRDRs(const char* rdrName/*=NULL*/, const char* className/*=NULL*/);
00298
00304 typedef struct _NCS_RDR_ENTRY
00305 {
00309   const char *className;
00313   mWidgetRenderer *renderer;
00314 } NCS_RDR_ENTRY;
00315
00329 MGNCS_EXPORT BOOL ncsRegisterCtrlRDRs (const char *rendererName, NCS_RDR_ENTRY * entries,
00330                            int count);
00331
00349 MGNCS_EXPORT BOOL ncsSetSystemRenderer(const char* name);
00350
00358 MGNCS_EXPORT const char* ncsGetSystemRenderer(void);
00359
00379 #define INVALID_RDR_VALUE  ((DWORD)-1)
00380
00381 static inline gal_pixel ncsColor2Pixel(HDC hdc, DWORD color)
00382 {
00383         return RGBA2Pixel(hdc,GetRValue(color),
00384                 GetGValue(color),
00385                 GetBValue(color),
00386                 GetAValue(color));
00387 }
00388
00389 MGNCS_EXPORT void ncsCommRDRDrawFocusFrame(HWND hWnd, HDC hdc, const RECT *rc);
00390 MGNCS_EXPORT BOOL ncsCommRDRDrawBkgnd(HWND hWnd, HDC hdc, const RECT* inv_rc);
00391
00392 MGNCS_EXPORT void ncsCommRDRDraw3dbox(HDC hdc, const RECT* rc,  DWORD color, DWORD flag);
00393 MGNCS_EXPORT void ncsCommRDRDraw3DRoundBox(HDC hdc, const RECT *rc, int rx, int ry, DWORD color, DWORD flag);
00394
00395 #define NCS_ROUND_CORNER_LEFT_TOP                       (0x1)
00396 #define NCS_ROUND_CORNER_LEFT_BOTTOM            (0x2)
00397 #define NCS_ROUND_CORNER_RIGHT_TOP          (0x4)
00398 #define NCS_ROUND_CORNER_RIGHT_BOTTOM       (0x8)
00399 #define NCS_ROUND_CORNER_LEFTS              (NCS_ROUND_CORNER_LEFT_TOP|NCS_ROUND_CORNER_LEFT_BOTTOM)
00400 #define NCS_ROUND_CORNER_RIGHTS             (NCS_ROUND_CORNER_RIGHT_TOP|NCS_ROUND_CORNER_RIGHT_BOTTOM)
00401 #define NCS_ROUND_CORNER_TOPS               (NCS_ROUND_CORNER_LEFT_TOP|NCS_ROUND_CORNER_RIGHT_TOP)
00402 #define NCS_ROUND_CORNER_BOTTOMS            (NCS_ROUND_CORNER_LEFT_BOTTOM|NCS_ROUND_CORNER_RIGHT_BOTTOM)
00403 #define NCS_ROUND_CORNER_ALL                (NCS_ROUND_CORNER_LEFT_TOP|NCS_ROUND_CORNER_LEFT_BOTTOM| \
00404                                                                                                 NCS_ROUND_CORNER_RIGHT_TOP|NCS_ROUND_CORNER_RIGHT_BOTTOM)
00405 #define NCS_BORDER_LEFT                     0x1000
00406 #define NCS_BORDER_RIGHT                    0x2000
00407 #define NCS_BORDER_TOP                      0x4000
00408 #define NCS_BORDER_BOTTOM                   0x8000
00409 #define NCS_BORDER_ALL                      (NCS_BORDER_LEFT|NCS_BORDER_RIGHT|NCS_BORDER_TOP|NCS_BORDER_BOTTOM)
00410
00411 MGNCS_EXPORT void ncsCommRDRDraw3DHalfRoundBox(HDC hdc, const RECT *rc, int rx, int ry, DWORD color, DWORD flag, DWORD part_flag);
00412 MGNCS_EXPORT void ncsCommRDRDrawHalfRoundRect(HDC hdc, const RECT *rc, int rx, int ry, DWORD color, DWORD part_flag);
00413
00414 MGNCS_EXPORT void ncsCommRDRFillHalfRoundRect(HDC hdc, const RECT *rc, int rx, int ry, DWORD color, DWORD part_flag);
00415
00416 MGNCS_EXPORT void ncsCommRDRDraw3DEllipse(HDC hdc, const RECT *rc, DWORD color1, DWORD color2, DWORD flag);
00417
00418 MGNCS_EXPORT void ncsCommRDRDrawCheckbox(HDC hdc, const RECT* rc, DWORD fgcolor, DWORD bgcolor, DWORD discolor, DWORD flag);
00419
00420 MGNCS_EXPORT void ncsCommRDRDrawRadio(HDC hdc, const RECT* rc,  DWORD fgcolor, DWORD bgcolor, DWORD discolor,DWORD flag);
00421
00422 MGNCS_EXPORT void ncsCommRDRDrawArrow(HDC hdc, const RECT* rc, int arrow,DWORD color, BOOL bFill);
00423
00424 MGNCS_EXPORT void ncsCommRDRDrawItem(HDC hdc, const RECT* rc, DWORD color);
00425
00426 MGNCS_EXPORT void ncsCommRDRDrawSmallHalfRoundBox(HDC hdc, const RECT *rc, DWORD flags, BOOL bFill);
00427
00428 enum ncsCommRDRColorCalc {
00429         NCSR_COLOR_DARKER = -100,
00430         NCSR_COLOR_DARKEST = -200 ,
00431         NCSR_COLOR_LIGHTER = 100 ,
00432         NCSR_COLOR_LIGHTEST = 200
00433 };
00434
00435 MGNCS_EXPORT DWORD ncsCommRDRCalc3dboxColor(DWORD color, int degree);
00436
00437 //skin
00438
00439 #define DI_FILL_TILE    0x01
00440 #define DI_FILL_STRETCH 0x02
00441
00442 /* Draw info */
00443 typedef struct _DRAWINFO
00444 {
00445     /* The pointer to the whole bitmap. */
00446     const BITMAP* bmp;
00447
00448     /* The number of line in this bitmap. */
00449     unsigned int nr_line;
00450
00451     /* The number of colume in this bitmap. */
00452     unsigned int nr_col;
00453
00454     /* The index of line to current sub bitmap. */
00455     unsigned int idx_line;
00456
00457     /* The index of colume to current sub bitmap. */
00458     unsigned int idx_col;
00459
00460     /* The left/top margin value of current sub bitmap. */
00461     unsigned int margin1;
00462
00463     /* The right/bottom margin value of current sub bitmap. */
00464     unsigned int margin2;
00465
00466     /* The margin direct. FALSE for left-to-right (default),
00467      * TRUE for top-to-bottom. */
00468     BOOL direct;
00469
00470     /* The flip flag. FALSE for not flip sub bitmap (default),
00471      * TRUE for flip. It can be used by draw_tab function.*/
00472     BOOL flip;
00473
00474     /* The style of drawing bitmap. It can be one of the
00475      * following value:
00476      *  - DI_FILL_TILE
00477      *  - DI_FILL_STRETCH
00478      */
00479     unsigned int style;
00480
00481 } DRAWINFO;
00482
00483 MGNCS_EXPORT void ncsSkinDraw(HDC hdc, const RECT* rc, const DRAWINFO *di);
00484
00488 #ifdef __cplusplus
00489 }
00490 #endif
00491
00492 #endif
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mrect.h Source File

include

mrect.h

00001
00002 #ifndef _MGUI_NCSCTRL_RECTANGLE_H
00003 #define _MGUI_NCSCTRL_RECTANGLE_H
00004
00005
00006 #ifdef __cplusplus
00007 extern "C" {
00008 #endif  /* __cplusplus */
00009
00019 #define NCSCTRL_RECTANGLE        NCSCLASSNAME("rectangle")
00020
00021 typedef struct _mRectangle mRectangle;
00022 typedef struct _mRectangleClass mRectangleClass;
00023 typedef struct _mRectangleRenderer mRectangleRenderer;
00024
00025 #define mRectangleHeader(clsName)   \
00026         mWidgetHeader(clsName)
00027
00034 struct _mRectangle
00035 {
00036         mRectangleHeader(mRectangle)
00037 };
00038
00039 #define mRectangleClassHeader(clsName, parentClass) \
00040         mWidgetClassHeader(clsName, parentClass)
00041
00047 struct _mRectangleClass
00048 {
00049         mRectangleClassHeader(mRectangle, mWidget)
00050 };
00051
00052 #define mRectangleRendererHeader(clsName, parentClass) \
00053         mWidgetRendererHeader(clsName, parentClass)
00054
00059 /* define the render of image static */
00060 struct _mRectangleRenderer {
00061         mRectangleRendererHeader(mRectangle, mWidget)
00062 };
00063
00068 MGNCS_EXPORT extern mRectangleClass g_stmRectangleCls;
00069
00075 /* property */
00076 enum mRectangleProp {
00084         NCSP_RECTANGLE_BORDERSIZE = NCSP_WIDGET_MAX + 1,
00092         NCSP_RECTANGLE_BORDERCOLOR,
00100         NCSP_RECTANGLE_FILLCOLOR,
00108         NCSP_RECTANGLE_XRADIUS,
00116         NCSP_RECTANGLE_YRADIUS,
00124         NCSP_RECTANGLE_FILLCLR_RED,
00132         NCSP_RECTANGLE_FILLCLR_GREEN,
00140         NCSP_RECTANGLE_FILLCLR_BLUE,
00148         NCSP_RECTANGLE_FILLCLR_ALPHA,
00156         NCSP_RECTANGLE_BRDCLR_RED,
00164         NCSP_RECTANGLE_BRDCLR_GREEN,
00172         NCSP_RECTANGLE_BRDCLR_BLUE,
00180         NCSP_RECTANGLE_BRDCLR_ALPHA,
00181         NCSP_RECTANGLE_MAX
00182 };
00183
00184 #define NCSS_RECT_SHIFT NCSS_WIDGET_SHIFT
00185
00190 enum enumRectNotify{
00191         NCSN_RECT_MAX = NCSN_WIDGET_MAX + 1
00192 };
00193
00197 #ifdef __cplusplus
00198 }
00199 #endif  /* __cplusplus */
00200
00201 #endif /* _MGUI_NCSCTRL_RECTANGLE_H */
00202
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mrectpiece.h Source File

include » pieces

mrectpiece.h

00001 #ifndef _MGNCS_RECTPIECE_H
00002 #define _MGNCS_RECTPIECE_H
00003
00004 #ifdef __cplusplus
00005 extern "C" {
00006 #endif
00007
00008 typedef struct _mRectPieceClass mRectPieceClass;
00009 typedef struct _mRectPiece mRectPiece;
00010
00011 #define mRectPieceClassHeader(clss, superCls) \
00012         mStaticPieceClassHeader(clss, superCls)
00013
00014 struct _mRectPieceClass
00015 {
00016         mRectPieceClassHeader(mRectPiece, mStaticPiece)
00017 };
00018
00019 MGNCS_EXPORT extern mRectPieceClass g_stmRectPieceCls;
00020
00021 #define mRectPieceHeader(clss) \
00022         mStaticPieceHeader(clss) \
00023         DWORD fill_color; \
00024         DWORD border_color; \
00025         unsigned int border_size:12; \
00026         unsigned int x_radius:10; \
00027         unsigned int y_radius:10;
00028
00029 struct _mRectPiece
00030 {
00031         mRectPieceHeader(mRectPiece)
00032 };
00033
00034 enum mRectPieceProps {
00035         NCSP_RECTPIECE_FILLCOLOR    = RECTPIECE_PROP_BEGIN,
00036         NCSP_RECTPIECE_BORDERCOLOR,
00037         NCSP_RECTPIECE_BORDERSIZE,
00038         NCSP_RECTPIECE_XRADIUS,
00039         NCSP_RECTPIECE_YRADIUS,
00040         NCSP_RECTPIECE_FILLCLR_RED, //FILLCOLOR
00041         NCSP_RECTPIECE_FILLCLR_GREEN,
00042         NCSP_RECTPIECE_FILLCLR_BLUE,
00043         NCSP_RECTPIECE_FILLCLR_ALPHA,
00044         NCSP_RECTPIECE_BRDCLR_RED, //BorderColor
00045         NCSP_RECTPIECE_BRDCLR_GREEN,
00046         NCSP_RECTPIECE_BRDCLR_BLUE,
00047         NCSP_RECTPIECE_BRDCLR_ALPHA,
00048         NCSP_RECTPIECE_MAX
00049 };
00050
00051
00052 #ifdef __cplusplus
00053 }
00054 #endif
00055
00056 #endif
00057
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mrenderablepiece.h Source File

include » pieces

mrenderablepiece.h

00001
00002 #ifndef _MGUI_NCSCTRL_RENDERABLEPIECE_H
00003 #define _MGUI_NCSCTRL_RENDERABLEPIECE_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif
00008
00009 typedef struct _mRenderablePieceClass mRenderablePieceClass;
00010 typedef struct _mRenderablePiece mRenderablePiece;
00011
00012 #define mRenderablePieceClassHeader(clss, superCls) \
00013         mStaticPieceClassHeader(clss, superCls)
00014
00015 struct _mRenderablePieceClass
00016 {
00017         mRenderablePieceClassHeader(mRenderablePiece, mStaticPiece)
00018 };
00019
00020 extern mRenderablePieceClass g_stmRenderablePieceCls;
00021
00022 #define mRenderablePieceHeader(clss) \
00023         mStaticPieceHeader(clss)  \
00024         PHotPieceRdrFunc rdr_func;
00025
00026 struct _mRenderablePiece
00027 {
00028         mRenderablePieceHeader(mRenderablePiece)
00029 };
00030
00031
00032 #ifdef __cplusplus
00033 }
00034 #endif
00035
00036 #endif
00037
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mresmgr.h Source File

include

mresmgr.h

Go to the documentation of this file.
00001
00026 #ifndef _MGUI_RESMANAGER_H
00027     #define _MGUI_RESMANAGER_H
00028
00029 #ifdef __cplusplus
00030 extern "C" {
00031 #endif  /* __cplusplus */
00032
00042 typedef unsigned int        HPACKAGE;
00043
00048 #define HPACKAGE_NULL       0
00049
00050 #define NCSRT_MASK             0x0FFF
00051
00052 #define NCSRT_STRING           0x0001
00053 #define NCSRT_TEXT             0x0002
00054 #define NCSRT_IMAGE            0x0004
00055 #define NCSRT_UI               0x0008
00056 #define NCSRT_RDRSET           0x0010
00057 #define NCSRT_RDR              0x0020
00058 #define NCSRT_BINARY           0x0040
00059
00064 #define NCSRM_SYSSTR_BASEID  1
00065
00070 #define NCSRM_SYSSTR_MAXID   128
00071
00076 #define NCSRM_SYSSTR_DEFRDR  (NCSRT_STRING << 16) |NCSRM_SYSSTR_BASEID
00077
00082 #define NCSRT_EXT_LEN        15
00083
00088 #define NCSRM_VERSION_LEN    4
00089
00094 #define NCSRM_VENDOR_LEN     16
00095
00100 #define NCSRM_ENCODING_LEN   16
00101
00103 typedef struct _NCSRM_HEADER
00104 {
00106     Uint32  magic;
00107
00109     char    package_version[NCSRM_VERSION_LEN];
00110
00112     char    format_version[NCSRM_VERSION_LEN];
00113
00114     char    char_encoding[NCSRM_ENCODING_LEN];
00115
00117     char    vendor[NCSRM_VENDOR_LEN];
00118
00120     Uint32  nr_sect;
00121 }NCSRM_HEADER;
00122
00124 typedef struct _NCSRM_TYPEITEM
00125 {
00142     Uint32  type;
00143
00145     Uint32  filename_id;
00146
00150     Uint32  offset;
00151 }NCSRM_TYPEITEM;
00152
00154 typedef struct _NCSRM_IDITEM
00155 {
00157     Uint32  id;
00158
00160     Uint32  filename_id;
00161
00163     Uint32  offset;
00164
00165 }NCSRM_IDITEM;
00166
00168 typedef struct _NCSRM_WINHEADER
00169 {
00171     Uint32  class_id;
00172
00174     Uint32  wnd_id;
00175
00177     Uint32  serial_num;
00178
00180     Uint32  caption_id;
00181
00183     Uint32  rdr_id;
00184
00185
00187     Sint32    x;
00188
00190     Sint32    y;
00191
00193     Uint32  w;
00194
00196     Uint32  h;
00197
00199     DWORD   style;
00200
00202     DWORD   ex_style;
00203
00205         DWORD   bk_color;
00206
00208         Uint32  font_id;
00209
00212     Uint32  size;
00213
00215     Uint32  offset_props;
00216
00218     Uint32  offset_ctrls;
00219
00221     Uint32  nr_props;
00222
00224     Uint32  nr_ctrls;
00225
00227     Uint32  offset_adddata;
00228
00230     Uint32  size_adddata;
00231 }NCSRM_WINHEADER;
00232
00233
00235 typedef struct _NCSRM_SECTHEADER
00236 {
00238     Uint32  sect_size;
00239
00241     Uint32  size_maps;
00242 }NCSRM_SECTHEADER;
00243
00245 typedef struct _NCSRM_DEFLOCALE_INFO
00246 {
00248     char    language[4];
00250     char    country[4];
00251 }NCSRM_DEFLOCALE_INFO;
00252
00254 typedef struct _NCSRM_LOCALEITEM
00255 {
00257     char    language[4];
00259     char    country[4];
00260
00262     Uint32  filename_id;
00263
00265     Uint32  offset;
00266 }NCSRM_LOCALEITEM;
00267
00269 typedef struct _NCSRM_INCORE_IMAGE
00270 {
00272     int     size;
00273
00275     char    ext[NCSRT_EXT_LEN + 1];
00276
00278     void    *data;
00279 }NCSRM_INCORE_IMAGE;
00280
00285 enum ncsRMRdrResType
00286 {
00288     NCSRM_RDRTYPE_COLOR = 0,
00290     NCSRM_RDRTYPE_METRIC,
00292     NCSRM_RDRTYPE_IMAGE,
00294     NCSRM_RDRTYPE_FONT,
00296     NCSRM_RDRTYPE_BINARY,
00298         NCSRM_RDRTYPE_STRING,
00300         NCSRM_RDRTYPE_FILE,
00302         NCSRM_RDRTYPE_TEXT,
00304     NCSRM_RDRTYPE_MAX,
00305 };
00306
00310 typedef struct _NCSRM_RDRINFO
00311 {
00313     Uint32  id;
00315     Uint32  value;
00316 }NCSRM_RDRINFO;
00317
00321 typedef struct _NCSRM_RDRHEADER
00322 {
00324     Uint32  rdrname_id;
00326     Uint32  clsname_id;
00327 }NCSRM_RDRHEADER;
00328
00332 typedef struct _NCSRM_PROP
00333 {
00335     Sint32 type;
00337         Sint32 id;
00339         DWORD value;
00340 } NCSRM_PROP;
00341
00351 MGNCS_EXPORT const char* ncsSetDefaultLocale (char* language, char* country);
00352
00359 MGNCS_EXPORT const char* ncsGetDefaultLocale(void);
00360
00369 MGNCS_EXPORT HPACKAGE ncsLoadResPackageFromFile (const char* fileName);
00370
00377 #define ncsLoadResPackage  ncsLoadResPackageFromFile
00378
00385 MGNCS_EXPORT int ncsAddRefResPackage(HPACKAGE package);
00386
00393 MGNCS_EXPORT void ncsUnloadResPackage (HPACKAGE package);
00394
00406 MGNCS_EXPORT HPACKAGE ncsLoadResPackageFromMem (const void* mem, int size);
00407
00417 MGNCS_EXPORT const char* ncsGetImageFileName (HPACKAGE package, Uint32 resId);
00418
00431 MGNCS_EXPORT int ncsGetBitmap(HDC hdc, HPACKAGE package, Uint32 resId,  PBITMAP pBitmap);
00432
00444 MGNCS_EXPORT void ncsReleaseBitmap (PBITMAP pBitmap);
00445
00458 MGNCS_EXPORT int ncsGetMyBitmap(HPACKAGE package, Uint32 resId,
00459         PMYBITMAP myBmp, RGB* pal);
00460
00471 MGNCS_EXPORT void ncsReleaseMyBitmap (PMYBITMAP myBmp);
00472
00484 MGNCS_EXPORT const char* ncsGetString (HPACKAGE package, Uint32 resId);
00485
00498 MGNCS_EXPORT BOOL ncsSetSysRdr(HPACKAGE package, Uint32 rdrSetId);
00499
00513 MGNCS_EXPORT BOOL ncsSetWinRdr(HWND hWnd, HPACKAGE package, Uint32 rdrId);
00514
00515 typedef struct _NCS_EVENT_HANDLER_INFO
00516 {
00517     int id;
00518     NCS_EVENT_HANDLER *handler;
00519 }NCS_EVENT_HANDLER_INFO;
00520
00543 MGNCS_EXPORT mMainWnd* ncsCreateMainWindowIndirectFromID (HPACKAGE package,
00544                     Uint32 wndId, HWND owner, HICON hIcon,
00545                     HMENU hMenu, NCS_EVENT_HANDLER_INFO* handlers,
00546                                         NCS_EVENT_CONNECT_INFO *connects,
00547                                         DWORD user_data);
00548
00570 MGNCS_EXPORT int ncsCreateModalDialogFromID (HPACKAGE package, Uint32 dlgId,
00571                     HWND owner, HICON hIcon, HMENU hMenu,
00572                     NCS_EVENT_HANDLER_INFO* handlers, NCS_EVENT_CONNECT_INFO *connects);
00573
00589 MGNCS_EXPORT BOOL ncsGetWndTemplFromID(HPACKAGE package, Uint32 wndId, \
00590                         NCS_MNWND_TEMPLATE * ptempl,
00591                         NCS_EVENT_HANDLER_INFO* handlers);
00592
00605 MGNCS_EXPORT void ncsFreeWndTemplate(NCS_MNWND_TEMPLATE *ptempl);
00606
00607
00609 #ifdef __cplusplus
00610 }
00611 #endif  /* __cplusplus */
00612
00613 #endif  /* _MGUI_RESMANAGER_H */
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mrightarrowpiece.h Source File

include » pieces

mrightarrowpiece.h

00001
00002 #ifndef _MGUI_NCSCTRL_RIGHTARROWPIECE_H
00003 #define _MGUI_NCSCTRL_RIGHTARROWPIECE_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif
00008
00009 typedef struct _mRightArrowPieceClass mRightArrowPieceClass;
00010 typedef struct _mRightArrowPiece mRightArrowPiece;
00011
00012 #define mRightArrowPieceClassHeader(clss, superCls) \
00013         mArrowPieceClassHeader(clss, superCls)
00014
00015 struct _mRightArrowPieceClass
00016 {
00017         mRightArrowPieceClassHeader(mRightArrowPiece, mArrowPiece)
00018 };
00019
00020 MGNCS_EXPORT extern mRightArrowPieceClass g_stmRightArrowPieceCls;
00021
00022 #define mRightArrowPieceHeader(clss) \
00023         mArrowPieceHeader(clss)
00024
00025 struct _mRightArrowPiece
00026 {
00027         mRightArrowPieceHeader(mRightArrowPiece)
00028 };
00029
00030
00031 #ifdef __cplusplus
00032 }
00033 #endif
00034
00035 #endif
00036
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mscroll_widget.h Source File

include

mscroll_widget.h

Go to the documentation of this file.
00001
00026 #ifndef _MGUI_WIDGET_SCROLL_H
00027 #define _MGUI_WIDGET_SCROLL_H
00028
00029
00030 #ifdef __cplusplus
00031 extern "C" {
00032 #endif  /* __cplusplus */
00033
00044 #define NCSCTRL_SCROLLWIDGET   NCSCLASSNAME("scrollwidget")
00045
00046 typedef struct _mScrollWidget mScrollWidget;
00047 typedef struct _mScrollWidgetClass mScrollWidgetClass;
00048 typedef struct _mScrollWidgetRenderer mScrollWidgetRenderer;
00049
00054 enum ncsSwgtDrawMode
00055 {
00059    NCSID_SWGT_AUTO = 0,
00063    NCSID_SWGT_ALWAYS,
00067    NCSID_SWGT_NEVER
00068 };
00069
00070 #define mScrollWidgetHeader(className)  \
00071         mWidgetHeader(className)            \
00072     unsigned int realContWidth;         \
00073     unsigned int realContHeight;        \
00074     unsigned int hStepVal;              \
00075     unsigned int vStepVal;              \
00076     int          contX;                 \
00077     int          contY;                 \
00078     unsigned int contWidth;             \
00079     unsigned int contHeight;            \
00080     unsigned int visWidth;              \
00081     unsigned int visHeight;             \
00082     unsigned int leftMargin;            \
00083     unsigned int topMargin;             \
00084     unsigned int rightMargin;           \
00085     unsigned int bottomMargin;          \
00086     unsigned int drawMode;
00087
00139 struct _mScrollWidget
00140 {
00141         mScrollWidgetHeader(mScrollWidget)
00142 };
00143
00144 #define mScrollWidgetClassHeader(clsName, parentClass)          \
00145         mWidgetClassHeader(clsName, parentClass)                    \
00146     void (*onHScroll)(clsName*, int code, int mouseX);          \
00147     void (*onVScroll)(clsName*, int code, int mouseY);          \
00148     void (*initMargins)(clsName*, int l, int t, int r, int b);  \
00149     void (*moveContent)(clsName*);                              \
00150     void (*resetViewPort)(clsName*, unsigned int,unsigned int); \
00151     void (*setScrollInfo)(clsName*, BOOL reDraw);               \
00152     BOOL (*makePosVisible)(clsName*, int x, int y);             \
00153     void (*getContRect)(clsName*, RECT *rcCont);                \
00154     void (*getVisRect)(clsName*, RECT *rcVis);                  \
00155     void (*viewportToWindow)(clsName*, int *x, int *y);         \
00156     void (*viewportToContent)(clsName*, int *x, int *y);        \
00157     void (*windowToViewport)(clsName*, int *x, int *y);         \
00158     void (*contentToViewport)(clsName*, int *x, int *y);        \
00159     void (*contentToWindow)(clsName*, int *x, int *y);          \
00160     void (*windowToContent)(clsName*, int *x, int *y);          \
00161     void (*refreshRect)(clsName*, const RECT *rc);              \
00162     BOOL (*isVisible)(clsName*, int x, int y);
00163
00220 struct _mScrollWidgetClass
00221 {
00222         mScrollWidgetClassHeader(mScrollWidget, mWidget)
00223 };
00224
00225 #define mScrollWidgetRendererHeader(clsName, parentClass) \
00226         mWidgetRendererHeader(clsName, parentClass)
00227
00233 struct  _mScrollWidgetRenderer {
00234         mScrollWidgetRendererHeader(mScrollWidget, mWidget)
00235 };
00236
00243 MGNCS_EXPORT extern mScrollWidgetClass g_stmScrollWidgetCls;
00244
00249 enum mScrollWidgetProp
00250 {
00254     NCSP_SWGT_CONTWIDTH = NCSP_WIDGET_MAX + 1,
00258         NCSP_SWGT_CONTHEIGHT,
00262         NCSP_SWGT_CONTX,
00266         NCSP_SWGT_CONTY,
00270         NCSP_SWGT_HSTEPVALUE,
00274         NCSP_SWGT_VSTEPVALUE,
00278         NCSP_SWGT_VISWIDTH,
00282         NCSP_SWGT_VISHEIGHT,
00286         NCSP_SWGT_MARGINRECT,
00290         NCSP_SWGT_DRAWMODE,
00294         NCSP_SWGT_MAX
00295 };
00296
00301 #define NCSS_SWGT_SHIFT  NCSS_WIDGET_SHIFT
00302
00307 enum mScrollWidgetNotify {
00311     NCSN_SWGT_MAX = NCSN_WIDGET_MAX + 1
00312 };
00313
00316 #ifdef __cplusplus
00317 }
00318 #endif  /* __cplusplus */
00319
00320 #endif /* _MGUI_WIDGET_SCROLL_H */
00321
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mscrollbar.h Source File

include

mscrollbar.h

Go to the documentation of this file.
00001
00019 #ifndef _MGUI_NCSCTRL_SCRLBR_H
00020 #define _MGUI_NCSCTRL_SCRLBR_H
00021
00022 #ifdef __cplusplus
00023 extern "C" {
00024 #endif  /* __cplusplus */
00025
00031 /*
00032  * \def NCSCTRL_SCROLLBAR
00033  * \brief the name of scrollbar control
00034 */
00035 #define NCSCTRL_SCROLLBAR   NCSCLASSNAME("scrollbar")
00036
00037 typedef struct _mScrollBar            mScrollBar;
00038 typedef struct _mScrollBarClass       mScrollBarClass;
00039 typedef struct _mScrollBarRenderer    mScrollBarRenderer;
00040
00041 #define mScrollBarHeader(Class) \
00042     mSliderHeader(Class)
00043
00050 struct _mScrollBar
00051 {
00052         mScrollBarHeader(mScrollBar)
00053 };
00054
00055 #define mScrollBarClassHeader(clsName, parentClass) \
00056         mSliderClassHeader(clsName, parentClass)
00057
00064 struct _mScrollBarClass
00065 {
00066         mScrollBarClassHeader(mScrollBar, mSlider)
00067 };
00068
00075 MGNCS_EXPORT extern mScrollBarClass g_stmScrollBarCls;
00076
00077
00078 #define mHScrollBar mScrollBar
00079 #define mHScrollBarClass mScrollBarClass
00080 #define g_stmHScrollBarCls  g_stmScrollBarCls
00081 #define mVScrollBar mScrollBar
00082 #define mVScrollBarClass mScrollBarClass
00083 #define g_stmVScrollBarCls  g_stmScrollBarCls
00084
00085
00086 #define mScrollBarRendererHeader(clsName, parentClass) \
00087         mSliderRendererHeader(clsName, parentClass)
00088
00095 struct _mScrollBarRenderer
00096 {
00097         mScrollBarRendererHeader(mScrollBar, mSlider)
00098 };
00099
00100
00105 #define NCSP_SCRLBR_MAXPOS              NCSP_SLIDER_MAXPOS
00106
00110 #define NCSP_SCRLBR_MINPOS              NCSP_SLIDER_MINPOS
00111
00115 #define NCSP_SCRLBR_CURPOS              NCSP_SLIDER_CURPOS
00116
00120 #define NCSP_SCRLBR_LINESTEP    NCSP_SLIDER_LINESTEP
00121
00125 #define NCSP_SCRLBR_PAGESTEP    NCSP_SLIDER_PAGESTEP
00126
00127 #define NCSP_SCRLBR_MAX        (NCSP_SLIDER_MAX + 1)
00128
00129
00134 #define NCSS_SCRLBR_HORIZONTAL       NCSS_SLIDER_HORIZONTAL
00135
00139 #define NCSS_SCRLBR_ARROWS           (1<<NCSS_SLIDER_SHIFT)
00140
00145 #define NCSS_SCRLBR_LEFTDBLARROWS    (2<<NCSS_SLIDER_SHIFT)
00146
00151 #define NCSS_SCRLBR_UPDBLARROWS      NCSS_SCRLBR_LEFTDBLARROWS
00152
00157 #define NCSS_SCRLBR_RIGHTDBLARROWS   (4<<NCSS_SLIDER_SHIFT)
00158
00163 #define NCSS_SCRLBR_DOWNDBLARROWS     NCSS_SCRLBR_RIGHTDBLARROWS
00164 #define NCSS_SCRLBR_SHIFT            (3+NCSS_SLIDER_SHIFT)
00165
00170 #define NCSS_SCRLBR_VERTICAL   NCSS_SLIDER_VERTICAL
00171
00176 #define NCSN_SCRLBR_CHANGED    NCSN_SLIDER_CHANGED
00177
00182 #define NCSN_SCRLBR_REACHMAX   NCSN_SLIDER_REACHMAX
00183
00188 #define NCSN_SCRLBR_REACHMIN   NCSN_SLIDER_REACHMIN
00189
00194 //#define       NCSN_SCRLBR_STARTDRAG  NCSN_SLIDER_STARTDRAG
00195
00200 //#define       NCSN_SCRLBR_STOPDRAG   NCSN_SLIDER_STOPDRAG
00201
00202 #define NCSN_SCRLBR_MAX        NCSN_SLIDER_MAX
00203
00206 #ifdef __cplusplus
00207 }
00208 #endif  /* __cplusplus */
00209
00210 #endif /* _MGUI_NCSCTRL_SCRLBR_H */
00211
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mscrollbarpiece.h Source File

include » pieces

mscrollbarpiece.h

00001
00002 #ifndef _MGUI_NCSCTRL_SCROLLBARPIECE_H
00003 #define _MGUI_NCSCTRL_SCROLLBARPIECE_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif
00008
00009 typedef struct _mScrollBarPieceClass mScrollBarPieceClass;
00010 typedef struct _mScrollBarPiece mScrollBarPiece;
00011
00012 #define mScrollBarPieceClassHeader(clss, superCls) \
00013         mRenderablePieceClassHeader(clss, superCls)
00014
00015 struct _mScrollBarPieceClass
00016 {
00017         mScrollBarPieceClassHeader(mScrollBarPiece, mRenderablePiece)
00018 };
00019
00020 MGNCS_EXPORT extern mScrollBarPieceClass g_stmScrollBarPieceCls;
00021
00022 #define mScrollBarPieceHeader(clss) \
00023         mRenderablePieceHeader(clss)
00024
00025 struct _mScrollBarPiece
00026 {
00027         mScrollBarPieceHeader(mScrollBarPiece)
00028 };
00029
00030
00031 #ifdef __cplusplus
00032 }
00033 #endif
00034
00035 #endif
00036
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mscrollthumbboxpiece.h Source File

include » pieces

mscrollthumbboxpiece.h

00001
00002 #ifndef _MGUI_NCSCTRL_SCROLLTHUMBBOXPIECE_H
00003 #define _MGUI_NCSCTRL_SCROLLTHUMBBOXPIECE_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif
00008
00009 typedef struct _mScrollThumbBoxPieceClass mScrollThumbBoxPieceClass;
00010 typedef struct _mScrollThumbBoxPiece mScrollThumbBoxPiece;
00011
00012 #define mScrollThumbBoxPieceClassHeader(clss, superCls) \
00013         mRenderablePieceClassHeader(clss, superCls)
00014
00015 struct _mScrollThumbBoxPieceClass
00016 {
00017         mScrollThumbBoxPieceClassHeader(mScrollThumbBoxPiece, mRenderablePiece)
00018 };
00019
00020 MGNCS_EXPORT extern mScrollThumbBoxPieceClass g_stmScrollThumbBoxPieceCls;
00021
00022 #define mScrollThumbBoxPieceHeader(clss) \
00023         mRenderablePieceHeader(clss)
00024
00025 struct _mScrollThumbBoxPiece
00026 {
00027         mScrollThumbBoxPieceHeader(mScrollThumbBoxPiece)
00028 };
00029
00030
00031 #ifdef __cplusplus
00032 }
00033 #endif
00034
00035 #endif
00036
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mscrollview.h Source File

include

mscrollview.h

Go to the documentation of this file.
00001
00026 #ifndef _MGUI_CTRL_SCRLV_H
00027 #define _MGUI_CTRL_SCRLV_H
00028
00029
00030 #ifdef __cplusplus
00031 extern "C" {
00032 #endif  /* __cplusplus */
00033
00042 typedef struct _NCS_SCRLV_ITEMINFO
00043 {
00045     int     index;
00047     int     height;
00049     DWORD   addData;
00050 }NCS_SCRLV_ITEMINFO;
00051
00052 typedef struct _mScrollView mScrollView;
00053 typedef struct _mScrollViewClass mScrollViewClass;
00054 typedef struct _mScrollViewRenderer mScrollViewRenderer;
00055
00060 #define NCSCTRL_SCROLLVIEW NCSCLASSNAME("scrollview")
00061
00066 #define NCSS_SCRLV_SHIFT       (NCSS_ITEMV_SHIFT)
00067
00072 #define NCSS_SCRLV_UPNOTIFY    NCSS_ITEMV_UPNOTIFY
00073
00078 #define NCSS_SCRLV_LOOP        NCSS_ITEMV_LOOP
00079
00084 #define NCSS_SCRLV_SORT        NCSS_ITEMV_AUTOSORT
00085
00086 #define mScrollViewHeader(className)    \
00087     mItemViewHeader(className)
00088
00089
00094 struct _mScrollView
00095 {
00096         mScrollViewHeader(mScrollView)
00097 };
00098
00099 #define mScrollViewClassHeader(clsName, parentClass)    \
00100     mItemViewClassHeader(clsName, parentClass)          \
00101     HITEM (*addItem)(clsName*, NCS_SCRLV_ITEMINFO *info, int *pos);
00102
00112 struct _mScrollViewClass
00113 {
00114         mScrollViewClassHeader(mScrollView, mItemView)
00115 };
00116
00117 #define mScrollViewRendererHeader(clsName, parentClass) \
00118         mItemViewRendererHeader(clsName, parentClass)
00119
00125 struct  _mScrollViewRenderer {
00126         mScrollViewRendererHeader(mScrollView, mItemView)
00127 };
00128
00133 enum mScrollViewProp
00134 {
00138         NCSP_SCRLV_MAX = NCSP_ITEMV_MAX + 1,
00139 };
00140
00145 enum mScrollViewNotify
00146 {
00148     NCSN_SCRLV_CLICKED = NCSN_ITEMV_CLICKED,
00150     NCSN_SCRLV_SELCHANGED = NCSN_ITEMV_SELCHANGED,
00152     NCSN_SCRLV_SELCHANGING = NCSN_ITEMV_SELCHANGING,
00156     NCSN_SCRLV_MAX = NCSN_ITEMV_MAX + 1,
00157 };
00158
00165 MGNCS_EXPORT extern mScrollViewClass g_stmScrollViewCls;
00168 #ifdef __cplusplus
00169 }
00170 #endif  /* __cplusplus */
00171
00172 #endif /* _MGUI_CTRL_SCRLV_H */
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mseparator.h Source File

include

mseparator.h

00001
00002 #ifndef _MGUI_NCSCTRL_SPRTR_H
00003 #define _MGUI_NCSCTRL_SPRTR_H
00004
00005
00006 #ifdef __cplusplus
00007 extern "C" {
00008 #endif  /* __cplusplus */
00009
00020 #define NCSCTRL_SEPARATOR        NCSCLASSNAME("separator")
00021
00022 typedef struct _mSeparator mSeparator;
00023 typedef struct _mSeparatorClass mSeparatorClass;
00024 typedef struct _mSeparatorRenderer mSeparatorRenderer;
00025
00026 #define mSeparatorHeader(clsName) \
00027         mStaticHeader(clsName)
00028
00034 struct _mSeparator
00035 {
00036         mSeparatorHeader(mSeparator)
00037 };
00038
00039 #define mSeparatorClassHeader(clsName, parentClass)  \
00040         mStaticClassHeader(clsName, parentClass)
00041
00047 struct _mSeparatorClass
00048 {
00049         mSeparatorClassHeader(mSeparator, mStatic)
00050 };
00051
00052 #define mHSeparator mSeparator
00053 #define mHSeparatorClass mSeparatorClass
00054 #define g_stmHSeparatorCls  g_stmSeparatorCls
00055 #define mVSeparator mSeparator
00056 #define mVSeparatorclass mSeparatorclass
00057 #define g_stmVSeparatorCls  g_stmSeparatorCls
00058
00059 #define mSeparatorRendererHeader(clsName, parentClass) \
00060         mStaticRendererHeader(clsName, parentClass)
00061
00067 /* define the render of image static */
00068 struct _mSeparatorRenderer {
00069         mSeparatorRendererHeader(mSeparator, mStatic)
00070 };
00071
00077 MGNCS_EXPORT extern mSeparatorClass g_stmSeparatorCls;
00078
00084 /* property */
00085 enum mSeparatorProp {
00086         NCSP_SPRTR_MAX = NCSP_STATIC_MAX + 1
00087 };
00088
00093 #define NCSS_SPRTR_VERT  (0x1<<NCSS_STATIC_SHIFT)
00094 #define NCSS_SPRTR_SHIFT (1+NCSS_STATIC_SHIFT)
00095
00100 enum enumSeparatorNotify{
00101         NCSN_SPRTR_MAX = NCSN_STATIC_MAX + 1
00102 };
00103
00107 #ifdef __cplusplus
00108 }
00109 #endif  /* __cplusplus */
00110
00111 #endif /* _MGUI_NCSCTRL_SPRTR_H */
00112
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mseparatorpiece.h Source File

include » pieces

mseparatorpiece.h

00001
00002 #ifndef _MGUI_NCSCTRL_SEPARATORPIECE_H
00003 #define _MGUI_NCSCTRL_SEPARATORPIECE_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif
00008
00009 typedef struct _mSeparatorPieceClass mSeparatorPieceClass;
00010 typedef struct _mSeparatorPiece mSeparatorPiece;
00011
00012 #define mSeparatorPieceClassHeader(clss, superCls) \
00013         mStaticPieceClassHeader(clss, superCls)
00014
00015 struct _mSeparatorPieceClass
00016 {
00017         mSeparatorPieceClassHeader(mSeparatorPiece, mStaticPiece)
00018 };
00019
00020 MGNCS_EXPORT extern mSeparatorPieceClass g_stmSeparatorPieceCls;
00021
00022 #define mSeparatorPieceHeader(clss) \
00023         mStaticPieceHeader(clss)
00024
00025 struct _mSeparatorPiece
00026 {
00027         mSeparatorPieceHeader(mSeparatorPiece)
00028 };
00029
00030
00031 #ifdef __cplusplus
00032 }
00033 #endif
00034
00035 #endif
00036
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: msimplelistpiece.h Source File

include » pieces

msimplelistpiece.h

00001
00002 #ifndef _MGUI_SIMPLE_LIST_H
00003 #define _MGUI_SIMPLE_LIST_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif
00008
00009 typedef struct _mSimpleListPieceClass mSimpleListPieceClass;
00010 typedef struct _mSimpleListPiece      mSimpleListPiece;
00011
00012 #define mSimpleListPieceClassHeader(clss, superCls)        \
00013         mContainerPieceClassHeader(clss, superCls)         \
00014         void (*reset)(clss*, void(*free_piece)(mHotPiece*));
00015
00016
00017 #define mSimpleListPieceHeader(clss)                       \
00018         mContainerPieceHeader(clss)                        \
00019         mLineLayoutPieceNode * cur_node;
00020
00021 struct _mSimpleListPieceClass {
00022         mSimpleListPieceClassHeader(mSimpleListPiece, mContainerPiece)
00023 };
00024
00025 struct _mSimpleListPiece {
00026         mSimpleListPieceHeader(mSimpleListPiece)
00027 };
00028
00029 extern mSimpleListPieceClass g_stmSimpleListPieceCls;
00030
00031 enum mSimpleListPieceProps {
00032         NCSP_SIMPLELISTPIECE_CURINDEX = SIMPLELISTPIECE_PROP_BEGIN,
00033 };
00034
00035 enum mSimpleListPieceEvent {
00036         NCSN_SIMPLELISTPIECE_REACHHEAD = SIMPLELISTPIECE_EVENT_BEGIN,
00037         NCSN_SIMPLELISTPIECE_REACHTAIL,
00038         NCSN_SIMPLELISTPIECE_CHANGED
00039 };
00040
00041 #define mSimpleListPiece_getLineLayout(slp) \
00042         ((mLineLayoutPiece*)((slp)?(slp)->body:NULL))
00043
00044
00045 #ifdef __cplusplus
00046 }
00047 #endif
00048
00049
00050 #endif
00051
00052
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: msledit.h Source File

include

msledit.h

Go to the documentation of this file.
00001
00019 #ifndef _MGUI_NCSCTRL_SLEDIT_H
00020 #define _MGUI_NCSCTRL_SLEDIT_H
00021
00022 #ifdef __cplusplus
00023 extern "C" {
00024 #endif  /* __cplusplus */
00025
00031 /*
00032  * \def NCSCTRL_SLEDIT
00033  * \brief the name of sledit control
00034 */
00035 #define NCSCTRL_SLEDIT   NCSCLASSNAME("sledit")
00036
00037 typedef struct _mSlEdit         mSlEdit;
00038 typedef struct _mSlEditClass    mSlEditClass;
00039 typedef struct _mSlEditRenderer mSlEditRenderer;
00040
00041 #define mSlEditHeader(Class) \
00042         mEditHeader(Class)      \
00043         DWORD   status;         \
00044         int     editPos;        \
00045         int     selStart;       \
00046         int     selEnd;         \
00047         int     nContX;         \
00048         int     nContW;         \
00049         RECT    rcVis;          \
00050         int     nVisW;          \
00051         int     startX;         \
00052         int     startY;         \
00053         int     nBlockSize;     \
00054         StrBuffer content;      \
00055         char    *tipText;       \
00056         int     hardLimit;      \
00057         int     passwdChar;     \
00058         int     changed;        \
00059         TextCopyPaste *cp;
00060
00106 struct _mSlEdit
00107 {
00108     mSlEditHeader(mSlEdit)
00109 };
00110
00111 #define mSlEditClassHeader(clsName, parentClass) \
00112         mEditClassHeader(clsName, parentClass)
00113
00120 struct _mSlEditClass
00121 {
00122     mSlEditClassHeader(mSlEdit, mEdit)
00123 };
00124
00131 MGNCS_EXPORT extern mSlEditClass g_stmSlEditCls;
00132
00133 #define mSlEditRendererHeader(clsName, parentClass) \
00134         mEditRendererHeader(clsName, parentClass)
00135
00142 struct _mSlEditRenderer
00143 {
00144         mSlEditRendererHeader(mSlEdit, mEdit)
00145 };
00146
00147
00152 #define NCSS_SLEDIT_PASSWORD   (0x0001L<<NCSS_EDIT_SHIFT)
00153
00158 #define NCSS_SLEDIT_AUTOSELECT (0x0002L<<NCSS_EDIT_SHIFT)
00159
00160 /*
00161  * \def NCSS_SLEDIT_TIP
00162  * \brief Shows specified tip text.
00163  */
00164 #define NCSS_SLEDIT_TIP        (0x0004L<<NCSS_EDIT_SHIFT)
00165
00166 #define NCSS_SLEDIT_SHIFT       (NCSS_EDIT_SHIFT+3)
00167
00169 enum mSlEditProp
00170 {
00171     NCSP_SLEDIT_TIPTEXT = NCSP_EDIT_MAX + 1,
00172     NCSP_SLEDIT_PWDCHAR,
00173     NCSP_SLEDIT_MAX
00174 };
00175
00177 enum mSlEditNotify
00178 {
00179     NCSN_SLEDIT_CHANGE = NCSN_EDIT_CHANGE,
00180     NCSN_SLEDIT_ENTER = NCSN_ITEMV_ENTER,
00181     NCSN_SLEDIT_MAX = NCSN_EDIT_MAX + 1,
00182 };
00183
00184 #define NCST_SLEDIT_FOCUSED     0x00000001L
00185 #define NCST_SLEDIT_MODIFY      0x00000002L
00186 #define NCST_SLEDIT_TMP         0x00000004L
00187 #define NCST_SLEDIT_REPLACE     0x00000008L
00188
00191 #ifdef __cplusplus
00192 }
00193 #endif  /* __cplusplus */
00194
00195 #endif /* _MGUI_NCSCTRL_SLEDIT_H */
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mslider.h Source File

include

mslider.h

Go to the documentation of this file.
00001
00020 #ifndef _MGUI_NCSCTRL_SLIDER_H
00021 #define _MGUI_NCSCTRL_SLIDER_H
00022
00023 #ifdef __cplusplus
00024 extern "C" {
00025 #endif  /* __cplusplus */
00026
00032 /*
00033  * \def NCSCTRL_SLIDER
00034  * \brief the name of slider control
00035 */
00036
00037 #define NCSCTRL_SLIDER   NCSCLASSNAME("slider")
00038
00039 typedef struct _mSlider            mSlider;
00040 typedef struct _mSliderClass       mSliderClass;
00041 typedef struct _mSliderRenderer    mSliderRenderer;
00042
00043 #define mSliderHeader(Class) \
00044     mWidgetHeader(Class)
00045
00052 struct _mSlider
00053 {
00054         mSliderHeader(mSlider)
00055 };
00056
00057 #define mSliderClassHeader(clsName, parentClass) \
00058         mWidgetClassHeader(clsName, parentClass)
00059
00066 struct _mSliderClass
00067 {
00068         mSliderClassHeader(mSlider, mWidget)
00069 };
00070
00077 MGNCS_EXPORT extern mSliderClass g_stmSliderCls;
00078
00079 #define mSliderRendererHeader(clsName, parentClass)  \
00080         mWidgetRendererHeader(clsName, parentClass)  \
00081         void (*calcSlider)(clsName *, DWORD calc_area); \
00082         void (*drawSlider)(clsName *, HDC hdc);
00083
00084 enum mSliderArea
00085 {
00086         NCSSLIDER_AREA_INCARROW = 0x01,
00087         NCSSLIDER_AREA_DECARROW = 0x02,
00088         NCSSLIDER_AREA_ARROWS = 0x03,
00089         NCSSLIDER_AREA_SLIDER = 0x04,
00090         NCSSLIDER_AREA_TRACK = 0x08,
00091         NCSSLIDER_AREA_ALL = 0xFFFF //
00092 };
00093
00100 struct _mSliderRenderer
00101 {
00102         mSliderRendererHeader(mSlider, mWidget)
00103 };
00104
00110 enum mSliderProp {
00116     NCSP_SLIDER_MAXPOS = NCSP_WIDGET_MAX + 1,
00122     NCSP_SLIDER_MINPOS,
00128     NCSP_SLIDER_CURPOS,
00134     NCSP_SLIDER_LINESTEP,
00140     NCSP_SLIDER_PAGESTEP,
00141     NCSP_SLIDER_MAX
00142 };
00143
00148 #define NCSS_SLIDER_HORIZONTAL          0x0000L
00149
00154 #define NCSS_SLIDER_VERTICAL            (0x0001L<<NCSS_WIDGET_SHIFT)
00155
00156 #define NCSS_SLIDER_SHIFT      (NCSS_WIDGET_SHIFT + 2)
00157
00158
00163 enum enumSliderNotify {
00168         NCSN_SLIDER_CHANGED = NCSN_WIDGET_MAX,
00172         NCSN_SLIDER_REACHMAX,
00176         NCSN_SLIDER_REACHMIN,
00177         //NCSN_SLIDER_STARTDRAG,                 /**< start to drag it*/
00178         //NCSN_SLIDER_STOPDRAG,                  /**< stop to drag it*/
00179         NCSN_SLIDER_MAX
00180 };
00181
00186 enum mSliderHitTest{
00187         NCSSLIDER_HT_NONE = 0,
00188         NCSSLIDER_HT_SLIDER ,
00189         NCSSLIDER_HT_TRACK,
00190         NCSSLIDER_HT_INCARROW,
00191         NCSSLIDER_HT_DECARROW
00192 };
00193 #ifdef __cplusplus
00194 }
00195 #endif  /* __cplusplus */
00196
00197 #endif /* _MGUI_NCSCTRL_SLIDER_H */
00198
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: msliderpiece.h Source File

include » pieces

msliderpiece.h

00001
00002 #ifndef _MGUI_NCSCTRL_SLIDERPIECE_H
00003 #define _MGUI_NCSCTRL_SLIDERPIECE_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif
00008
00009 typedef struct _mSliderPieceClass mSliderPieceClass;
00010 typedef struct _mSliderPiece mSliderPiece;
00011
00012 #define mSliderPieceClassHeader(clss, superCls) \
00013         mContainerPieceClassHeader(clss, superCls) \
00014         int (*stepLine)(clss*, BOOL forward); \
00015         int (*stepPage)(clss*, BOOL forward);
00016
00017 struct _mSliderPieceClass
00018 {
00019         mSliderPieceClassHeader(mSliderPiece, mContainerPiece)
00020 };
00021
00022 MGNCS_EXPORT extern mSliderPieceClass g_stmSliderPieceCls;
00023
00024 #define mSliderPieceHeader(clss) \
00025         mContainerPieceHeader(clss)  \
00026         mHotPiece * thumb; \
00027         unsigned char flags; \
00028         unsigned char thumb_state; \
00029         unsigned short line_step; \
00030         unsigned short page_step; \
00031         unsigned short cur_pos; \
00032         unsigned short min; \
00033         unsigned short max;
00034
00035 #define NCSS_SLIDERPIECE_VERT   0x01
00036 #define NCSS_SLIDERPIECE_TICK   0x02
00037 #define NCSS_SLIDERPIECE_MIN    0x04
00038 #define NCSS_SLIDERPIECE_MAX    0x08
00039 #define NCSS_SLIDERPIECE_CENTERTHUMB 0x10 //the start point at the center of thumb
00040
00041 #define mSliderPiece_setVert(self)    (((self)->flags)|= NCSS_SLIDERPIECE_VERT)
00042 #define mSliderPiece_setHorz(self)    (((self)->flags)&= (~NCSS_SLIDERPIECE_VERT))
00043 #define mSliderPiece_isVert(self)     ((((self)->flags)&NCSS_SLIDERPIECE_VERT) == NCSS_SLIDERPIECE_VERT)
00044
00045 #define mSliderPiece_setTick(self)    (((self)->flags)|=NCSS_SLIDERPIECE_TICK)
00046 #define mSliderPiece_clearTick(self)  (((self)->flags)&=(~NCSS_SLIDERPIECE_TICK))
00047 #define mSliderPiece_isTick(self)     (((self)->flags)&NCSS_SLIDERPIECE_TICK)
00048
00049 #define mSliderPiece_setMin(self)     (((self)->flags)|=NCSS_SLIDERPIECE_MIN)
00050 #define mSliderPiece_clearMin(self)   (((self)->flags)&=(~NCSS_SLIDERPIECE_MIN))
00051 #define mSliderPiece_isMin(self)      ((self)->flags & NCSS_SLIDERPIECE_MIN)
00052
00053 #define mSliderPiece_setMax(self)     (((self)->flags)|=NCSS_SLIDERPIECE_MAX)
00054 #define mSliderPiece_clearMax(self)   (((self)->flags)&=(~NCSS_SLIDERPIECE_MAX))
00055 #define mSliderPiece_isMax(self)      ((self)->flags & NCSS_SLIDERPIECE_MAX)
00056
00057 #define mSliderPiece_setCenterThumb(self)  (((self)->flags) |= NCSS_SLIDERPIECE_CENTERTHUMB)
00058 #define mSliderPiece_clearCenterThumb(self) (((self)->flags) &= (~NCSS_SLIDERPIECE_CENTERTHUMB))
00059 #define mSliderPiece_isCenterThumb(self)  ((self)->flags & NCSS_SLIDERPIECE_CENTERTHUMB)
00060
00061 struct _mSliderPiece
00062 {
00063         mSliderPieceHeader(mSliderPiece)
00064 };
00065
00066 enum mSliderPieceProps{
00067         NCSP_SLIDERPIECE_POS = SLIDERPIECE_PROP_BEGIN,
00068         NCSP_SLIDERPIECE_LINESTEP ,
00069         NCSP_SLIDERPIECE_PAGESTEP ,
00070         NCSP_SLIDERPIECE_MAX,
00071         NCSP_SLIDERPIECE_MIN,
00072         NCSP_SLIDERPIECE_TICK,
00073
00074         NCSP_SLIDERPIECE_DIRECTION = PIECECOMM_PROP_DIRECTION
00075 };
00076
00077 enum mSliderPieceEvent
00078 {
00079         NCSN_SLIDERPIECE_POSCHANGED = SLIDERPIECE_EVENT_BEGIN,
00080         NCSN_SLIDERPIECE_REACHMAX,
00081         NCSN_SLIDERPIECE_REACHMIN
00082 };
00083
00084 #ifdef __cplusplus
00085 }
00086 #endif
00087
00088 #endif
00089
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mspinbox.h Source File

include

mspinbox.h

Go to the documentation of this file.
00001
00020 #ifndef _MGUI_NCSCTRL_SPINBOX_H
00021 #define _MGUI_NCSCTRL_SPINBOX_H
00022
00023 #ifdef __cplusplus
00024 extern "C" {
00025 #endif  /* __cplusplus */
00026
00032 /*
00033  * \def NCSCTRL_SPINBOX
00034  * \brief the name of spinbox control
00035 */
00036 #define NCSCTRL_SPINBOX   NCSCLASSNAME("spinbox")
00037
00038 #define NCS_LEN_SPINBOX     63
00039
00040 typedef struct _mSpinBox            mSpinBox;
00041 typedef struct _mSpinBoxClass       mSpinBoxClass;
00042 typedef struct _mSpinBoxRenderer    mSpinBoxRenderer;
00043
00044 typedef struct _mSpinBoxItemInfo    mSpinBoxItemInfo;
00045 #define mSpinBoxHeader(clsName)     \
00046     mSpinnerHeader(clsName)      \
00047         union {                         \
00048                 char* num_format;           \
00049                 mSpinBoxItemInfo *items;    \
00050         }info;
00051
00058 struct _mSpinBox
00059 {
00060         mSpinBoxHeader(mSpinBox)
00061 };
00062
00063 #define mSpinBoxClassHeader(clsName, parentClass)   \
00064         mSpinnerClassHeader(clsName, parentClass)       \
00065     BOOL (*addItem)(clsName *self, char *item);    \
00066     BOOL (*removeItem)(clsName *self, int index);  \
00067     BOOL (*setItem)(clsName *self, int index, char *item);     \
00068     char* (*getItem)(clsName *self, int index);
00069
00094 struct _mSpinBoxClass
00095 {
00096         mSpinBoxClassHeader(mSpinBox, mSpinner)
00097 };
00098
00099 MGNCS_EXPORT extern mSpinBoxClass g_stmSpinBoxCls;
00100
00101 #define mSpinBoxRendererHeader(clsName, parentClass)    \
00102         mSpinnerRendererHeader(clsName, parentClass)
00103
00110 struct _mSpinBoxRenderer
00111 {
00112         mSpinBoxRendererHeader(mSpinBox, mSpinner)
00113 };
00114
00116 enum mSpinBoxProp {
00117     NCSP_SPNBOX_MAXPOS = NCSP_SPNR_MAXPOS,
00118     NCSP_SPNBOX_MINPOS = NCSP_SPNR_MINPOS,
00119     NCSP_SPNBOX_CURPOS = NCSP_SPNR_CURPOS,
00120     NCSP_SPNBOX_LINESTEP = NCSP_SPNR_LINESTEP,
00121     NCSP_SPNBOX_MAX = NCSP_SPNR_MAX
00122 };
00123
00124
00129 #define NCSS_SPNBOX_VERTICAL           (NCSS_SPNR_VERTICAL)
00130
00135 #define NCSS_SPNBOX_HORIZONTAL         (NCSS_SPNR_HORIZONTAL)
00136
00141 #define NCSS_SPNBOX_AUTOLOOP           (NCSS_SPNR_AUTOLOOP)
00142
00147 #define NCSS_SPNBOX_NUMBER             (0x0000L<<NCSS_SPNR_SHIFT)
00148
00153 #define NCSS_SPNBOX_STRING             (0x0001L<<NCSS_SPNR_SHIFT)
00154
00159 #define NCSS_SPNBOX_SORT               (0x0002L<<NCSS_SPNR_SHIFT)
00160
00165 #define NCSS_SPNBOX_EDITNOBORDER       (0x0004L<<NCSS_SPNR_SHIFT)
00166
00171 #define NCSS_SPNBOX_EDITBASELINE       (0x0008L<<NCSS_SPNR_SHIFT)
00172
00177 #define NCSS_SPNBOX_READONLY           (0x0010L<<NCSS_SPNR_SHIFT)
00178
00183 #define NCSS_SPNBOX_UPPERCASE          (0x0020L<<NCSS_SPNR_SHIFT)
00184
00189 #define NCSS_SPNBOX_LOWERCASE          (0x0040L<<NCSS_SPNR_SHIFT)
00190
00195 #define NCSS_SPNBOX_AUTOFOCUS          (0x0080L<<NCSS_SPNR_SHIFT)
00196
00197 #define NCSS_SPNBOX_SHIFT      (NCSS_SPNR_SHIFT + 9)
00198
00199
00201 enum mSpinBoxNotify {
00202     NCSN_SPNBOX_CHANGED = NCSN_SPNR_CHANGED,
00203     NCSN_SPNBOX_REACHMAX = NCSN_SPNR_REACHMAX,
00204     NCSN_SPNBOX_REACHMIN = NCSN_SPNR_REACHMIN,
00205     NCSN_SPNBOX_MAX = NCSN_SPNR_MAX
00206 };
00207
00211
00212 #define NCSST_SPNBOX_NORMAL        0x0000
00213 #define NCSST_SPNBOX_DISABLE       0x0001
00214 #define NCSST_SPNBOX_HILIGHT       0x0002
00215 #define NCSST_SPNBOX_PUSHED        0x0004
00216
00219 #ifdef __cplusplus
00220 }
00221 #endif  /* __cplusplus */
00222
00223 #endif /* _MGUI_NCSCTRL_SPINBOX_H */
00224
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mspinboxpiece.h Source File

include » pieces

mspinboxpiece.h

00001
00002 #ifndef _MGUI_NCSCTRL_SPNRPIECE_H
00003 #define _MGUI_NCSCTRL_SPNRPIECE_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif
00008
00009 typedef struct _mSpinBoxPieceClass mSpinBoxPieceClass;
00010 typedef struct _mSpinBoxPiece mSpinBoxPiece;
00011
00012 #define mSpinBoxPieceClassHeader(clss, superCls) \
00013         mSpinnerPieceClassHeader(clss, superCls)   \
00014         mHotPiece *(*getSpinnedPiece)(clss *);
00015
00016 struct _mSpinBoxPieceClass
00017 {
00018         mSpinBoxPieceClassHeader(mSpinBoxPiece, mSpinnerPiece)
00019 };
00020
00021 MGNCS_EXPORT extern mSpinBoxPieceClass g_stmSpinBoxPieceCls;
00022
00023 #define mSpinBoxPieceHeader(clss) \
00024         mSpinnerPieceHeader(clss)
00025
00026 struct _mSpinBoxPiece
00027 {
00028         mSpinBoxPieceHeader(mSpinBoxPiece)
00029 };
00030
00031 #ifdef __cplusplus
00032 }
00033 #endif
00034
00035 #endif
00036
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mspinner.h Source File

include

mspinner.h

Go to the documentation of this file.
00001
00020 #ifndef _MGUI_NCSCTRL_SPINNER_H
00021 #define _MGUI_NCSCTRL_SPINNER_H
00022
00023 #ifdef __cplusplus
00024 extern "C" {
00025 #endif  /* __cplusplus */
00026
00032 /*
00033  * \def NCSCTRL_SPINNER
00034  * \brief the name of spinner control
00035 */
00036 #define NCSCTRL_SPINNER   NCSCLASSNAME("spinner")
00037
00038 typedef struct _mSpinner            mSpinner;
00039 typedef struct _mSpinnerClass       mSpinnerClass;
00040 typedef struct _mSpinnerRenderer    mSpinnerRenderer;
00041
00042 #define mSpinnerHeader(clsName) \
00043     mWidgetHeader(clsName)      \
00044     HWND h_target;
00045
00046
00055 struct _mSpinner
00056 {
00057         mSpinnerHeader(mSpinner)
00058 };
00059
00060 #define mSpinnerClassHeader(clsName, parentClass) \
00061         mWidgetClassHeader(clsName, parentClass)
00062
00069 struct _mSpinnerClass
00070 {
00071         mSpinnerClassHeader(mSpinner, mWidget)
00072 };
00073
00074 MGNCS_EXPORT extern mSpinnerClass g_stmSpinnerCls;
00075
00076 #define mHSpinner mSpinner
00077 #define mHSpinnerClass mSpinnerClass
00078 #define g_stmHSpinnerCls  g_stmSpinnerCls
00079 #define mVSpinner mSpinner
00080 #define mVSpinnerClass mSpinnerClass
00081 #define g_stmVSpinnerCls  g_stmSpinnerCls
00082
00083
00084
00085 #define mSpinnerRendererHeader(clsName, parentClass)    \
00086         mWidgetRendererHeader(clsName, parentClass)
00087
00094 struct _mSpinnerRenderer
00095 {
00096         mSpinnerRendererHeader(mSpinner, mWidget)
00097 };
00098
00100 enum mSpinnerProp {
00101     NCSP_SPNR_MAXPOS = NCSP_WIDGET_MAX + 1,
00102     NCSP_SPNR_MINPOS,
00103     NCSP_SPNR_CURPOS,
00104     NCSP_SPNR_LINESTEP,
00105     NCSP_SPNR_TARGET,
00106     NCSP_SPNR_MAX
00107 };
00108
00109 #define KS_SPINPOST             0x00010000
00110
00111
00116 #define NCSS_SPNR_VERTICAL       0x0000L
00117
00122 #define NCSS_SPNR_HORIZONTAL     ((0x0001L)<<(NCSS_WIDGET_SHIFT))
00123
00128 #define NCSS_SPNR_AUTOLOOP       ((0x0002L)<<(NCSS_WIDGET_SHIFT))
00129
00130 #define NCSS_SPNR_SHIFT (NCSS_WIDGET_SHIFT + 2)
00131
00132
00134 enum mSpinnerNotify {
00135         NCSN_SPNR_CHANGED = NCSN_WIDGET_MAX + 1,
00136         NCSN_SPNR_REACHMAX,
00137         NCSN_SPNR_REACHMIN,
00138         NCSN_SPNR_MAX
00139 };
00140
00144
00145 #define NCSST_SPNR_NORMAL        0x0000
00146 #define NCSST_SPNR_DISABLE       0x0001
00147 #define NCSST_SPNR_HILIGHT       0x0002
00148 #define NCSST_SPNR_PUSHED        0x0004
00149
00152 #ifdef __cplusplus
00153 }
00154 #endif  /* __cplusplus */
00155
00156 #endif /* _MGUI_NCSCTRL_SPINNER_H */
00157
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mspinnerpiece.h Source File

include » pieces

mspinnerpiece.h

00001
00002 #ifndef _MGUI_NCSCTRL_SPINNERPIECE_H
00003 #define _MGUI_NCSCTRL_SPINNERPIECE_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif
00008
00009 typedef struct _mSpinnerPieceClass mSpinnerPieceClass;
00010 typedef struct _mSpinnerPiece mSpinnerPiece;
00011
00012 #define mSpinnerPieceClassHeader(clss, superCls) \
00013         mContainerPieceClassHeader(clss, superCls)  \
00014         int (*lineStep)(clss*, BOOL bPrev); \
00015  \
00016         mHotPiece *(*getIncPiece)(clss *); \
00017         mHotPiece *(*getDecPiece)(clss *); \
00018         void (*onPosChanged)(clss *);
00019
00020 struct _mSpinnerPieceClass
00021 {
00022         mSpinnerPieceClassHeader(mSpinnerPiece, mContainerPiece)
00023 };
00024
00025 MGNCS_EXPORT extern mSpinnerPieceClass g_stmSpinnerPieceCls;
00026
00027 #define mSpinnerPieceHeader(clss) \
00028         mContainerPieceHeader(clss)  \
00029         int max; \
00030         int min; \
00031         int cur_pos;  \
00032         int line_step; \
00033     int loop_flag;
00034
00035 struct _mSpinnerPiece
00036 {
00037         mSpinnerPieceHeader(mSpinnerPiece)
00038 };
00039
00040 enum mSpinnerPieceProps{
00041         NCSP_SPNRPIECE_MAXPOS   = PIECECOMM_PROP_MAX,
00042         NCSP_SPNRPIECE_MINPOS   = PIECECOMM_PROP_MIN,
00043         NCSP_SPNRPIECE_LINESTEP = PIECECOMM_PROP_LINESTEP,
00044         NCSP_SPNRPIECE_CURPOS   = PIECECOMM_PROP_POS,
00045         NCSP_SPNRPIECE_LOOP     = SPINBOXPIECE_PROP_BEGIN
00046 };
00047
00048 enum mSpinnerPieceEvents{
00049         NCSN_SPNRPIECE_INC = SPINBOXPIECE_EVENT_BEGIN,
00050         NCSN_SPNRPIECE_DEC,
00051         NCSN_SPNRPIECE_REACHMIN,
00052         NCSN_SPNRPIECE_REACHMAX,
00053         NCSN_SPNRPIECE_MAX
00054 };
00055
00056 #ifdef __cplusplus
00057 }
00058 #endif
00059
00060 #endif
00061
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mstatic.h Source File

include

mstatic.h

00001
00002 #ifndef _MGUI_NCSCTRL_STATIC_H
00003 #define _MGUI_NCSCTRL_STATIC_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif  /* __cplusplus */
00008
00014 #include "mwidget.h"
00015
00021 #define NCSCTRL_STATIC   NCSCLASSNAME("static")
00022
00023 typedef struct _mStatic mStatic;
00024 typedef struct _mStaticClass mStaticClass;
00025 typedef struct _mStaticRenderer mStaticRenderer;
00026
00027 /* define mStatic */
00028 #define mStaticHeader(clsName)  \
00029         mWidgetHeader(clsName) \
00030
00031
00037 struct _mStatic
00038 {
00039         mStaticHeader(mStatic)
00040 };
00041
00042 /* define mStaticClass */
00043 #define mStaticClassHeader(clsName, parentClass)    \
00044         mWidgetClassHeader(clsName, parentClass)        \
00045
00046
00051 struct _mStaticClass
00052 {
00053         mStaticClassHeader(mStatic, mWidget)
00054 };
00055
00056 /* define IRendererStatic */
00057 #define mStaticRendererHeader(clsName, parentClass) \
00058         mWidgetRendererHeader(clsName, parentClass)
00059
00064 struct  _mStaticRenderer {
00065         mStaticRendererHeader(mStatic, mWidget)
00066 };
00067
00072 MGNCS_EXPORT extern mStaticClass g_stmStaticCls;
00073
00074 /* define property of static */
00075
00081 enum mStaticProp {
00089         NCSP_STATIC_ALIGN = NCSP_WIDGET_MAX + 1,
00097         NCSP_STATIC_VALIGN,
00105         NCSP_STATIC_AUTOWRAP,
00106         NCSP_STATIC_MAX
00107 };
00108
00114 #define NCSS_STATIC_PREFIX  (0x1<<(NCSS_WIDGET_SHIFT))
00115
00120 #define NCSS_STATIC_SHIFT  (NCSS_WIDGET_SHIFT + 1)
00121
00126 enum enumStaticNotify {
00127         NCSN_STATIC_MAX = NCSN_WIDGET_MAX + 1
00128 };
00129
00133 #ifdef __cplusplus
00134 }
00135 #endif  /* __cplusplus */
00136
00137 #endif /* _MGUI_NCSCTRL_STATIC_H */
00138
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mstaticpiece.h Source File

include » pieces

mstaticpiece.h

00001 #ifndef _MGNCS_STATICPIECE_H
00002 #define _MGNCS_STATICPIECE_H
00003
00004 #ifdef __cplusplus
00005 extern "C" {
00006 #endif
00007
00008 typedef struct _mStaticPieceClass mStaticPieceClass;
00009 typedef struct _mStaticPiece mStaticPiece;
00010
00011 #define mStaticPieceClassHeader(clss, superCls) \
00012         mHotPieceClassHeader(clss, superCls)
00013
00014 struct _mStaticPieceClass
00015 {
00016         mStaticPieceClassHeader(mStaticPiece, mHotPiece)
00017 };
00018
00019 MGNCS_EXPORT extern mStaticPieceClass g_stmStaticPieceCls;
00020
00021 #define mStaticPieceHeader(clss) \
00022         mHotPieceHeader(clss) \
00023         int left:16; \
00024         int top:16; \
00025         int right:16; \
00026         int bottom:16;
00027
00028 struct _mStaticPiece
00029 {
00030         mStaticPieceHeader(mStaticPiece)
00031 };
00032
00033 #define SetStaticPieceRect(self, prc) do{ \
00034         (self)->left = (short)((prc->left)&0xFFFF); \
00035         (self)->top = (short)((prc->top)&0xFFFF); \
00036         (self)->right = (short)((prc->right)&0xFFFF); \
00037         (self)->bottom = (short)((prc->bottom)&0xFFFF); \
00038 }while(0)
00039
00040
00041 #ifdef __cplusplus
00042 }
00043 #endif
00044
00045 #endif
00046
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mtextedit.h Source File

include

mtextedit.h

Go to the documentation of this file.
00001
00028 #ifndef _MGUI_TEXT_EDIT_H
00029 #define _MGUI_TEXT_EDIT_H
00030
00031 #if defined(_MGNCS_TEXTEDITOR) || (defined(_MGCTRL_TEXTEDIT) && defined(_MGCTRL_TEXTEDIT_USE_NEW_IMPL))
00032
00033 #ifdef __cplusplus
00034 extern "C" {
00035 #endif
00036
00037 /* enable ES_TITLE stle of TEXTEDIT control */
00038 #define _MGHAVE_TEXTEDITTITLE 1
00039
00040 DECLARE_OBJECT(mTextBuffer)
00041 DECLARE_OBJECT(mTextIterator)
00042 DECLARE_OBJECT(mTextLayout)
00043 DECLARE_OBJECT(mTextLayoutNode)
00044 DECLARE_OBJECT(mTextRender)
00045
00047 // mTextBuffer
00048 typedef struct _TextBufferObserverNode {
00049         ITextBufferObserver* observer;
00050         struct _TextBufferObserverNode* next;
00051 }mTextBufferObserverNode;
00052
00053 #define mTextBufferHeader(Clss)  \
00054         mObjectHeader(Clss)     \
00055         INTERFACE(ITextBuffer) \
00056         char * buffer;  \
00057         int max_size; \
00058         int char_len; \
00059         mTextBufferObserverNode* observers;
00060
00061 #define mTextBufferClassHeader(Clss, Super) \
00062         mObjectClassHeader(Clss, Super)  \
00063         ITextBufferHeader(ITextBuffer, Clss)
00064
00065 //mTextBuffer_construct(const char* str = NULL, const char* str_len = 0)
00066
00067 DEFINE_OBJECT(mTextBuffer, mObject)
00068
00069
00070 // mTextIterator
00071 #define mTextIteratorHeader(Clss)  \
00072         mObjectHeader(Clss)           \
00073         INTERFACE(ITextIterator) \
00074         mTextBuffer* buffer;            \
00075         int index;
00076
00077 #define mTextIteratorClassHeader(Clss, Super) \
00078         mObjectClassHeader(Clss, Super)          \
00079         ITextIteratorHeader(ITextIterator, Clss)
00080
00081 //mTextIterator_construct(mTextBuffer*, int index)
00082
00083 DEFINE_OBJECT(mTextIterator, mObject)
00084
00085
00086 // mTextLayout
00087 #define mTextLayoutHeader(Clss)   \
00088         mCommBTreeHeader(Clss)        \
00089         INTERFACE(ITextLayout)       \
00090         ITextBuffer * text_buffer;   \
00091         int cursor;                  \
00092         int cursor_x, cursor_y;      \
00093         int cursor_height;           \
00094         int text_cursor;             \
00095         int sel_begin;               \
00096         int sel_begin_x, sel_begin_y;\
00097         int sel_begin_height;        \
00098         int text_sel_begin;          \
00099         ITextLayoutContext* context; \
00100     PCLIPRGN  dirty_area;        \
00101     int old_height, new_height; //height changed include
00102
00103 #define mTextLayoutClassHeader(Clss, Super) \
00104         mCommBTreeClassHeader(Clss, Super)      \
00105         ITextLayoutHeader(ITextLayout, Clss)
00106
00107 DEFINE_OBJECT(mTextLayout, mCommBTree)
00108
00109 //mTextLayoutNode
00110
00111 #define mTextLayoutNodeHeader(Clss)  \
00112         mCommBTreeNodeHeader(Clss)       \
00113         int str_count;         \
00114         int text_count;        \
00115         int width, height;
00116
00117 #define mTextLayoutNodeClassHeader(Clss, Super)  \
00118         mCommBTreeNodeClassHeader(Clss, Super)
00119
00120 DEFINE_OBJECT(mTextLayoutNode,mCommBTreeNode)
00121
00122
00123 //mTextRender
00124
00125 #define  mTextRenderHeader(Clss)    \
00126         mObjectHeader(Clss)            \
00127         INTERFACE(ITextRender)
00128
00129 #define mTextRenderClassHeader(Clss, Super)  \
00130         mObjectClassHeader(Clss, Super)         \
00131         ITextRenderHeader(ITextRender, Clss)
00132
00133 DEFINE_OBJECT(mTextRender,mObject)
00134
00135 enum {
00136         NCS_TXTRDR_TEXT = 0
00137 };
00138
00139 ITextRender* GetTextRender(int type);
00140
00141 /* mTextEditor object*/
00142 DECLARE_OBJECT(mTextEditor)
00143
00144
00149 #ifndef __MINIGUI_LIB__
00150
00154 #define NCSCTRL_TEXTEDITOR NCSCLASSNAME("texteditor")
00155 #endif
00156
00157 /* define the flag of TextEditor */
00158 #define NCS_TEF_REPLACE_MODE   0x010000
00159 #define NCS_TEF_HAS_PAINTED    0x020000
00160 #define mTextEditor_isReplaceMode(self)  \
00161                 ((self)->flags&NCS_TEF_REPLACE_MODE)
00162 #define mTextEditor_hasPainted(self)  \
00163                 ((self)->flags&NCS_TEF_HAS_PAINTED)
00164
00165
00166 #ifdef _MGHAVE_TEXTEDITTITLE
00167 #define TITLE_HEADER   \
00168         int title_idx, title_text_idx; \
00169         int title_x, title_y, title_last_height; \
00170         int title_paracount; \
00171         int title_last_para_text_index; \
00172         int title_linecount; \
00173         int title_last_line_text_index;
00174
00175 #define TITLE_CLASS_HEADER(Clss) \
00176         void (*setTitle)(Clss*, const char* buff, int len); \
00177         int  (*getTitle)(Clss*, char* buff, int max);
00178
00179
00180 #else
00181 #define TITLE_HEADER
00182 #define TITLE_CLASS_HEADER(Clss)
00183 #endif
00184
00185 //mTextEditor_construct(HWND hwnd)
00214 #define mTextEditorHeader(Clss)      \
00215     mWidgetHeader(Clss)             \
00216     INTERFACE(ITextLayoutContext)   \
00217     mTextBuffer  *textBuffer;        \
00218     mTextLayout  *textLayout;        \
00219         int         visWidth, visHeight;\
00220         int         offX, offY;         \
00221     int         hardLimit;          \
00222     unsigned int flags;             \
00223         int         caretWidth;         \
00224         int         caretHeight;        \
00225     unsigned short scrollBarMode;   \
00226     unsigned int scrollHStep;       \
00227     unsigned int scrollVStep;       \
00228     RECT         margins;           \
00229     int  oldOffX, oldOffY;          \
00230     TITLE_HEADER
00231
00232
00318 #define mTextEditorClassHeader(Clss, Super)  \
00319         mWidgetClassHeader(Clss, Super)     \
00320         ITextLayoutContextHeader(ITextLayoutContext, Clss)          \
00321         int (*onChar)(Clss*, int asciiCode, DWORD keyFlags);        \
00322         BOOL (*onFontChanged)(Clss*);                               \
00323         int (*getInvalidBkgnd)(Clss*, RECT *prc);                   \
00324         int (*onLButtonDBClk)(Clss*, int x, int y, DWORD keyFlags); \
00325         void (*onCSizeChanged)(Clss*, int cliWidth, int cliHeight); \
00326         void (*onSetFocus)(Clss*, HWND oldActiveWnd, int lParam);   \
00327         void (*onKillFocus)(Clss*, HWND newActiveWnd, int lParam);  \
00328         void (*onHScroll)(Clss*, int code, int mouseX);             \
00329         void (*onVScroll)(Clss*, int code, int mouseY);             \
00330         \
00331         int (*getParaText)(Clss*, int index, int start, int len, char* buffer);       \
00332         int (*getLineText)(Clss*, int index, int start, int len, char* buffer);       \
00333         int (*getParaLength)(Clss*, int index, int *startPos);      \
00334         int (*getParaLengthInMChar)(Clss*, int paraNo, int *startPos);                \
00335         int (*getLineLength)(Clss*, int lineNo, int *startPos, BOOL bMChar);          \
00336         int (*getParaNum)(Clss*);                                   \
00337         int (*setText)(Clss*, const char* text);                    \
00338         int (*insertText)(Clss*, const char* text, int len);        \
00339         int (*getText)(Clss*, char* text, int len);                 \
00340         int (*getTextLen)(Clss*);                                   \
00341         BOOL (*enableCaret)(Clss*, BOOL enable);                    \
00342         int (*setCaretPosByPara)(Clss*, unsigned int paraIdx, unsigned int offChar,   \
00343                 BOOL isSel);                                        \
00344         int (*getCaretPosByPara)(Clss*, int *paraIdx, int *offChar, \
00345                 int *height, BOOL isSel);                           \
00346         int (*setCaretPosByLine)(Clss*, unsigned int lineIdx, unsigned int offChar,   \
00347                 BOOL isSel);                                        \
00348         int (*getCaretPosByLine)(Clss*, int *lineIdx, int *offChar, \
00349                 int *height, BOOL isSel);                           \
00350         int (*getLineCount)(Clss*);                                 \
00351         void (*selectAll)(Clss*);                                   \
00352         int (*setSel)(Clss*, unsigned int startParaIdx, unsigned int startOffChar,    \
00353                 unsigned int endParaIdx, unsigned int endOffChar);  \
00354         int (*getSel)(Clss*, char *buffer, int len);                \
00355         BOOL (*needLineDecorative)(Clss*);                          \
00356         void (*lineDecorative)(Clss*, int x, int y, int w, int h,   \
00357                 int lineNo, HDC hdc);                               \
00358         TITLE_CLASS_HEADER(Clss)
00359
00360 #ifndef __MINIGUI_LIB__
00361
00366 #define NCSS_TE_READONLY  (1<<NCSS_WIDGET_SHIFT)
00367
00372 #define NCSS_TE_UPPERCASE (2<<NCSS_WIDGET_SHIFT)
00373
00378 #define NCSS_TE_LOWERCASE (4<<NCSS_WIDGET_SHIFT)
00379
00384 #define NCSS_TE_NOHIDESEL (8<<NCSS_WIDGET_SHIFT)
00385
00390 #define NCSS_TE_AUTOWRAP  (0x10<<NCSS_WIDGET_SHIFT)
00391
00396 #define NCSS_TE_BASELINE  (0x20<<NCSS_WIDGET_SHIFT)
00397
00402 #define NCSS_TE_OWNERBKGND (0x40<<NCSS_WIDGET_SHIFT)
00403
00404 /*
00405  * \def NCSS_TE_TITLE
00406  * \brief make the texteditor has title
00407  */
00408 #define NCSS_TE_TITLE  (0x80<<NCSS_WIDGET_SHIFT)
00409
00410 /*
00411  * \def NCSS_TE_AUTOVSCROLL
00412  * \brief make the texteditor has a auto vert scrollbar
00413  *
00414  * \note: NCSS_TE_AUTOVSCROLL | WS_VSCROLL == AUTO
00415  * !(dwStyle & NCSS_TE_AUTOVSCROLL) && (dwStyle & WS_VSCROLL)  == Always
00416  * !(dwStyle & (NCSS_TE_AUTOVSCROLL | WS_VSCROLL)) == Nerver
00417  */
00418 #define NCSS_TE_AUTOVSCROLL (0x100<<NCSS_WIDGET_SHIFT)
00419
00420 /*
00421  * \def NCSS_TE_AUTOHSCROLL
00422  * \brief make the texteditor has the auto horz scrollbar
00423  *
00424  * \note: NCSS_TE_AUTOHSCROLL | WS_HSCROLL == AUTO
00425  * !(dwStyle & NCSS_TE_AUTOHSCROLL) && (dwStyle & WS_HSCROLL)  == Always
00426  * !(dwStyle & (NCSS_TE_AUTOHSCROLL | WS_HSCROLL)) == Nerver
00427  */
00428 #define NCSS_TE_AUTOHSCROLL (0x200<<NCSS_WIDGET_SHIFT)
00429
00430 #define NCSS_TE_SHIFT  (NCSS_WIDGET_SHIFT + 10)
00431
00432 #endif
00433
00438  enum ncsTEScrollMode
00439  {
00443     NCS_TEF_SCROLLBAR_NEVER = 0,
00444
00448     NCS_TEF_SCROLLBAR_AUTO,
00449
00453     NCS_TEF_SCROLLBAR_ALWAYS,
00454 };
00455
00460 enum mTextEditorProp
00461 {
00465     NCSP_TE_READONLY = NCSP_WIDGET_MAX + 1,
00466
00470     NCSP_TE_SCROLL_MODE,
00471
00475     NCSP_TE_SCROLL_HSTEP,
00476
00480     NCSP_TE_SCROLL_VSTEP,
00481
00485         NCSP_TE_TEXTLIMIT,
00486
00490     NCSP_TE_LINECOUNT,
00491
00495     NCSP_TE_PARAGRAPHCOUNT,
00496
00500         NCSP_TE_MARGINRECT,
00501
00505     NCSP_TE_MAX,
00506 };
00507 #define NCSP_TE_NUMOFPARAGRAPHS NCSP_TE_PARAGRAPHCOUNT
00508
00509 #ifndef __MINIGUI_LIB__
00510
00514 enum mTextEditorNotify
00515 {
00519         NCSN_TE_CONTENTCHANGED = NCSN_WIDGET_MAX + 1,
00520
00524         NCSN_TE_SETFOCUS,
00525
00529         NCSN_TE_KILLFOCUS,
00530
00534         NCSN_TE_MAXTEXT,
00535
00539         NCSN_TE_CHANGE,
00540
00545         NCSN_TE_UPDATE,
00546
00550         NCSN_TE_SELCHANGED,
00551
00555         NCSN_TE_MAX
00556 };
00557
00558 typedef struct _mTextEditorRenderer mTextEditorRenderer;
00559 #endif
00560
00561
00562 DEFINE_OBJECT(mTextEditor, mWidget)
00563
00564 #ifdef __MINIGUI_LIB__
00565 void TextEditorDrawLinesDecorative(mTextEditor * self, HDC hdc, int x, int y, int w, int h);
00566 #define mTextEditor_drawLinesDecorative TextEditorDrawLinesDecorative
00567 #else
00568 void mTextEditor_drawLinesDecorative(mTextEditor * self, HDC hdc, int x, int y, int w, int h);
00569 #endif
00570
00572 #ifdef __cplusplus
00573 }
00574 #endif
00575
00576 #endif /*_MGNCS_TEXTEDITOR*/
00577
00578 #endif
00579
00580
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mtexteditbase.h Source File

include

mtexteditbase.h

00001 /*
00002 ** $Id: mtexteditbase.h 13589 2010-10-29 08:50:13Z wanzheng $
00003 **
00004 ** texteditbase.h: base header for the new text edit module.
00005 **
00006 ** Copyright (C) 2010 Feynman Software.
00007 **
00008 ** Create date: 2010/03/10
00009 */
00010
00011 #ifndef TEXTEDITBASE_H
00012 #define TEXTEDITBASE_H
00013
00014 #ifdef __cplusplus
00015 extern "C" {
00016 #endif
00017
00018 DECLARE_INTERFACE(ITextBufferObserver)
00019 DECLARE_INTERFACE(ITextIterator)
00020 DECLARE_INTERFACE(ITextBuffer)
00021 DECLARE_INTERFACE(ITextRender)
00022 DECLARE_INTERFACE(ITextLayoutContext)
00023 DECLARE_INTERFACE(ITextLayout)
00024
00025 //define the interface ITextBufferObserver
00026 #define ITextBufferObserverHeader(Interface,ClassImpl)  \
00027         IInterfaceHeader(Interface, ClassImpl)              \
00028         void (*onTextChanged)(ClassImpl*, int changedBegin, int delCount, int insertCount);
00029
00030 DEFINE_INTERFACE(ITextBufferObserver)
00031
00032
00033
00034 // ITextBuffer
00035 #define ITextBufferHeader(Interface, ClassImpl) \
00036         IInterfaceHeader(Interface, ClassImpl)      \
00037         /*replace */ \
00038         int (*replace)(ClassImpl *self,             \
00039                         int at, int count,                  \
00040                         const char* str,                    \
00041                         int str_count/*=-1*/);              \
00042         int (*getText)(ClassImpl* self,             \
00043                         int at /*=NULL*/,                   \
00044                         char* str_buff,                     \
00045                         int str_count);                     \
00046         int (*getCount)(ClassImpl* self);           \
00047         ITextIterator* (*getAt)(ClassImpl* self,    \
00048                         int charIndex);                     \
00049         BOOL (*addObserver)(ClassImpl*, ITextBufferObserver* observer);     \
00050         BOOL (*removeObserver)(ClassImpl*, ITextBufferObserver* observer);  \
00051         int (*find)(ClassImpl*self, int start, const char* str, int str_count); \
00052         int (*setCase)(ClassImpl *self, int start, int len, BOOL bupper);
00053
00054 DEFINE_INTERFACE(ITextBuffer)
00055
00056
00057 // ITextIterator
00058 #define ITextIteratorHeader(Interface, ClassImpl)           \
00059         IInterfaceHeader(Interface, ClassImpl)                  \
00060         void (*nextChar)(ClassImpl* self);                      \
00061         void (*prevChar)(ClassImpl* self);                      \
00062         /*get current index of charactor*/                      \
00063         int  (*index)(ClassImpl* self);                         \
00064         /*reset the iterator*/                                  \
00065         int  (*reset)(ClassImpl* self, int charIndex);          \
00066         /*is end*/ \
00067         BOOL (*isEnd)(ClassImpl* self);                         \
00068         /*is head*/ \
00069         BOOL (*isHead)(ClassImpl* self);                        \
00070         /*get the charactor as much as more*/                   \
00071         const char* (*getMore)(ClassImpl*,int *pTextLen,        \
00072         int *pVisibleTextLen, BOOL bAutoSkip/*=TRUE*/);     \
00073         /*reference one*/  \
00074         ITextIterator* (*reference)(ClassImpl* self);           \
00075         /*comapre */ \
00076         int (*diff)(ClassImpl*, const ITextIterator* another);  \
00077         /*is in a range*/ \
00078         int (*inRange)(ClassImpl*, const ITextIterator* left,   \
00079             const ITextIterator* right);                    \
00080         /*release me*/ \
00081         void (*releaseIterator)(ClassImpl* self);                       \
00082         /*text Render*/ \
00083         ITextRender* (*getTextRender)(ClassImpl* self);         \
00084         /*getCharType*/ \
00085         int (*getCharType)(ClassImpl* self, int offset);
00086
00087 enum {
00088         TI_OUTOFRANGE    = -1,
00089         TI_VISIBILE_CHAR = 0,   /*visible char*/
00090         TI_LINERETURN,           /*line return*/
00091     TI_EOF                  /* End OF File */
00092 };
00093
00094
00095 DEFINE_INTERFACE(ITextIterator)
00096
00097 //define the return value of inRange
00098 enum {
00099         TXTITER_RANGE_INVALID    = -1,
00100         TXTITER_RANGE_IN         = 0,   // left  < self  < right
00101         TXTITER_RANGE_LEFTEDGE   ,      // left  == self
00102         TXTITER_RANGE_RIGHTEDGE  ,      // right == self
00103         TXTITER_RANGE_LEFTOUT    ,
00104         TXTITER_RANGE_RIGHTOUT
00105 };
00106
00107
00109 // ITextRender
00110 #define ITextRenderHeader(Interface, ClassImpl)         \
00111         IInterfaceHeader(Interface, ClassImpl)              \
00112         int  (*calc)(ClassImpl* self, HDC hdc,              \
00113             ITextIterator* begin,                       \
00114                         int str_count, int* ptext_count,            \
00115                         const RECT* maxBound, RECT *bounds);        \
00116         int (*draw)(ClassImpl* self, HDC hdc, int x, int y, \
00117             ITextIterator* begin, int str_count);       \
00118         int (*getTextByteLen)(ClassImpl* self, HDC hdc,     \
00119         ITextIterator* it, /*in out*/int *ptext_index); \
00120         int (*getTextCount)(ClassImpl* self, HDC hdc,       \
00121             ITextIterator* it, /*in out*/int* pstr_len);\
00122         int (*getCaretSize)(ClassImpl* self, HDC hdc,       \
00123                         ITextIterator* it, int *pWidth, int *pHeight);
00124
00125 DEFINE_INTERFACE(ITextRender)
00126
00127
00128
00129 //Interface for ITextLayout
00130
00131 #define ITextLayoutContextHeader(Interface, ClassImpl)  \
00132         IInterfaceHeader(Interface, ClassImpl)              \
00133         int (*getMetrics)(ClassImpl*,int type);             \
00134         void (*setupDC)(ClassImpl*, HDC hdc);               \
00135         void (*beginSelection)(ClassImpl*,HDC hdc);         \
00136         void (*endSelection)(ClassImpl*, HDC hdc);          \
00137         HDC  (*getDC)(ClassImpl*);                          \
00138     void (*contentPosToDCPos)(ClassImpl*, HDC hdc,      \
00139             int *px, int *py);                          \
00140         void (*releaseDC)(ClassImpl*, HDC hdc);             \
00141     void (*updateCaret)(ClassImpl*);                    \
00142         void (*update)(ClassImpl*, BOOL);
00143
00144 enum {
00145         TEXTMETRICS_MAXWIDTH,
00146         TEXTMETRICS_MAXHEIGHT,
00147         TEXTMETRICS_LINESPACE,
00148     TEXTMETRICS_DEFLINEHEIGHT
00149 };
00150
00151 DEFINE_INTERFACE(ITextLayoutContext)
00153 //ITextLayout
00154 typedef void (*CB_LINE_PROC)(mObject* self, int x, int y, int width, int height, int lineNo, void* user_param);
00155 typedef BOOL (*CB_NODE_PROC)(mObject* self, mObject* cur_node, void* user_param);
00156
00157 #define ITextLayoutHeader(Interface, ClassImpl)         \
00158         ITextBufferObserverHeader(Interface, ClassImpl)     \
00159         /*get the text iterator by pos*/ \
00160         int (*getCharIndex)(ClassImpl*, int *px, int *py,   \
00161         int *plineHeight/*=NULL*/, int *ptext_index);   \
00162         /*get the pos by text iterator */ \
00163         int (*getCharPos)(ClassImpl*, int index, int *px,   \
00164             int *py, int *plineHeight, BOOL bAsText);   \
00165         /*get the size of the text */ \
00166         BOOL (*getTextBoundSize)(ClassImpl* self, int *cx, int *cy);                \
00167         BOOL (*setCursor)(ClassImpl* self, int index, BOOL isSel);                  \
00168         int (*setCursorPos)(ClassImpl* self, int x, int y, BOOL isSel);             \
00169         int (*getCursor)(ClassImpl*, int *px, int *py, int *cursor_h, BOOL isSel);  \
00170         void (*draw)(ClassImpl* self, HDC hdc, int x, int y, int width, int height);\
00171         int (*getLineHeight)(ClassImpl* self, int index);                           \
00172     void (*reset)(ClassImpl *self);                                             \
00173         int (*textCount2Len)(ClassImpl*, int text_index, int text_count, int *plen);\
00174         int (*textLen2Count)(ClassImpl*, int str_index, int str_len, int*text_count,\
00175             int *poutstr_index, int *poutstr_count);                            \
00176     void (*foreachLine)(ClassImpl*, int x, int y, int maxWidth, int maxHeight,  \
00177             CB_LINE_PROC proc, mObject* proc_owner, void* user_param);          \
00178     void (*travelNode)(ClassImpl*, CB_NODE_PROC proc, mObject* proc_owner, void* user_param); \
00179     PLOGFONT (*getReleatedFont)(ClassImpl*, int idx, BOOL isText);              \
00180     int (*getParaByIndex)(ClassImpl* self, int index, int *pcol, BOOL bText);   \
00181     int (*getLineByIndex)(ClassImpl* self, int index, int* pcol, BOOL bText);   \
00182     int (*getIndexByPara)(ClassImpl* self, int paraNo, int col, BOOL* outOfRange, BOOL bText); \
00183     int (*getIndexByLine)(ClassImpl* self, int lineIdx, int col, BOOL* outOfRange, BOOL bText);
00184
00185 DEFINE_INTERFACE(ITextLayout)
00186
00187 #ifdef __cplusplus
00188 }
00189 #endif
00190
00191 #endif
00192
00193
00194
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mthumbboxpiece.h Source File

include » pieces

mthumbboxpiece.h

00001
00002 #ifndef _MGUI_NCSCTRL_THUMBBOXPIECE_H
00003 #define _MGUI_NCSCTRL_THUMBBOXPIECE_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif
00008
00009 typedef struct _mThumbBoxPieceClass mThumbBoxPieceClass;
00010 typedef struct _mThumbBoxPiece mThumbBoxPiece;
00011
00012 #define mThumbBoxPieceClassHeader(clss, superCls) \
00013         mRenderablePieceClassHeader(clss, superCls)
00014
00015 struct _mThumbBoxPieceClass
00016 {
00017         mThumbBoxPieceClassHeader(mThumbBoxPiece, mRenderablePiece)
00018 };
00019
00020 MGNCS_EXPORT extern mThumbBoxPieceClass g_stmThumbBoxPieceCls;
00021
00022 #define mThumbBoxPieceHeader(clss) \
00023         mRenderablePieceHeader(clss)
00024
00025 struct _mThumbBoxPiece
00026 {
00027         mThumbBoxPieceHeader(mThumbBoxPiece)
00028 };
00029
00030
00031 #ifdef __cplusplus
00032 }
00033 #endif
00034
00035 #endif
00036
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mtimer.h Source File

include

mtimer.h

Go to the documentation of this file.
00001
00016 #ifndef _MGUI_NCSCTRL_TIMER_H
00017 #define _MGUI_NCSCTRL_TIMER_H
00018
00019 #ifdef __cplusplus
00020 extern "C"{
00021 #endif
00022
00032 #define NCSCTRL_TIMER  NCSCLASSNAME("timer")
00033
00034 typedef struct _mTimerClass mTimerClass;
00035 typedef struct _mTimer mTimer;
00036
00037 #define mTimerClassHeader(clss, superCls) \
00038         mInvsbCompClassHeader(clss, superCls) \
00039         BOOL (*start)(clss *self); \
00040         void (*stop)(clss *self);  \
00041         HWND (*getParent)(clss *self);
00042
00061 struct _mTimerClass {
00062         mTimerClassHeader(mTimer, mInvsbComp)
00063 };
00064
00069 MGNCS_EXPORT extern mTimerClass g_stmTimerCls; //Class(mTimer);
00070
00071 #define mTimerHeader(clss) \
00072         mInvsbCompHeader(clss) \
00073         DWORD interval;
00074
00083 struct _mTimer {
00084         mTimerHeader(mTimer)
00085 };
00086
00091 enum ncsTimerProp {
00092         NCSP_TIMER_INTERVAL = NCSP_IVCMPT_MAX + 1,
00093         NCSP_TIMER_MAX
00094 };
00112 typedef BOOL (*NCS_CB_ONTIMER)(mTimer* timer, DWORD total_count);
00113
00116 #ifdef __cplusplus
00117 }
00118 #endif
00119
00120 #endif
00121
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mtoolbar.h Source File

include

mtoolbar.h

00001
00002 #ifndef _MGUI_NCSCTRL_TLBAR_H
00003 #define _MGUI_NCSCTRL_TLBAR_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif  /* __cplusplus */
00008
00014 #include "mwidget.h"
00015
00021 #define NCSCTRL_TOOLBAR   NCSCLASSNAME("toolbar")
00022
00023 typedef struct _mToolBar mToolBar;
00024 typedef struct _mToolBarClass mToolBarClass;
00025 typedef struct _mToolBarRenderer mToolBarRenderer;
00026
00027 /* define mToolBar */
00028 #define mToolBarHeader(clsName)  \
00029         mWidgetHeader(clsName)
00030
00037 struct _mToolBar
00038 {
00039         mToolBarHeader(mToolBar)
00040 };
00041
00042 /* define mToolBarClass */
00043 #define mToolBarClassHeader(clsName, parentClass)    \
00044         mWidgetClassHeader(clsName, parentClass) \
00045         BOOL (*addItem)(clsName*, void *item, int type, int min_size, int max_size); \
00046         int  (*isItemChecked)(clsName *, int id); \
00047         int  (*checkItem)(clsName *, int id, int state);
00048
00082 struct _mToolBarClass
00083 {
00084         mToolBarClassHeader(mToolBar, mWidget)
00085 };
00086
00087 /* define IRendererToolBar */
00088 #define mToolBarRendererHeader(clsName, parentClass) \
00089         mWidgetRendererHeader(clsName, parentClass)
00090
00094 struct  _mToolBarRenderer {
00095         mToolBarRendererHeader(mToolBar, mWidget)
00096 };
00097
00102 MGNCS_EXPORT extern mToolBarClass g_stmToolBarCls;
00103
00104 /* define property of static */
00105
00111 enum mToolBarProp {
00112         NCSP_TLBAR_MAX = NCSP_WIDGET_MAX + 1,
00113 };
00114
00115
00120 #define NCSS_TLBAR_SHIFT  (NCSS_WIDGET_SHIFT + 1)
00121
00126 enum enumToolBarNotify {
00130         NCSN_TLBAR_ITEMCHAGED = NCSN_WIDGET_MAX + 1,
00131         NCSN_TLBAR_MAX
00132 };
00133
00137 #ifdef __cplusplus
00138 }
00139 #endif  /* __cplusplus */
00140
00141 #endif /* _MGUI_NCSCTRL_TLBAR_H */
00142
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mtoolbaritems.h Source File

include

mtoolbaritems.h

00001
00002 #ifndef MGNCS_TOOLBAR_ITEMS_H
00003 #define MGNCS_TOOLBAR_ITEMS_H
00004
00006
00010 typedef struct _mPushToolItemClass mPushToolItemClass;
00011 typedef struct _mPushToolItem mPushToolItem;
00012
00013 typedef struct mPushToolItemCreateInfo{
00014         mToolImage * toolImg;
00015         const char * str;
00016         UINT         flags;
00017 }mPushToolItemCreateInfo;
00018
00019 #define mPushToolItemClassHeader(clss, clssSuper) \
00020         mAbstractButtonPieceClassHeader(clss, clssSuper) \
00021         mHotPiece * (*createContent)(clss*, mPushToolItemCreateInfo* create_info); \
00022         BOOL (*setCheck)(clss *, int state); \
00023         int  (*getCheck)(clss *);
00024
00025 struct _mPushToolItemClass
00026 {
00027         mPushToolItemClassHeader(mPushToolItem, mAbstractButtonPiece)
00028 };
00029
00030 #define mPushToolItemHeader(clss) \
00031         mAbstractButtonPieceHeader(clss)
00032
00033 struct _mPushToolItem
00034 {
00035         mPushToolItemHeader(mPushToolItem)
00036 };
00037
00038 MGNCS_EXPORT extern mPushToolItemClass g_stmPushToolItemCls;
00039
00040
00044 typedef struct _mMenuToolItemClass mMenuToolItemClass;
00045 typedef struct _mMenuToolItem mMenuToolItem;
00046
00047
00048 #define mMenuToolItemClassHeader(clss, clssSuper) \
00049         mPushToolItemClassHeader(clss, clssSuper) \
00050         BOOL (*showMenu)(clss *, mWidget *owner);
00051
00052 struct _mMenuToolItemClass
00053 {
00054         mMenuToolItemClassHeader(mMenuToolItem, mPushToolItem)
00055 };
00056
00057 #define mMenuToolItemHeader(clss) \
00058         mPushToolItemHeader(clss) \
00059         mPopMenuMgr * popmenu;
00060
00061 struct _mMenuToolItem
00062 {
00063         mMenuToolItemHeader(mMenuToolItem)
00064 };
00065
00066 MGNCS_EXPORT extern mMenuToolItemClass g_stmMenuToolItemCls;
00067
00068
00069
00070 #endif
00071
00072
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mtoolimgpiece.h Source File

include » pieces

mtoolimgpiece.h

00001 #ifndef _MGNCS_TOOLIMAGEPIECE_H
00002 #define _MGNCS_TOOLIMAGEPIECE_H
00003
00004 #ifdef __cplusplus
00005 extern "C" {
00006 #endif
00007
00008 #include "../mpopmenumgr.h"
00009 #include "../mtoolitem.h"
00010
00011 typedef struct _mToolImagePieceClass mToolImagePieceClass;
00012 typedef struct _mToolImagePiece mToolImagePiece;
00013
00014 #define mToolImagePieceClassHeader(clss, superCls) \
00015         mStaticPieceClassHeader(clss, superCls)
00016
00017 struct _mToolImagePieceClass
00018 {
00019         mToolImagePieceClassHeader(mToolImagePiece, mStaticPiece)
00020 };
00021
00022 MGNCS_EXPORT extern mToolImagePieceClass g_stmToolImagePieceCls;
00023
00024 #define mToolImagePieceHeader(clss) \
00025         mStaticPieceHeader(clss) \
00026         mToolImage * toolImg;
00027
00028 struct _mToolImagePiece
00029 {
00030         mToolImagePieceHeader(mToolImagePiece)
00031 };
00032
00033
00034 enum mToolImagePieceProps {
00035         NCSP_TOOLIMAGEPIECE_TOOLIMAGE = TOOLIMAGEPIECE_PROP_BEGIN
00036 };
00037
00038
00039
00040 #ifdef __cplusplus
00041 }
00042 #endif
00043
00044 #endif
00045
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mtoolitem.h Source File

include

mtoolitem.h

00001 /*
00002  * mtoolitem.h
00003  *
00004  *  Created on: 2009-6-19
00005  *      Author: dongjunjie
00006  */
00007
00008 #ifndef _MG_MINIMTOOLITEM_H_
00009 #define _MG_MINIMTOOLITEM_H_
00010
00011 #ifdef __cplusplus
00012 extern "C"{
00013 #endif
00014
00025 enum mToolItemType{
00026         NCS_UNKNOWNTOOLITEM = 0,
00027         NCS_PUSHTOOLITEM,
00028         NCS_MENUTOOLITEM,
00029         NCS_WIDGETTOOLITEM,
00030         NCS_SEPARATORTOOLITEM
00031 };
00032
00033 typedef struct _mToolImage{
00034         PBITMAP pbmp;
00035         unsigned char flags;
00036         unsigned char cell_count;
00037         unsigned short ref;
00038 }mToolImage;
00039
00040 #define TOOLIMGF_UNLOAD   0x01
00041 #define TOOLIMGF_VERTCELL 0x02 //the image of cell a vert arranged
00042
00053 MGNCS_EXPORT mToolImage * ncsNewToolImage(PBITMAP pbmp, int cell_count, BOOL autoUnload, BOOL bVert);
00064 MGNCS_EXPORT mToolImage * ncsNewToolImageFromFile(const char *fileName, int cell_count, BOOL autoUnload, BOOL bVert);
00070 MGNCS_EXPORT void ncsFreeToolImage(mToolImage *mti);
00071 //BOOL ncsGetToolImageCell(mToolImage *mti, int idx, RECT *prc);
00081 MGNCS_EXPORT BOOL ncsDrawToolImageCell(mToolImage *mti, HDC hdc, int idx, const RECT *prc);
00082
00087 enum mToolItemEvent{
00091         NCSN_TOOLITEM_CLICKED = 1,
00095         NCSN_TOOLITEM_PUSHED,
00099         NCSN_TOOLITEM_SHOWMENU,
00103         NCSN_TOOLITEM_STATE_CHANGED
00104 };
00105
00110 #define NCS_TOOLITEM_FLAG_TEXT_LEFT  0x01
00111
00116 #define NCS_TOOLITEM_FLAG_TEXT_UP    NCS_TOOLITEM_FLAG_TEXT_LEFT
00117
00121 #define NCS_TOOLITEM_FLAG_VERT       0x02
00122
00123 #define NCS_TOOLITEM_LABEL_TEXT_LEFT 0x10
00124 #define NCS_TOOLITEM_LABEL_TEXT_RIGHT 0x20
00125 #define NCS_TOOLITEM_LABEL_TEXT_CENTER 0x40
00126
00127 #define NCS_TOOLITEM_LABEL_TEXT_TOP 0x80
00128 #define NCS_TOOLITEM_LABEL_TEXT_BOTTOM 0x100
00129 #define NCS_TOOLITEM_LABEL_TEXT_VCENTER 0x200
00130
00143 MGNCS_EXPORT void* ncsCreatePushToolItem(int id, mToolImage *img, const char* str, UINT flags);
00144
00145
00150 MGNCS_EXPORT BOOL ncsInitToolItems(void);
00151
00167 MGNCS_EXPORT void* ncsCreateMenuToolItem(int id, mToolImage *img, const char* str, UINT flags, mPopMenuMgr *menu);
00168
00173 #define NCS_TOOLITEM_UNCHECKED 0x00
00174
00178 #define NCS_TOOLITEM_CHECKED   0x01
00179
00195 MGNCS_EXPORT void* ncsCreateCheckToolItem(int id, mToolImage *img, const char* str, UINT flags, int state);
00211 MGNCS_EXPORT void* ncsCreateRadioToolItem(int id, mToolImage *img, const char* str, UINT flags);
00212
00221 MGNCS_EXPORT void* ncsCreateWidgetToolItem(mWidget* widget);
00222
00229 MGNCS_EXPORT void* ncsCreateSeparatorItem(void);
00230
00240 MGNCS_EXPORT int ncsGetToolItemType(void *toolitem);
00241
00249 MGNCS_EXPORT BOOL ncsIsPushToolItem(void *toolitem);
00257 MGNCS_EXPORT BOOL ncsIsMenuToolItem(void *toolitem);
00265 MGNCS_EXPORT BOOL ncsIsSeparatorToolItem(void *toolitem);
00273 MGNCS_EXPORT BOOL ncsIsWidgetToolItem(void *toolitem);
00274
00276
00283 MGNCS_EXPORT int ncsToolItem_getId(void *self);
00292 MGNCS_EXPORT int ncsToolItem_setId(void *self, int id);
00301 MGNCS_EXPORT BOOL ncsToolItem_setCheck(void *self, int check_state);
00309 MGNCS_EXPORT int ncsToolItem_getCheck(void *self);
00310
00320 MGNCS_EXPORT BOOL ncsToolItem_showMenu(void*self, mObject *owner);
00321
00322
00334 MGNCS_EXPORT mObject* ncsNewToolItem(int id, mObjectClass* _class, DWORD param);
00335
00336 #define NEWTOOLITEM(id, Object, param)  \
00337         (Object*)(ncsNewToolItem((id), (mObjectClass*)&Class(Object), (DWORD)(param)))
00338
00348 MGNCS_EXPORT void ncsFreeToolItem(mObject* obj);
00349
00350 #define FREETOOLITEM(obj)  \
00351         ncsFreeToolItem((mObject*)(obj))
00352
00355 #ifdef __cplusplus
00356  }
00357 #endif
00358
00359 #endif /* _MG_MINIMTOOLITEM_H_ */
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mtrackbar.h Source File

include

mtrackbar.h

Go to the documentation of this file.
00001
00019 #ifndef _MGUI_NCSCTRL_TRACKBAR_H
00020 #define _MGUI_NCSCTRL_TRACKBAR_H
00021
00022 #ifdef __cplusplus
00023 extern "C" {
00024 #endif  /* __cplusplus */
00025
00031 /*
00032  * \def NCSCTRL_TRACKBAR
00033  * \brief the name of TrackBar control
00034 */
00035 #define NCSCTRL_TRACKBAR   NCSCLASSNAME("trackbar")
00036
00037 typedef struct _mTrackBar            mTrackBar;
00038 typedef struct _mTrackBarClass       mTrackBarClass;
00039 typedef struct _mTrackBarRenderer    mTrackBarRenderer;
00040
00041 #define mTrackBarHeader(Class) \
00042     mSliderHeader(Class)
00043
00050 struct _mTrackBar
00051 {
00052         mTrackBarHeader(mTrackBar)
00053 };
00054
00055 #define mTrackBarClassHeader(clsName, parentClass) \
00056         mSliderClassHeader(clsName, parentClass)
00057
00064 struct _mTrackBarClass
00065 {
00066         mTrackBarClassHeader(mTrackBar, mSlider)
00067 };
00068
00075 MGNCS_EXPORT extern mTrackBarClass g_stmTrackBarCls;
00076
00077 #define mHTrackBar mTrackBar
00078 #define mHTrackBarClass mTrackBarClass
00079 #define g_stmHTrackBarCls  g_stmTrackBarCls
00080 #define mVTrackBar mTrackBar
00081 #define mVTrackBarClass mTrackBarClass
00082 #define g_stmVTrackBarCls  g_stmTrackBarCls
00083
00084
00085 #define mTrackBarRendererHeader(clsName, parentClass) \
00086         mSliderRendererHeader(clsName, parentClass)
00087
00094 struct _mTrackBarRenderer
00095 {
00096         mTrackBarRendererHeader(mTrackBar, mSlider)
00097 };
00098
00099 enum mTrackBarCalcArea {
00100         NCSTRACKBAR_AREA_TRICK = 0x10
00101 };
00102
00103
00108 #define NCSP_TRKBAR_MAXPOS              NCSP_SLIDER_MAXPOS
00109
00113 #define NCSP_TRKBAR_MINPOS              NCSP_SLIDER_MINPOS
00114
00118 #define NCSP_TRKBAR_CURPOS              NCSP_SLIDER_CURPOS
00119
00123 #define NCSP_TRKBAR_LINESTEP    NCSP_SLIDER_LINESTEP
00124
00128 #define NCSP_TRKBAR_PAGESTEP    NCSP_SLIDER_PAGESTEP
00129
00134 enum mTrackBarProp{
00136         NCSP_TRKBAR_THUMB_WIDTH = NCSP_SLIDER_MAX + 1,
00138         NCSP_TRKBAR_THUMB_HEIGHT,
00142         NCSP_TRKBAR_MAX
00143 };
00144
00160 #define NCSS_TRKBAR_HORIZONTAL NCSS_SLIDER_HORIZONTAL
00161
00166 #define NCSS_TRKBAR_VERTICAL   NCSS_SLIDER_VERTICAL
00167
00172 #define NCSS_TRKBAR_NOTICK     (0x0001L<<NCSS_SLIDER_SHIFT)
00173
00174 #define NCSS_TRKBAR_SHIFT      NCSS_SLIDER_SHIFT + 1
00175
00180 #define NCSN_TRKBAR_CHANGED    NCSN_SLIDER_CHANGED
00181
00186 #define NCSN_TRKBAR_REACHMAX   NCSN_SLIDER_REACHMAX
00187
00192 #define NCSN_TRKBAR_REACHMIN   NCSN_SLIDER_REACHMIN
00193
00198 //#define       NCSN_TRKBAR_STARTDRAG  NCSN_SLIDER_STARTDRAG
00199
00204 //#define       NCSN_TRKBAR_STOPDRAG   NCSN_SLIDER_STOPDRAG
00205
00206 #define NCSN_TRKBAR_MAX        NCSN_SLIDER_MAX
00207
00208
00209 #define HORZ_SLIDER_W           24
00210 #define HORZ_SLIDER_H           12
00211
00212 #define VERT_SLIDER_W           12
00213 #define VERT_SLIDER_H           24
00214
00215 #define VERT_TRACK_W            6
00216 #define HORZ_TRACK_H            6
00217
00218 #define LEN_TICK                4
00219 #define GAP_TICK_SLIDER         6
00220
00223 #ifdef __cplusplus
00224 }
00225 #endif  /* __cplusplus */
00226
00227 #endif /* _MGUI_NCSCTRL_TRACKBAR_H */
00228
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mtrackbarpiece.h Source File

include » pieces

mtrackbarpiece.h

00001
00002 #ifndef _MGUI_NCSCTRL_TRACKBARPIECE_H
00003 #define _MGUI_NCSCTRL_TRACKBARPIECE_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif
00008
00009 typedef struct _mTrackBarPieceClass mTrackBarPieceClass;
00010 typedef struct _mTrackBarPiece mTrackBarPiece;
00011
00012 #define mTrackBarPieceClassHeader(clss, superCls) \
00013         mRenderablePieceClassHeader(clss, superCls)
00014
00015 struct _mTrackBarPieceClass
00016 {
00017         mTrackBarPieceClassHeader(mTrackBarPiece, mRenderablePiece)
00018 };
00019
00020 MGNCS_EXPORT extern mTrackBarPieceClass g_stmTrackBarPieceCls;
00021
00022 #define mTrackBarPieceHeader(clss) \
00023         mRenderablePieceHeader(clss)
00024
00025 struct _mTrackBarPiece
00026 {
00027         mTrackBarPieceHeader(mTrackBarPiece)
00028 };
00029
00030
00031 #ifdef __cplusplus
00032 }
00033 #endif
00034
00035 #endif
00036
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mtype.h Source File

include

mtype.h

00001
00002 #ifndef MGNCS_TYPE_H
00003 #define MGNCS_TYPE_H
00004
00005 typedef void* HAUTOPOOL;
00006
00007 enum ncsBindingDataTYPE{
00008         NCS_BT_INT = 1,
00009         NCS_BT_STR,
00010         NCS_BT_CHAR,
00011     NCS_BT_NUMBER,
00012         NCS_BT_MAX
00013 };
00014
00015 #define SBPE_OK          0
00016 #define SBPE_READERROR   1 //psrc cannot read
00017 #define SBPE_WRITEERROR  2 //pdest cannot write
00018 #define SBPE_MISSMATCH   3 //type miss match
00019
00020 typedef void (*NCS_SET_VALUE)(void* self, DWORD dst_v);
00021 MGNCS_EXPORT int ncsTransType(DWORD value, int src_type, int dest_type, NCS_SET_VALUE set_value, void *self);
00022
00027 MGNCS_EXPORT int ncsTypeToInt(DWORD value, int src_type);
00028
00029 #define ncsStrToInt(str)  ncsTypeToInt((DWORD)(str), NCS_BT_STR)
00030 #define ncsCharToInt(ch)  (int)((char)(ch))
00031
00032 MGNCS_EXPORT int ncsTypeToChar(DWORD value, int scr_type);
00033
00034 static inline int ncsStrToChar(DWORD str) {
00035         if(str == 0)
00036                 return 0;
00037         return *((const char*)(str));
00038 }
00039
00040 #define ncsIntToChar(i) ((char)(i))
00041
00045 MGNCS_EXPORT char* ncsTypeToString(DWORD value, int src_type);
00046
00051 MGNCS_EXPORT HAUTOPOOL ncsCreateAutoPool(int size);
00052 MGNCS_EXPORT void ncsResetAutoPool(HAUTOPOOL hPool);
00053 MGNCS_EXPORT void ncsFreeAutoPool(HAUTOPOOL hPool);
00054
00055 MGNCS_EXPORT char* ncsTypeToAutoString(DWORD value, int src_type, HAUTOPOOL hAutoPool);
00056
00057 #define _BEGIN_AUTO_STR_EX(size)   { HAUTOPOOL __local_auto_pool__ = ncsCreateAutoPool(size);
00058 #define _BEGIN_AUTO_STR  _BEGIN_AUTO_STR_EX(-1)
00059
00060 #define _END_AUTO_STR   ncsFreeAutoPool(__local_auto_pool__); }
00061
00062 #define _RESET_AUTO_STR  ncsResetAutoPool(__local_auto_pool__);
00063
00064 #define _AUTO_STR(data,src_type) ((char*)ncsTypeToAutoString((data), (src_type), __local_auto_pool__))
00065
00066 #define _RET_AUTO_STR   do{ ncsFreeAutoPool(__local_auto_pool__); return; }while(0)
00067 #define _RETV_AUTO_STR(ret)  do { ncsFreeAutoPool(__local_auto_pool__); return (ret); }while(0)
00068
00069 #endif
00070
00071
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: muparrowpiece.h Source File

include » pieces

muparrowpiece.h

00001
00002 #ifndef _MGUI_NCSCTRL_UPARROWPIECE_H
00003 #define _MGUI_NCSCTRL_UPARROWPIECE_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif
00008
00009 typedef struct _mUpArrowPieceClass mUpArrowPieceClass;
00010 typedef struct _mUpArrowPiece mUpArrowPiece;
00011
00012 #define mUpArrowPieceClassHeader(clss, superCls) \
00013         mArrowPieceClassHeader(clss, superCls)
00014
00015 struct _mUpArrowPieceClass
00016 {
00017         mUpArrowPieceClassHeader(mUpArrowPiece, mArrowPiece)
00018 };
00019
00020 MGNCS_EXPORT extern mUpArrowPieceClass g_stmUpArrowPieceCls;
00021
00022 #define mUpArrowPieceHeader(clss) \
00023         mArrowPieceHeader(clss)
00024
00025 struct _mUpArrowPiece
00026 {
00027         mUpArrowPieceHeader(mUpArrowPiece)
00028 };
00029
00030
00031 #ifdef __cplusplus
00032 }
00033 #endif
00034
00035 #endif
00036
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mvboxlayoutpiece.h Source File

include » pieces

mvboxlayoutpiece.h

00001
00002 #ifndef _MGUI_NCSCTRL_VBOXLAYOUTPIECE_H
00003 #define _MGUI_NCSCTRL_VBOXLAYOUTPIECE_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif
00008
00009 typedef struct _mVBoxLayoutPieceClass mVBoxLayoutPieceClass;
00010 typedef struct _mVBoxLayoutPiece mVBoxLayoutPiece;
00011
00012 #define mVBoxLayoutPieceClassHeader(clss, superCls) \
00013         mBoxLayoutPieceClassHeader(clss, superCls)
00014
00015 struct _mVBoxLayoutPieceClass
00016 {
00017         mVBoxLayoutPieceClassHeader(mVBoxLayoutPiece, mBoxLayoutPiece)
00018 };
00019
00020 MGNCS_EXPORT extern mVBoxLayoutPieceClass g_stmVBoxLayoutPieceCls;
00021
00022 #define mVBoxLayoutPieceHeader(clss) \
00023         mBoxLayoutPieceHeader(clss)
00024
00025 struct _mVBoxLayoutPiece
00026 {
00027         mVBoxLayoutPieceHeader(mVBoxLayoutPiece)
00028 };
00029
00030
00031 #ifdef __cplusplus
00032 }
00033 #endif
00034
00035 #endif
00036
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mvspinboxpiece.h Source File

include » pieces

mvspinboxpiece.h

00001
00002 #ifndef _MGUI_NCSCTRL_VSPINNERPIECE_H
00003 #define _MGUI_NCSCTRL_VSPINNERPIECE_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif
00008
00009 typedef struct _mVSpinBoxPieceClass mVSpinBoxPieceClass;
00010 typedef struct _mVSpinBoxPiece mVSpinBoxPiece;
00011
00012 #define mVSpinBoxPieceClassHeader(clss, superCls) \
00013         mSpinBoxPieceClassHeader(clss, superCls)
00014
00015 struct _mVSpinBoxPieceClass
00016 {
00017         mVSpinBoxPieceClassHeader(mVSpinBoxPiece, mSpinBoxPiece)
00018 };
00019
00020 MGNCS_EXPORT extern mVSpinBoxPieceClass g_stmVSpinBoxPieceCls;
00021
00022 #define mVSpinBoxPieceHeader(clss) \
00023         mSpinBoxPieceHeader(clss)
00024
00025 struct _mVSpinBoxPiece
00026 {
00027         mVSpinBoxPieceHeader(mVSpinBoxPiece)
00028 };
00029
00030 #ifdef __cplusplus
00031 }
00032 #endif
00033
00034 #endif
00035
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mweekheadpiece.h Source File

include » pieces

mweekheadpiece.h

00001
00002 #ifndef _MGUI_NCSCTRL_WEEKHEADPIECE_H
00003 #define _MGUI_NCSCTRL_WEEKHEADPIECE_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif
00008
00009 typedef struct _mWeekHeadPieceClass mWeekHeadPieceClass;
00010 typedef struct _mWeekHeadPiece mWeekHeadPiece;
00011
00012 #define mWeekHeadPieceClassHeader(clss, superCls) \
00013         mRenderablePieceClassHeader(clss, superCls)
00014
00015 struct _mWeekHeadPieceClass
00016 {
00017         mWeekHeadPieceClassHeader(mWeekHeadPiece, mRenderablePiece)
00018 };
00019
00020 MGNCS_EXPORT extern mWeekHeadPieceClass g_stmWeekHeadPieceCls;
00021
00022 #define mWeekHeadPieceHeader(clss) \
00023         mRenderablePieceHeader(clss)  \
00024         char ** week_names;
00025
00026 struct _mWeekHeadPiece
00027 {
00028         mWeekHeadPieceHeader(mWeekHeadPiece)
00029 };
00030
00031 enum mWeekHeadPieceProps{
00032         NCSP_WEEKHEADPIECE_WEEKNAME = WEEKHEADPIECE_PROP_BEGIN
00033 };
00034
00035 #ifdef __cplusplus
00036 }
00037 #endif
00038
00039 #endif
00040
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mwidget.h Source File

include

mwidget.h

00001 /*
00002  * \file mwidget.h
00003  * \author ChaiPeng
00004  * \date 2009/01/01
00005  *
00006  * This file include the base widget control definition.
00007  *
00008  * \verbatim
00009  *
00010  *      This file is part of ncs, new control of MiniGUI.
00011  *
00012  *      \endverbatim
00013  *
00014  */
00015
00022 #ifndef _MGUI_NCSCTRL_WIDGET_H
00023 #define _MGUI_NCSCTRL_WIDGET_H
00024
00025
00026 #ifdef __cplusplus
00027 extern "C" {
00028 #endif  /* __cplusplus */
00029
00030
00031 #define TOWIDGET(x)    ((mWidget *)x)
00032 #define TOWIDGETCLASS(x)    ((mWidgetClass *)x)
00033
00034 #define RendererType(className) className##Renderer
00035
00036
00046 #define NCSCTRL_WIDGET  NCSCLASSNAME("widget")
00047
00048 typedef struct _mWidgetClass mWidgetClass;
00049 typedef struct _mWidget mWidget;
00050
00055 typedef struct _NCS_WND_TEMPLATE NCS_WND_TEMPLATE;
00056
00057
00058
00059
00060 typedef struct _mWidgetRenderer mWidgetRenderer;
00061
00062 #define mWidgetRendererHeader(clsName, parentClass)                         \
00063     const char* rdr_name;                                                   \
00064     /*renderer private method and data * every class must set NULL or it's ownd data */ \
00065     void (*class_init)(RendererType(clsName)* rdr);                         \
00066     RendererType(parentClass) *ptrParentClass;                              \
00067     BOOL (*init_self)(RendererType(clsName) *rdr);                          \
00068     void (*uninit_self)(RendererType(clsName) *rdr);                        \
00069     void * prv_data;                                                        \
00070     /*renderer drivedable method and data, * these data can be used directly by drived class */ \
00071     void (*drawFocusFrame)(clsName*, HDC, const RECT* );                    \
00072     BOOL (*drawBkground)(clsName*, HDC, const RECT*);                       \
00073     void (*draw3dbox)(clsName*, HDC, const RECT*, DWORD,DWORD);             \
00074     void (*drawCheckbox)(clsName*, HDC, const RECT*, DWORD);                \
00075     void (*drawRadio)(clsName*, HDC, const RECT*, DWORD);                   \
00076     void (*drawArrow)(clsName*, HDC, const RECT*, int arrow,DWORD, DWORD);  \
00077     void (*drawItem)(clsName*, HDC, const RECT*, DWORD);
00078
00083 enum ncsRendererState{
00084         NCSRS_NORMAL = 0x00,
00085         NCSRS_HIGHLIGHT = 0x01,
00086         NCSRS_SIGNIFICANT = 0x02,
00087         NCSRS_SELECTED = 0x04,
00088         NCSRS_HALFSELECTED = 0x10,
00089         NCSRS_DISABLE = 0x08
00090 };
00117 #define NCSR_STATUS(flag)  ((flag)&0xFFFF)
00118
00123 enum ncsRendererFlag{
00124         NCSRF_INNERFRAME = 0x010000,
00125         NCSRF_FILL       = 0x020000,
00126         NCSRF_FRAME      = 0x040000,
00127 };
00145 enum ncsRDRArrow {
00146         NCSR_ARROW_LEFT = 0,
00147         NCSR_ARROW_RIGHT,
00148         NCSR_ARROW_UP,
00149         NCSR_ARROW_DOWN
00150 };
00255 struct _mWidgetRenderer {
00256         mWidgetRendererHeader(mWidget, mWidget)
00257 };
00258
00259
00260 #define NCSSPEC_OBJ_CONTENT  MAX_USER_SPECIAL_KEY + 1
00261
00262 #define mWidgetHeader(clsName)                  \
00263         mComponentHeader(clsName)                   \
00264         HWND hwnd;                                  \
00265         RendererType(clsName) *renderer;            \
00266         mComponent* comps;                          \
00267         ImageDrawInfo  bkimg;                       \
00268         mObject *body;
00269
00288 struct _mWidget
00289 {
00290         mWidgetHeader(mWidget)
00291 };
00292
00293 #define mWidgetClassHeader(clsName, parentClass)                                    \
00294         mComponentClassHeader(clsName, parentClass)                                     \
00295         DWORD dlgCode;                                                                  \
00296         mObject * (*createBody)(clsName*);                                              \
00297         int (*wndProc)(clsName* , int, WPARAM, LPARAM);                                 \
00298         BOOL (*callUserHandler)(clsName* self, void *handler,                          \
00299                 int message, WPARAM wParam, LPARAM lParam, int *pRet);                      \
00300         BOOL (*onCreate)(clsName*, LPARAM);                                             \
00301         BOOL (*addChildren)(clsName*, NCS_WND_TEMPLATE* children,int count);           \
00302         void (*onPaint)(clsName*, HDC, const PCLIPRGN pClip);                           \
00303         int (*onLButtonDown)(clsName*, int x, int y, DWORD keyFlags);                  \
00304         int (*onLButtonUp)(clsName*, int x, int y, DWORD keyFlags);                    \
00305         int (*onMouseMove)(clsName*, int x, int y, DWORD keyFlags);                    \
00306         int (*onKeyDown)(clsName*, int scancode, DWORD keyFlags);                      \
00307         int (*onKeyUp)(clsName*, int scancode, DWORD keyFlags);                        \
00308         int (*onSizeChanged)(clsName*, RECT* rtClient);                                 \
00309         BOOL (*onEraseBkgnd)(clsName*, HDC hdc, const RECT* invRect);                  \
00310                                \
00311         BOOL (*refresh)(clsName *);
00312
00313
00340 struct _mWidgetClass
00341 {
00342         mWidgetClassHeader(mWidget, mComponent)
00343 };
00344
00345 #define SET_DLGCODE(code)  _class->dlgCode = (code);
00346
00353 MGNCS_EXPORT extern mWidgetClass g_stmWidgetCls;
00354
00355
00356 /* property support */
00357
00363 enum mWidgetProp{
00364         NCSP_WIDGET_RDR = 1,
00365         NCSP_WIDGET_TEXT,
00366         NCSP_WIDGET_BKIMAGE,
00367         NCSP_WIDGET_BKIMAGE_MODE,
00368         NCSP_WIDGET_BKIMAGE_FILE,
00369         NCSP_WIDGET_MAX
00370 };
00417 #define NCSS_NOTIFY (0x1)
00418
00419 #define IsNotify(self) \
00420         (GetWindowStyle(self->hwnd)&NCSS_NOTIFY)
00421
00422 #define NCSS_WIDGET_SHIFT 1
00423
00424 /*
00425  * \def NCSS_EX_UNNEEDIME
00426  * \brief the edit uneed ime or not
00427  */
00428 #define NCSS_EX_UNNEEDIME  0x1
00429
00435 enum mWidgetNotify {
00436         NCSN_WIDGET_CLICKED = 1,
00437         NCSN_WIDGET_DBCLICKED,
00438         NCSN_WIDGET_ENABLED,
00439         NCSN_WIDGET_DISABLED,
00440         NCSN_WIDGET_MAX
00441 };
00442
00471 #define NCSR_CONTINUE_MSG  FALSE
00472
00479 #define NCSR_STOP_MSG     TRUE
00480
00491 typedef void (*NCS_CB_ONNCCREATE)(mWidget*);
00492
00507 typedef BOOL (*NCS_CB_ONCREATE)(mWidget*, DWORD dwAddData);
00508
00522 typedef BOOL (*NCS_CB_ONINITDLG)(mWidget*, HWND hFocus, DWORD dwAddData);
00523
00534 typedef BOOL (*NCS_CB_ONVOID)(mWidget*, int message);
00546 typedef void (*NCS_CB_ONSZCHGING)(mWidget*, const PRECT prcExpect, PRECT prcResult);
00547
00561 typedef BOOL (*NCS_CB_ONSZCHGED)(mWidget*,PRECT prcClient);
00562 //MSG_CSIZECHANGED
00574 typedef void (*NCS_CB_ONCSZCHGED)(mWidget*, int clientWidth, int clientHeight);
00575
00587 typedef BOOL (*NCS_CB_ONFONTCHGING)(mWidget*, PLOGFONT logFont);
00600 typedef BOOL (*NCS_CB_ONERASEBKGND)(mWidget*, HDC hdc, const PRECT clip);
00610 typedef void (*NCS_CB_ONPAINT)(mWidget*, HDC hdc, const PCLIPRGN clipRgn);
00619 typedef BOOL (*NCS_CB_ONCLOSE)(mWidget*);
00620
00634 typedef BOOL (*NCS_CB_ONKEY)(mWidget*, int message, int code, DWORD keyStatus);
00635
00649 typedef BOOL(*NCS_CB_ONMOUSE)(mWidget*, int message, int x, int y, DWORD keyStatus);
00663 typedef BOOL (*NCS_CB_ONNCMOUSE)(mWidget*, int message, int x, int y, int  hitCode);
00675 typedef int (*NCS_CB_ONHITTEST)(mWidget*, int message,int x, int y);
00676
00686 typedef void (*NCS_CB_ONSCROLL)(mWidget*, int message, int code, int pos);
00698 typedef BOOL (*NCS_CB_ONCMD)(mWidget*, int id, int nc, HWND hCtrl);
00707 typedef void (*NCS_CB_WIDGET_ONTIMER)(mWidget*, int id, DWORD count);
00720 typedef int (*NCS_CB_ONMSG)(mWidget*, int message, WPARAM wParam, LPARAM lParam);
00730 typedef void (*NCS_CB_NOTIFY)(mWidget*, int id, int ncCode, DWORD addData);
00731
00738 #define NCS_NOTIFY_CODE(code)   (0xFFFF0000 | (code))
00739
00743 #define NCS_MAP_NOTIFY(code, handler) { NCS_NOTIFY_CODE(code), (void*)(handler) }
00744
00745
00747 void mWidget_captureHotPiece(mWidget *self, mObject *hotpice);
00748 mObject * mWidget_getCapturedHotPiece(mWidget *self);
00749 void mWidget_releaseCapturedHotPiece(void);
00750
00751 void mWidget_setHoveringFocus(mWidget *self, mObject *hotpiece);
00752 mObject * mWidget_getHoveringFocus(mWidget *self);
00753 void mWidget_releaseHoveringFocus(void);
00754
00755 void mWidget_setInputFocus(mWidget *self, mObject *hotpiece);
00756 mObject * mWidget_getInputFocus(mWidget *self);
00757 void mWidget_releaseInputFocus(void);
00758
00759 #ifdef _MGNCS_GUIBUILDER_SUPPORT
00760 //only for GUI Builder
00761 //used to create default content
00762 #define NCSP_DEFAULT_CONTENT  10000
00763 #endif
00764
00765
00789 MGNCS_EXPORT BOOL ncsSetFont (HWND hWnd, const char *fontName);
00790
00803 MGNCS_EXPORT BOOL ncsSetProperty(HWND hWnd, int id, DWORD value);
00815 MGNCS_EXPORT DWORD ncsGetProperty(HWND hWnd, int id);
00816
00824 typedef struct _NCS_PROP_ENTRY {
00828         int id;
00832         DWORD value;
00833 }NCS_PROP_ENTRY;
00834
00842 typedef struct _NCS_RDR_ELEMENT {
00846         int id;
00850         DWORD value;
00851 }NCS_RDR_ELEMENT;
00852
00858 typedef struct _NCS_RDR_INFO {
00862         const char* glb_rdr;
00866         const char* ctl_rdr;
00870         NCS_RDR_ELEMENT* elements;
00871 }NCS_RDR_INFO;
00872
00883 typedef struct _NCS_CREATE_NOTIFY_INFO {
00884     void (*onCreated)(struct _NCS_CREATE_NOTIFY_INFO*, mComponent* , DWORD special_id);
00885 }NCS_CREATE_NOTIFY_INFO;
00886
00887 typedef struct _NCS_CREATE_INFO{
00893         NCS_PROP_ENTRY * props;
00899         NCS_RDR_INFO * rdr_info;
00905         NCS_EVENT_HANDLER *handlers;
00911         NCS_WND_TEMPLATE * ctrls;
00915         int ctrl_count;
00919         DWORD user_data;
00920
00921         //FIXED ME Maybe I  should not put these two param here
00930         DWORD                           bk_color;
00934         const char*                     font_name;
00935
00936     // don't use in the control, to make the NCS_MNWND_TEMPLATE and NCS_WND_TEMPLATE same
00937     HICON               hIcon;
00938     HMENU               hMenu;
00939
00940     NCS_CREATE_NOTIFY_INFO * notify_info;
00941     DWORD                    special_id;
00942
00943 }NCS_CREATE_INFO;
00944
00977 MGNCS_EXPORT mWidget* ncsCreateWindow (const char *className, const char *caption, DWORD style, DWORD exStyle, \
00978         int id, int x, int y, int w, int h, HWND parent, \
00979         NCS_PROP_ENTRY * props, \
00980         NCS_RDR_INFO * rdrInfo, \
00981         NCS_EVENT_HANDLER * handlers, \
00982         DWORD addData);
00983
00992 typedef struct _NCS_MAIN_CREATE_INFO {
01002         const char* className;
01006         NCS_CREATE_INFO * create_info;
01007 }NCS_MAIN_CREATE_INFO;
01008
01045 MGNCS_EXPORT mWidget* ncsCreateMainWindow (const char *className, const char *caption,
01046         DWORD style, DWORD exStyle, \
01047         int id, int x, int y, int w, int h, HWND host, \
01048         HICON hIcon, HMENU hMenu,
01049         NCS_PROP_ENTRY * props, \
01050         NCS_RDR_INFO * rdrInfo, \
01051         NCS_EVENT_HANDLER * handlers, \
01052         DWORD addData);
01053
01059 struct _NCS_WND_TEMPLATE{
01065         const char*         class_name;
01069         int                 id;
01073         int                 x, y, w, h;
01077         DWORD               style;
01081         DWORD               ex_style;
01085         const char*         caption;
01086
01087         //same struct as NCS_CREATE_INFO
01093         NCS_PROP_ENTRY*     props;
01094         NCS_RDR_INFO*       rdr_info;
01095         NCS_EVENT_HANDLER*  handlers;
01096         NCS_WND_TEMPLATE*   ctrls;
01097         int                 count;
01098         DWORD               user_data;
01099
01100         //FIXED ME Maybe I  should not put these two param here
01101         DWORD                           bk_color;
01102         const char*             font_name;
01103
01104     // don't use in the control, to make the NCS_MNWND_TEMPLATE and NCS_WND_TEMPLATE same
01105     HICON               hIcon;
01106     HMENU               hMenu;
01107
01108     NCS_CREATE_NOTIFY_INFO * notify_info;
01109     DWORD                    special_id;
01110 };
01111
01112 //create control window indirect
01125 MGNCS_EXPORT mWidget* ncsCreateWindowIndirect( const NCS_WND_TEMPLATE* tmpl, HWND hParent);
01126
01134 typedef struct _NCS_MNWND_TEMPLATE{
01135         const char*         class_name;
01136         int                 id;
01137         int                 x, y, w, h;
01138         DWORD               style;
01139         DWORD               ex_style;
01140         const char*         caption;
01141
01142         NCS_PROP_ENTRY*     props;
01143         NCS_RDR_INFO*       rdr_info;
01144         NCS_EVENT_HANDLER*  handlers;
01145         NCS_WND_TEMPLATE*   ctrls;
01146         int                 count;
01147         DWORD               user_data;
01148
01149         //FIXED ME Maybe I  should not put these two param here
01150         DWORD                           bk_color;
01151         const char*                     font_name;
01152
01153         HICON               hIcon;
01154         HMENU               hMenu;
01155
01156
01157     NCS_CREATE_NOTIFY_INFO * notify_info;
01158     DWORD                    special_id;
01159
01160 }NCS_MNWND_TEMPLATE;
01161
01173 MGNCS_EXPORT mWidget* ncsCreateMainWindowIndirect(const NCS_MNWND_TEMPLATE* tmpl, HWND hHost);
01174
01186 MGNCS_EXPORT mWidgetClass* ncsGetMainWndClass(const char* className);
01187
01199 MGNCS_EXPORT void ncsNotifyParentEx(mWidget * self, int code, DWORD addData);
01200
01201 #define ncsNotifyParent(self, code)  ncsNotifyParentEx((mWidget*)self, code, 0)
01202
01211 static inline mWidget* ncsObjFromHandle(HWND hwnd)
01212 {
01213         if(IsWindow(hwnd))
01214                 return (mWidget*)(GetWindowAdditionalData2(hwnd));
01215         return NULL;
01216 }
01217
01227 static inline mWidget* ncsGetChildObj(HWND hwnd, int id)
01228 {
01229         mWidget * self = ncsObjFromHandle(hwnd);
01230         return (mWidget*)(self?_c(self)->getChild(self, id):NULL);
01231 }
01232
01241 static inline mWidget* ncsGetParentObj(HWND hwnd)
01242 {
01243         return ncsObjFromHandle(GetParent(hwnd));
01244 }
01245
01246
01255 static inline DWORD ncsGetDlgCode(HWND hwnd)
01256 {
01257
01258 #if 0
01259         mWidget * widget;
01260         if((widget=ncsObjFromHandle(hwnd)))
01261         {
01262                 return _c(widget)->dlgCode;
01263         }
01264         return 0;
01265 #endif
01266         return (DWORD)SendMessage(hwnd, MSG_GETDLGCODE, 0, 0);
01267 }
01268
01274 MGNCS_EXPORT void ncsDestroyWindow(mWidget* self, DWORD endCode);
01275
01276 #define ncsDeleteWidget(self) ncsDestroyWindow(self, 0)
01277
01278
01279 #define NCS_FETCH_MSGBINDINFO(sender, param, lParam) do{ \
01280         void ** __tmp = (void**)(lParam);                    \
01281         if(__tmp){                                           \
01282                 register DWORD* __param = (DWORD*)(void*)&(param);        \
01283                 register void** __sender = (void**)(void*)&(sender);     \
01284                 *__param  = (DWORD)__tmp[0];                       \
01285                 *__sender = __tmp[1];                            \
01286                 free(__tmp);                                     \
01287         }                                                    \
01288 }while(0)
01289
01290 MGNCS_EXPORT BOOL ncsBindEventsToMessage(mObject *sender, HWND hwnd_listener, int message, int* event_ids);
01291 MGNCS_EXPORT BOOL ncsBindEventToMessage(mObject* sender, HWND hwnd_listener, int message, int event_ids);
01292 MGNCS_EXPORT void ncsRemoveBindWindow(HWND hwnd_listener);
01293 MGNCS_EXPORT void ncsRemoveBindMessage(HWND hwnd_listener, int message,mObject* sender/*=NULL*/, int event_id/*=0*/);
01294
01295
01301 #ifdef __cplusplus
01302 }
01303 #endif  /* __cplusplus */
01304
01305 #endif /* _MGUI_NCSCTRL_WIDGET_H */
01306
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: mwidgetwrapperpiece.h Source File

include » pieces

mwidgetwrapperpiece.h

00001
00002 #ifndef _MGUI_NCSCTRL_WIDGETWRAPPERPIECE_H
00003 #define _MGUI_NCSCTRL_WIDGETWRAPPERPIECE_H
00004
00005 #ifdef __cplusplus
00006 extern "C" {
00007 #endif
00008
00009 typedef struct _mWidgetWrapperPieceClass mWidgetWrapperPieceClass;
00010 typedef struct _mWidgetWrapperPiece mWidgetWrapperPiece;
00011
00012 #define mWidgetWrapperPieceClassHeader(clss, superCls) \
00013         mHotPieceClassHeader(clss, superCls)
00014
00015 struct _mWidgetWrapperPieceClass
00016 {
00017         mWidgetWrapperPieceClassHeader(mWidgetWrapperPiece, mHotPiece)
00018 };
00019
00020 MGNCS_EXPORT extern mWidgetWrapperPieceClass g_stmWidgetWrapperPieceCls;
00021
00022 #define mWidgetWrapperPieceHeader(clss) \
00023         mHotPieceHeader(clss)  \
00024         mObject * widget;
00025
00026 struct _mWidgetWrapperPiece
00027 {
00028         mWidgetWrapperPieceHeader(mWidgetWrapperPiece)
00029 };
00030
00031 #define MSG_SETPIECE_PROPERTY  MSG_USER + 1234
00032 #define MSG_GETPIECE_PROPERTY  MSG_USER + 1235
00033
00034 #define RAISE_EVENT(obj,id, param)  _c(obj)->raiseEvent(obj, id, param)
00035
00036 #ifdef __cplusplus
00037 }
00038 #endif
00039
00040 #endif
00041
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: piece-id.h Source File

include » pieces

piece-id.h

00001
00002 #ifndef PIECE_ID_H
00003 #define PIECE_ID_H
00004
00008 enum SysPiecePropsRange{
00009         SYS_PIECE_PROP_BEGIN = 1,
00010         PIECECOMM_PROP_BEGIN = SYS_PIECE_PROP_BEGIN,
00011         PIECECOMM_PROP_ALIGN,
00012         PIECECOMM_PROP_VALIGN,
00013         PIECECOMM_PROP_AUTOWRAP,
00014         PIECECOMM_PROP_WORDBREAK,
00015         PIECECOMM_PROP_DRAWMOD,
00016         PIECECOMM_PROP_DIRECTION,
00017         PIECECOMM_PROP_SPACE,
00018         PIECECOMM_PROP_MARGIN,
00019         PIECECOMM_PROP_MAX,
00020         PIECECOMM_PROP_POS,
00021         PIECECOMM_PROP_MIN,
00022         PIECECOMM_PROP_LINESTEP,
00023         PIECECOMM_PROP_PAGESTEP,
00024         PIECECOMM_PROP_SELECT,
00025         PIECECOMM_PROP_END = PIECECOMM_PROP_BEGIN + 256,
00026
00027         HOTPIECE_PROP_BEGIN,
00028         HOTPIECE_PROP_END,
00029
00030
00031         LABELPIECE_PROP_BEGIN,
00032         LABELPIECE_PROP_END = LABELPIECE_PROP_BEGIN + 10,
00033
00034         LEDLBLPIECE_PROP_BEGIN,
00035         LEDLBLPIECE_PROP_END = LEDLBLPIECE_PROP_BEGIN + 10,
00036
00037         ANIMATEPIECE_PROP_BEGIN,
00038         ANIMATEPIECE_PROP_END = ANIMATEPIECE_PROP_BEGIN + 10,
00039
00040         IMAGEPIECE_PROP_BEGIN,
00041         IMAGEPIECE_PROP_END = IMAGEPIECE_PROP_BEGIN + 10,
00042
00043         IMAGELABELPIECE_PROP_BEGIN,
00044         IMAGELABELPIECE_PROP_END = IMAGELABELPIECE_PROP_BEGIN + 10,
00045
00046         ABP_PROP_BEGIN,
00047         ABP_PROP_END = ABP_PROP_BEGIN + 10,
00048
00049         PAIRPIECE_PROP_BEGIN,
00050         PAIRPIECE_PROP_END = PAIRPIECE_PROP_BEGIN + 10,
00051
00052         SLIDERPIECE_PROP_BEGIN,
00053         SLIDERPIECE_PROP_END = SLIDERPIECE_PROP_BEGIN + 10,
00054
00055         BOXLAYOUTPIECE_PROP_BEGIN,
00056         BOXLAYOUTPIECE_PROP_END = BOXLAYOUTPIECE_PROP_BEGIN + 10,
00057
00058         SPINBOXPIECE_PROP_BEGIN,
00059         SPINBOXPIECE_PROP_END = SPINBOXPIECE_PROP_BEGIN + 10,
00060
00061         GRIDBOXPIECE_PROP_BEGIN,
00062         GRIDBOXPIECE_PROP_END = GRIDBOXPIECE_PROP_BEGIN + 10,
00063
00064         DAYGRIDPIECE_PROP_BEGIN,
00065         DAYGRIDPIECE_PROP_END = DAYGRIDPIECE_PROP_BEGIN + 10,
00066
00067         CHECKBUTTONPIECE_PROP_BEGIN,
00068         CHECKBUTTONPIECE_PROP_END = CHECKBUTTONPIECE_PROP_BEGIN + 10,
00069
00070         WEEKHEADPIECE_PROP_BEGIN,
00071         WEEKHEADPIECE_PROP_END = WEEKHEADPIECE_PROP_BEGIN + 10,
00072
00073         MONTHPIECE_PROP_BEGIN,
00074         MONTHPIECE_PROP_END = MONTHPIECE_PROP_BEGIN + 10,
00075
00076         MLISTSPINNEDPIECE_PROP_BEGIN,
00077         MLISTSPINNEDPIECE_PROP_END = MLISTSPINNEDPIECE_PROP_BEGIN + 10,
00078
00079         TOOLIMAGEPIECE_PROP_BEGIN,
00080         TOOLIMAGEPIECE_PROP_END = TOOLIMAGEPIECE_PROP_BEGIN + 10,
00081
00082         LINELAYOUTPIECE_PROP_BEGIN,
00083         LINELAYOUTPIECE_PROP_END = LINELAYOUTPIECE_PROP_BEGIN + 10,
00084
00085         PROGRESSPIECE_PROP_BEGIN,
00086         PROGRESSPIECE_PROP_END = PROGRESSPIECE_PROP_BEGIN + 10,
00087
00088         RECTPIECE_PROP_BEGIN,
00089         RECTPIECE_PROP_END = RECTPIECE_PROP_BEGIN + 10,
00090
00091         SIMPLELISTPIECE_PROP_BEGIN,
00092         SIMPLELISTPIECE_PROP_END = SIMPLELISTPIECE_PROP_BEGIN + 10,
00093
00094         SYS_PIECE_PROP_END = 10000,
00095         USER_PIECE_PROP_BEGIN
00096 };
00097
00101 enum mSysPieceEventRange
00102 {
00103         SYS_PIECE_EVENT_BEGIN = 1,
00104
00105         ABP_EVENT_BEGIN,
00106
00107         ABP_EVENT_END = ABP_EVENT_BEGIN + 10,
00108
00109         SLIDERPIECE_EVENT_BEGIN,
00110         SLIDERPIECE_EVENT_END = SLIDERPIECE_EVENT_BEGIN + 10,
00111
00112         SPINBOXPIECE_EVENT_BEGIN,
00113         SPINBOXPIECE_EVENT_END = SPINBOXPIECE_EVENT_BEGIN + 10,
00114
00115
00116         MONTHPIECE_EVENT_BEGIN,
00117         MONTHPIECE_EVENT_END = MONTHPIECE_EVENT_BEGIN + 10,
00118
00119
00120         SIMPLELISTPIECE_EVENT_BEGIN,
00121         SIMPLELISTPIECE_EVENT_END = SIMPLELISTPIECE_EVENT_BEGIN + 10,
00122
00123         SYS_PIECE_EVENT_END = 10000,
00124
00125         USER_PIECE_EVENT_BEGIN,
00126 };
00127
00132 enum PieceState{
00133         PIECE_STATE_NORMAL = 0,
00134         PIECE_STATE_HILIGHT,
00135         PIECE_STATE_PUSHED,
00136         PIECE_STATE_CAPTURED,
00137         PIECE_STATE_DISABLE
00138 };
00139
00140 enum PieceCheckState{
00141         PIECE_CHECKSTATE_UNCHECKED = 0,
00142         PIECE_CHECKSTATE_HALFCHECKED,
00143         PIECE_CHECKSTATE_CHECKED
00144 };
00145
00154 #define NCS_PIECE_PAINT_STATE_MASK       0x000F
00155 #define NCS_PIECE_PAINT_CHECK_STATE_MASK 0x00F0
00156 #define NCS_PIECE_PAINT_GET_CHECK(add_data)      (((add_data)&NCS_PIECE_PAINT_CHECK_STATE_MASK)>>4)
00157 #define NCS_PIECE_PAINT_MAKE_CHECK(value)     \
00158                 (((value)&0xF)<<4)
00159
00163 #define NCS_PIECE_PAINT_ARROW_MASK      0x300
00164 #define NCS_PIECE_PAINT_ARROW_SHIFT     8
00165 #define NCS_PIECE_PAINT_ARROW_SHELL     0x400
00166 enum mArrowPieceType {
00167         NCS_ARROWPIECE_LEFT = 0x00,
00168         NCS_ARROWPIECE_RIGHT = 0x100,
00169         NCS_ARROWPIECE_UP = 0x200,
00170         NCS_ARROWPIECE_DOWN = 0x300
00171 };
00175 #define NCS_PIECE_PAINT_FLAT            0x010000 //flat style
00176
00177
00181 enum mLayoutPieceSizeType {
00182         NCS_LAYOUTPIECE_ST_FIXED = 0,
00183         NCS_LAYOUTPIECE_ST_PERCENT,
00184         NCS_LAYOUTPIECE_ST_AUTO //use the piece size of iteself
00185 };
00186
00187 #define mLayoutPiece_getSizeType(size)  (((size)&0xC000)>>6)
00188 #define mLayoutPiece_setSizeType(size, type) ((size)=((size)&0x3FFF)|((type)<<6))
00189 #define mLayoutPiece_setSize(size, value)    ((size)=((size)&0xC000)|((value)&0x3FFF))
00190 #define mLayoutPiece_getSize(size)           ((size)&0x3FFF)
00191
00192
00196 #define NCS_PIECE_PAINT_VERT             0x00010000
00197 #define NCS_PIECE_PAINT_TICK             0x00020000
00198 //progress
00199 #define NCS_PIECE_PAINT_BLOCK            0x00040000
00200 #define NCS_PIECE_PAINT_PERCENT          0x00080000
00201
00202 #endif
00203
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5


New Control Set V1.0.6 API Reference: piece.h Source File

include

piece.h

00001
00002 #ifndef _MGNCS_PIECE_H
00003 #define _MGNCS_PIECE_H
00004
00005 #include "manimateframes.h"
00006 #include "mbmparrayanimateframes.h"
00007 #include "mgifanimateframes.h"
00008
00009 #include "pieces/piece-id.h"
00010 #include "pieces/mhotpiece.h"
00011 #include "pieces/mstaticpiece.h"
00012 #include "pieces/mlayoutpiece.h"
00013 #include "pieces/mcontainerpiece.h"
00014 #include "pieces/mrenderablepiece.h"
00015 #include "pieces/mlabelpiece.h"
00016 #include "pieces/mimagepiece.h"
00017 #include "pieces/mabstractbuttonpiece.h"
00018 #include "pieces/mbuttonboxpiece.h"
00019 #include "pieces/mpairpiece.h"
00020 #include "pieces/mpushbuttonpiece.h"
00021 #include "pieces/mimagelabelpiece.h"
00022 #include "pieces/msliderpiece.h"
00023 #include "pieces/mthumbboxpiece.h"
00024 #include "pieces/mscrollthumbboxpiece.h"
00025 #include "pieces/mtrackbarpiece.h"
00026 #include "pieces/mboxlayoutpiece.h"
00027 #include "pieces/mhboxlayoutpiece.h"
00028 #include "pieces/mvboxlayoutpiece.h"
00029 #include "pieces/mcheckboxpiece.h"
00030 #include "pieces/mradioboxpiece.h"
00031 #include "pieces/mcheckbuttonpiece.h"
00032 #include "pieces/marrowpiece.h"
00033 #include "pieces/mleftarrowpiece.h"
00034 #include "pieces/mrightarrowpiece.h"
00035 #include "pieces/muparrowpiece.h"
00036 #include "pieces/mdownarrowpiece.h"
00037 #include "pieces/mscrollbarpiece.h"
00038 #include "pieces/marrowbuttonpiece.h"
00039 #include "pieces/mspinnerpiece.h"
00040 #include "pieces/mspinboxpiece.h"
00041 #include "pieces/mhspinboxpiece.h"
00042 #include "pieces/mvspinboxpiece.h"
00043 #include "pieces/mgridboxpiece.h"
00044 #include "pieces/mdaygridpiece.h"
00045 #include "pieces/mmonthpiece.h"
00046 #include "pieces/mnumspinnedpiece.h"
00047 #include "pieces/mlistspinnedpiece.h"
00048 #include "pieces/mweekheadpiece.h"
00049 #include "pieces/mtoolimgpiece.h"
00050 #include "pieces/mseparatorpiece.h"
00051 #include "pieces/mlinelayoutpiece.h"
00052 #include "pieces/mwidgetwrapperpiece.h"
00053 #include "pieces/mrectpiece.h"
00054 #include "pieces/manimatepiece.h"
00055 #include "pieces/mprogresspiece.h"
00056 #include "pieces/mledstaticpiece.h"
00057 #include "pieces/msimplelistpiece.h"
00058
00059 BOOL init_pieces_classes(void);
00060
00061 #define HP(ths)   ((mHotPiece*)(ths))
00062
00063 //for widget
00064 #define Body      HP(self->body)
00065 #define SetHotPieceProp(piece, id, value)  _c(HP(piece))->setProperty(HP(piece),id, value)
00066 #define GetHotPieceProp(piece, id)         _c(HP(piece))->getProperty(HP(piece),id)
00067 #define SetBodyProp(id, value)  _c(Body)->setProperty(Body, id, value)
00068 #define GetBodyProp(id)  _c(Body)->getProperty(Body, id)
00069
00070
00071 #endif
00072
Generated on Mon Dec 13 11:32:16 2010 for New Control Set V1.0.6 API Reference by doxygen 1.5.5