MiniGUI V3.0.10 API Reference: Bug List

  • Main Page
  • Related Pages
  • Modules
  • Data Structures
  • Files
  • Directories

Bug List

Global Tone
When MiniGUI runs on X Window or RTOS, the tone can not be played correctly.

Generated on Fri Dec 17 13:49:45 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Version information

  • Data Structures
  • Files
  • Directories

Version information
[Macros and data types commonly used]

Defines

  • #define _VERSION_CODE(major, minor, micro) (((major)<<16) | ((minor)<<8) | (micro))
    A macro that returns the version code from major, minor and micro version number.
  • #define _MINIGUI_VERSION_CODE ((MINIGUI_MAJOR_VERSION << 16) | (MINIGUI_MINOR_VERSION << 8) | MINIGUI_MICRO_VERSION)
    Version code of MiniGUI.

Define Documentation

#define _MINIGUI_VERSION_CODE ((MINIGUI_MAJOR_VERSION << 16) | (MINIGUI_MINOR_VERSION << 8) | MINIGUI_MICRO_VERSION)

Version code of MiniGUI.

See also:
_VERSION_CODE

Definition at line 96 of file common.h.

#define _VERSION_CODE | ( | major,
 |  | minor,
 |  | micro | ) | (((major)<<16) | ((minor)<<8) | (micro))

A macro that returns the version code from major, minor and micro version number.

MiniGUI uses this macro to evaluate the version code of current MiniGUI library installed in your system, and define it to _MINIGUI_VERSION_CODE.

See also:
_MINIGUI_VERSION_CODE

Definition at line 88 of file common.h.

Generated on Fri Dec 17 13:49:45 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Basic data types

Basic data types
[Macros and data types commonly used]

Typedefs

  • typedef unsigned char Uint8
    A type definition for an 8-bit unsigned character.
  • typedef signed char Sint8
    A type definition for an 8-bit signed character.
  • typedef unsigned short Uint16
    A type definition for a 16-bit unsigned integer.
  • typedef signed short Sint16
    A type definition for a 16-bit signed integer.
  • typedef unsigned int Uint32
    A type definition for a 32-bit unsigned integer.
  • typedef signed int Sint32
    A type definition for a 32-bit signed integer.
  • typedef unsigned long long Uint64
    A type definition for a 64-bit unsigned integer.
  • typedef signed long long Sint64
    A type definition for a 64-bit signed integer.

Typedef Documentation

typedef signed short Sint16

A type definition for a 16-bit signed integer.

Definition at line 125 of file common.h.

typedef signed int Sint32

A type definition for a 32-bit signed integer.

Definition at line 135 of file common.h.

typedef signed long long Sint64

A type definition for a 64-bit signed integer.

Warning:
Only available under GNU C.

Definition at line 166 of file common.h.

typedef signed char Sint8

A type definition for an 8-bit signed character.

Definition at line 115 of file common.h.

typedef unsigned short Uint16

A type definition for a 16-bit unsigned integer.

Definition at line 120 of file common.h.

typedef unsigned int Uint32

A type definition for a 32-bit unsigned integer.

Definition at line 130 of file common.h.

typedef unsigned long long Uint64

A type definition for a 64-bit unsigned integer.

Warning:
Only available under GNU C.

Definition at line 159 of file common.h.

typedef unsigned char Uint8

A type definition for an 8-bit unsigned character.

Definition at line 110 of file common.h.

Generated on Fri Dec 17 13:49:45 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Endianness information

Endianness information
[Macros and data types commonly used]

Defines

  • #define MGUI_LIL_ENDIAN 1234
    Little endianness.
  • #define MGUI_BIG_ENDIAN 4321
    Big endianness.
  • #define MGUI_BYTEORDER MGUI_LIL_ENDIAN
    The byte order (endianness) of the target system.

Define Documentation

#define MGUI_BIG_ENDIAN 4321

Big endianness.

Definition at line 206 of file common.h.

#define MGUI_BYTEORDER MGUI_LIL_ENDIAN

The byte order (endianness) of the target system.

This macro will be either defined to MGUI_LIL_ENDIAN or MGUI_BIG_ENDIAN. You can use the code like below

 #if MGUI_BYTEORDER == MGUI_LIL_ENDIAN
     ... // code for little endian system.
 #else
     ... // code for big endian system.
 #endif

to write endianness independent code.

Definition at line 238 of file common.h.

#define MGUI_LIL_ENDIAN 1234

Little endianness.

Definition at line 201 of file common.h.

Generated on Fri Dec 17 13:49:45 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Simple and common types and macros

Simple and common types and macros
[Macros and data types commonly used]

Defines

  • #define FALSE 0
    FALSE value, defined as 0 by MiniGUI.
  • #define TRUE 1
    TRUE value, defined as 1 by MiniGUI.
  • #define NULL ((void *)0)
    A value indicates null pointer.

Typedefs

  • typedef int BOOL
    A type definition for boolean value.

Define Documentation

#define FALSE 0

FALSE value, defined as 0 by MiniGUI.

Definition at line 264 of file common.h.

Referenced by PeekMessage(), and PtInRect().

#define NULL ((void *)0)

A value indicates null pointer.

Definition at line 282 of file common.h.

Referenced by CreateMainWindow(), CreateMainWindowIndirectParam(), CreateMemDC(), CreateWindowEx(), DialogBoxIndirectParam(), GetPixelInBitmap(), GetSystemFont(), and SetPixelInBitmap().

#define TRUE 1

TRUE value, defined as 1 by MiniGUI.

Definition at line 271 of file common.h.

Referenced by GetMessage(), HideCaret(), PtInRect(), and ShowCaret().

Typedef Documentation

typedef int BOOL

A type definition for boolean value.

Definition at line 256 of file common.h.

Generated on Fri Dec 17 13:49:45 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: MiniGUI handles

MiniGUI handles
[Macros and data types commonly used]

Typedefs

  • typedef unsigned int GHANDLE
    General handle.
  • typedef unsigned int HWND
    Handle to main window or control.
  • typedef unsigned int HDC
    Handle to device context.
  • typedef unsigned int HPALETTE
    Handle to a logical palette.
  • typedef unsigned int HCURSOR
    Handle to cursor.
  • typedef unsigned int HICON
    Handle to icon.
  • typedef unsigned int HMENU
    Handle to menu.
  • typedef unsigned int HACCEL
    Handle to accelarator.
  • typedef unsigned int HDLG
    Handle to dialog box, same as HWND.
  • typedef unsigned int HHOOK
    Handle to keyboard or mouse event hook.

Typedef Documentation

typedef unsigned int GHANDLE

General handle.

Definition at line 315 of file common.h.

typedef unsigned int HACCEL

Handle to accelarator.

Definition at line 350 of file common.h.

typedef unsigned int HCURSOR

Handle to cursor.

Definition at line 335 of file common.h.

typedef unsigned int HDC

Handle to device context.

Definition at line 325 of file common.h.

typedef unsigned int HDLG

Handle to dialog box, same as HWND.

Definition at line 355 of file common.h.

typedef unsigned int HHOOK

Handle to keyboard or mouse event hook.

Definition at line 360 of file common.h.

typedef unsigned int HICON

Handle to icon.

Definition at line 340 of file common.h.

typedef unsigned int HMENU

Handle to menu.

Definition at line 345 of file common.h.

typedef unsigned int HPALETTE

Handle to a logical palette.

Definition at line 330 of file common.h.

typedef unsigned int HWND

Handle to main window or control.

Definition at line 320 of file common.h.

Generated on Fri Dec 17 13:49:45 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Win32-like data types and macros

Win32-like data types and macros
[Macros and data types commonly used]

Data Structures

  • struct _RECT
  • struct _POINT
  • struct _SIZE
  • struct _RGB

Defines

  • #define LOBYTE(w) ((BYTE)(w))
    Returns the low byte of the word w.
  • #define HIBYTE(w) ((BYTE)(((WORD)(w) >> 8) & 0xFF))
    Returns the high byte of the word w.
  • #define MAKEWORD(low, high) ((WORD)(((BYTE)(low)) | (((WORD)((BYTE)(high))) << 8)))
    Makes a word from low byte and high byte.
  • #define LOWORD(l) ((WORD)(DWORD)(l))
    Returns the low word of the double word l.
  • #define HIWORD(l) ((WORD)((((DWORD)(l)) >> 16) & 0xFFFF))
    Returns the high word of the double word l.
  • #define LOSWORD(l) ((SWORD)(DWORD)(l))
    Returns the low signed word of the double word l.
  • #define HISWORD(l) ((SWORD)((((DWORD)(l)) >> 16) & 0xFFFF))
    Returns the high signed word of the double word l.
  • #define MAKELONG(low, high) ((DWORD)(((WORD)(low)) | (((DWORD)((WORD)(high))) << 16)))
    Makes a double word from low word and high word.
  • #define GetRValue(rgba) ((BYTE)(rgba))
    Gets the red component from a RGBA triple value rgba.
  • #define GetGValue(rgba) ((BYTE)(((DWORD)(rgba)) >> 8))
    Gets the green component from a RGBA triple value rgba.
  • #define GetBValue(rgba) ((BYTE)((DWORD)(rgba) >> 16))
    Gets the blue component from a RGBA triple value rgba.
  • #define GetAValue(rgba) ((BYTE)((DWORD)(rgba) >> 24))
    Gets the alpha component from a RGBA triple value rgba.
  • #define MakeRGBA(r, g, b, a)
    Makes a RGBA triple value from red r, green g, blue b and alpha components.
  • #define MakeRGB(r, g, b)
    Makes a RGB triple value from red r, green g, and blue b components.

Typedefs

  • typedef unsigned char BYTE
    A type definition for unsigned character (byte).
  • typedef signed char SBYTE
    A type definition for signed character.
  • typedef unsigned short WORD
    A type definition for unsigned short integer (word).
  • typedef signed short SWORD
    A type definition for signed short integer.
  • typedef unsigned long DWORD
    A type definition for unsigned long integer (double word).
  • typedef signed long SDWORD
    A type definition for signed long integer.
  • typedef unsigned int UINT
    A type definition for unsigned integer.
  • typedef long LONG
    A type definition for long integer.
  • typedef unsigned int WPARAM
    A type definition for the first message paramter.
  • typedef unsigned long LPARAM
    A type definition for the second message paramter.
  • typedef DWORD RGBCOLOR
    A type definition for a RGB color.
  • typedef RECT * PRECT
    Data type of the pointer to a RECT.
  • typedef POINT * PPOINT
    Data type of the pointer to a POINT.
  • typedef SIZE * PSIZE
    Data type of the pointer to a SIZE.
  • typedef RGB * PRGB
    Data type of the pointer to a RGB.

Define Documentation

#define GetAValue ( rgba ) ((BYTE)((DWORD)(rgba) >> 24))

Gets the alpha component from a RGBA triple value rgba.

You can make a RGBA triple by using MakeRGBA.

See also:
MakeRGBA, MakeRGB

Definition at line 530 of file common.h.

Referenced by DWORD2PIXEL().

#define GetBValue ( rgba ) ((BYTE)((DWORD)(rgba) >> 16))

Gets the blue component from a RGBA triple value rgba.

You can make a RGBA triple by using MakeRGBA.

See also:
MakeRGBA, MakeRGB

Definition at line 521 of file common.h.

Referenced by DWORD2PIXEL().

#define GetGValue ( rgba ) ((BYTE)(((DWORD)(rgba)) >> 8))

Gets the green component from a RGBA triple value rgba.

You can make a RGBA triple by using MakeRGBA.

See also:
MakeRGBA, MakeRGB

Definition at line 512 of file common.h.

Referenced by DWORD2PIXEL().

#define GetRValue ( rgba ) ((BYTE)(rgba))

Gets the red component from a RGBA triple value rgba.

You can make a RGBA triple by using MakeRGBA.

See also:
MakeRGBA, MakeRGB

Definition at line 503 of file common.h.

Referenced by DWORD2PIXEL().

#define HIBYTE ( w ) ((BYTE)(((WORD)(w) >> 8) & 0xFF))

Returns the high byte of the word w.

See also:
MAKEWORD

Definition at line 451 of file common.h.

#define HISWORD ( l ) ((SWORD)((((DWORD)(l)) >> 16) & 0xFFFF))

Returns the high signed word of the double word l.

See also:
MAKELONG

Definition at line 487 of file common.h.

#define HIWORD ( l ) ((WORD)((((DWORD)(l)) >> 16) & 0xFFFF))

Returns the high word of the double word l.

See also:
MAKELONG

Definition at line 472 of file common.h.

#define LOBYTE ( w ) ((BYTE)(w))

Returns the low byte of the word w.

See also:
MAKEWORD

Definition at line 444 of file common.h.

#define LOSWORD ( l ) ((SWORD)(DWORD)(l))

Returns the low signed word of the double word l.

See also:
MAKELONG

Definition at line 480 of file common.h.

#define LOWORD ( l ) ((WORD)(DWORD)(l))

Returns the low word of the double word l.

See also:
MAKELONG

Definition at line 465 of file common.h.

#define MAKELONG | ( | low,
 |  | high | ) | ((DWORD)(((WORD)(low)) | (((DWORD)((WORD)(high))) << 16)))

Makes a double word from low word and high word.

Definition at line 493 of file common.h.

#define MakeRGB | ( | r,
 |  | g,
 |  | b | )

Value:

(((DWORD)((BYTE)(r))) | ((DWORD)((BYTE)(g)) << 8) \
                | ((DWORD)((BYTE)(b)) << 16))
Makes a RGB triple value from red r, green g, and blue b components.

Note:
The red, green, and blue components are all ranged from 0 to 255, and the returned value will be a double word.
See also:
GetRValue, GetGValue, GetBValue

Definition at line 554 of file common.h.

#define MakeRGBA | ( | r,
 |  | g,
 |  | b,
 |  | a | )

Value:

(((DWORD)((BYTE)(r))) | ((DWORD)((BYTE)(g)) << 8) \
                | ((DWORD)((BYTE)(b)) << 16) | ((DWORD)((BYTE)(a)) << 24))
Makes a RGBA triple value from red r, green g, blue b and alpha components.

Note:
The red, green, blue and alpha components are all ranged from 0 to 255, and the returned value will be a double word.
See also:
GetRValue, GetGValue, GetBValue, GetAValue

Definition at line 542 of file common.h.

Referenced by Pixel2DWORD().

#define MAKEWORD | ( | low,
 |  | high | ) | ((WORD)(((BYTE)(low)) | (((WORD)((BYTE)(high))) << 8)))

Makes a word from low byte and high byte.

Definition at line 457 of file common.h.

Typedef Documentation

typedef unsigned char BYTE

A type definition for unsigned character (byte).

Definition at line 374 of file common.h.

typedef unsigned long DWORD

A type definition for unsigned long integer (double word).

Definition at line 401 of file common.h.

typedef long LONG

A type definition for long integer.

Definition at line 423 of file common.h.

typedef unsigned long LPARAM

A type definition for the second message paramter.

Definition at line 436 of file common.h.

typedef POINT * PPOINT

Data type of the pointer to a POINT.

See also:
POINT

Definition at line 620 of file common.h.

typedef RECT * PRECT

Data type of the pointer to a RECT.

See also:
RECT

Definition at line 597 of file common.h.

typedef RGB * PRGB

Data type of the pointer to a RGB.

See also:
RGB

Definition at line 675 of file common.h.

typedef SIZE * PSIZE

Data type of the pointer to a SIZE.

See also:
SIZE

Definition at line 643 of file common.h.

typedef DWORD RGBCOLOR

A type definition for a RGB color.

Definition at line 561 of file common.h.

typedef signed char SBYTE

A type definition for signed character.

Definition at line 380 of file common.h.

typedef signed long SDWORD

A type definition for signed long integer.

Definition at line 408 of file common.h.

typedef signed short SWORD

A type definition for signed short integer.

Definition at line 394 of file common.h.

typedef unsigned int UINT

A type definition for unsigned integer.

Definition at line 415 of file common.h.

typedef unsigned short WORD

A type definition for unsigned short integer (word).

Definition at line 387 of file common.h.

typedef unsigned int WPARAM

A type definition for the first message paramter.

Definition at line 430 of file common.h.

Generated on Fri Dec 17 13:49:45 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _RECT Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_RECT Struct Reference
[Win32-like data types and macros]

#include <common.h>

Data Fields

  • int left
  • int top
  • int right
  • int bottom

Detailed Description

A rectangle defined by coordinates of corners.

Note:
The lower-right corner does not belong to the rectangle, i.e. the bottom horizontal line and the right vertical line are excluded from the retangle.
See also:
PRECT, GAL_Rect

Definition at line 572 of file common.h.

Field Documentation

int left

The x coordinate of the upper-left corner of the rectangle.

Definition at line 577 of file common.h.

Referenced by PtInRect().

int top

The y coordinate of the upper-left corner of the rectangle.

Definition at line 581 of file common.h.

Referenced by PtInRect().

int right

The x coordinate of the lower-right corner of the rectangle.

Definition at line 585 of file common.h.

int bottom

The y coordinate of the lower-right corner of the rectangle.

Definition at line 589 of file common.h.

The documentation for this struct was generated from the following file:
  • common.h
Generated on Fri Dec 17 13:49:52 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _POINT Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_POINT Struct Reference
[Win32-like data types and macros]

#include <common.h>

Data Fields

  • int x
  • int y

Detailed Description

Point structure.
See also:
PPOINT

Definition at line 603 of file common.h.

Field Documentation

int x

The x coordinate of the point.

Definition at line 608 of file common.h.

int y

The y coordinate of the point.

Definition at line 612 of file common.h.

The documentation for this struct was generated from the following file:
  • common.h
Generated on Fri Dec 17 13:49:52 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _SIZE Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_SIZE Struct Reference
[Win32-like data types and macros]

#include <common.h>

Data Fields

  • int cx
  • int cy

Detailed Description

Size structure of a 2-dimension object.
See also:
PSIZE

Definition at line 626 of file common.h.

Field Documentation

int cx

The extent in x coordinate of a 2D object.

Definition at line 631 of file common.h.

int cy

The extent in y coordinate of a 2D object.

Definition at line 635 of file common.h.

The documentation for this struct was generated from the following file:
  • common.h
Generated on Fri Dec 17 13:49:52 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _RGB Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_RGB Struct Reference
[Win32-like data types and macros]

#include <common.h>

Data Fields

  • BYTE r
  • BYTE g
  • BYTE b
  • BYTE a

Detailed Description

RGB triple structure.
See also:
PRGB, GAL_Color

Definition at line 649 of file common.h.

Field Documentation

BYTE r

The red component of a RGB triple.

Definition at line 654 of file common.h.

Referenced by Pixel2RGB(), and Pixel2RGBA().

BYTE g

The green component of a RGB triple.

Definition at line 658 of file common.h.

Referenced by Pixel2RGB(), and Pixel2RGBA().

BYTE b

The blue component of a RGB triple.

Definition at line 662 of file common.h.

Referenced by Pixel2RGB(), and Pixel2RGBA().

BYTE a

Reserved for alignment, maybe used for the alpha component of a RGB triple.

Definition at line 666 of file common.h.

Referenced by Pixel2RGBA().

The documentation for this struct was generated from the following file:
  • common.h
Generated on Fri Dec 17 13:49:52 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data types for GDI

Data types for GDI
[Macros and data types commonly used]

Data Structures

  • struct _GAL_Color
  • struct _GAL_Palette
  • struct _GAL_Rect

Typedefs

  • typedef Sint8 gal_sint8
    Data type of 8-bit signed integer.
  • typedef Uint8 gal_uint8
    Data type of 8-bit unsigned integer.
  • typedef Sint16 gal_sint16
    Data type of 16-bit signed integer.
  • typedef Uint16 gal_uint16
    Data type of 16-bit unsigned integer.
  • typedef Sint32 gal_sint32
    Data type of 32-bit signed integer.
  • typedef Uint32 gal_uint32
    Data type of 32-bit unsigned integer.
  • typedef signed int gal_sint
    Data type of signed integer.
  • typedef unsigned int gal_uint
    Data type of unsigned integer.
  • typedef Uint32 gal_pixel
    Data type of pixel value.
  • typedef Uint32 gal_attr
    Data type of attribute value.
  • typedef long fixed
    Data type of fixed point.

Typedef Documentation

typedef long fixed

Data type of fixed point.

Definition at line 754 of file common.h.

typedef Uint32 gal_attr

Data type of attribute value.

Definition at line 748 of file common.h.

typedef Uint32 gal_pixel

Data type of pixel value.

Definition at line 743 of file common.h.

typedef signed int gal_sint

Data type of signed integer.

Definition at line 732 of file common.h.

typedef Sint16 gal_sint16

Data type of 16-bit signed integer.

See also:
Sint16

Definition at line 704 of file common.h.

typedef Sint32 gal_sint32

Data type of 32-bit signed integer.

See also:
Sint32

Definition at line 719 of file common.h.

typedef Sint8 gal_sint8

Data type of 8-bit signed integer.

See also:
Sint8

Definition at line 689 of file common.h.

typedef unsigned int gal_uint

Data type of unsigned integer.

Definition at line 737 of file common.h.

typedef Uint16 gal_uint16

Data type of 16-bit unsigned integer.

See also:
Uint16

Definition at line 711 of file common.h.

typedef Uint32 gal_uint32

Data type of 32-bit unsigned integer.

See also:
Uint32

Definition at line 726 of file common.h.

typedef Uint8 gal_uint8

Data type of 8-bit unsigned integer.

See also:
Uint8

Definition at line 696 of file common.h.

Generated on Fri Dec 17 13:49:45 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _GAL_Color Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_GAL_Color Struct Reference
[Data types for GDI]

#include <common.h>

Data Fields

  • gal_uint8 r
  • gal_uint8 g
  • gal_uint8 b
  • gal_uint8 a

Detailed Description

RGBA quarter structure.
See also:
RGB

Definition at line 760 of file common.h.

Field Documentation

gal_uint8 r

The red component of a RGBA quarter.

Definition at line 765 of file common.h.

gal_uint8 g

The green component of a RGBA quarter.

Definition at line 769 of file common.h.

gal_uint8 b

The blue component of a RGBA quarter.

Definition at line 773 of file common.h.

gal_uint8 a

The alpha component of a RGBA quarter.

Definition at line 777 of file common.h.

The documentation for this struct was generated from the following file:
  • common.h
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _GAL_Palette Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_GAL_Palette Struct Reference
[Data types for GDI]

#include <common.h>

Data Fields

  • int ncolors
  • GAL_Color * colors

Detailed Description

Palette structure.
See also:
GAL_Color

Definition at line 784 of file common.h.

Field Documentation

int ncolors

The number of palette items.

Definition at line 789 of file common.h.

GAL_Color* colors

The pointer to the array of palette items.

Definition at line 793 of file common.h.

The documentation for this struct was generated from the following file:
  • common.h
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _GAL_Rect Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_GAL_Rect Struct Reference
[Data types for GDI]

#include <common.h>

Data Fields

  • Sint32 x
  • Sint32 w

Detailed Description

A rectangle defined by upper-left coordinates and width/height.
See also:
RECT

Definition at line 800 of file common.h.

Field Documentation

Sint32 x

The coordinates of the upper-left corner of the rectangle.

Definition at line 804 of file common.h.

Sint32 w

The width and height of the rectangle.

Definition at line 808 of file common.h.

The documentation for this struct was generated from the following file:
  • common.h
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Macros for key codes and shift status

Macros for key codes and shift status
[Macros and data types commonly used]

Defines

  • #define MGUI_NR_KEYS 255
    Number of MiniGUI keys.
  • #define NR_KEYS 128
    The number of keys defined by Linux operating system.
  • #define SCANCODE_USER (NR_KEYS + 1)
    The first key scan code different from OS defined ones.
  • #define KS_REPEATED 0x00000800
    This status indicate that the key down message is an auto-repeated one.
  • #define KS_CAPTURED 0x00000400
    This status indicate that the mouse is captured by a window when the mouse message posted.
  • #define KS_IMEPOST 0x00000200
    This status indicate that the key message is posted by the IME window.
  • #define KS_CAPSLOCK 0x00000100
    This status indicate that the CapsLock key was locked when the key or mouse message posted to the window.
  • #define KS_NUMLOCK 0x00000080
    This status indicate that the NumLock key was locked when the key or mouse message posted to the window.
  • #define KS_SCROLLLOCK 0x00000040
    This status indicate that the ScrollLock key was locked when the key or mouse message posted to the window.
  • #define KS_LEFTCTRL 0x00000020
    This status indicate that the left-Ctrl key was pressed when the key or mouse message posted to the window.
  • #define KS_RIGHTCTRL 0x00000010
    This status indicate that the right-Ctrl key was pressed when the key or mouse message posted to the window.
  • #define KS_CTRL 0x00000030
    This status indicate that either the left-Ctrl key or the right-Ctrl key was pressed when the key or mouse message posted to the window.
  • #define KS_LEFTALT 0x00000008
    This status indicate that left-Alt key was pressed when the key or mouse message posted to the window.
  • #define KS_RIGHTALT 0x00000004
    This status indicate that right-Alt key was pressed when the key or mouse message posted to the window.
  • #define KS_ALT 0x0000000C
    This status indicate that either the left-Alt key or the right-Alt key was pressed when the key or mouse message posted to the window.
  • #define KS_LEFTSHIFT 0x00000002
    This status indicate that left-Shift key was pressed when the key or mouse message posted to the window.
  • #define KS_RIGHTSHIFT 0x00000001
    This status indicate that right-Shift key was pressed when the key or mouse message posted to the window.
  • #define KS_SHIFT 0x00000003
    This status indicate that either the left-Shift key or the right-Shift key was pressed when the key or mouse message posted to the window.
  • #define MASK_KS_SHIFTKEYS 0x00000FFF
    The mask of key status.
  • #define KS_LEFTBUTTON 0x00001000
    This status indicate that left button was pressed when the key or mouse message posted to the window.
  • #define KS_RIGHTBUTTON 0x00002000
    This status indicate that right button was pressed when the key or mouse message posted to the window.
  • #define KS_MIDDLBUTTON 0x00004000
    This status indicate that middle button was pressed when the key or mouse message posted to the window.
  • #define MASK_KS_BUTTONS 0x0000F000
    The mask of mouse button status.

Define Documentation

#define KS_ALT 0x0000000C

This status indicate that either the left-Alt key or the right-Alt key was pressed when the key or mouse message posted to the window.

See also:
Key event messages

Definition at line 1158 of file common.h.

#define KS_CAPSLOCK 0x00000100

This status indicate that the CapsLock key was locked when the key or mouse message posted to the window.

You can test the status by AND'ed with lParam of the message, like below

      switch (message) {
      case MSG_KEYDOWN:
          if (lParam & KS_CAPSLOCK) {
              // the CapsLock key is locked.
              ...
          }
          break;
      ...

See also:
Key event messages

Definition at line 1086 of file common.h.

#define KS_CAPTURED 0x00000400

This status indicate that the mouse is captured by a window when the mouse message posted.

You can test the status by AND'ed with wParam of the message, like below:

      switch (message) {
      case MSG_MOUSEMOVE:
          if (wParam & KS_CAPTURED) {
              // the mouse is captured by this window.
              ...
          }
          break;
      ...

See also:
Mouse event messages

Definition at line 1056 of file common.h.

#define KS_CTRL 0x00000030

This status indicate that either the left-Ctrl key or the right-Ctrl key was pressed when the key or mouse message posted to the window.

See also:
Key event messages

Definition at line 1131 of file common.h.

#define KS_IMEPOST 0x00000200

This status indicate that the key message is posted by the IME window.

See also:
Key event messages

Definition at line 1064 of file common.h.

#define KS_LEFTALT 0x00000008

This status indicate that left-Alt key was pressed when the key or mouse message posted to the window.

See also:
Key event messages

Definition at line 1140 of file common.h.

#define KS_LEFTBUTTON 0x00001000

This status indicate that left button was pressed when the key or mouse message posted to the window.

See also:
Key event messages

Definition at line 1200 of file common.h.

#define KS_LEFTCTRL 0x00000020

This status indicate that the left-Ctrl key was pressed when the key or mouse message posted to the window.

See also:
Key event messages

Definition at line 1113 of file common.h.

#define KS_LEFTSHIFT 0x00000002

This status indicate that left-Shift key was pressed when the key or mouse message posted to the window.

See also:
Key event messages

Definition at line 1167 of file common.h.

#define KS_MIDDLBUTTON 0x00004000

This status indicate that middle button was pressed when the key or mouse message posted to the window.

See also:
Key event messages

Definition at line 1218 of file common.h.

#define KS_NUMLOCK 0x00000080

This status indicate that the NumLock key was locked when the key or mouse message posted to the window.

See also:
Key event messages

Definition at line 1095 of file common.h.

#define KS_REPEATED 0x00000800

This status indicate that the key down message is an auto-repeated one.

You can test the status by AND'ed with lParam of the message, like below:

      switch (message) {
      case MSG_KEYDOWN:
          if (lParam & KS_REPEATED) {
              // the key down messsage is auto-repeated.
              ...
          }
          break;
      ...

See also:
Key event messages

Definition at line 1034 of file common.h.

#define KS_RIGHTALT 0x00000004

This status indicate that right-Alt key was pressed when the key or mouse message posted to the window.

See also:
Key event messages

Definition at line 1149 of file common.h.

#define KS_RIGHTBUTTON 0x00002000

This status indicate that right button was pressed when the key or mouse message posted to the window.

See also:
Key event messages

Definition at line 1209 of file common.h.

#define KS_RIGHTCTRL 0x00000010

This status indicate that the right-Ctrl key was pressed when the key or mouse message posted to the window.

See also:
Key event messages

Definition at line 1122 of file common.h.

#define KS_RIGHTSHIFT 0x00000001

This status indicate that right-Shift key was pressed when the key or mouse message posted to the window.

See also:
Key event messages

Definition at line 1176 of file common.h.

#define KS_SCROLLLOCK 0x00000040

This status indicate that the ScrollLock key was locked when the key or mouse message posted to the window.

See also:
Key event messages

Definition at line 1104 of file common.h.

#define KS_SHIFT 0x00000003

This status indicate that either the left-Shift key or the right-Shift key was pressed when the key or mouse message posted to the window.

See also:
Key event messages

Definition at line 1185 of file common.h.

#define MASK_KS_BUTTONS 0x0000F000

The mask of mouse button status.

Definition at line 1224 of file common.h.

#define MASK_KS_SHIFTKEYS 0x00000FFF

The mask of key status.

Definition at line 1191 of file common.h.

#define MGUI_NR_KEYS 255

Number of MiniGUI keys.

The number of MiniGUI keys is defined to 255 by default. This means that MiniGUI can destinguish 255 different keys with each has an unique scan code. The scan codes below 129 are defined for PC keyboard by default. If your system has a large amount of keys, you can define the scan code of keys ranged from 1 to 255 in your IAL engine. And your application will receive a MSG_KEYDOWN and MSG_KEYUP messages when a key pressed and released, and the wParam of the messages will be defined to be equal to the scan code of the key.

See also:
NR_KEYS, SCANCODE_USER

Definition at line 833 of file common.h.

#define NR_KEYS 128

The number of keys defined by Linux operating system.

For a PC box, NR_KEYS is defined to 128 by default. You can define some input events from an input device other than keyboard, e.g. your remote controller, as key events with different scan codes from those of PC's. MiniGUI can support 255 keys, and the constant is defined by MGUI_NR_KEYS.

See also:
MGUI_NR_KEYS

Definition at line 848 of file common.h.

#define SCANCODE_USER (NR_KEYS + 1)

The first key scan code different from OS defined ones.

You can define your special key scan codes like below

 #define SCANCODE_PLAY    (SCANCODE_USER)
 #define SCANCODE_STOP    (SCANCODE_USER + 1)
 #define SCANCODE_PAUSE   (SCANCODE_USER + 2)

to distinguish the keys on your remote controller.

See also:
MGUI_NR_KEYS, NR_KEYS

Definition at line 867 of file common.h.

Generated on Fri Dec 17 13:49:45 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Error codes

Error codes
[Macros and data types commonly used]

Defines

  • #define ERR_OK 0
    Return value error ok.
  • #define ERR_INV_HWND -1
    Return value invalid window handle error.
  • #define ERR_QUEUE_FULL -2
    Return value queue is full error.
  • #define ERR_INVALID_HANDLE -3
    Return value invalid handle error.
  • #define ERR_INVALID_HMENU -4
    Return value invalid menu handle error.
  • #define ERR_INVALID_POS -5
    Return value invalid postion error.
  • #define ERR_INVALID_ID -6
    Return value invalid id error.
  • #define ERR_RES_ALLOCATION -7
    Return value allocation resource error .
  • #define ERR_CTRLCLASS_INVNAME -8
    Return value invalid name of control class error.
  • #define ERR_CTRLCLASS_INVLEN -9
    Return value control class invalid length.
  • #define ERR_CTRLCLASS_MEM -10
    Return value control class memory error.
  • #define ERR_CTRLCLASS_INUSE -11
    Return value inuse control class error.
  • #define ERR_ALREADY_EXIST -12
    Return value already exit error.
  • #define ERR_NO_MATCH -13
    Return no match error.
  • #define ERR_BAD_OWNER -14
    Return bad owner error.
  • #define ERR_IME_TOOMUCHIMEWND -15
    Return value too much IME window error.
  • #define ERR_IME_NOSUCHIMEWND -16
    Return value no such IME wondow error.
  • #define ERR_IME_NOIMEWND -17
    Return value no IME wondow error.
  • #define ERR_CONFIG_FILE -18
    Return value configure file error.
  • #define ERR_FILE_IO -19
    Return value file I/O error.
  • #define ERR_GFX_ENGINE -20
    Return value GFX engine error.
  • #define ERR_INPUT_ENGINE -21
    Return value input engine error.
  • #define ERR_NO_ENGINE -22
    Return value no engine error.
  • #define ERR_INVALID_ARGS -23
    Return value invalid arguments.

Define Documentation

#define ERR_ALREADY_EXIST -12

Return value already exit error.

Definition at line 1308 of file common.h.

#define ERR_BAD_OWNER -14

Return bad owner error.

Definition at line 1320 of file common.h.

#define ERR_CONFIG_FILE -18

Return value configure file error.

Definition at line 1344 of file common.h.

#define ERR_CTRLCLASS_INUSE -11

Return value inuse control class error.

Definition at line 1302 of file common.h.

#define ERR_CTRLCLASS_INVLEN -9

Return value control class invalid length.

Definition at line 1290 of file common.h.

#define ERR_CTRLCLASS_INVNAME -8

Return value invalid name of control class error.

Definition at line 1284 of file common.h.

#define ERR_CTRLCLASS_MEM -10

Return value control class memory error.

Definition at line 1296 of file common.h.

#define ERR_FILE_IO -19

Return value file I/O error.

Definition at line 1350 of file common.h.

#define ERR_GFX_ENGINE -20

Return value GFX engine error.

Definition at line 1356 of file common.h.

#define ERR_IME_NOIMEWND -17

Return value no IME wondow error.

Definition at line 1338 of file common.h.

#define ERR_IME_NOSUCHIMEWND -16

Return value no such IME wondow error.

Definition at line 1332 of file common.h.

#define ERR_IME_TOOMUCHIMEWND -15

Return value too much IME window error.

Definition at line 1326 of file common.h.

#define ERR_INPUT_ENGINE -21

Return value input engine error.

Definition at line 1362 of file common.h.

#define ERR_INV_HWND -1

Return value invalid window handle error.

Definition at line 1242 of file common.h.

#define ERR_INVALID_ARGS -23

Return value invalid arguments.

Definition at line 1374 of file common.h.

#define ERR_INVALID_HANDLE -3

Return value invalid handle error.

Definition at line 1254 of file common.h.

#define ERR_INVALID_HMENU -4

Return value invalid menu handle error.

Definition at line 1260 of file common.h.

#define ERR_INVALID_ID -6

Return value invalid id error.

Definition at line 1272 of file common.h.

#define ERR_INVALID_POS -5

Return value invalid postion error.

Definition at line 1266 of file common.h.

#define ERR_NO_ENGINE -22

Return value no engine error.

Definition at line 1368 of file common.h.

#define ERR_NO_MATCH -13

Return no match error.

Definition at line 1314 of file common.h.

#define ERR_OK 0

Return value error ok.

Definition at line 1236 of file common.h.

#define ERR_QUEUE_FULL -2

Return value queue is full error.

Definition at line 1248 of file common.h.

#define ERR_RES_ALLOCATION -7

Return value allocation resource error .

Definition at line 1278 of file common.h.

Generated on Fri Dec 17 13:49:45 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Miscellaneous macros

Miscellaneous macros
[Macros and data types commonly used]

Defines

  • #define TABLESIZE(table) (sizeof(table)/sizeof(table[0]))
    A macro returns the number of elements in a table.
  • #define MAX(x, y) (((x) > (y))?(x):(y))
    A macro returns the maximum of x and y.
  • #define MIN(x, y) (((x) < (y))?(x):(y))
    A macro returns the minimum of x and y.
  • #define ABS(x) (((x)<0) ? -(x) : (x))
    A macro returns the absolute value of x.
  • #define MAX_PATH PATH_MAX
    The possible maximal length of a path name.
  • #define MAX_NAME NAME_MAX
    The possible maximal length of a file name.

Define Documentation

#define ABS ( x ) (((x)<0) ? -(x) : (x))

A macro returns the absolute value of x.

Definition at line 1408 of file common.h.

#define MAX | ( | x,
 |  | y | ) | (((x) > (y))?(x):(y))

A macro returns the maximum of x and y.

Definition at line 1394 of file common.h.

#define MAX_NAME NAME_MAX

The possible maximal length of a file name.

Note:
This definition is an alias of NAME_MAX

Definition at line 1440 of file common.h.

#define MAX_PATH PATH_MAX

The possible maximal length of a path name.

Note:
This definition is an alias of PATH_MAX

Definition at line 1431 of file common.h.

#define MIN | ( | x,
 |  | y | ) | (((x) < (y))?(x):(y))

A macro returns the minimum of x and y.

Definition at line 1401 of file common.h.

#define TABLESIZE ( table ) (sizeof(table)/sizeof(table[0]))

A macro returns the number of elements in a table.

Definition at line 1386 of file common.h.

Generated on Fri Dec 17 13:49:45 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Styles of ANIMATION control

Styles of ANIMATION control
[ANIMATION control and animation GIF (GIF87a/GIF89a) support]

Defines

  • #define ANS_AUTOLOOP 0x0001L
    Loop playing the animation automatically.
  • #define ANS_SCALED 0x0002L
    Scale the animation to the control size.
  • #define ANS_FITTOANI 0x0004L
    Resize the control to fit the animation.

Detailed Description

This control can be used to play the animation object, and you should specify the animation object when you create the control by using the dwAddData:

  HWND hwnd;
  ANIMATION* anim = CreateAnimationFromGIF89aFile (HDC_SCREEN, "banner.gif");

  if (anim == NULL)
      goto error;

  hwnd = CreateWindow (CTRL_ANIMATION,
                    "",
                    WS_VISIBLE | ANS_AUTOLOOP,
                    100,
                    10, 10, 300, 200, hWnd, (DWORD)anim);
  SendMessage (hwnd, ANM_STARTPLAY, 0, 0);

Define Documentation

#define ANS_AUTOLOOP 0x0001L

Loop playing the animation automatically.

Definition at line 206 of file animation.h.

#define ANS_FITTOANI 0x0004L

Resize the control to fit the animation.

Definition at line 218 of file animation.h.

#define ANS_SCALED 0x0002L

Scale the animation to the control size.

Definition at line 212 of file animation.h.

Generated on Fri Dec 17 13:49:45 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Messages of ANIMATION control

Messages of ANIMATION control
[ANIMATION control and animation GIF (GIF87a/GIF89a) support]

Defines

  • #define ANM_SETANIMATION 0xF110
    Sets the animation object for the control.
  • #define ANM_GETANIMATION 0xF111
    Gets the animation object of the control.
  • #define ANM_STARTPLAY 0xF112
    Indicates the control to start playing the animation.
  • #define ANM_PAUSE_RESUME 0xF113
    Indicates the control to pause/resume playing the animation.
  • #define ANM_STOPPLAY 0xF114
    Indicates the control to stop playing the animation.

Define Documentation

#define ANM_GETANIMATION 0xF111

Gets the animation object of the control.

An application can send ANM_GETANIMATION to retrive the animation object of a control.

 ANM_GETANIMATION

 wParam = 0;
 lParam = 0;

Returns:
The current animation object of the control.

Definition at line 260 of file animation.h.

#define ANM_PAUSE_RESUME 0xF113

Indicates the control to pause/resume playing the animation.

An application can send ANM_PAUSE_RESUME to an animation control to pause/resume playing the animation.

 ANM_PAUSE_RESUME

 wParam = 0;
 lParam = 0;

Returns:
Always be zero.

Definition at line 297 of file animation.h.

#define ANM_SETANIMATION 0xF110

Sets the animation object for the control.

An application can send ANM_SETANIMATION to set the animation object of a control.

 ANM_SETANIMATION
 ANIMATION* anim;

 wParam = 0;
 lParam = (LPARAM)anim;

Returns:
The old animation object.

Definition at line 243 of file animation.h.

#define ANM_STARTPLAY 0xF112

Indicates the control to start playing the animation.

The animation will not be played when create the control, an application should send ANM_STARTPLAY to an animation control to start playing the animation.

 ANM_STARTPLAY

 wParam = 0;
 lParam = 0;

Returns:
Always be zero.

Definition at line 279 of file animation.h.

#define ANM_STOPPLAY 0xF114

Indicates the control to stop playing the animation.

An application can send ANM_STOPPLAY to an animation control to stop playing the animation. The control will display the first frame of the animation.

 ANM_STOPPLAY

 wParam = 0;
 lParam = 0;

Returns:
Always be zero.

Definition at line 316 of file animation.h.

Generated on Fri Dec 17 13:49:45 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Notification code of ANIMATION control

Notification code of ANIMATION control
[ANIMATION control and animation GIF (GIF87a/GIF89a) support]

Defines

  • #define ANNC_CLICKED 1
    Indicates the user has clicked the control.
  • #define ANNC_DBLCLK 2
    Indicates the user has double clicked the control.

Define Documentation

#define ANNC_CLICKED 1

Indicates the user has clicked the control.

Definition at line 330 of file animation.h.

#define ANNC_DBLCLK 2

Indicates the user has double clicked the control.

Definition at line 336 of file animation.h.

Generated on Fri Dec 17 13:49:45 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: ANIMATION control and animation GIF (GIF87a/GIF89a) support

ANIMATION control and animation GIF (GIF87a/GIF89a) support
[Standard controls]

Modules

  • Styles of ANIMATION control
  • Messages of ANIMATION control
  • Notification code of ANIMATION control

Data Structures

  • struct _ANIMATIONFRAME
  • struct _ANIMATION

Defines

  • #define CTRL_ANIMATION ("Animation")
  • #define ANIMATION_OKAY 0
  • #define ANIMATION_ERR 1

Functions

  • ANIMATION * CreateAnimationFromGIF89a (HDC hdc, MG_RWops *area)
    Creates an ANIMATION obeject from a GIF 89a data source.
  • MG_EXPORT ANIMATION * CreateAnimationFromGIF89aFile (HDC hdc, const char *file)
    Creates an ANIMATION obeject from a GIF 89a file.
  • MG_EXPORT ANIMATION * CreateAnimationFromGIF89aMem (HDC hdc, const void *mem, int size)
    Creates an ANIMATION obeject from a GIF 89a memory data.
  • MG_EXPORT void DestroyAnimation (ANIMATION *anim, BOOL free_it)
    Destories an ANIMATION object.

Define Documentation

#define ANIMATION_ERR 1

Return values of ANIMATION control.

Definition at line 173 of file animation.h.

#define ANIMATION_OKAY 0

Return values of ANIMATION control.

Definition at line 171 of file animation.h.

#define CTRL_ANIMATION ("Animation")

Control class name of ANIMATION control.

Definition at line 168 of file animation.h.

Function Documentation

ANIMATION * CreateAnimationFromGIF89a | ( | HDC | hdc,
 |  | MG_RWops * | area
 | ) |  |

Creates an ANIMATION obeject from a GIF 89a data source.

This function load a GIF 89a graphic from the data source area, and create an ANIMATION object from the GIF 89a data.

Parameters:
hdc | The dc will be used to create BITMAP object for the animation frame.
area | The data source.
Returns:
This function returns an ANIMATION object when success, otherwise NULL.
See also:
DestroyAnimation, ANIMATION

ANIMATION * CreateAnimationFromGIF89aFile | ( | HDC | hdc,
 |  | const char * | file
 | ) |  |

Creates an ANIMATION obeject from a GIF 89a file.

This function load a GIF 89a graphic from the file file, and create an ANIMATION object.

Parameters:
hdc | The dc will be used to create BITMAP object for the animation frame.
file | The file name.
Returns:
This function returns an ANIMATION object when success, otherwise NULL.
See also:
DestroyAnimation, ANIMATION

ANIMATION * CreateAnimationFromGIF89aMem | ( | HDC | hdc,
 |  | const void * | mem,
 |  | int | size
 | ) |  |

Creates an ANIMATION obeject from a GIF 89a memory data.

This function load a GIF 89a graphic from the memory mem which is size long and create an ANIMATION object from the GIF 89a data.

Parameters:
hdc | The dc will be used to create BITMAP object for the animation frame.
mem | The pointer to the memory.
size | The size of the memory.
Returns:
This function returns an ANIMATION object when success, otherwise NULL.
See also:
DestroyAnimation, ANIMATION

void DestroyAnimation | ( | ANIMATION * | anim,
 |  | BOOL | free_it
 | ) |  |

Destories an ANIMATION object.

This function destroies the ANIMATION object anim, and free it if free_it is TRUE.

Parameters:
anim | Pointer to the ANIMATION object.
free_it | Specify whether free the object by calling free(3).
See also:
CreateAnimationFromGIF89a, ANIMATION

Generated on Fri Dec 17 13:49:45 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _ANIMATIONFRAME Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_ANIMATIONFRAME Struct Reference
[ANIMATION control and animation GIF (GIF87a/GIF89a) support]

#include <animation.h>

Data Fields

  • int disposal
  • int off_x
  • int off_y
  • unsigned int width
  • unsigned int height
  • unsigned int delay_time
  • HDC mem_dc
  • Uint8 * bits
  • struct _ANIMATIONFRAME * next
  • struct _ANIMATIONFRAME * prev

Detailed Description

Animation frame structure.

Definition at line 48 of file animation.h.

Field Documentation

int disposal

The disposal method (from GIF89a specification): Indicates the way in which the graphic is to be treated after being displayed.

  • 0
    No disposal specified. The decoder is not required to take any action.
  • 1
    Do not dispose. The graphic is to be left in place.
  • 2
    Restore to background color. The area used by the frame must be restored to the background color.
  • 3
    Restore to previous. The decoder is required to restore the area overwritten by the frmae with what was there prior to rendering the frame.

Definition at line 59 of file animation.h.

int off_x

The x-coordinate of top-left corner of the frame in whole animation screen.

Definition at line 61 of file animation.h.

int off_y

The y-coordinate of top-left corner of the frame in whole animation screen.

Definition at line 63 of file animation.h.

unsigned int width

The width of the frame.

Definition at line 65 of file animation.h.

unsigned int height

The height of the frame.

Definition at line 67 of file animation.h.

unsigned int delay_time

The time of the frame will be display, in the unit of animation time_unit.

Definition at line 70 of file animation.h.

HDC mem_dc

The memdc compatible with the gif image.

Definition at line 72 of file animation.h.

Uint8* bits

The bits of the mem_dc, should be freed after deleting the mem_dc.

Definition at line 74 of file animation.h.

struct _ANIMATIONFRAME* next [read]

The next frame

Definition at line 77 of file animation.h.

struct _ANIMATIONFRAME* prev [read]

The previous frame

Definition at line 79 of file animation.h.

The documentation for this struct was generated from the following file:
  • animation.h
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _ANIMATION Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_ANIMATION Struct Reference
[ANIMATION control and animation GIF (GIF87a/GIF89a) support]

#include <animation.h>

Data Fields

  • unsigned int width
  • unsigned int height
  • RGB bk
  • int nr_frames
  • int time_unit
  • ANIMATIONFRAME * frames

Detailed Description

Animation structure

Definition at line 83 of file animation.h.

Field Documentation

unsigned int width

The width of the animation.

Definition at line 86 of file animation.h.

unsigned int height

The height of the animation.

Definition at line 88 of file animation.h.

RGB bk

The background color

Definition at line 91 of file animation.h.

int nr_frames

The number of all frames.

Definition at line 94 of file animation.h.

int time_unit

The unit of the time will be used count the delay time of every frame. The default is 1, equal to 10ms.

Definition at line 99 of file animation.h.

ANIMATIONFRAME* frames

Pointer to the animation frame.

Definition at line 101 of file animation.h.

The documentation for this struct was generated from the following file:
  • animation.h
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Styles of button control

Styles of button control
[Button control]

Defines

  • #define BS_PUSHBUTTON 0x00000000L
    Creates a push button that is a pane that displays either a piece of text or an image and when it is pressed it performs an action.
  • #define BS_DEFPUSHBUTTON 0x00000001L
    Creates a push button that behaves like a BS_PUSHBUTTON style button.
  • #define BS_CHECKBOX 0x00000002L
    Creates a check button is a button that can be either selected or deselected, and its selection is independent of the selections of any other buttons.
  • #define BS_AUTOCHECKBOX 0x00000003L
    Creates a button that is almost the same as a check box.
  • #define BS_RADIOBUTTON 0x00000004L
    Creates a radio button that can be either selected or deselected, but when selecting it any other buttons in its group will be cleared.
  • #define BS_AUTORADIOBUTTON 0x00000005L
    Creates a button that is almost the same as a radio button.
  • #define BS_3STATE 0x00000006L
    Creates a button that is almost the same as a check box.
  • #define BS_AUTO3STATE 0x00000007L
    Creates a button that is almost the same as a three-state check box.
  • #define BS_OWNERDRAW 0x0000000AL
    Creates an owner-drawn button.
  • #define BS_TYPEMASK 0x0000000FL
    The type mask of style of button.
  • #define BS_TEXT 0x00000000L
    Specifies that the button displays text.
  • #define BS_LEFTTEXT 0x00000020L
    Places text on the left side.
  • #define BS_ICON 0x00000040L
    Specifies that the button displays an icon.
  • #define BS_BITMAP 0x00000080L
    Specifies that the button displays a bitmap.
  • #define BS_CONTENTMASK 0x000000F0L
    The content mask of style of button.
  • #define BS_LEFT 0x00000100L
    Left-justifies the text in the button rectangle.
  • #define BS_RIGHT 0x00000200L
    Right-justifies text in the button rectangle.
  • #define BS_CENTER 0x00000300L
    Centers text horizontally in the button rectangle.
  • #define BS_TOP 0x00000400L
    Places text at the top of the button rectangle.
  • #define BS_BOTTOM 0x00000800L
    Places text at the bottom of the button rectangle.
  • #define BS_VCENTER 0x00000C00L
    Places text in the middle (vertically) of the button rectangle.
  • #define BS_REALSIZEIMAGE 0x00000F00L
    Does not scale the image.
  • #define BS_ALIGNMASK 0x00000F00L
    The alignment mask of style of button.
  • #define BS_PUSHLIKE 0x00001000L
    Makes a button look and act like a push button.
  • #define BS_MULTLINE 0x00002000L
    Wraps the button text to multiple lines.
  • #define BS_NOTIFY 0x00004000L
    Enables a button to send notification messages to its parent window.
  • #define BS_CHECKED 0x00004000L
    Makes a button checked initially.
  • #define BS_FLAT 0x00008000L
    The flat style of button.
  • #define BS_NOBORDER 0x00010000L
    The no border style of button.
  • #define BS_RIGHTBUTTON BS_LEFTTEXT
    The right style of button.

Define Documentation

#define BS_3STATE 0x00000006L

Creates a button that is almost the same as a check box.

Creates a button that is the same as a check box, except that the box can be grayed as well as checked or unchecked. Use the grayed state to show that the state of the check box is not determined.

Definition at line 141 of file button.h.

#define BS_ALIGNMASK 0x00000F00L

The alignment mask of style of button.

Definition at line 258 of file button.h.

#define BS_AUTO3STATE 0x00000007L

Creates a button that is almost the same as a three-state check box.

Creates a button that is the same as a three-state check box, except that the box changes its state when the user selects it. The state cycles through checked, grayed, and unchecked.

Definition at line 151 of file button.h.

#define BS_AUTOCHECKBOX 0x00000003L

Creates a button that is almost the same as a check box.

Creates a button that is the same as a check box, except that the check state automatically toggles between checked and unchecked each time the user selects the check box.

Definition at line 105 of file button.h.

#define BS_AUTORADIOBUTTON 0x00000005L

Creates a button that is almost the same as a radio button.

Creates a button that is the same as a radio button, except that when the user selects it, The system automatically sets the button's check state to checked and automatically sets the check state for all other buttons in the same group to unchecked.

Definition at line 130 of file button.h.

#define BS_BITMAP 0x00000080L

Specifies that the button displays a bitmap.

Definition at line 197 of file button.h.

#define BS_BOTTOM 0x00000800L

Places text at the bottom of the button rectangle.

Definition at line 240 of file button.h.

#define BS_CENTER 0x00000300L

Centers text horizontally in the button rectangle.

Definition at line 228 of file button.h.

#define BS_CHECKBOX 0x00000002L

Creates a check button is a button that can be either selected or deselected, and its selection is independent of the selections of any other buttons.

By default, the text is displayed to the right of the check box. To display the text to the left of the check box, combine this flag with the BS_LEFTTEXT style (or with the equivalent BS_RIGHTBUTTON style).

Definition at line 95 of file button.h.

#define BS_CHECKED 0x00004000L

Makes a button checked initially.

Definition at line 289 of file button.h.

#define BS_CONTENTMASK 0x000000F0L

The content mask of style of button.

Definition at line 202 of file button.h.

#define BS_DEFPUSHBUTTON 0x00000001L

Creates a push button that behaves like a BS_PUSHBUTTON style button.

Creates a push button that behaves like a BS_PUSHBUTTON style button, but also has a heavy black border. If the button is in a dialog box, the user can select the button by pressing the enter key, even when the button does not have the input focus. This style is useful for enabling the user to quickly select the most likely (default) option.

Definition at line 83 of file button.h.

#define BS_FLAT 0x00008000L

The flat style of button.

Definition at line 295 of file button.h.

#define BS_ICON 0x00000040L

Specifies that the button displays an icon.

Definition at line 191 of file button.h.

#define BS_LEFT 0x00000100L

Left-justifies the text in the button rectangle.

However, if the button is a check box or radio button that does not have the BS_RIGHTBUTTON style, the text is left justified on the right side of the check box or radio button.

Definition at line 212 of file button.h.

#define BS_LEFTTEXT 0x00000020L

Places text on the left side.

Places text on the left side of the radio button or check box when combined with a radio button or check box style.

Definition at line 185 of file button.h.

#define BS_MULTLINE 0x00002000L

Wraps the button text to multiple lines.

Wraps the button text to multiple lines if the text string is too long to fit on a single line in the button rectangle.

Definition at line 277 of file button.h.

#define BS_NOBORDER 0x00010000L

The no border style of button.

Definition at line 301 of file button.h.

#define BS_NOTIFY 0x00004000L

Enables a button to send notification messages to its parent window.

Definition at line 283 of file button.h.

#define BS_OWNERDRAW 0x0000000AL

Creates an owner-drawn button.

Note:
Not implemented so far.

Definition at line 164 of file button.h.

#define BS_PUSHBUTTON 0x00000000L

Creates a push button that is a pane that displays either a piece of text or an image and when it is pressed it performs an action.

Definition at line 70 of file button.h.

#define BS_PUSHLIKE 0x00001000L

Makes a button look and act like a push button.

Makes a button (such as a check box, three-state check box, or radio button) look and act like a push button. The button looks raised when it isn't pushed or checked, and sunken when it is pushed or checked.

Definition at line 268 of file button.h.

#define BS_RADIOBUTTON 0x00000004L

Creates a radio button that can be either selected or deselected, but when selecting it any other buttons in its group will be cleared.

By default, the text is displayed to the right of the circle. To display the text to the left of the circle, combine this flag with the BS_LEFTTEXT style (or with the equivalent BS_RIGHTBUTTON style). Use radio buttons for groups of related, but mutually exclusive choices.

Definition at line 118 of file button.h.

#define BS_REALSIZEIMAGE 0x00000F00L

Does not scale the image.

Definition at line 252 of file button.h.

#define BS_RIGHT 0x00000200L

Right-justifies text in the button rectangle.

However, if the button is a check box or radio button that does not have the BS_RIGHTBUTTON style, the text is right justified on the right side of the check box or radio button.

Definition at line 222 of file button.h.

#define BS_RIGHTBUTTON BS_LEFTTEXT

The right style of button.

See also:
BS_LEFTTEXT

Definition at line 308 of file button.h.

#define BS_TEXT 0x00000000L

Specifies that the button displays text.

Definition at line 176 of file button.h.

#define BS_TOP 0x00000400L

Places text at the top of the button rectangle.

Definition at line 234 of file button.h.

#define BS_TYPEMASK 0x0000000FL

The type mask of style of button.

Definition at line 170 of file button.h.

#define BS_VCENTER 0x00000C00L

Places text in the middle (vertically) of the button rectangle.

Definition at line 246 of file button.h.

Generated on Fri Dec 17 13:49:45 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: States of button control

States of button control
[Button control]

Defines

  • #define BST_POSE_MASK 0x0003
    The pose(normal, hilite, pushed and disable) mask of status of button.
  • #define BST_NORMAL 0x0000
    Specifies the normal state.
  • #define BST_HILITE 0x0001
    Specifies the hilite state.
  • #define BST_PUSHED 0x0002
    Specifies the pushed state.
  • #define BST_DISABLE 0x0003
    Specifies the disable state.
  • #define BST_CHECK_MASK 0x000c
    The check(unchecked, checked and indeterminate) mask of status of button.
  • #define BST_UNCHECKED 0x0000
    Indicates the button is unchecked.
  • #define BST_CHECKED 0x0004
    Indicates the button is checked.
  • #define BST_INDETERMINATE 0x0008
    Indicates the button is grayed because the state of the button is indeterminate.
  • #define BST_FOCUS 0x0010
    Specifies the focus state.

Define Documentation

#define BST_CHECK_MASK 0x000c

The check(unchecked, checked and indeterminate) mask of status of button.

Definition at line 354 of file button.h.

#define BST_CHECKED 0x0004

Indicates the button is checked.

Definition at line 366 of file button.h.

#define BST_DISABLE 0x0003

Specifies the disable state.

Definition at line 346 of file button.h.

#define BST_FOCUS 0x0010

Specifies the focus state.

Definition at line 379 of file button.h.

#define BST_HILITE 0x0001

Specifies the hilite state.

Definition at line 334 of file button.h.

#define BST_INDETERMINATE 0x0008

Indicates the button is grayed because the state of the button is indeterminate.

Definition at line 373 of file button.h.

#define BST_NORMAL 0x0000

Specifies the normal state.

Definition at line 328 of file button.h.

#define BST_POSE_MASK 0x0003

The pose(normal, hilite, pushed and disable) mask of status of button.

Definition at line 322 of file button.h.

#define BST_PUSHED 0x0002

Specifies the pushed state.

Definition at line 340 of file button.h.

#define BST_UNCHECKED 0x0000

Indicates the button is unchecked.

Definition at line 360 of file button.h.

Generated on Fri Dec 17 13:49:45 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Messages of button control

Messages of button control
[Button control]

Defines

  • #define BM_GETCHECK 0xF0F0
    Retrieves the check state of a radio button or check box.
  • #define BM_SETCHECK 0xF0F1
    Sets the check state of a radio button or check box.
  • #define BM_GETSTATE 0xF0F2
    Gets the state of a button or check box.
  • #define BM_SETSTATE 0xF0F3
    Sets the state of a button.
  • #define BM_SETSTYLE 0xF0F4
    Changes the style of a button.
  • #define BM_CLICK 0xF0F5
    Simulates the user clicking a button.
  • #define BM_ENABLE 0xF0F6
    enable or disable the button. If it is disabled, it can receive mouse and key messages but don't response them
  • #define BM_GETIMAGE 0xF0F7
    Retrieves the handle to the image.
  • #define BM_SETIMAGE 0xF0F8
    Associates a new image (icon or bitmap) with the button.

Define Documentation

#define BM_CLICK 0xF0F5

Simulates the user clicking a button.

An application sends a BM_CLICK message to simulate the user clicking a button.

 BM_CLICK

 wParam = 0;
 lParam = 0;

Definition at line 516 of file button.h.

#define BM_ENABLE 0xF0F6

enable or disable the button. If it is disabled, it can receive mouse and key messages but don't response them

 BM_CLICK

 wParam = (BOOL)enable;
 lParam = 0;
Parameters:
enable TRUE--enable the button FALSE--disable the button.
Returns:
Always be zero.

Definition at line 535 of file button.h.

#define BM_GETCHECK 0xF0F0

Retrieves the check state of a radio button or check box.

An application sends a BM_GETCHECK message to retrieve the check state of a radio button or check box.

 BM_GETCHECK
 wParam = 0;
 lParam = 0;

Returns:
An integer indicates whether the button is checked.
Return values:
BST_UNCHECKED | The button is not checked.
BST_CHECKED | The button is checked.
BST_INDETERMINATE | The button is grayed because the state of the button is indeterminate.
See also:
States of button control

Definition at line 409 of file button.h.

#define BM_GETIMAGE 0xF0F7

Retrieves the handle to the image.

An application sends a BM_GETIMAGE message to retrieve a handle to the image (icon or bitmap) associated with the button.

 BM_GETIMAGE
 int image_type;

 wParam = (WPARAM)&image_type;
 lParam = 0;

Parameters:
image_type The type of a button image will be returned through this buferr. It can be one of the following values:
  • BM_IMAGE_BITMAP
    Bitmap of a button.
  • BM_IMAGE_ICON
    Icon of a button.
Returns:
A handle of the bitmap or icon of the button, zero when error.

Definition at line 561 of file button.h.

#define BM_GETSTATE 0xF0F2

Gets the state of a button or check box.

An application sends a BM_GETSTATE message to determine the state of a button or check box.

 BM_GETSTATE
 wParam = 0;
 lParam = 0;

Returns:
An integer indicates the button state.
See also:
States of button control

Definition at line 454 of file button.h.

#define BM_SETCHECK 0xF0F1

Sets the check state of a radio button or check box.

An application sends a BM_SETCHECK message to set the check state of a radio button or check box.

 BM_SETCHECK
 int check_state;

 wParam = (WPARAM)check_state;
 lParam = 0;

Parameters:
check_state The check state of button, can be one of the following values:
  • BST_UNCHECKED
    Want the button to be unchecked.
  • BST_CHECKED
    Want the button to be checked.
  • BST_INDETERMINATE
    Want the button to be grayed if it is a three states button.
Returns:
The old button state.

Definition at line 435 of file button.h.

#define BM_SETIMAGE 0xF0F8

Associates a new image (icon or bitmap) with the button.

An application sends a BM_SETIMAGE message to associate a new image (icon or bitmap) with the button.

Please use BM_IMAGE_BITMAP or BM_IMAGE_ICON as the first parameter of the message to indicate the type of button control image:

  • BM_IMAGE_BITMAP
    Specifies the type of image to associate with the button to be a bitmap.
  • BM_IMAGE_ICON
    Specifies the type of image to associate with the button to be an icon.

Definition at line 580 of file button.h.

#define BM_SETSTATE 0xF0F3

Sets the state of a button.

An application sends a BM_SETSTATE message to set the state of a button.

 BM_SETSTATE
 int push_state;

 wParam = (WPARAM)push_state;
 lParam = 0;

Parameters:
push_state The push state of a button, can be one of the following values:
  • Zero
    Want the button to be unpushed.
  • Non zero
    Want the button to be pushed.
Returns:
The old button state.

Definition at line 479 of file button.h.

#define BM_SETSTYLE 0xF0F4

Changes the style of a button.

An application sends a BM_SETSTYLE message to change the style of a button.

 BM_SETSTYLE
 int button_style;

 wParam = (WPARAM)button_style;
 lParam = 0;

Parameters:
button_style The styles of a button.
Returns:
Always be zero.
See also:
Styles of button control

Definition at line 501 of file button.h.

Generated on Fri Dec 17 13:49:45 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Notification codes of button control

Notification codes of button control
[Button control]

Defines

  • #define BN_CLICKED 0
    The BN_CLICKED notification message is sent when the user clicks a button.
  • #define BN_DBLCLK BN_DOUBLECLICKED
    The BN_DBLCLK notification message is sent when the user double-clicks a button.
  • #define BN_HILITE 2
    The BN_HILITE notification message is sent when the user hilite a button (the user moves the mouse onto it).
  • #define BN_UNHILITE 3
    The BN_UNHILITE notification message is sent when the user unhilite a button, (the user moves the mouse leaving it).
  • #define BN_PUSHED 4
    The BN_PUSHED notification message is sent when the user pushes a button.
  • #define BN_UNPUSHED 5
    The BN_UNPUSHED notification message is sent when the user unpushes a button.
  • #define BN_DISABLE 6
    The BN_DISABLE notification message is sent when the user disables a button. (the user sends BM_ENABLE(wParam == FALSE) to it).
  • #define BN_ENABLE 7
    The BN_DISABLE notification message is sent when the user disables a button. (the user sends BM_ENABLE(wParam == TRUE) to it).
  • #define BN_SETFOCUS 8
    The BN_SETFOCUS notification message is sent when a button receives the keyboard focus.
  • #define BN_KILLFOCUS 9
    The BN_KILLFOCUS notification message is sent when a button loses the keyboard focus.

Define Documentation

#define BN_CLICKED 0

The BN_CLICKED notification message is sent when the user clicks a button.

Definition at line 595 of file button.h.

#define BN_DBLCLK BN_DOUBLECLICKED

The BN_DBLCLK notification message is sent when the user double-clicks a button.

Definition at line 601 of file button.h.

#define BN_DISABLE 6

The BN_DISABLE notification message is sent when the user disables a button. (the user sends BM_ENABLE(wParam == FALSE) to it).

Definition at line 634 of file button.h.

#define BN_ENABLE 7

The BN_DISABLE notification message is sent when the user disables a button. (the user sends BM_ENABLE(wParam == TRUE) to it).

Definition at line 641 of file button.h.

#define BN_HILITE 2

The BN_HILITE notification message is sent when the user hilite a button (the user moves the mouse onto it).

Definition at line 608 of file button.h.

#define BN_KILLFOCUS 9

The BN_KILLFOCUS notification message is sent when a button loses the keyboard focus.

Definition at line 653 of file button.h.

#define BN_PUSHED 4

The BN_PUSHED notification message is sent when the user pushes a button.

Definition at line 621 of file button.h.

#define BN_SETFOCUS 8

The BN_SETFOCUS notification message is sent when a button receives the keyboard focus.

Definition at line 647 of file button.h.

#define BN_UNHILITE 3

The BN_UNHILITE notification message is sent when the user unhilite a button, (the user moves the mouse leaving it).

Definition at line 615 of file button.h.

#define BN_UNPUSHED 5

The BN_UNPUSHED notification message is sent when the user unpushes a button.

Definition at line 627 of file button.h.

Generated on Fri Dec 17 13:49:45 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Button control

Button control
[Standard controls]

Modules

  • Styles of button control
  • States of button control
  • Messages of button control
  • Notification codes of button control

Defines

  • #define BTN_WIDTH_BORDER 4
    The width of button border.
  • #define CTRL_BUTTON ("button")
    The class name of button control.

Define Documentation

#define BTN_WIDTH_BORDER 4

The width of button border.

Definition at line 51 of file button.h.

#define CTRL_BUTTON ("button")

The class name of button control.

Definition at line 57 of file button.h.

Generated on Fri Dec 17 13:49:45 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Styles of combobox control

Styles of combobox control
[ComboBox control]

Defines

  • #define CBS_SIMPLE 0x0000L
    Displays the list box at all times.
  • #define CBS_AUTOSPIN 0x0001L
    Creates AutoSpin box.
  • #define CBS_SPINLIST 0x0002L
    Creates SpinList box.
  • #define CBS_DROPDOWNLIST 0x0003L
    Specifies a drop-down list box in the selection filed.
  • #define CBS_TYPEMASK 0x0007L
    The type mask of style of combobox.
  • #define CBS_NOTIFY 0x0008L
    Notifies the parent window.
  • #define CBS_SPINARROW_TOPBOTTOM 0x0010L
    The spin arrow.
  • #define CBS_SPINARROW_LEFTRIGHT 0x0020L
    The spin arrow.
  • #define CBS_AUTOHSCROLL 0x0040L
    This style is reserved.
  • #define CBS_DISABLENOSCROLL 0x0080L
    This style is reserved.
  • #define CBS_SORT 0x0100L
    Automatically sorts strings entered in the list box.
  • #define CBS_AUTOLOOP 0x0200L
    Loops the value automatically if the type of combobox is CBS_AUTOSPIN.
  • #define CBS_EDITNOBORDER 0x0400L
    The edit box has no border.
  • #define CBS_EDITBASELINE 0x0800L
    The edit box has base line.
  • #define CBS_READONLY 0x1000L
    The edit field is read-only.
  • #define CBS_UPPERCASE 0x2000L
    The edit field is uppercase.
  • #define CBS_LOWERCASE 0x4000L
    The edit field is lowercase.
  • #define CBS_AUTOFOCUS 0x8000L
    The edit field will gain the focus automatically.

Define Documentation

#define CBS_AUTOFOCUS 0x8000L

The edit field will gain the focus automatically.

Definition at line 197 of file combobox.h.

#define CBS_AUTOHSCROLL 0x0040L

This style is reserved.

Definition at line 142 of file combobox.h.

#define CBS_AUTOLOOP 0x0200L

Loops the value automatically if the type of combobox is CBS_AUTOSPIN.

Definition at line 161 of file combobox.h.

#define CBS_AUTOSPIN 0x0001L

Creates AutoSpin box.

AutoSpin box has an input field with a spin button. The input field displays an integer, and you can click spin button to increase or decrease the value of the integer.

Definition at line 83 of file combobox.h.

#define CBS_DISABLENOSCROLL 0x0080L

This style is reserved.

Definition at line 149 of file combobox.h.

#define CBS_DROPDOWNLIST 0x0003L

Specifies a drop-down list box in the selection filed.

Note:
The argument dwAddData of CreateWindowEx function should be the expected height of the list box.
 int listbox_height = 100;

 CreateWindowEx (CTRL_COMBOBOX, ..., listbox_height));

Definition at line 108 of file combobox.h.

#define CBS_EDITBASELINE 0x0800L

The edit box has base line.

Definition at line 173 of file combobox.h.

#define CBS_EDITNOBORDER 0x0400L

The edit box has no border.

Definition at line 167 of file combobox.h.

#define CBS_LOWERCASE 0x4000L

The edit field is lowercase.

Definition at line 191 of file combobox.h.

#define CBS_NOTIFY 0x0008L

Notifies the parent window.

Causes the combo box to notify the parent window with a notification message.

Definition at line 123 of file combobox.h.

#define CBS_READONLY 0x1000L

The edit field is read-only.

Definition at line 179 of file combobox.h.

#define CBS_SIMPLE 0x0000L

Displays the list box at all times.

The current selection in the list box is displayed in the edit control.

Note:
The argument dwAddData of CreateWindowEx function should be the expected height of the list box.
 int listbox_height = 100;

 CreateWindowEx (CTRL_COMBOBOX, ..., listbox_height);

Definition at line 73 of file combobox.h.

#define CBS_SORT 0x0100L

Automatically sorts strings entered in the list box.

Definition at line 155 of file combobox.h.

#define CBS_SPINARROW_LEFTRIGHT 0x0020L

The spin arrow.

Definition at line 135 of file combobox.h.

#define CBS_SPINARROW_TOPBOTTOM 0x0010L

The spin arrow.

Definition at line 129 of file combobox.h.

#define CBS_SPINLIST 0x0002L

Creates SpinList box.

SpinList box has an input field with a spin button. The input field displays some text, and you can click spin button to change the text. The candidate text string comes from the strings you add to the box.

Definition at line 93 of file combobox.h.

#define CBS_TYPEMASK 0x0007L

The type mask of style of combobox.

Definition at line 114 of file combobox.h.

#define CBS_UPPERCASE 0x2000L

The edit field is uppercase.

Definition at line 185 of file combobox.h.

Generated on Fri Dec 17 13:49:45 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Messages of combobox control

Messages of combobox control
[ComboBox control]

Defines

  • #define CB_GETEDITSEL 0xF140
    Gets the starting and ending character positions of the current selection.
  • #define CB_LIMITTEXT 0xF141
    Limits the length of text in the edit control.
  • #define CB_SETEDITSEL 0xF142
    Sets the starting and ending character positions of the current selection.
  • #define CB_ADDSTRING 0xF143
    Adds a string to the list box of a combo box.
  • #define CB_DELETESTRING 0xF144
    Deletes a string in the list box of a combo box.
  • #define CB_GETCOUNT 0xF146
    Retreives the number of items in the list box of a combo box.
  • #define CB_GETCURSEL 0xF147
    Retreives the index of the currently selected item in the list box.
  • #define CB_GETLBTEXT 0xF148
    Retreives the string of an item in the list box.
  • #define CB_GETLBTEXTLEN 0xF149
    Gets the string length of an item in the list box.
  • #define CB_INSERTSTRING 0xF14A
    Inserts a string to the list box of a combo box.
  • #define CB_RESETCONTENT 0xF14B
    Removes all items from the list box and edit control.
  • #define CB_FINDSTRING 0xF14C
    Searchs the list box for an item beginning with the characters in a specified string.
  • #define CB_SETCURSEL 0xF14E
    Selects a string in the list of a combo box.
  • #define CB_GETITEMADDDATA 0xF150
    Retreives the application-supplied 32-bit value associated with the specified item.
  • #define CB_SETITEMADDDATA 0xF151
    Sets a 32-bit data value with the specified item.
  • #define CB_GETDROPPEDCONTROLRECT 0xF152
    Retreives the screen coordinates of the dropdown list box of a combo box.
  • #define CB_SETITEMHEIGHT 0xF153
    Sets the height of all items of the list box in a combo box.
  • #define CB_GETITEMHEIGHT 0xF154
    Gets the height of items of the list box in a combo box.
  • #define CB_GETDROPPEDSTATE 0xF157
    Determines whether the list box of a combo box is dropped down.
  • #define CB_FINDSTRINGEXACT 0xF158
    Searchs the list box for an item that matches the specified string.
  • #define CB_SETSPINFORMAT 0xF162
    Sets the format string of value for CBS_AUTOSPIN type.
  • #define CB_SETSPINRANGE 0xF163
    Determines the range of the spin box in a combo box.
  • #define CB_GETSPINRANGE 0xF164
    Gets the range of the spin box in a combo box.
  • #define CB_SETSPINVALUE 0xF165
    Determines the value of the spin box in a combo box.
  • #define CB_GETSPINVALUE 0xF166
    Gets the current value of the spin box in a combo box.
  • #define CB_SETSPINPACE 0xF167
    Determines the pace and the fast pace of the spin box in a combo box.
  • #define CB_GETSPINPACE 0xF168
    Gets the pace and the fast pace of the spin box in a combo box.
  • #define CB_SPIN 0xF170
    Spins the value of the spin box or auto spin box.
  • #define CB_FASTSPIN 0xF171
    Fast spins the value of the spin box or auto spin box.
  • #define CB_SETSTRCMPFUNC 0xF172
    Sets the STRCMP function used to sort items.
  • #define CB_GETCHILDREN 0xF173
    Gets the handles to the children of a ComboBox control.

Define Documentation

#define CB_ADDSTRING 0xF143

Adds a string to the list box of a combo box.

An application sends a CB_ADDSTRING message to add a string to the list box of a combo box.

 CB_ADDSTRING
 char* string;

 wParam = 0;
 lParam = (LPARAM)string;

Parameters:
string Pointer to the null-terminated string to be added.
Returns:
The index of the new item on success, else the one of the following error codes:
  • CB_ERRSPACE No memory can be allocated for new item.
  • CB_ERR Invalid passed arguments.

Definition at line 300 of file combobox.h.

#define CB_DELETESTRING 0xF144

Deletes a string in the list box of a combo box.

An application sends a CB_DELETESTRING message to delete a string in the list box of a combo box.

 CB_DELETESTRING
 int index;

 wParam = (WPARAM)index;
 lParam = 0;

Parameters:
index Specifies the index of the string to delete.
Returns:
If succeed, return zero; otherwise CB_ERR.

Definition at line 321 of file combobox.h.

#define CB_FASTSPIN 0xF171

Fast spins the value of the spin box or auto spin box.

 CB_FASTSPIN

 int direct

 wParam = (WPARAM)direct;
 lParam = 0;

Parameters:
direct Indicats the direct of the spin. Zero means up, non-zero down.
Returns:
Always be CB_OKAY.

Definition at line 822 of file combobox.h.

#define CB_FINDSTRING 0xF14C

Searchs the list box for an item beginning with the characters in a specified string.

An application sends a CB_FINDSTRING message to search the list box for an item beginning with the characters in a specified string.

 CB_FINDSTRING
 int indexStart;
 char* string;

 wParam = (WPARAM)indexStart;
 lParam = (LPARAM)string;

Parameters:
indexStart | Index of the item preceding the first item to be searched.
string | Pointer to the null-terminated string that contains the prefix to search for.
Returns:
The index of the matching item or CB_ERR to indicate not found.

Definition at line 477 of file combobox.h.

#define CB_FINDSTRINGEXACT 0xF158

Searchs the list box for an item that matches the specified string.

An application sends a CB_FINDSTRINGEXACT message to search the list box for an item that matches a specified string.

 CB_FINDSTRINGEXACT
 int indexStart;
 char* string;

 wParam = (WPARAM)indexStart;
 lParam = (LPARAM)string;

Parameters:
indexStart | Index of the item preceding the first item to be searched.
string | Pointer to the null-terminated string to search for.
Returns:
The index of the matching item; otherwise CB_ERR to indicate not found.

Definition at line 642 of file combobox.h.

#define CB_GETCHILDREN 0xF173

Gets the handles to the children of a ComboBox control.

An application sends a CB_GETCHILDREN message to get the handles to the children of a ComboBox control.

 CB_GETCHILDREN

 HWND *wnd_edit, *wnd_listbox;

 wParam = (WPARAM)wnd_edit;
 lParam = (LPARAM)wnd_listbox;

Parameters:
wnd_edit | The buffer saving the handle to the edit box of the ComboBox control.
wnd_list | The buffer saving the handle to the list box of the ComboBox control. If the ComboBox have type of CBS_AUTOSPIN, handle to the list box will be 0.
Returns:
Always be CB_OKAY.

Definition at line 879 of file combobox.h.

#define CB_GETCOUNT 0xF146

Retreives the number of items in the list box of a combo box.

An application sends a CB_GETCOUNT message to retreive the number of items in the list box of a combo box.

 CB_GETCOUNT

 wParam = 0;
 lParam = 0;

Returns:
The number of items in the list box.

Definition at line 341 of file combobox.h.

#define CB_GETCURSEL 0xF147

Retreives the index of the currently selected item in the list box.

An application sends a CB_GETCURSEL message to retreive the index of the currently selected item in the list box of a combo box.

 CB_GETCURSEL

 wParam = 0;
 lParam = 0;

Returns:
The index of currently selected item in the list box if have one; otherwise CB_ERR.

Definition at line 360 of file combobox.h.

#define CB_GETDROPPEDCONTROLRECT 0xF152

Retreives the screen coordinates of the dropdown list box of a combo box.

 CB_GETDROPPEDCONTROLRECT
 RECT *rect;

 wParam = 0;
 lParam = (LPARAM)rect;

Parameters:
rect Pointer to the RECT structure used to save the coordinates.

Definition at line 564 of file combobox.h.

#define CB_GETDROPPEDSTATE 0xF157

Determines whether the list box of a combo box is dropped down.

 CB_GETIDROPSTATE

 wParam = 0;
 lParam = 0;

Returns:
If the list box is visible, the return value is TRUE; otherwise, it is FALSE.

Definition at line 619 of file combobox.h.

#define CB_GETEDITSEL 0xF140

Gets the starting and ending character positions of the current selection.

An application sends a CB_GETEDITSEL message to get the starting and ending character positions of the current selection in the edit control of a combo box.

 CB_GETEDITSEL
 int start;
 int end;

 wParam = (WPARAM)&start;
 lParam = (LPARAM)&end;

Parameters:
start | Pointer to a 32-bit value that receives the starting position of the selection.
end | Pointer to a 32-bit value that receives the ending position of the selection.
Note:
Not implemented yet.

Definition at line 230 of file combobox.h.

#define CB_GETITEMADDDATA 0xF150

Retreives the application-supplied 32-bit value associated with the specified item.

An application sends an CB_GETITEMADDDATA message to retrive the 32-bit data value associated with with an item in the list box of the combo box.

 CB_GETITEMADDDATA
 int index;

 wParam = (WPARAM)index;
 lParam = 0;

Parameters:
index The index of the item.
Returns:
The 32-bit data value associated with an item on success, otherwise CB_ERR to indicate an error.

Definition at line 522 of file combobox.h.

#define CB_GETITEMHEIGHT 0xF154

Gets the height of items of the list box in a combo box.

 CB_GETITEMHEIGHT

 wParam = 0;
 lParam = 0;

Returns:
The height of item in the list box.

Definition at line 600 of file combobox.h.

#define CB_GETLBTEXT 0xF148

Retreives the string of an item in the list box.

An application sends a CB_GETLBTEXT message to retreive the string of a specified item in the list box of a combo box.

 CB_GETLBTEXT
 int index;
 char* string;

 wParam = (WPARAM)index;
 lParam = (LPARAM)string;

Parameters:
index | The index of the selected item.
string | Pointer to the string buffer.
Returns:
One of the following values:
  • CB_OKAY
    Success.
  • CB_ERR
    Invalid item index.

Definition at line 385 of file combobox.h.

#define CB_GETLBTEXTLEN 0xF149

Gets the string length of an item in the list box.

An application sends a CB_GETLBTEXTLEN message to get the string length of a specified item in the list box of a combo box.

 CB_GETLBTEXTLEN
 int index;

 wParam = (WPARAM)index;
 lParam = 0;

Parameters:
index The index of the specified item.
Returns:
The length of the string on success; otherwise CB_ERR.

Definition at line 406 of file combobox.h.

#define CB_GETSPINPACE 0xF168

Gets the pace and the fast pace of the spin box in a combo box.

 CB_GETSPINPACE
 int *spin_pace;
 int *spin_fastpace;

 wParam = (WPARAM)spin_pace;
 lParam = (LPARAM)spin_fastpace;

Parameters:
spin_pace | Pointer to the data to retreive the new pace value of the spin box.
spin_fastpace | Pointer to the data to retreive the new fast pace value of the spin box.
Returns:
Always be CB_OKAY.

Definition at line 784 of file combobox.h.

#define CB_GETSPINRANGE 0xF164

Gets the range of the spin box in a combo box.

 CB_GETSPINRANGE
 int *spin_min;
 int *spin_max;

 wParam = (WPARAM)spin_min;
 lParam = (LPARAM)spin_max;

Parameters:
spin_min | The minimum value of the spin box.
spin_max | The maximum value of the spin box.
Returns:
Always be CB_OKAY.

Definition at line 711 of file combobox.h.

#define CB_GETSPINVALUE 0xF166

Gets the current value of the spin box in a combo box.

 CB_GETSPINVALUE

 wParam = 0;
 lParam = 0;

Returns:
The current value of the spin box.

Definition at line 744 of file combobox.h.

#define CB_INSERTSTRING 0xF14A

Inserts a string to the list box of a combo box.

An application sends a CB_INSERTSTRING message to insert a string to the list box of a combo box. Unlike the CB_ADDSTRING message, the CB_INSERTSTRING message do not cause a list to be sorted.

 CB_INSERTSTRING
 int index;
 char* string;

 wParam = (WPARAM)index;
 lParam = (LPARAM)string;

Parameters:
index | The index of the position at which to insert the string.
string | Pointer to the null-terminated string to be added.
Returns:
The index of the new item on success, else the one of the following error codes:
  • CB_ERRSPACE No memory can be allocated for new item.
  • CB_ERR Invalid passed arguments.

Definition at line 434 of file combobox.h.

#define CB_LIMITTEXT 0xF141

Limits the length of text in the edit control.

An application sends a CB_LIMITTEXT message to limit the length of the text the user may type into the edit control of a combo box.

 CB_LIMITTEXT
 int newLimit;

 wParam = (WPARAM)newLimit;
 lParam = 0;

Parameters:
newLimit Specifies the maximum number of characters the user can enter.
Returns:
The return value is always zero.

Definition at line 251 of file combobox.h.

#define CB_RESETCONTENT 0xF14B

Removes all items from the list box and edit control.

An application sends a CB_RESETCONTENT message remove all items from the list box and edit control of a combo box.

 CB_RESETCONTENT

 wParam = 0;
 lParam = 0;

Returns:
Always be zero.

Definition at line 452 of file combobox.h.

#define CB_SETCURSEL 0xF14E

Selects a string in the list of a combo box.

 CB_SETCURLSEL
 int index;

 wParam = (WPARAM)index;
 lParam = 0;

Parameters:
index The index of the string to select.
Returns:
CB_OKAY on success; otherwise CB_ERR to indicate an invalid index.

Definition at line 497 of file combobox.h.

#define CB_SETEDITSEL 0xF142

Sets the starting and ending character positions of the current selection.

An application sends a CB_SETEDITSEL message to set the starting and ending character positions of the current selection in the edit control of a combo box.

 CB_SETEDITSEL
 int start;
 int end;

 wParam = (WPARAM)start;
 lParam = (LPARAM)end;

Parameters:
start | The starting position of the selection.
end | The ending position of the selection.
Note:
Not implemented yet.

Definition at line 275 of file combobox.h.

#define CB_SETITEMADDDATA 0xF151

Sets a 32-bit data value with the specified item.

An application sends an CB_SETITEMADDDATA message to associate a 32-bit data value specified in the lParam parameter with an item in the list box that is specified in the wParam parameter.

 CB_SETITEMADDDATA
 int index;
 DWORD addData;

 wParam = (WPARAM)index;
 lParam = (LPARAM)addData;

Parameters:
index | The index of the specified item.
addData | the 32-bit data value which will associated with the item.
Returns:
One of the following values:
  • CB_OKAY
    Success
  • CB_ERR
    Invalid item index

Definition at line 548 of file combobox.h.

#define CB_SETITEMHEIGHT 0xF153

Sets the height of all items of the list box in a combo box.

An application sends an CB_SETITEMHEIGHT message to set the height of all items of the list box in a combo box.

 CB_SETITEMHEIGHT
 int itemHeight;

 wParam = 0;
 lParam = (LPARAM)itemHeight;

Parameters:
itemHeight New height of item of the list box.
Returns:
The effective height of item of the list box.

Definition at line 585 of file combobox.h.

#define CB_SETSPINFORMAT 0xF162

Sets the format string of value for CBS_AUTOSPIN type.

 CB_SETSPINFORMAT
 const char* format;

 wParam = 0;
 lParam = (LPARAM)format;

Parameters:
format A format string can be used by sprintf function to format an interger.
Returns:
CB_OKAY on success; otherwise CB_ERR.

Definition at line 671 of file combobox.h.

#define CB_SETSPINPACE 0xF167

Determines the pace and the fast pace of the spin box in a combo box.

 CB_SETSPINPACE
 int new_pace;
 int new_fastpace;

 wParam = (WPARAM)new_pace;
 lParam = (LPARAM)new_fastpace;

Parameters:
new_pace | The new pace value of the spin box.
new_fastpace | The new fast pace value of the spin box.
Returns:
Always be CB_OKAY.

Definition at line 764 of file combobox.h.

#define CB_SETSPINRANGE 0xF163

Determines the range of the spin box in a combo box.

 CB_SETSPINRANGE
 int new_min;
 int new_max;

 wParam = (WPARAM)new_min;
 lParam = (LPARAM)new_max;

Parameters:
new_min | The new minimum value of the spin box.
new_max | The new maximum value of the spin box.
Returns:
CB_OKAY on success; otherwise CB_ERR to indicate invalid parameters.

Definition at line 691 of file combobox.h.

#define CB_SETSPINVALUE 0xF165

Determines the value of the spin box in a combo box.

 CB_SETSPINVALUE
 int new_value;

 wParam = (WPARAM)new_value;
 lParam = 0;

Parameters:
new_value The new value of the spin box.
Returns:
CB_OKAY on success; otherwise CB_ERR to indicate invalid parameters.

Definition at line 729 of file combobox.h.

#define CB_SETSTRCMPFUNC 0xF172

Sets the STRCMP function used to sort items.

An application sends a CB_SETSTRCMPFUNC message to set a new STRCMP function to sort items in the combo-box.

Note that you should send this message before adding any item to the combo-box control.

 static int my_strcmp (const char* s1, const char* s2, size_t n)
 {
      ...
      return 0;
 }

 CB_SETSTRCMPFUNC

 wParam = 0;
 lParam = (LPARAM) my_strcmp;

Parameters:
my_strcmp Your own function to compare two strings.
Returns:
One of the following values:
  • CB_OKAY
    Success
  • CB_ERR
    This combobox has no list box or it is not an empty list box.

Definition at line 855 of file combobox.h.

#define CB_SPIN 0xF170

Spins the value of the spin box or auto spin box.

 CB_SPIN

 int direct;

 wParam = (WPARAM)direct;
 lParam = 0;

Parameters:
direct Indicats the direct of the spin. Zero means up, non-zero down.
Returns:
Always be CB_OKAY.

Definition at line 803 of file combobox.h.

Generated on Fri Dec 17 13:49:45 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Notification codes of combobox control

Notification codes of combobox control
[ComboBox control]

Defines

  • #define CBN_SELCHANGE 1
    Notifies the change of the current selection.
  • #define CBN_DBLCLK 2
    Notifies the user has double clicked an item.
  • #define CBN_SETFOCUS 3
    Notifies the box has gained the input focus.
  • #define CBN_KILLFOCUS 4
    Notifies the box has lost the input focus.
  • #define CBN_EDITCHANGE 5
    Notifies the change of the text in the edit control.
  • #define CBN_DROPDOWN 7
    Notifies the list box has been dropped down.
  • #define CBN_CLOSEUP 8
    Notifies the list box has been closed up.
  • #define CBN_SELECTOK 9
    Notifies the selection of a list item.
  • #define CBN_SELECTCANCEL 10
    Notifies that the selection of a list item is ignored.
  • #define CBN_CLICKED 11
    Notifies that the user has clicked combo box.

Define Documentation

#define CBN_CLICKED 11

Notifies that the user has clicked combo box.

The CBN_CLICKED notification code is sent when the user has clicked combo box.

Definition at line 976 of file combobox.h.

#define CBN_CLOSEUP 8

Notifies the list box has been closed up.

Definition at line 950 of file combobox.h.

#define CBN_DBLCLK 2

Notifies the user has double clicked an item.

A combo box created with the CBS_NOTIFY style sends an CBN_DBLCLK notification message to its parent window when the user double-clicks a string in its listbox.

Definition at line 915 of file combobox.h.

#define CBN_DROPDOWN 7

Notifies the list box has been dropped down.

Definition at line 944 of file combobox.h.

#define CBN_EDITCHANGE 5

Notifies the change of the text in the edit control.

The CBN_EDITCHANGE notification code is sent when the user has taken an action that may have altered the text in the edit control portion of a combo box.

Definition at line 936 of file combobox.h.

#define CBN_KILLFOCUS 4

Notifies the box has lost the input focus.

Definition at line 927 of file combobox.h.

#define CBN_SELCHANGE 1

Notifies the change of the current selection.

The CBN_SELCHANGE notification code is sent when the user changes the current selection in the list box of a combo box.

Definition at line 906 of file combobox.h.

#define CBN_SELECTCANCEL 10

Notifies that the selection of a list item is ignored.

The CBN_SELECTCANCEL notification code is sent when the user has selected a list item but then selects another control or closes the dialog box.

Definition at line 968 of file combobox.h.

#define CBN_SELECTOK 9

Notifies the selection of a list item.

The CBN_SELECTOK notification code is sent when the user has selected a list item.

Definition at line 959 of file combobox.h.

#define CBN_SETFOCUS 3

Notifies the box has gained the input focus.

Definition at line 921 of file combobox.h.

Generated on Fri Dec 17 13:49:45 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: ComboBox control

ComboBox control
[Standard controls]

Modules

  • Styles of combobox control
  • Messages of combobox control
  • Notification codes of combobox control

Defines

  • #define CTRL_COMBOBOX ("combobox")
    The class name of combobox control.
  • #define CB_OKAY LB_OKAY
  • #define CB_ERR LB_ERR
  • #define CB_ERRSPACE LB_ERRSPACE

Define Documentation

#define CB_ERR LB_ERR

Combo Box return error value

Definition at line 888 of file combobox.h.

#define CB_ERRSPACE LB_ERRSPACE

Combo Box return space error value

Definition at line 890 of file combobox.h.

#define CB_OKAY LB_OKAY

Combo Box return ok value

Definition at line 886 of file combobox.h.

#define CTRL_COMBOBOX ("combobox")

The class name of combobox control.

Definition at line 51 of file combobox.h.

Generated on Fri Dec 17 13:49:45 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Styles of coolbar control

Styles of coolbar control
[CoolBar control]

Defines

  • #define CBS_BMP_16X16 0x0000
    The size of the item bitmap is 16x16.
  • #define CBS_BMP_32X32 0x0001
    The size of the item bitmap is 32x32.
  • #define CBS_BMP_CUSTOM 0x0002
    The item bitmap has customized size.
  • #define CBS_USEBKBMP 0x0004
    The control has a background bitmap.

Define Documentation

#define CBS_BMP_16X16 0x0000

The size of the item bitmap is 16x16.

Definition at line 115 of file coolbar.h.

#define CBS_BMP_32X32 0x0001

The size of the item bitmap is 32x32.

Definition at line 121 of file coolbar.h.

#define CBS_BMP_CUSTOM 0x0002

The item bitmap has customized size.

Note:
For the control with this style, you should pass the width and the height of the item bitmap by the argument dwAddData of CreateWindowEx function.
 int item_width = 20;
 int item_height = 20;

 CreateWindowEx (CTRL_COOLBAR, ..., MAKELONG (item_width, item_height)));

Definition at line 138 of file coolbar.h.

#define CBS_USEBKBMP 0x0004

The control has a background bitmap.

Note:
For a CoolBar control with this style, you should pass the bitmap file name by the argument spCaption of CreateWindowEx function.
 const char* file_bkgnd = "res/my_bkgnd.gif";

 CreateWindowEx (CTRL_COOLBAR, file_bkgnd, ...);

Definition at line 153 of file coolbar.h.

Generated on Fri Dec 17 13:49:45 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Messages of coolbar control

Messages of coolbar control
[CoolBar control]

Defines

  • #define CBM_ADDITEM 0xFE00
    Adds a new item in a coolbar control.
  • #define CBM_ENABLE 0xFE01
    Sets an item to be enabled or disabled.

Define Documentation

#define CBM_ADDITEM 0xFE00

Adds a new item in a coolbar control.

 CBM_ADDITEM
 COOLBARITEMINFO *newIteminfo;

 wParam = 0;
 lParam = (LPARAM)newIteminfo;

Parameters:
newIteminfo Pointer to the item info structure of the new item to be added.
Returns:
Zero when success, otherwise less than 0;

Definition at line 179 of file coolbar.h.

#define CBM_ENABLE 0xFE01

Sets an item to be enabled or disabled.

 CBM_ENABLE
 int id;
 BOOL enabled;

 wParam = (WPARAM)id;
 lParam = (LPARAM)enabled;

Parameters:
id | The identifier of the item to change.
enabled | TRUE to enable the item, FALSE to disable the item.
Returns:
Zero when success, otherwise less than 0.

Definition at line 199 of file coolbar.h.

Generated on Fri Dec 17 13:49:45 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: CoolBar control

CoolBar control
[Standard controls]

Modules

  • Styles of coolbar control
  • Messages of coolbar control

Data Structures

  • struct _COOLBARITEMINFO

Defines

  • #define CTRL_COOLBAR ("CoolBar")
    The class name of coolbar control.

Typedefs

  • typedef COOLBARITEMINFO * PCOOLBARITEMINFO
    Data type of the pointer to a COOLBARITEMINFO.

Define Documentation

#define CTRL_COOLBAR ("CoolBar")

The class name of coolbar control.

Definition at line 51 of file coolbar.h.

Typedef Documentation

typedef struct COOLBARITEMINFO * PCOOLBARITEMINFO

Data type of the pointer to a COOLBARITEMINFO.

Definition at line 104 of file coolbar.h.

Generated on Fri Dec 17 13:49:45 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _COOLBARITEMINFO Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_COOLBARITEMINFO Struct Reference
[CoolBar control]

#include <coolbar.h>

Data Fields

  • int insPos
  • int id
  • int ItemType
  • PBITMAP Bmp
  • const char * ItemHint
  • const char * Caption
  • DWORD dwAddData

Detailed Description

Structure of the coolbar item info

Definition at line 58 of file coolbar.h.

Field Documentation

int insPos

Reserved, do not use.

Definition at line 61 of file coolbar.h.

int id

Identifier of the item. When the user clicked the item, this control will send a notification message to the parent window with the notification code to be equal to this identifier.

Definition at line 68 of file coolbar.h.

int ItemType

Type of the item, can be one of the following values:

  • TYPE_BARITEM The item is a separator (a vertical line).
  • TYPE_BMPITEM The item is a bitmap.
  • TYPE_TEXTITEM The item is text.

Definition at line 79 of file coolbar.h.

PBITMAP Bmp

Pointer to the bitmap of the item, valid when the type is TYPE_BMPITEM.

Definition at line 84 of file coolbar.h.

const char* ItemHint

Hint text of the item, will be displayed in the tooltip window.

Definition at line 89 of file coolbar.h.

const char* Caption

Caption of the item, valid when the type is TPYE_TEXTITEM.

Definition at line 94 of file coolbar.h.

DWORD dwAddData

Additional data of the item

Definition at line 97 of file coolbar.h.

The documentation for this struct was generated from the following file:
  • coolbar.h
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Styles of edit control

Styles of edit control
[Edit/MEdit control]

Defines

  • #define ES_LEFT 0x00000000L
    Left-aligned text.
  • #define ES_CENTER 0x00000001L
    Center-aligned text.
  • #define ES_RIGHT 0x00000002L
    Right-aligned text.
  • #define ES_MULTILINE 0x00000004L
    Multi-line text.
  • #define ES_UPPERCASE 0x00000008L
    Converts all characters to uppercase as they are typed into the edit control.
  • #define ES_LOWERCASE 0x00000010L
    Converts all characters to lowercase as they are typed into the edit control.
  • #define ES_PASSWORD 0x00000020L
    Displays an asterisk (*) for each character typed into the edit control.
  • #define ES_AUTOVSCROLL 0x00000040L
    Show and hide the vertical scroll bar automatically.
  • #define ES_AUTOHSCROLL 0x00000080L
    Show and hide the horizontal scroll bar automatically.
  • #define ES_NOHIDESEL 0x00000100L
    Edit control with this style will remain selected when focus is lost.
  • #define ES_AUTOSELECT 0x00000400L
    Selects all text when getting focus.
  • #define ES_READONLY 0x00000800L
    Prevents the user from typing or editing text in the edit control.
  • #define ES_BASELINE 0x00001000L
    Draws base line under input area instead of frame border.
  • #define ES_AUTOWRAP 0x00002000L
    Automatically wraps against border when inputting.
  • #define ES_TITLE 0x00004000L
    Shows specified title texts.
  • #define ES_TIP 0x00008000L
    Shows specified tip texts.

Define Documentation

#define ES_AUTOHSCROLL 0x00000080L

Show and hide the horizontal scroll bar automatically.

Definition at line 149 of file edit.h.

#define ES_AUTOSELECT 0x00000400L

Selects all text when getting focus.

Definition at line 161 of file edit.h.

#define ES_AUTOVSCROLL 0x00000040L

Show and hide the vertical scroll bar automatically.

Definition at line 143 of file edit.h.

#define ES_AUTOWRAP 0x00002000L

Automatically wraps against border when inputting.

Definition at line 180 of file edit.h.

#define ES_BASELINE 0x00001000L

Draws base line under input area instead of frame border.

Definition at line 174 of file edit.h.

#define ES_CENTER 0x00000001L

Center-aligned text.

Definition at line 107 of file edit.h.

#define ES_LEFT 0x00000000L

Left-aligned text.

Definition at line 101 of file edit.h.

#define ES_LOWERCASE 0x00000010L

Converts all characters to lowercase as they are typed into the edit control.

Definition at line 131 of file edit.h.

#define ES_MULTILINE 0x00000004L

Multi-line text.

Definition at line 119 of file edit.h.

#define ES_NOHIDESEL 0x00000100L

Edit control with this style will remain selected when focus is lost.

Definition at line 155 of file edit.h.

#define ES_PASSWORD 0x00000020L

Displays an asterisk (*) for each character typed into the edit control.

Definition at line 137 of file edit.h.

#define ES_READONLY 0x00000800L

Prevents the user from typing or editing text in the edit control.

Definition at line 168 of file edit.h.

#define ES_RIGHT 0x00000002L

Right-aligned text.

Definition at line 113 of file edit.h.

#define ES_TIP 0x00008000L

Shows specified tip texts.

Definition at line 192 of file edit.h.

#define ES_TITLE 0x00004000L

Shows specified title texts.

Definition at line 186 of file edit.h.

#define ES_UPPERCASE 0x00000008L

Converts all characters to uppercase as they are typed into the edit control.

Definition at line 125 of file edit.h.

Generated on Fri Dec 17 13:49:45 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Messages of edit control

Messages of edit control
[Edit/MEdit control]

Data Structures

  • struct _TEXTPOSINFO

Defines

  • #define EM_GETSEL 0xF0B0
    Gets the selected string in the edit control.
  • #define EM_SETSEL 0xF0B1
    Sets the selected point in the edit control and makes the text between insertion point and selection point selected.
  • #define EM_SETSELPOS EM_SETSEL
  • #define EM_SETSELECTION EM_SETSEL
  • #define EM_SELECTALL 0xF0B2
    Selects all the texts, the same meaning as ctrl+a.
  • #define EM_GETSELPOS 0xF0B3
    Gets the position of the selection point.
  • #define EM_INSERTCBTEXT 0xF0B4
    Inserts the text in the clipboard to the current caret position.
  • #define EM_COPYTOCB 0xF0B5
    Copies the currently selected text to the clipboard.
  • #define EM_CUTTOCB 0xF0B6
    Cuts the currently selected text to the clipboard.
  • #define EM_SETLFDISPCHAR 0xF0B7
    Sets the char used to represent the line seperator.
  • #define EM_SETLINESEP 0xF0B8
    Sets the line seperator.
  • #define EM_GETCARETPOS 0xF0B9
    Gets the position of the caret.
  • #define EM_SETCARETPOS 0xF0BA
    Sets the position of the caret.
  • #define EM_SETINSERTION EM_SETCARETPOS
  • #define EM_GETLINECOUNT 0xF0BC
    Gets the line number.
  • #define EM_GETLINEHEIGHT 0xF0BD
    Gets the height of a line.
  • #define EM_SETLINEHEIGHT 0xF0BE
    Sets the height of a line.
  • #define EM_LINESCROLL 0xF0BF
    reserved.
  • #define EM_INSERTTEXT 0xF0C0
    Inserts the specified text to the current caret position.
  • #define EM_LINELENGTH 0xF0C1
    reserved.
  • #define EM_REPLACESEL 0xF0C2
    reserved.
  • #define EM_GETMAXLIMIT 0xF0C3
    Get text limit of a single-line edit control.
  • #define EM_GETLINE 0xF0C4
    reserved.
  • #define EM_LIMITTEXT 0xF0C5
    Set text limit of an edit control.
  • #define EM_REDO 0xF0C6
    Redo operation.
  • #define EM_UNDO 0xF0C7
    Undo operation.
  • #define EM_FMTLINES 0xF0C8
    reserved.
  • #define EM_LINEFROMCHAR 0xF0C9
    reserved.
  • #define EM_SETTABSTOPS 0xF0CB
    reserved.
  • #define EM_SETPASSWORDCHAR 0xF0CC
    Defines the character that edit control uses in conjunction with the ES_PASSWORD style.
  • #define EM_SETREADONLY 0xF0CF
    Sets or removes the read-only style (ES_READONLY) in an edit control.
  • #define EM_SETDRAWSELECTFUNC 0xF0D0
    Sets the callback function on drawing selected chars.
  • #define EM_SETGETCARETWIDTHFUNC 0xF0D1
    Sets the callback function on getting caret width.
  • #define EM_GETPASSWORDCHAR 0xF0D2
    Returns the character that edit controls uses in conjunction with the ES_PASSWORD style.
  • #define EM_SETLIMITTEXT EM_LIMITTEXT
  • #define ED_CARETSHAPE_LINE 0
    Line-shaped caret.
  • #define ED_CARETSHAPE_BLOCK 1
    Block-shaped caret.
  • #define EM_CHANGECARETSHAPE 0xF0D3
    Changes the shape of the caret.
  • #define EM_REFRESHCARET 0xF0D4
    Refresh caret of the edit control.
  • #define EM_ENABLECARET 0xF0D5
    To enable or disable the input caret.
  • #define EM_GETLIMITTEXT 0xF0D6
    Get text limit value of the edit control.
  • #define EM_SETTITLETEXT 0xF0DC
    Sets the title text displayed before content text.
  • #define EM_GETTITLETEXT 0xF0DD
    Gets the title text displayed before content text.
  • #define EM_SETTIPTEXT 0xF0DE
    Sets the tip text displayed when content is empty.
  • #define EM_GETTIPTEXT 0xF0DF
    Gets the tip text displayed when content is empty.
  • #define EM_GETNUMOFPARAGRAPHS 0xF0E0
    Gets the number of paragraphs in textedit control.
  • #define EM_GETPARAGRAPHLENGTH 0xF0E1
    Gets the specified paragraph length in textedit control.
  • #define EM_GETPARAGRAPHTEXT 0xF0E2
    Gets the specified paragraph text from textedit control.
  • #define EM_SETCARETPOSBYLINE 0xF0D9
    Sets the selected point in the edit control and makes the text between insertion point and selection point selected. This is set by really line. That means if you set the TES_AUTOWRAP, the line number you set, the caret pos line number you see. This is different from EM_SETCARETPOS.
  • #define EM_GETCARETPOSBYLINE 0xF0DA
    Gets the position of the caret.
  • #define EM_SETSELPOSBYLINE 0xF0DB
  • #define EM_GETSELPOSBYLINE 0xF0E4
    Gets the position of the selection point.
  • #define EM_GETPARAGRAPHLENGTHINMCHAR 0xF0E5
    Gets the specified paragraph length in textedit control. in text not charactors.
  • #define EM_GETLINELENGTHINMCHAR 0xF0E6
    Gets the specified line length in textedit control. in charactors not byte.
  • #define EM_GETLINELENGTH 0xF0E7
    Gets the specified line length in textedit control.
  • #define EM_GETLINETEXT 0xF0E8
    Gets the specified line text from textedit control.

Typedefs

  • typedef int(* ED_DRAWSEL_FUNC )(HWND, HDC, int, int, const char *, int, int)
    Type of the edit control callback function on drawing selected strings.

Define Documentation

#define ED_CARETSHAPE_BLOCK 1

Block-shaped caret.

Definition at line 755 of file edit.h.

#define ED_CARETSHAPE_LINE 0

Line-shaped caret.

Definition at line 749 of file edit.h.

#define EM_CHANGECARETSHAPE 0xF0D3

Changes the shape of the caret.

 EM_CHANGECARETSHAPE

 int caret_shape;

 wParam = (WPARAM)caret_shape;
 lParam = 0;

Parameters:
caret_shape Shape index of the caret, can be ED_CARETSHAPE_LINE or ED_CARETSHAPE_BLOCK.
Returns:
The old create shape

Definition at line 774 of file edit.h.

#define EM_COPYTOCB 0xF0B5

Copies the currently selected text to the clipboard.

 EM_COPYTOCB

 wParam = 0;
 lParam = 0

Returns:
Length of the text which is really copied to clipboard.

Definition at line 331 of file edit.h.

#define EM_CUTTOCB 0xF0B6

Cuts the currently selected text to the clipboard.

 EM_CUTTOCB

 wParam = 0;
 lParam = 0

Returns:
Length of the text which is really copied to clipboard.

Definition at line 346 of file edit.h.

#define EM_ENABLECARET 0xF0D5

To enable or disable the input caret.

 EM_ENABLECARET

 BOOL bEnable;

 wParam = (WPARAM)bEnable;
 lParam = 0;

Parameters:
bEnable TRUE to enable caret.
Returns:
The previous caret enabled status.

Definition at line 799 of file edit.h.

#define EM_FMTLINES 0xF0C8

reserved.

Definition at line 609 of file edit.h.

#define EM_GETCARETPOS 0xF0B9

Gets the position of the caret.

 EM_GETCARETPOS
 int* line_pos;
 int* char_pos;

 wParam = (WPARAM)line_pos;
 lParam = (LPARAM)char_pos;

Parameters:
line_pos | Pointer to a integer buffer to save the caret line position. For single line editor, it is always zero. Note : Here "line" means a text string ended with a line seperator, not a single text line in wrap mode. So, char_pos means the character position in a text string.
char_pos | Pointer to a integer buffer to save the caret character position.
Returns:
The string length of the text from the beginning to the caret pos.

Definition at line 414 of file edit.h.

#define EM_GETCARETPOSBYLINE 0xF0DA

Gets the position of the caret.

 EM_GETCARETPOSBYLINE
 int* line_pos;
 int* char_pos;

 wParam = (WPARAM)line_pos;
 lParam = (LPARAM)char_pos;

Parameters:
line_pos | Pointer to a integer buffer to save the caret line position. For single line editor, it is always zero.
char_pos | Pointer to a integer buffer to save the caret character position.
Returns:
The string length of the text from the beginning to the caret pos.

Definition at line 1073 of file edit.h.

#define EM_GETLIMITTEXT 0xF0D6

Get text limit value of the edit control.

Returns:
-1 when user doesn't set limit value, otherwise return current limit value.

Definition at line 808 of file edit.h.

#define EM_GETLINE 0xF0C4

reserved.

Definition at line 558 of file edit.h.

#define EM_GETLINECOUNT 0xF0BC

Gets the line number.

 EM_GETLINECOUNT

 wParam = 0;
 lParam = 0;

Returns:
Line number on success, otherwise -1.
Note:
Implemented for TextEdit control.

Definition at line 464 of file edit.h.

#define EM_GETLINEHEIGHT 0xF0BD

Gets the height of a line.

 EM_GETLINEHEIGHT

 wParam = 0;
 lParam = 0;

Returns:
Height value.
Note:
Implemented for TextEdit control.

Definition at line 480 of file edit.h.

#define EM_GETLINELENGTH 0xF0E7

Gets the specified line length in textedit control.

 EM_GETLINELENGTH
 wParam = (WPARAM) index;

Returns:
The length of text.

Definition at line 1141 of file edit.h.

#define EM_GETLINELENGTHINMCHAR 0xF0E6

Gets the specified line length in textedit control. in charactors not byte.

 EM_GETLINELENGTHINMCHAR
 wParam = (WPARAM) index;

Returns:
The length of text.

Definition at line 1128 of file edit.h.

#define EM_GETLINETEXT 0xF0E8

Gets the specified line text from textedit control.

 EM_GETLINETEXT
 const char buffer[BUF_SIZE];
 TEXTPOSINFO info;

 info.start_pos = 0;
 info.copy_len = BUF_SIZE;
 info.buff = buffer;
 info.line_index = -1;

 wParam = (WPARAM)&info;

Returns:
The copied length of text which doesn't include terminate character 0x0.

Definition at line 1163 of file edit.h.

#define EM_GETMAXLIMIT 0xF0C3

Get text limit of a single-line edit control.

Definition at line 550 of file edit.h.

#define EM_GETNUMOFPARAGRAPHS 0xF0E0

Gets the number of paragraphs in textedit control.

Returns:
The number of paragraphs.

Definition at line 976 of file edit.h.

#define EM_GETPARAGRAPHLENGTH 0xF0E1

Gets the specified paragraph length in textedit control.

 EM_GETPARAGRAPHLENGTH
 wParam = (WPARAM) index;

Returns:
The length of text.

Definition at line 988 of file edit.h.

#define EM_GETPARAGRAPHLENGTHINMCHAR 0xF0E5

Gets the specified paragraph length in textedit control. in text not charactors.

 EM_GETPARAGRAPHLENGTHINCHAR
 wParam = (WPARAM) index;

Returns:
The length of text.

Definition at line 1114 of file edit.h.

#define EM_GETPARAGRAPHTEXT 0xF0E2

Gets the specified paragraph text from textedit control.

 EM_GETPARAGRAPHTEXT
 const char buffer[BUF_SIZE];
 TEXTPOSINFO info;

 info.start_pos = 0;
 info.copy_len = BUF_SIZE;
 info.buff = buffer;
 info.paragraph_index = -1;

 wParam = (WPARAM)&info;

Returns:
The copied length of text which doesn't include terminate character 0x0.

Definition at line 1009 of file edit.h.

#define EM_GETPASSWORDCHAR 0xF0D2

Returns the character that edit controls uses in conjunction with the ES_PASSWORD style.

 EM_GETPASSWORDCHAR

 wParam = 0;
 lParam = 0;

Returns:
The currently used password character

Definition at line 737 of file edit.h.

#define EM_GETSEL 0xF0B0

Gets the selected string in the edit control.

 EM_GETSEL

 char *buffer;
 int len;

 wParam = (WPARAM)len;
 lParam = (LPARAM)buffer;

Parameters:
len | Length of buffer.
buffer | Pointer to the string buffer
Returns:
Length of the selected string

Definition at line 220 of file edit.h.

#define EM_GETSELPOS 0xF0B3

Gets the position of the selection point.

 EM_GETSELPOS
 int* line_pos;
 int* char_pos;

 wParam = (WPARAM)line_pos;
 lParam = (LPARAM)char_pos;

Parameters:
line_pos | Pointer to a integer buffer to save the selection line position. For single line editor, it is always zero. Note : Here "line" means a text string ended with a line seperator, not a single text line in wrap mode. So, char_pos means the character position in a text string.
char_pos | Pointer to a integer buffer to save the selection character position.
Returns:
The string length of the text from the beginning to the selection point.

Definition at line 298 of file edit.h.

#define EM_GETSELPOSBYLINE 0xF0E4

Gets the position of the selection point.

 EM_GETSELPOSBYLINE
 int* line_pos;
 int* char_pos;

 wParam = (WPARAM)line_pos;
 lParam = (LPARAM)char_pos;

Parameters:
line_pos | Pointer to a integer buffer to save the selection line position. For single line editor, it is always zero.
char_pos | Pointer to a integer buffer to save the selection character position.
Returns:
The string length of the text from the beginning to the selection point.

Definition at line 1100 of file edit.h.

#define EM_GETTIPTEXT 0xF0DF

Gets the tip text displayed when content is empty.

 EM_GETTIPTEXT
 const char *buffer;
 int len;

 wParam = (WPARAM)len;
 lParam = (LPARAM)buffer;

Parameters:
len | Should be length of buffer minus 1, left space for '\0'
buffer | String buffer
Returns:
Length of tip text

Definition at line 948 of file edit.h.

#define EM_GETTITLETEXT 0xF0DD

Gets the title text displayed before content text.

 EM_GETTITLETEXT
 const char *buffer;
 int len;

 wParam = (WPARAM)len;
 lParam = (LPARAM)buffer;

Parameters:
len | Should be length of buffer minus 1, left space for '\0'
buffer | String buffer
Returns:
Length of title
Note:
Implemented for TextEdit control.

Definition at line 912 of file edit.h.

#define EM_INSERTCBTEXT 0xF0B4

Inserts the text in the clipboard to the current caret position.

 EM_INSERTCBTEXT
 int len;
 const char *string;

 wParam = (WPARAM)len;
 lParam = (LPARAM)string;

Parameters:
len | Length of string
string | Pointer to the text string

Definition at line 316 of file edit.h.

#define EM_INSERTTEXT 0xF0C0

Inserts the specified text to the current caret position.

Normally used to input a long string.

 EM_INSERTTEXT
 int len;
 const char *string;

 wParam = (WPARAM)len;
 lParam = (LPARAM)string;

Parameters:
len | Length of string
string | Pointer to the text string

Definition at line 528 of file edit.h.

#define EM_LIMITTEXT 0xF0C5

Set text limit of an edit control.

 EM_LIMITTEXT
 int newLimit;

 wParam = (WPARAM)newLimit;
 lParam = 0;

Parameters:
newLimit The new text limit of an edit control, by character.

Definition at line 574 of file edit.h.

#define EM_LINEFROMCHAR 0xF0C9

reserved.

Definition at line 617 of file edit.h.

#define EM_LINELENGTH 0xF0C1

reserved.

Definition at line 536 of file edit.h.

#define EM_LINESCROLL 0xF0BF

reserved.

Definition at line 508 of file edit.h.

#define EM_REDO 0xF0C6

Redo operation.

 wParam = 0;
 lParam = 0;

Definition at line 587 of file edit.h.

#define EM_REFRESHCARET 0xF0D4

Refresh caret of the edit control.

Definition at line 780 of file edit.h.

#define EM_REPLACESEL 0xF0C2

reserved.

Definition at line 544 of file edit.h.

#define EM_SELECTALL 0xF0B2

Selects all the texts, the same meaning as ctrl+a.

 EM_SELECTALL

 wParam = 0;
 lParam = 0;

Definition at line 274 of file edit.h.

#define EM_SETCARETPOS 0xF0BA

Sets the position of the caret.

 EM_SETCARETPOS
 int line_pos;
 int char_pos;

 wParam = (WPARAM)line_pos;
 lParam = (LPARAM)char_pos;

Parameters:
line_pos | The new caret line position. For single line editor, it will be ignored. Note : Here "line" means a text string ended with a line seperator, not a single text line in wrap mode. So, char_pos means the character position in a text string.
char_pos | The new caret character position.
Returns:
Length of the string from the beginning to the caret position on success, otherwise -1.

Definition at line 438 of file edit.h.

#define EM_SETCARETPOSBYLINE 0xF0D9

Sets the selected point in the edit control and makes the text between insertion point and selection point selected. This is set by really line. That means if you set the TES_AUTOWRAP, the line number you set, the caret pos line number you see. This is different from EM_SETCARETPOS.

 EM_SETCARETPOSBYLINE

 int line_pos;
 int char_pos;

 wParam = (WPARAM)line_pos;
 lParam = (LPARAM)char_pos;

Parameters:
line_pos | Line position of the selection point. For single line editor, it is always zero. Note : For multi-line editor, "line" means a text string ended with a line seperator, in wrap mode there also is the really line number. So, char_pos means the character position in a text string.
char_pos | Character(wide character) position of the selection point.
Returns:
Length of the selected string

Definition at line 1051 of file edit.h.

#define EM_SETDRAWSELECTFUNC 0xF0D0

Sets the callback function on drawing selected chars.

 EM_SETDRAWSELECTFUNC
 ED_DRAWSEL_FUNC drawsel;

 wParam = 0;
 lParam = (LPARAM)drawsel;

Parameters:
drawsel The callback function used to draw selected strings.

Definition at line 697 of file edit.h.

#define EM_SETGETCARETWIDTHFUNC 0xF0D1

Sets the callback function on getting caret width.

 EM_SETGETCARETWIDTHFUNC
 int (*get_caret_width) (HWND, int);

 wParam = 0;
 lParam = (LPARAM)get_caret_width;

Parameters:
get_caret_width The callback function used to get caret width. The window handle and the maximum caret width are passed as arguments.
Returns:
The desired caret width.

Definition at line 716 of file edit.h.

#define EM_SETINSERTION EM_SETCARETPOS

See also:
EM_SETCARETPOS

Definition at line 444 of file edit.h.

#define EM_SETLFDISPCHAR 0xF0B7

Sets the char used to represent the line seperator.

In default case, the line sperator will not be shown. If the char used to represent the line seperator is not zero, this char will be shown in place of line seperator.

 EM_SETLFDISPCHAR
 unsigned char ch;

 wParam = 0;
 lParam = ch;

Parameters:
ch The char used to represent the line seperator

Definition at line 366 of file edit.h.

#define EM_SETLIMITTEXT EM_LIMITTEXT

See also:
EM_LIMITTEXT

Definition at line 743 of file edit.h.

#define EM_SETLINEHEIGHT 0xF0BE

Sets the height of a line.

 EM_SETLINEHEIGHT

 wParam = (WPARAM)height;
 lParam = 0;

Returns:
The old height value.
Note:
Implemented for TextEdit control.

Definition at line 496 of file edit.h.

#define EM_SETLINESEP 0xF0B8

Sets the line seperator.

In default case, the line sperator is Line Feed characters(LF , ASCII 10, '
').

 EM_SETLINESEP
 unsigned char ch;

 wParam = 0;
 lParam = ch;

Parameters:
ch The new line seperator

Definition at line 385 of file edit.h.

#define EM_SETPASSWORDCHAR 0xF0CC

Defines the character that edit control uses in conjunction with the ES_PASSWORD style.

 EM_SETPASSWORDCHAR
 char passwdChar;

 wParam = (WPARAM)passwdChar;
 lParam = 0;

Definition at line 640 of file edit.h.

#define EM_SETREADONLY 0xF0CF

Sets or removes the read-only style (ES_READONLY) in an edit control.

 EM_SETREADONLY
 int readonly;

 wParam = (WPARAM)readonly;
 lParam = 0;

Parameters:
readonly Indicates whether the edit control is read-only:
  • Zero
    Not read-only.
  • Non zero
    Read-only.

Definition at line 665 of file edit.h.

#define EM_SETSEL 0xF0B1

Sets the selected point in the edit control and makes the text between insertion point and selection point selected.

Generally, you should send EM_SETCARETPOS first to set insertion point before you use EM_SETSEL to select text.

 EM_SETSEL

 int line_pos;
 int char_pos;

 wParam = (WPARAM)line_pos;
 lParam = (LPARAM)char_pos;

Parameters:
line_pos | Line position of the selection point. For single line editor, it is always zero. Note : For multi-line editor, "line" means a text string ended with a line seperator, not a single text line in wrap mode. So, char_pos means the character position in a text string.
char_pos | Character(wide character) position of the selection point.
Returns:
Length of the selected string

Definition at line 249 of file edit.h.

#define EM_SETSELECTION EM_SETSEL

See also:
EM_SETSEL

Definition at line 261 of file edit.h.

#define EM_SETSELPOS EM_SETSEL

See also:
EM_SETSEL

Definition at line 255 of file edit.h.

#define EM_SETSELPOSBYLINE 0xF0DB

See also:
EM_SETSELBYLINE

Definition at line 1079 of file edit.h.

#define EM_SETTABSTOPS 0xF0CB

reserved.

Definition at line 625 of file edit.h.

#define EM_SETTIPTEXT 0xF0DE

Sets the tip text displayed when content is empty.

 EM_SETTIPTEXT
 const char *buffer;
 int len;

 wParam = (WPARAM)len;
 lParam = (LPARAM)buffer;

Definition at line 928 of file edit.h.

#define EM_SETTITLETEXT 0xF0DC

Sets the title text displayed before content text.

 EM_SETTITLETEXT
 const char *title;
 int len;

 wParam = (WPARAM)len;
 lParam = (LPARAM)title;

Note:
Implemented for TextEdit control.

Definition at line 890 of file edit.h.

#define EM_UNDO 0xF0C7

Undo operation.

 wParam = 0;
 lParam = 0;

Definition at line 601 of file edit.h.

Typedef Documentation

typedef int(* ED_DRAWSEL_FUNC)(HWND hWnd, HDC hdc, int startx, int starty, const char *content, int len, int selout)

Type of the edit control callback function on drawing selected strings.

Parameters:
hWnd | Handle of the edit control.
startx | x value of the beginning drawing position.
starty | y value of the beginning drawing position.
content | The string which will be drawed.
len | Length of the string which should be drawed by this callback.
selout | Length of the selected string that have been drawed before calling this callback function.
Returns:
Width of the outputed strings.

Definition at line 680 of file edit.h.

Generated on Fri Dec 17 13:49:45 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _TEXTPOSINFO Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_TEXTPOSINFO Struct Reference
[Messages of edit control]

#include <edit.h>

Data Fields

  • int paragraph_index
  • int line_index
  • int start_pos
  • int copy_len
  • char * buff

Detailed Description

Structure defines text position information.

Definition at line 953 of file edit.h.

Field Documentation

int paragraph_index

The index of paragraph, if value is -1, it will take effect on the whole text.

Definition at line 956 of file edit.h.

int line_index

The index of line, if value is -1, it will take effect on the whole text.

Definition at line 959 of file edit.h.

int start_pos

The beginning byte position can be copied to the buffer.

Definition at line 961 of file edit.h.

int copy_len

The maximal number of bytes can be copied to the buffer. It includes terminate character 0x0.

Definition at line 964 of file edit.h.

char* buff

The pointer to a buffer receives the text. Please make sure buffer size is more than the value of copy_len.

Definition at line 967 of file edit.h.

The documentation for this struct was generated from the following file:
  • edit.h
Generated on Fri Dec 17 13:49:52 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Notification codes of edit control

Notification codes of edit control
[Edit/MEdit control]

Defines

  • #define EN_CLICKED 0x0001
    Notifies a click in an edit control.
  • #define EN_DBLCLK 0x0002
    Notifies a double click in an edit control.
  • #define EN_SETFOCUS 0x0100
    Notifies the receipt of the input focus.
  • #define EN_KILLFOCUS 0x0200
    Notifies the lost of the input focus.
  • #define EN_CHANGE 0x0300
    Notifies that the text is altered by the user.
  • #define EN_UPDATE 0x0400
    Notifies that the text is altered by sending MSG_SETTEXT TEM_RESETCONTENT, or EM_SETLINEHEIGHT message to it.
  • #define EN_MAXTEXT 0x0501
    Notifies reach of maximum text limitation.
  • #define EN_SELCHANGED 0x0603
    Notifies that the current selection is changed in the text field.
  • #define EN_CONTCHANGED 0x0604
    Notifies that the current content is changed in the text field when text edit losts focus.
  • #define EN_ENTER 0x0700
    Notifies the user has type the ENTER key in a single-line edit control.

Define Documentation

#define EN_CHANGE 0x0300

Notifies that the text is altered by the user.

An edit control sends the EN_CHANGE notification code when the user takes an action that may have altered text in an edit control.

Definition at line 1219 of file edit.h.

#define EN_CLICKED 0x0001

Notifies a click in an edit control.

An edit control sends the EN_CLICKED notification code when the user clicks in an edit control.

Definition at line 1183 of file edit.h.

#define EN_CONTCHANGED 0x0604

Notifies that the current content is changed in the text field when text edit losts focus.

Definition at line 1260 of file edit.h.

#define EN_DBLCLK 0x0002

Notifies a double click in an edit control.

An edit control sends the EN_CLICKED notification code when the user double clicks in an edit control.

Definition at line 1192 of file edit.h.

#define EN_ENTER 0x0700

Notifies the user has type the ENTER key in a single-line edit control.

Definition at line 1266 of file edit.h.

#define EN_KILLFOCUS 0x0200

Notifies the lost of the input focus.

The EN_KILLFOCUS notification code is sent when an edit control loses the input focus.

Definition at line 1210 of file edit.h.

#define EN_MAXTEXT 0x0501

Notifies reach of maximum text limitation.

The EN_MAXTEXT notification message is sent when the current text insertion has exceeded the specified number of characters for the edit control.

Definition at line 1241 of file edit.h.

#define EN_SELCHANGED 0x0603

Notifies that the current selection is changed in the text field.

Definition at line 1253 of file edit.h.

#define EN_SETFOCUS 0x0100

Notifies the receipt of the input focus.

The EN_SETFOCUS notification code is sent when an edit control receives the input focus.

Definition at line 1201 of file edit.h.

#define EN_UPDATE 0x0400

Notifies that the text is altered by sending MSG_SETTEXT TEM_RESETCONTENT, or EM_SETLINEHEIGHT message to it.

An edit control sends the EN_UPDATE notification code when the control received MSG_SETTEXT, TEM_RESETCONTENT, or EM_SETLINEHEIGHT message.

Note that this notification will occured when you call SetWindowText or SetDlgItemText function on the control.

Definition at line 1232 of file edit.h.

Generated on Fri Dec 17 13:49:45 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Edit/MEdit control

Edit/MEdit control
[Standard controls]

Modules

  • Styles of edit control
  • Messages of edit control
  • Notification codes of edit control

Defines

  • #define CTRL_EDIT ("edit")
    The class name of simple single-line editor box.
  • #define CTRL_SLEDIT ("sledit")
    The class name of single-line editor box.
  • #define CTRL_BIDISLEDIT ("bidisledit")
    The class name of BIDI single-line editor box.
  • #define CTRL_MLEDIT ("mledit")
    The class name of multiple-line editor box.
  • #define CTRL_MEDIT ("medit")
    Another class name of multiple-line editor box.
  • #define EC_LEFTMARGIN 0x0001
    Value of wParam. Specifies the left margins to set.
  • #define EC_RIGHTMARGIN 0x0002
    Value of wParam. Specifies the right margins to set.
  • #define EC_USEFONTINFO 0xffff
    Value of wParam. Specifies the user font info to set.
  • #define EMSIS_COMPOSITIONSTRING 0x0001
    Indicates the type of status to retrieve.
  • #define EIMES_GETCOMPSTRATONCE 0x0001
    lParam for EMSIS_COMPOSITIONSTRING(reserved).
  • #define EIMES_CANCELCOMPSTRINFOCUS 0x0002
    lParam for EMSIS_COMPOSITIONSTRING(reserved).
  • #define EIMES_COMPLETECOMPSTRKILLFOCUS 0x0004
    lParam for EMSIS_COMPOSITIONSTRING(reserved).

Define Documentation

#define CTRL_BIDISLEDIT ("bidisledit")

The class name of BIDI single-line editor box.

This edit control uses the system logical font for control, which may be variable-width font.

Definition at line 72 of file edit.h.

#define CTRL_EDIT ("edit")

The class name of simple single-line editor box.

This edit control uses the system default fixed logical font.

Definition at line 54 of file edit.h.

#define CTRL_MEDIT ("medit")

Another class name of multiple-line editor box.

This edit control uses the system logical font for control, which may be variable-width font.

Definition at line 90 of file edit.h.

#define CTRL_MLEDIT ("mledit")

The class name of multiple-line editor box.

This edit control uses the system logical font for control, which may be variable-width font.

Definition at line 81 of file edit.h.

#define CTRL_SLEDIT ("sledit")

The class name of single-line editor box.

This edit control uses the system logical font for control, which may be variable-width font.

Definition at line 63 of file edit.h.

#define EC_LEFTMARGIN 0x0001

Value of wParam. Specifies the left margins to set.

Definition at line 1275 of file edit.h.

#define EC_RIGHTMARGIN 0x0002

Value of wParam. Specifies the right margins to set.

Definition at line 1280 of file edit.h.

#define EC_USEFONTINFO 0xffff

Value of wParam. Specifies the user font info to set.

Definition at line 1285 of file edit.h.

#define EIMES_CANCELCOMPSTRINFOCUS 0x0002

lParam for EMSIS_COMPOSITIONSTRING(reserved).

Definition at line 1304 of file edit.h.

#define EIMES_COMPLETECOMPSTRKILLFOCUS 0x0004

lParam for EMSIS_COMPOSITIONSTRING(reserved).

Definition at line 1309 of file edit.h.

#define EIMES_GETCOMPSTRATONCE 0x0001

lParam for EMSIS_COMPOSITIONSTRING(reserved).

Definition at line 1299 of file edit.h.

#define EMSIS_COMPOSITIONSTRING 0x0001

Indicates the type of status to retrieve.

Definition at line 1292 of file edit.h.

Generated on Fri Dec 17 13:49:45 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Messages of grid control

Messages of grid control
[GridView control]

Defines

  • #define GRIDM_SETCELLPROPERTY 0xF210
    An Application sends a GRIDM_SETCELLPROPERTY message to set the cells' property in the grid control.
  • #define GRIDM_GETCELLPROPERTY 0xF211
    An Application sends a GRIDM_GETCELLPROPERTY message to get a single cell's property in the grid control.
  • #define GRIDM_SETCOLWIDTH 0xF212
    An Application sends a GRIDM_SETCOLWIDTH message to set column width in the grid control.
  • #define GRIDM_GETCOLWIDTH 0xF213
    An Application sends a GRIDM_GETCOLWIDTH message to get a column width in the grid control.
  • #define GRIDM_SETROWHEIGHT 0xF214
    An Application sends a GRIDM_SETROWHEIGHT message to set a row height in the grid control.
  • #define GRIDM_GETROWHEIGHT 0xF215
    An Application sends a GRIDM_GETROWHEIGHT message to get a row height in the grid control.
  • #define GRIDM_ADDROW 0xF216
    An Application sends a GRIDM_ADDROW message to add a new row to the control.
  • #define GRIDM_DELROW 0xF217
    An Application sends a GRIDM_DELROW message to delete a row frow the control.
  • #define GRIDM_ADDCOLUMN 0xF218
    An Application sends a GRIDM_ADDCOLUMN message to add a new column to the control.
  • #define GRIDM_DELCOLUMN 0xF219
    An Application sends a GRIDM_DELCOLUMN message to delete a column frow the control.
  • #define GRIDM_GETROWCOUNT 0xF21A
    Gets the number of all rows in the grid control.
  • #define GRIDM_GETCOLCOUNT 0xF21B
    Gets the number of all columns in the grid control.
  • #define GRIDM_SETNUMFORMAT 0xF21C
    Sets the number format of a cell in the grid control. the format is just same as format in c printf.
  • #define GRIDM_SETSELECTED 0xF21D
    Sets the selected cell(s) in the grid control.
  • #define GRIDM_GETSELECTED 0xF21E
    Gets the selected cell(s) in the grid control.
  • #define GRIDM_ADDDEPENDENCE 0xF21F
    Adds a dependence relationship of cells to another cells.
  • #define GRIDM_DELDEPENDENCE 0xF220
    Deletes a dependence relationship of cells to another cells.
  • #define GRIDM_ENDCELLEDIT 0xF221
    This message is used inside minigui.

Define Documentation

#define GRIDM_ADDCOLUMN 0xF218

An Application sends a GRIDM_ADDCOLUMN message to add a new column to the control.

if (wParam > nCols) , it will do nothing. nCols is the columns' count of the grid control.

 GRIDM_ADDCOLUMN
 int index;
 GRIDCELLDATA* celldata;

 wParam = (WPARAM)index; // The index of the column which you want to add after it, zero base.
 lParam = (LPARAM)celldata; // The property which is setted to the new column.

Returns:
Returns GRID_OKAY if successful, or GRID_ERR otherwise.

Definition at line 452 of file gridview.h.

#define GRIDM_ADDDEPENDENCE 0xF21F

Adds a dependence relationship of cells to another cells.

An application sends an GRIDM_ADDDEPENDENCE message to add a dependence relationship of cells to another source cells, when the source cells changed, the target cells could updated automatically.

 GRIDCELLDEPENDENCE* dependence

 GRIDM_ADDDEPENDENCE

 wParam = 0;
 lParam = (WPARAM)dependence;  // Dependence relationship for adding.

Returns:
Returns a dependence id if successful, or GRID_ERR otherwise.

Definition at line 584 of file gridview.h.

#define GRIDM_ADDROW 0xF216

An Application sends a GRIDM_ADDROW message to add a new row to the control.

if (wParam > nRows) , it will do nothing. nRows is the rows' count of the grid control.

 GRIDM_ADDROW
 int index;
 GRIDCELLDATA* celldata;

 wParam = (WPARAM)index; // The index of the row which you want to add after it, zero base.
 lParam = (LPARAM)celldata; // The property which is setted to the new row.

Returns:
Returns GRID_OKAY if successful, or GRID_ERR otherwise.

Definition at line 414 of file gridview.h.

#define GRIDM_DELCOLUMN 0xF219

An Application sends a GRIDM_DELCOLUMN message to delete a column frow the control.

if (wParam < 1 or wParam > nCols) , it will do nothing. nCols is the columns' count of the grid control.

 GRIDM_DELCOLUMN
 int index;

 wParam = 0;
 lParam = (LPARAM)index; // The index of the column which you want to delete.

Returns:
Returns GRID_OKAY if successful, or GRID_ERR otherwise.

Definition at line 470 of file gridview.h.

#define GRIDM_DELDEPENDENCE 0xF220

Deletes a dependence relationship of cells to another cells.

An application sends an GRIDM_DELDEPENDENCE message to delete a dependence relationship of cells to another source cells.

 int dependence_id

 GRIDM_ADDDEPENDENCE

 wParam = (WPARAM)dependence_id;
 lParam = 0.

Returns:
Returns GRID_OKAY, or GRID_ERR otherwise.

Definition at line 604 of file gridview.h.

#define GRIDM_DELROW 0xF217

An Application sends a GRIDM_DELROW message to delete a row frow the control.

if (wParam < 1 or wParam > nRows) , it will do nothing. nRows is the rows' count of the grid control.

 GRIDM_DELROW
 int index;

 wParam = 0;
 lParam = index; // The index of the row which you want to delete.

Returns:
Returns GRID_OKAY if successful, or GRID_ERR otherwise.

Definition at line 433 of file gridview.h.

#define GRIDM_ENDCELLEDIT 0xF221

This message is used inside minigui.

Definition at line 611 of file gridview.h.

#define GRIDM_GETCELLPROPERTY 0xF211

An Application sends a GRIDM_GETCELLPROPERTY message to get a single cell's property in the grid control.

 GRIDM_GETCELLPROPERTY
 GRIDCELLS* cells;
 GRIDCELLDATA* celldata;

 wParam = (WPARAM)cell; // The cell(only for one cell now) which you want to get it's property
 lParam = (LPARAM)celldata; // The pointer of the property you want to get.

Returns:
Returns GRID_OKAY if successful, or GRID_ERR otherwise.
See also:
GRIDCELLDATA

Definition at line 316 of file gridview.h.

#define GRIDM_GETCOLCOUNT 0xF21B

Gets the number of all columns in the grid control.

An application sends an GRIDM_GETCOLCOUNT message to get the number of all columns in the grid control.

 GRIDM_GETCOLCOUNT

 wParam = 0;
 lParam = 0;

Returns:
The cols number on success, otherwise -1.

Definition at line 502 of file gridview.h.

#define GRIDM_GETCOLWIDTH 0xF213

An Application sends a GRIDM_GETCOLWIDTH message to get a column width in the grid control.

if (lParam < 1 or lParam > nCols) , it will do nothing. nCows is the columns' count of the grid control.

 GRIDM_GETCOLWIDTH
 int index;

 wParam = 0;
 lParam = (LPARAM)index; // The index of the column which you want to get width.

Returns:
The width of the column on success, otherwise -1.

Definition at line 355 of file gridview.h.

#define GRIDM_GETROWCOUNT 0xF21A

Gets the number of all rows in the grid control.

An application sends an GRIDM_GETROWCOUNT message to get the number of all rows in the grid control.

 GRIDM_GETROWCOUNT

 wParam = 0;
 lParam = 0;

Returns:
The rows number on success, otherwise -1.

Definition at line 486 of file gridview.h.

#define GRIDM_GETROWHEIGHT 0xF215

An Application sends a GRIDM_GETROWHEIGHT message to get a row height in the grid control.

if (lParam < 1 or lParam > nRows) , it will do nothing. nRows is the rows' count of the grid control.

 GRIDM_GETROWHEIGHT
 int index ;

 wParam = 0
 lParam = (LPARAM)index // The index of the row which you want to get height.

Returns:
The height of the row on success, otherwise -1.

Definition at line 394 of file gridview.h.

#define GRIDM_GETSELECTED 0xF21E

Gets the selected cell(s) in the grid control.

An application sends an GRIDM_GETSELECTED message to get the selected cell(s) in the grid control.

 GRIDCELLS* cells

 GRIDM_GETSELECTED

 wParam = 0;
 lParam = (WPARAM)cells;  // Get the selected cell(s) to it.

Returns:
Returns GRID_OKAY if successful, or GRID_ERR otherwise.

Definition at line 563 of file gridview.h.

#define GRIDM_SETCELLPROPERTY 0xF210

An Application sends a GRIDM_SETCELLPROPERTY message to set the cells' property in the grid control.

 GRIDM_SETCELLPROPERTY
 GRIDCELLS* cells;
 GRIDCELLDATA* celldata;

 wParam = (WPARAM)cells; // The cell(s) which you want to set it's(their) property
 lParam = (LPARAM)celldata; // The pointer of the property you want to set.

Returns:
Returns GRID_OKAY if successful, or GRID_ERR otherwise.
See also:
GRIDCELLDATA

Definition at line 296 of file gridview.h.

#define GRIDM_SETCOLWIDTH 0xF212

An Application sends a GRIDM_SETCOLWIDTH message to set column width in the grid control.

if (lParam < 1 or lParam > nCols) , it will do nothing. nCows is the columns' count of the grid control.

 GRIDM_SETCOLWIDTH
 int index;
 int width;

 wParam = (WPARAM)index; // The index of the column which you want to set width.
 lParam = (LPARAM)width; // The width of the column you want to set.

Returns:
Returns GRID_OKAY if successful, or GRID_ERR otherwise.

Definition at line 336 of file gridview.h.

#define GRIDM_SETNUMFORMAT 0xF21C

Sets the number format of a cell in the grid control. the format is just same as format in c printf.

An application sends an GRIDM_SETNUMFORMAT message to set the number format of a cell in the grid control.

 GRIDCELLS cells;
 char* format

 GRIDM_SETNUMFORMAT

 wParam = (WPARAM)cells; // The cells which you want to set.
 lParam = (WPARAM)format; // The cells' number format, like "%1.2f";

Returns:
Returns GRID_OKAY if successful, or GRID_ERR otherwise.

Definition at line 523 of file gridview.h.

#define GRIDM_SETROWHEIGHT 0xF214

An Application sends a GRIDM_SETROWHEIGHT message to set a row height in the grid control.

if (lParam < 1 or lParam > nRows) , it will do nothing. nRows is the rows' count of the grid control.

 GRIDM_SETROWHEIGHT
 int index
 int height;

 wParam = (WPARAM)index; // The index of the row which you want to set height.
 lParam = (LPARAM)height; //The height of the row you want to set.

Returns:
Returns GRID_OKAY if successful, or GRID_ERR otherwise.

Definition at line 375 of file gridview.h.

#define GRIDM_SETSELECTED 0xF21D

Sets the selected cell(s) in the grid control.

An application sends an GRIDM_SETSELECTED message to set the selected cell(s) in the grid control.

 GRIDCELLS* cells

 GRIDM_SETSELECTED

 wParam = 0;
 lParam = (WPARAM)cells; // The cell(s) which you want to set selected.

Returns:
Returns GRID_OKAY if successful, or GRID_ERR otherwise.

Definition at line 543 of file gridview.h.

Generated on Fri Dec 17 13:49:45 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Notification code of Grid control

Notification code of Grid control
[GridView control]

Defines

  • #define GRIDN_HEADLDOWN 1
    This notification code informs a application when the left mouse button down on the gridview.header.
  • #define GRIDN_HEADLUP 2
    This notification code informs a application when the left mouse button up on the gridview.header.
  • #define GRIDN_KEYDOWN 3
    This notification code informs a application when that a key has been pressed.
  • #define GRIDN_CELLDBCLK 4
    This notification code informs a application when the current selected cell has be double clicked.
  • #define GRIDN_CELLCLK 5
    This notification code informs a application when the current selected cell has been clicked.
  • #define GRIDN_FOCUSCHANGED 6
    This notification code informs a application when the current selected item has changed.
  • #define GRIDN_CELLTEXTCHANGED 7
    This notification code informs a application when the cell text has changed.

Define Documentation

#define GRIDN_CELLCLK 5

This notification code informs a application when the current selected cell has been clicked.

Definition at line 648 of file gridview.h.

#define GRIDN_CELLDBCLK 4

This notification code informs a application when the current selected cell has be double clicked.

Definition at line 642 of file gridview.h.

#define GRIDN_CELLTEXTCHANGED 7

This notification code informs a application when the cell text has changed.

Definition at line 660 of file gridview.h.

#define GRIDN_FOCUSCHANGED 6

This notification code informs a application when the current selected item has changed.

Definition at line 654 of file gridview.h.

#define GRIDN_HEADLDOWN 1

This notification code informs a application when the left mouse button down on the gridview.header.

Definition at line 625 of file gridview.h.

#define GRIDN_HEADLUP 2

This notification code informs a application when the left mouse button up on the gridview.header.

Definition at line 631 of file gridview.h.

#define GRIDN_KEYDOWN 3

This notification code informs a application when that a key has been pressed.

Definition at line 636 of file gridview.h.

Generated on Fri Dec 17 13:49:45 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: GridView control

GridView control
[Standard controls]

Modules

  • Messages of grid control
  • Notification code of Grid control

Data Structures

  • struct _GRIDVIEWDATA
  • struct _GRIDCELLS
  • struct _GRIDCELLDATAHEADER
  • struct _GRIDCELLDATATEXT
  • struct _GRIDCELLDATANUMBER
  • struct _GRIDCELLDATACHECKBOX
  • struct _GRIDCELLDATASELECTION
  • struct _GRIDCELLDATA

Defines

  • #define CTRL_GRIDVIEW "gridview"
    The class name of gridview control.
  • #define GRID_OKAY 0
    Gridview return value.
  • #define GRID_ERR (-1)
    Gridview return value.
  • #define GV_HALIGN_LEFT 0x00000001
  • #define GV_HALIGN_RIGHT 0x00000002
  • #define GV_HALIGN_CENTER 0x00000003
  • #define GV_VALIGN_TOP 0x00000010
  • #define GV_VALIGN_BOTTOM 0x00000020
  • #define GV_VALIGN_CENTER 0x00000030
  • #define GV_HALIGN_MASK 0x0000000F
  • #define GV_VALIGN_MASK 0x000000F0
  • #define GV_TYPE_UNKNOWN 0x00000000
  • #define GV_TYPE_TEXT 0x00000100
  • #define GV_TYPE_NUMBER 0x00000200
  • #define GV_TYPE_CHECKBOX 0x00000300
  • #define GV_TYPE_SELECTION 0x00000400
  • #define GV_TYPE_HEADER 0x00000500
  • #define GV_TYPE_TABLEHEADER 0x00000600
  • #define GV_TYPE_MASK 0x0000FF00
  • #define GVS_WITHICON 0x00010000
  • #define GVS_WITHCHECKBOX 0x00020000
  • #define GVS_MULTLINE 0x00100000
  • #define GVS_READONLY 0x00200000
  • #define GVS_BOXCHECKED 0x00400000

Define Documentation

#define CTRL_GRIDVIEW "gridview"

The class name of gridview control.

Definition at line 50 of file gridview.h.

#define GRID_ERR (-1)

Gridview return value.

Definition at line 65 of file gridview.h.

#define GRID_OKAY 0

Gridview return value.

Definition at line 59 of file gridview.h.

#define GV_HALIGN_CENTER 0x00000003

Column text horizontal center align

Definition at line 86 of file gridview.h.

#define GV_HALIGN_LEFT 0x00000001

The alignment of the cell Column text horizontal left align, default

Definition at line 82 of file gridview.h.

#define GV_HALIGN_MASK 0x0000000F

Mask of horizontal align type

Definition at line 95 of file gridview.h.

#define GV_HALIGN_RIGHT 0x00000002

Column text horizontal right align

Definition at line 84 of file gridview.h.

#define GV_TYPE_CHECKBOX 0x00000300

The checkbox type of the cell

Definition at line 107 of file gridview.h.

#define GV_TYPE_HEADER 0x00000500

The cell type of the row header or column header

Definition at line 111 of file gridview.h.

#define GV_TYPE_MASK 0x0000FF00

Mask of grid cell type

Definition at line 116 of file gridview.h.

#define GV_TYPE_NUMBER 0x00000200

The digit type of the cell

Definition at line 105 of file gridview.h.

#define GV_TYPE_SELECTION 0x00000400

The type of the cell having selection

Definition at line 109 of file gridview.h.

#define GV_TYPE_TABLEHEADER 0x00000600

The cell type of the cell

Definition at line 113 of file gridview.h.

#define GV_TYPE_TEXT 0x00000100

The text type of the cell

Definition at line 103 of file gridview.h.

#define GV_TYPE_UNKNOWN 0x00000000

The type of the unknown cell, use unknow type to query cell type

Definition at line 101 of file gridview.h.

#define GV_VALIGN_BOTTOM 0x00000020

Column text vertical bottom align

Definition at line 90 of file gridview.h.

#define GV_VALIGN_CENTER 0x00000030

Column text vertical center align

Definition at line 92 of file gridview.h.

#define GV_VALIGN_MASK 0x000000F0

Mask of vertical align type

Definition at line 98 of file gridview.h.

#define GV_VALIGN_TOP 0x00000010

Column text vertical top align

Definition at line 88 of file gridview.h.

#define GVS_BOXCHECKED 0x00400000

A status of the cell which has a checkbox and the checkbox is checked

Definition at line 128 of file gridview.h.

#define GVS_MULTLINE 0x00100000

A style of the cell, which text is multiple line

Definition at line 124 of file gridview.h.

#define GVS_READONLY 0x00200000

A status of the cell, which is read only

Definition at line 126 of file gridview.h.

#define GVS_WITHCHECKBOX 0x00020000

A style of the cell, which contains a checkbox

Definition at line 121 of file gridview.h.

#define GVS_WITHICON 0x00010000

A style of the cell, which has a icon bitmap

Definition at line 119 of file gridview.h.

Generated on Fri Dec 17 13:49:45 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _GRIDVIEWDATA Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_GRIDVIEWDATA Struct Reference
[GridView control]

#include <gridview.h>

Data Fields

  • int nr_rows
  • int nr_cols
  • int row_height
  • int col_width

Detailed Description

Struct of the whole grid control

Definition at line 68 of file gridview.h.

Field Documentation

int nr_rows

The number of the rows

Definition at line 71 of file gridview.h.

int nr_cols

The number of the columns

Definition at line 73 of file gridview.h.

int row_height

The default height of a row

Definition at line 75 of file gridview.h.

int col_width

The default width of a column

Definition at line 77 of file gridview.h.

The documentation for this struct was generated from the following file:
  • gridview.h
Generated on Fri Dec 17 13:49:52 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _GRIDCELLS Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_GRIDCELLS Struct Reference
[GridView control]

#include <gridview.h>

Data Fields

  • int row
  • int column
  • int width
  • int height

Detailed Description

Struct of the selected cell(s)

Definition at line 141 of file gridview.h.

Field Documentation

int row

The start row of the selected cell(s)

Definition at line 144 of file gridview.h.

int column

The start column of the selected cell(s)

Definition at line 146 of file gridview.h.

int width

The number of the column(s) which contain(s) selected cell(s)

Definition at line 148 of file gridview.h.

int height

The number of the row(s) which contain(s) selected cell(s)

Definition at line 150 of file gridview.h.

The documentation for this struct was generated from the following file:
  • gridview.h
Generated on Fri Dec 17 13:49:52 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _GRIDCELLDATAHEADER Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_GRIDCELLDATAHEADER Struct Reference
[GridView control]

#include <gridview.h>

Data Fields

  • int size
  • char * buff
  • int len_buff

Detailed Description

Struct of the header type cell

Definition at line 168 of file gridview.h.

Field Documentation

int size

The height of a row or the width of a column

Definition at line 171 of file gridview.h.

char* buff

The caption of the row or column

Definition at line 173 of file gridview.h.

int len_buff

The length of the buff string

Definition at line 175 of file gridview.h.

The documentation for this struct was generated from the following file:
  • gridview.h
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _GRIDCELLDATATEXT Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_GRIDCELLDATATEXT Struct Reference
[GridView control]

#include <gridview.h>

Data Fields

  • char * buff
  • int len_buff

Detailed Description

Struct of the text type cell

Definition at line 179 of file gridview.h.

Field Documentation

char* buff

The caption of the row or column

Definition at line 182 of file gridview.h.

int len_buff

The length of the buff string

Definition at line 184 of file gridview.h.

The documentation for this struct was generated from the following file:
  • gridview.h
Generated on Fri Dec 17 13:49:52 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _GRIDCELLDATANUMBER Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_GRIDCELLDATANUMBER Struct Reference
[GridView control]

#include <gridview.h>

Data Fields

  • double number
  • char * format
  • int len_format

Detailed Description

Struct of the number type cell

Definition at line 188 of file gridview.h.

Field Documentation

double number

The value of the number type cell

Definition at line 191 of file gridview.h.

char* format

The format of the number to display

Definition at line 193 of file gridview.h.

int len_format

The length of the format string

Definition at line 195 of file gridview.h.

The documentation for this struct was generated from the following file:
  • gridview.h
Generated on Fri Dec 17 13:49:52 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _GRIDCELLDATACHECKBOX Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_GRIDCELLDATACHECKBOX Struct Reference
[GridView control]

#include <gridview.h>

Data Fields

  • BOOL checked
  • char * text
  • int len_text

Detailed Description

Struct of the checkbox type cell

Definition at line 199 of file gridview.h.

Field Documentation

BOOL checked

Whether this checkbox is checked

Definition at line 202 of file gridview.h.

char* text

The text after checkbox

Definition at line 204 of file gridview.h.

int len_text

When used for set, -1 means null-terminated

Definition at line 206 of file gridview.h.

The documentation for this struct was generated from the following file:
  • gridview.h
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _GRIDCELLDATASELECTION Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_GRIDCELLDATASELECTION Struct Reference
[GridView control]

#include <gridview.h>

Data Fields

  • int cur_index
  • char * selections
  • int len_sel

Detailed Description

Struct of the selection type cell

Definition at line 210 of file gridview.h.

Field Documentation

int cur_index

The index of the combobox that current selected

Definition at line 213 of file gridview.h.

char* selections

"Yes\nNo\n"

Definition at line 215 of file gridview.h.

int len_sel

When used for set, -1 means null-terminated

Definition at line 217 of file gridview.h.

The documentation for this struct was generated from the following file:
  • gridview.h
Generated on Fri Dec 17 13:49:52 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _GRIDCELLDATA Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_GRIDCELLDATA Struct Reference
[GridView control]

#include <gridview.h>

Data Fields

  • DWORD mask
  • DWORD style
  • gal_pixel color_fg
  • gal_pixel color_bg
  • PLOGFONT font
  • PBITMAP image
  • void * content

Detailed Description

Struct of the cell

Definition at line 238 of file gridview.h.

Field Documentation

DWORD mask

Mask of properties, can be OR'ed with following values: Set or get a cell style

  • GVITEM_STYLE
    Set or get a cell text color
  • GVITEM_FGCOLOR
    Set or get a cell background color
  • GVITEM_BGCOLOR
    Set or get a cell text font
  • GVITEM_FONT
    Set or get a cell's image
  • GVITEM_IMAGE
    Set or get all of the content of a cell
  • GVITEM_ALLCONTENT
    Set or get the main content of a cell
  • GVITEM_MAINCONTENT
    Set or get the header size
  • GVITEM_SIZE

Definition at line 258 of file gridview.h.

DWORD style

The style of the cell

Definition at line 261 of file gridview.h.

gal_pixel color_fg

Text color

Definition at line 263 of file gridview.h.

gal_pixel color_bg

The background color

Definition at line 265 of file gridview.h.

PLOGFONT font

Text font

Definition at line 267 of file gridview.h.

PBITMAP image

Pointer to the bitmap of one cell

Definition at line 269 of file gridview.h.

void* content

The concrete data of one cell

Definition at line 271 of file gridview.h.

The documentation for this struct was generated from the following file:
  • gridview.h
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Styles of iconview control

Styles of iconview control
[IconView control]

Defines

  • #define IVS_NOTIFY SVS_NOTIFY
    The notify style of iconview control.
  • #define IVS_UPNOTIFY SVS_UPNOTIFY
    The upnotify style of iconview control.
  • #define IVS_AUTOSORT SVS_AUTOSORT
    The auto sort style of iconview control.
  • #define IVS_LOOP SVS_LOOP
    The loop style of iconview control.

Define Documentation

#define IVS_AUTOSORT SVS_AUTOSORT

The auto sort style of iconview control.

See also:
SVS_AUTOSORT

Definition at line 167 of file iconview.h.

#define IVS_LOOP SVS_LOOP

The loop style of iconview control.

See also:
SVS_LOOP

Definition at line 174 of file iconview.h.

#define IVS_NOTIFY SVS_NOTIFY

The notify style of iconview control.

See also:
SVS_NOTIFY

Definition at line 153 of file iconview.h.

#define IVS_UPNOTIFY SVS_UPNOTIFY

The upnotify style of iconview control.

See also:
SVS_UPNOTIFY

Definition at line 160 of file iconview.h.

Generated on Fri Dec 17 13:49:45 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Messages of ListView control

Messages of ListView control
[IconView control]

Defines

  • #define IVM_ADDITEM 0xF300
    Adds a item to iconview.
  • #define IVM_SETITEMSIZE 0xF436
    Sets the item width and height of an iconview control.
  • #define IVM_RESETCONTENT SVM_RESETCONTENT
  • #define IVM_DELITEM SVM_DELITEM
  • #define IVM_SETITEMDRAW SVM_SETITEMDRAW
  • #define IVM_SETCONTWIDTH SVM_SETCONTWIDTH
  • #define IVM_SETCONTHEIGHT SVM_SETCONTHEIGHT
  • #define IVM_SETITEMOPS SVM_SETITEMOPS
  • #define IVM_GETMARGINS SVM_GETMARGINS
  • #define IVM_SETMARGINS SVM_SETMARGINS
  • #define IVM_GETLEFTMARGIN SVM_GETLEFTMARGIN
  • #define IVM_GETTOPMARGIN SVM_GETTOPMARGIN
  • #define IVM_GETRIGHTMARGIN SVM_GETRIGHTMARGIN
  • #define IVM_GETBOTTOMMARGIN SVM_GETBOTTOMMARGIN
  • #define IVM_GETVISIBLEWIDTH SVM_GETVISIBLEWIDTH
  • #define IVM_GETVISIBLEHEIGHT SVM_GETVISIBLEHEIGHT
  • #define IVM_GETCONTWIDTH SVM_GETCONTWIDTH
  • #define IVM_GETCONTHEIGHT SVM_GETCONTHEIGHT
  • #define IVM_SETCONTRANGE SVM_SETCONTRANGE
  • #define IVM_GETCONTENTX SVM_GETCONTENTX
  • #define IVM_GETCONTENTY SVM_GETCONTENTY
  • #define IVM_SETCONTPOS SVM_SETCONTPOS
  • #define IVM_GETCURSEL SVM_GETCURSEL
  • #define IVM_SELECTITEM SVM_SELECTITEM
  • #define IVM_SHOWITEM SVM_SHOWITEM
  • #define IVM_CHOOSEITEM SVM_CHOOSEITEM
  • #define IVM_SETCURSEL SVM_SETCURSEL
  • #define IVM_SETITEMINIT SVM_SETITEMINIT
  • #define IVM_SETITEMDESTROY SVM_SETITEMDESTROY
  • #define IVM_SETITEMCMP SVM_SETITEMCMP
  • #define IVM_MAKEPOSVISIBLE SVM_MAKEPOSVISIBLE
  • #define IVM_GETHSCROLLVAL SVM_GETHSCROLLVAL
  • #define IVM_GETVSCROLLVAL SVM_GETVSCROLLVAL
  • #define IVM_GETHSCROLLPAGEVAL SVM_GETHSCROLLPAGEVAL
  • #define IVM_GETVSCROLLPAGEVAL SVM_GETVSCROLLPAGEVAL
  • #define IVM_SETSCROLLVAL SVM_SETSCROLLVAL
  • #define IVM_SETSCROLLPAGEVAL SVM_SETSCROLLPAGEVAL
  • #define IVM_SORTITEMS SVM_SORTITEMS
  • #define IVM_GETITEMCOUNT SVM_GETITEMCOUNT
  • #define IVM_GETITEMADDDATA SVM_GETITEMADDDATA
  • #define IVM_SETITEMADDDATA SVM_SETITEMADDDATA
  • #define IVM_REFRESHITEM SVM_REFRESHITEM
  • #define IVM_GETFIRSTVISIBLEITEM SVM_GETFIRSTVISIBLEITEM

Define Documentation

#define IVM_ADDITEM 0xF300

Adds a item to iconview.

  IVM_ADDITEM
  PIVITEMINFO p

  p =(LPARAM)lParam;

Parameters:
p Pointes to a IVITEMINFO structure that contains the information of the new item to be added. nItem member of the IVITEMINFO struct speficied the item position in its parent item, beginning with zero.
Returns:
Returns the handle of the new item if successful, or 0 otherwise.

Definition at line 201 of file iconview.h.

#define IVM_CHOOSEITEM SVM_CHOOSEITEM

The same common control messages as scrollview control

See also:
SVM_CHOOSEITEM

Definition at line 346 of file iconview.h.

#define IVM_DELITEM SVM_DELITEM

The same common control messages as scrollview control

See also:
SVM_DELITEM

Definition at line 236 of file iconview.h.

#define IVM_GETBOTTOMMARGIN SVM_GETBOTTOMMARGIN

The same common control messages as scrollview control

See also:
SVM_GETBOTTOMMARGIN

Definition at line 286 of file iconview.h.

#define IVM_GETCONTENTX SVM_GETCONTENTX

The same common control messages as scrollview control

See also:
SVM_GETCONTENTX

Definition at line 316 of file iconview.h.

#define IVM_GETCONTENTY SVM_GETCONTENTY

The same common control messages as scrollview control

See also:
SVM_GETCONTENTY

Definition at line 321 of file iconview.h.

#define IVM_GETCONTHEIGHT SVM_GETCONTHEIGHT

The same common control messages as scrollview control

See also:
SVM_GETCONTHEIGHT

Definition at line 306 of file iconview.h.

#define IVM_GETCONTWIDTH SVM_GETCONTWIDTH

The same common control messages as scrollview control

See also:
SVM_GETCONTWIDTH

Definition at line 301 of file iconview.h.

#define IVM_GETCURSEL SVM_GETCURSEL

The same common control messages as scrollview control

See also:
SVM_GETCURSEL

Definition at line 331 of file iconview.h.

#define IVM_GETFIRSTVISIBLEITEM SVM_GETFIRSTVISIBLEITEM

The same common control messages as scrollview control

See also:
SVM_GETFIRSTVISIBLEITEM

Definition at line 431 of file iconview.h.

#define IVM_GETHSCROLLPAGEVAL SVM_GETHSCROLLPAGEVAL

The same common control messages as scrollview control

See also:
SVM_GETHSCROLLPAGEVAL

Definition at line 386 of file iconview.h.

#define IVM_GETHSCROLLVAL SVM_GETHSCROLLVAL

The same common control messages as scrollview control

See also:
SVM_GETHSCROLLVAL

Definition at line 376 of file iconview.h.

#define IVM_GETITEMADDDATA SVM_GETITEMADDDATA

The same common control messages as scrollview control

See also:
SVM_GETITEMADDDATA

Definition at line 416 of file iconview.h.

#define IVM_GETITEMCOUNT SVM_GETITEMCOUNT

The same common control messages as scrollview control

See also:
SVM_GETITEMCOUNT

Definition at line 411 of file iconview.h.

#define IVM_GETLEFTMARGIN SVM_GETLEFTMARGIN

The same common control messages as scrollview control

See also:
SVM_GETLEFTMARGIN

Definition at line 271 of file iconview.h.

#define IVM_GETMARGINS SVM_GETMARGINS

The same common control messages as scrollview control

See also:
SVM_GETMARGINS

Definition at line 261 of file iconview.h.

#define IVM_GETRIGHTMARGIN SVM_GETRIGHTMARGIN

The same common control messages as scrollview control

See also:
SVM_GETRIGHTMARGIN

Definition at line 281 of file iconview.h.

#define IVM_GETTOPMARGIN SVM_GETTOPMARGIN

The same common control messages as scrollview control

See also:
SVM_GETTOPMARGIN

Definition at line 276 of file iconview.h.

#define IVM_GETVISIBLEHEIGHT SVM_GETVISIBLEHEIGHT

The same common control messages as scrollview control

See also:
SVM_GETVISIBLEHEIGHT

Definition at line 296 of file iconview.h.

#define IVM_GETVISIBLEWIDTH SVM_GETVISIBLEWIDTH

The same common control messages as scrollview control

See also:
SVM_GETVISIBLEWIDTH

Definition at line 291 of file iconview.h.

#define IVM_GETVSCROLLPAGEVAL SVM_GETVSCROLLPAGEVAL

The same common control messages as scrollview control

See also:
SVM_GETVSCROLLPAGEVAL

Definition at line 391 of file iconview.h.

#define IVM_GETVSCROLLVAL SVM_GETVSCROLLVAL

The same common control messages as scrollview control

See also:
SVM_GETVSCROLLVAL

Definition at line 381 of file iconview.h.

#define IVM_MAKEPOSVISIBLE SVM_MAKEPOSVISIBLE

The same common control messages as scrollview control

See also:
SVM_MAKEPOSVISIBLE

Definition at line 371 of file iconview.h.

#define IVM_REFRESHITEM SVM_REFRESHITEM

The same common control messages as scrollview control

See also:
SVM_REFRESHITEM

Definition at line 426 of file iconview.h.

#define IVM_RESETCONTENT SVM_RESETCONTENT

The same common control messages as scrollview control

See also:
SVM_RESETCONTENT

Definition at line 231 of file iconview.h.

#define IVM_SELECTITEM SVM_SELECTITEM

The same common control messages as scrollview control

See also:
SVM_SELECTITEM

Definition at line 336 of file iconview.h.

#define IVM_SETCONTHEIGHT SVM_SETCONTHEIGHT

The same common control messages as scrollview control

See also:
SVM_SETCONTHEIGHT

Definition at line 251 of file iconview.h.

#define IVM_SETCONTPOS SVM_SETCONTPOS

The same common control messages as scrollview control

See also:
SVM_SETCONTPOS

Definition at line 326 of file iconview.h.

#define IVM_SETCONTRANGE SVM_SETCONTRANGE

The same common control messages as scrollview control

See also:
SVM_SETCONTRANGE

Definition at line 311 of file iconview.h.

#define IVM_SETCONTWIDTH SVM_SETCONTWIDTH

The same common control messages as scrollview control

See also:
SVM_SETCONTWIDTH

Definition at line 246 of file iconview.h.

#define IVM_SETCURSEL SVM_SETCURSEL

The same common control messages as scrollview control

See also:
SVM_SETCURSEL

Definition at line 351 of file iconview.h.

#define IVM_SETITEMADDDATA SVM_SETITEMADDDATA

The same common control messages as scrollview control

See also:
SVM_SETITEMADDDATA

Definition at line 421 of file iconview.h.

#define IVM_SETITEMCMP SVM_SETITEMCMP

The same common control messages as scrollview control

See also:
SVM_SETITEMCMP

Definition at line 366 of file iconview.h.

#define IVM_SETITEMDESTROY SVM_SETITEMDESTROY

The same common control messages as scrollview control

See also:
SVM_SETITEMDESTROY

Definition at line 361 of file iconview.h.

#define IVM_SETITEMDRAW SVM_SETITEMDRAW

The same common control messages as scrollview control

See also:
SVM_SETITEMDRAW

Definition at line 241 of file iconview.h.

#define IVM_SETITEMINIT SVM_SETITEMINIT

The same common control messages as scrollview control

See also:
SVM_SETITEMINIT

Definition at line 356 of file iconview.h.

#define IVM_SETITEMOPS SVM_SETITEMOPS

The same common control messages as scrollview control

See also:
SVM_SETITEMOPS

Definition at line 256 of file iconview.h.

#define IVM_SETITEMSIZE 0xF436

Sets the item width and height of an iconview control.

All the items have the same item size. This message should be sent before you add items to iconview control.

 IVM_SETITEMSIZE
 int width;
 int height;

 wParam = width;
 lParam = height;

Parameters:
width | Width of an item.
height | Height of an item.
Returns:
0.

Definition at line 224 of file iconview.h.

#define IVM_SETMARGINS SVM_SETMARGINS

The same common control messages as scrollview control

See also:
SVM_SETMARGINS

Definition at line 266 of file iconview.h.

#define IVM_SETSCROLLPAGEVAL SVM_SETSCROLLPAGEVAL

The same common control messages as scrollview control

See also:
SVM_SETSCROLLPAGEVAL

Definition at line 401 of file iconview.h.

#define IVM_SETSCROLLVAL SVM_SETSCROLLVAL

The same common control messages as scrollview control

See also:
SVM_SETSCROLLVAL

Definition at line 396 of file iconview.h.

#define IVM_SHOWITEM SVM_SHOWITEM

The same common control messages as scrollview control

See also:
SVM_SHOWITEM

Definition at line 341 of file iconview.h.

#define IVM_SORTITEMS SVM_SORTITEMS

The same common control messages as scrollview control

See also:
SVM_SORTITEMS

Definition at line 406 of file iconview.h.

Generated on Fri Dec 17 13:49:45 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Notification code of IconView control

Notification code of IconView control
[IconView control]

Defines

  • #define IVN_CLICKED SVN_CLICKED
  • #define IVN_SELCHANGED SVN_SELCHANGED

Define Documentation

#define IVN_CLICKED SVN_CLICKED

The notification messages as scrollview control

See also:
SVN_CLICKED

Definition at line 444 of file iconview.h.

#define IVN_SELCHANGED SVN_SELCHANGED

The notification messages as scrollview control

See also:
SVN_SELCHANGED

Definition at line 450 of file iconview.h.

Generated on Fri Dec 17 13:49:46 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: IconView control

IconView control
[Standard controls]

Modules

  • Styles of iconview control
  • Messages of ListView control
  • Notification code of IconView control

Data Structures

  • struct _IVITEMINFO

Defines

  • #define CTRL_ICONVIEW ("IconView")
    The class name of iconview control.
  • #define IV_OKAY 0
  • #define IV_ERR (-1)
  • #define IV_ERRSPACE (-2)
  • #define IVFLAG_BITMAP 0x0001
  • #define IVFLAG_ICON 0x0002

Typedefs

  • typedef GHANDLE HIVITEM
    Icon view item handle.

Functions

  • MG_EXPORT int iconview_is_item_hilight (HWND hWnd, GHANDLE hivi)
    Uses this to get an iconview item is hilighted or not.
  • MG_EXPORT PBITMAP iconview_get_item_bitmap (GHANDLE hivi)
    Uses this to get bitmap handle from an iconview item.
  • MG_EXPORT const char * iconview_get_item_label (GHANDLE hivi)
    Uses this to get text label from an iconview item.
  • MG_EXPORT DWORD iconview_get_item_adddata (GHANDLE hivi)
    Uses this to get additional data from an iconview item.

Define Documentation

#define CTRL_ICONVIEW ("IconView")

The class name of iconview control.

Definition at line 50 of file iconview.h.

#define IV_ERR (-1)

Iconview return value

Definition at line 55 of file iconview.h.

#define IV_ERRSPACE (-2)

Iconview return value

Definition at line 57 of file iconview.h.

#define IV_OKAY 0

Iconview return value

Definition at line 53 of file iconview.h.

#define IVFLAG_BITMAP 0x0001

Iconview bitmap flags, reserved

Definition at line 98 of file iconview.h.

#define IVFLAG_ICON 0x0002

Iconview icon flags, reserved

Definition at line 100 of file iconview.h.

Typedef Documentation

typedef GHANDLE HIVITEM

Icon view item handle.

Definition at line 63 of file iconview.h.

Function Documentation

DWORD iconview_get_item_adddata ( GHANDLE hivi )

Uses this to get additional data from an iconview item.

Returns:
the additional data of iconview item.

DWORD iconview_get_item_bitmap ( GHANDLE hivi )

Uses this to get bitmap handle from an iconview item.

Returns:
the bitmap handle of iconview item.

DWORD iconview_get_item_label ( GHANDLE hivi )

Uses this to get text label from an iconview item.

Returns:
the text label of iconview item.

int iconview_is_item_hilight | ( | HWND | hWnd,
 |  | GHANDLE | hivi
 | ) |  |

Uses this to get an iconview item is hilighted or not.

Returns:
TRUE when item is hilighted, or FALSE.

Generated on Fri Dec 17 13:49:45 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _IVITEMINFO Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_IVITEMINFO Struct Reference
[IconView control]

#include <iconview.h>

Data Fields

  • int nItem
  • PBITMAP bmp
  • const char * label
  • DWORD addData
  • DWORD dwFlags

Detailed Description

Structure of the iconview item info, contains information about an item. This structure is used for creating or retrieving an item.

Definition at line 69 of file iconview.h.

Field Documentation

int nItem

The Index of the item

Definition at line 74 of file iconview.h.

PBITMAP bmp

The bitmap icon of the item

Definition at line 79 of file iconview.h.

const char* label

The text label of the item

Definition at line 84 of file iconview.h.

DWORD addData

Attached additional data of this item

Definition at line 87 of file iconview.h.

DWORD dwFlags

Reserved

Definition at line 92 of file iconview.h.

The documentation for this struct was generated from the following file:
  • iconview.h
Generated on Fri Dec 17 13:49:52 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Styles of listbox control

Styles of listbox control
[ListBox control]

Defines

  • #define LBS_NOTIFY 0x0001L
    Notifies the parent window.
  • #define LBS_SORT 0x0002L
    Sorts strings alphabetically.
  • #define LBS_MULTIPLESEL 0x0008L
    Causes the list box to allow the user to select multiple items.
  • #define LBS_CHECKBOX 0x1000L
    Displays a check box in an item.
  • #define LBS_USEICON 0x2000L
    Displays an icon or bitmap in an item.
  • #define LBS_AUTOCHECK 0x4000L
    If the list box has LBS_CHECKBOX style, this style tell the box to auto-switch the check box between checked or un-checked when the user click the check mark box of an item.
  • #define LBS_AUTOCHECKBOX (LBS_CHECKBOX | LBS_AUTOCHECK)
    If the list box has LBS_AUTOCHECKBOX style, this style tell the box use LBS_CHECKBOX and BLS_AUTOCHECK style.
  • #define LBS_SBALWAYS 0x8000L
    The list box with LBS_SBALWAYS style will always show vertical scrollbar.
  • #define LBS_MOUSEFOLLOW 0x0010L
    The list box with LBS_MOUSEFOLLOW style will always change the selected item following mouse.

Define Documentation

#define LBS_AUTOCHECK 0x4000L

If the list box has LBS_CHECKBOX style, this style tell the box to auto-switch the check box between checked or un-checked when the user click the check mark box of an item.

Definition at line 165 of file listbox.h.

#define LBS_AUTOCHECKBOX (LBS_CHECKBOX | LBS_AUTOCHECK)

If the list box has LBS_AUTOCHECKBOX style, this style tell the box use LBS_CHECKBOX and BLS_AUTOCHECK style.

Definition at line 172 of file listbox.h.

#define LBS_CHECKBOX 0x1000L

Displays a check box in an item.

Definition at line 151 of file listbox.h.

#define LBS_MOUSEFOLLOW 0x0010L

The list box with LBS_MOUSEFOLLOW style will always change the selected item following mouse.

Definition at line 185 of file listbox.h.

#define LBS_MULTIPLESEL 0x0008L

Causes the list box to allow the user to select multiple items.

Definition at line 145 of file listbox.h.

#define LBS_NOTIFY 0x0001L

Notifies the parent window.

Causes the list box to notify the list box parent window with a notification message when the user clicks or doubleclicks an item.

Definition at line 130 of file listbox.h.

#define LBS_SBALWAYS 0x8000L

The list box with LBS_SBALWAYS style will always show vertical scrollbar.

Definition at line 178 of file listbox.h.

#define LBS_SORT 0x0002L

Sorts strings alphabetically.

Causes the list box to sort strings alphabetically that are added to the list box with an LB_ADDSTRING message.

Definition at line 139 of file listbox.h.

#define LBS_USEICON 0x2000L

Displays an icon or bitmap in an item.

Definition at line 157 of file listbox.h.

Generated on Fri Dec 17 13:49:46 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Messages of listbox control

Messages of listbox control
[ListBox control]

Defines

  • #define LB_ADDSTRING 0xF180
    Appends the specified string.
  • #define LB_INSERTSTRING 0xF181
    Inserts an item to the list box.
  • #define LB_DELETESTRING 0xF182
    Removes an item from the list box.
  • #define LB_SELITEMRANGEEX 0xF183
    reserved.
  • #define LB_RESETCONTENT 0xF184
    Removes the contents of a list box.
  • #define LB_GETSEL 0xF187
    Gets the selected state for an specified item.
  • #define LB_SETSEL 0xF185
    Selects an item in a multiple-selection list box.
  • #define LB_GETCURSEL 0xF188
    Gets the index of the currently selected or highlighted item.
  • #define LB_SETCURSEL 0xF186
    Selects an item.
  • #define LB_GETTEXT 0xF189
    Retrieves the text of an item in list box.
  • #define LB_GETTEXTLEN 0xF18A
    Gets the length of text of item specified in a list box.
  • #define LB_GETCOUNT 0xF18B
    Gets the number of items in the list box.
  • #define LB_SELECTSTRING 0xF18C
    reserved.
  • #define LB_DIR 0xF18D
    reserved.
  • #define LB_GETTOPINDEX 0xF18E
    Gets the index to the first visible item in the list box.
  • #define LB_FINDSTRING 0xF18F
    Searchs a specified string.
  • #define LB_GETSELCOUNT 0xF190
    Gets the number of selected items in a multiple-selection list box.
  • #define LB_GETSELITEMS 0xF191
    Gets the numbers of selected items.
  • #define LB_GETHORIZONTALEXTENT 0xF193
    reserved.
  • #define LB_SETHORIZONTALEXTENT 0xF194
    reserved.
  • #define LB_SETCOLUMNWIDTH 0xF195
    reserved.
  • #define LB_ADDFILE 0xF196
    reserved.
  • #define LB_SETTOPINDEX 0xF197
    Ensures that a particular item in it is visible.
  • #define LB_GETITEMRECT 0xF198
    Retrieves the dimensions of the rectangle.
  • #define LB_GETITEMDATA 0xF199
    Gets item data in a list box if the box has LBS_CHECKBOX and/or LBS_USEICON styles.
  • #define LB_SETITEMDATA 0xF19A
    Sets item data in a list box if the box has LBS_CHECKBOX and/or LBS_USEICON styles.
  • #define LB_SETCARETINDEX 0xF19E
    Sets the focus rectangle to the item at the specified index.
  • #define LB_GETCARETINDEX 0xF19F
    Determines the index of the item that has the focus rectangle.
  • #define LB_SETITEMHEIGHT 0xF1A0
    Sets the height of all items.
  • #define LB_GETITEMHEIGHT 0xF1A1
    Gets the height in pixels of an item specified in the wParam parameter.
  • #define LB_FINDSTRINGEXACT 0xF1A2
    Searchs for an item that exactly matches the characters specified.
  • #define LB_SETLOCALE 0xF1A5
    reserved.
  • #define LB_GETLOCALE 0xF1A6
    reserved.
  • #define LB_SETCOUNT 0xF1A7
    reserved.
  • #define LB_INITSTORAGE 0xF1A8
    reserved.
  • #define LB_ITEMFROMPOINT 0xF1A9
    reserved.
  • #define LB_SETTEXT 0xF1AA
    Sets text of the specified item.
  • #define LB_GETCHECKMARK 0xF1AB
    Gets check mark status of an item.
  • #define LB_SETCHECKMARK 0xF1AC
    Sets check mark status of an item.
  • #define LB_GETITEMADDDATA 0xF1AD
    Gets the 32-bit data value associated with an item.
  • #define LB_SETITEMADDDATA 0xF1AE
    Associates a 32-bit data value with an item.
  • #define LB_SETSTRCMPFUNC 0xF1AF
    Sets the STRCMP function used to sort items.
  • #define LB_SETITEMDISABLE 0xF1B0
    Sets the item disable.
  • #define LB_GETITEMDISABLE 0xF1B1
    Get the item disable status.
  • #define LB_SETITEMBOLD 0xF1B2
    Sets the item display use bold font.
  • #define LB_MULTIADDITEM 0xF1B3
    Appends the multi strings.

Define Documentation

#define LB_ADDFILE 0xF196

reserved.

Definition at line 624 of file listbox.h.

#define LB_ADDSTRING 0xF180

Appends the specified string.

An application sends an LB_ADDSTRING message to append an item specified in the lParam parameter to a list box.

For a text-only list box:

 LB_ADDSTRING
 const char* text;

 wParam = 0;
 lParam = (LPARAM)text;

Parameters:
text Pointer to the string of the item to be added.
For a list box with check box or icon (with LBS_CHECKBOX or LBS_USEICON styles):

 LB_ADDSTRING
 PLISTBOXITEMINFO plbii;

 wParam = 0;
 lParam = (LPARAM)plbii;

Parameters:
plbii Pointer to the listbox item info to be added.
Returns:
The index of the new item on success, else the one of the following error codes:
  • LB_ERRSPACE No memory can be allocated for new item.
  • LB_ERR Invalid passed arguments.

Definition at line 244 of file listbox.h.

#define LB_DELETESTRING 0xF182

Removes an item from the list box.

An application sends an LB_DELETESTRING message to a list box to remove from the list box.

 LB_DELETESTRING
 int del;

 wParam = (WPARAM)del;
 lParam = 0;

Parameters:
del The index of the listbox item to be deleted.
Returns:
LB_OKAY on success, else LB_ERR to indicate you passed an invalid index.

Definition at line 310 of file listbox.h.

#define LB_DIR 0xF18D

reserved.

Definition at line 507 of file listbox.h.

#define LB_FINDSTRING 0xF18F

Searchs a specified string.

An application sends an LB_FINDSTRING message to search a list box for an item that begins with the characters specified in the lParam parameter. The wParam parameter specifies the zero-based index of the item before the first item to be searched; The lParam parameter specifies a pointer to a null-terminated string that contains the prefix to search for.

 LB_FINDSTRING
 int index;
 char *string;

 wParam = (WPARAM)index;
 lParam = (LPARAM)string;

Parameters:
index | The index of the item to be searched.
string | The string of the item to be searched.
Returns:
The index of the matched item; LB_ERR for not found.

Definition at line 552 of file listbox.h.

#define LB_FINDSTRINGEXACT 0xF1A2

Searchs for an item that exactly matches the characters specified.

An application sends an LB_FINDSTRINGEXACT message to a list box to search it for an item that exactly matches the characters specified in the lParam parameter.

 LB_FINDSTRINGEXACT
 int index;
 const char *string;

 wParam = (WPARAM)index;
 lParam = (LPARAM)string;

Parameters:
index | The index of the specified item.
string | The string of the item to be searched for.
Returns:
The index of the found item on success, else LB_ERR.

Definition at line 832 of file listbox.h.

#define LB_GETCARETINDEX 0xF19F

Determines the index of the item that has the focus rectangle.

An application sends an LB_GETCARETINDEX message to a list box to determine the index of the item that has the focus rectangle in a multiple-selection list box.

 LB_GETCARETINDEX

 wParam = 0;
 lParam = 0;

Returns:
The index of the item that has the focus rectangle.

Definition at line 770 of file listbox.h.

#define LB_GETCHECKMARK 0xF1AB

Gets check mark status of an item.

 LB_GETCHECKMARK
 int index;

 wParam = (WPARAM)index;
 lParam = 0;

Parameters:
index The index of the specified item.
Returns:
The check mark status of specified item on success; LB_ERR on error.
Return values:
LB_ERR | Invalid item index or the list box have no LBS_CHECKBOX style.
CMFLAG_CHECKED | The item is checked.
CMFLAG_PARTCHECKED | The item is partly checked.
CMFLAG_BLANK | The item is not checked.

Definition at line 903 of file listbox.h.

#define LB_GETCOUNT 0xF18B

Gets the number of items in the list box.

An application sends an LB_GETCOUNT message to a list box to get the number of items in the list box.

 LB_GETCOUNT

 wParam = 0;
 lParam = 0;

Returns:
The number of items in the listbox.

Definition at line 495 of file listbox.h.

#define LB_GETCURSEL 0xF188

Gets the index of the currently selected or highlighted item.

An application sends an LB_GETCURSEL message to a list box to get the index of the currently selected item, if there is one, in a single-selection list box. For multiple-selection list box, appliction send an LB_GETCURSEL message to a list box to get the index of the current highlighted item.

 LB_GETCURSEL

 wParam = 0;
 lParam = 0;

Returns:
The index of the currently selected item for single-selection list box; Else the index of the highlighted item for multiple-selection list box.

Definition at line 406 of file listbox.h.

#define LB_GETHORIZONTALEXTENT 0xF193

reserved.

Definition at line 606 of file listbox.h.

#define LB_GETITEMADDDATA 0xF1AD

Gets the 32-bit data value associated with an item.

An application sends an LB_GETITEMADDDATA message to a list box to get the 32-bit data value the list box has stored for the item with index of wParam; By default this is zero. An application must set the item data value by sending an LB_SETITEMADDDATA message to the list box for this value to have meaning.

 LB_GETITEMADDDATA
 int index;

 wParam = (WPARAM)index;
 lParam = 0;

Parameters:
index The index of the specified item.
Returns:
The 32-bit data value associated with an item on success, otherwise LB_ERR to indicate an error.

Definition at line 953 of file listbox.h.

#define LB_GETITEMDATA 0xF199

Gets item data in a list box if the box has LBS_CHECKBOX and/or LBS_USEICON styles.

An application sends LB_GETITEMDATA message to a list box to retrive the check box flag and the handle of icon. Note that the text of the item will not be returned, i.e., the field of string of LISTBOXITEMINFO structure will be ignored.

 LB_GETITEMDATA
 int index;
 PLISTBOXITEMINFO plbii;

 wParam = (WPARAM)index;
 lParam = (LPARAM)plbii;

Parameters:
index | The index of the specified item.
plbii | Pointer to the buffer used for storing the item data of the specified item.
Returns:
LB_OKAY on success; LB_ERR on error.
See also:
LISTBOXITEMINFO

Definition at line 701 of file listbox.h.

#define LB_GETITEMDISABLE 0xF1B1

Get the item disable status.

An application sends an LB_SETITEMDISABLE message to get a item to disable status.

 wParam = index;
 lParam = 0;

Returns:
One of the following values:
  • TRUE
    Item is disable
  • FLASE
    Item is enable

Definition at line 1045 of file listbox.h.

#define LB_GETITEMHEIGHT 0xF1A1

Gets the height in pixels of an item specified in the wParam parameter.

An application sends an LB_GETITEMHEIGHT message to a list box to get the height in pixels of an item specified in the wParam parameter.

 LB_GETITEMHEIGHT

 wParam = 0;
 lParam = 0;

Returns:
The height of item in the listbox.

Definition at line 809 of file listbox.h.

#define LB_GETITEMRECT 0xF198

Retrieves the dimensions of the rectangle.

An application sends an LB_GETITEMRECT message to a list box to retrieve the dimensions of the rectangle that bounds an item as it is currently displayed in the list box window. The item is specified in the wParam parameter, and a pointer to a RECT structure is given in the lParam parameter.

 LB_GETITEMRECT
 int index;
 RECT *rcItem;

 wParam = (WPARAM)index;
 lParam = (LPARAM)rcItem;

Parameters:
index | The index of the specified item.
rcItem | Pointer to the buffer used for storing the item rect;
Returns:
LB_OKAY on success; LB_ERR on error.

Definition at line 672 of file listbox.h.

#define LB_GETLOCALE 0xF1A6

reserved.

Definition at line 843 of file listbox.h.

#define LB_GETSEL 0xF187

Gets the selected state for an specified item.

An application sends an LB_GETSEL message to a list box to get the selected state for an item specified in the wParam parameter.

 LB_GETSEL
 int index;

 wParam = (WPARAM)index;
 lParam = 0;

Parameters:
index The index of the specified item.
Returns:
The state of the specified item:
  • 0
    Not selected.
  • >0
    Selected.
  • LB_ERR
    Invalid index.

Definition at line 358 of file listbox.h.

#define LB_GETSELCOUNT 0xF190

Gets the number of selected items in a multiple-selection list box.

An application sends an LB_GETSELCOUNT message to a list box to get the number of selected items in a multiple-selection list box.

 LB_GETSELCOUNT

 wParam = 0;
 lParam = 0;

Returns:
The number of selected items in the multiple-selection listbox.

Definition at line 570 of file listbox.h.

#define LB_GETSELITEMS 0xF191

Gets the numbers of selected items.

An application sends an LB_GETSELITEMS message to a list box to fill a buffer with an array of integers that specify the item numbers of selected items in a multiple-selection list box.

 LB_GETSELITEMS
 int nItem;
 int *pInt;

 wParam = (WPARAM)nItem;
 lParam = (LPARAM)pInt;

Parameters:
nItem | The maximum integer numbers wanted.
pInt | The buffer of an array of integers to save the indices of selected items.
Returns:
The number of selected items.

Definition at line 594 of file listbox.h.

#define LB_GETTEXT 0xF189

Retrieves the text of an item in list box.

An application sends an LB_GETTEXT message to a list box to retrieve the text of an item.

 LB_GETTEXT
 int index;
 char *string;

 wParam = (WPARAM)index;
 lParam = (LPARAM)string;

Parameters:
index | The index of the selected item.
string | Pointer to the string buffer. The buffer should be large enough to contain the text of the item.
Returns:
One of the following values:
  • LB_OKAY
    Success.
  • LB_ERR
    Invalid item index.
See also:
LB_GETTEXTLEN

Definition at line 456 of file listbox.h.

#define LB_GETTEXTLEN 0xF18A

Gets the length of text of item specified in a list box.

An application sends an LB_GETTEXTLEN message to a list box to get the length of text of the item specified in the wParam parameter.

 LB_GETTEXTLEN
 int index;

 wParam = (WPARAM)index;
 lParam = 0;

Parameters:
index The index of the specified item.
Returns:
The length of the strings on success, else LB_ERR to indicate invalid index.

Definition at line 477 of file listbox.h.

#define LB_GETTOPINDEX 0xF18E

Gets the index to the first visible item in the list box.

An application sends an LB_GETTOPINDEX message to get the index to the first visible item in the list box. Initially, the first visible item is item 0, but this changes as the list box is scrolled.

 LB_GETTOPINDEX

 wParam = 0;
 lParam = 0;

Returns:
The index of the first visible item in the listbox.

Definition at line 526 of file listbox.h.

#define LB_INITSTORAGE 0xF1A8

reserved.

Definition at line 853 of file listbox.h.

#define LB_INSERTSTRING 0xF181

Inserts an item to the list box.

An application sends an LB_INSERTSTRING message to insert an item into a list box. Unlike LB_ADDSTRING message, the LB_INSERTSTRING message do not cause the list to be sorted.

For a text-only list box:

 LB_INSERTSTRING
 const char* text;

 wParam = index;
 lParam = (LPARAM)text;

Parameters:
index | Specifies the index of the position at which to insert the item.
text | Pointer to the string of the item to be inserted.
For a list box with check box or icon (with LBS_CHECKBOX or LBS_USEICON styles):

 LB_INSERTSTRING
 int index;
 PLISTBOXITEMINFO plbii;

 wParam = (WPARAM)index;
 lParam = (LPARAM)plbii;

Parameters:
index | Specifies the index of the position at which to insert the item.
plbii | Pointer to the listbox item info to be inserted.
Returns:
The index of the new item on success, else the one of the following error codes:
  • LB_ERRSPACE No memory can be allocated for new item.
  • LB_ERR Invalid passed arguments.

Definition at line 289 of file listbox.h.

#define LB_ITEMFROMPOINT 0xF1A9

reserved.

Definition at line 858 of file listbox.h.

#define LB_MULTIADDITEM 0xF1B3

Appends the multi strings.

An application sends an LB_MULTIADDITEM message to append item array specified in the lParam parameter to a list box.

For a text-only list box:

 LB_MULTIADDITEM
 int num;
 const char text[num][];

 wParam = num;
 lParam = (LPARAM)text;

Parameters:
num | is count of text array
text | pointer to the string of the item array to be added.
For a list box with check box or icon (with LBS_CHECKBOX or LBS_USEICON styles):

 LB_MULTIADDITEM
 LISTBOXITEMINFO plbii[num];

 wParam = num;
 lParam = (LPARAM)plbii;

Parameters:
num | is count of plbii array
plbii | pointer to the listbox item info to be added.
Returns:
The index of the new item on success, else the one of the following error codes:
  • LB_ERRSPACE No memory can be allocated for new item.
  • LB_ERR Invalid passed arguments.

Definition at line 1107 of file listbox.h.

#define LB_RESETCONTENT 0xF184

Removes the contents of a list box.

An application sends an LB_RESETCONTENT message to remove the all items in a list box.

 LB_RESETCONTENT

 wParam = 0;
 lParam = 0;

Returns:
Always be zero.

Definition at line 334 of file listbox.h.

#define LB_SELECTSTRING 0xF18C

reserved.

Definition at line 501 of file listbox.h.

#define LB_SELITEMRANGEEX 0xF183

reserved.

#define LB_SETCARETINDEX 0xF19E

Sets the focus rectangle to the item at the specified index.

An application sends an LB_SETCARETINDEX message to set the focus rectangle to the item at the specified index in a multiple-selection list box.

 LB_SETCARETINDEX
 int index;

 wParam = (WPARAM)index;
 lParam = 0;

Definition at line 751 of file listbox.h.

#define LB_SETCHECKMARK 0xF1AC

Sets check mark status of an item.

 LB_SETCHECKMARK
 int index, status;

 wParam = (WPARAM)index;
 lParam = (LPARAM)status;

Parameters:
index The index of the specified item.
status The new check mark status, can be one of the followings.
  • CMFLAG_CHECKED
    The item is checked.
  • CMFLAG_PARTCHECKED
    The item is partly checked.
Returns:
One of the following values:
  • LB_OKAY
    Success
  • LB_ERR
    Invalid item index or this list box have no LBS_CHECKBOX style.

Definition at line 928 of file listbox.h.

#define LB_SETCOLUMNWIDTH 0xF195

reserved.

Definition at line 618 of file listbox.h.

#define LB_SETCOUNT 0xF1A7

reserved.

Definition at line 848 of file listbox.h.

#define LB_SETCURSEL 0xF186

Selects an item.

An application sends an LB_SETCURSEL message to a list box to select an item and scroll it into view, if necessary.

 LB_SETCURSEL
 int cursel;

 wParam = (WPARAM)cursel;
 lParam = 0;

Parameters:
cursel The index of the item to be selected and hilighted.
Returns:
The old index of the item selected on error, else LB_ERR to indicate an error occurred.

Definition at line 428 of file listbox.h.

#define LB_SETHORIZONTALEXTENT 0xF194

reserved.

Definition at line 612 of file listbox.h.

#define LB_SETITEMADDDATA 0xF1AE

Associates a 32-bit data value with an item.

An application sends an LB_SETITEMADDDATA message to associate a 32-bit data value specified in the lParam parameter with an item in the list box.

 LB_SETITEMADDDATA
 int index;
 DWORD addData;

 wParam = (WPARAM)index;
 lParam = (LPARAM)addData;

Parameters:
index | The index of the specified item.
addData | the 32-bit data value which will associated with the item.
Returns:
One of the following values:
  • LB_OKAY
    Success
  • LB_ERR
    Invalid item index

Definition at line 978 of file listbox.h.

#define LB_SETITEMBOLD 0xF1B2

Sets the item display use bold font.

An application sends an LB_SETITEMBOLD message to set a item display use bold font.

 wParam = index;
 lParam = (LPARAM)bold;

Returns:
One of the following values:
  • LB_OKAY
    Success
  • LB_ERR
    index of item is not exist.

Definition at line 1063 of file listbox.h.

#define LB_SETITEMDATA 0xF19A

Sets item data in a list box if the box has LBS_CHECKBOX and/or LBS_USEICON styles.

An application sends LB_SETITEMDATA message to a list box to set the check box flag and the handle of icon. Note that the text of the item will not be changed, i.e., the field of string of LISTBOXITEMINFO structure will be ignored.

 LB_SETITEMDATA
 int index;
 PLISTBOXITEMINFO plbii;

 wParam = (WPARAM)index;
 lParam = (LPARAM)plbii;

Parameters:
index | The index of the specified item.
plbii | Pointer to the buffer used for setting the item info of the specified item.
Returns:
LB_OKAY on success; LB_ERR on error.
See also:
LISTBOXITEMINFO

Definition at line 730 of file listbox.h.

#define LB_SETITEMDISABLE 0xF1B0

Sets the item disable.

An application sends an LB_SETITEMDISABLE message to set a item to disable.

 wParam = index;
 lParam = (LPARAM)disable;

Returns:
One of the following values:
  • LB_OKAY
    Success
  • LB_ERR
    index of item is not exist.

Definition at line 1027 of file listbox.h.

#define LB_SETITEMHEIGHT 0xF1A0

Sets the height of all items.

An application sends an LB_SETITEMHEIGHT message to set the height of all items in a list box.

 LB_SETITEMHEIGHT
 int itemHeight;

 wParam = 0;
 lParam = (LPARAM)itemHeight;

Parameters:
itemHeight New height of item.
Returns:
The effective height of item.

Definition at line 791 of file listbox.h.

#define LB_SETLOCALE 0xF1A5

reserved.

Definition at line 838 of file listbox.h.

#define LB_SETSEL 0xF185

Selects an item in a multiple-selection list box.

An application sends an LB_SETSEL message to select an item in a multiple-selection list box and scroll it into view if necessary.

 LB_SETSEL
 int index, sel

 wParam = (WPARAM)sel;
 lParam = (LPARAM)index;

Parameters:
sel Indicates the changes to be made to the listbox item, can be one of the following values:
  • -1
    If the item has been selected, makes it unselected, vice versa.
  • 0
    Makes the item unselected.
  • other
    Makes the item selected.
index The index of the item.
Returns:
LB_OKAY on success, else LB_ERR to indicate you passed an invalid index or the list box has no LBS_MULTIPLESEL style.

Definition at line 385 of file listbox.h.

#define LB_SETSTRCMPFUNC 0xF1AF

Sets the STRCMP function used to sort items.

An application sends an LB_SETSTRCMPFUNC message to set a new STRCMP function to sort items.

Note that you should send this message before adding any item to the list box control.

 static int my_strcmp (const char* s1, const char* s2, size_t n)
 {
      ...
      return 0;
 }

 LB_SETSTRCMPFUNC

 wParam = 0;
 lParam = (LPARAM)my_strcmp;

Parameters:
my_strcmp Your own function to compare two strings.
Returns:
One of the following values:
  • LB_OKAY
    Success
  • LB_ERR
    Not an empty list box.

Definition at line 1009 of file listbox.h.

#define LB_SETTEXT 0xF1AA

Sets text of the specified item.

 LB_SETTEXT
 int index;
 const char *string;

 wParam = (WPARAM)index;
 lParam = (LPARAM)string;

Parameters:
index | The index of the specified item.
string | The string of the item to be set.
Returns:
One of the following values:
  • LB_OKAY
    Success
  • LB_ERR
    Invalid item index or memory allocation error.

Definition at line 880 of file listbox.h.

#define LB_SETTOPINDEX 0xF197

Ensures that a particular item in it is visible.

An application sends an LB_SETTOPINDEX message to a list box to ensure that a particular item in it is visible. The item is specified in the wParam parameter. The list box scrolls so that either the specified item appears at the top of the list box or the maximum scroll range has been reached.

 LB_SETTOPINDEX
 int index;

 wParam = (WPARAM)index;
 lParam = 0;

Parameters:
index The index of the particular item to be set.
Returns:
Always be zero.

Definition at line 647 of file listbox.h.

Generated on Fri Dec 17 13:49:46 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Notification codes of listbox control

Notification codes of listbox control
[ListBox control]

Defines

  • #define LBN_ERRSPACE 255
    Indicates that memory is not enough.
  • #define LBN_SELCHANGE 1
    Indicates change due to mouse or keyboard user input.
  • #define LBN_DBLCLK 2
    Indicates double click on an item.
  • #define LBN_SELCANCEL 3
    Indicates cancel of the selection in the list box.
  • #define LBN_SETFOCUS 4
    Indicates gain of input focus.
  • #define LBN_KILLFOCUS 5
    Indicates loss of input focus.
  • #define LBN_CLICKCHECKMARK 6
    Indicates click on the check mark.
  • #define LBN_CLICKED 7
    Indicates click on the string.
  • #define LBN_ENTER 8
    Indicates the user has pressed the ENTER key.

Define Documentation

#define LBN_CLICKCHECKMARK 6

Indicates click on the check mark.

Definition at line 1178 of file listbox.h.

#define LBN_CLICKED 7

Indicates click on the string.

Definition at line 1184 of file listbox.h.

#define LBN_DBLCLK 2

Indicates double click on an item.

A list box created with the LBS_NOTIFY style sends an LBN_DBLCLK notification message to its parent window when the user double-clicks a string in it.

Definition at line 1144 of file listbox.h.

#define LBN_ENTER 8

Indicates the user has pressed the ENTER key.

Definition at line 1190 of file listbox.h.

#define LBN_ERRSPACE 255

Indicates that memory is not enough.

A list box sends an LBN_ERRSPACE notification message to its parent window when it cannot allocate enough memory to complete the current operation.

Definition at line 1125 of file listbox.h.

#define LBN_KILLFOCUS 5

Indicates loss of input focus.

A list box sends an LBN_KILLFOCUS notification message to its parent window when the list box loses the input focus.

Definition at line 1172 of file listbox.h.

#define LBN_SELCANCEL 3

Indicates cancel of the selection in the list box.

A list box created with the LBS_NOTIFY style sends an LBN_SELCANCEL notification message to its parent window when the user cancels the selection in the list box.

Definition at line 1154 of file listbox.h.

#define LBN_SELCHANGE 1

Indicates change due to mouse or keyboard user input.

A list box created with the LBS_NOTIFY style sends an LBN_SELCHANGE notification message to its parent window when the selection is about to change due to mouse or keyboard user input.

Definition at line 1135 of file listbox.h.

#define LBN_SETFOCUS 4

Indicates gain of input focus.

A list box sends an LBN_SETFOCUS notification message to its parent window when the list box gains the input focus.

Definition at line 1163 of file listbox.h.

Generated on Fri Dec 17 13:49:46 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: ListBox control

ListBox control
[Standard controls]

Modules

  • Styles of listbox control
  • Messages of listbox control
  • Notification codes of listbox control

Data Structures

  • struct _LISTBOXITEMINFO

Defines

  • #define CTRL_LISTBOX ("listbox")
    The class name of listbox control.
  • #define LB_OKAY 0
  • #define LB_ERR (-3)
  • #define LB_ERRSPACE (-2)
  • #define CMFLAG_MASK 0x000F
    The mask of check mark and image flag value.
  • #define IMGFLAG_BITMAP 0x0010
    Listbox item style that context of itme is bitmap.
  • #define LBIS_SIGNIFICANT 0x0020
    Listbox item style that item is rendered with WE_FGC_SIGNIFICANT_ITEM and WE_BGC_SIGNIFICANT_ITEM color.

Typedefs

  • typedef LISTBOXITEMINFO * PLISTBOXITEMINFO
    Data type of the pointer to a LISTBOXITEMINFO.

Define Documentation

#define CMFLAG_MASK 0x000F

The mask of check mark and image flag value.

See also:
_LISTBOXITEMINFO

Definition at line 69 of file listbox.h.

#define CTRL_LISTBOX ("listbox")

The class name of listbox control.

Definition at line 51 of file listbox.h.

#define IMGFLAG_BITMAP 0x0010

Listbox item style that context of itme is bitmap.

Definition at line 75 of file listbox.h.

#define LB_ERR (-3)

Listbox return value

Definition at line 56 of file listbox.h.

#define LB_ERRSPACE (-2)

Listbox return value

Definition at line 58 of file listbox.h.

#define LB_OKAY 0

Listbox return value

Definition at line 54 of file listbox.h.

#define LBIS_SIGNIFICANT 0x0020

Listbox item style that item is rendered with WE_FGC_SIGNIFICANT_ITEM and WE_BGC_SIGNIFICANT_ITEM color.

Definition at line 82 of file listbox.h.

Typedef Documentation

typedef LISTBOXITEMINFO * PLISTBOXITEMINFO

Data type of the pointer to a LISTBOXITEMINFO.

Definition at line 116 of file listbox.h.

Generated on Fri Dec 17 13:49:46 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _LISTBOXITEMINFO Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_LISTBOXITEMINFO Struct Reference
[ListBox control]

#include <listbox.h>

Data Fields

  • char * string
  • DWORD cmFlag
  • HICON hIcon

Detailed Description

Structrue of the listbox item info

Definition at line 85 of file listbox.h.

Field Documentation

char* string

Item string

Definition at line 88 of file listbox.h.

DWORD cmFlag

Check mark and image flag. It can be one of the following values:

  • CMFLAG_BLANK The item is blank.
  • CMFLAG_CHECKED The item is checked.
  • CMFLAG_PARTCHECKED The item is partly checked.

If you want to significant the item which to be render, you can OR'd cmFlag with LBIS_SIGNIFICANT.

For LBS_ICON list box, if you want to display bitmap other than icon, you can OR'd cmFlag with IMGFLAG_BITMAP.

Definition at line 106 of file listbox.h.

HICON hIcon

Handle to the icon (or pointer to bitmap object) of the item

Definition at line 109 of file listbox.h.

The documentation for this struct was generated from the following file:
  • listbox.h
Generated on Fri Dec 17 13:49:52 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Styles of listview control

Styles of listview control
[ListView control]

Defines

  • #define LVS_UPNOTIFY 0x0001L
    Notifies the parent window when mouse is up (default is down).
  • #define LVS_SORT 0x0002L
    Sorts strings automatically.
  • #define LVS_MULTIPLESEL 0x0008L
    Causes the listview to allow the user to select multiple items.
  • #define LVS_CHECKBOX 0x1000L
    Displays a check box in an item.
  • #define LVS_AUTOCHECK 0x2000L
    If the list view has LVS_CHECKBOX style, this style tell the list view to auto-switch the check box between checked or un-checked when the user click the check mark box of an item.
  • #define LVS_AUTOCHECKBOX (LVS_CHECKBOX | LVS_AUTOCHECK)
    If the list view has LVS_AUTOCHECKBOX style, this style tell the list view use LVS_CHECKBOX and LVS_AUTOCHECK style.
  • #define LVS_TREEVIEW 0x4000L
    Uses listview in a treeview style.

Define Documentation

#define LVS_AUTOCHECK 0x2000L

If the list view has LVS_CHECKBOX style, this style tell the list view to auto-switch the check box between checked or un-checked when the user click the check mark box of an item.

Definition at line 329 of file listview.h.

#define LVS_AUTOCHECKBOX (LVS_CHECKBOX | LVS_AUTOCHECK)

If the list view has LVS_AUTOCHECKBOX style, this style tell the list view use LVS_CHECKBOX and LVS_AUTOCHECK style.

Definition at line 335 of file listview.h.

#define LVS_CHECKBOX 0x1000L

Displays a check box in an item.

Definition at line 321 of file listview.h.

#define LVS_MULTIPLESEL 0x0008L

Causes the listview to allow the user to select multiple items.

Definition at line 315 of file listview.h.

#define LVS_SORT 0x0002L

Sorts strings automatically.

Causes the listview to sort strings automatically.

Definition at line 309 of file listview.h.

#define LVS_TREEVIEW 0x4000L

Uses listview in a treeview style.

Definition at line 341 of file listview.h.

#define LVS_UPNOTIFY 0x0001L

Notifies the parent window when mouse is up (default is down).

Causes the listview to notify the listview parent window with a notification message when the user make actions, such as clicks, doubleclicks, ...,etc.

Definition at line 300 of file listview.h.

Generated on Fri Dec 17 13:49:46 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Messages of ListView control

Messages of ListView control
[ListView control]

Defines

  • #define LVM_ADDITEM 0xF110
    Adds a item to listview, this item is also called a row.
  • #define LVM_FILLSUBITEM 0xF111
    Sets the content of a subitem, indentified by rows and columns.
  • #define LVM_ADDCOLUMN 0xF112
    Adds a new column to listview, identified by column.
  • #define LVM_DELITEM 0xF113
    Deletes an item form listview.
  • #define LVM_CLEARSUBITEM 0xF114
    Clears the content of a subitem.
  • #define LVM_DELCOLUMN 0xF115
    Deletes a column from listview, all subitem in this column will be removed.
  • #define LVM_COLSORT 0xF116
    Sorts all subitems according to a certain column.
  • #define LVM_SETSUBITEMCOLOR 0xF117
    Sets the text color of a subitem.
  • #define LVM_FINDITEM 0xF118
    Searchs a item.
  • #define LVM_GETSUBITEMTEXT 0xF119
    Retrieves the text of a listview subitem.
  • #define LVM_GETITEMCOUNT 0xF11A
    Gets the number of all the items(rows) in a listview.
  • #define LVM_GETCOLUMNCOUNT 0xF11B
    Gets the number of all the columns in listview.
  • #define LVM_GETSELECTEDITEM 0xF11C
    Gets the current selected item.
  • #define LVM_DELALLITEM 0xF11D
    Removes all the items in listview.
  • #define LVM_MODIFYHEAD 0xF11E
    Changes the title of a column.
  • #define LVM_SELECTITEM 0xF11F
    Selects an item.
  • #define LVM_SHOWITEM 0xF120
    Makes the item is entirely visible in the list view.
  • #define LVM_GETSUBITEMLEN 0xF121
    Gets the text length of the subitem.
  • #define LVM_SETCOLUMN 0xF122
    Sets the attributes of a list view column.
  • #define LVM_SETSUBITEMTEXT 0xF123
    Sets the text of a subitem.
  • #define LVM_SETSUBITEM 0xF124
    Sets the attributes of a subitem.
  • #define LVM_GETCOLUMN 0xF125
    Retrieves the information about a listview column.
  • #define LVM_GETCOLUMNWIDTH 0xF126
    Retrieves the width of a listview column.
  • #define LVM_GETITEM 0xF127
    Retrieves the item's attributes.
  • #define LVM_GETITEMSTATE 0xF128
    Retrieves the state of a listview item.
  • #define LVM_GETSELECTEDCOLUMN 0xF129
    Retrieves the index of the currently selected column of a listview.
  • #define LVM_GETSELECTEDCOUNT 0xF130
    Retrieves the number of the selected items in a listview.
  • #define LVM_GETTOPVISIBLE 0xF131
    Retrieves the index of the topmost visible item in a listview.
  • #define LVM_NULL 0xF132
    reserved.
  • #define LVM_SETITEMSTATE 0xF133
    reserved.
  • #define LVM_SORTITEMS 0xF134
    Uses an application-defined comparision function to sort the items.
  • #define LVM_SETITEMHEIGHT 0xF135
    Changes the height of a item.
  • #define LVM_SETHEADHEIGHT 0xF136
    Changes the height of the header.
  • #define LVM_GETITEMADDDATA 0xF137
    Gets the 32-bit data value associated with an item.
  • #define LVM_SETITEMADDDATA 0xF138
    Associates a 32-bit data value with an item.
  • #define LVM_CHOOSEITEM 0xF139
    Selects and shows an item.
  • #define LVM_SETSTRCMPFUNC 0xF140
    Sets the STRCMP function used to sort items.
  • #define LVM_GETRELATEDITEM 0xF141
    Retrives related item of specific item.
  • #define LVM_FOLDITEM 0xF142
    Folds or unfolds an item.
  • #define LVM_SETCUSTOMDRAW 0xF143
    Sets the customized drawing functions of listview.
  • #define LVM_GETSELECTEDITEMRECT 0xF144
    Get the selected item's Rectangle.

Define Documentation

#define LVM_ADDCOLUMN 0xF112

Adds a new column to listview, identified by column.

  LVM_ADDCOLUMN
  PLVCOLUMN p;

  wParam = 0;
  lParam =(LPARAM)p;

Parameters:
p Pointes to a LVCOLUMN structure that contains the information about the new column to be added.

Definition at line 414 of file listview.h.

#define LVM_ADDITEM 0xF110

Adds a item to listview, this item is also called a row.

  LVM_ADDITEM
  PLVITEM p
  HLVITEM parent;

  wParam = (WPARAM)parent;
  p =(LPARAM)lParam;

Parameters:
p | Pointes to a LVITEM structure that contains the information of the new item to be added. nItem member of the LVITEM struct speficied the item position in its parent item, beginning with zero.
parent | Handle of the parent item into which the new item is about to insert. If parent equals zero, the parent item will be the root of listview.
Returns:
Returns the handle of the new item if successful, or 0 otherwise.

Definition at line 373 of file listview.h.

#define LVM_CHOOSEITEM 0xF139

Selects and shows an item.

 LVM_CHOOSEITEM
 int nRow;
 HLVITEM pi;

 wParam = (WPARAM)nRow;
 lParam = (LPARAM)pi;

Parameters:
nRow | If pi is zero, nRow specified the row index of the target item to choose.
pi | Handle of the target item.
Returns:
Always returns 0.

Definition at line 1054 of file listview.h.

#define LVM_CLEARSUBITEM 0xF114

Clears the content of a subitem.

 LVM_CLEARSUBITEM
 PLVSUBITEM p;
 HLVITEM pi;

 lParam = (LPARAM)p;
 wParam = (WPARAM)pi;

Parameters:
p | Pointes to a PLVSUBITEM structure that contains the information of the subitem to clear. If pi is not zero, nItem member of this struct has no meaning.
pi | Handle of the target item. If pi equals zero, the row position of the target item is specified by nItem member of p structure.
Returns:
Returns LV_OKAY if successful, or LV_ERR otherwise.

Definition at line 458 of file listview.h.

#define LVM_COLSORT 0xF116

Sorts all subitems according to a certain column.

 LVM_COLSORT
 int ncol;

 wParam = (WPARAM)ncol;
 lParam = 0;

Parameters:
ncol Index of the column.
Returns:
Returns LV_OKAY if successful, or LV_ERR otherwise.

Definition at line 492 of file listview.h.

#define LVM_DELALLITEM 0xF11D

Removes all the items in listview.

 LVM_DEALLITEM

 wParam = 0;
 lParam = 0;

Returns:
Returns TRUE if successful, or FALSE otherwise.

Definition at line 621 of file listview.h.

#define LVM_DELCOLUMN 0xF115

Deletes a column from listview, all subitem in this column will be removed.

 LVM_DELCOLUMN
 int nCols;

 wParam = (WPARAM)nCol;
 lParam = 0;

Parameters:
nCol The index of the column to be removed.
Returns:
Returns LV_OKAY if successful, or LV_ERR otherwise.

Definition at line 475 of file listview.h.

#define LVM_DELITEM 0xF113

Deletes an item form listview.

 LVM_DELITEM
 int nRow;
 HLVITEM pi;

 wParam = (WPARAM)nRow;
 lParam = (LPARAM)pi;

Parameters:
nRow | If pi is zero, nRow specified the row index of the target item to delete.
pi | Handle of the target item.
Returns:
Returns LV_OKAY if successful, or LV_ERR otherwise.

Definition at line 434 of file listview.h.

#define LVM_FILLSUBITEM 0xF111

Sets the content of a subitem, indentified by rows and columns.

 LVM_FILLSUBITEM
 PLVSUBITEM p;
 HLVITEM pi;

 lParam = (LPARAM)p;
 wParam = (WPARAM)pi;

Parameters:
p | Pointes to a PLVSUBITEM structure that contains the information of the subitem to set. If pi is not zero, nItem member of this struct has no meaning.
pi | Handle of the target item. If pi equals zero, the row position of the target item is specified by nItem member of p structure.
Returns:
Returns LV_OKAY if successful, or LV_ERR otherwise.

Definition at line 397 of file listview.h.

#define LVM_FINDITEM 0xF118

Searchs a item.

 LVM_FINDITEM
 PLVFINDINFO plvfi;
 HLVITEM parent;
 wParam = (WPARAM)parent;
 lParam = (LPARAM)plvfi;
Parameters:
parent | Handle of the item to search in.
plvfi | Points to a LVFINDINFO structure containing information for searching. If parent is zero, iStart member of plvfi specifieds the start position on search.
Returns:
Returns the handle of the found item if successful, or 0 otherwise.

Definition at line 535 of file listview.h.

#define LVM_FOLDITEM 0xF142

Folds or unfolds an item.

 LVM_FOLDITEM
 int bFold;
 HLVITEM pi;

 wParam = (WPARAM)bFold;
 lParam = (LPARAM)pi;

Parameters:
bFold | To fold or to unfold, TRUE is to fold.
pi | Handle of the target item.
Returns:
Always returns 0.

Definition at line 1140 of file listview.h.

#define LVM_GETCOLUMN 0xF125

Retrieves the information about a listview column.

 LVM_GETCOLUMN
 int nCol;
 PLVCOLUMN pcol;

 wParam = (WPARAM)nCol;
 lParam = (LPARAM)pcol;

Parameters:
nCol | Index of the column.
pcol | Points to a LVCOLUMN structure for retrieving the information about the column.
Returns:
Returns TRUE if successful, or FALSE otherwise.

Definition at line 790 of file listview.h.

#define LVM_GETCOLUMNCOUNT 0xF11B

Gets the number of all the columns in listview.

 LVM_GETCOLUMNCOUNT

 wParam = 0;
 lParam = 0;

Returns:
Returns the number of all the columns in listview.

Definition at line 591 of file listview.h.

#define LVM_GETCOLUMNWIDTH 0xF126

Retrieves the width of a listview column.

 LVM_GETCOLUMNWIDTH
 int nCol;

 wParam = (WPARAM)nCol;
 lParam = (LPARAM)0;

Parameters:
nCol Index of the column.
Returns:
Returns the column width if successful, or -1 otherwise.

Definition at line 808 of file listview.h.

#define LVM_GETITEM 0xF127

Retrieves the item's attributes.

 LVM_GETITEM
 HLVITEM pi;
 LVITEM item_info;

 wParam = (WPARAM)pi;
 lParam = (LPARAM)&item_info;

Parameters:
pi | Handle of the target item.
item_info | Used for storing the target item's attributes. If pi is zero, nItem field of item_info specified the row index of the target item to get.
Returns:
Returns LV_OKAY if successful, or LV_ERR otherwise.

Definition at line 830 of file listview.h.

#define LVM_GETITEMADDDATA 0xF137

Gets the 32-bit data value associated with an item.

An application sends an LVM_GETITEMADDDATA message to a listview to get the 32-bit data value stored for the item with index of wParam; By default this is zero. An application must set the item data value by sending an LVM_SETITEMADDDATA message to the listview for this value to have meaning.

 LVM_GETITEMADDDATA
 int index;
 HLVITEM pi;

 wParam = (WPARAM)index;
 lParam = (LPARAM)pi;

Parameters:
pi | Handle of the target item.
index | The index of the specified item. If pi is not zero, use pi instead.
Returns:
The 32-bit data value associated with an item on success, otherwise -1 to indicate an error.

Definition at line 1008 of file listview.h.

#define LVM_GETITEMCOUNT 0xF11A

Gets the number of all the items(rows) in a listview.

 LVM_GETITEMCOUNT

 wParam = 0;
 lParam = 0;

Returns:
The number of the items.

Definition at line 576 of file listview.h.

#define LVM_GETITEMSTATE 0xF128

Retrieves the state of a listview item.

 LVM_GETITEMSTATE
 UINT mask;
 HLVITEM pi;

 wParam = (WPARAM)pi;
 lParam = (LPARAM)mask;

Parameters:
pi | Handle of the target item.
mask | Contains state information to retrieve, can be the combination of the following values.
Returns:
Returns the current state of the specified item.

Definition at line 851 of file listview.h.

#define LVM_GETRELATEDITEM 0xF141

Retrives related item of specific item.

 LVM_GETRELATEDITEM
 int related;
 GHANDLE item;

 wParam = (WPARAM)related;
 lParam = (LPARAM)item;

Parameters:
related A integer which indicates the relationship between the item to retrive and the specified item, can be one of the following values:
  • TVIR_PARENT
    To retrive the parent item of the specified item.
  • TVIR_FIRSTCHILD
    To retrive the first child item of the specified item.
  • TVIR_NEXTSIBLING
    To retrive the next sibling item of the specified item.
  • TVIR_PREVSIBLING
    To retrive the previous sibling item of the specified item.
item The handle to the known item.
Returns:
The handle of the related item on success, otherwise 0.

Definition at line 1120 of file listview.h.

#define LVM_GETSELECTEDCOLUMN 0xF129

Retrieves the index of the currently selected column of a listview.

 LVM_GETSELECTEDCOLUMN

 wParam = 0;
 lParam = 0;

Returns:
Returns the index of the selected column.

Definition at line 866 of file listview.h.

#define LVM_GETSELECTEDCOUNT 0xF130

Retrieves the number of the selected items in a listview.

 LVM_GETSELECTEDCOUNT

 wParam = 0;
 lParam = 0;

Returns:
Returns the number of the selected items.

Definition at line 881 of file listview.h.

#define LVM_GETSELECTEDITEM 0xF11C

Gets the current selected item.

 LVM_GETSELECTEDITEM

 wParam = 0;
 lParam = 0;

Returns:
Returns the handle of the current selected item.

Definition at line 606 of file listview.h.

#define LVM_GETSELECTEDITEMRECT 0xF144

Get the selected item's Rectangle.

 LVM_GETSELECTEDITEMRECT
 RECT * prcItem

 wPram = (WPARAM)0
 lParam = (LPARAM)prcItem

Parameters:
prcItem Pointer to a RECT which recieve the Item Rectangle
Returns:
If got, return TRUE, otherwise return FALSE

Definition at line 1176 of file listview.h.

#define LVM_GETSUBITEMLEN 0xF121

Gets the text length of the subitem.

 LVM_GETSUBITEMLEN
 PLVSUBITEM p;
 HLVITEM pi;

 lParam = (LPARAM)p;
 wParam = (WPARAM)pi;

Parameters:
p | Pointes to a PLVSUBITEM structure that contains the information of the subitem to set. If pi is not zero, nItem member of this struct has no meaning.
pi | Handle of the target item. If pi equals zero, the row position of the target item is specified by nItem member of p structure.
Returns:
Returns the text length if successful, or LV_ERR otherwise.

Definition at line 703 of file listview.h.

#define LVM_GETSUBITEMTEXT 0xF119

Retrieves the text of a listview subitem.

 LVM_GETSUBITEMTEXT
 PLVSUBITEM p;
 HLVITEM pi;

 lParam = (LPARAM)p;
 wParam = (WPARAM)pi;

Parameters:
p | Pointes to a PLVSUBITEM structure that contains the information of the subitem to set. If pi is not zero, nItem member of this struct has no meaning.
pi | Handle of the target item. If pi equals zero, the row position of the target item is specified by nItem member of p structure.
Returns:
Returns len of the text if successful, -1 otherwise.

Definition at line 561 of file listview.h.

#define LVM_GETTOPVISIBLE 0xF131

Retrieves the index of the topmost visible item in a listview.

 LVM_GETTOPVISIBLE

 wParam = 0;
 lParam = 0;

Returns:
Returns the index of the topmost visible item if successful, or zero.

Definition at line 896 of file listview.h.

#define LVM_MODIFYHEAD 0xF11E

Changes the title of a column.

 LVM_MODIFYHEAD
 PLVCOLUMN pcol;

 wParam = 0;
 lParam = (LPARAM)pcol;

Parameters:
pcol Pointer to a LVCOLUMN struct.
Returns:
Returns LV_OKAY if successfull, or LV_ERR otherwise.

Definition at line 638 of file listview.h.

#define LVM_NULL 0xF132

reserved.

Definition at line 902 of file listview.h.

#define LVM_SELECTITEM 0xF11F

Selects an item.

 LVM_SELECTITEM
 int nRow;
 HLVITEM pi;

 wParam = (WPARAM)nRow;
 lParam = (LPARAM)pi;

Parameters:
nRow | If pi is zero, nRow specified the row index of the target item to select.
pi | Handle of the target item.
Returns:
Always returns 0.

Definition at line 658 of file listview.h.

#define LVM_SETCOLUMN 0xF122

Sets the attributes of a list view column.

 LVM_SETCOLUMN
 PLVCOLUMN pcol;

 wParam = 0;
 lParam = (LPARAM)pcol;

Parameters:
pcol Points to a LVCOLUMN structure containing the new column information.
Returns:
Returns LV_OKAY if successful, or LV_ERR otherwise.

Definition at line 721 of file listview.h.

#define LVM_SETCUSTOMDRAW 0xF143

Sets the customized drawing functions of listview.

 LVM_SETCUSTOMDRAW
 LVCUSTOMDRAWFUNCS myFuncs;

 wParam = (WPARAM)0;
 lParam = (LPARAM)&myFuncs;

Parameters:
myFuncs Pointer to a customized drawing functions structure.
Returns:
Always returns 0.

Definition at line 1158 of file listview.h.

#define LVM_SETHEADHEIGHT 0xF136

Changes the height of the header.

 LVM_SETHEADHEIGHT
 int height;

 wParam = (WPARAM)height;
 lParam = 0;

Parameters:
height The new height of the header.
Returns:
Returns TRUE if successful, or FALSE otherwise.

Definition at line 981 of file listview.h.

#define LVM_SETITEMADDDATA 0xF138

Associates a 32-bit data value with an item.

An application sends an LVM_SETITEMADDDATA message to associate a 32-bit data value specified in the lParam parameter with an item in the listview.

 LVM_SETITEMADDDATA
 HLVITEM pi;
 DWORD addData;

 wParam = (WPARAM)pi;
 lParam = (LPARAM)addData;

Parameters:
pi | Handle of the target item.
addData | The 32-bit data value which will associated with the item.
Returns:
One of the following values:
  • LV_OKAY
    Success
  • LV_ERR
    Invalid item index

Definition at line 1034 of file listview.h.

#define LVM_SETITEMHEIGHT 0xF135

Changes the height of a item.

 LVM_SETITEMHEIGHT
 int height;
 HLVITEM pi;

 wParam = (WPARAM)pi;
 lParam = (LPARAM)height;

Parameters:
height | The new height of the item.
pi | Handle of the target item.
Returns:
Returns TRUE if successful, or FALSE otherwise.

Definition at line 964 of file listview.h.

#define LVM_SETITEMSTATE 0xF133

reserved.

Definition at line 908 of file listview.h.

#define LVM_SETSTRCMPFUNC 0xF140

Sets the STRCMP function used to sort items.

An application sends a LVM_SETSTRCMPFUNC message to set a new STRCMP function to sort items in the Listview control.

Note that you should send this message before adding any item to the Listview control.

 static int my_strcmp (const char* s1, const char* s2, size_t n)
 {
      ...
      return 0;
 }

 LVM_SETSTRCMPFUNC

 wParam = 0;
 lParam = (LPARAM) my_strcmp;

Parameters:
my_strcmp Your own function to compare two strings.
Returns:
One of the following values:
  • 0
    Success
  • -1
    Not an empty TreeView control

Definition at line 1085 of file listview.h.

#define LVM_SETSUBITEM 0xF124

Sets the attributes of a subitem.

 LVM_SETSUBITEM
 PLVSUBITEM p;
 HLVITEM pi;

 lParam = (LPARAM)p;
 wParam = (WPARAM)pi;

Parameters:
p | Pointes to a PLVSUBITEM structure that contains the information of the subitem to set. If pi is not zero, nItem member of this struct has no meaning.
pi | Handle of the target item. If pi equals zero, the row position of the target item is specified by nItem member of p structure.
Returns:
Returns LV_OKAY if successful, or LV_ERR otherwise.

Definition at line 769 of file listview.h.

#define LVM_SETSUBITEMCOLOR 0xF117

Sets the text color of a subitem.

 LVM_SETSUBITEMCOLOR
 PLVSUBITEM p;
 HLVITEM pi;

 lParam = (LPARAM)p;
 wParam = (WPARAM)pi;

Parameters:
p | Pointes to a PLVSUBITEM structure that contains the information of the subitem to set. If pi is not zero, nItem member of this struct has no meaning.
pi | Handle of the target item. If pi equals zero, the row position of the target item is specified by nItem member of p structure.
Returns:
Always returns 0;

Definition at line 516 of file listview.h.

#define LVM_SETSUBITEMTEXT 0xF123

Sets the text of a subitem.

 LVM_SETSUBITEMTEXT
 PLVSUBITEM p;
 HLVITEM pi;

 wParam = (WPARAM)pi;
 lParam = (LPARAM)p;

Parameters:
p | Pointes to a PLVSUBITEM structure that contains the information of the subitem to set. If pi is not zero, nItem member of this struct has no meaning.
pi | Handle of the target item. If pi equals zero, the row position of the target item is specified by nItem member of p structure.
Returns:
Returns LV_OKAY if successful, or LV_ERR otherwise.

Definition at line 745 of file listview.h.

#define LVM_SHOWITEM 0xF120

Makes the item is entirely visible in the list view.

 LVM_SHOWITEM
 int nRow;
 HLVITEM pi;

 wParam = (WPARAM)nRow;
 lParam = (LPARAM)pi;

Parameters:
nRow | If pi is zero, nRow specified the row index of the target item to show.
pi | Handle of the target item.
Returns:
Always returns 0.

Definition at line 679 of file listview.h.

#define LVM_SORTITEMS 0xF134

Uses an application-defined comparision function to sort the items.

 LVM_SORTITEMS
 PLVSORTDATA sortData;
 PFNLVCOMPARE pfnCompare;

 wParam = (WPARAM)sortData;
 lParam = (LPARAM)pfnCompare;

Parameters:
sortData | Sorting datas passed to the comparision function.
pfnCompare | Pointer to the application-defined comparision function. The comparision function is called during the sort operation each time the relative order of the two items needs to be compared.
The comparison function must return a negative value if the first item precedes the second, a positive value if the first item follows the second, or zero if the two items are equivalent.

The comparision function has the following form:

int CompareFunction(int nItem1, int nItem2, PLVSORTDATA sortData);

nItem1 is the handle of the first item, nItem2 is the handle of the second item, and sortData is passed to CompareFunction as the third parameter.

Returns:
Returns TRUE if successful, or FALSE otherwise.

Definition at line 944 of file listview.h.

Generated on Fri Dec 17 13:49:46 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Notification code of ListView control

Notification code of ListView control
[ListView control]

Defines

  • #define LVN_CLICKED 1
    This notification code informs parent window the mouse clicked.
  • #define LVN_SELCHANGE 2
    This notification code informs parent window the current selected item has changed.
  • #define LVN_ITEMRDOWN 4
    This notification code informs parent window the right mouse button down on a listview item.
  • #define LVN_ITEMRUP 5
    This notification code informs parent window the right mouse button up on a listview item.
  • #define LVN_HEADRDOWN 6
    This notification code informs parent window the right mouse button down on the listview header.
  • #define LVN_HEADRUP 7
    This notification code informs parent window the right mouse button up on the listview header.
  • #define LVN_KEYDOWN 8
    This notification code informs parent window that a key has been pressed.
  • #define LVN_ITEMDBCLK 9
    This notification code informs parent window the current selected item has be double clicked.
  • #define LVN_ITEMCLK 10
    This notification code informs parent window the current selected item has been clicked.
  • #define LVN_COLCHANGE 11
    This notification code informs parent window the current selected column has changed.
  • #define LVN_FOLDED 12
    This notification code informs that user folds an item by mouse clicking.
  • #define LVN_UNFOLDED 13
    This notification code informs that user unfolds an item by mouse clicking.

Define Documentation

#define LVN_CLICKED 1

This notification code informs parent window the mouse clicked.

Definition at line 1190 of file listview.h.

#define LVN_COLCHANGE 11

This notification code informs parent window the current selected column has changed.

Definition at line 1253 of file listview.h.

#define LVN_FOLDED 12

This notification code informs that user folds an item by mouse clicking.

Definition at line 1260 of file listview.h.

#define LVN_HEADRDOWN 6

This notification code informs parent window the right mouse button down on the listview header.

Definition at line 1218 of file listview.h.

#define LVN_HEADRUP 7

This notification code informs parent window the right mouse button up on the listview header.

Definition at line 1225 of file listview.h.

#define LVN_ITEMCLK 10

This notification code informs parent window the current selected item has been clicked.

Definition at line 1246 of file listview.h.

#define LVN_ITEMDBCLK 9

This notification code informs parent window the current selected item has be double clicked.

Definition at line 1239 of file listview.h.

#define LVN_ITEMRDOWN 4

This notification code informs parent window the right mouse button down on a listview item.

Definition at line 1204 of file listview.h.

#define LVN_ITEMRUP 5

This notification code informs parent window the right mouse button up on a listview item.

Definition at line 1211 of file listview.h.

#define LVN_KEYDOWN 8

This notification code informs parent window that a key has been pressed.

Definition at line 1231 of file listview.h.

#define LVN_SELCHANGE 2

This notification code informs parent window the current selected item has changed.

Definition at line 1197 of file listview.h.

#define LVN_UNFOLDED 13

This notification code informs that user unfolds an item by mouse clicking.

Definition at line 1267 of file listview.h.

Generated on Fri Dec 17 13:49:46 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: ListView control

ListView control
[Standard controls]

Modules

  • Styles of listview control
  • Messages of ListView control
  • Notification code of ListView control

Data Structures

  • struct _LVITEM
  • struct _LVSUBITEM
  • struct _LVSORTDATA
  • struct _LVCUSTOMDRAWFUNCS
  • struct _LVCOLUMN
  • struct _LVFINDINFO
  • struct _LVNM_NORMAL

Defines

  • #define CTRL_LISTVIEW ("ListView")
    The class name of listview control.
  • #define LV_OKAY 0
  • #define LV_ERR (-1)
  • #define LV_ERRSPACE (-2)
  • #define LVIF_FOLD 0x0001L
    listview item flags, is used inside minigui.
  • #define LVFLAG_BITMAP 0x0001
  • #define LVFLAG_ICON 0x0002
  • #define LVCF_LEFTALIGN 0x0000
  • #define LVCF_RIGHTALIGN 0x0001
  • #define LVCF_CENTERALIGN 0x0002
  • #define LVCF_TREEVIEW 0x0004
  • #define LVHF_LEFTALIGN 0x0000
  • #define LVHF_RIGHTALIGN 0x0004
  • #define LVHF_CENTERALIGN 0x0008
  • #define LVFF_TEXT 0x0001
  • #define LVFF_ADDDATA 0x0002

Typedefs

  • typedef GHANDLE HLVITEM
    List view item handle.
  • typedef LVITEM * PLVITEM
  • typedef LVSUBITEM * PLVSUBITEM
  • typedef LVSORTDATA * PLVSORTDATA
  • typedef int(* PFNLVCOMPARE )(HLVITEM nItem1, HLVITEM nItem2, PLVSORTDATA sortData)
  • typedef void(* PFN_LVHDR_BKDRAWFUNC )(HWND hWnd, HLVHDR hlvhdr, HDC hdc, RECT *rcDraw)
  • typedef void(* PFN_LVHDR_ITEMDRAWFUNC )(HWND hWnd, int idx, HDC hdc, RECT *rcDraw)
  • typedef LVCOLUMN * PLVCOLUMN
  • typedef LVFINDINFO * PLVFINDINFO
  • typedef LVNM_NORMAL * PLVNM_NORMAL
  • typedef LVNM_NORMAL LVNM_KEYDOWN
  • typedef LVNM_KEYDOWN * PLVNM_KEYDOWN
  • typedef LVNM_NORMAL LVNM_HEADRDOWN
  • typedef LVNM_HEADRDOWN * PLVNM_HEADRDOWN
  • typedef LVNM_NORMAL LVNM_HEADRUP
  • typedef LVNM_HEADRUP * PLVNM_HEADUP
  • typedef LVNM_NORMAL LVNM_ITEMRDOWN
  • typedef LVNM_ITEMRDOWN * PLVNM_ITEMRDOWN
  • typedef LVNM_NORMAL LVNM_ITEMRUP
  • typedef LVNM_ITEMRUP * PLVNM_ITEMRUP

Define Documentation

#define CTRL_LISTVIEW ("ListView")

The class name of listview control.

Definition at line 51 of file listview.h.

#define LV_ERR (-1)

Listview return value

Definition at line 56 of file listview.h.

#define LV_ERRSPACE (-2)

Listview return value

Definition at line 58 of file listview.h.

#define LV_OKAY 0

Listview return value

Definition at line 54 of file listview.h.

#define LVCF_CENTERALIGN 0x0002

Column text center align

Definition at line 180 of file listview.h.

#define LVCF_LEFTALIGN 0x0000

Column flags Column text left align, default

Definition at line 176 of file listview.h.

#define LVCF_RIGHTALIGN 0x0001

Column text right align

Definition at line 178 of file listview.h.

#define LVCF_TREEVIEW 0x0004

Column treeview style

Definition at line 182 of file listview.h.

#define LVFF_ADDDATA 0x0002

Search by addtional data

Definition at line 220 of file listview.h.

#define LVFF_TEXT 0x0001

Listview search flags Search by text

Definition at line 218 of file listview.h.

#define LVFLAG_BITMAP 0x0001

Listview bitmap flags

Definition at line 104 of file listview.h.

#define LVFLAG_ICON 0x0002

Listview icon flags

Definition at line 106 of file listview.h.

#define LVHF_CENTERALIGN 0x0008

Header text center align

Definition at line 190 of file listview.h.

#define LVHF_LEFTALIGN 0x0000

Header flags Header text left align, default

Definition at line 186 of file listview.h.

#define LVHF_RIGHTALIGN 0x0004

Header text right align

Definition at line 188 of file listview.h.

#define LVIF_FOLD 0x0001L

listview item flags, is used inside minigui.

Definition at line 70 of file listview.h.

Typedef Documentation

typedef GHANDLE HLVITEM

List view item handle.

Definition at line 64 of file listview.h.

typedef LVNM_NORMAL LVNM_HEADRDOWN

Contains listview notification information when mouse down on the header

Definition at line 269 of file listview.h.

typedef LVNM_NORMAL LVNM_HEADRUP

Contains listview notification information when mouse up on the header

Definition at line 274 of file listview.h.

typedef LVNM_NORMAL LVNM_ITEMRDOWN

Contains listview notification information when mouse down on the item area

Definition at line 279 of file listview.h.

typedef LVNM_NORMAL LVNM_ITEMRUP

Contains listview notification information when mouse up on the item area

Definition at line 284 of file listview.h.

typedef LVNM_NORMAL LVNM_KEYDOWN

Keydown notification information

Definition at line 264 of file listview.h.

typedef void(* PFN_LVHDR_BKDRAWFUNC)(HWND hWnd, HLVHDR hlvhdr, HDC hdc, RECT *rcDraw)

Type of listview header background drawing function

Definition at line 159 of file listview.h.

typedef void(* PFN_LVHDR_ITEMDRAWFUNC)(HWND hWnd, int idx, HDC hdc, RECT *rcDraw)

Type of listview header item drawing function

Definition at line 161 of file listview.h.

typedef int(* PFNLVCOMPARE)(HLVITEM nItem1, HLVITEM nItem2, PLVSORTDATA sortData)

Type of listview comparision fuction

Definition at line 152 of file listview.h.

typedef LVCOLUMN* PLVCOLUMN

Data type of pointer to a LVCOLUMN

Definition at line 214 of file listview.h.

typedef LVFINDINFO* PLVFINDINFO

Data type of pointer to a LVFINDINFO

Definition at line 250 of file listview.h.

typedef LVITEM* PLVITEM

Data type of the pointer to a LVITEM

Definition at line 101 of file listview.h.

typedef LVNM_HEADRDOWN* PLVNM_HEADRDOWN

Data type of pointer to a LVNM_HEADRDOWN

Definition at line 271 of file listview.h.

typedef LVNM_HEADRUP* PLVNM_HEADUP

Data type of pointer to a LVNM_HEADRUP

Definition at line 276 of file listview.h.

typedef LVNM_ITEMRDOWN* PLVNM_ITEMRDOWN

Data type of pointer to a LVNM_ITEMRDOWN

Definition at line 281 of file listview.h.

typedef LVNM_ITEMRUP* PLVNM_ITEMRUP

Data type of pointer to a LVNM_ITEMRUP

Definition at line 286 of file listview.h.

typedef LVNM_KEYDOWN* PLVNM_KEYDOWN

Data type of pointer to a LVNM_KEYDOWN

Definition at line 266 of file listview.h.

typedef LVNM_NORMAL* PLVNM_NORMAL

Data type of pointer to a LVNM_NORMAL

Definition at line 261 of file listview.h.

typedef LVSORTDATA* PLVSORTDATA

Data type of pointer to a LVSORTDATA

Definition at line 149 of file listview.h.

typedef LVSUBITEM* PLVSUBITEM

Data type of the pointer to a LVSUBITEM

Definition at line 136 of file listview.h.

Generated on Fri Dec 17 13:49:46 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _LVITEM Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_LVITEM Struct Reference
[ListView control]

#include <listview.h>

Data Fields

  • int nItem
  • int nItemHeight
  • DWORD itemData
  • DWORD dwFlags

Detailed Description

Structure of the listview item info, contains information about an item. This structure is used for creating or retrieving an item.

Definition at line 76 of file listview.h.

Field Documentation

int nItem

The rows of the item

Definition at line 81 of file listview.h.

int nItemHeight

Height of the item

Definition at line 83 of file listview.h.

DWORD itemData

Attached additional data of this item

Definition at line 85 of file listview.h.

DWORD dwFlags

State flags of the item, can be OR'ed by the following values:

  • LVIF_FOLD
    The item is folded.

When adding an item to the listview control, only LVIF_FOLD flag is valid.

Definition at line 96 of file listview.h.

The documentation for this struct was generated from the following file:
  • listview.h
Generated on Fri Dec 17 13:49:52 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _LVSUBITEM Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_LVSUBITEM Struct Reference
[ListView control]

#include <listview.h>

Data Fields

  • DWORD flags
  • int nItem
  • int subItem
  • char * pszText
  • int nTextMax
  • int nTextColor
  • DWORD image

Detailed Description

Struct of the listview subitem info, contains information about a subitem. This structure is used for creating or retrieving a subitem.

Definition at line 112 of file listview.h.

Field Documentation

DWORD flags

Flags of the subitem, can be OR'ed by the following values:

  • LVFLAG_BITMAP The sub item has a bitmap icon.
  • LVFLAG_ICON The sub item has an icon.

Definition at line 121 of file listview.h.

int nItem

The Subitem vertical position(rows)

Definition at line 123 of file listview.h.

int subItem

The Subitem horizontal position(columns)

Definition at line 125 of file listview.h.

char* pszText

Text content of this subitem

Definition at line 127 of file listview.h.

int nTextMax

Max text len

Definition at line 129 of file listview.h.

int nTextColor

Text color of the subitem

Definition at line 131 of file listview.h.

DWORD image

Image of the subitem, can be bitmap or icon, determined by flags

Definition at line 133 of file listview.h.

The documentation for this struct was generated from the following file:
  • listview.h
Generated on Fri Dec 17 13:49:52 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _LVSORTDATA Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_LVSORTDATA Struct Reference
[ListView control]

#include <listview.h>

Data Fields

  • int ncol
  • int losorted
  • HWND hLV

Detailed Description

Contains information for sorting listview

Definition at line 139 of file listview.h.

Field Documentation

int ncol

Sorting column index

Definition at line 142 of file listview.h.

int losorted

Low sorted or high sorted

Definition at line 144 of file listview.h.

HWND hLV

Listview handle

Definition at line 146 of file listview.h.

The documentation for this struct was generated from the following file:
  • listview.h
Generated on Fri Dec 17 13:49:52 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _LVCUSTOMDRAWFUNCS Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_LVCUSTOMDRAWFUNCS Struct Reference
[ListView control]

#include <listview.h>

Data Fields

  • PFN_LVHDR_BKDRAWFUNC pfnDrawHdrBk
  • PFN_LVHDR_ITEMDRAWFUNC pfnDrawHdrItem

Detailed Description

Contains function pointers for customized drawing

Definition at line 165 of file listview.h.

Field Documentation

PFN_LVHDR_BKDRAWFUNC pfnDrawHdrBk

Colunm header background drawing function

Definition at line 168 of file listview.h.

PFN_LVHDR_ITEMDRAWFUNC pfnDrawHdrItem

Colunm header item drawing function

Definition at line 170 of file listview.h.

The documentation for this struct was generated from the following file:
  • listview.h
Generated on Fri Dec 17 13:49:52 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _LVCOLUMN Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_LVCOLUMN Struct Reference
[ListView control]

#include <listview.h>

Data Fields

  • int nCols
  • int width
  • char * pszHeadText
  • int nTextMax
  • DWORD image
  • PFNLVCOMPARE pfnCompare
  • DWORD colFlags

Detailed Description

Struct of the listview column info, contains information about a column. This structure is used for creating or retrieving a column.

Definition at line 196 of file listview.h.

Field Documentation

int nCols

The horizontal position

Definition at line 199 of file listview.h.

int width

Column's width

Definition at line 201 of file listview.h.

char* pszHeadText

The title of this column

Definition at line 203 of file listview.h.

int nTextMax

Max text len

Definition at line 205 of file listview.h.

DWORD image

Image of the column header, can be bitmap or icon

Definition at line 207 of file listview.h.

PFNLVCOMPARE pfnCompare

Comparision function associated with the column

Definition at line 209 of file listview.h.

DWORD colFlags

Column and header flags

Definition at line 211 of file listview.h.

The documentation for this struct was generated from the following file:
  • listview.h
Generated on Fri Dec 17 13:49:52 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _LVFINDINFO Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_LVFINDINFO Struct Reference
[ListView control]

#include <listview.h>

Data Fields

  • DWORD flags
  • int iStart
  • int nCols
  • char ** pszInfo
  • DWORD addData
  • int nItem
  • int nSubitem

Detailed Description

Contains information for finding a certain item info

Definition at line 223 of file listview.h.

Field Documentation

DWORD flags

Type of search to perform. This member can be set to one or more of the following values:

  • LVFF_TEXT Searches based on the item(subitems) text.
  • LVFF_ADDDATA Searches based on the attached additional item data.

Definition at line 233 of file listview.h.

int iStart

Search index to begin with, 0 from the beginning

Definition at line 235 of file listview.h.

int nCols

PszInfo containing nCols columns' text

Definition at line 237 of file listview.h.

char** pszInfo

All the subitem's content of this item

Definition at line 239 of file listview.h.

DWORD addData

The additional item data

Definition at line 241 of file listview.h.

int nItem

The found item's row, reserved

Definition at line 244 of file listview.h.

int nSubitem

The found subitem's column, reserved

Definition at line 246 of file listview.h.

The documentation for this struct was generated from the following file:
  • listview.h
Generated on Fri Dec 17 13:49:52 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _LVNM_NORMAL Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_LVNM_NORMAL Struct Reference
[ListView control]

#include <listview.h>

Data Fields

  • WPARAM wParam
  • LPARAM lParam

Detailed Description

Contains listview general notification information

Definition at line 253 of file listview.h.

Field Documentation

WPARAM wParam

wParam parameter of the message

Definition at line 256 of file listview.h.

LPARAM lParam

lParam parameter of the message

Definition at line 258 of file listview.h.

The documentation for this struct was generated from the following file:
  • listview.h
Generated on Fri Dec 17 13:49:52 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Styles of menubutton control

Styles of menubutton control
[MenuButton control]

Defines

  • #define MBS_SORT 0x0001
    If this bit is set, the items listed in the control are displayed in a specified order.
  • #define MBS_LEFTARROW 0x0002
    The menu pull-down arrow will be display at the left of the text.
  • #define MBS_NOBUTTON 0x0004
    The control have not push button.
  • #define MBS_ALIGNLEFT 0x0000
    The text on menubutton is left-align (default).
  • #define MBS_ALIGNRIGHT 0x0010
    The text on menubutton is right-align.
  • #define MBS_ALIGNCENTER 0x0020
    The text on menubutton is center-align.
  • #define MBS_ALIGNMASK 0x00F0
    The align mask of menubutton.

Define Documentation

#define MBS_ALIGNCENTER 0x0020

The text on menubutton is center-align.

Definition at line 141 of file menubutton.h.

#define MBS_ALIGNLEFT 0x0000

The text on menubutton is left-align (default).

Definition at line 129 of file menubutton.h.

#define MBS_ALIGNMASK 0x00F0

The align mask of menubutton.

Definition at line 147 of file menubutton.h.

#define MBS_ALIGNRIGHT 0x0010

The text on menubutton is right-align.

Definition at line 135 of file menubutton.h.

#define MBS_LEFTARROW 0x0002

The menu pull-down arrow will be display at the left of the text.

Definition at line 117 of file menubutton.h.

#define MBS_NOBUTTON 0x0004

The control have not push button.

Definition at line 123 of file menubutton.h.

#define MBS_SORT 0x0001

If this bit is set, the items listed in the control are displayed in a specified order.

Definition at line 111 of file menubutton.h.

Generated on Fri Dec 17 13:49:46 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Messages of menubutton control

Messages of menubutton control
[MenuButton control]

Defines

  • #define MBM_ADDITEM 0xF200
    Sends to the control to add an item to the menu list.
  • #define MBM_DELITEM 0xF201
    Sends to the control to delete an item in the menu list.
  • #define MBM_RESETCTRL 0xF202
    Sends to the control to remove all items in the menu list.
  • #define MBM_SETITEMDATA 0xF203
    Sends to the control to set the data of a specific item.
  • #define MBM_GETITEMDATA 0xF204
    Sends to the control to retrive the data of a specific item.
  • #define MBM_GETCURITEM 0xF206
    Sends to get the index of the current selected item.
  • #define MBM_SETCURITEM 0xF207
    Sends to set the current selected item based on index.
  • #define MBM_SETSTRCMPFUNC 0xF208
    Sets the STRCMP function used to sort items.

Define Documentation

#define MBM_ADDITEM 0xF200

Sends to the control to add an item to the menu list.

 MBM_ADDITEM
 int pos;
 MENUBUTTONITEM newitem;

 wParam = (WPARAM)pos;
 lParam = (LPARAM)&newitem;

Parameters:
pos | The position at which to add the item. If the control was created with the style of MBS_SORT, this parameter will be ignored. If this parameter is less than 0, the new item will be append to the tail of the menu list.
newitem | Pointer to the menubutton item info structure.
Returns:
The position at which the item has been added, i.e., the index of the added item if success. Otherwise, the following error code will be returned:
  • MB_ERR_SPACE
    No memory can be allocated for new item.

Definition at line 181 of file menubutton.h.

#define MBM_DELITEM 0xF201

Sends to the control to delete an item in the menu list.

 MBM_DELETEITEM
 int del;

 wParam = (WPARAM)del;
 lParam = 0;

Parameters:
del The index of the item to be deleted.
Returns:
MB_OKAY if success, else MB_INV_ITEM to indicate valid index.

Definition at line 199 of file menubutton.h.

#define MBM_GETCURITEM 0xF206

Sends to get the index of the current selected item.

 MBM_GETCURITEM

 wParam = 0;
 lParam = 0;

Returns:
The index of the current selected item. If there is no seleted item, MB_INV_ITEM will be returned.

Definition at line 275 of file menubutton.h.

#define MBM_GETITEMDATA 0xF204

Sends to the control to retrive the data of a specific item.

 MBM_GETITEMDATA
 int index;
 PMENUBUTTONITEM pmbi;

 wParam = (WPARAM)index;
 lParam = (LPARAM)pmbi;

Parameters:
index | The index of the specific item.
pmbi | Pointer to the MENUBUTTONITEM structure for storing the menubutton item data.
Returns:
MB_OKAY if success, otherwise MB_INV_ITEM to indicate invalid index.

Definition at line 259 of file menubutton.h.

#define MBM_RESETCTRL 0xF202

Sends to the control to remove all items in the menu list.

 MBM_RESETCTRL

 wParam = 0;
 lParam = 0;

Returns:
Always be zero.

Definition at line 214 of file menubutton.h.

#define MBM_SETCURITEM 0xF207

Sends to set the current selected item based on index.

 MBM_SETCURITEM
 int cur;

 wParam = (WPARAM)cur;
 lParam = 0;

Parameters:
cur The index to be the current item.
Returns:
The index of the old selected item.

Definition at line 293 of file menubutton.h.

#define MBM_SETITEMDATA 0xF203

Sends to the control to set the data of a specific item.

 MBM_SETITEMDATA
 int index;
 PMENUBUTTONITEM pmbi;

 wParam = (WPARAM)index;
 lParam = (LPARAM)pmbi;

Parameters:
index | The index of the item to be altered.
pmbi | Pointer to the MENUBUTTONITEM structure that stores the new menubutton item data.
Returns:
MB_OKAY if success, otherwise will be one of the following error codes:
  • MB_INV_ITEM
    Indicate that the index you passed is valid.
  • MB_ERR_SPACE
    No memory can be allocated for new item data.

Definition at line 238 of file menubutton.h.

#define MBM_SETSTRCMPFUNC 0xF208

Sets the STRCMP function used to sort items.

An application sends a MBM_SETSTRCMPFUNC message to set a new STRCMP function to sort items in the menubutton.

Note that you should send this message before adding any item to the menubutton control.

 static int my_strcmp (const char* s1, const char* s2, size_t n)
 {
      ...
      return 0;
 }

 MBM_SETSTRCMPFUNC

 wParam = 0;
 lParam = (LPARAM) my_strcmp;

Parameters:
my_strcmp Your own function to compare two strings.
Returns:
One of the following values:
  • MB_OKAY
    Success
  • MB_ERR
    Not an empty menubutton

Definition at line 324 of file menubutton.h.

Generated on Fri Dec 17 13:49:46 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Notification codes of menubutton control

Notification codes of menubutton control
[MenuButton control]

Defines

  • #define MBN_ERRSPACE 255
    Sends when memory space error occures.
  • #define MBN_CHANGED 1
    Sends when selected item changes.
  • #define MBN_SELECTED 2
    Sends when an item is selected.
  • #define MBN_STARTMENU 4
    Sends when starting tracking popup menu.
  • #define MBN_ENDMENU 5
    Sends when ending tracking popup menu.
  • #define MBN_CLICKED 6
    Sends when the user clicked the menubutton but not active the menu.

Define Documentation

#define MBN_CHANGED 1

Sends when selected item changes.

Definition at line 346 of file menubutton.h.

#define MBN_CLICKED 6

Sends when the user clicked the menubutton but not active the menu.

Definition at line 370 of file menubutton.h.

#define MBN_ENDMENU 5

Sends when ending tracking popup menu.

Definition at line 364 of file menubutton.h.

#define MBN_ERRSPACE 255

Sends when memory space error occures.

Definition at line 340 of file menubutton.h.

#define MBN_SELECTED 2

Sends when an item is selected.

Definition at line 352 of file menubutton.h.

#define MBN_STARTMENU 4

Sends when starting tracking popup menu.

Definition at line 358 of file menubutton.h.

Generated on Fri Dec 17 13:49:46 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: MenuButton control

MenuButton control
[Standard controls]

Modules

  • Styles of menubutton control
  • Messages of menubutton control
  • Notification codes of menubutton control

Data Structures

  • struct _MENUBUTTONITEM

Defines

  • #define CTRL_MENUBTN ("menubutton")
    The class name of menubutton control.
  • #define CTRL_MENUBUTTON ("menubutton")
    The class name of menubutton control.
  • #define MB_OKAY 0
  • #define MB_ERR -1
  • #define MB_INV_ITEM -2
  • #define MB_ERR_SPACE -3
  • #define MB_WHICH_TEXT 0x01
  • #define MB_WHICH_BMP 0x02
  • #define MB_WHICH_ATTDATA 0x04

Typedefs

  • typedef MENUBUTTONITEM * PMENUBUTTONITEM
    Data type of the pointer to a MENUBUTTONITEM.

Define Documentation

#define CTRL_MENUBTN ("menubutton")

The class name of menubutton control.

Definition at line 51 of file menubutton.h.

#define CTRL_MENUBUTTON ("menubutton")

The class name of menubutton control.

Definition at line 57 of file menubutton.h.

#define MB_ERR -1

Menu Button return value

Definition at line 62 of file menubutton.h.

#define MB_ERR_SPACE -3

Menu Button return value

Definition at line 66 of file menubutton.h.

#define MB_INV_ITEM -2

Menu Button return value

Definition at line 64 of file menubutton.h.

#define MB_OKAY 0

Menu Button return value

Definition at line 60 of file menubutton.h.

#define MB_WHICH_ATTDATA 0x04

Struct used by parent to add/retrive item

Definition at line 73 of file menubutton.h.

#define MB_WHICH_BMP 0x02

Struct used by parent to add/retrive item

Definition at line 71 of file menubutton.h.

#define MB_WHICH_TEXT 0x01

Struct used by parent to add/retrive item

Definition at line 69 of file menubutton.h.

Typedef Documentation

typedef MENUBUTTONITEM * PMENUBUTTONITEM

Data type of the pointer to a MENUBUTTONITEM.

Definition at line 99 of file menubutton.h.

Generated on Fri Dec 17 13:49:46 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _MENUBUTTONITEM Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_MENUBUTTONITEM Struct Reference
[MenuButton control]

#include <menubutton.h>

Data Fields

  • DWORD which
  • const char * text
  • PBITMAP bmp
  • DWORD data

Detailed Description

Structure of the menubutton item

Definition at line 76 of file menubutton.h.

Field Documentation

DWORD which

Which fields are valid when sets/retrives the item information (ignored when add item). It can be OR'd with the following values:

  • MB_WHICH_TEXT The text field is valid.
  • MB_WHICH_BMP The bmp field is valid.
  • MB_WHICH_ATTDATA The data field is valid.

Definition at line 86 of file menubutton.h.

const char* text

Item string

Definition at line 88 of file menubutton.h.

PBITMAP bmp

Item bitmap

Definition at line 90 of file menubutton.h.

DWORD data

Attached data

Definition at line 92 of file menubutton.h.

The documentation for this struct was generated from the following file:
  • menubutton.h
Generated on Fri Dec 17 13:49:52 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Styles of monthcalendar control

Styles of monthcalendar control
[MonthCalendar control]

Defines

  • #define MCS_CHN 0x0001L
    Displays chinese label.
  • #define MCS_ENG_L 0x0002L
    Displays long english label.
  • #define MCS_ENG_S 0x0003L
    Displays short english label.
  • #define MCS_NOTIFY 0x0004L
    Notifies the parent window when something happens.
  • #define MCS_NOYEARMON 0x0008L
    Do not show year and month.

Define Documentation

#define MCS_CHN 0x0001L

Displays chinese label.

Definition at line 114 of file monthcal.h.

#define MCS_ENG_L 0x0002L

Displays long english label.

Definition at line 120 of file monthcal.h.

#define MCS_ENG_S 0x0003L

Displays short english label.

Definition at line 126 of file monthcal.h.

#define MCS_NOTIFY 0x0004L

Notifies the parent window when something happens.

Definition at line 132 of file monthcal.h.

#define MCS_NOYEARMON 0x0008L

Do not show year and month.

Definition at line 138 of file monthcal.h.

Generated on Fri Dec 17 13:49:46 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Messages of monthcalendar control

Messages of monthcalendar control
[MonthCalendar control]

Defines

  • #define MCM_GETCURDAY 0xF300
    Gets the day number of the current selected date.
  • #define MCM_GETCURMONTH 0xF301
    Gets the month number of the current selected date.
  • #define MCM_GETCURYEAR 0xF302
    Gets the year number of the current selected date.
  • #define MCM_GETCURWEEKDAY 0xF303
    Gets the weekday number of the current selected date.
  • #define MCM_GETCURMONLEN 0xF304
    Gets the month length of the current selected date.
  • #define MCM_SETCURDAY 0xF305
    Changes the day of the currently selected date.
  • #define MCM_SETCURMONTH 0xF306
    Changes the month of the currently selected date.
  • #define MCM_SETCURYEAR 0xF307
    Changes the year of the currently selected date.
  • #define MCM_SETTODAY 0xF308
    Sets the currently selected date as the date of "today".
  • #define MCM_GETFIRSTWEEKDAY 0xF309
    Gets the weekday of the first day of this month.
  • #define MCM_GETCURDATE 0xF310
    Gets the currently selected date.
  • #define MCM_GETTODAY 0xF311
    Gets the date of "today".
  • #define MCM_GETMINREQRECTW 0xF312
    Gets the minimum width required to display a full month in a month calendar control.
  • #define MCM_GETMINREQRECTH 0xF313
    Gets the minimum height required to display a full month in a month calendar control.
  • #define MCM_SETCURDATE 0xF314
    Sets the currently selected date.
  • #define MCM_SETCOLOR 0xF315
    Sets the color of the monthcalendar control.
  • #define MCM_GETCOLOR 0xF316
    Gets the color of the monthcalendar control.
  • #define MCM_SETDAYCOLOR 0xF317
    Sets the color of a specified date .
  • #define MCM_CLEARDAYCOLOR 0xF318
    Clears the color of a specified month view .

Define Documentation

#define MCM_CLEARDAYCOLOR 0xF318

Clears the color of a specified month view .

 MCM_CLEARDAYCOLOR

 wParam = 0;
 lParam = 0;

Definition at line 442 of file monthcal.h.

#define MCM_GETCOLOR 0xF316

Gets the color of the monthcalendar control.

 MCM_GETCOLOR
 PMCCOLORINFO color;

 wParam = 0;
 lParam = (LPARAM)color;

Parameters:
color Pointer to the MCCOLORINFO structure retreiving the color info.

Definition at line 411 of file monthcal.h.

#define MCM_GETCURDATE 0xF310

Gets the currently selected date.

 MCM_GETCURDATE
 PSYSTEMTIME pcurdate;

 wParam = 0;
 lParam = (LPARAM)pcurdate;

Parameters:
pcurdate Pointer to the SYSTEMTIME structure to retreive the date.

Definition at line 312 of file monthcal.h.

#define MCM_GETCURDAY 0xF300

Gets the day number of the current selected date.

 MCM_GETCURDAY

 wParam = 0;
 lParam = 0;

Returns:
The day number of the current selected date.

Definition at line 160 of file monthcal.h.

#define MCM_GETCURMONLEN 0xF304

Gets the month length of the current selected date.

 MCM_GETCURMONLEN

 wParam = 0;
 lParam = 0;

Returns:
The month length of the current selected date.

Definition at line 220 of file monthcal.h.

#define MCM_GETCURMONTH 0xF301

Gets the month number of the current selected date.

 MCM_GETCURMONTH

 wParam = 0;
 lParam = 0;

Returns:
The month number of the current selected date.

Definition at line 175 of file monthcal.h.

#define MCM_GETCURWEEKDAY 0xF303

Gets the weekday number of the current selected date.

 MCM_GETCURWEEKDAY

 wParam = 0;
 lParam = 0;

Returns:
The weekday number of the current selected date.

Definition at line 205 of file monthcal.h.

#define MCM_GETCURYEAR 0xF302

Gets the year number of the current selected date.

 MCM_GETCURYEAR

 wParam = 0;
 lParam = 0;

Returns:
The year number of the current selected date.

Definition at line 190 of file monthcal.h.

#define MCM_GETFIRSTWEEKDAY 0xF309

Gets the weekday of the first day of this month.

 MCM_GETFIRSTWEEKDAY

 wParam = 0;
 lParam = 0;

Returns:
The weekday of the first day.

Definition at line 296 of file monthcal.h.

#define MCM_GETMINREQRECTH 0xF313

Gets the minimum height required to display a full month in a month calendar control.

 MCM_GETMINREQRECTH

 wParam = 0;
 lParam = 0;

Returns:
The minimum height required to dispaly a full month.

Definition at line 361 of file monthcal.h.

#define MCM_GETMINREQRECTW 0xF312

Gets the minimum width required to display a full month in a month calendar control.

 MCM_GETMINREQRECTW

 wParam = 0;
 lParam = 0;

Returns:
The minimum width required to dispaly a full month.

Definition at line 345 of file monthcal.h.

#define MCM_GETTODAY 0xF311

Gets the date of "today".

 MCM_GETTODAY
 PSYSTEMTIME pcurdate;

 wParam = 0;
 lParam = (LPARAM)pcurdate;

Parameters:
pcurdate Pointer to the SYSTEMTIME structure to retreive the date of "today".

Definition at line 329 of file monthcal.h.

#define MCM_SETCOLOR 0xF315

Sets the color of the monthcalendar control.

 MCM_SETCOLOR
 PMCCOLORINFO newcolor;

 wParam = 0;
 lParam = (LPARAM)newcolor;

Parameters:
newcolor Pointer to the MCCOLORINFO structure storing the vaules of the new color info.

Definition at line 395 of file monthcal.h.

#define MCM_SETCURDATE 0xF314

Sets the currently selected date.

 MCM_SETCURDATE
 PSYSTEMTIME pcurdate;

 wParam = 0;
 lParam = (LPARAM)pcurdate;

Parameters:
pcurdate Pointer to the SYSTEMTIME structure storing the values of the current selected date.

Definition at line 378 of file monthcal.h.

#define MCM_SETCURDAY 0xF305

Changes the day of the currently selected date.

 MCM_SETCURDAY
 int newday;

 wParam = (WPARAM)newday;
 lParam = 0;

Parameters:
newday The new day number of the currently selected date.

Definition at line 236 of file monthcal.h.

#define MCM_SETCURMONTH 0xF306

Changes the month of the currently selected date.

 MCM_SETCURMONTH
 int newmonth;

 wParam = (WPARAM)newmonth;
 lParam = 0;

Parameters:
newmonth The new month number of the currently selected date.

Definition at line 252 of file monthcal.h.

#define MCM_SETCURYEAR 0xF307

Changes the year of the currently selected date.

 MCM_SETCURYEAR
 int newyear;

 wParam = (WPARAM)newyear;
 lParam = 0;

Parameters:
newyear The new year number of the currently selected date.

Definition at line 268 of file monthcal.h.

#define MCM_SETDAYCOLOR 0xF317

Sets the color of a specified date .

 MCM_SETDAYCOLOR
 int day;
 int color;

 wParam = day;
 lParam = color;

Parameters:
day | Month day to set color
color | Pixel color.

Definition at line 429 of file monthcal.h.

#define MCM_SETTODAY 0xF308

Sets the currently selected date as the date of "today".

 MCM_SETTODAY

 wParam = 0;
 lParam = 0;

Definition at line 281 of file monthcal.h.

Generated on Fri Dec 17 13:49:46 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Notification codes of monthcalendar control

Notification codes of monthcalendar control
[MonthCalendar control]

Defines

  • #define MCN_DATECHANGE 1
    Notifies that the currently selected date is changed.

Define Documentation

#define MCN_DATECHANGE 1

Notifies that the currently selected date is changed.

Definition at line 456 of file monthcal.h.

Generated on Fri Dec 17 13:49:46 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: MonthCalendar control

MonthCalendar control
[Standard controls]

Modules

  • Styles of monthcalendar control
  • Messages of monthcalendar control
  • Notification codes of monthcalendar control

Data Structures

  • struct _SYSTEMTIME
  • struct _MCCOLORINFO

Defines

  • #define CTRL_MONTHCALENDAR ("MonthCalendar")
    The class name of monthcalendar control.

Typedefs

  • typedef SYSTEMTIME * PSYSTEMTIME
    Data type of the pointer to a SYSTEMTIME.
  • typedef MCCOLORINFO * PMCCOLORINFO
    Data type of the pointer to a MCCOLORINFO.

Define Documentation

#define CTRL_MONTHCALENDAR ("MonthCalendar")

The class name of monthcalendar control.

Definition at line 51 of file monthcal.h.

Typedef Documentation

typedef MCCOLORINFO * PMCCOLORINFO

Data type of the pointer to a MCCOLORINFO.

Definition at line 104 of file monthcal.h.

typedef SYSTEMTIME * PSYSTEMTIME

Data type of the pointer to a SYSTEMTIME.

Definition at line 69 of file monthcal.h.

Generated on Fri Dec 17 13:49:46 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _SYSTEMTIME Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_SYSTEMTIME Struct Reference
[MonthCalendar control]

#include <monthcal.h>

Data Fields

  • int year
  • int month
  • int day
  • int weekday

Detailed Description

Structure of the system time

Definition at line 54 of file monthcal.h.

Field Documentation

int year

Year number of the date

Definition at line 57 of file monthcal.h.

int month

Month number of the date

Definition at line 59 of file monthcal.h.

int day

Day number of the date

Definition at line 61 of file monthcal.h.

int weekday

Weekday number of the date

Definition at line 63 of file monthcal.h.

The documentation for this struct was generated from the following file:
  • monthcal.h
Generated on Fri Dec 17 13:49:52 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _MCCOLORINFO Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_MCCOLORINFO Struct Reference
[MonthCalendar control]

#include <monthcal.h>

Data Fields

  • int clr_titlebk
  • int clr_titletext
  • int clr_arrow
  • int clr_arrowHibk
  • int clr_weekcaptbk
  • int clr_weekcapttext
  • int clr_daybk
  • int clr_dayHibk
  • int clr_daytext
  • int clr_trailingtext
  • int clr_dayHitext

Detailed Description

Struture of the color info of the monthcalendar control

Definition at line 72 of file monthcal.h.

Field Documentation

int clr_titlebk

Color of the titile background

Definition at line 75 of file monthcal.h.

int clr_titletext

Color of the titile text

Definition at line 77 of file monthcal.h.

int clr_arrow

Color of the arrow

Definition at line 79 of file monthcal.h.

int clr_arrowHibk

Color of the hilighted arrow background

Definition at line 81 of file monthcal.h.

int clr_weekcaptbk

Color of the week caption background

Definition at line 84 of file monthcal.h.

int clr_weekcapttext

Color of the week caption text

Definition at line 86 of file monthcal.h.

int clr_daybk

Color of the day text background

Definition at line 89 of file monthcal.h.

int clr_dayHibk

Color of the hilighted day text background

Definition at line 91 of file monthcal.h.

int clr_daytext

Color of the day text

Definition at line 93 of file monthcal.h.

int clr_trailingtext

Color of the trailing day text

Definition at line 95 of file monthcal.h.

int clr_dayHitext

Color of the hilighted day text

Definition at line 97 of file monthcal.h.

The documentation for this struct was generated from the following file:
  • monthcal.h
Generated on Fri Dec 17 13:49:52 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Styles of NewToolBar control

Styles of NewToolBar control
[NewToolBar control]

Defines

  • #define NTBS_WITHTEXT 0x000000001L
    Displays text with the item bitmap.
  • #define NTBS_TEXTRIGHT 0x000000002L
    Displays text at the right side of the item bitmap.
  • #define NTBS_DRAWSTATES 0x000000004L
    Draws the button states with 3D frame, and does not use the highlight, pushed and disabled bitmap cell.
  • #define NTBS_DRAWSEPARATOR 0x000000008L
    Draws the separator bar.
  • #define NTBS_HORIZONTAL 0x00000000L
    The NewToolbar will be displayed horizontally.
  • #define NTBS_VERTICAL 0x00000010L
    The NewToolbar will be displayed vertically.
  • #define NTBS_MULTLINE 0x00000020L
    The Newtoolbar item will be displayed in several lines. In this style , your should define the toolbar RECT in CreateWindwEx.

Define Documentation

#define NTBS_DRAWSEPARATOR 0x000000008L

Draws the separator bar.

Definition at line 237 of file newtoolbar.h.

#define NTBS_DRAWSTATES 0x000000004L

Draws the button states with 3D frame, and does not use the highlight, pushed and disabled bitmap cell.

Definition at line 231 of file newtoolbar.h.

#define NTBS_HORIZONTAL 0x00000000L

The NewToolbar will be displayed horizontally.

Definition at line 243 of file newtoolbar.h.

#define NTBS_MULTLINE 0x00000020L

The Newtoolbar item will be displayed in several lines. In this style , your should define the toolbar RECT in CreateWindwEx.

Definition at line 257 of file newtoolbar.h.

#define NTBS_TEXTRIGHT 0x000000002L

Displays text at the right side of the item bitmap.

Definition at line 224 of file newtoolbar.h.

#define NTBS_VERTICAL 0x00000010L

The NewToolbar will be displayed vertically.

Definition at line 249 of file newtoolbar.h.

#define NTBS_WITHTEXT 0x000000001L

Displays text with the item bitmap.

Definition at line 218 of file newtoolbar.h.

Generated on Fri Dec 17 13:49:46 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Messages of NewToolBar control

Messages of NewToolBar control
[NewToolBar control]

Defines

  • #define NTB_OKAY 0
  • #define NTB_ERR (-1)
  • #define NTB_ERR_SPACE (-2)
  • #define NTB_ERR_DUPID (-3)
  • #define NTBM_ADDITEM 0xFE00
    Adds an item to a newtoolbar.
  • #define NTBM_GETITEM 0xFE01
    Retrives the information of an item in a newtoolbar control.
  • #define NTBM_SETITEM 0xFE02
    Sets the information of an item in a newtoolbar control.
  • #define NTBM_ENABLEITEM 0xFE03
    Enables/Disables an item in a newtoolbar control.
  • #define NTBM_SETBITMAP 0xFE04
    Sets the bitmap of a newtoolbar control.

Define Documentation

#define NTB_ERR (-1)

Newtoolbar return value

Definition at line 268 of file newtoolbar.h.

#define NTB_ERR_DUPID (-3)

Newtoolbar return value

Definition at line 272 of file newtoolbar.h.

#define NTB_ERR_SPACE (-2)

Newtoolbar return value

Definition at line 270 of file newtoolbar.h.

#define NTB_OKAY 0

Newtoolbar return value

Definition at line 266 of file newtoolbar.h.

#define NTBM_ADDITEM 0xFE00

Adds an item to a newtoolbar.

 NTBM_ADDITEM
 NTBITEMINFO *ntbii;

 wParam = 0;
 lParam = (LPARAM)ntbii;

Parameters:
ntbii Pointer to the data storing the newtoobar item info.
Returns:
NTB_OKAY on success, else one of the following values:
  • NTB_ERR_SPACE
    No enongh space to allocate memory for new item.
  • NTB_ERR_DUPID
    Duplicated identifier with an existed item.

Definition at line 292 of file newtoolbar.h.

#define NTBM_ENABLEITEM 0xFE03

Enables/Disables an item in a newtoolbar control.

 NTBM_ENABLEITEM
 int id;
 BOOL enable;

 wParam = id;
 lParam = enable;

Parameters:
id | The identifier of the item.
enable | True to enable item; false to disable item.
Returns:
NTB_OKAY on success, else NTB_ERR.

Definition at line 352 of file newtoolbar.h.

#define NTBM_GETITEM 0xFE01

Retrives the information of an item in a newtoolbar control.

 NTBM_GETITEM
 int id;
 NTBITEMINFO *ntbii;

 wParam = id;
 lParam = (LPARAM)ntbii;

Parameters:
id | The identifier of the item.
ntbii | Pointer to the data storing the newtoobar item info.
Returns:
NTB_OKAY on success, else NTB_ERR.

Definition at line 312 of file newtoolbar.h.

#define NTBM_SETBITMAP 0xFE04

Sets the bitmap of a newtoolbar control.

 NTBM_SETBITMAP
 NTBINFO ntbi;

 wParam = 0;
 lParam = (LPARAM)&ntbi;

Parameters:
ntbi The structure for storing the newtoobar info.
Returns:
NTB_OKAY on success, else NTB_ERR.

Definition at line 370 of file newtoolbar.h.

#define NTBM_SETITEM 0xFE02

Sets the information of an item in a newtoolbar control.

 NTBM_SETITEM
 int id;
 NTBITEMINFO ntbii;

 wParam = id;
 lParam = (LPARAM)&ntbii;

Parameters:
id | The identifier of the item.
ntbii | The structure for storing the newtoobar item info.
Returns:
NTB_OKAY on success, else NTB_ERR.

Definition at line 332 of file newtoolbar.h.

Generated on Fri Dec 17 13:49:46 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: NewToolBar control

NewToolBar control
[Standard controls]

Modules

  • Styles of NewToolBar control
  • Messages of NewToolBar control

Data Structures

  • struct _NTBINFO
  • struct _NTBITEMINFO

Defines

  • #define CTRL_NEWTOOLBAR ("newtoolbar")
    The class name of newtoolbar control.
  • #define NTBIF_DISABLED 0x0010
    The item is disabled.
  • #define NTBIF_CHECKED 0x0020
    The item is checked.

Typedefs

  • typedef void(* HOTSPOTPROC )(HWND hwnd, int id, const RECT *cell, int x, int y)
    Type of the hotspot-clicked callback procedure.
  • typedef NTBITEMINFO * PNTBITEMINFO
    Data type of pointer to a NTBITEMINFO;.

Detailed Description

Note:
You should pass information of the control through the argument dwAddData of CreateWindowEx function.
 NTBINFO ntb_info;

 CreateWindowEx (CTRL_TOOLBAR, ..., (DWORD) &ntb_info);

See also:
NTBINFO

Define Documentation

#define CTRL_NEWTOOLBAR ("newtoolbar")

The class name of newtoolbar control.

Definition at line 63 of file newtoolbar.h.

#define NTBIF_CHECKED 0x0020

The item is checked.

Definition at line 135 of file newtoolbar.h.

#define NTBIF_DISABLED 0x0010

The item is disabled.

Definition at line 130 of file newtoolbar.h.

Typedef Documentation

typedef void(* HOTSPOTPROC)(HWND hwnd, int id, const RECT *cell, int x, int y)

Type of the hotspot-clicked callback procedure.

Parameters:
hwnd | The handle to the control.
id | The identifier of the button in the NewToolBar control.
cell | The rectangle of the button in screen coordinates.
x | The x-coordinate of the mouse down point.
y | THe y-coordinate of the mouse down point.

Definition at line 112 of file newtoolbar.h.

PNTBITEMINFO

Data type of pointer to a NTBITEMINFO;.

Definition at line 207 of file newtoolbar.h.

Generated on Fri Dec 17 13:49:46 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _NTBINFO Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_NTBINFO Struct Reference
[NewToolBar control]

#include <newtoolbar.h>

Data Fields

  • PBITMAP image
  • int nr_cells
  • int nr_cols
  • int w_cell
  • int h_cell

Detailed Description

Structure of the newtoolbar control information

Definition at line 66 of file newtoolbar.h.

Field Documentation

PBITMAP image

Images for displaying tool bar item.

Definition at line 69 of file newtoolbar.h.

int nr_cells

Number of bitmap cells in the image.

Definition at line 72 of file newtoolbar.h.

int nr_cols

Number of cell columns in the image. It should be one of the following values:

  • 0, 4
    Four rows, the cells have normal, highlight, pushed, and disabled states.
  • 1
    The cells have only normal state.
  • 2
    The cells have normal and highlight states.
  • 3
    The cells have normal, highlight, and pushed states.

Definition at line 86 of file newtoolbar.h.

int w_cell

Width of bitmap cell. If w_cell is zero, it will be equal to (width_of_image / nr_cols).

Definition at line 92 of file newtoolbar.h.

int h_cell

Height of bitmap cell. If h_cell is zero, it will be equal to (height_of_image / nr_cells).

Definition at line 98 of file newtoolbar.h.

The documentation for this struct was generated from the following file:
  • newtoolbar.h
Generated on Fri Dec 17 13:49:52 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _NTBITEMINFO Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_NTBITEMINFO Struct Reference
[NewToolBar control]

#include <newtoolbar.h>

Data Fields

  • DWORD which
  • DWORD flags
  • int id
  • char * text
  • char * tip
  • int bmp_cell
  • HOTSPOTPROC hotspot_proc
  • RECT rc_hotspot
  • DWORD add_data

Detailed Description

Structure of the new toolbar item info

Definition at line 146 of file newtoolbar.h.

Field Documentation

DWORD which

Which fields are valid when sets/retrives the item information (ignored when add item). It can be OR'd with the following values:

  • MTB_WHICH_FLAGS
    The flags is valid.
  • MTB_WHICH_ID
    The identifier is valid.
  • MTB_WHICH_TEXT
    The text is valid.
  • MTB_WHICH_TIP
    The tip text is valid.
  • MTB_WHICH_CELL
    The bitmap cell index is valid.
  • MTB_WHICH_HOTSPOT
    The hotspot rect is valid.
  • MTB_WHICH_ADDDATA
    The additional data is valid.

Definition at line 160 of file newtoolbar.h.

DWORD flags

Flags of the item. It can be OR'd with the following values:

  • NTBIF_PUSHBUTTON
    The item is a normal push button.
  • NTBIF_CHECKBUTTON
    The item is a normal check button.
  • NTBIF_NEWLINE
    The item is a newline tag.
  • NTBIF_HOTSPOTBUTTON
    The item is a menu button with hotspot.
  • NTBIF_SEPARATOR
    The item is a separator.
  • NTBIF_DISABLED
    The item is disabled.

Definition at line 172 of file newtoolbar.h.

int id

Identifier of the item. When the user clicked the item, this control will send a notification message to the parent window with the notification code to be equal to this identifier.

Definition at line 179 of file newtoolbar.h.

char* text

Text of the item. This text will be displayed under the bitmap if the control have NTBS_WITHTEXT style.

Definition at line 185 of file newtoolbar.h.

char* tip

Tooltip of the item, not used, reserved.

Definition at line 188 of file newtoolbar.h.

int bmp_cell

Index of bitmap cell.

Definition at line 191 of file newtoolbar.h.

HOTSPOTPROC hotspot_proc

Hotpot-clicked callback procedure for menubutton.

Definition at line 194 of file newtoolbar.h.

RECT rc_hotspot

Rectangle region of hotspot in the cell.

Definition at line 197 of file newtoolbar.h.

DWORD add_data

Additional data of the item

Definition at line 200 of file newtoolbar.h.

The documentation for this struct was generated from the following file:
  • newtoolbar.h
Generated on Fri Dec 17 13:49:52 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Styles of progressbar control

Styles of progressbar control
[ProgressBar control]

Defines

  • #define PBS_NOTIFY 0x0001L
    Notifies the parent window.
  • #define PBS_VERTICAL 0x0002L
    Creates progressbar vertically.

Define Documentation

#define PBS_NOTIFY 0x0001L

Notifies the parent window.

Sends the parent window notification messages when the user clicks or double-clicks the control.

Definition at line 69 of file progressbar.h.

#define PBS_VERTICAL 0x0002L

Creates progressbar vertically.

Definition at line 75 of file progressbar.h.

Generated on Fri Dec 17 13:49:46 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Messages of progressbar control

Messages of progressbar control
[ProgressBar control]

Defines

  • #define PBM_SETRANGE 0xF0A0
    Sets the limits of the range.
  • #define PBM_SETSTEP 0xF0A1
    Specifies the step increment for a progress bar control.
  • #define PBM_SETPOS 0xF0A2
    Sets the progress bar control's current position.
  • #define PBM_DELTAPOS 0xF0A3
    Advances the progress bar control's current position.
  • #define PBM_STEPIT 0xF0A4
    Advances the current position by the step increment.

Define Documentation

#define PBM_DELTAPOS 0xF0A3

Advances the progress bar control's current position.

Advances the progress bar control's current position as specified by posInc, and redraw the bar to reflect the new position.

 PBM_DELTAPOS
 int posInc;

 wParam = (WPARAM)posInc;
 lParam = 0;

Parameters:
posInc The progress bar control's position increment.
Returns:
Always be PB_OKAY.

Definition at line 161 of file progressbar.h.

#define PBM_SETPOS 0xF0A2

Sets the progress bar control's current position.

Sets the progress bar control's current position as specified by nPos, and redraw the bar to reflect the new position.

 PBM_SETPOS
 int nPos;

 wParam = (WPARAM)nPos;
 lParam = 0;

Parameters:
nPos The progress bar control's current position.
Returns:
Always be PB_OKAY.

Definition at line 141 of file progressbar.h.

#define PBM_SETRANGE 0xF0A0

Sets the limits of the range.

Sets the upper and lower limits of the progress bar control's range, and redraws the bar to reflect the new ranges.

 PBM_SETRANGE
 int min, max;

 wParam = (WPARAM)min;
 lParam = (LPARAM)max;

Parameters:
min | The lower limit of the progress bar.
max | The upper limit of the progress bar.
Returns:
PB_OKAY on success, else PB_ERR.

Definition at line 104 of file progressbar.h.

#define PBM_SETSTEP 0xF0A1

Specifies the step increment for a progress bar control.

 PBM_SETSTEP
 int stepinc;

 wParam = (WPARAM)stepinc;
 lParam = 0;

Parameters:
stepinc Step increment for a progress bar control.
Returns:
PB_OKAY on success, else PB_ERR.

Definition at line 121 of file progressbar.h.

#define PBM_STEPIT 0xF0A4

Advances the current position by the step increment.

Advances the current position for a progress bar control by the step increment, and redraw the bar to reflect the new position.

 PBM_STEPIT

 wParam = 0;
 lParam = 0;

Returns:
Always be PB_OKAY.

Definition at line 179 of file progressbar.h.

Generated on Fri Dec 17 13:49:46 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Notification codes of progressbar control

Notification codes of progressbar control
[ProgressBar control]

Defines

  • #define PBN_REACHMAX 1
    Notifies reach of maximum limit.
  • #define PBN_REACHMIN 2
    Notifies reach of minimum limit.

Define Documentation

#define PBN_REACHMAX 1

Notifies reach of maximum limit.

The PBN_REACHMAX notification code is sent when the progressbar reachs its maximum limit.

Definition at line 196 of file progressbar.h.

#define PBN_REACHMIN 2

Notifies reach of minimum limit.

The PBN_REACHMIN notification code is sent when the progressbar reachs its minimum limit.

Definition at line 204 of file progressbar.h.

Generated on Fri Dec 17 13:49:46 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: ProgressBar control

ProgressBar control
[Standard controls]

Modules

  • Styles of progressbar control
  • Messages of progressbar control
  • Notification codes of progressbar control

Defines

  • #define CTRL_PROGRESSBAR ("progressbar")
    The class name of progressbar control.
  • #define PB_OKAY 0
  • #define PB_ERR -1

Define Documentation

#define CTRL_PROGRESSBAR ("progressbar")

The class name of progressbar control.

Definition at line 51 of file progressbar.h.

#define PB_ERR -1

Progressbar return value

Definition at line 55 of file progressbar.h.

#define PB_OKAY 0

Progressbar return value

Definition at line 53 of file progressbar.h.

Generated on Fri Dec 17 13:49:46 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Styles of propertysheet control

Styles of propertysheet control
[PropertySheet control]

Defines

  • #define PSS_SIMPLE 0x0000L
    A simple property sheet control. All tabs of the control will have the same width.
  • #define PSS_COMPACTTAB 0x0001L
    Compact tab style. The width of a tab is adaptive to the tab title.
  • #define PSS_SCROLLABLE 0x0002L
    Tabs can be scrolled by scroll button.
  • #define PSS_BOTTOM 0x0010L
    Bottom tab style. Tabs will be located at the bottom of the property sheet.

Define Documentation

#define PSS_BOTTOM 0x0010L

Bottom tab style. Tabs will be located at the bottom of the property sheet.

Definition at line 82 of file propsheet.h.

#define PSS_COMPACTTAB 0x0001L

Compact tab style. The width of a tab is adaptive to the tab title.

Definition at line 69 of file propsheet.h.

#define PSS_SCROLLABLE 0x0002L

Tabs can be scrolled by scroll button.

Definition at line 75 of file propsheet.h.

#define PSS_SIMPLE 0x0000L

A simple property sheet control. All tabs of the control will have the same width.

Definition at line 63 of file propsheet.h.

Generated on Fri Dec 17 13:49:46 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Messages of propertysheet control

Messages of propertysheet control
[PropertySheet control]

Defines

  • #define PS_OKAY 0
  • #define PS_ERR (-1)
  • #define PSM_GETACTIVEPAGE 0xF1C0L
    Gets the handle of current active page.
  • #define PSM_SETACTIVEINDEX 0xF1C2L
    Changes the active page by index.
  • #define PSM_GETPAGE 0xF1C3L
    Gets the handle of a page by index.
  • #define PSM_GETACTIVEINDEX 0xF1C4L
    Gets the index of the current active page.
  • #define PSM_GETPAGEINDEX 0xF1C5L
    Gets the index of a page by handle.
  • #define PSM_GETPAGECOUNT 0xF1C6L
    Gets the number of pages of the propsheet.
  • #define PSM_GETTITLELENGTH 0xF1C7L
    Gets the length of a page title.
  • #define PSM_GETTITLE 0xF1C8L
    Gets a page title.
  • #define PSM_SETTITLE 0xF1C9L
    Sets a page title.
  • #define PSM_ADDPAGE 0xF1D0L
    Adds a page to the propsheet.
  • #define PSM_REMOVEPAGE 0xF1D1L
    Removes a page from the propsheet.
  • #define PSM_SHEETCMD 0xF1D2L
    Sends a MSG_SHEETCMD message to all pages in the propsheet.

Define Documentation

#define PS_ERR (-1)

Propsheet return value

Definition at line 93 of file propsheet.h.

#define PS_OKAY 0

Propsheet return value

Definition at line 91 of file propsheet.h.

#define PSM_ADDPAGE 0xF1D0L

Adds a page to the propsheet.

Sends this message to add a page to the propsheet.

 PSM_ADDPAGE
 DLGTEMPLATE *dlg_tmpl;
 WNDPROC proc;

 wParam = (WPARAM)dlg_tmpl;
 lParam = (LPARAM)proc;

Parameters:
hdlg | The handle of the page window to be added in the propsheet.
proc | The window callback procedure of the page window. Note that the procedure should call DefaultPageProc function by default.
Returns:
The index of the page added on success; PS_ERR on error.

Definition at line 292 of file propsheet.h.

#define PSM_GETACTIVEINDEX 0xF1C4L

Gets the index of the current active page.

Sends this message to retreive the index of the propsheet window's active page.

 PSM_GETACTIVEINDEX

 wParam = 0;
 lParam = 0;

Returns:
The index number of the active page.

Definition at line 167 of file propsheet.h.

#define PSM_GETACTIVEPAGE 0xF1C0L

Gets the handle of current active page.

Sends this message to retreive the propsheet window's active page.

 PSM_GETACTIVEPAGE

 wParam = 0;
 lParam = 0;

Returns:
The handle to the active page; HWND_INVALID if no such a page.

Definition at line 110 of file propsheet.h.

#define PSM_GETPAGE 0xF1C3L

Gets the handle of a page by index.

Sends this message to retreive the handle to a page by index.

 PSM_GETPAGE
 int index;

 wParam = (WPARAM)index;
 lParam = 0;

Parameters:
index The index of the page.
Returns:
The handle to the page; HWND_INVALID if no such a page.

Definition at line 150 of file propsheet.h.

#define PSM_GETPAGECOUNT 0xF1C6L

Gets the number of pages of the propsheet.

Sends this message to retreive the number of pages currently in the propsheet.

 PSM_GETPAGECOUNT

 wParam = 0;
 lParam = 0;

Returns:
The number of pages in the propsheet.

Definition at line 204 of file propsheet.h.

#define PSM_GETPAGEINDEX 0xF1C5L

Gets the index of a page by handle.

Sends this message to retreive the index to a page by handle.

 PSM_GETPAGEINDEX
 HWND hwnd;

 wParam = hwnd;
 lParam = 0;

Parameters:
hwnd The handle of the page.
Returns:
The index of the page; PS_ERR if no such a page.

Definition at line 187 of file propsheet.h.

#define PSM_GETTITLE 0xF1C8L

Gets a page title.

Sends this message to retreive the title of a page.

 PSM_GETTITLE
 int index;
 char *buffer;

 wParam = (WPARAM)index;
 lParam = (LPARAM)buffer;

Parameters:
index | The index number of the page in the propsheet.
buffer | The buffer storing the title string.
Returns:
PS_OKAY on success; PS_ERR if no such a page.

Definition at line 246 of file propsheet.h.

#define PSM_GETTITLELENGTH 0xF1C7L

Gets the length of a page title.

Sends this message to retreive the title length of a page.

 PSM_GETTITLELENGTH
 int index;

 wParam = (WPARAM)index;
 lParam = 0;

Parameters:
index The index number of the page in the propsheet.
Returns:
The length of the page in the propsheet; PS_ERR if no such a page.

Definition at line 224 of file propsheet.h.

#define PSM_REMOVEPAGE 0xF1D1L

Removes a page from the propsheet.

Sends this message to remove a page from the propsheet and destroys the associated controls.

 PSM_REMOVEPAGE
 int index;

 wParam = (WPARAM)index;
 lParam = 0;

Parameters:
index The index number of the page to be removed from the propsheet.
Returns:
If success, return PS_OKAY, otherwise PS_ERR.

Definition at line 313 of file propsheet.h.

#define PSM_SETACTIVEINDEX 0xF1C2L

Changes the active page by index.

Sends this message to change the propsheet window's active page.

 PSM_SETACTIVEINDEX
 int page;

 wParam = (WPARAM)page;
 lParam = 0;

Parameters:
page Index of the page to set.
Returns:
PS_OKAY on success, otherwise PS_ERR.

Definition at line 130 of file propsheet.h.

#define PSM_SETTITLE 0xF1C9L

Sets a page title.

Sends this message to specify the title of a page.

 PSM_SETTITLE
 int index;
 char *buffer;

 wParam = (WPARAM)index;
 lParam = (LPARAM)buffer;

Parameters:
index | The index number of the page in the propsheet.
buffer | The string buffer storing the title.
Returns:
PS_OKAY on success; PS_ERR if no such a page.

Definition at line 268 of file propsheet.h.

#define PSM_SHEETCMD 0xF1D2L

Sends a MSG_SHEETCMD message to all pages in the propsheet.

If you send MSG_SHEETCMD message to the propsheet control, the control will broadcast the message to all pages it contains. The page callback procedure will receive the message and handle it. If one page return non-zero value, the broadcast will be broken and the message will return a value indicating which page returned error. The value will be equal to the page index plus one.

The PSM_SHEETCMD can be used by property sheet window, i.e., the container of the property pages. The sheet can create three buttons, like "Ok", "Cancel", and "Apply". When the user clicked the "Apply" or "Ok" button, it can send a PSM_SHEETCMD message to the propsheet control, the control will then send the message to all pages to notify pages to apply the changes made by the user. If there are some errors, the page can return a non-zero value to indicate an invalid chage so that the sheet can stop to close the sheet window. You can tell the pages which action should be taken by passing a value through the WPARAM parameter of the message.

 PSM_SHEETCMD
 WPARAM wParam;
 LPARAM lParam;

 wParam = (WPARAM)wParam;
 lParam = (LPARAM)lParam;

Parameters:
wParam | The WPARAM parameter of the MSG_SHEETCMD message.
lParam | The LPARAM parameter of the MSG_SHEETCMD message.
Returns:
The message has been broken by a page, the value will be (page_index + 1); Zero indicates no page asserts an error.

Definition at line 351 of file propsheet.h.

Generated on Fri Dec 17 13:49:46 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Notification codes of propertysheet control

Notification codes of propertysheet control
[PropertySheet control]

Defines

  • #define PSN_ACTIVE_CHANGED 0x01
    Notifies the parent window that the active page of the propsheet has been changed.

Define Documentation

#define PSN_ACTIVE_CHANGED 0x01

Notifies the parent window that the active page of the propsheet has been changed.

Definition at line 367 of file propsheet.h.

Generated on Fri Dec 17 13:49:46 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: PropertySheet control

PropertySheet control
[Standard controls]

Modules

  • Styles of propertysheet control
  • Messages of propertysheet control
  • Notification codes of propertysheet control

Defines

  • #define CTRL_PROPSHEET ("propsheet")
    The class name of propsheet control.

Define Documentation

#define CTRL_PROPSHEET ("propsheet")

The class name of propsheet control.

Definition at line 51 of file propsheet.h.

Generated on Fri Dec 17 13:49:46 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Styles of scrollbar control

Styles of scrollbar control
[ScrollBar control]

Defines

  • #define SBS_HORZ 0x1000
    Create a horizontal scrollbar.
  • #define SBS_VERT 0x2000
    Create a vertical scrollbar.
  • #define SBS_BOTTOMALIGN 0x0001
    Create a horizontal scrollbar on the bottom of the rect.
  • #define SBS_TOPALIGN 0x0002
    Create a horizontal scrollbar on the top of the rect.
  • #define SBS_LEFTALIGN 0x0001
    Create a vertical scrollbar on the left of the rect.
  • #define SBS_RIGHTALIGN 0x0002
    Create a vertical scrollbar on the right of the rect.
  • #define SBS_NOARROW 0x0004
    Create a vertical scrollbar with no arrow.
  • #define SBS_NOSHAFT 0x0008
    Create a vertical scrollbar with no shaft.
  • #define SBS_FIXEDBARLEN 0x0010
    Create a scrollbar with fixed thumb.
  • #define SBS_NOTNOTIFYPARENT 0x0020
    send notification code with SendNotifyMessage instead of NotifyParent

Define Documentation

#define SBS_BOTTOMALIGN 0x0001

Create a horizontal scrollbar on the bottom of the rect.

Note:
This style must be used together with SBS_HORZ, and the height of the scrollbar will depend on the window elements or renderer.

Definition at line 78 of file scrollbar.h.

#define SBS_FIXEDBARLEN 0x0010

Create a scrollbar with fixed thumb.

Definition at line 128 of file scrollbar.h.

#define SBS_HORZ 0x1000

Create a horizontal scrollbar.

Definition at line 63 of file scrollbar.h.

#define SBS_LEFTALIGN 0x0001

Create a vertical scrollbar on the left of the rect.

Note:
This style must be used together with SBS_VERT, and the width of the scrollbar will depend on the window elements or renderer.

Definition at line 96 of file scrollbar.h.

#define SBS_NOARROW 0x0004

Create a vertical scrollbar with no arrow.

Note:
This style must't be used together with SBS_NOSHAFT.

Definition at line 113 of file scrollbar.h.

#define SBS_NOSHAFT 0x0008

Create a vertical scrollbar with no shaft.

Note:
This style must't be used together with SBS_NOARROWS.

Definition at line 121 of file scrollbar.h.

#define SBS_NOTNOTIFYPARENT 0x0020

send notification code with SendNotifyMessage instead of NotifyParent

Definition at line 135 of file scrollbar.h.

#define SBS_RIGHTALIGN 0x0002

Create a vertical scrollbar on the right of the rect.

Note:
This style must be used together with SBS_VERT, and the width of the scrollbar will depend on the window elements or renderer.

Definition at line 105 of file scrollbar.h.

#define SBS_TOPALIGN 0x0002

Create a horizontal scrollbar on the top of the rect.

Note:
This style must be used together with SBS_HORZ, and the height of the scrollbar will depend on the window elements or renderer.

Definition at line 87 of file scrollbar.h.

#define SBS_VERT 0x2000

Create a vertical scrollbar.

Definition at line 69 of file scrollbar.h.

Generated on Fri Dec 17 13:49:46 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Messages of scrollbar control

Messages of scrollbar control
[ScrollBar control]

Defines

  • #define SBM_GETSCROLLINFO 0xF0E0
    Get the scroll information of the scrollbar.
  • #define SBM_SETSCROLLINFO 0xF0E1
    Set the scroll information of the scrollbar.
  • #define SBM_GETPOS 0xF0E2
    Get the thumb pos of the scrollbar.
  • #define SBM_SETPOS 0xF0E3
    Set the thumb pos of the scrollbar.
  • #define SBM_GETRANGE 0xF0E4
    Get the range of the scrollbar.
  • #define SBM_SETRANGE 0xF0E5
    Set the range of the scrollbar.
  • #define SBM_SETRANGEREDRAW 0xF0E6
    Set the range of the scrollbar.
  • #define SBM_ENABLE_ARROW 0xF0E7
    Enable or disable the arrow of the scrollbar.

Define Documentation

#define SBM_ENABLE_ARROW 0xF0E7

Enable or disable the arrow of the scrollbar.

An application sends a SBM_ENABLE_ARROW message to enable or disable the arrow button of the scrollbar.

 SBM_ENABLE_ARROW
 int which = SB_ARROW_LTUP;
 BOOL is_active;

 wParam = (WPARAM)which;
 lParam = (LPARAM)is_active;
 SendMessage (hwnd_scrollbar, SBM_ENABLE_ARROW, wParam, lParam);

Parameters:
which the part of the scrollbar to enable or disable, can be one of the follow value:
  • SB_ARROW_LTUP
    the left or up arrow button.
  • SB_ARROW_BTDN
    the right or down arrow button.
  • SB_ARROW_BOTH
    all the arrow button.
is_active TRUE for enable ,FALSE for disable.

Definition at line 293 of file scrollbar.h.

#define SBM_GETPOS 0xF0E2

Get the thumb pos of the scrollbar.

An application sends a SBM_GETPOS message to get the start position of the scrollbar thumb.

 SBM_GETPOS
 int pos;

 pos = SendMessage (hwnd_scrollbar, SBM_GETPOS, 0, 0);

Returns:
the postion of the thumb.

Definition at line 173 of file scrollbar.h.

#define SBM_GETRANGE 0xF0E4

Get the range of the scrollbar.

An application sends a SBM_GETRANGE message to get the move range of the scrollbar.

 SBM_GETRANGE
 int range;

 range = SendMessage (hwnd_scrollbar, SBM_GETRANGE, 0, 0);

Returns:
the range of the scrollbar.

Definition at line 215 of file scrollbar.h.

#define SBM_GETSCROLLINFO 0xF0E0

Get the scroll information of the scrollbar.

Definition at line 149 of file scrollbar.h.

#define SBM_SETPOS 0xF0E3

Set the thumb pos of the scrollbar.

An application sends a SBM_SETPOS message to set the start position of the scrollbar thumb.

 SBM_SETPOS
 int pos = 10;
 BOOL redraw = TRUE;

 wParam = (WPARAM)pos;
 lParam = (LPARAM)redraw;
 SendMessage (hwnd_scrollbar, SBM_SETPOS, wParam, lParam);

Parameters:
pos | The new positon of the thumb to set.
redraw | Whether to repaint the control, TRUE for repaint, FALSE for not.
Returns:
the old postion of the thumb.

Definition at line 197 of file scrollbar.h.

#define SBM_SETRANGE 0xF0E5

Set the range of the scrollbar.

An application sends a SBM_SETRANGE message to set the move range of the scrollbar.

 SBM_SETRANGE
 int min = 0;
 int max = 100;

 wParam = (WPARAM)min;
 lParam = (LPARAM)max;
 SendMessage (hwnd_scrollbar, SBM_SETRANGE, wParam, lParam);

Parameters:
min | The minimum value of the range to set.
max | The maximum value of the range to set.
Note:
this message will not redraw the control.

Definition at line 239 of file scrollbar.h.

#define SBM_SETRANGEREDRAW 0xF0E6

Set the range of the scrollbar.

An application sends a SBM_SETRANGEREDRAW message to set the move range of the scrollbar and redraw the control.

 SBM_SETRANGEREDRAW
 int min = 0;
 int max = 100;

 wParam = (WPARAM)min;
 lParam = (LPARAM)max;
 SendMessage (hwnd_scrollbar, SBM_SETRANGEREDRAW, wParam, lParam);

Parameters:
min | The minimum value of the range to set.
max | The maximum value of the range to set.
Note:
this message will redraw the control.

Definition at line 263 of file scrollbar.h.

#define SBM_SETSCROLLINFO 0xF0E1

Set the scroll information of the scrollbar.

Definition at line 155 of file scrollbar.h.

Generated on Fri Dec 17 13:49:46 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: ScrollBar control

ScrollBar control
[Standard controls]

Modules

  • Styles of scrollbar control
  • Messages of scrollbar control

Defines

  • #define CTRL_SCROLLBAR ("scrollbar")
    The class name of scrollbar control.

Detailed Description

Note:
The scrollbar is not implemented as a control in current version.

Define Documentation

#define CTRL_SCROLLBAR ("scrollbar")

The class name of scrollbar control.

Definition at line 52 of file scrollbar.h.

Generated on Fri Dec 17 13:49:46 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Styles of scrollview control

Styles of scrollview control
[ScrollView control]

Defines

  • #define SVS_UPNOTIFY 0x0001L
    Sends the notification messages to parent window when the keys is up.
  • #define SVS_NOTIFY 0x0002L
    reserved.
  • #define SVS_AUTOSORT 0x0004L
    Automatically sorts strings entered in the scrollview control.
  • #define SVS_LOOP 0x0008L
    Loops the item automatically when user select item with down or up key.

Define Documentation

#define SVS_AUTOSORT 0x0004L

Automatically sorts strings entered in the scrollview control.

Definition at line 221 of file scrollview.h.

#define SVS_LOOP 0x0008L

Loops the item automatically when user select item with down or up key.

Definition at line 227 of file scrollview.h.

#define SVS_NOTIFY 0x0002L

reserved.

Definition at line 215 of file scrollview.h.

#define SVS_UPNOTIFY 0x0001L

Sends the notification messages to parent window when the keys is up.

Definition at line 209 of file scrollview.h.

Generated on Fri Dec 17 13:49:46 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Messages of scrollview control

Messages of scrollview control
[ScrollView control]

Defines

  • #define SVM_ADDITEM 0xF300
    Adds an item in the scrollview.
  • #define SVM_DELITEM 0xF301
    Deletes an item from the scrollview.
  • #define SVM_SETITEMDRAW 0xF302
    Sets the drawing operation of an item.
  • #define SVM_ADDCTRLS 0xF303
    Adds controls to the scrollview.
  • #define SVM_SETCONTWIDTH 0xF306
    Sets the scrollview content area (scrollable area) width.
  • #define SVM_SETCONTHEIGHT 0xF307
    Sets the scrollview content area (scrollable area) height.
  • #define SVM_GETCTRL 0xF308
    Gets the control handle in the scrollview window by control id.
  • #define SVM_RESETCONTENT 0xF309
    Clears all the controls and the items added to the scrollview window.
  • #define SVM_SETITEMOPS 0xF30a
    Sets the item operations of the items in the scrollview.
  • #define SVM_GETMARGINS 0xF30b
    Gets the margin values of the scrollview.
  • #define SVM_SETMARGINS 0xF311
    Sets the margin values of the scrollview.
  • #define SVM_GETLEFTMARGIN 0xF312
    Gets the left margin value of the scrollview.
  • #define SVM_GETTOPMARGIN 0xF313
    Gets the top margin value of the scrollview.
  • #define SVM_GETRIGHTMARGIN 0xF314
    Gets the right margin value of the scrollview.
  • #define SVM_GETBOTTOMMARGIN 0xF315
    Gets the bottom margin value of the scrollview.
  • #define SVM_GETVISIBLEWIDTH 0xF316
    Gets the width of the visible content area.
  • #define SVM_GETVISIBLEHEIGHT 0xF317
    Gets the height of the visible content area.
  • #define SVM_GETCONTWIDTH 0xF318
    Gets the width of the content area.
  • #define SVM_GETCONTHEIGHT 0xF319
    Gets the height of the content area.
  • #define SVM_SETCONTRANGE 0xF31a
    Sets the width and height of the content area.
  • #define SVM_GETCONTENTX 0xF31b
    Gets the content x offset in the viewport.
  • #define SVM_GETCONTENTY 0xF31c
    Gets the content y offset in the viewport.
  • #define SVM_SETCONTPOS 0xF31d
    Sets the content offset position in the viewport.
  • #define SVM_GETCURSEL 0xF31e
    Gets the index of the current hilighted scrollview item.
  • #define SVM_SELECTITEM 0xF31f
    Selects or unselects an item in the scrollview item.
  • #define SVM_SHOWITEM 0xF320
    Makes an item visible in the scrollview item.
  • #define SVM_CHOOSEITEM 0xF321
    Makes an item selected and visible in the scrollview item.
  • #define SVM_SETCURSEL 0xF322
    Makes an item as the current hilighted item in the scrollview item.
  • #define SVM_SETITEMINIT 0xF323
    Sets the init operation of the items in the scrollview.
  • #define SVM_SETITEMDESTROY 0xF324
    Sets the destroy operation of the items in the scrollview.
  • #define SVM_SETITEMCMP 0xF327
    Sets the item compare function.
  • #define SVM_MAKEPOSVISIBLE 0xF328
    Makes a position in the content area visible.
  • #define SVM_SETCONTAINERPROC 0xF329
    Sets the window procedure of the container window in the scrollview.
  • #define SVM_GETFOCUSCHILD 0xF32a
    Gets the focus control in the scrollview.
  • #define SVM_GETHSCROLLVAL 0xF32b
    Gets the horizontal scroll value.
  • #define SVM_GETVSCROLLVAL 0xF32c
    Gets the vertical scroll value.
  • #define SVM_GETHSCROLLPAGEVAL 0xF32d
    Gets the horizontal page scroll value.
  • #define SVM_GETVSCROLLPAGEVAL 0xF32e
    Gets the vertical page scroll value.
  • #define SVM_SETSCROLLVAL 0xF32f
    Sets the horizontal and vertical scroll value.
  • #define SVM_SETSCROLLPAGEVAL 0xF330
    Sets the horizontal and vertical page value.
  • #define SVM_SORTITEMS 0xF331
    Sorts the items according to a specified comparision function.
  • #define SVM_GETITEMCOUNT 0xF332
    Gets the total number of the items.
  • #define SVM_GETITEMADDDATA 0xF333
    Gets the additional data of the item.
  • #define SVM_SETITEMADDDATA 0xF334
    Sets the additional data of the item.
  • #define SVM_REFRESHITEM 0xF335
    Refresh the item.
  • #define SVM_SETITEMHEIGHT 0xF336
    Sets the height of an item.
  • #define SVM_GETFIRSTVISIBLEITEM 0xF337
    Gets the index of the first visible item.

Define Documentation

#define SVM_ADDCTRLS 0xF303

Adds controls to the scrollview.

 SVM_ADDCTRLS
 int itemNr;
 PCTRLDATA pctrls;

 wParam = (WPARAM)itemNr;
 lParam = (LPARAM)pctrls;

Parameters:
ctrlNr | Control number in the pctrls control array.
pctrls | Points to a CTRLDATA array that defines controls.
Returns:
Zero on success; otherwise -1.

Definition at line 317 of file scrollview.h.

#define SVM_ADDITEM 0xF300

Adds an item in the scrollview.

 SVM_ADDITEM
 SVITEMINFO svii;
 HSVITEM *phsvi;

 wParam = (WPARAM)phsvi;
 lParam = (LPARAM)&svii;

Parameters:
&svii | Pointer to a scrollview item information structure.
phsvi | Pointer to a HSVITEM var, used to store the item handle returned.
Returns:
Index of the scrollview item on success; otherwise -1.

Definition at line 255 of file scrollview.h.

#define SVM_CHOOSEITEM 0xF321

Makes an item selected and visible in the scrollview item.

 SVM_CHOOSEITEM
 int nItem;
 HSVITEM hsvi;

 wParam = (WPARAM)nItem;
 lParam = (LPARAM)hsvi;

Parameters:
nItem | Item index. Be useful when hsvi is zero.
hsvi | Item handle.
Returns:
0 on success, otherwise -1.

Definition at line 721 of file scrollview.h.

#define SVM_DELITEM 0xF301

Deletes an item from the scrollview.

 SVM_DELITEM
 int nItem;
 HSVITEM hsvi;

 wParam = (WPARAM)nItem;
 lParam = (LPARAM)hsvi;

Parameters:
nItem | Scrollview item index to delete. If hsvi is not zero, nItem will be ignored.
hsvi | Scrollview item handle to delete.
Returns:
Zero on success; otherwise -1.

Definition at line 276 of file scrollview.h.

#define SVM_GETBOTTOMMARGIN 0xF315

Gets the bottom margin value of the scrollview.

 SVM_GETBOTTOMMARGIN

 wParam = 0;
 lParam = 0;

Returns:
Bottom margin value on success, otherwise -1.

Definition at line 511 of file scrollview.h.

#define SVM_GETCONTENTX 0xF31b

Gets the content x offset in the viewport.

 SVM_GETCONTENTX

 wParam = 0;
 lParam = 0;

Returns:
Content x coordinate in the viewport on success, otherwise -1.

Definition at line 608 of file scrollview.h.

#define SVM_GETCONTENTY 0xF31c

Gets the content y offset in the viewport.

 SVM_GETCONTENTY

 wParam = 0;
 lParam = 0;

Returns:
Content y coordinate in the viewport on success, otherwise -1.

Definition at line 623 of file scrollview.h.

#define SVM_GETCONTHEIGHT 0xF319

Gets the height of the content area.

 SVM_GETCONTHEIGHT

 wParam = 0;
 lParam = 0;

Returns:
Height of the content area on success, otherwise -1.

Definition at line 571 of file scrollview.h.

#define SVM_GETCONTWIDTH 0xF318

Gets the width of the content area.

 SVM_GETCONTWIDTH

 wParam = 0;
 lParam = 0;

Returns:
Width of the content area on success, otherwise -1.

Definition at line 556 of file scrollview.h.

#define SVM_GETCTRL 0xF308

Gets the control handle in the scrollview window by control id.

 SVM_GETCTRL
 int id;

 wParam = (WPARAM)id;
 lParam = 0;

Parameters:
id Control id.
Returns:
Control window handle on success; otherwise 0.

Definition at line 375 of file scrollview.h.

#define SVM_GETCURSEL 0xF31e

Gets the index of the current hilighted scrollview item.

An application sends an this message to a scrollview window to get the index of the currently selected item, if there is one, in a single-selection scrollview. For multiple-selection case, appliction send this message to a scrollview to get the index of the current highlighted item.

 SVM_GETCURSEL

 wParam = 0;
 lParam = 0;

Returns:
Index of current hilighted item.

Definition at line 662 of file scrollview.h.

#define SVM_GETFIRSTVISIBLEITEM 0xF337

Gets the index of the first visible item.

 SVM_GETFIRSTVISIBLEITEM

Returns:
Item index.

Definition at line 1067 of file scrollview.h.

#define SVM_GETFOCUSCHILD 0xF32a

Gets the focus control in the scrollview.

 SVM_GETFOCUSCHILD

 wParam = 0;
 lParam = 0;

Returns:
Handle of the focus control.

Definition at line 851 of file scrollview.h.

#define SVM_GETHSCROLLPAGEVAL 0xF32d

Gets the horizontal page scroll value.

 SVM_GETHSCROLLPAGEVAL

 wParam = 0;
 lParam = 0;

Returns:
Current horizontal page scroll value.

Definition at line 896 of file scrollview.h.

#define SVM_GETHSCROLLVAL 0xF32b

Gets the horizontal scroll value.

 SVM_GETHSCROLLVAL

 wParam = 0;
 lParam = 0;

Returns:
Current horizontal scroll value.

Definition at line 866 of file scrollview.h.

#define SVM_GETITEMADDDATA 0xF333

Gets the additional data of the item.

 SVM_GETITEMADDDATA
 int nItem;
 HSVITEM hsvi;

 wParam = (WPARAM)nItem;
 lParam = (LPARAM)hsvi;

Parameters:
nItem | Scrollview item index to access. If hsvi is not zero, nItem will be ignored.
hsvi | Scrollview item handle to access.
Returns:
Item additional data.

Definition at line 995 of file scrollview.h.

#define SVM_GETITEMCOUNT 0xF332

Gets the total number of the items.

Returns:
Number of the items.

Definition at line 974 of file scrollview.h.

#define SVM_GETLEFTMARGIN 0xF312

Gets the left margin value of the scrollview.

 SVM_GETLEFTMARGIN

 wParam = 0;
 lParam = 0;

Returns:
Left margin value on success, otherwise -1.

Definition at line 466 of file scrollview.h.

#define SVM_GETMARGINS 0xF30b

Gets the margin values of the scrollview.

Application should use a RECT structure to get left, top, right, and bottom margins.

 SVM_GETMARGINS
 RECT rcMargin;

 wParam = 0;
 lParam = (LPARAM)&rcMargin;

Parameters:
rcMargin A RECT for storing 4 margin values.
Returns:
0 on success.

Definition at line 430 of file scrollview.h.

#define SVM_GETRIGHTMARGIN 0xF314

Gets the right margin value of the scrollview.

 SVM_GETRIGHTMARGIN

 wParam = 0;
 lParam = 0;

Returns:
Right margin value on success, otherwise -1.

Definition at line 496 of file scrollview.h.

#define SVM_GETTOPMARGIN 0xF313

Gets the top margin value of the scrollview.

 SVM_GETTOPMARGIN

 wParam = 0;
 lParam = 0;

Returns:
Top margin value on success, otherwise -1.

Definition at line 481 of file scrollview.h.

#define SVM_GETVISIBLEHEIGHT 0xF317

Gets the height of the visible content area.

 SVM_GETVISIBLEHEIGHT

 wParam = 0;
 lParam = 0;

Returns:
Height of the visible content area on success, otherwise -1.

Definition at line 541 of file scrollview.h.

#define SVM_GETVISIBLEWIDTH 0xF316

Gets the width of the visible content area.

 SVM_GETVISIBLEWIDTH

 wParam = 0;
 lParam = 0;

Returns:
Width of the visible content area on success, otherwise -1.

Definition at line 526 of file scrollview.h.

#define SVM_GETVSCROLLPAGEVAL 0xF32e

Gets the vertical page scroll value.

 SVM_GETVSCROLLPAGEVAL

 wParam = 0;
 lParam = 0;

Returns:
Current vertical page scroll value.

Definition at line 911 of file scrollview.h.

#define SVM_GETVSCROLLVAL 0xF32c

Gets the vertical scroll value.

 SVM_GETVSCROLLVAL

 wParam = 0;
 lParam = 0;

Returns:
Current vertical scroll value.

Definition at line 881 of file scrollview.h.

#define SVM_MAKEPOSVISIBLE 0xF328

Makes a position in the content area visible.

 SVM_MAKEPOSVISIBLE
 int pos_x, pos_y;

 wParam = (WPARAM)pos_x;
 lParam = (LPARAM)pos_y;

Parameters:
pos_x | X coordinate of the position to be made visible
pos_y | Y coordinate of the position to be made visible

Definition at line 818 of file scrollview.h.

#define SVM_REFRESHITEM 0xF335

Refresh the item.

 SVM_REFRESHITEM
 int nitem;
 HSVITEM hsvi;

 wParam = (WPARAM)nitem;
 lParam = (LPARAM)hsvi;

Parameters:
nitem | Item index. If hsvi is not zero, nItem will be ignored.
hsvi | Item handle.
Returns:
Returns 0.

Definition at line 1035 of file scrollview.h.

#define SVM_RESETCONTENT 0xF309

Clears all the controls and the items added to the scrollview window.

 SVM_RESETCONTENT

 wParam = 0;
 lParam = 0;

Returns:
Zero on success; otherwise -1.

Definition at line 390 of file scrollview.h.

#define SVM_SELECTITEM 0xF31f

Selects or unselects an item in the scrollview item.

 SVM_SELECTITEM
 int nItem;

 wParam = (WPARAM)nItem;
 lParam = (LPARAM)bSel;

Parameters:
nItem | Index of the item to select or unselect.
bSel | To select or unselect.
Returns:
0 on success, otherwise -1.

Definition at line 681 of file scrollview.h.

#define SVM_SETCONTAINERPROC 0xF329

Sets the window procedure of the container window in the scrollview.

 SVM_SETCONTAINERPROC
 WNDPROC pfn;

 wParam = 0;
 lParam = (LPARAM)pfn;

Parameters:
pfn New container procedure function.
Returns:
Old container procedure.

Definition at line 836 of file scrollview.h.

#define SVM_SETCONTHEIGHT 0xF307

Sets the scrollview content area (scrollable area) height.

Scrollable area of a scrolled window is always larger than the visible area.

 SVM_SETCONTHEIGHT
 int cont_h;

 wParam = (WPARAM)cont_h;
 lParam = 0;

Parameters:
cont_h Scrollview content height.
Returns:
Zero on success; otherwise -1.

Definition at line 357 of file scrollview.h.

#define SVM_SETCONTPOS 0xF31d

Sets the content offset position in the viewport.

 SVM_SETCONTPOS
 int cont_x, cont_y;

 wParam = (WPARAM)cont_x;
 lParam = (LPARAM)cont_y;

Parameters:
cont_x | New content x offset
cont_y | New content y offset
Returns:
0 on success, otherwise -1.

Definition at line 642 of file scrollview.h.

#define SVM_SETCONTRANGE 0xF31a

Sets the width and height of the content area.

If you want to change width and height, give a value large than zero. If you give -1, this value will remain untouched.

 SVM_SETCONTRANGE
 int cont_w, cont_h;

 wParam = (WPARAM)cont_w;
 lParam = (LPARAM)cont_h;

Parameters:
cont_w | Width of the content area.
cont_h | Height of the content area.
Returns:
0 on success, otherwise -1.

Definition at line 593 of file scrollview.h.

#define SVM_SETCONTWIDTH 0xF306

Sets the scrollview content area (scrollable area) width.

Scrollable area of a scrolled window is always larger than the visible area.

 SVM_SETCONTWIDTH
 int cont_w;

 wParam = (WPARAM)cont_w;
 lParam = 0;

Parameters:
cont_w Scrollview content width.
Returns:
Zero on success; otherwise -1.

Definition at line 337 of file scrollview.h.

#define SVM_SETCURSEL 0xF322

Makes an item as the current hilighted item in the scrollview item.

 SVM_SETCURSEL
 int nItem;
 BOOL bVisible;

 wParam = (WPARAM)nItem;
 lParam = (LPARAM)bVisible;

Parameters:
nitem | Item index.
bVisible | If bVisible is TRUE, this item wille be made visible.
Returns:
old hilighted item index on success, otherwise -1.

Definition at line 741 of file scrollview.h.

#define SVM_SETITEMADDDATA 0xF334

Sets the additional data of the item.

 SVM_SETITEMADDDATA
 int nitem;
 int addData;

 wParam = (WPARAM)nitem;
 lParam = (LPARAM)addData;

Parameters:
nitem | Item index.
addData | Additional data
Returns:
Old item additional data.

Definition at line 1015 of file scrollview.h.

#define SVM_SETITEMCMP 0xF327

Sets the item compare function.

 SVM_SETITEMCMP
 SVITEM_CMP *pfn;

 wParam = 0;
 lParam = (LPARAM)pfn;

Parameters:
pfn New item compare function
Returns:
Old function on success; otherwise NULL.

Definition at line 801 of file scrollview.h.

#define SVM_SETITEMDESTROY 0xF324

Sets the destroy operation of the items in the scrollview.

Normally item operations should be set before adding items. The destroy callback function will be called when deleting an item

 SVM_SETITEMDESTROY
 SVITEM_DESTROYFUNC *pfn;

 wParam = 0;
 lParam = (LPARAM)pfn;

Parameters:
pfn Item destroy operation function
Returns:
Old function on success; otherwise NULL.

Definition at line 783 of file scrollview.h.

#define SVM_SETITEMDRAW 0xF302

Sets the drawing operation of an item.

Scrollview item drawing function will be called when doing with MSG_PAINT message, scrollview window should define this function if it want to draw an customed item.

 SVM_SETITEMDRAW
 SVITEM_DRAWFUNC pfn;

 wParam = 0;
 lParam = (LPARAM)pfn;

Parameters:
pfn Scrollview item drawing function.
Returns:
Old drawing function pointer; otherwise 0.

Definition at line 297 of file scrollview.h.

#define SVM_SETITEMHEIGHT 0xF336

Sets the height of an item.

 SVM_SETITEMHEIGHT
 int nitem;
 int height;

 wParam = (WPARAM)nitem;
 lParam = (LPARAM)height;

Parameters:
nitem | Item index.
height | New height of the item
Returns:
Old item height.

Definition at line 1055 of file scrollview.h.

#define SVM_SETITEMINIT 0xF323

Sets the init operation of the items in the scrollview.

Normally item operations should be set before adding items. The initialization callback function will be called when adding an item.

 SVM_SETITEMINIT
 SVITEM_INITFUNC *pfn;

 wParam = 0;
 lParam = (LPARAM)pfn;

Parameters:
pfn Item init operation function
Returns:
Old function on success; otherwise NULL.

Definition at line 762 of file scrollview.h.

#define SVM_SETITEMOPS 0xF30a

Sets the item operations of the items in the scrollview.

Normally item operations should be set before adding items.

 SVM_SETITEMOPS
 SVITEMOPS *iop;

 wParam = 0;
 lParam = (LPARAM)iop;

Parameters:
iop Points to a SVITEMOPS structure that defines item operations
Returns:
Zero on success; otherwise -1.

Definition at line 410 of file scrollview.h.

#define SVM_SETMARGINS 0xF311

Sets the margin values of the scrollview.

Application should use a RECT structure to give left, top, right, and bottom margins. If you want to change a margin value, give a value large than zero, or else -1.

 SVM_SETMARGINS
 RECT *rcMargin;

 wParam = 0;
 lParam = (LPARAM)rcMargin;

Parameters:
rcMargin A RECT Containing 4 margin values.
Returns:
0 on success.

Definition at line 451 of file scrollview.h.

#define SVM_SETSCROLLPAGEVAL 0xF330

Sets the horizontal and vertical page value.

 SVM_SETSCROLLPAGEVAL
 int hval, vval;

 wParam = (WPARAM)hval;
 lParam = (WPARAM)vval;

Parameters:
hval | New horizontal page value.
vval | New vertical page value.
Returns:
Zero.

Definition at line 949 of file scrollview.h.

#define SVM_SETSCROLLVAL 0xF32f

Sets the horizontal and vertical scroll value.

 SVM_SETSCROLLVAL
 int hval, vval;

 wParam = (WPARAM)hval;
 lParam = (LPARAM)vval;

Parameters:
hval | New horizontal scroll value.
vval | New vertical scroll value.
Returns:
Zero.

Definition at line 930 of file scrollview.h.

#define SVM_SHOWITEM 0xF320

Makes an item visible in the scrollview item.

 SVM_SHOWITEM
 int nItem;
 HSVITEM hsvi;

 wParam = (WPARAM)nItem;
 lParam = (LPARAM)hsvi;

Parameters:
nItem | Item index. Be useful when hsvi is zero.
hsvi | Item handle.
Returns:
0 on success, otherwise -1.

Definition at line 701 of file scrollview.h.

#define SVM_SORTITEMS 0xF331

Sorts the items according to a specified comparision function.

 SVM_SORTITEMS
 SVITEM_CMP pfn;

 lParam = pfn;

Parameters:
pfn Comparision function.
Returns:
Zero.

Definition at line 966 of file scrollview.h.

Generated on Fri Dec 17 13:49:46 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Notification codes of scrollview control

Notification codes of scrollview control
[ScrollView control]

Defines

  • #define SVN_CLICKED 1
  • #define SVN_SELCHANGED 2
  • #define SVN_SELCHANGING 4

Define Documentation

#define SVN_CLICKED 1

Indicates clicking on the item

Definition at line 1078 of file scrollview.h.

#define SVN_SELCHANGED 2

Indicates the hilighted item changed

Definition at line 1081 of file scrollview.h.

#define SVN_SELCHANGING 4

Indicates the hilighted item changing

Definition at line 1084 of file scrollview.h.

Generated on Fri Dec 17 13:49:46 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: ScrollView control

ScrollView control
[Standard controls]

Modules

  • Styles of scrollview control
  • Messages of scrollview control
  • Notification codes of scrollview control

Data Structures

  • struct _CONTAINERINFO
  • struct _svitem_operations
  • struct _SCROLLVIEWITEMINFO

Defines

  • #define CTRL_SCROLLVIEW ("scrollview")
    The class name of scrollview control, uses this name to create a scrollable window that consists of items.
  • #define CTRL_SCROLLWND ("scrollwnd")
    The class name of scrollwnd control, uses this name to create a scrollable window to which you can add controls.

Typedefs

  • typedef GHANDLE HSVITEM
  • typedef CONTAINERINFO * PCONTAINERINFO
  • typedef int(* SVITEM_INITFUNC )(HWND hWnd, HSVITEM hsvi)
    Type of the scrollview item initialization callback procedure.
  • typedef void(* SVITEM_DESTROYFUNC )(HWND hWnd, HSVITEM hsvi)
    Type of the scrollview item destroy callback procedure.
  • typedef void(* SVITEM_DRAWFUNC )(HWND hWnd, HSVITEM hsvi, HDC hdc, RECT *rcDraw)
    Type of the scrollview item drawing callback procedure.
  • typedef int(* SVITEM_CMP )(HSVITEM hsvi1, HSVITEM hsvi2)
    Type of the scrollview item compare function.
  • typedef SVITEMOPS * PSVITEMOPS
  • typedef SVITEMINFO * PSVITEMINFO

Functions

  • MG_EXPORT int GUIAPI DefaultContainerProc (HWND hWnd, int message, WPARAM wParam, LPARAM lParam)
  • MG_EXPORT DWORD mglist_get_item_adddata (GHANDLE hi)
    Use this to get additional data from a list item in a control, such as scrollview and iconview.
  • MG_EXPORT DWORD scrollview_get_item_adddata (HSVITEM hsvi)
    Use this to get additional data from scrollview item.
  • MG_EXPORT int scrollview_get_item_index (HWND hWnd, HSVITEM hsvi)
    To get item index.
  • MG_EXPORT BOOL scrollview_is_item_hilight (HWND hWnd, HSVITEM hsvi)
    To decide whether an item is the current hilighted item.
  • MG_EXPORT BOOL scrollview_is_item_selected (HSVITEM hsvi)
    To decide whether an item is a selected.
  • MG_EXPORT int scrollview_set_item_height (HWND hWnd, HSVITEM hsvi, int height)
    Sets the height of an item.

Detailed Description

Scrollview control is a scrollable window, which has a visible area and normally a larger content area, user can browse content area using scrollbar. Contents of the content area is totally user-defined, you can add controls in it, add customed listed items, or anything you want.

In fact, you can build a control needing scrolled window support on scrollview.

Define Documentation

#define CTRL_SCROLLVIEW ("scrollview")

The class name of scrollview control, uses this name to create a scrollable window that consists of items.

Definition at line 60 of file scrollview.h.

#define CTRL_SCROLLWND ("scrollwnd")

The class name of scrollwnd control, uses this name to create a scrollable window to which you can add controls.

Definition at line 68 of file scrollview.h.

Typedef Documentation

typedef GHANDLE HSVITEM

Scrollview item object, use this handle to access a scrollview item

Definition at line 76 of file scrollview.h.

typedef CONTAINERINFO* PCONTAINERINFO

Data type of pointer to a CONTAINERINFO

Definition at line 98 of file scrollview.h.

typedef SVITEMINFO* PSVITEMINFO

Data type of pointer to a SVITEMINFO

Definition at line 198 of file scrollview.h.

typedef SVITEMOPS* PSVITEMOPS

Data type of pointer to a SVITEMOPS

Definition at line 185 of file scrollview.h.

typedef int(* SVITEM_CMP)(HSVITEM hsvi1, HSVITEM hsvi2)

Type of the scrollview item compare function.

Definition at line 172 of file scrollview.h.

typedef void(* SVITEM_DESTROYFUNC)(HWND hWnd, HSVITEM hsvi)

Type of the scrollview item destroy callback procedure.

Parameters:
hWnd | Handle of the scrollview control .
hsvi | Scrollview item handle.

Definition at line 155 of file scrollview.h.

typedef void(* SVITEM_DRAWFUNC)(HWND hWnd, HSVITEM hsvi, HDC hdc, RECT *rcDraw)

Type of the scrollview item drawing callback procedure.

Parameters:
hWnd | Handle of the scrollview control.
hsvi | Scrollview item handle.
hdc | Drawing device context.
rcDraw | Drawing rect area.

Definition at line 166 of file scrollview.h.

typedef void(* SVITEM_INITFUNC)(HWND hWnd, HSVITEM hsvi)

Type of the scrollview item initialization callback procedure.

Parameters:
hWnd | Handle of the scrollview control .
hsvi | Scrollview item handle.
Returns:
Zero on success; otherwise -1.

Definition at line 146 of file scrollview.h.

Function Documentation

MG_EXPORT int GUIAPI DefaultContainerProc | ( | HWND | hWnd,
 |  | int | message,
 |  | WPARAM | wParam,
 |  | LPARAM | lParam
 | ) |  |

Default container window procedure

See also:
DefaultDialogProc

DWORD mglist_get_item_adddata ( GHANDLE hi )

Use this to get additional data from a list item in a control, such as scrollview and iconview.

DWORD scrollview_get_item_adddata ( HSVITEM hsvi )

Use this to get additional data from scrollview item.

int scrollview_get_item_index | ( | HWND | hWnd,
 |  | HSVITEM | hsvi
 | ) |  |

To get item index.

int scrollview_is_item_hilight | ( | HWND | hWnd,
 |  | HSVITEM | hsvi
 | ) |  |

To decide whether an item is the current hilighted item.

int scrollview_is_item_selected ( HSVITEM hsvi )

To decide whether an item is a selected.

int scrollview_set_item_height | ( | HWND | hWnd,
 |  | HSVITEM | hsvi,
 |  | int | height
 | ) |  |

Sets the height of an item.

Generated on Fri Dec 17 13:49:46 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _CONTAINERINFO Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_CONTAINERINFO Struct Reference
[ScrollView control]

#include <scrollview.h>

Data Fields

  • WNDPROC user_proc
  • int controlnr
  • PCTRLDATA controls
  • DWORD dwAddData

Detailed Description

Structure which defines a container.

Definition at line 81 of file scrollview.h.

Field Documentation

WNDPROC user_proc

User-defined window procedure of the container

Definition at line 89 of file scrollview.h.

int controlnr

Number of controls

Definition at line 91 of file scrollview.h.

PCTRLDATA controls

Pointer to control array

Definition at line 93 of file scrollview.h.

DWORD dwAddData

Additional data

Definition at line 95 of file scrollview.h.

The documentation for this struct was generated from the following file:
  • scrollview.h
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _svitem_operations Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_svitem_operations Struct Reference
[ScrollView control]

#include <scrollview.h>

Data Fields

  • SVITEM_INITFUNC initItem
  • SVITEM_DESTROYFUNC destroyItem
  • SVITEM_DRAWFUNC drawItem

Detailed Description

Structure of item operations

Definition at line 175 of file scrollview.h.

Field Documentation

SVITEM_INITFUNC initItem

Called when an scrollview item is created

Definition at line 178 of file scrollview.h.

SVITEM_DESTROYFUNC destroyItem

Called when an item is destroied

Definition at line 180 of file scrollview.h.

SVITEM_DRAWFUNC drawItem

Call this to draw an item

Definition at line 182 of file scrollview.h.

The documentation for this struct was generated from the following file:
  • scrollview.h
Generated on Fri Dec 17 13:49:52 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _SCROLLVIEWITEMINFO Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_SCROLLVIEWITEMINFO Struct Reference
[ScrollView control]

#include <scrollview.h>

Data Fields

  • int nItem
  • int nItemHeight
  • DWORD addData

Detailed Description

Structure of the scrollview item info

Definition at line 188 of file scrollview.h.

Field Documentation

int nItem

Index of item

Definition at line 191 of file scrollview.h.

int nItemHeight

Height of an item

Definition at line 193 of file scrollview.h.

DWORD addData

Item additional data

Definition at line 195 of file scrollview.h.

The documentation for this struct was generated from the following file:
  • scrollview.h
Generated on Fri Dec 17 13:49:52 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Styles of spinbox control

Styles of spinbox control
[SpinBox control]

Defines

  • #define SPS_AUTOSCROLL 0x00000001L
    The spinbox control can automatically scroll, and disable itself when reach maximal or minimal value.
  • #define SPS_HORIZONTAL 0x00000010L
    The spinbox control is horizontal. The default is vertical.
  • #define SPS_TYPE_NORMAL 0x00000000L
    The spinbox control contains the up and left arrows.
  • #define SPS_TYPE_UPARROW 0x00000100L
    The spinbox control contains only the up/left arrow.
  • #define SPS_TYPE_DOWNARROW 0x00000200L
    The spinbox control contains only the down/right arrow.
  • #define SPS_TYPE_MASK 0x00000F00L
    The mask code of spinbox control.

Define Documentation

#define SPS_AUTOSCROLL 0x00000001L

The spinbox control can automatically scroll, and disable itself when reach maximal or minimal value.

Definition at line 91 of file spinbox.h.

#define SPS_HORIZONTAL 0x00000010L

The spinbox control is horizontal. The default is vertical.

Definition at line 97 of file spinbox.h.

#define SPS_TYPE_DOWNARROW 0x00000200L

The spinbox control contains only the down/right arrow.

Definition at line 115 of file spinbox.h.

#define SPS_TYPE_MASK 0x00000F00L

The mask code of spinbox control.

Definition at line 121 of file spinbox.h.

#define SPS_TYPE_NORMAL 0x00000000L

The spinbox control contains the up and left arrows.

Definition at line 103 of file spinbox.h.

#define SPS_TYPE_UPARROW 0x00000100L

The spinbox control contains only the up/left arrow.

Definition at line 109 of file spinbox.h.

Generated on Fri Dec 17 13:49:46 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Messages of spinbox control

Messages of spinbox control
[SpinBox control]

Defines

  • #define KS_SPINPOST 0x00010000
    The flag of the spinbox control message.
  • #define SPM_SETTARGET 0xF300
    Sets the target window of the spinbox.
  • #define SPM_GETTARGET 0xF301
    Gets the target window of the spinbox.
  • #define SPM_SETINFO 0xF302
    Sets the parameter information of the spinbox.
  • #define SPM_GETINFO 0xF303
    Gets the parameter infos of the spinbox.
  • #define SPM_DISABLEUP 0xF304
    Disable the ability to scroll up.
  • #define SPM_DISABLEDOWN 0xF305
    Disable the ability to scroll down.
  • #define SPM_ENABLEUP 0xF306
    Enable the ability to scroll up.
  • #define SPM_ENABLEDOWN 0xF307
    Enable the ability to scroll down.
  • #define SPM_SETCUR 0xF308
    Sets the current position in the range of the spinbox.
  • #define SPM_GETCUR 0xF309
    Gets the current position in the range of the spinbox.

Define Documentation

#define KS_SPINPOST 0x00010000

The flag of the spinbox control message.

Definition at line 133 of file spinbox.h.

#define SPM_DISABLEDOWN 0xF305

Disable the ability to scroll down.

 SPM_DISABLEDOWN

 wParam = 0;
 lParam = 0;

Returns:
Always be zero.

Definition at line 241 of file spinbox.h.

#define SPM_DISABLEUP 0xF304

Disable the ability to scroll up.

 SPM_DISABLEUP

 wParam = 0;
 lParam = 0;

Returns:
Always be zero.

Definition at line 226 of file spinbox.h.

#define SPM_ENABLEDOWN 0xF307

Enable the ability to scroll down.

 SPM_ENABLEDOWN

 wParam = 0;
 lParam = 0;

Returns:
Always be zero.

Definition at line 271 of file spinbox.h.

#define SPM_ENABLEUP 0xF306

Enable the ability to scroll up.

 SPM_ENABLEUP

 wParam = 0;
 lParam = 0;

Returns:
Always be zero.

Definition at line 256 of file spinbox.h.

#define SPM_GETCUR 0xF309

Gets the current position in the range of the spinbox.

 SPM_GETCUR

 wParam = 0;
 lParam = 0;

Returns:
The current position in the range of the spinbox.

Definition at line 304 of file spinbox.h.

#define SPM_GETINFO 0xF303

Gets the parameter infos of the spinbox.

 SPM_GETINFO
 PSPININFO info;

 wParam = 0;
 lParam = (LPARAM)info;

Parameters:
info Pointer to the SPININFO structure retreiving the spinbox info.
Returns:
Zero on success, -1 to indicate invalid parameter.
See also:
SPININFO

Definition at line 211 of file spinbox.h.

#define SPM_GETTARGET 0xF301

Gets the target window of the spinbox.

 SPM_GETTARGET

 wParam = 0;
 lParam = 0;

Returns:
The handle to the target window.

Definition at line 171 of file spinbox.h.

#define SPM_SETCUR 0xF308

Sets the current position in the range of the spinbox.

 SPM_SETCUR
 int pos;

 wParam = (WPARAM)pos;
 lParam = 0;

Parameters:
pos The current position to set.
Returns:
Zero on success, -1 to indicate invalid parameter.

Definition at line 289 of file spinbox.h.

#define SPM_SETINFO 0xF302

Sets the parameter information of the spinbox.

 SPM_SETINFO
 PSPININFO newinfo;

 wParam = 0;
 lParam = (LPARAM)newinfo;

Parameters:
newinfo Pointer to the SPININFO structure storing the new spinbox info.
Returns:
Zero on success, -1 to indicate invalid parameter.
See also:
SPININFO

Definition at line 191 of file spinbox.h.

#define SPM_SETTARGET 0xF300

Sets the target window of the spinbox.

When the user click the up/left or down/right arrow of the spin box, it will emulate the down and up of the key SCANCODE_CURSORBLOCKUP or SCANCODE_CURSORBLOCKDOWN, and post MSG_KEYDOWN and MSG_KEYUP message to the target window. Note that the shifit key status of the message will have the flag KS_SPINPOST set.

 SPM_SETTARGET
 HWND hTarget;

 wParam = 0;
 lParam = (LPARAM)hTarget;

Parameters:
hTarget Handle of the target window.
Returns:
Always be zero.

Definition at line 156 of file spinbox.h.

Generated on Fri Dec 17 13:49:47 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Notification codes of spinbox control

Notification codes of spinbox control
[SpinBox control]

Defines

  • #define SPN_REACHMIN 1
    Notifies that the spin box has reached the minimum limit.
  • #define SPN_REACHMAX 2
    Notifies that the spin box has reached the maximum limit.

Define Documentation

#define SPN_REACHMAX 2

Notifies that the spin box has reached the maximum limit.

Definition at line 323 of file spinbox.h.

#define SPN_REACHMIN 1

Notifies that the spin box has reached the minimum limit.

Definition at line 317 of file spinbox.h.

Generated on Fri Dec 17 13:49:47 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: SpinBox control

SpinBox control
[Standard controls]

Modules

  • Styles of spinbox control
  • Messages of spinbox control
  • Notification codes of spinbox control

Data Structures

  • struct _SPININFO

Defines

  • #define CTRL_SPINBOX ("SpinBox")
    The class name of spinbox control.

Typedefs

  • typedef SPININFO * PSPININFO
    Data type of the pointer to a SPININFO.

Functions

  • void GetSpinBoxSize (DWORD dwStyle, int *w, int *h)
    Gets size of a vertical spin box control.

Define Documentation

#define CTRL_SPINBOX ("SpinBox")

The class name of spinbox control.

Definition at line 50 of file spinbox.h.

Typedef Documentation

typedef SPININFO * PSPININFO

Data type of the pointer to a SPININFO.

Definition at line 66 of file spinbox.h.

Function Documentation

void GetSpinBoxSize | ( | DWORD | dwStyle,
 |  | int * | w,
 |  | int * | h
 | ) |  |

Gets size of a vertical spin box control.

The spin box control in MiniGUI has fixed size. This function gets the size of a spin box control.

Parameters:
dwStyle | The style of the spin box.
w | The width of the spin box control will be returned through this argument.
h | The height of the spin box control will be returned through this argument.

Generated on Fri Dec 17 13:49:46 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _SPININFO Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_SPININFO Struct Reference
[SpinBox control]

#include <spinbox.h>

Data Fields

  • int max
  • int min
  • int cur

Detailed Description

Structure of the spinbox info

Definition at line 53 of file spinbox.h.

Field Documentation

int max

Maximum position value

Definition at line 56 of file spinbox.h.

int min

Minimum position value

Definition at line 58 of file spinbox.h.

int cur

Current position value

Definition at line 60 of file spinbox.h.

The documentation for this struct was generated from the following file:
  • spinbox.h
Generated on Fri Dec 17 13:49:52 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Styles of static control

Styles of static control
[Static control]

Defines

  • #define SS_SIMPLE 0x00000000L
    Designates a simple rectangle and displays a single line of text flush-left in the rectangle.
  • #define SS_BLACKRECT 0x00000001L
    Specifies a rectangle filled with the black color.
  • #define SS_GRAYRECT 0x00000002L
    Specifies a rectangle filled with the light gray color.
  • #define SS_WHITERECT 0x00000003L
    Specifies a rectangle filled with the light white color.
  • #define SS_BLACKFRAME 0x00000004L
    Specifies a box with a frame drawn with the black color.
  • #define SS_GRAYFRAME 0x00000005L
    Specifies a box with a frame drawn with the light gray color.
  • #define SS_WHITEFRAME 0x00000006L
    Specifies a box with a frame drawn with the light white color.
  • #define SS_GROUPBOX 0x00000007L
    Creates a rectangle in which other controls can be grouped.
  • #define SS_ICON 0x00000008L
    Designates an icon displayed in the static control.
  • #define SS_BITMAP 0x00000009L
    Specifies that a bitmap will be displayed in the static control.
  • #define SS_TYPEMASK 0x0000000FL
    The mask code of the static control.
  • #define SS_LEFT 0x00000010L
    Displays the given text flush-left.
  • #define SS_CENTER 0x00000020L
    Displays the given text centered in the rectangle.
  • #define SS_RIGHT 0x00000030L
    Displays the given text flush-right.
  • #define SS_ALIGNMASK 0x000000F0L
    The mask code of the static control.
  • #define SS_NOPREFIX 0x00000100L
    Prevents interpretation of any ampersand (&) characters in the control's text as accelerator prefix characters.
  • #define SS_CENTERIMAGE 0x00000200L
    Puts the image in the center of the static control. Default is top-left aligned.
  • #define SS_NOWORDWRAP 0x00000400L
    Designates a simple rectangle and displays the given text in single line in the rectangle.
  • #define SS_LEFTNOWORDWRAP SS_NOWORDWRAP
    Backward compatibility definition.
  • #define SS_REALSIZEIMAGE 0x00000800L
    Does not scale the image.
  • #define SS_NOTIFY 0x00001000L
    Sends the parent window notification messages when the user clicks or double-clicks the control.

Define Documentation

#define SS_ALIGNMASK 0x000000F0L

The mask code of the static control.

Definition at line 154 of file static.h.

#define SS_BITMAP 0x00000009L

Specifies that a bitmap will be displayed in the static control.

Definition at line 117 of file static.h.

#define SS_BLACKFRAME 0x00000004L

Specifies a box with a frame drawn with the black color.

Definition at line 87 of file static.h.

#define SS_BLACKRECT 0x00000001L

Specifies a rectangle filled with the black color.

Definition at line 69 of file static.h.

#define SS_CENTER 0x00000020L

Displays the given text centered in the rectangle.

Definition at line 141 of file static.h.

#define SS_CENTERIMAGE 0x00000200L

Puts the image in the center of the static control. Default is top-left aligned.

Definition at line 170 of file static.h.

#define SS_GRAYFRAME 0x00000005L

Specifies a box with a frame drawn with the light gray color.

Definition at line 93 of file static.h.

#define SS_GRAYRECT 0x00000002L

Specifies a rectangle filled with the light gray color.

Definition at line 75 of file static.h.

#define SS_GROUPBOX 0x00000007L

Creates a rectangle in which other controls can be grouped.

Definition at line 105 of file static.h.

#define SS_ICON 0x00000008L

Designates an icon displayed in the static control.

Definition at line 111 of file static.h.

#define SS_LEFT 0x00000010L

Displays the given text flush-left.

Definition at line 135 of file static.h.

#define SS_LEFTNOWORDWRAP SS_NOWORDWRAP

Backward compatibility definition.

See also:
SS_NOWORDWRAP

Definition at line 188 of file static.h.

#define SS_NOPREFIX 0x00000100L

Prevents interpretation of any ampersand (&) characters in the control's text as accelerator prefix characters.

Note:
Not implemented so far.

Definition at line 163 of file static.h.

#define SS_NOTIFY 0x00001000L

Sends the parent window notification messages when the user clicks or double-clicks the control.

Definition at line 201 of file static.h.

#define SS_NOWORDWRAP 0x00000400L

Designates a simple rectangle and displays the given text in single line in the rectangle.

Tabs are expanded, but words are not wrapped. Text that extends past the rectagnel is clipped.

Definition at line 180 of file static.h.

#define SS_REALSIZEIMAGE 0x00000800L

Does not scale the image.

Definition at line 194 of file static.h.

#define SS_RIGHT 0x00000030L

Displays the given text flush-right.

Definition at line 147 of file static.h.

#define SS_SIMPLE 0x00000000L

Designates a simple rectangle and displays a single line of text flush-left in the rectangle.

Definition at line 63 of file static.h.

#define SS_TYPEMASK 0x0000000FL

The mask code of the static control.

Definition at line 129 of file static.h.

#define SS_WHITEFRAME 0x00000006L

Specifies a box with a frame drawn with the light white color.

Definition at line 99 of file static.h.

#define SS_WHITERECT 0x00000003L

Specifies a rectangle filled with the light white color.

Definition at line 81 of file static.h.

Generated on Fri Dec 17 13:49:47 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Messages of static control

Messages of static control
[Static control]

Defines

  • #define STM_SETIMAGE 0xF172
    Associates a new image (icon or bitmap) with a static control.
  • #define STM_GETIMAGE 0xF173
    Retrieves a handle to the image.

Define Documentation

#define STM_GETIMAGE 0xF173

Retrieves a handle to the image.

An application sends an STM_GETIMAGE message to retrieve a handle to the image associated with a static control.

 STM_GETIMAGE
 wParam = 0;
 lParam = 0;

Returns:
The handle to the icon if the type of static control type is SS_ICON, or the pointer to the BITMAP object if the type is SS_BITMAP.

Definition at line 254 of file static.h.

#define STM_SETIMAGE 0xF172

Associates a new image (icon or bitmap) with a static control.

An application sends an STM_SETIMAGE message to associate a new image (icon or bitmap) with a static control.

 STM_SETIMAGE
 HICON image;
  or
 BITMAP* image;

 wParam = (WPARAM)image;
 lParam = 0;

Parameters:
image The handle to an icon if the type of static control type is SS_ICON, or the pointer to a BITMAP object if the type is SS_BITMAP.
Returns:
The old image (handle or pointer).

Definition at line 236 of file static.h.

Generated on Fri Dec 17 13:49:47 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Notification codes of static control

Notification codes of static control
[Static control]

Defines

  • #define STN_DBLCLK 1
    Notifies a double-click.
  • #define STN_CLICKED 4
    Notifies that a static control is clicked.

Define Documentation

#define STN_CLICKED 4

Notifies that a static control is clicked.

The STN_CLICKED notification message is sent when the user clicks a static control that has the SS_NOTIFY style.

Definition at line 286 of file static.h.

#define STN_DBLCLK 1

Notifies a double-click.

The STN_DBLCLK notification message is sent when the user double-clicks a static control that has the SS_NOTIFY style.

Definition at line 272 of file static.h.

Generated on Fri Dec 17 13:49:47 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Static control

Static control
[Standard controls]

Modules

  • Styles of static control
  • Messages of static control
  • Notification codes of static control

Defines

  • #define CTRL_STATIC ("static")
    The class name of static control.

Define Documentation

#define CTRL_STATIC ("static")

The class name of static control.

Definition at line 51 of file static.h.

Generated on Fri Dec 17 13:49:47 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: TextEdit control

TextEdit control
[Standard controls]

Modules

  • Styles of textedit control
  • Messages of textedit control
  • Notification codes of textedit control

Defines

  • #define CTRL_TEXTEDIT ("textedit")
    The class name of textedit control.

Typedefs

  • typedef GHANDLE HTEXTDOC
    Text document/buffer object.

Define Documentation

#define CTRL_TEXTEDIT ("textedit")

The class name of textedit control.

Definition at line 51 of file textedit.h.

Typedef Documentation

typedef GHANDLE HTEXTDOC

Text document/buffer object.

Definition at line 58 of file textedit.h.

Generated on Fri Dec 17 13:49:47 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Styles of trackbar control

Styles of trackbar control
[TrackBar control]

Defines

  • #define TBS_NOTIFY 0x0001L
    Causes the trackbar to notify the parent window with a notification message when the user clicks or doubleclicks the trackbar.
  • #define TBS_VERTICAL 0x0002L
    The trackbar control will be oriented vertically.
  • #define TBS_BORDER 0x0004L
    The trackbar control will have border.
  • #define TBS_TIP 0x0008L
    The trackbar control will display tip string above the control.
  • #define TBS_NOTICK 0x0010L
    The trackbar control will not display tick line beside the control.

Define Documentation

#define TBS_BORDER 0x0004L

The trackbar control will have border.

Definition at line 81 of file trackbar.h.

#define TBS_NOTICK 0x0010L

The trackbar control will not display tick line beside the control.

Definition at line 93 of file trackbar.h.

#define TBS_NOTIFY 0x0001L

Causes the trackbar to notify the parent window with a notification message when the user clicks or doubleclicks the trackbar.

Definition at line 69 of file trackbar.h.

#define TBS_TIP 0x0008L

The trackbar control will display tip string above the control.

Definition at line 87 of file trackbar.h.

#define TBS_VERTICAL 0x0002L

The trackbar control will be oriented vertically.

Definition at line 75 of file trackbar.h.

Generated on Fri Dec 17 13:49:47 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Messages of trackbar control

Messages of trackbar control
[TrackBar control]

Defines

  • #define TBM_SETRANGE 0xF090
    Sets the range of minimum and maximum logical positions for the slider in a trackbar.
  • #define TBM_GETMIN 0xF091
    Gets the minimum logical position for the slider.
  • #define TBM_SETPOS 0xF092
    Sets the current logical position of the slider.
  • #define TBM_GETPOS 0xF093
    Gets the current logical position of the slider.
  • #define TBM_SETLINESIZE 0xF094
    Sets the number of logical positions moved in response to keyboard input from the arrow keys.
  • #define TBM_GETLINESIZE 0xF095
    Gets the number of logical positions moved in response to keyboard input from the arrow keys.
  • #define TBM_SETPAGESIZE 0xF096
    Sets the number of logical positions moved in response to keyboard input from page keys..
  • #define TBM_GETPAGESIZE 0xF097
    Gets the number of logical positions moved in response to keyboard input from page keys..
  • #define TBM_SETTIP 0xF098
    Sets the start and end tip strings.
  • #define TBM_GETTIP 0xF09A
    Gets the start and end tip strings.
  • #define TBM_SETTICKFREQ 0xF09B
    Sets the interval frequency for tick marks in a trackbar.
  • #define TBM_GETTICKFREQ 0xF09C
    Gets the interval frequency for tick marks in a trackbar.
  • #define TBM_SETMIN 0xF09D
    Sets the minimum logical position for the slider in a trackbar.
  • #define TBM_SETMAX 0xF09E
    Sets the maximum logical position for the slider in a trackbar.
  • #define TBM_GETMAX 0xF09F
    Gets the maximum logical position for the slider in a trackbar.

Define Documentation

#define TBM_GETLINESIZE 0xF095

Gets the number of logical positions moved in response to keyboard input from the arrow keys.

Gets the number of logical positions the trackbar's slider moves in response to keyboard input from the arrow keys. The logical positions are the integer increments in the trackbar's range of minimum to maximum slider positions.

 TBM_GETLINESIZE

 wParam = 0;
 lParam = 0;

Returns:
The current line size.

Definition at line 215 of file trackbar.h.

#define TBM_GETMAX 0xF09F

Gets the maximum logical position for the slider in a trackbar.

 TBM_GETMAX

 wParam = 0;
 lParam = 0;

Returns:
The current maximum logical position for the slider in a trackbar.

Definition at line 386 of file trackbar.h.

#define TBM_GETMIN 0xF091

Gets the minimum logical position for the slider.

 TBM_GETMIN

 wParam = 0;
 lParam = 0;

Returns:
The minimum logical position for the slider.

Definition at line 139 of file trackbar.h.

#define TBM_GETPAGESIZE 0xF097

Gets the number of logical positions moved in response to keyboard input from page keys..

Gets the number of logical positions the trackbar's slider moves in response to keyboard input form page keys, such as PAGE DOWN or PAGE UP keys. The logical positions are the integer increments in the trackbar's range of minimum to maximum slider positions.

 TBM_GETPAGESIZE

 wParam = 0;
 lParam = 0;

Returns:
The current page size.

Definition at line 260 of file trackbar.h.

#define TBM_GETPOS 0xF093

Gets the current logical position of the slider.

 TBM_GETPOS

 wParam = 0;
 lParam = 0;

Returns:
The current logical position of the slider.

Definition at line 172 of file trackbar.h.

#define TBM_GETTICKFREQ 0xF09C

Gets the interval frequency for tick marks in a trackbar.

 TBM_GETTICKFREQ

 wParam = 0;
 lParam = 0;

Returns:
The current interval frequency for tick marks in a trackbar.

Definition at line 335 of file trackbar.h.

#define TBM_GETTIP 0xF09A

Gets the start and end tip strings.

 TBM_GETTIP
 char starttip [TBLEN_TIP + 1];
 char endtip [TBLEN_TIP + 1];

 wParam = (WPARAM)starttip;
 lParam = (LPARAM)endtip;

Parameters:
starttip | Buffer receives the start tip string. It should be length enough to save (TBLEN_TIP + 1) characters.
endtip | Buffer receives the end tip string. It should be length enough to save (TBLEN_TIP + 1) characters.
Returns:
Always be zero.

Definition at line 302 of file trackbar.h.

#define TBM_SETLINESIZE 0xF094

Sets the number of logical positions moved in response to keyboard input from the arrow keys.

Sets the number of logical positions the trackbar's slider moves in response to keyboard input from the arrow keys. The logical positions are the integer increments in the trackbar's range of minimum to maximum slider positions.

 TBM_SETLINESIZE
 int linesize;

 wParam = (WPARAM)linesize;
 lParam = 0;

Parameters:
linesize New line size.
Returns:
Zero on success; otherwise -1.

Definition at line 195 of file trackbar.h.

#define TBM_SETMAX 0xF09E

Sets the maximum logical position for the slider in a trackbar.

 TBM_SETMAX
 int max;

 wParam = (WPARAM)max;
 lParam = 0;

Parameters:
min The new maximum logical position for the slider in a trackbar.
Returns:
Zero on success; otherwise -1.

Definition at line 371 of file trackbar.h.

#define TBM_SETMIN 0xF09D

Sets the minimum logical position for the slider in a trackbar.

 TBM_SETMIN
 int min;

 wParam = (WPARAM)min;
 lParam = 0;

Parameters:
min The new minimum logical position for the slider in a trackbar.
Returns:
Zero on success; otherwise -1.

Definition at line 353 of file trackbar.h.

#define TBM_SETPAGESIZE 0xF096

Sets the number of logical positions moved in response to keyboard input from page keys..

Sets the number of logical positions the trackbar's slider moves in response to keyboard input form page keys, such as PAGE DOWN or PAGE UP keys. The logical positions are the integer increments in the trackbar's range of minimum to maximum slider positions.

 TBM_SETPAGESIZE
 int pagesize;

 wParam = (WPARAM)pagesize;
 lParam = 0;

Parameters:
pagesize New page size.
Returns:
Zero on success; otherwise -1.

Definition at line 239 of file trackbar.h.

#define TBM_SETPOS 0xF092

Sets the current logical position of the slider.

 TBM_SETPOS
 int pos;

 wParam = (WPARAM)pos;
 lParam = 0;

Parameters:
pos New logical position of the slider.
Returns:
Always be zero.

Definition at line 157 of file trackbar.h.

#define TBM_SETRANGE 0xF090

Sets the range of minimum and maximum logical positions for the slider in a trackbar.

 TBM_SETRANGE
 int min;
 int max;

 wParam = (WPARAM)min;
 lParam = (LPARAM)max;

Parameters:
min | Minimum position for the slider.
max | Maximum position for the slider.
Returns:
Zero on success; otherwise -1.

Definition at line 124 of file trackbar.h.

#define TBM_SETTICKFREQ 0xF09B

Sets the interval frequency for tick marks in a trackbar.

 TBM_SETTICKFREQ
 int tickfreq;

 wParam = (WPARAM)tickfreq;
 lParam = 0;

Parameters:
tickfreq New interval frequency for tick marks in a trackbar.
Returns:
Zero on success; otherwise -1.

Definition at line 320 of file trackbar.h.

#define TBM_SETTIP 0xF098

Sets the start and end tip strings.

 TBM_SETTIP
 char* starttip;
 char* endtip;

 wParam = (WPARAM)starttip;
 lParam = (LPARAM)endtip;

Parameters:
starttip | New start tip string.
endtip | New end tip tip string.
Returns:
Always be zero.

Definition at line 280 of file trackbar.h.

Generated on Fri Dec 17 13:49:47 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Notification codes of trackbar control

Notification codes of trackbar control
[TrackBar control]

Defines

  • #define TBN_REACHMIN 1
    Notifies that the slider has reached the minimum position.
  • #define TBN_REACHMAX 2
    Notifies that the slider has reached the maximum position.
  • #define TBN_CHANGE 3
    Notifies that the position of the slider has changed.
  • #define TBN_STARTDRAG 4
    Notifies that the user start to drag the slider.
  • #define TBN_STOPDRAG 5
    Notifies that the user stop to drag the slider.

Define Documentation

#define TBN_CHANGE 3

Notifies that the position of the slider has changed.

Definition at line 413 of file trackbar.h.

#define TBN_REACHMAX 2

Notifies that the slider has reached the maximum position.

Definition at line 407 of file trackbar.h.

#define TBN_REACHMIN 1

Notifies that the slider has reached the minimum position.

Definition at line 401 of file trackbar.h.

#define TBN_STARTDRAG 4

Notifies that the user start to drag the slider.

Definition at line 419 of file trackbar.h.

#define TBN_STOPDRAG 5

Notifies that the user stop to drag the slider.

Definition at line 425 of file trackbar.h.

Generated on Fri Dec 17 13:49:47 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: state for renderer

state for renderer
[TrackBar control]

Defines

  • #define LFRDR_TBS_PRESSED 0x0100L
    indicate left button down
  • #define LFRDR_TBS_HILITE 0x0200L
    indicate mouse is in region of thumb of trackbar

Define Documentation

#define LFRDR_TBS_HILITE 0x0200L

indicate mouse is in region of thumb of trackbar

Definition at line 443 of file trackbar.h.

#define LFRDR_TBS_PRESSED 0x0100L

indicate left button down

Definition at line 437 of file trackbar.h.

Generated on Fri Dec 17 13:49:47 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: TrackBar control

TrackBar control
[Standard controls]

Modules

  • Styles of trackbar control
  • Messages of trackbar control
  • Notification codes of trackbar control
  • state for renderer

Defines

  • #define CTRL_TRACKBAR ("trackbar")
    The class name of trackbar control.
  • #define TBLEN_TIP 31
    The maximum length of the trackbar tip string.

Define Documentation

#define CTRL_TRACKBAR ("trackbar")

The class name of trackbar control.

Definition at line 51 of file trackbar.h.

#define TBLEN_TIP 31

The maximum length of the trackbar tip string.

Definition at line 57 of file trackbar.h.

Generated on Fri Dec 17 13:49:47 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Styles of treeview control

Styles of treeview control
[TreeView control]

Defines

  • #define TVS_NOTIFY 0x0001L
    Sends the parent window notification messages when the user clicks or double-clicks the control.
  • #define TVS_WITHICON 0x0002L
    The treeview item will use icons to indicate folded or unfolded status.
  • #define TVS_ICONFORSELECT 0x0000L
    The fold icon is used to indicate selected item.
  • #define TVS_SORT 0x0010L
    Enables sorting in the treeview.

Define Documentation

#define TVS_ICONFORSELECT 0x0000L

The fold icon is used to indicate selected item.

For TreeView control with TVS_ICONFORSELECT style, the item icons will be used to indicate selected or unselected status of the item.

Note:
This style is obselete since MiniGUI V3.0.

Definition at line 132 of file treeview.h.

#define TVS_NOTIFY 0x0001L

Sends the parent window notification messages when the user clicks or double-clicks the control.

Definition at line 114 of file treeview.h.

#define TVS_SORT 0x0010L

Enables sorting in the treeview.

Definition at line 141 of file treeview.h.

#define TVS_WITHICON 0x0002L

The treeview item will use icons to indicate folded or unfolded status.

Definition at line 120 of file treeview.h.

Generated on Fri Dec 17 13:49:47 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Messages of treeview control

Messages of treeview control
[TreeView control]

Defines

  • #define TVM_ADDITEM 0xF110
    Adds a new item in a treeview control.
  • #define TVM_INSERTITEM 0xF111
    The same as TVM_ADDITEM message.
  • #define TVM_GETROOT 0xF112
    Gets the root item of a treeview control.
  • #define TVM_DELTREE 0xF113
    Removes an item and its descendant items for the treeview control.
  • #define TVM_SEARCHITEM 0xF114
    Searches an item matching a specified string in a subtree rooted by a specific item.
  • #define TVM_FINDCHILD 0xF115
    Finds a child item matching a specified string in children of a specific item.
  • #define TVM_GETSELITEM 0xF116
    Gets the selected item.
  • #define TVM_SETSELITEM 0xF117
    Sets the selected item.
  • #define TVM_GETITEMTEXTLEN 0xF118
    Retrives the text length of the specified item in TreeView control.
  • #define TVM_GETITEMTEXT 0xF119
    Retrives the text of the specified item in TreeView control.
  • #define TVM_GETITEMINFO 0xF11A
    Retrives the information of an item in TreeView control.
  • #define TVM_SETITEMINFO 0xF11B
    Changes the information of an item.
  • #define TVM_GETRELATEDITEM 0xF11C
    Retrives related item of specific item.
  • #define TVM_SETSTRCMPFUNC 0xF11D
    Sets the STRCMP function used to sort items.

Define Documentation

#define TVM_ADDITEM 0xF110

Adds a new item in a treeview control.

 TVM_ADDITEM
 GHANDLE parent;
 PTVITEMINFO newIteminfo;

 wParam = (WPARAM)parent;
 lParam = (LPARAM)newIteminfo;

Parameters:
parent | Handle to the item who is the parent of the new item.
newIteminfo | Pointer to the item info structure of the new item to be added.
Returns:
The handle to the new item on success, otherwise return 0.

Definition at line 169 of file treeview.h.

#define TVM_DELTREE 0xF113

Removes an item and its descendant items for the treeview control.

 TVM_DELTREE
 GHANDLE item;

 wParam = (WPARAM)item;
 lParam = 0;

Returns:
Zero on success, otherwise -1.

Definition at line 206 of file treeview.h.

#define TVM_FINDCHILD 0xF115

Finds a child item matching a specified string in children of a specific item.

 TVM_FINDCHILD
 GHNADLE item;
 char* string;

 wParam = (WPARAM)item;
 lParam = (LPARAM)string;

Parameters:
item | The handle to the item. Zero means the root item.
string | The specified string.
Returns:
The handle to the item whose text matches the specified string on success, otherwise zero for not found or invalid parameters.

Definition at line 251 of file treeview.h.

#define TVM_GETITEMINFO 0xF11A

Retrives the information of an item in TreeView control.

 TVM_GETITEMINFO

 GHANDLE item;
 TVITEMINFO* tvii;

 wParam = (WPARAM)item;
 lParam = (LPARAM)tvii;

Parameters:
item | The handle to the item which we want to retrive.
tvii | A pointer to a TVITEMINFO structure to receive the item information. Note that the text field of this structure should be large enough to get the item text.
Returns:
Zero on success, otherwise -1.
See also:
TVM_GETITEMTEXTLEN

Definition at line 349 of file treeview.h.

#define TVM_GETITEMTEXT 0xF119

Retrives the text of the specified item in TreeView control.

 TVM_GETITEMTEXT

 GHANDLE item;
 char* buffer;

 wParam = (WPARAM)item;
 lParam = (LPARAM)buffer;

Parameters:
item | The handle to the item which we want to retrive.
buffer | The pointer to a buffer to save the text of the item.
Returns:
The length of the item text on success, otherwise -1.

Definition at line 324 of file treeview.h.

#define TVM_GETITEMTEXTLEN 0xF118

Retrives the text length of the specified item in TreeView control.

 TVM_GETITEMTEXTLEN

 GHANDLE item;

 wParam = (WPARAM)item;
 lParam = (LPARAM)0;

Parameters:
item The handle to the item which we want to retrive.
Returns:
The length of the item text on success, otherwise -1.

Definition at line 303 of file treeview.h.

#define TVM_GETRELATEDITEM 0xF11C

Retrives related item of specific item.

 TVM_GETRELATEDITEM
 int related;
 GHANDLE item;

 wParam = (WPARAM)related;
 lParam = (LPARAM)item;

Parameters:
related A integer which indicates the relationship between the item to retrive and the specified item, can be one of the following values:
  • TVIR_PARENT
    To retrive the parent item of the specified item.
  • TVIR_FIRSTCHILD
    To retrive the first child item of the specified item.
  • TVIR_NEXTSIBLING
    To retrive the next sibling item of the specified item.
  • TVIR_PREVSIBLING
    To retrive the previous sibling item of the specified item.
item The handle to the known item.
Returns:
The handle to the related item on success, otherwise 0.

Definition at line 405 of file treeview.h.

#define TVM_GETROOT 0xF112

Gets the root item of a treeview control.

 TVM_GETROOT

 wParam = 0;
 lParam = 0;

Returns:
The handle to the root item.

Definition at line 190 of file treeview.h.

#define TVM_GETSELITEM 0xF116

Gets the selected item.

 TVM_GETSELITEM

 wParam = 0;
 lParam = 0;

Returns:
Handle to the selected item.

Definition at line 266 of file treeview.h.

#define TVM_INSERTITEM 0xF111

The same as TVM_ADDITEM message.

Definition at line 175 of file treeview.h.

#define TVM_SEARCHITEM 0xF114

Searches an item matching a specified string in a subtree rooted by a specific item.

Note:
This is a depth first search.
 TVM_SEARCHITEM
 GHNADLE item;
 char* string;

 wParam = (WPARAM)item;
 lParam = (LPARAM)string;

Parameters:
found | The handle to the item which is the root item of the subtree. Zero means the root item.
string | The specified string.
Returns:
The handle to the item whose text matches the specified string on success, otherwise zero for not found or invalid parameters.

Definition at line 230 of file treeview.h.

#define TVM_SETITEMINFO 0xF11B

Changes the information of an item.

 TVM_SETITEMTEXT
 GHANDLE item;
 TVITEMINFO* tvii;

 wParam = (WPARAM)id;
 lParam = (LPARAM)tvii;

Parameters:
item | The handle of the item.
newText | Pointer to a TVITEMINFO structure which include the new information of the item.
Returns:
Zero on success, otherwise -1.

Definition at line 370 of file treeview.h.

#define TVM_SETSELITEM 0xF117

Sets the selected item.

 TVM_SETSELITEM
 GHANDLE item;

 wParam = (WPARAM)item;
 lParam = 0;

Parameters:
item The handle to candicate item.
Returns:
The handle to the old selected item on success, otherwise -1.

Definition at line 284 of file treeview.h.

#define TVM_SETSTRCMPFUNC 0xF11D

Sets the STRCMP function used to sort items.

An application sends a TVM_SETSTRCMPFUNC message to set a new STRCMP function to sort items in the TreeView control.

Note that you should send this message before adding any item to the TreeView control.

 static int my_strcmp (const char* s1, const char* s2, size_t n)
 {
      ...
      return 0;
 }

 TVM_SETSTRCMPFUNC

 wParam = 0;
 lParam = (LPARAM) my_strcmp;

Parameters:
my_strcmp Your own function to compare two strings.
Returns:
One of the following values:
  • 0
    Success
  • -1
    Not an empty TreeView control

Definition at line 436 of file treeview.h.

Generated on Fri Dec 17 13:49:47 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Notification codes of treeview control

Notification codes of treeview control
[TreeView control]

Defines

  • #define TVN_ERRSPACE 255
    Indicates that memory is not enough.
  • #define TVN_SELCHANGE 1
    Notifies the change of selection.
  • #define TVN_DBLCLK 2
    Notifies the user has double-clicked an item.
  • #define TVN_SETFOCUS 4
    Indicates gain of input focus.
  • #define TVN_KILLFOCUS 5
    Indicates loss of input focus.
  • #define TVN_CLICKED 7
    Indicates the user has clicked an item.
  • #define TVN_ENTER 8
    Indicates the user has pressed the ENTER key.
  • #define TVN_FOLDED 9
    Indicates a sub-tree has folded.
  • #define TVN_UNFOLDED 10
    Indicates a sub-tree has unfolded.

Define Documentation

#define TVN_CLICKED 7

Indicates the user has clicked an item.

Definition at line 490 of file treeview.h.

#define TVN_DBLCLK 2

Notifies the user has double-clicked an item.

Definition at line 466 of file treeview.h.

#define TVN_ENTER 8

Indicates the user has pressed the ENTER key.

Definition at line 496 of file treeview.h.

#define TVN_ERRSPACE 255

Indicates that memory is not enough.

A list box sends an TVN_ERRSPACE notification message to its parent window when it cannot allocate enough memory to complete the current operation.

Definition at line 454 of file treeview.h.

#define TVN_FOLDED 9

Indicates a sub-tree has folded.

Note:
This is an extended notification, the control calls NotifyParentEx function to notify the parent, and passes the handle to the folded item through add_data argument of NotifyParentEx function. You should define and set Notificaton Callback Procedure for the control in order to get the handle to the folded item.
See also:
SetNotificationCallback, NotifyParentEx

Definition at line 510 of file treeview.h.

#define TVN_KILLFOCUS 5

Indicates loss of input focus.

A TreeView control sends an TVN_KILLFOCUS notification message to its parent window when the list box loses the input focus.

Definition at line 484 of file treeview.h.

#define TVN_SELCHANGE 1

Notifies the change of selection.

Definition at line 460 of file treeview.h.

#define TVN_SETFOCUS 4

Indicates gain of input focus.

A TreeView control sends an TVN_SETFOCUS notification message to its parent window when the list box gains the input focus.

Definition at line 475 of file treeview.h.

#define TVN_UNFOLDED 10

Indicates a sub-tree has unfolded.

Note:
This is an extended notification, the control calls NotifyParentEx function to nofity the parent, and passes the handle to the unfolded item through add_data argument of NotifyParentEx function. You should define and set Notificaton Callback Procedure for the control in order to get the handle to the unfolded item.
See also:
SetNotificationCallback, NotifyParentEx

Definition at line 524 of file treeview.h.

Generated on Fri Dec 17 13:49:47 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: TreeView control

TreeView control
[Standard controls]

Modules

  • Styles of treeview control
  • Messages of treeview control
  • Notification codes of treeview control

Data Structures

  • struct _TVITEMINFO

Defines

  • #define CTRL_TREEVIEW ("TreeView")
    The class name of treeview control.

Typedefs

  • typedef TVITEMINFO * PTVITEMINFO
    Data type of the pointer to a TVITEMINFO.

Detailed Description

Note:
You can pass the root item information through dwAddData argument of CreateWindowEx function.
 HICON folded, unfolded;
 TVITEMINFO tvii = {"/proc", 0, folded, unfolded};

 CreateWindowEx (CTRL_TREEVIEW, ..., (DWORD)&tvii);

Define Documentation

#define CTRL_TREEVIEW ("TreeView")

The class name of treeview control.

Definition at line 62 of file treeview.h.

Typedef Documentation

typedef TVITEMINFO * PTVITEMINFO

Data type of the pointer to a TVITEMINFO.

Definition at line 102 of file treeview.h.

Generated on Fri Dec 17 13:49:47 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _TVITEMINFO Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_TVITEMINFO Struct Reference
[TreeView control]

#include <treeview.h>

Data Fields

  • char * text
  • DWORD dwFlags
  • HICON hIconFold
  • HICON hIconUnfold
  • DWORD dwAddData

Detailed Description

TreeView item info structure

Definition at line 70 of file treeview.h.

Field Documentation

char* text

Text of the item

Definition at line 73 of file treeview.h.

DWORD dwFlags

State flags of the item, can be OR'ed by the following values:

  • TVIF_ROOT
    The item is a root item.
  • TVIF_SELECTED
    The item is a selected item.
  • TVIF_FOLD
    The item is folded.

When adding an item to the TreeView control, only TVIF_FOLD flag is valid.

Definition at line 87 of file treeview.h.

HICON hIconFold

Handle to the icon of the folded item.

Definition at line 90 of file treeview.h.

HICON hIconUnfold

Handle to the icon of the unfolded item.

Definition at line 92 of file treeview.h.

DWORD dwAddData

Additional data associated with the item.

Definition at line 95 of file treeview.h.

The documentation for this struct was generated from the following file:
  • treeview.h
Generated on Fri Dec 17 13:49:52 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Mouse event messages

Mouse event messages
[Messages]

Defines

  • #define MSG_LBUTTONDOWN 0x0001
    Left mouse button down message.
  • #define MSG_LBUTTONUP 0x0002
    Left mouse button up message.
  • #define MSG_LBUTTONDBLCLK 0x0003
    Left mouse button double clicked message.
  • #define MSG_MOUSEMOVE 0x0004
    The mouse moved message.
  • #define MSG_RBUTTONDOWN 0x0005
    Right mouse button down message.
  • #define MSG_RBUTTONUP 0x0006
    Right mouse button up message.
  • #define MSG_RBUTTONDBLCLK 0x0007
    Right mouse button double clicked message.
  • #define MSG_NCLBUTTONDOWN 0x0008
    Left mouse button down message in the non-client area.
  • #define MSG_NCLBUTTONUP 0x0009
    Left mouse button up message in the non-client area.
  • #define MSG_NCLBUTTONDBLCLK 0x000A
    Left mouse button double clicked in the non-client area.
  • #define MSG_NCMOUSEMOVE 0x000B
    Mouse moves in the non-client area.
  • #define MSG_NCRBUTTONDOWN 0x000C
    Right mouse button down message in the non-client area.
  • #define MSG_NCRBUTTONUP 0x000D
    Right mouse button up message in the non-client area.
  • #define MSG_NCRBUTTONDBLCLK 0x000E
    Right mouse button double clicked in the non-client area.

Define Documentation

#define MSG_LBUTTONDBLCLK 0x0003

Left mouse button double clicked message.

This message is posted to the window when the user double clicks the left button of the mouse in the client area of the window.

 MSG_LBUTTONDBLCLK
 DWORD key_flags = (DWORD)wParam;
 int x_pos = LOSWORD (lParam);
 int y_pos = HISWORD (lParam);

Parameters:
key_flags | The shift key status when this message occurred.
x_pos,y_pos | The position of the mouse in client coordinates.
See also:
MSG_RBUTTONDBLCLK, Macros for key codes and shift status

Definition at line 120 of file window.h.

#define MSG_LBUTTONDOWN 0x0001

Left mouse button down message.

This message is posted to the window when the user presses down the left button of the mouse in the client area of the window.

 MSG_LBUTTONDOWN
 DWORD key_flags = (DWORD)wParam;
 int x_pos = LOSWORD (lParam);
 int y_pos = HISWORD (lParam);

Parameters:
key_flags | The shift key status when this message occurred.
x_pos,y_pos | The position of the mouse in client coordinates.
See also:
MSG_LBUTTONUP, Macros for key codes and shift status
Example:
/*
 * This example trys to handle the event when the user presses
 * left button and right button of the mouse at the same time.
 */
int MyWinProc (HWND hWnd, int message, WPARAM wParam, LPARAM lParam)
{
    switch (message) {
        case MSG_LBUTTONDOWN:
            if (wParam & KS_RIGHTBUTTON) {
                // Left button and right button both are pressed.
                break;
            }
            break;

        case MSG_RBUTTONDOWN:
            if (wParam & KS_LEFTBUTTON) {
                // Left button and right button both are pressed.
                break;
            }
            break;

        case MSG_MOUSEMOVE:
            if (wParam & KS_CTRL) {
                // User moves the mouse as the <Ctrl> key is down.
                break;
            }
            break;

        ...
    }

    return DefaultMainWinProc (hWnd, message, wParam, lParam);
}

Definition at line 78 of file window.h.

#define MSG_LBUTTONUP 0x0002

Left mouse button up message.

This message is posted to the window when the user releases up the left button of the mouse in the client area of the window.

 MSG_LBUTTONUP
 DWORD key_flags = (DWORD)wParam;
 int x_pos = LOSWORD (lParam);
 int y_pos = HISWORD (lParam);

Parameters:
key_flags | The shift key status when this message occurred.
x_pos,y_pos | The position of the mouse in client coordinates.
See also:
MSG_LBUTTONDOWN, Macros for key codes and shift status

Definition at line 99 of file window.h.

#define MSG_MOUSEMOVE 0x0004

The mouse moved message.

This message is posted to the window when the user moves the mouse in the client area of the window.

 MSG_MOUSEMOVE
 DWORD key_flags = (DWORD)wParam;
 int x_pos = LOSWORD (lParam);
 int y_pos = HISWORD (lParam);

Parameters:
key_flags | The shift key status when this message occurred.
x_pos,y_pos | The position of the mouse in client coordinates.
See also:
Macros for key codes and shift status

Definition at line 141 of file window.h.

#define MSG_NCLBUTTONDBLCLK 0x000A

Left mouse button double clicked in the non-client area.

This message is posted to the window when the user double clicks the left button of the mouse in the non-client area of the window.

 MSG_NCLBUTTONDBLCLK
 int hit_code = (int)wParam;
 int x_pos = LOSWORD (lParam);
 int y_pos = HISWORD (lParam);

Parameters:
hit_code | The hit test code which tells the area of the mouse.
x_pos,y_pos | The position of the mouse in window coordinates.
See also:
MSG_NCRBUTTONDBLCLK, MSG_NCHITTEST

Definition at line 272 of file window.h.

#define MSG_NCLBUTTONDOWN 0x0008

Left mouse button down message in the non-client area.

This message is posted to the window when the user presses down the left button of the mouse in the non-client area of the window.

 MSG_NCLBUTTONDOWN
 int hit_code = (int)wParam;
 int x_pos = LOSWORD (lParam);
 int y_pos = HISWORD (lParam);

Parameters:
hit_code | The hit test code which tells the area of the mouse.
x_pos,y_pos | The position of the mouse in window coordinates.
See also:
MSG_NCLBUTTONUP, MSG_NCHITTEST

Definition at line 230 of file window.h.

#define MSG_NCLBUTTONUP 0x0009

Left mouse button up message in the non-client area.

This message is posted to the window when the user releases up the left button of the mouse in the non-client area of the window.

 MSG_NCLBUTTONUP
 int hit_code = (int)wParam;
 int x_pos = LOSWORD (lParam);
 int y_pos = HISWORD (lParam);

Parameters:
hit_code | The hit test code which tells the area of the mouse.
x_pos,y_pos | The position of the mouse in window coordinates.
See also:
MSG_NCLBUTTONDOWN, MSG_NCHITTEST

Definition at line 251 of file window.h.

#define MSG_NCMOUSEMOVE 0x000B

Mouse moves in the non-client area.

This message is posted to the window when the user moves the mouse in the non-client area of the window.

 MSG_NCMOUSEMOVE
 int hit_code = (int)wParam;
 int x_pos = LOSWORD (lParam);
 int y_pos = HISWORD (lParam);

Parameters:
hit_code | The hit test code which tells the area of the mouse.
x_pos,y_pos | The position of the mouse in window coordinates.
See also:
MSG_NCHITTEST

Definition at line 293 of file window.h.

#define MSG_NCRBUTTONDBLCLK 0x000E

Right mouse button double clicked in the non-client area.

This message is posted to the window when the user double clicks the right button of the mouse in the non-client area of the window.

 MSG_NCRBUTTONDBLCLK
 int hit_code = (int)wParam;
 int x_pos = LOSWORD (lParam);
 int y_pos = HISWORD (lParam);

Parameters:
hit_code | The hit test code which tells the area of the mouse.
x_pos,y_pos | The position of the mouse in window coordinates.
See also:
MSG_NCLBUTTONDBLCLK, MSG_NCHITTEST

Definition at line 356 of file window.h.

#define MSG_NCRBUTTONDOWN 0x000C

Right mouse button down message in the non-client area.

This message is posted to the window when the user presses down the right button of the mouse in the non-client area of the window.

 MSG_NCRBUTTONDOWN
 int hit_code = (int)wParam;
 int x_pos = LOSWORD (lParam);
 int y_pos = HISWORD (lParam);

Parameters:
hit_code | The hit test code which tells the area of the mouse.
x_pos,y_pos | The position of the mouse in window coordinates.
See also:
MSG_NCRBUTTONUP, MSG_NCHITTEST

Definition at line 314 of file window.h.

#define MSG_NCRBUTTONUP 0x000D

Right mouse button up message in the non-client area.

This message is posted to the window when the user releases up the right button of the mouse in the non-client area of the window.

 MSG_NCRBUTTONUP
 int hit_code = (int)wParam;
 int x_pos = LOSWORD (lParam);
 int y_pos = HISWORD (lParam);

Parameters:
hit_code | The hit test code which tells the area of the mouse.
x_pos,y_pos | The position of the mouse in window coordinates.
See also:
MSG_NCRBUTTONDOWN, MSG_NCHITTEST

Definition at line 335 of file window.h.

#define MSG_RBUTTONDBLCLK 0x0007

Right mouse button double clicked message.

This message is posted to the window when the user double clicks the right button of the mouse in the client area of the window.

 MSG_RBUTTONDBLCLK
 DWORD key_flags = (DWORD)wParam;
 int x_pos = LOSWORD (lParam);
 int y_pos = HISWORD (lParam);

Parameters:
key_flags | The shift key status when this message occurred.
x_pos,y_pos | The position of the mouse in client coordinates.
See also:
MSG_LBUTTONDBLCLK, Macros for key codes and shift status

Definition at line 207 of file window.h.

#define MSG_RBUTTONDOWN 0x0005

Right mouse button down message.

This message is posted to the window when the user presses down the right button of the mouse in the client area of the window.

 MSG_RBUTTONDOWN
 DWORD key_flags = (DWORD)wParam;
 int x_pos = LOSWORD (lParam);
 int y_pos = HISWORD (lParam);

Parameters:
key_flags | The shift key status when this message occurred.
x_pos,y_pos | The position of the mouse in client coordinates.
See also:
MSG_RBUTTONUP, Macros for key codes and shift status
Example:
/*
 * This example trys to handle the event when the user presses
 * left button and right button of the mouse at the same time.
 */
int MyWinProc (HWND hWnd, int message, WPARAM wParam, LPARAM lParam)
{
    switch (message) {
        case MSG_LBUTTONDOWN:
            if (wParam & KS_RIGHTBUTTON) {
                // Left button and right button both are pressed.
                break;
            }
            break;

        case MSG_RBUTTONDOWN:
            if (wParam & KS_LEFTBUTTON) {
                // Left button and right button both are pressed.
                break;
            }
            break;

        case MSG_MOUSEMOVE:
            if (wParam & KS_CTRL) {
                // User moves the mouse as the <Ctrl> key is down.
                break;
            }
            break;

        ...
    }

    return DefaultMainWinProc (hWnd, message, wParam, lParam);
}

Definition at line 165 of file window.h.

#define MSG_RBUTTONUP 0x0006

Right mouse button up message.

This message is posted to the window when the user releases up the right button of the mouse in the client area of the window.

 MSG_RBUTTONUP
 DWORD key_flags = (DWORD)wParam;
 int x_pos = LOSWORD (lParam);
 int y_pos = HISWORD (lParam);

Parameters:
key_flags | The shift key status when this message occurred.
x_pos,y_pos | The position of the mouse in client coordinates.
See also:
MSG_RBUTTONDOWN, Macros for key codes and shift status

Definition at line 186 of file window.h.

Generated on Fri Dec 17 13:49:49 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Key event messages

Key event messages
[Messages]

Defines

  • #define MSG_KEYDOWN 0x0010
    User presses a key down.
  • #define MSG_CHAR 0x0011
    A character translated from MSG_KEYDOWN message.
  • #define MSG_KEYUP 0x0012
    User releases up a key.
  • #define MSG_SYSKEYDOWN 0x0013
    User presses down a key when <Alt> key is down.
  • #define MSG_SYSCHAR 0x0014
    A system character translated from MSG_SYSKEYDOWN message.
  • #define MSG_SYSKEYUP 0x0015
    User releases up a key when <Alt> key is down.
  • #define MSG_KEYSYM 0x0016
    A key symbol translated from MSG_KEYDOWN messages.
  • #define MSG_KEYLONGPRESS 0x0017
    A key is long pressed.
  • #define MSG_KEYALWAYSPRESS 0x0018
    A key is always pressed.
  • #define DEF_LPRESS_TIME 500
    Default long pressed time of a key.
  • #define DEF_APRESS_TIME 1000
    Default always pressed time of a key.
  • #define DEF_INTERVAL_TIME 200
    Default send MSG_KEYLONGPRESS in interval value.
  • #define SetKeyLongPressTime(time)
    User set default long pressed time of a key.
  • #define SetKeyAlwaysPressTime(time)
    User set default always pressed time of a key.
  • #define SetIntervalTime(time)
    User set default interval time that MSG_KEYLONGPRESS is sent.

Define Documentation

#define DEF_APRESS_TIME 1000

Default always pressed time of a key.

See also:
MSG_KEYALWAYSPRESS

Definition at line 555 of file window.h.

#define DEF_INTERVAL_TIME 200

Default send MSG_KEYLONGPRESS in interval value.

Definition at line 561 of file window.h.

#define DEF_LPRESS_TIME 500

Default long pressed time of a key.

See also:
MSG_KEYLONGPRESS

Definition at line 547 of file window.h.

#define MSG_CHAR 0x0011

A character translated from MSG_KEYDOWN message.

This message is translated from a MSG_KEYDOWN message by TranslateMessage and sent to the current active window.

 MSG_CHAR
 int ch = (int)wParam;
 DWORD key_flags = (DWORD)lParam;

Parameters:
ch | The ASCII code of the pressed key.
key_flags | The shift key status when this message occurred.
See also:
MSG_SYSCHAR, TranslateMessage, Macros for key codes and shift status

Definition at line 412 of file window.h.

#define MSG_KEYALWAYSPRESS 0x0018

A key is always pressed.

This message is sent when a key is pressed to exceed user-defined always time value.

Definition at line 539 of file window.h.

#define MSG_KEYDOWN 0x0010

User presses a key down.

This message is posted to the current active window when the user presses a key down.

 MSG_KEYDOWN
 int scancode = (int)wParam;
 DWORD key_flags = (DWORD)lParam;

Parameters:
scancode | The scan code of the pressed key.
key_flags | The shift key status when this message occurred.
See also:
MSG_KEYUP, Macros for key codes and shift status
Example:

/*
 * This example trys to handle the event when the user
 * presses <C> key as the <Ctrl> key is down.
 */
int MyWinProc (HWND hWnd, int message, WPARAM wParam, LPARAM lParam)
{
    switch (message) {
        case MSG_KEYDOWN:
            if (wParam ==SCANCODE_C && lParam & KS_CTRL) {
                // User pressed Ctrl+C.
                break;
            }
            break;
        ...
    }

    return DefaultMainWinProc (hWnd, message, wParam, lParam);
}

Definition at line 392 of file window.h.

#define MSG_KEYLONGPRESS 0x0017

A key is long pressed.

This message is sent when a key is pressed exceed user-defined long time value.

Definition at line 530 of file window.h.

#define MSG_KEYSYM 0x0016

A key symbol translated from MSG_KEYDOWN messages.

This message is translated from a MSG_KEYDOWN message by TranslateMessage and sent to the current active window.

Note that one translation may generate a key symbol made by more than one character, e.g., when using default keymap, DEL key will generate the key symbol "^[[3~".

 MSG_KEYSYM
 int index = HIBYTE (wParam);
 int keysym = LOBYTE (wParam);
 DWORD key_flags = (DWORD)lParam;

Parameters:
index | The index of the key symbol in one translation, zero for a new translation, and the keysym is the first symbol.
keysym | The code of the key symbol.
key_flags | The shift key status when this message occurred.
See also:
MSG_SYSCHAR, TranslateMessage, Macros for key codes and shift status

Definition at line 519 of file window.h.

#define MSG_KEYUP 0x0012

User releases up a key.

This message is posted to the current active window when the user releases up a key.

 MSG_KEYUP
 int scancode = (int)wParam;
 DWORD key_flags = (DWORD)lParam;

Parameters:
scancode | The scan code of the released key.
key_flags | The shift key status when this message occurred.
See also:
MSG_KEYDOWN, Macros for key codes and shift status

Definition at line 432 of file window.h.

#define MSG_SYSCHAR 0x0014

A system character translated from MSG_SYSKEYDOWN message.

This message is translated from a MSG_SYSKEYDOWN message by TranslateMessage and sent to the current active window.

 MSG_SYSCHAR
 int ch = (int)wParam;
 DWORD key_flags = (DWORD)lParam;

Parameters:
ch | The ASCII code of the pressed key.
key_flags | The shift key status when this message occurred.
See also:
MSG_CHAR, TranslateMessage, Macros for key codes and shift status

Definition at line 472 of file window.h.

#define MSG_SYSKEYDOWN 0x0013

User presses down a key when <Alt> key is down.

This message is posted to the current active window when the user presses down a key as <Alt> key is down.

 MSG_SYSKEYDOWN
 int scancode = (int)wParam;
 DWORD key_flags = (DWORD)lParam;

Parameters:
scancode | The scan code of the pressed key.
key_flags | The shift key status when this message occurred.
See also:
MSG_SYSKEYUP, MSG_SYSCHAR, Macros for key codes and shift status

Definition at line 452 of file window.h.

#define MSG_SYSKEYUP 0x0015

User releases up a key when <Alt> key is down.

This message is posted to the current active window when the user releases up a key as <Alt> key is down.

 MSG_SYSKEYUP
 int scancode = (int)wParam;
 DWORD key_flags = (DWORD)lParam;

Parameters:
scancode | The scan code of the released key.
key_flags | The shift key status when this message occurred.
See also:
MSG_SYSKEYDOWN, Macros for key codes and shift status

Definition at line 492 of file window.h.

#define SetIntervalTime ( time )

Value:

do {                                \
        __mg_interval_time = time;      \
    } while (0)
User set default interval time that MSG_KEYLONGPRESS is sent.

Definition at line 589 of file window.h.

#define SetKeyAlwaysPressTime ( time )

Value:

do {                                \
        __mg_key_alwayspress_time = time; \
    } while (0)
User set default always pressed time of a key.

Definition at line 580 of file window.h.

#define SetKeyLongPressTime ( time )

Value:

do {                                \
        __mg_key_longpress_time = time; \
    } while (0)
User set default long pressed time of a key.

Definition at line 571 of file window.h.

Generated on Fri Dec 17 13:49:49 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Notification codes of srollbar control

Notification codes of srollbar control
[User-machine Interaction messages]

Defines

  • #define SB_LINEUP 0x01a
    The SB_LINEUP notification message is sent when the user clicked the up arrow on the bar.
  • #define SB_LINEDOWN 0x02
    The SB_LINEDOWN notification message is sent when the user clicked the down arrow on the bar.
  • #define SB_LINELEFT 0x03
    The SB_LINELEFT notification message is sent when the user clicked the left arrow on the bar.
  • #define SB_LINERIGHT 0x04
    The SB_LINERIGHT notification message is sent when the user clicked the right arrow on the bar.
  • #define SB_PAGEUP 0x05
    The SB_PAGEUP notification message is sent when the user clicked the page up area on the bar.
  • #define SB_PAGEDOWN 0x06
    The SB_PAGEDOWN notification message is sent when the user clicked the page down area on the bar.
  • #define SB_PAGELEFT 0x07
    The SB_PAGELEFT notification message is sent when the user clicked the page left area on the bar.
  • #define SB_PAGERIGHT 0x08
    The SB_PAGERIGHT notification message is sent when the user clicked the page right area on the bar.
  • #define SB_THUMBPOSITION 0x09
    The SB_THUMBPOSITION notification message is sent when the user set a new thumb position.
  • #define SB_THUMBTRACK 0x0A
    The SB_THUMBTRACK notification message is sent when the user is draging and tracking the thumb.
  • #define SB_TOP 0x0B
    The SB_TOP notification message is sent when the user move thumb to minimum position.
  • #define SB_BOTTOM 0x0C
    The SB_BOTTOM notification message is sent when the user move thumb to maximum position.
  • #define SB_ENDSCROLL 0x0D
    The SB_ENDSCROLL notification message is sent when the thumb at the end of bar.

Define Documentation

#define SB_BOTTOM 0x0C

The SB_BOTTOM notification message is sent when the user move thumb to maximum position.

Definition at line 975 of file window.h.

#define SB_ENDSCROLL 0x0D

The SB_ENDSCROLL notification message is sent when the thumb at the end of bar.

Definition at line 982 of file window.h.

#define SB_LINEDOWN 0x02

The SB_LINEDOWN notification message is sent when the user clicked the down arrow on the bar.

Definition at line 905 of file window.h.

#define SB_LINELEFT 0x03

The SB_LINELEFT notification message is sent when the user clicked the left arrow on the bar.

Definition at line 912 of file window.h.

#define SB_LINERIGHT 0x04

The SB_LINERIGHT notification message is sent when the user clicked the right arrow on the bar.

Definition at line 919 of file window.h.

#define SB_LINEUP 0x01a

The SB_LINEUP notification message is sent when the user clicked the up arrow on the bar.

Definition at line 898 of file window.h.

#define SB_PAGEDOWN 0x06

The SB_PAGEDOWN notification message is sent when the user clicked the page down area on the bar.

Definition at line 933 of file window.h.

#define SB_PAGELEFT 0x07

The SB_PAGELEFT notification message is sent when the user clicked the page left area on the bar.

Definition at line 940 of file window.h.

#define SB_PAGERIGHT 0x08

The SB_PAGERIGHT notification message is sent when the user clicked the page right area on the bar.

Definition at line 947 of file window.h.

#define SB_PAGEUP 0x05

The SB_PAGEUP notification message is sent when the user clicked the page up area on the bar.

Definition at line 926 of file window.h.

#define SB_THUMBPOSITION 0x09

The SB_THUMBPOSITION notification message is sent when the user set a new thumb position.

Definition at line 954 of file window.h.

#define SB_THUMBTRACK 0x0A

The SB_THUMBTRACK notification message is sent when the user is draging and tracking the thumb.

Definition at line 961 of file window.h.

#define SB_TOP 0x0B

The SB_TOP notification message is sent when the user move thumb to minimum position.

Definition at line 968 of file window.h.

Generated on Fri Dec 17 13:49:49 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: User-machine Interaction messages

User-machine Interaction messages
[Messages]

Modules

  • Notification codes of srollbar control

Defines

  • #define MSG_SETCURSOR 0x0020
    Sets cursor shape in the client area.
  • #define MSG_NCHITTEST 0x0021
    Hit test in non-client area. This is an async message.
  • #define MSG_HITTEST MSG_NCHITTEST
    Hit test in non-client area.
  • #define MSG_CHANGESIZE 0x0022
    Change window size.
  • #define MSG_QUERYCLIENTAREA 0x0024
    Query client area.
  • #define MSG_SIZECHANGING 0x0025
    Indicates the size of the window is being changed.
  • #define MSG_SIZECHANGED 0x0026
    Indicates the size of the window has been changed.
  • #define MSG_CSIZECHANGED 0x0027
    Indicates the size of the client area of the window has been changed.
  • #define MSG_SETFOCUS 0x0030
    Indicates that the window has gained the input focus.
  • #define MSG_KILLFOCUS 0x0031
    Indicates that the window has lost the input focus.
  • #define MSG_MOUSEACTIVE 0x0032
    Indicates that the window has gained the input focus because the user clicked the window.
  • #define MSG_ACTIVE 0x0033
    Indicates that the window has gained the input focus because the user clicked the window.
  • #define MSG_CHILDHIDDEN 0x0034
    Hide child window.
  • #define MSG_ACTIVEMENU 0x0040
    Indicates that the user activates the menu bar and tracks it.
  • #define MSG_DEACTIVEMENU 0x0041
    Indicates the end of the tracking of a menu bar or a popup menu.
  • #define MSG_HSCROLL 0x0042
    Indicates that the user has clicked the horizontal scroll bar.
  • #define MSG_VSCROLL 0x0043
    Indicates that the user has clicked the vertical scroll bar.
  • #define MSG_NCSETCURSOR 0x0044
    Sets cursor shape in the non-client area.
  • #define MSG_MOUSEMOVEIN 0x0050
    Indicates the mouse is moved in/out the area of the window.
  • #define MSG_WINDOWDROPPED 0x0051
    Indicates that user dropped window. server to client; (wParam, lParam): result rectangle.

Define Documentation

#define MSG_ACTIVE 0x0033

Indicates that the window has gained the input focus because the user clicked the window.

This message is sent to the window procedure after the user clicked the window and it has gained the input focus.

Definition at line 830 of file window.h.

#define MSG_ACTIVEMENU 0x0040

Indicates that the user activates the menu bar and tracks it.

This message is sent to the window procedure when the user activates the menu bar and tracks it.

If you want to change the states of menu items in the submenu before displaying it, you can handle this message.

 MSG_ACTIVEMENU
 int pos = (int)wParam;
 HMENU submenu = (HMENU)lParam;

Parameters:
pos | The position of the activated submenu. The position value of the first submenu is 0.
submenu | The handle to the activated submenu.
Example:

/*
 * This handler checks the specified menu items to contain
 * a radio bitmap by calling CheckMenuRadioItem function,
 * if the submenu at position 2 has been activated.
 */
        case MSG_ACTIVEMENU:
            if (wParam == 2) {
                CheckMenuRadioItem ((HMENU)lParam,
                    IDM_40X15, IDM_CUSTOMIZE,
                    pConInfo->termType, MF_BYCOMMAND);
                CheckMenuRadioItem ((HMENU)lParam,
                    IDM_DEFAULT, IDM_BIG5,
                    pConInfo->termCharset, MF_BYCOMMAND);
            }
        break;

Definition at line 866 of file window.h.

#define MSG_CHANGESIZE 0x0022

Change window size.

Definition at line 710 of file window.h.

#define MSG_CHILDHIDDEN 0x0034

Hide child window.

Definition at line 836 of file window.h.

#define MSG_CSIZECHANGED 0x0027

Indicates the size of the client area of the window has been changed.

This message is sent as a notification to the window when the size of the client area has been changed.

 MSG_CSIZECHANGED
 int client_width = (int)wParam;
 int client_height = (int)lParam;

Parameters:
client_width | The width of the client area.
client_height | The height of the client area.

Definition at line 786 of file window.h.

#define MSG_DEACTIVEMENU 0x0041

Indicates the end of the tracking of a menu bar or a popup menu.

This message is sent to the window procedure when the user has closed the tracking menu bar or popup menu.

 MSG_DEACTIVEMENU
 HMENU menubar = (HMENU)wParam;
 HMENU submenu = (HMENU)lParam;

Parameters:
menubar | The handle to the menu bar. It will be zero when the deactivated menu is a popup menu.
submenu | The handle to the submenu.

Definition at line 885 of file window.h.

#define MSG_HITTEST MSG_NCHITTEST

Hit test in non-client area.

See also:
MSG_NCHITTEST

Definition at line 704 of file window.h.

#define MSG_HSCROLL 0x0042

Indicates that the user has clicked the horizontal scroll bar.

This message is sent to the window procedure when the user has clicked the horizontal scroll bar and changed the position of the thumb.

 MSG_HSCROLL
 int hs_nc = (int)wParam;

Parameters:
hs_nc The scrolling code, can be one of the following values:
  • SB_LINELEFT
    The user clicked the left arrow on the bar.
  • SB_LINERIGHT
    The user clicked the right arrow on the bar.
  • SB_PAGELEFT
    The user clicked the left page area on the bar.
  • SB_PAGERIGHT
    The user clicked the right page area on the bar.
  • SB_THUMBPOSITION
    The user set a new thumb position.
  • SB_THUMBTRACK
    The user is draging and tracking the thumb.
  • SB_ENDSCROLL
    The end of scrolling.

Definition at line 1014 of file window.h.

#define MSG_KILLFOCUS 0x0031

Indicates that the window has lost the input focus.

Parameters:
lparam The parameter passed into used for pass killfocus msg to child control if lparam > 0.
This message is sent to the window procedure after the window losts the input focus.

Definition at line 810 of file window.h.

#define MSG_MOUSEACTIVE 0x0032

Indicates that the window has gained the input focus because the user clicked the window.

This message is sent to the window procedure after the user clicked the window and it has gained the input focus.

Definition at line 820 of file window.h.

#define MSG_MOUSEMOVEIN 0x0050

Indicates the mouse is moved in/out the area of the window.

This message is posted to the window when the user moves the mouse in/out the area of the window.

 MSG_MOUSEMOVEIN
 BOOL in_out = (BOOL)wParam;

Parameters:
in_out Indicates whether the mouse has been moved in the window or out the window.

Definition at line 1075 of file window.h.

#define MSG_NCHITTEST 0x0021

Hit test in non-client area. This is an async message.

Definition at line 696 of file window.h.

#define MSG_NCSETCURSOR 0x0044

Sets cursor shape in the non-client area.

This message is posted to the window under the cursor when the user moves the mouse in order to give the chance to change the cursor shape. The default handler set the cursor shape to the default cursor of the window. If you set a new cursor shape, your message handler should return immediately.

See also:
MSG_SETCURSOR

Definition at line 1058 of file window.h.

#define MSG_QUERYCLIENTAREA 0x0024

Query client area.

Definition at line 719 of file window.h.

#define MSG_SETCURSOR 0x0020

Sets cursor shape in the client area.

This message is posted to the window under the cursor when the user moves the mouse in order to give the chance to change the cursor shape. The default handler set the cursor shape to the default cursor of the window. If you set a new cursor shape, your message handler should return immediately.

 MSG_SETCURSOR
 int cx = LOSWORD (lParam);
 int cy = HISWORD (lParam);

Parameters:
cx,cy The client coordinates of the cursor.
Example:

/*
 * The following MSG_SETCURSOR handler set the cursor
 * shape to the arrow cursor when the window is disabled.
 */
        case MSG_SETCURSOR:
            if (GetWindowStyle (hwnd) & WS_DISABLED) {
                SetCursor (GetSystemCursor (IDC_ARROW));
                return 0;
            }
        break;

See also:
MSG_NCSETCURSOR

Definition at line 630 of file window.h.

#define MSG_SETFOCUS 0x0030

Indicates that the window has gained the input focus.

Parameters:
lparam The parameter passed into used for pass setfocus msg to child control if lparam > 0.
This message is sent to the window procedure after the window gains the input focus.

Definition at line 798 of file window.h.

#define MSG_SIZECHANGED 0x0026

Indicates the size of the window has been changed.

This message is sent to the window when the size has been changed. If you want adjust the size of the client area of the window, you should handle this message, change the values of the client area, and return non-zero value to indicate that the client area has been modified.

 MSG_SIZECHANGED
 RECT* rcClient = (RECT*)lParam;

Parameters:
rcClient The pointer to a RECT structure which contains the new client area.
Example:

                case MSG_SIZECHANGED:
                {
                        RECT* rcClient = (RECT*)lParam;
                        rcClient->right = rcClient->left + _WIDTH;
                        rcClient->bottom = rcClient->top + _HEIGHT;
                        return 1;
                }

Definition at line 768 of file window.h.

#define MSG_SIZECHANGING 0x0025

Indicates the size of the window is being changed.

This message is sent to the window when the size is being changed. If you want to control the actual position and size of the window when the size is being changed (this may be caused by MoveWindow or other functions), you should handle this message, and return the actual position and size of the window through the second parameter.

 MSG_SIZECHANGING
 const RECT* rcExpect = (const RECT*)wParam;
 RECT* rcResult = (RECT*)lParam;

Parameters:
rcExpect | The expected size of the window after changing.
rcResult | The actual size of the window after changing.
Example:

/*
 * The handler set the actual size of the window always
 * to be _WIDTH wide and _HEIGHT high.
 */
                case MSG_SIZECHANGING:
                {
                        const RECT* rcExpect = (const RECT*)wParam;
                        RECT* rcResult = (RECT*)lParam;

                        rcResult->left = rcExpect->left;
                        rcResult->top = rcExpect->top;
                        rcResult->right = rcExpect->left + _WIDTH;
                        rcResult->bottom = rcExpect->top + _HEIGHT;
                    return 0;
                }

Definition at line 744 of file window.h.

#define MSG_VSCROLL 0x0043

Indicates that the user has clicked the vertical scroll bar.

This message is sent to the window procedure when the user has clicked the vertical scroll bar and changed the position of the thumb.

 MSG_HSCROLL
 int vs_nc = (int)wParam;

Parameters:
vs_nc The scrolling code, can be one of the following values:
  • SB_LINEUP
    The user clicked the up arrow on the bar.
  • SB_LINEDOWN
    The user clicked the down arrow on the bar.
  • SB_PAGEUP
    The user clicked the up page area on the bar.
  • SB_PAGEDOWN
    The user clicked the down page area on the bar.
  • SB_THUMBPOSITION
    The user set a new thumb position.
  • SB_THUMBTRACK
    The user is draging and tracking the thumb.
  • SB_ENDSCROLL
    The end of scrolling.

Definition at line 1044 of file window.h.

#define MSG_WINDOWDROPPED 0x0051

Indicates that user dropped window. server to client; (wParam, lParam): result rectangle.

Definition at line 1082 of file window.h.

Generated on Fri Dec 17 13:49:49 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Window creation messages

Window creation messages
[Messages]

Defines

  • #define MSG_CREATE 0x0060
    Indicates the window has been created, and gives you a chance to initialize your private objects.
  • #define MSG_NCCREATE 0x0061
    Indicates the window has been created, but has not registered to the system.
  • #define MSG_DESTROY 0x0064
    Indicates the window will be destroyed.
  • #define MSG_CLOSE 0x0066
    Indicates the user has clicked the closing box on the caption.

Define Documentation

#define MSG_CLOSE 0x0066

Indicates the user has clicked the closing box on the caption.

This message is sent to the window when the user has clicked the closing box on the caption of the window.

Definition at line 1184 of file window.h.

#define MSG_CREATE 0x0060

Indicates the window has been created, and gives you a chance to initialize your private objects.

This messages is sent to the window after the window has been created and registered to the system. You can initialize your own objects when you receive this message, and return zero to the system in order to indicates the success of your initialization. If you return non-zero to the system after handled this message, the created window will be destroyed immediately.

 MSG_CREATE for main windows:
 PMAINWINCREATE create_info = (PMAINWINCREATE)lParam;

 MSG_CREATE for controls:
 HWND parent = (HWND)wParam;
 DWORD add_data = (DWORD)lParam;

Parameters:
create_info | The pointer to the MAINWINCREATE structure which is passed to CreateMainWindow function.
parent | The handle to the parent window of the control.
add_data | The first additional data passed to CreateWindowEx function.
See also:
CreateMainWindow, CreateWindowEx, MAINWINCREATE

Definition at line 1123 of file window.h.

#define MSG_DESTROY 0x0064

Indicates the window will be destroyed.

This message is sent to the window when DestroyMainWindow or DestroyWindow is calling. You can destroy your private objects when receiving this message.

If you return non-zero to the system after handle this message, the process of DestroyMainWindow and DestroyWindow will return immediately.

See also:
DestroyMainWindow, DestroyWindow

Definition at line 1172 of file window.h.

#define MSG_NCCREATE 0x0061

Indicates the window has been created, but has not registered to the system.

This message is sent to the window after the window has been created, but not registered the system. Like MSG_CREATE message, you can initialize your own objects when you receive this message, but can not create child windows of the window, and can not get a device context to paint.

If you return non-zero to the system after handled this message, the created window will be destroyed immediately.

 MSG_NCCREATE for main windows:
 PMAINWINCREATE create_info = (PMAINWINCREATE)lParam;

 MSG_NCCREATE for controls:
 DWORD add_data = (DWORD)lParam;

Parameters:
create_info | The pointer to the MAINWINCREATE structure which is passed to CreateMainWindow function.
add_data | The first additional data passed to CreateWindowEx function.
See also:
CreateMainWindow, CreateWindowEx, MAINWINCREATE

Definition at line 1153 of file window.h.

Generated on Fri Dec 17 13:49:49 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Window painting messages

Window painting messages
[Messages]

Defines

  • #define MSG_SHOWWINDOW 0x00A0
    Indicates that the window has been shown or hidden.
  • #define MSG_ERASEBKGND 0x00B0
    Sent to the window to erase the background.
  • #define MSG_PAINT 0x00B1
    Sent to the window if the window contains an invalid region.
  • #define MSG_NCPAINT 0x00B2
    Indicates that paints non-client area.
  • #define MSG_NCACTIVATE 0x00B3
    Indicates that active non-client area of main window.
  • #define MSG_SYNCPAINT 0x00B4
    Indicates that actives and paints main window synchronously.

Define Documentation

#define MSG_ERASEBKGND 0x00B0

Sent to the window to erase the background.

This message is sent to the window if the whole or a part of the background should be erased.

 MSG_ERASEBKGND
 const RECT* inv_rect = (const RECT*)lParam;

Parameters:
inv_rect The pointer to a RECT structure contains the rectangle should be erase. The rectangle is in client coordinates system. If it is NULL, the whole client area should be erased.

Definition at line 1276 of file window.h.

#define MSG_NCACTIVATE 0x00B3

Indicates that active non-client area of main window.

Definition at line 1303 of file window.h.

#define MSG_NCPAINT 0x00B2

Indicates that paints non-client area.

Definition at line 1297 of file window.h.

#define MSG_PAINT 0x00B1

Sent to the window if the window contains an invalid region.

This message is sent to the window if the window contains an invalid region.

 MSG_PAINT
 const CLIPRGN* inv_rgn = (const CLIPRGN*) lParam;

Parameters:
inv_rgn The pointer to the invalid region of the window.

Definition at line 1291 of file window.h.

#define MSG_SHOWWINDOW 0x00A0

Indicates that the window has been shown or hidden.

This message is sent to the window when the window has been shown or hidden (due to the calling of the function ShowWindow).

 MSG_SHOWWINDOW
 int show_cmd = (int)wParam;

Parameters:
show_cmd The command to show or hide, can be one of the following values:
  • SW_SHOW
    Shows the window.
  • SW_HIDE
    Hides the window.
  • SW_SHOWNORMAL
    Shows the window, and if the window is a main window sets it to be the topmost main window.
See also:
ShowWindow

Definition at line 1258 of file window.h.

#define MSG_SYNCPAINT 0x00B4

Indicates that actives and paints main window synchronously.

Definition at line 1309 of file window.h.

Generated on Fri Dec 17 13:49:49 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Internal desktop messages

Internal desktop messages
[Messages]

Defines

  • #define MSG_DT_LBUTTONDOWN 0x00E1
    Left mouse button down message on the desktop.
  • #define MSG_DT_LBUTTONUP 0x00E2
    Left mouse button up message on the desktop.
  • #define MSG_DT_LBUTTONDBLCLK 0x00E3
    Left mouse button double clicked message on the desktop.
  • #define MSG_DT_MOUSEMOVE 0x00E4
    The mouse moved message on the desktop.
  • #define MSG_DT_RBUTTONDOWN 0x00E5
    Right mouse button down message on the desktop.
  • #define MSG_DT_RBUTTONUP 0x00E6
    Right mouse button up message on the desktop.
  • #define MSG_DT_RBUTTONDBLCLK 0x00E7
    Right mouse button double clicked message on the desktop.
  • #define MSG_DT_KEYDOWN 0x00E8
    User presses a key down on the desktop.
  • #define MSG_DT_KEYUP 0x00EA
    User releases up a key on the desktop.

Define Documentation

#define MSG_DT_KEYDOWN 0x00E8

User presses a key down on the desktop.

This message is posted to the desktop window when the user presses a key down.

 MSG_DT_KEYDOWN
 int scancode = (int)wParam;

Parameters:
scancode The scan code of the pressed key.
See also:
MSG_DT_KEYUP

Definition at line 1486 of file window.h.

#define MSG_DT_KEYUP 0x00EA

User releases up a key on the desktop.

This message is posted to the desktop window when the user releases up a key.

 MSG_DT_KEYUP
 int scancode = (int)wParam;

Parameters:
scancode The scan code of the released key.
See also:
MSG_DT_KEYDOWN

Definition at line 1504 of file window.h.

#define MSG_DT_LBUTTONDBLCLK 0x00E3

Left mouse button double clicked message on the desktop.

This message is posted to the desktop window when the user double clicks the left button of the mouse in the area of the desktop window.

 MSG_DT_LBUTTONDBLCLK
 int x_pos = LOSWORD (lParam);
 int y_pos = HISWORD (lParam);

Parameters:
x_pos,y_pos The position of the mouse in client coordinates.
See also:
MSG_RBUTTONDBLCLK

Definition at line 1388 of file window.h.

#define MSG_DT_LBUTTONDOWN 0x00E1

Left mouse button down message on the desktop.

This message is posted to the desktop window when the user presses down the left button of the mouse in the area of the desktop window.

 MSG_DT_LBUTTONDOWN
 int x_pos = LOSWORD (lParam);
 int y_pos = HISWORD (lParam);

Parameters:
x_pos,y_pos The position of the mouse in desktop coordinates.
See also:
MSG_DT_LBUTTONUP, MSG_LBUTTONDOWN

Definition at line 1350 of file window.h.

#define MSG_DT_LBUTTONUP 0x00E2

Left mouse button up message on the desktop.

This message is posted to the desktop window when the user releases up the left button of the mouse in the area of the desktop window.

 MSG_DT_LBUTTONUP
 int x_pos = LOSWORD (lParam);
 int y_pos = HISWORD (lParam);

Parameters:
x_pos,y_pos The position of the mouse in desktop coordinates.
See also:
MSG_DT_LBUTTONDOWN, MSG_LBUTTONUP

Definition at line 1369 of file window.h.

#define MSG_DT_MOUSEMOVE 0x00E4

The mouse moved message on the desktop.

This message is posted to the desktop window when the user moves the mouse in the area of the desktop window.

 MSG_DT_MOUSEMOVE
 int x_pos = LOSWORD (lParam);
 int y_pos = HISWORD (lParam);

Parameters:
x_pos,y_pos The position of the mouse in desktop coordinates.
See also:
MSG_MOUSEMOVE

Definition at line 1407 of file window.h.

#define MSG_DT_RBUTTONDBLCLK 0x00E7

Right mouse button double clicked message on the desktop.

This message is posted to the desktop window when the user double clicks the right button of the mouse in the area of the desktop window.

 MSG_DT_RBUTTONDBLCLK
 int x_pos = LOSWORD (lParam);
 int y_pos = HISWORD (lParam);

Parameters:
x_pos,y_pos The position of the mouse in desktop coordinates.
See also:
MSG_LBUTTONDBLCLK

Definition at line 1465 of file window.h.

#define MSG_DT_RBUTTONDOWN 0x00E5

Right mouse button down message on the desktop.

This message is posted to the desktop window when the user presses down the right button of the mouse in the area of the desktop window.

 MSG_DT_RBUTTONDOWN
 int x_pos = LOSWORD (lParam);
 int y_pos = HISWORD (lParam);

Parameters:
x_pos,y_pos The position of the mouse in desktop coordinates.
See also:
MSG_DT_RBUTTONUP, MSG_RBUTTONDOWN

Definition at line 1427 of file window.h.

#define MSG_DT_RBUTTONUP 0x00E6

Right mouse button up message on the desktop.

This message is posted to the desktop window when the user releases up the right button of the mouse in the area of the desktop window.

 MSG_DT_RBUTTONUP
 int x_pos = LOSWORD (lParam);
 int y_pos = HISWORD (lParam);

Parameters:
x_pos,y_pos The position of the mouse in desktop coordinates.
See also:
MSG_DT_RBUTTONDOWN, MSG_RBUTTONUP

Definition at line 1446 of file window.h.

Generated on Fri Dec 17 13:49:49 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Dialog and control messages

Dialog and control messages
[Messages]

Defines

  • #define MSG_COMMAND 0x0120
    The command message, indicates a notification message from child window, or the user has selected a menu item.
  • #define MSG_SYSCOMMAND 0x0121
    The system command message.
  • #define MSG_GETDLGCODE 0x0122
    Get dialog code.
  • #define MSG_INITDIALOG 0x0123
    Ready to initialize the controls in a dialog box.
  • #define MSG_DLG_GETDEFID 0x0126
    Get default push button ID first.
  • #define MSG_DLG_SETDEFID 0x0127
    Set default push button ID first.
  • #define MSG_ISDIALOG 0x0128
    Sends to a window to query whether the window is a dialog window.
  • #define MSG_INITPAGE 0x0129
    Ready to initialize the controls in a property page.
  • #define MSG_SHOWPAGE 0x012A
    Indicates the page will be shown or hidden.
  • #define MSG_SHEETCMD 0x012B
    Indicates that a PSM_SHEETCMD message had been sent to the PropertySheet control.
  • #define MSG_INITCONTAINER 0x012C
    This message will be sent to the container window procedure after the container window is created.
  • #define MSG_SVCONTCMD 0x012D
    This message will be sent to the parent of the ScrollView control when the container of the ScrollView control reveived a MSG_COMMAND message.
  • #define MSG_FREEZECTRL 0x012E
    You can send this message to freeze or thaw the paint action of the control.
  • #define MSG_FONTCHANGING 0x0130
    Indicates the user is trying to change the font of the window.
  • #define MSG_FONTCHANGED 0x0131
    Indicates the window font has been changed.
  • #define MSG_GETTEXTLENGTH 0x0132
    Sent to the control to get the length of the text.
  • #define MSG_GETTEXT 0x0133
    Sent to the control to get the text.
  • #define MSG_SETTEXT 0x0134
    Sent to the control to set the text.
  • #define MSG_ENABLE 0x0135
    Indicates the window is disabled/enabled.

Define Documentation

#define MSG_COMMAND 0x0120

The command message, indicates a notification message from child window, or the user has selected a menu item.

This message sent to the window when the user has selected a menu item, or a child window has sent a notification message to the parent.

 MSG_COMMAND
 int id = LOWORD(wParam);
 int code = HIWORD(wParam);
 HWND hwnd = (HWND)lParam;

Parameters:
id | The identifier of the menu item or the child window.
code | The notification code.
hwnd | The handle to the control.
See also:
NotifyParentEx

Definition at line 1601 of file window.h.

#define MSG_DLG_GETDEFID 0x0126

Get default push button ID first.

Definition at line 1651 of file window.h.

#define MSG_DLG_SETDEFID 0x0127

Set default push button ID first.

Definition at line 1657 of file window.h.

#define MSG_ENABLE 0x0135

Indicates the window is disabled/enabled.

This message is sent to the window if the window has been disabled or enabled.

 MSG_ENABLE
 BOOL enabled = (BOOL)wParam;

Parameters:
enabled Indicates whether the window was disabled or enabled.

Definition at line 1910 of file window.h.

#define MSG_FONTCHANGED 0x0131

Indicates the window font has been changed.

This message is sent to the window after the window font has changed. Some window should be repainted to reflect the new window font.

Definition at line 1830 of file window.h.

#define MSG_FONTCHANGING 0x0130

Indicates the user is trying to change the font of the window.

This message is sent to the window when the user is trying to change the font of the window by calling SetWindowFont. If you return non-zero after handling this message, SetWindowFont will return immediately, i.e., the default window font will not change.

 MSG_FONTCHANGING
 PLOGFONT log_font = (PLOGFONT)lParam;

Parameters:
log_font The pointer to the new window logical font.
See also:
SetWindowFont

Definition at line 1820 of file window.h.

#define MSG_FREEZECTRL 0x012E

You can send this message to freeze or thaw the paint action of the control.

 MSG_FREEZECTRL
 BOOL bFrozen;

 wParam = bFrozen
 lParam = 0;

Note:
Note that implemented only in scrollview and listview.
Parameters:
bFrozen to freeze or to thaw.

Definition at line 1800 of file window.h.

#define MSG_GETDLGCODE 0x0122

Get dialog code.

Definition at line 1613 of file window.h.

#define MSG_GETTEXT 0x0133

Sent to the control to get the text.

This message is sent to the control when you calling GetWindowText function to get the text.

 MSG_GETTEXT
 int max_len;
 char* text_buf;

 wParam = (WPARAM)max_len;
 lParam = (LPARAM)text_buf;

Parameters:
max_len | The maximal number of characters can be copied to the buffer.
text_buf | The pointer to a buffer receives the text.
Returns:
The length of the window text string.
See also:
GetWindowText

Definition at line 1873 of file window.h.

#define MSG_GETTEXTLENGTH 0x0132

Sent to the control to get the length of the text.

This message is sent to the control when you calling GetWindowTextLength function to get the lenght of the text.

 MSG_GETTEXTLENGTH
 wParam = 0;
 lParam = 0;

Returns:
The length of the text.
See also:
GetWindowTextLength

Definition at line 1849 of file window.h.

#define MSG_INITCONTAINER 0x012C

This message will be sent to the container window procedure after the container window is created.

This message is sent to the container in order that you can initialize the controls in the container.

 MSG_INITCONTAINER
 DWORD add_data = (DWORD)lParam;

Parameters:
add_data The additional data in CONTAINERINFO structure passed through the argument of dwAddData when creating the ScrollView control by calling CreateWindowEx.
See also:
ScrollView control, CONTAINERINFO

Definition at line 1750 of file window.h.

#define MSG_INITDIALOG 0x0123

Ready to initialize the controls in a dialog box.

This message is sent to the dialog in order that you can initialize the controls in the dialog box.

 MSG_INITDIALOG
 HWND focus_hwnd = (HWND)wParam;
 LPARAM lparam = (LPARAM)lParam;

Parameters:
focus_hwnd | The handle to the control which will gain the input focus.
lparam | The parameter passed into the dialog box through DialogBoxIndirectParam function.
Returns:
Returns non-zero value to set the input focus to focus_hwnd, else do not set focus.
See also:
DialogBoxIndirectParam
Example:

static int DepInfoBoxProc (HWND hDlg, int message, WPARAM wParam, LPARAM lParam)
{
    struct _DepInfo *info;

    switch(message) {
    case MSG_INITDIALOG:
    {
        /*
         * Get the lParam passed to this dialog box, and assign it
         * to the second private additional data assoiciated
         * with the dialog box.
         */
        info = (struct _DepInfo*)lParam;
        SetWindowAdditionalData2 (hDlg, (DWORD)lParam);
        break;
    }

    case MSG_COMMAND:
    {
        /*
         * Get the parameter from the second private data assoiciated
         * with the dialog box.
         */
        info = (struct _DepInfo*) GetWindowAdditionalData2 (hDlg);

        switch(wParam) {
        case IDOK:
            /* Use the data in the parameter. */
            ......

        case IDCANCEL:
            EndDialog(hDlg,wParam);
            break;
        }
    }
    }

    return DefaultDialogProc (hDlg, message, wParam, lParam);
}

Definition at line 1641 of file window.h.

#define MSG_INITPAGE 0x0129

Ready to initialize the controls in a property page.

This message is sent to the page in order that you can initialize the controls in the page.

 MSG_INITPAGE
 DWORD add_data = (DWORD)lParam;

Parameters:
add_data The additional data in DLGTEMPLATE structure passed through PSM_ADDPAGE message.
See also:
PropertySheet control

Definition at line 1686 of file window.h.

#define MSG_ISDIALOG 0x0128

Sends to a window to query whether the window is a dialog window.

Note:
This is a asynchronical message.

Definition at line 1667 of file window.h.

#define MSG_SETTEXT 0x0134

Sent to the control to set the text.

This message is sent to the control when you calling SetWindowText function to set the text.

 MSG_GETTEXT
 char* text_buf;

 wParam = 0;
 lParam = (LPARAM)text_buf;

Parameters:
text_buf The pointer to a buffer contains the text.
Returns:
The return value is equal to zero if the text is set.
See also:
SetWindowText

Definition at line 1895 of file window.h.

#define MSG_SHEETCMD 0x012B

Indicates that a PSM_SHEETCMD message had been sent to the PropertySheet control.

This message is sent to the property page when the property sheet contains the page received the PSM_SHEETCMD message.

 MSG_SHEETCMD
 WPARAM param1 = wParam;
 LPARAM param2 = lParam;

Parameters:
param1 | The wParam of PSM_SHEETCMD message.
param2 | The lParam of PSM_SHEETCMD message.
See also:
PropertySheet control, PSM_SHEETCMD

Definition at line 1729 of file window.h.

#define MSG_SHOWPAGE 0x012A

Indicates the page will be shown or hidden.

This message is sent to the page when the page will be shown or hidden.

 MSG_SHOWPAGE
 HWND focus_hwnd = (HWND)wParam;
 int show_cmd = (int)lParam;

Parameters:
focus_hwnd The handle to the child which will gain the input focus if showing the page.
show_cmd The show command, can be one of the following values:
  • SW_SHOW
    The page will be shown.
  • SW_HIDE
    The page will be hidden.
See also:
PropertySheet control

Definition at line 1708 of file window.h.

#define MSG_SVCONTCMD 0x012D

This message will be sent to the parent of the ScrollView control when the container of the ScrollView control reveived a MSG_COMMAND message.

This message will be sent to the parent of the ScrollView when the container of the ScrollView control reveived a MSG_COMMAND message. Generally, the notification of the child control in the container will be sent via MSG_COMMAND to the container. If you have not defined your own window procedure for the container, this message gives a chance for the parent of the ScrollView control to handle the notifications come from the controls in the container.

Note that you can also define your window procedure for the container, and handle the notification from the child control in this procedure.

 MSG_SVCONTCMD
 WPARAM param1 = wParam;
 WPARAM param2 = lParam;

Parameters:
param1 | The wParam of MSG_COMMAND message.
param2 | The lParam of MSG_COMMAND message.
See also:
ScrollView control, MSG_COMMAND

Definition at line 1780 of file window.h.

#define MSG_SYSCOMMAND 0x0121

The system command message.

Definition at line 1607 of file window.h.

Generated on Fri Dec 17 13:49:49 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: System messages

System messages
[Messages]

Defines

  • #define MSG_IDLE 0x0142
    Indicates the system enters idle loop.
  • #define MSG_TIMER 0x0144
    Indicates a timer has expired.
  • #define MSG_FDEVENT 0x0146
    Indicates an event of registered file descriptor occurred.
  • #define MSG_SRVNOTIFY 0x0147
    Indicates a notification from the server of MiniGUI-Processes.
  • #define MSG_DOESNEEDIME 0x0150
    Sends to a window to query whether the window needs to open IME window.

Define Documentation

#define MSG_DOESNEEDIME 0x0150

Sends to a window to query whether the window needs to open IME window.

The system will send this message when the window gain the input focus to determine whether the window needs to open IME window.

The application should handle this message and return TRUE when the window need IME window. Default window procedure returns FALSE.

Note:
This is an asynchronical message.

Definition at line 2021 of file window.h.

#define MSG_FDEVENT 0x0146

Indicates an event of registered file descriptor occurred.

You can use RegisterListenFD to register a file desciptor to MiniGUI-Processes for listening.

When there is a read/write/except event on the fd, MiniGUI will post a MSG_FDEVENT message with wParam being equal to MAKELONG (fd, type), and the lParam being set to be the context to the target window.

 MSG_FDEVENT
 int fd = LOWORD(wParam);
 int type = HIWORD(wParam);
 void* context = (void*)lParam;

Parameters:
fd | The listened file descriptor.
type | The event type.
context | A context value.
Note:
Only available on MiniGUI-Processes.
See also:
RegisterListenFD

Definition at line 1985 of file window.h.

#define MSG_IDLE 0x0142

Indicates the system enters idle loop.

This message is sent to the all main windows when the system enters idle loop.

Definition at line 1933 of file window.h.

#define MSG_SRVNOTIFY 0x0147

Indicates a notification from the server of MiniGUI-Processes.

This message will be broadcasted to all of the main windows in a client process when the client receives a MSG_SRVNOTIFY message from the server.

The server, i.e. 'mginit' defines the meaning of two parameters of this message.

Note:
Only available on MiniGUI-Processes.

Definition at line 2000 of file window.h.

#define MSG_TIMER 0x0144

Indicates a timer has expired.

This message is sent to the window when a timer expired.

 MSG_TIMER
 int timer_id = (int)wParam;
 DWORD tick_count = (DWORD)lParam;

Parameters:
timer_id | The identifier of the timer has expired.
tick_count | The tick count when the timer had expired.

Definition at line 1952 of file window.h.

Generated on Fri Dec 17 13:49:49 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: User-defined messages

User-defined messages
[Messages]

Defines

  • #define MSG_USER 0x0800
    The first user-defined message.

Define Documentation

#define MSG_USER 0x0800

The first user-defined message.

MiniGUI reserved the range from 0x0800 to 0xEFFF for user-defined messages. MSG_USER is the first user-defined message you can use it by your own.

Definition at line 2125 of file window.h.

Generated on Fri Dec 17 13:49:49 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Window styles

Window styles

Defines

  • #define WS_NONE 0x00000000L
    None style.
  • #define WS_CHILD 0x40000000L
    Indicates the window is a child.
  • #define WS_CAPTION 0x20000000L
    Creates a main window with caption.
  • #define WS_SYSMENU 0x10000000L
    Creates a main window with system menu.
  • #define WS_VISIBLE 0x08000000L
    Creates a window initially visible.
  • #define WS_DISABLED 0x04000000L
    Creates a window initially disabled.
  • #define WS_DLGFRAME 0x00800000L
    The window has a fixed frame, i.e. user can not drag the border of the window.
  • #define WS_BORDER 0x00400000L
    Creates a window with border.
  • #define WS_THICKFRAME 0x00200000L
    Creates a window with thick frame.
  • #define WS_THINFRAME 0x00100000L
    Creates a window with thin frame.
  • #define WS_VSCROLL 0x00080000L
    Creates a window with vertical scroll bar.
  • #define WS_HSCROLL 0x00040000L
    Creates a window with horizontal scroll bar.
  • #define WS_GROUP 0x00020000L
    Indicates the control is the leader of a group.
  • #define WS_TABSTOP 0x00010000L
    Indicates the user can set the input focus to the control by using Tab key.
  • #define WS_EX_CONTROL_MASK 0x0000000FL
    The extended style mask for control usage.
  • #define WS_EX_INTERNAL_MASK 0xF0000000L
    The extended style mask for internal usage.
  • #define WS_EX_NONE 0x00000000L
    No any extended window style.
  • #define WS_EX_TROUNDCNS 0x00000010L
    The window have round corners in top.
  • #define WS_EX_BROUNDCNS 0x00000020L
    The window have round corners at bottom.
  • #define WS_EX_USEPRIVATECDC 0x00000040L
    The window has its own private client device context.
  • #define WS_EX_NOTDRAGGABLE 0x00000080L
    A style controlling whether a main window can be dragged by using mouse.
  • #define WS_EX_USEPARENTFONT 0x00000100L
    The window uses the font of its parent as the default font.
  • #define WS_EX_USEPARENTCURSOR 0x00000200L
    The window uses the cursor of its parent as the default cursor.
  • #define WS_EX_USEPARENTRDR 0x00000400L
    The window use the same window renderer as parent.
  • #define WS_EX_NOPARENTNOTIFY 0x00000800L
    The window will not send any notification to the parent.
  • #define WS_EX_AUTOSECONDARYDC 0x00001000L
    The window creates its own secondary device context automatically.
  • #define WS_EX_TRANSPARENT 0x00002000L
    The window is transparent.
  • #define WS_EX_TOPMOST 0x00004000L
    The main window is a topmost (always on top) window.
  • #define WS_EX_TOOLWINDOW 0x00008000L
    The main window is a tool window, which can not gain the input focus.
  • #define WS_EX_LEFTSCROLLBAR 0x00040000L
    The horizontal scroll bar of the window is located at left.
  • #define WS_EX_RIGHTSCROLLBAR 0x00000000L
    The horizontal scroll bar of the window is located at right (default).
  • #define WS_EX_DLGHIDE 0x00100000L
    The dialog won't show immediately after it is created.
  • #define WS_EX_NOCLOSEBOX 0x00400000L
    The main window has no closing box on its caption.
  • #define WS_EX_CLIPCHILDREN 0x00800000L
    When paint the window, the children areas will be clipped.
  • #define WS_EX_LFRDR_MASK 0x0F000000L
    The style mask for LF renderer internal usage.
  • #define WS_EX_LFRDR_CUSTOM1 0x01000000L
    The user-defined extended style. It's often used to process user-defined hotspot area.
  • #define WS_EX_LFRDR_CUSTOM2 0x02000000L
    The user-defined extended style.
  • #define WS_EX_LFRDR_CUSTOM3 0x04000000L
    The user-defined extended style.
  • #define WS_EX_LFRDR_CUSTOM4 0x08000000L
    The user-defined extended style.

Define Documentation

#define WS_BORDER 0x00400000L

Creates a window with border.

Definition at line 3022 of file window.h.

#define WS_CAPTION 0x20000000L

Creates a main window with caption.

Definition at line 2987 of file window.h.

#define WS_CHILD 0x40000000L

Indicates the window is a child.

Definition at line 2981 of file window.h.

#define WS_DISABLED 0x04000000L

Creates a window initially disabled.

Definition at line 3005 of file window.h.

#define WS_DLGFRAME 0x00800000L

The window has a fixed frame, i.e. user can not drag the border of the window.

Definition at line 3016 of file window.h.

#define WS_EX_AUTOSECONDARYDC 0x00001000L

The window creates its own secondary device context automatically.

See also:
CreateSencondaryDC

Definition at line 3162 of file window.h.

#define WS_EX_BROUNDCNS 0x00000020L

The window have round corners at bottom.

Definition at line 3113 of file window.h.

#define WS_EX_CLIPCHILDREN 0x00800000L

When paint the window, the children areas will be clipped.

Definition at line 3217 of file window.h.

#define WS_EX_CONTROL_MASK 0x0000000FL

The extended style mask for control usage.

Definition at line 3089 of file window.h.

#define WS_EX_DLGHIDE 0x00100000L

The dialog won't show immediately after it is created.

Definition at line 3205 of file window.h.

#define WS_EX_INTERNAL_MASK 0xF0000000L

The extended style mask for internal usage.

Definition at line 3095 of file window.h.

#define WS_EX_LEFTSCROLLBAR 0x00040000L

The horizontal scroll bar of the window is located at left.

Definition at line 3193 of file window.h.

#define WS_EX_LFRDR_CUSTOM1 0x01000000L

The user-defined extended style. It's often used to process user-defined hotspot area.

Definition at line 3230 of file window.h.

#define WS_EX_LFRDR_CUSTOM2 0x02000000L

The user-defined extended style.

See also:
WS_EX_LFRDR_CUSTOM1

Definition at line 3238 of file window.h.

#define WS_EX_LFRDR_CUSTOM3 0x04000000L

The user-defined extended style.

See also:
WS_EX_LFRDR_CUSTOM1

Definition at line 3246 of file window.h.

#define WS_EX_LFRDR_CUSTOM4 0x08000000L

The user-defined extended style.

See also:
WS_EX_LFRDR_CUSTOM1

Definition at line 3254 of file window.h.

#define WS_EX_LFRDR_MASK 0x0F000000L

The style mask for LF renderer internal usage.

Definition at line 3223 of file window.h.

#define WS_EX_NOCLOSEBOX 0x00400000L

The main window has no closing box on its caption.

Definition at line 3211 of file window.h.

#define WS_EX_NONE 0x00000000L

No any extended window style.

Definition at line 3101 of file window.h.

#define WS_EX_NOPARENTNOTIFY 0x00000800L

The window will not send any notification to the parent.

See also:
NotifyParentEx

Definition at line 3154 of file window.h.

#define WS_EX_NOTDRAGGABLE 0x00000080L

A style controlling whether a main window can be dragged by using mouse.

Definition at line 3127 of file window.h.

#define WS_EX_RIGHTSCROLLBAR 0x00000000L

The horizontal scroll bar of the window is located at right (default).

Definition at line 3199 of file window.h.

#define WS_EX_TOOLWINDOW 0x00008000L

The main window is a tool window, which can not gain the input focus.

Definition at line 3181 of file window.h.

#define WS_EX_TOPMOST 0x00004000L

The main window is a topmost (always on top) window.

Definition at line 3175 of file window.h.

#define WS_EX_TRANSPARENT 0x00002000L

The window is transparent.

Note:
This style is only implemented for controls.

Definition at line 3169 of file window.h.

#define WS_EX_TROUNDCNS 0x00000010L

The window have round corners in top.

Definition at line 3107 of file window.h.

#define WS_EX_USEPARENTCURSOR 0x00000200L

The window uses the cursor of its parent as the default cursor.

Definition at line 3140 of file window.h.

#define WS_EX_USEPARENTFONT 0x00000100L

The window uses the font of its parent as the default font.

Definition at line 3134 of file window.h.

#define WS_EX_USEPARENTRDR 0x00000400L

The window use the same window renderer as parent.

Definition at line 3146 of file window.h.

#define WS_EX_USEPRIVATECDC 0x00000040L

The window has its own private client device context.

See also:
CreatePrivateClientDC

Definition at line 3121 of file window.h.

#define WS_GROUP 0x00020000L

Indicates the control is the leader of a group.

Note:
This style is valid only for controls.

Definition at line 3053 of file window.h.

#define WS_HSCROLL 0x00040000L

Creates a window with horizontal scroll bar.

Definition at line 3046 of file window.h.

#define WS_NONE 0x00000000L

None style.

Definition at line 2975 of file window.h.

#define WS_SYSMENU 0x10000000L

Creates a main window with system menu.

Definition at line 2993 of file window.h.

#define WS_TABSTOP 0x00010000L

Indicates the user can set the input focus to the control by using Tab key.

Note:
This style is valid only for controls.

Definition at line 3061 of file window.h.

#define WS_THICKFRAME 0x00200000L

Creates a window with thick frame.

Definition at line 3028 of file window.h.

#define WS_THINFRAME 0x00100000L

Creates a window with thin frame.

Definition at line 3034 of file window.h.

#define WS_VISIBLE 0x08000000L

Creates a window initially visible.

Definition at line 2999 of file window.h.

#define WS_VSCROLL 0x00080000L

Creates a window with vertical scroll bar.

Definition at line 3040 of file window.h.

Generated on Fri Dec 17 13:49:49 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Region operations

Region operations
[GDI functions]

Data Structures

  • struct _CLIPRECT
  • struct _CLIPRGN

Defines

  • #define InitFreeClipRectList(heap, size) InitBlockDataHeap (heap, sizeof (CLIPRECT), size)
    Initializes the private block data heap used to allocate clipping rectangles.
  • #define ClipRectAlloc(heap) BlockDataAlloc (heap)
    Allocates a clipping rectangles from the private block data heap.
  • #define FreeClipRect(heap, cr) BlockDataFree (heap, cr);
    Frees a clipping rectangle which is allocated from the private block data heap.
  • #define DestroyFreeClipRectList(heap) DestroyBlockDataHeap (heap);
    Destroys the private block data heap used to allocate clipping rectangles.
  • #define UnionRectWithRegion AddClipRect
    Is an alias of AddClipRect.
  • #define CopyRegion ClipRgnCopy
    Is an alias of ClipRgnCopy.
  • #define IntersectRegion ClipRgnIntersect
    Is an alias of ClipRgnIntersect.

Typedefs

  • typedef CLIPRGN * PCLIPRGN
    Data type of the pointer to a CLIPRGN.

Functions

  • MG_EXPORT void GUIAPI InitClipRgn (PCLIPRGN pRgn, PBLOCKHEAP pFreeList)
    Initializes a clipping region.
  • MG_EXPORT void GUIAPI EmptyClipRgn (PCLIPRGN pRgn)
    Empties a clipping region.
  • MG_EXPORT PCLIPRGN GUIAPI CreateClipRgn (void)
    Creates a clipping region.
  • MG_EXPORT void GUIAPI DestroyClipRgn (PCLIPRGN pRgn)
    Empties and destroys a clipping region.
  • MG_EXPORT BOOL GUIAPI ClipRgnCopy (PCLIPRGN pDstRgn, const CLIPRGN *pSrcRgn)
    Copies one region to another.
  • MG_EXPORT BOOL GUIAPI ClipRgnIntersect (PCLIPRGN pRstRgn, const CLIPRGN *pRgn1, const CLIPRGN *pRgn2)
    Intersects two region.
  • MG_EXPORT void GUIAPI GetClipRgnBoundRect (PCLIPRGN pRgn, PRECT pRect)
    Gets the bounding rectangle of a region.
  • MG_EXPORT BOOL GUIAPI SetClipRgn (PCLIPRGN pRgn, const RECT *pRect)
    Sets a region to contain only one rect.
  • MG_EXPORT BOOL GUIAPI IsEmptyClipRgn (const CLIPRGN *pRgn)
    Determines whether a region is an empty region.
  • MG_EXPORT BOOL GUIAPI AddClipRect (PCLIPRGN pRgn, const RECT *pRect)
    Unions one rectangle to a region.
  • MG_EXPORT BOOL GUIAPI IntersectClipRect (PCLIPRGN pRgn, const RECT *pRect)
    Intersects a rectangle with a region.
  • MG_EXPORT BOOL GUIAPI SubtractClipRect (PCLIPRGN pRgn, const RECT *pRect)
    Subtracts a rectangle from a region.
  • MG_EXPORT BOOL GUIAPI PtInRegion (PCLIPRGN region, int x, int y)
    Determines whether a point is in a region.
  • MG_EXPORT BOOL GUIAPI RectInRegion (PCLIPRGN region, const RECT *rect)
    Determines whether a rectangle is intersected with a region.
  • MG_EXPORT void GUIAPI OffsetRegionEx (PCLIPRGN region, const RECT *rcClient, const RECT *rcScroll, int x, int y)
    Offsets the region in the specified window's scroll area.
  • MG_EXPORT void GUIAPI OffsetRegion (PCLIPRGN region, int x, int y)
    Offsets the region.
  • MG_EXPORT BOOL GUIAPI UnionRegion (PCLIPRGN dst, const CLIPRGN *src1, const CLIPRGN *src2)
    Unions two regions.
  • MG_EXPORT BOOL GUIAPI SubtractRegion (CLIPRGN *rgnD, const CLIPRGN *rgnM, const CLIPRGN *rgnS)
    Substrcts a region from another.
  • MG_EXPORT BOOL GUIAPI XorRegion (CLIPRGN *dst, const CLIPRGN *src1, const CLIPRGN *src2)
    Does the XOR operation between two regions.
  • MG_EXPORT BOOL GUIAPI InitCircleRegion (PCLIPRGN dst, int x, int y, int r)
    Initializes a region to be an enclosed circle.
  • MG_EXPORT BOOL GUIAPI InitEllipseRegion (PCLIPRGN dst, int x, int y, int rx, int ry)
    Initializes a region to be an enclosed ellipse.
  • MG_EXPORT BOOL GUIAPI InitPolygonRegion (PCLIPRGN dst, const POINT *pts, int vertices)
    Initializes a region to be an enclosed polygon.

Detailed Description

A Region is simply an area, as the name implies, and is implemented as a "y-x-banded" array of rectangles. To explain: Each Region is made up of a certain number of rectangles sorted by y coordinate first, and then by x coordinate.

Furthermore, the rectangles are banded such that every rectangle with a given upper-left y coordinate (y1) will have the same lower-right y coordinate (y2) and vice versa. If a rectangle has scanlines in a band, it will span the entire vertical distance of the band. This means that some areas that could be merged into a taller rectangle will be represented as several shorter rectangles to account for shorter rectangles to its left or right but within its "vertical scope".

An added constraint on the rectangles is that they must cover as much horizontal area as possible. E.g. no two rectangles in a band are allowed to touch.

Whenever possible, bands will be merged together to cover a greater vertical distance (and thus reduce the number of rectangles). Two bands can be merged only if the bottom of one touches the top of the other and they have rectangles in the same places (of the same width, of course). This maintains the y-x-banding that's so nice to have...

Example:

#ifdef _USE_NEWGAL

static BLOCKHEAP my_cliprc_heap;
static BOOL ch_inited = FALSE;

static void GDIDemo_Region (HWND hWnd, HDC hdc)
{
    CLIPRGN my_cliprgn1;
    CLIPRGN my_cliprgn2;

    if (!ch_inited) {
        /* Init the heap used by our region. */
        InitFreeClipRectList (&my_cliprc_heap, 100);
        ch_inited = TRUE;
    }

    InitClipRgn (&my_cliprgn1, &my_cliprc_heap);
    InitClipRgn (&my_cliprgn2, &my_cliprc_heap);

    /* Create one circle region. */
    InitCircleRegion (&my_cliprgn1, 100, 100, 60);
    /* Create one ellipse region. */
    InitEllipseRegion (&my_cliprgn2, 100, 100, 50, 70);

    /* Fill a box to earase the background. */
    SetBrushColor (hdc, PIXEL_blue);
    FillBox (hdc, 0, 0, DEFAULT_WIDTH, 200);

    /* Get the difference between two regions. */
    SubtractRegion (&my_cliprgn1, &my_cliprgn1, &my_cliprgn2);
    /* Select the difference region as the current visible region of DC. */
    SelectClipRegion (hdc, &my_cliprgn1);

    /* Fill a box, but you will only see red color in the different region. */
    SetBrushColor (hdc, PIXEL_red);
    FillBox (hdc, 0, 0, 180, 200);

    /* Do more with XorRegion. */
    InitCircleRegion (&my_cliprgn1, 300, 100, 60);
    OffsetRegion (&my_cliprgn2, 200, 0);

    XorRegion (&my_cliprgn1, &my_cliprgn1, &my_cliprgn2);
    SelectClipRegion (hdc, &my_cliprgn1);

    FillBox (hdc, 200, 0, 180, 200);

    /* Do more with IntersectRegion. */
    InitCircleRegion (&my_cliprgn1, 500, 100, 60);
    OffsetRegion (&my_cliprgn2, 200, 0);

    IntersectRegion (&my_cliprgn1, &my_cliprgn1, &my_cliprgn2);
    SelectClipRegion (hdc, &my_cliprgn1);

    FillBox (hdc, 400, 0, 180, 200);

    /*
     * Empty two clipping region to free the clipping rectangles used
     * by them.
     */
    EmptyClipRgn (&my_cliprgn1);
    EmptyClipRgn (&my_cliprgn2);

    /*
     * You should not forget to destroy the FreeClipRectList in your
     * applications.
     * Here we do not destroy the heap because we will use it in next call.
     *
     * DestroyFreeClipRectList (&my_cliprc_heap);
     * ch_inited = FALSE;
     *
     */
}

#endif /* _USE_NEWGAL */

Define Documentation

#define ClipRectAlloc ( heap ) BlockDataAlloc (heap)

Allocates a clipping rectangles from the private block data heap.

Parameters:
heap The pointer to the initialized BLOCKHEAP structure.
Note:
This macro is defined to call BlockDataAlloc function.
See also:
BlockDataAlloc

Definition at line 639 of file gdi.h.

#define CopyRegion ClipRgnCopy

Is an alias of ClipRgnCopy.

See also:
ClipRgnCopy

Definition at line 992 of file gdi.h.

#define DestroyFreeClipRectList ( heap ) DestroyBlockDataHeap (heap);

Destroys the private block data heap used to allocate clipping rectangles.

Parameters:
heap The pointer to the BLOCKHEAP structure.
Note:
This macro is defined to call DestroyBlockDataHeap function.
See also:
DestroyBlockDataHeap

Definition at line 666 of file gdi.h.

#define FreeClipRect | ( | heap,
 |  | cr | ) | BlockDataFree (heap, cr);

Frees a clipping rectangle which is allocated from the private block data heap.

Parameters:
heap | The pointer to the initialized BLOCKHEAP structure.
cr | The pointer to the clipping rectangle to be freed.
Note:
This macro is defined to call BlockDataFree function.
See also:
BlockDataFree

Definition at line 653 of file gdi.h.

#define InitFreeClipRectList | ( | heap,
 |  | size | ) | InitBlockDataHeap (heap, sizeof (CLIPRECT), size)

Initializes the private block data heap used to allocate clipping rectangles.

Parameters:
heap | The pointer to a BLOCKHEAP structure.
size | The size of the heap.
Note:
This macro is defined to call InitBlockDataHeap function with bd_size set to sizeof(CLIPRECT).
See also:
InitBlockDataHeap

Definition at line 626 of file gdi.h.

#define IntersectRegion ClipRgnIntersect

Is an alias of ClipRgnIntersect.

See also:
ClipRgnIntersect

Definition at line 999 of file gdi.h.

#define UnionRectWithRegion AddClipRect

Is an alias of AddClipRect.

See also:
AddClipRect

Definition at line 985 of file gdi.h.

Typedef Documentation

typedef CLIPRGN * PCLIPRGN

Data type of the pointer to a CLIPRGN.

See also:
CLIPRGN

Definition at line 611 of file gdi.h.

Function Documentation

BOOL GUIAPI AddClipRect | ( | PCLIPRGN | pRgn,
 |  | const RECT * | pRect
 | ) |  |

Unions one rectangle to a region.

This function unions a rectangle to the region pointed to by pRgn.

Parameters:
pRgn | The pointer to the region.
pRect | The pointer to the rectangle.
Returns:
TRUE on success, otherwise FALSE.
See also:
IntersectClipRect, SubtractClipRect

BOOL GUIAPI ClipRgnCopy | ( | PCLIPRGN | pDstRgn,
 |  | const CLIPRGN * | pSrcRgn
 | ) |  |

Copies one region to another.

This function copies the region pointed to by pSrcRgn to the region pointed to by pDstRgn.

Parameters:
pDstRgn | The destination region.
pSrcRgn | The source region.
Returns:
TRUE on success, otherwise FALSE.
Note:
This function will empty the region pDstRgn first.
See also:
EmptyClipRgn, ClipRgnIntersect, UnionRegion, SubtractRegion, XorRegion

BOOL GUIAPI ClipRgnIntersect | ( | PCLIPRGN | pRstRgn,
 |  | const CLIPRGN * | pRgn1,
 |  | const CLIPRGN * | pRgn2
 | ) |  |

Intersects two region.

This function gets the intersection of two regions pointed to by pRgn1 and pRgn2 respectively and puts the result to the region pointed to by pRstRgn.

Parameters:
pRstRgn | The intersected result region.
pRgn1 | The first region.
pRgn2 | The second region.
Returns:
TRUE on success, otherwise FALSE.
Note:
If pRgn1 does not intersected with pRgn2, the result region will be a emgty region.
See also:
EmptyClipRgn, ClipRgnCopy, UnionRegion, SubtractRegion, XorRegion

PCLIPRGN GUIAPI CreateClipRgn ( void )

Creates a clipping region.

Returns:
The pointer to the clip region.
See also:
InitClipRgn, EmptyClipRgn, DestroyClipRgn.

void GUIAPI DestroyClipRgn ( PCLIPRGN pRgn )

Empties and destroys a clipping region.

This function empties and destroys a clipping region pointed to by pRgn.

Parameters:
pRgn The pointer to the region.
See also:
InitClipRgn, CreateClipRgn

void GUIAPI EmptyClipRgn ( PCLIPRGN pRgn )

Empties a clipping region.

This function empties a clipping region pointed to by pRgn.

Parameters:
pRgn The pointer to the region.
See also:
InitClipRgn

void GUIAPI GetClipRgnBoundRect | ( | PCLIPRGN | pRgn,
 |  | PRECT | pRect
 | ) |  |

Gets the bounding rectangle of a region.

This function gets the bounding rect of the region pointed to by pRgn, and returns the rect in the rect pointed to by pRect.

Parameters:
pRgn | The pointer to the region.
pRect | The pointer to the result rect.
See also:
IsEmptyClipRgn

BOOL GUIAPI InitCircleRegion | ( | PCLIPRGN | dst,
 |  | int | x,
 |  | int | y,
 |  | int | r
 | ) |  |

Initializes a region to be an enclosed circle.

Parameters:
dst | The pointer to the region to be initialized.
x | x,y: The center of the circle.
y | x,y: The center of the circle.
r | The radius of the circle.
Returns:
TRUE on success, otherwise FALSE.
See also:
InitEllipseRegion, InitPolygonRegion

void GUIAPI InitClipRgn | ( | PCLIPRGN | pRgn,
 |  | PBLOCKHEAP | pFreeList
 | ) |  |

Initializes a clipping region.

Before intializing a clipping region, you should initialize a private block data heap first. The region operations, such as UnionRegion function, will allocate/free the clipping rectangles from/to the heap. This function will set the heap field of pRgn to be pFreeList, and empty the region.

Parameters:
pRgn | The pointer to the CLIPRGN structure to be initialized.
pFreeList | The pointer to the initialized private block data heap.
See also:
InitFreeClipRectList, EmptyClipRgn.
Example:

static BLOCKHEAP sg_MyFreeClipRectList;

...

    CLIPRGN my_region

    InitFreeClipRectList (&sg_MyFreeClipRectList, 20);
    InitClipRgn (&my_regioni, &sg_MyFreeClipRectList);

BOOL GUIAPI InitEllipseRegion | ( | PCLIPRGN | dst,
 |  | int | x,
 |  | int | y,
 |  | int | rx,
 |  | int | ry
 | ) |  |

Initializes a region to be an enclosed ellipse.

Parameters:
dst | The pointer to the region to be initialized.
x | x,y: The center of the ellipse.
y | x,y: The center of the ellipse.
rx | The x-radius of the ellipse.
ry | The y-radius of the ellipse.
Returns:
TRUE on success, otherwise FALSE.
See also:
InitCircleRegion, InitPolygonRegion

BOOL GUIAPI InitPolygonRegion | ( | PCLIPRGN | dst,
 |  | const POINT * | pts,
 |  | int | vertices
 | ) |  |

Initializes a region to be an enclosed polygon.

Parameters:
dst | The pointer to the region to be initialized.
pts | The vertex array of the polygon.
vertices | The number of the vertices.
Returns:
TRUE on success, otherwise FALSE.
See also:
InitCircleRegion, InitEllipseRegion

BOOL GUIAPI IntersectClipRect | ( | PCLIPRGN | pRgn,
 |  | const RECT * | pRect
 | ) |  |

Intersects a rectangle with a region.

This function intersects the region pointed to by pRgn with a rect pointed to by pRect.

Parameters:
pRgn | The pointer to the region.
pRect | The pointer to the rectangle.
Returns:
TRUE on success, otherwise FALSE.
See also:
AddClipRect, SubtractClipRect

BOOL GUIAPI IsEmptyClipRgn ( const CLIPRGN * pRgn )

Determines whether a region is an empty region.

This function determines whether the region pointed to by pRgn is an empty region.

Parameters:
pRgn The pointer to the region.
Returns:
TRUE for empty one, else for not empty region.
See also:
EmptyClipRgn

void GUIAPI OffsetRegion | ( | PCLIPRGN | region,
 |  | int | x,
 |  | int | y
 | ) |  |

Offsets the region.

This function offsets a given region pointed to by region.

Parameters:
region | The pointer to the region.
x | x,y: Offsets on x and y coodinates.
y | x,y: Offsets on x and y coodinates.

void GUIAPI OffsetRegionEx | ( | PCLIPRGN | region,
 |  | const RECT * | rcClient,
 |  | const RECT * | rcScroll,
 |  | int | x,
 |  | int | y
 | ) |  |

Offsets the region in the specified window's scroll area.

This function offsets a given region pointed to by region in the specified window's scroll area.

Parameters:
region | The pointer to the region.
rcClient | The client area which the region belongs to.
rcScroll | The rectangle of the area in which the region will be offset.
x | x,y: Offsets on x and y coodinates.
y | x,y: Offsets on x and y coodinates.

BOOL GUIAPI PtInRegion | ( | PCLIPRGN | region,
 |  | int | x,
 |  | int | y
 | ) |  |

Determines whether a point is in a region.

This function determines whether a point (x,y) is in the region pointed to by region.

Parameters:
region | The pointer to the region.
x | x,y: The point.
y | x,y: The point.
Returns:
TRUE for in the region, otherwise FALSE.
See also:
RectInRegion

BOOL GUIAPI RectInRegion | ( | PCLIPRGN | region,
 |  | const RECT * | rect
 | ) |  |

Determines whether a rectangle is intersected with a region.

This function determines whether the rect rect is intersected with the region pointed to by region.

Parameters:
region | The pointer to the region.
rect | The pointer to the rect.
Returns:
TRUE for in the region, otherwise FALSE.
See also:
PtInRegion

BOOL GUIAPI SetClipRgn | ( | PCLIPRGN | pRgn,
 |  | const RECT * | pRect
 | ) |  |

Sets a region to contain only one rect.

This function sets the region pRgn to contain only a rect pointed to by pRect.

Parameters:
pRgn | The pointer to the region.
pRect | The pointer to the rect.
Returns:
TRUE on success, otherwise FALSE.
Note:
This function will empty the region pRgn first.
See also:
EmptyClipRgn

BOOL GUIAPI SubtractClipRect | ( | PCLIPRGN | pRgn,
 |  | const RECT * | pRect
 | ) |  |

Subtracts a rectangle from a region.

This function subtracts a rect pointed to by pRect from the region pointed to by pRgn.

Parameters:
pRgn | The pointer to the region.
pRect | The pointer to the rect.
Returns:
TRUE on success, otherwise FALSE.
See also:
AddClipRect, IntersectClipRect

BOOL GUIAPI SubtractRegion | ( | CLIPRGN * | rgnD,
 |  | const CLIPRGN * | rgnM,
 |  | const CLIPRGN * | rgnS
 | ) |  |

Substrcts a region from another.

This function subtracts rgnS from rgnM and leave the result in rgnD.

Parameters:
rgnD | The pointer to the difference region.
rgnM | The pointer to the minuend region.
rgnS | The pointer to the subtrahend region.
Returns:
TRUE on success, otherwise FALSE.
See also:
UnionRegion, XorRegion

BOOL GUIAPI UnionRegion | ( | PCLIPRGN | dst,
 |  | const CLIPRGN * | src1,
 |  | const CLIPRGN * | src2
 | ) |  |

Unions two regions.

This function unions two regions pointed to by src1 and src2 respectively and puts the result to the region pointed to by dst.

Parameters:
dst | The pointer to the result region.
src1 | src1,src2: Two regions will be unioned.
src2 | src1,src2: Two regions will be unioned.
Returns:
TRUE on success, otherwise FALSE.
See also:
SubtractRegion, XorRegion

BOOL GUIAPI XorRegion | ( | CLIPRGN * | dst,
 |  | const CLIPRGN * | src1,
 |  | const CLIPRGN * | src2
 | ) |  |

Does the XOR operation between two regions.

This function does the XOR operation between two regions pointed to by src1 and src2 and puts the result to the region pointed to by dst.

Parameters:
dst | The pointer to the result region.
src1 | src1,src2: Two regions will be xor'ed.
src2 | src1,src2: Two regions will be xor'ed.
Returns:
TRUE on success, otherwise FALSE.
See also:
UnionRegion, SubtractRegion

Generated on Fri Dec 17 13:49:47 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _CLIPRECT Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_CLIPRECT Struct Reference
[Region operations]

#include <gdi.h>

Data Fields

  • RECT rc
  • struct _CLIPRECT * next
  • struct _CLIPRECT * prev

Detailed Description

Clipping rectangle structure.

Definition at line 545 of file gdi.h.

Field Documentation

RECT rc

The clipping rectangle itself.

Definition at line 550 of file gdi.h.

struct _CLIPRECT* next [read]

The next clipping rectangle.

Definition at line 554 of file gdi.h.

struct _CLIPRECT* prev [read]

The previous clipping rectangle.

Definition at line 558 of file gdi.h.

The documentation for this struct was generated from the following file:
  • gdi.h
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _CLIPRGN Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_CLIPRGN Struct Reference
[Region operations]

#include <gdi.h>

Data Fields

  • BYTE type
  • BYTE reserved [3]
  • RECT rcBound
  • PCLIPRECT head
  • PCLIPRECT tail
  • PBLOCKHEAP heap

Detailed Description

Clipping region structure, alos used for general regions.

Definition at line 570 of file gdi.h.

Field Documentation

BYTE type

Type of the region, can be one of the following:

  • NULLREGION
    A null region.
  • SIMPLEREGION
    A simple region.
  • COMPLEXREGION
    A complex region.

Definition at line 581 of file gdi.h.

BYTE reserved[3]

Reserved for alignment.

Definition at line 585 of file gdi.h.

RECT rcBound

The bounding rect of the region.

Definition at line 589 of file gdi.h.

PCLIPRECT head

Head of the clipping rectangle list.

Definition at line 593 of file gdi.h.

PCLIPRECT tail

Tail of the clipping rectangle list.

Definition at line 597 of file gdi.h.

PBLOCKHEAP heap

The private block data heap used to allocate clipping rectangles.

See also:
BLOCKHEAP

Definition at line 602 of file gdi.h.

The documentation for this struct was generated from the following file:
  • gdi.h
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: General DC operations

General DC operations
[GDI functions]

Defines

  • #define HDC_SCREEN 0
    Handle to the device context of the whole screen.
  • #define HDC_INVALID 0xFFFFFFFF
    Indicates an invalid handle to device context.
  • #define CreateCompatibleDC(hdc) CreateCompatibleDCEx(hdc, 0, 0)
    Creates a memory DC which is compatible with a given DC.
  • #define DeleteCompatibleDC(hdc) DeleteMemDC(hdc)
    Deletes a memory DC.

Typedefs

  • typedef void(* CB_DIRECT_DRAW_RECT )(HDC hdc, Uint8 *pixels, int pitch, int bytesPerPixel, const RECT *rc, void *context)
    Type of directly access pixels hook function.
  • typedef int(* ON_UPDATE_SECONDARYDC )(HWND hwnd, HDC secondary_dc, HDC real_dc, const RECT *secondary_rc, const RECT *real_rc, const RECT *main_update_rc)
    The callback type of on updating secondary DC.

Functions

  • MG_EXPORT unsigned int GUIAPI GetGDCapability (HDC hdc, int iItem)
    Returns a capability of a DC.
  • MG_EXPORT HDC GUIAPI GetDC (HWND hwnd)
    Gets a window DC of a window.
  • MG_EXPORT HDC GUIAPI GetClientDC (HWND hwnd)
    Gets a client DC of a window.
  • MG_EXPORT HDC GUIAPI GetSubDC (HDC hdc, int off_x, int off_y, int width, int height)
    This function gets a sub DC which is compliant to the specified client DC.
  • MG_EXPORT void GUIAPI ReleaseDC (HDC hdc)
    Releases a DC from DC pool.
  • MG_EXPORT HWND GUIAPI WindowFromDC (HDC hdc)
    Get the window handle from DC.
  • MG_EXPORT int GUIAPI SaveDC (HDC hdc)
    Saves the current state of a device context.
  • MG_EXPORT BOOL GUIAPI RestoreDC (HDC hdc, int saved_dc)
    Restores a device context (DC) to the specified state.
  • MG_EXPORT HDC GUIAPI CreateCompatibleDCEx (HDC hdc, int width, int height)
    Creates a memory DC which is compatible with the specified reference DC.
  • MG_EXPORT BOOL GUIAPI IsCompatibleDC (HDC hdc1, HDC hdc2)
    Check whether a given DC is compliant to a specific DC.
  • MG_EXPORT HDC GUIAPI CreateMemDCEx (int width, int height, int depth, DWORD flags, Uint32 Rmask, Uint32 Gmask, Uint32 Bmask, Uint32 Amask, void *bits, int pitch)
    Creates a memory DC.
  • static HDC GUIAPI CreateMemDC (int width, int height, int depth, DWORD flags, Uint32 Rmask, Uint32 Gmask, Uint32 Bmask, Uint32 Amask)
    Creates a memory DC.
  • MG_EXPORT HDC GUIAPI CreateSubMemDC (HDC parent, int off_x, int off_y, int width, int height, BOOL comp_to_parent)
    Creates a sub memory DC in the given memory DC.
  • MG_EXPORT HDC GUIAPI CreateMemDCFromBitmap (HDC hdc, const BITMAP *bmp)
    Creates a memory DC from a reference DC and a BITMAP object.
  • MG_EXPORT HDC GUIAPI CreateMemDCFromMyBitmap (const MYBITMAP *my_bmp, const RGB *pal)
    Creates a memory DC from a device independent MYBITMAP object.
  • MG_EXPORT BOOL GUIAPI ConvertMemDC (HDC mem_dc, HDC ref_dc, DWORD flags)
    Converts a memory DC to have a same format as a reference DC.
  • MG_EXPORT BOOL GUIAPI SetMemDCAlpha (HDC mem_dc, DWORD flags, Uint8 alpha)
    Sets the alpha value for the entire surface of a DC, as opposed to using the alpha component of each pixel.
  • MG_EXPORT BOOL GUIAPI SetMemDCColorKey (HDC mem_dc, DWORD flags, Uint32 color_key)
    Sets the color key (transparent pixel) of a memory DC.
  • MG_EXPORT void GUIAPI DeleteMemDC (HDC mem_dc)
    Deletes a memory DC.
  • MG_EXPORT Uint8 *GUIAPI LockDC (HDC hdc, const RECT *rw_rc, int *width, int *height, int *pitch)
    Locks a dc to get direct access to pixels in the DC.
  • MG_EXPORT BOOL GUIAPI LockDCEx (HDC hdc, const PCLIPRGN region, void *context, CB_DIRECT_DRAW_RECT cb)
    directly access the pixels in a DC.
  • MG_EXPORT void GUIAPI UnlockDC (HDC hdc)
    Unlocks a locked DC.
  • MG_EXPORT HDC GUIAPI CreatePrivateDC (HWND hwnd)
    Creates a private window DC of a window.
  • MG_EXPORT HDC GUIAPI CreatePrivateClientDC (HWND hwnd)
    Creates a private client DC of a window.
  • HDC GUIAPI CreatePrivateSubDC (HDC hdc, int off_x, int off_y, int width, int height)
    Creates a private SubDC of a window.
  • MG_EXPORT HDC GUIAPI GetPrivateClientDC (HWND hwnd)
    Returns the private client DC of a window.
  • MG_EXPORT void GUIAPI DeletePrivateDC (HDC hdc)
    Deletes the DC returned by CreatePrivateDC or CreatePrivateClientDC or CreatePrivateSubDC.
  • MG_EXPORT HDC GUIAPI CreateSecondaryDC (HWND hwnd)
    Creates a secondary window DC of a window.
  • MG_EXPORT HDC GUIAPI SetSecondaryDC (HWND hwnd, HDC secondary_dc, ON_UPDATE_SECONDARYDC on_update_secondarydc)
    Set a window's secondary DC and the callback procedure for the secondary DC update.
  • MG_EXPORT HDC GUIAPI GetSecondaryDC (HWND hwnd)
    Retrives and returns the secondary DC of a specific window.
  • MG_EXPORT HDC GUIAPI GetSecondaryClientDC (HWND hwnd)
    Retrives and returns the client secondary DC of a specific window.
  • MG_EXPORT void GUIAPI ReleaseSecondaryDC (HWND hwnd, HDC hdc)
    Release the DC returned by GetSecondaryDC or GetSecondaryClientDC.
  • MG_EXPORT void GUIAPI DeleteSecondaryDC (HWND hwnd)
    Deletes the secondary DC of the window.

Detailed Description

DC means Device Context, just like Graphics Context (GC) of X Lib. DC represents a rectangle area on the actual screen or a virtual screen created in memory. We call the rectangle area as "surface" of the DC.

You can call a GDI function and pass a DC to the function to draw lines, circles, or text. Commonly, you should call a function like GetClientDC or CreateCompatibleDC to get or create a DC, then call GDI functions to draw objects, e.g. MoveTo and LineTo. After finishing drawing, you should call ReleaseDC or DeleteMemDC function to release or destroy the DC.

MiniGUI reserved an global DC called HDC_SCREEN. You can use this DC directly without getting/creating or releasing/destroying.

For main windows or controls, MiniGUI will send a MSG_PAINT message to the window when the whole or part of window area have been invalidated. You should call BegainPaint function to get the DC, then repaint the window, and call EndPaint function to release the DC at the last.

Example:

case MSG_PAINT:
{
    HDC hdc;

    hdc = BeginPaint (hWnd);

    // Draw a line.
    MoveTo (hdc, 0, 0);
    LineTo (hdc, 100, 100);

    EndPaint (hWnd, hdc);
    return 0;
}

Define Documentation

#define CreateCompatibleDC ( hdc ) CreateCompatibleDCEx(hdc, 0, 0)

Creates a memory DC which is compatible with a given DC.

This function creates a memory DC fully compatible with the reference DC hdc, including pixel format and geomatry.

Parameters:
hdc The reference DC.
Returns:
The handle to the memory DC, HDC_INVALID indicates an error.
See also:
CreateCompatibleDCEx, DeleteMemDC

Definition at line 1616 of file gdi.h.

#define DeleteCompatibleDC ( hdc ) DeleteMemDC(hdc)

Deletes a memory DC.

This function deletes a memory DC created by CreateCompatibleDC.

Parameters:
hdc The device context to be deleted.
See also:
CreateCompatibleDC, DeleteMemDC

Definition at line 1628 of file gdi.h.

#define HDC_INVALID 0xFFFFFFFF

Indicates an invalid handle to device context.

Definition at line 1105 of file gdi.h.

#define HDC_SCREEN 0

Handle to the device context of the whole screen.

This DC is a special one. MiniGUI uses it to draw popup menus and other global objects. You can also use this DC to draw lines or text on the screen directly, and there is no need to get or release it.

If you do not want to create any main window, but you want to draw on the screen, you can use this DC.

Note:
MiniGUI does not do any clipping operation for this DC, so use this DC may make a mess of other windows.

Definition at line 1093 of file gdi.h.

Typedef Documentation

typedef void(* CB_DIRECT_DRAW_RECT)(HDC hdc, Uint8 *pixels, int pitch, int bytesPerPixel, const RECT *rc, void *context)

Type of directly access pixels hook function.

This function is invoked by LockDCEx, application should implement this function in which could directly read and write the pixels in a DC.

Parameters:
hdc | the device context.
pixels | the pixels addr point to the rc's left-top in DC.
pitch | (the bytes of one scan line) of the DC.
bytesPerPixel | bytes per pixel.
rc | the rectangle to draw, the field left of which is mapped to pixels.
context | the context provided by application.

Definition at line 1686 of file gdi.h.

typedef int(* ON_UPDATE_SECONDARYDC)(HWND hwnd, HDC secondary_dc, HDC real_dc, const RECT *secondary_rc, const RECT *real_rc, const RECT *main_update_rc)

The callback type of on updating secondary DC.

Parameters:
hwnd | The handle to the updated window.
secondary_dc | The update src dc.
real_dc | The update dst dc.
secondary_rc | The rectangle relative to secondary_dc.
real_rc | The rectangle relative to real_dc.
main_update_dc | The rectangle relative to main window.
Returns:
The update result.

Definition at line 1871 of file gdi.h.

Function Documentation

BOOL GUIAPI ConvertMemDC | ( | HDC | mem_dc,
 |  | HDC | ref_dc,
 |  | DWORD | flags
 | ) |  |

Converts a memory DC to have a same format as a reference DC.

This function converts a memory DC mem_dc in order to let it have the same pixel format as the reference DC ref_dc. This function will try to create a new surface for mem_dc, and then copies and maps the surface of ref_dc to it so the blit of the converted memory DC will be as fast as possible.

The flags parameter has the same semantics as CreateMemDC. You can also pass MEMDC_FLAG_RLEACCEL in the flags parameter and MiniGUI will try to RLE accelerate colorkey and alpha blits in the resulting memory DC.

Parameters:
mem_dc | The device context to be converted.
ref_dc | The reference device context.
flags | The memory DC flags, has the same semantics as CreateMemDC.
Returns:
TRUE on success, otherwise FALSE.
See also:
CreateMemDC, DeleteMemDC

HDC GUIAPI CreateCompatibleDCEx | ( | HDC | hdc,
 |  | int | width,
 |  | int | height
 | ) |  |

Creates a memory DC which is compatible with the specified reference DC.

This function creates a memory DC which have the same pixel format as the specified reference DC hdc. The same pixel format means that the memory DC will have the same pixel depth, the same RGB composition, or the same palette as the reference DC. Note that the memdc will have the same DC attributes as the reference DC.

Parameters:
hdc | The handle to the reference DC.
width | The expected width of the result memory DC. If it is zero, the width will be equal to the width of the reference DC.
height | The expected height of the result memory DC. If it is zero, the height will be equal to the height of the reference DC.
Returns:
The handle to the memory DC, HDC_INVALID indicates an error.
See also:
CreateCompatibleDC

HDC GUIAPI CreateMemDC | ( | int | width,
 |  | int | height,
 |  | int | depth,
 |  | DWORD | flags,
 |  | Uint32 | Rmask,
 |  | Uint32 | Gmask,
 |  | Uint32 | Bmask,
 |  | Uint32 | Amask |
 | ) |  |  | [inline, static]

Creates a memory DC.

This function creates a memory DC which have the specified flags and pixel format.

Parameters:
width | The expected width of the result memory DC.
height | The expected height of the result memory DC.
depth | The expected color depth of the memory DC.
flags | The memory DC flags, can be or'ed values of the following flags:
  • MEMDC_FLAG_SWSURFACE
    Creates the surface of memory DC in the system memory.
  • MEMDC_FLAG_HWSURFACE
    Creates the surface of memory DC in the video memory.
  • MEMDC_FLAG_SRCCOLORKEY
    The created memory DC will use a source color key to blit to other DC.
  • MEMDC_FLAG_SRCALPHA
    The created memory DC will use a source alpha blending to blit to other DC.
  • MEMDC_FLAG_RLEACCEL
    The memory DC will be RLE encoded.

Parameters:
Rmask | The bit-masks of the red components in a pixel value.
Gmask | The bit-masks of the green components in a pixel value.
Bmask | The bit-masks of the blue components in a pixel value.
Amask | The bit-masks of the alpha components in a pixel value.
Returns:
The handle to the memory DC, HDC_INVALID indicates an error.
See also:
CreateMemDCEx, CreateMemDCFromBitmap, CreateMemDCFromMyBitmap, CreateCompatibleDCEx

Definition at line 1434 of file gdi.h.

References CreateMemDCEx(), and NULL.

HDC GUIAPI CreateMemDCEx | ( | int | width,
 |  | int | height,
 |  | int | depth,
 |  | DWORD | flags,
 |  | Uint32 | Rmask,
 |  | Uint32 | Gmask,
 |  | Uint32 | Bmask,
 |  | Uint32 | Amask,
 |  | void * | bits,
 |  | int | pitch
 | ) |  |

Creates a memory DC.

This function creates a memory DC which have the specified flags and pixel format, and uses the pre-allocated buffer as the surface if bits is not NULL.

Parameters:
width | The expected width of the result memory DC.
height | The expected height of the result memory DC.
depth | The expected color depth of the memory DC.
flags | The memory DC flags, can be or'ed values of the following flags:
  • MEMDC_FLAG_SWSURFACE
    Creates the surface of memory DC in the system memory.
  • MEMDC_FLAG_HWSURFACE
    Creates the surface of memory DC in the video memory.
  • MEMDC_FLAG_SRCCOLORKEY
    The created memory DC will use a source color key to blit to other DC.
  • MEMDC_FLAG_SRCALPHA
    The created memory DC will use a source alpha blending to blit to other DC.
  • MEMDC_FLAG_RLEACCEL
    The memory DC will be RLE encoded.

Parameters:
Rmask | The bit-masks of the red components in a pixel value.
Gmask | The bit-masks of the green components in a pixel value.
Bmask | The bit-masks of the blue components in a pixel value.
Amask | The bit-masks of the alpha components in a pixel value.
bits | The pointer to the pre-allocated surface. If this is NULL, MiniGUI will try to allocate the surface from video memory or system memory.
pitch | The pitch (the number of bytes of one scan line) of the surface.
Returns:
The handle to the memory DC, HDC_INVALID indicates an error.
Note:
If you pass a pre-allocated surface buffer to this function, MiniGUI will not free the buffer when you delete the memdc by calling DeleteMemDC.
See also:
CreateMemDC, CreateMemDCFromBitmap, CreateMemDCFromMyBitmap, CreateCompatibleDCEx

Referenced by CreateMemDC().

HDC GUIAPI CreateMemDCFromBitmap | ( | HDC | hdc,
 |  | const BITMAP * | bmp
 | ) |  |

Creates a memory DC from a reference DC and a BITMAP object.

This function creates a memory DC compatible with the specified DC, and use the bits of the BITMAP object as the surface of the memory DC. The created memory DC will have the same geometry as the BITMAP object.

Parameters:
hdc | The reference DC.
bmp | The BITMAP object.
Returns:
The handle to the memory DC, HDC_INVALID indicates an error.
See also:
CreateMemDCFromMyBitmap, DeleteMemDC, BITMAP

HDC GUIAPI CreateMemDCFromMyBitmap | ( | const MYBITMAP * | my_bmp,
 |  | const RGB * | pal
 | ) |  |

Creates a memory DC from a device independent MYBITMAP object.

This function creates a memory DC which have the same pixel format as the MYBITMAP object my_bmp, and use the bits of the MYBITMAP object as the surface of the memory DC. The created memory DC will have the same geometry as the MYBITMAP object. If the depth of my_bmp is 8-bit, the function will use pal to initialize the palette of the memory DC.

Note that the color depth of a memory DC can not be less than 8. Thefore, if the color depth of the MYBITMAP object is less than 8, this function will return HDC_INVALID.

Note that if the MYBITMAP object has the flag MYBMP_FLOW_UP, this function will return HDC_INVALID as well.

Parameters:
my_bmp | The device independent MYBITMAP object.
pal | The palette of the MYBITMAP object. If the depth of my_bmp is larger than 8-bit, this argument can be NULL.
Returns:
The handle to the memory DC, HDC_INVALID indicates an error.
See also:
CreateMemDCFromBitmap, DeleteMemDC, MYBITMAP

HDC GUIAPI CreatePrivateClientDC ( HWND hwnd )

Creates a private client DC of a window.

This function creates a private client DC of the window hwnd and returns the handle to the DC.

When you calling CreatePrivateClientDC function to create a private client DC, MiniGUI will create the DC in the system heap, rather than allocate one from the DC pool. Thus, you can keep up the DC in the life cycle of the window, and are not needed to release it for using by other windows.

Parameters:
hwnd The handle to the window.
Returns:
The handle to the DC, HDC_INVALID indicates an error.
See also:
DeletePrivateDC

HDC GUIAPI CreatePrivateDC ( HWND hwnd )

Creates a private window DC of a window.

This function creates a private window DC of the window hwnd and returns the handle to the DC.

When you calling CreatePrivateDC function to create a private DC, MiniGUI will create the DC in the system heap, rather than allocate one from the DC pool. Thus, you can keep up the private DC in the life cycle of the window, and are not needed to release it for using by other windows.

Parameters:
hwnd The handle to the window.
Returns:
The handle to the DC, HDC_INVALID indicates an error.
See also:
DeletePrivateDC

HDC GUIAPI CreatePrivateSubDC | ( | HDC | hdc,
 |  | int | off_x,
 |  | int | off_y,
 |  | int | width,
 |  | int | height
 | ) |  |

Creates a private SubDC of a window.

This function creates a private SubDC of the DC and returns the handle of the SubDC.

When you calling CreatePrivateSubDC function to create a private Sub DC, MiniGUI will create the DC in the system heap, rather than allocate one from the DC pool. Thus, you can keep up the DC in the life cycle of the window, and are not needed to release it for using by other windows.

Parameters:
hdc | The handle of the DC.
off_x | The x-coordinate of the sub DC in the parent DC (in device coordinate system).
off_y | The y-coordinate of the sub DC in the parent DC (in device coordinate system).
width | The expected width of the sub DC.
height | The expected height of the sub DC.
Returns:
The handle to SubDC, HDC_INVALID indicates an error.
See also:
DeletePrivateDC

HDC GUIAPI CreateSecondaryDC ( HWND hwnd )

Creates a secondary window DC of a window.

This function creates a secondary DC for the main window hwnd and returns the handle to the secondary DC.

When you calling CreateSecondaryDC function, MiniGUI will create a memory DC which is compatible with HDC_SCREEN.

When a main window have the extended style WS_EX_AUTOSECONDARYDC, MiniGUI will create a Secondary DC for this main window in the creation progress of the main window, and destroy the DC when you destroy the window. MiniGUI will use this Secondary DC and its sub DCs to render the window content and childen.

Parameters:
hwnd The handle to the window.
Returns:
The handle to the DC, HDC_INVALID indicates an error.
See also:
DeleteSecondaryDC

HDC GUIAPI CreateSubMemDC | ( | HDC | parent,
 |  | int | off_x,
 |  | int | off_y,
 |  | int | width,
 |  | int | height,
 |  | BOOL | comp_to_parent
 | ) |  |

Creates a sub memory DC in the given memory DC.

This function creates a sub memory DC in the given memory DC (the parent memory DC). Note that the new sub memdc will have the same DC attributes as the parent memdc.

Parameters:
parent | The handle to the parent memory DC.
off_x | The x-coordinate of the sub memory DC in the parent DC (in device coordinate system).
off_y | The y-coordinate of the sub memory DC in the parent DC (in device coordinate system).
width | The expected width of the sub memory DC.
height | The expected height of the sub memory DC.
comp_to_parent | The flag indicates whether the sub memdc is compliant to the parent dc.
Returns:
The handle to the memory DC; HDC_INVALID indicates an error.
Note:
Only defined for _USE_NEWGAL.
See also:
CreateMemDC

void GUIAPI DeleteMemDC ( HDC mem_dc )

Deletes a memory DC.

This function deletes the memory DC mem_dc, and frees the surface of the DC. For the memory DC created from BITMAP object or MYBITMAP object, the bits used by the surface of the DC will be reserved.

Parameters:
mem_dc The device context to be deleted.
See also:
CreateMemDC, CreateMemDCFromBitmap, CreateMemDCFromMyBitmap

void GUIAPI DeletePrivateDC ( HDC hdc )

Deletes the DC returned by CreatePrivateDC or CreatePrivateClientDC or CreatePrivateSubDC.

Parameters:
hdc The handle to the DC.
See also:
CreatePrivateDC, CreatePrivateClientDC

void GUIAPI DeleteSecondaryDC ( HWND hwnd )

Deletes the secondary DC of the window.

Parameters:
hwnd The handle to the window.
See also:
CreateSecondaryDC

HDC GUIAPI GetClientDC ( HWND hwnd )

Gets a client DC of a window.

This function gets a client DC of the specified hwnd, and returns the handle to the DC. MiniGUI will try to return an unused DC from the internal DC pool, rather than allocate a new one from the system heap. Thus, you should release the DC when you finish drawing as soon as possible.

Parameters:
hwnd The handle to the window.
Returns:
The handle to the DC, HDC_INVALID indicates an error.
Note:
You should call ReleaseDC to release the DC when you are done.
See also:
GetDC, ReleaseDC

HDC GUIAPI GetDC ( HWND hwnd )

Gets a window DC of a window.

This function gets a window DC of the specified hwnd, and returns the handle to the DC. MiniGUI will try to return an unused DC from the internal DC pool, rather than allocate a new one from the system heap. Thus, you should release the DC when you finish drawing as soon as possible.

Parameters:
hwnd The handle to the window.
Returns:
The handle to the DC, HDC_INVALID indicates an error.
Note:
You should call ReleaseDC to release the DC when you are done.
See also:
GetClientDC, ReleaseDC

unsigned int GUIAPI GetGDCapability | ( | HDC | hdc,
 |  | int | iItem
 | ) |  |

Returns a capability of a DC.

This function returns the capability of the specified item iItem of the DC hdc.

Parameters:
hdc | The handle to the DC.
iItem | An integer presents the capablity, can be one of the following values:
  • GDCAP_COLORNUM
    Tell GetGDCapability to return the colors number of the DC. Note the for a DC with 32-bit depth, the function will return 0xFFFFFFFF, not 0x100000000.
  • GDCAP_HPIXEL
    Tell GetGCapability to return the horizontal resolution of the DC.
  • GDCAP_VPIXEL
    Tell GetGDCapability to return the vertical resolution of the DC.
  • GDCAP_MAXX
    Tell GetGDCapability to return the maximal visible x value of the DC.
  • GDCAP_MAXY
    Tell GetGDCapability to return the maximal visible y value of the DC.
  • GDCAP_DEPTH
    Tell GetGDCapability to return the color depth of the DC. The returned value can be 1, 4, 8, 15, 16, 24, or 32.
  • GDCAP_BITSPP
    Tell GetGDCapability to return the bits number for storing a pixle in the DC.
  • GDCAP_BPP
    Tell GetGDCapability to return the bytes number for storing a pixle in the DC.
  • GDCAP_RMASK
    Tell GetGDCapability to return the pixel red color mask for the DC.
  • GDCAP_GMASK
    Tell GetGDCapability to return the pixel green color mask for the DC.
  • GDCAP_BMASK
    Tell GetGDCapability to return the pixel blue color mask for the DC.
  • GDCAP_AMASK
    Tell GetGDCapability to return the pixel alpha color mask for the DC.
  • GDCAP_PITCH
    Tell GetGDCapability to return the pitch (the bytes of one scan line) of the DC.

Returns:
The capbility.

HDC GUIAPI GetPrivateClientDC ( HWND hwnd )

Returns the private client DC of a window.

This function returns the private client DC of the window hwnd which have extended style WS_EX_USEPRIVATECDC.

When a main window have the extended style WS_EX_USEPRIVATECDC, or a control class have the style CS_OWNDC, MiniGUI will create a private client DC for this window in the creation progress of the window, and destroy the DC when you destroy the window, and use this private client DC in default message handlers. So there will be some improvments on drawing/repaint performance. You can alos call this function to get the private client DC, and use it to draw anything in your window.

Parameters:
hwnd The handle to the window.
Returns:
The handle to the private client DC, HDC_INVALID indicates an error.
See also:
CreatePrivateClientDC

HDC GUIAPI GetSecondaryClientDC ( HWND hwnd )

Retrives and returns the client secondary DC of a specific window.

This function retrives and returns the client secondary DC of the main window hwnd.

When a main window have the secondary DC, MiniGUI will use this secondary DC and its sub DCs to render the content of the window and its children.

Parameters:
hwnd The handle to the main window.
Returns:
The handle to the client secondary DC, HDC_SCREEN indicates that the main window has no secondary DC.
See also:
ReleaseSecondaryDC, SetSecondaryDC

HDC GUIAPI GetSecondaryDC ( HWND hwnd )

Retrives and returns the secondary DC of a specific window.

This function retrives and returns the secondary DC of the window hwnd.

When a main window have the secondary DC, MiniGUI will use this secondary DC and its sub DCs to render the content of the window and its children.

Parameters:
hwnd The handle to the window.
Returns:
The handle to the secondary DC, HDC_SCREEN indicates that the window has no secondary DC.
See also:
ReleaseSecondaryDC, SetSecondaryDC

HDC GUIAPI GetSubDC | ( | HDC | hdc,
 |  | int | off_x,
 |  | int | off_y,
 |  | int | width,
 |  | int | height
 | ) |  |

This function gets a sub DC which is compliant to the specified client DC.

This function creates a sub client DC, which is restricted in the specified rectangle and compliant to the specified client DC hdc. Note that you should release the returned dc by calling ReleaseDC.

Parameters:
hdc | The handle to the parent client DC.
off_x | The x-coordinate of the sub DC in the parent DC (in device coordinate system).
off_y | The y-coordinate of the sub DC in the parent DC (in device coordinate system).
width | The expected width of the sub DC.
height | The expected height of the sub DC.
Returns:
The handle to the new sub DC, HDC_INVALID indicates an error.
Note:
You should call ReleaseDC to release the DC when you are done.
See also:
GetDC, GetClientDC, ReleaseDC

BOOL GUIAPI IsCompatibleDC | ( | HDC | hdc1,
 |  | HDC | hdc2
 | ) |  |

Check whether a given DC is compliant to a specific DC.

This function checks whether a give DC hdc2 is compliant to the specific DC hdc1.

Parameters:
hdc1 | The handle to a DC.
hdc2 | The handle to another DC.
Returns:
TRUE when hdc2 is compiliant to hdc1, otherwise FALSE.
See also:
CreateCompatibleDCEx

Uint8 *GUIAPI LockDC | ( | HDC | hdc,
 |  | const RECT * | rw_rc,
 |  | int * | width,
 |  | int * | height,
 |  | int * | pitch
 | ) |  |

Locks a dc to get direct access to pixels in the DC.

Calling this function will try to lock the DC hdc to directly access the pixels of the DC. You should tell this function the rectangle to be accessed, and the function will return the requested width, height and pitch of the DC. The access beyond requested width and height will be invalid.

Locking a DC which uses screen surface will lock some global objects, such as mouse cursor, and so on. All GDI calls of other threads (in MiniGUI-Threads) or other process (in MiniGUI-Processes) will be blocked as well. So you should call UnlockDC to unlock the DC as soon as possible, and should not call any system function in the duration of locking the DC.

Parameters:
hdc | The handle to the device context.
rw_rc | The rectangle in device coordinate system to be accessed in the DC.
width | The width of the effective rectangle can access will be returned through this pointer.
height | The height of the effective rectangle can access will be returned through this pointer.
pitch | The pitch of the scan line of the DC will be returned through this pointer. Pitch means the length of the scan line in bytes.
Returns:
The bits pointer to the upper-left corner of the requested rectangle, NULL on error.
See also:
UnlockDC, LockDCEx
Example:

    /*
     * lock the dc and draw the scan line with random color.
     */

    int i, width, height, pitch;
    RECT rc = {0, 0, 200, 200};
    int bpp = GetGDCapability (hdc, GDCAP_BPP);
    Uint8* frame_buffer = LockDC (hdc, &rc, &width, &height, &pitch);
    Uint8* row = frame_buffer;

    for (i = 0; i < *height; i++) {
        memset (row, rand ()%0x100, *width * bpp);
        row += *pitch;
    }

    UnlockDC (hdc);

BOOL GUIAPI LockDCEx | ( | HDC | hdc,
 |  | const PCLIPRGN | region,
 |  | void * | context,
 |  | CB_DIRECT_DRAW_RECT | cb
 | ) |  |

directly access the pixels in a DC.

This function fill region by function cb that directly accesses pixels in a DC. This function is used to draw region more effiently. The function that lock __mg_gdilock should not be invoked any more after invoking this function, or else it will cause deadlock. UnlockDC should be invoked after invoking this function that will call back CB_DIRECT_DRAW_RECT, other process could not draw any more until the DC has been unlocked.

Parameters:
hdc | the device context.
region | the visible region to draw.
context | the context provided by application, which is as a parameter of cb.
cb | the direct draw function that directly accesses pixels which should be implemented by application. if cb is NULL, the region will be filled by current brush color.
Returns:
if LockDCEx success return TRUE, else return FALSE;
See also:
UnlockDC, LockDC

void GUIAPI ReleaseDC ( HDC hdc )

Releases a DC from DC pool.

This function releases the DC returned by GetDC or GetClientDC.

Parameters:
hdc The handle to the DC.
See also:
GetDC, GetClientDC, GetSubDC

void GUIAPI ReleaseSecondaryDC | ( | HWND | hwnd,
 |  | HDC | hdc
 | ) |  |

Release the DC returned by GetSecondaryDC or GetSecondaryClientDC.

Parameters:
hwnd | The handle to the window.
hdc | The handle to the secondary DC.
Returns:
void
See also:
GetSecondaryDC, GetSecondaryClientDC

BOOL GUIAPI RestoreDC | ( | HDC | hdc,
 |  | int | saved_dc
 | ) |  |

Restores a device context (DC) to the specified state.

This function restores a device context (DC) to the specified state. The DC is restored by popping state information off a stack created by earlier calls to the SaveDC function.

Parameters:
hdc | The handle to the DC.
saved_dc | Specifies the saved state to be restored. If this parameter is positive, saved_dc represents a specific instance of the state to be restored. If this parameter is negative, saved_dc represents an instance relative to the current state. For example, -1 restores the most recently saved state.
Returns:
If the function succeeds, the return value is nonzero. If the function fails, the return value is zero.
Note:
The stack can contain the state information for several instances of the DC. If the state specified by the specified parameter is not at the top of the stack, RestoreDC deletes all state information between the top of the stack and the specified instance.
See also:
SaveDC

int GUIAPI SaveDC ( HDC hdc )

Saves the current state of a device context.

This function saves the current state of the specified device context (DC) by copying data describing selected objects and graphic modes (such as pen, brush, palette, font, pen, region, drawing mode, and mapping mode) to a context stack.

Parameters:
hdc The handle to the DC whose state is to be saved.
Returns:
If the function succeeds, the return value identifies the saved state. If the function fails, the return value is zero.
Note:
This function can be used any number of times to save any number of instances of the DC state. A saved state can be restored by using the RestoreDC function.
See also:
RestoreDC

BOOL GUIAPI SetMemDCAlpha | ( | HDC | mem_dc,
 |  | DWORD | flags,
 |  | Uint8 | alpha
 | ) |  |

Sets the alpha value for the entire surface of a DC, as opposed to using the alpha component of each pixel.

This function sets the alpha value for the entire surface of the DC mem_dc, as opposed to using the alpha component of each pixel. This value measures the range of transparency of the surface, 0 being completely transparent to 255 being completely opaque. An alpha value of 255 causes blits to be opaque, the source pixels copied to the destination (the default). Note that per-surface alpha can be combined with colorkey transparency.

If flags is 0, alpha blending is disabled for the surface. If flags is MEMDC_FLAG_SRCALPHA, alpha blending is enabled for the surface. OR'ing the flag with MEMDC_FLAG_RLEACCEL requests RLE acceleration for the surface; if MEMDC_FLAG_RLEACCEL is not specified, the RLE acceleration will be removed. If flags is MEMDC_FLAG_SRCPIXELALPHA, per-pixel alpha blending is enabled for the surface.

Parameters:
mem_dc | The device context.
flags | The alpha value specific memory DC flags.
alpha | the alpha value for the entire surface of the DC mem_dc.
Returns:
TRUE on success, otherwise FALSE.
See also:
SetMemDCColorKey

BOOL GUIAPI SetMemDCColorKey | ( | HDC | mem_dc,
 |  | DWORD | flags,
 |  | Uint32 | color_key
 | ) |  |

Sets the color key (transparent pixel) of a memory DC.

This function sets the color key (transparent pixel) of the memory DC mem_dc. If flags is MEMDC_FLAG_SRCCOLORKEY (optionally OR'ed with MEMDC_FLAG_RLEACCEL), color_key will be the transparent pixel in the source DC of a blit. MEMDC_FLAG_RLEACCEL requests RLE acceleration for the source of the DC if present, and removes RLE acceleration if absent. If flags is 0, this function clears any current color key.

Parameters:
mem_dc | The device context.
flags | The color key specific memory DC flags.
color_key | The color_key of the memory DC.
Returns:
TRUE on success, otherwise FALSE.
See also:
SetMemDCAlpha

HDC GUIAPI SetSecondaryDC | ( | HWND | hwnd,
 |  | HDC | secondary_dc,
 |  | ON_UPDATE_SECONDARYDC | on_update_secondarydc
 | ) |  |

Set a window's secondary DC and the callback procedure for the secondary DC update.

This function set the secondary DC of the main window hwnd and returns the handle to the old seconadary DC.

Parameters:
hwnd | The handle to the main window.
secondary_dc | The secondary DC which will be the new secondary DC of the main window.
on_update_secondarydc The callback procedure for the secondary DC update. You can pass one of two sepcial values:
  • ON_UPDSECDC_DEFAULT
    The default operation to update the secondary DC to the real DC of the main window.
  • ON_UPDSECDC_DONOTHING
    No any operation occures.
Returns:
The handle to the old secondary DC, HDC_SCREEN indicates the main window has no secondary DC before calling this function.
See also:
DeleteSecondaryDC

void GUIAPI UnlockDC ( HDC hdc )

Unlocks a locked DC.

Parameters:
hdc The locked DC.
See also:
LockDC, LockDCEx

HWND GUIAPI WindowFromDC ( HDC hdc )

Get the window handle from DC.

This function returns the handle to a window according to the handle to DC of the window.

Parameters:
hdc The handle to the DC.
Note:
Do not call this function on memory DC.
See also:
GetDC.

Generated on Fri Dec 17 13:49:47 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: DC attribute operations

DC attribute operations
[GDI functions]

Defines

  • #define GetBkColor(hdc) GetDCAttr (hdc, DC_ATTR_BK_COLOR)
    Gets the background color of a DC.
  • #define GetBkMode(hdc) GetDCAttr (hdc, DC_ATTR_BK_MODE)
    Gets the background mode of a DC.
  • #define GetPenColor(hdc) GetDCAttr (hdc, DC_ATTR_PEN_COLOR)
    Gets the pen color of a DC.
  • #define GetBrushColor(hdc) GetDCAttr (hdc, DC_ATTR_BRUSH_COLOR)
    Gets the brush color of a DC.
  • #define GetTextColor(hdc) GetDCAttr (hdc, DC_ATTR_TEXT_COLOR)
    Gets the text color of a DC.
  • #define GetTabStop(hdc) GetDCAttr (hdc, DC_ATTR_TAB_STOP)
    Gets the tabstop value of a DC.
  • #define SetBkColor(hdc, color) SetDCAttr (hdc, DC_ATTR_BK_COLOR, (DWORD) color)
    Sets the background color of a DC to a new value.
  • #define SetBkMode(hdc, mode) SetDCAttr (hdc, DC_ATTR_BK_MODE, (DWORD) mode)
    Sets the background color of a DC to a new mode.
  • #define SetPenColor(hdc, color) SetDCAttr (hdc, DC_ATTR_PEN_COLOR, (DWORD) color)
    Sets the pen color of a DC to a new value.
  • #define SetBrushColor(hdc, color) SetDCAttr (hdc, DC_ATTR_BRUSH_COLOR, (DWORD) color)
    Sets the brush color of a DC to a new value.
  • #define SetTextColor(hdc, color) SetDCAttr (hdc, DC_ATTR_TEXT_COLOR, (DWORD) color)
    Sets the text color of a DC to a new value.
  • #define SetTabStop(hdc, value) SetDCAttr (hdc, DC_ATTR_TAB_STOP, (DWORD) value)
    Sets the tabstop of a DC to a new value.

Functions

  • MG_EXPORT Uint32 GUIAPI GetDCAttr (HDC hdc, int attr)
    Gets a specified attribute value of a DC.
  • MG_EXPORT Uint32 GUIAPI SetDCAttr (HDC hdc, int attr, Uint32 value)
    Sets a specified attribute value of a DC.
  • MG_EXPORT int GUIAPI GetRasterOperation (HDC hdc)
    Gets the raster operation of a DC.
  • MG_EXPORT int GUIAPI SetRasterOperation (HDC hdc, int rop)
    Sets the raster operation of a DC to a new value.

Define Documentation

#define GetBkColor ( hdc ) GetDCAttr (hdc, DC_ATTR_BK_COLOR)

Gets the background color of a DC.

Parameters:
hdc The device context.
Returns:
The background pixel value of the DC hdc.
See also:
GetDCAttr, SetBkColor

Definition at line 2079 of file gdi.h.

#define GetBkMode ( hdc ) GetDCAttr (hdc, DC_ATTR_BK_MODE)

Gets the background mode of a DC.

Parameters:
hdc The device context.
Returns:
The background mode of the DC hdc.
Return values:
BM_TRANSPARENT | Indicate that reserve the background untouched when drawing text.
BM_OPAQUE | Indicate that erase the background with background color when drawing text.
See also:
GetDCAttr, SetBkMode

Definition at line 2096 of file gdi.h.

#define GetBrushColor ( hdc ) GetDCAttr (hdc, DC_ATTR_BRUSH_COLOR)

Gets the brush color of a DC.

Parameters:
hdc The device context.
Returns:
The brush color (pixel value) of the DC hdc.
See also:
GetDCAttr, SetBrushColor

Definition at line 2118 of file gdi.h.

#define GetPenColor ( hdc ) GetDCAttr (hdc, DC_ATTR_PEN_COLOR)

Gets the pen color of a DC.

Parameters:
hdc The device context.
Returns:
The pen color (pixel value) of the DC hdc.
See also:
GetDCAttr, SetPenColor

Definition at line 2107 of file gdi.h.

#define GetTabStop ( hdc ) GetDCAttr (hdc, DC_ATTR_TAB_STOP)

Gets the tabstop value of a DC.

Parameters:
hdc The device context.
Returns:
The tabstop value of the DC hdc.
See also:
GetDCAttr, SetTabStop

Definition at line 2140 of file gdi.h.

#define GetTextColor ( hdc ) GetDCAttr (hdc, DC_ATTR_TEXT_COLOR)

Gets the text color of a DC.

Parameters:
hdc The device context.
Returns:
The text color (pixel value) of the DC hdc.
See also:
GetDCAttr, SetTextColor

Definition at line 2129 of file gdi.h.

#define SetBkColor | ( | hdc,
 |  | color | ) | SetDCAttr (hdc, DC_ATTR_BK_COLOR, (DWORD) color)

Sets the background color of a DC to a new value.

Parameters:
hdc | The device context.
color | The new background color (pixel value).
Returns:
The old background pixel value of the DC hdc.
See also:
SetDCAttr, GetBkColor

Definition at line 2152 of file gdi.h.

#define SetBkMode | ( | hdc,
 |  | mode | ) | SetDCAttr (hdc, DC_ATTR_BK_MODE, (DWORD) mode)

Sets the background color of a DC to a new mode.

Parameters:
hdc | The device context.
mode | The new background mode, be can one of the following values:
  • BM_TRANSPARENT
    Indicate that reserve the background untouched when drawing text.
  • BM_OPAQUE
    Indicate that erase the background with background color when drawing text.

Returns:
The old background mode of the DC hdc.
See also:
SetDCAttr, GetBkMode

Definition at line 2172 of file gdi.h.

#define SetBrushColor | ( | hdc,
 |  | color | ) | SetDCAttr (hdc, DC_ATTR_BRUSH_COLOR, (DWORD) color)

Sets the brush color of a DC to a new value.

Parameters:
hdc | The device context.
color | The new brush color (pixel value).
Returns:
The old brush pixel value of the DC hdc.
See also:
SetDCAttr, GetBrushColor

Definition at line 2198 of file gdi.h.

#define SetPenColor | ( | hdc,
 |  | color | ) | SetDCAttr (hdc, DC_ATTR_PEN_COLOR, (DWORD) color)

Sets the pen color of a DC to a new value.

Parameters:
hdc | The device context.
color | The new pen color (pixel value).
Returns:
The old pen pixel value of the DC hdc.
See also:
SetDCAttr, GetPenColor

Definition at line 2185 of file gdi.h.

#define SetTabStop | ( | hdc,
 |  | value | ) | SetDCAttr (hdc, DC_ATTR_TAB_STOP, (DWORD) value)

Sets the tabstop of a DC to a new value.

Parameters:
hdc | The device context.
value | The new tabstop value in pixels.
Returns:
The old tabstop value in pixels of the DC hdc.
See also:
SetDCAttr, GetTabStop

Definition at line 2224 of file gdi.h.

#define SetTextColor | ( | hdc,
 |  | color | ) | SetDCAttr (hdc, DC_ATTR_TEXT_COLOR, (DWORD) color)

Sets the text color of a DC to a new value.

Parameters:
hdc | The device context.
color | The new text color (pixel value).
Returns:
The old text color (pixel value) of the DC hdc.
See also:
SetDCAttr, GetTextColor

Definition at line 2211 of file gdi.h.

Function Documentation

Uint32 GUIAPI GetDCAttr | ( | HDC | hdc,
 |  | int | attr
 | ) |  |

Gets a specified attribute value of a DC.

This function retrieves a specified attribute value of the DC hdc.

Parameters:
hdc | The device context.
attr | The attribute to be retrieved, can be one of the following values:
  • DC_ATTR_BK_COLOR
    Background color.
  • DC_ATTR_BK_MODE
    Background mode.
  • DC_ATTR_PEN_TYPE
    Pen type.
  • DC_ATTR_PEN_CAP_STYLE
    Cap style of pen.
  • DC_ATTR_PEN_JOIN_STYLE
    Join style of pen.
  • DC_ATTR_PEN_COLOR
    Pen color.
  • DC_ATTR_BRUSH_TYPE
    Brush type.
  • DC_ATTR_BRUSH_COLOR
    Brush color.
  • DC_ATTR_TEXT_COLOR
    Text color.
  • DC_ATTR_TAB_STOP
    Tabstop width.
  • DC_ATTR_CHAR_EXTRA
    Intercharacter spacing for the DC.
  • DC_ATTR_ALINE_EXTRA
    Spacing above line for the DC.
  • DC_ATTR_BLINE_EXTRA
    Spacing bellow line for the DC.
  • DC_ATTR_MAP_MODE
    mode of a DC.
  • DC_ATTR_TEXT_ALIGN
    Text-alignment flags of a DC.

Returns:
The attribute value.
See also:
SetDCAttr

int GUIAPI GetRasterOperation ( HDC hdc )

Gets the raster operation of a DC.

This function gets the raster operation of the DC hdc.

Parameters:
hdc The device context.
Returns:
The current raster operation of the DC hdc.
Return values:
ROP_SET | Set to the new pixel value, erase original pixel on the surface.
ROP_AND | AND'd the new pixel value with the original pixel on the surface.
ROP_OR | OR'd the new pixel value with the original pixel on the surface.
ROP_XOR | XOR'd the new pixel value with the original pixel on the surface.
ROP_COMPOSITE | call default color composition the new pixel value with the original pixel on the surface.
ROP_COMP_USER | User defined color composition operations.
See also:
SetRasterOperation, SetUserCompositionOps

Uint32 GUIAPI SetDCAttr | ( | HDC | hdc,
 |  | int | attr,
 |  | Uint32 | value
 | ) |  |

Sets a specified attribute value of a DC.

This function sets a specified attribute value of the DC hdc.

Parameters:
hdc | The device context.
attr | The attribute to be set.
value | The attribute value.
Returns:
The old attribute value.
See also:
GetDCAttr

int GUIAPI SetRasterOperation | ( | HDC | hdc,
 |  | int | rop
 | ) |  |

Sets the raster operation of a DC to a new value.

This function sets the raster operation of the DC hdc to the new value rop.

Parameters:
hdc | The device context.
rop | The new raster operation, can be one of the following values:
  • ROP_SET
    Set to the new pixel value, erase original pixel on the surface.
  • ROP_AND
    AND'd the new pixel value with the original pixel on the surface.
  • ROP_OR
    OR'd the new pixel value with the original pixel on the surface.
  • ROP_XOR
    XOR'd the new pixel value with the original pixel on the surface.
  • ROP_COMPOSITE
    call default color composition operators the new pixel value with the original pixel on the surface.
  • ROP_COMP_USER
    call user defined color composition operators the new pixel value with the original pixel on the surface.

Returns:
The old raster operation of the DC hdc.
See also:
GetRasterOperation, SetUserCompositionOps

Generated on Fri Dec 17 13:49:47 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Palette operations

Palette operations
[GDI functions]

Functions

  • MG_EXPORT BOOL GUIAPI GetPalette (HDC hdc, int start, int len, GAL_Color *cmap)
    Gets palette entries of a DC.
  • MG_EXPORT BOOL GUIAPI SetPalette (HDC hdc, int start, int len, GAL_Color *cmap)
    Sets palette entries of a DC.
  • MG_EXPORT BOOL GUIAPI SetColorfulPalette (HDC hdc)
    Sets a DC with colorfule palette.
  • MG_EXPORT HPALETTE GUIAPI CreatePalette (GAL_Palette *pal)
    Creates a logical palette.
  • MG_EXPORT BOOL GUIAPI SelectPalette (HDC hdc, HPALETTE hpal, BOOL reserved)
    Selects a palette for a DC.
  • MG_EXPORT BOOL GUIAPI RealizePalette (HDC hdc)
    This function maps palette entries from the current logical palette to the system palette.
  • MG_EXPORT BOOL GUIAPI ResizePalette (HPALETTE hpal, int len)
    Resizes a logical palette.
  • MG_EXPORT void GUIAPI DestroyPalette (HPALETTE hpal)
    Destroy a logical palette.
  • MG_EXPORT HPALETTE GUIAPI GetDefaultPalette (void)
    Gets the system default logical palette.
  • MG_EXPORT int GUIAPI GetPaletteEntries (HPALETTE hpal, int start, int len, GAL_Color *cmap)
    Gets palette entries of a logical palette.
  • MG_EXPORT int GUIAPI SetPaletteEntries (HPALETTE hpal, int start, int len, GAL_Color *cmap)
    Sets palette entries of a logical palette.
  • MG_EXPORT UINT GUIAPI GetNearestPaletteIndex (HPALETTE hpal, Uint8 red, Uint8 green, Uint8 blue)
    Gets the nearest palette index in the logical palette for a spefici color.
  • MG_EXPORT RGBCOLOR GUIAPI GetNearestColor (HDC hdc, Uint8 red, Uint8 green, Uint8 blue)
    Gets the nearest color compliant to a DC for a spefici color.

Function Documentation

HPALETTE GUIAPI CreatePalette ( GAL_Palette * pal )

Creates a logical palette.

This function creates a logical palette from a palette entry pal.

Parameters:
pal The Pointer to a GAL_Palette structure that contains information about the colors in the logical palette..
Returns:
Handle to the logical palette on success, otherwise 0.
See also:
GetPalette

void GUIAPI DestroyPalette ( HPALETTE pal )

Destroy a logical palette.

This function destroyes a logical palette pal.

Parameters:
pal The handle to the logical palette.
See also:
CreatePalette

HPALETTE GUIAPI GetDefaultPalette ( void )

Gets the system default logical palette.

Returns:
Handle to the system default logical palette on success, otherwise 0.
See also:
GetPalette

RGBCOLOR GUIAPI GetNearestColor | ( | HDC | hdc,
 |  | Uint8 | red,
 |  | Uint8 | green,
 |  | Uint8 | blue
 | ) |  |

Gets the nearest color compliant to a DC for a spefici color.

This function gets the nearest color compliant to the DC hdc for the specific color (red, green, blue).

Parameters:
hdc | The handle to the device context.
red | The red component value of the color.
green | The green component value of the color.
blue | The blue component value of the color.
Returns:
The color of the nearest color.
See also:
GetNearestPaletteIndex

UINT GUIAPI GetNearestPaletteIndex | ( | HPALETTE | hpal,
 |  | Uint8 | red,
 |  | Uint8 | green,
 |  | Uint8 | blue
 | ) |  |

Gets the nearest palette index in the logical palette for a spefici color.

This function gets the nearest palette index in the logical palette hpal for the color (red, green, blue).

Parameters:
hpal | The logical palette.
red | The red component value of the color.
green | The green component value of the color.
blue | The blue component value of the color.
Returns:
The index of palette entry in the logical palette.
See also:
GetNearestColor

int GUIAPI GetPalette | ( | HDC | hdc,
 |  | int | start,
 |  | int | len,
 |  | GAL_Color * | cmap
 | ) |  |

Gets palette entries of a DC.

This function gets some palette entries of the DC hdc.

Parameters:
hdc | The device context.
start | The start entry of palette to be retrieved.
len | The length of entries to be retrieved.
cmap | The buffer receives the palette entries.
Returns:
The number of entries retrieved from the logical palette.
See also:
SetPalette

int GUIAPI GetPaletteEntries | ( | HPALETTE | hpal,
 |  | int | start,
 |  | int | len,
 |  | GAL_Color * | cmap
 | ) |  |

Gets palette entries of a logical palette.

This function gets some palette entries of the logical palette hpal.

Parameters:
hpal | The logical palette.
start | The start entry of palette to be retrieved.
len | The length of entries to be retrieved.
cmap | The buffer receives the palette entries.
Returns:
The number of entries retrieved from the logical palette.
See also:
GetPalette

BOOL GUIAPI RealizePalette ( HDC hdc )

This function maps palette entries from the current logical palette to the system palette.

RealizePalette modifies the palette for the device associated with the specified device context.

If the device context is a display DC, the physical palette for that device is modified. RealizePalette will return FALSE if the hdc does not have a settable palette.

If the device context is a memory DC, this function will return FALSE and do nothing.

Parameters:
hdc Handle to the device context into which a logical palette has been selected.
Returns:
TRUE on success, otherwise FALSE.

BOOL GUIAPI ResizePalette | ( | HPALETTE | hpal,
 |  | int | len
 | ) |  |

Resizes a logical palette.

This function resizes a logical palette.

Parameters:
hpal | The handle to the logical palette.
len | The new size of the logical palette.
Returns:
TRUE for success, else returns FALSE.
See also:
CreatePalette

BOOL GUIAPI SelectPalette | ( | HDC | hdc,
 |  | HPALETTE | hpal,
 |  | BOOL | reserved
 | ) |  |

Selects a palette for a DC.

This function the palette hpal to be the palette of the DC hdc.

Parameters:
hdc | The device context.
hpal | Handle to the palette.
reserved | No use, reserved.
Returns:
TRUE on success, otherwise FALSE.
See also:
CreatePalette

BOOL GUIAPI SetColorfulPalette ( HDC hdc )

Sets a DC with colorfule palette.

This function sets the DC specified by hdc with colorful palette.

Parameters:
hdc The device context.
Returns:
TRUE on success, otherwise FALSE.
See also:
SetPalette

BOOL GUIAPI SetPalette | ( | HDC | hdc,
 |  | int | start,
 |  | int | len,
 |  | GAL_Color * | cmap
 | ) |  |

Sets palette entries of a DC.

This function sets some palette entries of the DC hdc.

Parameters:
hdc | The device context.
start | The start entry of palette to be set.
len | The length of entries to be set.
cmap | Pointer to the palette entries.
Returns:
TRUE on success, otherwise FALSE.
See also:
GetPalette

int GUIAPI SetPaletteEntries | ( | HPALETTE | hpal,
 |  | int | start,
 |  | int | len,
 |  | GAL_Color * | cmap
 | ) |  |

Sets palette entries of a logical palette.

This function sets some palette entries of the logical palette hpal.

Parameters:
hpal | The logical palette.
start | The start entry of palette to be set.
len | The length of entries to be set.
cmap | The buffer contains the palette entries.
Returns:
The number of entries set for the logical palette.
See also:
SetPalette

Generated on Fri Dec 17 13:49:47 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Advanced 2-Dimension graphics functions.

Advanced 2-Dimension graphics functions.
[General drawing functions]

Data Structures

  • struct _STIPPLE
  • struct _ARC

Defines

  • #define GetPenType(hdc) GetDCAttr (hdc, DC_ATTR_PEN_TYPE)
    Gets the pen type of a DC.
  • #define SetPenType(hdc, type) SetDCAttr (hdc, DC_ATTR_PEN_TYPE, (DWORD) type)
    Sets the pen type of a DC to a new type.
  • #define GetPenCapStyle(hdc) GetDCAttr (hdc, DC_ATTR_PEN_CAP_STYLE)
    Gets the pen cap style of a DC.
  • #define SetPenCapStyle(hdc, style) SetDCAttr (hdc, DC_ATTR_PEN_CAP_STYLE, (DWORD) style)
    Sets the pen type of a DC to a new type.
  • #define GetPenJoinStyle(hdc) GetDCAttr (hdc, DC_ATTR_PEN_JOIN_STYLE)
    Gets the pen join style of a DC.
  • #define SetPenJoinStyle(hdc, style) SetDCAttr (hdc, DC_ATTR_PEN_JOIN_STYLE, (DWORD) style)
    Sets the pen type of a DC to a new type.
  • #define GetPenWidth(hdc) GetDCAttr (hdc, DC_ATTR_PEN_WIDTH)
    Gets the pen width of a DC.
  • #define SetPenWidth(hdc, width) SetDCAttr (hdc, DC_ATTR_PEN_WIDTH, (DWORD) width)
    Sets the pen width of a DC to a new width.
  • #define GetBrushType(hdc) GetDCAttr (hdc, DC_ATTR_BRUSH_TYPE)
    Gets the brush type of a DC.
  • #define SetBrushType(hdc, type) SetDCAttr (hdc, DC_ATTR_BRUSH_TYPE, (DWORD) type)
    Sets the brush type of a DC to a new type.

Enumerations

  • enum PenType { PT_SOLID, PT_ON_OFF_DASH, PT_DOUBLE_DASH }
  • enum PTCapStyle { PT_CAP_BUTT, PT_CAP_ROUND, PT_CAP_PROJECTING }
  • enum PTJoinStyle { PT_JOIN_MITER, PT_JOIN_ROUND, PT_JOIN_BEVEL }
  • enum BrushType { BT_SOLID, BT_TILED, BT_STIPPLED, BT_OPAQUE_STIPPLED }

Functions

  • MG_EXPORT void GUIAPI SetPenDashes (HDC hdc, int dash_offset, const unsigned char *dash_list, int n)
    Sets the way dashed-lines are drawn.
  • MG_EXPORT void GUIAPI SetBrushInfo (HDC hdc, const BITMAP *tile, const STIPPLE *stipple)
    Set the tile or stipple with the DC.
  • MG_EXPORT void GUIAPI SetBrushOrigin (HDC hdc, int x, int y)
    Set the origin when using tiles or stipples with the DC.
  • MG_EXPORT void GUIAPI LineEx (HDC hdc, int x1, int y1, int x2, int y2)
    Draws a line with the current pen in the DC hdc.
  • MG_EXPORT void GUIAPI ArcEx (HDC hdc, int x, int y, int width, int height, int ang1, int ang2)
    Draws an arc with the current pen in a DC.
  • MG_EXPORT void GUIAPI FillArcEx (HDC hdc, int x, int y, int width, int height, int ang1, int ang2)
    Fills an arc with the current brush in a DC.
  • MG_EXPORT void GUIAPI PolyLineEx (HDC hdc, const POINT *pts, int nr_pts)
    Draws a polyline with the current pen in a DC.
  • MG_EXPORT void GUIAPI PolyArcEx (HDC hdc, const ARC *arcs, int nr_arcs)
    Draws a polyarc with the current pen in a DC.
  • MG_EXPORT void GUIAPI PolyFillArcEx (HDC hdc, const ARC *arcs, int nr_arcs)
    Fill a polyarc with the current brush in a DC.
  • MG_EXPORT BOOL GUIAPI RoundRect (HDC hdc, int x0, int y0, int x1, int y1, int cw, int ch)
    Draw and fill a rectangle with rounded corners in a DC.

Define Documentation

#define GetBrushType ( hdc ) GetDCAttr (hdc, DC_ATTR_BRUSH_TYPE)

Gets the brush type of a DC.

Parameters:
hdc The device context.
Returns:
The brush type of the DC hdc.
See also:
BrushType, GetDCAttr, SetBrushType

Definition at line 3729 of file gdi.h.

#define GetPenCapStyle ( hdc ) GetDCAttr (hdc, DC_ATTR_PEN_CAP_STYLE)

Gets the pen cap style of a DC.

Parameters:
hdc The device context.
Returns:
The pen cap style of the DC hdc.
See also:
PTCapStyle, GetDCAttr, SetPenCapStyle

Definition at line 3602 of file gdi.h.

#define GetPenJoinStyle ( hdc ) GetDCAttr (hdc, DC_ATTR_PEN_JOIN_STYLE)

Gets the pen join style of a DC.

Parameters:
hdc The device context.
Returns:
The pen join style of the DC hdc.
See also:
PTJoinStyle, GetDCAttr, SetPenJoinStyle

Definition at line 3647 of file gdi.h.

#define GetPenType ( hdc ) GetDCAttr (hdc, DC_ATTR_PEN_TYPE)

Gets the pen type of a DC.

Parameters:
hdc The device context.
Returns:
The pen type of the DC hdc.
See also:
PenType, GetDCAttr, SetPenType

Definition at line 3533 of file gdi.h.

#define GetPenWidth ( hdc ) GetDCAttr (hdc, DC_ATTR_PEN_WIDTH)

Gets the pen width of a DC.

Parameters:
hdc The device context.
Returns:
The width of the current pen in the DC hdc.
See also:
GetDCAttr, SetPenWidth

Definition at line 3671 of file gdi.h.

#define SetBrushType | ( | hdc,
 |  | type | ) | SetDCAttr (hdc, DC_ATTR_BRUSH_TYPE, (DWORD) type)

Sets the brush type of a DC to a new type.

Parameters:
hdc | The device context.
type | The new brush type.
Returns:
The old brush type of the DC hdc.
See also:
BrushType, SetDCAttr, GetBrushType

Definition at line 3742 of file gdi.h.

#define SetPenCapStyle | ( | hdc,
 |  | style | ) | SetDCAttr (hdc, DC_ATTR_PEN_CAP_STYLE, (DWORD) style)

Sets the pen type of a DC to a new type.

Parameters:
hdc | The device context.
style | The new pen cap style.
Returns:
The old pen cap style of the DC hdc.
See also:
PTCapStyle, SetDCAttr, GetPenCapStyle

Definition at line 3615 of file gdi.h.

#define SetPenJoinStyle | ( | hdc,
 |  | style | ) | SetDCAttr (hdc, DC_ATTR_PEN_JOIN_STYLE, (DWORD) style)

Sets the pen type of a DC to a new type.

Parameters:
hdc | The device context.
style | The new pen join style.
Returns:
The old pen join style of the DC hdc.
See also:
PTJoinStyle, SetDCAttr, GetPenJoinStyle

Definition at line 3659 of file gdi.h.

#define SetPenType | ( | hdc,
 |  | type | ) | SetDCAttr (hdc, DC_ATTR_PEN_TYPE, (DWORD) type)

Sets the pen type of a DC to a new type.

Parameters:
hdc | The device context.
type | The new pen type.
Returns:
The old pen type of the DC hdc.
See also:
PenType, SetDCAttr, GetPenType

Definition at line 3546 of file gdi.h.

#define SetPenWidth | ( | hdc,
 |  | width | ) | SetDCAttr (hdc, DC_ATTR_PEN_WIDTH, (DWORD) width)

Sets the pen width of a DC to a new width.

Parameters:
hdc | The device context.
width | The new pen width.
Returns:
The old pen width of the DC hdc.
See also:
SetDCAttr, GetPenWidth

Definition at line 3684 of file gdi.h.

Enumeration Type Documentation

enum BrushType

DC brush types. Solid: Tiled: Stippled: OpaqueStippled:

Enumerator:
BT_SOLID | Draw with the current brush color.
BT_TILED | Draw with a tiled bitmap.
BT_STIPPLED | Draw using the stipple bitmap. Pixels corresponding to bits in the stipple bitmap that are set will be drawn in the brush color; pixels corresponding to bits that are not set will be left untouched.
BT_OPAQUE_STIPPLED | Draw using the stipple bitmap. Pixels corresponding to bits in the stipple bitmap that are set will be drawn in the brush color; pixels corresponding to bits that are not set will be drawn with the background color.

Definition at line 3694 of file gdi.h.

enum PenType

DC Line styles

Enumerator:
PT_SOLID | The solid pen. We call the solid pen with zero wide as "zero pen".
PT_ON_OFF_DASH | The on/off dash pen, even segments are drawn; odd segments are not drawn.
PT_DOUBLE_DASH | The double dash pen, even segments are normally. Odd segments are drawn in the brush color if the brush type is BT_SOLID, or in the brush color masked by the stipple if the brush type is BT_STIPPLED.

Definition at line 3503 of file gdi.h.

enum PTCapStyle

DC Line cap styles

Enumerator:
PT_CAP_BUTT | The ends of the lines are drawn squared off and extending to the coordinates of the end point.
PT_CAP_ROUND | The ends of the lines are drawn as semicircles with the diameter equal to the line width and centered at the end point.
PT_CAP_PROJECTING | The ends of the lines are drawn squared off and extending half the width of the line beyond the end point.

Definition at line 3574 of file gdi.h.

enum PTJoinStyle

DC Line join styles

Enumerator:
PT_JOIN_MITER | The sides of each line are extended to meet at an angle.
PT_JOIN_ROUND | The sides of the two lines are joined by a circular arc.
PT_JOIN_BEVEL | The sides of the two lines are joined by a straight line which makes an equal angle with each line.

Definition at line 3621 of file gdi.h.

Function Documentation

void GUIAPI ArcEx | ( | HDC | hdc,
 |  | int | x,
 |  | int | y,
 |  | int | width,
 |  | int | height,
 |  | int | ang1,
 |  | int | ang2
 | ) |  |

Draws an arc with the current pen in a DC.

This function draws an arc with the current pen in the DC hdc. The coordinates of the upper-left corner of the bounding rectanglecenter of the arc is (x, y), the bounding box of the arc is width wide and height high, and the degree of start angle and end angle are ang1 and ang2 respectively.

Parameters:
hdc | The device context.
x | The x coordinate of the left edge of the bounding rectangle.
y | The y coordinate of the left edge of the bounding rectangle.
width | The width of the bounding box of the arc.
height | The height of the bounding box of the arc.
ang1 | The start angle of the arc, relative to the 3 o'clock position, counter-clockwise, in 1/64ths of a degree.
ang2 | The end angle of the arc, relative to angle1, in 1/64ths of a degree.
See also:
DC attribute operations

void GUIAPI FillArcEx | ( | HDC | hdc,
 |  | int | x,
 |  | int | y,
 |  | int | width,
 |  | int | height,
 |  | int | ang1,
 |  | int | ang2
 | ) |  |

Fills an arc with the current brush in a DC.

This function fills an arc with the current brush in the DC hdc. The coordinates of the upper-left corner of the bounding rectanglecenter of the arc is (x, y), the bounding box of the arc is width wide and height high, and the degree of start angle and end angle are ang1 and ang2 respectively.

Parameters:
hdc | The device context.
x | The x coordinate of the left edge of the bounding rectangle.
y | The y coordinate of the left edge of the bounding rectangle.
width | The width of the bounding box of the arc.
height | The height of the bounding box of the arc.
ang1 | The start angle of the arc, relative to the 3 o'clock position, counter-clockwise, in 1/64ths of a degree.
ang2 | The end angle of the arc, relative to angle1, in 1/64ths of a degree.
See also:
ArcEx, DC attribute operations

void GUIAPI LineEx | ( | HDC | hdc,
 |  | int | x1,
 |  | int | y1,
 |  | int | x2,
 |  | int | y2
 | ) |  |

Draws a line with the current pen in the DC hdc.

This function draws a line with the current pen in the DC hdc. The line draws from (x1, y1) to (x2, y2).

Parameters:
hdc | The device context.
x1 | x1,y1: The start point of the line.
y1 | x1,y1: The start point of the line.
x2 | x2,y2: The end point of the line.
y2 | x2,y2: The end point of the line.
Note:
This function does not change the pen position.
See also:
LineTo, DC attribute operations

void GUIAPI PolyArcEx | ( | HDC | hdc,
 |  | const ARC * | arcs,
 |  | int | nr_arcs
 | ) |  |

Draws a polyarc with the current pen in a DC.

This function draws a polyarc with the current pen in the DC hdc.

Parameters:
hdc | The device context.
arcs | The pointer to an ARC array which defines the arcs.
nr_arcs | The number of the arcs.
See also:
ArcEx

void GUIAPI PolyFillArcEx | ( | HDC | hdc,
 |  | const ARC * | arcs,
 |  | int | nr_arcs
 | ) |  |

Fill a polyarc with the current brush in a DC.

This function fill a polyarc with the current brush in the DC hdc.

Parameters:
hdc | The device context.
arcs | The pointer to an ARC array which defines the arcs.
nr_arcs | The number of the arcs.
See also:
ArcEx

void GUIAPI PolyLineEx | ( | HDC | hdc,
 |  | const POINT * | pts,
 |  | int | nr_pts
 | ) |  |

Draws a polyline with the current pen in a DC.

This function draws a polyline with the current pen in the DC hdc.

Parameters:
hdc | The device context.
pts | The pointer to the vertex array of the polyline.
nr_pts | The number of the vertices.
See also:
LineEx

BOOL GUIAPI RoundRect | ( | HDC | hdc,
 |  | int | x0,
 |  | int | y0,
 |  | int | x1,
 |  | int | y1,
 |  | int | rw,
 |  | int | rh
 | ) |  |

Draw and fill a rectangle with rounded corners in a DC.

This function draws a rectangle with rounded corners. The rectangle is outlined by using the current pen and filled by using the current brush in the DC hdc.

Parameters:
hdc | The device context.
x0 | The x-coordinate of the upper-left corner of the rectangle.
y0 | The y-coordinate of the upper-left corner of the rectangle.
x1 | The x-coordinate of the lower-right corner of the rectangle.
y1 | The y-coordinate of the lower-right corner of the rectangle.
rw | The x-radius of the rounded corners.
rh | The y-radius of the rounded corners.
Returns:
TRUE for visible, else for not.
See also:
ArcEx, LineEx, FillArcEx, FillBox

void GUIAPI SetBrushInfo | ( | HDC | hdc,
 |  | const BITMAP * | tile,
 |  | const STIPPLE * | stipple
 | ) |  |

Set the tile or stipple with the DC.

Parameters:
hdc | The device context.
tile | The tile bitmap.
stipple | The stipple bitmap.
See also:
SetBrushInfo

void GUIAPI SetBrushOrigin | ( | HDC | hdc,
 |  | int | x,
 |  | int | y
 | ) |  |

Set the origin when using tiles or stipples with the DC.

Set the origin when using tiles or stipples with the DC. The tile or stipple will be aligned such that the upper left corner of the tile or stipple will coincide with this point.

Parameters:
hdc | The device context.
x | The x-coordinate of the origin.
y | The y-coordinate of the origin.
See also:
SetBrushInfo

void SetPenDashes | ( | HDC | hdc,
 |  | int | dash_offset,
 |  | const unsigned char * | dash_list,
 |  | int | n
 | ) |  |

Sets the way dashed-lines are drawn.

Sets the way dashed-lines are drawn. Lines will be drawn with alternating on and off segments of the lengths specified in dash_list. The manner in which the on and off segments are drawn is determined by the pen type of the DC. (This can be changed with SetPenType function.)

Parameters:
hdc | The device context.
dash_offset | The offset in the dash list.
dash_list | The dash list.
n | The lenght of the dash list.
Returns:
The old pen type of the DC hdc.
See also:
SetPenType

Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _STIPPLE Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_STIPPLE Struct Reference
[Advanced 2-Dimension graphics functions.]

#include <gdi.h>

Data Fields

  • int width
  • int height
  • int pitch
  • size_t size
  • const unsigned char * bits

Detailed Description

The stipple bitmap structure.

Definition at line 3746 of file gdi.h.

Field Documentation

int width

The width of the stipple bitmap.

Definition at line 3749 of file gdi.h.

int height

The height of the stipple bitmap.

Definition at line 3751 of file gdi.h.

int pitch

The pitch of the stipple bitmap.

Definition at line 3754 of file gdi.h.

size_t size

The size of the stipple bitmap.

Definition at line 3757 of file gdi.h.

const unsigned char* bits

The pointer to the buffer of glyph bitmap bits.

Definition at line 3760 of file gdi.h.

The documentation for this struct was generated from the following file:
  • gdi.h
Generated on Fri Dec 17 13:49:52 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _ARC Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_ARC Struct Reference
[Advanced 2-Dimension graphics functions.]

#include <gdi.h>

Data Fields

  • int x
  • int y
  • int width
  • int height
  • int angle1
  • int angle2

Detailed Description

Arc structure.

Definition at line 3881 of file gdi.h.

Field Documentation

int x

The x coordinate of the left edge of the bounding rectangle.

Definition at line 3884 of file gdi.h.

int y

The y coordinate of the left edge of the bounding rectangle.

Definition at line 3886 of file gdi.h.

int width

The width of the bounding box of the arc.

Definition at line 3889 of file gdi.h.

int height

The height of the bounding box of the arc.

Definition at line 3891 of file gdi.h.

int angle1

The start angle of the arc, relative to the 3 o'clock position, counter-clockwise, in 1/64ths of a degree.

Definition at line 3897 of file gdi.h.

int angle2

The end angle of the arc, relative to angle1, in 1/64ths of a degree.

Definition at line 3901 of file gdi.h.

The documentation for this struct was generated from the following file:
  • gdi.h
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: General drawing functions

General drawing functions
[GDI functions]

Modules

  • Advanced 2-Dimension graphics functions.

Defines

  • #define DrawHDotLine(hdc, x, y, w) DrawHVDotLine (hdc, x, y, w, TRUE);
    Draws a horizontal dot dash line.
  • #define DrawVDotLine(hdc, x, y, h) DrawHVDotLine (hdc, x, y, h, FALSE);
    Draws a vertical dot line.
  • #define PolygonGenerator(context, pts, vertices, cb) PolygonGeneratorEx(context, pts, vertices, cb, NULL)
    This is a general polygon generator.

Typedefs

  • typedef void(* CB_LINE )(void *context, int stepx, int stepy)
    The type of line generator callback.
  • typedef void(* CB_CIRCLE )(void *context, int x1, int x2, int y)
    The type of circle generator callback.
  • typedef void(* CB_ELLIPSE )(void *context, int x1, int x2, int y)
    The type of ellipse generator callback.
  • typedef void(* CB_ARC )(void *context, int x, int y)
    The type of arc generator callback.
  • typedef void(* CB_POLYGON )(void *context, int x1, int x2, int y)
    The type of polygon generator callback.
  • typedef BOOL(* CB_EQUAL_PIXEL )(void *context, int x, int y)
    Flodd filling generator's equation callback.
  • typedef void(* CB_FLOOD_FILL )(void *context, int x1, int x2, int y)
    Flodd filling generator's scan line callback.

Functions

  • MG_EXPORT void GUIAPI SetPixel (HDC hdc, int x, int y, gal_pixel pixel)
    Sets the pixel with a new pixel value at the specified position on a DC.
  • MG_EXPORT gal_pixel GUIAPI SetPixelRGB (HDC hdc, int x, int y, Uint8 r, Uint8 g, Uint8 b)
    Sets the pixel by a RGB triple at the specified position on a DC.
  • MG_EXPORT gal_pixel GUIAPI SetPixelRGBA (HDC hdc, int x, int y, Uint8 r, Uint8 g, Uint8 b, Uint8 a)
    Sets the pixel by a RGBA quarter at the specified position on a DC.
  • MG_EXPORT gal_pixel GUIAPI GetPixel (HDC hdc, int x, int y)
    Gets the pixel value at the specified position on a DC.
  • MG_EXPORT gal_pixel GUIAPI GetPixelRGB (HDC hdc, int x, int y, Uint8 *r, Uint8 *g, Uint8 *b)
    Gets the pixel value at the specified position on a DC in RGB triple.
  • MG_EXPORT gal_pixel GUIAPI GetPixelRGBA (HDC hdc, int x, int y, Uint8 *r, Uint8 *g, Uint8 *b, Uint8 *a)
    Gets the pixel value at the specified position on a DC in RGBA quarter.
  • MG_EXPORT void GUIAPI RGBA2Pixels (HDC hdc, const RGB *rgbs, gal_pixel *pixels, int count)
    Gets the pixel values from a color array in RGBA quarter under a DC.
  • static gal_pixel RGBA2Pixel (HDC hdc, Uint8 r, Uint8 g, Uint8 b, Uint8 a)
    Gets the pixel value from a color in RGBA quarter under a DC.
  • MG_EXPORT void GUIAPI RGB2Pixels (HDC hdc, const RGB *rgbs, gal_pixel *pixels, int count)
    Gets the pixel values from a color array in RGB triple under a DC.
  • static gal_pixel RGB2Pixel (HDC hdc, Uint8 r, Uint8 g, Uint8 b)
    Gets the pixel value from a color in RGB triple under a DC.
  • MG_EXPORT void GUIAPI Pixel2RGBs (HDC hdc, const gal_pixel *pixels, RGB *rgbs, int count)
    Gets the colors in RGB triple from a pixel value array under a DC.
  • static void Pixel2RGB (HDC hdc, gal_pixel pixel, Uint8 *r, Uint8 *g, Uint8 *b)
    Gets the color in RGB triple from a pixel value under a DC.
  • MG_EXPORT void GUIAPI Pixel2RGBAs (HDC hdc, const gal_pixel *pixels, RGB *rgbs, int count)
    Gets the colors in RGBA quarter from a array of pixel values under a DC.
  • static void Pixel2RGBA (HDC hdc, gal_pixel pixel, Uint8 *r, Uint8 *g, Uint8 *b, Uint8 *a)
    Gets the color in RGBA quarter from a pixel value under a DC.
  • static DWORD Pixel2DWORD (HDC hdc, gal_pixel pixel)
    An inline function to convert pixel value to DWORD color.
  • static gal_pixel DWORD2PIXEL (HDC hdc, DWORD dword)
    An inline function to convert DWORD color to gal_pixel.
  • MG_EXPORT void GUIAPI FocusRect (HDC hdc, int x0, int y0, int x1, int y1)
    Draws a focus rectangle.
  • MG_EXPORT void GUIAPI DrawHVDotLine (HDC hdc, int x, int y, int w_h, BOOL H_V)
    Draws a horizontal or vertical dot dash line.
  • MG_EXPORT BOOL GUIAPI LineClipper (const RECT *cliprc, int *_x0, int *_y0, int *_x1, int *_y1)
    The line clipper using Cohen-Sutherland algorithm.
  • MG_EXPORT void GUIAPI LineGenerator (void *context, int x1, int y1, int x2, int y2, CB_LINE cb)
    A line generator based-on Breshenham algorithm.
  • MG_EXPORT void GUIAPI CircleGenerator (void *context, int sx, int sy, int r, CB_CIRCLE cb)
    A circle generator.
  • MG_EXPORT void GUIAPI EllipseGenerator (void *context, int sx, int sy, int rx, int ry, CB_ELLIPSE cb)
    An ellipse generator.
  • MG_EXPORT void GUIAPI CircleArcGenerator (void *context, int sx, int sy, int r, int ang1, int ang2, CB_ARC cb)
    An arc generator.
  • MG_EXPORT BOOL GUIAPI MonotoneVerticalPolygonGenerator (void *context, const POINT *pts, int vertices, CB_POLYGON cb)
    A monotone vertical polygon generator.
  • MG_EXPORT BOOL GUIAPI PolygonIsMonotoneVertical (const POINT *pts, int vertices)
    Checks a polygon is monotone vertical or not.
  • MG_EXPORT BOOL GUIAPI PolygonGeneratorEx (void *context, const POINT *pts, int vertices, CB_POLYGON cb, RECT *rc_output)
    A general polygon generator.
  • MG_EXPORT BOOL GUIAPI FloodFillGenerator (void *context, const RECT *src_rc, int x, int y, CB_EQUAL_PIXEL cb_equal_pixel, CB_FLOOD_FILL cb_flood_fill)
    A flood filling generator.
  • MG_EXPORT int GUIAPI SetBitmapScalerType (HDC hdc, int scaler_type)
    set bitmap scaler algorithm callback of DC according by scaler_type.
  • MG_EXPORT void GUIAPI MoveTo (HDC hdc, int x, int y)
    Moves the current zero pen position.
  • MG_EXPORT void GUIAPI LineTo (HDC hdc, int x, int y)
    Draws a zero line to a position.
  • MG_EXPORT void GUIAPI Rectangle (HDC hdc, int x0, int y0, int x1, int y1)
    Draws a rectangle.
  • MG_EXPORT void GUIAPI PolyLineTo (HDC hdc, const POINT *pts, int vertices)
    Draws a polyline.
  • MG_EXPORT void GUIAPI SplineTo (HDC hdc, const POINT *pts)
    Draws a bezier spline.
  • MG_EXPORT void GUIAPI Circle (HDC hdc, int sx, int sy, int r)
    Draws a circle.
  • MG_EXPORT void GUIAPI Ellipse (HDC hdc, int sx, int sy, int rx, int ry)
    Draws a ellipse.
  • MG_EXPORT void GUIAPI CircleArc (HDC hdc, int sx, int sy, int r, int ang1, int ang2)
    Draws an arc.
  • MG_EXPORT void GUIAPI FillBox (HDC hdc, int x, int y, int w, int h)
    Fills a rectangle box.
  • MG_EXPORT void GUIAPI FillCircle (HDC hdc, int sx, int sy, int r)
    Fills a circle.
  • MG_EXPORT void GUIAPI FillEllipse (HDC hdc, int sx, int sy, int rx, int ry)
    Fills an ellipse.
  • MG_EXPORT BOOL GUIAPI FillPolygon (HDC hdc, const POINT *pts, int vertices)
    Fills an polygon.
  • MG_EXPORT BOOL GUIAPI FloodFill (HDC hdc, int x, int y)
    Fills an enclosed area starting at point (x,y).

Define Documentation

#define DrawHDotLine | ( | hdc,
 |  | x,
 |  | y,
 |  | w | ) | DrawHVDotLine (hdc, x, y, w, TRUE);

Draws a horizontal dot dash line.

This function draws a horizontal dot dash line with the zero pen.

Parameters:
hdc | The device context.
x | x,y: The start point of the line.
y | x,y: The start point of the line.
w | The width of the horizontal dot line.
Note:
Defined as a macro calling DrawHVDotLine.
See also:
DrawVDotLine, DrawHVDotLine

Definition at line 2926 of file gdi.h.

#define DrawVDotLine | ( | hdc,
 |  | x,
 |  | y,
 |  | h | ) | DrawHVDotLine (hdc, x, y, h, FALSE);

Draws a vertical dot line.

This function draws a vertical dot dash line with the zero pen.

Parameters:
hdc | The device context.
x | x,y: The start point of the line.
y | x,y: The start point of the line.
h | The height of the horizontal dot line.
Note:
Defined as a macro calling DrawHVDotLine.
See also:
DrawHDotLine, DrawHVDotLine

Definition at line 2944 of file gdi.h.

#define PolygonGenerator | ( | context,
 |  | pts,
 |  | vertices,
 |  | cb | ) | PolygonGeneratorEx(context, pts, vertices, cb, NULL)

This is a general polygon generator.

Defined as a macro calling PolygonGeneratorEx passing and rc_output as NULL.

See also:
PolygonGeneratorEx

Definition at line 3214 of file gdi.h.

Typedef Documentation

typedef void(* CB_ARC)(void *context, int x, int y)

The type of arc generator callback.

Definition at line 3082 of file gdi.h.

typedef void(* CB_CIRCLE)(void *context, int x1, int x2, int y)

The type of circle generator callback.

Definition at line 3013 of file gdi.h.

typedef void(* CB_ELLIPSE)(void *context, int x1, int x2, int y)

The type of ellipse generator callback.

Definition at line 3049 of file gdi.h.

typedef BOOL(* CB_EQUAL_PIXEL)(void *context, int x, int y)

Flodd filling generator's equation callback.

Definition at line 3221 of file gdi.h.

typedef void(* CB_FLOOD_FILL)(void *context, int x1, int x2, int y)

Flodd filling generator's scan line callback.

Definition at line 3227 of file gdi.h.

typedef void(* CB_LINE)(void *context, int stepx, int stepy)

The type of line generator callback.

Definition at line 2982 of file gdi.h.

typedef void(* CB_POLYGON)(void *context, int x1, int x2, int y)

The type of polygon generator callback.

Definition at line 3114 of file gdi.h.

Function Documentation

void GUIAPI Circle | ( | HDC | hdc,
 |  | int | sx,
 |  | int | sy,
 |  | int | r
 | ) |  |

Draws a circle.

This function draws a circle with the zero pen on the DC hdc. The center of the circle is at (sx, sy), and the radius is r.

Parameters:
hdc | The device context.
sx | sx,sy: The center of the circle.
sy | sx,sy: The center of the circle.
r | The radius of the circle.
See also:
CircleGenerator

void GUIAPI CircleArc | ( | HDC | hdc,
 |  | int | sx,
 |  | int | sy,
 |  | int | r,
 |  | int | ang1,
 |  | int | ang2
 | ) |  |

Draws an arc.

This function draws an arc with the zero pen on the DC hdc. The center of the arc is at (sx, sy), the radius is r, and the radians of start angle and end angle are ang1 and ang2 respectively.

Parameters:
hdc | The device context.
sx | sx,sy: The center of the arc.
sy | sx,sy: The center of the arc.
r | The radius of the arc.
ang1 | The start angle of the arc, relative to the 3 o'clock position, counter-clockwise, in 1/64ths of a degree.
ang2 | The end angle of the arc, relative to angle1, in 1/64ths of a degree.
See also:
CircleArcGenerator, Fixed point math functions, DC attribute operations

void GUIAPI CircleArcGenerator | ( | void * | context,
 |  | int | sx,
 |  | int | sy,
 |  | int | r,
 |  | int | ang1,
 |  | int | ang2,
 |  | CB_ARC | cb
 | ) |  |

An arc generator.

This is a general arc generator. When it generates a point on the arc, it will call the callback cb and pass the context context, the coordinates of the point.

MiniGUI implements CircleArc function by using this generator.

Parameters:
context | The context, will be passed to the callback cb.
sx | sx,sy: The center of the arc.
sy | sx,sy: The center of the arc.
r | The radius of the arc.
ang1 | The start angle of the arc, relative to the 3 o'clock position, counter-clockwise, in 1/64ths of a degree.
ang2 | The end angle of the arc, relative to angle1, in 1/64ths of a degree.
cb | The arc generator callback.
See also:
CircleArc, CB_ARC

void GUIAPI CircleGenerator | ( | void * | context,
 |  | int | sx,
 |  | int | sy,
 |  | int | r,
 |  | CB_CIRCLE | cb
 | ) |  |

A circle generator.

This is a general circle generator, it will generate two points on the same horizontal scan line at every turn. When it generates the points on the circle, it will call the callback cb and pass the context context, the y-coordinate of the scan line, the x-coordinate of the left point on the scan line, and the x-coordinate of the right point. Note that in some cases, the left point and the right point will be the same.

MiniGUI implements Circle, FillCircle and InitCircleRegion functions by using this generator.

Parameters:
context | The context, will be passed to the callback cb.
sx | sx,sy: The center of the circle.
sy | sx,sy: The center of the circle.
r | The radius of the circle.
cb | The circle generator callback.
See also:
Circle, FillCircle, InitCircleRegion, CB_CIRCLE
Example:

/*
 * Draw a circle which is 4 pixels wide by using CircleGenerator.
 */
static void draw_circle_pixel (void* context, int x1, int x2, int y)
{
    HDC hdc = (HDC) context;

    FillCircle (hdc, x1, y, 2);
    FillCircle (hdc, x2, y, 2);
}

void DrawMyCircle (HDC hdc, int x, int y, int r, gal_pixel pixel)
{
    gal_pixel old_brush;

    old_bursh = SetBrushColor (hdc, pixle);

    CircleGenerator ((void*)hdc, x, y, r, draw_circle_pixel);

    SetBrushColor (hdc, old_brush);
}

void GUIAPI DrawHVDotLine | ( | HDC | hdc,
 |  | int | x,
 |  | int | y,
 |  | int | w_h,
 |  | BOOL | H_V
 | ) |  |

Draws a horizontal or vertical dot dash line.

This function draws a horizontal or vertical dot dash line with the zero pen.

Parameters:
hdc | The device context.
x | x,y: The start point of the line.
y | x,y: The start point of the line.
w_h | The width of the line or horizontal dot line, or the height if you want to draw a vertical dot line.
H_V | Specify whether you want to draw a horizontal or vertical line. TRUE for horizontal, FALSE for vertical.
See also:
FocusRect

gal_pixel DWORD2PIXEL | ( | HDC | hdc,
 |  | DWORD | dword |
 | ) |  |  | [inline, static]

An inline function to convert DWORD color to gal_pixel.

This function converts a color in DWORD to pixel value.

Parameters:
hdc | The device context.
dword | The color value in DWORD.
Returns:
The converted pixel value.

Definition at line 2865 of file gdi.h.

References GetAValue, GetBValue, GetGValue, GetRValue, and RGBA2Pixel().

void GUIAPI Ellipse | ( | HDC | hdc,
 |  | int | sx,
 |  | int | sy,
 |  | int | rx,
 |  | int | ry
 | ) |  |

Draws a ellipse.

This function draws an ellipse with the zero pen on the DC hdc. The center of the ellipse is at (sx, sy), the x-coordinate radius is rx, and the y-coordinate radius is ry.

Parameters:
hdc | The device context.
sx | sx,sy: The center of the ellipse.
sy | sx,sy: The center of the ellipse.
rx | The x-coordinate radius of the ellipse.
ry | The y-coordinate radius of the ellipse.
See also:
EllipseGenerator, DC attribute operations

void GUIAPI EllipseGenerator | ( | void * | context,
 |  | int | sx,
 |  | int | sy,
 |  | int | rx,
 |  | int | ry,
 |  | CB_ELLIPSE | cb
 | ) |  |

An ellipse generator.

This is a general ellipse generator, it will generate two points on the same horizontal scan line at every turn. When it generates the points on the ellipse, it will call the callback cb and pass the context context, the y-coordinate of the scan line, the x-coordinate of the left point on the scan line, and the x-coordinate of the right point. Note that in some cases, the left point and the right point will be the same.

MiniGUI implements Ellipse, FillEllipse, and InitEllipseRegion functions by using this generator.

Parameters:
context | The context, will be passed to the callback cb.
sx | sx,sy: The center of the ellipse.
sy | sx,sy: The center of the ellipse.
rx | The x-radius of the ellipse.
ry | The y-radius of the ellipse.
cb | The ellipse generator callback.
See also:
Ellipse, FillEllipse, InitEllipseRegion, CB_CIRCLE

void GUIAPI FillBox | ( | HDC | hdc,
 |  | int | x,
 |  | int | y,
 |  | int | w,
 |  | int | h
 | ) |  |

Fills a rectangle box.

This function fills a box with the current brush in the DC hdc.

Parameters:
hdc | The device context.
x | x,y: The coorinates of the upper-left corner of the box.
y | x,y: The coorinates of the upper-left corner of the box.
w | The width of the box.
h | The height of the box.
See also:
DC attribute operations

void GUIAPI FillCircle | ( | HDC | hdc,
 |  | int | sx,
 |  | int | sy,
 |  | int | r
 | ) |  |

Fills a circle.

This function fills a circle with the current brush in the DC hdc.

Parameters:
hdc | The device context.
sx | sx,sy: The center of the circle.
sy | sx,sy: The center of the circle.
r | The radius of the circle.
See also:
CircleGenerator, DC attribute operations

void GUIAPI FillEllipse | ( | HDC | hdc,
 |  | int | sx,
 |  | int | sy,
 |  | int | rx,
 |  | int | ry
 | ) |  |

Fills an ellipse.

This function fills an ellipse with the current brush in the DC hdc. Note that MiniGUI only defined the color property for the brush objects so far.

Parameters:
hdc | The device context.
sx | sx,sy: The center of the circle.
sy | sx,sy: The center of the circle.
rx | The x-coordinate radius of the ellipse.
ry | The y-coordinate radius of the ellipse.
See also:
EllipseGenerator, DC attribute operations

BOOL GUIAPI FillPolygon | ( | HDC | hdc,
 |  | const POINT * | pts,
 |  | int | vertices
 | ) |  |

Fills an polygon.

This function fills a polygon with the current brush in the DC hdc.

Parameters:
hdc | The device context.
pts | The pointer to the vertex array of the polygon.
vertices | The number of the vertices, i.e. the size of the vertex array.
See also:
PolygonGenerator, DC attribute operations

BOOL GUIAPI FloodFill | ( | HDC | hdc,
 |  | int | x,
 |  | int | y
 | ) |  |

Fills an enclosed area starting at point (x,y).

This function fills an enclosed area staring at point (x,y), and stops when encountering a pixel different from the start point.

Parameters:
hdc | The device context.
x | x,y: The start point.
y | x,y: The start point.
See also:
FloodFillGenerator, DC attribute operations

BOOL GUIAPI FloodFillGenerator | ( | void * | context,
 |  | const RECT * | src_rc,
 |  | int | x,
 |  | int | y,
 |  | CB_EQUAL_PIXEL | cb_equal_pixel,
 |  | CB_FLOOD_FILL | cb_flood_fill
 | ) |  |

A flood filling generator.

This function is a general flood filling generator.

MiniGUI implements FloodFill function by using this generator.

Parameters:
context | The context, will be passed to the callback cb.
src_rc | The filling bounding rectangle.
x | x,y: The start filling point.
y | x,y: The start filling point.
cb_equal_pixel | The callback to check the pixel is equal with the start point or not.
cb_flood_fill | The callback to fill a scan line.
See also:
FloodFill, CB_EQUAL_PIXEL, CB_FLOOD_FILL

void GUIAPI FocusRect | ( | HDC | hdc,
 |  | int | x0,
 |  | int | y0,
 |  | int | x1,
 |  | int | y1
 | ) |  |

Draws a focus rectangle.

This function uses XOR mode to draw the focus rectangle on the device context, i.e. calling this function then calling this function with same arguments again will erase the focus rectangle and restore the pixels before the first call.

Parameters:
hdc | The device context.
x0 | x0,y0: The coordinates of upper-left corner of the rectangle.
y0 | x0,y0: The coordinates of upper-left corner of the rectangle.
x1 | x1,y1: The corrdinates of lower-right corner of the rectangle.
y1 | x1,y1: The corrdinates of lower-right corner of the rectangle.
See also:
DrawHVDotLine

gal_pixel GUIAPI GetPixel | ( | HDC | hdc,
 |  | int | x,
 |  | int | y
 | ) |  |

Gets the pixel value at the specified position on a DC.

This function gets the pixel value at the specified position (x,y) on the DC hdc.

Parameters:
hdc | The device context.
x | x,y: The pixel position.
y | x,y: The pixel position.
Returns:
The pixel value.
See also:
SetPixel

gal_pixel GUIAPI GetPixelRGB | ( | HDC | hdc,
 |  | int | x,
 |  | int | y,
 |  | Uint8 * | r,
 |  | Uint8 * | g,
 |  | Uint8 * | b
 | ) |  |

Gets the pixel value at the specified position on a DC in RGB triple.

This function gets the pixel value at the specified position (x,y) on the DC hdc in RGB triple.

Parameters:
hdc | The device context.
x | x,y: The pixel position.
y | x,y: The pixel position.
r | The red component of the pixel will be returned through this pointer.
g | The green component of the pixel will be returned through this pointer.
b | The blue component of the pixel will be returned through this pointer.
Returns:
The pixel value.
See also:
SetPixelRGB

gal_pixel GUIAPI GetPixelRGBA | ( | HDC | hdc,
 |  | int | x,
 |  | int | y,
 |  | Uint8 * | r,
 |  | Uint8 * | g,
 |  | Uint8 * | b,
 |  | Uint8 * | a
 | ) |  |

Gets the pixel value at the specified position on a DC in RGBA quarter.

This function gets the pixel value at the specified position (x,y) on the DC hdc in RGBA quarter.

Parameters:
hdc | The device context.
x | x,y: The pixel position.
y | x,y: The pixel position.
r | The red component of the pixel will be returned through this pointers.
g | The green component of the pixel will be returned through this pointers.
b | The blue component of the pixel will be returned through this pointers.
a | The alpha component of the pixel will be returned through this pointers.
Returns:
The pixel value.
See also:
SetPixelRGBA

BOOL GUIAPI LineClipper | ( | const RECT * | cliprc,
 |  | int * | _x0,
 |  | int * | _y0,
 |  | int * | _x1,
 |  | int * | _y1
 | ) |  |

The line clipper using Cohen-Sutherland algorithm.

This function clips a line from (*_x0,*_y0) to (*_x1, *_y1) with the specified clipping rectangle pointed to by cliprc. Then return the clipped line throught the pointers (_x0, _y0, _x1, _y1).

It is modified to do pixel-perfect clipping. This means that it will generate the same endpoints that would be drawn if an ordinary Bresenham line-drawer where used and only visible pixels drawn.

Parameters:
cliprc | The Pointer to the clipping rectangle.
_x0 | _x0,_y0: The pointers contains the start point of the line. The start point after clipping will be returned through them as well as.
_y0 | _x0,_y0: The pointers contains the start point of the line. The start point after clipping will be returned through them as well as.
_x1 | _x1,_y1: The pointers contains the end point of the line. The end point after clipping will be returned through them as well as.
_y1 | _x1,_y1: The pointers contains the end point of the line. The end point after clipping will be returned through them as well as.
Returns:
TRUE for clipped by the clipping rectangle, FALSE for not clipped.
See also:
LineGenerator

void GUIAPI LineGenerator | ( | void * | context,
 |  | int | x1,
 |  | int | y1,
 |  | int | x2,
 |  | int | y2,
 |  | CB_LINE | cb
 | ) |  |

A line generator based-on Breshenham algorithm.

This is a Breshenham line generator. When it generates a new point on the line, it will call the callback cb and pass the context context and the step values on x-coordinate and y-coodinate since the last point. The first generated point always be the start point you passed to this function. Thus, the first step values passed to cb will be (0,0).

MiniGUI implements LineTo function by using this generator.

Parameters:
context | The context, will be passed to the callback cb.
x1 | x1,y1: The start point of the line.
y1 | x1,y1: The start point of the line.
x2 | x2,y2: The end point of the line.
y2 | x2,y2: The end point of the line.
cb | The line generator callback.
See also:
LineTo, LineClipper, CB_LINE

void GUIAPI LineTo | ( | HDC | hdc,
 |  | int | x,
 |  | int | y
 | ) |  |

Draws a zero line to a position.

This function draws a line from the current zero pen position to (x,y), and then moves the zero pen position to (x,y) by using the zero pen. The next zero line drawing operation will start from the position.

Parameters:
hdc | The device context.
x | x,y: The end point of the line.
y | x,y: The end point of the line.
See also:
MoveTo, LineGenerator, DC attribute operations

BOOL GUIAPI MonotoneVerticalPolygonGenerator | ( | void * | context,
 |  | const POINT * | pts,
 |  | int | vertices,
 |  | CB_POLYGON | cb
 | ) |  |

A monotone vertical polygon generator.

This is a monotone vertical polygon generator.

"Monoton vertical" means "monotone with respect to a vertical line"; that is, every horizontal line drawn through the polygon at any point would cross exactly two active edges (neither horizontal lines nor zero-length edges count as active edges; both are acceptable anywhere in the polygon). Right & left edges may cross (polygons may be nonsimple). Polygons that are not convex according to this definition won't be drawn properly.

You can call PolygonIsMonotoneVertical function to check one polygon is monotone vertical or not.

This function will generate two points on the same horizontal scan line at every turn. When it generates the points on the polygon, it will call the callback cb and pass the context context, the y-coordinate of the scan line, the x-coordinate of the left point on the scan line, and the x-coordinate of the right point. Note that in some cases, the left point and the right point will be the same.

MiniGUI implements FillPolygon and InitPolygonRegion functions by using this generator.

Parameters:
context | The context, will be passed to the callback cb.
pts | The pointer to the vertex array of the polygon.
vertices | The number of the vertices, i.e. the size of the vertex array.
cb | The polygon generator callback.
Returns:
TRUE on success, FALSE on error.
See also:
FillPolygon, InitPolygonRegion, PolygonIsMonotoneVertical, CB_CIRCLE

void GUIAPI MoveTo | ( | HDC | hdc,
 |  | int | x,
 |  | int | y
 | ) |  |

Moves the current zero pen position.

This function moves the current pen position of the DC hdc to (x,y). The next line or other pen drawing operation will start from the position.

Parameters:
hdc | The device context.
x | x,y: The new pen position.
y | x,y: The new pen position.
See also:
LineTo

DWORD GUIAPI Pixel2DWORD | ( | HDC | hdc,
 |  | gal_pixel | pixel |
 | ) |  |  | [inline, static]

An inline function to convert pixel value to DWORD color.

This function converts a pixel value to color in DWORD.

Parameters:
hdc | The device context.
pixel | The pixel value to be converted.
Returns:
The converted color value in DWORD.

Definition at line 2846 of file gdi.h.

References MakeRGBA, and Pixel2RGBA().

void GUIAPI Pixel2RGB | ( | HDC | hdc,
 |  | gal_pixel | pixel,
 |  | Uint8 * | r,
 |  | Uint8 * | g,
 |  | Uint8 * | b |
 | ) |  |  | [inline, static]

Gets the color in RGB triple from a pixel value under a DC.

This function gets the color in RGB triple from the pixel value pixel under the DC hdc.

Parameters:
hdc | The device context.
pixel | The pixel value.
r | The red component of the pixel will be returned through this pointer.
g | The green component of the pixel will be returned through this pointer.
b | The blue component of the pixel will be returned through this pointer.
Note:
This function is implemented as an inline to RGB2Pixels.
See also:
Pixel2RGBs, RGB2Pixel

Definition at line 2780 of file gdi.h.

References _RGB::b, _RGB::g, Pixel2RGBs(), and _RGB::r.

void GUIAPI Pixel2RGBA | ( | HDC | hdc,
 |  | gal_pixel | pixel,
 |  | Uint8 * | r,
 |  | Uint8 * | g,
 |  | Uint8 * | b,
 |  | Uint8 * | a |
 | ) |  |  | [inline, static]

Gets the color in RGBA quarter from a pixel value under a DC.

This function gets the color in RGBA quarter from the pixel value pixel under the DC hdc.

Parameters:
hdc | The device context.
pixel | The pixel value.
r | The red component of the pixel will be returned through this pointer.
g | The green component of the pixel will be returned through this pointer.
b | The blue component of the pixel will be returned through this pointer.
a | The alpha component of the pixel will be returned through this pointer.
Note:
This function is implemented as an inline to RGBA2Pixels.
See also:
RGBA2Pixels, RGB2Pixel

Definition at line 2828 of file gdi.h.

References _RGB::a, _RGB::b, _RGB::g, Pixel2RGBAs(), and _RGB::r.

Referenced by Pixel2DWORD().

void GUIAPI Pixel2RGBAs | ( | HDC | hdc,
 |  | const gal_pixel * | pixels,
 |  | RGB * | rgbs,
 |  | int | count
 | ) |  |

Gets the colors in RGBA quarter from a array of pixel values under a DC.

This function gets the colors in RGBA quarter from the pixel value array pixels under the DC hdc.

Parameters:
hdc | The device context.
pixels | The array of pixel values.
rgbs | The array returns the converted RGB quarters.
count | The number of pixels.
See also:
RGB2Pixels

Referenced by Pixel2RGBA().

void GUIAPI Pixel2RGBs | ( | HDC | hdc,
 |  | const gal_pixel * | pixels,
 |  | RGB * | rgbs,
 |  | int | count
 | ) |  |

Gets the colors in RGB triple from a pixel value array under a DC.

This function gets the colors in RGB triple from the pixel value array pixels under the DC hdc.

Parameters:
hdc | The device context.
pixels | The array of pixel values.
rgbs | The array returns the converted RGB triples.
count | The number of pixels.
See also:
RGB2Pixels

Referenced by Pixel2RGB().

BOOL GUIAPI PolygonGeneratorEx | ( | void * | context,
 |  | const POINT * | pts,
 |  | int | vertices,
 |  | CB_POLYGON | cb,
 |  | RECT * | rc_output
 | ) |  |

A general polygon generator.

This is a general polygon generator.

This function will generate two points on the same horizontal scan line at every turn. When it generates the points on the polygon, it will call the callback cb and pass the context context, the y-coordinate of the scan line, the x-coordinate of the left point on the scan line, and the x-coordinate of the right point. Note that in some cases, the left point and the right point will be the same.

MiniGUI implements FillPolygon and InitPolygonRegion functions by using this generator.

Parameters:
context | The context, will be passed to the callback cb.
pts | The pointer to the vertex array of the polygon.
vertices | The number of the vertices, i.e. the size of the vertex array.
cb | The polygon generator callback.
rc_output | The limit RECT for Polygon ScanLines ranges .
See also:
FillPolygon, InitPolygonRegion, CB_CIRCLE

BOOL GUIAPI PolygonIsMonotoneVertical | ( | const POINT * | pts,
 |  | int | vertices
 | ) |  |

Checks a polygon is monotone vertical or not.

This function checks if the given polygon is monotone vertical.

Parameters:
pts | The pointer to the vertex array of the polygon.
vertices | The number of the vertices, i.e. the size of the vertex array.
Returns:
TRUE if it is monotonoe vertical, otherwise FALSE.
Note:
To make sure a polygon is monotone vertical, the polygon must be a closed one, that is, the pts[0] must be equal to the pts[vertices-1].
See also:
MonotoneVerticalPolygonGenerator

void GUIAPI PolyLineTo | ( | HDC | hdc,
 |  | const POINT * | pts,
 |  | int | vertices
 | ) |  |

Draws a polyline.

This function draws a polyline by using MoveTo and LineTo. The current zero pen position after calling this function will be the last vertex of the polyline.

Parameters:
hdc | The device context.
pts | The pointer to the vertex array of the polyline.
vertices | The number of the vertices.
See also:
MoveTo, LineTo

void GUIAPI Rectangle | ( | HDC | hdc,
 |  | int | x0,
 |  | int | y0,
 |  | int | x1,
 |  | int | y1
 | ) |  |

Draws a rectangle.

This function draws a rectangle by using MoveTo and LineTo. The current zero pen position after calling this function will be (x1,y1).

Parameters:
hdc | The device context.
x0 | x0,y0: The coordinates of the upper-left corner of the rectangle.
y0 | x0,y0: The coordinates of the upper-left corner of the rectangle.
x1 | x1,y1: The coordinates of the lower-right corner of the rectangle.
y1 | x1,y1: The coordinates of the lower-right corner of the rectangle.
See also:
MoveTo, LineTo

gal_pixel GUIAPI RGB2Pixel | ( | HDC | hdc,
 |  | Uint8 | r,
 |  | Uint8 | g,
 |  | Uint8 | b |
 | ) |  |  | [inline, static]

Gets the pixel value from a color in RGB triple under a DC.

This function gets the pixel value from the RGB triple (r,g,b) under the DC hdc.

Parameters:
hdc | The device context.
r | The red component of a color.
g | The green component of a color.
b | The blue component of a color.
Returns:
The pixel value.
Note:
This function is implemented as an inline to RGB2Pixels.
See also:
RGB2Pixels, Pixel2RGB

Definition at line 2733 of file gdi.h.

References RGB2Pixels().

void GUIAPI RGB2Pixels | ( | HDC | hdc,
 |  | const RGB * | rgbs,
 |  | gal_pixel * | pixels,
 |  | int | count
 | ) |  |

Gets the pixel values from a color array in RGB triple under a DC.

This function gets the pixel values from the RGB triple array rgbs under the DC hdc.

Parameters:
hdc | The device context.
rgbs | The array of RGB triples to be converted.
pixels | The array returns the converted pixel values.
count | The number of RGB triples.
See also:
Pixel2RGBs

Referenced by RGB2Pixel().

gal_pixel GUIAPI RGBA2Pixel | ( | HDC | hdc,
 |  | Uint8 | r,
 |  | Uint8 | g,
 |  | Uint8 | b,
 |  | Uint8 | a |
 | ) |  |  | [inline, static]

Gets the pixel value from a color in RGBA quarter under a DC.

This function gets the pixel value from the RGB quarter (r,g,b,a) under the DC hdc.

Parameters:
hdc | The device context.
r | The red component of a color.
g | The green component of a color.
b | The blue component of a color.
a | The alpha component of a color.
Returns:
The pixel value.
Note:
This function is implemented as an inline to RGBA2Pixels.
See also:
RGBA2Pixels, Pixel2RGBA

Definition at line 2689 of file gdi.h.

References RGBA2Pixels().

Referenced by DWORD2PIXEL().

void GUIAPI RGBA2Pixels | ( | HDC | hdc,
 |  | const RGB * | rgbs,
 |  | gal_pixel * | pixels,
 |  | int | count
 | ) |  |

Gets the pixel values from a color array in RGBA quarter under a DC.

This function gets the pixel values from the RGB quarter array rgbs under the DC hdc.

Parameters:
hdc | The device context.
rgbs | The array of RGBA quarters to be converted.
pixels | The array returns the converted pixel values.
count | The number of RGBA quarters.
See also:
Pixel2RGBAs

Referenced by RGBA2Pixel().

int GUIAPI SetBitmapScalerType | ( | HDC | hdc,
 |  | int | scaler_type
 | ) |  |

set bitmap scaler algorithm callback of DC according by scaler_type.

This function is a set general bitmap scaler type that is DDA or Bilinear interpolation algorithm. MiniGUI implements StretchBlt functions by using this scaler.

Parameters:
hdc | The device context.
scaler_type | The type of scaler algorithm, BITMAP_SCALER_DDA or BITMAP_SCALER_BILINEAR.
See also:
BitmapDDAScaler, BitmapBinearScaler

void GUIAPI SetPixel | ( | HDC | hdc,
 |  | int | x,
 |  | int | y,
 |  | gal_pixel | pixel
 | ) |  |

Sets the pixel with a new pixel value at the specified position on a DC.

This function sets the pixel with a pixel value pixel at the specified position (x,y) on the DC hdc. You can the pre-defined standard system pixel values.

Parameters:
hdc | The device context.
x | x,y: The pixel position.
y | x,y: The pixel position.
pixel | The pixel value.
See also:
GetPixel, System colors and pixel values.

gal_pixel GUIAPI SetPixelRGB | ( | HDC | hdc,
 |  | int | x,
 |  | int | y,
 |  | Uint8 | r,
 |  | Uint8 | g,
 |  | Uint8 | b
 | ) |  |

Sets the pixel by a RGB triple at the specified position on a DC.

This function sets the pixel with a RGB triple (r,g,b) at the specified position (x,y) on the DC hdc.

Parameters:
hdc | The device context.
x | x,y: The pixel position.
y | x,y: The pixel position.
r | The red component of a color.
g | The green component of a color.
b | The blue component of a color.
Returns:
The pixel value of the RGB triple.
See also:
GetPixel, RGB2Pixel

gal_pixel GUIAPI SetPixelRGBA | ( | HDC | hdc,
 |  | int | x,
 |  | int | y,
 |  | Uint8 | r,
 |  | Uint8 | g,
 |  | Uint8 | b,
 |  | Uint8 | a
 | ) |  |

Sets the pixel by a RGBA quarter at the specified position on a DC.

This function sets the pixel with a RGBA quarter (r,g,b,a) at the specified position (x,y) on the DC hdc.

Parameters:
hdc | The device context.
x | x,y: The pixel position.
y | x,y: The pixel position.
r | The red component of a color.
g | The green component of a color.
b | The blue component of a color.
a | The alpha component of a color.
Returns:
The pixel value of the RGBA quarter.
See also:
GetPixel, RGBA2Pixel

void GUIAPI SplineTo | ( | HDC | hdc,
 |  | const POINT * | pts
 | ) |  |

Draws a bezier spline.

This function draws a bezier spline by using MoveTo and LineTo. The current pen position after calling this function will be the last control point of the spline. Note that the number of the control points should always be 4.

Parameters:
hdc | The device context.
pts | The pointer to the control point array of the spline.
See also:
MoveTo, LineTo

Generated on Fri Dec 17 13:49:47 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Mapping Operations

Mapping Operations
[GDI functions]

Defines

  • #define GetMapMode(hdc) GetDCAttr (hdc, DC_ATTR_MAP_MODE)
    Retrieves the current mapping mode of a DC.
  • #define SetMapMode(hdc, mapmode) SetDCAttr (hdc, DC_ATTR_MAP_MODE, (DWORD)mapmode)
    Sets the mapping mode of a display context.
  • #define GetViewportOrg(hdc, pPt) GetDCLCS(hdc, DC_LCS_VORG, pPt)
    Retrieves the x-coordinates and y-coordinates of the viewport origin for a device context.
  • #define GetViewportExt(hdc, pPt) GetDCLCS(hdc, DC_LCS_VEXT, pPt)
    Retrieves the x-extents and y-extents of the current viewport for a device context.
  • #define GetWindowOrg(hdc, pPt) GetDCLCS(hdc, DC_LCS_WORG, pPt)
    Retrieves the x-coordinates and y-coordinates of the window for a device context.
  • #define GetWindowExt(hdc, pPt) GetDCLCS(hdc, DC_LCS_WEXT, pPt)
    Retrieves the x-extents and y-extents of the current window for a device context.
  • #define SetViewportOrg(hdc, pPt) SetDCLCS(hdc, DC_LCS_VORG, pPt)
    Sets the x-coordinates and y-coordinates of the viewport origin for a device context.
  • #define SetViewportExt(hdc, pPt) SetDCLCS(hdc, DC_LCS_VEXT, pPt)
    Sets the x-extents and y-extents of the current viewport for a device context.
  • #define SetWindowOrg(hdc, pPt) SetDCLCS(hdc, DC_LCS_WORG, pPt)
    Sets the x-coordinates and y-coordinates of the window for a device context.
  • #define SetWindowExt(hdc, pPt) SetDCLCS(hdc, DC_LCS_WEXT, pPt)
    Sets the x-extents and y-extents of the current window for a device context.

Functions

  • MG_EXPORT void GUIAPI GetDCLCS (HDC hdc, int which, POINT *pt)
    Retrieves mapping parameters of a device context.
  • MG_EXPORT void GUIAPI SetDCLCS (HDC hdc, int which, const POINT *pt)
    Sets mapping parameters of a device context.
  • MG_EXPORT void GUIAPI DPtoLP (HDC hdc, POINT *pPt)
    Converts device coordinates into logical coordinates.
  • MG_EXPORT void GUIAPI LPtoDP (HDC hdc, POINT *pPt)
    Converts logical coordinates into device coordinates.
  • MG_EXPORT void GUIAPI SPtoLP (HDC hdc, POINT *pPt)
    Converts screen coordinates into logical coordinates.
  • MG_EXPORT void GUIAPI LPtoSP (HDC hdc, POINT *pPt)
    Converts logical coordinates into screen coordinates.

Detailed Description

end of draw_adv_2d_fns

The mapping mode defines the unit of measure used to transform page-space units into device-space units, and also defines the orientation of the device's x and y axes.

So far, MiniGUI support only two mapping mode:

  • MM_TEXT
    Each logical unit is mapped to on device pixel. Positive x is to the right; positive y is down.
  • MM_ANISOTROPIC
    Logical units are mapped to arbitrary units with arbitrarily scaled axes; Use SetWindowExt and SetViewportExt functions to specify the units, orientation, and scaling required.

The following formula shows the math involved in converting a point from page space to device space:

      Dx = ((Lx - WOx) * VEx / WEx) + VOx

The following variables are involved:

  • Dx x value in device units
  • Lx x value in logical units (also known as page space units)
  • WO window x origin
  • VO viewport x origin
  • WE window x-extent
  • VE viewport x-extent

The same equation with y replacing x transforms the y component of a point. The formula first offsets the point from its coordinate origin. This value, no longer biased by the origin, is then scaled into the destination coordinate system by the ratio of the extents. Finally, the scaled value is offset by the destination origin to its final mapping.

Define Documentation

#define GetMapMode ( hdc ) GetDCAttr (hdc, DC_ATTR_MAP_MODE)

Retrieves the current mapping mode of a DC.

This function retrieves the current mapping mode of the DC hdc.

So far, MiniGUI support two mapping modes: MM_TEXT and MM_ANISOTROPIC.

Parameters:
hdc The device context.
Returns:
The current mapping mode, can be either MM_TEXT or MM_ANISOTROPIC.
See also:
SetWindowExt, SetViewportExt, SetMapMode

Definition at line 4020 of file gdi.h.

#define GetViewportExt | ( | hdc,
 |  | pPt | ) | GetDCLCS(hdc, DC_LCS_VEXT, pPt)

Retrieves the x-extents and y-extents of the current viewport for a device context.

This function retrieves the x-extents and y-extens of the current viewport of the specified device context hdc.

Parameters:
hdc | The device context.
pPt | The viewport extents will be returned through this buffer.
See also:
GetMapMode, SetViewportExt

Definition at line 4126 of file gdi.h.

#define GetViewportOrg | ( | hdc,
 |  | pPt | ) | GetDCLCS(hdc, DC_LCS_VORG, pPt)

Retrieves the x-coordinates and y-coordinates of the viewport origin for a device context.

This function retrieves the x-coordinates and y-coordinates of the viewport origin of the specified device context hdc.

Parameters:
hdc | The device context.
pPt | The viewport origin will be returned through this buffer.
See also:
GetMapMode, SetViewportOrg

Definition at line 4111 of file gdi.h.

#define GetWindowExt | ( | hdc,
 |  | pPt | ) | GetDCLCS(hdc, DC_LCS_WEXT, pPt)

Retrieves the x-extents and y-extents of the current window for a device context.

This function retrieves the x-extents and y-extens of the current window of the specified device context hdc.

Parameters:
hdc | The device context.
pPt | The window extents will be returned through this buffer.
See also:
GetMapMode, SetWindowExt

Definition at line 4156 of file gdi.h.

#define GetWindowOrg | ( | hdc,
 |  | pPt | ) | GetDCLCS(hdc, DC_LCS_WORG, pPt)

Retrieves the x-coordinates and y-coordinates of the window for a device context.

This function retrieves the x-coordinates and y-coordinates of the window origin of the specified device context hdc.

Parameters:
hdc | The device context.
pPt | The window origin will be returned through this buffer.
See also:
GetMapMode, SetWindowOrg

Definition at line 4141 of file gdi.h.

#define SetMapMode | ( | hdc,
 |  | mapmode | ) | SetDCAttr (hdc, DC_ATTR_MAP_MODE, (DWORD)mapmode)

Sets the mapping mode of a display context.

This function sets the mapping mode of the specified display context hdc.

So far, MiniGUI support two mapping modes: MM_TEXT and MM_ANISOTROPIC.

Parameters:
hdc | The device context.
mapmode | The new mapping mode, should be either MM_TEXT or MM_ANISOTROPIC.
Returns:
The old mapping mode, either MM_TEXT or MM_ANISOTROPIC.
See also:
SetWindowExt, SetViewportExt, SetMapMode

Definition at line 4037 of file gdi.h.

#define SetViewportExt | ( | hdc,
 |  | pPt | ) | SetDCLCS(hdc, DC_LCS_VEXT, pPt)

Sets the x-extents and y-extents of the current viewport for a device context.

This function sets the x-extents and y-extens of the current viewport of the specified device context hdc.

Parameters:
hdc | The device context.
pPt | The viewport extents will be set.
See also:
GetMapMode, GetViewportExt

Definition at line 4186 of file gdi.h.

#define SetViewportOrg | ( | hdc,
 |  | pPt | ) | SetDCLCS(hdc, DC_LCS_VORG, pPt)

Sets the x-coordinates and y-coordinates of the viewport origin for a device context.

This function sets the x-coordinates and y-coordinates of the viewport origin of the specified device context hdc.

Parameters:
hdc | The device context.
pPt | The viewport origin will be set.
See also:
GetMapMode, GetViewportOrg

Definition at line 4171 of file gdi.h.

#define SetWindowExt | ( | hdc,
 |  | pPt | ) | SetDCLCS(hdc, DC_LCS_WEXT, pPt)

Sets the x-extents and y-extents of the current window for a device context.

This function sets the x-extents and y-extens of the current window of the specified device context hdc.

Parameters:
hdc | The device context.
pPt | The window extents will be set.
See also:
GetMapMode, GetWindowExt

Definition at line 4216 of file gdi.h.

#define SetWindowOrg | ( | hdc,
 |  | pPt | ) | SetDCLCS(hdc, DC_LCS_WORG, pPt)

Sets the x-coordinates and y-coordinates of the window for a device context.

This function sets the x-coordinates and y-coordinates of the window origin of the specified device context hdc.

Parameters:
hdc | The device context.
pPt | The window origin will be set.
See also:
GetMapMode, GetWindowOrg

Definition at line 4201 of file gdi.h.

Function Documentation

void GUIAPI DPtoLP | ( | HDC | hdc,
 |  | POINT * | pPt
 | ) |  |

Converts device coordinates into logical coordinates.

This function converts device coordinates into logical coordinates in the device context hdc.

The conversion depends on the mapping mode of the display context, the settings of the origins and extents for the window and viewport. The x-coordinate and y-coordinate contained in struct pPt will be transformed.

Parameters:
hdc | The device context.
pPt | The coordinates to be converted, and the transformed coordinates will be contained in this buffer after the function returns.
See also:
LPtoDP

void GUIAPI GetDCLCS | ( | HDC | hdc,
 |  | int | which,
 |  | POINT * | pt
 | ) |  |

Retrieves mapping parameters of a device context.

This function retrieves mapping paramters of the specified device context hdc when the mapping mode is not MM_TEXT.

Parameters:
hdc | The device context.
which | Which parameter you want to retrieve, can be one of the following values:
  • DC_LCS_VORG
    Retrieves the x-coordinates and y-coordinates of the viewport origin.
  • DC_LCS_VEXT
    Retrieves the x-extents and y-extents of the current viewport.
  • DC_LCS_WORG
    Retrieves the x-coordinates and y-coordinates of the window origin.
  • DC_LCS_WEXT
    Retrieves the x-extents and y-extents of the window.

Parameters:
pt The coordinates or extents will be returned through this buffer.
See also:
GetMapMode, SetMapMode, SetDCLCS

void GUIAPI LPtoDP | ( | HDC | hdc,
 |  | POINT * | pPt
 | ) |  |

Converts logical coordinates into device coordinates.

This function converts logical coordinates into device coordinates in the device context hdc.

The conversion depends on the mapping mode of the display context, the settings of the origins and extents for the window and viewport. The x-coordinate and y-coordinate contained in struct pPt will be transformed.

Parameters:
hdc | The device context.
pPt | The coordinates to be converted, and the transformed coordinates will be contained in this buffer after the function returns.
See also:
DPtoLP

void GUIAPI LPtoSP | ( | HDC | hdc,
 |  | POINT * | pPt
 | ) |  |

Converts logical coordinates into screen coordinates.

This function converts logical coordinates into screen coordinates in the device context hdc.

The conversion depends on the mapping mode of the display context, the settings of the origins and extents for the window and viewport. The x-coordinate and y-coordinate contained in struct pPt will be transformed.

Parameters:
hdc | The device context.
pPt | The coordinates to be converted, and the transformed coordinates will be contained in this buffer after the function returns.
See also:
SPtoLP

void GUIAPI SetDCLCS | ( | HDC | hdc,
 |  | int | which,
 |  | const POINT * | pt
 | ) |  |

Sets mapping parameters of a device context.

This function sets mapping paramters of the specified device context hdc when the mapping mode is not MM_TEXT.

Parameters:
hdc | The device context.
which | Which parameter you want to retrieve, can be one of the following values:
  • DC_LCS_VORG
    Sets the x-coordinates and y-coordinates of the viewport origin.
  • DC_LCS_VEXT
    Sets the x-extents and y-extents of the current viewport.
  • DC_LCS_WORG
    Sets the x-coordinates and y-coordinates of the window origin.
  • DC_LCS_WEXT
    Sets the x-extents and y-extents of the window.

Parameters:
pt The coordinates or extents will be set.
See also:
GetMapMode, SetMapMode, GetDCLCS

void GUIAPI SPtoLP | ( | HDC | hdc,
 |  | POINT * | pPt
 | ) |  |

Converts screen coordinates into logical coordinates.

This function converts screen coordinates into logical coordinates in the device context hdc.

The conversion depends on the mapping mode of the display context, the settings of the origins and extents for the window and viewport. The x-coordinate and y-coordinate contained in struct pPt will be transformed.

Parameters:
hdc | The device context.
pPt | The coordinates to be converted, and the transformed coordinates will be contained in this buffer after the function returns.
See also:
LPtoSP

Generated on Fri Dec 17 13:49:48 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Clipping operations

Clipping operations
[GDI functions]

Functions

  • MG_EXPORT void GUIAPI ExcludeClipRect (HDC hdc, const RECT *prc)
    Excludes the specified rectangle from the current visible region of a DC.
  • MG_EXPORT void GUIAPI IncludeClipRect (HDC hdc, const RECT *prc)
    Includes the specified rectangle to the current visible region of a DC.
  • MG_EXPORT BOOL GUIAPI PtVisible (HDC hdc, int x, int y)
    Checks whether a point is visible.
  • MG_EXPORT void GUIAPI ClipRectIntersect (HDC hdc, const RECT *prc)
    Intersects the specified rectangle with the visible region of the DC.
  • MG_EXPORT void GUIAPI SelectClipRect (HDC hdc, const RECT *prc)
    Sets the visible region of a DC to be a rectangle.
  • MG_EXPORT int GUIAPI SelectClipRegionEx (HDC hdc, const CLIPRGN *pRgn, int fnMode)
    Combines the specified region with the current clipping region using the specified mode.
  • MG_EXPORT void GUIAPI SelectClipRegion (HDC hdc, const CLIPRGN *pRgn)
    Sets the visible region of a DC to be a region.
  • MG_EXPORT int GUIAPI OffsetClipRegion (HDC hdc, int nXOffset, int nYOffset)
    Moves the clipping region of a device context by the specified offsets.
  • MG_EXPORT void GUIAPI GetBoundsRect (HDC hdc, RECT *pRect)
    Retrieves the bounding rectangle of the current visible region of a DC.
  • MG_EXPORT BOOL GUIAPI RectVisible (HDC hdc, const RECT *pRect)
    Checks whether the specified rectangle is visible.
  • MG_EXPORT int GUIAPI GetClipBox (HDC hdc, RECT *clipbox)
    Retrieves the bounding rectangle of the current clipping region of a DC.

Function Documentation

void GUIAPI ClipRectIntersect | ( | HDC | hdc,
 |  | const RECT * | prc
 | ) |  |

Intersects the specified rectangle with the visible region of the DC.

This function intersects the specified rectangle prc with the visible region of the device context hdc.

Parameters:
hdc | The device context.
prc | Pointer to the rectangle.
See also:
IncludeClipRect, ExcludeClipRect, Region operations

void GUIAPI ExcludeClipRect | ( | HDC | hdc,
 |  | const RECT * | prc
 | ) |  |

Excludes the specified rectangle from the current visible region of a DC.

This function excludes the specified rect prc from the current visible region of the device context hdc.

Parameters:
hdc | The device context.
prc | The rectangle to be excluded.
See also:
IncludeClipRect, Region operations

void GUIAPI GetBoundsRect | ( | HDC | hdc,
 |  | RECT * | pRect
 | ) |  |

Retrieves the bounding rectangle of the current visible region of a DC.

This function retrieves the bounding rectangle of the current visible region of the specified device context hdc, and returned through pRect.

Parameters:
hdc | The device context.
pRect | The bounding rectangle will be returned through this buffer.
See also:
Region operations

int GetClipBox | ( | HDC | hdc,
 |  | RECT * | clipbox
 | ) |  |

Retrieves the bounding rectangle of the current clipping region of a DC.

This function retrieves the bounding rectangle of the current clipping region of the specified device context hdc, and returned through clipbox.

Parameters:
hdc | The device context.
clipbox | The bounding rectangle will be returned through this buffer.
Returns:
-1 for error, else the type of clipping region, can be one of the following values:
  • NULLREGION
    A null region.
  • SIMPLEREGION
    A simple region.
  • COMPLEXREGION
    A complex region.
See also:
GetBoundsRect

void GUIAPI IncludeClipRect | ( | HDC | hdc,
 |  | const RECT * | prc
 | ) |  |

Includes the specified rectangle to the current visible region of a DC.

This function includes the specified rectangle prc to the current visible region of the device context hdc.

Parameters:
hdc | The device context.
prc | The rectangle to be included.
See also:
ExcludeClipRect, Region operations

int GUIAPI OffsetClipRegion | ( | HDC | hdc,
 |  | int | off_x,
 |  | int | off_y
 | ) |  |

Moves the clipping region of a device context by the specified offsets.

This function moves the clipping region of a device context hdc by the specified offsets (off_x, off_y).

Parameters:
hdc | Handle to the device context.
off_x | Specifies the number of device units to move left or right.
off_y | pecifies the number of device units to move up or down.
Returns:
The return value specifies the new clipping region's complexity; it can be one of the following values.
NULLREGION Region is empty. SIMPLEREGION Region is a single rectangle. COMPLEXREGION Region is more than one rectangle. -1 An error occurred.

See also:
SelectClipRegion

BOOL GUIAPI PtVisible | ( | HDC | hdc,
 |  | int | x,
 |  | int | y
 | ) |  |

Checks whether a point is visible.

This function checks whether the point specified by (x,y) is visible, i.e. it is within the current visible clipping region of the device context hdc.

Parameters:
hdc | The device context.
x | x,y: The coordinates of the point.
y | x,y: The coordinates of the point.
Returns:
TRUE for visible, else for not.
See also:
RectVisible, Region operations

BOOL GUIAPI RectVisible | ( | HDC | hdc,
 |  | const RECT * | pRect
 | ) |  |

Checks whether the specified rectangle is visible.

This function checks whether the rectangle pointed to by pRect is visible, i.e. it is intersected with the current visible region of the device context hdc.

Parameters:
hdc | The device context.
pRect | Pointer to the rectangle.
See also:
PtVisible, Region operations
Example:

/*
 * Use RectVisible to optimize the repaint of the window.
 */
MSG_PAINT:
{
        HDC hdc = BeginPaint (hWnd);

        for (j = 0; j < 10; j ++) {
                if (RectVisible  (hdc, rcs + j)) {
                        FillBox (hdc, rcs[j].left, rcs[j].top, rcs [j].right, rcs [j].bottom);
                }
        }

        EndPaint (hWnd, hdc);
        return 0;
}

void GUIAPI SelectClipRect | ( | HDC | hdc,
 |  | const RECT * | prc
 | ) |  |

Sets the visible region of a DC to be a rectangle.

This function sets the visible region of the device context hdc to the rectangle pointed to by prc.

Parameters:
hdc | The device context.
prc | Pointer to the rectangle.
See also:
SelectClipRegion, Region operations

void GUIAPI SelectClipRegion | ( | HDC | hdc,
 |  | const CLIPRGN * | pRgn
 | ) |  |

Sets the visible region of a DC to be a region.

This function sets the visible region of the device context hdc to the region pointed to by pRgn.

Parameters:
hdc | The device context.
pRgn | Pointer to the region.
See also:
SelectClipRect, GetClipRegion, Region operations

int GUIAPI SelectClipRegionEx | ( | HDC | hdc,
 |  | const CLIPRGN * | pRgn,
 |  | int | fnMode
 | ) |  |

Combines the specified region with the current clipping region using the specified mode.

This function combines the specified region with the current clipping region using the specified mode.

If an error occurs when this function is called, the previous clipping region for the specified device context is not affected.

The SelectClipRegionEx function assumes that the coordinates for the specified region are specified in device units.

Only a copy of the region identified by the pRgn parameter is used. The region itself can be reused after this call or it can be deleted.

Parameters:
hdc | Handle to the device context.
pRgn | Pointer to the region to be selected. This handle can only be NULL when the RGN_COPY mode is specified.
Specifies | the operation to be performed. It must be one of the following values:
  • RGN_AND
    The new clipping region combines the overlapping areas of the current clipping region and the region identified by pRgn.
  • RGN_COPY
    The new clipping region is a copy of the region identified by pRgn. This is identical to SelectClipRegion. If the region identified by pRgn is NULL, the new clipping region is the default clipping region (the default clipping region is a null region).
  • RGN_DIFF
    The new clipping region combines the areas of the current clipping region with those areas excluded from the region identified by hrgn.
  • RGN_OR
    The new clipping region combines the current clipping region and the region identified by hrgn.
  • RGN_XOR
    The new clipping region combines the current clipping region and the region identified by hrgn but excludes any overlapping areas.

Returns:
The return value specifies the new clipping region's complexity; it can be one of the following values.
NULLREGION Region is empty. SIMPLEREGION Region is a single rectangle. COMPLEXREGION Region is more than one rectangle. -1 An error occurred.

See also:
SelectClipRect, SelectClipRegion, GetClipRegion, Region operations

Generated on Fri Dec 17 13:49:48 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: BITMAP and blitting operations

BITMAP and blitting operations
[GDI functions]

Functions

  • MG_EXPORT BOOL GUIAPI GetBitmapFromDC (HDC hdc, int x, int y, int w, int h, BITMAP *bmp)
    Gets image box on a DC and saves it into a BITMAP object.
  • MG_EXPORT BOOL GUIAPI FillBoxWithBitmap (HDC hdc, int x, int y, int w, int h, const BITMAP *bmp)
    Fills a box with a BITMAP object.
  • MG_EXPORT BOOL GUIAPI FillBoxWithBitmapPart (HDC hdc, int x, int y, int w, int h, int bw, int bh, const BITMAP *bmp, int xo, int yo)
    Fills a box with a part of a bitmap oject.
  • MG_EXPORT BOOL GUIAPI FillBitmapPartInBox (HDC hdc, int box_x, int box_y, int box_w, int box_h, const BITMAP *pbmp, int bmp_x, int bmp_y, int bmp_w, int bmp_h)
    Fills a part of bitmap into a box, and the parts bitmap will be scaled if needed.
  • MG_EXPORT void GUIAPI BitBlt (HDC hsdc, int sx, int sy, int sw, int sh, HDC hddc, int dx, int dy, DWORD dwRop)
    Performs a bit-block transfer from a device context into another device context.
  • MG_EXPORT void GUIAPI StretchBlt (HDC hsdc, int sx, int sy, int sw, int sh, HDC hddc, int dx, int dy, int dw, int dh, DWORD dwRop)
    Copies a bitmap from a source rectangle into a destination rectangle, streches the bitmap if necessary.
  • MG_EXPORT BOOL GUIAPI ScaleBitmapEx (BITMAP *dst, const BITMAP *src, HDC ref_dc)
    Scales a BITMAP object into another BITMAP object by specify algorithm.
  • MG_EXPORT gal_pixel GUIAPI GetPixelInBitmapEx (const BITMAP *bmp, int x, int y, Uint8 *alpha)
    Returns the pixel value in a BITMAP object.
  • static gal_pixel GUIAPI GetPixelInBitmap (const BITMAP *bmp, int x, int y)
    Returns the pixel value in a BITMAP object.
  • static BOOL GUIAPI SetPixelInBitmap (const BITMAP *bmp, int x, int y, gal_pixel pixel)
    Sets pixel value in a BITMAP object.
  • MG_EXPORT BOOL GUIAPI SaveScreenRectContent (const RECT *rcWin, const char *filename)
    Saves content of a rectangle in the screen to a file.
  • MG_EXPORT BOOL GUIAPI SaveMainWindowContent (HWND hWnd, const char *filename)
    Saves content of a main window to a file.

Detailed Description

Example:

{
    int tox = 800, toy = 800;
    int count;
    BITMAP bitmap;
    unsigned int start_tick, end_tick;

    /* Load the bitmap from the file. */
    if (LoadBitmap (hdc, &bitmap, "res/icon.bmp"))
        return;

    bitmap.bmType = BMP_TYPE_ALPHACHANNEL;

    /* Fill a box with the bitmap with alpha channel. */
    start_tick = GetTickCount ();
    count = 1000;
    while (count--) {
        tox = rand() % 800;
        toy = rand() % 800;

        /* Set a random alpha channel. */
        bitmap.bmAlpha = rand() % 256;
        /* Fill the box. */
        FillBoxWithBitmap (hdc, tox, toy, 0, 0, &bitmap);
    }
    end_tick = GetTickCount ();
    TellSpeed (hwnd, start_tick, end_tick, "Alpha Blended Bitmap", 1000);

    bitmap.bmType = BMP_TYPE_ALPHACHANNEL | BMP_TYPE_COLORKEY;
    /* Set the color key (the transparent pixel) of the bitmap. */
    bitmap.bmColorKey = GetPixelInBitmap (&bitmap, 0, 0);

    /* Fill a box with the bitmap with alpha channel and color key. */
    start_tick = GetTickCount ();
    count = 1000;
    while (count--) {
        tox = rand() % 800;
        toy = rand() % 800;

        /* Set a random alpha channel. */
        bitmap.bmAlpha = rand() % 256;
        /* Fill the box. */
        FillBoxWithBitmap (hdc, tox, toy, 0, 0, &bitmap);
    }
    end_tick = GetTickCount ();
    TellSpeed (hwnd, start_tick, end_tick, "Alpha Blended Transparent Bitmap", 1000);

    UnloadBitmap (&bitmap);
}

{
    /* Create a memory DC which hanve alpha per-pixel. */
    mem_dc = CreateMemDC (400, 100, 16, MEMDC_FLAG_HWSURFACE | MEMDC_FLAG_SRCALPHA,
                    0x0000F000, 0x00000F00, 0x000000F0, 0x0000000F);

    /* Set brush color and fill a box. */
    SetBrushColor (mem_dc, RGBA2Pixel (mem_dc, 0xFF, 0xFF, 0x00, 0xFF));
    FillBox (mem_dc, 0, 0, 200, 50);

    /* Set another brush color and fill a box */
    SetBrushColor (mem_dc, RGBA2Pixel (mem_dc, 0xFF, 0xFF, 0x00, 0x40));
    FillBox (mem_dc, 200, 0, 200, 50);

    /* Set another brush color and fill a box */
    SetBrushColor (mem_dc, RGBA2Pixel (mem_dc, 0xFF, 0xFF, 0x00, 0x80));
    FillBox (mem_dc, 0, 50, 200, 50);

    /* Set another brush color and fill a box */
    SetBrushColor (mem_dc, RGBA2Pixel (mem_dc, 0xFF, 0xFF, 0x00, 0xC0));
    FillBox (mem_dc, 200, 50, 200, 50);
    SetBkMode (mem_dc, BM_TRANSPARENT);

    /* Set a text color and output the text */
    SetTextColor (mem_dc, RGBA2Pixel (mem_dc, 0x00, 0x00, 0x00, 0x80));
    TabbedTextOut (mem_dc, 0, 0, "Memory DC with alpha.\n"
                                 "The source DC have alpha per-pixel.");

    /* Blitting to a client DC. */
    start_tick = GetTickCount ();
    count = 100;
    while (count--) {
        BitBlt (mem_dc, 0, 0, 400, 100, hdc, rand () % 800, rand () % 800);
    }
    end_tick = GetTickCount ();
    TellSpeed (hwnd, start_tick, end_tick, "Alpha Blit", 100);

    /* delete the momory DC. */
    DeleteMemDC (mem_dc);
}

Function Documentation

void GUIAPI BitBlt | ( | HDC | hsdc,
 |  | int | sx,
 |  | int | sy,
 |  | int | sw,
 |  | int | sh,
 |  | HDC | hddc,
 |  | int | dx,
 |  | int | dy,
 |  | DWORD | dwRop
 | ) |  |

Performs a bit-block transfer from a device context into another device context.

This function performs a bit-block transfer of the color data cooresponding to a rectangle of pixels from the specified source device context hsdc into a destination device context hddc. (sx,sy,sw,sh) specifies the rectangle in the source DC, and (dx,dy) specifies the position of the rectangle in the destination DC. Note that the size of the two rectangles are identical.

Note that all coordinates should be in the device space.

Parameters:
hsdc | The source device context.
sx | The x coordinate of the upper-left corner of the rectangle in the source DC.
sy | The y coordinate of the upper-left corner of the rectangle in the source DC.
sw | The width of the source rectangle.
sh | The height of the source rectangle.
hddc | The destination device context hddc.
dx | The x coordinate of the upper-left corner of the rectangle in the destination DC.
dy | The y coordinate of the upper-left corner of the rectangle in the destination DC.
dwRop | The raster operation, currently ignored.
Note:
The alpha and color key settings of the source DC will come into play.
See also:
StretchBlt, SetMemDCAlpha, SetMemDCColorKey

BOOL FillBitmapPartInBox | ( | HDC | hdc,
 |  | int | box_x,
 |  | int | box_y,
 |  | int | box_w,
 |  | int | box_h,
 |  | const BITMAP * | pbmp,
 |  | int | bmp_x,
 |  | int | bmp_y,
 |  | int | bmp_w,
 |  | int | bmp_h
 | ) |  |

Fills a part of bitmap into a box, and the parts bitmap will be scaled if needed.

This function gives an intuitionistic way to use function FillBoxWidthBitmapPart.

Parameters:
hdc | The target DC to show bitmap
box_x | The left of target box
box_y | The top of target box
box_w | The width of target box
box_h | The height of target box
pbmp | The bitmap which will be showed in the hdc
bmp_x | The visible part's left of bitmap
bmp_y | The visible part's top of bitmap
bmp_w | The visible part's width of bitmap
bmp_h | The visible part's height of bitmap
See also:
FillBoxWidthBitmapPart

BOOL GUIAPI FillBoxWithBitmap | ( | HDC | hdc,
 |  | int | x,
 |  | int | y,
 |  | int | w,
 |  | int | h,
 |  | const BITMAP * | bmp
 | ) |  |

Fills a box with a BITMAP object.

This function fills a box with a BITMAP object pointed to by bmp. (x,y) is the upper-left corner of the box, and w, h are the width and the height of the box respectively.

This function will scale the bitmap when necessary; that is, when the width or the height of the box is not equal to the with or the height of the BITMAP object.

Parameters:
hdc | The device context.
x | The x coordinate of the upper-left corner of the box.
y | The y coordinate of the upper-left corner of the box.
w | The width of the box. Can be zero, means the width or the height will be equal to the width or the height of the BITMAP object.
h | The height of the box. Can be zero, means the width or the height will be equal to the width or the height of the BITMAP object.
bmp | The pointer to the BITMAP object.
Returns:
TRUE on success, otherwise FALSE.
Note:
You can specify the alpha value or the color key of the BITMAP object, and the current raster operation was set by SetRasterOperation for the DC will override the alpha value of color key if ROP is not ROP_SET.

If the bitmap has BMP_TYPE_RLE, the target w and h will be ignored. That is, the scale of the bitmap is not supported for RLE encoded bitmap.

See also:
FillBoxWithBitmapPart, GetBitmapFromDC, Bitmap file load/save operations

BOOL GUIAPI FillBoxWithBitmapPart | ( | HDC | hdc,
 |  | int | x,
 |  | int | y,
 |  | int | w,
 |  | int | h,
 |  | int | bw,
 |  | int | bh,
 |  | const BITMAP * | bmp,
 |  | int | xo,
 |  | int | yo
 | ) |  |

Fills a box with a part of a bitmap oject.

This function fills a box with a part of a bitmap object pointed to by bmp. (x,y) is the upper-left corner of the box, and w, h are the width and the height of the box respectively. (xo, yo) is the start position of the part box in the bitmap relative to upper-left corner of the bitmap, and bw, bh are the width and the height of the full bitmap expected.

If bw or bh is less than or equal to zero, this function will use the original width and height of the bitmap, else it will scale the BITMAP object when necessary; that is, when bw or bh is not equal to the width or the height of the BITMAP object.

Parameters:
hdc | The device context.
x | The x coordinate of the upper-left corner of the box.
y | The y coordinate of the upper-left corner of the box.
w | The width of the box.
h | The height of the box.
bw | The width of the full bitmap expected. Can be zero, means the width or the height will be equal to the width or the height of the BITMAP object.
bh | The height of the full bitmap expected. Can be zero, means the width or the height will be equal to the width or the height of the BITMAP object.
xo | xo,yo: The start position of the part box in the bitmap relative to upper-left corner of the BITMAP object.
yo | xo,yo: The start position of the part box in the bitmap relative to upper-left corner of the BITMAP object.
bmp | The pointer to the BITMAP object.
Returns:
TRUE on success, otherwise FALSE.
Note:
1: You can specify the alpha value or the color key of the BITMAP object, and the current raster operation was set by SetRasterOperation for the DC will override the alpha value or the color key if ROP is not ROP_SET.

2: xo/yo must be greater zero and (xo + w) < bw, (yo + h) < bh. else with fill nothing.

3: xo/yo must be multiply scale factor when bitmap scaled.

4: if bw or bh is not equal to he width or the height of the BITMAP object, it will be scale bitmap, but fill box is also (0, 0, w,h).

The RLE encoded bitmap is not supported by this function so far.

See also:
FillBoxWithBitmap, GetBitmapFromDC, Bitmap structure

BOOL GUIAPI GetBitmapFromDC | ( | HDC | hdc,
 |  | int | x,
 |  | int | y,
 |  | int | w,
 |  | int | h,
 |  | BITMAP * | bmp
 | ) |  |

Gets image box on a DC and saves it into a BITMAP object.

This function gets image box on the specified device context hdc, and saves the image bits into the BITMAP object pointed to by bmp. The image box begins at (x,y), and is w wide and h high. You must make sure that bmp->bits is big enough to store the image.

Parameters:
hdc | The device context.
x | The x coordinate in pixels of upper-left corner of the image box.
y | The y coordinate in pixels of upper-left corner of the image box.
w | The width of the image box.
h | The height of the image box.
bmp | The pointer to the BITMAP object.
Note:
If BITMAP's bmPitch is zero or bmBits is NULL, it will be malloc bmBits internal, you need init the BITMAP surely(such as InitBitmap) or memset(bmp, 0, sizeof(BITMAP)).
 void GUIAPI SaveScreenBox (int x, int y, int w, int h, void* vbuf)
See also:
FillBoxWithBitmap, Bitmap structure

static inline gal_pixel GUIAPI GetPixelInBitmap | ( | const BITMAP * | bmp,
 |  | int | x,
 |  | int | y |
 | ) |  |  | [inline, static]

Returns the pixel value in a BITMAP object.

This function returns the pixel value at the position (x,y) in the BITMAP object bmp.

Parameters:
bmp | The BITMAP object.
x | x,y: The position of the pixel in the bitmap relative to the upper-left corner of the bitmap.
y | x,y: The position of the pixel in the bitmap relative to the upper-left corner of the bitmap.
Returns:
The pixel value, if the position is out of the bitmap, zero returned.
See also:
SetPixelInBitmap, Bitmap structure

Definition at line 4859 of file gdi.h.

References GetPixelInBitmapEx(), and NULL.

gal_pixel GUIAPI GetPixelInBitmapEx | ( | const BITMAP * | bmp,
 |  | int | x,
 |  | int | y,
 |  | Uint8 * | alpha
 | ) |  |

Returns the pixel value in a BITMAP object.

This function returns the pixel value and alpha at the position (x,y) in the BITMAP object bmp.

Parameters:
bmp | The BITMAP object.
x | x,y: The position of the pixel in the bitmap relative to the upper-left corner of the bitmap.
y | x,y: The position of the pixel in the bitmap relative to the upper-left corner of the bitmap.
alpha | The point to alpha of position (x, y).
Returns:
The pixel value, if the position is out of the bitmap, zero returned.
Note:
if the bitmap with BMP_TYPE_ALPHA_MASK flag, the alpha value will be read from bmp->AlphaMask(Bitmap Alpha Mask array).
See also:
SetPixelInBitmapEx, Bitmap structure

Referenced by GetPixelInBitmap().

BOOL GUIAPI SaveMainWindowContent | ( | HWND | hWnd,
 |  | const char * | filename
 | ) |  |

Saves content of a main window to a file.

This function saves the content of the main window hWnd to the image file filename. MiniGUI uses the extension name of the file to determine the format of the image file.

Parameters:
hWnd | Handle to the main window.
filename | The name of the image file.
Returns:
TRUE on success, otherwise FALSE.
Note:
Only defined for _MGMISC_SAVESCREEN.
See also:
Bitmap file load/save operations

BOOL GUIAPI SaveScreenRectContent | ( | const RECT * | rc,
 |  | const char * | filename
 | ) |  |

Saves content of a rectangle in the screen to a file.

This function saves the content of the rect rc to the image file filename. MiniGUI uses the extension name of the file to determine the format of the image file.

Parameters:
rc | The RECT object defined the rectangle in the screen.
filename | The name of the image file.
Returns:
TRUE on success, otherwise FALSE.
Note:
Only defined for _MGMISC_SAVESCREEN.
See also:
Bitmap file load/save operations

BOOL GUIAPI ScaleBitmapEx | ( | BITMAP * | dst,
 |  | const BITMAP * | src,
 |  | HDC | ref_dc
 | ) |  |

Scales a BITMAP object into another BITMAP object by specify algorithm.

This function scales a BITMAP object src into another BITMAO object dst by specify algorithm. The source rectangle and the destination rectangle both are defined in the BITMAP objects.

Parameters:
dst | The destination BITMAP object.
src | The srouce BITMAP object.
ref_dc | The device context of Bitmap's relative device dc.
Returns:
TRUE on success, otherwise FALSE.
Note:
you should init the dst Bitmap first, such as bmPitch and bmBits.
See also:
FillBoxWithBitmap, StretchBlt, Bitmap structure

static inline BOOL GUIAPI SetPixelInBitmap | ( | const BITMAP * | bmp,
 |  | int | x,
 |  | int | y,
 |  | gal_pixel | pixel |
 | ) |  |  | [inline, static]

Sets pixel value in a BITMAP object.

This function sets the pixel value at the position (x,y) in the BITMAP object bmp.

Parameters:
bmp | The BITMAP object.
x | x,y: The position of the pixel in the bitmap relative to the upper-left corner of the bitmap.
y | x,y: The position of the pixel in the bitmap relative to the upper-left corner of the bitmap.
pixel | The pixel value.
Returns:
TRUE on success. If the position is out of the bitmap, FALSE returned.
See also:
GetPixelInBitmap, Bitmap structure

Definition at line 4911 of file gdi.h.

References NULL.

void GUIAPI StretchBlt | ( | HDC | hsdc,
 |  | int | sx,
 |  | int | sy,
 |  | int | sw,
 |  | int | sh,
 |  | HDC | hddc,
 |  | int | dx,
 |  | int | dy,
 |  | int | dw,
 |  | int | dh,
 |  | DWORD | dwRop
 | ) |  |

Copies a bitmap from a source rectangle into a destination rectangle, streches the bitmap if necessary.

This function copies a bitmap from a source rectangle into a destination rectangle, streching or compressing the bitmap to fit the dimension of the destination rectangle, if necessary. This function is similar with

See also:
BitBlt function except the former scaling the bitmap. (dw,dh) specifies the size of the destination rectangle.
Parameters:
hsdc | The source device context.
sx | The x coordinate of the upper-left corner of the rectangle in the source DC.
sy | The y coordinate of the upper-left corner of the rectangle in the source DC.
sw | The width of the source rectangle.
sh | The height of the source rectangle.
hddc | The destination device context hddc.
dx | The x coordinate of the upper-left corner of the rectangle in the destination DC.
dy | The y coordinate of the upper-left corner of the rectangle in the destination DC.
dw | The width of the destination rectangle.
dh | The height of the destination rectangle.
dwRop | The raster operation, currently ignored.
Note:
The source rect should be contained in the device space entirely, and all coordinates should be in the device space.

The source DC and dest DC must compatible, else will do nothing.

The alpha and color key settings of the source DC will not come into play.

See also:
BitBlt, SetMemDCAlpha, SetMemDCColorKey

Generated on Fri Dec 17 13:49:48 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Icon operations

Icon operations
[GDI functions]

Defines

  • #define CreateIcon(hdc, w, h, AndBits, XorBits, colornum) CreateIconEx(hdc, w, h, AndBits, XorBits, colornum, NULL)

Functions

  • MG_EXPORT HICON GUIAPI LoadIconFromFile (HDC hdc, const char *filename, int which)
    Loads an icon from a Windows ICO file.
  • MG_EXPORT HICON GUIAPI LoadIconFromMem (HDC hdc, const void *area, int which)
    Loads an icon from a memory area.
  • MG_EXPORT HICON GUIAPI CreateIconEx (HDC hdc, int w, int h, const BYTE *AndBits, const BYTE *XorBits, int colornum, const RGB *pal)
    Creates an icon object from the memory.
  • MG_EXPORT BOOL GUIAPI DestroyIcon (HICON hicon)
    Destroys an icon object.
  • MG_EXPORT BOOL GUIAPI GetIconSize (HICON hicon, int *w, int *h)
    Gets the size of an icon object.
  • MG_EXPORT void GUIAPI DrawIcon (HDC hdc, int x, int y, int w, int h, HICON hicon)
    Draws an icon into a box.

Define Documentation

#define CreateIcon | ( | hdc,
 |  | w,
 |  | h,
 |  | AndBits,
 |  | XorBits,
 |  | colornum | ) | CreateIconEx(hdc, w, h, AndBits, XorBits, colornum, NULL)

See also:
CreateIconEx

Definition at line 5038 of file gdi.h.

Function Documentation

HICON GUIAPI CreateIconEx | ( | HDC | hdc,
 |  | int | w,
 |  | int | h,
 |  | const BYTE * | AndBits,
 |  | const BYTE * | XorBits,
 |  | int | colornum,
 |  | const RGB * | pal
 | ) |  |

Creates an icon object from the memory.

This function creates an icon from memory data rather than icon file. w and h are the width and the height of the icon respectively. pANDBits and pXORBits are AND bitmask and XOR bitmask of the icon. MiniGUI currently support mono-color cursor 256-color icon and 16-color icon, colornum specifies the cursor's color depth. For mono-color, it should be 1, and for 16-color cursor, it should be 4.

Parameters:
hdc | The device context.
w | The width of the icon.
h | The height of the icon.
AndBits | The pointer to the AND bits of the icon.
XorBits | The pointer to the XOR bits of the icon.
colornum | The bit-per-pixel of XOR bits.
pal | The palette of icon.
Returns:
The handle to the icon object, zero means error occurred.
See also:
LoadIconFromFile

BOOL GUIAPI DestroyIcon ( HICON hicon )

Destroys an icon object.

This function destroys the icon object hicon.

Parameters:
hicon The icon object.
Returns:
TRUE on success, otherwise FALSE.
See also:
CreateIconEx, LoadIconFromFile

void GUIAPI DrawIcon | ( | HDC | hdc,
 |  | int | x,
 |  | int | y,
 |  | int | w,
 |  | int | h,
 |  | HICON | hicon
 | ) |  |

Draws an icon into a box.

This function draws an icon object hicon into a box specified by (x,y,w,h).

Parameters:
hdc | The device context.
x | The x coordinate of the upper-left corner of the box.
y | The y coordinate of the upper-left corner of the box.
w | The width of the box.
h | The height of the box.
hicon | The icon object.
See also:
CreateIconEx, LoadIconFromFile

BOOL GUIAPI GetIconSize | ( | HICON | hicon,
 |  | int * | w,
 |  | int * | h
 | ) |  |

Gets the size of an icon object.

This function gets the size of the icon object hicon.

Parameters:
hicon | The icon object.
w | The width of the icon will be returned throught this buffer.
h | The height of the icon will be returned throught this buffer.
Returns:
TRUE on success, otherwise FALSE.
See also:
CreateIconEx, LoadIconFromFile

HICON GUIAPI LoadIconFromFile | ( | HDC | hdc,
 |  | const char * | filename,
 |  | int | which
 | ) |  |

Loads an icon from a Windows ICO file.

This function loads an icon from a Windows ICO file named filename and creates an icon object. This function can load mono-,16-color and 256-color icons.Some Windows ICO file contain two icons in different sizes. You can tell this function to load which icon though which, 0 for the first icon, and 1 for the second icon. Generally, the later icon is the larger icon.

Parameters:
hdc | The device context.
filename | The file name of the ICO file.
which | Tell the function to load which icon.
Returns:
The handle to the icon object, zero means error occurred.
See also:
CreateIconEx

HICON GUIAPI LoadIconFromMem | ( | HDC | hdc,
 |  | const void * | area,
 |  | int | which
 | ) |  |

Loads an icon from a memory area.

This function loads an icon from a memroy area pointed to by area. The memory area has the same layout as the M$ Windows ICO file. This function can load mono- ,16-color and 256-color icons. Some Windows ICO file contain two icons in different sizes. You can tell this function to load which icon though which, 0 for the first icon, and 1 for the second icon. Generally, the later icon is the larger icon.

Parameters:
hdc | The device context.
area | The pointer to the memory area.
which | Tell the function to load which icon.
Returns:
The handle to the icon object, zero means error occurred.
See also:
CreateIconEx

Generated on Fri Dec 17 13:49:48 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Rectangle operations

Rectangle operations
[GDI functions]

Defines

  • #define RECTWP(prc) ((prc)->right - (prc)->left)
    Gets the width of a RECT object by using the pointer to it.
  • #define RECTHP(prc) ((prc)->bottom - (prc)->top)
    Gets the height of a RECT object by using the pointer to it.
  • #define RECTW(rc) ((rc).right - (rc).left)
    Gets the width of a RECT object.
  • #define RECTH(rc) ((rc).bottom - (rc).top)
    Gets the height of a RECT object.

Functions

  • static void SetRect (RECT *prc, int left, int top, int right, int bottom)
    Sets a rectangle.
  • static void SetRectEmpty (RECT *prc)
    Empties a rectangle.
  • static void CopyRect (RECT *pdrc, const RECT *psrc)
    Copies one rectangle to another.
  • static void OffsetRect (RECT *prc, int x, int y)
    Moves a rectangle by offsets.
  • static void InflateRect (RECT *prc, int cx, int cy)
    Increases or decreases the width and height of an rectangle.
  • static void InflateRectToPt (RECT *prc, int x, int y)
    Inflates a rectangle to contain a point.
  • static BOOL PtInRect (const RECT *prc, int x, int y)
    Determines whether a point lies within an rectangle.
  • MG_EXPORT BOOL GUIAPI IsRectEmpty (const RECT *prc)
    Determines whether an rectangle is empty.
  • MG_EXPORT BOOL GUIAPI EqualRect (const RECT *prc1, const RECT *prc2)
    Determines whether two rectangles are equal.
  • MG_EXPORT void GUIAPI NormalizeRect (RECT *pRect)
    Normalizes a rectangle.
  • MG_EXPORT BOOL GUIAPI IntersectRect (RECT *pdrc, const RECT *psrc1, const RECT *psrc2)
    Calculates the intersection of two rectangles.
  • MG_EXPORT BOOL GUIAPI IsCovered (const RECT *prc1, const RECT *prc2)
    Determines whether one rectangle is covered by another.
  • MG_EXPORT BOOL GUIAPI DoesIntersect (const RECT *psrc1, const RECT *psrc2)
    Determines whether two rectangles intersect.
  • MG_EXPORT BOOL GUIAPI UnionRect (RECT *pdrc, const RECT *psrc1, const RECT *psrc2)
    Unions two source rectangles.
  • MG_EXPORT void GUIAPI GetBoundRect (PRECT pdrc, const RECT *psrc1, const RECT *psrc2)
    Gets the bound rectangle of two source rectangles.
  • MG_EXPORT int GUIAPI SubtractRect (RECT *rc, const RECT *psrc1, const RECT *psrc2)
    Obtains the rectangles when substracting one rectangle from another.

Define Documentation

#define RECTH ( rc ) ((rc).bottom - (rc).top)

Gets the height of a RECT object.

Definition at line 5407 of file gdi.h.

#define RECTHP ( prc ) ((prc)->bottom - (prc)->top)

Gets the height of a RECT object by using the pointer to it.

Definition at line 5397 of file gdi.h.

#define RECTW ( rc ) ((rc).right - (rc).left)

Gets the width of a RECT object.

Definition at line 5402 of file gdi.h.

#define RECTWP ( prc ) ((prc)->right - (prc)->left)

Gets the width of a RECT object by using the pointer to it.

Definition at line 5392 of file gdi.h.

Function Documentation

void CopyRect | ( | RECT * | pdrc,
 |  | const RECT * | psrc |
 | ) |  |  | [inline, static]

Copies one rectangle to another.

This function copies the coordinates of the source rectangle pointed to by psrc to the destination rectangle pointed to by pdrc.

Parameters:
pdrc | The pointer to the destination rectangle.
psrc | The pointer to the source rectangle.
See also:
SetRect

Definition at line 5147 of file gdi.h.

BOOL GUIAPI DoesIntersect | ( | const RECT * | psrc1,
 |  | const RECT * | psrc2
 | ) |  |

Determines whether two rectangles intersect.

This function determines whether two rectangles (psrc1 and psrc2) intersect.

Parameters:
psrc1 | The first source rectangles.
psrc2 | The second source rectangles.
Returns:
TRUE if the source rectangles intersect, otherwise FALSE.
See also:
IntersectRect

BOOL GUIAPI EqualRect | ( | const RECT * | prc1,
 |  | const RECT * | prc2
 | ) |  |

Determines whether two rectangles are equal.

This function determines whether the two specified rectangles (prc1 and prc2) are equal by comparing the coordinates of the upper-left and lower-right corners.

Parameters:
prc1 | The pointers to the first rectangles.
prc2 | The pointers to the second rectangles.
Returns:
TRUE for equal, otherwise FALSE.

void GUIAPI GetBoundRect | ( | PRECT | pdrc,
 |  | const RECT * | psrc1,
 |  | const RECT * | psrc2
 | ) |  |

Gets the bound rectangle of two source rectangles.

This function creates the bound rect (pdrc) of two rectangles (psrc1 and prsrc2). The bound rect is the smallest rectangle that contains both source rectangles.

Parameters:
pdrc | The destination rectangle.
psrc1 | The first source rectangle.
psrc2 | The second source rectangle.
See also:
UnionRect

void InflateRect | ( | RECT * | prc,
 |  | int | cx,
 |  | int | cy |
 | ) |  |  | [inline, static]

Increases or decreases the width and height of an rectangle.

This function increases or decreases the width and height of the specified rectangle prc. This function adds cx units to the left and right ends of the rectangle and cy units to the top and bottom. the cx and cy are signed values; positive values increases the width and height, and negative values decreases them.

Parameters:
prc | The pointer to the rectangle.
cx | The inflating x value.
cy | The inflating y value.
See also:
InflateRectToPt

Definition at line 5189 of file gdi.h.

void InflateRectToPt | ( | RECT * | prc,
 |  | int | x,
 |  | int | y |
 | ) |  |  | [inline, static]

Inflates a rectangle to contain a point.

This function inflates the rectangle prc to contain the specified point (x,y).

Parameters:
prc | The pointer to the rectangle.
x | x,y: The point.
y | x,y: The point.
See also:
InflateRect

Definition at line 5208 of file gdi.h.

BOOL GUIAPI IntersectRect | ( | RECT * | pdrc,
 |  | const RECT * | psrc1,
 |  | const RECT * | psrc2
 | ) |  |

Calculates the intersection of two rectangles.

This function calculates the intersection of two source rectangles (psrc1 and psrc2) and places the coordinates of the intersection rectangle into the destination rectangle pointed to by pdrc. If the source rectangles do not intersect, and empty rectangle (in which all coordinates are set to zero) is placed into the destination rectangle.

Parameters:
pdrc | The pointer to the destination rectangle.
psrc1 | The first source rectangles.
psrc2 | The second source rectangles.
Returns:
TRUE if the source rectangles intersect, otherwise FALSE.
See also:
DoesIntersect, IsCovered

BOOL GUIAPI IsCovered | ( | const RECT * | prc1,
 |  | const RECT * | prc2
 | ) |  |

Determines whether one rectangle is covered by another.

This function determines whether one rectangle (prc1) is covered by another rectangle (prc2).

Parameters:
prc1 | The first rectangles.
prc2 | The second rectangles.
Returns:
TRUE if the first rectangle is covered by the second, otherwise FALSE.
See also:
DoesIntersect

BOOL GUIAPI IsRectEmpty ( const RECT * prc )

Determines whether an rectangle is empty.

This function determines whether the specified rectangle prc is empty. An empty rectangle is one that has no area; that is, the coordinates of the right side is equal to the coordinate of the left side, or the coordinates of the bottom side is equal to the coordinate of the top side.

Parameters:
prc The pointer to the rectangle.
Returns:
TRUE for empty, otherwise FALSE.

void GUIAPI NormalizeRect ( RECT * pRect )

Normalizes a rectangle.

This function normalizes the rectangle pointed to by prc so that both the height and width are positive.

Parameters:
pRect The pointer to the rectangle.

void OffsetRect | ( | RECT * | prc,
 |  | int | x,
 |  | int | y |
 | ) |  |  | [inline, static]

Moves a rectangle by offsets.

This function moves the specified rectangle by the specified offsets. x and y specify the amount to move the rectangle left/right or up/down respectively. x must be a negative value to move the rectangle to the left, and y must be a negative value to move the rectangle up.

Parameters:
prc | The pointer to the rectangle.
x | The x offset.
y | The y offset.
See also:
InflateRect

Definition at line 5168 of file gdi.h.

BOOL PtInRect | ( | const RECT * | prc,
 |  | int | x,
 |  | int | y |
 | ) |  |  | [inline, static]

Determines whether a point lies within an rectangle.

This function determines whether the specified point (x,y) lies within the specified rectangle prc.

A point is within a rectangle if it lies on the left or top side or is within all four sides. A point on the right or bottom side is considered outside the rectangle.

Parameters:
prc | The pointer to the rectangle.
x | x,y: The point.
y | x,y: The point.

Definition at line 5231 of file gdi.h.

References FALSE, _RECT::left, _RECT::top, and TRUE.

void SetRect | ( | RECT * | prc,
 |  | int | left,
 |  | int | top,
 |  | int | right,
 |  | int | bottom |
 | ) |  |  | [inline, static]

Sets a rectangle.

This function sets the rectangle with specified values.

Parameters:
prc | The pointer to the rectangle.
left | The x coordinate of the upper-left corner of the rectangle.
top | The y coordinate of the upper-left corner of the rectangle.
right | The x coordinate of the lower-right corner of the rectangle.
bottom | The y coordinate of the lower-right corner of the rectangle.
See also:
SetRectEmpty

Definition at line 5111 of file gdi.h.

void SetRectEmpty ( RECT * prc ) [inline, static]

Empties a rectangle.

This function empties the rectangle pointed to by prc. An empty rectangle in MiniGUI is a rectangle whose width and height both are zero. This function will sets all coordinates of the rectangle to be zero.

Parameters:
prc The pointer to the rectangle.
See also:
SetRect

Definition at line 5130 of file gdi.h.

int GUIAPI SubtractRect | ( | RECT * | rc,
 |  | const RECT * | psrc1,
 |  | const RECT * | psrc2
 | ) |  |

Obtains the rectangles when substracting one rectangle from another.

This function obtains the rectangles substracting the rectangle psrc1 from the other psrc2. rc should be an array of RECT struct, and may contain at most four rectangles. This function returns the number of result rectangles.

Parameters:
rc | The pointer to the resule rectangle array.
psrc1 | The pointer to the minuend rectangle.
psrc2 | The pointer to the subtrahend rectangle.
Returns:
The number of result rectangles.
See also:
UnionRect

BOOL GUIAPI UnionRect | ( | RECT * | pdrc,
 |  | const RECT * | psrc1,
 |  | const RECT * | psrc2
 | ) |  |

Unions two source rectangles.

This function creates the union (pdrc) of two rectangles (psrc1 and psrc2), if the source rectangles are border upon and not stagger.

Parameters:
pdrc | The unioned rectangle.
psrc1 | The first source rectangles.
psrc2 | The second source rectangles.
Returns:
TRUE if the source rectangles are border upon and not stagger, otherwise FALSE.
See also:
GetBoundRect

Generated on Fri Dec 17 13:49:48 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Logical font operations

Logical font operations
[GDI functions]

Data Structures

  • struct _LOGFONT
  • struct _DEVFONT
  • struct _FONTMETRICS
  • struct _GLYPHBITMAP

Defines

  • #define FONT_CHARSET_GB1988_0 "GB1988-0"
    EUC encoding of GB1988 charset, treat as ISO8859-1.
  • #define FONT_CHARSET_GB2312_0 "GB2312-0"
    EUC encoding of GB2312 charset.
  • #define FONT_CHARSET_GB18030_0 "GB18030-0"
    EUC encoding of GB18030 charset.
  • #define FONT_CHARSET_EUCTW "EUC-TW"
    EUC encoding of CNS11643 charset, not supported.
  • #define FONT_CHARSET_KSC5636_0 "KSC5636-0"
    EUC encoding of KSC5636 charset, treat as ISO8859-1.
  • #define FONT_CHARSET_KSC5601_0 "KSC5601-0"
    EUC encoding of KSC5601 charset.
  • #define FONT_CHARSET_JISX0201_0 "JISX0201-0"
    EUC encoding of JISX0201 charset.
  • #define FONT_CHARSET_JISX0208_0 "JISX0208-0"
    EUC encoding of JISX0208 charset.
  • #define FONT_CHARSET_JISX0201_1 "JISX0201-1"
    Shift-JIS encoding of JISX0201 charset.
  • #define FONT_CHARSET_JISX0208_1 "JISX0208-1"
    Shift-JIS encoding of JISX0208 charset.
  • #define FONT_CHARSET_ISO_10646_1 "ISO-10646-1"
    UCS-2 encoding of UNICODE.
  • #define FONT_CHARSET_UTF8 "UTF-8"
    UTF-8 encoding of UNICODE.
  • #define FONT_CHARSET_UTF16LE "UTF-16LE"
    UTF-16 encoding (Little-Endian) of UNICODE.
  • #define FONT_CHARSET_UTF16BE "UTF-16BE"
    UTF-16 encoding (Big-Endian) of UNICODE.
  • #define INV_LOGFONT 0
    Invalid logfont.

Typedefs

  • typedef LOGFONT * PLOGFONT
    Data type of pointer to a LOGFONT.
  • typedef const LOGFONT * CPLOGFONT
    Data type of pointer to a const LOGFONT.
  • typedef struct _WORDINFO WORDINFO
    Date type of _WORDINFO.

Enumerations

  • enum mg_FT_LcdFilter {
MG_SMOOTH_NONE =  0,
MG_SMOOTH_DEFAULT =  1,
MG_SMOOTH_LIGHT =  2,
MG_SMOOTH_LEGACY =  16,
MG_SMOOTH_MAX
}

Functions

  • MG_EXPORT void GUIAPI GetFontMetrics (LOGFONT *log_font, FONTMETRICS *font_metrics)
    Gets metrics information of a logical font.
  • MG_EXPORT void GUIAPI GetGlyphBitmap (LOGFONT *log_font, const char *mchar, int mchar_len, GLYPHBITMAP *glyph_bitmap)
    Gets the glyph bitmap information when uses a logical font to output a character.
  • MG_EXPORT BOOL GUIAPI InitVectorialFonts (void)
    Initializes vectorial font renderer.
  • MG_EXPORT void GUIAPI TermVectorialFonts (void)
    Terminates vectorial font renderer.
  • MG_EXPORT PLOGFONT GUIAPI CreateLogFont (const char *type, const char *family, const char *charset, char weight, char slant, char flip, char other, char underline, char struckout, int size, int rotation)
    Creates a logical font.
  • MG_EXPORT PLOGFONT GUIAPI CreateLogFontByName (const char *font_name)
    Creates a logical font by a font name.
  • MG_EXPORT PLOGFONT GUIAPI CreateLogFontIndirect (LOGFONT *logfont)
    Creates a logical font indirectly from a LOGFONT structure.
  • MG_EXPORT void GUIAPI DestroyLogFont (PLOGFONT log_font)
    Destroys a logical font.
  • MG_EXPORT void GUIAPI GetLogFontInfo (HDC hdc, LOGFONT *log_font)
    Gets logical font information of a DC.
  • MG_EXPORT PLOGFONT GUIAPI GetCurFont (HDC hdc)
    Gets the pointer to the current logical font of a DC.
  • MG_EXPORT PLOGFONT GUIAPI SelectFont (HDC hdc, PLOGFONT log_font)
    Selects a logical font into a DC.
  • MG_EXPORT const DEVFONT *GUIAPI GetNextDevFont (const DEVFONT *dev_font)
    Get next devfont information.
  • MG_EXPORT BOOL GUIAPI ft2SetLcdFilter (LOGFONT *logfont, mg_FT_LcdFilter filter)
    Set freetype2 smooth mode.
  • MG_EXPORT DEVFONT *GUIAPI LoadDevFontFromFile (const char *devfont_name, const char *file_name)
    Load device font from font file.
  • MG_EXPORT void GUIAPI DestroyDynamicDevFont (DEVFONT **devfont)
    Destroy device font loaded dynamically from font file.

Detailed Description

MiniGUI uses logical font to render text in a DC. You can create a logical font by using CreateLogFont and select it into a DC by using SelectFont, then you can use this logical font to render text by using TextOutLen or DrawTextEx.

Define Documentation

#define FONT_CHARSET_EUCTW "EUC-TW"

EUC encoding of CNS11643 charset, not supported.

Definition at line 5608 of file gdi.h.

#define FONT_CHARSET_GB18030_0 "GB18030-0"

EUC encoding of GB18030 charset.

Definition at line 5601 of file gdi.h.

#define FONT_CHARSET_GB1988_0 "GB1988-0"

EUC encoding of GB1988 charset, treat as ISO8859-1.

Definition at line 5588 of file gdi.h.

#define FONT_CHARSET_GB2312_0 "GB2312-0"

EUC encoding of GB2312 charset.

Definition at line 5594 of file gdi.h.

#define FONT_CHARSET_ISO_10646_1 "ISO-10646-1"

UCS-2 encoding of UNICODE.

Definition at line 5653 of file gdi.h.

#define FONT_CHARSET_JISX0201_0 "JISX0201-0"

EUC encoding of JISX0201 charset.

Definition at line 5628 of file gdi.h.

#define FONT_CHARSET_JISX0201_1 "JISX0201-1"

Shift-JIS encoding of JISX0201 charset.

Definition at line 5641 of file gdi.h.

#define FONT_CHARSET_JISX0208_0 "JISX0208-0"

EUC encoding of JISX0208 charset.

Definition at line 5634 of file gdi.h.

#define FONT_CHARSET_JISX0208_1 "JISX0208-1"

Shift-JIS encoding of JISX0208 charset.

Definition at line 5647 of file gdi.h.

#define FONT_CHARSET_KSC5601_0 "KSC5601-0"

EUC encoding of KSC5601 charset.

Definition at line 5621 of file gdi.h.

#define FONT_CHARSET_KSC5636_0 "KSC5636-0"

EUC encoding of KSC5636 charset, treat as ISO8859-1.

Definition at line 5615 of file gdi.h.

#define FONT_CHARSET_UTF16BE "UTF-16BE"

UTF-16 encoding (Big-Endian) of UNICODE.

Definition at line 5671 of file gdi.h.

#define FONT_CHARSET_UTF16LE "UTF-16LE"

UTF-16 encoding (Little-Endian) of UNICODE.

Definition at line 5665 of file gdi.h.

#define FONT_CHARSET_UTF8 "UTF-8"

UTF-8 encoding of UNICODE.

Definition at line 5659 of file gdi.h.

#define INV_LOGFONT 0

Invalid logfont.

Definition at line 5824 of file gdi.h.

Typedef Documentation

typedef const LOGFONT * CPLOGFONT

Data type of pointer to a const LOGFONT.

Definition at line 5715 of file gdi.h.

typedef LOGFONT * PLOGFONT

Data type of pointer to a LOGFONT.

Definition at line 5710 of file gdi.h.

typedef struct _WORDINFO WORDINFO

Date type of _WORDINFO.

Definition at line 5722 of file gdi.h.

Enumeration Type Documentation

enum mg_FT_LcdFilter

List of values to identify various types of LCD filters, Note a freetype2 specific definition.

Enumerator:
MG_SMOOTH_NONE | equal to FT_LCD_FILTER_NONE
MG_SMOOTH_DEFAULT | equal to FT_LCD_FILTER_DEFAULT
MG_SMOOTH_LIGHT | equal to FT_LCD_FILTER_LIGHT
MG_SMOOTH_LEGACY | equal to FT_LCD_FILTER_LEGACY
MG_SMOOTH_MAX | equal to FT_LCD_FILTER_MAX

Definition at line 6161 of file gdi.h.

Function Documentation

PLOGFONT GUIAPI CreateLogFont | ( | const char * | type,
 |  | const char * | family,
 |  | const char * | charset,
 |  | char | weight,
 |  | char | slant,
 |  | char | flip,
 |  | char | other,
 |  | char | underline,
 |  | char | struckout,
 |  | int | size,
 |  | int | rotation
 | ) |  |

Creates a logical font.

This function creates a logical font.

Parameters:
type The type of the logical font, can be one of the values:
  • FONT_TYPE_NAME_BITMAP_RAW
    Creates a logical font by using raw bitmap device font, i.e. mono-space bitmap font.
  • FONT_TYPE_NAME_BITMAP_VAR
    Creates a logical font by using var-width bitmap device font.
  • FONT_TYPE_NAME_BITMAP_QPF
    Creates a logical font by using qpf device font.
  • FONT_TYPE_NAME_BITMAP_BMP
    Creates a logical font by using bitmap font.
  • FONT_TYPE_NAME_SCALE_TTF
    Creates a logical font by using scalable TrueType device font.
  • FONT_TYPE_NAME_SCALE_T1F
    Creates a logical font by using scalable Adobe Type1 device font.
  • FONT_TYPE_NAME_ALL
    Creates a logical font by using any type device font.
family | The family of the logical font, such as "Courier", "Helvetica", and so on.
charset | The charset of the logical font. You can specify a sigle-byte charset like "ISO8859-1", or a multi-byte charset like "GB2312-0".
weight The weight of the logical font, can be one of the values:
  • FONT_WEIGHT_ALL
    Any one.
  • FONT_WEIGHT_REGULAR
    Regular font.
  • FONT_WEIGHT_BOLD
    Bold font.
  • FONT_WEIGHT_BOOK
    Anti-aliase font.
  • FONT_WEIGHT_LIGHT
    Draw the glyph border with the background color.
slant The slant of the logical font, can be one of the values:
  • FONT_SLANT_ALL
    Any one.
  • FONT_SLANT_ROMAN
    Regular font.
  • FONT_SLANT_ITALIC
    Italic font.
flip Does flip the glyph of the font, can be one of the following values:
  • FONT_FLIP_NIL
    Do not flip the glyph.
  • FONT_FLIP_HORZ
    Flip the glyph horizontally .
  • FONT_FLIP_VERT
    Flip the glyph vertically.
  • FONT_FLIP_HORZVERT
    Flip the glyph horizontally and vertically.
other Other rendering features, can be one of the following values:
  • FONT_OTHER_NIL
    Not specified.
  • FONT_OTHER_AUTOSCALE
    Auto scale the bitmap glyph to match the desired font size.
  • FONT_OTHER_TTFNOCACHE
    Do not use cache when using TrueType font.
  • FONT_OTHER_TTFKERN
    Kern the glyph when using TrueType font.
  • FONT_OTHER_TTFNOCACHEKERN
    When using TrueType font, kern the glyph and do not use cache.
  • FONT_OTHER_LCDPORTRAIT
    When using TrueType font and sub-pixels smoothing strategy, set lcd portrait and do not use kern the glyph.
  • FONT_OTHER_LCDPORTRAITKERN
    When using TrueType font and sub-pixels smoothing strategy, set lcd portrait and use kern the glyph.
underline The underline of the logical font, can be one of the values:
  • FONT_UNDERLINE_ALL
    Any one.
  • FONT_UNDERLINE_LINE
    With underline.
  • FONT_UNDERLINE_NONE
    Without underline.
struckout The struckout line of the logical font, can be one of the values:
  • FONT_STRUCKOUT_ALL
    Any one.
  • FONT_STRUCKOUT_LINE
    With struckout line.
  • FONT_STRUCKOUT_NONE
    Without struckout line.
size | The size, i.e. the height, of the logical font. Note that the size of the created logical font may be different from the size expected.
rotation | The rotation of the logical font, it is in units of tenth degrees. Note that you can specify rotation only for TrueType and Adobe Type1 fonts.
Returns:
The pointer to the logical font created, NULL on error.
See also:
CreateLogFontIndirect, CreateLogFontByName, SelectFont
Example:

    static LOGFONT  *logfont, *logfontgb12, *logfontbig24;

            logfont = CreateLogFont (NULL, "SansSerif", "ISO8859-1",
                        FONT_WEIGHT_REGULAR, FONT_SLANT_ITALIC, FONT_SETWIDTH_NORMAL,
                        FONT_SPACING_CHARCELL, FONT_UNDERLINE_NONE, FONT_STRUCKOUT_LINE,
                        16, 0);
            logfontgb12 = CreateLogFont (NULL, "song", "GB2312",
                        FONT_WEIGHT_REGULAR, FONT_SLANT_ROMAN, FONT_SETWIDTH_NORMAL,
                        FONT_SPACING_CHARCELL, FONT_UNDERLINE_LINE, FONT_STRUCKOUT_LINE,
                        12, 0);
            logfontbig24 = CreateLogFont (NULL, "ming", "BIG5",
                        FONT_WEIGHT_REGULAR, FONT_SLANT_ROMAN, FONT_SETWIDTH_NORMAL,
                        FONT_SPACING_CHARCELL, FONT_UNDERLINE_LINE, FONT_STRUCKOUT_NONE,
                        24, 0);

PLOGFONT GUIAPI CreateLogFontByName ( const char * font_name )

Creates a logical font by a font name.

This function creates a logical font by a font name specified by font_name.

Parameters:
font_name The name of the font.
Returns:
The pointer to the logical font created, NULL on error.
See also:
CreateLogFont, SelectFont

PLOGFONT GUIAPI CreateLogFontIndirect ( LOGFONT * logfont )

Creates a logical font indirectly from a LOGFONT structure.

This function creates a logical font from information in a LOGFONT object.

Parameters:
logfont The pointer to the reference logical font structure.
Returns:
The pointer to the logical font created, NULL on error.
See also:
CreateLogFont, SelectFont

void GUIAPI DestroyDynamicDevFont ( DEVFONT ** devfont )

Destroy device font loaded dynamically from font file.

Parameters:
devfont The double pointer to DEVFONT structure. Note that the pointer must be the double pointer to device font loaded by LoadDevFontFromFile.
See also:
LoadDevFontFromFile

void GUIAPI DestroyLogFont ( PLOGFONT log_font )

Destroys a logical font.

This function destroys the specified logical font log_font.

Parameters:
log_font The logical font will be destroied.
See also:
CreateLogFont, CreateLogFontIndirect

BOOL ft2SetLcdFilter | ( | LOGFONT * | logfont,
 |  | mg_FT_LcdFilter | filter
 | ) |  |

Set freetype2 smooth mode.

This function can be used to set freetype2 library handle font smooth mode.

Parameters:
logfont | The logical font.
filter | The handle font smooth mode, it must be a value of mg_FT_LcdFilter.
Returns:
TRUE on success, otherwise FALSE.
See also:
mg_FT_LcdFilter

PLOGFONT GUIAPI GetCurFont ( HDC hdc )

Gets the pointer to the current logical font of a DC.

This function returns the pointer to the current logical font selected to the DC hdc.

Parameters:
hdc The device context.
Returns:
The pointer to the current logical font.
See also:
GetLogFontInfo, SelectFont

void GUIAPI GetFontMetrics | ( | LOGFONT * | log_font,
 |  | FONTMETRICS * | font_metrics
 | ) |  |

Gets metrics information of a logical font.

This function returns the font metrics information of the specified logical font log_font.

Parameters:
log_font | The pointer to the logical font.
font_metrics | The buffer receives the metrics information.
Returns:
None.
See also:
GetGlyphBitmap, FONTMETRICS

void GUIAPI GetGlyphBitmap | ( | LOGFONT * | log_font,
 |  | const char * | mchar,
 |  | int | mchar_len,
 |  | GLYPHBITMAP * | glyph_bitmap
 | ) |  |

Gets the glyph bitmap information when uses a logical font to output a character.

This function gets the glyph bitmap of one multi-byte character (specified by mchar and mchar_len) and returns the bitmap information through font_bitmap when using log_font to render the character.

Parameters:
log_font | The logical font used to render the character.
mchar | The pointer to the multi-byte character.
mchar_len | The length of the multi-byte character.
glyph_bitmap | The buffer receives the glyph bitmap information.
Returns:
None.
Example:
      GLYPHBITMAP glyph_bitmap = {0};

      GetGlyphBitmap (log_font, "A", 1, &glyph_bitmap);

See also:
GetFontMetrics, GLYPHBITMAP

void GUIAPI GetLogFontInfo | ( | HDC | hdc,
 |  | LOGFONT * | log_font
 | ) |  |

Gets logical font information of a DC.

This function gets the logical font information of the specified DC hdc, and copies to the LOGFONT structure pointed to by log_font.

Parameters:
hdc | The device context.
log_font | The pointer to the LOGFONT structure to save the logical font info.
See also:
GetCurFont

const DEVFONT *GUIAPI GetNextDevFont ( const DEVFONT * dev_font )

Get next devfont information.

This function can be used to enumerate all device fonts loaded by MiniGUI.

Parameters:
dev_font The pointer to the current device font, can be NULL to get the first device font.
Returns:
The next device font.

BOOL GUIAPI InitVectorialFonts ( void )

Initializes vectorial font renderer.

This function initializes vectorial font renderer for MiniGUI-Processes application. For the performance reason, MiniGUI-Processes does not load vetorical fonts, such as TrueType or Adobe Type1, at startup. If you want to render text in vectorial fonts, you must call this function to initialize TrueType and Type1 font renderer.

Returns:
TRUE on success, FALSE on error.
Note:
Only defined for non-threads runmode. If your MiniGUI configured as MiniGUI-Threads, no need to initialize TrueType and Type1 font renderer explicitly.
See also:
TermVectorialFonts

DEVFONT *GUIAPI LoadDevFontFromFile | ( | const char * | devfont_name,
 |  | const char * | file_name
 | ) |  |

Load device font from font file.

This function can be used to load device font from font file.Now,it support free type font file and qpf font file.

Parameters:
devfont_name | The device font name.
file_name | The font file name.
Returns:
the pointer to the new device font on success, NULL on error.
See also:
GetNextDevFont, DestroyDynamicDevFont

PLOGFONT GUIAPI SelectFont | ( | HDC | hdc,
 |  | PLOGFONT | log_font
 | ) |  |

Selects a logical font into a DC.

This function selects the specified logical font log_font into the device context hdc.

Parameters:
hdc | The device context.
log_font | The pointer to the logical font to be selected into the DC.
Returns:
The old logical font of the DC.
See also:
GetCurFont
Example:

void OnModeDrawText (HDC hdc)
{
    RECT rc1, rc2, rc3, rc4;
    const char* szBuff1 = "This is a good day. \n"
            "This text is drawn by calling DrawText.";
    const char* szBuff2 = "This is a good day. \n"
            "This text is drawn by calling DrawText.";
    const char* szBuff3 = "Single line text, center.";
    const char* szBuff4 =
            "This text is drawn by calling DrawText.";

    rc1.left = 1; rc1.top  = 1; rc1.right = 401; rc1.bottom = 101;
    rc2.left = 0; rc2.top  = 110; rc2.right = 401; rc2.bottom = 351;
    rc3.left = 0; rc3.top  = 361; rc3.right = 401; rc3.bottom = 451;
    rc4.left = 0; rc4.top  = 461; rc4.right = 401; rc4.bottom = 551;

    SetBkColor (hdc, COLOR_lightwhite);

    Rectangle (hdc, rc1.left, rc1.top, rc1.right, rc1.bottom);
    Rectangle (hdc, rc2.left, rc2.top, rc2.right, rc2.bottom);
    Rectangle (hdc, rc3.left, rc3.top, rc3.right, rc3.bottom);
    Rectangle (hdc, rc4.left, rc4.top, rc4.right, rc4.bottom);

    InflateRect (&rc1, -1, -1);
    InflateRect (&rc2, -1, -1);
    InflateRect (&rc3, -1, -1);
    InflateRect (&rc4, -1, -1);

    SelectFont (hdc, logfontgb12);
    DrawText (hdc, szBuff1, -1, &rc1, DT_NOCLIP | DT_CENTER | DT_WORDBREAK);

    SelectFont (hdc, logfontgb16);
    DrawText (hdc, szBuff2, -1, &rc2, DT_NOCLIP | DT_RIGHT | DT_WORDBREAK);

    SelectFont (hdc, logfontgb24);
    DrawText (hdc, szBuff3, -1, &rc3, DT_NOCLIP | DT_SINGLELINE | DT_CENTER | DT_VCENTER);

    SelectFont (hdc, logfontgb16);
    DrawTextEx (hdc, szBuff4, -1, &rc4, 32, DT_NOCLIP | DT_LEFT | DT_WORDBREAK);
}

void GUIAPI TermVectorialFonts ( void )

Terminates vectorial font renderer.

This function terminates the vectorial font renderer. When you are done with vectorial fonts, you should call this function to unload the vectorial fonts to save memory.

Note:
Only defined for non-threads runmode.
See also:
InitVectorialFonts

Generated on Fri Dec 17 13:49:48 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _LOGFONT Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_LOGFONT Struct Reference
[Logical font operations]

#include <gdi.h>

Data Fields

  • char type [LEN_FONT_NAME+1]
  • char family [LEN_FONT_NAME+1]
  • char charset [LEN_FONT_NAME+1]
  • DWORD style
  • int size
  • int rotation
  • int ascent
  • int descent
  • unsigned short sbc_scale
  • unsigned short mbc_scale
  • DEVFONT * sbc_devfont
  • DEVFONT * mbc_devfont

Detailed Description

The logical font structure.

Definition at line 5680 of file gdi.h.

Field Documentation

char type[LEN_FONT_NAME+1]

The type of the logical font.

Definition at line 5682 of file gdi.h.

char family[LEN_FONT_NAME+1]

The family name of the logical font.

Definition at line 5684 of file gdi.h.

char charset[LEN_FONT_NAME+1]

The charset of the logical font.

Definition at line 5686 of file gdi.h.

DWORD style

The styles of the logical font.

Definition at line 5688 of file gdi.h.

int size

The size of the logical font.

Definition at line 5690 of file gdi.h.

int rotation

The rotation angle of the logical font.

Definition at line 5692 of file gdi.h.

int ascent

The ascent of the logical font.

Definition at line 5694 of file gdi.h.

int descent

The descent of the logical font.

Definition at line 5696 of file gdi.h.

unsigned short sbc_scale

The scale factor of sbc device font.

Definition at line 5698 of file gdi.h.

unsigned short mbc_scale

The scale factor of mbc device font.

Definition at line 5700 of file gdi.h.

DEVFONT* sbc_devfont

Device font in single charset set

Definition at line 5702 of file gdi.h.

DEVFONT* mbc_devfont

Device font in multiply charset set

Definition at line 5704 of file gdi.h.

The documentation for this struct was generated from the following file:
  • gdi.h
Generated on Fri Dec 17 13:49:52 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _DEVFONT Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_DEVFONT Struct Reference
[Logical font operations]

#include <gdi.h>

Data Fields

  • char name [LEN_UNIDEVFONT_NAME+1]
  • DWORD style
  • FONTOPS * font_ops
  • CHARSETOPS * charset_ops
  • struct _DEVFONT * next
  • void * data
  • void * relationship
  • BOOL need_unload

Detailed Description

The device font structure.

Definition at line 5787 of file gdi.h.

Field Documentation

char name[LEN_UNIDEVFONT_NAME+1]

The device font name.

Definition at line 5790 of file gdi.h.

DWORD style

The styles of the device font.

Definition at line 5793 of file gdi.h.

FONTOPS* font_ops

The pointer to font operation structure.

Definition at line 5796 of file gdi.h.

CHARSETOPS* charset_ops

The pointer to character set operation structure.

Definition at line 5799 of file gdi.h.

struct _DEVFONT* next [read]

The pointer to next device font.

Definition at line 5802 of file gdi.h.

void* data

The device font used data.

Definition at line 5805 of file gdi.h.

void* relationship

The device font used relationship.

Definition at line 5808 of file gdi.h.

BOOL need_unload

indicating if the data need to be unloaded before delete a devfont

Definition at line 5811 of file gdi.h.

The documentation for this struct was generated from the following file:
  • gdi.h
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _FONTMETRICS Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_FONTMETRICS Struct Reference
[Logical font operations]

#include <gdi.h>

Data Fields

  • int font_height
  • int ascent
  • int descent
  • int max_width
  • int ave_width

Detailed Description

The font metrics structure.

Definition at line 5827 of file gdi.h.

Field Documentation

int font_height

The height of the logical font.

Definition at line 5830 of file gdi.h.

int ascent

The ascent of the logical font.

Definition at line 5832 of file gdi.h.

int descent

The descent of the logical font.

Definition at line 5834 of file gdi.h.

int max_width

The maximal width of the logical font.

Definition at line 5837 of file gdi.h.

int ave_width

The average width of the logical font.

Definition at line 5839 of file gdi.h.

The documentation for this struct was generated from the following file:
  • gdi.h
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _GLYPHBITMAP Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_GLYPHBITMAP Struct Reference
[Logical font operations]

#include <gdi.h>

Data Fields

  • int bbox_x
  • int advance_x
  • size_t bmp_size
  • int bmp_pitch
  • const unsigned char * bits

Detailed Description

The glyph bitmap structure.

Definition at line 5860 of file gdi.h.

Field Documentation

int bbox_x

The bounding box of the glyph.

Definition at line 5863 of file gdi.h.

int advance_x

The advance value of the glyph.

Definition at line 5865 of file gdi.h.

size_t bmp_size

The size of the glyph bitmap.

Definition at line 5868 of file gdi.h.

int bmp_pitch

The pitch of the glyph bitmap.

Definition at line 5870 of file gdi.h.

const unsigned char* bits

The pointer to the buffer of glyph bitmap bits.

Definition at line 5872 of file gdi.h.

The documentation for this struct was generated from the following file:
  • gdi.h
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: System charset and font operations

System charset and font operations
[GDI functions]

Defines

  • #define SYSLOGFONT_DEFAULT 0
  • #define SYSLOGFONT_WCHAR_DEF 1
  • #define SYSLOGFONT_FIXED 2
  • #define SYSLOGFONT_CAPTION 3
  • #define SYSLOGFONT_MENU 4
  • #define SYSLOGFONT_CONTROL 5

Functions

  • static PLOGFONT GUIAPI GetSystemFont (int font_id)
    Gets the system logical font through an font identifier.
  • MG_EXPORT int GUIAPI GetSysFontMaxWidth (int font_id)
    Gets the maximal width of a single-byte character of a system font.
  • MG_EXPORT int GUIAPI GetSysFontAveWidth (int font_id)
    Gets the average width of a single-byte character of a system font.
  • MG_EXPORT int GUIAPI GetSysFontHeight (int font_id)
    Gets the height of a single-byte character of a system font.
  • MG_EXPORT const char *GUIAPI GetSysCharset (BOOL wchar)
    Gets the current system charset.
  • MG_EXPORT int GUIAPI GetSysCharHeight (void)
    Gets the height of a character of the default system font.
  • MG_EXPORT int GUIAPI GetSysCharWidth (void)
    Gets the width of a single-byte character of the default system font.
  • MG_EXPORT int GUIAPI GetSysCCharWidth (void)
    Gets the width of a multi-byte character of the default system font.

Detailed Description

MiniGUI creates a few system fonts to draw menu text, window caption, or other general items. MiniGUI at least creates two system fonts: one mono-space logical font for single-byte charset, and one mono-space logical font for multi-byte charset. For the multi-byte charset, the width of one multi-byte character should be equal to the width of two single-byte characters.

Define Documentation

#define SYSLOGFONT_CAPTION 3

See also:
GetSystemFont

Definition at line 6262 of file gdi.h.

#define SYSLOGFONT_CONTROL 5

See also:
GetSystemFont

Definition at line 6274 of file gdi.h.

#define SYSLOGFONT_DEFAULT 0

See also:
GetSystemFont

Definition at line 6244 of file gdi.h.

#define SYSLOGFONT_FIXED 2

See also:
GetSystemFont

Definition at line 6256 of file gdi.h.

#define SYSLOGFONT_MENU 4

See also:
GetSystemFont

Definition at line 6268 of file gdi.h.

#define SYSLOGFONT_WCHAR_DEF 1

See also:
GetSystemFont

Definition at line 6250 of file gdi.h.

Function Documentation

int GUIAPI GetSysCCharWidth ( void )

Gets the width of a multi-byte character of the default system font.

This function returns the width of a multi-byte character of the default system font. MiniGUI uses mono-space font as the system default font.

Returns:
The width of multi-byte character of the default system font.
See also:
GetSysCharHeight, GetSysCharWidth

int GUIAPI GetSysCharHeight ( void )

Gets the height of a character of the default system font.

This function returns the height of a character of the system default font. MiniGUI uses mono-space font as the default system font.

Normally, the width of one multi-byte character is equal to the width of two single-byte character when using the default system font.

Returns:
The character height of the default system font.
See also:
GetSysCharWidth, GetSysCCharWidth

const char *GUIAPI GetSysCharset ( BOOL wchar )

Gets the current system charset.

This function gets the current system charset and returns the charset name. By default, the system charset is ISO8859-1 (for single-byte charset) or GB2312.1980-0 (for wide charset), but you can change it by modifying MiniGUI.cfg.

Parameters:
wchar Whether to retrieve the wide charset supported currently.
Returns:
The read-only buffer of charset name. If you pass wchar TRUE, This function may return NULL, if there is not any wide charset supported.

int GUIAPI GetSysCharWidth ( void )

Gets the width of a single-byte character of the default system font.

This function returns the width of a single-byte character of the default system font. MiniGUI uses mono-space font as the default system font, but you can specify a different font to output text in windows of MiniGUI.

Returns:
The width of single-byte character of the default system font.
See also:
GetSysCharHeight, GetSysCCharWidth, SelectFont, CreateLogFont

int GUIAPI GetSysFontAveWidth ( int font_id )

Gets the average width of a single-byte character of a system font.

This function returns the average width of a single-byte character of one system font.

Parameters:
font_id The identifier of a system font.
Returns:
The average width of single-byte character of the default system font.
See also:
GetSystemFont

int GUIAPI GetSysFontHeight ( int font_id )

Gets the height of a single-byte character of a system font.

This function returns the height of a single-byte character of one system font.

Parameters:
font_id The identifier of a system font.
Returns:
The height of single-byte character of the default system font.
See also:
GetSystemFont

int GUIAPI GetSysFontMaxWidth ( int font_id )

Gets the maximal width of a single-byte character of a system font.

This function returns the maximal width of a single-byte character of one system font.

Parameters:
font_id The identifier of a system font.
Returns:
The maximal width of single-byte character of the default system font.
See also:
GetSystemFont

PLOGFONT GUIAPI GetSystemFont ( int font_id ) [inline, static]

Gets the system logical font through an font identifier.

This function returns the system logical font through the font identifier font_id.

Parameters:
font_id The identifier of a system font, can be one of the following values:
  • SYSLOGFONT_DEFAULT
    The default system logical font in single-byte charset, must be rbf.
  • SYSLOGFONT_WCHAR_DEF
    The default system logical font in multi-byte charset, must be rbf.
  • SYSLOGFONT_FIXED
    The fixed space system logical font.
  • SYSLOGFONT_CAPTION
    The system logical font used to draw caption text.
  • SYSLOGFONT_MENU
    The system logical font used to draw menu items.
  • SYSLOGFONT_CONTROL
    The system logical font used to draw controls.
Returns:
The pointer to the system logical font. NULL on error.

Definition at line 6304 of file gdi.h.

References NULL.

Generated on Fri Dec 17 13:49:48 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Text parsing functions

Text parsing functions
[GDI functions]

Data Structures

  • struct _WORDINFO

Defines

  • #define MB2WC(log_font, dest, mstr, n) MB2WCEx (log_font, dest, sizeof(wchar_t) == 4, mstr, n)
    The backward compatibility version of MB2WCEx.
  • #define WC2MB(log_font, s, wc) WC2MBEx (log_font, s, (UChar32)wc)
    The backward compatibility version of WC2MBEx.
  • #define MBS2WCS(log_font, dest, mstr, mstr_len, n)
    The backward compatibility version of MBS2WCSEx.
  • #define WCS2MBS(log_font, dest, wcs, wcs_len, n)
    The backward compatibility version of WCS2MBSEx.

Functions

  • MG_EXPORT int GUIAPI GetTextMCharInfo (PLOGFONT log_font, const char *mstr, int len, int *pos_chars)
    Retrieves positions of multi-byte characters in a string.
  • MG_EXPORT int GUIAPI GetTextWordInfo (PLOGFONT log_font, const char *mstr, int len, int *pos_words, WORDINFO *info_words)
    Retrieves information of multi-byte words in a string.
  • MG_EXPORT int GUIAPI GetFirstMCharLen (PLOGFONT log_font, const char *mstr, int len)
    Retrieves the length of the first multi-byte character in a string.
  • MG_EXPORT int GUIAPI GetFirstWord (PLOGFONT log_font, const char *mstr, int len, WORDINFO *word_info)
    Retrieves the length and info of the first multi-byte word in a string.
  • MG_EXPORT int GUIAPI MB2WCEx (PLOGFONT log_font, void *dest, BOOL wc32, const unsigned char *mstr, int n)
    Converts a multibyte character to a wide character in UCS according to the charset/encoding of the logical font.
  • MG_EXPORT int GUIAPI WC2MBEx (PLOGFONT log_font, unsigned char *s, UChar32 wc)
    Converts a wide character in UCS to a multibyte character according to the charset/encoding of the logical font.
  • MG_EXPORT int GUIAPI MBS2WCSEx (PLOGFONT log_font, void *dest, BOOL wc32, const unsigned char *mstr, int mstr_len, int n, int *conved_mstr_len)
    Converts a multibyte string to a wide character string in UC16 according to the charset/encoding of the logical font.
  • MG_EXPORT int GUIAPI WCS2MBSEx (PLOGFONT log_font, unsigned char *dest, const void *wcs, int wcs_len, BOOL wc32, int n, int *conved_wcs_len)
    Converts a wide character string in UC16 to a multibyte string according to the charset/encoding of the logical font.
  • MG_EXPORT int GUIAPI GetTextExtentPoint (HDC hdc, const char *text, int len, int max_extent, int *fit_chars, int *pos_chars, int *dx_chars, SIZE *size)
    Computes the extent of a string when output the string in a limited space.
  • MG_EXPORT int GUIAPI GetTabbedTextExtentPoint (HDC hdc, const char *text, int len, int max_extent, int *fit_chars, int *pos_chars, int *dx_chars, SIZE *size)
    Computes the extent of a string when output the formatted string in a limited space.

Detailed Description

MiniGUI uses logical font to output text, also uses logical font to parsing the multi-byte characters and words in the text.

Define Documentation

#define MB2WC | ( | log_font,
 |  | dest,
 |  | mstr,
 |  | n | ) | MB2WCEx (log_font, dest, sizeof(wchar_t) == 4, mstr, n)

The backward compatibility version of MB2WCEx.

See also:
MB2WCEx

Definition at line 6565 of file gdi.h.

#define MBS2WCS | ( | log_font,
 |  | dest,
 |  | mstr,
 |  | mstr_len,
 |  | n | )

Value:

MBS2WCSEx(log_font, dest, sizeof (wchar_t) == 4, mstr, \
            mstr_len, n, NULL)
The backward compatibility version of MBS2WCSEx.

See also:
MBS2WCSEx

Definition at line 6638 of file gdi.h.

#define WC2MB | ( | log_font,
 |  | s,
 |  | wc | ) | WC2MBEx (log_font, s, (UChar32)wc)

The backward compatibility version of WC2MBEx.

See also:
WC2MBEx

Definition at line 6593 of file gdi.h.

#define WCS2MBS | ( | log_font,
 |  | dest,
 |  | wcs,
 |  | wcs_len,
 |  | n | )

Value:

WCS2MBSEx (log_font, dest, wcs, wcs_len, sizeof (wchar_t) == 4, \
            n, NULL)
The backward compatibility version of WCS2MBSEx.

See also:
WCS2MBSEx

Definition at line 6684 of file gdi.h.

Function Documentation

MG_EXPORT int GUIAPI GetFirstMCharLen | ( | PLOGFONT | log_font,
 |  | const char * | mstr,
 |  | int | len
 | ) |  |

Retrieves the length of the first multi-byte character in a string.

This function retrieves and returns the length of the first multi-byte character in the string mstr which is len bytes long.

Parameters:
log_font | The logical font used to parse the multi-byte string.
mstr | The multi-byte string.
len | The length of the string.
Returns:
The length of the first multi-byte character.
See also:
GetFirstWord

MG_EXPORT int GUIAPI GetFirstWord | ( | PLOGFONT | log_font,
 |  | const char * | mstr,
 |  | int | len,
 |  | WORDINFO * | word_info
 | ) |  |

Retrieves the length and info of the first multi-byte word in a string.

This function retrieves the information of the first multi-byte character in the string mstr which is len bytes long, and returns it through word_info. It also returns the full length of the word including the delimiters after the word.

Parameters:
log_font | The logical font used to parse the multi-byte string.
mstr | The multi-byte string.
len | The length of the string.
word_info | The pointer to a WORDINFO structure used to return the word information.
Returns:
The length of the first multi-byte word.
See also:
GetFirstMCharLen, WORDINFO

int GUIAPI GetTabbedTextExtentPoint | ( | HDC | hdc,
 |  | const char * | text,
 |  | int | len,
 |  | int | max_extent,
 |  | int * | fit_chars,
 |  | int * | pos_chars,
 |  | int * | dx_chars,
 |  | SIZE * | size
 | ) |  |

Computes the extent of a string when output the formatted string in a limited space.

int GUIAPI GetTextExtentPoint | ( | HDC | hdc,
 |  | const char * | text,
 |  | int | len,
 |  | int | max_extent,
 |  | int * | fit_chars,
 |  | int * | pos_chars,
 |  | int * | dx_chars,
 |  | SIZE * | size
 | ) |  |

Computes the extent of a string when output the string in a limited space.

This function computes the extent of the specified string of text text which is len bytes long when output the text in a limited space (max_extent wide). If pos_chars and dx_chars are not NULL, this function will return the positions of each character in the text, and the output position of each character. This function returns the text extent in a SIZE struct pointed to by size, and the width of text as return value.

Parameters:
hdc | The device context.
text | The multi-byte string.
len | The length of the string.
max_extent | The width of the limited space.
fit_chars | The number of the characters actually outputed.
pos_chars | The positions of each character in the text will be returned through this pointer.
dx_chars | The output positions of each character in the text will be returned through this pointer.
size | The output extent of the text in the limited space will be returned through this pointer.
Returns:
The number of the characters which can be fit to the limited space.
See also:
GetFirstMCharLen, GetFirstWord

MG_EXPORT int GUIAPI GetTextMCharInfo | ( | PLOGFONT | log_font,
 |  | const char * | mstr,
 |  | int | len,
 |  | int * | pos_chars
 | ) |  |

Retrieves positions of multi-byte characters in a string.

This function retrieves position of multi-byte characters in the string mstr which is len bytes long. It returns the positions of characters in the string in an integer array pointed to by pos_chars.

Parameters:
log_font | The logical font used to parse the multi-byte string.
mstr | The multi-byte string.
len | The length of the string.
pos_chars | The position of characters will be returned through this array if it is not NULL.
Returns:
The number of characters in the multi-byte string.
See also:
GetTextWordInfo

MG_EXPORT int GUIAPI GetTextWordInfo | ( | PLOGFONT | log_font,
 |  | const char * | mstr,
 |  | int | len,
 |  | int * | pos_words,
 |  | WORDINFO * | info_words
 | ) |  |

Retrieves information of multi-byte words in a string.

This function retrieves information of multi-byte words in the string mstr which is len bytes long. It returns the positions of words in the string in an integer array pointed to by pos_words if the pointer is not NULL. This function also returns the information of words in a WORDINFO struct array pointed to by info_words when the pointer is not NULL.

Parameters:
log_font | The logical font used to parse the multi-byte string.
mstr | The multi-byte string.
len | The length of the string.
pos_words | The position of words will be returned through this array if it is not NULL.
info_words | The words' information will be returned through this array if it is not NULL.
Returns:
The number of words in the multi-byte string.
See also:
GetTextMCharInfo, WORDINFO

MG_EXPORT int GUIAPI MB2WCEx | ( | PLOGFONT | log_font,
 |  | void * | dest,
 |  | BOOL | wc32,
 |  | const unsigned char * | mstr,
 |  | int | n
 | ) |  |

Converts a multibyte character to a wide character in UCS according to the charset/encoding of the logical font.

Parameters:
log_font | The logical font.
dest | The buffer used to store the wide character; can be NULL.
wc32 | Whether the wide char is 32-bit long. TRUE for yes, FALSE for 16-bit long.
mstr | The pointer to the multi-byte character.
n | The length of the multi-byte character.
Returns:
If mchar is not NULL, the function returns the number of consumed bytes starting at mchar, or 0 if s points to a null byte, or -1 upon failure.
See also:
WC2MBEx, mbtowc

MG_EXPORT int GUIAPI MBS2WCSEx | ( | PLOGFONT | log_font,
 |  | void * | dest,
 |  | BOOL | wc32,
 |  | const unsigned char * | mstr,
 |  | int | mstr_len,
 |  | int | n,
 |  | int * | conved_mstr_len
 | ) |  |

Converts a multibyte string to a wide character string in UC16 according to the charset/encoding of the logical font.

This function is a MiniGUI version of ISO/ANSI mbstowcs function. It converts a multibyte string to a wide character string in UC16. The behaviour of mbstowcs depends on the LC_CTYPE category of the current locale, while MBS2WCS depends on the charset/encoding of MiniGUI logical font.

Parameters:
log_font | The logical font.
dest | The buffer used to store the converted wide character string.
wc32 | Whether the unicode char is 32-bit long. TRUE for yes, FALSE for 16-bit long.
mstr | The pointer to multibyte string.
mstr_len | The length of the multibyte string in bytes.
n | The length of the buffer in wide characters.
conved_mstr_len | The length of the multibyte string which are converted correctly in bytes will be returned through this pointer, can be NULL.
Returns:
The function returns the number of wide characters that make up the converted part of the wide character string, not including the terminating null wide character. If an invalid multibyte sequence was encountered, -1 is returned.
See also:
WCS2MBSEx, mbstowcs, mbsrtowcs

MG_EXPORT int GUIAPI WC2MBEx | ( | PLOGFONT | log_font,
 |  | unsigned char * | s,
 |  | UChar32 | wc
 | ) |  |

Converts a wide character in UCS to a multibyte character according to the charset/encoding of the logical font.

Parameters:
log_font | The logical font.
s | The buffer used to store the converted multibyte characters.
wc | The wide character.
Returns:
If s is not NULL, the function returns the number of bytes that have been written to the byte array at s. If wc can not be represented as a multibyte sequence (according to the current logfont), -1 is returned.
See also:
WC2MB, mbtowc

MG_EXPORT int GUIAPI WCS2MBSEx | ( | PLOGFONT | log_font,
 |  | unsigned char * | dest,
 |  | const void * | wcs,
 |  | int | wcs_len,
 |  | BOOL | wc32,
 |  | int | n,
 |  | int * | conved_wcs_len
 | ) |  |

Converts a wide character string in UC16 to a multibyte string according to the charset/encoding of the logical font.

This function is a MiniGUI version of ISO/ANSI wcstombs function. It converts a wide character string in UC16 to a multibyte string. The behaviour of wcstombs depends on the LC_CTYPE category of the current locale, while WCS2MBS depends on the charset/encoding of MiniGUI logical font.

Parameters:
log_font | The logical font.
dest | The buffer used to store the converted multibyte string.
wcs | The pointer to the wide character string.
wcs_len | The number of the wide characters in wcs.
wc32 | Whether the wide char is 32-bit long. TRUE for yes, FALSE for 16-bit long.
n | The length of the dest in bytes.
conved_wcs_len | The number of the wide characters which are converted correctly will be returned through this pointer, can be NULL.
Returns:
The function returns the number of bytes that make up the converted part of multibyte sequence, not including the terminating null byte. If a wide character was encountered which could not be converted, -1 is returned.
See also:
MBS2WCSEx, wcstombs, wcsrtombs

Generated on Fri Dec 17 13:49:48 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _WORDINFO Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_WORDINFO Struct Reference
[Text parsing functions]

#include <gdi.h>

Data Fields

  • int len
  • unsigned char delimiter
  • int nr_delimiters

Detailed Description

Word information structure

Definition at line 6432 of file gdi.h.

Field Documentation

int len

The length of the word.

Definition at line 6435 of file gdi.h.

unsigned char delimiter

The delimiter after the word.

Definition at line 6437 of file gdi.h.

int nr_delimiters

The number of delimiters after the word.

Definition at line 6439 of file gdi.h.

The documentation for this struct was generated from the following file:
  • gdi.h
Generated on Fri Dec 17 13:49:52 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Text output functions

Text output functions
[GDI functions]

Data Structures

  • struct _DTFIRSTLINE

Defines

  • #define GetTextCharacterExtra(hdc) GetDCAttr (hdc, DC_ATTR_CHAR_EXTRA)
    Retrieves the current intercharacter spacing for the DC.
  • #define GetTextAboveLineExtra(hdc) GetDCAttr (hdc, DC_ATTR_ALINE_EXTRA)
    Retrieves the current spacing above line for the DC.
  • #define GetTextBellowLineExtra(hdc) GetDCAttr (hdc, DC_ATTR_BLINE_EXTRA)
    Retrieves the current spacing bellow line for the DC.
  • #define SetTextCharacterExtra(hdc, extra) SetDCAttr (hdc, DC_ATTR_CHAR_EXTRA, (DWORD) extra)
    Sets the intercharacter spacing for the DC and returns the old spacing value.
  • #define SetTextAboveLineExtra(hdc, extra) SetDCAttr (hdc, DC_ATTR_ALINE_EXTRA, (DWORD) extra)
    Sets the spacing above line for the DC and returns the old value.
  • #define SetTextBellowLineExtra(hdc, extra) SetDCAttr (hdc, DC_ATTR_BLINE_EXTRA, (DWORD) extra)
    Sets the spacing bellow line for the DC and returns the old value.
  • #define GetTextAlign(hdc) GetDCAttr (hdc, DC_ATTR_TEXT_ALIGN)
    Retrieves the current text-alignment flags of a DC.
  • #define SetTextAlign(hdc, ta_flags) SetDCAttr (hdc, DC_ATTR_TEXT_ALIGN, (DWORD)ta_flags)
    Sets text-alignment flags of a DC.
  • #define TextOut(hdc, x, y, text) TextOutLen (hdc, x, y, text, -1)
    Outputs text.
  • #define TabbedTextOut(hdc, x, y, text) TabbedTextOutLen (hdc, x, y, text, -1)
    Outputs formatted text.
  • #define DrawText(hdc, text, n, rc, format) DrawTextEx2 (hdc, text, n, rc, 0, format, NULL)
    Draws a formatted text in a rectangle.
  • #define DrawTextEx(hdc, text, n, rc, indent, format) DrawTextEx2 (hdc, text, n, rc, indent, format, NULL)
    Draws a formatted text in a rectangle.

Functions

  • MG_EXPORT int GUIAPI GetFontHeight (HDC hdc)
    Retrieves the height of the current logical font in a DC.
  • MG_EXPORT int GUIAPI GetMaxFontWidth (HDC hdc)
    Retrieves the maximal character width of the current logical font in a DC.
  • MG_EXPORT int GUIAPI GetTextExtent (HDC hdc, const char *spText, int len, SIZE *pSize)
    Computes the output extent of a string of text.
  • MG_EXPORT int GUIAPI GetTabbedTextExtent (HDC hdc, const char *spText, int len, SIZE *pSize)
    Computes the output extent of a formatted text.
  • MG_EXPORT int GUIAPI TextOutLen (HDC hdc, int x, int y, const char *spText, int len)
    Outputs a string of text.
  • MG_EXPORT int GUIAPI TextOutOmitted (HDC hdc, int x, int y, const char *mtext, int len, int max_extent)
    Outputs a string of text with omitted format.
  • MG_EXPORT int GUIAPI TabbedTextOutLen (HDC hdc, int x, int y, const char *spText, int len)
    Outputs a formatted text.
  • MG_EXPORT int GUIAPI TabbedTextOutEx (HDC hdc, int x, int y, const char *spText, int nCount, int nTabPositions, int *pTabPositions, int nTabOrigin)
    Writes a character string at a specified location, expanding tabs to the values specified in an anrry of tab-stop positions.
  • MG_EXPORT void GUIAPI GetLastTextOutPos (HDC hdc, POINT *pt)
    Retrieves the last text output position.
  • MG_EXPORT int GUIAPI DrawTextEx2 (HDC hdc, const char *pText, int nCount, RECT *pRect, int nIndent, UINT nFormat, DTFIRSTLINE *firstline)
    Draws a formatted text in a rectangle.

Define Documentation

#define DrawText | ( | hdc,
 |  | text,
 |  | n,
 |  | rc,
 |  | format | ) | DrawTextEx2 (hdc, text, n, rc, 0, format, NULL)

Draws a formatted text in a rectangle.

Defined as a macro calling DrawTextEx2 passing nIndent as 0 and firstline as NULL.

See also:
DrawTextEx2

Definition at line 7248 of file gdi.h.

#define DrawTextEx | ( | hdc,
 |  | text,
 |  | n,
 |  | rc,
 |  | indent,
 |  | format | ) | DrawTextEx2 (hdc, text, n, rc, indent, format, NULL)

Draws a formatted text in a rectangle.

Defined as a macro calling DrawTextEx2 passing firstline as NULL.

See also:
DrawTextEx2

Definition at line 7259 of file gdi.h.

#define GetTextAboveLineExtra ( hdc ) GetDCAttr (hdc, DC_ATTR_ALINE_EXTRA)

Retrieves the current spacing above line for the DC.

See also:
SetTextAboveLineExtra

Definition at line 6832 of file gdi.h.

#define GetTextAlign ( hdc ) GetDCAttr (hdc, DC_ATTR_TEXT_ALIGN)

Retrieves the current text-alignment flags of a DC.

Parameters:
hdc The device context.
Returns:
The return value is one or more of the following values:
  • TA_TOP
    Specifies alignment of the x-axis and the top of the bounding rectangle.
  • TA_BASELINE
    Specifies alignment of the x-axis and the baseline of the chosen font within the bounding rectangle.
  • TA_BOTTOM
    Specifies alignment of the x-axis and the bottom of the bounding rectangle.
  • TA_LEFT
    Specifies alignment of the y-axis and the left side of the bounding rectangle.
  • TA_RIGHT
    Specifies alignment of the y-axis and the right side of the bounding rectangle.
  • TA_CENTER
    Specifies alignment of the y-axis and the center of the bounding rectangle. Note that MiniGUI does not support TA_CENTER so far.
  • TA_NOUPDATECP
    Specifies that the current position is not updated.
  • TA_UPDATECP
    Specifies that the current position is updated.

Note:
The text-alignment flags determine how the TextOut, TabbedTextOut, and TabbedTextOutEx functions align a string of text in relation to the string's starting point. The text-alignment flags are not necessarily single-bit flags and may be equal to 0. To test whether a flag is set, an application should follow these steps:
1. Apply the bitwise OR operator to the flag and its related flags, grouped as follows:

  • TA_LEFT, TA_RIGHT, TA_CENTER (TA_X_MASK)
  • TA_BASELINE, TA_BOTTOM, and TA_TOP (TA_Y_MASK)
  • TA_NOUPDATECP and TA_UPDATECP (TA_CP_MASK)

2. Apply the bitwise-AND operator to the result and the return value of GetTextAlign.

3. Test for the equality of this result and the flag.

See also:
SetTextAlign

Definition at line 6935 of file gdi.h.

#define GetTextBellowLineExtra ( hdc ) GetDCAttr (hdc, DC_ATTR_BLINE_EXTRA)

Retrieves the current spacing bellow line for the DC.

See also:
SetTextBellowLineExtra

Definition at line 6840 of file gdi.h.

#define GetTextCharacterExtra ( hdc ) GetDCAttr (hdc, DC_ATTR_CHAR_EXTRA)

Retrieves the current intercharacter spacing for the DC.

See also:
SetTextCharacterExtra

Definition at line 6824 of file gdi.h.

#define SetTextAboveLineExtra | ( | hdc,
 |  | extra | ) | SetDCAttr (hdc, DC_ATTR_ALINE_EXTRA, (DWORD) extra)

Sets the spacing above line for the DC and returns the old value.

See also:
GetTextAboveLineExtra

Definition at line 6858 of file gdi.h.

#define SetTextAlign | ( | hdc,
 |  | ta_flags | ) | SetDCAttr (hdc, DC_ATTR_TEXT_ALIGN, (DWORD)ta_flags)

Sets text-alignment flags of a DC.

Parameters:
hdc | The device context.
ta_flags | The flags specify the relationship between a point and a rectangle that bounds the text. The point can be either the current position or coordinates specified by a text-output function. The rectangle that bounds the text is defined by the adjacent character cells in the text string. The ta_flags parameter can be one or more flags from the following three categories. Choose only one flag from each category.
The first category affects text alignment in the x-direction:
  • TA_LEFT
    Aligns the point with the left side of the bounding rectangle. This is the default setting.
  • TA_RIGHT
    Aligns the point with the right side of the bounding rectangle.
  • TA_CENTER
    Aligns the point with the horizontal center of the bounding rectangle. Note that MiniGUI does not support TA_CENTER so far.

The second category affects text alignment in the y-direction:

  • TA_BASELINE
    Aligns the point with the base line of the chosen font.
  • TA_BOTTOM
    Aligns the point with the bottom of the bounding rectangle.
  • TA_TOP
    Aligns the point with the top of the bounding rectangle. This is the default setting.

The third category determines whether the current position is updated when text is written:

  • TA_NOUPDATECP
    Does not update the current position after each call to a text-output function. This is the default setting.
  • TA_UPDATECP
    Updates the current x-position after each call to a text-output function. The new position is at the right side of the bounding rectangle for the text. When this flag is set, the coordinates specified in calls to the TextOut function are ignored.

Returns:
The previous text-alignment setting, if successful. The low-order word contains the horizontal setting and the high-order word contains the vertical setting; otherwise 0.
Note:
The TextOut, TabbedTextOut, and TabbedTextOutEx functions use these flags when positioning a string of text on a DC. The flags specify the relationship between a specific point and a rectangle that bounds the text. The coordinates of this point are passed as parameters to the TextOut function. The rectangle that bounds the text is formed by the adjacent character cells in the text string.
See also:
GetTextAlign

Definition at line 6993 of file gdi.h.

#define SetTextBellowLineExtra | ( | hdc,
 |  | extra | ) | SetDCAttr (hdc, DC_ATTR_BLINE_EXTRA, (DWORD) extra)

Sets the spacing bellow line for the DC and returns the old value.

See also:
GetTextBellowLineExtra

Definition at line 6867 of file gdi.h.

#define SetTextCharacterExtra | ( | hdc,
 |  | extra | ) | SetDCAttr (hdc, DC_ATTR_CHAR_EXTRA, (DWORD) extra)

Sets the intercharacter spacing for the DC and returns the old spacing value.

See also:
GetTextCharacterExtra

Definition at line 6849 of file gdi.h.

#define TabbedTextOut | ( | hdc,
 |  | x,
 |  | y,
 |  | text | ) | TabbedTextOutLen (hdc, x, y, text, -1)

Outputs formatted text.

Defined as a macro calling TabbedTextOutLen passing len as -1.

See also:
TextOutLen

Definition at line 7125 of file gdi.h.

#define TextOut | ( | hdc,
 |  | x,
 |  | y,
 |  | text | ) | TextOutLen (hdc, x, y, text, -1)

Outputs text.

Defined as a macro calling TextOutLen passing len as -1.

See also:
TextOutLen

Definition at line 7115 of file gdi.h.

Function Documentation

int GUIAPI DrawTextEx2 | ( | HDC | hdc,
 |  | const char * | pText,
 |  | int | nCount,
 |  | RECT * | pRect,
 |  | int | nIndent,
 |  | UINT | nFormat,
 |  | DTFIRSTLINE * | firstline
 | ) |  |

Draws a formatted text in a rectangle.

This function draws formatted text (pText) in the specified rectangle (pRect). It formats the text according to the specified method (through nFormat, including expanding tabs, justifying characters, breaking lines, and so forth).

Parameters:
hdc | The device context.
pText | The formatted text.
nCount | The length of the text. If it is less than 0, MiniGUI will treat it as a null-terminated string.
pRect | The output rectangle.
nIndent | The indent value of the first line.
nFormat | The methods used to format the text. MiniGUI support the following method to format text so far:
  • DT_TOP
    Top-justifies text (single line only).
  • DT_LEFT
    Aligns text to the left.
  • DT_CENTER
    Centers text horizontally in the rectangle.
  • DT_RIGHT
    Aligns text to the right.
  • DT_VCENTER
    Centers text vertically (single line only).
  • DT_BOTTOM
    Justify the text to the bottom of the rectangle. This value must be combined with DT_SINGLELINE.
  • DT_WORDBREAK
    Break words. Lines are automatically broken between words if a word would extend past the edge of the rectangle specified by the the pRect parameter. A carriage return or linefeed also breaks the line.
  • DT_CHARBREAK
    Break characters. Lines are automatically broken between characters if a character would extend past the edge of the rectangle specified by the the pRect parameter. A carriage return or linefeed also breaks the line. DT_CHARBREAK will override DT_WORDBREAK.
  • DT_SINGLELINE
    Display text on the single line only. Carriage returns and linefeeds do not break the line.
  • DT_EXPANDTABS
    Expands tab characters. The default number of character per tab is eight.
  • DT_TABSTOP
    Set tab stops. Bits 15-8 (high-order byte of the low-order word) of the uForma parameter specify the number of characters for each tab. The default number of characters per tab is eight.
  • DT_NOCLIP
    Draws without clipping. DrawText is somewhat faster when DT_NOCLIP is used.
  • DT_CALCRECT
    Determines the width and the height of the rectangle. If there are multiple lines of text, DrawText uses the width of the rectangle pointed to by the lpRect parameter and extends the base of the rectangle to bound the last line of text. If there is only one line of text, DrawText modifies the right side of the rectangle so that it bounds the last character in the line. In either case, DrawText returns the height of the formatted text but does not draw the text.

Parameters:
firstline If not null, DrawTextEx2 will only calculate the first line will be output in the rectangle, and return the number of the characters and the output width.
Returns:
The output height of the formatted text.
See also:
DrawText
Example:

void OnModeDrawText (HDC hdc)
{
    RECT rc1, rc2, rc3, rc4;
    const char* szBuff1 = "This is a good day. \n"
            "This text is drawn by calling DrawText.";
    const char* szBuff2 = "This is a good day. \n"
            "This text is drawn by calling DrawText.";
    const char* szBuff3 = "Single line text, center.";
    const char* szBuff4 =
            "This text is drawn by calling DrawText.";

    rc1.left = 1; rc1.top  = 1; rc1.right = 401; rc1.bottom = 101;
    rc2.left = 0; rc2.top  = 110; rc2.right = 401; rc2.bottom = 351;
    rc3.left = 0; rc3.top  = 361; rc3.right = 401; rc3.bottom = 451;
    rc4.left = 0; rc4.top  = 461; rc4.right = 401; rc4.bottom = 551;

    SetBkColor (hdc, COLOR_lightwhite);

    Rectangle (hdc, rc1.left, rc1.top, rc1.right, rc1.bottom);
    Rectangle (hdc, rc2.left, rc2.top, rc2.right, rc2.bottom);
    Rectangle (hdc, rc3.left, rc3.top, rc3.right, rc3.bottom);
    Rectangle (hdc, rc4.left, rc4.top, rc4.right, rc4.bottom);

    InflateRect (&rc1, -1, -1);
    InflateRect (&rc2, -1, -1);
    InflateRect (&rc3, -1, -1);
    InflateRect (&rc4, -1, -1);

    SelectFont (hdc, logfontgb12);
    DrawText (hdc, szBuff1, -1, &rc1, DT_NOCLIP | DT_CENTER | DT_WORDBREAK);

    SelectFont (hdc, logfontgb16);
    DrawText (hdc, szBuff2, -1, &rc2, DT_NOCLIP | DT_RIGHT | DT_WORDBREAK);

    SelectFont (hdc, logfontgb24);
    DrawText (hdc, szBuff3, -1, &rc3, DT_NOCLIP | DT_SINGLELINE | DT_CENTER | DT_VCENTER);

    SelectFont (hdc, logfontgb16);
    DrawTextEx (hdc, szBuff4, -1, &rc4, 32, DT_NOCLIP | DT_LEFT | DT_WORDBREAK);
}

int GUIAPI GetFontHeight ( HDC hdc )

Retrieves the height of the current logical font in a DC.

This function retrieves the height of the current logical font in the DC hdc.

Parameters:
hdc The device context.
Returns:
The height of the current logical font.
See also:
GetMaxFontWidth

void GUIAPI GetLastTextOutPos | ( | HDC | hdc,
 |  | POINT * | pt
 | ) |  |

Retrieves the last text output position.

Parameters:
hdc | The device context.
pt | The last text output position will be returned through this pointer.

int GUIAPI GetMaxFontWidth ( HDC hdc )

Retrieves the maximal character width of the current logical font in a DC.

This function retrieves the maximal character width of the current logical font in the DC hdc.

Parameters:
hdc The device context.
Returns:
The maximal character width of the current logical font.
See also:
GetFontHeight

int GUIAPI GetTabbedTextExtent | ( | HDC | hdc,
 |  | const char * | spText,
 |  | int | len,
 |  | SIZE * | pSize
 | ) |  |

Computes the output extent of a formatted text.

This function computes the output extent of the formatted text (spText) with length of len. This function returns the extent in a SIZE struct pointed to by pSize and the width of text as the return value. The output extent will be affected by the default tab size if there are some TAB characters in the text.

Parameters:
hdc | The device context.
spText | The pointer to the string of text.
len | The length of the text.
pSize | The output extent will be returned through this buffer.
Returns:
The width of the text in baseline direction.
See also:
GetTextExtent

int GUIAPI GetTextExtent | ( | HDC | hdc,
 |  | const char * | spText,
 |  | int | len,
 |  | SIZE * | pSize
 | ) |  |

Computes the output extent of a string of text.

This function computes the output extent of the text (spText) with length of len. This function returns the extent in a SIZE struct pointed to by pSize and the width of text as the return value.

Parameters:
hdc | The device context.
spText | The pointer to the string of text.
len | The length of the text.
pSize | The output extent will be returned through this buffer.
Returns:
The width of the text in baseline direction.
See also:
GetTabbedTextExtent

int GUIAPI TabbedTextOutEx | ( | HDC | hdc,
 |  | int | x,
 |  | int | y,
 |  | const char * | spText,
 |  | int | nCount,
 |  | int | nTabPositions,
 |  | int * | pTabPositions,
 |  | int | nTabOrigin
 | ) |  |

Writes a character string at a specified location, expanding tabs to the values specified in an anrry of tab-stop positions.

This function writes the string spText with length of nCount at a specified locations, expanding tabs to the value spcified in the array pTabPositions of tab-stop positions. The output will start a new line if there is a line feed character '
' in the text.

Parameters:
hdc | The device context.
x | x,y: The output start position.
y | x,y: The output start position.
spText | The formatted text.
nCount | The length of the text. If it is less than 0, MiniGUI will treat it as a null-terminated string.
nTabPositions | The length of the array of the tab-stop positions.
pTabPositions | The array of the tab-stop positions.
nTabOrigin | The origin of the tab-stops.
Returns:
The output width of the text.
See also:
TabbedTextOutLen

int GUIAPI TabbedTextOutLen | ( | HDC | hdc,
 |  | int | x,
 |  | int | y,
 |  | const char * | spText,
 |  | int | len
 | ) |  |

Outputs a formatted text.

This function outputs the formatted text spText with length of len at (x,y). This function returns the width of text. The output will start a new line if there is a line feed character '
' in the text. The output will be affected by the default tab size if there are some TAB characters in the text.

Parameters:
hdc | The device context.
x | x,y: The output start position.
y | x,y: The output start position.
spText | The formatted text.
len | The length of the text. If it is less than 0, MiniGUI will treat it as a null-terminated string.
Returns:
The output width of the text.
See also:
TextOutLen

int GUIAPI TextOutLen | ( | HDC | hdc,
 |  | int | x,
 |  | int | y,
 |  | const char * | spText,
 |  | int | len
 | ) |  |

Outputs a string of text.

This function outputs the text spText with length of len at a (x,y). This function returns the width of text.

Parameters:
hdc | The device context.
x | x,y: The output start position.
y | x,y: The output start position.
spText | The string of the text.
len | The length of the text. If it is less than 0, MiniGUI will treat it as a null-terminated string.
Returns:
The output width of the text.
See also:
TabbedTextOutLen

int GUIAPI TextOutOmitted | ( | HDC | hdc,
 |  | int | x,
 |  | int | y,
 |  | const char * | mtext,
 |  | int | len,
 |  | int | max_extent
 | ) |  |

Outputs a string of text with omitted format.

This function outputs the text mtext with length of len at a (x,y) with omitted format, if width of the text more than max_extent.This function returns the output width of the text.

Parameters:
hdc | The device context.
x | x,y: The output start position.
y | x,y: The output start position.
mtext | The string of the text.
len | The length of the text. If it is less than 0, MiniGUI will treat it as a null-terminated string.
max_extent | The max extent of output text.
Returns:
The output width of the text.
See also:
TextOutLen

Generated on Fri Dec 17 13:49:48 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _DTFIRSTLINE Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_DTFIRSTLINE Struct Reference
[Text output functions]

#include <gdi.h>

Data Fields

  • int nr_chars
  • int startx
  • int starty
  • int width
  • int height

Detailed Description

First line information of DrawTextEx2

Definition at line 7147 of file gdi.h.

Field Documentation

int nr_chars

The number of the characters of first line in bytes.

Definition at line 7150 of file gdi.h.

int startx

The output x-coordinate of the fist line.

Definition at line 7152 of file gdi.h.

int starty

The output y-coordinate of the fist line.

Definition at line 7154 of file gdi.h.

int width

The output width of the fist line.

Definition at line 7156 of file gdi.h.

int height

The output height of the fist line.

Definition at line 7158 of file gdi.h.

The documentation for this struct was generated from the following file:
  • gdi.h
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _MYBITMAP Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_MYBITMAP Struct Reference
[Bitmap structure]

#include <gdi.h>

Data Fields

  • DWORD flags
  • int frames
  • Uint8 depth
  • Uint8 alpha
  • Uint32 transparent
  • Uint32 w
  • Uint32 h
  • Uint32 pitch
  • Uint32 size
  • BYTE * bits

Detailed Description

Device-independent bitmap structure.

Definition at line 7296 of file gdi.h.

Field Documentation

DWORD flags

Flags of the bitmap, can be OR'ed by the following values:

  • MYBMP_TYPE_NORMAL
    A normal palette bitmap.
  • MYBMP_TYPE_RGB
    A RGB bitmap.
  • MYBMP_TYPE_BGR
    A BGR bitmap.
  • MYBMP_TYPE_RGBA
    A RGBA bitmap.
  • MYBMP_FLOW_DOWN
    The scanline flows from top to bottom.
  • MYBMP_FLOW_UP
    The scanline flows from bottom to top.
  • MYBMP_TRANSPARENT
    Have a trasparent value.
  • MYBMP_ALPHACHANNEL
    Have a alpha channel.
  • MYBMP_ALPHA
    Have a per-pixel alpha value.
  • MYBMP_RGBSIZE_3
    Size of each RGB triple is 3 bytes.
  • MYBMP_RGBSIZE_4
    Size of each RGB triple is 4 bytes.
  • MYBMP_LOAD_GRAYSCALE
    Tell bitmap loader to load a grayscale bitmap.
  • MYBMP_LOAD_ALLOCATE_ONE
    Tell bitmap loader to allocate space for only one scanline.

Definition at line 7327 of file gdi.h.

int frames

The number of the frames.

Definition at line 7329 of file gdi.h.

Uint8 depth

The pixel depth.

Definition at line 7331 of file gdi.h.

Uint8 alpha

The alpha channel value.

Definition at line 7333 of file gdi.h.

Uint32 transparent

The transparent pixel.

Definition at line 7336 of file gdi.h.

Uint32 w

The width of the bitmap.

Definition at line 7339 of file gdi.h.

Uint32 h

The height of the bitmap.

Definition at line 7341 of file gdi.h.

Uint32 pitch

The pitch of the bitmap.

Definition at line 7343 of file gdi.h.

Uint32 size

The size of the bits of the bitmap.

Definition at line 7345 of file gdi.h.

BYTE* bits

The pointer to the bits of the bitmap.

Definition at line 7348 of file gdi.h.

The documentation for this struct was generated from the following file:
  • gdi.h
Generated on Fri Dec 17 13:49:52 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _BITMAP Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_BITMAP Struct Reference
[Bitmap structure]

#include <gdi.h>

Data Fields

  • Uint8 bmType
  • Uint8 bmBitsPerPixel
  • Uint8 bmBytesPerPixel
  • Uint8 bmAlpha
  • Uint32 bmColorKey
  • Uint32 bmWidth
  • Uint32 bmHeight
  • Uint32 bmPitch
  • Uint8 * bmBits
  • Uint8 * bmAlphaMask

Detailed Description

Expanded device-dependent bitmap structure.

Definition at line 7365 of file gdi.h.

Field Documentation

Uint8 bmType

Bitmap types, can be OR'ed by the following values:

  • BMP_TYPE_NORMAL
    A nomal bitmap, without alpha and color key.
  • BMP_TYPE_RLE
    A RLE (run-length-encode) encoded bitmap. The encoding translates the pixel data to a stream of segments of the form

<skip> <run> <data>

where <skip> is the number of transparent pixels to skip, <run> is the number of opaque pixels to blit, and <data> are the pixels themselves.

Encoded pixels always have the same format as the BITMAP. <skip> and <run> are unsigned 8 bit integers, except for 32 bit depth where they are 16 bit. This makes the pixel data aligned at all times. Segments never wrap around from one scan line to the next. The end of one segment is marked by a zero <skip>,<run> pair.

  • BMP_TYPE_ALPHA
    Per-pixel alpha in the bitmap.
  • BMP_TYPE_ALPHACHANNEL
    The bmAlpha is a valid alpha channel value.
  • BMP_TYPE_COLORKEY
    The bmColorKey is a valid color key value.
  • BMP_TYPE_ALPHA_MASK
    The bitmap have a private Alpha Mask array.

Definition at line 7396 of file gdi.h.

Uint8 bmBitsPerPixel

The bits per piexel.

Definition at line 7398 of file gdi.h.

Uint8 bmBytesPerPixel

The bytes per piexel.

Definition at line 7400 of file gdi.h.

Uint8 bmAlpha

The alpha channel value.

Definition at line 7402 of file gdi.h.

Uint32 bmColorKey

The color key value.

Definition at line 7404 of file gdi.h.

Uint32 bmWidth

The width of the bitmap

Definition at line 7410 of file gdi.h.

Uint32 bmHeight

The height of the bitmap

Definition at line 7412 of file gdi.h.

Uint32 bmPitch

The pitch of the bitmap

Definition at line 7414 of file gdi.h.

Uint8* bmBits

The bits of the bitmap

Definition at line 7416 of file gdi.h.

Uint8* bmAlphaMask

The private pixel format The Alpha Mask array of the bitmap

Definition at line 7421 of file gdi.h.

The documentation for this struct was generated from the following file:
  • gdi.h
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Bitmap file load/save operations

Bitmap file load/save operations
[GDI functions]

Defines

  • #define MLS_BLENDMODE_NONE 0x00
  • #define LoadBitmap LoadBitmapFromFile
    An alias of LoadBitmapFromFile.
  • #define LoadMyBitmap LoadMyBitmapFromFile
    Alias of LoadMyBitmapFromFile.

Typedefs

  • typedef void(* CB_ONE_SCANLINE )(void *context, MYBITMAP *my_bmp, int y)
    The type of scanline loaded callback.

Functions

  • MG_EXPORT BOOL GUIAPI RegisterBitmapFileType (const char *ext, void *(*init)(MG_RWops *fp, MYBITMAP *my_bmp, RGB *pal), int(*load)(MG_RWops *fp, void *init_info, MYBITMAP *my_bmp, CB_ONE_SCANLINE cb, void *context), void(*cleanup)(void *init_info), int(*save)(MG_RWops *fp, MYBITMAP *my_bmp, RGB *pal), BOOL(*check)(MG_RWops *fp))
    Registers a bitmap file loader, saver, and checker.
  • MG_EXPORT const char *GUIAPI CheckBitmapType (MG_RWops *fp)
    Checks the type of the bitmap in a data source.
  • MG_EXPORT BOOL GUIAPI mlsEnableSlaveScreen (HDC dc_mls, BOOL enable)
    Enable or Disable a MLShadow slave screen.
  • MG_EXPORT int GUIAPI LoadBitmapEx (HDC hdc, PBITMAP pBitmap, MG_RWops *area, const char *ext)
    Loads a device-dependent bitmap from a general data source.
  • MG_EXPORT int GUIAPI LoadBitmapFromFile (HDC hdc, PBITMAP pBitmap, const char *spFileName)
    Loads a device-dependent bitmap from a file.
  • MG_EXPORT int GUIAPI LoadBitmapFromMem (HDC hdc, PBITMAP pBitmap, const void *mem, int size, const char *ext)
    Loads a device-dependent bitmap from memory.
  • MG_EXPORT void GUIAPI UnloadBitmap (PBITMAP pBitmap)
    Unloads a bitmap.
  • MG_EXPORT void GUIAPI ReplaceBitmapColor (HDC hdc, PBITMAP pBitmap, gal_pixel iOColor, gal_pixel iNColor)
    Replaces a specific pixels in a bitmap with another pixel.
  • MG_EXPORT void GUIAPI HFlipBitmap (BITMAP *bmp, unsigned char *inter_buff)
    Horizontal Flip the special Bitmap object.
  • MG_EXPORT void GUIAPI VFlipBitmap (BITMAP *bmp, unsigned char *inter_buff)
    Vertical Flip the special Bitmap object.
  • MG_EXPORT void *GUIAPI InitMyBitmapSL (MG_RWops *area, const char *ext, MYBITMAP *my_bmp, RGB *pal)
    Initializes scanline loader of the MYBITMAP object from a data source.
  • MG_EXPORT int GUIAPI LoadMyBitmapSL (MG_RWops *area, void *load_info, MYBITMAP *my_bmp, CB_ONE_SCANLINE cb, void *context)
    Loads MYBITMAP scanlines from a data source one by one.
  • MG_EXPORT int GUIAPI CleanupMyBitmapSL (MYBITMAP *my_bmp, void *load_info)
    Cleanups the scanline loader.
  • MG_EXPORT int GUIAPI LoadMyBitmapEx (PMYBITMAP my_bmp, RGB *pal, MG_RWops *area, const char *ext)
    Loads a MYBITMAP object from a data source.
  • MG_EXPORT int GUIAPI LoadMyBitmapFromFile (PMYBITMAP my_bmp, RGB *pal, const char *file_name)
    Loads a MYBITMAP object from a file.
  • MG_EXPORT int GUIAPI LoadMyBitmapFromMem (PMYBITMAP my_bmp, RGB *pal, const void *mem, int size, const char *ext)
    Loads a MYBITMAP object from memory.
  • MG_EXPORT void GUIAPI UnloadMyBitmap (PMYBITMAP my_bmp)
    Unloads a bitmap.
  • MG_EXPORT int GUIAPI SaveMyBitmapToFile (PMYBITMAP my_bmp, RGB *pal, const char *spFileName)
    Saves a MYBITMAP object to a bitmap file.
  • MG_EXPORT int GUIAPI SaveBitmapToFile (HDC hdc, PBITMAP pBitmap, const char *spFileName)
    Saves a BITMAP object to a bitmap file.
  • MG_EXPORT BOOL GUIAPI InitBitmap (HDC hdc, Uint32 w, Uint32 h, Uint32 pitch, BYTE *bits, PBITMAP bmp)
    Initializes a BITMAP object as a normal bitmap.
  • MG_EXPORT HDC GUIAPI InitSlaveScreen (const char *name, const char *mode)
    Initializes slave screen.
  • MG_EXPORT void GUIAPI TerminateSlaveScreen (HDC hdc)
    Terminates slave screen.
  • MG_EXPORT BOOL GUIAPI InitBitmapPixelFormat (HDC hdc, PBITMAP bmp)
    Initializes the bitmap pixel format information of a BITMAP object.
  • MG_EXPORT void GUIAPI DeleteBitmapAlphaPixel (PBITMAP bmp)
    Deletes the bitmap alpha pixel format information of a BITMAP object.
  • MG_EXPORT int GUIAPI ExpandMyBitmap (HDC hdc, PBITMAP bmp, const MYBITMAP *my_bmp, const RGB *pal, int frame)
    Expands a MYBITMAP object to a BITMAP object.
  • MG_EXPORT void GUIAPI ExpandMonoBitmap (HDC hdc, BYTE *bits, Uint32 pitch, const BYTE *my_bits, Uint32 my_pitch, Uint32 w, Uint32 h, DWORD flags, Uint32 bg, Uint32 fg)
    Convert a mono color MYBITMAP pixel data to a BITMAP pixel data.
  • MG_EXPORT void GUIAPI Expand16CBitmap (HDC hdc, BYTE *bits, Uint32 pitch, const BYTE *my_bits, Uint32 my_pitch, Uint32 w, Uint32 h, DWORD flags, const RGB *pal)
    Convert a 16 color MYBITMAP pixel data to a BITMAP pixel data.
  • MG_EXPORT void GUIAPI CompileRGBABitmap (HDC hdc, BYTE *bits, Uint32 pitch, const BYTE *my_bits, Uint32 my_pitch, Uint32 w, Uint32 h, DWORD flags, void *pixel_format, CB_DRAW_PIXEL cb_draw, MYBITMAP_CONTXT *mybmp)
    Convert a MYBITMAP pixel data to a BITMAP pixel data.
  • MG_EXPORT void GUIAPI CompileRGBABitmapEx (HDC hdc, BYTE *bits, Uint32 pitch, const BYTE *my_bits, Uint32 my_pitch, Uint32 w, Uint32 h, DWORD flags, void *pixel_format, CB_DRAW_PIXEL cb_draw, MYBITMAP_CONTXT *mybmp, BYTE *alpha_mask)
    Compile a MYBITMAP pixel data to a BITMAP pixel data.
  • MG_EXPORT int GUIAPI PaintImageEx (HDC hdc, int x, int y, MG_RWops *area, const char *ext)
    Paints an image from data source on device directly.
  • MG_EXPORT int GUIAPI PaintImageFromFile (HDC hdc, int x, int y, const char *spFileName)
    Paints an image from file on device directly.
  • MG_EXPORT int GUIAPI PaintImageFromMem (HDC hdc, int x, int y, const void *mem, int size, const char *ext)
    Paints an image from memory on device directly.
  • MG_EXPORT int GUIAPI StretchPaintImageEx (HDC hdc, int x, int y, int w, int h, MG_RWops *area, const char *ext)
    Paints an image from data source on device directly.
  • MG_EXPORT int GUIAPI StretchPaintImageFromFile (HDC hdc, int x, int y, int w, int h, const char *spFileName)
    Paints an image from file on device directly.
  • MG_EXPORT int GUIAPI StretchPaintImageFromMem (HDC hdc, int x, int y, int w, int h, const void *mem, int size, const char *ext)
    Paints an image from memory on device directly.
  • MG_EXPORT void GUIAPI RotateBitmap (HDC hdc, const BITMAP *bmp, int lx, int ty, int angle)
    Rotate a bitmap object.
  • MG_EXPORT void GUIAPI RotateBitmapVFlip (HDC hdc, const BITMAP *bmp, int lx, int ty, int angle)
    Flips vertically and rotates a bitmap object.
  • MG_EXPORT void GUIAPI RotateBitmapHFlip (HDC hdc, const BITMAP *bmp, int lx, int ty, int angle)
    Flips horizontally and rotates a bitmap object.
  • MG_EXPORT void GUIAPI RotateScaledBitmap (HDC hdc, const BITMAP *bmp, int lx, int ty, int angle, int w, int h)
    Stretches or shrinks a bitmap object at the same as rotating it.
  • MG_EXPORT void GUIAPI RotateScaledBitmapVFlip (HDC hdc, const BITMAP *bmp, int lx, int ty, int angle, int w, int h)
    Flip vertically, rotates, stretch or shrinks a bitmap object.
  • MG_EXPORT void GUIAPI RotateScaledBitmapHFlip (HDC hdc, const BITMAP *bmp, int lx, int ty, int angle, int w, int h)
    Flip horizontaly, rotates, stretch or shrinks a bitmap object.
  • MG_EXPORT void GUIAPI PivotBitmap (HDC hdc, const BITMAP *bmp, int lx, int ty, int cx, int cy, int angle)
    Pivot a bitmap object.
  • MG_EXPORT void GUIAPI PivotScaledBitmapFlip (HDC hdc, const BITMAP *bmp, fixed x, fixed y, fixed cx, fixed cy, int angle, fixed scale_x, fixed scale_y, BOOL h_flip, BOOL v_flip)
    Rotates, stretches or shrinks, flips a bitmap object.

Detailed Description

Example:

/*
 * The following code loads a BITMAP object from a file and then
 * fills a box in a DC.
 *
 * You should note that the code assigns 'bmType' field of the BITMAP object directly.
 */
{
    int tox = 800, toy = 800;
    int count;
    BITMAP bitmap;
    unsigned int start_tick, end_tick;

    /* Load the bitmap from the file. */
    if (LoadBitmap (hdc, &bitmap, "res/icon.bmp"))
        return;

    bitmap.bmType = BMP_TYPE_ALPHACHANNEL;

    /* Fill a box with the bitmap with alpha channel. */
    start_tick = GetTickCount ();
    count = 1000;
    while (count--) {
        tox = rand() % 800;
        toy = rand() % 800;

        /* Set a random alpha channel. */
        bitmap.bmAlpha = rand() % 256;
        /* Fill the box. */
        FillBoxWithBitmap (hdc, tox, toy, 0, 0, &bitmap);
    }
    end_tick = GetTickCount ();
    TellSpeed (hwnd, start_tick, end_tick, "Alpha Blended Bitmap", 1000);

    bitmap.bmType = BMP_TYPE_ALPHACHANNEL | BMP_TYPE_COLORKEY;
    /* Set the color key (the transparent pixel) of the bitmap. */
    bitmap.bmColorKey = GetPixelInBitmap (&bitmap, 0, 0);

    /* Fill a box with the bitmap with alpha channel and color key. */
    start_tick = GetTickCount ();
    count = 1000;
    while (count--) {
        tox = rand() % 800;
        toy = rand() % 800;

        /* Set a random alpha channel. */
        bitmap.bmAlpha = rand() % 256;
        /* Fill the box. */
        FillBoxWithBitmap (hdc, tox, toy, 0, 0, &bitmap);
    }
    end_tick = GetTickCount ();
    TellSpeed (hwnd, start_tick, end_tick, "Alpha Blended Transparent Bitmap", 1000);

    UnloadBitmap (&bitmap);
}

Define Documentation

#define LoadBitmap LoadBitmapFromFile

An alias of LoadBitmapFromFile.

See also:
LoadBitmapFromFile

Definition at line 7632 of file gdi.h.

#define LoadMyBitmap LoadMyBitmapFromFile

Alias of LoadMyBitmapFromFile.

See also:
LoadMyBitmapFromFile

Definition at line 7788 of file gdi.h.

#define MLS_BLENDMODE_NONE 0x00

This function is used to set attributes of MLShadow slave screen. After creating a slave screen by InitSlaveScreen successfully, you should call this function to set its attributes. When blend_flags is MLS_INFOMASK_ALL, it will set all attributes of slave screen.

Parameters:
dc_mls | The handle to the slave screen.
mask | The attributes mask, can be or'ed values of the following mask:
  • MLS_INFOMASK_OFFSET
    Set x and y offset value of slave screen.

  • MLS_INFOMASK_BLEND
    Set blend mode of slave screen.

  • MLS_INFOMASK_ZORDER
    Set z_order value of slave screen.

  • MLS_INFOMASK_ALL
    Set all attribute value of slave screen.

Parameters:
offset_x | The x offset value of slave screen relative to masterscreen.
offset_y | The y offset value of slave screen relative to masterscreen.
blend_flags | The blend flags, can be one of the following values:
  • MLS_BLENDMODE_COLORKEY
    Set color_key value of slave screen.

  • MLS_BLENDMODE_ALPHA
    Set alpha value of slave screen.

  • MLS_BLENDMODE_NONE
    The value of alpha and color_key is invalid.

Parameters:
color_key | The colorkey value of MLShadow slave screen.
alpha | The alpha value of MLShadow slave screen.
z_order | The zorder of MLShadow slave screen.
Returns:
TRUE on success, FALSE on error.

Definition at line 7544 of file gdi.h.

Typedef Documentation

typedef void(* CB_ONE_SCANLINE)(void *context, MYBITMAP *my_bmp, int y)

The type of scanline loaded callback.

Definition at line 7442 of file gdi.h.

Function Documentation

const char *GUIAPI CheckBitmapType ( MG_RWops * fp )

Checks the type of the bitmap in a data source.

This function checks the type of the bitmap in the data source fp, and returns the extension of this type of bitmap file.

Parameters:
fp The pointer to the data source.
Returns:
The extension of the type of bitmap file. NULL for not recongnized bitmap type.
See also:
RegisterBitmapFileType

int GUIAPI CleanupMyBitmapSL | ( | MYBITMAP * | my_bmp,
 |  | void * | load_info
 | ) |  |

Cleanups the scanline loader.

This function cleanups the scanline loader.

Parameters:
my_bmp | The pointer to the MYBITMAP object.
load_info | The initialized information retured by InitMyBitmapSL function.
Returns:
0 on success, less than 0 on error.
See also:
LoadMyBitmapEx, InitMyBitmapSL, LoadMyBitmapSL

void GUIAPI CompileRGBABitmap | ( | HDC | hdc,
 |  | BYTE * | bits,
 |  | Uint32 | pitch,
 |  | const BYTE * | my_bits,
 |  | Uint32 | my_pitch,
 |  | Uint32 | w,
 |  | Uint32 | h,
 |  | DWORD | flags,
 |  | void * | pixel_format,
 |  | CB_DRAW_PIXEL | cb_draw,
 |  | MYBITMAP_CONTXT * | mybmp
 | ) |  |

Convert a MYBITMAP pixel data to a BITMAP pixel data.

This function Convert a MYBITMAP pixel data to a BITMAP pixel data.

Parameters:
hdc | The device context.
bits | The BITMAP pixel data(RGBA etc.).
pitch | The pitch of the BITMAP object.
my_bits | The MYBITMAP pixel data to be compile.
my_pitch | The pitch of the MYBITMAP object.
w | The width of the MYBITMAP object.
h | The height of the MYBITMAP object.
flags | The flags of the MYBITMAP object.
pixel_format | The pixel format of the MYBITMAP object.
cb_draw | The draw callback function.
mybmp | The context of cb_draw.
See also:
CompileRGBABitmapEx

void GUIAPI CompileRGBABitmapEx | ( | HDC | hdc,
 |  | BYTE * | bits,
 |  | Uint32 | pitch,
 |  | const BYTE * | my_bits,
 |  | Uint32 | my_pitch,
 |  | Uint32 | w,
 |  | Uint32 | h,
 |  | DWORD | flags,
 |  | void * | pixel_format,
 |  | CB_DRAW_PIXEL | cb_draw,
 |  | MYBITMAP_CONTXT * | mybmp,
 |  | BYTE * | alpha_mask
 | ) |  |

Compile a MYBITMAP pixel data to a BITMAP pixel data.

This function compile a MYBITMAP pixel data to a BITMAP pixel data.

See also:
CompileRGBABitmap

void GUIAPI DeleteBitmapAlphaPixel ( PBITMAP bmp )

Deletes the bitmap alpha pixel format information of a BITMAP object.

This function deletes the bitmap alpha pixel format information of the BITMAP object bmp.

See also:
InitBitmapPixelFormat

void GUIAPI Expand16CBitmap | ( | HDC | hdc,
 |  | BYTE * | bits,
 |  | Uint32 | pitch,
 |  | const BYTE * | my_bits,
 |  | Uint32 | my_pitch,
 |  | Uint32 | w,
 |  | Uint32 | h,
 |  | DWORD | flags,
 |  | const RGB * | pal
 | ) |  |

Convert a 16 color MYBITMAP pixel data to a BITMAP pixel data.

This function compile a 16 color MYBITMAP pixel data to a BITMAP pixel data.

Parameters:
hdc | The device context.
bits | The BITMAP pixel data(RGBA etc.).
pitch | The pitch of the BITMAP object.
my_bits | The MYBITMAP pixel data to be compile.
my_pitch | The pitch of the MYBITMAP object.
w | The width of the MYBITMAP object.
h | The height of the MYBITMAP object.
flags | The flags of the MYBITMAP object.
pal | The Palette of the MYBITMAP object.
See also:
ExpandMonoBitmap, Expand256CBitmap

void GUIAPI ExpandMonoBitmap | ( | HDC | hdc,
 |  | BYTE * | bits,
 |  | Uint32 | pitch,
 |  | const BYTE * | my_bits,
 |  | Uint32 | my_pitch,
 |  | Uint32 | w,
 |  | Uint32 | h,
 |  | DWORD | flags,
 |  | Uint32 | bg,
 |  | Uint32 | fg
 | ) |  |

Convert a mono color MYBITMAP pixel data to a BITMAP pixel data.

This function compile a MYBITMAP pixel data to a BITMAP pixel data.

Parameters:
hdc | The device context.
bits | The BITMAP pixel data(RGBA etc.).
pitch | The pitch of the BITMAP object.
my_bits | The MYBITMAP pixel data to be compile.
my_pitch | The pitch of the MYBITMAP object.
w | The width of the MYBITMAP object.
h | The height of the MYBITMAP object.
flags | The flags of the MYBITMAP object.
bg | The foreground color of the BITMAP object.
fg | The foreground color of the BITMAP object.
See also:
Expand16CBitmap, Expand256CBitmap

int GUIAPI ExpandMyBitmap | ( | HDC | hdc,
 |  | PBITMAP | bmp,
 |  | const MYBITMAP * | my_bmp,
 |  | const RGB * | pal,
 |  | int | frame
 | ) |  |

Expands a MYBITMAP object to a BITMAP object.

This function expands the MYBITMAP object pointed to by my_bmp to a BITMAP object (bmp).

Parameters:
hdc | The device context.
bmp | The expanded BITMAP object.
my_bmp | The MYBITMAP object to be expanded.
pal | The palette of the MYBITMAP object.
frame | The frame of the MYBITMAP object.
Returns:
0 on success, non-zero on error.

void void GUIAPI HFlipBitmap | ( | BITMAP * | bmp,
 |  | unsigned char * | inter_buff
 | ) |  |

Horizontal Flip the special Bitmap object.

Parameters:
bmp | The BITMAP object.
inter_buff | The one scan line pre-alloc buffer of bitmap.

BOOL GUIAPI InitBitmap | ( | HDC | hdc,
 |  | Uint32 | w,
 |  | Uint32 | h,
 |  | Uint32 | pitch,
 |  | BYTE * | bits,
 |  | PBITMAP | bmp
 | ) |  |

Initializes a BITMAP object as a normal bitmap.

This function initializes the bitmap pointed to by bmp as a normal bitmap. It sets the bitmap structure fields, and allocates the bits if bits is NULL.

Parameters:
hdc | The device context.
w | The width of the bitmap.
h | The height of the bitmap.
pitch | The pitch of the bitmap.
bits | The bits of the bitmap.
bmp | The BITMAP object to be initialized.
Returns:
TRUE on success, FALSE on error.
Note:
LoadBitmapEx will initialize the BITMAP object itself.
See also:
InitBitmapPixelFormat, UnloadBitmap, Bitmap structure

BOOL GUIAPI InitBitmapPixelFormat | ( | HDC | hdc,
 |  | PBITMAP | bmp
 | ) |  |

Initializes the bitmap pixel format information of a BITMAP object.

This function initializes the bitmap pixel format information of the BITMAP object pointed to by bmp. This includes bmBitsPerPixel and bmBytesPerPixel fields, and the private pixel format if the bitmap is a bitmap with alpha.

Parameters:
hdc | The device context.
bmp | The BITMAP object to be initialized.
Returns:
TRUE on success, FALSE on error.
See also:
InitBitmap, Bitmap structure

void *GUIAPI InitMyBitmapSL | ( | MG_RWops * | area,
 |  | const char * | ext,
 |  | MYBITMAP * | my_bmp,
 |  | RGB * | pal
 | ) |  |

Initializes scanline loader of the MYBITMAP object from a data source.

This function initializes scanline loader of the MYBITMAP object from a data source.

Parameters:
area | The data source.
ext | The extension of the type of this bitmap.
my_bmp | The pointer to the MYBITMAP object.
pal | The palette will be returned.
Returns:
The initialized information which should be passed to LoadMyBitmapSL function, and NULL on error.
See also:
LoadMyBitmapEx, LoadMyBitmapSL, CleanupMyBitmapSL

HDC GUIAPI InitSlaveScreen | ( | const char * | name,
 |  | const char * | mode
 | ) |  |

Initializes slave screen.

Parameters:
name | The gal engine name.
mode | The display mode. For example : 640x480-16bpp.
Returns:
Valid handle on success, HDC_INVALID on failure.

int GUIAPI LoadBitmapEx | ( | HDC | hdc,
 |  | PBITMAP | pBitmap,
 |  | MG_RWops * | area,
 |  | const char * | ext
 | ) |  |

Loads a device-dependent bitmap from a general data source.

This function loads a device-dependent bitmap from the data source area.

Parameters:
hdc | The device context.
pBitmap | The pointer to the BITMAP object.
area | The data source.
ext | The extension of the type of this bitmap.
Returns:
0 on success, less than 0 on error.
Return values:
ERR_BMP_OK | Loading successfully
ERR_BMP_IMAGE_TYPE | Not a valid bitmap.
ERR_BMP_UNKNOWN_TYPE | Not recongnized bitmap type.
ERR_BMP_CANT_READ | Read error.
ERR_BMP_CANT_SAVE | Save error.
ERR_BMP_NOT_SUPPORTED | Not supported bitmap type.
ERR_BMP_MEM | Memory allocation error.
ERR_BMP_LOAD | Loading error.
ERR_BMP_FILEIO | I/O failed.
ERR_BMP_OTHER | Other error.
ERR_BMP_ERROR_SOURCE | A error data source.
See also:
LoadBitmapFromFile, LoadBitmapFromMem

int GUIAPI LoadBitmapFromFile | ( | HDC | hdc,
 |  | PBITMAP | pBitmap,
 |  | const char * | spFileName
 | ) |  |

Loads a device-dependent bitmap from a file.

See also:
LoadBitmapEx

int GUIAPI LoadBitmapFromMem | ( | HDC | hdc,
 |  | PBITMAP | pBitmap,
 |  | const void * | mem,
 |  | int | size,
 |  | const char * | ext
 | ) |  |

Loads a device-dependent bitmap from memory.

See also:
LoadBitmapEx

int GUIAPI LoadMyBitmapEx | ( | PMYBITMAP | my_bmp,
 |  | RGB * | pal,
 |  | MG_RWops * | area,
 |  | const char * | ext
 | ) |  |

Loads a MYBITMAP object from a data source.

This function loads a MYBITMAP object from the data source area.

Parameters:
my_bmp | The pointer to the MYBITMAP object.
area | The data source.
pal | The palette will be returned.
ext | The extension of the type of this bitmap.
Returns:
0 on success, less than 0 on error.
See also:
LoadBitmapEx

int GUIAPI LoadMyBitmapFromFile | ( | PMYBITMAP | my_bmp,
 |  | RGB * | pal,
 |  | const char * | file_name
 | ) |  |

Loads a MYBITMAP object from a file.

See also:
LoadMyBitmapEx

int GUIAPI LoadMyBitmapFromMem | ( | PMYBITMAP | my_bmp,
 |  | RGB * | pal,
 |  | const void * | mem,
 |  | int | size,
 |  | const char * | ext
 | ) |  |

Loads a MYBITMAP object from memory.

This function loads a MYBITMAP object from memory.

Parameters:
my_bmp | The pointer to the MYBITMAP object.
pal | The palette will be retruned through this pointer.
mem | The pointer to the memory area.
size | The size of the memory area.
ext | The extension name used to determine the type of the bitmap.
See also:
LoadMyBitmapEx, MYBITMAP

int GUIAPI LoadMyBitmapSL | ( | MG_RWops * | area,
 |  | void * | load_info,
 |  | MYBITMAP * | my_bmp,
 |  | CB_ONE_SCANLINE | cb,
 |  | void * | context
 | ) |  |

Loads MYBITMAP scanlines from a data source one by one.

This function loads MYBITMAP scanlines from the data source area one by one.

Parameters:
area | The data source.
load_info | The initialized information retured by InitMyBitmapSL function.
my_bmp | The pointer to the MYBITMAP object.
cb | The callback to inform one scanline loaded. It can be NULL.
context | The context information passed to the callback.
Returns:
0 on success, less than 0 on error.
See also:
LoadMyBitmapEx, InitMyBitmapSL, CleanupMyBitmapSL

BOOL GUIAPI mlsEnableSlaveScreen | ( | HDC | dc_mls,
 |  | BOOL | enable
 | ) |  |

Enable or Disable a MLShadow slave screen.

This function is used to enable or diable a MLShadow slave screen. After creating a slave screen by InitSlaveScreen successfully, its default status is diabled.

Parameters:
dc_mls | The handle of MLShadow slave screen.
enable | Whether to enable the MLShadow slave screen.
Returns:
TRUE on success, FALSE on error.

int GUIAPI PaintImageEx | ( | HDC | hdc,
 |  | int | x,
 |  | int | y,
 |  | MG_RWops * | area,
 |  | const char * | ext
 | ) |  |

Paints an image from data source on device directly.

This function paints an image from data source onto device directly.

Parameters:
hdc | The device context.
x | (x,y), the paint position on device.
y | (x,y), the paint position on device.
area | The data source.
ext | The extension of the type of this bitmap.
Returns:
0 on success, less than 0 on error.
Return values:
ERR_BMP_OK | Painted successfully
ERR_BMP_IMAGE_TYPE | Not a valid image type.
ERR_BMP_UNKNOWN_TYPE | Not recongnized bitmap type.
ERR_BMP_CANT_READ | Read error.
ERR_BMP_NOT_SUPPORTED | Not supported bitmap type.
ERR_BMP_MEM | Memory allocation error.
ERR_BMP_LOAD | Loading error.
ERR_BMP_FILEIO | I/O failed.
ERR_BMP_OTHER | Other error.
ERR_BMP_ERROR_SOURCE | A error data source.
See also:
PaintImageFromFile, PaintImageFromMem

int GUIAPI PaintImageFromFile | ( | HDC | hdc,
 |  | int | x,
 |  | int | y,
 |  | const char * | spFileName
 | ) |  |

Paints an image from file on device directly.

Parameters:
hdc | The device context.
x | (x,y), the paint position on device.
y | (x,y), the paint position on device.
spFileName | The file name of the image file.
Returns:
0 on success, less than 0 on error.
See also:
PaintImageEx

int GUIAPI PaintImageFromMem | ( | HDC | hdc,
 |  | int | x,
 |  | int | y,
 |  | const void * | mem,
 |  | int | size,
 |  | const char * | ext
 | ) |  |

Paints an image from memory on device directly.

Parameters:
hdc | The device context.
x | (x,y), the paint position on device.
y | (x,y), the paint position on device.
mem | The pointer to memory containing image data.
size | The size of the image data.
ext | The name of the image which indicates the type of the image.
Returns:
0 on success, less than 0 on error.
See also:
PaintImageEx

void GUIAPI PivotBitmap | ( | HDC | hdc,
 |  | const BITMAP * | bmp,
 |  | int | x,
 |  | int | y,
 |  | int | cx,
 |  | int | cy,
 |  | int | angle
 | ) |  |

Pivot a bitmap object.

This function aligns the point in the bitmap given by (cx, cy) to (x, y) in device context, then rotates around this point.

See also:
PivotScaledBitmapFlip

void GUIAPI PivotScaledBitmapFlip | ( | HDC | hdc,
 |  | const BITMAP * | bmp,
 |  | fixed | x,
 |  | fixed | y,
 |  | fixed | cx,
 |  | fixed | cy,
 |  | int | angle,
 |  | fixed | scale_x,
 |  | fixed | scale_y,
 |  | BOOL | h_flip,
 |  | BOOL | v_flip
 | ) |  |

Rotates, stretches or shrinks, flips a bitmap object.

This function flips the bitmap vertically if v_flip is TRUE, flips the bitmap horizontally if h_flip is TRUE first. Then stretches or shrinks the bitmap according to scale and aligns the point in the bitmap given by (cx, cy) to (x, y) in device context, Finally rotates specified angle pointed to angle in 1/64ths of a degree around this point (cx, cy).

Parameters:
hdc | The device context.
bmp | The pointer of BITMAP object.
x | (x,y) The x coordinate of a point in fixed point on dc.
y | (x,y) The y coordinate of a point in fixed point on dc.
cx | (cx,cy) The x coordinate of a point in fixed point on the bitmap.
cy | (cx,cy) The y coordinate of a point in fixed point on the bitmap.
angle | The specified rotated angle around its center.
scale_x | The ratio of width of stretching or shrinking the bitmap in fixed point.
scale_y | The ratio of height of stretching or shrinking the bitmap in fixed point.
h_flip | The flags of fliping horizontally.
v_flip | The flags of fliping vertically.

BOOL GUIAPI RegisterBitmapFileType | ( | const char * | ext,
 |  | void *(*)(MG_RWops *fp, MYBITMAP *my_bmp, RGB *pal) | init,
 |  | int(*)(MG_RWops *fp, void *init_info, MYBITMAP *my_bmp, CB_ONE_SCANLINE cb, void *context) | load,
 |  | void(*)(void *init_info) | cleanup,
 |  | int(*)(MG_RWops *fp, MYBITMAP *my_bmp, RGB *pal) | save,
 |  | BOOL(*)(MG_RWops *fp) | check
 | ) |  |

Registers a bitmap file loader, saver, and checker.

This function registers a new bitmap file loader, saver, and checker. You should pass the extension of the bitmap files, the functions to init, load, and cleanup this type of bitmap file, the function to save, and the function to check the type.

Parameters:
ext | The extension name of the type of bitmap file, like "jpg" or "gif".
init | The routine to init the MYBITMAP object (bmp). This routine fills the MYBITMAP structure and get the pallete if needed. It will return the init_info for the following load routine.
load | The routine to load the scanlines of the bitmap file. This routine will load the initialized MYBITMAP object (bmp) from the data source (fp). It will call the scanline loaded callback (cb) by passing through the context (context), the MYBITMAP object (bmp), and the index of the scanline.
cleanup | The cleanup routine.
save | The saver of the bitmap file, can be NULL.
check | The checker of the bitmap file.
Returns:
TRUE on success, FALSE on error.
See also:
CheckBitmapType, InitMyBitmapSL, LoadMyBitmapSL, CleanupMyBitmapSL, General read/write operations

void GUIAPI ReplaceBitmapColor | ( | HDC | hdc,
 |  | PBITMAP | pBitmap,
 |  | gal_pixel | iOColor,
 |  | gal_pixel | iNColor
 | ) |  |

Replaces a specific pixels in a bitmap with another pixel.

This function replaces the specific pixels with value iOColor with the other pixel value iNcolor in the bitmap pBitmap.

Parameters:
hdc | The device context.
pBitmap | The BITMAP object.
iOColor | The pixel value of the color will be replaced.
iNColor | The pixel value of the new color.

void GUIAPI RotateBitmap | ( | HDC | hdc,
 |  | const BITMAP * | bmp,
 |  | int | lx,
 |  | int | ty,
 |  | int | angle
 | ) |  |

Rotate a bitmap object.

Parameters:
hdc | The device context.
bmp | The pointer of Bitmap object.
lx | (lx,ty), the x coordinate of top left corner.
ty | (lx,ty), the y coordinate of top left corner.
angle | The specified rotated angle around its center. It must be in 1/64ths of a degree.
See also:
PivotScaledBitmapFlip

void GUIAPI RotateBitmapHFlip | ( | HDC | hdc,
 |  | const BITMAP * | bmp,
 |  | int | lx,
 |  | int | ty,
 |  | int | angle
 | ) |  |

Flips horizontally and rotates a bitmap object.

See also:
RotateBitmap

void GUIAPI RotateBitmapVFlip | ( | HDC | hdc,
 |  | const BITMAP * | bmp,
 |  | int | lx,
 |  | int | ty,
 |  | int | angle
 | ) |  |

Flips vertically and rotates a bitmap object.

This function flips vertically before rotating the bitmap pointed to bmp.

See also:
RotateBitmap

void GUIAPI RotateScaledBitmap | ( | HDC | hdc,
 |  | const BITMAP * | bmp,
 |  | int | lx,
 |  | int | ty,
 |  | int | angle,
 |  | int | w,
 |  | int | h
 | ) |  |

Stretches or shrinks a bitmap object at the same as rotating it.

See also:
RotateBitmap

void GUIAPI RotateScaledBitmapHFlip | ( | HDC | hdc,
 |  | const BITMAP * | bmp,
 |  | int | lx,
 |  | int | ty,
 |  | int | angle,
 |  | int | w,
 |  | int | h
 | ) |  |

Flip horizontaly, rotates, stretch or shrinks a bitmap object.

This function is similar to RotateScaledBitmap() expect that it flips the bitmap horizontally first.

See also:
RotateScaledBitmap()

void GUIAPI RotateScaledBitmapVFlip | ( | HDC | hdc,
 |  | const BITMAP * | bmp,
 |  | int | lx,
 |  | int | ty,
 |  | int | angle,
 |  | int | w,
 |  | int | h
 | ) |  |

Flip vertically, rotates, stretch or shrinks a bitmap object.

This function is similar to RotateScaledBitmap() expect that it flips the bitmap vertically first.

See also:
RotateScaledBitmap()

int GUIAPI SaveBitmapToFile | ( | HDC | hdc,
 |  | PBITMAP | pBitmap,
 |  | const char * | spFileName
 | ) |  |

Saves a BITMAP object to a bitmap file.

This function saves the BITMAP object pBitmap to the bitmap file named spFileName.

Parameters:
hdc | The device context.
pBitmap | The BITMAP object.
spFileName | The file name.
Returns:
0 on success, less than 0 on error.
See also:
SaveMyBitmapToFile

int GUIAPI SaveMyBitmapToFile | ( | PMYBITMAP | my_bmp,
 |  | RGB * | pal,
 |  | const char * | spFileName
 | ) |  |

Saves a MYBITMAP object to a bitmap file.

This function saves the MYBITMAP object my_bmp to the bitmap file named spFileName.

Parameters:
my_bmp | The MYBITMAP object.
pal | The palette.
spFileName | The file name.
Returns:
0 on success, less than 0 on error.
See also:
SaveBitmapToFile

int GUIAPI StretchPaintImageEx | ( | HDC | hdc,
 |  | int | x,
 |  | int | y,
 |  | int | w,
 |  | int | h,
 |  | MG_RWops * | area,
 |  | const char * | ext
 | ) |  |

Paints an image from data source on device directly.

This function paints an image from data source onto device directly with stretch.

Parameters:
hdc | The device context.
x | (x,y), the paint position on device.
y | (x,y), the paint position on device.
w | the width of the stretched bitmap.
h | the height of the stretched bitmap.
area | The data source.
ext | The extension of the type of this bitmap.
Returns:
0 on success, less than 0 on error.
Return values:
ERR_BMP_OK | Painted successfully
ERR_BMP_IMAGE_TYPE | Not a valid image type.
ERR_BMP_UNKNOWN_TYPE | Not recongnized bitmap type.
ERR_BMP_CANT_READ | Read error.
ERR_BMP_NOT_SUPPORTED | Not supported bitmap type.
ERR_BMP_MEM | Memory allocation error.
ERR_BMP_LOAD | Loading error.
ERR_BMP_FILEIO | I/O failed.
ERR_BMP_OTHER | Other error.
ERR_BMP_ERROR_SOURCE | A error data source.
See also:
PaintImageFromFile, PaintImageFromMem

int GUIAPI StretchPaintImageFromFile | ( | HDC | hdc,
 |  | int | x,
 |  | int | y,
 |  | int | w,
 |  | int | h,
 |  | const char * | spFileName
 | ) |  |

Paints an image from file on device directly.

Parameters:
hdc | The device context.
x | (x,y), the paint position on device.
y | (x,y), the paint position on device.
w | The width of the stretched bitmap.
h | The height of the stretched bitmap.
spFileName | the file name of the image file.
Returns:
0 on success, less than 0 on error.
See also:
StretchPaintImageEx

int GUIAPI StretchPaintImageFromMem | ( | HDC | hdc,
 |  | int | x,
 |  | int | y,
 |  | int | w,
 |  | int | h,
 |  | const void * | mem,
 |  | int | size,
 |  | const char * | ext
 | ) |  |

Paints an image from memory on device directly.

Parameters:
hdc | The device context.
x | (x,y) the paint position on device.
y | (x,y) the paint position on device.
w | The width of the stretched bitmap.
h | The height of the stretched bitmap.
mem | The pointer to memory containing image data.
size | The size of the image data.
ext | The name of the image which indicates the type of the image.
Returns:
0 on success, less than 0 on error.
See also:
StretchPaintImageEx

void TerminateSlaveScreen ( HDC hdc )

Terminates slave screen.

Parameters:
hdc The slave device context.

void GUIAPI UnloadBitmap ( PBITMAP pBitmap )

Unloads a bitmap.

This function unloads the specified bitmap pBitmap. It will free the private pixel format and the bits of the bitmap.

Parameters:
pBitmap The BITMAP object.
See also:
LoadBitmapEx

void GUIAPI UnloadMyBitmap ( PMYBITMAP my_bmp )

Unloads a bitmap.

This function unloads the specified MYBITMAP object my_bmp. It will free the bits of the bitmap.

Parameters:
my_bmp The pointer to the MYBITMAP object.
See also:
LoadMyBitmapEx

void GUIAPI VFlipBitmap | ( | BITMAP * | bmp,
 |  | unsigned char * | inter_buff
 | ) |  |

Vertical Flip the special Bitmap object.

Parameters:
bmp | The BITMAP object.
inter_buff | The one scan line pre-alloc buffer of bitmap.

Generated on Fri Dec 17 13:49:48 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Glyph defines and operations

Glyph defines and operations
[GDI functions]

Defines

  • #define IS_MBC_GLYPH(glyph) ((glyph) & 0x80000000)
    to judge wether the glyph is multibyte glyph
  • #define SET_MBC_GLYPH(glyph) ((glyph) | 0x80000000)
    set the glyph with multibyte mask
  • #define REAL_GLYPH(glyph) ((glyph) & 0x7FFFFFFF)
    get real glyph value from a glyph
  • #define SELECT_DEVFONT(plogfont, glyph)
    select a device font acording to the glyph value.

Typedefs

  • typedef struct _GLYPHMAPINFO GLYPHMAPINFO
    Data type of struct _GLYPHMAPINFO.
  • typedef struct _GLYPHINFO GLYPHINFO
    Data type of struct _GLYPHINFO.

Enumerations

  • enum SHAPETYPE
    Data type of enum. More...

Functions

  • MG_EXPORT Glyph32 GUIAPI GetGlyphValue (LOGFONT *logfont, const char *mchar, int mchar_len, const char *pre_mchar, int pre_len)
    Get the glyph value of a multi-byte character.
  • MG_EXPORT Glyph32 GUIAPI GetGlyphShape (LOGFONT *logfont, const char *mchar, int mchar_len, SHAPETYPE shape_type)
    Get the glyph shape of a character.
  • MG_EXPORT int GUIAPI DrawGlyph (HDC hdc, int x, int y, Glyph32 glyph_value, int *adv_x, int *adv_y)
    Draw a glyph.
  • MG_EXPORT int GUIAPI GetGlyphInfo (LOGFONT *logfont, Glyph32 glyph_value, GLYPHINFO *glyph_info)
    Retriev the information of a glyph.
  • MG_EXPORT int GUIAPI GetGlyphsExtent (HDC hdc, Glyph32 *glyphs, int nr_glyphs, SIZE *size)
    Get visual extent value of a glyph string.
  • MG_EXPORT int GUIAPI GetGlyphsExtentPoint (HDC hdc, Glyph32 *glyphs, int nr_glyphs, int max_extent, SIZE *size)
    Get the visual extent value of a glyph string.
  • MG_EXPORT int GUIAPI BIDIGetTextLogicalGlyphs (LOGFONT *log_font, const char *text, int text_len, Glyph32 **glyphs, GLYPHMAPINFO **glyphs_map)
    Get logical glyphs string of the text.
  • MG_EXPORT int GUIAPI BIDIGetTextVisualGlyphs (LOGFONT *log_font, const char *text, int text_len, Glyph32 **glyphs, GLYPHMAPINFO **glyphs_map)
    Get visual glyphs and glyph_map info relative with logical string byte index.
  • MG_EXPORT Glyph32 *GUIAPI BIDILogGlyphs2VisGlyphs (LOGFONT *log_font, Glyph32 *glyphs, int nr_glyphs, GLYPHMAPINFO *glyphs_map)
    Reorder the logical glyphs string to visual glyphs string.
  • MG_EXPORT void GUIAPI GetTextRangesLog2Vis (LOGFONT *log_font, char *text, int text_len, int start_index, int end_index, int **ranges, int *nr_ranges)
    Get a list of visual ranges corresponding to a given logical range.
  • MG_EXPORT void GUIAPI BIDIGetLogicalEmbeddLevels (LOGFONT *log_font, Glyph32 *glyphs, int nr_glyphs, Uint8 **embedding_level_list)
    Get the logical embedding levels for the logical glyph string and generate runs by embedding levels, the for reorder to get visual glyph string.
  • MG_EXPORT void GUIAPI BIDIGetVisualEmbeddLevels (LOGFONT *log_font, Glyph32 *glyphs, int nr_glyphs, Uint8 **embedding_level_list)
    Get the visual embedding levels for the given logical glyph string, then you can get the edge for visual glyphs.

Detailed Description

MiniGUI maintains some glyph defines and operations

Define Documentation

#define IS_MBC_GLYPH ( glyph ) ((glyph) & 0x80000000)

to judge wether the glyph is multibyte glyph

Parameters:
glyph glyph value

Definition at line 8510 of file gdi.h.

#define REAL_GLYPH ( glyph ) ((glyph) & 0x7FFFFFFF)

get real glyph value from a glyph

Parameters:
glyph glyph value

Definition at line 8526 of file gdi.h.

#define SELECT_DEVFONT | ( | plogfont,
 |  | glyph | )

Value:

((glyph) & 0x80000000 ? \
    (plogfont)->mbc_devfont : \
    (plogfont)->sbc_devfont)
select a device font acording to the glyph value.

Parameters:
plogfont | pointer to a logical font.
glyph | glyph value.

Definition at line 8537 of file gdi.h.

#define SET_MBC_GLYPH ( glyph ) ((glyph) | 0x80000000)

set the glyph with multibyte mask

Parameters:
glyph glyph value

Definition at line 8518 of file gdi.h.

Typedef Documentation

typedef struct _GLYPHINFO GLYPHINFO

Data type of struct _GLYPHINFO.

typedef struct _GLYPHMAPINFO GLYPHMAPINFO

Data type of struct _GLYPHMAPINFO.

Enumeration Type Documentation

enum typedef enum SHAPETYPE

Data type of enum.

Definition at line 8546 of file gdi.h.

Function Documentation

void GUIAPI BIDIGetLogicalEmbeddLevels | ( | LOGFONT * | log_font,
 |  | Glyph32 * | glyphs,
 |  | int | nr_glyphs,
 |  | Uint8 ** | embedding_level_list
 | ) |  |

Get the logical embedding levels for the logical glyph string and generate runs by embedding levels, the for reorder to get visual glyph string.

Parameters:
log_font | The logical font.
glyphs | The pointer to the logical glyph string.
nr_glyphs | The length of the glyph string.
embedding_level_list | The logical embedding level.
Returns:
None.

int GUIAPI BIDIGetTextLogicalGlyphs | ( | LOGFONT * | log_font,
 |  | const char * | text,
 |  | int | text_len,
 |  | Glyph32 ** | glyphs,
 |  | GLYPHMAPINFO ** | glyphs_map
 | ) |  |

Get logical glyphs string of the text.

Parameters:
log_font | The logical font.
text | The logical text string.
text_len | The lenght of the logical text string in bytes.
glyphs | The pointer to the logical glyph string.
glyphs_map | The position map from the logical glyphs string to the logical text.
Returns:
The length of the logical glyph string.
See also:
GLYPHMAPINFO

int GUIAPI BIDIGetTextVisualGlyphs | ( | LOGFONT * | log_font,
 |  | const char * | text,
 |  | int | text_len,
 |  | Glyph32 ** | glyphs,
 |  | GLYPHMAPINFO ** | glyphs_map
 | ) |  |

Get visual glyphs and glyph_map info relative with logical string byte index.

Parameters:
log_font | The logical font.
text | The logical text string.
text_len | The length of the logical text string in bytes.
glyphs | The pointer to the visual glyph string.
glyphs_map | The position map from visual glyphs string to the logical text.
Returns:
The length of the visual glyph string.

void GUIAPI BIDIGetVisualEmbeddLevels | ( | LOGFONT * | log_font,
 |  | Glyph32 * | glyphs,
 |  | int | nr_glyphs,
 |  | Uint8 ** | embedding_level_list
 | ) |  |

Get the visual embedding levels for the given logical glyph string, then you can get the edge for visual glyphs.

Parameters:
log_font | The logical font.
glyphs | The pointer to the logical glyph string.
nr_glyphs | The length of the glyph string.
embedding_level_list | The embedding level logical to visual.
Returns:
void.

Glyph32 *GUIAPI BIDILogGlyphs2VisGlyphs | ( | LOGFONT * | log_font,
 |  | Glyph32 * | glyphs,
 |  | int | nr_glyphs,
 |  | GLYPHMAPINFO * | glyphs_map
 | ) |  |

Reorder the logical glyphs string to visual glyphs string.

This function reorders the logical glyphs string to visual glyphs string. If glyphs_map is not NULL, get the visual glyphs map info.

Parameters:
log_font | The logical font.
glyphs | The pointer to the glyph string.
nr_glyphs | The length of the glyph string.
glyphs_map | The position map from the logical glyph string to the visual glyph string.
Returns:
The pointer to the visual glyph string.

int GUIAPI DrawGlyph | ( | HDC | hdc,
 |  | int | x,
 |  | int | y,
 |  | Glyph32 | glyph_value,
 |  | int * | adv_x,
 |  | int * | adv_y
 | ) |  |

Draw a glyph.

This function draws a glyph to the specific postion of a DC.

Parameters:
hdc | The device context.
x | The output start x position.
y | The output start y position.
glyph_value | The glyph value.
adv_x | The pointer used to return the advance in x-coordinate of the glyph, can be NULL.
adv_y | The pointer used to return the advance in y-coordinate of the glyph, can be NULL.
Returns:
The advance on baseline.

int GUIAPI GetGlyphInfo | ( | LOGFONT * | logfont,
 |  | Glyph32 | glyph_value,
 |  | GLYPHINFO * | glyph_info
 | ) |  |

Retriev the information of a glyph.

This function retrieves the information of a glyph.

Parameters:
logfont | The logical font.
glyph_value | The glyph value.
glyph_info | The glyph information will be returned through this struct.
Note:
You must set glyph_info->mask to indicate what you want.
Returns:
The advance of the glyph string on baseline.
See also:
GLYPHINFO

int GUIAPI GetGlyphsExtent | ( | HDC | hdc,
 |  | Glyph32 * | glyphs,
 |  | int | nr_glyphs,
 |  | SIZE * | size
 | ) |  |

Get visual extent value of a glyph string.

This function gets the extent value of a glyph string on a DC.

Parameters:
hdc | The device context.
glyphs | Input glyph string, input.
nr_glyphs | Input glyph string len, input.
size | Ouput the fit glyph's extent value, Output.
Returns:
The extent of the glyph string.

int GUIAPI GetGlyphsExtentPoint | ( | HDC | hdc,
 |  | Glyph32 * | glyphs,
 |  | int | nr_glyphs,
 |  | int | max_extent,
 |  | SIZE * | size
 | ) |  |

Get the visual extent value of a glyph string.

This function gets the visual extent value of a glpyh string.

Parameters:
hdc | The device context.
glyphs | The pointer to the glyph string.
nr_glyphs | The length of the glyph string len.
max_extent | The maximal output extent value.
size | The real extent of all visual glyphs in the glyph string.
Returns:
The the index of the last glyph which can be fit to the extent.

Glyph32 GUIAPI GetGlyphShape | ( | LOGFONT * | logfont,
 |  | const char * | mchar,
 |  | int | mchar_len,
 |  | SHAPETYPE | shape_type
 | ) |  |

Get the glyph shape of a character.

Parameters:
logfont | The logical font.
mchar | The pointer to the multi-byte character.
mchar_len | The length of mchar in bytes.
shape_type | The shape type of mchar.
Returns:
The multi-byte character's glyph shape value.

Glyph32 GUIAPI GetGlyphValue | ( | LOGFONT * | logfont,
 |  | const char * | mchar,
 |  | int | mchar_len,
 |  | const char * | pre_mchar,
 |  | int | pre_len
 | ) |  |

Get the glyph value of a multi-byte character.

Parameters:
logfont | The logical font.
mchar | The pointer to the multi-byte character.
mchar_len | The length of mchar in bytes.
pre_mchar | The pointer to the multi-byte character before mchar.
pre_len | The length of per_mchar in bytes.
Returns:
The glyph value of the multi-byte character.

void GUIAPI GetTextRangesLog2Vis | ( | LOGFONT * | log_font,
 |  | char * | text,
 |  | int | text_len,
 |  | int | start_index,
 |  | int | end_index,
 |  | int ** | ranges,
 |  | int * | nr_ranges
 | ) |  |

Get a list of visual ranges corresponding to a given logical range.

Parameters:
log_font | The logical font.
text | The pointer to the logical text string.
text_len | The length of the logical text string in bytes.
start_index | The start index of the logical range.
end_index | The end index of the logical range.
ranges | The pointer to store a pointer to an array of arranges.
nr_ranges | The number of ranges stored in ranges.
Returns:
None.

Generated on Fri Dec 17 13:49:48 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: GDI functions

GDI functions
[Functions]

Modules

  • Region operations
  • General DC operations
  • DC attribute operations
  • Palette operations
  • General drawing functions
  • Mapping Operations
  • Clipping operations
  • BITMAP and blitting operations
  • Icon operations
  • Rectangle operations
  • Logical font operations
  • System charset and font operations
  • Text parsing functions
  • Text output functions
  • Bitmap structure
  • Bitmap file load/save operations
  • Glyph defines and operations

Typedefs

  • typedef struct _BITMAP BITMAP
  • typedef BITMAP * PBITMAP
    Data type of pointer to a BITMAP.
  • typedef struct _MYBITMAP MYBITMAP
  • typedef struct _MYBITMAP * PMYBITMAP
    Data type of pointer to a struct _MYBITMAP.

Typedef Documentation

typedef struct _BITMAP BITMAP

See also:
_BITMAP

Definition at line 484 of file gdi.h.

typedef struct _MYBITMAP MYBITMAP

See also:
_MYBITMAP

Definition at line 499 of file gdi.h.

typedef BITMAP * PBITMAP

Data type of pointer to a BITMAP.

See also:
BITMAP _BITMAP

Definition at line 491 of file gdi.h.

typedef struct _MYBITMAP * PMYBITMAP

Data type of pointer to a struct _MYBITMAP.

See also:
MYBITMAP _MYBITMAP

Definition at line 506 of file gdi.h.

Generated on Fri Dec 17 13:49:47 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Message passing functions

Message passing functions
[Message functions]

Data Structures

  • struct _MSG

Defines

  • #define PM_NOREMOVE 0x0000
  • #define PM_REMOVE 0x0001
  • #define PM_NOYIELD 0x0002
  • #define SendAsyncMessage SendMessage
    Is an alias of SendMessage for MiniGUI-Processes and MiniGUI-Standalone.

Functions

  • MG_EXPORT BOOL GUIAPI PeekMessageEx (PMSG pMsg, HWND hWnd, int iMsgFilterMin, int iMsgFilterMax, BOOL bWait, UINT uRemoveMsg)
    Peeks a message from the message queue of a main window.
  • static BOOL GUIAPI GetMessage (PMSG pMsg, HWND hWnd)
    Gets a message from the message queue of a main window.
  • MG_EXPORT BOOL GUIAPI WaitMessage (PMSG pMsg, HWND hMainWnd)
    Waits for a message from the message queue of a main window.
  • MG_EXPORT BOOL GUIAPI HavePendingMessage (HWND hMainWnd)
    Checks if there is any pending message in the message queue of a main window.
  • static BOOL GUIAPI PeekMessage (PMSG pMsg, HWND hWnd, int iMsgFilterMin, int iMsgFilterMax, UINT uRemoveMsg)
    Peeks a message from the message queue of a main window.
  • MG_EXPORT BOOL GUIAPI PeekPostMessage (PMSG pMsg, HWND hWnd, int iMsgFilterMin, int iMsgFilterMax, UINT uRemoveMsg)
    Peeks a post message from the message queue of a main window.
  • MG_EXPORT int GUIAPI PostMessage (HWND hWnd, int iMsg, WPARAM wParam, LPARAM lParam)
    Posts a message into the message queue of a window and returns immediatly.
  • MG_EXPORT int GUIAPI SendMessage (HWND hWnd, int iMsg, WPARAM wParam, LPARAM lParam)
    Sends a message to a window.
  • MG_EXPORT void GUIAPI SetAutoRepeatMessage (HWND hwnd, int msg, WPARAM wParam, LPARAM lParam)
    Sets the auto-repeat message.
  • MG_EXPORT int GUIAPI SendNotifyMessage (HWND hWnd, int iMsg, WPARAM wParam, LPARAM lParam)
    Sends a notification message to a window.
  • MG_EXPORT int GUIAPI BroadcastMessage (int iMsg, WPARAM wParam, LPARAM lParam)
    Broadcasts a message to all main window on the desktop.
  • MG_EXPORT int GUIAPI PostQuitMessage (HWND hWnd)
    Puts a MSG_QUIT message into the message queue of a main window.
  • MG_EXPORT BOOL GUIAPI SetKeyboardLayout (const char *kbd_layout)
    Sets a new keyboard layout.
  • MG_EXPORT BOOL GUIAPI TranslateMessage (PMSG pMsg)
    Translates key down and key up messages to MSG_CHAR message and post it into the message queue.
  • MG_EXPORT BOOL GUIAPI TranslateKeyMsgToChar (int message, WPARAM wParam, LPARAM lParam, WORD *ch)
    Translates a key down and key up message to a corresponding character.
  • MG_EXPORT int GUIAPI DispatchMessage (PMSG pMsg)
    Dispatches a message to the window's callback procedure.
  • MG_EXPORT int GUIAPI ThrowAwayMessages (HWND pMainWnd)
    Removes all messages in the message queue associated with a window.
  • MG_EXPORT BOOL GUIAPI EmptyMessageQueue (HWND hWnd)
    Empties a message queue.

Define Documentation

#define PM_NOREMOVE 0x0000

See also:
PeekMessage PeekMessageEx

Definition at line 2189 of file window.h.

#define PM_NOYIELD 0x0002

See also:
PeekMessage PeekMessageEx PeekPostMessage

Definition at line 2203 of file window.h.

#define PM_REMOVE 0x0001

See also:
PeekMessage PeekMessageEx PeekPostMessage

Definition at line 2196 of file window.h.

Referenced by GetMessage().

#define SendAsyncMessage SendMessage

Is an alias of SendMessage for MiniGUI-Processes and MiniGUI-Standalone.

See also:
SendMessage

Definition at line 2423 of file window.h.

Function Documentation

int BroadcastMessage | ( | int | iMsg,
 |  | WPARAM | wParam,
 |  | LPARAM | lParam
 | ) |  |

Broadcasts a message to all main window on the desktop.

This function posts the message specified by (iMsg, wParam, lParam) to all the main windows on the desktop.

Parameters:
iMsg | The message identifier.
wParam | The first parameter of the message.
lParam | The second parameter of the message.
Returns:
0 if all OK, < 0 on error.
See also:
PostMessage

int DispatchMessage ( PMSG pMsg )

Dispatches a message to the window's callback procedure.

This function dispatches the message pointed to by pMsg to the target window's callback procedure.

Parameters:
pMsg The pointer to the message.
Returns:
The return value of the message handler.
See also:
GetMessage
Example:

/*
 * A typical message loop.
 */

    MSG Msg;
    MAINWINCREATE CreateInfo;
    HWND hMainWnd;

    InitCreateInfo (&CreateInfo);

    hMainWnd = CreateMainWindow (&CreateInfo);
    if (hMainWnd == HWND_INVALID)
        return -1;

    while (GetMessage (&Msg, hMainWnd)) {
        TranslateMessage (&Msg);
        DispatchMessage (&Msg);
    }

BOOL EmptyMessageQueue ( HWND hWnd )

Empties a message queue.

This function empties the message queue of the main window hWnd.

Parameters:
hWnd The handle to the main window.
Returns:
TRUE on all success, FALSE on error.
Note:
Only defined for MiniGUI-Processes.
See also:
ThrowAwayMessages

BOOL GetMessage | ( | PMSG | pMsg,
 |  | HWND | hMainWnd |
 | ) |  |  | [inline, static]

Gets a message from the message queue of a main window.

This function gets a message from the message queue of the main window hMainWnd, and returns until there is a message in the message queue.

Parameters:
pMsg | Pointer to the result message.
hMainWnd | Handle to the window.
Returns:
FALSE on MSG_QUIT have been found or on error, else gets a message.
See also:
HavePendingMessage, PostQuitMessage, MSG
Example:

/*
 * A typical message loop.
 */

    MSG Msg;
    MAINWINCREATE CreateInfo;
    HWND hMainWnd;

    InitCreateInfo (&CreateInfo);

    hMainWnd = CreateMainWindow (&CreateInfo);
    if (hMainWnd == HWND_INVALID)
        return -1;

    while (GetMessage (&Msg, hMainWnd)) {
        TranslateMessage (&Msg);
        DispatchMessage (&Msg);
    }

Definition at line 2254 of file window.h.

References PeekMessageEx(), PM_REMOVE, and TRUE.

BOOL HavePendingMessage ( HWND hMainWnd )

Checks if there is any pending message in the message queue of a main window.

This function checks whether there is any pending message in the message queue of the main window hMainWnd.

Parameters:
hMainWnd The handle to the main window.
Returns:
TRUE for pending message, FALSE for empty message queue.
See also:
GetMessage, MSG

BOOL PeekMessage | ( | PMSG | pMsg,
 |  | HWND | hWnd,
 |  | int | iMsgFilterMin,
 |  | int | iMsgFilterMax,
 |  | UINT | uRemoveMsg |
 | ) |  |  | [inline, static]

Peeks a message from the message queue of a main window.

This functions peek a message from the message queue of the window hWnd and returns immediatly. Unlike GetMessage, this function does not wait for a message.

Parameters:
pMsg | Pointer to the result message.
hWnd | The handle to the window.
iMsgFilterMin | The min identifier of the message that should be peeked.
iMsgFilterMax | The max identifier of the message that should be peeked.
uRemoveMsg Whether remove the message from the message queue. Should be the following values:
  • PM_NOREMOVE
    Leave it in the message queue.
  • PM_REMOVE Remove it from the message queue.
  • PM_NOYIELD Nouse now.
Returns:
TRUE if there is a message peeked, or FALSE.
See also:
GetMessage, PeekPostMessage, HavePendingMessage, PostMessage

Definition at line 2319 of file window.h.

References FALSE, and PeekMessageEx().

BOOL PeekMessageEx | ( | PMSG | pMsg,
 |  | HWND | hWnd,
 |  | int | iMsgFilterMin,
 |  | int | iMsgFilterMax,
 |  | BOOL | bWait,
 |  | UINT | uRemoveMsg
 | ) |  |

Peeks a message from the message queue of a main window.

This functions peek a message from the message queue of the window hWnd; if bWait is TRUE, it will wait for the message, else return immediatly.

Parameters:
pMsg | Pointer to the result message.
hWnd | The handle to the window.
iMsgFilterMin | The min identifier of the message that should be peeked.
iMsgFilterMax | The max identifier of the message that should be peeked.
bWait | Whether to wait for a message.
uRemoveMsg Whether remove the message from the message queue. Should be the following values:
  • PM_NOREMOVE
    Leave it in the message queue.
  • PM_REMOVE Remove it from the message queue.
  • PM_NOYIELD Nouse now.
Returns:
TRUE if there is a message peeked, or FALSE.
See also:
GetMessage, PeekPostMessage, HavePendingMessage, PostMessage

Referenced by GetMessage(), and PeekMessage().

BOOL PeekPostMessage | ( | PMSG | pMsg,
 |  | HWND | hWnd,
 |  | int | iMsgFilterMin,
 |  | int | iMsgFilterMax,
 |  | UINT | uRemoveMsg
 | ) |  |

Peeks a post message from the message queue of a main window.

This functions peek a message from the message queue of the window hWnd and returns immediatly. Unlike PeekMessage, this function only peek a post message.

Parameters:
pMsg | Pointer to the result message.
hWnd | The handle to the window.
iMsgFilterMin | The min identifier of the message that should be peeked.
iMsgFilterMax | The max identifier of the message that should be peeked.
uRemoveMsg Whether remove the message from the message queue. Should be the following values:
  • PM_NOREMOVE
    Leave it in the message queue.
  • PM_REMOVE Remove it from the message queue.
  • PM_NOYIELD Nouse now.
Returns:
TRUE if there is a message peeked, or FALSE.
See also:
GetMessage, PeekMessage, HavePendingMessage, PostMessage

int PostMessage | ( | HWND | hWnd,
 |  | int | iMsg,
 |  | WPARAM | wParam,
 |  | LPARAM | lParam
 | ) |  |

Posts a message into the message queue of a window and returns immediatly.

This functions posts a message into the message queue of the window hWnd and returns immediately.

Parameters:
hWnd | The handle to the window.
iMsg | The identifier of the message.
wParam | The first parameter of the message.
lParam | The second parameter of the message.
Returns:
ERR_OK on success, < 0 on errors.
Return values:
ERR_OK | Post message successfully.
ERR_QUEUE_FULL | The message queue is full.
ERR_INV_HWND | Invalid window handle.
See also:
SendMessage

int PostQuitMessage ( HWND hWnd )

Puts a MSG_QUIT message into the message queue of a main window.

This function puts a MSG_QUIT message into the message queue of the main window hWnd. The next call to GetMessage will return 0.

Parameters:
hWnd The handle to the main window.
Returns:
0 if all OK, < 0 on error.
See also:
GetMessage

int SendMessage | ( | HWND | hWnd,
 |  | int | iMsg,
 |  | WPARAM | wParam,
 |  | LPARAM | lParam
 | ) |  |

Sends a message to a window.

This function sends a message to the window hWnd, and will return until the message-handling process returns.

Parameters:
hWnd | The handle to the window.
iMsg | The identifier of the message.
wParam | The first parameter of the message.
lParam | The second parameter of the message.
Returns:
The return value of the message handler.
See also:
PostMessage

int SendNotifyMessage | ( | HWND | hWnd,
 |  | int | iMsg,
 |  | WPARAM | wParam,
 |  | LPARAM | lParam
 | ) |  |

Sends a notification message to a window.

This function sends the notification message specified by (iMsg, wParam, lParam) to the window hWnd. This function puts the notication message in the message queue and then returns immediately.

Parameters:
hWnd | The handle to the window.
iMsg | The message identifier.
wParam | The first parameter of the message.
lParam | The second parameter of the message.
Returns:
0 if all OK, < 0 on error.
See also:
SendMessage, PostMessage

void GUIAPI SetAutoRepeatMessage | ( | HWND | hwnd,
 |  | int | msg,
 |  | WPARAM | wParam,
 |  | LPARAM | lParam
 | ) |  |

Sets the auto-repeat message.

This function sets the auto-repeat message. When the default message procedure receives an MSG_IDLE message, the default handler will send the auto-repeat message to the target window as a notification message.

Parameters:
hwnd | The handle to the target window. Set it to zero to disable the auto-repeat message.
msg | The identifier of the auto-repeat message.
wParam | The first parameter of the auto-repeat message.
lParam | The second parameter of the auto-repeat message.

BOOL SetKeyboardLayout ( const char * kbd_layout )

Sets a new keyboard layout.

This function sets the keymaps to translate key scancodes to MSG_CHAR or MSG_KEYSYM messages. The default keymaps is for US PC keyboard layout, you can call this function to set a different keyboard layout. The argument of kbd_layout specifies the name of the keyboard layout.

Parameters:
kbd_layout The keyboard layout name. It can be one of the following values:
  • KBD_LAYOUT_DEFAULT
    The default keyboard layout, i.e., US PC.
  • KBD_LAYOUT_FRPC
    The France PC keyboard layout.
  • KBD_LAYOUT_FR
    The France keyboard layout.
  • KBD_LAYOUT_DE
    The German keyboard layout.
  • KBD_LAYOUT_DELATIN1
    The German Latin1 keyboard layout.
  • KBD_LAYOUT_IT
    The Italian keyboard layout.
  • KBD_LAYOUT_ES
    The Spanish keyboard layout.
  • KBD_LAYOUT_ESCP850
    The Spanish CP850 keyboard layout.
  • KBD_LAYOUT_HEBREW
    The hebrew keyboard layout.
  • KBD_LAYOUT_ARABIC
    The arabic keyboard layout.

Returns:
TRUE for success, otherwise FALSE.
See also:
TranslateMessage, MSG_CHAR, MSG_KEYSYM

int ThrowAwayMessages ( HWND pMainWnd )

Removes all messages in the message queue associated with a window.

This function removes all messages which are associated with the specified window pMainWnd.

Parameters:
pMainWnd The handle to the window.
Returns:
The number of thrown messages.
See also:
EmptyMessageQueue

BOOL GUIAPI TranslateKeyMsgToChar | ( | int | message,
 |  | WPARAM | wParam,
 |  | LPARAM | lParam,
 |  | WORD * | ch
 | ) |  |

Translates a key down and key up message to a corresponding character.

This function translates a key down and key up message to a character. If the message is not a key message, this function does nothing.

The behavior of this function is inflected by the current keyboard layout. The default keyboard layout is US PC keyboard, but you can call SetKeyboardLayout function to set a different keyboard layout.

Parameters:
message | The type of message.
wParam | Message parameter.
lParam | Message parameter.
ch | A string buffer for storing translated characters.
Returns:
A boolean indicates whether the message is a key message.
See also:
TranslateMessage

BOOL TranslateMessage ( PMSG pMsg )

Translates key down and key up messages to MSG_CHAR message and post it into the message queue.

This function translates key down and key up message to an MSG_CHAR message or some MSG_KEYSYM messages, and send the message(s) to the window procedure as a notification message. If the message is not a key message, this function does nothing.

The behavior of this function is inflected by the current keyboard layout. The default keyboard layout is US PC keyboard, but you can call SetKeyboardLayout function to set a different keyboard layout.

Parameters:
pMsg The pointer of message.
Returns:
A boolean indicates whether the message is a key message.
See also:
SetKeyboardLayout, MSG_CHAR, MSG_KEYSYM

BOOL WaitMessage | ( | PMSG | pMsg,
 |  | HWND | hMainWnd
 | ) |  |

Waits for a message from the message queue of a main window.

This function waits for a message from the message queue of the main window hMainWnd, and returns until there is a message in the message queue. Unlike GetMessage, this function does not remove the message from the message queue.

Parameters:
pMsg | Pointer to the result message.
hMainWnd | Handle to the window.
Returns:
0 on MSG_QUIT have been found, else gets a message.
See also:
HavePendingMessage, PostQuitMessage, MSG

Generated on Fri Dec 17 13:49:49 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _MSG Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_MSG Struct Reference
[Message passing functions]

#include <window.h>

Data Fields

  • HWND hwnd
  • int message
  • WPARAM wParam
  • LPARAM lParam
  • unsigned int time

Detailed Description

The message structure.
See also:
GetMessage, PostMessage, Messages

Definition at line 2152 of file window.h.

Field Documentation

HWND hwnd

The handle to the window which receives this message.

Definition at line 2155 of file window.h.

The documentation for this struct was generated from the following file:
  • window.h
Generated on Fri Dec 17 13:49:52 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Message or event hook functions

Message or event hook functions
[Message functions]

Data Structures

  • struct _HOOKINFO

Defines

  • #define HOOK_GOON 0
  • #define HOOK_STOP 1

Typedefs

  • typedef int(* MSGHOOK )(void *context, HWND dst_wnd, int msg, WPARAM wparam, LPARAM lparam)
    Type of message hook function.
  • typedef int(* SRVEVTHOOK )(PMSG pMsg)
    The type of the event hook.

Functions

  • MG_EXPORT MSGHOOK GUIAPI RegisterKeyMsgHook (void *context, MSGHOOK hook)
    Registers a key message hook.
  • MG_EXPORT MSGHOOK GUIAPI RegisterMouseMsgHook (void *context, MSGHOOK hook)
    Registers a mouse message hook.
  • MG_EXPORT SRVEVTHOOK GUIAPI SetServerEventHook (SRVEVTHOOK SrvEvtHook)
    Sets an event hook in the server of MiniGUI-Processes.

Define Documentation

#define HOOK_GOON 0

See also:
SRVEVTHOOK RegisterKeyHookWindow RegisterMouseHookWindow

Definition at line 2806 of file window.h.

#define HOOK_STOP 1

See also:
SRVEVTHOOK RegisterKeyHookWindow RegisterMouseHookWindow

Definition at line 2812 of file window.h.

Typedef Documentation

typedef int(* MSGHOOK)(void *context, HWND dst_wnd, int msg, WPARAM wparam, LPARAM lparam)

Type of message hook function.

Definition at line 2822 of file window.h.

typedef int(* SRVEVTHOOK)(PMSG pMsg)

The type of the event hook.

You can call SetServerEventHook to set an event hook in the server of the MiniGUI-Processes.

If the event hook returns HOOK_GOON, mginit will continue to handle the event, and send it to the active client. If the hook returns HOOK_STOP, mginit will cancel normal handling.

See also:
SetServerEventHook

Definition at line 2889 of file window.h.

Function Documentation

MSGHOOK GUIAPI RegisterKeyMsgHook | ( | void * | context,
 |  | MSGHOOK | hook
 | ) |  |

Registers a key message hook.

This function registers a key message hook pointed to by hook.

When the desktop receives a key message, it will send it to the hook first, and passes the context value to the hook as the first argument.

Parameters:
context | The context value will be passed to the hook.
hook | The hook. This function will unregister the old hook if hook is NULL.
Returns:
The old hook.
See also:
UnregisterHook, KEYMSGHOOK

MSGHOOK GUIAPI RegisterMouseMsgHook | ( | void * | context,
 |  | MSGHOOK | hook
 | ) |  |

Registers a mouse message hook.

This function registers a mouse message hook pointed to by hook.

When the desktop receives a mouse message, it will send it to the hook first, and passes the context value to the hook as the first argument.

Parameters:
context | The context value will be passed to the hook.
hook | The hook. This function will unregister the old hook if hook is NULL.
Returns:
The old hook.
See also:
UnregisterHook, KEYMSGHOOK

void GUIAPI SetServerEventHook ( SRVEVTHOOK SrvEvtHook )

Sets an event hook in the server of MiniGUI-Processes.

This function sets the event hook as SrvEvtHook in the server, i.e. mginit, of MiniGUI-Processes.

Parameters:
SrvEvtHook The pointer to the hook, NULL to cancel the hook.
Note:
Only defined for MiniGUI-Processes, and only can be used by the server.
See also:
SRVEVTHOOK

Generated on Fri Dec 17 13:49:49 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _HOOKINFO Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_HOOKINFO Struct Reference
[Message or event hook functions]

#include <window.h>

Data Fields

  • void * context
  • MSGHOOK hook

Detailed Description

Structure defines a message hook.

Definition at line 2828 of file window.h.

Field Documentation

void* context

the context which will be passed to the hook function.

Definition at line 2831 of file window.h.

The documentation for this struct was generated from the following file:
  • window.h
Generated on Fri Dec 17 13:49:52 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Look and Feel Renderer management functions

Look and Feel Renderer management functions
[Functions]

Data Structures

  • struct _WINDOW_ELEMENT_ATTR
  • struct _LFSCROLLBARINFO
  • struct _SCROLLBARDATA
  • struct _LFRDR_WINSTYLEINFO
  • struct _LFRDR_TRACKBARINFO
  • struct _WINDOW_ELEMENT_RENDERER
  • struct _WINDOWINFO

Defines

  • #define WE_FONTS_NUMBER 4
    The number of window element font attributes.
  • #define WE_METRICS_NUMBER 6
    The number of window element metric attributes.
  • #define WE_COLORS_NUMBER 14
    The number of window element color attributes.
  • #define WE_ATTR_TYPE_RDR 0x5000
    The specific type for LF renderer.
  • #define SBS_DISABLED_LTUP 0x0100
  • #define SBS_DISABLED_BTDN 0x0200
  • #define SBS_HILITE_LTUP 0x0400
  • #define SBS_HILITE_BTDN 0x0800
  • #define SBS_HILITE_THUMB 0x0010
  • #define SBS_PRESSED_LTUP 0x0020
  • #define SBS_PRESSED_BTDN 0x0040
  • #define SBS_PRESSED_THUMB 0x0080
  • #define LEN_RENDERER_NAME 15
    The maximum length of a renderer name.

Functions

  • static const WINDOWINFO *GUIAPI GetWindowInfo (HWND hWnd)
    Get the handle of window information.
  • MG_EXPORT BOOL GUIAPI InitWindowElementAttrs (PWERENDERER rdr)
  • MG_EXPORT DWORD GUIAPI GetWindowElementAttr (HWND hwnd, int we_attr_id)
    Get a window element data.
  • MG_EXPORT DWORD GUIAPI SetWindowElementAttr (HWND hwnd, int we_attr_id, DWORD we_attr)
    Set a new window element data specified by we_attr_id.
  • MG_EXPORT gal_pixel GUIAPI GetWindowElementPixelEx (HWND hwnd, HDC hdc, int we_attr_id)
    Get a window element gal_pixel color.
  • MG_EXPORT const
    WINDOW_ELEMENT_RENDERER
    *GUIAPI GetWindowRendererFromName (const char *name)
    Get window renderer from name.
  • MG_EXPORT BOOL GUIAPI AddWindowElementRenderer (const char *name, const WINDOW_ELEMENT_RENDERER *we_rdr)
    Add a window element renderer to the system.
  • MG_EXPORT BOOL GUIAPI RemoveWindowElementRenderer (const char *name)
    Remove a window renderer from MiniGUI.
  • MG_EXPORT const
    WINDOW_ELEMENT_RENDERER
    *GUIAPI GetDefaultWindowElementRenderer (void)
    Get the default window renderer.
  • MG_EXPORT const char *GUIAPI SetDefaultWindowElementRenderer (const char *name)
    Set a window element renderer as the default system renderer.
  • MG_EXPORT BOOL GUIAPI SetWindowElementRenderer (HWND hWnd, const char *werdr_name, const WINDOW_ELEMENT_ATTR *we_attrs)
    Set a window element renderer and window element attributes for window specified by hwnd.
  • MG_EXPORT BOOL InitRendererSystemIcon (const char *rdr_name, HICON *small_icon, HICON *large_icon)
    Initialize large and small system icons in the specified renderer rdr_name.
  • MG_EXPORT void TermRendererSystemIcon (HICON *small_icon, HICON *large_icon)
    Release large and small system icon resources.

Define Documentation

#define LEN_RENDERER_NAME 15

The maximum length of a renderer name.

Definition at line 3606 of file window.h.

#define SBS_DISABLED_BTDN 0x0200

right or bottom arrow is in disabled state

Definition at line 3531 of file window.h.

#define SBS_DISABLED_LTUP 0x0100

left or up arrow is in disabled state

Definition at line 3528 of file window.h.

#define SBS_HILITE_BTDN 0x0800

right or bottom arrow is in hilited state

Definition at line 3537 of file window.h.

#define SBS_HILITE_LTUP 0x0400

left or up arrow is in hilited state

Definition at line 3534 of file window.h.

#define SBS_HILITE_THUMB 0x0010

thumb is in hilite state as cursor is in the area of thumb

Definition at line 3540 of file window.h.

#define SBS_PRESSED_BTDN 0x0040

right or bottom arrow is in pressed state

Definition at line 3546 of file window.h.

#define SBS_PRESSED_LTUP 0x0020

left or up arrow is in pressed state

Definition at line 3543 of file window.h.

#define SBS_PRESSED_THUMB 0x0080

thumb is in pressed state as left button presses it

Definition at line 3549 of file window.h.

#define WE_ATTR_TYPE_RDR 0x5000

The specific type for LF renderer.

Definition at line 3408 of file window.h.

#define WE_COLORS_NUMBER 14

The number of window element color attributes.

Definition at line 3287 of file window.h.

#define WE_FONTS_NUMBER 4

The number of window element font attributes.

Definition at line 3275 of file window.h.

#define WE_METRICS_NUMBER 6

The number of window element metric attributes.

Definition at line 3281 of file window.h.

Function Documentation

BOOL GUIAPI AddWindowElementRenderer | ( | const char * | name,
 |  | const WINDOW_ELEMENT_RENDERER * | we_rdr
 | ) |  |

Add a window element renderer to the system.

This function adds a new window renderer to MiniGUI system.

Parameters:
name | The renderer name.
we_rdr | The pointer to a new renderer.
Returns:
TRUE for success, FALSE for failure.

const WINDOW_ELEMENT_RENDERER *GUIAPI GetDefaultWindowElementRenderer ( void )

Get the default window renderer.

This function gets the default window renderer in MiniGUI.

Returns:
the pointer to the default renderer.

DWORD GUIAPI GetWindowElementAttr | ( | HWND | hwnd,
 |  | int | we_attr_id
 | ) |  |

Get a window element data.

This function gets a window element data which is identified by we_attr_id.

Parameters:
hwnd | The handle to the window.
we_attr_id | The window element id number, can be one of the following values:
  • WE_FONT_CAPTION
    The caption font.
  • WE_FONT_MENU
    The menu font. Used by menu and listbox.
  • WE_FONT_MESSAGEBOX
    The messagebox font. Resevered.
  • WE_FONT_TOOLTIP
    The tooltip font. Used by tooltip window.

  • WE_METRICS_CAPTION
    The caption size.
  • WE_METRICS_CAPTION_BUTTON
    The caption button size.
  • WE_METRICS_MENU
    The menu size.
  • WE_METRICS_WND_BORDER
    The border size.
  • WE_METRICS_SCROLLBAR
    The scrollbar size.

  • WE_FGC_ACTIVE_CAPTION
    The active caption foreground color.
  • WE_BGCA_ACTIVE_CAPTION
    The active caption background color A.
  • WE_BGCB_ACTIVE_CAPTION
    The active caption background color B.
  • WE_FGC_MENU
    The menu foreground color.
  • WE_BGC_MENU
    The menu background color.
  • WE_FGC_MESSAGEBOX
    The messagebox foreground color. Reserved.
  • WE_FGC_TOOLTIP
    The tooltip foreground color. Only used by tooltip window.
  • WE_BGC_TOOLTIP
    The tooltip background color. Only used by tooltip window.
  • WE_FGC_ACTIVE_WND_BORDER
    The active border foreground color.
  • WE_FGC_INACTIVE_WND_BORDER
    The inactive border foreground color.
  • WE_FGC_INACTIVE_CAPTION
    The inactive caption foreground color.
  • WE_BGCA_INACTIVE_CAPTION
    The inactive caption background color A.
  • WE_BGCB_INACTIVE_CAPTION
    The inactive caption background color B.
  • WE_FGC_WINDOW
    The window foreground color. Used by window and control.
  • WE_BGC_WINDOW
    The window background color. Used by window and control.
  • WE_FGC_THREED_BODY
    The 3dbox foreground color. Mainly used by drawing 3dbox object, such as dialog and button, etc.
  • WE_MAINC_THREED_BODY
    The 3dbox background color. Mainly used by drawing menubar, dialog, header and button, etc.
  • WE_FGC_SELECTED_ITEM
    The selected item foreground color. Used by menu and control.
  • WE_BGC_SELECTED_ITEM
    The selected item background color. Used by menu and control.
  • WE_BGC_SELECTED_LOSTFOCUS
    The lostfocus selected item background color. Only Used by mledit.
  • WE_FGC_DISABLED_ITEM
    The disabled item foreground color. Used by menu and control.
  • WE_BGC_DISABLED_ITEM
    The disabled item background color. Used by menu and control.
  • WE_FGC_HIGHLIGHT_ITEM
    The highlight item foreground color. Used by menu and control.
  • WE_BGC_HIGHLIGHT_ITEM
    The highlight item background color. Used by menu and control.
  • WE_FGC_SIGNIFICANT_ITEM
    The significant item foreground color. Used by listbox.
  • WE_BGC_SIGNIFICANT_ITEM
    The significant item background color. Used by listbox.
  • WE_BGC_DESKTOP
    The desktop background color. Only used by desktop.

Returns:
If succeed, return the window element data; otherwise return -1.
See also:
SetWindowElementAttr

gal_pixel GUIAPI GetWindowElementPixelEx | ( | HWND | hwnd,
 |  | HDC | hdc,
 |  | int | we_attr_id
 | ) |  |

Get a window element gal_pixel color.

This function gets a window element gal_pixel color which is identified by we_attr_id and hdc.

Parameters:
hwnd | The handle to the window.
hdc | The device context. If -1, it will return pixel value according to window handle hwnd; otherwise return pixel value according to pixel format in hdc.
we_attr_id | The window element id number.
Returns:
If succeed, return the window element pixel color data; otherwise return -1.
See also:
GetWindowElementAttr

const WINDOWINFO *GUIAPI GetWindowInfo ( HWND hWnd ) [inline, static]

Get the handle of window information.

This function gets the handle to the window information \ from the specified window handle hWnd.

Parameters:
hWnd The handle to the window.
Returns:
The handle to the window information.

Definition at line 4093 of file window.h.

const WINDOW_ELEMENT_RENDERER *GUIAPI GetWindowRendererFromName ( const char * name )

Get window renderer from name.

Parameters:
name The renderer name.
This function gets window renderer from the specified name name, which is case-insensitive.

Returns:
The handle to the window renderer for success, NULL for failure.

BOOL GUIAPI InitRendererSystemIcon | ( | const char * | rdr_name,
 |  | HICON * | large_icon,
 |  | HICON * | small_icon
 | ) |  |

Initialize large and small system icons in the specified renderer rdr_name.

Parameters:
rdr_name | The renderer name.
large_icon | The pointer to large system icons.
small_icon | The pointer to small system icons.
Returns:
TRUE for success, FALSE for failure.

BOOL GUIAPI InitWindowElementAttrs ( PWERENDERER rdr )

This function initializes window element attributes of the specified renderer rdr according to the appropriate section in configuration file.

Parameters:
rdr The pointer to the specified renderer.
Returns:
If succeed, return TRUE; otherwise return FALSE.

BOOL BOOL GUIAPI RemoveWindowElementRenderer ( const char * name )

Remove a window renderer from MiniGUI.

This function only removes a window renderer named by name.

Parameters:
name The renderer name.
Returns:
TRUE for success, FALSE for failure.

const char *GUIAPI SetDefaultWindowElementRenderer ( const char * name )

Set a window element renderer as the default system renderer.

This function sets a window element renderer as the default system renderer.

Parameters:
name The renderer name.
Returns:
the old renderer's name for success, NULL for failure.

DWORD GUIAPI SetWindowElementAttr | ( | HWND | hwnd,
 |  | int | we_attr_id,
 |  | DWORD | we_attr
 | ) |  |

Set a new window element data specified by we_attr_id.

This function sets a new window element data we_attr to MiniGUI, which is identified by we_attr_id.

Parameters:
hwnd | The handle to the window.
we_attr_id | The window element id.
we_attr | The new window element data.
Returns:
If succeed, return the old window element data; otherwise return -1.
See also:
GetWindowElementAttr

BOOL GUIAPI SetWindowElementRenderer | ( | HWND | hwnd,
 |  | const char * | werdr_name,
 |  | const WINDOW_ELEMENT_ATTR * | we_attrs
 | ) |  |

Set a window element renderer and window element attributes for window specified by hwnd.

This function sets the window handled by hWnd to use a different window element renderer OR'ed window element attributes and updates window in time.

Parameters:
hwnd | The handle to the window.
werdr_name | The renderer name.
we_attrs | The pointer to new window element attributes.
Returns:
TRUE for success, FALSE for failure.

void GUIAPI TermRendererSystemIcon | ( | HICON * | large_icon,
 |  | HICON * | small_icon
 | ) |  |

Release large and small system icon resources.

Parameters:
large_icon | The pointer to large system icons.
small_icon | The pointer to small system icons.
See also:
InitRendererSystemIcon

Generated on Fri Dec 17 13:49:50 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _WINDOW_ELEMENT_ATTR Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_WINDOW_ELEMENT_ATTR Struct Reference
[Look and Feel Renderer management functions]

#include <window.h>

Data Fields

  • int we_attr_id
  • DWORD we_attr

Detailed Description

The window element attributes structure.

Definition at line 3458 of file window.h.

Field Documentation

int we_attr_id

The attribute identifier.

Definition at line 3460 of file window.h.

The documentation for this struct was generated from the following file:
  • window.h
Generated on Fri Dec 17 13:49:52 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _LFSCROLLBARINFO Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_LFSCROLLBARINFO Struct Reference
[Look and Feel Renderer management functions]

#include <window.h>

Data Fields

  • int minPos
  • int maxPos
  • int curPos
  • int pageStep
  • int arrowLen
  • int barStart
  • int barLen
  • int status

Detailed Description

The scrollbar information structure in look and feel.

Definition at line 3475 of file window.h.

Field Documentation

int minPos

The minimum value of scrollbar range.

Definition at line 3477 of file window.h.

The documentation for this struct was generated from the following file:
  • window.h
Generated on Fri Dec 17 13:49:52 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _SCROLLBARDATA Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_SCROLLBARDATA Struct Reference
[Look and Feel Renderer management functions]

#include <window.h>

Data Fields

  • int minPos
  • int maxPos
  • int curPos
  • int pageStep
  • int arrowLen
  • int barStart
  • int barLen
  • int status

Detailed Description

The scrollbar data construction for scrollbar control.

Definition at line 3499 of file window.h.

Field Documentation

int minPos

The minimum value of scrollbar range.

Definition at line 3501 of file window.h.

The documentation for this struct was generated from the following file:
  • window.h
Generated on Fri Dec 17 13:49:52 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _LFRDR_WINSTYLEINFO Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_LFRDR_WINSTYLEINFO Struct Reference
[Look and Feel Renderer management functions]

#include <window.h>

Data Fields

  • int dwStyle
  • int winType

Detailed Description

The window style information structure. Used by calc_we_metrics renderer function.

Definition at line 3560 of file window.h.

Field Documentation

int dwStyle

The styles of window.

Definition at line 3563 of file window.h.

The documentation for this struct was generated from the following file:
  • window.h
Generated on Fri Dec 17 13:49:52 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _LFRDR_TRACKBARINFO Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_LFRDR_TRACKBARINFO Struct Reference
[Look and Feel Renderer management functions]

#include <window.h>

Detailed Description

The scrollbar information structure. Used by draw_scrollbar and get_scrollbar_rect renderer function.

Definition at line 3581 of file window.h.

The documentation for this struct was generated from the following file:
  • window.h
Generated on Fri Dec 17 13:49:52 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _WINDOW_ELEMENT_RENDERER Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_WINDOW_ELEMENT_RENDERER Struct Reference
[Look and Feel Renderer management functions]

#include <window.h>

Data Fields

  • const char name [LEN_RENDERER_NAME+1]
  • int(* init )(PWERENDERER renderer)
  • int(* deinit )(PWERENDERER renderer)
  • DWORD(* calc_3dbox_color )(DWORD color, int flag)
  • void(* draw_3dbox )(HDC hdc, const RECT *pRect, DWORD color, DWORD flag)
  • void(* draw_radio )(HDC hdc, const RECT *pRect, DWORD color, int status)
  • void(* draw_checkbox )(HDC hdc, const RECT *pRect, DWORD color, int status)
  • void(* draw_checkmark )(HDC hdc, const RECT *pRect, DWORD color, int status)
  • void(* draw_arrow )(HWND hWnd, HDC hdc, const RECT *pRect, DWORD color, int status)
  • void(* draw_fold )(HWND hWnd, HDC hdc, const RECT *pRect, DWORD color, int status, int next)
  • void(* draw_focus_frame )(HDC hdc, const RECT *pRect, DWORD color)
  • void(* draw_normal_item )(HWND hWnd, HDC hdc, const RECT *pRect, DWORD color)
  • void(* draw_hilite_item )(HWND hWnd, HDC hdc, const RECT *pRect, DWORD color)
  • void(* draw_disabled_item )(HWND hWnd, HDC hdc, const RECT *pRect, DWORD color)
  • void(* draw_significant_item )(HWND hWnd, HDC hdc, const RECT *pRect, DWORD color)
  • void(* draw_push_button )(HWND hWnd, HDC hdc, const RECT *pRect, DWORD color1, DWORD color2, int status)
  • void(* draw_radio_button )(HWND hWnd, HDC hdc, const RECT *pRect, int status)
  • void(* draw_check_button )(HWND hWnd, HDC hdc, const RECT *pRect, int status)
  • void(* draw_border )(HWND hWnd, HDC hdc, BOOL is_active)
  • void(* draw_caption )(HWND hWnd, HDC hdc, BOOL is_active)
  • void(* draw_caption_button )(HWND hwnd, HDC hdc, int ht_code, int state)
  • void(* draw_scrollbar )(HWND hWnd, HDC hdc, int sb_pos)
  • void(* calc_trackbar_rect )(HWND hWnd, LFRDR_TRACKBARINFO *info, DWORD dwStyle, const RECT *rcClient, RECT *rcRuler, RECT *rcBar, RECT *rcBorder)
  • void(* draw_trackbar )(HWND hWnd, HDC hdc, LFRDR_TRACKBARINFO *info)
  • int(* calc_we_area )(HWND hWnd, int which, RECT *we_area)
  • int(* calc_we_metrics )(HWND hWnd, LFRDR_WINSTYLEINFO *style_info, int which)
  • int(* hit_test )(HWND hWnd, int x, int y)
  • int(* on_click_hotspot )(HWND hWnd, int which)
  • void(* draw_custom_hotspot )(HWND hWnd, HDC hdc, int ht_code, int state)
  • void(* calc_thumb_area )(HWND hWnd, BOOL vertical, LFSCROLLBARINFO *sb_info)
  • void(* disabled_text_out )(HWND hWnd, HDC hdc, const char *spText, PRECT rc, DWORD dt_fmt)
  • void(* draw_tab )(HWND hWnd, HDC hdc, RECT *rect, char *title, DWORD color, int flag, HICON icon)
  • void(* draw_progress )(HWND hWnd, HDC hdc, int nMax, int nMin, int nPos, BOOL fVertical)
  • void(* draw_header )(HWND hWnd, HDC hdc, const RECT *pRect, DWORD color)
  • DWORD(* on_get_rdr_attr )(struct _WINDOW_ELEMENT_RENDERER *, int we_attr_id)
  • DWORD(* on_set_rdr_attr )(struct _WINDOW_ELEMENT_RENDERER *, int we_attr_id, DWORD we_attr, BOOL change)
  • void(* erase_background )(HWND hWnd, HDC hdc, const RECT *rect)
  • void(* draw_normal_menu_item )(HWND hWnd, HDC hdc, const RECT *pRect, DWORD color)
  • void(* draw_hilite_menu_item )(HWND hWnd, HDC hdc, const RECT *pRect, DWORD color)
  • void(* draw_disabled_menu_item )(HWND hWnd, HDC hdc, const RECT *pRect, DWORD color)
  • int we_metrics [WE_METRICS_NUMBER]
  • DWORD we_colors [WE_COLORS_NUMBER][3]
  • PLOGFONT we_fonts [WE_FONTS_NUMBER]
  • HICON we_icon [2][SYSICO_ITEM_NUMBER]
  • unsigned int refcount
  • const void * private_info

Detailed Description

The window element renderer structure.

Definition at line 3670 of file window.h.

Field Documentation

const char name[LEN_RENDERER_NAME+1]

The renderer name.

Definition at line 3672 of file window.h.

The documentation for this struct was generated from the following file:
  • window.h
Generated on Fri Dec 17 13:49:52 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _WINDOWINFO Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_WINDOWINFO Struct Reference
[Look and Feel Renderer management functions]

#include <window.h>

Data Fields

  • int left
  • int cl
  • DWORD dwStyle
  • DWORD dwExStyle
  • int iBkColor
  • HMENU hMenu
  • HACCEL hAccel
  • HCURSOR hCursor
  • HICON hIcon
  • HMENU hSysMenu
  • PLOGFONT pLogFont
  • char * spCaption
  • int id
  • LFSCROLLBARINFO vscroll
  • LFSCROLLBARINFO hscroll
  • WINDOW_ELEMENT_RENDERER * we_rdr

Detailed Description

The window information structure.

Definition at line 4038 of file window.h.

Field Documentation

int left

The position and size of window.

Definition at line 4041 of file window.h.

The documentation for this struct was generated from the following file:
  • window.h
Generated on Fri Dec 17 13:49:52 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Resource managment functions

Resource managment functions
[Functions]

Functions

  • MG_EXPORT BOOL GUIAPI RegisterResFromFile (HDC hdc, const char *file)
    Register a device-dependent bitmap from a file.
  • MG_EXPORT BOOL GUIAPI RegisterResFromMem (HDC hdc, const char *file, const unsigned char *data, size_t data_size)
    Register a device-dependent bitmap to bitmap cache from memory.
  • MG_EXPORT BOOL GUIAPI RegisterResFromBitmap (const char *file, const BITMAP *bmp)
    Register a device-dependent bitmap to bitmap cache.
  • MG_EXPORT const BITMAP *GUIAPI RetrieveRes (const char *file)
    Get a BITMAP object from cache according to the specified resource file name.
  • MG_EXPORT void GUIAPI UnregisterRes (const char *file)
    Unregister the BITMAP object from cache according to the specified resource file name.
  • MG_EXPORT BOOL GUIAPI RegisterSystemBitmap (HDC hdc, const char *rdr_name, const char *id)
    Register a device-dependent bitmap from id to BITMAP cache.
  • MG_EXPORT void GUIAPI UnregisterSystemBitmap (HDC hdc, const char *rdr_name, const char *id)
    Unregister a BITMAP object from BITMAP cache.
  • MG_EXPORT int SetResPath (const char *path)
    Set user's resouce path into the search paths of resouce manager.
  • MG_EXPORT int AddInnerRes (INNER_RES *inner_res, int count, BOOL copy)
    Add some incore resource into the resource manager in order to call LoadResouce to get those resource.
  • MG_EXPORT int RegisterResType (int type, RES_TYPE_OPS *ops)
    Register a new user-defined type into resource manager, so that the LoadResouce can load the special resouce automatically.
  • MG_EXPORT int UnregisterResType (int type)
    Unregister a user-defined resource type.
  • MG_EXPORT void * LoadResource (const char *res_name, int type, DWORD usr_param)
    Load a resouce from disk or memory.
  • MG_EXPORT void * GetResource (RES_KEY key)
    Retrive and return a buffered resouce by the key.
  • MG_EXPORT int AddResRef (RES_KEY key)
    Increase the reference count of a buffered resouce.
  • MG_EXPORT int ReleaseRes (RES_KEY key)
    Release the buffered resouce. It will decrease the reference count of the resouce. If the reference count is less then 0, the resource will be released.
  • MG_EXPORT RES_KEY Str2Key (const char *str)
    Translate a string to an unsigned long (RES_KEY), which is used to find a resouce in the resource manager.

Function Documentation

int AddInnerRes | ( | INNER_RES * | inner_res,
 |  | int | count,
 |  | BOOL | copy
 | ) |  |

Add some incore resource into the resource manager in order to call LoadResouce to get those resource.

Parameters:
inner_res | The pointer to the incore resouce.
count | The bytes count of inner_res.
copy | TRUE indicate that resouce manager will copy the value of inner_res array, otherwise, resouce manager just save the pointer to inner_res.
Returns:
RES_RET_OK for success or error code.

int AddResRef ( RES_KEY key )

Increase the reference count of a buffered resouce.

When you get a resouce, you should call this function to ensure that the resouce can not be unloaded when you still use it. This function must be called after LoadResouce.

Parameters:
key The key of resouce (use Str2Key(res_name) to get the key).
Returns:
The reference count; -1 if the resouce does not exist.
See also:
LoadResouce, GetResouce, ReleaseRes, Str2Key

void * GetResource ( RES_KEY key )

Retrive and return a buffered resouce by the key.

You should call LoadResouce firstly, and then call GetResouce when you need it. Note that GetResouce will not increase the reference count automatically.

Parameters:
key The key of the resouce.
Returns:
the pointer to the resouce; NULL if the resource does not exist.
See also:
LoadResouce, Str2Key

void * LoadResource | ( | const char * | res_name,
 |  | int | type,
 |  | DWORD | usr_param
 | ) |  |

Load a resouce from disk or memory.

This function loads a resource from disk or memory. If the resouce is loaded, it will return the buffered one and increase the reference count. This function will try to find a loader for the resource first according to type.

Parameters:
res_name The resouce name. If res_name is an absolute path (the leading character is '/'), it will load resouce from disk directly, else it will:
  • step 1) try to find the resource in loaded buffer.
  • step 2) if step 1 failed, try to load from incore memory.
  • step 3) if step 2 failed, try to find the file in the path set by SetResPath and load it.
  • step 4) if step 3 failed, try to find the file in the path where MiniGUI.cfg locates.
  • step 5) return NULL if all steps faild
type The resource type what you want to load. It must be one of the following values:
  • RES_TYPE_IMAGE: A BITMAP object (BITMAP*).
  • RES_TYPE_MYBITMAP: A MYBITMAP object (MYBITMAP*).
  • RES_TYPE_ICON: An icon (HICON).
  • RES_TYPE_CURSOR: A cursor (HCURSOR).
  • RES_TYPE_ETC: A configuration (GHANDLE).
  • RES_TYPE_TEXT: NOT implemented.
  • RES_TYPE_MENU: NOT implemented.
  • RES_TYPE_WINDOW: NOT implemented.
  • RES_TYPE_MEM_RES: A in-memory resource (MEM_RES*).
  • RES_TYPE_USER ~ RES_TYPE_USER_MAX: A user-defined resource type (void*).
usr_param The param pass to RES_TYPE_OPS.get_res_data. For resource type RES_TYPE_IMAGE and RES_TYPE_ICON, it must be a handle to DC.
Returns:
The pointer of resouce, see the parameter type.
See also:
enum emResType, MEM_RES, SetResPath, AddInnerRes, RegisterResType, GetResouce

BOOL GUIAPI RegisterResFromBitmap | ( | const char * | file,
 |  | const BITMAP * | bmp
 | ) |  |

Register a device-dependent bitmap to bitmap cache.

This function register a device-dependent bitmap to bitmap cache.

Parameters:
file | The name of image file. The suffix indicates image type such as bmp, png, jpg etc.
bmp | The pointer to a BITMAP object.
Returns:
TRUE on success, FALSE on error.

BOOL GUIAPI RegisterResFromFile | ( | HDC | hdc,
 |  | const char * | file
 | ) |  |

Register a device-dependent bitmap from a file.

This function load a device-dependent bitmap from a file and register it to bitmap cache.

Parameters:
hdc | The device context.
file | The name of image file. The suffix indicates image type such as bmp, png, jpg etc.
Returns:
TRUE on success, FALSE on error.

BOOL GUIAPI RegisterResFromMem | ( | HDC | hdc,
 |  | const char * | file,
 |  | const unsigned char * | data,
 |  | size_t | data_size
 | ) |  |

Register a device-dependent bitmap to bitmap cache from memory.

This function load a device-dependent bitmap from memory and register it to bitmap cache.

Parameters:
hdc | The device context.
file | The name of image file. The suffix indicates image type such as bmp, png, jpg etc.
data | The pointer to image data.
data_size | The size of image data.
Returns:
TRUE on success, FALSE on error.

int RegisterResType | ( | int | type,
 |  | RES_TYPE_OPS * | ops
 | ) |  |

Register a new user-defined type into resource manager, so that the LoadResouce can load the special resouce automatically.

Parameters:
type | The user-defined type. It must >=RES_TYPE_USER and <RES_TYPE_USER_MAX
ops | the operations of the resouce.
Returns:
RES_RET_OK for success or error code
See also:
RES_TYPE_OPS, enum emResType, UnregisterResType

BOOL GUIAPI RegisterSystemBitmap | ( | HDC | hdc,
 |  | const char * | rdr_name,
 |  | const char * | id
 | ) |  |

Register a device-dependent bitmap from id to BITMAP cache.

This function load a device-dependent bitmap from id and register it to BITMAP cache.

Parameters:
hdc | The device context.
rdr_name | The name of window element renderer. NULL for default renderer.
id | The id of system image.
Returns:
TRUE on success, FALSE on error.

int ReleaseRes ( RES_KEY key )

Release the buffered resouce. It will decrease the reference count of the resouce. If the reference count is less then 0, the resource will be released.

Parameters:
key The key of the resouce (use Str2Key(res_name) to get the key).
Returns:
The reference count; -1 if the resouce does not exist.
See also:
LoadResouce, GetResouce, AddResRef, Str2Key

MG_EXPORT const BITMAP * RetrieveRes ( const char * file )

Get a BITMAP object from cache according to the specified resource file name.

This function gets a BITMAP object from cache according to the specified resource file name file.

Parameters:
file The specified file name.
Returns:
a BITMAP object for success, NULL for error.

int SetResPath ( const char * path )

Set user's resouce path into the search paths of resouce manager.

If you set this value, resouce mamanger will try to find a resource in the path.

Parameters:
path The path which store the resouces. It can be an absolute path or relative path.
Returns:
RES_RET_OK for success or error code.

RES_KEY Str2Key ( const char * str )

Translate a string to an unsigned long (RES_KEY), which is used to find a resouce in the resource manager.

Parameters:
str The name of resouce. Normaly, it's a path and filename of the resouce.
Returns:
The key.
See also:
GetResouce, AddResRef, ReleaseRes

void UnregisterRes ( const char * file )

Unregister the BITMAP object from cache according to the specified resource file name.

This function unregister the BITMAP object from cache according to the specified resource file name file and the BITMAP bmp.

Parameters:
file The specified file name.
Returns:
None.

int UnregisterResType ( int type )

Unregister a user-defined resource type.

Parameters:
type The user-defined type registered by calling RegisterResType.
Returns:
RES_RET_OK or error code
See also:
RegisterResType

void GUIAPI UnregisterSystemBitmap | ( | HDC | hdc,
 |  | const char * | rdr_name,
 |  | const char * | id
 | ) |  |

Unregister a BITMAP object from BITMAP cache.

This function unregister a BITMAP object from BITMAP cache.

Parameters:
hdc | The device context.
rdr_name | The name of window element renderer. NULL for default renderer.
id | The id of system image.

Generated on Fri Dec 17 13:49:50 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: General window operations

General window operations
[Window creating/destroying]

Defines

  • #define SetFocus SetFocusChild
  • #define GetFocus GetFocusChild
  • #define GetForegroundWindow GetActiveWindow
  • #define SetForegroundWindow SetActiveWindow
  • #define GetWindowElementColor(iItem) GetWindowElementPixelEx(HWND_NULL, -1, iItem)
    Get window element color.

Functions

  • MG_EXPORT void GUIAPI UpdateWindow (HWND hWnd, BOOL bErase)
    Updates a window.
  • MG_EXPORT BOOL GUIAPI ShowWindow (HWND hWnd, int iCmdShow)
    Shows or hides a window.
  • MG_EXPORT BOOL GUIAPI EnableWindow (HWND hWnd, BOOL fEnable)
    Enables of disables a window.
  • MG_EXPORT BOOL GUIAPI IsWindowEnabled (HWND hWnd)
    Determines whether the specified window is enabled for mouse and keyboard input.
  • MG_EXPORT BOOL GUIAPI GetClientRect (HWND hWnd, PRECT prc)
    Retrives the client rectangle of a window.
  • MG_EXPORT int GUIAPI GetWindowBkColor (HWND hWnd)
    Returns the current background color of a window.
  • MG_EXPORT int GUIAPI SetWindowBkColor (HWND hWnd, int new_bkcolor)
    Sets the background color of a window.
  • MG_EXPORT PLOGFONT GUIAPI GetWindowFont (HWND hWnd)
    Retrives the default font of a window.
  • MG_EXPORT PLOGFONT GUIAPI SetWindowFont (HWND hWnd, PLOGFONT pLogFont)
    Sets the default font of a window.
  • MG_EXPORT HCURSOR GUIAPI GetWindowCursor (HWND hWnd)
    Retrives the current cursor of a window.
  • MG_EXPORT HCURSOR GUIAPI SetWindowCursor (HWND hWnd, HCURSOR hNewCursor)
    Sets the current cursor of a window.
  • MG_EXPORT HICON GUIAPI GetWindowIcon (HWND hWnd)
    Retrives the current icon of a window.
  • MG_EXPORT HICON GUIAPI SetWindowIcon (HWND hWnd, HICON hIcon, BOOL bRedraw)
    Sets the current icon of a window.
  • MG_EXPORT DWORD GUIAPI GetWindowStyle (HWND hWnd)
    Retrives the style of a window.
  • MG_EXPORT DWORD GUIAPI GetWindowExStyle (HWND hWnd)
    Retrives the extended style of a window.
  • MG_EXPORT BOOL GUIAPI ExcludeWindowStyle (HWND hWnd, DWORD dwStyle)
    Removes the specific style of a window.
  • MG_EXPORT BOOL GUIAPI IncludeWindowStyle (HWND hWnd, DWORD dwStyle)
    Includes the specific style of a window.
  • MG_EXPORT BOOL GUIAPI ExcludeWindowExStyle (HWND hWnd, DWORD dwStyle)
    Removes the specific extended style of a window.
  • MG_EXPORT BOOL GUIAPI IncludeWindowExStyle (HWND hWnd, DWORD dwStyle)
    Includes the specific extended style of a window.
  • MG_EXPORT WNDPROC GUIAPI GetWindowCallbackProc (HWND hWnd)
    Retrives the callback procedure of a window.
  • MG_EXPORT WNDPROC GUIAPI SetWindowCallbackProc (HWND hWnd, WNDPROC newProc)
    Sets the callback procedure of a window.
  • MG_EXPORT DWORD GUIAPI GetWindowAdditionalData (HWND hWnd)
    Retrives the first additional data of a window.
  • MG_EXPORT DWORD GUIAPI SetWindowAdditionalData (HWND hWnd, DWORD newData)
    Sets the first additional data of a window.
  • MG_EXPORT DWORD GUIAPI GetWindowAdditionalData2 (HWND hWnd)
    Retrives the second additional data of a window.
  • MG_EXPORT DWORD GUIAPI SetWindowAdditionalData2 (HWND hWnd, DWORD newData)
    Sets the second additional data of a window.
  • MG_EXPORT DWORD GUIAPI GetWindowClassAdditionalData (HWND hWnd)
    Retrives the additional data of a control class.
  • MG_EXPORT DWORD GUIAPI SetWindowClassAdditionalData (HWND hWnd, DWORD newData)
    Sets the additional data of a control class.
  • MG_EXPORT const char *GUIAPI GetWindowCaption (HWND hWnd)
    Retrives the caption of a window.
  • MG_EXPORT BOOL GUIAPI SetWindowCaption (HWND hWnd, const char *spCaption)
    Sets the caption of a window.
  • MG_EXPORT BOOL GUIAPI InvalidateRect (HWND hWnd, const RECT *prc, BOOL bEraseBkgnd)
    Makes a rectangle region in the client area of a window invalid.
  • MG_EXPORT HDC GUIAPI BeginPaint (HWND hWnd)
    Prepares a window for painting.
  • MG_EXPORT void GUIAPI EndPaint (HWND hWnd, HDC hdc)
    Marks the end of painting in a window.
  • MG_EXPORT BOOL GUIAPI GetUpdateRect (HWND hWnd, RECT *update_rect)
    Retrives the bounding box of the update region of a window.
  • MG_EXPORT int GUIAPI ClientWidthToWindowWidthEx (DWORD dwStyle, int win_type, int cw)
    Calculates main window width from the width of the client area.
  • MG_EXPORT int GUIAPI ClientHeightToWindowHeightEx (DWORD dwStyle, int win_type, int ch, BOOL hasMenu)
    Calculates window height from the height of the client area.
  • MG_EXPORT void GUIAPI ClientToScreen (HWND hWnd, int *x, int *y)
    Converts the client coordinates of a point to screen coordinates.
  • MG_EXPORT void GUIAPI ScreenToClient (HWND hWnd, int *x, int *y)
    Converts the screen coordinates of a point to client coordinates.
  • MG_EXPORT void GUIAPI ClientToWindow (HWND hWnd, int *x, int *y)
    Converts the client coordinates to the window coordinates.
  • MG_EXPORT void GUIAPI WindowToClient (HWND hWnd, int *x, int *y)
    Converts the window coordinates to client coordinates.
  • MG_EXPORT void GUIAPI WindowToScreen (HWND hWnd, int *x, int *y)
    Converts the window coordinates of a point to screen coordinates.
  • MG_EXPORT void GUIAPI ScreenToWindow (HWND hWnd, int *x, int *y)
    Converts the screen coordinates of a point to window coordinates.
  • MG_EXPORT BOOL GUIAPI IsMainWindow (HWND hWnd)
    Determines whether a window is a main window.
  • MG_EXPORT BOOL GUIAPI IsControl (HWND hWnd)
    Determines whether a window is a control.
  • MG_EXPORT BOOL GUIAPI IsWindow (HWND hWnd)
    Determines whether a window handle identifies an existing window.
  • MG_EXPORT BOOL GUIAPI IsDialog (HWND hWnd)
    Determines whether a window handle identifies a dialog window.
  • MG_EXPORT HWND GUIAPI GetParent (HWND hWnd)
    Retrieves the handle to a child window's parent window.
  • MG_EXPORT HWND GUIAPI GetMainWindowHandle (HWND hWnd)
    Retrives the handle to the main window contains a window.
  • MG_EXPORT BOOL GUIAPI IsWindowVisible (HWND hWnd)
    Retrieves the visibility state of the specified window.
  • MG_EXPORT BOOL GUIAPI GetWindowRect (HWND hWnd, PRECT prc)
    Retrives the dimensions of the bounding rectangle of a window.
  • MG_EXPORT HWND GUIAPI GetNextChild (HWND hWnd, HWND hChild)
    Retrives the next control in a window.
  • MG_EXPORT HWND GUIAPI GetNextMainWindow (HWND hMainWnd)
    Retrives the next main window in the system according to the zorder.
  • MG_EXPORT HWND GUIAPI GetHosting (HWND hMainWnd)
    Retrives the hosting main window of a main window.
  • MG_EXPORT HWND GUIAPI GetFirstHosted (HWND hHosting)
    Retrives the first hosted main window of a main window.
  • MG_EXPORT HWND GUIAPI GetNextHosted (HWND hHosting, HWND hHosted)
    Retrives the next hosted main window of a main window.
  • MG_EXPORT int GUIAPI GetWindowTextLength (HWND hWnd)
    Retrieves the length of a window's text.
  • MG_EXPORT int GUIAPI GetWindowText (HWND hWnd, char *spString, int nMaxLen)
    Copies the text of a window's into a buffer.
  • MG_EXPORT BOOL GUIAPI SetWindowText (HWND hWnd, const char *spString)
    Sets the text of a window.
  • MG_EXPORT HWND GUIAPI GetFocusChild (HWND hParent)
    Retrieves the handle to the window's active child that has the keyboard focus.
  • MG_EXPORT HWND GUIAPI SetNullFocus (HWND hParent)
    Cancels the current active child and set the focus child to be null.
  • MG_EXPORT HWND GUIAPI SetFocusChild (HWND hWnd)
    Sets the active child of a window.
  • MG_EXPORT HWND GUIAPI GetActiveWindow (void)
    Retrieves the main window handle to the active main window.
  • MG_EXPORT HWND GUIAPI SetActiveWindow (HWND hMainWnd)
    Sets a main window to be the active main window.
  • MG_EXPORT HWND GUIAPI GetCapture (void)
    Retrives the handle to the window (if any) that has captured the mouse.
  • MG_EXPORT HWND GUIAPI SetCapture (HWND hWnd)
    Sets the mouse capture to the specified window.
  • MG_EXPORT void GUIAPI ReleaseCapture (void)
    Releases the mouse capture from a window and restores normal mouse input processing.
  • MG_EXPORT HWND GUIAPI GetWindowUnderCursor (void)
    Retrives the handle to the window (if any) which is just beneath the mouse cursor.
  • MG_EXPORT BOOL GUIAPI MoveWindow (HWND hWnd, int x, int y, int w, int h, BOOL fPaint)
    Changes the position and dimensions of a window.
  • MG_EXPORT void GUIAPI ScrollWindow (HWND hWnd, int iOffx, int iOffy, const RECT *rc1, const RECT *rc2)
    Scrolls the content of a window's client area.

Define Documentation

#define GetFocus GetFocusChild

See also:
GetFocusChild

Definition at line 6220 of file window.h.

#define GetForegroundWindow GetActiveWindow

See also:
GetActiveWindow

Definition at line 6254 of file window.h.

#define GetWindowElementColor ( iItem ) GetWindowElementPixelEx(HWND_NULL, -1, iItem)

Get window element color.

Definition at line 6373 of file window.h.

#define SetFocus SetFocusChild

See also:
SetFocusChild

Definition at line 6214 of file window.h.

#define SetForegroundWindow SetActiveWindow

See also:
SetActiveWindow

Definition at line 6260 of file window.h.

Function Documentation

HDC GUIAPI BeginPaint ( HWND hWnd )

Prepares a window for painting.

This function prepares the specified window hWnd for painting. This function is called in the handler of MSG_PAINT message normally. It returns a device context including the update region of the window. When you are done with the device context, you should call EndPaint to finish the painting of the window.

Parameters:
hWnd The handle to the window.
Returns:
The device context.
See also:
EndPaint

int GUIAPI ClientHeightToWindowHeightEx | ( | DWORD | dwStyle,
 |  | int | win_type,
 |  | int | ch,
 |  | BOOL | hasMenu
 | ) |  |

Calculates window height from the height of the client area.

This function calculates the main window height from the height of the client area.

Parameters:
dwStyle | The style of window.
win_type | The type of window.
ch | The height of the client area.
hasMenu | Indicates whether the main window has menu.
Returns:
The height of the main window.
See also:
ClientWidthToWindowWidthEx

void GUIAPI ClientToScreen | ( | HWND | hWnd,
 |  | int * | x,
 |  | int * | y
 | ) |  |

Converts the client coordinates of a point to screen coordinates.

This function converts the client coordinates of the specified point (*x,*y) in the specified window hWnd to screen coordinates.

Parameters:
hWnd | The handle to the window.
x | The pointer to the x coordinate.
y | The pointer to the y coordinate.
See also:
ScreenToClient

void GUIAPI ClientToWindow | ( | HWND | hWnd,
 |  | int * | x,
 |  | int * | y
 | ) |  |

Converts the client coordinates to the window coordinates.

This function converts the client coordinates of the specified point (*x,*y) in the specified window hWnd to the window coordinates.

Parameters:
hWnd | The handle to the window.
x | The pointer to the x coordinate.
y | The pointer to the y coordinate.
See also:
WindowToClient

int GUIAPI ClientWidthToWindowWidthEx | ( | DWORD | dwStyle,
 |  | int | win_type,
 |  | int | cw
 | ) |  |

Calculates main window width from the width of the client area.

This function calculates the window width from the width of the client area.

Parameters:
dwStyle | The style of window.
win_type | The type of window.
cw | The width of the client area.
Returns:
The width of the main window.
See also:
ClientHeightToWindowHeightEx

BOOL GUIAPI EnableWindow | ( | HWND | hWnd,
 |  | BOOL | fEnable
 | ) |  |

Enables of disables a window.

This function enables or disables mouse and keyboard input to the specified window hWnd. When input is disabled, the window does not receive input such as mouse clicks and key presses. When input is enabled, the window receives all input.

Parameters:
hWnd | The handle to the window.
fEnable | Indicates whether to enable or disable the window, TRUE for enable.
Returns:
The old enable state of the window.
See also:
IsWindowEnabled

void GUIAPI EndPaint | ( | HWND | hWnd,
 |  | HDC | hdc
 | ) |  |

Marks the end of painting in a window.

This function marks the end of painting in the specified window. This function is required for each call to the BeginPaint function, but only after painting is complete.

Parameters:
hWnd | The handle to the window.
hdc | The device context returned by BeginPaint.
See also:
BeginPaint

BOOL GUIAPI ExcludeWindowExStyle | ( | HWND | hWnd,
 |  | DWORD | dwStyle
 | ) |  |

Removes the specific extended style of a window.

This function removes the specific extended style of the window specified by hWnd.

Parameters:
hWnd | The handle to the window.
dwStyle | The specific extended style which will be removed.
Returns:
TRUE on success, otherwise FALSE.
See also:
ExcludeWindowStyle

BOOL GUIAPI ExcludeWindowStyle | ( | HWND | hWnd,
 |  | DWORD | dwStyle
 | ) |  |

Removes the specific style of a window.

This function removes the specific style of the window specified by hWnd.

Parameters:
hWnd | The handle to the window.
dwStyle | The specific style which will be removed.
Returns:
TRUE on success, otherwise FALSE.
See also:
ExcludeWindowStyle

HWND GUIAPI GetActiveWindow ( void )

Retrieves the main window handle to the active main window.

This function retrives the main window handle to the active main window which receives the input.

Returns:
The handle to the active main window.
See also:
SetActiveWindow, GetFocusChild

HWND GUIAPI GetCapture ( void )

Retrives the handle to the window (if any) that has captured the mouse.

This function retrieves the handle to the window (if any) that has captured the mouse. Only one window at a time can capture the mouse; this window receives mouse input whether or not the cursor is within its borders.

Returns:
The handle to the window that has captured the mouse, 0 for no window captures the mouse.
See also:
SetCapture

BOOL GUIAPI GetClientRect | ( | HWND | hWnd,
 |  | PRECT | prc
 | ) |  |

Retrives the client rectangle of a window.

This function retrives the coordinates of the client area of the window specified by hWnd. The client coordinates specify the upper-left and lower-right corners of the client area. Because client coordinates are relative to the upper-left corner of a window's client area, the coordinates of the upper-left corner are always (0,0).

Parameters:
hWnd | The handle to the window.
prc | The pointer to a RECT structure receives the client rectangle.
Returns:
TRUE on sucess, otherwise FALSE.
Note:
Note that the coordinates of the upper-left corner are always zero.
See also:
MoveWindow

HWND GUIAPI GetFirstHosted ( HWND hHosting )

Retrives the first hosted main window of a main window.

This function retrives the first hosted main window of the specified main window hMainWnd.

For MiniGUI-Threads, HWND_DESKTOP has no any "hosted" window, so do not use this function for it.

Parameters:
hHosting The handle to the hosting main window.
Returns:
The handle to the first hosted main window. If an invalid window handle is passed for hHosting, HWND_INVALID will be returned. If tihs main window do not have a hosted window, HWND_NULL will be returned.
See also:
GetHosting, GetNextHosted

HWND GUIAPI GetFocusChild ( HWND hParent )

Retrieves the handle to the window's active child that has the keyboard focus.

This function retrives the handle to the window's active child that has the keyboard focus.

Parameters:
hParent The handle to the parent window.
Returns:
The handle to the active child.
See also:
SetFocusChild, SetNullFoucs

HWND GUIAPI GetHosting ( HWND hMainWnd )

Retrives the hosting main window of a main window.

This function retrives the hosting main window of the specified main window hWnd. The hosting main window creates the message queue, which shared with all hosted main window of it. The hosting window of a top-level main window is HWND_DESKTOP.

HWND_DESKTOP has no hosting window, do not use this function for it.

Parameters:
hMainWnd The handle to the main window.
Returns:
The handle to the hosting main window. A valid window must have a hosting window. If error occurs, such as a invalid handle or HWND_DESKTOP is passed as hMainWnd, HWND_INVALID is returned.
See also:
GetFirstHosted, GetNextHosted

HWND GUIAPI GetMainWindowHandle ( HWND hWnd )

Retrives the handle to the main window contains a window.

This function retrives the handle to the main window which contains the specified window hWnd.

Parameters:
hWnd The handle to the window.
Returns:
The handle to the main window, HWND_INVALID indicates an error.
Note:
For a main window, this function always returns the handle to itself. For HWND_DESKTOP, HWND_DESKTOP is returned.
See also:
GetParent

HWND GUIAPI GetNextChild | ( | HWND | hWnd,
 |  | HWND | hChild
 | ) |  |

Retrives the next control in a window.

This function retrives the next child of the specified window hWnd. If you pass HWND_NULL for the argument of hChild, the function will return the first child of the window.

Parameters:
hWnd | The handle to the window.
hChild | The handle to a child of the window.
Returns:
The handle of the next child. If you pass HWND_NULL for the argument of hChild, it will return the first child of the window. When the child you passed is the last one, this function will return HWND_NULL. If hWnd is not the parent of hChild, this function will return HWND_INVALID.
See also:
GetNextMainWindow
Note:
Do not use HWND_DESKTOP for hWnd or hChild.
Example:

/*
 * Sample code for GetNextChild:
 * Travles all child of a window \a hWnd.
 */

HWND child = HWND_DESKTOP;

do {
    child = GetNextChild (hWnd, child);
} while (child != HWND_DESKTOP);

HWND GUIAPI GetNextHosted | ( | HWND | hHosting,
 |  | HWND | hHosted
 | ) |  |

Retrives the next hosted main window of a main window.

This function retrives the next hosted main window of the specified main window hHosting.

For MiniGUI-Threads, HWND_DESKTOP has no any "hosted" window, so do not use this function for it.

Parameters:
hHosting | The handle to the hosting main window.
hHosted | The handle to a known hosted main window. This function will return the next hosted main window.
Returns:
Handle to the next hosted main window. Returns 0 when hHosted is the last hosted main window; HWND_INVALID when error occurs. If hHosted is 0, this call equals GetFirstHosted(hHosting). If an invalid window handle is passed as hHosting or hHosted, HWND_INVALID will be returned; If hHosted is not the hosted window of hHosting, HWND_INVALID will be returned.
See also:
GetFirstHosted

HWND GUIAPI GetNextMainWindow ( HWND hMainWnd )

Retrives the next main window in the system according to the zorder.

This function retrives the next main window of the specified main window hMainWnd.

Parameters:
hMainWnd The handle to the main window.
Returns:
The handle of the next main window. If you pass HWND_NULL for the argument of hMainWnd, it will return the topmost main window. When the main window you passed is the bottommost one, this function will return HWND_NULL. If hMainWnd is not a main window, the function will return HWND_INVALID.
See also:
GetNextChild

HWND GUIAPI GetParent ( HWND hWnd )

Retrieves the handle to a child window's parent window.

This function retrieves the handle to the specified child window's parent window.

Parameters:
hWnd The handle to the child window.
Returns:
The handle to the parent, HWND_INVALID indicates an error.
Note:
For a main window, this function always returns 0. For HWND_DESKTOP or an invalid window handle, HWND_INVALID will be returned.
See also:
GetMainWindowHandle

BOOL GUIAPI GetUpdateRect | ( | HWND | hWnd,
 |  | RECT * | update_rect
 | ) |  |

Retrives the bounding box of the update region of a window.

This function retrives the bounding box of the update region of the specified window hWnd.

Parameters:
hWnd | The handle to the window.
update_rect | The pointer to a RECT structure which will contains the bounding box of the update region.
Returns:
TRUE on success, otherwise FALSE.
See also:
InvalidateRect

DWORD GUIAPI GetWindowAdditionalData ( HWND hWnd )

Retrives the first additional data of a window.

This function retrives the first additional data of the specified window hWnd.

Parameters:
hWnd The handle to the window.
Returns:
The first additional data of the window.
See also:
SetWindowAdditionalData

DWORD GUIAPI GetWindowAdditionalData2 ( HWND hWnd )

Retrives the second additional data of a window.

This function retrives the second additional data of the specified window hWnd.

Parameters:
hWnd The handle to the window.
Returns:
The second additional data of the window.
See also:
SetWindowAdditionalData2

int GUIAPI GetWindowBkColor ( HWND hWnd )

Returns the current background color of a window.

This function returns the pixel value of the current background color of the window specified by hWnd.

Parameters:
hWnd The handle to the window.
Returns:
The pixel value of the background color.
See also:
SetWindowBkColor

WNDPROC GUIAPI GetWindowCallbackProc ( HWND hWnd )

Retrives the callback procedure of a window.

This function retrives the window callback procedure of the specified window hWnd.

Parameters:
hWnd The handle to the window.
Returns:
The callback procedure of the window.
See also:
SetWindowCallbackProc

const char *GUIAPI GetWindowCaption ( HWND hWnd )

Retrives the caption of a window.

This function retrives the caption of the specified window hWnd.

Parameters:
hWnd The handle to the window.
Returns:
The pointer to the caption string of the window.
See also:
SetWindowCaption

DWORD GUIAPI GetWindowClassAdditionalData ( HWND hWnd )

Retrives the additional data of a control class.

This function retrives the additional data of the control class to which the specified control hWnd belongs.

Parameters:
hWnd The handle to the control.
Returns:
The additional data of the control class to which the control belongs.
Note:
Note that this function always returns zero for the main window.
See also:
SetWindowClassAdditionalData

HCURSOR GUIAPI GetWindowCursor ( HWND hWnd )

Retrives the current cursor of a window.

This function retrives the current cursor of the specified window hWnd.

Parameters:
hWnd The handle to the window.
Returns:
The handle to the cursor.
See also:
SetWindowCursor

DWORD GUIAPI GetWindowExStyle ( HWND hWnd )

Retrives the extended style of a window.

This function retrives the extended style of the window specified by hWnd.

Parameters:
hWnd The handle to the window.
Returns:
The extended style of the window.
See also:
GetWindowStyle

PLOGFONT GUIAPI GetWindowFont ( HWND hWnd )

Retrives the default font of a window.

This function retrives the default font of the specified window hWnd.

Parameters:
hWnd The handle to the window.
Returns:
The default logical font of the window.
See also:
SetWindowFont

HICON GUIAPI GetWindowIcon ( HWND hWnd )

Retrives the current icon of a window.

This function retrives the current icon of the specified window hWnd.

Parameters:
hWnd The handle to the window.
Returns:
The handle to the icon.
See also:
SetWindowIcon

BOOL GUIAPI GetWindowRect | ( | HWND | hWnd,
 |  | PRECT | prc
 | ) |  |

Retrives the dimensions of the bounding rectangle of a window.

This function retrives the dimension of the bounding rectangle of the specified window hWnd. The dimensions are given in parent's client coordinates (screen coordinates for main window) that are relative to the upper-left corner of the parent's client area (screen).

Parameters:
hWnd | The handle to the window.
prc | The pointer to a RECT structure which will contains the window rectangle.
Returns:
TRUE on success, otherwise FALSE.
See also:
GetClientRect

DWORD GUIAPI GetWindowStyle ( HWND hWnd )

Retrives the style of a window.

This function retrives the style of the window specified by hWnd.

Parameters:
hWnd The handle to the window.
Returns:
The style of the window.
See also:
GetWindowExStyle

int GUIAPI GetWindowText | ( | HWND | hWnd,
 |  | char * | spString,
 |  | int | nMaxLen
 | ) |  |

Copies the text of a window's into a buffer.

This function copies the text of the specified window hWnd into the buffer pointed to by spString. The function gets the window text by sending an MSG_GETTEXT message to the window.

Parameters:
hWnd | The handle to the window.
spString | The pointer to a buffer receives the text.
nMaxLen | The maximal number of characters can be copied to the buffer.
Returns:
The length of the window text string.
See also:
GetWindowCaption, SetWindowText

int GUIAPI GetWindowTextLength ( HWND hWnd )

Retrieves the length of a window's text.

This function retrieves the length, in characters, of the specified window's text. The function retrieves the length of the text by sending an MSG_GETTEXTLENGTH message to the window.

Parameters:
hWnd The handle to the window.
Returns:
The length of the window's text.
See also:
GetWindowText

HWND GUIAPI GetWindowUnderCursor ( void )

Retrives the handle to the window (if any) which is just beneath the mouse cursor.

This function retrieves the handle to the window (if any) that is under the mouse cursor. If a parent window and a child window are all under the mouse cursor, the handle to the child window will be returned.

Returns:
The handle to the window under the mouse cursor, HWND_NULL for no window is under the mouse cursor.

BOOL GUIAPI IncludeWindowExStyle | ( | HWND | hWnd,
 |  | DWORD | dwStyle
 | ) |  |

Includes the specific extended style of a window.

This function includes the specific extended style of the window specified by hWnd.

Parameters:
hWnd | The handle to the window.
dwStyle | The specific extended style which will be included.
Returns:
TRUE on success, otherwise FALSE.
See also:
IncludeWindowStyle

BOOL GUIAPI IncludeWindowStyle | ( | HWND | hWnd,
 |  | DWORD | dwStyle
 | ) |  |

Includes the specific style of a window.

This function includes the specific style of the window specified by hWnd.

Parameters:
hWnd | The handle to the window.
dwStyle | The specific style which will be included.
Returns:
TRUE on success, otherwise FALSE.
See also:
IncludeWindowStyle

BOOL GUIAPI InvalidateRect | ( | HWND | hWnd,
 |  | const RECT * | prc,
 |  | BOOL | bEraseBkgnd
 | ) |  |

Makes a rectangle region in the client area of a window invalid.

This function adds a rectangle pointed to by prc to the specified window's update region. The update region represents the portion of the window's client area that must be redrawn, and erase background if argument bReaseBkgnd is set.

Parameters:
hWnd | The handle to the window.
prc | The pointer to a RECT structure which defines the invalid rectangle.
bEraseBkgnd | Indicates whether the background should be erased.
Returns:
TRUE on success, otherwise FALSE.
See also:
MSG_PAINT

BOOL GUIAPI IsControl ( HWND hWnd )

Determines whether a window is a control.

This function determines whether the specified window hWnd is a control.

Parameters:
hWnd The handle to the window.
Returns:
TRUE for control, otherwise FALSE.
See also:
IsMainWindow, IsWindow

BOOL GUIAPI IsDialog ( HWND hWnd )

Determines whether a window handle identifies a dialog window.

This function determines whether the specified window handle hWnd identifies a dialog window.

Parameters:
hWnd The window handle.
Returns:
TRUE for dialog window, otherwise FALSE.
See also:
IsMainWindow, IsControl

BOOL GUIAPI IsMainWindow ( HWND hWnd )

Determines whether a window is a main window.

This function determines whether the specified window hWnd is a main window or not.

Parameters:
hWnd The handle to the window.
Returns:
TRUE for main window, otherwise FALSE.
See also:
IsControl, IsWindow

BOOL GUIAPI IsWindow ( HWND hWnd )

Determines whether a window handle identifies an existing window.

This function determines whether the specified window handle hWnd identifies an existing window.

Parameters:
hWnd The window handle.
Returns:
TRUE for window, otherwise FALSE.
See also:
IsMainWindow, IsControl

BOOL GUIAPI IsWindowEnabled ( HWND hWnd )

Determines whether the specified window is enabled for mouse and keyboard input.

This function returns the enable/disable state of the window specified by hWnd.

Parameters:
hWnd The handle to the window.
Returns:
The enable/disable state of the window, TRUE for enabled.
See also:
EnableWindow

BOOL GUIAPI IsWindowVisible ( HWND hWnd )

Retrieves the visibility state of the specified window.

This function retrives the visibility state of the specified window hWnd.

Parameters:
hWnd Handle to the window to test.
Returns:
If the specified window, its parent window, its parent's parent window, and so forth, all have the WS_VISIBLE style, the return value is nonzero. Otherwise the return value is zero.
See also:
ShowWindow

BOOL GUIAPI MoveWindow | ( | HWND | hWnd,
 |  | int | x,
 |  | int | y,
 |  | int | w,
 |  | int | h,
 |  | BOOL | fPaint
 | ) |  |

Changes the position and dimensions of a window.

This function changes the position and dimensions of the specified window hWnd. For a main window, the position and dimensions are relative to the upper-left corner of the screen. For a control, they are relative to the upper-left corner of the parent window's client area.

Parameters:
hWnd | The handle to the window.
x | The new x coordinate of the upper-left corner of the window.
y | The new y coordinate of the upper-left corner of the window.
w | The new width of the window.
h | The new height of the window.
fPaint | Indicates whether the window should be repainted.
Returns:
TRUE on success, otherwise FALSE.
See also:
ScrollWindow

void GUIAPI ReleaseCapture ( void )

Releases the mouse capture from a window and restores normal mouse input processing.

This function releases the mouse capture from a window and restores normal mouse input processing. A window that has captured the mouse receives all mouse input, regardless of the position of the cursor.

See also:
GetCapture, SetCapture

void GUIAPI ScreenToClient | ( | HWND | hWnd,
 |  | int * | x,
 |  | int * | y
 | ) |  |

Converts the screen coordinates of a point to client coordinates.

This function converts the screen coordinates of the specified point (*x,*y) to client coordinates of the specified window hWnd.

Parameters:
hWnd | The handle to the window.
x | The pointer to the x coordinate.
y | The pointer to the y coordinate.
See also:
ClientToScreen

void GUIAPI ScreenToWindow | ( | HWND | hWnd,
 |  | int * | x,
 |  | int * | y
 | ) |  |

Converts the screen coordinates of a point to window coordinates.

This function converts the screen coordinates of the specified point (*x,*y) to the window coordinates of the specfied window hWnd.

Parameters:
hWnd | The handle to the window.
x | The pointer to the x coordinate.
y | The pointer to the y coordinate.
See also:
WindowToScreen

void GUIAPI ScrollWindow | ( | HWND | hWnd,
 |  | int | iOffx,
 |  | int | iOffy,
 |  | const RECT * | rc1,
 |  | const RECT * | rc2
 | ) |  |

Scrolls the content of a window's client area.

This function scrolls the content of the specified window's client area.

Parameters:
hWnd | The handle to the window.
iOffx | The new x coordinate of the origin in the client coordinates system after scrolling.
iOffy | The new y coordinate of the origin in the client coordinates system after scrolling.
rc1 | The rectangle of the area which will be scrolled actually. NULL for whole client area.
rc2 | A rectangle, all children covered totally by this rectangle will be moved after scrolling. All of the children will be moved if rc2 is NULL.
See also:
MoveWindow

HWND GUIAPI SetActiveWindow ( HWND hMainWnd )

Sets a main window to be the active main window.

This function sets the specified main window hMainWnd to be the active main window which receives the input.

Parameters:
hMainWnd The handle to the new active main window.
Returns:
The handle to the old active main window.
See also:
GetActiveWindow, SetFocusChild

HWND GUIAPI SetCapture ( HWND hWnd )

Sets the mouse capture to the specified window.

This function sets the mouse capture to the specified window hWnd. Once a window has captured the mouse, all mouse input is directed to that window, regardless of whether the cursor is within the borders of that window. Only one window at a time can capture the mouse.

Parameters:
hWnd The handle to the window.
Returns:
The old capture window.
See also:
GetCapture

HWND GUIAPI SetFocusChild ( HWND hWnd )

Sets the active child of a window.

This function sets the specified window hWnd as the active child of its parent.

Parameters:
hWnd The handle to the window.
Returns:
The handle to the old active child of its parent.
See also:
GetFocusChild, SetNullFocus

HWND GUIAPI SetNullFocus ( HWND hParent )

Cancels the current active child and set the focus child to be null.

This function cancels the current active child and set the focus child of the window hParent to be null.

Parameters:
hParent The handle to the parent window.
Returns:
The handle to the old active child.
See also:
GetFocusChild, SetFocusChild

DWORD GUIAPI SetWindowAdditionalData | ( | HWND | hWnd,
 |  | DWORD | newData
 | ) |  |

Sets the first additional data of a window.

This function sets the first additional data of the specified window hWnd.

Parameters:
hWnd | The handle to the window.
newData | The new first additional data of the window.
Returns:
The old first additional data of the window.
Note:
For a dialog box created by DialogBoxIndirectParam, its second additional data used internally by the system to save the return value of the box. So you should avoid setting the second additional data of a dialog box.
See also:
GetWindowAdditionalData

DWORD GUIAPI SetWindowAdditionalData2 | ( | HWND | hWnd,
 |  | DWORD | newData
 | ) |  |

Sets the second additional data of a window.

This function sets the second additional data of the specified window hWnd.

Parameters:
hWnd | The handle to the window.
newData | The new second additional data of the window.
Returns:
The old second additional data of the window.
Note:
For a control created by CreateWindowEx, its second additional data is reserved for internal use. So you should avoid setting the second additional data of a control.
See also:
GetWindowAdditionalData2

int GUIAPI SetWindowBkColor | ( | HWND | hWnd,
 |  | int | new_bkcolor
 | ) |  |

Sets the background color of a window.

This function sets the background color of the specified window hWnd to be new pixel value new_backcolor. You should call UpdateWindow or InvalidateRect in order that the new background color runs into affect.

Parameters:
hWnd | The handle to the window.
new_bkcolor | The pixel value of the new background color.
Returns:
The pixel value of the old background color.
See also:
GetWindowBkColor

WNDPROC GUIAPI SetWindowCallbackProc | ( | HWND | hWnd,
 |  | WNDPROC | newProc
 | ) |  |

Sets the callback procedure of a window.

This function sets the window callback procedure of the specified window hWnd to be the procedure newProc.

Parameters:
hWnd | The handle to the window.
newProc | The new callback procedure of the window.
Returns:
The old callback procedure of the window.
See also:
GetWindowCallbackProc
Example:

/*
 * The following code uses SetWindowCallbackProc function to
 * change the default window callback procedures of some controls.
 */
#define IDC_CTRL1     100
#define IDC_CTRL2     110
#define IDC_CTRL3     120
#define IDC_CTRL4     130

#define MY_ES_DIGIT_ONLY    0x0001
#define MY_ES_ALPHA_ONLY    0x0002
static WNDPROC old_edit_proc;
static int RestrictedEditBox (HWND hwnd, int message, WPARAM wParam, LPARAM lParam)
{
    if (message == MSG_CHAR) {
        DWORD my_style = GetWindowAdditionalData (hwnd);

        /* Determine whether the character should be masked. */
        if ((my_style & MY_ES_DIGIT_ONLY) && (wParam < '0' || wParam > '9'))
            return 0;
        else if (my_style & MY_ES_ALPHA_ONLY)
            if (!((wParam >= 'A' && wParam <= 'Z') || (wParam >= 'a' && wParam <= 'z')))
                /* It is not the desired character, just return. */
                return 0;
    }

    /* Calling old procedure to handle the messages using default handler. */
    return (*old_edit_proc) (hwnd, message, wParam, lParam);
}

static int ControlTestWinProc (HWND hWnd, int message, WPARAM wParam, LPARAM lParam)
{
    switch (message) {
    case MSG_CREATE:
    {
        HWND hWnd1, hWnd2, hWnd3;

        CreateWindow (CTRL_STATIC, "Digit-only box:", WS_CHILD | WS_VISIBLE | SS_RIGHT, 0,
                    10, 10, 180, 24, hWnd, 0);
        hWnd1 = CreateWindow (CTRL_EDIT, "", WS_CHILD | WS_VISIBLE | WS_BORDER, IDC_CTRL1,
                    200, 10, 180, 24, hWnd, MY_ES_DIGIT_ONLY);
        CreateWindow (CTRL_STATIC, "Alpha-only box:", WS_CHILD | WS_VISIBLE | SS_RIGHT, 0,
                    10, 40, 180, 24, hWnd, 0);
        hWnd2 = CreateWindow (CTRL_EDIT, "", WS_CHILD | WS_BORDER | WS_VISIBLE, IDC_CTRL2,
                    200, 40, 180, 24, hWnd, MY_ES_ALPHA_ONLY);
        CreateWindow (CTRL_STATIC, "Normal edit box:", WS_CHILD | WS_VISIBLE | SS_RIGHT, 0,
                    10, 70, 180, 24, hWnd, 0);
        hWnd3 = CreateWindow (CTRL_EDIT, "", WS_CHILD | WS_BORDER | WS_VISIBLE, IDC_CTRL2,
                    200, 70, 180, 24, hWnd, MY_ES_ALPHA_ONLY);

        CreateWindow ("button", "Close", WS_CHILD | BS_PUSHBUTTON | WS_VISIBLE, IDC_CTRL4,
                    100, 100, 60, 24, hWnd, 0);

        /* Set new window procedure and save the old procedure. */
        old_edit_proc = SetWindowCallbackProc (hWnd1, RestrictedEditBox);
        SetWindowCallbackProc (hWnd2, RestrictedEditBox);
        break;
    }

    ......

    }

    return DefaultMainWinProc (hWnd, message, wParam, lParam);
}

BOOL GUIAPI SetWindowCaption | ( | HWND | hWnd,
 |  | const char * | spCaption
 | ) |  |

Sets the caption of a window.

This function sets the caption of the specified window hWnd.

Parameters:
hWnd | The handle to the window.
spCaption | The pointer to the new caption of the window.
Returns:
TRUE on success, otherwise FALSE.
See also:
GetWindowCaption, SetWindowText

DWORD GUIAPI SetWindowClassAdditionalData | ( | HWND | hWnd,
 |  | DWORD | newData
 | ) |  |

Sets the additional data of a control class.

This function sets the additional data of the control class to which the specified control hWnd belongs.

Parameters:
hWnd | The handle to the control.
newData | The new additional data of the control class.
Returns:
The old additional data of the control class.
Note:
This function always does nothing and returns zero for the main window.
See also:
SetWindowClassAdditionalData

HCURSOR GUIAPI SetWindowCursor | ( | HWND | hWnd,
 |  | HCURSOR | hNewCursor
 | ) |  |

Sets the current cursor of a window.

This function sets the current cursor of the specified window hWnd with argument hNewCursor.

Parameters:
hWnd | The handle to the window.
hNewCursor | The handle to the new cursor.
Returns:
The handle to the old cursor.
See also:
GetWindowCursor

PLOGFONT GUIAPI SetWindowFont | ( | HWND | hWnd,
 |  | PLOGFONT | pLogFont
 | ) |  |

Sets the default font of a window.

This function sets the default font of the specified window hWnd to be the logical font pLogFont. This function will send an MSG_FONTCHANGING message to the window. If the handler of the message returns non-zero value, this function will return immediately with the unchanged default font. Or, after the new default font set, this function will send an MSG_FONTCHANGED message to the window as a notification.

Parameters:
hWnd | The handle to the window.
pLogFont | The new default logical font. If it is NULL, this function will set the default font to be the system wchar font.
Returns:
The old default logical font of the window, NULL on error.
See also:
GetWindowFont, GetSystemFont

HICON GUIAPI SetWindowIcon | ( | HWND | hWnd,
 |  | HICON | hIcon,
 |  | BOOL | bRedraw
 | ) |  |

Sets the current icon of a window.

This function sets the current icon of the specified window hWnd with argument hIcon.

Parameters:
hWnd | The handle to the window.
hIcon | The handle to the new icon.
bRedraw | Indicates whether to update the whole window.
Returns:
The handle to the old icon.
Note:
Note that MiniGUI only provides icon support for main window so far.
See also:
GetWindowIcon

BOOL GUIAPI SetWindowText | ( | HWND | hWnd,
 |  | const char * | spString
 | ) |  |

Sets the text of a window.

This function copies the string in the buffer pointed to by spString to be the text of the specified window hWnd. The function sets the window text by sending an MSG_SETTEXT message to the window.

Parameters:
hWnd | The handle to the window.
spString | The pointer to the buffer.
Returns:
TRUE on success, otherwise FALSE.
See also:
SetWindowCaption, GetWindowText

BOOL GUIAPI ShowWindow | ( | HWND | hWnd,
 |  | int | iCmdShow
 | ) |  |

Shows or hides a window.

This function shows or hides the window specified by hWnd.

Parameters:
hWnd The handle to the window.
iCmdShow The command to show or hide, can be one of the following values:
  • SW_SHOW
    Shows the window.
  • SW_HIDE
    Hides the window.
  • SW_SHOWNORMAL
    Shows the window, and if the window is a main window sets it to be the top most main window.
Returns:
TRUE on sucess, otherwise FALSE.

void GUIAPI UpdateWindow | ( | HWND | hWnd,
 |  | BOOL | bErase
 | ) |  |

Updates a window.

This function updates the window specified by hWnd. It will redraw the caption, the frame, and the menu bar of the window. It will invalidate the client area of the window as well, and if bErase is TRUE, the client area will be erased by using background color.

Parameters:
hWnd | The handle to the window.
bErase | Indicates whether to erase the client area of the window.
See also:
InvalidateRect

void GUIAPI WindowToClient | ( | HWND | hWnd,
 |  | int * | x,
 |  | int * | y
 | ) |  |

Converts the window coordinates to client coordinates.

This function converts the window coordinates of the specified point (*x,*y) in the specified window hWnd to the client coordinates.

Parameters:
hWnd | The handle to the window.
x | The pointer to the x coordinate.
y | The pointer to the y coordinate.
See also:
WindowToScreen

void GUIAPI WindowToScreen | ( | HWND | hWnd,
 |  | int * | x,
 |  | int * | y
 | ) |  |

Converts the window coordinates of a point to screen coordinates.

This function converts the window coordinates of the specified point (*x,*y) in the specified window hWnd to the screen coordinates.

Parameters:
hWnd | The handle to the window.
x | The pointer to the x coordinate.
y | The pointer to the y coordinate.
See also:
ScreenToWindow

Generated on Fri Dec 17 13:49:50 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: System bitmap/icon operations

System bitmap/icon operations
[Window creating/destroying]

Defines

  • #define GetLargeSystemIcon(iItem) GetLargeSystemIconEx(HWND_NULL, iItem)
    Retrives a large (32x32) system icon by its identifier in default renderer.
  • #define GetSmallSystemIcon(iItem) GetSmallSystemIconEx(HWND_NULL, iItem)
    Retrives a small (16x16) system icon by its identifier in default renderer.

Functions

  • MG_EXPORT const BITMAP *GUIAPI GetSystemBitmapEx (const char *rdr_name, const char *id)
    Retrives the system bitmap object by identifier.
  • MG_EXPORT const BITMAP *GUIAPI GetSystemBitmapByHwnd (HWND hWnd, const char *id)
    Retrives the system bitmap object by identifier.
  • MG_EXPORT const BITMAP *GUIAPI GetSystemBitmap (HWND hWnd, const char *id)
    Retrives the system bitmap object by identifier.
  • MG_EXPORT void GUIAPI TermSystemBitmapEx (const char *id, const char *rdr_name, PBITMAP bmp)
    Release the system bitmap object by identifier.
  • MG_EXPORT void GUIAPI TermSystemBitmap (HWND hWnd, const char *id, PBITMAP bmp)
    Release the system bitmap object by identifier.
  • MG_EXPORT HICON GUIAPI LoadSystemIconEx (HDC hdc, const char *rdr_name, const char *szItemName, int which)
    Loads an icon from information defined in MiniGUI.cfg.
  • MG_EXPORT HICON GUIAPI LoadSystemIcon (const char *szItemName, int which)
    Uses default renderer and HDC_SCREEN to load an icon from information defined in MiniGUI.cfg.
  • MG_EXPORT HICON GUIAPI GetLargeSystemIconEx (HWND hWnd, int iItem)
    Retrives a large system icon by its identifier in default renderer.
  • MG_EXPORT HICON GUIAPI GetSmallSystemIconEx (HWND hWnd, int iItem)
    Retrives a small system icon by its identifier.

Define Documentation

#define GetLargeSystemIcon ( iItem ) GetLargeSystemIconEx(HWND_NULL, iItem)

Retrives a large (32x32) system icon by its identifier in default renderer.

See also:
GetSmallSystemIconEx

Definition at line 6601 of file window.h.

#define GetSmallSystemIcon ( iItem ) GetSmallSystemIconEx(HWND_NULL, iItem)

Retrives a small (16x16) system icon by its identifier in default renderer.

See also:
GetSmallSystemIconEx

Definition at line 6609 of file window.h.

Function Documentation

HICON GUIAPI GetLargeSystemIconEx | ( | HWND | hWnd,
 |  | int | iItem
 | ) |  |

Retrives a large system icon by its identifier in default renderer.

This function retrives the handle to a large (32x32) system icon by its identifier id.

Parameters:
hWnd The handle to the window.
iItem The identifier of the icon. It can be one of the following values:
  • IDI_APPLICATION
    The application icon.
  • IDI_STOP
    The stop icon.
  • IDI_QUESTION
    The question mark icon.
  • IDI_EXCLAMATION
    The exclamation mark icon.
  • IDI_INFORMATION
    The information mark icon.
Returns:
The handle to the icon.
See also:
GetSystemBitmap

HICON GUIAPI GetSmallSystemIconEx | ( | HWND | hWnd,
 |  | int | iItem
 | ) |  |

Retrives a small system icon by its identifier.

This function retrives the handle to a small (16x16) system icon by its identifier id.

Parameters:
hWnd The handle to the window.
iItem The identifier of the icon. It can be one of the following values:
  • IDI_APPLICATION
    The application icon.
  • IDI_STOP
    The stop icon.
  • IDI_QUESTION
    The question mark icon.
  • IDI_EXCLAMATION
    The exclamation mark icon.
  • IDI_INFORMATION
    The information mark icon.
Returns:
The handle to the icon.
See also:
GetSystemBitmap

PBITMAP GUIAPI GetSystemBitmap | ( | HWND | hWnd,
 |  | const char * | id
 | ) |  |

Retrives the system bitmap object by identifier.

This function returns the system bitmap object by its identifier.

Parameters:
hWnd | The handle to the window.
id | The identifier of the system bitmap object, can be one of the following values:
  • SYSBMP_RADIOBUTTON
  • SYSBMP_CHECKBUTTON
  • SYSBMP_BGPICTURE

Returns:
The pointer to the system bitmap object.
See also:
GetLargeSystemIcon, GetSmallSystemIcon

PBITMAP GUIAPI GetSystemBitmapByHwnd | ( | HWND | hWnd,
 |  | const char * | id
 | ) |  |

Retrives the system bitmap object by identifier.

This function returns the system bitmap object by its identifier.

Parameters:
hWnd | The handle to the window.
id | The identifier of the system bitmap object, can be one of the following values:
  • SYSBMP_RADIOBUTTON
  • SYSBMP_CHECKBUTTON
  • SYSBMP_BGPICTURE

Returns:
The pointer to the system bitmap object.
See also:
GetLargeSystemIcon, GetSmallSystemIcon

MG_EXPORT const BITMAP *GUIAPI GetSystemBitmapEx | ( | const char * | rdr_name,
 |  | const char * | id
 | ) |  |

Retrives the system bitmap object by identifier.

This function returns the system bitmap object by its identifier.

Parameters:
rdr_name | The renderer name.
id | The identifier of the system bitmap object, can be one of the following values:
  • SYSBMP_RADIOBUTTON
  • SYSBMP_CHECKBUTTON
  • SYSBMP_BGPICTURE

Returns:
The pointer to the system bitmap object.
See also:
GetLargeSystemIcon, GetSmallSystemIcon

HICON GUIAPI LoadSystemIcon | ( | const char * | szItemName,
 |  | int | which
 | ) |  |

Uses default renderer and HDC_SCREEN to load an icon from information defined in MiniGUI.cfg.

This function loads an icon from information defined in MiniGUI.cfg.

Parameters:
szItemName | The key name in the section of renderer name in MiniGUI.cfg.
which | Tell the function to load which icon.
Returns:
The handle to the loaded icon.
See also:
LoadSystemBitmap, LoadIconFromFile, DestroyIcon

HICON GUIAPI LoadSystemIconEx | ( | HDC | hdc,
 |  | const char * | rdr_name,
 |  | const char * | szItemName,
 |  | int | which
 | ) |  |

Loads an icon from information defined in MiniGUI.cfg.

This function loads an icon from information defined in MiniGUI.cfg.

Parameters:
hdc | The device context.
rdr_name | The renderer name.
szItemName | The key name in the section of renderer name in MiniGUI.cfg.
which | Tell the function to load which icon. 0 for the small icon, and 1 for large icon.
Returns:
The handle to the loaded icon.
See also:
LoadSystemBitmap, LoadIconFromFile, DestroyIcon

void GUIAPI TermSystemBitmap | ( | HWND | hWnd,
 |  | const char * | id,
 |  | PBITMAP | bmp
 | ) |  |

Release the system bitmap object by identifier.

Parameters:
hWnd | The handle to the window.
id | The identifier of the system bitmap object, can be one of the following values:
  • SYSBMP_RADIOBUTTON
  • SYSBMP_CHECKBUTTON
  • SYSBMP_BGPICTURE

Parameters:
bmp The pointer to the system bitmap object.
Returns:
none.
See also:
GetSystemBitmap

void GUIAPI TermSystemBitmapEx | ( | const char * | id,
 |  | const char * | rdr_name,
 |  | PBITMAP | bmp
 | ) |  |

Release the system bitmap object by identifier.

Parameters:
id The identifier of the system bitmap object, can be one of the following values:
  • SYSBMP_RADIOBUTTON
  • SYSBMP_CHECKBUTTON
  • SYSBMP_BGPICTURE

Parameters:
rdr_name | The renderer name.
bmp | The pointer to the system bitmap object.
Returns:
none.
See also:
GetSystemBitmap

Generated on Fri Dec 17 13:49:50 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Scroll bar operations

Scroll bar operations
[Window creating/destroying]

Data Structures

  • struct _SCROLLINFO

Defines

  • #define SB_ARROW_LTUP 0x0001
  • #define SB_ARROW_BTDN 0x0002
  • #define SB_ARROW_BOTH (SB_ARROW_LTUP | SB_ARROW_BTDN)

Functions

  • MG_EXPORT BOOL GUIAPI EnableScrollBar (HWND hWnd, int iSBar, BOOL bEnable)
    Enables or disables one scroll bar arrows.
  • MG_EXPORT BOOL GUIAPI GetScrollPos (HWND hWnd, int iSBar, int *pPos)
    Retrieves the current position of the scroll box (thumb) in the specified scroll bar.
  • MG_EXPORT BOOL GUIAPI GetScrollRange (HWND hWnd, int iSBar, int *pMinPos, int *pMaxPos)
    Retrives the minimum and maximum position values for the specified scroll bar.
  • MG_EXPORT BOOL GUIAPI SetScrollPos (HWND hWnd, int iSBar, int iNewPos)
    Sets the position of the scroll box (thumb) of the specified scroll bar.
  • MG_EXPORT BOOL GUIAPI SetScrollRange (HWND hWnd, int iSBar, int iMinPos, int iMaxPos)
    Sets the minimum and maximum position values for the specified scroll bar.
  • MG_EXPORT BOOL GUIAPI ShowScrollBar (HWND hWnd, int iSBar, BOOL bShow)
    Shows or hides the specified scroll bar.
  • MG_EXPORT BOOL GUIAPI SetScrollInfo (HWND hWnd, int iSBar, const SCROLLINFO *lpsi, BOOL fRedraw)
    Sets the parameters of a scroll bar.
  • MG_EXPORT BOOL GUIAPI GetScrollInfo (HWND hWnd, int iSBar, PSCROLLINFO lpsi)
    Retrieves the parameters of a scroll bar.

Define Documentation

#define SB_ARROW_BOTH (SB_ARROW_LTUP | SB_ARROW_BTDN)

left,up, right or bottom arrow

Definition at line 6777 of file window.h.

#define SB_ARROW_BTDN 0x0002

right or bottom arrow

Definition at line 6774 of file window.h.

#define SB_ARROW_LTUP 0x0001

left or up arrow

Definition at line 6771 of file window.h.

Function Documentation

BOOL GUIAPI EnableScrollBar | ( | HWND | hWnd,
 |  | int | iSBar,
 |  | BOOL | bEnable
 | ) |  |

Enables or disables one scroll bar arrows.

This function enables or disables one scroll bar arrows.

Parameters:
hWnd | The handle to the window.
iSBar Indicates to enable or disable which scroll bar, can be one of the following values:
  • SB_HORZ
    The horizontal scroll bar.
  • SB_VERT
    The vertical scroll bar.
bEnable | Indicates whether to enable or disable the scroll bar.
Returns:
TRUE on success, FALSE on error.
See also:
ShowScrollBar

BOOL GUIAPI GetScrollInfo | ( | HWND | hWnd,
 |  | int | iSBar,
 |  | PSCROLLINFO | lpsi
 | ) |  |

Retrieves the parameters of a scroll bar.

This function retrieves the parameters of a scroll bar, including the minimum and maximum scrolling positions, the page size, and the position of the scroll box (thumb).

Parameters:
hWnd | The handle to the window.
iSBar Indicates to enable or disable which scroll bar, can be one of the following values:
  • SB_HORZ
    The horizontal scroll bar.
  • SB_VERT
    The vertical scroll bar.
lpsi | The pointer to a structure of SCROLLINFO which receives the parameters.
Returns:
TRUE on success, FALSE on error.
See also:
SetScrollInfo, SCROLLINFO

BOOL GUIAPI GetScrollPos | ( | HWND | hWnd,
 |  | int | iSBar,
 |  | int * | pPos
 | ) |  |

Retrieves the current position of the scroll box (thumb) in the specified scroll bar.

This function retrieves the current position of the scroll box (thumb) in the specified scroll bar. The current position is a relative value that depends on the current scrolling range.

Parameters:
hWnd | The handle to the window.
iSBar Indicates to enable or disable which scroll bar, can be one of the following values:
  • SB_HORZ
    The horizontal scroll bar.
  • SB_VERT
    The vertical scroll bar.
pPos | The pointer to a integer which receives the position value.
Returns:
TRUE on success, FALSE on error.
See also:
SetScrollPos

BOOL GUIAPI GetScrollRange | ( | HWND | hWnd,
 |  | int | iSBar,
 |  | int * | pMinPos,
 |  | int * | pMaxPos
 | ) |  |

Retrives the minimum and maximum position values for the specified scroll bar.

This function retrives the minimum and maximum position values for the specified scroll bar.

Parameters:
hWnd | The handle to the window.
iSBar Indicates to enable or disable which scroll bar, can be one of the following values:
  • SB_HORZ
    The horizontal scroll bar.
  • SB_VERT
    The vertical scroll bar.
pMinPos | The pointer to a integer which receives the minimum position value.
pMaxPos | The pointer to a integer which receives the maximum position value.
Returns:
TRUE on success, FALSE on error.
See also:
SetScrollRange

BOOL GUIAPI SetScrollInfo | ( | HWND | hWnd,
 |  | int | iSBar,
 |  | const SCROLLINFO * | lpsi,
 |  | BOOL | fRedraw
 | ) |  |

Sets the parameters of a scroll bar.

This function sets the parameters of a scroll bar, including the minimum and maximum scrolling positions, the page size, and the position of the scroll box (thumb). The function also redraws the scroll bar, if requested.

Parameters:
hWnd | The handle to the window.
iSBar Indicates to enable or disable which scroll bar, can be one of the following values:
  • SB_HORZ
    The horizontal scroll bar.
  • SB_VERT
    The vertical scroll bar.
lpsi | The pointer to the structure of scroll bar information.
fRedraw | A boolean indicates whether to redraw the scroll bar.
Returns:
TRUE on success, FALSE on error.
See also:
GetScrollInfo, SCROLLINFO

BOOL GUIAPI SetScrollPos | ( | HWND | hWnd,
 |  | int | iSBar,
 |  | int | iNewPos
 | ) |  |

Sets the position of the scroll box (thumb) of the specified scroll bar.

This function sets the position of the scroll box (thumb) of the specified scroll bar, and if needed, redraws the scroll bar to reflect the new position of the scroll box.

Parameters:
hWnd | The handle to the window.
iSBar Indicates to enable or disable which scroll bar, can be one of the following values:
  • SB_HORZ
    The horizontal scroll bar.
  • SB_VERT
    The vertical scroll bar.
iNewPos | The new position value.
Returns:
TRUE on success, FALSE on error.
See also:
GetScrollPos

BOOL GUIAPI SetScrollRange | ( | HWND | hWnd,
 |  | int | iSBar,
 |  | int | iMinPos,
 |  | int | iMaxPos
 | ) |  |

Sets the minimum and maximum position values for the specified scroll bar.

This function sets the minimum and maximum position values for the specified scroll bar, and if needed, redraws the scroll bar to reflect the new position values of the scroll box.

Parameters:
hWnd | The handle to the window.
iSBar Indicates to enable or disable which scroll bar, can be one of the following values:
  • SB_HORZ
    The horizontal scroll bar.
  • SB_VERT
    The vertical scroll bar.
iMinPos | The new minimum position value.
iMaxPos | The new maximum position value.
Returns:
TRUE on success, FALSE on error.
See also:
GetScrollRange

BOOL GUIAPI ShowScrollBar | ( | HWND | hWnd,
 |  | int | iSBar,
 |  | BOOL | bShow
 | ) |  |

Shows or hides the specified scroll bar.

This function shows or hides the specified scroll bar.

Parameters:
hWnd | The handle to the window.
iSBar Indicates to enable or disable which scroll bar, can be one of the following values:
  • SB_HORZ
    The horizontal scroll bar.
  • SB_VERT
    The vertical scroll bar.
bShow | Indicates whether show or hide the scrollbar.
Returns:
TRUE on success, FALSE on error.
See also:
EnableScrollBar

Generated on Fri Dec 17 13:49:50 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _SCROLLINFO Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_SCROLLINFO Struct Reference
[Scroll bar operations]

#include <window.h>

Data Fields

  • UINT cbSize
  • UINT fMask
  • int nMin
  • int nMax
  • UINT nPage
  • int nPos

Detailed Description

Scroll bar information structure.

Definition at line 6782 of file window.h.

Field Documentation

UINT cbSize

Size of the structrue in bytes

Definition at line 6785 of file window.h.

The documentation for this struct was generated from the following file:
  • window.h
Generated on Fri Dec 17 13:49:52 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Window class operations

Window class operations
[Window creating/destroying]

Data Structures

  • struct _WNDCLASS

Functions

  • MG_EXPORT BOOL GUIAPI RegisterWindowClass (PWNDCLASS pWndClass)
    Registers a window class.
  • MG_EXPORT BOOL GUIAPI UnregisterWindowClass (const char *szClassName)
    Undoes the effect of RegisterWindowClass.
  • MG_EXPORT const char *GUIAPI GetClassName (HWND hWnd)
    Retrieves the name of the class to which the specified window belongs.
  • MG_EXPORT BOOL GUIAPI GetWindowClassInfo (PWNDCLASS pWndClass)
    Retrieves the information of the specified window class.
  • MG_EXPORT BOOL GUIAPI SetWindowClassInfo (const WNDCLASS *pWndClass)
    Sets the information of the specified window class.

Function Documentation

const char *GUIAPI GetClassName ( HWND hWnd )

Retrieves the name of the class to which the specified window belongs.

This function retrieves the name of the class to which the specified window hWnd belongs.

Parameters:
hWnd The handle to the window.
Returns:
The pointer to a const class name string, NULL on error.
See also:
RegisterWindowClass

BOOL GUIAPI GetWindowClassInfo ( PWNDCLASS pWndClass )

Retrieves the information of the specified window class.

This function retrives the information of a window class. The window class to be retrived is specified by pWndClass->spClassName.

Parameters:
pWndClass The pointer to a WNDCLASS structure, which specifies the window class to be retrived via spClassName field, and returns the information through other fields.
Returns:
TRUE on success, FALSE on error.
See also:
SetWindowClassInfo

BOOL GUIAPI RegisterWindowClass ( PWNDCLASS pWndClass )

Registers a window class.

This function registers a window class. Later on, you can create a window of the registered class.

Parameters:
pWndClass The pointer to a WNDCLASS structure which specifies the information of the window class.
Returns:
TRUE on success, FALSE on error.
See also:
UnregisterWindowClass, WNDCLASS
Example:

#define STEP_CTRL_NAME "mystep"

#define MSG_SET_STEP_INFO   (MSG_USER + 1)
#define MSG_SET_CURR_STEP   (MSG_USER + 2)

static int StepControlProc (HWND hwnd,
                int message, WPARAM wParam, LPARAM lParam)
{
    HDC hdc;
    HELPWININFO* info;

    switch (message) {
    case MSG_PAINT:
        hdc = BeginPaint (hwnd);

        /* Get the step information. */
        info = (HELPWININFO*)GetWindowAdditionalData (hwnd);

        /* Draw the step information. */
        ......

        EndPaint (hwnd, hdc);
        break;

    /* A message defined by the control, used to set the step information. */
    case MSG_SET_STEP_INFO:
        SetWindowAdditionalData (hwnd, (DWORD)lParam);
        InvalidateRect (hwnd, NULL, TRUE);
        break;

    /*
     * A message defined by the control, used to set the information
     * of the current step.
     */
    case MSG_SET_CURR_STEP:
        InvalidateRect (hwnd, NULL, FALSE);
        break;

    case MSG_DESTROY:
        break;
    }

    return DefaultControlProc (hwnd, message, wParam, lParam);
}

static BOOL RegisterStepControl ()
{
    int result;
    WNDCLASS StepClass;

    StepClass.spClassName = STEP_CTRL_NAME;
    StepClass.dwStyle     = 0;
    StepClass.hCursor     = GetSystemCursor (IDC_ARROW);
    StepClass.iBkColor    = COLOR_lightwhite;
    StepClass.WinProc     = StepControlProc;

    return RegisterWindowClass (&StepClass);
}

static void UnregisterStepControl ()
{
    UnregisterWindowClass (STEP_CTRL_NAME);
}

BOOL GUIAPI SetWindowClassInfo ( const WNDCLASS * pWndClass )

Sets the information of the specified window class.

This function sets the information of a window class. The window class to be operated is specified by pWndClass->spClassName.

Parameters:
pWndClass The pointer to a WNDCLASS structure, which specifies the new information of the window class.
Returns:
TRUE on success, FALSE on error.
See also:
GetWindowClassInfo

BOOL GUIAPI UnregisterWindowClass ( const char * szClassName )

Undoes the effect of RegisterWindowClass.

This function unregisters a registered window class specified by szClassName.

Parameters:
szClassName The name of the class to be unregistered.
Returns:
TRUE on success, FALSE on error.
See also:
RegisterWindowClass

Generated on Fri Dec 17 13:49:50 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _WNDCLASS Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_WNDCLASS Struct Reference
[Window class operations]

#include <window.h>

Data Fields

  • const char * spClassName
  • DWORD opMask
  • DWORD dwStyle
  • DWORD dwExStyle
  • HCURSOR hCursor
  • int iBkColor
  • int(* WinProc )(HWND, int, WPARAM, LPARAM)
  • DWORD dwAddData

Detailed Description

Structure defines a window class

Definition at line 6897 of file window.h.

Field Documentation

const char* spClassName

The class name

Definition at line 6900 of file window.h.

The documentation for this struct was generated from the following file:
  • window.h
Generated on Fri Dec 17 13:49:52 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Control creating/destroying

Control creating/destroying
[Window creating/destroying]

Defines

  • #define CreateWindow(class_name, caption, style,id, x, y, w, h, parent, add_data)
    A simplified version of CreateWindowEx.

Typedefs

  • typedef void(* NOTIFPROC )(HWND hwnd, int id, int nc, DWORD add_data)
    Type of the notification callback procedure.

Functions

  • MG_EXPORT HWND GUIAPI CreateWindowEx2 (const char *spClassName, const char *spCaption, DWORD dwStyle, DWORD dwExStyle, int id, int x, int y, int w, int h, HWND hParentWnd, const char *werdr_name, const WINDOW_ELEMENT_ATTR *we_attrs, DWORD dwAddData)
    Creates a child window with extended style, renderer and attributes table.
  • static HWND GUIAPI CreateWindowEx (const char *spClassName, const char *spCaption, DWORD dwStyle, DWORD dwExStyle, int id, int x, int y, int w, int h, HWND hParentWnd, DWORD dwAddData)
    A shortcut version of CreateWindowEx2.
  • MG_EXPORT BOOL GUIAPI DestroyWindow (HWND hWnd)
    Destroys a specified control.
  • MG_EXPORT NOTIFPROC GUIAPI SetNotificationCallback (HWND hwnd, NOTIFPROC notif_proc)
    Sets a new notification callback procedure for a control.
  • MG_EXPORT NOTIFPROC GUIAPI GetNotificationCallback (HWND hwnd)
    Gets the notification callback procedure of a control.

Define Documentation

#define CreateWindow | ( | class_name,
 |  | caption,
 |  | style,
 |  | id,
 |  | x,
 |  | y,
 |  | w,
 |  | h,
 |  | parent,
 |  | add_data | )

Value:

CreateWindowEx(class_name, caption, style, 0,   \
                        id, x, y, w, h, parent, add_data)
A simplified version of CreateWindowEx.

See also:
CreateWindowEx

Definition at line 7171 of file window.h.

Typedef Documentation

typedef void(* NOTIFPROC)(HWND hwnd, int id, int nc, DWORD add_data)

Type of the notification callback procedure.

This is the function type of Notification Callback Procedure. If you set the Notification Callback Procedure for a control, when a notification occurred the control will call this callback procedure.

See also:
SetNotificationCallback

Definition at line 7118 of file window.h.

Function Documentation

HWND GUIAPI CreateWindowEx | ( | const char * | spClassName,
 |  | const char * | spCaption,
 |  | DWORD | dwStyle,
 |  | DWORD | dwExStyle,
 |  | int | id,
 |  | int | x,
 |  | int | y,
 |  | int | w,
 |  | int | h,
 |  | HWND | hParentWnd,
 |  | DWORD | dwAddData |
 | ) |  |  | [inline, static]

A shortcut version of CreateWindowEx2.

This function creates a child window by calling CreateWindowEx2 function and passing NULL for both werdr_name and we_attrs parameters.

See also:
CreateWindowEx2

Definition at line 7084 of file window.h.

References CreateWindowEx2(), and NULL.

HWND GUIAPI CreateWindowEx2 | ( | const char * | spClassName,
 |  | const char * | spCaption,
 |  | DWORD | dwStyle,
 |  | DWORD | dwExStyle,
 |  | int | id,
 |  | int | x,
 |  | int | y,
 |  | int | w,
 |  | int | h,
 |  | HWND | hParentWnd,
 |  | const char * | werdr_name,
 |  | const WINDOW_ELEMENT_ATTR * | we_attrs,
 |  | DWORD | dwAddData
 | ) |  |

Creates a child window with extended style, renderer and attributes table.

This function creates a child window (also known as "control") with extended style, renderer and attributes table. It specifies the window class, the window title, the window style, the window extended style, the initial position, and the size of the window, etc. The function also specifies the window's parent or owner.

Parameters:
spClassName | The class name of the control.
spCaption | The caption of the control.
dwStyle | The control style.
dwExStyle | The extended control style.
id | The identifier of the control.
x | x,y: The initial position of the control in the parent window.
y | x,y: The initial position of the control in the parent window.
w | The initial width of the control.
h | The initial height of the control.
hParentWnd | The handle to the parent window.
werdr_name | The window renderer name. NULL for default renderer.
we_attrs | The pointer to window element attribute table. NULL for default attribute table.
dwAddData | The first private additional data of the control. Note that some control classes use this value to initialize some properties of the new control instance. For these control classes, you should pass a valid value to it.
Returns:
The handle to the new control, HWND_INVALID on error.
See also:
CreateWindowEx, CreateMainWindow, CTRLDATA

Referenced by CreateWindowEx().

BOOL GUIAPI DestroyWindow ( HWND hWnd )

Destroys a specified control.

This function destroys the specified control hWnd, which is created by CreateWindowEx or CreateWindowEx2.

Parameters:
hWnd The handle to the control.
Returns:
TRUE on success, FALSE on error.
See also:
CreateWindowEx

NOTIFPROC GUIAPI GetNotificationCallback ( HWND hwnd )

Gets the notification callback procedure of a control.

This function gets the new notification callback procedure of the control of hwnd.

Parameters:
hwnd The handle to the control.
Returns:
The notification callback procedure.
See also:
NOTIFPROC, SetNotificationCallback

NOTIFPROC GUIAPI SetNotificationCallback | ( | HWND | hwnd,
 |  | NOTIFPROC | notif_proc
 | ) |  |

Sets a new notification callback procedure for a control.

This function sets the new notification callback procedure (notif_proc) for the control of hwnd.

By default, the notification from a control will be sent to its parent window within a MSG_COMMAND messsage.

Since version 1.2.6, MiniGUI defines the Notification Callback Procedure for control. You can specify a callback function for a control by calling SetNotificationCallback to receive and handle the notifications from the control.

If you did not set the notification callback function for a control, the notification will be sent to its parent as same as the earlier version of MiniGUI.

Parameters:
hwnd | The handle to the control.
notif_proc | The new notification callback procedure, can be NULL.
Returns:
The old notification callback procedure.
See also:
NOTIFPROC, GetNotificationCallback

Generated on Fri Dec 17 13:49:50 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Timer operations

Timer operations
[Window creating/destroying]

Defines

  • #define SetTimer(hwnd, id, speed) SetTimerEx(hwnd, id, speed, NULL)
    The backward compatibility version of SetTimerEx.
  • #define ResetTimer(hwnd, id, speed) ResetTimerEx(hwnd, id, speed, (TIMERPROC)0xFFFFFFFF)
    The backward compatibility version of ResetTimerEx.

Typedefs

  • typedef BOOL(* TIMERPROC )(HWND, int, DWORD)
    Type of the timer callback procedure.

Functions

  • MG_EXPORT BOOL GUIAPI SetTimerEx (HWND hWnd, int id, unsigned int speed, TIMERPROC timer_proc)
    Creates a timer with the specified timeout value.
  • MG_EXPORT int GUIAPI KillTimer (HWND hWnd, int id)
    Destroys a timer.
  • MG_EXPORT BOOL GUIAPI ResetTimerEx (HWND hWnd, int id, unsigned int speed, TIMERPROC timer_proc)
    Adjusts a timer with a different timeout value or different timer callback procedure.
  • MG_EXPORT unsigned int GUIAPI GetTickCount (void)
    Retrieves the tick counts that have elapsed since MiniGUI was started.
  • MG_EXPORT BOOL GUIAPI IsTimerInstalled (HWND hWnd, int id)
    Determines whether a timer is installed.
  • MG_EXPORT BOOL GUIAPI HaveFreeTimer (void)
    Determines whether there is any free timer slot in the system.

Define Documentation

#define ResetTimer | ( | hwnd,
 |  | id,
 |  | speed | ) | ResetTimerEx(hwnd, id, speed, (TIMERPROC)0xFFFFFFFF)

The backward compatibility version of ResetTimerEx.

See also:
ResetTimerEx

Definition at line 7286 of file window.h.

#define SetTimer | ( | hwnd,
 |  | id,
 |  | speed | ) | SetTimerEx(hwnd, id, speed, NULL)

The backward compatibility version of SetTimerEx.

See also:
SetTimerEx

Definition at line 7239 of file window.h.

Typedef Documentation

typedef BOOL(* TIMERPROC)(HWND, int, DWORD)

Type of the timer callback procedure.

This is the prototype of the callback procedure of a timer created by SetTimerEx. MiniGUI will call the timer procedure instead of sending MSG_TIMER message.

If the return value of a timer procedure is FALSE, the timer will be killed by MiniGUI automatically. This can be used to implement a one-shot timer.

See also:
SetTimerEx

Definition at line 7195 of file window.h.

Function Documentation

unsigned int GUIAPI GetTickCount ( void )

Retrieves the tick counts that have elapsed since MiniGUI was started.

This function retrieves the tick counts that have elapsed since MiniGUI was started. It is limited to the resolution of the system timer, i.e. for a general Linux box, the returned tick count value is in unit of 10ms.

Returns:
The tick counts value that have elapsed since MiniGUI was started.

BOOL GUIAPI HaveFreeTimer ( void )

Determines whether there is any free timer slot in the system.

This function determines whether there is any free timer slot in the system.

Returns:
TRUE for yes, otherwise FALSE.
See also:
IsTimerInstalled

BOOL GUIAPI IsTimerInstalled | ( | HWND | hWnd,
 |  | int | id
 | ) |  |

Determines whether a timer is installed.

This function determines whether a timer with identifier id of a window hwnd has been installed.

Parameters:
hWnd | The window owns the timer.
id | The identifier of the timer.
Returns:
TRUE for installed, otherwise FALSE.
See also:
SetTimer, HaveFreeTimer

int GUIAPI KillTimer | ( | HWND | hWnd,
 |  | int | id
 | ) |  |

Destroys a timer.

This function destroys the specified timer id.

Parameters:
hWnd | The window owns the timer.
id | The identifier of the timer. If id equals or is less than 0, this function will kill all timers in the system.
Returns:
The number of actually killed timer.
See also:
SetTimer

BOOL GUIAPI ResetTimerEx | ( | HWND | hWnd,
 |  | int | id,
 |  | unsigned int | speed,
 |  | TIMERPROC | timer_proc
 | ) |  |

Adjusts a timer with a different timeout value or different timer callback procedure.

This function resets a timer with the specified timeout speed value.

Parameters:
hWnd | The window owns the timer.
id | The identifier of the timer.
speed | The new timeout value.
timer_proc | The new timer callback procedure. If timer_proc is 0xFFFFFFFF, the setting of timer callback procedure will not changed.
Returns:
TRUE on success, FALSE on error.
See also:
SetTimerEx

BOOL GUIAPI SetTimerEx | ( | HWND | hWnd,
 |  | int | id,
 |  | unsigned int | speed,
 |  | TIMERPROC | timer_proc
 | ) |  |

Creates a timer with the specified timeout value.

This function creates a timer with the specified timeout value speed. Note that the timeout value is in unit of 10 ms. When the timer expires, an MSG_TIMER message will be send to the window hWnd if timer_proc is NULL, otherwise MiniGUI will call timer_proc by passing hWnd, id, and the tick count when this timer had expired to this callback procedure.

Parameters:
hWnd | The window receives the MSG_TIMER message. If timer_proc is not NULL, MiniGUI will call timer_proc instead sending MSG_TIMER message to this window. If you use timer callback procedure, hWnd can be any value you can pass.
id | The identifier of the timer, will be passed to the window with MSG_TIMER message as the first parameter of the message.
speed | The timeout value of the timer. Note that the timeout value is in unit of 10 ms.
timer_proc | The timer callback procedure. If this argument is NULL, MiniGUI will send MSG_TIMER to the window procedure of hWnd.
Returns:
TRUE on success, FALSE on error.
See also:
SetTimer, ResetTimerEx, KillTimer, MSG_TIMER
Note:
You should set, reset, and kill a timer in the same thread if your MiniGUI is configured as MiniGUI-Threads.
Example:

/*
 * A typical handling of timer.
 */
int FlyingGUIWinProc (HWND hWnd, int message, WPARAM wParam, LPARAM lParam)
{
    switch (message) {
        case MSG_CREATE:
        /* create a timer which expires every 100 ms, and whose id is 100. */
#ifdef _MGTIMER_UNIT_10MS
            SetTimer (hWnd, 100, 10);
#else
            SetTimer (hWnd, 100, 100);
#endif
        break;

        /* handling the MSG_TIMER message. */
        case MSG_TIMER:
            if (wParam == 100) /* if it is the timer whose id is 100. */
                InvalidateRect (hWnd, NULL, FALSE);
        break;

        case MSG_CLOSE:
            /* kill the timer whose id is 100. */
            KillTimer (hWnd, 100);
            DestroyMainWindow (hWnd);
            PostQuitMessage (hWnd);
        return 0;
    }

    return DefaultMainWinProc(hWnd, message, wParam, lParam);
}

Generated on Fri Dec 17 13:49:50 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: IME Window functions

IME Window functions
[Window creating/destroying]

Data Structures

  • struct _IME_TARGET_INFO

Functions

  • MG_EXPORT int GUIAPI RegisterIMEWindow (HWND hWnd)
    Registers an IME window.
  • MG_EXPORT int GUIAPI UnregisterIMEWindow (HWND hWnd)
    Unregisters an IME window.
  • MG_EXPORT int GUIAPI GetIMEStatus (int StatusCode)
    Retrives status of the current IME window.
  • MG_EXPORT int GUIAPI SetIMEStatus (int StatusCode, int Value)
    Sets the status of the current IME window.
  • MG_EXPORT int GUIAPI GetIMETargetInfo (IME_TARGET_INFO *info)
    Retrives the target info of the current IME window.
  • MG_EXPORT int GUIAPI GetIMEPos (POINT *pt)
    Retrives the position of the current IME window.
  • MG_EXPORT int GUIAPI SetIMETargetInfo (const IME_TARGET_INFO *info)
    Sets the target info of the current IME window.

Function Documentation

int GUIAPI GetIMEPos ( POINT * pt ) [inline]

Retrives the position of the current IME window.

This function retrives the position of the current IME window.

Parameters:
pt The item to be retrived. The positon is return by the current IME Window.
Returns:
The current IME window positon. ERR_IME_NOIMEWND if error occurred.
See also:
GetIMEPos

int GUIAPI GetIMEStatus ( int StatusCode )

Retrives status of the current IME window.

This function retrives status of the current IME window.

Parameters:
StatusCode The item to be retrived, can be one of the following values:
  • IME_STATUS_REGISTERED
    Is there any registered IME window?
  • IME_STATUS_ENABLED
    Is the IME window enabled?
  • IME_STATUS_AUTOTRACK
    Does the IME window autotrack the input focus?
  • IME_STATUS_LANGUAGE
    Retrieve the selected input method. The return value can be one of the following values:
    • IME_LANGUAGE_UNKNOWN
      Unknown
    • IME_LANGUAGE_LATIN
      Latin
    • IME_LANGUAGE_ZHCN
      Chinese simplified
    • IME_LANGUAGE_ZHTW
      Chinese traditional
  • IME_STATUS_ENCODING
    Retrieve the output encoding. The return value can be one of the following values:
    • IME_ENCODING_LOCAL
      The local encoding
    • IME_ENCODING_UTF8
      UTF-8
  • IME_STATUS_VERSION
    Retrieve the version of the IME
  • IME_STATUS_USER_MIN, IME_STATUS_USER_MAX Reserved for user. The return value and its meaning is determined by the specific IME implementation.
Returns:
The status of the item specified by StatusCode, ERR_IME_NOIMEWND if error occurred.
See also:
SetIMEStatus

int GUIAPI GetIMETargetInfo ( IME_TARGET_INFO * info )

Retrives the target info of the current IME window.

This function retrives the target info of the current IME window.

Parameters:
info The item to be retrived. The target info is return by the current IME Window.
Returns:
ERR_OK on success, otherwise less than zero.
See also:
GetIMETargetInfo

int GUIAPI RegisterIMEWindow ( HWND hWnd )

Registers an IME window.

This function registers the specified window hWnd as the IME window of the MiniGUI. After that, the keyboard input will be sent to IME window first. Note that only one IME window can be registered.

Parameters:
hWnd The handle to your IME window.
Returns:
ERR_OK on success, otherwise less than zero.
Return values:
ERR_OK | Success.
ERR_IME_TOOMUCHIMEWND | Already have an IME window registered.
ERR_INV_HWND | Invalid main window handle.
See also:
UnregisterIMEWindow

int GUIAPI SetIMEStatus | ( | int | StatusCode,
 |  | int | Value
 | ) |  |

Sets the status of the current IME window.

This function sets the status of the current IME window.

Parameters:
StatusCode | The item to be set. Please see GetIMEStatus for more information.
Value | The status value of the item.
Return values:
ERR_OK | Success.
ERR_IME_NOIMEWND | There is no any IME window registered.
See also:
GetIMEStatus

int GUIAPI SetIMETargetInfo ( const IME_TARGET_INFO * info )

Sets the target info of the current IME window.

This function sets the target info of the current IME window.

Parameters:
info The set target info.
Returns:
ERR_OK on success, otherwise less than zero.
Return values:
ERR_OK | Success.
ERR_IME_NOIMEWND | There is no any IME window registered.
See also:
SetIMETargetInfo

int GUIAPI UnregisterIMEWindow ( HWND hWnd )

Unregisters an IME window.

This function undoes the effect of RegisterIMEWindow.

Parameters:
hWnd The handle to the current IME window.
Returns:
ERR_OK on success, otherwise less than zero.
Return values:
ERR_OK | Success.
ERR_IME_NOSUCHIMEWND | The window is not the current IME window.
See also:
RegisterIMEWindow

Generated on Fri Dec 17 13:49:50 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _IME_TARGET_INFO Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_IME_TARGET_INFO Struct Reference
[IME Window functions]

#include <window.h>

Data Fields

  • int iEditBoxType

Detailed Description

\ struct defines a ime target info

Definition at line 7340 of file window.h.

Field Documentation

int iEditBoxType

The type of the edit box:

  • IME_WINDOW_TYPE_READONLY
    The edit box is readonly.

  • IME_WINDOW_TYPE_PASSWORD
    The edit box is readonly.

  • IME_WINDOW_TYPE_NOT_EDITABLE
    The edit box is not editable.

Definition at line 7353 of file window.h.

The documentation for this struct was generated from the following file:
  • window.h
Generated on Fri Dec 17 13:49:52 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Accelerator operations

Accelerator operations
[Window creating/destroying]

Functions

  • MG_EXPORT HACCEL GUIAPI CopyAcceleratorTable (HACCEL hacc)
    Copies the specified accelerator table.
  • MG_EXPORT int GUIAPI DeleteAccelerators (HACCEL hacc, int key, DWORD keymask)
    Deletes an accelerator from the accelerator table.
  • MG_EXPORT int GUIAPI AddAccelerators (HACCEL hacc, int key, DWORD keymask, WPARAM wParam, LPARAM lParam)
    Adds an accelerator to the accelerator table.
  • MG_EXPORT int GUIAPI DestroyAcceleratorTable (HACCEL hacc)
    Destroys an accelerator table.
  • MG_EXPORT HACCEL GUIAPI CreateAcceleratorTable (HWND hWnd)
    Creates an empty accelerator table.
  • MG_EXPORT int GUIAPI TranslateAccelerator (HACCEL hAccel, PMSG pMsg)
    Translates an accelerator key message to MSG_COMMAND messge and sends it to the window procedure.

Function Documentation

int GUIAPI AddAccelerators | ( | HACCEL | hacc,
 |  | int | key,
 |  | DWORD | keymask,
 |  | WPARAM | wParam,
 |  | LPARAM | lParam
 | ) |  |

Adds an accelerator to the accelerator table.

This function adds an accelerator to the accelerator table. It's called after you call CreateAcceleratorTable function.

Parameters:
hacc | The handle to the accelerator table.
key | The key value of the accelerator. Note that you can define the key value by either scancode or ASCII code. If you define the key with scancode, the key value should be equal to (scancode + 256).
keymask The shift key state, can be OR'ed value of the following values:
  • KS_SHIFT
    Shift key should be pressed.
  • KS_ALT
    Alt key should be pressed.
  • KS_CTRL
    Ctrl key should be pressed.
wParam | The first parameter of the MSG_COMMAND when receiving such a accelerator key.
lParam | The second parameter of the MSG_COMMAND when receiving such a accelerator key.
Returns:
The function returns 0 for success, non-zero for failure.
See also:
CreateAcceleratorTable, DeleteAccelerators

HACCEL GUIAPI CopyAcceleratorTable ( HACCEL hacc )

Copies the specified accelerator table.

This function copies the specified accelerator table. The function is used to obtain the accelerator table data that corresponds to an accelerator table handle.

Parameters:
hacc The handle to the accelerator table.
Returns:
The handle to the copied new accelerator table.

HACCEL GUIAPI CreateAcceleratorTable ( HWND hWnd )

Creates an empty accelerator table.

This function creates an empty accelerator table.

Parameters:
hWnd The handle to the main window.
Returns:
The handle to the new accelerator table, zero when error.
See also:
AddAccelerators, DestroyAcceleratorTable

int GUIAPI DeleteAccelerators | ( | HACCEL | hacc,
 |  | int | key,
 |  | DWORD | keymask
 | ) |  |

Deletes an accelerator from the accelerator table.

This function deletes an accelerator from the accelerator table.

Parameters:
hacc | The handle to the accelerator table.
key | The key value of the accelerator.
keymask | The shift key state.
Returns:
The function returns 0 for success, non-zero for failure.
See also:
AddAccelerators, DestroyAcceleratorTable

int GUIAPI DestroyAcceleratorTable ( HACCEL hacc )

Destroys an accelerator table.

This function destroys the specified accelerator table hacc. Before closing a window, you must call this function to destroy each accelerator table that is created by using CreateAcceleratorTable function.

Parameters:
hacc The handle to the accelerator table.
Returns:
The function returns 0 for success, non-zero for failure.
See also:
CreateAcceleratorTable

int GUIAPI TranslateAccelerator | ( | HACCEL | hAccel,
 |  | PMSG | pMsg
 | ) |  |

Translates an accelerator key message to MSG_COMMAND messge and sends it to the window procedure.

Parameters:
hAccel | The handle to the accelerator table.
pMsg | The pointer to the MSG structure to be translated.
Returns:
The function returns 0 for success, non-zero for failure.
See also:
TranslateMessage

Generated on Fri Dec 17 13:49:50 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Caret operations

Caret operations
[Window creating/destroying]

Functions

  • MG_EXPORT BOOL GUIAPI CreateCaret (HWND hWnd, PBITMAP pBitmap, int nWidth, int nHeight)
    Creates a new shape for the system caret and assigns ownership of the caret to the specified window.
  • MG_EXPORT BOOL GUIAPI ChangeCaretSize (HWND hWnd, int newWidth, int newHeight)
    Changes the size of the caret.
  • MG_EXPORT BOOL GUIAPI ActiveCaret (HWND hWnd)
    Activates the caret owned by a window.
  • MG_EXPORT UINT GUIAPI GetCaretBlinkTime (HWND hWnd)
    Returns the elapsed time, in milliseconds, required to invert the caret's pixels.
  • MG_EXPORT BOOL GUIAPI SetCaretBlinkTime (HWND hWnd, UINT uTime)
    Sets the caret blink time to the specified number of milliseconds.
  • MG_EXPORT BOOL GUIAPI DestroyCaret (HWND hWnd)
    Destroys a caret.
  • static BOOL GUIAPI HideCaret (HWND hWnd)
    Hides a caret.
  • MG_EXPORT BOOL GUIAPI ShowCaretEx (HWND hWnd, BOOL ime)
    Shows a caret.
  • static BOOL GUIAPI ShowCaret (HWND hWnd)
    Shows a caret.
  • MG_EXPORT BOOL GUIAPI SetCaretPos (HWND hWnd, int x, int y)
    Moves the caret to a new position.
  • MG_EXPORT BOOL GUIAPI GetCaretPos (HWND hWnd, PPOINT pPt)
    Gets the caret position.

Function Documentation

BOOL GUIAPI ActiveCaret ( HWND hWnd )

Activates the caret owned by a window.

This function activates the caret owned by the specified window hWnd. After activating the caret, the caret will begin flashing automatically.

Parameters:
hWnd The owner of the caret.
Returns:
TRUE on success, otherwise FALSE.
See also:
HideCaret, ShowCaret

BOOL GUIAPI ChangeCaretSize | ( | HWND | hWnd,
 |  | int | newWidth,
 |  | int | newHeight
 | ) |  |

Changes the size of the caret.

This function change the size of the caret owned by the specified window hWnd. Note that the new size of the caret should be smaller than the original size which is specified when you call CreateCaret.

Parameters:
hWnd | The owner of the caret.
newWidth | The new width of the caret.
newHeight | The new height of the caret.
Returns:
TRUE on success, otherwise FALSE.
See also:
CreateCaret

BOOL GUIAPI CreateCaret | ( | HWND | hWnd,
 |  | PBITMAP | pBitmap,
 |  | int | nWidth,
 |  | int | nHeight
 | ) |  |

Creates a new shape for the system caret and assigns ownership of the caret to the specified window.

This function creates a new shape for the system caret and assigns ownership of the caret to the specified window hWnd. The caret shape can be a line, a block, or a bitmap.

Parameters:
hWnd | The owner of the caret.
pBitmap | The bitmap shape of the caret. It can be NULL.
nWidth | The width of the caret.
nHeight | The height of the caret.
Returns:
TRUE on success, otherwise FALSE.
See also:
ActiveCaret, ChangeCaretSize

BOOL GUIAPI DestroyCaret ( HWND hWnd )

Destroys a caret.

This function destroys the caret's current shape, frees the caret from the window, and removes the caret from the screen.

Parameters:
hWnd The owner of the caret.
Returns:
TRUE on success, otherwise FALSE.
See also:
CreateCaret

UINT GUIAPI GetCaretBlinkTime ( HWND hWnd )

Returns the elapsed time, in milliseconds, required to invert the caret's pixels.

This function returns the elapsed time, in milliseconds, required to invert the caret's pixels. The default blink time of a caret is 500 milliseconds.

Parameters:
hWnd The owner of the caret.
Returns:
The elapsed time in milliseconds. Returns zero on error.
See also:
SetCaretBlinkTime

BOOL GUIAPI GetCaretPos | ( | HWND | hWnd,
 |  | PPOINT | pPt
 | ) |  |

Gets the caret position.

This function copies the caret's position, in client coordinates, to the specified POINT structure pPt.

Parameters:
hWnd | The owner of the caret.
pPt | The pointer to the buffer saves the caret's position.
Returns:
TRUE on success, otherwise FALSE.
See also:
SetCaretPos

BOOL GUIAPI HideCaret ( HWND hWnd ) [inline, static]

Hides a caret.

This function removes the caret from the screen and close the IME window. Hiding a caret does not destroy its current shape or invalidate the insertion point.

Parameters:
hWnd The owner of the caret.
Returns:
TRUE on success, otherwise FALSE.
See also:
ShowCaret

Definition at line 7778 of file window.h.

References TRUE.

BOOL GUIAPI SetCaretBlinkTime | ( | HWND | hWnd,
 |  | UINT | uTime
 | ) |  |

Sets the caret blink time to the specified number of milliseconds.

This function sets the caret blink time to the specified number of milliseconds. The blink time is the elapsed time, in milliseconds, required to invert the caret's pixels. The default blink time of a caret is 500 milliseconds.

Parameters:
hWnd | The owner of the caret.
uTime | New blink time in milliseconds.
Returns:
TRUE on success, otherwise FALSE.
See also:
GetCaretBlinkTime

BOOL GUIAPI SetCaretPos | ( | HWND | hWnd,
 |  | int | x,
 |  | int | y
 | ) |  |

Moves the caret to a new position.

This function moves the caret to the specified coordinates (x,y).

Parameters:
hWnd | The owner of the caret.
x | x,y: The position of the caret in client coordiantes of the owner window.
y | x,y: The position of the caret in client coordiantes of the owner window.
Returns:
TRUE on success, otherwise FALSE.
See also:
GetCaretPos

BOOL GUIAPI ShowCaret ( HWND hWnd ) [inline, static]

Shows a caret.

This function makes the caret visible on the screen at the caret's current position. When the caret becomes visible, it begins flashing automatically.

Parameters:
hWnd The owner of the caret.
Returns:
TRUE on success, otherwise FALSE.
See also:
HideCaret

Definition at line 7816 of file window.h.

References ShowCaretEx(), and TRUE.

BOOL GUIAPI ShowCaretEx | ( | HWND | hWnd,
 |  | BOOL | ime
 | ) |  |

Shows a caret.

This function makes the caret visible on the screen at the caret's current position. When the caret becomes visible, it begins flashing automatically.

Parameters:
hWnd | The owner of the caret.
ime | TRUE if you want to let the hidden IME window (if there is any) show up at the same time.
Returns:
TRUE on success, otherwise FALSE.
See also:
HideCaretEx

Referenced by ShowCaret().

Generated on Fri Dec 17 13:49:50 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Menu operations

Menu operations
[Window creating/destroying]

Data Structures

  • struct _MENUITEMINFO

Functions

  • MG_EXPORT HMENU GUIAPI CreateMenu (void)
    Creates an empty menu.
  • MG_EXPORT HMENU GUIAPI CreatePopupMenu (PMENUITEMINFO pmii)
    Creates a drop-down menu or submenu.
  • MG_EXPORT HMENU GUIAPI CreateSystemMenu (HWND hwnd, DWORD dwStyle)
    Creates a system menu.
  • MG_EXPORT int GUIAPI InsertMenuItem (HMENU hmnu, int item, UINT flag, PMENUITEMINFO pmii)
    Inserts a new menu item at the specified position in a menu.
  • MG_EXPORT int GUIAPI RemoveMenu (HMENU hmnu, int item, UINT flag)
    Deletes a menu item or detaches a submenu from the specified menu.
  • MG_EXPORT int GUIAPI DeleteMenu (HMENU hmnu, int item, UINT flag)
    Deletes an item from the specified menu.
  • MG_EXPORT int GUIAPI DestroyMenu (HMENU hmnu)
    Destroys the specified menu and frees any memory that the menu occupies.
  • MG_EXPORT int GUIAPI IsMenu (HMENU hmnu)
    Determines whether a handle is a menu handle.
  • MG_EXPORT HMENU GUIAPI SetMenu (HWND hwnd, HMENU hmnu)
    Assigns a new menu to the specified main window.
  • MG_EXPORT HMENU GUIAPI GetMenu (HWND hwnd)
    Retrieves the handle to the menu assigned to the given main window.
  • MG_EXPORT void GUIAPI DrawMenuBar (HWND hwnd)
    Redraws the menu bar of the specified main window.
  • MG_EXPORT int GUIAPI TrackMenuBar (HWND hwnd, int pos)
    Displays the specified submenu.
  • MG_EXPORT int GUIAPI TrackPopupMenu (HMENU hmnu, UINT uFlags, int x, int y, HWND hwnd)
    Displays and tracks a popup menu.
  • MG_EXPORT HMENU GUIAPI GetMenuBarItemRect (HWND hwnd, int pos, RECT *prc)
    Retrieves the rect of a menu bar item.
  • MG_EXPORT BOOL GUIAPI HiliteMenuBarItem (HWND hwnd, int pos, UINT flag)
    Draws the specified menubar item with 3D effect.
  • MG_EXPORT int GUIAPI GetMenuItemCount (HMENU hmnu)
    Determines the number of items in a menu.
  • MG_EXPORT int GUIAPI GetMenuItemID (HMENU hmnu, int pos)
    Retrieves the menu item identifier of a menu item at specified position in a menu.
  • MG_EXPORT int GUIAPI GetMenuItemInfo (HMENU hmnu, int item, UINT flag, PMENUITEMINFO pmii)
    Retrieves information about a menu item.
  • MG_EXPORT HMENU GUIAPI GetPopupSubMenu (HMENU hpppmnu)
    Retrieves the submenu of the specified popup menu.
  • MG_EXPORT HMENU GUIAPI StripPopupHead (HMENU hpppmnu)
    Strips the title of the popup menu.
  • MG_EXPORT HMENU GUIAPI GetSubMenu (HMENU hmnu, int pos)
    Retrieves the handle to the submenu activated by the specified menu item.
  • MG_EXPORT HMENU GUIAPI GetSystemMenu (HWND hwnd, BOOL flag)
    Allows the application to access the window menu (also known as the system menu) for copying and modifying.
  • MG_EXPORT UINT GUIAPI EnableMenuItem (HMENU hmnu, int item, UINT flag)
    Enables, disables, or grays the specified menu item.
  • MG_EXPORT int GUIAPI CheckMenuRadioItem (HMENU hmnu, int first, int last, int checkitem, UINT flag)
    Checks a specified menu item and makes it a radio item.
  • MG_EXPORT int GUIAPI SetMenuItemBitmaps (HMENU hmnu, int item, UINT flag, PBITMAP hBmpUnchecked, PBITMAP hBmpChecked)
    Associates the specified bitmap with a menu item.
  • MG_EXPORT int GUIAPI SetMenuItemInfo (HMENU hmnu, int item, UINT flag, PMENUITEMINFO pmii)
    Changes information about a menu item.

Function Documentation

int GUIAPI CheckMenuRadioItem | ( | HMENU | hmnu,
 |  | int | first,
 |  | int | last,
 |  | int | checkitem,
 |  | UINT | flag
 | ) |  |

Checks a specified menu item and makes it a radio item.

This function checks a specified menu item and makes it a radio item. At the same time, the function unchecks all other menu items in the associated group and clears the radio-item type flag for those items.

Parameters:
hmnu | The handle to the menu.
first | The position of the first item in the group.
last | The position of the last item in the group.
checkitem | The position of the menu item to check.
flag Indicates the position base, can be one of the following values:
  • MF_BYCOMMAND
    The position value item is based on the command identifier.
  • MF_BYPOSITION
    The position value item is based on the position in the menu.
Returns:
The function returns 0 for success, non-zero for failure.
See also:
SetMenuItemInfo, MENUITEMINFO

HMENU GUIAPI CreateMenu ( void )

Creates an empty menu.

This function creates a menu. The menu is initially empty, but it can be filled with menu items by using the InsertMenuItem functions.

Returns:
The handle to the menu, zero when error.
See also:
InsertMenuItem

HMENU GUIAPI CreatePopupMenu ( PMENUITEMINFO pmii )

Creates a drop-down menu or submenu.

This function creates a drop-down menu or submenu. The menu is initially empty. You can insert or append menu items by using the InsertMenuItem function.

Parameters:
pmii Menu item information used to create the popup menu.
Returns:
The handle to the popup menu.
See also:
InsertMenuItem, MENUITEMINFO

HMENU GUIAPI CreateSystemMenu | ( | HWND | hwnd,
 |  | DWORD | dwStyle
 | ) |  |

Creates a system menu.

This function creates a system menu for the main window specified by hwnd.

Parameters:
hwnd | The handle to the main window.
dwStyle | The style of the main window.
Returns:
The handle to the system menu.
See also:
CreateMenu, CreatePopupMenu

int GUIAPI DeleteMenu | ( | HMENU | hmnu,
 |  | int | item,
 |  | UINT | flag
 | ) |  |

Deletes an item from the specified menu.

This function deletes an item from the specified menu hmnu. Either the item is a normal menu item or a submenu, this function will delete the item.

Parameters:
hmnu | The handle to the menu.
item | The position of the menu item or submenu.
flag Indicates the position base, can be one of the following values:
  • MF_BYCOMMAND
    The position value item is based on the command identifier.
  • MF_BYPOSITION
    The position value item is based on the position in the menu.
Returns:
The function returns 0 for success, non-zero for failure.
Return values:
ERR_INVALID_HANDLE | hmnu is not a handle to menu.
ERR_INVALID_HMENU | hmnu is an invalid menu.
See also:
InsertMenuItem, RemoveMenu

int GUIAPI DestroyMenu ( HMENU hmnu )

Destroys the specified menu and frees any memory that the menu occupies.

This function destroys the specified menu hmnu and frees any memory that the menu occupies.

Parameters:
hmnu The handle to the menu.
Returns:
The function returns 0 for success, non-zero for failure.
Return values:
ERR_INVALID_HANDLE hmnu is not a handle to menu.
See also:
RemoveMenu, DeleteMenu

void GUIAPI DrawMenuBar ( HWND hwnd )

Redraws the menu bar of the specified main window.

This function redraws the menu bar of the specified main window. If the menu bar changes after the system has created the window, this function must be called to draw the changed menu bar.

Parameters:
hwnd The handle to the main window.
See also:
TrackMenuBar

UINT GUIAPI EnableMenuItem | ( | HMENU | hmnu,
 |  | int | item,
 |  | UINT | flag
 | ) |  |

Enables, disables, or grays the specified menu item.

This function enables, disables, or grays the specified menu item.

Parameters:
hmnu | [in] Handle to the menu.
item | [in] Specifies the menu item or submenu to be enabled, disabled, or grayed, as determined by the flag parameter. This parameter specifies an item in a menu bar, menu or submenu.
flag | [in] Controls the interpretation of the item parameter and indicates whether the menu item is enabled, disabled, or grayed. This parameter must be a combination of either MF_BYPOSITION or MF_BYCOMMAND.
Returns:
The return value specifies the previous state of the menu item. If the menu item does not exist, the return value is -1.
See also:
GetMenuItemInfo

HMENU GUIAPI GetMenu ( HWND hwnd )

Retrieves the handle to the menu assigned to the given main window.

This function retrives the handle to the menu assigned to the given main window hwnd.

Parameters:
hwnd The handle to the main window.
Returns:
The handle to the menu of the window.
See also:
SetMenu

HMENU GUIAPI GetMenuBarItemRect | ( | HWND | hwnd,
 |  | int | pos,
 |  | RECT * | prc
 | ) |  |

Retrieves the rect of a menu bar item.

This function retrieves the rect of the menu bar item specified by the parameter pos.

Parameters:
hwnd | The handle to the main window.
pos | The position of the item. The position value of the first item is 0.
prc | The pointer to a RECT object, which will receive the rectangle.
Returns:
The function returns the handle to the menu bar if success, otherwise returns 0.
See also:
TrackMenuBar

int GUIAPI GetMenuItemCount ( HMENU hmnu )

Determines the number of items in a menu.

This function determines the number of items in the specified menu hmnu.

Parameters:
hmnu The handle to the menu.
Returns:
The number of the items in the menu.
See also:
GetMenuItemInfo

int GUIAPI GetMenuItemID | ( | HMENU | hmnu,
 |  | int | pos
 | ) |  |

Retrieves the menu item identifier of a menu item at specified position in a menu.

This function retrieves the menu item identifier of a menu item at the specified position pos in the specified menu hmnu.

Parameters:
hmnu | The handle to the menu.
pos | The position of the menu item. The position value of the first item is 0.
Returns:
The identifier of the items in the menu.
See also:
GetMenuItemInfo

int GUIAPI GetMenuItemInfo | ( | HMENU | hmnu,
 |  | int | item,
 |  | UINT | flag,
 |  | PMENUITEMINFO | pmii
 | ) |  |

Retrieves information about a menu item.

This function retrieves information about a menu item, and returns the information via pmii.

Parameters:
hmnu | [in] Handle to the menu that contains the menu item.
item | The position of the menu item or submenu.
flag Indicates the position base, can be one of the following values:
  • MF_BYCOMMAND
    The position value item is based on the command identifier.
  • MF_BYPOSITION
    The position value item is based on the position in the menu.
pmii | [in, out] Pointer to a MENUITEMINFO structure that specifies the information to retrieve and receive information about the menu item.
Returns:
The function returns 0 for success, non-zero for failure.
See also:
SetMenuItemInfo, MENUITEMINFO

HMENU GUIAPI GetPopupSubMenu ( HMENU hpppmnu )

Retrieves the submenu of the specified popup menu.

This function retrieves the submenu of the specified popup menu.

Parameters:
hpppmnu The handle to the popup menu.
Returns:
The handle to the submenu of the popup menu.
See also:
CreatePopupMenu

HMENU GUIAPI GetSubMenu | ( | HMENU | hmnu,
 |  | int | pos
 | ) |  |

Retrieves the handle to the submenu activated by the specified menu item.

This function retrieves the handle to the drop-down menu or submenu activated by the specified menu item.

Parameters:
hmnu | The handle to the menu.
pos | The position of the menu item. The position value of the first item is 0.
Returns:
The handle to the submenu; 0 if the menu item can not activate a submenu.
See also:
GetPopupSubMenu

HMENU GUIAPI GetSystemMenu | ( | HWND | hwnd,
 |  | BOOL | flag
 | ) |  |

Allows the application to access the window menu (also known as the system menu) for copying and modifying.

This function returns the handle to the system menu of the main window. This allows the application to access the window menu (also known as the system menu) for copying and modifying.

Parameters:
hwnd | The handle to the main window.
flag | Ignored currently; reserved for future use.
Returns:
The handle to the system menu; 0 if the main window has not a system menu.
See also:
GetMenu, SetMenu

BOOL GUIAPI HiliteMenuBarItem | ( | HWND | hwnd,
 |  | int | pos,
 |  | UINT | flag
 | ) |  |

Draws the specified menubar item with 3D effect.

This function draws the specified menubar item with 3D effect.

Parameters:
hwnd | The handle to the main window.
pos | The position of the item. The position value of the first item is 0.
flag The drawing flag, can be one of the following values:
  • LFRDR_MENU_STATE_HILITE
    hilite item.
  • LFRDR_MENU_STATE_NORMAL
    normal item.
  • LFRDR_MENU_STATE_DISABLED
    disabled item.
Returns:
TRUE on success, otherwise FALSE.
See also:
TrackMenuBar

int GUIAPI InsertMenuItem | ( | HMENU | hmnu,
 |  | int | item,
 |  | UINT | flag,
 |  | PMENUITEMINFO | pmii
 | ) |  |

Inserts a new menu item at the specified position in a menu.

This function inserts a new menu item specified by pmmi at the specified position (determined by item and flag) in the menu hmnu.

Parameters:
hmnu | The handle to the menu.
item | The insertion position.
flag Indicates the position base, can be one of the following values:
  • MF_BYCOMMAND
    The position value item is based on the command identifier. The new menu item will insert bellow the item whose id is item.
  • MF_BYPOSITION
    The position value item is based on the position in the menu.
pmii | Menu item information used to create the popup menu.
Returns:
The function returns 0 for success, non-zero for failure.
Return values:
ERR_INVALID_HANDLE | hmnu is not a handle to menu.
ERR_RES_ALLOCATION | Can not allocate new menu item.
ERR_INVALID_HMENU | hmnu is an invalid menu.
See also:
RemoveMenu, MENUITEMINFO

int GUIAPI IsMenu ( HMENU hmnu )

Determines whether a handle is a menu handle.

This function determines whether the handle specified by hmnu is a menu handle.

Parameters:
hmnu The handle to a menu.
Returns:
The function returns 0 for none menu handle, otherwise the type of the menu.
See also:
CreateMenu

int GUIAPI RemoveMenu | ( | HMENU | hmnu,
 |  | int | item,
 |  | UINT | flag
 | ) |  |

Deletes a menu item or detaches a submenu from the specified menu.

This function deletes a menu item or detaches a submenu from the specified menu hmnu. If the item is a normal menu item, the function will delete the item. If the item is a submenu, the function will detache the submenu for the menu, but not delete the submenu.

Parameters:
hmnu | The handle to the menu.
item | The position of the menu item or submenu.
flag Indicates the position base, can be one of the following values:
  • MF_BYCOMMAND
    The position value item is based on the command identifier.
  • MF_BYPOSITION
    The position value item is based on the position in the menu.
Returns:
The function returns 0 for success, non-zero for failure.
Return values:
ERR_INVALID_HANDLE | hmnu is not a handle to menu.
ERR_INVALID_HMENU | hmnu is an invalid menu.
See also:
InsertMenuItem, DeleteMenu

HMENU GUIAPI SetMenu | ( | HWND | hwnd,
 |  | HMENU | hmnu
 | ) |  |

Assigns a new menu to the specified main window.

This functionn assigns the specified menu hmnu to the main window specified by hwnd.

Parameters:
hwnd | The handle to the main window.
hmnu | The handle to the new menu.
Returns:
The handle to the old menu of the window.
See also:
GetMenu

int GUIAPI SetMenuItemBitmaps | ( | HMENU | hmnu,
 |  | int | item,
 |  | UINT | flag,
 |  | PBITMAP | hBmpUnchecked,
 |  | PBITMAP | hBmpChecked
 | ) |  |

Associates the specified bitmap with a menu item.

This function associates the specified bitmap with a menu item. Whether the menu item is checked or unchecked, the system displays the appropriate bitmap next to the menu item.

Parameters:
hmnu | The handle to the menu.
item | The position of the menu item.
flag Indicates the position base, can be one of the following values:
  • MF_BYCOMMAND
    The position value item is based on the command identifier.
  • MF_BYPOSITION
    The position value item is based on the position in the menu.
hBmpUnchecked | The pointer to the unchecked BITMAP object.
hBmpChecked | The pointer to the checked BITMAP object.
Returns:
The function returns 0 for success, non-zero for failure.
See also:
SetMenuItemInfo, MENUITEMINFO

int GUIAPI SetMenuItemInfo | ( | HMENU | hmnu,
 |  | int | item,
 |  | UINT | flag,
 |  | PMENUITEMINFO | pmii
 | ) |  |

Changes information about a menu item.

This function changes information about the specified menu item.

Parameters:
hmnu | [in] Handle to the menu that contains the menu item.
item | [in] Specifies the identifier or position of the menu item to change. The meaning of this parameter depends on the value of flag.
flag Indicates the position base, can be one of the following values:
  • MF_BYCOMMAND
    The position value item is based on the command identifier.
  • MF_BYPOSITION
    The position value item is based on the position in the menu.
pmii | The pointer to a MENUITEMINFO structure contains the information.
Returns:
The function returns 0 for success, non-zero for failure.
See also:
GetMenuItemInfo, MENUITEMINFO

HMENU GUIAPI StripPopupHead ( HMENU hpppmnu )

Strips the title of the popup menu.

This function strips the title of the popup menu hpppmnu.

Parameters:
hpppmnu The handle to the popup menu.
Returns:
The handle to the submenu whose title has been stripped.
See also:
GetPopupSubMenu

int GUIAPI TrackMenuBar | ( | HWND | hwnd,
 |  | int | pos
 | ) |  |

Displays the specified submenu.

This function displays the specified submenu in the menu bar of the specified main window hwnd.

Parameters:
hwnd | The handle to the main window.
pos | The position of the submenu. The position value of the first submenu is 0.
Returns:
The function returns 0 for success, non-zero for failure.
See also:
TrackPopupMenu, CreateMenu

int GUIAPI TrackPopupMenu | ( | HMENU | hmnu,
 |  | UINT | uFlags,
 |  | int | x,
 |  | int | y,
 |  | HWND | hwnd
 | ) |  |

Displays and tracks a popup menu.

This function displays a shortcut menu at the specified location and tracks the selection of items on the menu. The shortcut menu can appear anywhere on the screen.

Parameters:
hmnu | The handle to the popup menu.
uFlags The tracking flags, can be OR'ed value of the following values:
  • TPM_LEFTALIGN
    Horz alignement is left.
  • TPM_CENTERALIGN
    Horz alignement is center.
  • TPM_RIGHTALIGN
    Horz alignement is right.
  • TPM_TOPALIGN
    Vert alignement is top.
  • TPM_VCENTERALIGN
    Vert alignement is center.
  • TPM_BOTTOMALIGN
    Vert alignement is bottom.
  • TPM_DESTROY
    Destroys the popup menu after finishing tracking.
  • TPM_SYSCMD
    Sends an MSG_SYSCOMMAND message to the window when the use select a menu item.
x | The x coordinate of the position of the popup menu.
y | The y coordinate of the position of the popup menu.
hwnd | The handle to the window which will receive the MSG_COMMAND or MSG_SYSCOMMAND message.
Returns:
The function returns 0 for success, non-zero for failure.
See also:
TrackMenuBar, CreatePopupMenu

Generated on Fri Dec 17 13:49:50 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _MENUITEMINFO Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_MENUITEMINFO Struct Reference
[Menu operations]

#include <window.h>

Data Fields

  • UINT mask
  • UINT type
  • UINT state
  • int id
  • HMENU hsubmenu
  • PBITMAP uncheckedbmp
  • PBITMAP checkedbmp
  • DWORD itemdata
  • DWORD typedata
  • UINT cch

Detailed Description

Structure defines a menu item

Definition at line 7986 of file window.h.

Field Documentation

UINT mask

Used by GetMenuItemInfo and SetMenuItemInfo functions, can be OR'ed with the following values:

  • MIIM_STATE
    Get/set the state of the menu item.
  • MIIM_ID
    Get/set the identifier of the menu item.
  • MIIM_SUBMENU
    Get/set the sub-menu of the menu item.
  • MIIM_CHECKMARKS
    Get/set the check/uncheck bitmap.
  • MIIM_TYPE
    Get/set the type and the type data of the menu item.
  • MIIM_DATA
    Get/set the item data of the menu item.

Definition at line 8004 of file window.h.

The documentation for this struct was generated from the following file:
  • window.h
Generated on Fri Dec 17 13:49:52 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Dialog operations

Dialog operations
[Window creating/destroying]

Data Structures

  • struct _CTRLDATA
  • struct _DLGTEMPLATE

Defines

  • #define DLGC_WANTARROWS 0x0001
    Control wants arrow keys.
  • #define DLGC_WANTTAB 0x0002
    Control wants tab keys.
  • #define DLGC_WANTALLKEYS 0x0004
    Control wants all keys.
  • #define DLGC_WANTCHARS 0x0008
    Want MSG_CHAR messages.
  • #define DLGC_WANTENTER 0x0010
    Control wants enter keys.
  • #define DLGC_HASSETSEL 0x0080
    Understands EM_SETSEL message.
  • #define DLGC_DEFPUSHBUTTON 0x0100
    Default pushbutton.
  • #define DLGC_PUSHBUTTON 0x0200
    Non-default pushbutton.
  • #define DLGC_RADIOBUTTON 0x0400
    Radio button.
  • #define DLGC_3STATE 0x0800
    3 States button item.
  • #define DLGC_STATIC 0x1000
    Static item: don't include.
  • #define DLGC_BUTTON 0x2000
    Button item: can be checked.

Functions

  • MG_EXPORT HWND GUIAPI CreateMainWindowIndirectParamEx (PDLGTEMPLATE pDlgTemplate, HWND hOwner, WNDPROC WndProc, LPARAM lParam, const char *werdr_name, WINDOW_ELEMENT_ATTR *we_attrs, const char *window_name, const char *layer_name)
    Uses a dialog template and other information to create a modeless main window and controls in it, and pass a parameter to the window procedure.
  • static HWND GUIAPI CreateMainWindowIndirectParam (PDLGTEMPLATE pDlgTemplate, HWND hOwner, WNDPROC WndProc, LPARAM lParam)
    A simplified version of CreateMainWindowIndirectParamEx.
  • static HWND GUIAPI CreateMainWindowIndirect (PDLGTEMPLATE pDlgTemplate, HWND hOwner, WNDPROC WndProc)
    A simplified version of CreateMainWindowIndirectParam.
  • MG_EXPORT BOOL GUIAPI DestroyMainWindowIndirect (HWND hMainWin)
    Destroys a main window created by CreateMainWindowIndirectParam.
  • MG_EXPORT int GUIAPI DialogBoxIndirectParamEx (PDLGTEMPLATE pDlgTemplate, HWND hOwner, WNDPROC DlgProc, LPARAM lParam, const char *werdr_name, WINDOW_ELEMENT_ATTR *we_attrs, const char *window_name, const char *layer_name)
    Creates a modal dialog box from a dialog box template in memory and other information.
  • static int GUIAPI DialogBoxIndirectParam (PDLGTEMPLATE pDlgTemplate, HWND hOwner, WNDPROC DlgProc, LPARAM lParam)
    A simplified version of DialogBoxIndirectParamEx.
  • MG_EXPORT BOOL GUIAPI EndDialog (HWND hDlg, int endCode)
    Destroys a modal dialog box, causing MiniGUI to end any processing for the dialog box.
  • MG_EXPORT void GUIAPI DestroyAllControls (HWND hWnd)
    Destroys all controls in a window.
  • MG_EXPORT HWND GUIAPI GetDlgDefPushButton (HWND hWnd)
    Gets the default push button control in a window.
  • MG_EXPORT int GUIAPI GetDlgCtrlID (HWND hwndCtl)
    Gets the integer identifier of a control.
  • MG_EXPORT HWND GUIAPI GetDlgItem (HWND hDlg, int nIDDlgItem)
    Retrives the handle to a control in a dialog box.
  • MG_EXPORT UINT GUIAPI GetDlgItemInt (HWND hDlg, int nIDDlgItem, BOOL *lpTranslated, BOOL bSigned)
    Translates the text of a control in a dialog box into an integer value.
  • MG_EXPORT int GUIAPI GetDlgItemText (HWND hDlg, int nIDDlgItem, char *lpString, int nMaxCount)
    Retrieves the title or text associated with a control in a dialog box.
  • MG_EXPORT char *GUIAPI GetDlgItemText2 (HWND hDlg, int id, int *lenPtr)
    Retrieves the title or text associated with a control in a dialog box.
  • MG_EXPORT HWND GUIAPI GetNextDlgGroupItem (HWND hDlg, HWND hCtl, BOOL bPrevious)
    Retrieves the handle to the first control in a group of controls that precedes (or follows) the specified control in a dialog box.
  • MG_EXPORT HWND GUIAPI GetNextDlgTabItem (HWND hDlg, HWND hCtl, BOOL bPrevious)
    Retrieves the handle to the first control that has the WS_TABSTOP style that precedes (or follows) the specified control.
  • MG_EXPORT int GUIAPI SendDlgItemMessage (HWND hDlg, int nIDDlgItem, int message, WPARAM wParam, LPARAM lParam)
    Sends a message to the specified control in a dialog box.
  • MG_EXPORT BOOL GUIAPI SetDlgItemInt (HWND hDlg, int nIDDlgItem, UINT uValue, BOOL bSigned)
    Sets the text of a control in a dialog box to the string representation of a specified integer value.
  • MG_EXPORT BOOL GUIAPI SetDlgItemText (HWND hDlg, int nIDDlgItem, const char *lpString)
    Sets the title or text of a control in a dialog box.
  • MG_EXPORT void GUIAPI CheckDlgButton (HWND hDlg, int nIDDlgItem, int nCheck)
    Changes the check status of a button control.
  • MG_EXPORT void GUIAPI CheckRadioButton (HWND hDlg, int idFirstButton, int idLastButton, int idCheckButton)
    Adds a check mark to (checks) a specified radio button in a group and removes a check mark from (clears) all other radio buttons in the group.
  • MG_EXPORT int GUIAPI IsDlgButtonChecked (HWND hDlg, int idButton)
    Determines whether a button control has a check mark next to it or whether a three-state button control is grayed, checked, or neither.

Define Documentation

#define DLGC_3STATE 0x0800

3 States button item.

Definition at line 8664 of file window.h.

#define DLGC_BUTTON 0x2000

Button item: can be checked.

Definition at line 8674 of file window.h.

#define DLGC_DEFPUSHBUTTON 0x0100

Default pushbutton.

Definition at line 8649 of file window.h.

#define DLGC_HASSETSEL 0x0080

Understands EM_SETSEL message.

Definition at line 8643 of file window.h.

#define DLGC_PUSHBUTTON 0x0200

Non-default pushbutton.

Definition at line 8654 of file window.h.

#define DLGC_RADIOBUTTON 0x0400

Radio button.

Definition at line 8659 of file window.h.

#define DLGC_STATIC 0x1000

Static item: don't include.

Definition at line 8669 of file window.h.

#define DLGC_WANTALLKEYS 0x0004

Control wants all keys.

Definition at line 8627 of file window.h.

#define DLGC_WANTARROWS 0x0001

Control wants arrow keys.

Definition at line 8617 of file window.h.

#define DLGC_WANTCHARS 0x0008

Want MSG_CHAR messages.

Definition at line 8632 of file window.h.

#define DLGC_WANTENTER 0x0010

Control wants enter keys.

Definition at line 8638 of file window.h.

#define DLGC_WANTTAB 0x0002

Control wants tab keys.

Definition at line 8622 of file window.h.

Function Documentation

void GUIAPI CheckDlgButton | ( | HWND | hDlg,
 |  | int | nIDDlgItem,
 |  | int | nCheck
 | ) |  |

Changes the check status of a button control.

This function changes the check status of the button control whose identifier is nIDDlgItem in the dialog box hDlg.

Parameters:
hDlg | The handle to the dialog box.
nIDDlgItem | The identifier of the control.
nCheck The state of the button. If the button is a normal button, the value being zero means the button is checked, otherwise unchecked. If the button is a special button with three states, the value can be one of the following values:
  • BST_UNCHECKED
    The button is unchecked.
  • BST_CHECKED
    The button is checked.
  • BST_INDETERMINATE
    The button is in indeterminate state.
See also:
CheckRadioButton, IsDlgButtonChecked

void GUIAPI CheckRadioButton | ( | HWND | hDlg,
 |  | int | idFirstButton,
 |  | int | idLastButton,
 |  | int | idCheckButton
 | ) |  |

Adds a check mark to (checks) a specified radio button in a group and removes a check mark from (clears) all other radio buttons in the group.

This function adds a check mark to (checks) the specified radio button idCheckButton in a group between idFirstButton and idLastButton, and removes a check mark from (clears) all other radio buttons in the group.

Parameters:
hDlg | The handle to the dialog box.
idFirstButton | The identifier of the first control in the group.
idLastButton | The identifier of the last control in the group.
idCheckButton | The identifier of the control to be checked.
See also:
CheckDlgButton

HWND GUIAPI CreateMainWindowIndirect | ( | PDLGTEMPLATE | pDlgTemplate,
 |  | HWND | hOwner,
 |  | WNDPROC | WndProc |
 | ) |  |  | [inline, static]

A simplified version of CreateMainWindowIndirectParam.

This function creates a main window by calling CreateMainWindowIndirectParam function and passing 0 for lParam parameter.

See also:
CreateMainWindowIndirectParam

Definition at line 8801 of file window.h.

References CreateMainWindowIndirectParam().

HWND GUIAPI CreateMainWindowIndirectParam | ( | PDLGTEMPLATE | pDlgTemplate,
 |  | HWND | hOwner,
 |  | WNDPROC | WndProc,
 |  | LPARAM | lParam |
 | ) |  |  | [inline, static]

A simplified version of CreateMainWindowIndirectParamEx.

This function creates a main window by calling CreateMainWindowIndirectParamEx function and passing NULL for werdr_name, we_attrs, window_name, and layer_name parameters.

See also:
CreateMainWindowIndirectParamEx

Definition at line 8782 of file window.h.

References CreateMainWindowIndirectParamEx(), and NULL.

Referenced by CreateMainWindowIndirect().

HWND GUIAPI CreateMainWindowIndirectParamEx | ( | PDLGTEMPLATE | pDlgTemplate,
 |  | HWND | hOwner,
 |  | WNDPROC | WndProc,
 |  | LPARAM | lParam,
 |  | const char * | werdr_name,
 |  | WINDOW_ELEMENT_ATTR * | we_attrs,
 |  | const char * | window_name,
 |  | const char * | layer_name
 | ) |  |

Uses a dialog template and other information to create a modeless main window and controls in it, and pass a parameter to the window procedure.

This function uses a dialog template pointed to by pDlgTemplate and other information to create a modeless main window and controls in it. The parameter specified by lParam will be passed to the window procedure as the second paramter of MSG_INITDIALOG message.

Parameters:
pDlgTemplate | The pointer to a DLGTEMPLATE structure.
hOwner | The handle to the hosting main window.
WndProc | The window procedure of the new main window.
lParam | The parameter will be passed to the window procedure.
werdr_name | The name of window element renderer. NULL for default renderer.
we_attrs | The pointer to window element attribute table. NULL for default window attribute table.
window_name | The window name; reserved for future use.
layer_name | The layer name; reserved for future use.
Returns:
Handle to the new main window, HWND_INVALID on error.
See also:
CreateMainWindowIndirectParam, DestroyMainWindowIndirect, DialogBoxIndirectParam, DLGTEMPLATE

Referenced by CreateMainWindowIndirectParam().

void GUIAPI DestroyAllControls ( HWND hWnd )

Destroys all controls in a window.

This function destroys all controls (child windows) in a window.

Parameters:
hWnd The handle to the window.
See also:
DestroyWindow

BOOL GUIAPI DestroyMainWindowIndirect ( HWND hMainWin )

Destroys a main window created by CreateMainWindowIndirectParam.

This function destroys the main window which was created by CreateMainWindowIndirectParam function.

Parameters:
hMainWin The handle to the main window.
See also:
CreateMainWindowIndirectParam

int GUIAPI DialogBoxIndirectParam | ( | PDLGTEMPLATE | pDlgTemplate,
 |  | HWND | hOwner,
 |  | WNDPROC | DlgProc,
 |  | LPARAM | lParam |
 | ) |  |  | [inline, static]

A simplified version of DialogBoxIndirectParamEx.

This function creates a dialog box by calling DialogBoxIndirectParamEx function and passing NULL for werdr_name, we_attrs, window_name, and layer_name parameters.

See also:
DialogBoxIndirectParamEx

Definition at line 8869 of file window.h.

References DialogBoxIndirectParamEx(), and NULL.

int GUIAPI DialogBoxIndirectParamEx | ( | PDLGTEMPLATE | pDlgTemplate,
 |  | HWND | hOwner,
 |  | WNDPROC | DlgProc,
 |  | LPARAM | lParam,
 |  | const char * | werdr_name,
 |  | WINDOW_ELEMENT_ATTR * | we_attrs,
 |  | const char * | window_name,
 |  | const char * | layer_name
 | ) |  |

Creates a modal dialog box from a dialog box template in memory and other information.

This function creates a modal dialog box from a dialog box template in memory and other information. Before displaying the dialog box, the function passes an application-defined value to the dialog box procedure as the second parameter of the MSG_INITDIALOG message. An application can use this value to initialize the controls in the dialog box.

Parameters:
pDlgTemplate | The pointer to a DLGTEMPLATE structure.
hOwner | The handle to the hosting main window.
DlgProc | The window procedure of the new dialog box.
lParam | The parameter will be passed to the window procedure.
werdr_name | The name of window element renderer. NULL for default renderer.
we_attrs | The pointer to window element attribute table. NULL for default window attribute table.
window_name | The window name; reserved for future use.
layer_name | The layer name; reserved for future use.
Returns:
Return value of the dialog box, i.e., the second argument passed to EndDialog function which closes the dialog box.
See also:
EndDialog, DialogBoxIndirectParam, CreateMainWindowIndirectParam, DLGTEMPLATE

Referenced by DialogBoxIndirectParam().

BOOL GUIAPI EndDialog | ( | HWND | hDlg,
 |  | int | endCode
 | ) |  |

Destroys a modal dialog box, causing MiniGUI to end any processing for the dialog box.

This function destroys the modal dialog box hDlg created by DialogBoxIndirectParam and ends any processing for the dialog box. The argument endCode will be returned by DialogBoxIndirectParam as the return value.

Parameters:
hDlg | The handle to the dialog box.
endCode | The value will be returned by DialogBoxIndirectParam.
Returns:
TRUE on success, FALSE on error.
See also:
DialogBoxIndirectParam

int GUIAPI GetDlgCtrlID ( HWND hwndCtl )

Gets the integer identifier of a control.

This function gets the integer identifier of the control hwndCtl.

Parameters:
hwndCtl The handle to the control.
Returns:
The identifier of the control, -1 for error.
See also:
GetDlgItem

HWND GUIAPI GetDlgDefPushButton ( HWND hWnd )

Gets the default push button control in a window.

This function gets the handle to the default push button (with BS_DEFPUSHBUTTON style) in the specified window hWnd.

Parameters:
hWnd The handle to the window.
Returns:
The handle to the default push button, zero for non default push button in the window.

HWND GUIAPI GetDlgItem | ( | HWND | hDlg,
 |  | int | nIDDlgItem
 | ) |  |

Retrives the handle to a control in a dialog box.

This function retrives the handle to a control, whose identifier is nIDDlgItem, in the specified dialog box hDlg.

Parameters:
hDlg | The handle to the dialog box.
nIDDlgItem | The identifier of the control.
Returns:
The handle to the control, zero for not found.

UINT GUIAPI GetDlgItemInt | ( | HWND | hDlg,
 |  | int | nIDDlgItem,
 |  | BOOL * | lpTranslated,
 |  | BOOL | bSigned
 | ) |  |

Translates the text of a control in a dialog box into an integer value.

This function translates the text of the control, whose identifier is nIDDlgItem in the dialog box hDlg into an integer value.

Parameters:
hDlg | The handle to the dialog box.
nIDDlgItem | The identifier of the control.
lpTranslated | The pointer to a boolean value, which indicates whether translated successfully.
bSigned | Indicates whether handle the text as a signed integer.
Returns:
The translated 32-bit integer.
Note:
MiniGUI uses strtol or strtoul to convert the string value to a 32-bit integer, and pass the base as 0. Thus, the valid string value should be in the following forms:
  • [+|-]0x[0-9|A-F]*
    Will be read in base 16.
  • [+|-]0[0-7]*
    Will be read in base 8.
  • [+|-][1-9][0-9]*
    Will be read in base 10.

See also:
GetDlgItemText, SetDlgItemInt

int GUIAPI GetDlgItemText | ( | HWND | hDlg,
 |  | int | nIDDlgItem,
 |  | char * | lpString,
 |  | int | nMaxCount
 | ) |  |

Retrieves the title or text associated with a control in a dialog box.

This function retrives the title or text associated with a control, whose identifier is nIDDlgItem in the dialog box hDlg.

Parameters:
hDlg | The handle to the dialog box.
nIDDlgItem | The identifier of the control.
lpString | The pointer to a buffer which receives the text.
nMaxCount | The maximal length of the string, not including the null character.
Returns:
The length of the null-terminated text.
Note:
The buffer should at least have size of (nMaxCount + 1).
See also:
GetDlgItemInt, GetDlgItemText2

char *GUIAPI GetDlgItemText2 | ( | HWND | hDlg,
 |  | int | id,
 |  | int * | lenPtr
 | ) |  |

Retrieves the title or text associated with a control in a dialog box.

This function is similiar as GetDlgItemText function, but it allocates memory for the text and returns the pointer to the allocated buffer. You should free the buffer when done by using free function.

Parameters:
hDlg | The handle to the dialog box.
id | The identifier of the control.
lenPtr | The pointer to an integer which receives the length of the text if it is not NULL.
Returns:
The pointer to the allocated buffer.
See also:
GetDlgItemText

HWND GUIAPI GetNextDlgGroupItem | ( | HWND | hDlg,
 |  | HWND | hCtl,
 |  | BOOL | bPrevious
 | ) |  |

Retrieves the handle to the first control in a group of controls that precedes (or follows) the specified control in a dialog box.

This function retrieves the handle to the first control in a group of controls that precedes (or follows) the specified control hCtl in the dialog box hDlg.

Parameters:
hDlg | The handle to the dialog box.
hCtl | The handle to the control.
bPrevious | A boolean value indicates to retrive the preceding or following control. TRUE for preceding control.
Returns:
The handle to the preceding or following control.
See also:
GetNextDlgTabItem

HWND GUIAPI GetNextDlgTabItem | ( | HWND | hDlg,
 |  | HWND | hCtl,
 |  | BOOL | bPrevious
 | ) |  |

Retrieves the handle to the first control that has the WS_TABSTOP style that precedes (or follows) the specified control.

This function retrieves the handle to the first control that has the WS_TABSTOP style that precedes (or follows) the specified control hCtl in the dialog box hDlg.

Parameters:
hDlg | The handle to the dialog box.
hCtl | The handle to the control.
bPrevious | A boolean value indicates to retrive the preceding or following control. TRUE for preceding control.
Returns:
The handle to the preceding or following control.
See also:
GetNextDlgGroupItem

int GUIAPI IsDlgButtonChecked | ( | HWND | hDlg,
 |  | int | idButton
 | ) |  |

Determines whether a button control has a check mark next to it or whether a three-state button control is grayed, checked, or neither.

This function determines whether the button control whose identifier is idButton has a check mark next to it or whether a three-state button control is grayed, checked, or neither.

Parameters:
hDlg | The handle to the dialog box.
idButton | The identifier of the button.
Returns:
The check state of the button. If the button is a normal button, the value being zero means the button is checked, otherwise unchecked. If the button is a special button with three states, the value can be one of the following values:
  • BST_UNCHECKED
    The button is unchecked.
  • BST_CHECKED
    The button is checked.
  • BST_INDETERMINATE
    The button is in indeterminate state.
See also:
CheckDlgButton

int GUIAPI SendDlgItemMessage | ( | HWND | hDlg,
 |  | int | nIDDlgItem,
 |  | int | message,
 |  | WPARAM | wParam,
 |  | LPARAM | lParam
 | ) |  |

Sends a message to the specified control in a dialog box.

This function sends a message specified by (message, wParam, lParam) to the specified control whose identifier is nIDDlgItem in the dialog box hDlg.

Parameters:
hDlg | The handle to the dialog box.
nIDDlgItem | The identifier of the control.
message | The message identifier.
wParam | The first message parameter.
lParam | The second message parameter.
Returns:
The return value of the message handler.
See also:
SendMessage, GetDlgItem

BOOL GUIAPI SetDlgItemInt | ( | HWND | hDlg,
 |  | int | nIDDlgItem,
 |  | UINT | uValue,
 |  | BOOL | bSigned
 | ) |  |

Sets the text of a control in a dialog box to the string representation of a specified integer value.

This function sets the text of the control whose identifier is nIDDlgItem in the dialog box hDlg to the string representation of the specified integer value nValue.

Parameters:
hDlg | The handle to the dialog box.
nIDDlgItem | The identifier of the control.
uValue | The 32-bit integer value.
bSigned | A boolean value indicates whether the integer value is a signed integer.
Returns:
TRUE on success, FALSE on error.
See also:
GetDlgItemInt, SetDlgItemText

BOOL GUIAPI SetDlgItemText | ( | HWND | hDlg,
 |  | int | nIDDlgItem,
 |  | const char * | lpString
 | ) |  |

Sets the title or text of a control in a dialog box.

This function sets the title or text of the control whose identifier is nIDDlgItem in the dialog box hDlg to the string pointed to by lpString.

Parameters:
hDlg | The handle to the dialog box.
nIDDlgItem | The identifier of the control.
lpString | The pointer to the string.
Returns:
TRUE on success, FALSE on error.
See also:
GetDlgItemText, SetDlgItemInt

Generated on Fri Dec 17 13:49:50 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _CTRLDATA Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_CTRLDATA Struct Reference
[Dialog operations]

#include <window.h>

Data Fields

  • const char * class_name
  • DWORD dwStyle
  • int x
  • int id
  • const char * caption
  • DWORD dwAddData
  • DWORD dwExStyle
  • const char * werdr_name
  • const WINDOW_ELEMENT_ATTR * we_attrs

Detailed Description

Structure which defines a control.

Definition at line 8679 of file window.h.

Field Documentation

const char* class_name

Class name of the control

Definition at line 8682 of file window.h.

The documentation for this struct was generated from the following file:
  • window.h
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _DLGTEMPLATE Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_DLGTEMPLATE Struct Reference
[Dialog operations]

#include <window.h>

Data Fields

  • DWORD dwStyle
  • DWORD dwExStyle
  • int x
  • const char * caption
  • HICON hIcon
  • HMENU hMenu
  • int controlnr
  • PCTRLDATA controls
  • DWORD dwAddData

Detailed Description

Structure which defines a dialogbox.

Example:

static DLGTEMPLATE DlgInitProgress =
{
    WS_BORDER | WS_CAPTION,
    WS_EX_NONE,
    120, 150, 400, 130,
    "VAM-CNC is initializing",
    0, 0,
    3, NULL,
    0
};

static CTRLDATA CtrlInitProgress [] =
{
    {
        "static",
        WS_VISIBLE | SS_SIMPLE,
        10, 10, 380, 16,
        IDC_PROMPTINFO,
        "Initialize...",
        0
    },
    {
        "progressbar",
        WS_VISIBLE,
        10, 40, 380, 20,
        IDC_PROGRESS,
        NULL,
        0
    },
    {
        "button",
        WS_TABSTOP | WS_VISIBLE | BS_DEFPUSHBUTTON,
        170, 70, 60, 25,
        IDOK,
        "OK",
        0
    }
};

Definition at line 8711 of file window.h.

Field Documentation

DWORD dwStyle

Dialog box style

Definition at line 8714 of file window.h.

The documentation for this struct was generated from the following file:
  • window.h
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Message box operations

Message box operations
[Window creating/destroying]

Functions

  • MG_EXPORT int GUIAPI MessageBox (HWND hParentWnd, const char *pszText, const char *pszCaption, DWORD dwStyle)
    Displays a message box within one, two, or three push buttons.
  • MG_EXPORT void GUIAPI MessageBeep (DWORD dwBeep)
    Makes a sound of beep.
  • MG_EXPORT int GUIAPI SetBitmapKeyColor (HDC hdc, PBITMAP bmp, Uint8 r, Uint8 g, Uint8 b)
    Set the bitmap color key.

Function Documentation

void GUIAPI MessageBeep ( DWORD dwBeep )

Makes a sound of beep.

This function makes a sound of beep. We ignore dwBeep argument so far.

Parameters:
dwBeep The beep type, ignored so far.
See also:
Beep, Ping, Tone

int GUIAPI MessageBox | ( | HWND | hParentWnd,
 |  | const char * | pszText,
 |  | const char * | pszCaption,
 |  | DWORD | dwStyle
 | ) |  |

Displays a message box within one, two, or three push buttons.

This function displays a message box within one, two, or three buttons, and returns the identifier of the button clicked by the user. You can pass dwStyle argument with different values to control the number of buttons, the button titles, and so on.

Parameters:
hParentWnd | The handle to the hosting main window.
pszText | The message text will be displayed in the message box.
pszCaption | The caption of the message box.
dwStyle | Specifies the contents and behavior of the dialog box. This parameter can be a combination of flags from the following groups of flags.
To indicate the buttons displayed in the message box, specify one of the following values.
  • MB_OK
    Create a message box within only one button whose title is "OK".
  • MB_OKCANCEL
    Create a message box within two buttons whose title are "OK" and "Cancel" respectively.
  • MB_YESNO
    Create a message box within two buttons whose title are "Yes" and "No" respectively.
  • MB_RETRYCANCEL
    Create a message box within two buttons whose title are "Retry" and "Cancel" respectively.
  • MB_ABORTRETRYIGNORE
    Create a message box within three buttons whose title are "Abort", "Retry" and "Ignore" respectively.
  • MB_YESNOCANCEL
    Create a message box within three buttons whose title are "Yes", "No" and "Cancel" respectively.
  • MB_CANCELASBACK
    Title "Cancel" replaced with title "Previous".

To display an icon in the message box, specify one of the following values.

  • MB_ICONHAND
    Display a hand/stop icon in the message box.
  • MB_ICONQUESTION
    Display a question mark icon in the message box.
  • MB_ICONEXCLAMATION
    Display a exclamation mark icon in the message box.
  • MB_ICONASTERISK
    Display an information icon in the message box.
  • MB_ICONINFORMATION
    Display an information icon in the message box.
  • MB_ICONSTOP
    Display a hand/stop icon in the message box.

To indicate the default button, specify one of the following values.

  • MB_DEFBUTTON1
    The first button is the default button.
  • MB_DEFBUTTON2
    The second button is the default button.
  • MB_DEFBUTTON3
    The third button is the default button.

To indicate the default text alignment, specify one of the following values.

  • MB_ALIGNCENTER
    The message box is center aligned.
  • MB_ALIGNTOPLEFT
    The message box is upper-left aligned.
  • MB_ALIGNBTMLEFT
    The message box is lower-left aligned.
  • MB_ALIGNTOPRIGHT
    The message box is upper-right aligned.
  • MB_ALIGNBTMRIGHT
    The message box is lower-right aligned.

To indicate the default align based on hosting window, specify the following value.

  • MB_BASEDONPARENT
    A flag indicates that the alignments above are based on the hosting window, not the desktop.

Returns:
The identifier of the button clicked by user, can be one of the following values:
  • IDOK
    The "OK" button clicked.
  • IDCANCEL
    The "Cancel" or "Previous" button clicked.
  • IDABORT
    The "Abort" button clicked.
  • IDRETRY
    The "Retry" button clicked.
  • IDIGNORE
    The "Ignore" button clicked.
  • IDYES
    The "Yes" button clicked.
  • IDNO
    The "No" button clicked.
Note:
This function will call GetSysText to translate the button titles to localized text.
See also:
GetSysText, DialogBoxIndirectParam

int GUIAPI SetBitmapKeyColor | ( | HDC | hdc,
 |  | PBITMAP | bmp,
 |  | Uint8 | r,
 |  | Uint8 | g,
 |  | Uint8 | b
 | ) |  |

Set the bitmap color key.

This function set the bitmap member bmColorKey with the param r,g,b and set the BMP_TYPE_COLORKEY flag.

Parameters:
hdc | The device context.
bmp | Point of the bitmap which to set color key.
r | The red componets of RGB color.
g | The green componets of RGB color.
b | The blue componets of RGB color.
Returns:
ERR_BMP_OK for success, ERR_BMP_UNKNOWN_TYPE for error.
/sa SetMemDCColorKey

Generated on Fri Dec 17 13:49:50 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Window creating/destroying

Window creating/destroying
[Windowing functions]

Modules

  • General window operations
  • System bitmap/icon operations
  • Scroll bar operations
  • Window class operations
  • Control creating/destroying
  • Timer operations
  • IME Window functions
  • Accelerator operations
  • Caret operations
  • Menu operations
  • Dialog operations
  • Message box operations

Data Structures

  • struct _MAINWINCREATE

Defines

  • #define HWND_DESKTOP __mg_hwnd_desktop
    Desktop window handle.
  • #define HWND_NULL 0
    Null window handle.
  • #define HWND_INVALID 0xFFFFFFFF
    Invalid window handle.
  • #define MainWindowCleanup(hwnd) MainWindowThreadCleanup(hwnd)
    Is an alias of MainWindowThreadCleanup.
  • #define DefaultMainWinProc (__mg_def_proc[0])
    Is the default main window callback procedure.
  • #define DefaultDialogProc (__mg_def_proc[1])
    The default dialog box procedure.
  • #define DefaultControlProc (__mg_def_proc[2])
    The default control callback procedure.

Typedefs

  • typedef int(* WNDPROC )(HWND, int, WPARAM, LPARAM)
    Type of the window callback procedure.

Functions

  • MG_EXPORT void GUIAPI MainWindowThreadCleanup (HWND hMainWnd)
    Cleans up system resource associated with a main window.
  • MG_EXPORT HWND GUIAPI CreateMainWindowEx (PMAINWINCREATE pCreateInfo, const char *werdr_name, const WINDOW_ELEMENT_ATTR *we_attrs, const char *window_name, const char *layer_name)
    Creates a main window.
  • static HWND GUIAPI CreateMainWindow (PMAINWINCREATE pCreateInfo)
    A simplified version of CreateMainWindowEx.
  • MG_EXPORT BOOL GUIAPI DestroyMainWindow (HWND hWnd)
    Destroys a main window.
  • MG_EXPORT BOOL GUIAPI SetWindowMask (HWND hWnd, const MYBITMAP *mask)
    Set window (a main window, or a child window which is also known as "control")'s Mask Rect with MYBITMAP data.
  • MG_EXPORT BOOL GUIAPI SetWindowMaskEx (HWND hWnd, HDC hdc, const BITMAP *mask)
    Set window (a main window, or a child window which is also known as "control")'s Mask Rect with BITMAP data,.
  • BOOL GUIAPI SetWindowRegion (HWND hWnd, const CLIPRGN *region)
    Set window's Mask Rect with CLIPRGN data.
  • MG_EXPORT int GUIAPI DefaultWindowProc (HWND hWnd, int message, WPARAM wParam, LPARAM lParam)
    The default window callback procedure.

Variables

  • MG_EXPORT WNDPROC __mg_def_proc [3]
    The default window callback procedure array.

Define Documentation

#define DefaultControlProc (__mg_def_proc[2])

The default control callback procedure.

This function is the default control callback procedure. You should call this function for all messages, you do not want to handle in your own control procedure.

Parameters:
hWnd | The handle to the window.
message | The message identifier.
wParam | The first parameter of the message.
lParam | The second parameter of the message.

Definition at line 5178 of file window.h.

#define DefaultDialogProc (__mg_def_proc[1])

The default dialog box procedure.

This function is the default dialog box procedure. You should call this function in your dialog box procedure to process the unhandled messages.

Parameters:
hWnd | The handle to the window.
message | The message identifier.
wParam | The first message parameter.
lParam | The second message parameter.
Returns:
The return value of the message handler.

Definition at line 5163 of file window.h.

#define DefaultMainWinProc (__mg_def_proc[0])

Is the default main window callback procedure.

This function is the default main window callback procedure. You should call this function for all messages, you do not want to handle in your main window procedure.

Parameters:
hWnd | The handle to the window.
message | The message identifier.
wParam | The first parameter of the message.
lParam | The second parameter of the message.

Definition at line 5145 of file window.h.

#define HWND_DESKTOP __mg_hwnd_desktop

Desktop window handle.

Definition at line 4864 of file window.h.

#define HWND_INVALID 0xFFFFFFFF

Invalid window handle.

Definition at line 4876 of file window.h.

#define HWND_NULL 0

Null window handle.

Definition at line 4870 of file window.h.

#define MainWindowCleanup ( hwnd ) MainWindowThreadCleanup(hwnd)

Is an alias of MainWindowThreadCleanup.

See also:
MainWindowThreadCleanup

Definition at line 4983 of file window.h.

Typedef Documentation

typedef int(* WNDPROC)(HWND, int, WPARAM, LPARAM)

Type of the window callback procedure.

Definition at line 4856 of file window.h.

Function Documentation

HWND GUIAPI CreateMainWindow ( PMAINWINCREATE pCreateInfo ) [inline, static]

A simplified version of CreateMainWindowEx.

This function creates a main window by calling CreateMainWindow function and passing NULL for werdr_name, we_attrs, window_name, and layer_name parameters.

See also:
CreateMainWindowEx

Definition at line 5024 of file window.h.

References CreateMainWindowEx(), and NULL.

HWND GUIAPI CreateMainWindowEx | ( | PMAINWINCREATE | pCreateInfo,
 |  | const char * | werdr_name,
 |  | const WINDOW_ELEMENT_ATTR * | we_attrs,
 |  | const char * | window_name,
 |  | const char * | layer_name
 | ) |  |

Creates a main window.

This function creates a main window by using some information, and returns the handle to the main window.

Parameters:
pCreateInfo | The pointer to a MAINWINCREATE structure.
werdr_name | The name of window element renderer. NULL for default renderer.
we_attrs | The pointer to window element attribute table. NULL for default window attribute table.
window_name | The window name; reserved for future use.
layer_name | The layer name; reserved for future use.
Returns:
The handle to the new main window; HWND_INVALID indicates an error.
See also:
CreateMainWindow, MAINWINCREATE, Window styles
Example:

/*
 * The following code initializes a MAINWINCREATE struct and then
 * creates a main window.
 */
{
    MAINWINCREATE CreateInfo;
    HWND hWnd;

    /* Initialize the MAINWINCREATE structure. */
    CreateInfo.dwStyle = WS_VISIBLE | WS_VSCROLL | WS_HSCROLL | WS_CAPTION;
    CreateInfo.spCaption= "MiniGUI step three";
    CreateInfo.dwExStyle = WS_EX_NONE;
    CreateInfo.hMenu = createmenu();
    CreateInfo.hCursor = GetSystemCursor(0);
    CreateInfo.hIcon = 0;
    CreateInfo.MainWindowProc = MainWinProc;
    CreateInfo.lx = 0;
    CreateInfo.ty = 0;
    CreateInfo.rx = 640;
    CreateInfo.by = 480;
    CreateInfo.iBkColor = COLOR_lightwhite;
    CreateInfo.dwAddData = 0;
    CreateInfo.hHosting = HWND_DESKTOP;

    /* Create the main window. */
    hWnd = CreateMainWindow(&CreateInfo);
    if (hWnd == HWND_INVALID)
        return 0;
}

Referenced by CreateMainWindow().

int DefaultWindowProc | ( | HWND | hWnd,
 |  | int | message,
 |  | WPARAM | wParam,
 |  | LPARAM | lParam
 | ) |  |

The default window callback procedure.

This window procedure can be used for main windows, dialog boxes, and child windows.

This function is the default window callback procedure. You should call this function for all messages you do not want to handle in your window procedure.

Parameters:
hWnd | The handle to the window.
message | The message identifier.
wParam | The first parameter of the message.
lParam | The second parameter of the message.

BOOL GUIAPI DestroyMainWindow ( HWND hWnd )

Destroys a main window.

This function destroys the main window specified by hWnd. It does not release all system resource used by the main window. You should call MainWindowThreadCleanup to destroy the main window actually.

Parameters:
hWnd The handle to the main window.
Returns:
TRUE on success, FALSE on error.
See also:
MainWindowThreadCleanup
Example:

/*
 * The following code destroies all resource used by the main window
 * and then destroies the main window itself.
 */
                case MSG_CLOSE:
                    /* Destroy the resource used by the main window. */
                    DestroyLogFont (logfont1);
                    DestroyLogFont (logfont2);
                    DestroyLogFont (logfont3);

                    /* Destroy the child windows. */
                    DestroyWindow(hWndButton);
                    DestroyWindow(hWndEdit);

                    /* Destroy the main window. */
                    DestroyMainWindow (hWnd);

                    /* Send a MSG_QUIT message to quit the message loop. */
                    PostQuitMessage(hWnd);
                    return 0;

void GUIAPI MainWindowThreadCleanup ( HWND hMainWnd )

Cleans up system resource associated with a main window.

This function cleans up the system resource such as message queue associated with the main window hMainWnd. DestroyMainWindow does not destroy all resource used by a main window, therefore, you should call this function after calling DestroyMainWindow and skipping out from the message loop. After calling this function, the main window object will destroyed actually.

Parameters:
hMainWnd The handle to the main window.
See also:
DestroyMainWindow

BOOL GUIAPI SetWindowMask | ( | HWND | hWnd,
 |  | const MYBITMAP * | mask
 | ) |  |

Set window (a main window, or a child window which is also known as "control")'s Mask Rect with MYBITMAP data.

Parameters:
hWnd | The handle to the window.
mask | The mask of the window which indicate the transparency of each pixel on this window.
Returns:
return TRUE on success, otherwise FALSE.
See also:
SetWindowRegion

BOOL GUIAPI SetWindowMaskEx | ( | HWND | hWnd,
 |  | HDC | hdc,
 |  | const BITMAP * | mask
 | ) |  |

Set window (a main window, or a child window which is also known as "control")'s Mask Rect with BITMAP data,.

Parameters:
hWnd | The handle to the window.
hdc | The reference dc which indicate the colorformat of the mask.
mask | The mask of the window which indicate the transparency of each pixel on this window.
Returns:
return TRUE on success, otherwise FALSE.
See also:
SetWindowRegion

BOOL GUIAPI SetWindowRegion | ( | HWND | hWnd,
 |  | const CLIPRGN * | region
 | ) |  |

Set window's Mask Rect with CLIPRGN data.

Parameters:
hWnd | The handle to the window.
region | The region to indicate which part of the window is visible.
Returns:
return TRUE on success, otherwise FALSE.

Variable Documentation

WNDPROC __mg_def_proc[3]

The default window callback procedure array.

Generated on Fri Dec 17 13:49:50 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _MAINWINCREATE Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_MAINWINCREATE Struct Reference
[Window creating/destroying]

#include <window.h>

Data Fields

  • DWORD dwStyle
  • DWORD dwExStyle
  • const char * spCaption
  • HMENU hMenu
  • HCURSOR hCursor
  • HICON hIcon
  • HWND hHosting
  • int(* MainWindowProc )(HWND, int, WPARAM, LPARAM)
  • int lx
  • int iBkColor
  • DWORD dwAddData
  • DWORD dwReserved

Detailed Description

Structure defines a main window.

Definition at line 4883 of file window.h.

Field Documentation

DWORD dwStyle

The style of the main window

Definition at line 4886 of file window.h.

The documentation for this struct was generated from the following file:
  • window.h
Generated on Fri Dec 17 13:49:52 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: General read/write operations

General read/write operations
[Global/general functions]

Data Structures

  • struct _MG_RWops

Defines

  • #define MGUI_RWseek(ctx, offset, whence) (ctx)->seek(ctx, offset, whence)
    Seeks an MG_RWops object.
  • #define MGUI_RWtell(ctx) (ctx)->seek(ctx, 0, SEEK_CUR)
    Obtains the current value of the position indicator for a data source.
  • #define MGUI_RWread(ctx, ptr, size, n) (ctx)->read(ctx, ptr, size, n)
    Reads data blocks from a data source.
  • #define MGUI_RWwrite(ctx, ptr, size, n) (ctx)->write(ctx, ptr, size, n)
    Writes data blocks to a data source.
  • #define MGUI_RWclose(ctx) (ctx)->close(ctx)
    Closes an MG_RWops object.
  • #define MGUI_RWeof(ctx) (ctx)->eof(ctx)
    Tests the end-of-file indicator for an data source.

Functions

  • MG_EXPORT MG_RWops * MGUI_RWFromFile (const char *file, const char *mode)
    Creates an MG_RWops object from a file.
  • MG_EXPORT MG_RWops * MGUI_RWFromFP (FILE *fp, int autoclose)
    Creates an MG_RWops object from an opened stdio FILE object.
  • MG_EXPORT MG_RWops * MGUI_RWFromMem (void *mem, int size)
    Creates an MG_RWops object from a block of memory.
  • MG_EXPORT void MGUI_InitMemRW (MG_RWops *area, void *mem, int size)
    Initializes an MG_RWops object from a block of memory.
  • MG_EXPORT MG_RWops * MGUI_AllocRW (void)
    Allocates an uninitialized MG_RWops object.
  • MG_EXPORT void MGUI_FreeRW (MG_RWops *area)
    Frees an MG_RWops object.
  • MG_EXPORT int MGUI_RWgetc (MG_RWops *area)
    Reads the next character from an data source.

Detailed Description

MiniGUI's general read/write operation provides a general interface to read from and write to various data source, such as files, memory, and so on.

Define Documentation

#define MGUI_RWclose ( ctx ) (ctx)->close(ctx)

Closes an MG_RWops object.

This macro close the MG_RWops object pointed to by ctx.

Parameters:
ctx The pointer to the MG_RWops object.
Returns:
Upon successful completion 0 is returned, otherwise non-zero on error.
See also:
MGUI_RWread

Definition at line 315 of file endianrw.h.

#define MGUI_RWeof ( ctx ) (ctx)->eof(ctx)

Tests the end-of-file indicator for an data source.

This macro tests the end-of-file indicator for the data source pointed to by ctx.

Parameters:
ctx The pointer to the MG_RWops object.
Returns:
Non-zero if end-of-file indicator is set.
See also:
MGUI_RWtell

Definition at line 330 of file endianrw.h.

#define MGUI_RWread | ( | ctx,
 |  | ptr,
 |  | size,
 |  | n | ) | (ctx)->read(ctx, ptr, size, n)

Reads data blocks from a data source.

This macro reads up to n objects each of size size from the data source ctx to the area pointed to by ptr.

Parameters:
ctx | The pointer to the MG_RWops object.
ptr | The buffer will save the data read.
size | The size of each object.
n | The number of objects to be read.
Returns:
The number of objects read, or -1 if the read failed.
See also:
MGUI_RWwrite

Definition at line 283 of file endianrw.h.

#define MGUI_RWseek | ( | ctx,
 |  | offset,
 |  | whence | ) | (ctx)->seek(ctx, offset, whence)

Seeks an MG_RWops object.

This macro seeks to offset relative to whence.

Parameters:
ctx | The pointer to the MG_RWops object.
offset | The offset relative to whence.
whence | One of stdio's whence values:
  • SEEK_SET
    the offset is relative to the start of the file.
  • SEEK_CUR
    the offset is relative to the current position indicator.
  • SEEK_END
    the offset is relative to the end of the file.

Returns:
The final offset in the data source.
See also:
MGUI_RWtell

Definition at line 251 of file endianrw.h.

#define MGUI_RWtell ( ctx ) (ctx)->seek(ctx, 0, SEEK_CUR)

Obtains the current value of the position indicator for a data source.

This macro obtains the current value of the position indicator for the data source pointed to by ctx.

Parameters:
ctx The pointer to the MG_RWops object.
Returns:
The current value of the position indicator.
See also:
MGUI_RWseek

Definition at line 266 of file endianrw.h.

#define MGUI_RWwrite | ( | ctx,
 |  | ptr,
 |  | size,
 |  | n | ) | (ctx)->write(ctx, ptr, size, n)

Writes data blocks to a data source.

This macro writes exactly n objects each of size size from the area pointed to by ptr to the data source ctx.

Parameters:
ctx | The pointer to the MG_RWops object.
ptr | The buffer contains the data to be written.
size | The size of each object.
n | The number of objects to be written.
Returns:
The number written, or -1 if the write failed.
See also:
MGUI_RWread

Definition at line 300 of file endianrw.h.

Function Documentation

MG_RWops * MGUI_AllocRW ( void )

Allocates an uninitialized MG_RWops object.

This function allocates an uninitialized MG_RWops object. You can specify the fields of the structure, and implemente a customized MG_RWops object.

Returns:
The pointer to allocated MG_RWops structure, NULL indicates error.
See also:
MG_RWops

void MGUI_FreeRW ( MG_RWops * area )

Frees an MG_RWops object.

This function frees the MG_RWops object pointed to by area.

Parameters:
area The pointer to the MG_RWops object.
See also:
MGUI_RWFromFile, MGUI_RWFromFP, MGUI_RWFromMem

void MGUI_InitMemRW | ( | MG_RWops * | area,
 |  | void * | mem,
 |  | int | size
 | ) |  |

Initializes an MG_RWops object from a block of memory.

This function initializes an MG_RWops object pointed to by area from a block of memory pointed to by mem, which is size bytes long.

Parameters:
area | The pointer to the MG_RWops object.
mem | The pointer to the memory block.
size | The size of the memory block.
Returns:
None.
See also:
MG_RWops, MGUI_FreeRW, MGUI_RWFromMem

MG_RWops * MGUI_RWFromFile | ( | const char * | file,
 |  | const char * | mode
 | ) |  |

Creates an MG_RWops object from a file.

This function uses the mode specified by mode and opens the file file by using stdio function fopen. If success, this function creates a MG_RWops object and returns it.

Parameters:
file | The file name.
mode | The mode will be passed to fopen.
Returns:
The pointer to created MG_RWops structure, NULL indicates error.
See also:
MG_RWops, MGUI_RWFromFP, MGUI_FreeRW, fopen(3)

MG_RWops * MGUI_RWFromFP | ( | FILE * | fp,
 |  | int | autoclose
 | ) |  |

Creates an MG_RWops object from an opened stdio FILE object.

This function uses an opened stdio FILE object fp to create a MG_RWops object.

Parameters:
fp | The opened stdio FILE object.
autoclose | Indicates whether to close the FILE object when close method is called.
Returns:
The pointer to created MG_RWops structure, NULL indicates error.
See also:
MG_RWops, MGUI_RWFromFile, MGUI_FreeRW

MG_RWops * MGUI_RWFromMem | ( | void * | mem,
 |  | int | size
 | ) |  |

Creates an MG_RWops object from a block of memory.

This function creates an MG_RWops object from a block of memory pointed to by mem, which is size bytes long.

Parameters:
mem | The pointer to the memory block.
size | The size of the memory block.
Returns:
The pointer to created MG_RWops structure, NULL indicates error.
See also:
MG_RWops, MGUI_FreeRW

int MGUI_RWgetc ( MG_RWops * area )

Reads the next character from an data source.

This function reads the next character from the data source pointed to by area, and returns it as an unsigned char cast to an int, or EOF on end of file or error.

Parameters:
area The pointer to the MG_RWops object.
Returns:
The character read, EOF indicates end-of-file or error.
See also:
MGUI_RWread

Generated on Fri Dec 17 13:49:47 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _MG_RWops Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_MG_RWops Struct Reference
[General read/write operations]

#include <endianrw.h>

Data Fields

  • int(* seek )(struct _MG_RWops *context, int offset, int whence)
  • int(* read )(struct _MG_RWops *context, void *ptr, int objsize, int num)
  • int(* write )(struct _MG_RWops *context, const void *ptr, int objsize, int num)
  • int(* close )(struct _MG_RWops *context)
  • int(* eof )(struct _MG_RWops *context)
  • Uint32 type

Detailed Description

The read/write operation structure.

Definition at line 74 of file endianrw.h.

Field Documentation

int(* seek)(struct _MG_RWops *context, int offset, int whence)

Seek to offset relative to whence, one of stdio's whence values:
SEEK_SET, SEEK_CUR, SEEK_END
Returns the final offset in the data source.

int(* read)(struct _MG_RWops *context, void *ptr, int objsize, int num)

Read up to num objects each of size objsize from the data source to the area pointed at by ptr. Returns the number of objects read, or -1 if the read failed.

int(* write)(struct _MG_RWops *context, const void *ptr, int objsize, int num)

Write exactly num objects each of size objsize from the area pointed at by ptr to data source. Returns num, or -1 if the write failed.

int(* close)(struct _MG_RWops *context)

Close and free an allocated MG_RWops structure.

int(* eof)(struct _MG_RWops *context)

Test the end-of-file indicator.

Uint32 type

Indicates the type of data source. can be one of the following values:

  • RWAREA_TYPE_UNKNOWN
    A unknown (uninitialized) data source type.
  • RWAREA_TYPE_STDIO
    Stdio stream data source.
  • RWAREA_TYPE_MEM
    Memory data source.

Definition at line 122 of file endianrw.h.

The documentation for this struct was generated from the following file:
  • endianrw.h
Generated on Fri Dec 17 13:49:52 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Endian specific read/write interfaces

Endian specific read/write interfaces
[Global/general functions]

Defines

  • #define ArchSwapLE16(X) (X)
  • #define ArchSwapLE32(X) (X)
  • #define ArchSwapLE64(X) (X)
  • #define ArchSwapBE16(X) ArchSwap16(X)
  • #define ArchSwapBE32(X) ArchSwap32(X)
  • #define ArchSwapBE64(X) ArchSwap64(X)

Functions

  • Uint16 MGUI_ReadLE16 (MG_RWops *src)
    Reads a 16-bit little endian integer from a MG_RWops object.
  • Uint16 MGUI_ReadBE16 (MG_RWops *src)
    Reads a 16-bit big endian integer from a MG_RWops object.
  • Uint32 MGUI_ReadLE32 (MG_RWops *src)
    Reads a 32-bit little endian integer from a MG_RWops object.
  • Uint32 MGUI_ReadBE32 (MG_RWops *src)
    Reads a 32-bit big endian integer from a MG_RWops object.
  • Uint64 MGUI_ReadLE64 (MG_RWops *src)
    Reads a 64-bit little endian integer from a MG_RWops object.
  • Uint64 MGUI_ReadBE64 (MG_RWops *src)
    Reads a 64-bit big endian integer from a MG_RWops object.
  • int MGUI_WriteLE16 (MG_RWops *dst, Uint16 value)
    Writes an 16-bit integer of native format to a MG_RWops object in littlen endianness.
  • int MGUI_WriteBE16 (MG_RWops *dst, Uint16 value)
    Writes an 16-bit integer of native format to a MG_RWops object in big endianness.
  • int MGUI_WriteLE32 (MG_RWops *dst, Uint32 value)
    Writes an 32-bit integer of native format to a MG_RWops object in littlen endianness.
  • int MGUI_WriteBE32 (MG_RWops *dst, Uint32 value)
    Writes an 32-bit integer of native format to a MG_RWops object in big endianness.
  • int MGUI_WriteLE64 (MG_RWops *dst, Uint64 value)
    Writes an 64-bit integer of native format to a MG_RWops object in littlen endianness.
  • int MGUI_WriteBE64 (MG_RWops *dst, Uint64 value)
    Writes an 64-bit integer of native format to a MG_RWops object in big endianness.
  • Uint16 MGUI_ReadLE16FP (FILE *src)
    Reads a 16-bit little endian integer from a stdio FILE object.
  • Uint32 MGUI_ReadLE32FP (FILE *src)
    Reads a 32-bit little endian integer from a stdio FILE object.
  • int MGUI_WriteLE16FP (FILE *dst, Uint16 value)
    Writes an 16-bit integer of native format to a stdio FILE object in littlen endianness.
  • int MGUI_WriteLE32FP (FILE *dst, Uint32 value)
    Writes an 32-bit integer of native format to a stdio FILE object in littlen endianness.

Detailed Description

The endian specific read/write functions read and write data of the specified endianness, dynamically translating to the host machine endianness.

e.g.: If you want to read a 16 bit value on big-endian machine from an opened file containing little endian values, you would use:

  value = MGUI_ReadLE16(rp);

See also:
General read/write operations
Example:

    int fd, len_header;

...

    if (read (fd, &len_header, sizeof (int)) == -1)
        goto error;
#if MGUI_BYTEORDER == MGUI_BIG_ENDIAN
    /* If the native system is big endian, calling ArchSwap32 to
     * swap the bytes.
     */
    len_header = ArchSwap32 (len_header);
#endif

...

Define Documentation

#define ArchSwapBE16 ( X ) ArchSwap16(X)

Swaps a 16-bit big endian integer to the native endianness.

Definition at line 435 of file endianrw.h.

#define ArchSwapBE32 ( X ) ArchSwap32(X)

Swaps a 32-bit big endian integer to the native endianness.

Definition at line 437 of file endianrw.h.

#define ArchSwapBE64 ( X ) ArchSwap64(X)

Swaps a 64-bit big endian integer to the native endianness.

Definition at line 439 of file endianrw.h.

#define ArchSwapLE16 ( X ) (X)

Swaps a 16-bit little endian integer to the native endianness.

Definition at line 429 of file endianrw.h.

#define ArchSwapLE32 ( X ) (X)

Swaps a 32-bit little endian integer to the native endianness.

Definition at line 431 of file endianrw.h.

#define ArchSwapLE64 ( X ) (X)

Swaps a 64-bit little endian integer to the native endianness.

Definition at line 433 of file endianrw.h.

Function Documentation

Uint16 MGUI_ReadBE16 ( MG_RWops * src )

Reads a 16-bit big endian integer from a MG_RWops object.

This function reads a 16-bit big endian integer from the data source pointed to by src, and return it in native format.

Parameters:
src The pointer to the MG_RWops object.
Returns:
The integer in native endianness.
See also:
MGUI_WriteBE16

Uint32 MGUI_ReadBE32 ( MG_RWops * src )

Reads a 32-bit big endian integer from a MG_RWops object.

This function reads a 32-bit big endian integer from the data source pointed to by src, and return it in native format.

Parameters:
src The pointer to the MG_RWops object.
Returns:
The integer in native endianness.
See also:
MGUI_WriteBE32

Uint64 MGUI_ReadBE64 ( MG_RWops * src )

Reads a 64-bit big endian integer from a MG_RWops object.

This function reads a 64-bit big endian integer from the data source pointed to by src, and return it in native format.

Parameters:
src The pointer to the MG_RWops object.
Returns:
The integer in native endianness.
See also:
MGUI_WriteBE64

Uint16 MGUI_ReadLE16 ( MG_RWops * src )

Reads a 16-bit little endian integer from a MG_RWops object.

This function reads a 16-bit little endian integer from the data source pointed to by src, and return it in native format.

Parameters:
src The pointer to the MG_RWops object.
Returns:
The integer in native endianness.
See also:
MGUI_WriteLE16

Uint16 MGUI_ReadLE16FP ( FILE * src )

Reads a 16-bit little endian integer from a stdio FILE object.

This function reads a 16-bit little endian integer from the stdio FILE object pointed to by src, and return it in native format.

Parameters:
src The pointer to the stdio FILE object.
Returns:
The integer in native endianness.
See also:
MGUI_WriteLE16FP, MGUI_ReadLE16

Uint32 MGUI_ReadLE32 ( MG_RWops * src )

Reads a 32-bit little endian integer from a MG_RWops object.

This function reads a 32-bit little endian integer from the data source pointed to by src, and return it in native format.

Parameters:
src The pointer to the MG_RWops object.
Returns:
The integer in native endianness.
See also:
MGUI_WriteLE32

Uint32 MGUI_ReadLE32FP ( FILE * src )

Reads a 32-bit little endian integer from a stdio FILE object.

This function reads a 32-bit little endian integer from the stdio FILE object pointed to by src, and return it in native format.

Parameters:
src The pointer to the stdio FILE object.
Returns:
The integer in native endianness.
See also:
MGUI_WriteLE32FP, MGUI_ReadLE32

Uint64 MGUI_ReadLE64 ( MG_RWops * src )

Reads a 64-bit little endian integer from a MG_RWops object.

This function reads a 64-bit little endian integer from the data source pointed to by src, and return it in native format.

Parameters:
src The pointer to the MG_RWops object.
Returns:
The integer in native endianness.
See also:
MGUI_WriteLE64

int MGUI_WriteBE16 | ( | MG_RWops * | src,
 |  | Uint16 | value
 | ) |  |

Writes an 16-bit integer of native format to a MG_RWops object in big endianness.

This function writes a 16-bit integer of native format to the data source pointed to by src in big endiannes.

Parameters:
src | The pointer to the MG_RWops object.
value | The 16-bit integer in native endianness.
Returns:
Returns 1 on success, else indicates an error.
See also:
MGUI_ReadLE16

int MGUI_WriteBE32 | ( | MG_RWops * | src,
 |  | Uint32 | value
 | ) |  |

Writes an 32-bit integer of native format to a MG_RWops object in big endianness.

This function writes a 32-bit integer of native format to the data source pointed to by src in big endiannes.

Parameters:
src | The pointer to the MG_RWops object.
value | The 32-bit integer in native endianness.
Returns:
Returns 1 on success, else indicates an error.
See also:
MGUI_ReadLE32

int MGUI_WriteBE64 | ( | MG_RWops * | src,
 |  | Uint64 | value
 | ) |  |

Writes an 64-bit integer of native format to a MG_RWops object in big endianness.

This function writes a 64-bit integer of native format to the data source pointed to by src in big endiannes.

Parameters:
src | The pointer to the MG_RWops object.
value | The 64-bit integer in native endianness.
Returns:
Returns 1 on success, else indicates an error.
See also:
MGUI_ReadLE64

int MGUI_WriteLE16 | ( | MG_RWops * | src,
 |  | Uint16 | value
 | ) |  |

Writes an 16-bit integer of native format to a MG_RWops object in littlen endianness.

This function writes a 16-bit integer of native format to the data source pointed to by src in littlen endiannes.

Parameters:
src | The pointer to the MG_RWops object.
value | The 16-bit integer in native endianness.
Returns:
Returns 1 on success, else indicates an error.
See also:
MGUI_ReadLE16

int MGUI_WriteLE16FP | ( | FILE * | dst,
 |  | Uint16 | value
 | ) |  |

Writes an 16-bit integer of native format to a stdio FILE object in littlen endianness.

This function writes a 16-bit integer of native format to the stdio FILE object pointed to by src in littlen endiannes.

Parameters:
dst | The pointer to the MG_RWops object.
value | The 16-bit integer in native endianness.
Returns:
Returns 1 on success, else indicates an error.
See also:
MGUI_ReadLE16FP, MGUI_WriteLE16

int MGUI_WriteLE32 | ( | MG_RWops * | src,
 |  | Uint32 | value
 | ) |  |

Writes an 32-bit integer of native format to a MG_RWops object in littlen endianness.

This function writes a 32-bit integer of native format to the data source pointed to by src in littlen endiannes.

Parameters:
src | The pointer to the MG_RWops object.
value | The 32-bit integer in native endianness.
Returns:
Returns 1 on success, else indicates an error.
See also:
MGUI_ReadLE32

int MGUI_WriteLE32FP | ( | FILE * | dst,
 |  | Uint32 | value
 | ) |  |

Writes an 32-bit integer of native format to a stdio FILE object in littlen endianness.

This function writes a 32-bit integer of native format to the stdio FILE object pointed to by src in littlen endiannes.

Parameters:
dst | The pointer to the MG_RWops object.
value | The 32-bit integer in native endianness.
Returns:
Returns 1 on success, else indicates an error.
See also:
MGUI_ReadLE32FP, MGUI_WriteLE32

int MGUI_WriteLE64 | ( | MG_RWops * | src,
 |  | Uint64 | value
 | ) |  |

Writes an 64-bit integer of native format to a MG_RWops object in littlen endianness.

This function writes a 64-bit integer of native format to the data source pointed to by src in littlen endiannes.

Parameters:
src | The pointer to the MG_RWops object.
value | The 64-bit integer in native endianness.
Returns:
Returns 1 on success, else indicates an error.
See also:
MGUI_ReadLE64

Generated on Fri Dec 17 13:49:47 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Fixed point math functions

Fixed point math functions
[Global/general functions]

Functions

  • MG_EXPORT fixed fixsqrt (fixed x)
    Returns the non-negative square root of a fixed point value.
  • MG_EXPORT fixed fixhypot (fixed x, fixed y)
    Returns the Euclidean distance from the origin.
  • MG_EXPORT fixed fixatan (fixed x)
    Calculates the arc tangent of a fixed point value.
  • MG_EXPORT fixed fixatan2 (fixed y, fixed x)
    Calculates the arc tangent of two fixed point variables.
  • static fixed ftofix (double x)
    Converts a float point value to a fixed point value.
  • static double fixtof (fixed x)
    Converts a fixed point value to a float point value.
  • static fixed fixadd (fixed x, fixed y)
    Returns the sum of two fixed point values.
  • static fixed fixsub (fixed x, fixed y)
    Subtract a fixed point value from another.
  • MG_EXPORT fixed fixmul (fixed x, fixed y)
    Returns the product of two fixed point values.
  • MG_EXPORT fixed fixdiv (fixed x, fixed y)
    Returns the quotient of two fixed point values.
  • static int fixceil (fixed x)
    Rounds a fixed point value to the nearest integer.
  • static fixed itofix (int x)
    Converts an integer to a fixed point value.
  • static int fixtoi (fixed x)
    Converts an fixed point value to an integer.
  • static fixed fixcos (fixed x)
    Returns the cosine of a fixed point.
  • static fixed fixsin (fixed x)
    Returns the sine of a fixed point.
  • static fixed fixtan (fixed x)
    Returns the tangent of a fixed point.
  • static fixed fixacos (fixed x)
    Calculates and returns the arc cosine of a fixed point.
  • static fixed fixasin (fixed x)
    Calculates and returns the arc sine of a fixed point.

Detailed Description

You know that the float point mathematics routines are very expensive. If you do not want precision mathematics result, you can use fixed point. MiniGUI uses a double word (32-bit) integer to represent a fixed point ranged from -32767.0 to 32767.0, and defines some fixed point mathematics routines for your application. Some GDI functions need fixed point math routines, like Arc.

Example 1:

    /* Draw an arc from 0 radians to 1 radians */
    Arc (hdc, 100, 100, 100, 0, itofix (1));

    /* Draw an arc from 0.5 radians to 1.5 radians */
    fixed radian1 = itofix (1);
    fixed radian2 = itofix (2);
    fixed radian05 = fixdiv (radian1, radian2);
    fixed radian15 = fixdiv (fadd (radian1, randian2), radian2);

    Arc (hdc, 100, 100, 100, radian05, radian15);

Example 2:

void draw_arc (HDC hdc, POINT* pts)
{
            int sx = pts [0].x, sy = pts [0].y;
            int dx = pts [1].x - sx, dy = pts [1].y - sy;
            int r = sqrt (dx * dx * 1.0 + dy * dy * 1.0);
            double cos_d = dx * 1.0 / r;
            fixed cos_f = ftofix (cos_d);
            fixed ang1 = fixacos (cos_f);
            int r2;
            fixed ang2;

            if (dy > 0) {
                ang1 = fixsub (0, ang1);
            }

            dx = pts [2].x - sx;
            dy = pts [2].y - sy;
            r2 = sqrt (dx * dx * 1.0 + dy * dy * 1.0);
            cos_d = dx * 1.0 / r2;
            cos_f = ftofix (cos_d);
            ang2 = fixacos (cos_f);
            if (dy > 0) {
                ang2 = fixsub (0, ang2);
            }

            Arc (hdc, sx, sy, r, ang1, ang2);
}

Function Documentation

fixed fixacos ( fixed x ) [inline, static]

Calculates and returns the arc cosine of a fixed point.

This function calculates the arc cosine of the fixed point x; that is the value whose cosine is x. If x falls outside the range -1 to 1, this function fails and errno is set to EDOM.

Returns:
Returns the arc cosine in radians and the value is mathematically defined to be between 0 and PI (inclusive).
See also:
fixcos

Definition at line 390 of file fixedmath.h.

fixed fixadd | ( | fixed | x,
 |  | fixed | y |
 | ) |  |  | [inline, static]

Returns the sum of two fixed point values.

This function adds two fixed point values x and y, and returns the sum.

Parameters:
x | x,y: Two addends.
y | x,y: Two addends.
Returns:
The sum. If the result runs out of range of fixed point, this function sets errno to ERANGE.
See also:
fixsub

Definition at line 196 of file fixedmath.h.

fixed fixasin ( fixed x ) [inline, static]

Calculates and returns the arc sine of a fixed point.

This function calculates the arc sine of the fixed point x; that is the value whose sine is x. If x falls outside the range -1 to 1, this function fails and errno is set to EDOM.

Returns:
Returns the arc sine in radians and the value is mathematically defined to be between -PI/2 and PI/2 (inclusive).
See also:
fixsin

Definition at line 413 of file fixedmath.h.

fixed fixatan ( fixed x )

Calculates the arc tangent of a fixed point value.

This function calculates the arc tangent of x; that is the value whose tangent is x.

Returns:
Returns the arc tangent in radians and the value is mathematically defined to be between -PI/2 and PI/2 (inclusive).
See also:
fixatan2

fixed fixatan2 | ( | fixed | y,
 |  | fixed | x
 | ) |  |

Calculates the arc tangent of two fixed point variables.

This function calculates the arc tangent of the two variables x and y. It is similar to calculating the arc tangent of y / x, except that the signs of both arguments are used to determine the quadrant of the result.

Returns:
Returns the result in radians, which is between -PI and PI (inclusive).
See also:
fixatan

int fixceil ( fixed x ) [inline, static]

Rounds a fixed point value to the nearest integer.

This function rounds the fixed point value x to the nearest integer and returns it.

Returns:
The rounded integer value.

Definition at line 295 of file fixedmath.h.

fixed fixcos ( fixed x ) [inline, static]

Returns the cosine of a fixed point.

This function returns the cosine of the fixed point x, where x is given in radians.

See also:
fixacos

Definition at line 344 of file fixedmath.h.

fixed fixdiv | ( | fixed | x,
 |  | fixed | y
 | ) |  |

Returns the quotient of two fixed point values.

This function returns the quotient of two fixed point values x and y.

Parameters:
x | The dividend.
y | The divisor.
Returns:
The quotient. If the result runs out of range of fixed point, this function sets errno to ERANGE.
See also:
fixmul

fixed fixhypot | ( | fixed | x,
 |  | fixed | y
 | ) |  |

Returns the Euclidean distance from the origin.

The function returns the sqrt(x*x+y*y). This is the length of the hypotenuse of a right-angle triangle with sides of length x and y, or the distance of the point (x,y) from the origin.

See also:
fixsqrt

fixed fixmul | ( | fixed | x,
 |  | fixed | y
 | ) |  |

Returns the product of two fixed point values.

This function returns the product of two fixed point values x and y.

Parameters:
x | The faciend.
y | The multiplicato.
Returns:
The prodcut. If the result runs out of range of fixed point, this function sets errno to ERANGE.
See also:
fixdiv

fixed fixsin ( fixed x ) [inline, static]

Returns the sine of a fixed point.

This function returns the sine of the fixed point x, where x is given in radians.

See also:
fixasin

Definition at line 358 of file fixedmath.h.

fixed fixsqrt ( fixed x )

Returns the non-negative square root of a fixed point value.

This function returns the non-negative square root of x. It fails and sets errno to EDOM, if x is negative.

See also:
fixhypot

fixed fixsub | ( | fixed | x,
 |  | fixed | y |
 | ) |  |  | [inline, static]

Subtract a fixed point value from another.

This function subtracts the fixed point values y from the fixed point value x, and returns the difference.

Parameters:
x | The minuend.
y | The subtrahend.
Returns:
The difference. If the result runs out of range of fixed point, this function sets errno to ERANGE.
See also:
fixadd

Definition at line 233 of file fixedmath.h.

fixed fixtan ( fixed x ) [inline, static]

Returns the tangent of a fixed point.

This function returns the tangent of the fixed point x, where x is given in radians.

See also:
fixcos, fixsin

Definition at line 372 of file fixedmath.h.

double fixtof ( fixed x ) [inline, static]

Converts a fixed point value to a float point value.

This function converts the specified fixed point value x to a float point value.

See also:
ftofix

Definition at line 176 of file fixedmath.h.

int fixtoi ( fixed x ) [inline, static]

Converts an fixed point value to an integer.

This function converts the fixed point x to an integer.

See also:
itofix

Definition at line 330 of file fixedmath.h.

fixed ftofix ( double x ) [inline, static]

Converts a float point value to a fixed point value.

This function converts the specified float point value x to a fixed point value.

Note:
The float point should be ranged from -32767.0 to 32767.0. If it runs out of the range, this function sets errno to ERANGE.
See also:
fixtof

Definition at line 152 of file fixedmath.h.

fixed itofix ( int x ) [inline, static]

Converts an integer to a fixed point value.

This function converts the integer x to a fixed point value.

See also:
fixtoi

Definition at line 317 of file fixedmath.h.

Generated on Fri Dec 17 13:49:47 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Block data heap operations

Block data heap operations
[Global/general functions]

Data Structures

  • struct _BLOCKHEAP

Typedefs

  • typedef BLOCKHEAP * PBLOCKHEAP
    Data type of the pointer to a BLOCKHEAP.

Functions

  • MG_EXPORT void InitBlockDataHeap (PBLOCKHEAP heap, size_t bd_size, size_t heap_size)
    Initializes a private block data heap.
  • MG_EXPORT void * BlockDataAlloc (PBLOCKHEAP heap)
    Allocates a data block from private heap.
  • MG_EXPORT void BlockDataFree (PBLOCKHEAP heap, void *data)
    Frees an allocated data block.
  • MG_EXPORT void DestroyBlockDataHeap (PBLOCKHEAP heap)
    Destroys a private block data heap.

Detailed Description

MiniGUI maintains some private block data heaps to allocate data blocks which have fixed size, such as the clipping rectangles in a region. By using the private heap, we can avoiding calling malloc and free function frequently, so will have a slight performance enhancement.

Typedef Documentation

typedef BLOCKHEAP * PBLOCKHEAP

Data type of the pointer to a BLOCKHEAP.

See also:
BLOCKHEAP

Definition at line 400 of file gdi.h.

Function Documentation

void * BlockDataAlloc ( PBLOCKHEAP heap )

Allocates a data block from private heap.

This function allocates a data block from an initialized block data heap. The allocated block will have the size of heap->bd_size. If there is no free block in the heap, this function will try to allocate the block from the system heap by using malloc(3) function.

Parameters:
heap The pointer to the initialized heap.
Returns:
Pointer to the allocated data block, NULL on error.
See also:
InitBlockDataHeap, BlockDataFree

void BlockDataFree | ( | PBLOCKHEAP | heap,
 |  | void * | data
 | ) |  |

Frees an allocated data block.

This function frees the specified data block pointed to by data to the heap heap. If the block was allocated by using malloc function, this function will free the element by using free(3) function.

Parameters:
heap | The pointer to the heap.
data | The pointer to the element to be freed.
See also:
InitBlockDataHeap, BlockDataAlloc

void DestroyBlockDataHeap ( PBLOCKHEAP heap )

Destroys a private block data heap.

Parameters:
heap The pointer to the heap to be destroied.
See also:
InitBlockDataHeap, BLOCKHEAP

void InitBlockDataHeap | ( | PBLOCKHEAP | heap,
 |  | size_t | bd_size,
 |  | size_t | heap_size
 | ) |  |

Initializes a private block data heap.

This function initializes a block data heap pointed to by heap. It will allocate the buffer used by the heap from system heap by using malloc(3). Initially, the heap has heap_size blocks free, and each is bd_size bytes long.

Parameters:
heap | The pointer to the heap structure.
bd_size | The size of one block in bytes.
heap_size | The size of the heap in blocks.
Returns:
heap->heap will contains a valid pointer on success, NULL on error.
Note:
This function does not return anything. You should check the heap field of the heap structure.
See also:
BLOCKHEAP

Generated on Fri Dec 17 13:49:47 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _BLOCKHEAP Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_BLOCKHEAP Struct Reference
[Block data heap operations]

#include <gdi.h>

Data Fields

  • size_t bd_size
  • size_t heap_size
  • int free
  • void * heap

Detailed Description

MiniGUI's private block data heap.

See also:
InitBlockDataHeap, DestroyBlockDataHeap

Definition at line 371 of file gdi.h.

Field Documentation

size_t bd_size

Size of one block element.

Definition at line 379 of file gdi.h.

size_t heap_size

Size of the heap in blocks.

Definition at line 383 of file gdi.h.

int free

The first free element in the heap.

Definition at line 387 of file gdi.h.

void* heap

Pointer to the pre-allocated heap.

Definition at line 391 of file gdi.h.

The documentation for this struct was generated from the following file:
  • gdi.h
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Listening a file descriptor

Listening a file descriptor
[MiniGUI-Processes specific functions]

Defines

  • #define MAX_NR_LISTEN_FD 5
    The max number of listen fd which user can use.

Functions

  • MG_EXPORT BOOL GUIAPI RegisterListenFD (int fd, int type, HWND hwnd, void *context)
    Registers a listening file descriptor to MiniGUI-Lite.
  • MG_EXPORT BOOL GUIAPI UnregisterListenFD (int fd)
    Unregisters a being listened file descriptor.

Detailed Description

Register/Unregister a listen fd to MiniGUI.

When you need to listen a file descriptor, you can use select(2) system call. In MiniGUI, you can also register it to MiniGUI to be a listened fd, and when there is a read/write/except event on the registered fd , MiniGUI will sent a notification message to the registered window.

Example:

    ...

    /* Register to listen the read event of the master pty. */
    RegisterListenFD (pConInfo->masterPty, POLLIN, hMainWnd, 0);

    /* Enter the message loop. */
    while (!pConInfo->terminate && GetMessage (&Msg, hMainWnd)) {
        DispatchMessage (&Msg);
    }
    /* Unregister the listening fd. */
    UnregisterListenFD (pConInfo->masterPty);

    ...

/* The window procedure. */
static int VCOnGUIMainWinProc (HWND hWnd, int message, WPARAM wParam, LPARAM lParam)
{
    PCONINFO pConInfo;

    pConInfo = (PCONINFO)GetWindowAdditionalData (hWnd);
    switch (message) {

         ...

        /* MSG_FDEVENT sent by MiniGUI indicates that you should to read the data. */
        case MSG_FDEVENT:
            ReadMasterPty (pConInfo);
        break;

        ...
    }

    /* Calling default window procedure. */
    if (pConInfo->DefWinProc)
        return (*pConInfo->DefWinProc)(hWnd, message, wParam, lParam);
    else
        return DefaultMainWinProc (hWnd, message, wParam, lParam);
}

Define Documentation

#define MAX_NR_LISTEN_FD 5

The max number of listen fd which user can use.

Definition at line 303 of file minigui.h.

Function Documentation

BOOL GUIAPI RegisterListenFD | ( | int | fd,
 |  | int | type,
 |  | HWND | hwnd,
 |  | void * | context
 | ) |  |

Registers a listening file descriptor to MiniGUI-Lite.

This function registers the file desciptor fd to MiniGUI-Lite for listening.

When there is a read/write/except event on this fd, MiniGUI will post a MSG_FDEVENT message with wParam being equal to MAKELONG (fd, type), and the lParam being set to context to the target window hwnd.

Parameters:
fd | The file descriptor to be listened.
type | The type of the event to be listened, can be POLLIN, POLLOUT, or POLLERR.
hwnd | The handle to the window will receive MSG_FDEVENT message.
context | The value will be passed to the window as lParam of MSG_FDEVENT message.
Returns:
TRUE if all OK, and FALSE on error.
Note:
Only available on MiniGUI-Processes.
See also:
UnregisterListenFD, System messages

BOOL GUIAPI UnregisterListenFD ( int fd )

Unregisters a being listened file descriptor.

This function unregisters the being listened file descriptor fd.

Parameters:
fd The file descriptor to be unregistered, should be a being listened file descriptor.
Returns:
TRUE if all OK, and FALSE on error.
Note:
Only available on MiniGUI-Processes.
See also:
RegisterListenFD

Generated on Fri Dec 17 13:49:48 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Initialization and termination functions

Initialization and termination functions
[MiniGUI-Processes specific functions]

Data Structures

  • struct _DESKTOPOPS

Defines

  • #define ReinitDesktop() ReinitDesktopEx (TRUE)
    Re-initializes the desktop including the local system text.
  • #define MiniGUIMain
    The main entry of a MiniGUI application.
  • #define IDM_DTI_FIRST (300)
    The minimum interger value of command ID when user customize desktop menu.

Functions

  • MG_EXPORT BOOL GUIAPI ReinitDesktopEx (BOOL init_sys_text)
    Re-initializes the desktop.
  • MG_EXPORT void GUIAPI ExitGUISafely (int exitcode)
    Exits your MiniGUI application safely.
  • MG_EXPORT DESKTOPOPS *GUIAPI SetCustomDesktopOperationSet (DESKTOPOPS *usr_dsk_ops)
    Set customer desktop operation set.
  • MG_EXPORT void GUIAPI DesktopUpdateAllWindow (void)
    Update all visible windows on the desktop.

Detailed Description

Normally, the only entry of any MiniGUI application is MiniGUIMain. The application will terminate when you call exit(3) or just return from MiniGUIMain.

Example 1:

/*
 * This program parses the command line arguments.
 * If the user specified a layer name by using "-layer <layer_name",
 * the program will try to join the layer, otherwise create a new layer.
 */
int MiniGUIMain (int args, const char* arg[])
{
#ifdef _MGRM_PROCESSES
    int i;
    const char* layer = NULL;

    for (i = 1; i < args; i++) {
        if (strcmp (arg[i], "-layer") == 0) {
            layer = arg[i + 1];
            break;
        }
    }

    if (GetLayerInfo (layer, NULL, NULL, NULL) == INV_LAYER_HANDLE) {
        printf ("GetLayerInfo: the requested layer does not exist.\n");
    }

    if (JoinLayer (layer, arg[0], 0, 0) == INV_LAYER_HANDLE) {
        printf ("JoinLayer: invalid layer handle.\n");
        exit (1);
    }
#endif

    ...

    return 0;
}

Example 2:

/*
 * This is a every simple sample for MiniGUI.
 * It will create a main window and display a string of "Hello, world!" in it.
 */
#include <stdio.h>
#include <stdlib.h>
#include <string.h>

#include <minigui/common.h>
#include <minigui/minigui.h>
#include <minigui/gdi.h>
#include <minigui/window.h>

static int HelloWinProc (HWND hWnd, int message, WPARAM wParam, LPARAM lParam)
{
    HDC hdc;

    switch (message) {
        case MSG_PAINT:
            hdc = BeginPaint (hWnd);
            TextOut (hdc, 0, 0, "Hello, world!");
            EndPaint (hWnd, hdc);
        break;

        case MSG_CLOSE:
            DestroyMainWindow (hWnd);
            PostQuitMessage (hWnd);
        return 0;
    }

    return DefaultMainWinProc(hWnd, message, wParam, lParam);
}

static void InitCreateInfo (PMAINWINCREATE pCreateInfo)
{
    pCreateInfo->dwStyle = WS_CAPTION | WS_VISIBLE;
    pCreateInfo->dwExStyle = 0;
    pCreateInfo->spCaption = "Hello, world!" ;
    pCreateInfo->hMenu = 0;
    pCreateInfo->hCursor = GetSystemCursor (0);
    pCreateInfo->hIcon = 0;
    pCreateInfo->MainWindowProc = HelloWinProc;
    pCreateInfo->lx = 0;
    pCreateInfo->ty = 0;
    pCreateInfo->rx = 320;
    pCreateInfo->by = 240;
    pCreateInfo->iBkColor = PIXEL_lightwhite;
    pCreateInfo->dwAddData = 0;
    pCreateInfo->hHosting = HWND_DESKTOP;
}

int MiniGUIMain (int args, const char* arg[])
{
    MSG Msg;
    MAINWINCREATE CreateInfo;
    HWND hMainWnd;

#ifdef _MGRM_PROCESSES
    JoinLayer (NAME_DEF_LAYER, arg[0], 0, 0);
#endif

    InitCreateInfo (&CreateInfo);

    hMainWnd = CreateMainWindow (&CreateInfo);
    if (hMainWnd == HWND_INVALID)
        return -1;

    while (GetMessage (&Msg, hMainWnd)) {
        DispatchMessage (&Msg);
    }

    MainWindowThreadCleanup (hMainWnd);
    return 0;
}

Define Documentation

#define IDM_DTI_FIRST (300)

The minimum interger value of command ID when user customize desktop menu.

Definition at line 1485 of file minigui.h.

#define MiniGUIMain

Value:

MiniGUIAppMain (int args, const char* argv[]); \
int main_entry (int args, const char* argv[]) \
{ \
    int iRet = 0; \
    if (InitGUI (args, argv) != 0) { \
        return 1; \
    } \
    iRet = MiniGUIAppMain (args, argv); \
    TerminateGUI (iRet); \
    return iRet; \
} \
int MiniGUIAppMain
The main entry of a MiniGUI application.

This function should be defined by your application. Before Version 1.6.1, MiniGUI defines main() function in libminigui library for your application, and call MiniGUIMain() in this main() function. The main() defined by MiniGUI is responsible of initializing and terminating MiniGUI.

After version 1.6.1, MiniGUI defines MiniGUIMain as a macro.

Parameters:
args | The number of arguments passed to main() by operating system.
argv | The arguments passed to main() by operating system.
Returns:
The exit status will be retured to the parent process.

Definition at line 1466 of file minigui.h.

#define ReinitDesktop ( ) ReinitDesktopEx (TRUE)

Re-initializes the desktop including the local system text.

Returns:
TRUE on success, otherwise FALSE.
Note:
This function defined as a macro calling ReinitDesktopEx with init_sys_text set to TRUE.
See also:
ReinitDesktopEx

Definition at line 1424 of file minigui.h.

Function Documentation

void GUIAPI DesktopUpdateAllWindow ( void )

Update all visible windows on the desktop.

On MiniGUI-Processes update all the main windows of the client and desktop window, and it only can be used by mginit on MiniGUI-Processes. On MiniGUI-Threads and MiniGUI-Standalone update all visible windows and desktop window.

void GUIAPI ExitGUISafely ( int exitcode )

Exits your MiniGUI application safely.

Calling this function will terminate your MiniGUI application. This function will restore console attributes and call exit() function and pass exitcode to it.

Parameters:
exitcode The exit status will be passed to exit(3) function.
Returns:
This function will not return.
See also:
exit(3)

BOOL GUIAPI ReinitDesktopEx ( BOOL init_sys_text )

Re-initializes the desktop.

When you changed the charset or the background picture of the desktop, you should call this function to re-initialize the local system text (when init_sys_text is TRUE), the background picture, and the desktop menu.

Parameters:
init_sys_text Indicates whether to initialize the local system text.
Returns:
TRUE on success, otherwise FALSE.
See also:
ReinitDesktop

DESKTOPOPS *GUIAPI SetCustomDesktopOperationSet ( DESKTOPOPS * usr_dsk_ops )

Set customer desktop operation set.

Parameters:
usr_dsk_ops The pointer to user customer desktop operation set.
Returns:
Old desktop operation set.
 static void* this_init(void)
 {
     ......
 }

 static void this_deinit(void* context)
 {
     ......
 }

 static void this_paint_desktop(void* context,\
                         HDC dc_desktop, const RECT* inv_rc)
 {
     ......
 }

 static void this_keyboard_handler(void* context, int message,\
                                       WPARAM wParam, LPARAM lParam)
 {
     ......
 }

 static void this_mouse_handler(void* context, int message,\
                                            WPARAM wParam, LPARAM lParam)
 {
     ......
 }

 static void this_customize_desktop_menu (void* context,\
                                           HMENU hmnu, int start_pos)
 {
     ......
 }

 static void this_desktop_menucmd_handler (void* context, int id)
 {
     ......
 }

 static DESKTOPOPS this_dsk_ops =
 {
     this_init,
     this_deinit,
     this_paint_desktop,
     this_keyboard_handler,
     this_mouse_handler,
     this_customize_desktop_menu,
     this_desktop_menucmd_handler,
 };

 SetCustomDesktopOperationSet(&this_dsk_ops);

See also:
DESKTOPOPS

Generated on Fri Dec 17 13:49:48 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _DESKTOPOPS Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_DESKTOPOPS Struct Reference
[Initialization and termination functions]

#include <minigui.h>

Data Fields

  • void *(* init )(void)
  • void(* deinit )(void *context)
  • void(* paint_desktop )(void *context, HDC dc_desktop, const RECT *inv_rc)
  • void(* keyboard_handler )(void *context, int message, WPARAM wParam, LPARAM lParam)
  • void(* mouse_handler )(void *context, int message, WPARAM wParam, LPARAM lParam)
  • void(* customize_desktop_menu )(void *context, HMENU hmenu, int start_pos)
  • void(* desktop_menucmd_handler )(void *context, int id)

Detailed Description

Desktop operation set

Definition at line 1488 of file minigui.h.

Field Documentation

void*(* init)(void)

called when starting a new session, and return a context

The documentation for this struct was generated from the following file:
  • minigui.h
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Mouse calibration.

Mouse calibration.
[MiniGUI-Processes specific functions]

Functions

  • MG_EXPORT BOOL GUIAPI SetMouseCalibrationParameters (const POINT *src_pts, const POINT *dst_pts)
    Sets the parameters for doing mouse calibration.
  • MG_EXPORT void GUIAPI GetOriginalMousePosition (int *x, int *y)
    Gets the original mouse position.

Function Documentation

void GUIAPI GetOriginalMousePosition | ( | int * | x,
 |  | int * | y
 | ) |  |

Gets the original mouse position.

Parameters:
x | The pointer used to return the x coordinate of original mouse position.
y | The pointer used to return the y coordinate of original mouse position.
Returns:
none.
Note:
This function is available when _MGHAVE_MOUSECALIBRATE (option: --enable-mousecalibrate) defined.

Only call this function in MiniGUI-Standalone, MiniGUI-Threads, and the server (mginit) of MiniGUI-Processes. The behavior of this function will be undefined if you call it in a client of MiniGUI-Processes.

BOOL GUIAPI SetMouseCalibrationParameters | ( | const POINT * | src_pts,
 |  | const POINT * | dst_pts
 | ) |  |

Sets the parameters for doing mouse calibration.

This function set the parameters for doing mouse calibration. You should pass five source points and five destination points.

Normally, the points should be the upper-left, upper-right, lower-right, lower-left, and center points on the touch panel. The source point is the coordinates before calibrating, and the destination point is the desired coordinates after calibrating.

This function will try to evaluate a matrix to calibrate. If the points are okay, MiniGUI will do the calibration after getting a point from the underlay IAL engine.

Parameters:
src_pts | The pointer to an array of five source points.
dst_pts | The pointer to an array of five destination points.
Returns:
TRUE for success, FALSE for bad arguments.
Note:
This function is available when _MGHAVE_MOUSECALIBRATE (option: --enable-mousecalibrate) defined.

Only call this function in MiniGUI-Standalone, MiniGUI-Threads, and the server (mginit) of MiniGUI-Processes. The behavior of this function will be undefined if you call it in a client of MiniGUI-Processes.

Generated on Fri Dec 17 13:49:48 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: About MiniGUI dialog

About MiniGUI dialog
[MiniGUI-Processes specific functions]

Functions

  • MG_EXPORT HWND GUIAPI OpenAboutDialog (HWND hHosting)
    Opens or actives the 'About MiniGUI' dialog.

Function Documentation

HWND GUIAPI OpenAboutDialog ( HWND hHosting )

Opens or actives the 'About MiniGUI' dialog.

Calling this function will create a main window displaying copyright and license information of MiniGUI. When the about dialog is displaying, calling this function again will bring the dialog to be the topmost main window, not create a new one.

Parameters:
hHosting The hosting main window of the about dialog.
Returns:
The handle to the about dialog box.
Note:
This function is available for MiniGUI-Processes and when _MGMISC_ABOUTDLG defined. For MiniGUI-Threads, you should call 'void GUIAPI OpenAboutDialog (void)' function instead.

Generated on Fri Dec 17 13:49:48 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Configuration file operations

Configuration file operations
[MiniGUI-Processes specific functions]

Data Structures

  • struct _ETCSECTION
  • struct _ETC_S

Defines

  • #define ETC_MAXLINE 1024
    The max line number of etc file.
  • #define ETC_FILENOTFOUND -1
    No found etc file.
  • #define ETC_SECTIONNOTFOUND -2
    No found section in etc file.
  • #define ETC_KEYNOTFOUND -3
    No found key in etc file.
  • #define ETC_TMPFILEFAILED -4
    Create tmpfile failed.
  • #define ETC_FILEIOFAILED -5
    IO operation failed to etc file.
  • #define ETC_INTCONV -6
    Convert the value string to an integer failed.
  • #define ETC_INVALIDOBJ -7
    Invalid object to etc file.
  • #define ETC_READONLYOBJ -8
    Read only to etc file.
  • #define ETC_OK 0
    Operate success to etc file.
  • #define SetValueToEtc(hEtc, pSection, pKey, pValue) GetValueFromEtc(hEtc, pSection, pKey, pValue, -1)
    Sets the value in the etc object.

Typedefs

  • typedef ETCSECTION * PETCSECTION

Functions

  • MG_EXPORT int GUIAPI GetValueFromEtcFile (const char *pEtcFile, const char *pSection, const char *pKey, char *pValue, int iLen)
    Gets value from a configuration file.
  • MG_EXPORT int GUIAPI GetIntValueFromEtcFile (const char *pEtcFile, const char *pSection, const char *pKey, int *value)
    Gets integer value from a configuration file.
  • MG_EXPORT int GUIAPI SetValueToEtcFile (const char *pEtcFile, const char *pSection, const char *pKey, char *pValue)
    Sets a value in a configuration file.
  • MG_EXPORT int GUIAPI RemoveSectionInEtcFile (const char *pEtcFile, const char *pSection)
    Removes a section in an etc file.
  • MG_EXPORT int GUIAPI SaveSectionToEtcFile (const char *pEtcFile, PETCSECTION psect)
    Saves a section to an etc file.
  • MG_EXPORT GHANDLE GUIAPI LoadEtcFile (const char *pEtcFile)
    Loads an etc file into memory.
  • MG_EXPORT int GUIAPI SaveEtcToFile (GHANDLE hEtc, const char *file_name)
    Saves an ETC object into a file.
  • MG_EXPORT int GUIAPI UnloadEtcFile (GHANDLE hEtc)
    Unloads an etc file.
  • MG_EXPORT int GUIAPI GetValueFromEtc (GHANDLE hEtc, const char *pSection, const char *pKey, char *pValue, int iLen)
    Gets value from a configuration etc object.
  • MG_EXPORT int GUIAPI GetIntValueFromEtc (GHANDLE hEtc, const char *pSection, const char *pKey, int *pValue)
    Gets the integer value from a configuration etc object.
  • MG_EXPORT GHANDLE GUIAPI FindSectionInEtc (GHANDLE hEtc, const char *pSection, BOOL bCreateNew)
    Finds/Creates a section from an etc object.
  • MG_EXPORT int GUIAPI GetValueFromEtcSec (GHANDLE hSect, const char *pKey, char *pValue, int iLen)
    Gets value from an etc section object.
  • MG_EXPORT int GUIAPI GetIntValueFromEtcSec (GHANDLE hSect, const char *pKey, int *pValue)
    Gets an integer value from an etc section object.
  • MG_EXPORT int GUIAPI SetValueToEtcSec (GHANDLE hSect, const char *pKey, char *pValue)
    Sets the value in the etc section object.
  • MG_EXPORT int GUIAPI RemoveSectionInEtc (GHANDLE hEtc, const char *pSection)
    Removes a section in etc object.
  • static int GetMgEtcValue (const char *pSection, const char *pKey, char *pValue, int iLen)
    Gets value from MiniGUI configuration etc object.
  • static int GetMgEtcIntValue (const char *pSection, const char *pKey, int *value)
    Gets integer value from MiniGUI configuration etc object.

Variables

  • MG_EXPORT char ETCFILEPATH []
    The path name of MiniGUI configuration file.

Detailed Description

The configuration file used by MiniGUI have a similiar format as M$ Windows INI file, i.e. the file consists of sections, and the section consists of key-value pairs, like this:

 [system]
 # GAL engine
 gal_engine=fbcon

 # IAL engine
 ial_engine=console

 mdev=/dev/mouse
 mtype=PS2

 [fbcon]
 defaultmode=1024x768-16bpp

 [qvfb]
 defaultmode=640x480-16bpp
 display=0

Assume that the configuration file named my.cfg, if you want get the value of mdev in system section, you can call GetValueFromEtcFile in the following way:

 char buffer [51];

 GetValueFromEtcFile ("my.cfg", "system", "mdev", buffer, 51);

Example:

/*
 * The following code is used by MDE to get the applications information.
 *
 * It gets the information from a INI-like configuration file.
 */

#define APP_INFO_FILE "mginit.rc"

static BOOL get_app_info (void)
{
    int i;
    APPITEM* item;

    /* Get the number of the applications */
    if (GetIntValueFromEtcFile (APP_INFO_FILE, "mginit", "nr", &app_info.nr_apps) != ETC_OK)
        return FALSE;

    if (app_info.nr_apps <= 0)
        return FALSE;

    /* Get the index of the autostart application. */
    GetIntValueFromEtcFile (APP_INFO_FILE, "mginit", "autostart", &app_info.autostart);

    if (app_info.autostart >= app_info.nr_apps || app_info.autostart < 0)
        app_info.autostart = 0;

    /* Allocate application information structures. */
    if ((app_info.app_items = (APPITEM*)calloc (app_info.nr_apps, sizeof (APPITEM))) == NULL) {
        return FALSE;
    }

    /* Get the path, name, and icon of every application. */
    item = app_info.app_items;
    for (i = 0; i < app_info.nr_apps; i++, item++) {
        char section [10];

        sprintf (section, "app%d", i);
        if (GetValueFromEtcFile (APP_INFO_FILE, section, "path", item->path, PATH_MAX) != ETC_OK)
            goto error;

        if (GetValueFromEtcFile (APP_INFO_FILE, section, "name", item->name, NAME_MAX) != ETC_OK)
            goto error;

        if (GetValueFromEtcFile (APP_INFO_FILE, section, "layer", item->layer, LEN_LAYER_NAME) != ETC_OK)
            goto error;

        if (GetValueFromEtcFile (APP_INFO_FILE, section, "tip", item->tip, TIP_MAX) != ETC_OK)
            goto error;

        strsubchr (item->tip, '&', ' ');

        if (GetValueFromEtcFile (APP_INFO_FILE, section, "icon", item->bmp_path, PATH_MAX + NAME_MAX) != ETC_OK)
            goto error;

        if (LoadBitmap (HDC_SCREEN, &item->bmp, item->bmp_path) != ERR_BMP_OK)
            goto error;

        item->cdpath = TRUE;
    }
    return TRUE;

error:
    free_app_info ();
    return FALSE;
}

Define Documentation

#define ETC_FILEIOFAILED -5

IO operation failed to etc file.

Definition at line 1784 of file minigui.h.

#define ETC_FILENOTFOUND -1

No found etc file.

Definition at line 1764 of file minigui.h.

#define ETC_INTCONV -6

Convert the value string to an integer failed.

Definition at line 1789 of file minigui.h.

#define ETC_INVALIDOBJ -7

Invalid object to etc file.

Definition at line 1794 of file minigui.h.

#define ETC_KEYNOTFOUND -3

No found key in etc file.

Definition at line 1774 of file minigui.h.

#define ETC_MAXLINE 1024

The max line number of etc file.

Definition at line 1758 of file minigui.h.

#define ETC_OK 0

Operate success to etc file.

Definition at line 1804 of file minigui.h.

#define ETC_READONLYOBJ -8

Read only to etc file.

Definition at line 1799 of file minigui.h.

#define ETC_SECTIONNOTFOUND -2

No found section in etc file.

Definition at line 1769 of file minigui.h.

#define ETC_TMPFILEFAILED -4

Create tmpfile failed.

Definition at line 1779 of file minigui.h.

#define SetValueToEtc | ( | hEtc,
 |  | pSection,
 |  | pKey,
 |  | pValue | ) | GetValueFromEtc(hEtc, pSection, pKey, pValue, -1)

Sets the value in the etc object.

This fuctions sets the value in the etc object, somewhat similiar to

See also:
SetValueToEtcFile.

SetValueToEtcFile, GetValueFromEtc

Definition at line 2100 of file minigui.h.

Typedef Documentation

typedef ETCSECTION* PETCSECTION

Data type of pointer to a ETCSECTION

Definition at line 1821 of file minigui.h.

Function Documentation

GHANDLE GUIAPI FindSectionInEtc | ( | GHANDLE | hEtc,
 |  | const char * | pSection,
 |  | BOOL | bCreateNew
 | ) |  |

Finds/Creates a section from an etc object.

This function look for a section named pSection from the etc object hEtc. If there is no such section in the etc object and bCreateNew is TRUE, the function will create an empty section.

Parameters:
hEtc | Handle to the etc object.
pSection | The name of the section.
bCreateNew | Indicate whether to create a new section.
Returns:
The handle to the section, 0 if not found or creatation failed.
See also:
GetValueFromEtcSec, GetIntValueFromEtcSec, SetValueInEtcSec

int GUIAPI GetIntValueFromEtc | ( | GHANDLE | hEtc,
 |  | const char * | pSection,
 |  | const char * | pKey,
 |  | int * | pValue
 | ) |  |

Gets the integer value from a configuration etc object.

See also:
GetValueFromEtc, GetIntValueFromEtcFile

Referenced by GetMgEtcIntValue().

int GUIAPI GetIntValueFromEtcFile | ( | const char * | pEtcFile,
 |  | const char * | pSection,
 |  | const char * | pKey,
 |  | int * | value
 | ) |  |

Gets integer value from a configuration file.

This function gets the integer value of the key pKey in the section pSection of the configuration file pEtcFile, and returns the integer value through the buffer pointed to by value.

Parameters:
pEtcFile | The path name of the configuration file.
pSection | The section name in which the value located.
pKey | The key name of the value.
value | The integer value will be saved in this buffer.
Returns:
ETC_OK on success, < 0 on error.
Return values:
ETC_OK | Gets value successfullly.
ETC_FILENOTFOUND | Can not find the specified configuration file.
ETC_SECTIONNOTFOUND | Can not find the specified section in the configuration file.
ETC_KEYNOTFOUND | Can not find the specified key in the section.
ETC_FILEIOFAILED | File I/O operation error occurred.
ETC_INTCONV | Can not convert the value string to an integer.
Note:
MiniGUI uses strtol to convert the string value to an integer, and pass the base as 0. Thus, the valid string value can be converted to integer should be in the following forms:
  • [+|-]0x[0-9|A-F]*
    Will be read in base 16.
  • [+|-]0[0-7]*
    Will be read in base 8.
  • [+|-][1-9][0-9]*
    Will be read in base 10.

See also:
GetValueFromEtcFile, SetValueToEtcFile, strtol(3)

Referenced by GetMgEtcIntValue().

int GUIAPI GetIntValueFromEtcSec | ( | GHANDLE | hSect,
 |  | const char * | pKey,
 |  | int * | pValue
 | ) |  |

Gets an integer value from an etc section object.

This function gets an integer value from an etc section object, similar to GetIntValueFromEtc. It gets the value of the key pKey in the section hSect, and saves the value to the buffer pointed to by pValue.

Parameters:
hSect | The handle to the section.
pKey | The key name of the value.
pValue | The value will be saved in this buffer.
Returns:
ETC_OK on success, < 0 on error.
Return values:
ETC_OK | Gets value successfullly.
ETC_INVALIDOBJ | Invalid etc object.
ETC_KEYNOTFOUND | Can not find the specified key in the section.
ETC_INTCONV | Can not convert the value string to an integer.
See also:
GetValueFromEtcFile, GetValueFromEtc, FindSectionInEtc

static inline int GetMgEtcIntValue | ( | const char * | pSection,
 |  | const char * | pKey,
 |  | int * | value |
 | ) |  |  | [inline, static]

Gets integer value from MiniGUI configuration etc object.

This fuctions get integer value from MiniGUI configuration etc object some what similiar to GetIntValueFromEtcFile and GetIntValueFromEtc

See also:
GetIntValueFromEtcFile

GetIntValueFromEtc

Definition at line 2244 of file minigui.h.

References GetIntValueFromEtc(), and GetIntValueFromEtcFile().

static inline int GetMgEtcValue | ( | const char * | pSection,
 |  | const char * | pKey,
 |  | char * | pValue,
 |  | int | iLen |
 | ) |  |  | [inline, static]

Gets value from MiniGUI configuration etc object.

This fuctions gets the value from MiniGUi configuration etc object, somewhat similiar to GetValueFromEtcFile and GetValueFromEtc

See also:
GetValueFromEtcFile

GetValueFromEtc.

Definition at line 2224 of file minigui.h.

References GetValueFromEtc(), and GetValueFromEtcFile().

int GUIAPI GetValueFromEtc | ( | GHANDLE | hEtc,
 |  | const char * | pSection,
 |  | const char * | pKey,
 |  | char * | pValue,
 |  | int | iLen
 | ) |  |

Gets value from a configuration etc object.

This function gets value from an etc object, similar to GetValueFromEtcFile. This function gets the value of the key pKey in the section pSection of the etc object hEtc, and saves the value to the buffer pointed to by pValue.

Parameters:
hEtc | Handle to the etc object.
pSection | The section name in which the value located.
pKey | The key name of the value.
pValue | The value will be saved in this buffer.
iLen | The length in bytes of the buffer. This function will set value if the iLen is less than 1.
Returns:
ETC_OK on success, < 0 on error.
Return values:
ETC_OK | Gets value successfullly.
ETC_INVALIDOBJ | Invalid etc object.
ETC_SECTIONNOTFOUND | Can not find the specified section in the configuration file.
ETC_KEYNOTFOUND | Can not find the specified key in the section.
ETC_READONLYOBJ | The etc object is read-only.
See also:
GetValueFromEtcFile, LoadEtcFile, UnloadEtcFile

Referenced by GetMgEtcValue().

int GUIAPI GetValueFromEtcFile | ( | const char * | pEtcFile,
 |  | const char * | pSection,
 |  | const char * | pKey,
 |  | char * | pValue,
 |  | int | iLen
 | ) |  |

Gets value from a configuration file.

This function gets the value of the key pKey in the section pSection of the configuration file pEtcFile, and saves the value to the buffer pointed to by pValue.

Parameters:
pEtcFile | The path name of the configuration file.
pSection | The section name in which the value located.
pKey | The key name of the value.
pValue | The value will be saved in this buffer.
iLen | The length in bytes of the buffer.
Returns:
ETC_OK on success, < 0 on error.
Return values:
ETC_OK | Gets value successfullly.
ETC_FILENOTFOUND | Can not find the specified configuration file.
ETC_SECTIONNOTFOUND | Can not find the specified section in the configuration file.
ETC_KEYNOTFOUND | Can not find the specified key in the section.
ETC_FILEIOFAILED | File I/O operation error occurred.
Note:
MiniGUI use strncpy to copy actual value to pValue. Thus, if the length of the actual value is larger than iLen, the result copied to pValue will NOT be null-terminated.
See also:
GetIntValueFromEtcFile, SetValueToEtcFile, strncpy(3)

Referenced by GetMgEtcValue().

int GUIAPI GetValueFromEtcSec | ( | GHANDLE | hSect,
 |  | const char * | pKey,
 |  | char * | pValue,
 |  | int | iLen
 | ) |  |

Gets value from an etc section object.

This function gets value from an etc section object, similar to GetValueFromEtc. It gets the value of the key pKey in the section hSect, and saves the value to the buffer pointed to by pValue.

Parameters:
hSect | The handle to the section.
pKey | The key name of the value.
pValue | The value will be saved in this buffer.
iLen | The length in bytes of the buffer. This function will set value if the iLen is less than 1.
Returns:
ETC_OK on success, < 0 on error.
Return values:
ETC_OK | Gets value successfullly.
ETC_INVALIDOBJ | Invalid etc object.
ETC_KEYNOTFOUND | Can not find the specified key in the section.
ETC_READONLYOBJ | The section object is read-only.
See also:
GetValueFromEtcFile, GetValueFromEtc, FindSectionInEtc

GHANDLE GUIAPI LoadEtcFile ( const char * pEtcFile )

Loads an etc file into memory.

This function loads the content of an etc file into the memory, later, you can visit the content using GetValueFromEtc function.

Parameters:
pEtcFile The path name of the configuration file. If pEtcFile is NULL, the function will create an empty ETC object.
Returns:
Handle of the etc object on success, NULL on error.
See also:
UnloadEtcFile, GetValueFromEtc

int GUIAPI RemoveSectionInEtc | ( | GHANDLE | hEtc,
 |  | const char * | pSection
 | ) |  |

Removes a section in etc object.

This function removes a section named pSection from the etc object hEtc.

Parameters:
hEtc | The handle to the etc object.
pSection | The name of the pSection;
Returns:
ETC_OK on success, < 0 on error.
Return values:
ETC_OK | Gets value successfullly.
ETC_INVALIDOBJ | Invalid etc object.
ETC_READONLYOBJ | The etc object is read-only.
ETC_SECTIONNOTFOUND | Can not find the specified section in the etc object.
See also:
RemoveSectionInEtcFile

int GUIAPI RemoveSectionInEtcFile | ( | const char * | pEtcFile,
 |  | const char * | pSection
 | ) |  |

Removes a section in an etc file.

This function removes a section named pSection from the etc file named pEtcFile.

Parameters:
pEtcFile | The name of the etc file.
pSection | The name of the pSection;
Returns:
ETC_OK on success, < 0 on error.
Return values:
ETC_OK | Gets value successfullly.
ETC_FILEIOFAILED | File I/O operation error occurred.
ETC_SECTIONNOTFOUND | Can not find the specified section in the etc object.
See also:
RemoveSectionInEtc

int GUIAPI SaveEtcToFile | ( | GHANDLE | hEtc,
 |  | const char * | file_name
 | ) |  |

Saves an ETC object into a file.

This function saves the etc object into the file named file_name;

Parameters:
hEtc | Handle to the etc object.
file_name | The name of the target file.
Returns:
ETC_OK on success, 0 < on error.
Return values:
ETC_OK | Sets the etc object successfullly.
ETC_INVALIDOBJ | Invalid etc object.
ETC_FILEIOFAILED | File I/O operation error occurred.
See also:
LoadEtcFile

int GUIAPI SaveSectionToEtcFile | ( | const char * | pEtcFile,
 |  | PETCSECTION | psect
 | ) |  |

Saves a section to an etc file.

This function saves a section named psect to the etc file named pEtcFile.

Parameters:
pEtcFile | The name of the etc file.
psect | The name of the psect;
Returns:
ETC_OK on success, < 0 on error.
Return values:
ETC_OK | Gets value successfullly.
ETC_FILEIOFAILED | File I/O operation error occurred.
ETC_SECTIONNOTFOUND | Can not find the specified section in the etc object.

int GUIAPI SetValueToEtcFile | ( | const char * | pEtcFile,
 |  | const char * | pSection,
 |  | const char * | pKey,
 |  | char * | pValue
 | ) |  |

Sets a value in a configuration file.

This function sets the value of the key pKey in the section pSection of the configuration file pEtcFile to be the string pointed to by pValue.

Parameters:
pEtcFile | The path name of the configuration file.
pSection | The section name in which the value located.
pKey | The key name of the value.
pValue | The null-terminated value string.
Returns:
ETC_OK on success, < 0 on error.
Return values:
ETC_OK | Sets value successfullly.
ETC_FILEIOFAILED | File I/O operation error occurred.
ETC_TMPFILEFAILED | Can not create temporary file.
Note:
If the specified configuration file does not exist, MiniGUI will try to create this file.
See also:
GetValueFromEtcFile, GetIntValueFromEtcFile

int GUIAPI SetValueToEtcSec | ( | GHANDLE | hSect,
 |  | const char * | pKey,
 |  | char * | pValue
 | ) |  |

Sets the value in the etc section object.

This fuctions sets the value in the etc section object hSect, somewhat similiar to SetValueToEtc

See also:
SetValueToEtc.

GetValueFromEtc, FindSectionInEtc

GUIAPI UnloadEtcFile ( GHANDLE hEtc )

Unloads an etc file.

This function unloads the etc object generated by using

See also:
LoadEtcFile function.
Parameters:
hEtc Handle of the etc object.
Returns:
Returns 0 on success, -1 on error.
See also:
LoadEtcFile, GetValueFromEtc

Variable Documentation

char * ETCFILEPATH

The path name of MiniGUI configuration file.

By default, the configuration file of MiniGUI must be installed in /etc, /usr/local/etc or your home directory. When you install it in your home directory, the name should be ".MiniGUI.cfg".

MiniGUI will try to use MiniGUI.cfg in the current directory, ~/.MiniGUI.cfg, then /usr/local/etc/MiniGUI.cfg, and /etc/MiniGUI.cfg last.

If MiniGUI can not find any MiniGUI.cfg file, or find a bad formated configure file, the initialzation of MiniGUI will be canceled.

Generated on Fri Dec 17 13:49:49 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _ETCSECTION Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_ETCSECTION Struct Reference
[Configuration file operations]

#include <minigui.h>

Data Fields

  • int key_nr_alloc
  • int key_nr
  • char * name
  • char ** keys
  • char ** values

Detailed Description

Etc The current config section information

Definition at line 1807 of file minigui.h.

Field Documentation

int key_nr_alloc

Allocated number of keys

Definition at line 1810 of file minigui.h.

The documentation for this struct was generated from the following file:
  • minigui.h
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _ETC_S Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_ETC_S Struct Reference
[Configuration file operations]

#include <minigui.h>

Data Fields

  • int sect_nr_alloc
  • int section_nr
  • PETCSECTION sections

Detailed Description

ETC_S The current config file information

Definition at line 1824 of file minigui.h.

Field Documentation

int sect_nr_alloc

Allocated number of sections

Definition at line 1827 of file minigui.h.

The documentation for this struct was generated from the following file:
  • minigui.h
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Length-Fixed string operations

Length-Fixed string operations
[MiniGUI-Processes specific functions]

Functions

  • MG_EXPORT char *GUIAPI FixStrAlloc (int len)
    Allocates a buffer for a length-fixed string.
  • MG_EXPORT char *GUIAPI FixStrDup (const char *str)
    Duplicates a length-fixed string.
  • MG_EXPORT void GUIAPI FreeFixStr (char *str)
    Frees a length-fixed string.

Detailed Description

MiniGUI maintains a private heap for length-fixed strings, and allocates length-fixed strings from this heap for window caption, menu item text, and so on. You can also use this private heap to allocate length-fixed strings.

    char * buffer = FixStrAlloc (strlen ("Hello, world!"));

    if (buffer)
        strcpy (buffer, "Hello, world!");

    ...

    FreeFixStr (buffer);

Function Documentation

char *GUIAPI FixStrAlloc ( int len )

Allocates a buffer for a length-fixed string.

This function allocates a buffer from the length-fixed string heap for a string which is len bytes long (does not include the null character of the string).

Note:
You can change the content of the string, but do not change the length of this string (shorter is valid) via strcat function or other equivalent functions or operations.
Parameters:
len The length of the string.
Returns:
The pointer to the buffer on success, otherwise NULL.
See also:
FreeFixStr

char *GUIAPI FixStrDup ( const char * str )

Duplicates a length-fixed string.

This function allocates a buffer from the length-fixed string heap and copy the string str to the buffer.

Note:
You can change the content of the string, but do not change the length of this string (shorter is valid) via strcat function or other equivalent functions or operations.
Parameters:
str The pointer to the string will be duplicated.
Returns:
The pointer to the buffer on success, otherwise NULL.
See also:
FreeFixStr

void GUIAPI FreeFixStr ( char * str )

Frees a length-fixed string.

This function frees the buffer used by the length-fixed string str.

Parameters:
str The length-fixed string.
Note:
Do not use free to free the length-fixed string.
See also:
FixStrAlloc

Generated on Fri Dec 17 13:49:49 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Cursor operations

Cursor operations
[MiniGUI-Processes specific functions]

Defines

  • #define IDC_ARROW 0
  • #define IDC_IBEAM 1
  • #define IDC_PENCIL 2
  • #define IDC_CROSS 3
  • #define IDC_MOVE 4
  • #define IDC_SIZENWSE 5
  • #define IDC_SIZENESW 6
  • #define IDC_SIZEWE 7
  • #define IDC_SIZENS 8
  • #define IDC_UPARROW 9
  • #define IDC_NONE 10
  • #define IDC_HELP 11
  • #define IDC_BUSY 12
  • #define IDC_WAIT 13
  • #define IDC_RARROW 14
  • #define IDC_COLOMN 15
  • #define IDC_ROW 16
  • #define IDC_DRAG 17
  • #define IDC_NODROP 18
  • #define IDC_HAND_POINT 19
  • #define IDC_HAND_SELECT 20
  • #define IDC_SPLIT_HORZ 21
  • #define IDC_SPLIT_VERT 22
  • #define SetCursor(hcsr) SetCursorEx (hcsr, FALSE)
    Changes the current cursor.
  • #define SetDefaultCursor(hcsr) SetCursorEx (hcsr, TRUE)
    Changes the current cursor, and set it as the default cursor.

Functions

  • MG_EXPORT HCURSOR GUIAPI LoadCursorFromFile (const char *filename)
    Loads a cursor from a M$ Windows cursor file.
  • MG_EXPORT HCURSOR GUIAPI LoadCursorFromMem (const void *area)
    Loads a cursor from a memory area.
  • MG_EXPORT HCURSOR GUIAPI CreateCursor (int xhotspot, int yhotspot, int w, int h, const BYTE *pANDBits, const BYTE *pXORBits, int colornum)
    Creates a cursor from memory data.
  • MG_EXPORT BOOL GUIAPI DestroyCursor (HCURSOR hcsr)
    Destroys a cursor object.
  • MG_EXPORT HCURSOR GUIAPI GetSystemCursor (int csrid)
    Gets the handle to a system cursor by its identifier.
  • MG_EXPORT HCURSOR GUIAPI GetCurrentCursor (void)
    Gets the handle to the current cursor.
  • MG_EXPORT void GUIAPI ClipCursor (const RECT *prc)
    Clips the cursor range.
  • MG_EXPORT void GUIAPI GetClipCursor (RECT *prc)
    Gets the current cursor clipping rectangle.
  • MG_EXPORT void GUIAPI GetCursorPos (POINT *ppt)
    Gets position of the current cursor.
  • MG_EXPORT void GUIAPI SetCursorPos (int x, int y)
    Sets position of the current cursor.
  • MG_EXPORT HCURSOR GUIAPI SetCursorEx (HCURSOR hcsr, BOOL set_def)
    Changes the current cursor.
  • MG_EXPORT HCURSOR GUIAPI GetDefaultCursor (void)
    Gets the default cursor.
  • MG_EXPORT int GUIAPI ShowCursor (BOOL fShow)
    Shows or hides cursor.

Define Documentation

#define IDC_ARROW 0

System arrow cursor index.

Definition at line 2710 of file minigui.h.

#define IDC_BUSY 12

System busy cursor index.

Definition at line 2734 of file minigui.h.

#define IDC_COLOMN 15

System colomn cursor index.

Definition at line 2740 of file minigui.h.

#define IDC_CROSS 3

System cross cursor index.

Definition at line 2716 of file minigui.h.

#define IDC_DRAG 17

System drag cursor index.

Definition at line 2744 of file minigui.h.

#define IDC_HAND_POINT 19

System hand point cursor index.

Definition at line 2748 of file minigui.h.

#define IDC_HAND_SELECT 20

System hand select cursor index.

Definition at line 2750 of file minigui.h.

#define IDC_HELP 11

System help cursor index.

Definition at line 2732 of file minigui.h.

#define IDC_IBEAM 1

System beam cursor index.

Definition at line 2712 of file minigui.h.

#define IDC_MOVE 4

System move cursor index.

Definition at line 2718 of file minigui.h.

#define IDC_NODROP 18

System nodrop cursor index.

Definition at line 2746 of file minigui.h.

#define IDC_NONE 10

System none cursor index.

Definition at line 2730 of file minigui.h.

#define IDC_PENCIL 2

System pencil cursor index.

Definition at line 2714 of file minigui.h.

#define IDC_RARROW 14

System right arrow cursor index.

Definition at line 2738 of file minigui.h.

#define IDC_ROW 16

System row cursor index.

Definition at line 2742 of file minigui.h.

#define IDC_SIZENESW 6

System size northeast to southwest cursor index.

Definition at line 2722 of file minigui.h.

#define IDC_SIZENS 8

System north to south cursor index.

Definition at line 2726 of file minigui.h.

#define IDC_SIZENWSE 5

System size northwest to southeast cursor index.

Definition at line 2720 of file minigui.h.

#define IDC_SIZEWE 7

System west to east cursor index.

Definition at line 2724 of file minigui.h.

#define IDC_SPLIT_HORZ 21

System horizontal split cursor index.

Definition at line 2752 of file minigui.h.

#define IDC_SPLIT_VERT 22

System vertical cursor index.

Definition at line 2754 of file minigui.h.

#define IDC_UPARROW 9

System up arrow cursor index.

Definition at line 2728 of file minigui.h.

#define IDC_WAIT 13

System wait cursor index.

Definition at line 2736 of file minigui.h.

#define SetCursor ( hcsr ) SetCursorEx (hcsr, FALSE)

Changes the current cursor.

This function changes the current cursor to be hcsr.

Parameters:
hcsr The expected cursor handle.
Returns:
The old cursor handle.
Note:
This function defined as a macro calling SetCursorEx with passing set_def as FALSE.
See also:
SetCursorEx, SetDefaultCursor

Definition at line 2845 of file minigui.h.

#define SetDefaultCursor ( hcsr ) SetCursorEx (hcsr, TRUE)

Changes the current cursor, and set it as the default cursor.

This function changes the current cursor to be hcsr, and set it as the default cursor.

Parameters:
hcsr The expected cursor handle.
Returns:
The old cursor handle.
Note:
This function defined as a macro calling SetCursorEx with passing set_def as TRUE.
See also:
SetCursorEx, SetCursor

Definition at line 2862 of file minigui.h.

Function Documentation

void GUIAPI ClipCursor ( const RECT * prc )

Clips the cursor range.

This function sets cursor's clipping rectangle. prc is the new clipping rectangle in screen coordinates. If prc is NULL, ClipCursor will disable cursor clipping.

Parameters:
prc The clipping rectangle.
Returns:
None.

HCURSOR GUIAPI CreateCursor | ( | int | xhotspot,
 |  | int | yhotspot,
 |  | int | w,
 |  | int | h,
 |  | const BYTE * | pANDBits,
 |  | const BYTE * | pXORBits,
 |  | int | colornum
 | ) |  |

Creates a cursor from memory data.

This function creates a cursor from memory data rather than cursor file. xhotspot and yhotspot specify the hotpot of the cursor, w and h are the width and the height of the cursor respectively. pANDBits and pXORBits are AND bitmask and XOR bitmask of the cursor. MiniGUI currently support mono-color cursor and 16-color cursor, colornum specifies the cursor's color depth. For mono-color, it should be 1, and for 16-color cursor, it should be 4.

Parameters:
xhotspot | The x-coordinate of the hotspot.
yhotspot | The y-coordinate of the hotspot.
w | The width of the cursor.
h | The height of the cursor.
pANDBits | The pointer to AND bits of the cursor.
pXORBits | The pointer to XOR bits of the cursor.
colornum | The bit-per-pixel of XOR bits.
Returns:
Handle to the cursor, zero on error.
Note:
MiniGUI only support 2-color or 16-color cursor.

BOOL GUIAPI DestroyCursor ( HCURSOR hcsr )

Destroys a cursor object.

This function destroys a cursor object specified by hcsr.

Parameters:
hcsr Handle to the cursor.
Returns:
TRUE on success, otherwise FALSE.

void GUIAPI GetClipCursor ( RECT * prc )

Gets the current cursor clipping rectangle.

This function copies the current clipping rectangle to a RECT pointed to by prc.

Parameters:
prc The clipping rectangle will be saved to this rectangle.
Returns:
None.

HCURSOR GUIAPI GetCurrentCursor ( void )

Gets the handle to the current cursor.

This function retrives the current cursor and returns its handle.

Returns:
Handle to the current system cursor, zero means no current cursor.

void GUIAPI GetCursorPos ( POINT * ppt )

Gets position of the current cursor.

This function copies the current mouse cursor position to a POINT structure pointed to by ppt.

Parameters:
ppt The position will be saved in this buffer.
Returns:
None.
See also:
SetCursorPos, POINT

HCURSOR GUIAPI GetDefaultCursor ( void )

Gets the default cursor.

This function gets the current default cursor.

Returns:
The current default cursor handle.
See also:
SetCursorEx, SetDefaultCursor

HCURSOR GUIAPI GetSystemCursor ( int csrid )

Gets the handle to a system cursor by its identifier.

MiniGUI creates (MAX_SYSCURSORINDEX + 1) system cursors for application. You can use GetSystemCursor to get the handle to these system cursors. The identifier can be one of the following:

  • IDC_ARROW
    Normal arrow cursor.
  • IDC_IBEAM
    'I' shaped beam cursor, indicate an input field.
  • IDC_PENCIL
    Pencil-shape cursor.
  • IDC_CROSS
    Cross cursor.
  • IDC_MOVE
    Moving cursor.
  • IDC_SIZENWSE
    Sizing cursor, along north-west and south-east.
  • IDC_SIZENESW
    Sizing cursor, along north-east and south-west.
  • IDC_SIZEWE
    Sizing cursor, along west and east.
  • IDC_SIZENS
    Sizing cursor, along north and south.
  • IDC_UPARROW
    Up arrow cursor.
  • IDC_NONE
    None cursor.
  • IDC_HELP
    Arrow with question.
  • IDC_BUSY
    Busy cursor.
  • IDC_WAIT
    Wait cursor.
  • IDC_RARROW
    Right arrow cursor.
  • IDC_COLOMN
    Cursor indicates column.
  • IDC_ROW
    Cursor indicates row.
  • IDC_DRAG
    Draging cursor.
  • IDC_NODROP
    No droping cursor.
  • IDC_HAND_POINT
    Hand point cursor.
  • IDC_HAND_SELECT
    Hand selection cursor.
  • IDC_SPLIT_HORZ
    Horizontal splitting cursor.
  • IDC_SPLIT_VERT
    Vertical splitting cursor.

Parameters:
csrid The identifier of the system cursor.
Returns:
Handle to the system cursor, otherwise zero.

HCURSOR GUIAPI LoadCursorFromFile ( const char * filename )

Loads a cursor from a M$ Windows cursor file.

This function loads a cursor from M$ Windows *.cur file named filename and returns the handle to loaded cursor. The returned handle can be used by SetCursor to set new mouse cursor.

Parameters:
filename The path name of the cursor file.
Returns:
Handle to the cursor, zero on error.
Note:
MiniGUI does not support 256-color or animation cursor.
See also:
SetCursor

HCURSOR GUIAPI LoadCursorFromMem ( const void * area )

Loads a cursor from a memory area.

This function loads a cursor from a memory area pointed to by area. The memory has the same layout as a M$ Windows CURSOR file. The returned handle can be used by SetCursor to set new mouse cursor.

Parameters:
area The pointer to the cursor data.
Returns:
Handle to the cursor, zero on error.
Note:
MiniGUI does not support 256-color or animation cursor.
See also:
SetCursor

HCURSOR GUIAPI SetCursorEx | ( | HCURSOR | hcsr,
 |  | BOOL | set_def
 | ) |  |

Changes the current cursor.

This function changes the current cursor to be hcsr, and/or sets it to be the default cursor.

If you pass set_def as TRUE, the expected cursor will be the default cursor. The default cursor will be used when you move the cursor to the desktop.

Parameters:
hcsr | The expected cursor handle.
set_def | Indicates whether setting the cursor as the default cursor.
Returns:
The old cursor handle.
See also:
SetCursor, SetDefaultCursor, GetDefaultCursor

void GUIAPI SetCursorPos | ( | int | x,
 |  | int | y
 | ) |  |

Sets position of the current cursor.

This function sets mouse cursor position with the given arguments: (x,y).

Parameters:
x | The x-corrdinate of the expected poistion.
y | The y-corrdinate of the expected poistion.
Returns:
None.
See also:
GetCursorPos

int GUIAPI ShowCursor ( BOOL fShow )

Shows or hides cursor.

This function shows or hides cursor according to the argument fShow. Show cursor when fShow is TRUE, and hide cursor when fShow is FALSE. MiniGUI maintains a showing count value. Calling ShowCursor once, the count will increase when fShow is TRUE, or decrease one when FALSE. When the count is less than 0, the cursor will disapear actually.

Parameters:
fShow Indicates show or hide the cursor.
Returns:
Cursor showing count value.

Generated on Fri Dec 17 13:49:49 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Asynchronous key status functions

Asynchronous key status functions
[MiniGUI-Processes specific functions]

Functions

  • MG_EXPORT BOOL GUIAPI GetKeyStatus (UINT uKey)
    Gets a key or a mouse button status.
  • MG_EXPORT DWORD GUIAPI GetShiftKeyStatus (void)
    Gets status of the shift keys.

Function Documentation

BOOL GUIAPI GetKeyStatus ( UINT uKey )

Gets a key or a mouse button status.

This function gets a key or a mouse button status, returns TRUE when pressed, or FALSE when released. uKey indicates the key or mouse button. For keys on keyboard, uKey should be the scancode of the key, for mouse button, uKey should be one value of the following:

  • SCANCODE_LEFTBUTTON
    Left mouse button.
  • SCANCODE_MIDDLBUTTON
    Middle mouse button.
  • SCANCODE_RIGHTBUTTON
    Right mouse button.

These constants and the scancodes of keys are defined in <minigui/common.h>.

Parameters:
uKey Indicates the key or mouse button.
Returns:
Returns TRUE when pressed, or FALSE when released.
See also:
GetShiftKeyStatus

DWORD GUIAPI GetShiftKeyStatus ( void )

Gets status of the shift keys.

This function gets ths status of the shift keys, the returned value indicates the status of shift keys -- CapsLock, ScrollLock, NumLock, Left Shift, Right Shift, Left Ctrl, Right Ctrl, Left Alt, and Right Alt. You can use KS_* ORed with the status value to determine one shift key's status:

  • KS_CAPSLOCK
    Indicates that CapsLock is locked.
  • KS_NUMLOCK
    Indicates that NumLock is locked.
  • KS_SCROLLLOCK
    Indicates that ScrollLock is locked.
  • KS_LEFTCTRL
    Indicates that left Ctrl key is pressed.
  • KS_RIGHTCTRL
    Indicates that right Ctrl key is pressed.
  • KS_CTRL
    Indicates that either left or right Ctrl key is pressed.
  • KS_LEFTALT
    Indicates that left Alt key is pressed.
  • KS_RIGHTALT
    Indicates that right Alt key is pressed.
  • KS_ALT
    Indicates that either left or right Alt key is pressed.
  • KS_LEFTSHIFT
    Indicates that left Shift key is pressed.
  • KS_RIGHTSHIFT
    Indicates that right Shift key is pressed.
  • KS_SHIFT
    Indicates that either left or right Shift key is pressed.

These constants are defined in <minigui/common.h>.

Returns:
The status of the shift keys.
See also:
Macros for key codes and shift status

Generated on Fri Dec 17 13:49:49 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Internationlization of system text

Internationlization of system text
[MiniGUI-Processes specific functions]

Defines

  • #define IDS_MGST_WINDOW 0
    The identifier of the window system text.
  • #define IDS_MGST_START 1
    The identifier of the start system text.
  • #define IDS_MGST_REFRESH 2
    The identifier of the refresh background system text.
  • #define IDS_MGST_CLOSEALLWIN 3
    The identifier of the close all windows system text.
  • #define IDS_MGST_ENDSESSION 4
    The identifier of the end session system text.
  • #define IDS_MGST_OPERATIONS 5
    The identifier of the operations system text.
  • #define IDS_MGST_MINIMIZE 6
    The identifier of the minimize system text.
  • #define IDS_MGST_MAXIMIZE 7
    The identifier of the maximize system text.
  • #define IDS_MGST_RESTORE 8
    The identifier of the restore system text.
  • #define IDS_MGST_CLOSE 9
    The identifier of the close system text.
  • #define IDS_MGST_OK 10
    The identifier of the ok system text.
  • #define IDS_MGST_NEXT 11
    The identifier of the next system text.
  • #define IDS_MGST_CANCEL 12
    The identifier of the cancel system text.
  • #define IDS_MGST_PREV 13
    The identifier of the previous system text.
  • #define IDS_MGST_YES 14
    The identifier of the yes system text.
  • #define IDS_MGST_NO 15
    The identifier of the no system text.
  • #define IDS_MGST_ABORT 16
    The identifier of the abort system text.
  • #define IDS_MGST_RETRY 17
    The identifier of the retry system text.
  • #define IDS_MGST_IGNORE 18
    The identifier of the ignore system text.
  • #define IDS_MGST_ABOUTMG 19
    The identifier of the about minigui system text.
  • #define IDS_MGST_OPENFILE 20
    The identifier of the open file system text.
  • #define IDS_MGST_SAVEFILE 21
    The identifier of the save file system text.
  • #define IDS_MGST_COLORSEL 22
    The identifier of the color selection system text.
  • #define IDS_MGST_SWITCHLAYER 23
    The identifier of the switch layer system text.
  • #define IDS_MGST_DELLAYER 24
    The identifier of the delete layer system text.
  • #define IDS_MGST_ERROR 25
    The identifier of the error system text.
  • #define IDS_MGST_LOGO 26
    The identifier of the logo system text.
  • #define IDS_MGST_CURRPATH 27
    The identifier of the current path system text.
  • #define IDS_MGST_FILE 28
    The identifier of the file system text.
  • #define IDS_MGST_LOCATION 29
    The identifier of the location system text.
  • #define IDS_MGST_UP 30
    The identifier of the up system text.
  • #define IDS_MGST_NAME 31
    The identifier of the name system text.
  • #define IDS_MGST_SIZE 32
    The identifier of the size system text.
  • #define IDS_MGST_ACCESSMODE 33
    The identifier of the access mode system text.
  • #define IDS_MGST_LASTMODTIME 34
    The identifier of the last modify time system text.
  • #define IDS_MGST_OPEN 35
    The identifier of the open system text.
  • #define IDS_MGST_FILENAME 36
    The identifier of the file name system text.
  • #define IDS_MGST_FILETYPE 37
    The identifier of the file type system text.
  • #define IDS_MGST_SHOWHIDEFILE 38
    The identifier of the show hide file system text.
  • #define IDS_MGST_NOTFOUND 39
    The identifier of the not found file system text.
  • #define IDS_MGST_NR 40
    The identifier of the can't read system text.
  • #define IDS_MGST_NW 41
    The identifier of the can't write system text.
  • #define IDS_MGST_INFO 42
    The identifier of the information system text.
  • #define IDS_MGST_R 43
    The identifier of the read system text.
  • #define IDS_MGST_W 44
    The identifier of the write system text.
  • #define IDS_MGST_WR 45
    The identifier of the read and write system text.
  • #define IDS_MGST_SAVE 46
    The identifier of the save system text.
  • #define IDS_MGST_FILEEXIST 47
    The identifier of the file exist system text.

Functions

  • MG_EXPORT const char *GUIAPI GetSysText (unsigned int id)
    Translates system text to localized text.
  • MG_EXPORT const char **GUIAPI GetSysTextInUTF8 (const char *language)
    Gets the localized system text array in UTF-8 for a specified language.

Variables

  • MG_EXPORT const char * SysText []
    Contains all text used by MiniGUI in English.
  • MG_EXPORT const char ** local_SysText
    The pointer to the current localized system text array.

Define Documentation

#define IDS_MGST_ABORT 16

The identifier of the abort system text.

Definition at line 3087 of file minigui.h.

#define IDS_MGST_ABOUTMG 19

The identifier of the about minigui system text.

Definition at line 3105 of file minigui.h.

#define IDS_MGST_ACCESSMODE 33

The identifier of the access mode system text.

Definition at line 3189 of file minigui.h.

#define IDS_MGST_CANCEL 12

The identifier of the cancel system text.

Definition at line 3063 of file minigui.h.

#define IDS_MGST_CLOSE 9

The identifier of the close system text.

Definition at line 3045 of file minigui.h.

#define IDS_MGST_CLOSEALLWIN 3

The identifier of the close all windows system text.

Definition at line 3009 of file minigui.h.

#define IDS_MGST_COLORSEL 22

The identifier of the color selection system text.

Definition at line 3123 of file minigui.h.

#define IDS_MGST_CURRPATH 27

The identifier of the current path system text.

Definition at line 3153 of file minigui.h.

#define IDS_MGST_DELLAYER 24

The identifier of the delete layer system text.

Definition at line 3135 of file minigui.h.

#define IDS_MGST_ENDSESSION 4

The identifier of the end session system text.

Definition at line 3015 of file minigui.h.

#define IDS_MGST_ERROR 25

The identifier of the error system text.

Definition at line 3141 of file minigui.h.

#define IDS_MGST_FILE 28

The identifier of the file system text.

Definition at line 3159 of file minigui.h.

#define IDS_MGST_FILEEXIST 47

The identifier of the file exist system text.

Definition at line 3273 of file minigui.h.

#define IDS_MGST_FILENAME 36

The identifier of the file name system text.

Definition at line 3207 of file minigui.h.

#define IDS_MGST_FILETYPE 37

The identifier of the file type system text.

Definition at line 3213 of file minigui.h.

#define IDS_MGST_IGNORE 18

The identifier of the ignore system text.

Definition at line 3099 of file minigui.h.

#define IDS_MGST_INFO 42

The identifier of the information system text.

Definition at line 3243 of file minigui.h.

#define IDS_MGST_LASTMODTIME 34

The identifier of the last modify time system text.

Definition at line 3195 of file minigui.h.

#define IDS_MGST_LOCATION 29

The identifier of the location system text.

Definition at line 3165 of file minigui.h.

#define IDS_MGST_LOGO 26

The identifier of the logo system text.

Definition at line 3147 of file minigui.h.

#define IDS_MGST_MAXIMIZE 7

The identifier of the maximize system text.

Definition at line 3033 of file minigui.h.

#define IDS_MGST_MINIMIZE 6

The identifier of the minimize system text.

Definition at line 3027 of file minigui.h.

#define IDS_MGST_NAME 31

The identifier of the name system text.

Definition at line 3177 of file minigui.h.

#define IDS_MGST_NEXT 11

The identifier of the next system text.

Definition at line 3057 of file minigui.h.

#define IDS_MGST_NO 15

The identifier of the no system text.

Definition at line 3081 of file minigui.h.

#define IDS_MGST_NOTFOUND 39

The identifier of the not found file system text.

Definition at line 3225 of file minigui.h.

#define IDS_MGST_NR 40

The identifier of the can't read system text.

Definition at line 3231 of file minigui.h.

#define IDS_MGST_NW 41

The identifier of the can't write system text.

Definition at line 3237 of file minigui.h.

#define IDS_MGST_OK 10

The identifier of the ok system text.

Definition at line 3051 of file minigui.h.

#define IDS_MGST_OPEN 35

The identifier of the open system text.

Definition at line 3201 of file minigui.h.

#define IDS_MGST_OPENFILE 20

The identifier of the open file system text.

Definition at line 3111 of file minigui.h.

#define IDS_MGST_OPERATIONS 5

The identifier of the operations system text.

Definition at line 3021 of file minigui.h.

#define IDS_MGST_PREV 13

The identifier of the previous system text.

Definition at line 3069 of file minigui.h.

#define IDS_MGST_R 43

The identifier of the read system text.

Definition at line 3249 of file minigui.h.

#define IDS_MGST_REFRESH 2

The identifier of the refresh background system text.

Definition at line 3003 of file minigui.h.

#define IDS_MGST_RESTORE 8

The identifier of the restore system text.

Definition at line 3039 of file minigui.h.

#define IDS_MGST_RETRY 17

The identifier of the retry system text.

Definition at line 3093 of file minigui.h.

#define IDS_MGST_SAVE 46

The identifier of the save system text.

Definition at line 3267 of file minigui.h.

#define IDS_MGST_SAVEFILE 21

The identifier of the save file system text.

Definition at line 3117 of file minigui.h.

#define IDS_MGST_SHOWHIDEFILE 38

The identifier of the show hide file system text.

Definition at line 3219 of file minigui.h.

#define IDS_MGST_SIZE 32

The identifier of the size system text.

Definition at line 3183 of file minigui.h.

#define IDS_MGST_START 1

The identifier of the start system text.

Definition at line 2997 of file minigui.h.

#define IDS_MGST_SWITCHLAYER 23

The identifier of the switch layer system text.

Definition at line 3129 of file minigui.h.

#define IDS_MGST_UP 30

The identifier of the up system text.

Definition at line 3171 of file minigui.h.

#define IDS_MGST_W 44

The identifier of the write system text.

Definition at line 3255 of file minigui.h.

#define IDS_MGST_WINDOW 0

The identifier of the window system text.

Definition at line 2991 of file minigui.h.

#define IDS_MGST_WR 45

The identifier of the read and write system text.

Definition at line 3261 of file minigui.h.

#define IDS_MGST_YES 14

The identifier of the yes system text.

Definition at line 3075 of file minigui.h.

Function Documentation

const char *GUIAPI GetSysText ( unsigned int id )

Translates system text to localized text.

When MiniGUI display some system messages, it will call GetSysText function to translate system text from English to other language. Global variable SysText contains all text used by MiniGUI in English.

GetSysText function returns localized text from local_SysText. MiniGUI have already defined localized sytem text for en_US, zh_CN.GB2312 and zh_TW.Big5 locales. MiniGUI initializes local_SysText to point one of above localized system text when startup. You can also let local_SysText point to your customized string array.

Parameters:
id The system text id.
Returns:
The localized text.
See also:
SysText, local_SysText

const char **GUIAPI GetSysTextInUTF8 ( const char * language )

Gets the localized system text array in UTF-8 for a specified language.

This function returns the localized system text array in UTF-8 encode for the specified language. You can use the returned localized system text array to set local_SysText if your system logical fonts are using UNICODE/UTF-8 charset.

Parameters:
language The language name. So far, you can specify the language as 'zh_CN' (for simlified Chinese) or 'zh_TW' (for tranditional Chinese).
Returns:
The pointer to the localized system text array.
See also:
SysText, local_SysText

Variable Documentation

const char ** local_SysText

The pointer to the current localized system text array.

Changing local_SysText will lead to GetSysText returns a different localized system text. Please set it when MiniGUI starts and send desktop a MSG_REINITSESSION message (call ReinitDesktop function) after assigned a different value to this variable.

See also:
GetSysText, SysText, ReinitDesktopEx

const char * SysText[]

Contains all text used by MiniGUI in English.

System text defined as follows in MiniGUI:

 const char* SysText [] =
 {
    "Windows...",
    "Start...",
    "Refresh Background",
    "Close All Windows",
    "End Session",
    "Operations...",
    "Minimize",
    "Maximize",
    "Restore",
    "Close",
    "OK",
    "Next",
    "Cancel",
    "Previous",
    "Yes",
    "No",
    "Abort",
    "Retry",
    "Ignore",
    "About MiniGUI...",
    "Open File",
    "Save File",
    "Color Selection",
    "Switch Layer",
    "Delete Layer",
    "Error",
    "LOGO",
    "Current Path",
    "File",
  #if (!defined (__NOUNIX__) || defined (WIN32)) && defined (_MGCTRL_LISTVIEW)

    "Location",
    "Up",
    "Name",
    "Size",
    "Access Mode",
    "Last Modify Time",
    "Open",
    "File Name",
    "File Type",
    "Show Hide File",
    "Sorry! not find %s ",
    "Can't Read %s !",
    "Can't Write  %s !",
    "Information",
    "R",
    "W",
    "WR",
    "Save",
    "File %s exists, Replace or not?",
  #endif
    NULL
 };

See also:
GetSysText, local_SysText

Generated on Fri Dec 17 13:49:49 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: String operation helpers

String operation helpers
[MiniGUI-Processes specific functions]

Functions

  • MG_EXPORT char * strnchr (const char *s, size_t n, int c)
    Locates character in the first n characters of string s.
  • MG_EXPORT int substrlen (const char *text, int len, int delimiter, int *nr_delim)
    Locates a substring delimited by one or more delimiters in the first len characters of string text.
  • MG_EXPORT char * strtrimall (char *src)
    Deletes all space characters.

Function Documentation

char * strnchr | ( | const char * | s,
 |  | size_t | n,
 |  | int | c
 | ) |  |

Locates character in the first n characters of string s.

Parameters:
s | The pointer to the string.
n | The number of first characters will be searched.
c | The expected character.
Returns:
Returns a pointer to the first occurrence of the character c in the string s.
See also:
strchr(3)

char * strtrimall ( char * src )

Deletes all space characters.

This function deletes the blank space, form-feed('\f'), newline('\n'), carriage return('\r'), horizontal tab('\t'),and vertical tab('\v') in the head and the tail of the string.

Parameters:
src The pointer to the string.
Returns:
Returns a pointer to the string.

int substrlen | ( | const char * | text,
 |  | int | len,
 |  | int | delimiter,
 |  | int * | nr_delim
 | ) |  |

Locates a substring delimited by one or more delimiters in the first len characters of string text.

Parameters:
text | The pointer to the string.
len | The number of first characters will be searched.
delimiter | The delimiter which delimites the substring from other.
nr_delim | The number of continuous delimiters will be returned through this pointer.
Returns:
The length of the substring.
See also:
strstr(3)

Generated on Fri Dec 17 13:49:49 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: ClipBoard Operations

ClipBoard Operations
[MiniGUI-Processes specific functions]

Defines

  • #define LEN_CLIPBOARD_NAME 15
    The maximum length of the name of clipboard.
  • #define NR_CLIPBOARDS 4
    The maximum number of clipboard.
  • #define CBNAME_TEXT ("text")
    The default clipboard name of text control.
  • #define CBERR_OK 0
    Operate clipboard success.
  • #define CBERR_BADNAME 1
    Bad name to clipboard.
  • #define CBERR_NOMEM 2
    No enough memory to clipboard.
  • #define CBOP_NORMAL 0
    Overwrite operation to clipboard.
  • #define CBOP_APPEND 1
    Append the new data to clipboarda after the old data.

Functions

  • MG_EXPORT int GUIAPI CreateClipBoard (const char *cb_name, size_t size)
    Creates a new clipboard.
  • MG_EXPORT int GUIAPI DestroyClipBoard (const char *cb_name)
    Destroys a new clipboard.
  • MG_EXPORT int GUIAPI SetClipBoardData (const char *cb_name, void *data, size_t n, int cbop)
    Sets the data of a clipboard.
  • MG_EXPORT size_t GUIAPI GetClipBoardDataLen (const char *cb_name)
    Gets the length of the data of a clipboard.
  • MG_EXPORT size_t GUIAPI GetClipBoardData (const char *cb_name, void *data, size_t n)
    Gets the data of a clipboard.
  • MG_EXPORT int GUIAPI GetClipBoardByte (const char *cb_name, int index, unsigned char *byte)
    Gets a byte from a clipboard.

Define Documentation

#define CBERR_BADNAME 1

Bad name to clipboard.

See also:
CreateClipBoard

Definition at line 2292 of file minigui.h.

#define CBERR_NOMEM 2

No enough memory to clipboard.

See also:
CreateClipBoard

Definition at line 2298 of file minigui.h.

#define CBERR_OK 0

Operate clipboard success.

See also:
CreateClipBoard

Definition at line 2286 of file minigui.h.

#define CBNAME_TEXT ("text")

The default clipboard name of text control.

Definition at line 2279 of file minigui.h.

#define CBOP_APPEND 1

Append the new data to clipboarda after the old data.

Definition at line 2309 of file minigui.h.

#define CBOP_NORMAL 0

Overwrite operation to clipboard.

Definition at line 2304 of file minigui.h.

#define LEN_CLIPBOARD_NAME 15

The maximum length of the name of clipboard.

Definition at line 2268 of file minigui.h.

#define NR_CLIPBOARDS 4

The maximum number of clipboard.

Definition at line 2273 of file minigui.h.

Function Documentation

int GUIAPI CreateClipBoard | ( | const char * | cb_name,
 |  | size_t | size
 | ) |  |

Creates a new clipboard.

This function creates a new clipboard with the name cb_name. MiniGUI itself creates a clipboard for text copying/pasting called CBNAME_TEXT.

Parameters:
cb_name | The name of the new clipboard.
size | The size of the clipboard.
Return values:
CBERR_OK | The clipboard created.
CBERR_BADNAME | Duplicated clipboard name.
CBERR_NOMEM | No enough memory.
See also:
DestroyClipBoard

int GUIAPI DestroyClipBoard ( const char * cb_name )

Destroys a new clipboard.

This function destroys a clipboard with the name cb_name.

Parameters:
cb_name The name of the clipboard.
Return values:
CBERR_OK | The clipboard has been destroyed.
CBERR_BADNAME | Can not find the clipboard with the name.
See also:
CreateClipBoard

int GUIAPI GetClipBoardByte | ( | const char * | cb_name,
 |  | int | index,
 |  | unsigned char * | byte
 | ) |  |

Gets a byte from a clipboard.

This function gets a byte from the clipboard named cb_name.

Parameters:
cb_name | The name of the clipboard.
index | The index of the byte.
byte | The buffer saving the returned byte.
Return values:
CBERR_OK | Success.
CBERR_BADNAME | Bad clipboard name.
CBERR_NOMEM | The index is beyond the data in the clipboard.
See also:
GetClipBoardData

size_t GUIAPI GetClipBoardData | ( | const char * | cb_name,
 |  | void * | data,
 |  | size_t | n
 | ) |  |

Gets the data of a clipboard.

This function gets the all data from the clipboard named cb_name.

Parameters:
cb_name | The name of the clipboard.
data | The pointer to a buffer will save the data.
n | The length of the buffer.
Returns:
The size of the data got if success, otherwise zero.
See also:
GetClipBoardByte

size_t GUIAPI GetClipBoardDataLen ( const char * cb_name )

Gets the length of the data of a clipboard.

This function gets the data length of the clipboard named cb_name.

Parameters:
cb_name The name of the clipboard.
Returns:
The size of the data if success, otherwise zero.
See also:
GetClipBoardData

int GUIAPI SetClipBoardData | ( | const char * | cb_name,
 |  | void * | data,
 |  | size_t | n,
 |  | int | cbop
 | ) |  |

Sets the data of a clipboard.

This function sets the data into the clipboard named cb_name.

Parameters:
cb_name | The name of the clipboard.
data | The pointer to the data.
n | The length of the data.
cbop Type of clipboard operations, can be one of the following values:
  • CBOP_NORMAL
    Overwrite the old data.
  • CBOP_APPEND
    Append the new data after the old data.
Return values:
CBERR_OK | Success.
CBERR_BADNAME | Bad clipboard name.
CBERR_NOMEM | No enough memory.
See also:
GetClipBoardDataLen, GetClipBoardData

Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Miscellaneous functions

Miscellaneous functions
[Global/general functions, MiniGUI-Processes specific functions]

Defines

  • #define NotifyParent(hwnd, id, code) NotifyParentEx(hwnd, id, code, 0)
    Sends a notification message to the parent, but without additional data.
  • #define Beep Ping
    Alias of Ping.

Typedefs

  • typedef int(* STRCMP )(const char *s1, const char *s2, size_t n)
    Type of general strncmp function.

Enumerations

  • enum SBPolicyType { SB_POLICY_ALWAYS, SB_POLICY_AUTOMATIC, SB_POLICY_NEVER }
    Scroll bar display policies in scrolled window. More...

Functions

  • MG_EXPORT void GUIAPI DisabledTextOutEx (HDC hdc, HWND hwnd, int x, int y, const char *szText)
    Outputs disabled (grayed) text.
  • MG_EXPORT HWND CreateToolTipWin (HWND hParentWnd, int x, int y, int timeout_ms, const char *text,...)
    Creates a tool tip window.
  • MG_EXPORT void ResetToolTipWin (HWND hwnd, int x, int y, const char *text,...)
    Resets a tool tip window.
  • MG_EXPORT void DestroyToolTipWin (HWND hwnd)
    Destroies a tool tip window.
  • MG_EXPORT void GUIAPI NotifyParentEx (HWND hwnd, int id, int code, DWORD add_data)
    Sends a notification message to the parent.
  • MG_EXPORT void GUIAPI Ping (void)
    Makes a beep sound.
  • MG_EXPORT void GUIAPI Tone (int frequency_hz, int duration_ms)
    Makes a tone.
  • MG_EXPORT void *GUIAPI GetOriginalTermIO (void)
    Gets termios structure of the original terminal before initializing MiniGUI.

Define Documentation

#define Beep Ping

Alias of Ping.

See also:
Ping

Definition at line 2444 of file minigui.h.

#define NotifyParent | ( | hwnd,
 |  | id,
 |  | code | ) | NotifyParentEx(hwnd, id, code, 0)

Sends a notification message to the parent, but without additional data.

Parameters:
hwnd | The handle to current control window.
id | The identifier of current control.
code | The notification code.
Note:
This function is actually a macro of NotifyParentEx with dwAddData being zero.
See also:
NotifiyParentEx

Definition at line 195 of file ctrlhelper.h.

Typedef Documentation

typedef int(* STRCMP)(const char *s1, const char *s2, size_t n)

Type of general strncmp function.

The function compares the two strings s1 and s2. It returns an integer less than, equal to, or greater than zero if s1 is found, respectively, to be less than, to match, or be greater than s2.

Note that it only compares the first (at most) n characters of s1 and s2.

Definition at line 208 of file ctrlhelper.h.

Enumeration Type Documentation

enum SBPolicyType

Scroll bar display policies in scrolled window.

Enumerator:
SB_POLICY_ALWAYS | The scroll bar is always visible
SB_POLICY_AUTOMATIC | The scroll bar is shown or hided automatically
SB_POLICY_NEVER | The scroll bar is never visbile

Definition at line 56 of file ctrlhelper.h.

Function Documentation

HWND CreateToolTipWin | ( | HWND | hParentWnd,
 |  | int | x,
 |  | int | y,
 |  | int | timeout_ms,
 |  | const char * | text,
 |  |  | ...
 | ) |  |

Creates a tool tip window.

This function creates a tool tip window and returns the handle to it. You can call DestroyToolTipWin to destroy it. This function also receives printf-like arguments to format a string.

Note that the tool tip window will disappear automatically after the specified milliseconds by timeout_ms if timeout_ms is larger than 9 ms.

Parameters:
hParentWnd | The hosting main window.
x | The position of the tool tip window.
y | The position of the tool tip window.
timeout_ms | The timeout value of the tool tip window.
text | The format string.
Returns:
The handle to the tool tip window on success, HWND_INVALID on error.
See also:
ResetToolTipWin, DestroyToolTipWin

void DestroyToolTipWin ( HWND hwnd )

Destroies a tool tip window.

This function destroies the specified tool tip window hwnd, which is returned by CreateToolTipWin.

Parameters:
hwnd The handle to the tool tip window.
See also:
CreateToolTipWin

void GUIAPI DisabledTextOutEx | ( | HDC | hdc,
 |  | HWND | hwnd,
 |  | int | x,
 |  | int | y,
 |  | const char * | szText
 | ) |  |

Outputs disabled (grayed) text.

This function outputs a grayed text at the specified position.

Parameters:
hdc | The device context.
hwnd | Tell the function to draw with the color definitions of this window.
x | The x-coordinate of start point.
y | The y-coordinate of start point.
szText | The null-terminated text to be output.
See also:
TextOut, DrawText

void *GUIAPI GetOriginalTermIO ( void )

Gets termios structure of the original terminal before initializing MiniGUI.

Returns:
The pointer to the original termios structure.

void GUIAPI NotifyParentEx | ( | HWND | hwnd,
 |  | int | id,
 |  | int | code,
 |  | DWORD | add_data
 | ) |  |

Sends a notification message to the parent.

By default, the notification from a control will be sent to its parent window within a MSG_COMMAND messsage.

Since version 1.2.6, MiniGUI defines the Nofication Callback Procedure for control. You can specify a callback function for a control by calling SetNotificationCallback to receive and handle the notification from the control.

If you have defined the Notificaton Callback Procedure for the control, calling NotifyParentEx will call the notification callback procedure, not send the notification message to the parent.

Note that if the control has WS_EX_NOPARENTNOTIFY style, this function will not notify the parent.

Parameters:
hwnd | The handle to current control window.
id | The identifier of current control.
code | The notification code.
add_data | The additional data of the notification.
See also:
SetNotificationCallback

void GUIAPI Ping ( void )

Makes a beep sound.

See also:
Beep

void ResetToolTipWin | ( | HWND | hwnd,
 |  | int | x,
 |  | int | y,
 |  | const char * | text,
 |  |  | ...
 | ) |  |

Resets a tool tip window.

This function resets the tool tip window specified by hwnd, including its position, text displayed in it, and the visible status. If the tool tip is invisible, it will become visible.

This function also receives printf-like arguments to format a string.

Parameters:
hwnd | The tool tip window handle returned by CreateToolTipWin.
x | The new position of the tool tip window.
y | The new position of the tool tip window.
text | The new format string.
See also:
CreateToolTipWin, DestroyToolTipWin

void GUIAPI Tone | ( | int | frequency_hz,
 |  | int | duration_ms
 | ) |  |

Makes a tone.

This function will return after the tone. Thus, your program will be blocked when the tone is being played.

Parameters:
frequency_hz | The frequency of the tone in hertz.
duration_ms | The duration of the tone in millisecond.
Bug:
When MiniGUI runs on X Window or RTOS, the tone can not be played correctly.
See also:
Ping

Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Functions

Functions

Modules

  • GDI functions
  • Message functions
  • Look and Feel Renderer management functions
  • Resource managment functions
  • Windowing functions
  • Global/general functions

Variables

  • void(* deinit )(void *context)
  • void(* paint_desktop )(void *context, HDC dc_desktop, const RECT *inv_rc)
  • void(* keyboard_handler )(void *context, int message, WPARAM wParam, LPARAM lParam)
  • void(* mouse_handler )(void *context, int message, WPARAM wParam, LPARAM lParam)
  • void(* customize_desktop_menu )(void *context, HMENU hmenu, int start_pos)
  • void(* desktop_menucmd_handler )(void *context, int id)
  • int key_nr
  • char * name
  • char ** keys
  • char ** values
  • int section_nr
  • PETCSECTION sections
  • int message
  • WPARAM wParam
  • LPARAM lParam
  • unsigned int time
  • MSGHOOK hook
  • DWORD we_attr
  • int maxPos
  • int curPos
  • int pageStep
  • int arrowLen
  • int barStart
  • int barLen
  • int status
  • int maxPos
  • int curPos
  • int pageStep
  • int arrowLen
  • int barStart
  • int barLen
  • int status
  • int winType
  • int(* init )(PWERENDERER renderer)
  • int(* deinit )(PWERENDERER renderer)
  • DWORD(* calc_3dbox_color )(DWORD color, int flag)
  • void(* draw_3dbox )(HDC hdc, const RECT *pRect, DWORD color, DWORD flag)
  • void(* draw_radio )(HDC hdc, const RECT *pRect, DWORD color, int status)
  • void(* draw_checkbox )(HDC hdc, const RECT *pRect, DWORD color, int status)
  • void(* draw_checkmark )(HDC hdc, const RECT *pRect, DWORD color, int status)
  • void(* draw_arrow )(HWND hWnd, HDC hdc, const RECT *pRect, DWORD color, int status)
  • void(* draw_fold )(HWND hWnd, HDC hdc, const RECT *pRect, DWORD color, int status, int next)
  • void(* draw_focus_frame )(HDC hdc, const RECT *pRect, DWORD color)
  • void(* draw_normal_item )(HWND hWnd, HDC hdc, const RECT *pRect, DWORD color)
  • void(* draw_hilite_item )(HWND hWnd, HDC hdc, const RECT *pRect, DWORD color)
  • void(* draw_disabled_item )(HWND hWnd, HDC hdc, const RECT *pRect, DWORD color)
  • void(* draw_significant_item )(HWND hWnd, HDC hdc, const RECT *pRect, DWORD color)
  • void(* draw_push_button )(HWND hWnd, HDC hdc, const RECT *pRect, DWORD color1, DWORD color2, int status)
  • void(* draw_radio_button )(HWND hWnd, HDC hdc, const RECT *pRect, int status)
  • void(* draw_check_button )(HWND hWnd, HDC hdc, const RECT *pRect, int status)
  • void(* draw_border )(HWND hWnd, HDC hdc, BOOL is_active)
  • void(* draw_caption )(HWND hWnd, HDC hdc, BOOL is_active)
  • void(* draw_caption_button )(HWND hwnd, HDC hdc, int ht_code, int state)
  • void(* draw_scrollbar )(HWND hWnd, HDC hdc, int sb_pos)
  • void(* calc_trackbar_rect )(HWND hWnd, LFRDR_TRACKBARINFO *info, DWORD dwStyle, const RECT *rcClient, RECT *rcRuler, RECT *rcBar, RECT *rcBorder)
  • void(* draw_trackbar )(HWND hWnd, HDC hdc, LFRDR_TRACKBARINFO *info)
  • int(* calc_we_area )(HWND hWnd, int which, RECT *we_area)
  • int(* calc_we_metrics )(HWND hWnd, LFRDR_WINSTYLEINFO *style_info, int which)
  • int(* hit_test )(HWND hWnd, int x, int y)
  • int(* on_click_hotspot )(HWND hWnd, int which)
  • void(* draw_custom_hotspot )(HWND hWnd, HDC hdc, int ht_code, int state)
  • void(* calc_thumb_area )(HWND hWnd, BOOL vertical, LFSCROLLBARINFO *sb_info)
  • void(* disabled_text_out )(HWND hWnd, HDC hdc, const char *spText, PRECT rc, DWORD dt_fmt)
  • void(* draw_tab )(HWND hWnd, HDC hdc, RECT *rect, char *title, DWORD color, int flag, HICON icon)
  • void(* draw_progress )(HWND hWnd, HDC hdc, int nMax, int nMin, int nPos, BOOL fVertical)
  • void(* draw_header )(HWND hWnd, HDC hdc, const RECT *pRect, DWORD color)
  • DWORD(* on_get_rdr_attr )(struct _WINDOW_ELEMENT_RENDERER *, int we_attr_id)
  • DWORD(* on_set_rdr_attr )(struct _WINDOW_ELEMENT_RENDERER *, int we_attr_id, DWORD we_attr, BOOL change)
  • void(* erase_background )(HWND hWnd, HDC hdc, const RECT *rect)
  • void(* draw_normal_menu_item )(HWND hWnd, HDC hdc, const RECT *pRect, DWORD color)
  • void(* draw_hilite_menu_item )(HWND hWnd, HDC hdc, const RECT *pRect, DWORD color)
  • void(* draw_disabled_menu_item )(HWND hWnd, HDC hdc, const RECT *pRect, DWORD color)
  • int we_metrics [WE_METRICS_NUMBER]
  • DWORD we_colors [WE_COLORS_NUMBER][3]
  • PLOGFONT we_fonts [WE_FONTS_NUMBER]
  • HICON we_icon [2][SYSICO_ITEM_NUMBER]
  • unsigned int refcount
  • const void * private_info
  • int cl
  • DWORD dwStyle
  • DWORD dwExStyle
  • int iBkColor
  • HMENU hMenu
  • HACCEL hAccel
  • HCURSOR hCursor
  • HICON hIcon
  • HMENU hSysMenu
  • PLOGFONT pLogFont
  • char * spCaption
  • int id
  • LFSCROLLBARINFO vscroll
  • LFSCROLLBARINFO hscroll
  • WINDOW_ELEMENT_RENDERER * we_rdr
  • DWORD dwExStyle
  • const char * spCaption
  • HMENU hMenu
  • HCURSOR hCursor
  • HICON hIcon
  • HWND hHosting
  • int(* MainWindowProc )(HWND, int, WPARAM, LPARAM)
  • int lx
  • int iBkColor
  • DWORD dwAddData
  • DWORD dwReserved
  • UINT fMask
  • int nMin
  • int nMax
  • UINT nPage
  • int nPos
  • DWORD opMask
  • DWORD dwStyle
  • DWORD dwExStyle
  • HCURSOR hCursor
  • int iBkColor
  • int(* WinProc )(HWND, int, WPARAM, LPARAM)
  • DWORD dwAddData
  • UINT type
  • UINT state
  • int id
  • HMENU hsubmenu
  • PBITMAP uncheckedbmp
  • PBITMAP checkedbmp
  • DWORD itemdata
  • DWORD typedata
  • UINT cch
  • DWORD dwStyle
  • int x
  • int id
  • const char * caption
  • DWORD dwAddData
  • DWORD dwExStyle
  • const char * werdr_name
  • const WINDOW_ELEMENT_ATTR * we_attrs
  • DWORD dwExStyle
  • int x
  • const char * caption
  • HICON hIcon
  • HMENU hMenu
  • int controlnr
  • PCTRLDATA controls
  • DWORD dwAddData

Variable Documentation

int arrowLen [inherited]

The length of arrow.

Definition at line 3509 of file window.h.

int arrowLen [inherited]

The length of arrow.

Definition at line 3485 of file window.h.

int barLen [inherited]

The length of thumb.

Definition at line 3513 of file window.h.

int barLen [inherited]

The length of thumb.

Definition at line 3489 of file window.h.

int barStart [inherited]

The start pixel of thumb.

Definition at line 3511 of file window.h.

int barStart [inherited]

The start pixel of thumb.

Definition at line 3487 of file window.h.

DWORD(* calc_3dbox_color)(DWORD color, int flag) [inherited]

The function pointer to calculate lighter, lightest, darker and darkest color according to main color.

Parameters:
color The main color.
flag The color type, can be one of the values:
  • LFRDR_3DBOX_COLOR_DARKER
    darker color.
  • LFRDR_3DBOX_COLOR_DARKEST
    darkest color.
  • LFRDR_3DBOX_COLOR_LIGHTER
    lighter color.
  • LFRDR_3DBOX_COLOR_LIGHTEST
    lightest color.

void(* calc_thumb_area)(HWND hWnd, BOOL vertical, LFSCROLLBARINFO *sb_info) [inherited]

The pointer to calculate scrollbar's thumb area function.

Parameters:
vertical | Vertical scrollbar or Horizontal scrollbar.
sb_info | The scrollbar information for calculating result.

void(* calc_trackbar_rect)(HWND hWnd, LFRDR_TRACKBARINFO *info, DWORD dwStyle, const RECT *rcClient, RECT *rcRuler, RECT *rcBar, RECT *rcBorder) [inherited]

The pointer to get trackbar rect function.

int(* calc_we_area)(HWND hWnd, int which, RECT *we_area) [inherited]

The pointer to calculate window element area function.

Parameters:
which | The hit test code of the part to be calculated.
we_area | The reactangle for calculating result.

int(* calc_we_metrics)(HWND hWnd, LFRDR_WINSTYLEINFO *style_info, int which) [inherited]

The pointer to calculate window element metrics function.

Parameters:
which,can be one of the following values:
  • LFRDR_METRICS_BORDER
    The metrics of window border.
  • LFRDR_METRICS_CAPTION_H
    The height of window caption.
  • LFRDR_METRICS_MENU_H
    The height of window menu.
  • LFRDR_METRICS_VSCROLL_W
    The width of vertical scrollbar.
  • LFRDR_METRICS_HSCROLL_H
    The height of horizontal scrollbar.
  • LFRDR_METRICS_ICON_H
    The height of window icon.
  • LFRDR_METRICS_ICON_W
    The width of window icon.
  • LFRDR_METRICS_MINWIN_WIDTH
    The minimize width of window.
  • LFRDR_METRICS_MINWIN_HEIGHT
    The minimize height of window.

const char* caption [inherited]

Dialog box caption

Definition at line 8720 of file window.h.

const char* caption [inherited]

Control caption

Definition at line 8690 of file window.h.

UINT cch [inherited]

Used by GetMenuItemInfo function to indicate the maximal length of the string

Definition at line 8071 of file window.h.

PBITMAP checkedbmp [inherited]

The pointer to a BITMAP object used for checked bitmap menu item

Definition at line 8059 of file window.h.

int cl [inherited]

The position and size of client area.

Definition at line 4045 of file window.h.

int controlnr [inherited]

Number of controls

Definition at line 8726 of file window.h.

PCTRLDATA controls [inherited]

Poiter to control array

Definition at line 8728 of file window.h.

int curPos [inherited]

The current scrollbar pos.

Definition at line 3505 of file window.h.

int curPos [inherited]

The current scrollbar pos.

Definition at line 3481 of file window.h.

void(* customize_desktop_menu)(void *context, HMENU hmenu, int start_pos) [inherited]

the desktop menu customizer

int(* deinit)(PWERENDERER renderer) [inherited]

The pointer to release function. It is used to release renderer resource.

See also:
init

void(* deinit)(void *context) [inherited]

called when terminating a seesion

void(* desktop_menucmd_handler)(void *context, int id) [inherited]

the desktop menu command handler

void(* disabled_text_out)(HWND hWnd, HDC hdc, const char *spText, PRECT rc, DWORD dt_fmt) [inherited]

The pointer to output disabled text function.

void(* draw_3dbox)(HDC hdc, const RECT *pRect, DWORD color, DWORD flag) [inherited]

The pointer to draw 3dbox function.

Parameters:
flag,can be OR'ed by the following values:
  • LFRDR_BTN_STATUS_NORMAL
    Normal status.
  • LFRDR_BTN_STATUS_HILITE
    Highlight status.
  • LFRDR_BTN_STATUS_PRESSED
    Pushed status.
  • LFRDR_BTN_STATUS_DISABLED
    Disabled status.
  • LFRDR_BTN_STATUS_SELECTED
    Selected status.
  • LFRDR_3DBOX_THICKFRAME
    Use thick/thin frame.
  • LFRDR_3DBOX_FILLED
    Filled rectangle.

void(* draw_arrow)(HWND hWnd, HDC hdc, const RECT *pRect, DWORD color, int status) [inherited]

The pointer to draw arrow function.

Parameters:
status,can be OR'ed by the following values:
  • LFRDR_ARROW_LEFT
    Left arrow.
  • LFRDR_ARROW_RIGHT
    Right arrow.
  • LFRDR_ARROW_UP
    Up arrow.
  • LFRDR_ARROW_DOWN
    Down arrow.
  • LFRDR_ARROW_NOFILL
    No filled arrow area.
  • LFRDR_ARROW_HAVESHELL
    Have shell for arrow.

void(* draw_border)(HWND hWnd, HDC hdc, BOOL is_active) [inherited]

The pointer to draw window border function.

void(* draw_caption)(HWND hWnd, HDC hdc, BOOL is_active) [inherited]

The pointer to draw window text and icon function.

void(* draw_caption_button)(HWND hwnd, HDC hdc, int ht_code, int state) [inherited]

The pointer to draw caption button function.

Parameters:
ht_code The hittest code. If 0, it should draw all buttons.
state The button state, can be one of the values:
  • LFRDR_BTN_STATUS_NORMAL
    Normal status.
  • LFRDR_BTN_STATUS_HILITE
    Highlight status.
  • LFRDR_BTN_STATUS_PRESSED
    Pushed status.
  • LFRDR_BTN_STATUS_DISABLED
    Disabled status.

void(* draw_check_button)(HWND hWnd, HDC hdc, const RECT *pRect, int status) [inherited]

The pointer to draw check button function, this function used by button.

Parameters:
status,can be OR'ed by the following values:
  • LFRDR_BTN_STATUS_NORMAL
    Normal status.
  • LFRDR_BTN_STATUS_HILITE
    Highlight status.
  • LFRDR_BTN_STATUS_PRESSED
    Pushed status.
  • LFRDR_BTN_STATUS_DISABLED
    Disabled status.
  • LFRDR_BTN_STATUS_SELECTED
    Selected status.

void(* draw_checkbox)(HDC hdc, const RECT *pRect, DWORD color, int status) [inherited]

The pointer to draw checkbox function.

See also:
draw_radio

void(* draw_checkmark)(HDC hdc, const RECT *pRect, DWORD color, int status) [inherited]

The pointer to draw checkmark function.

See also:
draw_radio

void(* draw_custom_hotspot)(HWND hWnd, HDC hdc, int ht_code, int state) [inherited]

The pointer to draw user-defined hotspot function.

Parameters:
ht_code The hittest code. If 0, it should draw all user-defined hotspot.
state The button state, can be one of the values:
  • LFRDR_BTN_STATUS_NORMAL
  • LFRDR_BTN_STATUS_HILITE
  • LFRDR_BTN_STATUS_PRESSED

void(* draw_disabled_item)(HWND hWnd, HDC hdc, const RECT *pRect, DWORD color) [inherited]

The pointer to draw disabled item function, this function used by listbox.

void(* draw_disabled_menu_item)(HWND hWnd, HDC hdc, const RECT *pRect, DWORD color) [inherited]

The pointer to draw menu disabled item function.

void(* draw_focus_frame)(HDC hdc, const RECT *pRect, DWORD color) [inherited]

The pointer to draw focus frame function.

void(* draw_fold)(HWND hWnd, HDC hdc, const RECT *pRect, DWORD color, int status, int next) [inherited]

The pointer to draw fold function, this function used by listview and treeview.

Parameters:
status,can be OR'ed by the following values:
  • LFRDR_TREE_FOLD
    Draw opening/closing folder.
  • LFRDR_TREE_CHILD
    Draw connecting status between parent and child node.
  • LFRDR_TREE_NEXT
    Draw connecting status between current and next node.
next The number of child node.

void(* draw_header)(HWND hWnd, HDC hdc, const RECT *pRect, DWORD color) [inherited]

The pointer to draw table header function. this function used by listview and gridview.

void(* draw_hilite_item)(HWND hWnd, HDC hdc, const RECT *pRect, DWORD color) [inherited]

The pointer to draw highlight item function, this function used by listbox.

void(* draw_hilite_menu_item)(HWND hWnd, HDC hdc, const RECT *pRect, DWORD color) [inherited]

The pointer to draw menu highlight item function.

void(* draw_normal_item)(HWND hWnd, HDC hdc, const RECT *pRect, DWORD color) [inherited]

The pointer to draw normal item function, this function used by listbox.

void(* draw_normal_menu_item)(HWND hWnd, HDC hdc, const RECT *pRect, DWORD color) [inherited]

The pointer to draw menu normal item function.

void(* draw_progress)(HWND hWnd, HDC hdc, int nMax, int nMin, int nPos, BOOL fVertical) [inherited]

The pointer to draw progressbar's chunk/bar function.

void(* draw_push_button)(HWND hWnd, HDC hdc, const RECT *pRect, DWORD color1, DWORD color2, int status) [inherited]

The pointer to draw push button function, this function used by button.

Parameters:
status,can be OR'ed by the following values:
  • BST_NORMAL
  • BST_HILITE
  • BST_PUSHED
  • BST_DISABLE
  • BST_UNCHECKED
  • BST_CHECKED
  • BST_INDETERMINATE
  • BST_FOCUS

void(* draw_radio)(HDC hdc, const RECT *pRect, DWORD color, int status) [inherited]

The pointer to draw radio function.

Parameters:
status,can be OR'ed by the following values:
  • LFRDR_MARK_ALL_SELECTED
    All selected status.
  • LFRDR_MARK_HALF_SELECTED
    Half selected status.
  • LFRDR_MARK_HAVESHELL
    Have shell for mark.

void(* draw_radio_button)(HWND hWnd, HDC hdc, const RECT *pRect, int status) [inherited]

The pointer to draw radio button function, the function ued by button.

Parameters:
status,can be OR'ed by the following values:
  • LFRDR_BTN_STATUS_NORMAL
    Normal status.
  • LFRDR_BTN_STATUS_HILITE
    Highlight status.
  • LFRDR_BTN_STATUS_PRESSED
    Pushed status.
  • LFRDR_BTN_STATUS_DISABLED
    Disabled status.
  • LFRDR_BTN_STATUS_SELECTED
    Selected status.

void(* draw_scrollbar)(HWND hWnd, HDC hdc, int sb_pos) [inherited]

The pointer to draw scrollbar function.

Parameters:
sb_pos The position need to be paint. If 0, it should draw all the scrollbar.
status,which is one of the value:
  • LFRDR_BTN_STATUS_NORMAL
    Normal status.
  • LFRDR_BTN_STATUS_HILITE
    Highlight status.
  • LFRDR_BTN_STATUS_PRESSED
    Pushed status.
  • LFRDR_BTN_STATUS_DISABLED
    Disabled status.

void(* draw_significant_item)(HWND hWnd, HDC hdc, const RECT *pRect, DWORD color) [inherited]

The pointer to draw significant item function, this function used by listbox.

void(* draw_tab)(HWND hWnd, HDC hdc, RECT *rect, char *title, DWORD color, int flag, HICON icon) [inherited]

The pointer to draw propsheet's tab function.

Parameters:
flag,can be OR'ed by the following values:
  • LFRDR_TAB_BOTTOM
    Use bottom tab.
  • LFRDR_TAB_ACTIVE
    Active tab.
  • LFRDR_TAB_ICON
    With icon.

void(* draw_trackbar)(HWND hWnd, HDC hdc, LFRDR_TRACKBARINFO *info) [inherited]

The pointer to draw trackbar function.

DWORD dwAddData [inherited]

Addtional data, must be zero

Definition at line 8730 of file window.h.

DWORD dwAddData [inherited]

Additional data

Definition at line 8692 of file window.h.

DWORD dwAddData [inherited]

The private additional data associated with this window class

Definition at line 6932 of file window.h.

DWORD dwAddData [inherited]

The first private data associated with the main window

Definition at line 4916 of file window.h.

DWORD dwExStyle [inherited]

Dialog box extended style

Definition at line 8716 of file window.h.

DWORD dwExStyle [inherited]

Control extended style

Definition at line 8694 of file window.h.

DWORD dwExStyle [inherited]

Extended window style for all instances of this window class

Definition at line 6920 of file window.h.

DWORD dwExStyle [inherited]

The extended style of the main window

Definition at line 4889 of file window.h.

DWORD dwExStyle [inherited]

The extended styles of window.

Definition at line 4051 of file window.h.

DWORD dwReserved [inherited]

Reserved, do not use

Definition at line 4919 of file window.h.

DWORD dwStyle [inherited]

Control style

Definition at line 8684 of file window.h.

DWORD dwStyle [inherited]

Window style for all instances of this window class

Definition at line 6917 of file window.h.

DWORD dwStyle [inherited]

The styles of window.

Definition at line 4049 of file window.h.

void(* erase_background)(HWND hWnd, HDC hdc, const RECT *rect) [inherited]

The pointer to erase background function.

UINT fMask [inherited]

A flag indicates which fields contain valid values, can be OR'ed value of the following values:

  • SIF_RANGE
    Retrives or sets the range of the scroll bar.
  • SIF_PAGE
    Retrives or sets the page size of the scroll bar.
  • SIF_POS
    Retrives or sets the position of the scroll bar.
  • SIF_DISABLENOSCROLL
    Hides the scroll when disabled, not implemented so far.

Definition at line 6798 of file window.h.

HACCEL hAccel [inherited]

The handle of accelerator table.

Definition at line 4058 of file window.h.

HCURSOR hCursor [inherited]

Cursor handle to all instances of this window class

Definition at line 6923 of file window.h.

HCURSOR hCursor [inherited]

The handle to the cursor of the main window

Definition at line 4898 of file window.h.

HCURSOR hCursor [inherited]

The handle of cursor.

Definition at line 4060 of file window.h.

HWND hHosting [inherited]

The hosting main window

Definition at line 4904 of file window.h.

HICON hIcon [inherited]

Dialog box icon

Definition at line 8722 of file window.h.

HICON hIcon [inherited]

The handle to the icon of the main window

Definition at line 4901 of file window.h.

HICON hIcon [inherited]

The handle of icon.

Definition at line 4062 of file window.h.

int(* hit_test)(HWND hWnd, int x, int y) [inherited]

The pointer to hittest function.

Parameters:
x,y The position of the mouse in screen coordinates.
Returns:
HT_XXX or HT_USER_XXX, hittest value.

HMENU hMenu [inherited]

Dialog box menu

Definition at line 8724 of file window.h.

HMENU hMenu [inherited]

The handle to the menu of the main window

Definition at line 4895 of file window.h.

HMENU hMenu [inherited]

The handle of menu.

Definition at line 4056 of file window.h.

MSGHOOK hook [inherited]

the pointer to the hook function.

Definition at line 2833 of file window.h.

LFSCROLLBARINFO hscroll [inherited]

The horizital scrollbar information.

Definition at line 4076 of file window.h.

HMENU hsubmenu [inherited]

The handle to the sub-menu if this menu contains a sub menu

Definition at line 8053 of file window.h.

HMENU hSysMenu [inherited]

The handle of system menu.

Definition at line 4064 of file window.h.

int iBkColor [inherited]

Background color pixel value of all instances of this window class

Definition at line 6926 of file window.h.

int iBkColor [inherited]

The pixel value of background color of the main window

Definition at line 4913 of file window.h.

int iBkColor [inherited]

The background color.

Definition at line 4054 of file window.h.

int id [inherited]

Control identifier

Definition at line 8688 of file window.h.

int id [inherited]

The identifier of the menu item

Definition at line 8050 of file window.h.

int id [inherited]

The identifier of window.

Definition at line 4071 of file window.h.

int(* init)(PWERENDERER renderer) [inherited]

The pointer to initialize function. It is used to initialize basic renderer information (metrics, color, font, icon, etc) and private information.

DWORD itemdata [inherited]

The private data attached to the menu item

Definition at line 8062 of file window.h.

int key_nr [inherited]

Key number in the section

Definition at line 1812 of file minigui.h.

void(* keyboard_handler)(void *context, int message, WPARAM wParam, LPARAM lParam) [inherited]

the keyboard event handler for the desktop

char** keys [inherited]

Array of keys

Definition at line 1816 of file minigui.h.

LPARAM lParam [inherited]

The second parameter of the message (32-bit integer).

Definition at line 2161 of file window.h.

int lx [inherited]

The position of the main window in the screen coordinates

Definition at line 4910 of file window.h.

int(* MainWindowProc)(HWND, int, WPARAM, LPARAM) [inherited]

The window callback procedure

int maxPos [inherited]

The max value of scrollbar range.

Definition at line 3503 of file window.h.

int maxPos [inherited]

The max value of scrollbar range.

Definition at line 3479 of file window.h.

int message [inherited]

The message identifier.

Definition at line 2157 of file window.h.

void(* mouse_handler)(void *context, int message, WPARAM wParam, LPARAM lParam) [inherited]

the mouse event handler for the desktop

char* name [inherited]

Name of the section

Definition at line 1814 of file minigui.h.

int nMax [inherited]

The maximum position value of the scroll bar

Definition at line 6802 of file window.h.

int nMin [inherited]

The minimum position value of the scroll bar

Definition at line 6800 of file window.h.

UINT nPage [inherited]

The page size of the scroll bar

Definition at line 6804 of file window.h.

int nPos [inherited]

The position value of the scroll bar

Definition at line 6806 of file window.h.

int(* on_click_hotspot)(HWND hWnd, int which) [inherited]

The pointer to user-defined hotspot function.

DWORD(* on_get_rdr_attr)(struct _WINDOW_ELEMENT_RENDERER *, int we_attr_id) [inherited]

The pointer to get renderer private data function.

Parameters:
we_attr_id The id pointed renderer private data.

DWORD(* on_set_rdr_attr)(struct _WINDOW_ELEMENT_RENDERER *, int we_attr_id, DWORD we_attr, BOOL change) [inherited]

The pointer to set renderer private data function.

Parameters:
we_attr_id | The id pointed renderer private data.
we_attr | The new renderer private data.

DWORD opMask [inherited]

The mask of class information, can be OR'd with the following values:

  • COP_STYLE
    Retrive the style of the window class.
  • COP_HCURSOR
    Retrive the cursor of the window class.
  • COP_BKCOLOR
    Retrive the background pixel value of the window class.
  • COP_WINPROC Retrive the window procedure of the window class.
  • COP_ADDDATA
    Retrive the additional data of the window class.

Definition at line 6914 of file window.h.

int pageStep [inherited]

The step per page.

Definition at line 3507 of file window.h.

int pageStep [inherited]

The step per page.

Definition at line 3483 of file window.h.

void(* paint_desktop)(void *context, HDC dc_desktop, const RECT *inv_rc) [inherited]

called when the desktop should be repainted

PLOGFONT pLogFont [inherited]

The pointer to logical font.

Definition at line 4066 of file window.h.

const void* private_info [inherited]

The private information.

Definition at line 4032 of file window.h.

unsigned int refcount [inherited]

The reference count.

Definition at line 4029 of file window.h.

int section_nr [inherited]

Number of sections

Definition at line 1829 of file minigui.h.

PETCSECTION sections [inherited]

Pointer to section arrays

Definition at line 1831 of file minigui.h.

const char* spCaption [inherited]

The caption of the main window

Definition at line 4892 of file window.h.

char* spCaption [inherited]

The caption of window.

Definition at line 4069 of file window.h.

UINT state [inherited]

State of the menu item, can be one of the following values:

  • MFS_GRAYED
    The menu item is disabled.
  • MFS_DISABLED
    The menu item is disabled.
  • MFS_CHECKED
    The menu item is checked.
  • MFS_ENABLED
    The menu item is enabled.
  • MFS_UNCHECKED
    The menu item is unchecked.

Definition at line 8047 of file window.h.

int status [inherited]

The status of scrollbar.

Definition at line 3522 of file window.h.

int status [inherited]

The status of scrollbar.

Definition at line 3491 of file window.h.

unsigned int time [inherited]

Time

Definition at line 2163 of file window.h.

UINT type [inherited]

Type of menu item, can be one of the following values:

  • MFT_STRING
    A normal string menu item.

  • MFT_BITMAP
    A bitmap menu item. When the menu item is this type, the member typedata will be the pointer to the normal BITMAP object, the member uncheckedbmp will be the pointer to the hilighted BITMAP object, the member checkedbmp will be the pointer to the checked BITMAP object.

  • MFT_BMPSTRING
    A bitmap menu item followed by a string. When the menu item is this type, the member typedata will be the pointer to the text string, the member uncheckedbmp will be the pointer to the normal BITMAP object, and the member checkedbmp will be the pointer to the checked BITMAP object.

  • MFT_SEPARATOR
    A separator in menu.

  • MFT_RADIOCHECK
    A normal string with a radio check mark.

  • MFT_MARKCHECK
    A normal string with a check box mark.

Definition at line 8032 of file window.h.

DWORD typedata [inherited]

The data of this menu item, used to pass the string or the pointer to the BITMAP object of the menu item

Definition at line 8065 of file window.h.

PBITMAP uncheckedbmp [inherited]

The pointer to a BITMAP object used for unchecked/highlited bitmap menu item

Definition at line 8056 of file window.h.

char** values [inherited]

Array of values

Definition at line 1818 of file minigui.h.

LFSCROLLBARINFO vscroll [inherited]

The vertical scrollbar information.

Definition at line 4074 of file window.h.

DWORD we_attr [inherited]

The attribute value.

Definition at line 3462 of file window.h.

const WINDOW_ELEMENT_ATTR* we_attrs [inherited]

table of we_attrs

Definition at line 8700 of file window.h.

DWORD we_colors[WE_COLORS_NUMBER][3] [inherited]

The window element color information.

Definition at line 4020 of file window.h.

PLOGFONT we_fonts[WE_FONTS_NUMBER] [inherited]

The window element font information.

Definition at line 4023 of file window.h.

HICON we_icon[2][SYSICO_ITEM_NUMBER] [inherited]

The renderer icon information.

Definition at line 4026 of file window.h.

int we_metrics[WE_METRICS_NUMBER] [inherited]

The window element metrics information.

Definition at line 4017 of file window.h.

WINDOW_ELEMENT_RENDERER* we_rdr [inherited]

The window renderer.

Definition at line 4079 of file window.h.

const char* werdr_name [inherited]

window element renderer name

Definition at line 8697 of file window.h.

int(* WinProc)(HWND, int, WPARAM, LPARAM) [inherited]

Window callback procedure of all instances of this window class

int winType [inherited]

The window type, can be one of the values:

  • LFRDR_WINTYPE_DIALOG
    For dialog.
  • LFRDR_WINTYPE_MAINWIN
    For main window.
  • LFRDR_WINTYPE_CONTROL
    For control.

Definition at line 3573 of file window.h.

WPARAM wParam [inherited]

The first parameter of the message (32-bit integer).

Definition at line 2159 of file window.h.

int x [inherited]

Dialog box position

Definition at line 8718 of file window.h.

int x [inherited]

Control position in dialog

Definition at line 8686 of file window.h.

Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: System colors and pixel values.

System colors and pixel values.
[Global variables]

Defines

  • #define PIXEL_invalid 0
    Invalid pixel.
  • #define PIXEL_transparent SysPixelIndex[0]
    Transparent.
  • #define PIXEL_darkblue SysPixelIndex[1]
    Dark blue.
  • #define PIXEL_darkgreen SysPixelIndex[2]
    Dark green.
  • #define PIXEL_darkcyan SysPixelIndex[3]
    Dark cyan.
  • #define PIXEL_darkred SysPixelIndex[4]
    Dark red.
  • #define PIXEL_darkmagenta SysPixelIndex[5]
    Dark magenta.
  • #define PIXEL_darkyellow SysPixelIndex[6]
    Dark yellow.
  • #define PIXEL_darkgray SysPixelIndex[7]
    Dark gray.
  • #define PIXEL_lightgray SysPixelIndex[8]
    Light gray.
  • #define PIXEL_blue SysPixelIndex[9]
    Blue.
  • #define PIXEL_green SysPixelIndex[10]
    Green.
  • #define PIXEL_cyan SysPixelIndex[11]
    Cyan.
  • #define PIXEL_red SysPixelIndex[12]
    Red.
  • #define PIXEL_magenta SysPixelIndex[13]
    Magenta.
  • #define PIXEL_yellow SysPixelIndex[14]
    Yellow.
  • #define PIXEL_lightwhite SysPixelIndex[15]
    Light white.
  • #define PIXEL_black SysPixelIndex[16]
    Black.
  • #define COLOR_invalid PIXEL_invalid
  • #define COLOR_transparent PIXEL_transparent
  • #define COLOR_darkred PIXEL_darkred
  • #define COLOR_darkgreen PIXEL_darkgreen
  • #define COLOR_darkyellow PIXEL_darkyellow
  • #define COLOR_darkblue PIXEL_darkblue
  • #define COLOR_darkmagenta PIXEL_darkmagenta
  • #define COLOR_darkcyan PIXEL_darkcyan
  • #define COLOR_lightgray PIXEL_lightgray
  • #define COLOR_darkgray PIXEL_darkgray
  • #define COLOR_red PIXEL_red
  • #define COLOR_green PIXEL_green
  • #define COLOR_yellow PIXEL_yellow
  • #define COLOR_blue PIXEL_blue
  • #define COLOR_magenta PIXEL_magenta
  • #define COLOR_cyan PIXEL_cyan
  • #define COLOR_lightwhite PIXEL_lightwhite
  • #define COLOR_black PIXEL_black
  • #define SysColorIndex SysPixelIndex

Variables

  • MG_EXPORT gal_pixel SysPixelIndex []
    The pre-defined system pixel values.
  • const MG_EXPORT RGB SysPixelColor []
    The pre-defined system RGB colors.

Define Documentation

#define COLOR_black PIXEL_black

See also:
PIXEL_black

Definition at line 332 of file gdi.h.

#define COLOR_blue PIXEL_blue

See also:
PIXEL_blue

Definition at line 308 of file gdi.h.

#define COLOR_cyan PIXEL_cyan

See also:
PIXEL_cyan

Definition at line 320 of file gdi.h.

#define COLOR_darkblue PIXEL_darkblue

See also:
PIXEL_darkblue

Definition at line 260 of file gdi.h.

#define COLOR_darkcyan PIXEL_darkcyan

See also:
PIXEL_darkcyan

Definition at line 272 of file gdi.h.

#define COLOR_darkgray PIXEL_darkgray

See also:
PIXEL_darkgray

Definition at line 284 of file gdi.h.

#define COLOR_darkgreen PIXEL_darkgreen

See also:
PIXEL_darkgreen

Definition at line 248 of file gdi.h.

#define COLOR_darkmagenta PIXEL_darkmagenta

See also:
PIXEL_darkmagenta

Definition at line 266 of file gdi.h.

#define COLOR_darkred PIXEL_darkred

See also:
PIXEL_darkred

Definition at line 242 of file gdi.h.

#define COLOR_darkyellow PIXEL_darkyellow

See also:
PIXEL_darkyellow

Definition at line 254 of file gdi.h.

#define COLOR_green PIXEL_green

See also:
PIXEL_green

Definition at line 296 of file gdi.h.

#define COLOR_invalid PIXEL_invalid

See also:
PIXEL_invalid

Definition at line 230 of file gdi.h.

#define COLOR_lightgray PIXEL_lightgray

See also:
PIXEL_lightgray

Definition at line 278 of file gdi.h.

#define COLOR_lightwhite PIXEL_lightwhite

See also:
PIXEL_lightwhite

Definition at line 326 of file gdi.h.

#define COLOR_magenta PIXEL_magenta

See also:
PIXEL_magenta

Definition at line 314 of file gdi.h.

#define COLOR_red PIXEL_red

See also:
PIXEL_red

Definition at line 290 of file gdi.h.

#define COLOR_transparent PIXEL_transparent

See also:
PIXEL_transparent

Definition at line 236 of file gdi.h.

#define COLOR_yellow PIXEL_yellow

See also:
PIXEL_yellow

Definition at line 302 of file gdi.h.

#define PIXEL_black SysPixelIndex[16]

Black.

See also:
SysPixelIndex

Definition at line 223 of file gdi.h.

#define PIXEL_blue SysPixelIndex[9]

Blue.

See also:
SysPixelIndex

Definition at line 174 of file gdi.h.

#define PIXEL_cyan SysPixelIndex[11]

Cyan.

See also:
SysPixelIndex

Definition at line 188 of file gdi.h.

#define PIXEL_darkblue SysPixelIndex[1]

Dark blue.

See also:
SysPixelIndex

Definition at line 118 of file gdi.h.

#define PIXEL_darkcyan SysPixelIndex[3]

Dark cyan.

See also:
SysPixelIndex

Definition at line 132 of file gdi.h.

#define PIXEL_darkgray SysPixelIndex[7]

Dark gray.

See also:
SysPixelIndex

Definition at line 160 of file gdi.h.

#define PIXEL_darkgreen SysPixelIndex[2]

Dark green.

See also:
SysPixelIndex

Definition at line 125 of file gdi.h.

#define PIXEL_darkmagenta SysPixelIndex[5]

Dark magenta.

See also:
SysPixelIndex

Definition at line 146 of file gdi.h.

#define PIXEL_darkred SysPixelIndex[4]

Dark red.

See also:
SysPixelIndex

Definition at line 139 of file gdi.h.

#define PIXEL_darkyellow SysPixelIndex[6]

Dark yellow.

See also:
SysPixelIndex

Definition at line 153 of file gdi.h.

#define PIXEL_green SysPixelIndex[10]

Green.

See also:
SysPixelIndex

Definition at line 181 of file gdi.h.

#define PIXEL_invalid 0

Invalid pixel.

See also:
SysPixelIndex

Definition at line 104 of file gdi.h.

#define PIXEL_lightgray SysPixelIndex[8]

Light gray.

See also:
SysPixelIndex

Definition at line 167 of file gdi.h.

#define PIXEL_lightwhite SysPixelIndex[15]

Light white.

See also:
SysPixelIndex

Definition at line 216 of file gdi.h.

#define PIXEL_magenta SysPixelIndex[13]

Magenta.

See also:
SysPixelIndex

Definition at line 202 of file gdi.h.

#define PIXEL_red SysPixelIndex[12]

Red.

See also:
SysPixelIndex

Definition at line 195 of file gdi.h.

#define PIXEL_transparent SysPixelIndex[0]

Transparent.

See also:
SysPixelIndex

Definition at line 111 of file gdi.h.

#define PIXEL_yellow SysPixelIndex[14]

Yellow.

See also:
SysPixelIndex

Definition at line 209 of file gdi.h.

#define SysColorIndex SysPixelIndex

See also:
SysPixelIndex

Definition at line 338 of file gdi.h.

Variable Documentation

RGB SysPixelColor[]

The pre-defined system RGB colors.

The elements in this array are system colors in RGB triples.

gal_pixel SysPixelIndex[]

The pre-defined system pixel values.

MiniGUI defines some system pixel values when initializing graphics sub-system. You can access the arrary to get the system pixel values, or just use the following macros:

  • PIXEL_black
    black
  • PIXEL_darkred
    dark red
  • PIXEL_darkgreen
    dark green
  • PIXEL_darkyellow
    dark yellow
  • PIXEL_darkblue
    dark blue
  • PIXEL_darkmagenta
    dark magenta
  • PIXEL_darkcyan
    dark cyan
  • PIXEL_lightgray
    light gray
  • PIXEL_darkgray
    dark gray
  • PIXEL_red
    red
  • PIXEL_green
    green
  • PIXEL_yellow
    yellow
  • PIXEL_blue
    blue
  • PIXEL_magenta
    magenta
  • PIXEL_cyan
    cyan
  • PIXEL_lightwhite
    light white

Generated on Fri Dec 17 13:49:47 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Global Rectangles

Global Rectangles
[Global variables]

Defines

  • #define g_rcDesktop g_rcScr
    Contains the rectangle of desktop of the application.

Variables

  • MG_EXPORT RECT g_rcScr
    Contains the rectangle of the whole screen.

Define Documentation

#define g_rcDesktop g_rcScr

Contains the rectangle of desktop of the application.

g_rcDesktop is defined as an alias (macro) of g_rcScr.

See also:
g_rcScr

Definition at line 65 of file minigui.h.

Variable Documentation

RECT g_rcScr

Contains the rectangle of the whole screen.

Generated on Fri Dec 17 13:49:48 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: MiniGUI-Processes specific variables

MiniGUI-Processes specific variables
[Global variables]

Generated on Fri Dec 17 13:49:48 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: x virtual framebuffer

x virtual framebuffer
[Global variables]

Data Structures

  • struct _XVFBHeader
  • struct _XVFBKEYDATA
  • struct _XVFBMOUSEDATA
  • struct _XVFBEVENT
  • struct _XVFBPalEntry

Variables

  • MG_EXPORT void * __mg_rtos_xvfb_event_buffer
    shared memory header of x virtual framebuffer.

Variable Documentation

void * __mg_rtos_xvfb_event_buffer

shared memory header of x virtual framebuffer.

event circular buffer

x virtual framebuffer put event to it, and minigui get event from it.

Generated on Fri Dec 17 13:49:50 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _XVFBHeader Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_XVFBHeader Struct Reference
[x virtual framebuffer]

#include <xvfb.h>

Data Fields

  • unsigned int info_size
  • int width
  • int height
  • int depth
  • Uint8 MSBLeft
  • Uint32 Rmask
  • Uint32 Gmask
  • Uint32 Bmask
  • Uint32 Amask
  • int pitch
  • int dirty
  • int dirty_rc_l
  • int dirty_rc_t
  • int dirty_rc_r
  • int dirty_rc_b
  • int palette_changed
  • int palette_offset
  • int fb_offset

Detailed Description

infomation header of xvfb frame buffer.

Definition at line 50 of file xvfb.h.

Field Documentation

unsigned int info_size

size of infomation header

Definition at line 53 of file xvfb.h.

int width

width of x virtual framebuffer

Definition at line 56 of file xvfb.h.

int height

height of x virtual framebuffer

Definition at line 59 of file xvfb.h.

int depth

color depth of x virtual framebuffer

Definition at line 62 of file xvfb.h.

Uint8 MSBLeft

The flag indicating the Most Significant Bits (MSB) is left when depth is less than 8.

Definition at line 68 of file xvfb.h.

Uint32 Rmask

the pixel red color mask for x virtual framebuffer.

Definition at line 71 of file xvfb.h.

Uint32 Gmask

the pixel green color mask for x virtual framebuffer.

Definition at line 74 of file xvfb.h.

Uint32 Bmask

the pixel blue color mask for x virtual framebuffer.

Definition at line 77 of file xvfb.h.

Uint32 Amask

the pixel alpha mask for x virtual framebuffer.

Definition at line 80 of file xvfb.h.

int pitch

The pitch of x virtual framebuffer.

Definition at line 83 of file xvfb.h.

int dirty

Flag indicate whether x virtual framebuffer should be update, and should reset to false after refreshing the dirty area

Definition at line 89 of file xvfb.h.

int dirty_rc_l

the left of dirty area

Definition at line 92 of file xvfb.h.

int dirty_rc_t

the top of dirty area

Definition at line 94 of file xvfb.h.

int dirty_rc_r

the right of dirty area

Definition at line 96 of file xvfb.h.

int dirty_rc_b

the bottom of dirty area

Definition at line 98 of file xvfb.h.

int palette_changed

Flag indicate whether palette have been changed, and should reset to false after reflecting the change.

Definition at line 104 of file xvfb.h.

int palette_offset

the offset off palette based on address of XVFBHeader.

Definition at line 107 of file xvfb.h.

int fb_offset

the offset off framebuffer based on address of XVFBHeader.

Definition at line 110 of file xvfb.h.

The documentation for this struct was generated from the following file:
  • xvfb.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _XVFBKEYDATA Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_XVFBKEYDATA Struct Reference
[x virtual framebuffer]

#include <xvfb.h>

Data Fields

  • unsigned short key_code
  • unsigned short key_state

Detailed Description

data of keyboard event

Definition at line 115 of file xvfb.h.

Field Documentation

unsigned short key_code

the scancode in minigui of the keyboard.

Definition at line 118 of file xvfb.h.

unsigned short key_state

the keyboard state

  • 0 pressed
  • 1 released

Definition at line 125 of file xvfb.h.

The documentation for this struct was generated from the following file:
  • xvfb.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _XVFBMOUSEDATA Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_XVFBMOUSEDATA Struct Reference
[x virtual framebuffer]

#include <xvfb.h>

Data Fields

  • unsigned short x
  • unsigned short y
  • unsigned short btn

Detailed Description

data of mouse event

Definition at line 129 of file xvfb.h.

Field Documentation

unsigned short x

x coordinate of mouse

Definition at line 132 of file xvfb.h.

unsigned short y

y coordinate of mouse

Definition at line 135 of file xvfb.h.

unsigned short btn

buttons pressed of mouse, can be OR'ed by following values:

  • 0x0001 left button pressed
  • 0x0002 right button pressed

Definition at line 142 of file xvfb.h.

The documentation for this struct was generated from the following file:
  • xvfb.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _XVFBEVENT Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_XVFBEVENT Struct Reference
[x virtual framebuffer]

#include <xvfb.h>

Data Fields

  • int event_type
  • XVFBKEYDATA kb_data
  • XVFBMOUSEDATA mouse_data

Detailed Description

event sended to minigui by x virtual framebuffer

Definition at line 147 of file xvfb.h.

Field Documentation

int event_type

  • 0 the event is mouse event
  • 1 the event is keyboard event

Definition at line 153 of file xvfb.h.

XVFBKEYDATA kb_data

keyboard event data

Definition at line 157 of file xvfb.h.

XVFBMOUSEDATA mouse_data

mouse event data

Definition at line 159 of file xvfb.h.

The documentation for this struct was generated from the following file:
  • xvfb.h
Generated on Fri Dec 17 13:49:52 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: _XVFBPalEntry Struct Reference

  • Alphabetical List
  • Data Structures
  • Data Fields

_XVFBPalEntry Struct Reference
[x virtual framebuffer]

#include <xvfb.h>

Data Fields

  • unsigned char r
  • unsigned char g
  • unsigned char b
  • unsigned char a

Detailed Description

the entry in palette

Definition at line 165 of file xvfb.h.

Field Documentation

unsigned char r

red of color in palette

Definition at line 167 of file xvfb.h.

unsigned char g

gree of color in palette

Definition at line 169 of file xvfb.h.

unsigned char b

blue of color in palette

Definition at line 171 of file xvfb.h.

unsigned char a

alpha weight of color in palette

Definition at line 173 of file xvfb.h.

The documentation for this struct was generated from the following file:
  • xvfb.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- a -

  • a : _RGB , _GAL_Color , _XVFBPalEntry
  • add_data : _NTBITEMINFO
  • addData : _IVITEMINFO , _LVFINDINFO , _SCROLLVIEWITEMINFO
  • advance_x : _GLYPHBITMAP
  • alpha : _MYBITMAP
  • Amask : _XVFBHeader
  • angle1 : _ARC
  • angle2 : _ARC
  • arrowLen : _SCROLLBARDATA , _LFSCROLLBARINFO
  • ascent : _FONTMETRICS , _LOGFONT
  • ave_width : _FONTMETRICS
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: animation.h File Reference

include » ctrl

animation.h File Reference

Go to the source code of this file.

Data Structures

  • struct _ANIMATIONFRAME
  • struct _ANIMATION

Defines

  • #define CTRL_ANIMATION ("Animation")
  • #define ANIMATION_OKAY 0
  • #define ANIMATION_ERR 1
  • #define ANS_AUTOLOOP 0x0001L
    Loop playing the animation automatically.
  • #define ANS_SCALED 0x0002L
    Scale the animation to the control size.
  • #define ANS_FITTOANI 0x0004L
    Resize the control to fit the animation.
  • #define ANM_SETANIMATION 0xF110
    Sets the animation object for the control.
  • #define ANM_GETANIMATION 0xF111
    Gets the animation object of the control.
  • #define ANM_STARTPLAY 0xF112
    Indicates the control to start playing the animation.
  • #define ANM_PAUSE_RESUME 0xF113
    Indicates the control to pause/resume playing the animation.
  • #define ANM_STOPPLAY 0xF114
    Indicates the control to stop playing the animation.
  • #define ANNC_CLICKED 1
    Indicates the user has clicked the control.
  • #define ANNC_DBLCLK 2
    Indicates the user has double clicked the control.

Functions

  • ANIMATION * CreateAnimationFromGIF89a (HDC hdc, MG_RWops *area)
    Creates an ANIMATION obeject from a GIF 89a data source.
  • MG_EXPORT ANIMATION * CreateAnimationFromGIF89aFile (HDC hdc, const char *file)
    Creates an ANIMATION obeject from a GIF 89a file.
  • MG_EXPORT ANIMATION * CreateAnimationFromGIF89aMem (HDC hdc, const void *mem, int size)
    Creates an ANIMATION obeject from a GIF 89a memory data.
  • MG_EXPORT void DestroyAnimation (ANIMATION *anim, BOOL free_it)
    Destories an ANIMATION object.

Detailed Description

Author:
Wei Yongming <ymwei@minigui.org>
Date:
2002/01/06

    Copyright (C) 2002-2008 Feynman Software
    Copyright (C) 1998-2002 Wei Yongming

    All rights reserved by Feynman Software.

    This file is part of MiniGUI, a compact cross-platform Graphics
    User Interface (GUI) support system for real-time embedded systems.

Definition in file animation.h.

Generated on Fri Dec 17 13:49:41 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: button.h File Reference

include » ctrl

button.h File Reference

Go to the source code of this file.

Defines

  • #define BTN_WIDTH_BORDER 4
    The width of button border.
  • #define CTRL_BUTTON ("button")
    The class name of button control.
  • #define BS_PUSHBUTTON 0x00000000L
    Creates a push button that is a pane that displays either a piece of text or an image and when it is pressed it performs an action.
  • #define BS_DEFPUSHBUTTON 0x00000001L
    Creates a push button that behaves like a BS_PUSHBUTTON style button.
  • #define BS_CHECKBOX 0x00000002L
    Creates a check button is a button that can be either selected or deselected, and its selection is independent of the selections of any other buttons.
  • #define BS_AUTOCHECKBOX 0x00000003L
    Creates a button that is almost the same as a check box.
  • #define BS_RADIOBUTTON 0x00000004L
    Creates a radio button that can be either selected or deselected, but when selecting it any other buttons in its group will be cleared.
  • #define BS_AUTORADIOBUTTON 0x00000005L
    Creates a button that is almost the same as a radio button.
  • #define BS_3STATE 0x00000006L
    Creates a button that is almost the same as a check box.
  • #define BS_AUTO3STATE 0x00000007L
    Creates a button that is almost the same as a three-state check box.
  • #define BS_OWNERDRAW 0x0000000AL
    Creates an owner-drawn button.
  • #define BS_TYPEMASK 0x0000000FL
    The type mask of style of button.
  • #define BS_TEXT 0x00000000L
    Specifies that the button displays text.
  • #define BS_LEFTTEXT 0x00000020L
    Places text on the left side.
  • #define BS_ICON 0x00000040L
    Specifies that the button displays an icon.
  • #define BS_BITMAP 0x00000080L
    Specifies that the button displays a bitmap.
  • #define BS_CONTENTMASK 0x000000F0L
    The content mask of style of button.
  • #define BS_LEFT 0x00000100L
    Left-justifies the text in the button rectangle.
  • #define BS_RIGHT 0x00000200L
    Right-justifies text in the button rectangle.
  • #define BS_CENTER 0x00000300L
    Centers text horizontally in the button rectangle.
  • #define BS_TOP 0x00000400L
    Places text at the top of the button rectangle.
  • #define BS_BOTTOM 0x00000800L
    Places text at the bottom of the button rectangle.
  • #define BS_VCENTER 0x00000C00L
    Places text in the middle (vertically) of the button rectangle.
  • #define BS_REALSIZEIMAGE 0x00000F00L
    Does not scale the image.
  • #define BS_ALIGNMASK 0x00000F00L
    The alignment mask of style of button.
  • #define BS_PUSHLIKE 0x00001000L
    Makes a button look and act like a push button.
  • #define BS_MULTLINE 0x00002000L
    Wraps the button text to multiple lines.
  • #define BS_NOTIFY 0x00004000L
    Enables a button to send notification messages to its parent window.
  • #define BS_CHECKED 0x00004000L
    Makes a button checked initially.
  • #define BS_FLAT 0x00008000L
    The flat style of button.
  • #define BS_NOBORDER 0x00010000L
    The no border style of button.
  • #define BS_RIGHTBUTTON BS_LEFTTEXT
    The right style of button.
  • #define BST_POSE_MASK 0x0003
    The pose(normal, hilite, pushed and disable) mask of status of button.
  • #define BST_NORMAL 0x0000
    Specifies the normal state.
  • #define BST_HILITE 0x0001
    Specifies the hilite state.
  • #define BST_PUSHED 0x0002
    Specifies the pushed state.
  • #define BST_DISABLE 0x0003
    Specifies the disable state.
  • #define BST_CHECK_MASK 0x000c
    The check(unchecked, checked and indeterminate) mask of status of button.
  • #define BST_UNCHECKED 0x0000
    Indicates the button is unchecked.
  • #define BST_CHECKED 0x0004
    Indicates the button is checked.
  • #define BST_INDETERMINATE 0x0008
    Indicates the button is grayed because the state of the button is indeterminate.
  • #define BST_FOCUS 0x0010
    Specifies the focus state.
  • #define BM_GETCHECK 0xF0F0
    Retrieves the check state of a radio button or check box.
  • #define BM_SETCHECK 0xF0F1
    Sets the check state of a radio button or check box.
  • #define BM_GETSTATE 0xF0F2
    Gets the state of a button or check box.
  • #define BM_SETSTATE 0xF0F3
    Sets the state of a button.
  • #define BM_SETSTYLE 0xF0F4
    Changes the style of a button.
  • #define BM_CLICK 0xF0F5
    Simulates the user clicking a button.
  • #define BM_ENABLE 0xF0F6
    enable or disable the button. If it is disabled, it can receive mouse and key messages but don't response them
  • #define BM_GETIMAGE 0xF0F7
    Retrieves the handle to the image.
  • #define BM_SETIMAGE 0xF0F8
    Associates a new image (icon or bitmap) with the button.
  • #define BN_CLICKED 0
    The BN_CLICKED notification message is sent when the user clicks a button.
  • #define BN_DBLCLK BN_DOUBLECLICKED
    The BN_DBLCLK notification message is sent when the user double-clicks a button.
  • #define BN_HILITE 2
    The BN_HILITE notification message is sent when the user hilite a button (the user moves the mouse onto it).
  • #define BN_UNHILITE 3
    The BN_UNHILITE notification message is sent when the user unhilite a button, (the user moves the mouse leaving it).
  • #define BN_PUSHED 4
    The BN_PUSHED notification message is sent when the user pushes a button.
  • #define BN_UNPUSHED 5
    The BN_UNPUSHED notification message is sent when the user unpushes a button.
  • #define BN_DISABLE 6
    The BN_DISABLE notification message is sent when the user disables a button. (the user sends BM_ENABLE(wParam == FALSE) to it).
  • #define BN_ENABLE 7
    The BN_DISABLE notification message is sent when the user disables a button. (the user sends BM_ENABLE(wParam == TRUE) to it).
  • #define BN_SETFOCUS 8
    The BN_SETFOCUS notification message is sent when a button receives the keyboard focus.
  • #define BN_KILLFOCUS 9
    The BN_KILLFOCUS notification message is sent when a button loses the keyboard focus.

Detailed Description

Author:
Wei Yongming <ymwei@minigui.org>
Date:
2001/12/29

    Copyright (C) 2002-2008 Feynman Software.
    Copyright (C) 1998-2002 Wei Yongming.

    All rights reserved by Feynman Software.

    This file is part of MiniGUI, a compact cross-platform Graphics
    User Interface (GUI) support system for real-time embedded systems.

Definition in file button.h.

Generated on Fri Dec 17 13:49:41 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: combobox.h File Reference

include » ctrl

combobox.h File Reference

Go to the source code of this file.

Defines

  • #define CTRL_COMBOBOX ("combobox")
    The class name of combobox control.
  • #define CBS_SIMPLE 0x0000L
    Displays the list box at all times.
  • #define CBS_AUTOSPIN 0x0001L
    Creates AutoSpin box.
  • #define CBS_SPINLIST 0x0002L
    Creates SpinList box.
  • #define CBS_DROPDOWNLIST 0x0003L
    Specifies a drop-down list box in the selection filed.
  • #define CBS_TYPEMASK 0x0007L
    The type mask of style of combobox.
  • #define CBS_NOTIFY 0x0008L
    Notifies the parent window.
  • #define CBS_SPINARROW_TOPBOTTOM 0x0010L
    The spin arrow.
  • #define CBS_SPINARROW_LEFTRIGHT 0x0020L
    The spin arrow.
  • #define CBS_AUTOHSCROLL 0x0040L
    This style is reserved.
  • #define CBS_DISABLENOSCROLL 0x0080L
    This style is reserved.
  • #define CBS_SORT 0x0100L
    Automatically sorts strings entered in the list box.
  • #define CBS_AUTOLOOP 0x0200L
    Loops the value automatically if the type of combobox is CBS_AUTOSPIN.
  • #define CBS_EDITNOBORDER 0x0400L
    The edit box has no border.
  • #define CBS_EDITBASELINE 0x0800L
    The edit box has base line.
  • #define CBS_READONLY 0x1000L
    The edit field is read-only.
  • #define CBS_UPPERCASE 0x2000L
    The edit field is uppercase.
  • #define CBS_LOWERCASE 0x4000L
    The edit field is lowercase.
  • #define CBS_AUTOFOCUS 0x8000L
    The edit field will gain the focus automatically.
  • #define CB_GETEDITSEL 0xF140
    Gets the starting and ending character positions of the current selection.
  • #define CB_LIMITTEXT 0xF141
    Limits the length of text in the edit control.
  • #define CB_SETEDITSEL 0xF142
    Sets the starting and ending character positions of the current selection.
  • #define CB_ADDSTRING 0xF143
    Adds a string to the list box of a combo box.
  • #define CB_DELETESTRING 0xF144
    Deletes a string in the list box of a combo box.
  • #define CB_GETCOUNT 0xF146
    Retreives the number of items in the list box of a combo box.
  • #define CB_GETCURSEL 0xF147
    Retreives the index of the currently selected item in the list box.
  • #define CB_GETLBTEXT 0xF148
    Retreives the string of an item in the list box.
  • #define CB_GETLBTEXTLEN 0xF149
    Gets the string length of an item in the list box.
  • #define CB_INSERTSTRING 0xF14A
    Inserts a string to the list box of a combo box.
  • #define CB_RESETCONTENT 0xF14B
    Removes all items from the list box and edit control.
  • #define CB_FINDSTRING 0xF14C
    Searchs the list box for an item beginning with the characters in a specified string.
  • #define CB_SETCURSEL 0xF14E
    Selects a string in the list of a combo box.
  • #define CB_GETITEMADDDATA 0xF150
    Retreives the application-supplied 32-bit value associated with the specified item.
  • #define CB_SETITEMADDDATA 0xF151
    Sets a 32-bit data value with the specified item.
  • #define CB_GETDROPPEDCONTROLRECT 0xF152
    Retreives the screen coordinates of the dropdown list box of a combo box.
  • #define CB_SETITEMHEIGHT 0xF153
    Sets the height of all items of the list box in a combo box.
  • #define CB_GETITEMHEIGHT 0xF154
    Gets the height of items of the list box in a combo box.
  • #define CB_GETDROPPEDSTATE 0xF157
    Determines whether the list box of a combo box is dropped down.
  • #define CB_FINDSTRINGEXACT 0xF158
    Searchs the list box for an item that matches the specified string.
  • #define CB_SETSPINFORMAT 0xF162
    Sets the format string of value for CBS_AUTOSPIN type.
  • #define CB_SETSPINRANGE 0xF163
    Determines the range of the spin box in a combo box.
  • #define CB_GETSPINRANGE 0xF164
    Gets the range of the spin box in a combo box.
  • #define CB_SETSPINVALUE 0xF165
    Determines the value of the spin box in a combo box.
  • #define CB_GETSPINVALUE 0xF166
    Gets the current value of the spin box in a combo box.
  • #define CB_SETSPINPACE 0xF167
    Determines the pace and the fast pace of the spin box in a combo box.
  • #define CB_GETSPINPACE 0xF168
    Gets the pace and the fast pace of the spin box in a combo box.
  • #define CB_SPIN 0xF170
    Spins the value of the spin box or auto spin box.
  • #define CB_FASTSPIN 0xF171
    Fast spins the value of the spin box or auto spin box.
  • #define CB_SETSTRCMPFUNC 0xF172
    Sets the STRCMP function used to sort items.
  • #define CB_GETCHILDREN 0xF173
    Gets the handles to the children of a ComboBox control.
  • #define CB_OKAY LB_OKAY
  • #define CB_ERR LB_ERR
  • #define CB_ERRSPACE LB_ERRSPACE
  • #define CBN_SELCHANGE 1
    Notifies the change of the current selection.
  • #define CBN_DBLCLK 2
    Notifies the user has double clicked an item.
  • #define CBN_SETFOCUS 3
    Notifies the box has gained the input focus.
  • #define CBN_KILLFOCUS 4
    Notifies the box has lost the input focus.
  • #define CBN_EDITCHANGE 5
    Notifies the change of the text in the edit control.
  • #define CBN_DROPDOWN 7
    Notifies the list box has been dropped down.
  • #define CBN_CLOSEUP 8
    Notifies the list box has been closed up.
  • #define CBN_SELECTOK 9
    Notifies the selection of a list item.
  • #define CBN_SELECTCANCEL 10
    Notifies that the selection of a list item is ignored.
  • #define CBN_CLICKED 11
    Notifies that the user has clicked combo box.

Detailed Description

Author:
Wei Yongming <ymwei@minigui.org>
Date:
2001/12/29

    Copyright (C) 2002-2008 Feynman Software.
    Copyright (C) 1998-2002 Wei Yongming.

    All rights reserved by Feynman Software.

    This file is part of MiniGUI, a compact cross-platform Graphics
    User Interface (GUI) support system for real-time embedded systems.

Definition in file combobox.h.

Generated on Fri Dec 17 13:49:41 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: common.h File Reference

include

common.h File Reference

Go to the source code of this file.

Data Structures

  • struct _RECT
  • struct _POINT
  • struct _SIZE
  • struct _RGB
  • struct _GAL_Color
  • struct _GAL_Palette
  • struct _GAL_Rect

Defines

  • #define _VERSION_CODE(major, minor, micro) (((major)<<16) | ((minor)<<8) | (micro))
    A macro that returns the version code from major, minor and micro version number.
  • #define _MINIGUI_VERSION_CODE ((MINIGUI_MAJOR_VERSION << 16) | (MINIGUI_MINOR_VERSION << 8) | MINIGUI_MICRO_VERSION)
    Version code of MiniGUI.
  • #define MGUI_LIL_ENDIAN 1234
    Little endianness.
  • #define MGUI_BIG_ENDIAN 4321
    Big endianness.
  • #define MGUI_BYTEORDER MGUI_LIL_ENDIAN
    The byte order (endianness) of the target system.
  • #define FALSE 0
    FALSE value, defined as 0 by MiniGUI.
  • #define TRUE 1
    TRUE value, defined as 1 by MiniGUI.
  • #define NULL ((void *)0)
    A value indicates null pointer.
  • #define LOBYTE(w) ((BYTE)(w))
    Returns the low byte of the word w.
  • #define HIBYTE(w) ((BYTE)(((WORD)(w) >> 8) & 0xFF))
    Returns the high byte of the word w.
  • #define MAKEWORD(low, high) ((WORD)(((BYTE)(low)) | (((WORD)((BYTE)(high))) << 8)))
    Makes a word from low byte and high byte.
  • #define LOWORD(l) ((WORD)(DWORD)(l))
    Returns the low word of the double word l.
  • #define HIWORD(l) ((WORD)((((DWORD)(l)) >> 16) & 0xFFFF))
    Returns the high word of the double word l.
  • #define LOSWORD(l) ((SWORD)(DWORD)(l))
    Returns the low signed word of the double word l.
  • #define HISWORD(l) ((SWORD)((((DWORD)(l)) >> 16) & 0xFFFF))
    Returns the high signed word of the double word l.
  • #define MAKELONG(low, high) ((DWORD)(((WORD)(low)) | (((DWORD)((WORD)(high))) << 16)))
    Makes a double word from low word and high word.
  • #define GetRValue(rgba) ((BYTE)(rgba))
    Gets the red component from a RGBA triple value rgba.
  • #define GetGValue(rgba) ((BYTE)(((DWORD)(rgba)) >> 8))
    Gets the green component from a RGBA triple value rgba.
  • #define GetBValue(rgba) ((BYTE)((DWORD)(rgba) >> 16))
    Gets the blue component from a RGBA triple value rgba.
  • #define GetAValue(rgba) ((BYTE)((DWORD)(rgba) >> 24))
    Gets the alpha component from a RGBA triple value rgba.
  • #define MakeRGBA(r, g, b, a)
    Makes a RGBA triple value from red r, green g, blue b and alpha components.
  • #define MakeRGB(r, g, b)
    Makes a RGB triple value from red r, green g, and blue b components.
  • #define MGUI_NR_KEYS 255
    Number of MiniGUI keys.
  • #define NR_KEYS 128
    The number of keys defined by Linux operating system.
  • #define SCANCODE_USER (NR_KEYS + 1)
    The first key scan code different from OS defined ones.
  • #define KS_REPEATED 0x00000800
    This status indicate that the key down message is an auto-repeated one.
  • #define KS_CAPTURED 0x00000400
    This status indicate that the mouse is captured by a window when the mouse message posted.
  • #define KS_IMEPOST 0x00000200
    This status indicate that the key message is posted by the IME window.
  • #define KS_CAPSLOCK 0x00000100
    This status indicate that the CapsLock key was locked when the key or mouse message posted to the window.
  • #define KS_NUMLOCK 0x00000080
    This status indicate that the NumLock key was locked when the key or mouse message posted to the window.
  • #define KS_SCROLLLOCK 0x00000040
    This status indicate that the ScrollLock key was locked when the key or mouse message posted to the window.
  • #define KS_LEFTCTRL 0x00000020
    This status indicate that the left-Ctrl key was pressed when the key or mouse message posted to the window.
  • #define KS_RIGHTCTRL 0x00000010
    This status indicate that the right-Ctrl key was pressed when the key or mouse message posted to the window.
  • #define KS_CTRL 0x00000030
    This status indicate that either the left-Ctrl key or the right-Ctrl key was pressed when the key or mouse message posted to the window.
  • #define KS_LEFTALT 0x00000008
    This status indicate that left-Alt key was pressed when the key or mouse message posted to the window.
  • #define KS_RIGHTALT 0x00000004
    This status indicate that right-Alt key was pressed when the key or mouse message posted to the window.
  • #define KS_ALT 0x0000000C
    This status indicate that either the left-Alt key or the right-Alt key was pressed when the key or mouse message posted to the window.
  • #define KS_LEFTSHIFT 0x00000002
    This status indicate that left-Shift key was pressed when the key or mouse message posted to the window.
  • #define KS_RIGHTSHIFT 0x00000001
    This status indicate that right-Shift key was pressed when the key or mouse message posted to the window.
  • #define KS_SHIFT 0x00000003
    This status indicate that either the left-Shift key or the right-Shift key was pressed when the key or mouse message posted to the window.
  • #define MASK_KS_SHIFTKEYS 0x00000FFF
    The mask of key status.
  • #define KS_LEFTBUTTON 0x00001000
    This status indicate that left button was pressed when the key or mouse message posted to the window.
  • #define KS_RIGHTBUTTON 0x00002000
    This status indicate that right button was pressed when the key or mouse message posted to the window.
  • #define KS_MIDDLBUTTON 0x00004000
    This status indicate that middle button was pressed when the key or mouse message posted to the window.
  • #define MASK_KS_BUTTONS 0x0000F000
    The mask of mouse button status.
  • #define ERR_OK 0
    Return value error ok.
  • #define ERR_INV_HWND -1
    Return value invalid window handle error.
  • #define ERR_QUEUE_FULL -2
    Return value queue is full error.
  • #define ERR_INVALID_HANDLE -3
    Return value invalid handle error.
  • #define ERR_INVALID_HMENU -4
    Return value invalid menu handle error.
  • #define ERR_INVALID_POS -5
    Return value invalid postion error.
  • #define ERR_INVALID_ID -6
    Return value invalid id error.
  • #define ERR_RES_ALLOCATION -7
    Return value allocation resource error .
  • #define ERR_CTRLCLASS_INVNAME -8
    Return value invalid name of control class error.
  • #define ERR_CTRLCLASS_INVLEN -9
    Return value control class invalid length.
  • #define ERR_CTRLCLASS_MEM -10
    Return value control class memory error.
  • #define ERR_CTRLCLASS_INUSE -11
    Return value inuse control class error.
  • #define ERR_ALREADY_EXIST -12
    Return value already exit error.
  • #define ERR_NO_MATCH -13
    Return no match error.
  • #define ERR_BAD_OWNER -14
    Return bad owner error.
  • #define ERR_IME_TOOMUCHIMEWND -15
    Return value too much IME window error.
  • #define ERR_IME_NOSUCHIMEWND -16
    Return value no such IME wondow error.
  • #define ERR_IME_NOIMEWND -17
    Return value no IME wondow error.
  • #define ERR_CONFIG_FILE -18
    Return value configure file error.
  • #define ERR_FILE_IO -19
    Return value file I/O error.
  • #define ERR_GFX_ENGINE -20
    Return value GFX engine error.
  • #define ERR_INPUT_ENGINE -21
    Return value input engine error.
  • #define ERR_NO_ENGINE -22
    Return value no engine error.
  • #define ERR_INVALID_ARGS -23
    Return value invalid arguments.
  • #define TABLESIZE(table) (sizeof(table)/sizeof(table[0]))
    A macro returns the number of elements in a table.
  • #define MAX(x, y) (((x) > (y))?(x):(y))
    A macro returns the maximum of x and y.
  • #define MIN(x, y) (((x) < (y))?(x):(y))
    A macro returns the minimum of x and y.
  • #define ABS(x) (((x)<0) ? -(x) : (x))
    A macro returns the absolute value of x.
  • #define MAX_PATH PATH_MAX
    The possible maximal length of a path name.
  • #define MAX_NAME NAME_MAX
    The possible maximal length of a file name.

Typedefs

  • typedef unsigned char Uint8
    A type definition for an 8-bit unsigned character.
  • typedef signed char Sint8
    A type definition for an 8-bit signed character.
  • typedef unsigned short Uint16
    A type definition for a 16-bit unsigned integer.
  • typedef signed short Sint16
    A type definition for a 16-bit signed integer.
  • typedef unsigned int Uint32
    A type definition for a 32-bit unsigned integer.
  • typedef signed int Sint32
    A type definition for a 32-bit signed integer.
  • typedef unsigned long long Uint64
    A type definition for a 64-bit unsigned integer.
  • typedef signed long long Sint64
    A type definition for a 64-bit signed integer.
  • typedef int BOOL
    A type definition for boolean value.
  • typedef unsigned int GHANDLE
    General handle.
  • typedef unsigned int HWND
    Handle to main window or control.
  • typedef unsigned int HDC
    Handle to device context.
  • typedef unsigned int HPALETTE
    Handle to a logical palette.
  • typedef unsigned int HCURSOR
    Handle to cursor.
  • typedef unsigned int HICON
    Handle to icon.
  • typedef unsigned int HMENU
    Handle to menu.
  • typedef unsigned int HACCEL
    Handle to accelarator.
  • typedef unsigned int HDLG
    Handle to dialog box, same as HWND.
  • typedef unsigned int HHOOK
    Handle to keyboard or mouse event hook.
  • typedef unsigned char BYTE
    A type definition for unsigned character (byte).
  • typedef signed char SBYTE
    A type definition for signed character.
  • typedef unsigned short WORD
    A type definition for unsigned short integer (word).
  • typedef signed short SWORD
    A type definition for signed short integer.
  • typedef unsigned long DWORD
    A type definition for unsigned long integer (double word).
  • typedef signed long SDWORD
    A type definition for signed long integer.
  • typedef unsigned int UINT
    A type definition for unsigned integer.
  • typedef long LONG
    A type definition for long integer.
  • typedef unsigned int WPARAM
    A type definition for the first message paramter.
  • typedef unsigned long LPARAM
    A type definition for the second message paramter.
  • typedef DWORD RGBCOLOR
    A type definition for a RGB color.
  • typedef RECT * PRECT
    Data type of the pointer to a RECT.
  • typedef POINT * PPOINT
    Data type of the pointer to a POINT.
  • typedef SIZE * PSIZE
    Data type of the pointer to a SIZE.
  • typedef RGB * PRGB
    Data type of the pointer to a RGB.
  • typedef Sint8 gal_sint8
    Data type of 8-bit signed integer.
  • typedef Uint8 gal_uint8
    Data type of 8-bit unsigned integer.
  • typedef Sint16 gal_sint16
    Data type of 16-bit signed integer.
  • typedef Uint16 gal_uint16
    Data type of 16-bit unsigned integer.
  • typedef Sint32 gal_sint32
    Data type of 32-bit signed integer.
  • typedef Uint32 gal_uint32
    Data type of 32-bit unsigned integer.
  • typedef signed int gal_sint
    Data type of signed integer.
  • typedef unsigned int gal_uint
    Data type of unsigned integer.
  • typedef Uint32 gal_pixel
    Data type of pixel value.
  • typedef Uint32 gal_attr
    Data type of attribute value.
  • typedef long fixed
    Data type of fixed point.

Detailed Description

Author:
Wei Yongming <ymwei@minigui.org>
Date:
2002/01/06
This file includes macro definitions and typedefs that commonly used by MiniGUI.

    Copyright (C) 2002-2009 Feynman Software.
    Copyright (C) 1998-2002 Wei Yongming.

    All rights reserved by Feynman Software.

    This file is part of MiniGUI, a compact cross-platform Graphics
    User Interface (GUI) support system for real-time embedded systems.

Definition in file common.h.

Generated on Fri Dec 17 13:49:41 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: control.h File Reference

include

control.h File Reference

Go to the source code of this file.

Detailed Description

Author:
Wei Yongming <ymwei@minigui.org>
Date:
2001/12/29
This file includes interfaces of standard controls of MiniGUI.

    Copyright (C) 2002-2009 Feynman Software.
    Copyright (C) 1998-2002 Wei Yongming.

    All rights reserved by Feynman Software.

    This file is part of MiniGUI, a compact cross-platform Graphics
    User Interface (GUI) support system for real-time embedded systems.

Definition in file control.h.

Generated on Fri Dec 17 13:49:41 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: coolbar.h File Reference

include » ctrl

coolbar.h File Reference

Go to the source code of this file.

Data Structures

  • struct _COOLBARITEMINFO

Defines

  • #define CTRL_COOLBAR ("CoolBar")
    The class name of coolbar control.
  • #define CBS_BMP_16X16 0x0000
    The size of the item bitmap is 16x16.
  • #define CBS_BMP_32X32 0x0001
    The size of the item bitmap is 32x32.
  • #define CBS_BMP_CUSTOM 0x0002
    The item bitmap has customized size.
  • #define CBS_USEBKBMP 0x0004
    The control has a background bitmap.
  • #define CBM_ADDITEM 0xFE00
    Adds a new item in a coolbar control.
  • #define CBM_ENABLE 0xFE01
    Sets an item to be enabled or disabled.

Typedefs

  • typedef COOLBARITEMINFO * PCOOLBARITEMINFO
    Data type of the pointer to a COOLBARITEMINFO.

Detailed Description

Author:
Wei Yongming <ymwei@minigui.org>
Date:
2002/01/06

    Copyright (C) 2002-2008 Feynman Software
    Copyright (C) 1998-2002 Wei Yongming

    All rights reserved by Feynman Software.

    This file is part of MiniGUI, a compact cross-platform Graphics
    User Interface (GUI) support system for real-time embedded systems.

Definition in file coolbar.h.

Generated on Fri Dec 17 13:49:41 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: ctrlhelper.h File Reference

include » ctrl

ctrlhelper.h File Reference

Go to the source code of this file.

Defines

  • #define NotifyParent(hwnd, id, code) NotifyParentEx(hwnd, id, code, 0)
    Sends a notification message to the parent, but without additional data.

Typedefs

  • typedef int(* STRCMP )(const char *s1, const char *s2, size_t n)
    Type of general strncmp function.

Enumerations

  • enum SBPolicyType { SB_POLICY_ALWAYS, SB_POLICY_AUTOMATIC, SB_POLICY_NEVER }
    Scroll bar display policies in scrolled window. More...

Functions

  • MG_EXPORT void GUIAPI DisabledTextOutEx (HDC hdc, HWND hwnd, int x, int y, const char *szText)
    Outputs disabled (grayed) text.
  • MG_EXPORT HWND CreateToolTipWin (HWND hParentWnd, int x, int y, int timeout_ms, const char *text,...)
    Creates a tool tip window.
  • MG_EXPORT void ResetToolTipWin (HWND hwnd, int x, int y, const char *text,...)
    Resets a tool tip window.
  • MG_EXPORT void DestroyToolTipWin (HWND hwnd)
    Destroies a tool tip window.
  • MG_EXPORT void GUIAPI NotifyParentEx (HWND hwnd, int id, int code, DWORD add_data)
    Sends a notification message to the parent.

Detailed Description

Author:
Wei Yongming <ymwei@minigui.org>
Date:
2001/12/29

    Copyright (C) 2002-2008 Feynman Software.
    Copyright (C) 1998-2002 Wei Yongming.

    All rights reserved by Feynman Software.

    This file is part of MiniGUI, a compact cross-platform Graphics
    User Interface (GUI) support system for real-time embedded systems.

Definition in file ctrlhelper.h.

Generated on Fri Dec 17 13:49:41 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: edit.h File Reference

include » ctrl

edit.h File Reference

Go to the source code of this file.

Data Structures

  • struct _TEXTPOSINFO

Defines

  • #define CTRL_EDIT ("edit")
    The class name of simple single-line editor box.
  • #define CTRL_SLEDIT ("sledit")
    The class name of single-line editor box.
  • #define CTRL_BIDISLEDIT ("bidisledit")
    The class name of BIDI single-line editor box.
  • #define CTRL_MLEDIT ("mledit")
    The class name of multiple-line editor box.
  • #define CTRL_MEDIT ("medit")
    Another class name of multiple-line editor box.
  • #define ES_LEFT 0x00000000L
    Left-aligned text.
  • #define ES_CENTER 0x00000001L
    Center-aligned text.
  • #define ES_RIGHT 0x00000002L
    Right-aligned text.
  • #define ES_MULTILINE 0x00000004L
    Multi-line text.
  • #define ES_UPPERCASE 0x00000008L
    Converts all characters to uppercase as they are typed into the edit control.
  • #define ES_LOWERCASE 0x00000010L
    Converts all characters to lowercase as they are typed into the edit control.
  • #define ES_PASSWORD 0x00000020L
    Displays an asterisk (*) for each character typed into the edit control.
  • #define ES_AUTOVSCROLL 0x00000040L
    Show and hide the vertical scroll bar automatically.
  • #define ES_AUTOHSCROLL 0x00000080L
    Show and hide the horizontal scroll bar automatically.
  • #define ES_NOHIDESEL 0x00000100L
    Edit control with this style will remain selected when focus is lost.
  • #define ES_AUTOSELECT 0x00000400L
    Selects all text when getting focus.
  • #define ES_READONLY 0x00000800L
    Prevents the user from typing or editing text in the edit control.
  • #define ES_BASELINE 0x00001000L
    Draws base line under input area instead of frame border.
  • #define ES_AUTOWRAP 0x00002000L
    Automatically wraps against border when inputting.
  • #define ES_TITLE 0x00004000L
    Shows specified title texts.
  • #define ES_TIP 0x00008000L
    Shows specified tip texts.
  • #define EM_GETSEL 0xF0B0
    Gets the selected string in the edit control.
  • #define EM_SETSEL 0xF0B1
    Sets the selected point in the edit control and makes the text between insertion point and selection point selected.
  • #define EM_SETSELPOS EM_SETSEL
  • #define EM_SETSELECTION EM_SETSEL
  • #define EM_SELECTALL 0xF0B2
    Selects all the texts, the same meaning as ctrl+a.
  • #define EM_GETSELPOS 0xF0B3
    Gets the position of the selection point.
  • #define EM_INSERTCBTEXT 0xF0B4
    Inserts the text in the clipboard to the current caret position.
  • #define EM_COPYTOCB 0xF0B5
    Copies the currently selected text to the clipboard.
  • #define EM_CUTTOCB 0xF0B6
    Cuts the currently selected text to the clipboard.
  • #define EM_SETLFDISPCHAR 0xF0B7
    Sets the char used to represent the line seperator.
  • #define EM_SETLINESEP 0xF0B8
    Sets the line seperator.
  • #define EM_GETCARETPOS 0xF0B9
    Gets the position of the caret.
  • #define EM_SETCARETPOS 0xF0BA
    Sets the position of the caret.
  • #define EM_SETINSERTION EM_SETCARETPOS
  • #define EM_GETLINECOUNT 0xF0BC
    Gets the line number.
  • #define EM_GETLINEHEIGHT 0xF0BD
    Gets the height of a line.
  • #define EM_SETLINEHEIGHT 0xF0BE
    Sets the height of a line.
  • #define EM_LINESCROLL 0xF0BF
    reserved.
  • #define EM_INSERTTEXT 0xF0C0
    Inserts the specified text to the current caret position.
  • #define EM_LINELENGTH 0xF0C1
    reserved.
  • #define EM_REPLACESEL 0xF0C2
    reserved.
  • #define EM_GETMAXLIMIT 0xF0C3
    Get text limit of a single-line edit control.
  • #define EM_GETLINE 0xF0C4
    reserved.
  • #define EM_LIMITTEXT 0xF0C5
    Set text limit of an edit control.
  • #define EM_REDO 0xF0C6
    Redo operation.
  • #define EM_UNDO 0xF0C7
    Undo operation.
  • #define EM_FMTLINES 0xF0C8
    reserved.
  • #define EM_LINEFROMCHAR 0xF0C9
    reserved.
  • #define EM_SETTABSTOPS 0xF0CB
    reserved.
  • #define EM_SETPASSWORDCHAR 0xF0CC
    Defines the character that edit control uses in conjunction with the ES_PASSWORD style.
  • #define EM_SETREADONLY 0xF0CF
    Sets or removes the read-only style (ES_READONLY) in an edit control.
  • #define EM_SETDRAWSELECTFUNC 0xF0D0
    Sets the callback function on drawing selected chars.
  • #define EM_SETGETCARETWIDTHFUNC 0xF0D1
    Sets the callback function on getting caret width.
  • #define EM_GETPASSWORDCHAR 0xF0D2
    Returns the character that edit controls uses in conjunction with the ES_PASSWORD style.
  • #define EM_SETLIMITTEXT EM_LIMITTEXT
  • #define ED_CARETSHAPE_LINE 0
    Line-shaped caret.
  • #define ED_CARETSHAPE_BLOCK 1
    Block-shaped caret.
  • #define EM_CHANGECARETSHAPE 0xF0D3
    Changes the shape of the caret.
  • #define EM_REFRESHCARET 0xF0D4
    Refresh caret of the edit control.
  • #define EM_ENABLECARET 0xF0D5
    To enable or disable the input caret.
  • #define EM_GETLIMITTEXT 0xF0D6
    Get text limit value of the edit control.
  • #define EM_SETTITLETEXT 0xF0DC
    Sets the title text displayed before content text.
  • #define EM_GETTITLETEXT 0xF0DD
    Gets the title text displayed before content text.
  • #define EM_SETTIPTEXT 0xF0DE
    Sets the tip text displayed when content is empty.
  • #define EM_GETTIPTEXT 0xF0DF
    Gets the tip text displayed when content is empty.
  • #define EM_GETNUMOFPARAGRAPHS 0xF0E0
    Gets the number of paragraphs in textedit control.
  • #define EM_GETPARAGRAPHLENGTH 0xF0E1
    Gets the specified paragraph length in textedit control.
  • #define EM_GETPARAGRAPHTEXT 0xF0E2
    Gets the specified paragraph text from textedit control.
  • #define EM_SETCARETPOSBYLINE 0xF0D9
    Sets the selected point in the edit control and makes the text between insertion point and selection point selected. This is set by really line. That means if you set the TES_AUTOWRAP, the line number you set, the caret pos line number you see. This is different from EM_SETCARETPOS.
  • #define EM_GETCARETPOSBYLINE 0xF0DA
    Gets the position of the caret.
  • #define EM_SETSELPOSBYLINE 0xF0DB
  • #define EM_GETSELPOSBYLINE 0xF0E4
    Gets the position of the selection point.
  • #define EM_GETPARAGRAPHLENGTHINMCHAR 0xF0E5
    Gets the specified paragraph length in textedit control. in text not charactors.
  • #define EM_GETLINELENGTHINMCHAR 0xF0E6
    Gets the specified line length in textedit control. in charactors not byte.
  • #define EM_GETLINELENGTH 0xF0E7
    Gets the specified line length in textedit control.
  • #define EM_GETLINETEXT 0xF0E8
    Gets the specified line text from textedit control.
  • #define EN_CLICKED 0x0001
    Notifies a click in an edit control.
  • #define EN_DBLCLK 0x0002
    Notifies a double click in an edit control.
  • #define EN_SETFOCUS 0x0100
    Notifies the receipt of the input focus.
  • #define EN_KILLFOCUS 0x0200
    Notifies the lost of the input focus.
  • #define EN_CHANGE 0x0300
    Notifies that the text is altered by the user.
  • #define EN_UPDATE 0x0400
    Notifies that the text is altered by sending MSG_SETTEXT TEM_RESETCONTENT, or EM_SETLINEHEIGHT message to it.
  • #define EN_MAXTEXT 0x0501
    Notifies reach of maximum text limitation.
  • #define EN_SELCHANGED 0x0603
    Notifies that the current selection is changed in the text field.
  • #define EN_CONTCHANGED 0x0604
    Notifies that the current content is changed in the text field when text edit losts focus.
  • #define EN_ENTER 0x0700
    Notifies the user has type the ENTER key in a single-line edit control.
  • #define EC_LEFTMARGIN 0x0001
    Value of wParam. Specifies the left margins to set.
  • #define EC_RIGHTMARGIN 0x0002
    Value of wParam. Specifies the right margins to set.
  • #define EC_USEFONTINFO 0xffff
    Value of wParam. Specifies the user font info to set.
  • #define EMSIS_COMPOSITIONSTRING 0x0001
    Indicates the type of status to retrieve.
  • #define EIMES_GETCOMPSTRATONCE 0x0001
    lParam for EMSIS_COMPOSITIONSTRING(reserved).
  • #define EIMES_CANCELCOMPSTRINFOCUS 0x0002
    lParam for EMSIS_COMPOSITIONSTRING(reserved).
  • #define EIMES_COMPLETECOMPSTRKILLFOCUS 0x0004
    lParam for EMSIS_COMPOSITIONSTRING(reserved).

Typedefs

  • typedef int(* ED_DRAWSEL_FUNC )(HWND, HDC, int, int, const char *, int, int)
    Type of the edit control callback function on drawing selected strings.

Detailed Description

Author:
Wei Yongming <ymwei@minigui.org>
Date:
2001/12/29

    Copyright (C) 2002-2008 Feynman Software.
    Copyright (C) 1998-2002 Wei Yongming.

    All rights reserved by Feynman Software.

    This file is part of MiniGUI, a compact cross-platform Graphics
    User Interface (GUI) support system for real-time embedded systems.

Definition in file edit.h.

Generated on Fri Dec 17 13:49:41 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: endianrw.h File Reference

include

endianrw.h File Reference

Go to the source code of this file.

Data Structures

  • struct _MG_RWops

Defines

  • #define MGUI_RWseek(ctx, offset, whence) (ctx)->seek(ctx, offset, whence)
    Seeks an MG_RWops object.
  • #define MGUI_RWtell(ctx) (ctx)->seek(ctx, 0, SEEK_CUR)
    Obtains the current value of the position indicator for a data source.
  • #define MGUI_RWread(ctx, ptr, size, n) (ctx)->read(ctx, ptr, size, n)
    Reads data blocks from a data source.
  • #define MGUI_RWwrite(ctx, ptr, size, n) (ctx)->write(ctx, ptr, size, n)
    Writes data blocks to a data source.
  • #define MGUI_RWclose(ctx) (ctx)->close(ctx)
    Closes an MG_RWops object.
  • #define MGUI_RWeof(ctx) (ctx)->eof(ctx)
    Tests the end-of-file indicator for an data source.
  • #define ArchSwapLE16(X) (X)
  • #define ArchSwapLE32(X) (X)
  • #define ArchSwapLE64(X) (X)
  • #define ArchSwapBE16(X) ArchSwap16(X)
  • #define ArchSwapBE32(X) ArchSwap32(X)
  • #define ArchSwapBE64(X) ArchSwap64(X)

Functions

  • MG_EXPORT MG_RWops * MGUI_RWFromFile (const char *file, const char *mode)
    Creates an MG_RWops object from a file.
  • MG_EXPORT MG_RWops * MGUI_RWFromFP (FILE *fp, int autoclose)
    Creates an MG_RWops object from an opened stdio FILE object.
  • MG_EXPORT MG_RWops * MGUI_RWFromMem (void *mem, int size)
    Creates an MG_RWops object from a block of memory.
  • MG_EXPORT void MGUI_InitMemRW (MG_RWops *area, void *mem, int size)
    Initializes an MG_RWops object from a block of memory.
  • MG_EXPORT MG_RWops * MGUI_AllocRW (void)
    Allocates an uninitialized MG_RWops object.
  • MG_EXPORT void MGUI_FreeRW (MG_RWops *area)
    Frees an MG_RWops object.
  • MG_EXPORT int MGUI_RWgetc (MG_RWops *area)
    Reads the next character from an data source.
  • Uint16 MGUI_ReadLE16 (MG_RWops *src)
    Reads a 16-bit little endian integer from a MG_RWops object.
  • Uint16 MGUI_ReadBE16 (MG_RWops *src)
    Reads a 16-bit big endian integer from a MG_RWops object.
  • Uint32 MGUI_ReadLE32 (MG_RWops *src)
    Reads a 32-bit little endian integer from a MG_RWops object.
  • Uint32 MGUI_ReadBE32 (MG_RWops *src)
    Reads a 32-bit big endian integer from a MG_RWops object.
  • Uint64 MGUI_ReadLE64 (MG_RWops *src)
    Reads a 64-bit little endian integer from a MG_RWops object.
  • Uint64 MGUI_ReadBE64 (MG_RWops *src)
    Reads a 64-bit big endian integer from a MG_RWops object.
  • int MGUI_WriteLE16 (MG_RWops *dst, Uint16 value)
    Writes an 16-bit integer of native format to a MG_RWops object in littlen endianness.
  • int MGUI_WriteBE16 (MG_RWops *dst, Uint16 value)
    Writes an 16-bit integer of native format to a MG_RWops object in big endianness.
  • int MGUI_WriteLE32 (MG_RWops *dst, Uint32 value)
    Writes an 32-bit integer of native format to a MG_RWops object in littlen endianness.
  • int MGUI_WriteBE32 (MG_RWops *dst, Uint32 value)
    Writes an 32-bit integer of native format to a MG_RWops object in big endianness.
  • int MGUI_WriteLE64 (MG_RWops *dst, Uint64 value)
    Writes an 64-bit integer of native format to a MG_RWops object in littlen endianness.
  • int MGUI_WriteBE64 (MG_RWops *dst, Uint64 value)
    Writes an 64-bit integer of native format to a MG_RWops object in big endianness.
  • Uint16 MGUI_ReadLE16FP (FILE *src)
    Reads a 16-bit little endian integer from a stdio FILE object.
  • Uint32 MGUI_ReadLE32FP (FILE *src)
    Reads a 32-bit little endian integer from a stdio FILE object.
  • int MGUI_WriteLE16FP (FILE *dst, Uint16 value)
    Writes an 16-bit integer of native format to a stdio FILE object in littlen endianness.
  • int MGUI_WriteLE32FP (FILE *dst, Uint32 value)
    Writes an 32-bit integer of native format to a stdio FILE object in littlen endianness.

Detailed Description

Author:
Wei Yongming <ymwei@minigui.org>
Date:
2002/01/06
This file includes functions for reading and writing data from general sources, such as file, memory, etc., and also includes functions for reading and writing endian-specific values.

    Copyright (C) 2002-2009 Feynman Software.
    Copyright (C) 1998-2002 Wei Yongming.

    All rights reserved by Feynman Software.

    This file is part of MiniGUI, a compact cross-platform Graphics
    User Interface (GUI) support system for real-time embedded systems.

Definition in file endianrw.h.

Generated on Fri Dec 17 13:49:42 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: fixedmath.h File Reference

include

fixedmath.h File Reference

Go to the source code of this file.

Functions

  • MG_EXPORT fixed fixsqrt (fixed x)
    Returns the non-negative square root of a fixed point value.
  • MG_EXPORT fixed fixhypot (fixed x, fixed y)
    Returns the Euclidean distance from the origin.
  • MG_EXPORT fixed fixatan (fixed x)
    Calculates the arc tangent of a fixed point value.
  • MG_EXPORT fixed fixatan2 (fixed y, fixed x)
    Calculates the arc tangent of two fixed point variables.
  • static fixed ftofix (double x)
    Converts a float point value to a fixed point value.
  • static double fixtof (fixed x)
    Converts a fixed point value to a float point value.
  • static fixed fixadd (fixed x, fixed y)
    Returns the sum of two fixed point values.
  • static fixed fixsub (fixed x, fixed y)
    Subtract a fixed point value from another.
  • MG_EXPORT fixed fixmul (fixed x, fixed y)
    Returns the product of two fixed point values.
  • MG_EXPORT fixed fixdiv (fixed x, fixed y)
    Returns the quotient of two fixed point values.
  • static int fixceil (fixed x)
    Rounds a fixed point value to the nearest integer.
  • static fixed itofix (int x)
    Converts an integer to a fixed point value.
  • static int fixtoi (fixed x)
    Converts an fixed point value to an integer.
  • static fixed fixcos (fixed x)
    Returns the cosine of a fixed point.
  • static fixed fixsin (fixed x)
    Returns the sine of a fixed point.
  • static fixed fixtan (fixed x)
    Returns the tangent of a fixed point.
  • static fixed fixacos (fixed x)
    Calculates and returns the arc cosine of a fixed point.
  • static fixed fixasin (fixed x)
    Calculates and returns the arc sine of a fixed point.

Detailed Description

Author:
Wei Yongming <ymwei@minigui.org>
Date:
2002/01/12
This file includes fixed point and three-dimension math routines.

    Copyright (C) 2002-2009 Feynman Software.
    Copyright (C) 1998-2002 Wei Yongming.

    All rights reserved by Feynman Software.

    This file is part of MiniGUI, a compact cross-platform Graphics
    User Interface (GUI) support system for real-time embedded systems.

Definition in file fixedmath.h.

Generated on Fri Dec 17 13:49:42 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: gdi.h File Reference

include

gdi.h File Reference

Go to the source code of this file.

Data Structures

  • struct _BLOCKHEAP
  • struct _CLIPRECT
  • struct _CLIPRGN
  • struct _STIPPLE
  • struct _ARC
  • struct _LOGFONT
  • struct _DEVFONT
  • struct _FONTMETRICS
  • struct _GLYPHBITMAP
  • struct _WORDINFO
  • struct _DTFIRSTLINE
  • struct _MYBITMAP
  • struct _BITMAP

Defines

  • #define PIXEL_invalid 0
    Invalid pixel.
  • #define PIXEL_transparent SysPixelIndex[0]
    Transparent.
  • #define PIXEL_darkblue SysPixelIndex[1]
    Dark blue.
  • #define PIXEL_darkgreen SysPixelIndex[2]
    Dark green.
  • #define PIXEL_darkcyan SysPixelIndex[3]
    Dark cyan.
  • #define PIXEL_darkred SysPixelIndex[4]
    Dark red.
  • #define PIXEL_darkmagenta SysPixelIndex[5]
    Dark magenta.
  • #define PIXEL_darkyellow SysPixelIndex[6]
    Dark yellow.
  • #define PIXEL_darkgray SysPixelIndex[7]
    Dark gray.
  • #define PIXEL_lightgray SysPixelIndex[8]
    Light gray.
  • #define PIXEL_blue SysPixelIndex[9]
    Blue.
  • #define PIXEL_green SysPixelIndex[10]
    Green.
  • #define PIXEL_cyan SysPixelIndex[11]
    Cyan.
  • #define PIXEL_red SysPixelIndex[12]
    Red.
  • #define PIXEL_magenta SysPixelIndex[13]
    Magenta.
  • #define PIXEL_yellow SysPixelIndex[14]
    Yellow.
  • #define PIXEL_lightwhite SysPixelIndex[15]
    Light white.
  • #define PIXEL_black SysPixelIndex[16]
    Black.
  • #define COLOR_invalid PIXEL_invalid
  • #define COLOR_transparent PIXEL_transparent
  • #define COLOR_darkred PIXEL_darkred
  • #define COLOR_darkgreen PIXEL_darkgreen
  • #define COLOR_darkyellow PIXEL_darkyellow
  • #define COLOR_darkblue PIXEL_darkblue
  • #define COLOR_darkmagenta PIXEL_darkmagenta
  • #define COLOR_darkcyan PIXEL_darkcyan
  • #define COLOR_lightgray PIXEL_lightgray
  • #define COLOR_darkgray PIXEL_darkgray
  • #define COLOR_red PIXEL_red
  • #define COLOR_green PIXEL_green
  • #define COLOR_yellow PIXEL_yellow
  • #define COLOR_blue PIXEL_blue
  • #define COLOR_magenta PIXEL_magenta
  • #define COLOR_cyan PIXEL_cyan
  • #define COLOR_lightwhite PIXEL_lightwhite
  • #define COLOR_black PIXEL_black
  • #define SysColorIndex SysPixelIndex
  • #define InitFreeClipRectList(heap, size) InitBlockDataHeap (heap, sizeof (CLIPRECT), size)
    Initializes the private block data heap used to allocate clipping rectangles.
  • #define ClipRectAlloc(heap) BlockDataAlloc (heap)
    Allocates a clipping rectangles from the private block data heap.
  • #define FreeClipRect(heap, cr) BlockDataFree (heap, cr);
    Frees a clipping rectangle which is allocated from the private block data heap.
  • #define DestroyFreeClipRectList(heap) DestroyBlockDataHeap (heap);
    Destroys the private block data heap used to allocate clipping rectangles.
  • #define UnionRectWithRegion AddClipRect
    Is an alias of AddClipRect.
  • #define CopyRegion ClipRgnCopy
    Is an alias of ClipRgnCopy.
  • #define IntersectRegion ClipRgnIntersect
    Is an alias of ClipRgnIntersect.
  • #define HDC_SCREEN 0
    Handle to the device context of the whole screen.
  • #define HDC_INVALID 0xFFFFFFFF
    Indicates an invalid handle to device context.
  • #define CreateCompatibleDC(hdc) CreateCompatibleDCEx(hdc, 0, 0)
    Creates a memory DC which is compatible with a given DC.
  • #define DeleteCompatibleDC(hdc) DeleteMemDC(hdc)
    Deletes a memory DC.
  • #define GetBkColor(hdc) GetDCAttr (hdc, DC_ATTR_BK_COLOR)
    Gets the background color of a DC.
  • #define GetBkMode(hdc) GetDCAttr (hdc, DC_ATTR_BK_MODE)
    Gets the background mode of a DC.
  • #define GetPenColor(hdc) GetDCAttr (hdc, DC_ATTR_PEN_COLOR)
    Gets the pen color of a DC.
  • #define GetBrushColor(hdc) GetDCAttr (hdc, DC_ATTR_BRUSH_COLOR)
    Gets the brush color of a DC.
  • #define GetTextColor(hdc) GetDCAttr (hdc, DC_ATTR_TEXT_COLOR)
    Gets the text color of a DC.
  • #define GetTabStop(hdc) GetDCAttr (hdc, DC_ATTR_TAB_STOP)
    Gets the tabstop value of a DC.
  • #define SetBkColor(hdc, color) SetDCAttr (hdc, DC_ATTR_BK_COLOR, (DWORD) color)
    Sets the background color of a DC to a new value.
  • #define SetBkMode(hdc, mode) SetDCAttr (hdc, DC_ATTR_BK_MODE, (DWORD) mode)
    Sets the background color of a DC to a new mode.
  • #define SetPenColor(hdc, color) SetDCAttr (hdc, DC_ATTR_PEN_COLOR, (DWORD) color)
    Sets the pen color of a DC to a new value.
  • #define SetBrushColor(hdc, color) SetDCAttr (hdc, DC_ATTR_BRUSH_COLOR, (DWORD) color)
    Sets the brush color of a DC to a new value.
  • #define SetTextColor(hdc, color) SetDCAttr (hdc, DC_ATTR_TEXT_COLOR, (DWORD) color)
    Sets the text color of a DC to a new value.
  • #define SetTabStop(hdc, value) SetDCAttr (hdc, DC_ATTR_TAB_STOP, (DWORD) value)
    Sets the tabstop of a DC to a new value.
  • #define DrawHDotLine(hdc, x, y, w) DrawHVDotLine (hdc, x, y, w, TRUE);
    Draws a horizontal dot dash line.
  • #define DrawVDotLine(hdc, x, y, h) DrawHVDotLine (hdc, x, y, h, FALSE);
    Draws a vertical dot line.
  • #define PolygonGenerator(context, pts, vertices, cb) PolygonGeneratorEx(context, pts, vertices, cb, NULL)
    This is a general polygon generator.
  • #define GetPenType(hdc) GetDCAttr (hdc, DC_ATTR_PEN_TYPE)
    Gets the pen type of a DC.
  • #define SetPenType(hdc, type) SetDCAttr (hdc, DC_ATTR_PEN_TYPE, (DWORD) type)
    Sets the pen type of a DC to a new type.
  • #define GetPenCapStyle(hdc) GetDCAttr (hdc, DC_ATTR_PEN_CAP_STYLE)
    Gets the pen cap style of a DC.
  • #define SetPenCapStyle(hdc, style) SetDCAttr (hdc, DC_ATTR_PEN_CAP_STYLE, (DWORD) style)
    Sets the pen type of a DC to a new type.
  • #define GetPenJoinStyle(hdc) GetDCAttr (hdc, DC_ATTR_PEN_JOIN_STYLE)
    Gets the pen join style of a DC.
  • #define SetPenJoinStyle(hdc, style) SetDCAttr (hdc, DC_ATTR_PEN_JOIN_STYLE, (DWORD) style)
    Sets the pen type of a DC to a new type.
  • #define GetPenWidth(hdc) GetDCAttr (hdc, DC_ATTR_PEN_WIDTH)
    Gets the pen width of a DC.
  • #define SetPenWidth(hdc, width) SetDCAttr (hdc, DC_ATTR_PEN_WIDTH, (DWORD) width)
    Sets the pen width of a DC to a new width.
  • #define GetBrushType(hdc) GetDCAttr (hdc, DC_ATTR_BRUSH_TYPE)
    Gets the brush type of a DC.
  • #define SetBrushType(hdc, type) SetDCAttr (hdc, DC_ATTR_BRUSH_TYPE, (DWORD) type)
    Sets the brush type of a DC to a new type.
  • #define GetMapMode(hdc) GetDCAttr (hdc, DC_ATTR_MAP_MODE)
    Retrieves the current mapping mode of a DC.
  • #define SetMapMode(hdc, mapmode) SetDCAttr (hdc, DC_ATTR_MAP_MODE, (DWORD)mapmode)
    Sets the mapping mode of a display context.
  • #define GetViewportOrg(hdc, pPt) GetDCLCS(hdc, DC_LCS_VORG, pPt)
    Retrieves the x-coordinates and y-coordinates of the viewport origin for a device context.
  • #define GetViewportExt(hdc, pPt) GetDCLCS(hdc, DC_LCS_VEXT, pPt)
    Retrieves the x-extents and y-extents of the current viewport for a device context.
  • #define GetWindowOrg(hdc, pPt) GetDCLCS(hdc, DC_LCS_WORG, pPt)
    Retrieves the x-coordinates and y-coordinates of the window for a device context.
  • #define GetWindowExt(hdc, pPt) GetDCLCS(hdc, DC_LCS_WEXT, pPt)
    Retrieves the x-extents and y-extents of the current window for a device context.
  • #define SetViewportOrg(hdc, pPt) SetDCLCS(hdc, DC_LCS_VORG, pPt)
    Sets the x-coordinates and y-coordinates of the viewport origin for a device context.
  • #define SetViewportExt(hdc, pPt) SetDCLCS(hdc, DC_LCS_VEXT, pPt)
    Sets the x-extents and y-extents of the current viewport for a device context.
  • #define SetWindowOrg(hdc, pPt) SetDCLCS(hdc, DC_LCS_WORG, pPt)
    Sets the x-coordinates and y-coordinates of the window for a device context.
  • #define SetWindowExt(hdc, pPt) SetDCLCS(hdc, DC_LCS_WEXT, pPt)
    Sets the x-extents and y-extents of the current window for a device context.
  • #define CreateIcon(hdc, w, h, AndBits, XorBits, colornum) CreateIconEx(hdc, w, h, AndBits, XorBits, colornum, NULL)
  • #define RECTWP(prc) ((prc)->right - (prc)->left)
    Gets the width of a RECT object by using the pointer to it.
  • #define RECTHP(prc) ((prc)->bottom - (prc)->top)
    Gets the height of a RECT object by using the pointer to it.
  • #define RECTW(rc) ((rc).right - (rc).left)
    Gets the width of a RECT object.
  • #define RECTH(rc) ((rc).bottom - (rc).top)
    Gets the height of a RECT object.
  • #define FONT_CHARSET_GB1988_0 "GB1988-0"
    EUC encoding of GB1988 charset, treat as ISO8859-1.
  • #define FONT_CHARSET_GB2312_0 "GB2312-0"
    EUC encoding of GB2312 charset.
  • #define FONT_CHARSET_GB18030_0 "GB18030-0"
    EUC encoding of GB18030 charset.
  • #define FONT_CHARSET_EUCTW "EUC-TW"
    EUC encoding of CNS11643 charset, not supported.
  • #define FONT_CHARSET_KSC5636_0 "KSC5636-0"
    EUC encoding of KSC5636 charset, treat as ISO8859-1.
  • #define FONT_CHARSET_KSC5601_0 "KSC5601-0"
    EUC encoding of KSC5601 charset.
  • #define FONT_CHARSET_JISX0201_0 "JISX0201-0"
    EUC encoding of JISX0201 charset.
  • #define FONT_CHARSET_JISX0208_0 "JISX0208-0"
    EUC encoding of JISX0208 charset.
  • #define FONT_CHARSET_JISX0201_1 "JISX0201-1"
    Shift-JIS encoding of JISX0201 charset.
  • #define FONT_CHARSET_JISX0208_1 "JISX0208-1"
    Shift-JIS encoding of JISX0208 charset.
  • #define FONT_CHARSET_ISO_10646_1 "ISO-10646-1"
    UCS-2 encoding of UNICODE.
  • #define FONT_CHARSET_UTF8 "UTF-8"
    UTF-8 encoding of UNICODE.
  • #define FONT_CHARSET_UTF16LE "UTF-16LE"
    UTF-16 encoding (Little-Endian) of UNICODE.
  • #define FONT_CHARSET_UTF16BE "UTF-16BE"
    UTF-16 encoding (Big-Endian) of UNICODE.
  • #define INV_LOGFONT 0
    Invalid logfont.
  • #define SYSLOGFONT_DEFAULT 0
  • #define SYSLOGFONT_WCHAR_DEF 1
  • #define SYSLOGFONT_FIXED 2
  • #define SYSLOGFONT_CAPTION 3
  • #define SYSLOGFONT_MENU 4
  • #define SYSLOGFONT_CONTROL 5
  • #define MB2WC(log_font, dest, mstr, n) MB2WCEx (log_font, dest, sizeof(wchar_t) == 4, mstr, n)
    The backward compatibility version of MB2WCEx.
  • #define WC2MB(log_font, s, wc) WC2MBEx (log_font, s, (UChar32)wc)
    The backward compatibility version of WC2MBEx.
  • #define MBS2WCS(log_font, dest, mstr, mstr_len, n)
    The backward compatibility version of MBS2WCSEx.
  • #define WCS2MBS(log_font, dest, wcs, wcs_len, n)
    The backward compatibility version of WCS2MBSEx.
  • #define GetTextCharacterExtra(hdc) GetDCAttr (hdc, DC_ATTR_CHAR_EXTRA)
    Retrieves the current intercharacter spacing for the DC.
  • #define GetTextAboveLineExtra(hdc) GetDCAttr (hdc, DC_ATTR_ALINE_EXTRA)
    Retrieves the current spacing above line for the DC.
  • #define GetTextBellowLineExtra(hdc) GetDCAttr (hdc, DC_ATTR_BLINE_EXTRA)
    Retrieves the current spacing bellow line for the DC.
  • #define SetTextCharacterExtra(hdc, extra) SetDCAttr (hdc, DC_ATTR_CHAR_EXTRA, (DWORD) extra)
    Sets the intercharacter spacing for the DC and returns the old spacing value.
  • #define SetTextAboveLineExtra(hdc, extra) SetDCAttr (hdc, DC_ATTR_ALINE_EXTRA, (DWORD) extra)
    Sets the spacing above line for the DC and returns the old value.
  • #define SetTextBellowLineExtra(hdc, extra) SetDCAttr (hdc, DC_ATTR_BLINE_EXTRA, (DWORD) extra)
    Sets the spacing bellow line for the DC and returns the old value.
  • #define GetTextAlign(hdc) GetDCAttr (hdc, DC_ATTR_TEXT_ALIGN)
    Retrieves the current text-alignment flags of a DC.
  • #define SetTextAlign(hdc, ta_flags) SetDCAttr (hdc, DC_ATTR_TEXT_ALIGN, (DWORD)ta_flags)
    Sets text-alignment flags of a DC.
  • #define TextOut(hdc, x, y, text) TextOutLen (hdc, x, y, text, -1)
    Outputs text.
  • #define TabbedTextOut(hdc, x, y, text) TabbedTextOutLen (hdc, x, y, text, -1)
    Outputs formatted text.
  • #define DrawText(hdc, text, n, rc, format) DrawTextEx2 (hdc, text, n, rc, 0, format, NULL)
    Draws a formatted text in a rectangle.
  • #define DrawTextEx(hdc, text, n, rc, indent, format) DrawTextEx2 (hdc, text, n, rc, indent, format, NULL)
    Draws a formatted text in a rectangle.
  • #define MLS_BLENDMODE_NONE 0x00
  • #define LoadBitmap LoadBitmapFromFile
    An alias of LoadBitmapFromFile.
  • #define LoadMyBitmap LoadMyBitmapFromFile
    Alias of LoadMyBitmapFromFile.
  • #define IS_MBC_GLYPH(glyph) ((glyph) & 0x80000000)
    to judge wether the glyph is multibyte glyph
  • #define SET_MBC_GLYPH(glyph) ((glyph) | 0x80000000)
    set the glyph with multibyte mask
  • #define REAL_GLYPH(glyph) ((glyph) & 0x7FFFFFFF)
    get real glyph value from a glyph
  • #define SELECT_DEVFONT(plogfont, glyph)
    select a device font acording to the glyph value.

Typedefs

  • typedef BLOCKHEAP * PBLOCKHEAP
    Data type of the pointer to a BLOCKHEAP.
  • typedef struct _BITMAP BITMAP
  • typedef BITMAP * PBITMAP
    Data type of pointer to a BITMAP.
  • typedef struct _MYBITMAP MYBITMAP
  • typedef struct _MYBITMAP * PMYBITMAP
    Data type of pointer to a struct _MYBITMAP.
  • typedef CLIPRGN * PCLIPRGN
    Data type of the pointer to a CLIPRGN.
  • typedef void(* CB_DIRECT_DRAW_RECT )(HDC hdc, Uint8 *pixels, int pitch, int bytesPerPixel, const RECT *rc, void *context)
    Type of directly access pixels hook function.
  • typedef int(* ON_UPDATE_SECONDARYDC )(HWND hwnd, HDC secondary_dc, HDC real_dc, const RECT *secondary_rc, const RECT *real_rc, const RECT *main_update_rc)
    The callback type of on updating secondary DC.
  • typedef void(* CB_LINE )(void *context, int stepx, int stepy)
    The type of line generator callback.
  • typedef void(* CB_CIRCLE )(void *context, int x1, int x2, int y)
    The type of circle generator callback.
  • typedef void(* CB_ELLIPSE )(void *context, int x1, int x2, int y)
    The type of ellipse generator callback.
  • typedef void(* CB_ARC )(void *context, int x, int y)
    The type of arc generator callback.
  • typedef void(* CB_POLYGON )(void *context, int x1, int x2, int y)
    The type of polygon generator callback.
  • typedef BOOL(* CB_EQUAL_PIXEL )(void *context, int x, int y)
    Flodd filling generator's equation callback.
  • typedef void(* CB_FLOOD_FILL )(void *context, int x1, int x2, int y)
    Flodd filling generator's scan line callback.
  • typedef LOGFONT * PLOGFONT
    Data type of pointer to a LOGFONT.
  • typedef const LOGFONT * CPLOGFONT
    Data type of pointer to a const LOGFONT.
  • typedef struct _WORDINFO WORDINFO
    Date type of _WORDINFO.
  • typedef void(* CB_ONE_SCANLINE )(void *context, MYBITMAP *my_bmp, int y)
    The type of scanline loaded callback.
  • typedef struct _GLYPHMAPINFO GLYPHMAPINFO
    Data type of struct _GLYPHMAPINFO.
  • typedef struct _GLYPHINFO GLYPHINFO
    Data type of struct _GLYPHINFO.

Enumerations

  • enum PenType { PT_SOLID, PT_ON_OFF_DASH, PT_DOUBLE_DASH }
  • enum PTCapStyle { PT_CAP_BUTT, PT_CAP_ROUND, PT_CAP_PROJECTING }
  • enum PTJoinStyle { PT_JOIN_MITER, PT_JOIN_ROUND, PT_JOIN_BEVEL }
  • enum BrushType { BT_SOLID, BT_TILED, BT_STIPPLED, BT_OPAQUE_STIPPLED }
  • enum mg_FT_LcdFilter {
MG_SMOOTH_NONE =  0,
MG_SMOOTH_DEFAULT =  1,
MG_SMOOTH_LIGHT =  2,
MG_SMOOTH_LEGACY =  16,
MG_SMOOTH_MAX
}
  • enum SHAPETYPE
    Data type of enum. More...

Functions

  • MG_EXPORT void InitBlockDataHeap (PBLOCKHEAP heap, size_t bd_size, size_t heap_size)
    Initializes a private block data heap.
  • MG_EXPORT void * BlockDataAlloc (PBLOCKHEAP heap)
    Allocates a data block from private heap.
  • MG_EXPORT void BlockDataFree (PBLOCKHEAP heap, void *data)
    Frees an allocated data block.
  • MG_EXPORT void DestroyBlockDataHeap (PBLOCKHEAP heap)
    Destroys a private block data heap.
  • MG_EXPORT void GUIAPI InitClipRgn (PCLIPRGN pRgn, PBLOCKHEAP pFreeList)
    Initializes a clipping region.
  • MG_EXPORT void GUIAPI EmptyClipRgn (PCLIPRGN pRgn)
    Empties a clipping region.
  • MG_EXPORT PCLIPRGN GUIAPI CreateClipRgn (void)
    Creates a clipping region.
  • MG_EXPORT void GUIAPI DestroyClipRgn (PCLIPRGN pRgn)
    Empties and destroys a clipping region.
  • MG_EXPORT BOOL GUIAPI ClipRgnCopy (PCLIPRGN pDstRgn, const CLIPRGN *pSrcRgn)
    Copies one region to another.
  • MG_EXPORT BOOL GUIAPI ClipRgnIntersect (PCLIPRGN pRstRgn, const CLIPRGN *pRgn1, const CLIPRGN *pRgn2)
    Intersects two region.
  • MG_EXPORT void GUIAPI GetClipRgnBoundRect (PCLIPRGN pRgn, PRECT pRect)
    Gets the bounding rectangle of a region.
  • MG_EXPORT BOOL GUIAPI SetClipRgn (PCLIPRGN pRgn, const RECT *pRect)
    Sets a region to contain only one rect.
  • MG_EXPORT BOOL GUIAPI IsEmptyClipRgn (const CLIPRGN *pRgn)
    Determines whether a region is an empty region.
  • MG_EXPORT BOOL GUIAPI AddClipRect (PCLIPRGN pRgn, const RECT *pRect)
    Unions one rectangle to a region.
  • MG_EXPORT BOOL GUIAPI IntersectClipRect (PCLIPRGN pRgn, const RECT *pRect)
    Intersects a rectangle with a region.
  • MG_EXPORT BOOL GUIAPI SubtractClipRect (PCLIPRGN pRgn, const RECT *pRect)
    Subtracts a rectangle from a region.
  • MG_EXPORT BOOL GUIAPI PtInRegion (PCLIPRGN region, int x, int y)
    Determines whether a point is in a region.
  • MG_EXPORT BOOL GUIAPI RectInRegion (PCLIPRGN region, const RECT *rect)
    Determines whether a rectangle is intersected with a region.
  • MG_EXPORT void GUIAPI OffsetRegionEx (PCLIPRGN region, const RECT *rcClient, const RECT *rcScroll, int x, int y)
    Offsets the region in the specified window's scroll area.
  • MG_EXPORT void GUIAPI OffsetRegion (PCLIPRGN region, int x, int y)
    Offsets the region.
  • MG_EXPORT BOOL GUIAPI UnionRegion (PCLIPRGN dst, const CLIPRGN *src1, const CLIPRGN *src2)
    Unions two regions.
  • MG_EXPORT BOOL GUIAPI SubtractRegion (CLIPRGN *rgnD, const CLIPRGN *rgnM, const CLIPRGN *rgnS)
    Substrcts a region from another.
  • MG_EXPORT BOOL GUIAPI XorRegion (CLIPRGN *dst, const CLIPRGN *src1, const CLIPRGN *src2)
    Does the XOR operation between two regions.
  • MG_EXPORT BOOL GUIAPI InitCircleRegion (PCLIPRGN dst, int x, int y, int r)
    Initializes a region to be an enclosed circle.
  • MG_EXPORT BOOL GUIAPI InitEllipseRegion (PCLIPRGN dst, int x, int y, int rx, int ry)
    Initializes a region to be an enclosed ellipse.
  • MG_EXPORT BOOL GUIAPI InitPolygonRegion (PCLIPRGN dst, const POINT *pts, int vertices)
    Initializes a region to be an enclosed polygon.
  • MG_EXPORT unsigned int GUIAPI GetGDCapability (HDC hdc, int iItem)
    Returns a capability of a DC.
  • MG_EXPORT HDC GUIAPI GetDC (HWND hwnd)
    Gets a window DC of a window.
  • MG_EXPORT HDC GUIAPI GetClientDC (HWND hwnd)
    Gets a client DC of a window.
  • MG_EXPORT HDC GUIAPI GetSubDC (HDC hdc, int off_x, int off_y, int width, int height)
    This function gets a sub DC which is compliant to the specified client DC.
  • MG_EXPORT void GUIAPI ReleaseDC (HDC hdc)
    Releases a DC from DC pool.
  • MG_EXPORT HWND GUIAPI WindowFromDC (HDC hdc)
    Get the window handle from DC.
  • MG_EXPORT int GUIAPI SaveDC (HDC hdc)
    Saves the current state of a device context.
  • MG_EXPORT BOOL GUIAPI RestoreDC (HDC hdc, int saved_dc)
    Restores a device context (DC) to the specified state.
  • MG_EXPORT HDC GUIAPI CreateCompatibleDCEx (HDC hdc, int width, int height)
    Creates a memory DC which is compatible with the specified reference DC.
  • MG_EXPORT BOOL GUIAPI IsCompatibleDC (HDC hdc1, HDC hdc2)
    Check whether a given DC is compliant to a specific DC.
  • MG_EXPORT HDC GUIAPI CreateMemDCEx (int width, int height, int depth, DWORD flags, Uint32 Rmask, Uint32 Gmask, Uint32 Bmask, Uint32 Amask, void *bits, int pitch)
    Creates a memory DC.
  • static HDC GUIAPI CreateMemDC (int width, int height, int depth, DWORD flags, Uint32 Rmask, Uint32 Gmask, Uint32 Bmask, Uint32 Amask)
    Creates a memory DC.
  • MG_EXPORT HDC GUIAPI CreateSubMemDC (HDC parent, int off_x, int off_y, int width, int height, BOOL comp_to_parent)
    Creates a sub memory DC in the given memory DC.
  • MG_EXPORT HDC GUIAPI CreateMemDCFromBitmap (HDC hdc, const BITMAP *bmp)
    Creates a memory DC from a reference DC and a BITMAP object.
  • MG_EXPORT HDC GUIAPI CreateMemDCFromMyBitmap (const MYBITMAP *my_bmp, const RGB *pal)
    Creates a memory DC from a device independent MYBITMAP object.
  • MG_EXPORT BOOL GUIAPI ConvertMemDC (HDC mem_dc, HDC ref_dc, DWORD flags)
    Converts a memory DC to have a same format as a reference DC.
  • MG_EXPORT BOOL GUIAPI SetMemDCAlpha (HDC mem_dc, DWORD flags, Uint8 alpha)
    Sets the alpha value for the entire surface of a DC, as opposed to using the alpha component of each pixel.
  • MG_EXPORT BOOL GUIAPI SetMemDCColorKey (HDC mem_dc, DWORD flags, Uint32 color_key)
    Sets the color key (transparent pixel) of a memory DC.
  • MG_EXPORT void GUIAPI DeleteMemDC (HDC mem_dc)
    Deletes a memory DC.
  • MG_EXPORT Uint8 *GUIAPI LockDC (HDC hdc, const RECT *rw_rc, int *width, int *height, int *pitch)
    Locks a dc to get direct access to pixels in the DC.
  • MG_EXPORT BOOL GUIAPI LockDCEx (HDC hdc, const PCLIPRGN region, void *context, CB_DIRECT_DRAW_RECT cb)
    directly access the pixels in a DC.
  • MG_EXPORT void GUIAPI UnlockDC (HDC hdc)
    Unlocks a locked DC.
  • MG_EXPORT HDC GUIAPI CreatePrivateDC (HWND hwnd)
    Creates a private window DC of a window.
  • MG_EXPORT HDC GUIAPI CreatePrivateClientDC (HWND hwnd)
    Creates a private client DC of a window.
  • HDC GUIAPI CreatePrivateSubDC (HDC hdc, int off_x, int off_y, int width, int height)
    Creates a private SubDC of a window.
  • MG_EXPORT HDC GUIAPI GetPrivateClientDC (HWND hwnd)
    Returns the private client DC of a window.
  • MG_EXPORT void GUIAPI DeletePrivateDC (HDC hdc)
    Deletes the DC returned by CreatePrivateDC or CreatePrivateClientDC or CreatePrivateSubDC.
  • MG_EXPORT HDC GUIAPI CreateSecondaryDC (HWND hwnd)
    Creates a secondary window DC of a window.
  • MG_EXPORT HDC GUIAPI SetSecondaryDC (HWND hwnd, HDC secondary_dc, ON_UPDATE_SECONDARYDC on_update_secondarydc)
    Set a window's secondary DC and the callback procedure for the secondary DC update.
  • MG_EXPORT HDC GUIAPI GetSecondaryDC (HWND hwnd)
    Retrives and returns the secondary DC of a specific window.
  • MG_EXPORT HDC GUIAPI GetSecondaryClientDC (HWND hwnd)
    Retrives and returns the client secondary DC of a specific window.
  • MG_EXPORT void GUIAPI ReleaseSecondaryDC (HWND hwnd, HDC hdc)
    Release the DC returned by GetSecondaryDC or GetSecondaryClientDC.
  • MG_EXPORT void GUIAPI DeleteSecondaryDC (HWND hwnd)
    Deletes the secondary DC of the window.
  • MG_EXPORT Uint32 GUIAPI GetDCAttr (HDC hdc, int attr)
    Gets a specified attribute value of a DC.
  • MG_EXPORT Uint32 GUIAPI SetDCAttr (HDC hdc, int attr, Uint32 value)
    Sets a specified attribute value of a DC.
  • MG_EXPORT int GUIAPI GetRasterOperation (HDC hdc)
    Gets the raster operation of a DC.
  • MG_EXPORT int GUIAPI SetRasterOperation (HDC hdc, int rop)
    Sets the raster operation of a DC to a new value.
  • MG_EXPORT BOOL GUIAPI GetPalette (HDC hdc, int start, int len, GAL_Color *cmap)
    Gets palette entries of a DC.
  • MG_EXPORT BOOL GUIAPI SetPalette (HDC hdc, int start, int len, GAL_Color *cmap)
    Sets palette entries of a DC.
  • MG_EXPORT BOOL GUIAPI SetColorfulPalette (HDC hdc)
    Sets a DC with colorfule palette.
  • MG_EXPORT HPALETTE GUIAPI CreatePalette (GAL_Palette *pal)
    Creates a logical palette.
  • MG_EXPORT BOOL GUIAPI SelectPalette (HDC hdc, HPALETTE hpal, BOOL reserved)
    Selects a palette for a DC.
  • MG_EXPORT BOOL GUIAPI RealizePalette (HDC hdc)
    This function maps palette entries from the current logical palette to the system palette.
  • MG_EXPORT BOOL GUIAPI ResizePalette (HPALETTE hpal, int len)
    Resizes a logical palette.
  • MG_EXPORT void GUIAPI DestroyPalette (HPALETTE hpal)
    Destroy a logical palette.
  • MG_EXPORT HPALETTE GUIAPI GetDefaultPalette (void)
    Gets the system default logical palette.
  • MG_EXPORT int GUIAPI GetPaletteEntries (HPALETTE hpal, int start, int len, GAL_Color *cmap)
    Gets palette entries of a logical palette.
  • MG_EXPORT int GUIAPI SetPaletteEntries (HPALETTE hpal, int start, int len, GAL_Color *cmap)
    Sets palette entries of a logical palette.
  • MG_EXPORT UINT GUIAPI GetNearestPaletteIndex (HPALETTE hpal, Uint8 red, Uint8 green, Uint8 blue)
    Gets the nearest palette index in the logical palette for a spefici color.
  • MG_EXPORT RGBCOLOR GUIAPI GetNearestColor (HDC hdc, Uint8 red, Uint8 green, Uint8 blue)
    Gets the nearest color compliant to a DC for a spefici color.
  • MG_EXPORT void GUIAPI SetPixel (HDC hdc, int x, int y, gal_pixel pixel)
    Sets the pixel with a new pixel value at the specified position on a DC.
  • MG_EXPORT gal_pixel GUIAPI SetPixelRGB (HDC hdc, int x, int y, Uint8 r, Uint8 g, Uint8 b)
    Sets the pixel by a RGB triple at the specified position on a DC.
  • MG_EXPORT gal_pixel GUIAPI SetPixelRGBA (HDC hdc, int x, int y, Uint8 r, Uint8 g, Uint8 b, Uint8 a)
    Sets the pixel by a RGBA quarter at the specified position on a DC.
  • MG_EXPORT gal_pixel GUIAPI GetPixel (HDC hdc, int x, int y)
    Gets the pixel value at the specified position on a DC.
  • MG_EXPORT gal_pixel GUIAPI GetPixelRGB (HDC hdc, int x, int y, Uint8 *r, Uint8 *g, Uint8 *b)
    Gets the pixel value at the specified position on a DC in RGB triple.
  • MG_EXPORT gal_pixel GUIAPI GetPixelRGBA (HDC hdc, int x, int y, Uint8 *r, Uint8 *g, Uint8 *b, Uint8 *a)
    Gets the pixel value at the specified position on a DC in RGBA quarter.
  • MG_EXPORT void GUIAPI RGBA2Pixels (HDC hdc, const RGB *rgbs, gal_pixel *pixels, int count)
    Gets the pixel values from a color array in RGBA quarter under a DC.
  • static gal_pixel RGBA2Pixel (HDC hdc, Uint8 r, Uint8 g, Uint8 b, Uint8 a)
    Gets the pixel value from a color in RGBA quarter under a DC.
  • MG_EXPORT void GUIAPI RGB2Pixels (HDC hdc, const RGB *rgbs, gal_pixel *pixels, int count)
    Gets the pixel values from a color array in RGB triple under a DC.
  • static gal_pixel RGB2Pixel (HDC hdc, Uint8 r, Uint8 g, Uint8 b)
    Gets the pixel value from a color in RGB triple under a DC.
  • MG_EXPORT void GUIAPI Pixel2RGBs (HDC hdc, const gal_pixel *pixels, RGB *rgbs, int count)
    Gets the colors in RGB triple from a pixel value array under a DC.
  • static void Pixel2RGB (HDC hdc, gal_pixel pixel, Uint8 *r, Uint8 *g, Uint8 *b)
    Gets the color in RGB triple from a pixel value under a DC.
  • MG_EXPORT void GUIAPI Pixel2RGBAs (HDC hdc, const gal_pixel *pixels, RGB *rgbs, int count)
    Gets the colors in RGBA quarter from a array of pixel values under a DC.
  • static void Pixel2RGBA (HDC hdc, gal_pixel pixel, Uint8 *r, Uint8 *g, Uint8 *b, Uint8 *a)
    Gets the color in RGBA quarter from a pixel value under a DC.
  • static DWORD Pixel2DWORD (HDC hdc, gal_pixel pixel)
    An inline function to convert pixel value to DWORD color.
  • static gal_pixel DWORD2PIXEL (HDC hdc, DWORD dword)
    An inline function to convert DWORD color to gal_pixel.
  • MG_EXPORT void GUIAPI FocusRect (HDC hdc, int x0, int y0, int x1, int y1)
    Draws a focus rectangle.
  • MG_EXPORT void GUIAPI DrawHVDotLine (HDC hdc, int x, int y, int w_h, BOOL H_V)
    Draws a horizontal or vertical dot dash line.
  • MG_EXPORT BOOL GUIAPI LineClipper (const RECT *cliprc, int *_x0, int *_y0, int *_x1, int *_y1)
    The line clipper using Cohen-Sutherland algorithm.
  • MG_EXPORT void GUIAPI LineGenerator (void *context, int x1, int y1, int x2, int y2, CB_LINE cb)
    A line generator based-on Breshenham algorithm.
  • MG_EXPORT void GUIAPI CircleGenerator (void *context, int sx, int sy, int r, CB_CIRCLE cb)
    A circle generator.
  • MG_EXPORT void GUIAPI EllipseGenerator (void *context, int sx, int sy, int rx, int ry, CB_ELLIPSE cb)
    An ellipse generator.
  • MG_EXPORT void GUIAPI CircleArcGenerator (void *context, int sx, int sy, int r, int ang1, int ang2, CB_ARC cb)
    An arc generator.
  • MG_EXPORT BOOL GUIAPI MonotoneVerticalPolygonGenerator (void *context, const POINT *pts, int vertices, CB_POLYGON cb)
    A monotone vertical polygon generator.
  • MG_EXPORT BOOL GUIAPI PolygonIsMonotoneVertical (const POINT *pts, int vertices)
    Checks a polygon is monotone vertical or not.
  • MG_EXPORT BOOL GUIAPI PolygonGeneratorEx (void *context, const POINT *pts, int vertices, CB_POLYGON cb, RECT *rc_output)
    A general polygon generator.
  • MG_EXPORT BOOL GUIAPI FloodFillGenerator (void *context, const RECT *src_rc, int x, int y, CB_EQUAL_PIXEL cb_equal_pixel, CB_FLOOD_FILL cb_flood_fill)
    A flood filling generator.
  • MG_EXPORT int GUIAPI SetBitmapScalerType (HDC hdc, int scaler_type)
    set bitmap scaler algorithm callback of DC according by scaler_type.
  • MG_EXPORT void GUIAPI MoveTo (HDC hdc, int x, int y)
    Moves the current zero pen position.
  • MG_EXPORT void GUIAPI LineTo (HDC hdc, int x, int y)
    Draws a zero line to a position.
  • MG_EXPORT void GUIAPI Rectangle (HDC hdc, int x0, int y0, int x1, int y1)
    Draws a rectangle.
  • MG_EXPORT void GUIAPI PolyLineTo (HDC hdc, const POINT *pts, int vertices)
    Draws a polyline.
  • MG_EXPORT void GUIAPI SplineTo (HDC hdc, const POINT *pts)
    Draws a bezier spline.
  • MG_EXPORT void GUIAPI Circle (HDC hdc, int sx, int sy, int r)
    Draws a circle.
  • MG_EXPORT void GUIAPI Ellipse (HDC hdc, int sx, int sy, int rx, int ry)
    Draws a ellipse.
  • MG_EXPORT void GUIAPI CircleArc (HDC hdc, int sx, int sy, int r, int ang1, int ang2)
    Draws an arc.
  • MG_EXPORT void GUIAPI FillBox (HDC hdc, int x, int y, int w, int h)
    Fills a rectangle box.
  • MG_EXPORT void GUIAPI FillCircle (HDC hdc, int sx, int sy, int r)
    Fills a circle.
  • MG_EXPORT void GUIAPI FillEllipse (HDC hdc, int sx, int sy, int rx, int ry)
    Fills an ellipse.
  • MG_EXPORT BOOL GUIAPI FillPolygon (HDC hdc, const POINT *pts, int vertices)
    Fills an polygon.
  • MG_EXPORT BOOL GUIAPI FloodFill (HDC hdc, int x, int y)
    Fills an enclosed area starting at point (x,y).
  • MG_EXPORT void GUIAPI SetPenDashes (HDC hdc, int dash_offset, const unsigned char *dash_list, int n)
    Sets the way dashed-lines are drawn.
  • MG_EXPORT void GUIAPI SetBrushInfo (HDC hdc, const BITMAP *tile, const STIPPLE *stipple)
    Set the tile or stipple with the DC.
  • MG_EXPORT void GUIAPI SetBrushOrigin (HDC hdc, int x, int y)
    Set the origin when using tiles or stipples with the DC.
  • MG_EXPORT void GUIAPI LineEx (HDC hdc, int x1, int y1, int x2, int y2)
    Draws a line with the current pen in the DC hdc.
  • MG_EXPORT void GUIAPI ArcEx (HDC hdc, int x, int y, int width, int height, int ang1, int ang2)
    Draws an arc with the current pen in a DC.
  • MG_EXPORT void GUIAPI FillArcEx (HDC hdc, int x, int y, int width, int height, int ang1, int ang2)
    Fills an arc with the current brush in a DC.
  • MG_EXPORT void GUIAPI PolyLineEx (HDC hdc, const POINT *pts, int nr_pts)
    Draws a polyline with the current pen in a DC.
  • MG_EXPORT void GUIAPI PolyArcEx (HDC hdc, const ARC *arcs, int nr_arcs)
    Draws a polyarc with the current pen in a DC.
  • MG_EXPORT void GUIAPI PolyFillArcEx (HDC hdc, const ARC *arcs, int nr_arcs)
    Fill a polyarc with the current brush in a DC.
  • MG_EXPORT BOOL GUIAPI RoundRect (HDC hdc, int x0, int y0, int x1, int y1, int cw, int ch)
    Draw and fill a rectangle with rounded corners in a DC.
  • MG_EXPORT void GUIAPI GetDCLCS (HDC hdc, int which, POINT *pt)
    Retrieves mapping parameters of a device context.
  • MG_EXPORT void GUIAPI SetDCLCS (HDC hdc, int which, const POINT *pt)
    Sets mapping parameters of a device context.
  • MG_EXPORT void GUIAPI DPtoLP (HDC hdc, POINT *pPt)
    Converts device coordinates into logical coordinates.
  • MG_EXPORT void GUIAPI LPtoDP (HDC hdc, POINT *pPt)
    Converts logical coordinates into device coordinates.
  • MG_EXPORT void GUIAPI SPtoLP (HDC hdc, POINT *pPt)
    Converts screen coordinates into logical coordinates.
  • MG_EXPORT void GUIAPI LPtoSP (HDC hdc, POINT *pPt)
    Converts logical coordinates into screen coordinates.
  • MG_EXPORT void GUIAPI ExcludeClipRect (HDC hdc, const RECT *prc)
    Excludes the specified rectangle from the current visible region of a DC.
  • MG_EXPORT void GUIAPI IncludeClipRect (HDC hdc, const RECT *prc)
    Includes the specified rectangle to the current visible region of a DC.
  • MG_EXPORT BOOL GUIAPI PtVisible (HDC hdc, int x, int y)
    Checks whether a point is visible.
  • MG_EXPORT void GUIAPI ClipRectIntersect (HDC hdc, const RECT *prc)
    Intersects the specified rectangle with the visible region of the DC.
  • MG_EXPORT void GUIAPI SelectClipRect (HDC hdc, const RECT *prc)
    Sets the visible region of a DC to be a rectangle.
  • MG_EXPORT int GUIAPI SelectClipRegionEx (HDC hdc, const CLIPRGN *pRgn, int fnMode)
    Combines the specified region with the current clipping region using the specified mode.
  • MG_EXPORT void GUIAPI SelectClipRegion (HDC hdc, const CLIPRGN *pRgn)
    Sets the visible region of a DC to be a region.
  • MG_EXPORT int GUIAPI OffsetClipRegion (HDC hdc, int nXOffset, int nYOffset)
    Moves the clipping region of a device context by the specified offsets.
  • MG_EXPORT void GUIAPI GetBoundsRect (HDC hdc, RECT *pRect)
    Retrieves the bounding rectangle of the current visible region of a DC.
  • MG_EXPORT BOOL GUIAPI RectVisible (HDC hdc, const RECT *pRect)
    Checks whether the specified rectangle is visible.
  • MG_EXPORT int GUIAPI GetClipBox (HDC hdc, RECT *clipbox)
    Retrieves the bounding rectangle of the current clipping region of a DC.
  • MG_EXPORT BOOL GUIAPI GetBitmapFromDC (HDC hdc, int x, int y, int w, int h, BITMAP *bmp)
    Gets image box on a DC and saves it into a BITMAP object.
  • MG_EXPORT BOOL GUIAPI FillBoxWithBitmap (HDC hdc, int x, int y, int w, int h, const BITMAP *bmp)
    Fills a box with a BITMAP object.
  • MG_EXPORT BOOL GUIAPI FillBoxWithBitmapPart (HDC hdc, int x, int y, int w, int h, int bw, int bh, const BITMAP *bmp, int xo, int yo)
    Fills a box with a part of a bitmap oject.
  • MG_EXPORT BOOL GUIAPI FillBitmapPartInBox (HDC hdc, int box_x, int box_y, int box_w, int box_h, const BITMAP *pbmp, int bmp_x, int bmp_y, int bmp_w, int bmp_h)
    Fills a part of bitmap into a box, and the parts bitmap will be scaled if needed.
  • MG_EXPORT void GUIAPI BitBlt (HDC hsdc, int sx, int sy, int sw, int sh, HDC hddc, int dx, int dy, DWORD dwRop)
    Performs a bit-block transfer from a device context into another device context.
  • MG_EXPORT void GUIAPI StretchBlt (HDC hsdc, int sx, int sy, int sw, int sh, HDC hddc, int dx, int dy, int dw, int dh, DWORD dwRop)
    Copies a bitmap from a source rectangle into a destination rectangle, streches the bitmap if necessary.
  • MG_EXPORT BOOL GUIAPI ScaleBitmapEx (BITMAP *dst, const BITMAP *src, HDC ref_dc)
    Scales a BITMAP object into another BITMAP object by specify algorithm.
  • MG_EXPORT gal_pixel GUIAPI GetPixelInBitmapEx (const BITMAP *bmp, int x, int y, Uint8 *alpha)
    Returns the pixel value in a BITMAP object.
  • static gal_pixel GUIAPI GetPixelInBitmap (const BITMAP *bmp, int x, int y)
    Returns the pixel value in a BITMAP object.
  • static BOOL GUIAPI SetPixelInBitmap (const BITMAP *bmp, int x, int y, gal_pixel pixel)
    Sets pixel value in a BITMAP object.
  • MG_EXPORT BOOL GUIAPI SaveScreenRectContent (const RECT *rcWin, const char *filename)
    Saves content of a rectangle in the screen to a file.
  • MG_EXPORT BOOL GUIAPI SaveMainWindowContent (HWND hWnd, const char *filename)
    Saves content of a main window to a file.
  • MG_EXPORT HICON GUIAPI LoadIconFromFile (HDC hdc, const char *filename, int which)
    Loads an icon from a Windows ICO file.
  • MG_EXPORT HICON GUIAPI LoadIconFromMem (HDC hdc, const void *area, int which)
    Loads an icon from a memory area.
  • MG_EXPORT HICON GUIAPI CreateIconEx (HDC hdc, int w, int h, const BYTE *AndBits, const BYTE *XorBits, int colornum, const RGB *pal)
    Creates an icon object from the memory.
  • MG_EXPORT BOOL GUIAPI DestroyIcon (HICON hicon)
    Destroys an icon object.
  • MG_EXPORT BOOL GUIAPI GetIconSize (HICON hicon, int *w, int *h)
    Gets the size of an icon object.
  • MG_EXPORT void GUIAPI DrawIcon (HDC hdc, int x, int y, int w, int h, HICON hicon)
    Draws an icon into a box.
  • static void SetRect (RECT *prc, int left, int top, int right, int bottom)
    Sets a rectangle.
  • static void SetRectEmpty (RECT *prc)
    Empties a rectangle.
  • static void CopyRect (RECT *pdrc, const RECT *psrc)
    Copies one rectangle to another.
  • static void OffsetRect (RECT *prc, int x, int y)
    Moves a rectangle by offsets.
  • static void InflateRect (RECT *prc, int cx, int cy)
    Increases or decreases the width and height of an rectangle.
  • static void InflateRectToPt (RECT *prc, int x, int y)
    Inflates a rectangle to contain a point.
  • static BOOL PtInRect (const RECT *prc, int x, int y)
    Determines whether a point lies within an rectangle.
  • MG_EXPORT BOOL GUIAPI IsRectEmpty (const RECT *prc)
    Determines whether an rectangle is empty.
  • MG_EXPORT BOOL GUIAPI EqualRect (const RECT *prc1, const RECT *prc2)
    Determines whether two rectangles are equal.
  • MG_EXPORT void GUIAPI NormalizeRect (RECT *pRect)
    Normalizes a rectangle.
  • MG_EXPORT BOOL GUIAPI IntersectRect (RECT *pdrc, const RECT *psrc1, const RECT *psrc2)
    Calculates the intersection of two rectangles.
  • MG_EXPORT BOOL GUIAPI IsCovered (const RECT *prc1, const RECT *prc2)
    Determines whether one rectangle is covered by another.
  • MG_EXPORT BOOL GUIAPI DoesIntersect (const RECT *psrc1, const RECT *psrc2)
    Determines whether two rectangles intersect.
  • MG_EXPORT BOOL GUIAPI UnionRect (RECT *pdrc, const RECT *psrc1, const RECT *psrc2)
    Unions two source rectangles.
  • MG_EXPORT void GUIAPI GetBoundRect (PRECT pdrc, const RECT *psrc1, const RECT *psrc2)
    Gets the bound rectangle of two source rectangles.
  • MG_EXPORT int GUIAPI SubtractRect (RECT *rc, const RECT *psrc1, const RECT *psrc2)
    Obtains the rectangles when substracting one rectangle from another.
  • MG_EXPORT void GUIAPI GetFontMetrics (LOGFONT *log_font, FONTMETRICS *font_metrics)
    Gets metrics information of a logical font.
  • MG_EXPORT void GUIAPI GetGlyphBitmap (LOGFONT *log_font, const char *mchar, int mchar_len, GLYPHBITMAP *glyph_bitmap)
    Gets the glyph bitmap information when uses a logical font to output a character.
  • MG_EXPORT BOOL GUIAPI InitVectorialFonts (void)
    Initializes vectorial font renderer.
  • MG_EXPORT void GUIAPI TermVectorialFonts (void)
    Terminates vectorial font renderer.
  • MG_EXPORT PLOGFONT GUIAPI CreateLogFont (const char *type, const char *family, const char *charset, char weight, char slant, char flip, char other, char underline, char struckout, int size, int rotation)
    Creates a logical font.
  • MG_EXPORT PLOGFONT GUIAPI CreateLogFontByName (const char *font_name)
    Creates a logical font by a font name.
  • MG_EXPORT PLOGFONT GUIAPI CreateLogFontIndirect (LOGFONT *logfont)
    Creates a logical font indirectly from a LOGFONT structure.
  • MG_EXPORT void GUIAPI DestroyLogFont (PLOGFONT log_font)
    Destroys a logical font.
  • MG_EXPORT void GUIAPI GetLogFontInfo (HDC hdc, LOGFONT *log_font)
    Gets logical font information of a DC.
  • MG_EXPORT PLOGFONT GUIAPI GetCurFont (HDC hdc)
    Gets the pointer to the current logical font of a DC.
  • MG_EXPORT PLOGFONT GUIAPI SelectFont (HDC hdc, PLOGFONT log_font)
    Selects a logical font into a DC.
  • MG_EXPORT const DEVFONT *GUIAPI GetNextDevFont (const DEVFONT *dev_font)
    Get next devfont information.
  • MG_EXPORT BOOL GUIAPI ft2SetLcdFilter (LOGFONT *logfont, mg_FT_LcdFilter filter)
    Set freetype2 smooth mode.
  • MG_EXPORT DEVFONT *GUIAPI LoadDevFontFromFile (const char *devfont_name, const char *file_name)
    Load device font from font file.
  • MG_EXPORT void GUIAPI DestroyDynamicDevFont (DEVFONT **devfont)
    Destroy device font loaded dynamically from font file.
  • static PLOGFONT GUIAPI GetSystemFont (int font_id)
    Gets the system logical font through an font identifier.
  • MG_EXPORT int GUIAPI GetSysFontMaxWidth (int font_id)
    Gets the maximal width of a single-byte character of a system font.
  • MG_EXPORT int GUIAPI GetSysFontAveWidth (int font_id)
    Gets the average width of a single-byte character of a system font.
  • MG_EXPORT int GUIAPI GetSysFontHeight (int font_id)
    Gets the height of a single-byte character of a system font.
  • MG_EXPORT const char *GUIAPI GetSysCharset (BOOL wchar)
    Gets the current system charset.
  • MG_EXPORT int GUIAPI GetSysCharHeight (void)
    Gets the height of a character of the default system font.
  • MG_EXPORT int GUIAPI GetSysCharWidth (void)
    Gets the width of a single-byte character of the default system font.
  • MG_EXPORT int GUIAPI GetSysCCharWidth (void)
    Gets the width of a multi-byte character of the default system font.
  • MG_EXPORT int GUIAPI GetTextMCharInfo (PLOGFONT log_font, const char *mstr, int len, int *pos_chars)
    Retrieves positions of multi-byte characters in a string.
  • MG_EXPORT int GUIAPI GetTextWordInfo (PLOGFONT log_font, const char *mstr, int len, int *pos_words, WORDINFO *info_words)
    Retrieves information of multi-byte words in a string.
  • MG_EXPORT int GUIAPI GetFirstMCharLen (PLOGFONT log_font, const char *mstr, int len)
    Retrieves the length of the first multi-byte character in a string.
  • MG_EXPORT int GUIAPI GetFirstWord (PLOGFONT log_font, const char *mstr, int len, WORDINFO *word_info)
    Retrieves the length and info of the first multi-byte word in a string.
  • MG_EXPORT int GUIAPI MB2WCEx (PLOGFONT log_font, void *dest, BOOL wc32, const unsigned char *mstr, int n)
    Converts a multibyte character to a wide character in UCS according to the charset/encoding of the logical font.
  • MG_EXPORT int GUIAPI WC2MBEx (PLOGFONT log_font, unsigned char *s, UChar32 wc)
    Converts a wide character in UCS to a multibyte character according to the charset/encoding of the logical font.
  • MG_EXPORT int GUIAPI MBS2WCSEx (PLOGFONT log_font, void *dest, BOOL wc32, const unsigned char *mstr, int mstr_len, int n, int *conved_mstr_len)
    Converts a multibyte string to a wide character string in UC16 according to the charset/encoding of the logical font.
  • MG_EXPORT int GUIAPI WCS2MBSEx (PLOGFONT log_font, unsigned char *dest, const void *wcs, int wcs_len, BOOL wc32, int n, int *conved_wcs_len)
    Converts a wide character string in UC16 to a multibyte string according to the charset/encoding of the logical font.
  • MG_EXPORT int GUIAPI GetTextExtentPoint (HDC hdc, const char *text, int len, int max_extent, int *fit_chars, int *pos_chars, int *dx_chars, SIZE *size)
    Computes the extent of a string when output the string in a limited space.
  • MG_EXPORT int GUIAPI GetTabbedTextExtentPoint (HDC hdc, const char *text, int len, int max_extent, int *fit_chars, int *pos_chars, int *dx_chars, SIZE *size)
    Computes the extent of a string when output the formatted string in a limited space.
  • MG_EXPORT int GUIAPI GetFontHeight (HDC hdc)
    Retrieves the height of the current logical font in a DC.
  • MG_EXPORT int GUIAPI GetMaxFontWidth (HDC hdc)
    Retrieves the maximal character width of the current logical font in a DC.
  • MG_EXPORT int GUIAPI GetTextExtent (HDC hdc, const char *spText, int len, SIZE *pSize)
    Computes the output extent of a string of text.
  • MG_EXPORT int GUIAPI GetTabbedTextExtent (HDC hdc, const char *spText, int len, SIZE *pSize)
    Computes the output extent of a formatted text.
  • MG_EXPORT int GUIAPI TextOutLen (HDC hdc, int x, int y, const char *spText, int len)
    Outputs a string of text.
  • MG_EXPORT int GUIAPI TextOutOmitted (HDC hdc, int x, int y, const char *mtext, int len, int max_extent)
    Outputs a string of text with omitted format.
  • MG_EXPORT int GUIAPI TabbedTextOutLen (HDC hdc, int x, int y, const char *spText, int len)
    Outputs a formatted text.
  • MG_EXPORT int GUIAPI TabbedTextOutEx (HDC hdc, int x, int y, const char *spText, int nCount, int nTabPositions, int *pTabPositions, int nTabOrigin)
    Writes a character string at a specified location, expanding tabs to the values specified in an anrry of tab-stop positions.
  • MG_EXPORT void GUIAPI GetLastTextOutPos (HDC hdc, POINT *pt)
    Retrieves the last text output position.
  • MG_EXPORT int GUIAPI DrawTextEx2 (HDC hdc, const char *pText, int nCount, RECT *pRect, int nIndent, UINT nFormat, DTFIRSTLINE *firstline)
    Draws a formatted text in a rectangle.
  • MG_EXPORT BOOL GUIAPI RegisterBitmapFileType (const char *ext, void *(*init)(MG_RWops *fp, MYBITMAP *my_bmp, RGB *pal), int(*load)(MG_RWops *fp, void *init_info, MYBITMAP *my_bmp, CB_ONE_SCANLINE cb, void *context), void(*cleanup)(void *init_info), int(*save)(MG_RWops *fp, MYBITMAP *my_bmp, RGB *pal), BOOL(*check)(MG_RWops *fp))
    Registers a bitmap file loader, saver, and checker.
  • MG_EXPORT const char *GUIAPI CheckBitmapType (MG_RWops *fp)
    Checks the type of the bitmap in a data source.
  • MG_EXPORT BOOL GUIAPI mlsEnableSlaveScreen (HDC dc_mls, BOOL enable)
    Enable or Disable a MLShadow slave screen.
  • MG_EXPORT int GUIAPI LoadBitmapEx (HDC hdc, PBITMAP pBitmap, MG_RWops *area, const char *ext)
    Loads a device-dependent bitmap from a general data source.
  • MG_EXPORT int GUIAPI LoadBitmapFromFile (HDC hdc, PBITMAP pBitmap, const char *spFileName)
    Loads a device-dependent bitmap from a file.
  • MG_EXPORT int GUIAPI LoadBitmapFromMem (HDC hdc, PBITMAP pBitmap, const void *mem, int size, const char *ext)
    Loads a device-dependent bitmap from memory.
  • MG_EXPORT void GUIAPI UnloadBitmap (PBITMAP pBitmap)
    Unloads a bitmap.
  • MG_EXPORT void GUIAPI ReplaceBitmapColor (HDC hdc, PBITMAP pBitmap, gal_pixel iOColor, gal_pixel iNColor)
    Replaces a specific pixels in a bitmap with another pixel.
  • MG_EXPORT void GUIAPI HFlipBitmap (BITMAP *bmp, unsigned char *inter_buff)
    Horizontal Flip the special Bitmap object.
  • MG_EXPORT void GUIAPI VFlipBitmap (BITMAP *bmp, unsigned char *inter_buff)
    Vertical Flip the special Bitmap object.
  • MG_EXPORT void *GUIAPI InitMyBitmapSL (MG_RWops *area, const char *ext, MYBITMAP *my_bmp, RGB *pal)
    Initializes scanline loader of the MYBITMAP object from a data source.
  • MG_EXPORT int GUIAPI LoadMyBitmapSL (MG_RWops *area, void *load_info, MYBITMAP *my_bmp, CB_ONE_SCANLINE cb, void *context)
    Loads MYBITMAP scanlines from a data source one by one.
  • MG_EXPORT int GUIAPI CleanupMyBitmapSL (MYBITMAP *my_bmp, void *load_info)
    Cleanups the scanline loader.
  • MG_EXPORT int GUIAPI LoadMyBitmapEx (PMYBITMAP my_bmp, RGB *pal, MG_RWops *area, const char *ext)
    Loads a MYBITMAP object from a data source.
  • MG_EXPORT int GUIAPI LoadMyBitmapFromFile (PMYBITMAP my_bmp, RGB *pal, const char *file_name)
    Loads a MYBITMAP object from a file.
  • MG_EXPORT int GUIAPI LoadMyBitmapFromMem (PMYBITMAP my_bmp, RGB *pal, const void *mem, int size, const char *ext)
    Loads a MYBITMAP object from memory.
  • MG_EXPORT void GUIAPI UnloadMyBitmap (PMYBITMAP my_bmp)
    Unloads a bitmap.
  • MG_EXPORT int GUIAPI SaveMyBitmapToFile (PMYBITMAP my_bmp, RGB *pal, const char *spFileName)
    Saves a MYBITMAP object to a bitmap file.
  • MG_EXPORT int GUIAPI SaveBitmapToFile (HDC hdc, PBITMAP pBitmap, const char *spFileName)
    Saves a BITMAP object to a bitmap file.
  • MG_EXPORT BOOL GUIAPI InitBitmap (HDC hdc, Uint32 w, Uint32 h, Uint32 pitch, BYTE *bits, PBITMAP bmp)
    Initializes a BITMAP object as a normal bitmap.
  • MG_EXPORT HDC GUIAPI InitSlaveScreen (const char *name, const char *mode)
    Initializes slave screen.
  • MG_EXPORT void GUIAPI TerminateSlaveScreen (HDC hdc)
    Terminates slave screen.
  • MG_EXPORT BOOL GUIAPI InitBitmapPixelFormat (HDC hdc, PBITMAP bmp)
    Initializes the bitmap pixel format information of a BITMAP object.
  • MG_EXPORT void GUIAPI DeleteBitmapAlphaPixel (PBITMAP bmp)
    Deletes the bitmap alpha pixel format information of a BITMAP object.
  • MG_EXPORT int GUIAPI ExpandMyBitmap (HDC hdc, PBITMAP bmp, const MYBITMAP *my_bmp, const RGB *pal, int frame)
    Expands a MYBITMAP object to a BITMAP object.
  • MG_EXPORT void GUIAPI ExpandMonoBitmap (HDC hdc, BYTE *bits, Uint32 pitch, const BYTE *my_bits, Uint32 my_pitch, Uint32 w, Uint32 h, DWORD flags, Uint32 bg, Uint32 fg)
    Convert a mono color MYBITMAP pixel data to a BITMAP pixel data.
  • MG_EXPORT void GUIAPI Expand16CBitmap (HDC hdc, BYTE *bits, Uint32 pitch, const BYTE *my_bits, Uint32 my_pitch, Uint32 w, Uint32 h, DWORD flags, const RGB *pal)
    Convert a 16 color MYBITMAP pixel data to a BITMAP pixel data.
  • MG_EXPORT void GUIAPI CompileRGBABitmap (HDC hdc, BYTE *bits, Uint32 pitch, const BYTE *my_bits, Uint32 my_pitch, Uint32 w, Uint32 h, DWORD flags, void *pixel_format, CB_DRAW_PIXEL cb_draw, MYBITMAP_CONTXT *mybmp)
    Convert a MYBITMAP pixel data to a BITMAP pixel data.
  • MG_EXPORT void GUIAPI CompileRGBABitmapEx (HDC hdc, BYTE *bits, Uint32 pitch, const BYTE *my_bits, Uint32 my_pitch, Uint32 w, Uint32 h, DWORD flags, void *pixel_format, CB_DRAW_PIXEL cb_draw, MYBITMAP_CONTXT *mybmp, BYTE *alpha_mask)
    Compile a MYBITMAP pixel data to a BITMAP pixel data.
  • MG_EXPORT int GUIAPI PaintImageEx (HDC hdc, int x, int y, MG_RWops *area, const char *ext)
    Paints an image from data source on device directly.
  • MG_EXPORT int GUIAPI PaintImageFromFile (HDC hdc, int x, int y, const char *spFileName)
    Paints an image from file on device directly.
  • MG_EXPORT int GUIAPI PaintImageFromMem (HDC hdc, int x, int y, const void *mem, int size, const char *ext)
    Paints an image from memory on device directly.
  • MG_EXPORT int GUIAPI StretchPaintImageEx (HDC hdc, int x, int y, int w, int h, MG_RWops *area, const char *ext)
    Paints an image from data source on device directly.
  • MG_EXPORT int GUIAPI StretchPaintImageFromFile (HDC hdc, int x, int y, int w, int h, const char *spFileName)
    Paints an image from file on device directly.
  • MG_EXPORT int GUIAPI StretchPaintImageFromMem (HDC hdc, int x, int y, int w, int h, const void *mem, int size, const char *ext)
    Paints an image from memory on device directly.
  • MG_EXPORT void GUIAPI RotateBitmap (HDC hdc, const BITMAP *bmp, int lx, int ty, int angle)
    Rotate a bitmap object.
  • MG_EXPORT void GUIAPI RotateBitmapVFlip (HDC hdc, const BITMAP *bmp, int lx, int ty, int angle)
    Flips vertically and rotates a bitmap object.
  • MG_EXPORT void GUIAPI RotateBitmapHFlip (HDC hdc, const BITMAP *bmp, int lx, int ty, int angle)
    Flips horizontally and rotates a bitmap object.
  • MG_EXPORT void GUIAPI RotateScaledBitmap (HDC hdc, const BITMAP *bmp, int lx, int ty, int angle, int w, int h)
    Stretches or shrinks a bitmap object at the same as rotating it.
  • MG_EXPORT void GUIAPI RotateScaledBitmapVFlip (HDC hdc, const BITMAP *bmp, int lx, int ty, int angle, int w, int h)
    Flip vertically, rotates, stretch or shrinks a bitmap object.
  • MG_EXPORT void GUIAPI RotateScaledBitmapHFlip (HDC hdc, const BITMAP *bmp, int lx, int ty, int angle, int w, int h)
    Flip horizontaly, rotates, stretch or shrinks a bitmap object.
  • MG_EXPORT void GUIAPI PivotBitmap (HDC hdc, const BITMAP *bmp, int lx, int ty, int cx, int cy, int angle)
    Pivot a bitmap object.
  • MG_EXPORT void GUIAPI PivotScaledBitmapFlip (HDC hdc, const BITMAP *bmp, fixed x, fixed y, fixed cx, fixed cy, int angle, fixed scale_x, fixed scale_y, BOOL h_flip, BOOL v_flip)
    Rotates, stretches or shrinks, flips a bitmap object.
  • MG_EXPORT DEVFONT *GUIAPI CreateBMPDevFont (const char *bmpfont_name, const BITMAP *glyph_bmp, const char *start_mchar, int nr_glyphs, int glyph_width)
    Create a bitmap device font.
  • MG_EXPORT BOOL GUIAPI AddGlyphsToBMPFont (DEVFONT *dev_font, BITMAP *glyph_bmp, const char *start_mchar, int nr_glyphs, int glyph_width)
    Add a new segment in device font.
  • MG_EXPORT void GUIAPI DestroyBMPFont (DEVFONT *dev_font)
    Destroy the bitmap device font.
  • MG_EXPORT Glyph32 GUIAPI GetGlyphValue (LOGFONT *logfont, const char *mchar, int mchar_len, const char *pre_mchar, int pre_len)
    Get the glyph value of a multi-byte character.
  • MG_EXPORT Glyph32 GUIAPI GetGlyphShape (LOGFONT *logfont, const char *mchar, int mchar_len, SHAPETYPE shape_type)
    Get the glyph shape of a character.
  • MG_EXPORT int GUIAPI DrawGlyph (HDC hdc, int x, int y, Glyph32 glyph_value, int *adv_x, int *adv_y)
    Draw a glyph.
  • MG_EXPORT int GUIAPI GetGlyphInfo (LOGFONT *logfont, Glyph32 glyph_value, GLYPHINFO *glyph_info)
    Retriev the information of a glyph.
  • MG_EXPORT int GUIAPI GetGlyphsExtent (HDC hdc, Glyph32 *glyphs, int nr_glyphs, SIZE *size)
    Get visual extent value of a glyph string.
  • MG_EXPORT int GUIAPI GetGlyphsExtentPoint (HDC hdc, Glyph32 *glyphs, int nr_glyphs, int max_extent, SIZE *size)
    Get the visual extent value of a glyph string.
  • MG_EXPORT int GUIAPI BIDIGetTextLogicalGlyphs (LOGFONT *log_font, const char *text, int text_len, Glyph32 **glyphs, GLYPHMAPINFO **glyphs_map)
    Get logical glyphs string of the text.
  • MG_EXPORT int GUIAPI BIDIGetTextVisualGlyphs (LOGFONT *log_font, const char *text, int text_len, Glyph32 **glyphs, GLYPHMAPINFO **glyphs_map)
    Get visual glyphs and glyph_map info relative with logical string byte index.
  • MG_EXPORT Glyph32 *GUIAPI BIDILogGlyphs2VisGlyphs (LOGFONT *log_font, Glyph32 *glyphs, int nr_glyphs, GLYPHMAPINFO *glyphs_map)
    Reorder the logical glyphs string to visual glyphs string.
  • MG_EXPORT void GUIAPI GetTextRangesLog2Vis (LOGFONT *log_font, char *text, int text_len, int start_index, int end_index, int **ranges, int *nr_ranges)
    Get a list of visual ranges corresponding to a given logical range.
  • MG_EXPORT void GUIAPI BIDIGetLogicalEmbeddLevels (LOGFONT *log_font, Glyph32 *glyphs, int nr_glyphs, Uint8 **embedding_level_list)
    Get the logical embedding levels for the logical glyph string and generate runs by embedding levels, the for reorder to get visual glyph string.
  • MG_EXPORT void GUIAPI BIDIGetVisualEmbeddLevels (LOGFONT *log_font, Glyph32 *glyphs, int nr_glyphs, Uint8 **embedding_level_list)
    Get the visual embedding levels for the given logical glyph string, then you can get the edge for visual glyphs.

Variables

  • MG_EXPORT gal_pixel SysPixelIndex []
    The pre-defined system pixel values.
  • const MG_EXPORT RGB SysPixelColor []
    The pre-defined system RGB colors.

Detailed Description

Author:
Wei Yongming <ymwei@minigui.org>
Date:
2002/01/06
This file includes graphics device interfaces of MiniGUI.

    Copyright (C) 2002-2009 Feynman Software.
    Copyright (C) 1998-2002 Wei Yongming.

    All rights reserved by Feynman Software.

    This file is part of MiniGUI, a compact cross-platform Graphics
    User Interface (GUI) support system for real-time embedded systems.

Definition in file gdi.h.

Function Documentation

BOOL GUIAPI AddGlyphsToBMPFont | ( | DEVFONT * | dev_font,
 |  | BITMAP * | glyph_bmp,
 |  | const char * | start_mchar,
 |  | int | nr_glyphs,
 |  | int | glyph_width
 | ) |  |

Add a new segment in device font.

This function add a new segment to the device font pointed by dev_font.

Parameters:
dev_font | The pointer to the device font.
glyph_bmp | The pointer to the segment glyph bitmap object.
start_mchar | The pointer to the first char of the segment.
nr_glyphs | The character count of the segment.
glyph_width | The character width in the segment.
Returns:
TRUE if success, otherwise FALSE.

DEVFONT *GUIAPI CreateBMPDevFont | ( | const char * | bmpfont_name,
 |  | const BITMAP * | glyph_bmp,
 |  | const char * | start_mchar,
 |  | int | nr_glyphs,
 |  | int | glyph_width
 | ) |  |

Create a bitmap device font.

This function create a bitmap device font and return the pointer to the new device font.

Parameters:
bmpfont_name | The font name.
glyph_bmp | The pointer to the bitmap object.
start_mchar | The pointer to the first char of segment.
nr_glyphs | The character count of the segment.
glyph_width | The character width.
Returns:
The pointer to the new device font on sucess, otherwise NULL.

void GUIAPI DestroyBMPFont ( DEVFONT * dev_font )

Destroy the bitmap device font.

This function destroy the bitmap device font pointed by dev_font.

Parameters:
dev_font The pointer to the device font which will be destroyed.
Returns:
TRUE if success, otherwise FALSE.

Generated on Fri Dec 17 13:49:42 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: gridview.h File Reference

include » ctrl

gridview.h File Reference

Go to the source code of this file.

Data Structures

  • struct _GRIDVIEWDATA
  • struct _GRIDCELLS
  • struct _GRIDCELLDATAHEADER
  • struct _GRIDCELLDATATEXT
  • struct _GRIDCELLDATANUMBER
  • struct _GRIDCELLDATACHECKBOX
  • struct _GRIDCELLDATASELECTION
  • struct _GRIDCELLDATA

Defines

  • #define CTRL_GRIDVIEW "gridview"
    The class name of gridview control.
  • #define GRID_OKAY 0
    Gridview return value.
  • #define GRID_ERR (-1)
    Gridview return value.
  • #define GV_HALIGN_LEFT 0x00000001
  • #define GV_HALIGN_RIGHT 0x00000002
  • #define GV_HALIGN_CENTER 0x00000003
  • #define GV_VALIGN_TOP 0x00000010
  • #define GV_VALIGN_BOTTOM 0x00000020
  • #define GV_VALIGN_CENTER 0x00000030
  • #define GV_HALIGN_MASK 0x0000000F
  • #define GV_VALIGN_MASK 0x000000F0
  • #define GV_TYPE_UNKNOWN 0x00000000
  • #define GV_TYPE_TEXT 0x00000100
  • #define GV_TYPE_NUMBER 0x00000200
  • #define GV_TYPE_CHECKBOX 0x00000300
  • #define GV_TYPE_SELECTION 0x00000400
  • #define GV_TYPE_HEADER 0x00000500
  • #define GV_TYPE_TABLEHEADER 0x00000600
  • #define GV_TYPE_MASK 0x0000FF00
  • #define GVS_WITHICON 0x00010000
  • #define GVS_WITHCHECKBOX 0x00020000
  • #define GVS_MULTLINE 0x00100000
  • #define GVS_READONLY 0x00200000
  • #define GVS_BOXCHECKED 0x00400000
  • #define GRIDM_SETCELLPROPERTY 0xF210
    An Application sends a GRIDM_SETCELLPROPERTY message to set the cells' property in the grid control.
  • #define GRIDM_GETCELLPROPERTY 0xF211
    An Application sends a GRIDM_GETCELLPROPERTY message to get a single cell's property in the grid control.
  • #define GRIDM_SETCOLWIDTH 0xF212
    An Application sends a GRIDM_SETCOLWIDTH message to set column width in the grid control.
  • #define GRIDM_GETCOLWIDTH 0xF213
    An Application sends a GRIDM_GETCOLWIDTH message to get a column width in the grid control.
  • #define GRIDM_SETROWHEIGHT 0xF214
    An Application sends a GRIDM_SETROWHEIGHT message to set a row height in the grid control.
  • #define GRIDM_GETROWHEIGHT 0xF215
    An Application sends a GRIDM_GETROWHEIGHT message to get a row height in the grid control.
  • #define GRIDM_ADDROW 0xF216
    An Application sends a GRIDM_ADDROW message to add a new row to the control.
  • #define GRIDM_DELROW 0xF217
    An Application sends a GRIDM_DELROW message to delete a row frow the control.
  • #define GRIDM_ADDCOLUMN 0xF218
    An Application sends a GRIDM_ADDCOLUMN message to add a new column to the control.
  • #define GRIDM_DELCOLUMN 0xF219
    An Application sends a GRIDM_DELCOLUMN message to delete a column frow the control.
  • #define GRIDM_GETROWCOUNT 0xF21A
    Gets the number of all rows in the grid control.
  • #define GRIDM_GETCOLCOUNT 0xF21B
    Gets the number of all columns in the grid control.
  • #define GRIDM_SETNUMFORMAT 0xF21C
    Sets the number format of a cell in the grid control. the format is just same as format in c printf.
  • #define GRIDM_SETSELECTED 0xF21D
    Sets the selected cell(s) in the grid control.
  • #define GRIDM_GETSELECTED 0xF21E
    Gets the selected cell(s) in the grid control.
  • #define GRIDM_ADDDEPENDENCE 0xF21F
    Adds a dependence relationship of cells to another cells.
  • #define GRIDM_DELDEPENDENCE 0xF220
    Deletes a dependence relationship of cells to another cells.
  • #define GRIDM_ENDCELLEDIT 0xF221
    This message is used inside minigui.
  • #define GRIDN_HEADLDOWN 1
    This notification code informs a application when the left mouse button down on the gridview.header.
  • #define GRIDN_HEADLUP 2
    This notification code informs a application when the left mouse button up on the gridview.header.
  • #define GRIDN_KEYDOWN 3
    This notification code informs a application when that a key has been pressed.
  • #define GRIDN_CELLDBCLK 4
    This notification code informs a application when the current selected cell has be double clicked.
  • #define GRIDN_CELLCLK 5
    This notification code informs a application when the current selected cell has been clicked.
  • #define GRIDN_FOCUSCHANGED 6
    This notification code informs a application when the current selected item has changed.
  • #define GRIDN_CELLTEXTCHANGED 7
    This notification code informs a application when the cell text has changed.

Detailed Description

Author:
Wei Yongming <ymwei@minigui.org>
Date:
2002/01/06

    Copyright (C) 2002-2008 Feynman Software
    Copyright (C) 1998-2002 Wei Yongming

    All rights reserved by Feynman Software.

    This file is part of MiniGUI, a compact cross-platform Graphics
    User Interface (GUI) support system for real-time embedded systems.

Definition in file gridview.h.

Generated on Fri Dec 17 13:49:42 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: iconview.h File Reference

include » ctrl

iconview.h File Reference

Go to the source code of this file.

Data Structures

  • struct _IVITEMINFO

Defines

  • #define CTRL_ICONVIEW ("IconView")
    The class name of iconview control.
  • #define IV_OKAY 0
  • #define IV_ERR (-1)
  • #define IV_ERRSPACE (-2)
  • #define IVFLAG_BITMAP 0x0001
  • #define IVFLAG_ICON 0x0002
  • #define IVS_NOTIFY SVS_NOTIFY
    The notify style of iconview control.
  • #define IVS_UPNOTIFY SVS_UPNOTIFY
    The upnotify style of iconview control.
  • #define IVS_AUTOSORT SVS_AUTOSORT
    The auto sort style of iconview control.
  • #define IVS_LOOP SVS_LOOP
    The loop style of iconview control.
  • #define IVM_ADDITEM 0xF300
    Adds a item to iconview.
  • #define IVM_SETITEMSIZE 0xF436
    Sets the item width and height of an iconview control.
  • #define IVM_RESETCONTENT SVM_RESETCONTENT
  • #define IVM_DELITEM SVM_DELITEM
  • #define IVM_SETITEMDRAW SVM_SETITEMDRAW
  • #define IVM_SETCONTWIDTH SVM_SETCONTWIDTH
  • #define IVM_SETCONTHEIGHT SVM_SETCONTHEIGHT
  • #define IVM_SETITEMOPS SVM_SETITEMOPS
  • #define IVM_GETMARGINS SVM_GETMARGINS
  • #define IVM_SETMARGINS SVM_SETMARGINS
  • #define IVM_GETLEFTMARGIN SVM_GETLEFTMARGIN
  • #define IVM_GETTOPMARGIN SVM_GETTOPMARGIN
  • #define IVM_GETRIGHTMARGIN SVM_GETRIGHTMARGIN
  • #define IVM_GETBOTTOMMARGIN SVM_GETBOTTOMMARGIN
  • #define IVM_GETVISIBLEWIDTH SVM_GETVISIBLEWIDTH
  • #define IVM_GETVISIBLEHEIGHT SVM_GETVISIBLEHEIGHT
  • #define IVM_GETCONTWIDTH SVM_GETCONTWIDTH
  • #define IVM_GETCONTHEIGHT SVM_GETCONTHEIGHT
  • #define IVM_SETCONTRANGE SVM_SETCONTRANGE
  • #define IVM_GETCONTENTX SVM_GETCONTENTX
  • #define IVM_GETCONTENTY SVM_GETCONTENTY
  • #define IVM_SETCONTPOS SVM_SETCONTPOS
  • #define IVM_GETCURSEL SVM_GETCURSEL
  • #define IVM_SELECTITEM SVM_SELECTITEM
  • #define IVM_SHOWITEM SVM_SHOWITEM
  • #define IVM_CHOOSEITEM SVM_CHOOSEITEM
  • #define IVM_SETCURSEL SVM_SETCURSEL
  • #define IVM_SETITEMINIT SVM_SETITEMINIT
  • #define IVM_SETITEMDESTROY SVM_SETITEMDESTROY
  • #define IVM_SETITEMCMP SVM_SETITEMCMP
  • #define IVM_MAKEPOSVISIBLE SVM_MAKEPOSVISIBLE
  • #define IVM_GETHSCROLLVAL SVM_GETHSCROLLVAL
  • #define IVM_GETVSCROLLVAL SVM_GETVSCROLLVAL
  • #define IVM_GETHSCROLLPAGEVAL SVM_GETHSCROLLPAGEVAL
  • #define IVM_GETVSCROLLPAGEVAL SVM_GETVSCROLLPAGEVAL
  • #define IVM_SETSCROLLVAL SVM_SETSCROLLVAL
  • #define IVM_SETSCROLLPAGEVAL SVM_SETSCROLLPAGEVAL
  • #define IVM_SORTITEMS SVM_SORTITEMS
  • #define IVM_GETITEMCOUNT SVM_GETITEMCOUNT
  • #define IVM_GETITEMADDDATA SVM_GETITEMADDDATA
  • #define IVM_SETITEMADDDATA SVM_SETITEMADDDATA
  • #define IVM_REFRESHITEM SVM_REFRESHITEM
  • #define IVM_GETFIRSTVISIBLEITEM SVM_GETFIRSTVISIBLEITEM
  • #define IVN_CLICKED SVN_CLICKED
  • #define IVN_SELCHANGED SVN_SELCHANGED

Typedefs

  • typedef GHANDLE HIVITEM
    Icon view item handle.

Functions

  • MG_EXPORT int iconview_is_item_hilight (HWND hWnd, GHANDLE hivi)
    Uses this to get an iconview item is hilighted or not.
  • MG_EXPORT PBITMAP iconview_get_item_bitmap (GHANDLE hivi)
    Uses this to get bitmap handle from an iconview item.
  • MG_EXPORT const char * iconview_get_item_label (GHANDLE hivi)
    Uses this to get text label from an iconview item.
  • MG_EXPORT DWORD iconview_get_item_adddata (GHANDLE hivi)
    Uses this to get additional data from an iconview item.

Detailed Description

Author:
Wei Yongming <ymwei@minigui.org>
Date:
2002/01/06

    Copyright (C) 2002-2008 Feynman Software
    Copyright (C) 1998-2002 Wei Yongming

    All rights reserved by Feynman Software.

    This file is part of MiniGUI, a compact cross-platform Graphics
    User Interface (GUI) support system for real-time embedded systems.

Definition in file iconview.h.

Generated on Fri Dec 17 13:49:42 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: listbox.h File Reference

include » ctrl

listbox.h File Reference

Go to the source code of this file.

Data Structures

  • struct _LISTBOXITEMINFO

Defines

  • #define CTRL_LISTBOX ("listbox")
    The class name of listbox control.
  • #define LB_OKAY 0
  • #define LB_ERR (-3)
  • #define LB_ERRSPACE (-2)
  • #define CMFLAG_MASK 0x000F
    The mask of check mark and image flag value.
  • #define IMGFLAG_BITMAP 0x0010
    Listbox item style that context of itme is bitmap.
  • #define LBIS_SIGNIFICANT 0x0020
    Listbox item style that item is rendered with WE_FGC_SIGNIFICANT_ITEM and WE_BGC_SIGNIFICANT_ITEM color.
  • #define LBS_NOTIFY 0x0001L
    Notifies the parent window.
  • #define LBS_SORT 0x0002L
    Sorts strings alphabetically.
  • #define LBS_MULTIPLESEL 0x0008L
    Causes the list box to allow the user to select multiple items.
  • #define LBS_CHECKBOX 0x1000L
    Displays a check box in an item.
  • #define LBS_USEICON 0x2000L
    Displays an icon or bitmap in an item.
  • #define LBS_AUTOCHECK 0x4000L
    If the list box has LBS_CHECKBOX style, this style tell the box to auto-switch the check box between checked or un-checked when the user click the check mark box of an item.
  • #define LBS_AUTOCHECKBOX (LBS_CHECKBOX | LBS_AUTOCHECK)
    If the list box has LBS_AUTOCHECKBOX style, this style tell the box use LBS_CHECKBOX and BLS_AUTOCHECK style.
  • #define LBS_SBALWAYS 0x8000L
    The list box with LBS_SBALWAYS style will always show vertical scrollbar.
  • #define LBS_MOUSEFOLLOW 0x0010L
    The list box with LBS_MOUSEFOLLOW style will always change the selected item following mouse.
  • #define LB_ADDSTRING 0xF180
    Appends the specified string.
  • #define LB_INSERTSTRING 0xF181
    Inserts an item to the list box.
  • #define LB_DELETESTRING 0xF182
    Removes an item from the list box.
  • #define LB_SELITEMRANGEEX 0xF183
    reserved.
  • #define LB_RESETCONTENT 0xF184
    Removes the contents of a list box.
  • #define LB_GETSEL 0xF187
    Gets the selected state for an specified item.
  • #define LB_SETSEL 0xF185
    Selects an item in a multiple-selection list box.
  • #define LB_GETCURSEL 0xF188
    Gets the index of the currently selected or highlighted item.
  • #define LB_SETCURSEL 0xF186
    Selects an item.
  • #define LB_GETTEXT 0xF189
    Retrieves the text of an item in list box.
  • #define LB_GETTEXTLEN 0xF18A
    Gets the length of text of item specified in a list box.
  • #define LB_GETCOUNT 0xF18B
    Gets the number of items in the list box.
  • #define LB_SELECTSTRING 0xF18C
    reserved.
  • #define LB_DIR 0xF18D
    reserved.
  • #define LB_GETTOPINDEX 0xF18E
    Gets the index to the first visible item in the list box.
  • #define LB_FINDSTRING 0xF18F
    Searchs a specified string.
  • #define LB_GETSELCOUNT 0xF190
    Gets the number of selected items in a multiple-selection list box.
  • #define LB_GETSELITEMS 0xF191
    Gets the numbers of selected items.
  • #define LB_GETHORIZONTALEXTENT 0xF193
    reserved.
  • #define LB_SETHORIZONTALEXTENT 0xF194
    reserved.
  • #define LB_SETCOLUMNWIDTH 0xF195
    reserved.
  • #define LB_ADDFILE 0xF196
    reserved.
  • #define LB_SETTOPINDEX 0xF197
    Ensures that a particular item in it is visible.
  • #define LB_GETITEMRECT 0xF198
    Retrieves the dimensions of the rectangle.
  • #define LB_GETITEMDATA 0xF199
    Gets item data in a list box if the box has LBS_CHECKBOX and/or LBS_USEICON styles.
  • #define LB_SETITEMDATA 0xF19A
    Sets item data in a list box if the box has LBS_CHECKBOX and/or LBS_USEICON styles.
  • #define LB_SETCARETINDEX 0xF19E
    Sets the focus rectangle to the item at the specified index.
  • #define LB_GETCARETINDEX 0xF19F
    Determines the index of the item that has the focus rectangle.
  • #define LB_SETITEMHEIGHT 0xF1A0
    Sets the height of all items.
  • #define LB_GETITEMHEIGHT 0xF1A1
    Gets the height in pixels of an item specified in the wParam parameter.
  • #define LB_FINDSTRINGEXACT 0xF1A2
    Searchs for an item that exactly matches the characters specified.
  • #define LB_SETLOCALE 0xF1A5
    reserved.
  • #define LB_GETLOCALE 0xF1A6
    reserved.
  • #define LB_SETCOUNT 0xF1A7
    reserved.
  • #define LB_INITSTORAGE 0xF1A8
    reserved.
  • #define LB_ITEMFROMPOINT 0xF1A9
    reserved.
  • #define LB_SETTEXT 0xF1AA
    Sets text of the specified item.
  • #define LB_GETCHECKMARK 0xF1AB
    Gets check mark status of an item.
  • #define LB_SETCHECKMARK 0xF1AC
    Sets check mark status of an item.
  • #define LB_GETITEMADDDATA 0xF1AD
    Gets the 32-bit data value associated with an item.
  • #define LB_SETITEMADDDATA 0xF1AE
    Associates a 32-bit data value with an item.
  • #define LB_SETSTRCMPFUNC 0xF1AF
    Sets the STRCMP function used to sort items.
  • #define LB_SETITEMDISABLE 0xF1B0
    Sets the item disable.
  • #define LB_GETITEMDISABLE 0xF1B1
    Get the item disable status.
  • #define LB_SETITEMBOLD 0xF1B2
    Sets the item display use bold font.
  • #define LB_MULTIADDITEM 0xF1B3
    Appends the multi strings.
  • #define LBN_ERRSPACE 255
    Indicates that memory is not enough.
  • #define LBN_SELCHANGE 1
    Indicates change due to mouse or keyboard user input.
  • #define LBN_DBLCLK 2
    Indicates double click on an item.
  • #define LBN_SELCANCEL 3
    Indicates cancel of the selection in the list box.
  • #define LBN_SETFOCUS 4
    Indicates gain of input focus.
  • #define LBN_KILLFOCUS 5
    Indicates loss of input focus.
  • #define LBN_CLICKCHECKMARK 6
    Indicates click on the check mark.
  • #define LBN_CLICKED 7
    Indicates click on the string.
  • #define LBN_ENTER 8
    Indicates the user has pressed the ENTER key.

Typedefs

  • typedef LISTBOXITEMINFO * PLISTBOXITEMINFO
    Data type of the pointer to a LISTBOXITEMINFO.

Detailed Description

Author:
Wei Yongming <ymwei@minigui.org>
Date:
2001/12/29

    Copyright (C) 2002-2008 Feynman Software.
    Copyright (C) 1998-2002 Wei Yongming.

    All rights reserved by Feynman Software.

    This file is part of MiniGUI, a compact cross-platform Graphics
    User Interface (GUI) support system for real-time embedded systems.

Definition in file listbox.h.

Generated on Fri Dec 17 13:49:42 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: listview.h File Reference

include » ctrl

listview.h File Reference

Go to the source code of this file.

Data Structures

  • struct _LVITEM
  • struct _LVSUBITEM
  • struct _LVSORTDATA
  • struct _LVCUSTOMDRAWFUNCS
  • struct _LVCOLUMN
  • struct _LVFINDINFO
  • struct _LVNM_NORMAL

Defines

  • #define CTRL_LISTVIEW ("ListView")
    The class name of listview control.
  • #define LV_OKAY 0
  • #define LV_ERR (-1)
  • #define LV_ERRSPACE (-2)
  • #define LVIF_FOLD 0x0001L
    listview item flags, is used inside minigui.
  • #define LVFLAG_BITMAP 0x0001
  • #define LVFLAG_ICON 0x0002
  • #define LVCF_LEFTALIGN 0x0000
  • #define LVCF_RIGHTALIGN 0x0001
  • #define LVCF_CENTERALIGN 0x0002
  • #define LVCF_TREEVIEW 0x0004
  • #define LVHF_LEFTALIGN 0x0000
  • #define LVHF_RIGHTALIGN 0x0004
  • #define LVHF_CENTERALIGN 0x0008
  • #define LVFF_TEXT 0x0001
  • #define LVFF_ADDDATA 0x0002
  • #define LVS_UPNOTIFY 0x0001L
    Notifies the parent window when mouse is up (default is down).
  • #define LVS_SORT 0x0002L
    Sorts strings automatically.
  • #define LVS_MULTIPLESEL 0x0008L
    Causes the listview to allow the user to select multiple items.
  • #define LVS_CHECKBOX 0x1000L
    Displays a check box in an item.
  • #define LVS_AUTOCHECK 0x2000L
    If the list view has LVS_CHECKBOX style, this style tell the list view to auto-switch the check box between checked or un-checked when the user click the check mark box of an item.
  • #define LVS_AUTOCHECKBOX (LVS_CHECKBOX | LVS_AUTOCHECK)
    If the list view has LVS_AUTOCHECKBOX style, this style tell the list view use LVS_CHECKBOX and LVS_AUTOCHECK style.
  • #define LVS_TREEVIEW 0x4000L
    Uses listview in a treeview style.
  • #define LVM_ADDITEM 0xF110
    Adds a item to listview, this item is also called a row.
  • #define LVM_FILLSUBITEM 0xF111
    Sets the content of a subitem, indentified by rows and columns.
  • #define LVM_ADDCOLUMN 0xF112
    Adds a new column to listview, identified by column.
  • #define LVM_DELITEM 0xF113
    Deletes an item form listview.
  • #define LVM_CLEARSUBITEM 0xF114
    Clears the content of a subitem.
  • #define LVM_DELCOLUMN 0xF115
    Deletes a column from listview, all subitem in this column will be removed.
  • #define LVM_COLSORT 0xF116
    Sorts all subitems according to a certain column.
  • #define LVM_SETSUBITEMCOLOR 0xF117
    Sets the text color of a subitem.
  • #define LVM_FINDITEM 0xF118
    Searchs a item.
  • #define LVM_GETSUBITEMTEXT 0xF119
    Retrieves the text of a listview subitem.
  • #define LVM_GETITEMCOUNT 0xF11A
    Gets the number of all the items(rows) in a listview.
  • #define LVM_GETCOLUMNCOUNT 0xF11B
    Gets the number of all the columns in listview.
  • #define LVM_GETSELECTEDITEM 0xF11C
    Gets the current selected item.
  • #define LVM_DELALLITEM 0xF11D
    Removes all the items in listview.
  • #define LVM_MODIFYHEAD 0xF11E
    Changes the title of a column.
  • #define LVM_SELECTITEM 0xF11F
    Selects an item.
  • #define LVM_SHOWITEM 0xF120
    Makes the item is entirely visible in the list view.
  • #define LVM_GETSUBITEMLEN 0xF121
    Gets the text length of the subitem.
  • #define LVM_SETCOLUMN 0xF122
    Sets the attributes of a list view column.
  • #define LVM_SETSUBITEMTEXT 0xF123
    Sets the text of a subitem.
  • #define LVM_SETSUBITEM 0xF124
    Sets the attributes of a subitem.
  • #define LVM_GETCOLUMN 0xF125
    Retrieves the information about a listview column.
  • #define LVM_GETCOLUMNWIDTH 0xF126
    Retrieves the width of a listview column.
  • #define LVM_GETITEM 0xF127
    Retrieves the item's attributes.
  • #define LVM_GETITEMSTATE 0xF128
    Retrieves the state of a listview item.
  • #define LVM_GETSELECTEDCOLUMN 0xF129
    Retrieves the index of the currently selected column of a listview.
  • #define LVM_GETSELECTEDCOUNT 0xF130
    Retrieves the number of the selected items in a listview.
  • #define LVM_GETTOPVISIBLE 0xF131
    Retrieves the index of the topmost visible item in a listview.
  • #define LVM_NULL 0xF132
    reserved.
  • #define LVM_SETITEMSTATE 0xF133
    reserved.
  • #define LVM_SORTITEMS 0xF134
    Uses an application-defined comparision function to sort the items.
  • #define LVM_SETITEMHEIGHT 0xF135
    Changes the height of a item.
  • #define LVM_SETHEADHEIGHT 0xF136
    Changes the height of the header.
  • #define LVM_GETITEMADDDATA 0xF137
    Gets the 32-bit data value associated with an item.
  • #define LVM_SETITEMADDDATA 0xF138
    Associates a 32-bit data value with an item.
  • #define LVM_CHOOSEITEM 0xF139
    Selects and shows an item.
  • #define LVM_SETSTRCMPFUNC 0xF140
    Sets the STRCMP function used to sort items.
  • #define LVM_GETRELATEDITEM 0xF141
    Retrives related item of specific item.
  • #define LVM_FOLDITEM 0xF142
    Folds or unfolds an item.
  • #define LVM_SETCUSTOMDRAW 0xF143
    Sets the customized drawing functions of listview.
  • #define LVM_GETSELECTEDITEMRECT 0xF144
    Get the selected item's Rectangle.
  • #define LVN_CLICKED 1
    This notification code informs parent window the mouse clicked.
  • #define LVN_SELCHANGE 2
    This notification code informs parent window the current selected item has changed.
  • #define LVN_ITEMRDOWN 4
    This notification code informs parent window the right mouse button down on a listview item.
  • #define LVN_ITEMRUP 5
    This notification code informs parent window the right mouse button up on a listview item.
  • #define LVN_HEADRDOWN 6
    This notification code informs parent window the right mouse button down on the listview header.
  • #define LVN_HEADRUP 7
    This notification code informs parent window the right mouse button up on the listview header.
  • #define LVN_KEYDOWN 8
    This notification code informs parent window that a key has been pressed.
  • #define LVN_ITEMDBCLK 9
    This notification code informs parent window the current selected item has be double clicked.
  • #define LVN_ITEMCLK 10
    This notification code informs parent window the current selected item has been clicked.
  • #define LVN_COLCHANGE 11
    This notification code informs parent window the current selected column has changed.
  • #define LVN_FOLDED 12
    This notification code informs that user folds an item by mouse clicking.
  • #define LVN_UNFOLDED 13
    This notification code informs that user unfolds an item by mouse clicking.

Typedefs

  • typedef GHANDLE HLVITEM
    List view item handle.
  • typedef LVITEM * PLVITEM
  • typedef LVSUBITEM * PLVSUBITEM
  • typedef LVSORTDATA * PLVSORTDATA
  • typedef int(* PFNLVCOMPARE )(HLVITEM nItem1, HLVITEM nItem2, PLVSORTDATA sortData)
  • typedef void(* PFN_LVHDR_BKDRAWFUNC )(HWND hWnd, HLVHDR hlvhdr, HDC hdc, RECT *rcDraw)
  • typedef void(* PFN_LVHDR_ITEMDRAWFUNC )(HWND hWnd, int idx, HDC hdc, RECT *rcDraw)
  • typedef LVCOLUMN * PLVCOLUMN
  • typedef LVFINDINFO * PLVFINDINFO
  • typedef LVNM_NORMAL * PLVNM_NORMAL
  • typedef LVNM_NORMAL LVNM_KEYDOWN
  • typedef LVNM_KEYDOWN * PLVNM_KEYDOWN
  • typedef LVNM_NORMAL LVNM_HEADRDOWN
  • typedef LVNM_HEADRDOWN * PLVNM_HEADRDOWN
  • typedef LVNM_NORMAL LVNM_HEADRUP
  • typedef LVNM_HEADRUP * PLVNM_HEADUP
  • typedef LVNM_NORMAL LVNM_ITEMRDOWN
  • typedef LVNM_ITEMRDOWN * PLVNM_ITEMRDOWN
  • typedef LVNM_NORMAL LVNM_ITEMRUP
  • typedef LVNM_ITEMRUP * PLVNM_ITEMRUP

Detailed Description

Author:
Wei Yongming <ymwei@minigui.org>
Date:
2002/01/06

    Copyright (C) 2002-2008 Feynman Software
    Copyright (C) 1998-2002 Wei Yongming

    All rights reserved by Feynman Software.

    This file is part of MiniGUI, a compact cross-platform Graphics
    User Interface (GUI) support system for real-time embedded systems.

Definition in file listview.h.

Generated on Fri Dec 17 13:49:43 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: menubutton.h File Reference

include » ctrl

menubutton.h File Reference

Go to the source code of this file.

Data Structures

  • struct _MENUBUTTONITEM

Defines

  • #define CTRL_MENUBTN ("menubutton")
    The class name of menubutton control.
  • #define CTRL_MENUBUTTON ("menubutton")
    The class name of menubutton control.
  • #define MB_OKAY 0
  • #define MB_ERR -1
  • #define MB_INV_ITEM -2
  • #define MB_ERR_SPACE -3
  • #define MB_WHICH_TEXT 0x01
  • #define MB_WHICH_BMP 0x02
  • #define MB_WHICH_ATTDATA 0x04
  • #define MBS_SORT 0x0001
    If this bit is set, the items listed in the control are displayed in a specified order.
  • #define MBS_LEFTARROW 0x0002
    The menu pull-down arrow will be display at the left of the text.
  • #define MBS_NOBUTTON 0x0004
    The control have not push button.
  • #define MBS_ALIGNLEFT 0x0000
    The text on menubutton is left-align (default).
  • #define MBS_ALIGNRIGHT 0x0010
    The text on menubutton is right-align.
  • #define MBS_ALIGNCENTER 0x0020
    The text on menubutton is center-align.
  • #define MBS_ALIGNMASK 0x00F0
    The align mask of menubutton.
  • #define MBM_ADDITEM 0xF200
    Sends to the control to add an item to the menu list.
  • #define MBM_DELITEM 0xF201
    Sends to the control to delete an item in the menu list.
  • #define MBM_RESETCTRL 0xF202
    Sends to the control to remove all items in the menu list.
  • #define MBM_SETITEMDATA 0xF203
    Sends to the control to set the data of a specific item.
  • #define MBM_GETITEMDATA 0xF204
    Sends to the control to retrive the data of a specific item.
  • #define MBM_GETCURITEM 0xF206
    Sends to get the index of the current selected item.
  • #define MBM_SETCURITEM 0xF207
    Sends to set the current selected item based on index.
  • #define MBM_SETSTRCMPFUNC 0xF208
    Sets the STRCMP function used to sort items.
  • #define MBN_ERRSPACE 255
    Sends when memory space error occures.
  • #define MBN_CHANGED 1
    Sends when selected item changes.
  • #define MBN_SELECTED 2
    Sends when an item is selected.
  • #define MBN_STARTMENU 4
    Sends when starting tracking popup menu.
  • #define MBN_ENDMENU 5
    Sends when ending tracking popup menu.
  • #define MBN_CLICKED 6
    Sends when the user clicked the menubutton but not active the menu.

Typedefs

  • typedef MENUBUTTONITEM * PMENUBUTTONITEM
    Data type of the pointer to a MENUBUTTONITEM.

Detailed Description

Author:
Wei Yongming <ymwei@minigui.org>
Date:
2001/12/29

    Copyright (C) 2002-2008 Feynman Software.
    Copyright (C) 1998-2002 Wei Yongming.

    All rights reserved by Feynman Software.

    This file is part of MiniGUI, a compact cross-platform Graphics
    User Interface (GUI) support system for real-time embedded systems.

Definition in file menubutton.h.

Generated on Fri Dec 17 13:49:43 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: minigui.h File Reference

include

minigui.h File Reference

Go to the source code of this file.

Data Structures

  • struct _DESKTOPOPS
  • struct _ETCSECTION
  • struct _ETC_S

Defines

  • #define g_rcDesktop g_rcScr
    Contains the rectangle of desktop of the application.
  • #define MAX_NR_LISTEN_FD 5
    The max number of listen fd which user can use.
  • #define ReinitDesktop() ReinitDesktopEx (TRUE)
    Re-initializes the desktop including the local system text.
  • #define MiniGUIMain
    The main entry of a MiniGUI application.
  • #define IDM_DTI_FIRST (300)
    The minimum interger value of command ID when user customize desktop menu.
  • #define ETC_MAXLINE 1024
    The max line number of etc file.
  • #define ETC_FILENOTFOUND -1
    No found etc file.
  • #define ETC_SECTIONNOTFOUND -2
    No found section in etc file.
  • #define ETC_KEYNOTFOUND -3
    No found key in etc file.
  • #define ETC_TMPFILEFAILED -4
    Create tmpfile failed.
  • #define ETC_FILEIOFAILED -5
    IO operation failed to etc file.
  • #define ETC_INTCONV -6
    Convert the value string to an integer failed.
  • #define ETC_INVALIDOBJ -7
    Invalid object to etc file.
  • #define ETC_READONLYOBJ -8
    Read only to etc file.
  • #define ETC_OK 0
    Operate success to etc file.
  • #define SetValueToEtc(hEtc, pSection, pKey, pValue) GetValueFromEtc(hEtc, pSection, pKey, pValue, -1)
    Sets the value in the etc object.
  • #define LEN_CLIPBOARD_NAME 15
    The maximum length of the name of clipboard.
  • #define NR_CLIPBOARDS 4
    The maximum number of clipboard.
  • #define CBNAME_TEXT ("text")
    The default clipboard name of text control.
  • #define CBERR_OK 0
    Operate clipboard success.
  • #define CBERR_BADNAME 1
    Bad name to clipboard.
  • #define CBERR_NOMEM 2
    No enough memory to clipboard.
  • #define CBOP_NORMAL 0
    Overwrite operation to clipboard.
  • #define CBOP_APPEND 1
    Append the new data to clipboarda after the old data.
  • #define Beep Ping
    Alias of Ping.
  • #define IDC_ARROW 0
  • #define IDC_IBEAM 1
  • #define IDC_PENCIL 2
  • #define IDC_CROSS 3
  • #define IDC_MOVE 4
  • #define IDC_SIZENWSE 5
  • #define IDC_SIZENESW 6
  • #define IDC_SIZEWE 7
  • #define IDC_SIZENS 8
  • #define IDC_UPARROW 9
  • #define IDC_NONE 10
  • #define IDC_HELP 11
  • #define IDC_BUSY 12
  • #define IDC_WAIT 13
  • #define IDC_RARROW 14
  • #define IDC_COLOMN 15
  • #define IDC_ROW 16
  • #define IDC_DRAG 17
  • #define IDC_NODROP 18
  • #define IDC_HAND_POINT 19
  • #define IDC_HAND_SELECT 20
  • #define IDC_SPLIT_HORZ 21
  • #define IDC_SPLIT_VERT 22
  • #define SetCursor(hcsr) SetCursorEx (hcsr, FALSE)
    Changes the current cursor.
  • #define SetDefaultCursor(hcsr) SetCursorEx (hcsr, TRUE)
    Changes the current cursor, and set it as the default cursor.
  • #define IDS_MGST_WINDOW 0
    The identifier of the window system text.
  • #define IDS_MGST_START 1
    The identifier of the start system text.
  • #define IDS_MGST_REFRESH 2
    The identifier of the refresh background system text.
  • #define IDS_MGST_CLOSEALLWIN 3
    The identifier of the close all windows system text.
  • #define IDS_MGST_ENDSESSION 4
    The identifier of the end session system text.
  • #define IDS_MGST_OPERATIONS 5
    The identifier of the operations system text.
  • #define IDS_MGST_MINIMIZE 6
    The identifier of the minimize system text.
  • #define IDS_MGST_MAXIMIZE 7
    The identifier of the maximize system text.
  • #define IDS_MGST_RESTORE 8
    The identifier of the restore system text.
  • #define IDS_MGST_CLOSE 9
    The identifier of the close system text.
  • #define IDS_MGST_OK 10
    The identifier of the ok system text.
  • #define IDS_MGST_NEXT 11
    The identifier of the next system text.
  • #define IDS_MGST_CANCEL 12
    The identifier of the cancel system text.
  • #define IDS_MGST_PREV 13
    The identifier of the previous system text.
  • #define IDS_MGST_YES 14
    The identifier of the yes system text.
  • #define IDS_MGST_NO 15
    The identifier of the no system text.
  • #define IDS_MGST_ABORT 16
    The identifier of the abort system text.
  • #define IDS_MGST_RETRY 17
    The identifier of the retry system text.
  • #define IDS_MGST_IGNORE 18
    The identifier of the ignore system text.
  • #define IDS_MGST_ABOUTMG 19
    The identifier of the about minigui system text.
  • #define IDS_MGST_OPENFILE 20
    The identifier of the open file system text.
  • #define IDS_MGST_SAVEFILE 21
    The identifier of the save file system text.
  • #define IDS_MGST_COLORSEL 22
    The identifier of the color selection system text.
  • #define IDS_MGST_SWITCHLAYER 23
    The identifier of the switch layer system text.
  • #define IDS_MGST_DELLAYER 24
    The identifier of the delete layer system text.
  • #define IDS_MGST_ERROR 25
    The identifier of the error system text.
  • #define IDS_MGST_LOGO 26
    The identifier of the logo system text.
  • #define IDS_MGST_CURRPATH 27
    The identifier of the current path system text.
  • #define IDS_MGST_FILE 28
    The identifier of the file system text.
  • #define IDS_MGST_LOCATION 29
    The identifier of the location system text.
  • #define IDS_MGST_UP 30
    The identifier of the up system text.
  • #define IDS_MGST_NAME 31
    The identifier of the name system text.
  • #define IDS_MGST_SIZE 32
    The identifier of the size system text.
  • #define IDS_MGST_ACCESSMODE 33
    The identifier of the access mode system text.
  • #define IDS_MGST_LASTMODTIME 34
    The identifier of the last modify time system text.
  • #define IDS_MGST_OPEN 35
    The identifier of the open system text.
  • #define IDS_MGST_FILENAME 36
    The identifier of the file name system text.
  • #define IDS_MGST_FILETYPE 37
    The identifier of the file type system text.
  • #define IDS_MGST_SHOWHIDEFILE 38
    The identifier of the show hide file system text.
  • #define IDS_MGST_NOTFOUND 39
    The identifier of the not found file system text.
  • #define IDS_MGST_NR 40
    The identifier of the can't read system text.
  • #define IDS_MGST_NW 41
    The identifier of the can't write system text.
  • #define IDS_MGST_INFO 42
    The identifier of the information system text.
  • #define IDS_MGST_R 43
    The identifier of the read system text.
  • #define IDS_MGST_W 44
    The identifier of the write system text.
  • #define IDS_MGST_WR 45
    The identifier of the read and write system text.
  • #define IDS_MGST_SAVE 46
    The identifier of the save system text.
  • #define IDS_MGST_FILEEXIST 47
    The identifier of the file exist system text.

Typedefs

  • typedef ETCSECTION * PETCSECTION

Functions

  • MG_EXPORT int GUIAPI InitGUI (int, const char **)
    Initialize MiniGUI.
  • MG_EXPORT void GUIAPI TerminateGUI (int not_used)
    Terminate MiniGUI.
  • MG_EXPORT void GUIAPI MiniGUIPanic (int exitcode)
    The panic of MiniGUI application.
  • MG_EXPORT BOOL GUIAPI RegisterListenFD (int fd, int type, HWND hwnd, void *context)
    Registers a listening file descriptor to MiniGUI-Lite.
  • MG_EXPORT BOOL GUIAPI UnregisterListenFD (int fd)
    Unregisters a being listened file descriptor.
  • MG_EXPORT BOOL GUIAPI ReinitDesktopEx (BOOL init_sys_text)
    Re-initializes the desktop.
  • MG_EXPORT void GUIAPI ExitGUISafely (int exitcode)
    Exits your MiniGUI application safely.
  • MG_EXPORT DESKTOPOPS *GUIAPI SetCustomDesktopOperationSet (DESKTOPOPS *usr_dsk_ops)
    Set customer desktop operation set.
  • MG_EXPORT void GUIAPI DesktopUpdateAllWindow (void)
    Update all visible windows on the desktop.
  • MG_EXPORT BOOL GUIAPI SetMouseCalibrationParameters (const POINT *src_pts, const POINT *dst_pts)
    Sets the parameters for doing mouse calibration.
  • MG_EXPORT void GUIAPI GetOriginalMousePosition (int *x, int *y)
    Gets the original mouse position.
  • MG_EXPORT HWND GUIAPI OpenAboutDialog (HWND hHosting)
    Opens or actives the 'About MiniGUI' dialog.
  • MG_EXPORT int GUIAPI GetValueFromEtcFile (const char *pEtcFile, const char *pSection, const char *pKey, char *pValue, int iLen)
    Gets value from a configuration file.
  • MG_EXPORT int GUIAPI GetIntValueFromEtcFile (const char *pEtcFile, const char *pSection, const char *pKey, int *value)
    Gets integer value from a configuration file.
  • MG_EXPORT int GUIAPI SetValueToEtcFile (const char *pEtcFile, const char *pSection, const char *pKey, char *pValue)
    Sets a value in a configuration file.
  • MG_EXPORT int GUIAPI RemoveSectionInEtcFile (const char *pEtcFile, const char *pSection)
    Removes a section in an etc file.
  • MG_EXPORT int GUIAPI SaveSectionToEtcFile (const char *pEtcFile, PETCSECTION psect)
    Saves a section to an etc file.
  • MG_EXPORT GHANDLE GUIAPI LoadEtcFile (const char *pEtcFile)
    Loads an etc file into memory.
  • MG_EXPORT int GUIAPI SaveEtcToFile (GHANDLE hEtc, const char *file_name)
    Saves an ETC object into a file.
  • MG_EXPORT int GUIAPI UnloadEtcFile (GHANDLE hEtc)
    Unloads an etc file.
  • MG_EXPORT int GUIAPI GetValueFromEtc (GHANDLE hEtc, const char *pSection, const char *pKey, char *pValue, int iLen)
    Gets value from a configuration etc object.
  • MG_EXPORT int GUIAPI GetIntValueFromEtc (GHANDLE hEtc, const char *pSection, const char *pKey, int *pValue)
    Gets the integer value from a configuration etc object.
  • MG_EXPORT GHANDLE GUIAPI FindSectionInEtc (GHANDLE hEtc, const char *pSection, BOOL bCreateNew)
    Finds/Creates a section from an etc object.
  • MG_EXPORT int GUIAPI GetValueFromEtcSec (GHANDLE hSect, const char *pKey, char *pValue, int iLen)
    Gets value from an etc section object.
  • MG_EXPORT int GUIAPI GetIntValueFromEtcSec (GHANDLE hSect, const char *pKey, int *pValue)
    Gets an integer value from an etc section object.
  • MG_EXPORT int GUIAPI SetValueToEtcSec (GHANDLE hSect, const char *pKey, char *pValue)
    Sets the value in the etc section object.
  • MG_EXPORT int GUIAPI RemoveSectionInEtc (GHANDLE hEtc, const char *pSection)
    Removes a section in etc object.
  • static int GetMgEtcValue (const char *pSection, const char *pKey, char *pValue, int iLen)
    Gets value from MiniGUI configuration etc object.
  • static int GetMgEtcIntValue (const char *pSection, const char *pKey, int *value)
    Gets integer value from MiniGUI configuration etc object.
  • MG_EXPORT int GUIAPI CreateClipBoard (const char *cb_name, size_t size)
    Creates a new clipboard.
  • MG_EXPORT int GUIAPI DestroyClipBoard (const char *cb_name)
    Destroys a new clipboard.
  • MG_EXPORT int GUIAPI SetClipBoardData (const char *cb_name, void *data, size_t n, int cbop)
    Sets the data of a clipboard.
  • MG_EXPORT size_t GUIAPI GetClipBoardDataLen (const char *cb_name)
    Gets the length of the data of a clipboard.
  • MG_EXPORT size_t GUIAPI GetClipBoardData (const char *cb_name, void *data, size_t n)
    Gets the data of a clipboard.
  • MG_EXPORT int GUIAPI GetClipBoardByte (const char *cb_name, int index, unsigned char *byte)
    Gets a byte from a clipboard.
  • MG_EXPORT void GUIAPI Ping (void)
    Makes a beep sound.
  • MG_EXPORT void GUIAPI Tone (int frequency_hz, int duration_ms)
    Makes a tone.
  • MG_EXPORT void *GUIAPI GetOriginalTermIO (void)
    Gets termios structure of the original terminal before initializing MiniGUI.
  • MG_EXPORT char *GUIAPI FixStrAlloc (int len)
    Allocates a buffer for a length-fixed string.
  • MG_EXPORT char *GUIAPI FixStrDup (const char *str)
    Duplicates a length-fixed string.
  • MG_EXPORT void GUIAPI FreeFixStr (char *str)
    Frees a length-fixed string.
  • MG_EXPORT HCURSOR GUIAPI LoadCursorFromFile (const char *filename)
    Loads a cursor from a M$ Windows cursor file.
  • MG_EXPORT HCURSOR GUIAPI LoadCursorFromMem (const void *area)
    Loads a cursor from a memory area.
  • MG_EXPORT HCURSOR GUIAPI CreateCursor (int xhotspot, int yhotspot, int w, int h, const BYTE *pANDBits, const BYTE *pXORBits, int colornum)
    Creates a cursor from memory data.
  • MG_EXPORT BOOL GUIAPI DestroyCursor (HCURSOR hcsr)
    Destroys a cursor object.
  • MG_EXPORT HCURSOR GUIAPI GetSystemCursor (int csrid)
    Gets the handle to a system cursor by its identifier.
  • MG_EXPORT HCURSOR GUIAPI GetCurrentCursor (void)
    Gets the handle to the current cursor.
  • MG_EXPORT void GUIAPI ClipCursor (const RECT *prc)
    Clips the cursor range.
  • MG_EXPORT void GUIAPI GetClipCursor (RECT *prc)
    Gets the current cursor clipping rectangle.
  • MG_EXPORT void GUIAPI GetCursorPos (POINT *ppt)
    Gets position of the current cursor.
  • MG_EXPORT void GUIAPI SetCursorPos (int x, int y)
    Sets position of the current cursor.
  • MG_EXPORT HCURSOR GUIAPI SetCursorEx (HCURSOR hcsr, BOOL set_def)
    Changes the current cursor.
  • MG_EXPORT HCURSOR GUIAPI GetDefaultCursor (void)
    Gets the default cursor.
  • MG_EXPORT int GUIAPI ShowCursor (BOOL fShow)
    Shows or hides cursor.
  • MG_EXPORT BOOL GUIAPI GetKeyStatus (UINT uKey)
    Gets a key or a mouse button status.
  • MG_EXPORT DWORD GUIAPI GetShiftKeyStatus (void)
    Gets status of the shift keys.
  • MG_EXPORT const char *GUIAPI GetSysText (unsigned int id)
    Translates system text to localized text.
  • MG_EXPORT const char **GUIAPI GetSysTextInUTF8 (const char *language)
    Gets the localized system text array in UTF-8 for a specified language.
  • MG_EXPORT char * strnchr (const char *s, size_t n, int c)
    Locates character in the first n characters of string s.
  • MG_EXPORT int substrlen (const char *text, int len, int delimiter, int *nr_delim)
    Locates a substring delimited by one or more delimiters in the first len characters of string text.
  • MG_EXPORT char * strtrimall (char *src)
    Deletes all space characters.

Variables

  • MG_EXPORT RECT g_rcScr
    Contains the rectangle of the whole screen.
  • MG_EXPORT char ETCFILEPATH []
    The path name of MiniGUI configuration file.
  • MG_EXPORT const char * SysText []
    Contains all text used by MiniGUI in English.
  • MG_EXPORT const char ** local_SysText
    The pointer to the current localized system text array.

Detailed Description

Author:
Wei Yongming <ymwei@minigui.org>
Date:
2002/01/06
This file includes global and miscellaneous interfaces of MiniGUI.

    Copyright (C) 2002-2009 Feynman Software.
    Copyright (C) 1998-2002 Wei Yongming.

    All rights reserved by Feynman Software.

    This file is part of MiniGUI, a compact cross-platform Graphics
    User Interface (GUI) support system for real-time embedded systems.

Definition in file minigui.h.

Function Documentation

int GUIAPI InitGUI | ( | int | ,
 |  | const char ** |
 | ) |  |

Initialize MiniGUI.

The meaning of two parameters is same with parameters of main function.

void GUIAPI MiniGUIPanic ( int exitcode )

The panic of MiniGUI application.

The function forces to close GAL and IAL engine.

Parameters:
exitcode The value of exitcode, now it can be any values.

void GUIAPI TerminateGUI ( int not_used )

Terminate MiniGUI.

Parameters:
not_used not used

Generated on Fri Dec 17 13:49:43 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: monthcal.h File Reference

include » ctrl

monthcal.h File Reference

Go to the source code of this file.

Data Structures

  • struct _SYSTEMTIME
  • struct _MCCOLORINFO

Defines

  • #define CTRL_MONTHCALENDAR ("MonthCalendar")
    The class name of monthcalendar control.
  • #define MCS_CHN 0x0001L
    Displays chinese label.
  • #define MCS_ENG_L 0x0002L
    Displays long english label.
  • #define MCS_ENG_S 0x0003L
    Displays short english label.
  • #define MCS_NOTIFY 0x0004L
    Notifies the parent window when something happens.
  • #define MCS_NOYEARMON 0x0008L
    Do not show year and month.
  • #define MCM_GETCURDAY 0xF300
    Gets the day number of the current selected date.
  • #define MCM_GETCURMONTH 0xF301
    Gets the month number of the current selected date.
  • #define MCM_GETCURYEAR 0xF302
    Gets the year number of the current selected date.
  • #define MCM_GETCURWEEKDAY 0xF303
    Gets the weekday number of the current selected date.
  • #define MCM_GETCURMONLEN 0xF304
    Gets the month length of the current selected date.
  • #define MCM_SETCURDAY 0xF305
    Changes the day of the currently selected date.
  • #define MCM_SETCURMONTH 0xF306
    Changes the month of the currently selected date.
  • #define MCM_SETCURYEAR 0xF307
    Changes the year of the currently selected date.
  • #define MCM_SETTODAY 0xF308
    Sets the currently selected date as the date of "today".
  • #define MCM_GETFIRSTWEEKDAY 0xF309
    Gets the weekday of the first day of this month.
  • #define MCM_GETCURDATE 0xF310
    Gets the currently selected date.
  • #define MCM_GETTODAY 0xF311
    Gets the date of "today".
  • #define MCM_GETMINREQRECTW 0xF312
    Gets the minimum width required to display a full month in a month calendar control.
  • #define MCM_GETMINREQRECTH 0xF313
    Gets the minimum height required to display a full month in a month calendar control.
  • #define MCM_SETCURDATE 0xF314
    Sets the currently selected date.
  • #define MCM_SETCOLOR 0xF315
    Sets the color of the monthcalendar control.
  • #define MCM_GETCOLOR 0xF316
    Gets the color of the monthcalendar control.
  • #define MCM_SETDAYCOLOR 0xF317
    Sets the color of a specified date .
  • #define MCM_CLEARDAYCOLOR 0xF318
    Clears the color of a specified month view .
  • #define MCN_DATECHANGE 1
    Notifies that the currently selected date is changed.

Typedefs

  • typedef SYSTEMTIME * PSYSTEMTIME
    Data type of the pointer to a SYSTEMTIME.
  • typedef MCCOLORINFO * PMCCOLORINFO
    Data type of the pointer to a MCCOLORINFO.

Detailed Description

Author:
Wei Yongming <ymwei@minigui.org>
Date:
2002/01/06

    Copyright (C) 2002-2008 Feynman Software
    Copyright (C) 1998-2002 Wei Yongming

    All rights reserved by Feynman Software.

    This file is part of MiniGUI, a compact cross-platform Graphics
    User Interface (GUI) support system for real-time embedded systems.

Definition in file monthcal.h.

Generated on Fri Dec 17 13:49:43 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: newtoolbar.h File Reference

include » ctrl

newtoolbar.h File Reference

Go to the source code of this file.

Data Structures

  • struct _NTBINFO
  • struct _NTBITEMINFO

Defines

  • #define CTRL_NEWTOOLBAR ("newtoolbar")
    The class name of newtoolbar control.
  • #define NTBIF_DISABLED 0x0010
    The item is disabled.
  • #define NTBIF_CHECKED 0x0020
    The item is checked.
  • #define NTBS_WITHTEXT 0x000000001L
    Displays text with the item bitmap.
  • #define NTBS_TEXTRIGHT 0x000000002L
    Displays text at the right side of the item bitmap.
  • #define NTBS_DRAWSTATES 0x000000004L
    Draws the button states with 3D frame, and does not use the highlight, pushed and disabled bitmap cell.
  • #define NTBS_DRAWSEPARATOR 0x000000008L
    Draws the separator bar.
  • #define NTBS_HORIZONTAL 0x00000000L
    The NewToolbar will be displayed horizontally.
  • #define NTBS_VERTICAL 0x00000010L
    The NewToolbar will be displayed vertically.
  • #define NTBS_MULTLINE 0x00000020L
    The Newtoolbar item will be displayed in several lines. In this style , your should define the toolbar RECT in CreateWindwEx.
  • #define NTB_OKAY 0
  • #define NTB_ERR (-1)
  • #define NTB_ERR_SPACE (-2)
  • #define NTB_ERR_DUPID (-3)
  • #define NTBM_ADDITEM 0xFE00
    Adds an item to a newtoolbar.
  • #define NTBM_GETITEM 0xFE01
    Retrives the information of an item in a newtoolbar control.
  • #define NTBM_SETITEM 0xFE02
    Sets the information of an item in a newtoolbar control.
  • #define NTBM_ENABLEITEM 0xFE03
    Enables/Disables an item in a newtoolbar control.
  • #define NTBM_SETBITMAP 0xFE04
    Sets the bitmap of a newtoolbar control.

Typedefs

  • typedef void(* HOTSPOTPROC )(HWND hwnd, int id, const RECT *cell, int x, int y)
    Type of the hotspot-clicked callback procedure.
  • typedef NTBITEMINFO * PNTBITEMINFO
    Data type of pointer to a NTBITEMINFO;.

Detailed Description

Author:
Wei Yongming <ymwei@minigui.org>
Date:
2001/12/29

    Copyright (C) 2002-2008 Feynman Software.
    Copyright (C) 1998-2002 Wei Yongming.

    All rights reserved by Feynman Software.

    This file is part of MiniGUI, a compact cross-platform Graphics
    User Interface (GUI) support system for real-time embedded systems.

Definition in file newtoolbar.h.

Generated on Fri Dec 17 13:49:43 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: progressbar.h File Reference

include » ctrl

progressbar.h File Reference

Go to the source code of this file.

Defines

  • #define CTRL_PROGRESSBAR ("progressbar")
    The class name of progressbar control.
  • #define PB_OKAY 0
  • #define PB_ERR -1
  • #define PBS_NOTIFY 0x0001L
    Notifies the parent window.
  • #define PBS_VERTICAL 0x0002L
    Creates progressbar vertically.
  • #define PBM_SETRANGE 0xF0A0
    Sets the limits of the range.
  • #define PBM_SETSTEP 0xF0A1
    Specifies the step increment for a progress bar control.
  • #define PBM_SETPOS 0xF0A2
    Sets the progress bar control's current position.
  • #define PBM_DELTAPOS 0xF0A3
    Advances the progress bar control's current position.
  • #define PBM_STEPIT 0xF0A4
    Advances the current position by the step increment.
  • #define PBN_REACHMAX 1
    Notifies reach of maximum limit.
  • #define PBN_REACHMIN 2
    Notifies reach of minimum limit.

Detailed Description

Author:
Wei Yongming <ymwei@minigui.org>
Date:
2001/12/29

    Copyright (C) 2002-2008 Feynman Software.
    Copyright (C) 1998-2002 Wei Yongming.

    All rights reserved by Feynman Software.

    This file is part of MiniGUI, a compact cross-platform Graphics
    User Interface (GUI) support system for real-time embedded systems.

Definition in file progressbar.h.

Generated on Fri Dec 17 13:49:43 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: propsheet.h File Reference

include » ctrl

propsheet.h File Reference

Go to the source code of this file.

Defines

  • #define CTRL_PROPSHEET ("propsheet")
    The class name of propsheet control.
  • #define PSS_SIMPLE 0x0000L
    A simple property sheet control. All tabs of the control will have the same width.
  • #define PSS_COMPACTTAB 0x0001L
    Compact tab style. The width of a tab is adaptive to the tab title.
  • #define PSS_SCROLLABLE 0x0002L
    Tabs can be scrolled by scroll button.
  • #define PSS_BOTTOM 0x0010L
    Bottom tab style. Tabs will be located at the bottom of the property sheet.
  • #define PS_OKAY 0
  • #define PS_ERR (-1)
  • #define PSM_GETACTIVEPAGE 0xF1C0L
    Gets the handle of current active page.
  • #define PSM_SETACTIVEINDEX 0xF1C2L
    Changes the active page by index.
  • #define PSM_GETPAGE 0xF1C3L
    Gets the handle of a page by index.
  • #define PSM_GETACTIVEINDEX 0xF1C4L
    Gets the index of the current active page.
  • #define PSM_GETPAGEINDEX 0xF1C5L
    Gets the index of a page by handle.
  • #define PSM_GETPAGECOUNT 0xF1C6L
    Gets the number of pages of the propsheet.
  • #define PSM_GETTITLELENGTH 0xF1C7L
    Gets the length of a page title.
  • #define PSM_GETTITLE 0xF1C8L
    Gets a page title.
  • #define PSM_SETTITLE 0xF1C9L
    Sets a page title.
  • #define PSM_ADDPAGE 0xF1D0L
    Adds a page to the propsheet.
  • #define PSM_REMOVEPAGE 0xF1D1L
    Removes a page from the propsheet.
  • #define PSM_SHEETCMD 0xF1D2L
    Sends a MSG_SHEETCMD message to all pages in the propsheet.
  • #define PSN_ACTIVE_CHANGED 0x01
    Notifies the parent window that the active page of the propsheet has been changed.

Detailed Description

Author:
Wei Yongming <ymwei@minigui.org>
Date:
2001/12/29

    Copyright (C) 2002-2008 Feynman Software.
    Copyright (C) 1998-2002 Wei Yongming.

    All rights reserved by Feynman Software.

    This file is part of MiniGUI, a compact cross-platform Graphics
    User Interface (GUI) support system for real-time embedded systems.

Definition in file propsheet.h.

Generated on Fri Dec 17 13:49:43 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: scrollbar.h File Reference

include » ctrl

scrollbar.h File Reference

Go to the source code of this file.

Defines

  • #define CTRL_SCROLLBAR ("scrollbar")
    The class name of scrollbar control.
  • #define SBS_HORZ 0x1000
    Create a horizontal scrollbar.
  • #define SBS_VERT 0x2000
    Create a vertical scrollbar.
  • #define SBS_BOTTOMALIGN 0x0001
    Create a horizontal scrollbar on the bottom of the rect.
  • #define SBS_TOPALIGN 0x0002
    Create a horizontal scrollbar on the top of the rect.
  • #define SBS_LEFTALIGN 0x0001
    Create a vertical scrollbar on the left of the rect.
  • #define SBS_RIGHTALIGN 0x0002
    Create a vertical scrollbar on the right of the rect.
  • #define SBS_NOARROW 0x0004
    Create a vertical scrollbar with no arrow.
  • #define SBS_NOSHAFT 0x0008
    Create a vertical scrollbar with no shaft.
  • #define SBS_FIXEDBARLEN 0x0010
    Create a scrollbar with fixed thumb.
  • #define SBS_NOTNOTIFYPARENT 0x0020
    send notification code with SendNotifyMessage instead of NotifyParent
  • #define SBM_GETSCROLLINFO 0xF0E0
    Get the scroll information of the scrollbar.
  • #define SBM_SETSCROLLINFO 0xF0E1
    Set the scroll information of the scrollbar.
  • #define SBM_GETPOS 0xF0E2
    Get the thumb pos of the scrollbar.
  • #define SBM_SETPOS 0xF0E3
    Set the thumb pos of the scrollbar.
  • #define SBM_GETRANGE 0xF0E4
    Get the range of the scrollbar.
  • #define SBM_SETRANGE 0xF0E5
    Set the range of the scrollbar.
  • #define SBM_SETRANGEREDRAW 0xF0E6
    Set the range of the scrollbar.
  • #define SBM_ENABLE_ARROW 0xF0E7
    Enable or disable the arrow of the scrollbar.

Detailed Description

Author:
wangjian <wangjian@minigui.org>
Date:
2008/01/17

    Copyright (C) 2002-2008 Feynman Software.
    Copyright (C) 1998-2002 Wei Yongming.

    All rights reserved by Feynman Software.

    This file is part of MiniGUI, a compact cross-platform Graphics
    User Interface (GUI) support system for real-time embedded systems.

Definition in file scrollbar.h.

Generated on Fri Dec 17 13:49:43 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: scrollview.h File Reference

include » ctrl

scrollview.h File Reference

Go to the source code of this file.

Data Structures

  • struct _CONTAINERINFO
  • struct _svitem_operations
  • struct _SCROLLVIEWITEMINFO

Defines

  • #define CTRL_SCROLLVIEW ("scrollview")
    The class name of scrollview control, uses this name to create a scrollable window that consists of items.
  • #define CTRL_SCROLLWND ("scrollwnd")
    The class name of scrollwnd control, uses this name to create a scrollable window to which you can add controls.
  • #define SVS_UPNOTIFY 0x0001L
    Sends the notification messages to parent window when the keys is up.
  • #define SVS_NOTIFY 0x0002L
    reserved.
  • #define SVS_AUTOSORT 0x0004L
    Automatically sorts strings entered in the scrollview control.
  • #define SVS_LOOP 0x0008L
    Loops the item automatically when user select item with down or up key.
  • #define SVM_ADDITEM 0xF300
    Adds an item in the scrollview.
  • #define SVM_DELITEM 0xF301
    Deletes an item from the scrollview.
  • #define SVM_SETITEMDRAW 0xF302
    Sets the drawing operation of an item.
  • #define SVM_ADDCTRLS 0xF303
    Adds controls to the scrollview.
  • #define SVM_SETCONTWIDTH 0xF306
    Sets the scrollview content area (scrollable area) width.
  • #define SVM_SETCONTHEIGHT 0xF307
    Sets the scrollview content area (scrollable area) height.
  • #define SVM_GETCTRL 0xF308
    Gets the control handle in the scrollview window by control id.
  • #define SVM_RESETCONTENT 0xF309
    Clears all the controls and the items added to the scrollview window.
  • #define SVM_SETITEMOPS 0xF30a
    Sets the item operations of the items in the scrollview.
  • #define SVM_GETMARGINS 0xF30b
    Gets the margin values of the scrollview.
  • #define SVM_SETMARGINS 0xF311
    Sets the margin values of the scrollview.
  • #define SVM_GETLEFTMARGIN 0xF312
    Gets the left margin value of the scrollview.
  • #define SVM_GETTOPMARGIN 0xF313
    Gets the top margin value of the scrollview.
  • #define SVM_GETRIGHTMARGIN 0xF314
    Gets the right margin value of the scrollview.
  • #define SVM_GETBOTTOMMARGIN 0xF315
    Gets the bottom margin value of the scrollview.
  • #define SVM_GETVISIBLEWIDTH 0xF316
    Gets the width of the visible content area.
  • #define SVM_GETVISIBLEHEIGHT 0xF317
    Gets the height of the visible content area.
  • #define SVM_GETCONTWIDTH 0xF318
    Gets the width of the content area.
  • #define SVM_GETCONTHEIGHT 0xF319
    Gets the height of the content area.
  • #define SVM_SETCONTRANGE 0xF31a
    Sets the width and height of the content area.
  • #define SVM_GETCONTENTX 0xF31b
    Gets the content x offset in the viewport.
  • #define SVM_GETCONTENTY 0xF31c
    Gets the content y offset in the viewport.
  • #define SVM_SETCONTPOS 0xF31d
    Sets the content offset position in the viewport.
  • #define SVM_GETCURSEL 0xF31e
    Gets the index of the current hilighted scrollview item.
  • #define SVM_SELECTITEM 0xF31f
    Selects or unselects an item in the scrollview item.
  • #define SVM_SHOWITEM 0xF320
    Makes an item visible in the scrollview item.
  • #define SVM_CHOOSEITEM 0xF321
    Makes an item selected and visible in the scrollview item.
  • #define SVM_SETCURSEL 0xF322
    Makes an item as the current hilighted item in the scrollview item.
  • #define SVM_SETITEMINIT 0xF323
    Sets the init operation of the items in the scrollview.
  • #define SVM_SETITEMDESTROY 0xF324
    Sets the destroy operation of the items in the scrollview.
  • #define SVM_SETITEMCMP 0xF327
    Sets the item compare function.
  • #define SVM_MAKEPOSVISIBLE 0xF328
    Makes a position in the content area visible.
  • #define SVM_SETCONTAINERPROC 0xF329
    Sets the window procedure of the container window in the scrollview.
  • #define SVM_GETFOCUSCHILD 0xF32a
    Gets the focus control in the scrollview.
  • #define SVM_GETHSCROLLVAL 0xF32b
    Gets the horizontal scroll value.
  • #define SVM_GETVSCROLLVAL 0xF32c
    Gets the vertical scroll value.
  • #define SVM_GETHSCROLLPAGEVAL 0xF32d
    Gets the horizontal page scroll value.
  • #define SVM_GETVSCROLLPAGEVAL 0xF32e
    Gets the vertical page scroll value.
  • #define SVM_SETSCROLLVAL 0xF32f
    Sets the horizontal and vertical scroll value.
  • #define SVM_SETSCROLLPAGEVAL 0xF330
    Sets the horizontal and vertical page value.
  • #define SVM_SORTITEMS 0xF331
    Sorts the items according to a specified comparision function.
  • #define SVM_GETITEMCOUNT 0xF332
    Gets the total number of the items.
  • #define SVM_GETITEMADDDATA 0xF333
    Gets the additional data of the item.
  • #define SVM_SETITEMADDDATA 0xF334
    Sets the additional data of the item.
  • #define SVM_REFRESHITEM 0xF335
    Refresh the item.
  • #define SVM_SETITEMHEIGHT 0xF336
    Sets the height of an item.
  • #define SVM_GETFIRSTVISIBLEITEM 0xF337
    Gets the index of the first visible item.
  • #define SVN_CLICKED 1
  • #define SVN_SELCHANGED 2
  • #define SVN_SELCHANGING 4

Typedefs

  • typedef GHANDLE HSVITEM
  • typedef CONTAINERINFO * PCONTAINERINFO
  • typedef int(* SVITEM_INITFUNC )(HWND hWnd, HSVITEM hsvi)
    Type of the scrollview item initialization callback procedure.
  • typedef void(* SVITEM_DESTROYFUNC )(HWND hWnd, HSVITEM hsvi)
    Type of the scrollview item destroy callback procedure.
  • typedef void(* SVITEM_DRAWFUNC )(HWND hWnd, HSVITEM hsvi, HDC hdc, RECT *rcDraw)
    Type of the scrollview item drawing callback procedure.
  • typedef int(* SVITEM_CMP )(HSVITEM hsvi1, HSVITEM hsvi2)
    Type of the scrollview item compare function.
  • typedef SVITEMOPS * PSVITEMOPS
  • typedef SVITEMINFO * PSVITEMINFO

Functions

  • MG_EXPORT int GUIAPI DefaultContainerProc (HWND hWnd, int message, WPARAM wParam, LPARAM lParam)
  • MG_EXPORT DWORD mglist_get_item_adddata (GHANDLE hi)
    Use this to get additional data from a list item in a control, such as scrollview and iconview.
  • MG_EXPORT DWORD scrollview_get_item_adddata (HSVITEM hsvi)
    Use this to get additional data from scrollview item.
  • MG_EXPORT int scrollview_get_item_index (HWND hWnd, HSVITEM hsvi)
    To get item index.
  • MG_EXPORT BOOL scrollview_is_item_hilight (HWND hWnd, HSVITEM hsvi)
    To decide whether an item is the current hilighted item.
  • MG_EXPORT BOOL scrollview_is_item_selected (HSVITEM hsvi)
    To decide whether an item is a selected.
  • MG_EXPORT int scrollview_set_item_height (HWND hWnd, HSVITEM hsvi, int height)
    Sets the height of an item.

Detailed Description

Author:
Wei Yongming <ymwei@minigui.org>
Date:
2001/12/29

    Copyright (C) 2002-2008 Feynman Software.
    Copyright (C) 1998-2002 Wei Yongming.

    All rights reserved by Feynman Software.

    This file is part of MiniGUI, a compact cross-platform Graphics
    User Interface (GUI) support system for real-time embedded systems.

Definition in file scrollview.h.

Generated on Fri Dec 17 13:49:43 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: spinbox.h File Reference

include » ctrl

spinbox.h File Reference

Go to the source code of this file.

Data Structures

  • struct _SPININFO

Defines

  • #define CTRL_SPINBOX ("SpinBox")
    The class name of spinbox control.
  • #define SPS_AUTOSCROLL 0x00000001L
    The spinbox control can automatically scroll, and disable itself when reach maximal or minimal value.
  • #define SPS_HORIZONTAL 0x00000010L
    The spinbox control is horizontal. The default is vertical.
  • #define SPS_TYPE_NORMAL 0x00000000L
    The spinbox control contains the up and left arrows.
  • #define SPS_TYPE_UPARROW 0x00000100L
    The spinbox control contains only the up/left arrow.
  • #define SPS_TYPE_DOWNARROW 0x00000200L
    The spinbox control contains only the down/right arrow.
  • #define SPS_TYPE_MASK 0x00000F00L
    The mask code of spinbox control.
  • #define KS_SPINPOST 0x00010000
    The flag of the spinbox control message.
  • #define SPM_SETTARGET 0xF300
    Sets the target window of the spinbox.
  • #define SPM_GETTARGET 0xF301
    Gets the target window of the spinbox.
  • #define SPM_SETINFO 0xF302
    Sets the parameter information of the spinbox.
  • #define SPM_GETINFO 0xF303
    Gets the parameter infos of the spinbox.
  • #define SPM_DISABLEUP 0xF304
    Disable the ability to scroll up.
  • #define SPM_DISABLEDOWN 0xF305
    Disable the ability to scroll down.
  • #define SPM_ENABLEUP 0xF306
    Enable the ability to scroll up.
  • #define SPM_ENABLEDOWN 0xF307
    Enable the ability to scroll down.
  • #define SPM_SETCUR 0xF308
    Sets the current position in the range of the spinbox.
  • #define SPM_GETCUR 0xF309
    Gets the current position in the range of the spinbox.
  • #define SPN_REACHMIN 1
    Notifies that the spin box has reached the minimum limit.
  • #define SPN_REACHMAX 2
    Notifies that the spin box has reached the maximum limit.

Typedefs

  • typedef SPININFO * PSPININFO
    Data type of the pointer to a SPININFO.

Functions

  • void GetSpinBoxSize (DWORD dwStyle, int *w, int *h)
    Gets size of a vertical spin box control.

Detailed Description

Author:
Wei Yongming <ymwei@minigui.org>
Date:
2002/01/06

    Copyright (C) 2002-2008 Feynman Software
    Copyright (C) 1998-2002 Wei Yongming

    All rights reserved by Feynman Software.

    This file is part of MiniGUI, a compact cross-platform Graphics
    User Interface (GUI) support system for real-time embedded systems.

Definition in file spinbox.h.

Generated on Fri Dec 17 13:49:43 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: static.h File Reference

include » ctrl

static.h File Reference

Go to the source code of this file.

Defines

  • #define CTRL_STATIC ("static")
    The class name of static control.
  • #define SS_SIMPLE 0x00000000L
    Designates a simple rectangle and displays a single line of text flush-left in the rectangle.
  • #define SS_BLACKRECT 0x00000001L
    Specifies a rectangle filled with the black color.
  • #define SS_GRAYRECT 0x00000002L
    Specifies a rectangle filled with the light gray color.
  • #define SS_WHITERECT 0x00000003L
    Specifies a rectangle filled with the light white color.
  • #define SS_BLACKFRAME 0x00000004L
    Specifies a box with a frame drawn with the black color.
  • #define SS_GRAYFRAME 0x00000005L
    Specifies a box with a frame drawn with the light gray color.
  • #define SS_WHITEFRAME 0x00000006L
    Specifies a box with a frame drawn with the light white color.
  • #define SS_GROUPBOX 0x00000007L
    Creates a rectangle in which other controls can be grouped.
  • #define SS_ICON 0x00000008L
    Designates an icon displayed in the static control.
  • #define SS_BITMAP 0x00000009L
    Specifies that a bitmap will be displayed in the static control.
  • #define SS_TYPEMASK 0x0000000FL
    The mask code of the static control.
  • #define SS_LEFT 0x00000010L
    Displays the given text flush-left.
  • #define SS_CENTER 0x00000020L
    Displays the given text centered in the rectangle.
  • #define SS_RIGHT 0x00000030L
    Displays the given text flush-right.
  • #define SS_ALIGNMASK 0x000000F0L
    The mask code of the static control.
  • #define SS_NOPREFIX 0x00000100L
    Prevents interpretation of any ampersand (&) characters in the control's text as accelerator prefix characters.
  • #define SS_CENTERIMAGE 0x00000200L
    Puts the image in the center of the static control. Default is top-left aligned.
  • #define SS_NOWORDWRAP 0x00000400L
    Designates a simple rectangle and displays the given text in single line in the rectangle.
  • #define SS_LEFTNOWORDWRAP SS_NOWORDWRAP
    Backward compatibility definition.
  • #define SS_REALSIZEIMAGE 0x00000800L
    Does not scale the image.
  • #define SS_NOTIFY 0x00001000L
    Sends the parent window notification messages when the user clicks or double-clicks the control.
  • #define STM_SETIMAGE 0xF172
    Associates a new image (icon or bitmap) with a static control.
  • #define STM_GETIMAGE 0xF173
    Retrieves a handle to the image.
  • #define STN_DBLCLK 1
    Notifies a double-click.
  • #define STN_CLICKED 4
    Notifies that a static control is clicked.

Detailed Description

Author:
Wei Yongming <ymwei@minigui.org>
Date:
2001/12/29

    Copyright (C) 2002-2008 Feynman Software.
    Copyright (C) 1998-2002 Wei Yongming.

    All rights reserved by Feynman Software.

    This file is part of MiniGUI, a compact cross-platform Graphics
    User Interface (GUI) support system for real-time embedded systems.

Definition in file static.h.

Generated on Fri Dec 17 13:49:44 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: textedit.h File Reference

include » ctrl

textedit.h File Reference

Go to the source code of this file.

Defines

  • #define CTRL_TEXTEDIT ("textedit")
    The class name of textedit control.

Typedefs

  • typedef GHANDLE HTEXTDOC
    Text document/buffer object.

Detailed Description

Author:
Wei Yongming <ymwei@minigui.org>
Date:
2001/12/29

    Copyright (C) 2002-2008 Feynman Software.
    Copyright (C) 1998-2002 Wei Yongming.

    All rights reserved by Feynman Software.

    This file is part of MiniGUI, a compact cross-platform Graphics
    User Interface (GUI) support system for real-time embedded systems.

Definition in file textedit.h.

Generated on Fri Dec 17 13:49:44 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: trackbar.h File Reference

include » ctrl

trackbar.h File Reference

Go to the source code of this file.

Defines

  • #define CTRL_TRACKBAR ("trackbar")
    The class name of trackbar control.
  • #define TBLEN_TIP 31
    The maximum length of the trackbar tip string.
  • #define TBS_NOTIFY 0x0001L
    Causes the trackbar to notify the parent window with a notification message when the user clicks or doubleclicks the trackbar.
  • #define TBS_VERTICAL 0x0002L
    The trackbar control will be oriented vertically.
  • #define TBS_BORDER 0x0004L
    The trackbar control will have border.
  • #define TBS_TIP 0x0008L
    The trackbar control will display tip string above the control.
  • #define TBS_NOTICK 0x0010L
    The trackbar control will not display tick line beside the control.
  • #define TBM_SETRANGE 0xF090
    Sets the range of minimum and maximum logical positions for the slider in a trackbar.
  • #define TBM_GETMIN 0xF091
    Gets the minimum logical position for the slider.
  • #define TBM_SETPOS 0xF092
    Sets the current logical position of the slider.
  • #define TBM_GETPOS 0xF093
    Gets the current logical position of the slider.
  • #define TBM_SETLINESIZE 0xF094
    Sets the number of logical positions moved in response to keyboard input from the arrow keys.
  • #define TBM_GETLINESIZE 0xF095
    Gets the number of logical positions moved in response to keyboard input from the arrow keys.
  • #define TBM_SETPAGESIZE 0xF096
    Sets the number of logical positions moved in response to keyboard input from page keys..
  • #define TBM_GETPAGESIZE 0xF097
    Gets the number of logical positions moved in response to keyboard input from page keys..
  • #define TBM_SETTIP 0xF098
    Sets the start and end tip strings.
  • #define TBM_GETTIP 0xF09A
    Gets the start and end tip strings.
  • #define TBM_SETTICKFREQ 0xF09B
    Sets the interval frequency for tick marks in a trackbar.
  • #define TBM_GETTICKFREQ 0xF09C
    Gets the interval frequency for tick marks in a trackbar.
  • #define TBM_SETMIN 0xF09D
    Sets the minimum logical position for the slider in a trackbar.
  • #define TBM_SETMAX 0xF09E
    Sets the maximum logical position for the slider in a trackbar.
  • #define TBM_GETMAX 0xF09F
    Gets the maximum logical position for the slider in a trackbar.
  • #define TBN_REACHMIN 1
    Notifies that the slider has reached the minimum position.
  • #define TBN_REACHMAX 2
    Notifies that the slider has reached the maximum position.
  • #define TBN_CHANGE 3
    Notifies that the position of the slider has changed.
  • #define TBN_STARTDRAG 4
    Notifies that the user start to drag the slider.
  • #define TBN_STOPDRAG 5
    Notifies that the user stop to drag the slider.
  • #define LFRDR_TBS_PRESSED 0x0100L
    indicate left button down
  • #define LFRDR_TBS_HILITE 0x0200L
    indicate mouse is in region of thumb of trackbar

Detailed Description

Author:
Wei Yongming <ymwei@minigui.org>
Date:
2001/12/29

    Copyright (C) 2002-2008 Feynman Software.
    Copyright (C) 1998-2002 Wei Yongming.

    All rights reserved by Feynman Software.

    This file is part of MiniGUI, a compact cross-platform Graphics
    User Interface (GUI) support system for real-time embedded systems.

Definition in file trackbar.h.

Generated on Fri Dec 17 13:49:44 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: treeview.h File Reference

include » ctrl

treeview.h File Reference

Go to the source code of this file.

Data Structures

  • struct _TVITEMINFO

Defines

  • #define CTRL_TREEVIEW ("TreeView")
    The class name of treeview control.
  • #define TVS_NOTIFY 0x0001L
    Sends the parent window notification messages when the user clicks or double-clicks the control.
  • #define TVS_WITHICON 0x0002L
    The treeview item will use icons to indicate folded or unfolded status.
  • #define TVS_ICONFORSELECT 0x0000L
    The fold icon is used to indicate selected item.
  • #define TVS_SORT 0x0010L
    Enables sorting in the treeview.
  • #define TVM_ADDITEM 0xF110
    Adds a new item in a treeview control.
  • #define TVM_INSERTITEM 0xF111
    The same as TVM_ADDITEM message.
  • #define TVM_GETROOT 0xF112
    Gets the root item of a treeview control.
  • #define TVM_DELTREE 0xF113
    Removes an item and its descendant items for the treeview control.
  • #define TVM_SEARCHITEM 0xF114
    Searches an item matching a specified string in a subtree rooted by a specific item.
  • #define TVM_FINDCHILD 0xF115
    Finds a child item matching a specified string in children of a specific item.
  • #define TVM_GETSELITEM 0xF116
    Gets the selected item.
  • #define TVM_SETSELITEM 0xF117
    Sets the selected item.
  • #define TVM_GETITEMTEXTLEN 0xF118
    Retrives the text length of the specified item in TreeView control.
  • #define TVM_GETITEMTEXT 0xF119
    Retrives the text of the specified item in TreeView control.
  • #define TVM_GETITEMINFO 0xF11A
    Retrives the information of an item in TreeView control.
  • #define TVM_SETITEMINFO 0xF11B
    Changes the information of an item.
  • #define TVM_GETRELATEDITEM 0xF11C
    Retrives related item of specific item.
  • #define TVM_SETSTRCMPFUNC 0xF11D
    Sets the STRCMP function used to sort items.
  • #define TVN_ERRSPACE 255
    Indicates that memory is not enough.
  • #define TVN_SELCHANGE 1
    Notifies the change of selection.
  • #define TVN_DBLCLK 2
    Notifies the user has double-clicked an item.
  • #define TVN_SETFOCUS 4
    Indicates gain of input focus.
  • #define TVN_KILLFOCUS 5
    Indicates loss of input focus.
  • #define TVN_CLICKED 7
    Indicates the user has clicked an item.
  • #define TVN_ENTER 8
    Indicates the user has pressed the ENTER key.
  • #define TVN_FOLDED 9
    Indicates a sub-tree has folded.
  • #define TVN_UNFOLDED 10
    Indicates a sub-tree has unfolded.

Typedefs

  • typedef TVITEMINFO * PTVITEMINFO
    Data type of the pointer to a TVITEMINFO.

Detailed Description

Author:
Wei Yongming <ymwei@minigui.org>
Date:
2002/01/06

    Copyright (C) 2002-2008 Feynman Software
    Copyright (C) 1998-2002 Wei Yongming

    All rights reserved by Feynman Software.

    This file is part of MiniGUI, a compact cross-platform Graphics
    User Interface (GUI) support system for real-time embedded systems.

Definition in file treeview.h.

Generated on Fri Dec 17 13:49:44 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: window.h File Reference

include

window.h File Reference

Go to the source code of this file.

Data Structures

  • struct _MSG
  • struct _HOOKINFO
  • struct _WINDOW_ELEMENT_ATTR
  • struct _LFSCROLLBARINFO
  • struct _SCROLLBARDATA
  • struct _LFRDR_WINSTYLEINFO
  • struct _LFRDR_TRACKBARINFO
  • struct _WINDOW_ELEMENT_RENDERER
  • struct _WINDOWINFO
  • struct _MAINWINCREATE
  • struct _SCROLLINFO
  • struct _WNDCLASS
  • struct _IME_TARGET_INFO
  • struct _MENUITEMINFO
  • struct _CTRLDATA
  • struct _DLGTEMPLATE

Defines

  • #define MSG_LBUTTONDOWN 0x0001
    Left mouse button down message.
  • #define MSG_LBUTTONUP 0x0002
    Left mouse button up message.
  • #define MSG_LBUTTONDBLCLK 0x0003
    Left mouse button double clicked message.
  • #define MSG_MOUSEMOVE 0x0004
    The mouse moved message.
  • #define MSG_RBUTTONDOWN 0x0005
    Right mouse button down message.
  • #define MSG_RBUTTONUP 0x0006
    Right mouse button up message.
  • #define MSG_RBUTTONDBLCLK 0x0007
    Right mouse button double clicked message.
  • #define MSG_NCLBUTTONDOWN 0x0008
    Left mouse button down message in the non-client area.
  • #define MSG_NCLBUTTONUP 0x0009
    Left mouse button up message in the non-client area.
  • #define MSG_NCLBUTTONDBLCLK 0x000A
    Left mouse button double clicked in the non-client area.
  • #define MSG_NCMOUSEMOVE 0x000B
    Mouse moves in the non-client area.
  • #define MSG_NCRBUTTONDOWN 0x000C
    Right mouse button down message in the non-client area.
  • #define MSG_NCRBUTTONUP 0x000D
    Right mouse button up message in the non-client area.
  • #define MSG_NCRBUTTONDBLCLK 0x000E
    Right mouse button double clicked in the non-client area.
  • #define MSG_KEYDOWN 0x0010
    User presses a key down.
  • #define MSG_CHAR 0x0011
    A character translated from MSG_KEYDOWN message.
  • #define MSG_KEYUP 0x0012
    User releases up a key.
  • #define MSG_SYSKEYDOWN 0x0013
    User presses down a key when <Alt> key is down.
  • #define MSG_SYSCHAR 0x0014
    A system character translated from MSG_SYSKEYDOWN message.
  • #define MSG_SYSKEYUP 0x0015
    User releases up a key when <Alt> key is down.
  • #define MSG_KEYSYM 0x0016
    A key symbol translated from MSG_KEYDOWN messages.
  • #define MSG_KEYLONGPRESS 0x0017
    A key is long pressed.
  • #define MSG_KEYALWAYSPRESS 0x0018
    A key is always pressed.
  • #define DEF_LPRESS_TIME 500
    Default long pressed time of a key.
  • #define DEF_APRESS_TIME 1000
    Default always pressed time of a key.
  • #define DEF_INTERVAL_TIME 200
    Default send MSG_KEYLONGPRESS in interval value.
  • #define SetKeyLongPressTime(time)
    User set default long pressed time of a key.
  • #define SetKeyAlwaysPressTime(time)
    User set default always pressed time of a key.
  • #define SetIntervalTime(time)
    User set default interval time that MSG_KEYLONGPRESS is sent.
  • #define MSG_SETCURSOR 0x0020
    Sets cursor shape in the client area.
  • #define MSG_NCHITTEST 0x0021
    Hit test in non-client area. This is an async message.
  • #define MSG_HITTEST MSG_NCHITTEST
    Hit test in non-client area.
  • #define MSG_CHANGESIZE 0x0022
    Change window size.
  • #define MSG_QUERYCLIENTAREA 0x0024
    Query client area.
  • #define MSG_SIZECHANGING 0x0025
    Indicates the size of the window is being changed.
  • #define MSG_SIZECHANGED 0x0026
    Indicates the size of the window has been changed.
  • #define MSG_CSIZECHANGED 0x0027
    Indicates the size of the client area of the window has been changed.
  • #define MSG_SETFOCUS 0x0030
    Indicates that the window has gained the input focus.
  • #define MSG_KILLFOCUS 0x0031
    Indicates that the window has lost the input focus.
  • #define MSG_MOUSEACTIVE 0x0032
    Indicates that the window has gained the input focus because the user clicked the window.
  • #define MSG_ACTIVE 0x0033
    Indicates that the window has gained the input focus because the user clicked the window.
  • #define MSG_CHILDHIDDEN 0x0034
    Hide child window.
  • #define MSG_ACTIVEMENU 0x0040
    Indicates that the user activates the menu bar and tracks it.
  • #define MSG_DEACTIVEMENU 0x0041
    Indicates the end of the tracking of a menu bar or a popup menu.
  • #define SB_LINEUP 0x01a
    The SB_LINEUP notification message is sent when the user clicked the up arrow on the bar.
  • #define SB_LINEDOWN 0x02
    The SB_LINEDOWN notification message is sent when the user clicked the down arrow on the bar.
  • #define SB_LINELEFT 0x03
    The SB_LINELEFT notification message is sent when the user clicked the left arrow on the bar.
  • #define SB_LINERIGHT 0x04
    The SB_LINERIGHT notification message is sent when the user clicked the right arrow on the bar.
  • #define SB_PAGEUP 0x05
    The SB_PAGEUP notification message is sent when the user clicked the page up area on the bar.
  • #define SB_PAGEDOWN 0x06
    The SB_PAGEDOWN notification message is sent when the user clicked the page down area on the bar.
  • #define SB_PAGELEFT 0x07
    The SB_PAGELEFT notification message is sent when the user clicked the page left area on the bar.
  • #define SB_PAGERIGHT 0x08
    The SB_PAGERIGHT notification message is sent when the user clicked the page right area on the bar.
  • #define SB_THUMBPOSITION 0x09
    The SB_THUMBPOSITION notification message is sent when the user set a new thumb position.
  • #define SB_THUMBTRACK 0x0A
    The SB_THUMBTRACK notification message is sent when the user is draging and tracking the thumb.
  • #define SB_TOP 0x0B
    The SB_TOP notification message is sent when the user move thumb to minimum position.
  • #define SB_BOTTOM 0x0C
    The SB_BOTTOM notification message is sent when the user move thumb to maximum position.
  • #define SB_ENDSCROLL 0x0D
    The SB_ENDSCROLL notification message is sent when the thumb at the end of bar.
  • #define MSG_HSCROLL 0x0042
    Indicates that the user has clicked the horizontal scroll bar.
  • #define MSG_VSCROLL 0x0043
    Indicates that the user has clicked the vertical scroll bar.
  • #define MSG_NCSETCURSOR 0x0044
    Sets cursor shape in the non-client area.
  • #define MSG_MOUSEMOVEIN 0x0050
    Indicates the mouse is moved in/out the area of the window.
  • #define MSG_WINDOWDROPPED 0x0051
    Indicates that user dropped window. server to client; (wParam, lParam): result rectangle.
  • #define MSG_CREATE 0x0060
    Indicates the window has been created, and gives you a chance to initialize your private objects.
  • #define MSG_NCCREATE 0x0061
    Indicates the window has been created, but has not registered to the system.
  • #define MSG_DESTROY 0x0064
    Indicates the window will be destroyed.
  • #define MSG_CLOSE 0x0066
    Indicates the user has clicked the closing box on the caption.
  • #define MSG_SHOWWINDOW 0x00A0
    Indicates that the window has been shown or hidden.
  • #define MSG_ERASEBKGND 0x00B0
    Sent to the window to erase the background.
  • #define MSG_PAINT 0x00B1
    Sent to the window if the window contains an invalid region.
  • #define MSG_NCPAINT 0x00B2
    Indicates that paints non-client area.
  • #define MSG_NCACTIVATE 0x00B3
    Indicates that active non-client area of main window.
  • #define MSG_SYNCPAINT 0x00B4
    Indicates that actives and paints main window synchronously.
  • #define MSG_DT_LBUTTONDOWN 0x00E1
    Left mouse button down message on the desktop.
  • #define MSG_DT_LBUTTONUP 0x00E2
    Left mouse button up message on the desktop.
  • #define MSG_DT_LBUTTONDBLCLK 0x00E3
    Left mouse button double clicked message on the desktop.
  • #define MSG_DT_MOUSEMOVE 0x00E4
    The mouse moved message on the desktop.
  • #define MSG_DT_RBUTTONDOWN 0x00E5
    Right mouse button down message on the desktop.
  • #define MSG_DT_RBUTTONUP 0x00E6
    Right mouse button up message on the desktop.
  • #define MSG_DT_RBUTTONDBLCLK 0x00E7
    Right mouse button double clicked message on the desktop.
  • #define MSG_DT_KEYDOWN 0x00E8
    User presses a key down on the desktop.
  • #define MSG_DT_KEYUP 0x00EA
    User releases up a key on the desktop.
  • #define MSG_COMMAND 0x0120
    The command message, indicates a notification message from child window, or the user has selected a menu item.
  • #define MSG_SYSCOMMAND 0x0121
    The system command message.
  • #define MSG_GETDLGCODE 0x0122
    Get dialog code.
  • #define MSG_INITDIALOG 0x0123
    Ready to initialize the controls in a dialog box.
  • #define MSG_DLG_GETDEFID 0x0126
    Get default push button ID first.
  • #define MSG_DLG_SETDEFID 0x0127
    Set default push button ID first.
  • #define MSG_ISDIALOG 0x0128
    Sends to a window to query whether the window is a dialog window.
  • #define MSG_INITPAGE 0x0129
    Ready to initialize the controls in a property page.
  • #define MSG_SHOWPAGE 0x012A
    Indicates the page will be shown or hidden.
  • #define MSG_SHEETCMD 0x012B
    Indicates that a PSM_SHEETCMD message had been sent to the PropertySheet control.
  • #define MSG_INITCONTAINER 0x012C
    This message will be sent to the container window procedure after the container window is created.
  • #define MSG_SVCONTCMD 0x012D
    This message will be sent to the parent of the ScrollView control when the container of the ScrollView control reveived a MSG_COMMAND message.
  • #define MSG_FREEZECTRL 0x012E
    You can send this message to freeze or thaw the paint action of the control.
  • #define MSG_FONTCHANGING 0x0130
    Indicates the user is trying to change the font of the window.
  • #define MSG_FONTCHANGED 0x0131
    Indicates the window font has been changed.
  • #define MSG_GETTEXTLENGTH 0x0132
    Sent to the control to get the length of the text.
  • #define MSG_GETTEXT 0x0133
    Sent to the control to get the text.
  • #define MSG_SETTEXT 0x0134
    Sent to the control to set the text.
  • #define MSG_ENABLE 0x0135
    Indicates the window is disabled/enabled.
  • #define MSG_IDLE 0x0142
    Indicates the system enters idle loop.
  • #define MSG_TIMER 0x0144
    Indicates a timer has expired.
  • #define MSG_FDEVENT 0x0146
    Indicates an event of registered file descriptor occurred.
  • #define MSG_SRVNOTIFY 0x0147
    Indicates a notification from the server of MiniGUI-Processes.
  • #define MSG_DOESNEEDIME 0x0150
    Sends to a window to query whether the window needs to open IME window.
  • #define MSG_USER 0x0800
    The first user-defined message.
  • #define PM_NOREMOVE 0x0000
  • #define PM_REMOVE 0x0001
  • #define PM_NOYIELD 0x0002
  • #define SendAsyncMessage SendMessage
    Is an alias of SendMessage for MiniGUI-Processes and MiniGUI-Standalone.
  • #define HOOK_GOON 0
  • #define HOOK_STOP 1
  • #define WS_NONE 0x00000000L
    None style.
  • #define WS_CHILD 0x40000000L
    Indicates the window is a child.
  • #define WS_CAPTION 0x20000000L
    Creates a main window with caption.
  • #define WS_SYSMENU 0x10000000L
    Creates a main window with system menu.
  • #define WS_VISIBLE 0x08000000L
    Creates a window initially visible.
  • #define WS_DISABLED 0x04000000L
    Creates a window initially disabled.
  • #define WS_DLGFRAME 0x00800000L
    The window has a fixed frame, i.e. user can not drag the border of the window.
  • #define WS_BORDER 0x00400000L
    Creates a window with border.
  • #define WS_THICKFRAME 0x00200000L
    Creates a window with thick frame.
  • #define WS_THINFRAME 0x00100000L
    Creates a window with thin frame.
  • #define WS_VSCROLL 0x00080000L
    Creates a window with vertical scroll bar.
  • #define WS_HSCROLL 0x00040000L
    Creates a window with horizontal scroll bar.
  • #define WS_GROUP 0x00020000L
    Indicates the control is the leader of a group.
  • #define WS_TABSTOP 0x00010000L
    Indicates the user can set the input focus to the control by using Tab key.
  • #define WS_EX_CONTROL_MASK 0x0000000FL
    The extended style mask for control usage.
  • #define WS_EX_INTERNAL_MASK 0xF0000000L
    The extended style mask for internal usage.
  • #define WS_EX_NONE 0x00000000L
    No any extended window style.
  • #define WS_EX_TROUNDCNS 0x00000010L
    The window have round corners in top.
  • #define WS_EX_BROUNDCNS 0x00000020L
    The window have round corners at bottom.
  • #define WS_EX_USEPRIVATECDC 0x00000040L
    The window has its own private client device context.
  • #define WS_EX_NOTDRAGGABLE 0x00000080L
    A style controlling whether a main window can be dragged by using mouse.
  • #define WS_EX_USEPARENTFONT 0x00000100L
    The window uses the font of its parent as the default font.
  • #define WS_EX_USEPARENTCURSOR 0x00000200L
    The window uses the cursor of its parent as the default cursor.
  • #define WS_EX_USEPARENTRDR 0x00000400L
    The window use the same window renderer as parent.
  • #define WS_EX_NOPARENTNOTIFY 0x00000800L
    The window will not send any notification to the parent.
  • #define WS_EX_AUTOSECONDARYDC 0x00001000L
    The window creates its own secondary device context automatically.
  • #define WS_EX_TRANSPARENT 0x00002000L
    The window is transparent.
  • #define WS_EX_TOPMOST 0x00004000L
    The main window is a topmost (always on top) window.
  • #define WS_EX_TOOLWINDOW 0x00008000L
    The main window is a tool window, which can not gain the input focus.
  • #define WS_EX_LEFTSCROLLBAR 0x00040000L
    The horizontal scroll bar of the window is located at left.
  • #define WS_EX_RIGHTSCROLLBAR 0x00000000L
    The horizontal scroll bar of the window is located at right (default).
  • #define WS_EX_DLGHIDE 0x00100000L
    The dialog won't show immediately after it is created.
  • #define WS_EX_NOCLOSEBOX 0x00400000L
    The main window has no closing box on its caption.
  • #define WS_EX_CLIPCHILDREN 0x00800000L
    When paint the window, the children areas will be clipped.
  • #define WS_EX_LFRDR_MASK 0x0F000000L
    The style mask for LF renderer internal usage.
  • #define WS_EX_LFRDR_CUSTOM1 0x01000000L
    The user-defined extended style. It's often used to process user-defined hotspot area.
  • #define WS_EX_LFRDR_CUSTOM2 0x02000000L
    The user-defined extended style.
  • #define WS_EX_LFRDR_CUSTOM3 0x04000000L
    The user-defined extended style.
  • #define WS_EX_LFRDR_CUSTOM4 0x08000000L
    The user-defined extended style.
  • #define WE_FONTS_NUMBER 4
    The number of window element font attributes.
  • #define WE_METRICS_NUMBER 6
    The number of window element metric attributes.
  • #define WE_COLORS_NUMBER 14
    The number of window element color attributes.
  • #define WE_ATTR_TYPE_RDR 0x5000
    The specific type for LF renderer.
  • #define SBS_DISABLED_LTUP 0x0100
  • #define SBS_DISABLED_BTDN 0x0200
  • #define SBS_HILITE_LTUP 0x0400
  • #define SBS_HILITE_BTDN 0x0800
  • #define SBS_HILITE_THUMB 0x0010
  • #define SBS_PRESSED_LTUP 0x0020
  • #define SBS_PRESSED_BTDN 0x0040
  • #define SBS_PRESSED_THUMB 0x0080
  • #define LEN_RENDERER_NAME 15
    The maximum length of a renderer name.
  • #define HWND_DESKTOP __mg_hwnd_desktop
    Desktop window handle.
  • #define HWND_NULL 0
    Null window handle.
  • #define HWND_INVALID 0xFFFFFFFF
    Invalid window handle.
  • #define MainWindowCleanup(hwnd) MainWindowThreadCleanup(hwnd)
    Is an alias of MainWindowThreadCleanup.
  • #define DefaultMainWinProc (__mg_def_proc[0])
    Is the default main window callback procedure.
  • #define DefaultDialogProc (__mg_def_proc[1])
    The default dialog box procedure.
  • #define DefaultControlProc (__mg_def_proc[2])
    The default control callback procedure.
  • #define SetFocus SetFocusChild
  • #define GetFocus GetFocusChild
  • #define GetForegroundWindow GetActiveWindow
  • #define SetForegroundWindow SetActiveWindow
  • #define GetWindowElementColor(iItem) GetWindowElementPixelEx(HWND_NULL, -1, iItem)
    Get window element color.
  • #define GetLargeSystemIcon(iItem) GetLargeSystemIconEx(HWND_NULL, iItem)
    Retrives a large (32x32) system icon by its identifier in default renderer.
  • #define GetSmallSystemIcon(iItem) GetSmallSystemIconEx(HWND_NULL, iItem)
    Retrives a small (16x16) system icon by its identifier in default renderer.
  • #define SB_ARROW_LTUP 0x0001
  • #define SB_ARROW_BTDN 0x0002
  • #define SB_ARROW_BOTH (SB_ARROW_LTUP | SB_ARROW_BTDN)
  • #define CreateWindow(class_name, caption, style,id, x, y, w, h, parent, add_data)
    A simplified version of CreateWindowEx.
  • #define SetTimer(hwnd, id, speed) SetTimerEx(hwnd, id, speed, NULL)
    The backward compatibility version of SetTimerEx.
  • #define ResetTimer(hwnd, id, speed) ResetTimerEx(hwnd, id, speed, (TIMERPROC)0xFFFFFFFF)
    The backward compatibility version of ResetTimerEx.
  • #define DLGC_WANTARROWS 0x0001
    Control wants arrow keys.
  • #define DLGC_WANTTAB 0x0002
    Control wants tab keys.
  • #define DLGC_WANTALLKEYS 0x0004
    Control wants all keys.
  • #define DLGC_WANTCHARS 0x0008
    Want MSG_CHAR messages.
  • #define DLGC_WANTENTER 0x0010
    Control wants enter keys.
  • #define DLGC_HASSETSEL 0x0080
    Understands EM_SETSEL message.
  • #define DLGC_DEFPUSHBUTTON 0x0100
    Default pushbutton.
  • #define DLGC_PUSHBUTTON 0x0200
    Non-default pushbutton.
  • #define DLGC_RADIOBUTTON 0x0400
    Radio button.
  • #define DLGC_3STATE 0x0800
    3 States button item.
  • #define DLGC_STATIC 0x1000
    Static item: don't include.
  • #define DLGC_BUTTON 0x2000
    Button item: can be checked.

Typedefs

  • typedef int(* MSGHOOK )(void *context, HWND dst_wnd, int msg, WPARAM wparam, LPARAM lparam)
    Type of message hook function.
  • typedef int(* SRVEVTHOOK )(PMSG pMsg)
    The type of the event hook.
  • typedef int(* WNDPROC )(HWND, int, WPARAM, LPARAM)
    Type of the window callback procedure.
  • typedef void(* NOTIFPROC )(HWND hwnd, int id, int nc, DWORD add_data)
    Type of the notification callback procedure.
  • typedef BOOL(* TIMERPROC )(HWND, int, DWORD)
    Type of the timer callback procedure.

Functions

  • MG_EXPORT BOOL GUIAPI PeekMessageEx (PMSG pMsg, HWND hWnd, int iMsgFilterMin, int iMsgFilterMax, BOOL bWait, UINT uRemoveMsg)
    Peeks a message from the message queue of a main window.
  • static BOOL GUIAPI GetMessage (PMSG pMsg, HWND hWnd)
    Gets a message from the message queue of a main window.
  • MG_EXPORT BOOL GUIAPI WaitMessage (PMSG pMsg, HWND hMainWnd)
    Waits for a message from the message queue of a main window.
  • MG_EXPORT BOOL GUIAPI HavePendingMessage (HWND hMainWnd)
    Checks if there is any pending message in the message queue of a main window.
  • static BOOL GUIAPI PeekMessage (PMSG pMsg, HWND hWnd, int iMsgFilterMin, int iMsgFilterMax, UINT uRemoveMsg)
    Peeks a message from the message queue of a main window.
  • MG_EXPORT BOOL GUIAPI PeekPostMessage (PMSG pMsg, HWND hWnd, int iMsgFilterMin, int iMsgFilterMax, UINT uRemoveMsg)
    Peeks a post message from the message queue of a main window.
  • MG_EXPORT int GUIAPI PostMessage (HWND hWnd, int iMsg, WPARAM wParam, LPARAM lParam)
    Posts a message into the message queue of a window and returns immediatly.
  • MG_EXPORT int GUIAPI SendMessage (HWND hWnd, int iMsg, WPARAM wParam, LPARAM lParam)
    Sends a message to a window.
  • MG_EXPORT void GUIAPI SetAutoRepeatMessage (HWND hwnd, int msg, WPARAM wParam, LPARAM lParam)
    Sets the auto-repeat message.
  • MG_EXPORT int GUIAPI SendNotifyMessage (HWND hWnd, int iMsg, WPARAM wParam, LPARAM lParam)
    Sends a notification message to a window.
  • MG_EXPORT int GUIAPI BroadcastMessage (int iMsg, WPARAM wParam, LPARAM lParam)
    Broadcasts a message to all main window on the desktop.
  • MG_EXPORT int GUIAPI PostQuitMessage (HWND hWnd)
    Puts a MSG_QUIT message into the message queue of a main window.
  • MG_EXPORT BOOL GUIAPI SetKeyboardLayout (const char *kbd_layout)
    Sets a new keyboard layout.
  • MG_EXPORT BOOL GUIAPI TranslateMessage (PMSG pMsg)
    Translates key down and key up messages to MSG_CHAR message and post it into the message queue.
  • MG_EXPORT BOOL GUIAPI TranslateKeyMsgToChar (int message, WPARAM wParam, LPARAM lParam, WORD *ch)
    Translates a key down and key up message to a corresponding character.
  • MG_EXPORT int GUIAPI DispatchMessage (PMSG pMsg)
    Dispatches a message to the window's callback procedure.
  • MG_EXPORT int GUIAPI ThrowAwayMessages (HWND pMainWnd)
    Removes all messages in the message queue associated with a window.
  • MG_EXPORT BOOL GUIAPI EmptyMessageQueue (HWND hWnd)
    Empties a message queue.
  • MG_EXPORT MSGHOOK GUIAPI RegisterKeyMsgHook (void *context, MSGHOOK hook)
    Registers a key message hook.
  • MG_EXPORT MSGHOOK GUIAPI RegisterMouseMsgHook (void *context, MSGHOOK hook)
    Registers a mouse message hook.
  • MG_EXPORT SRVEVTHOOK GUIAPI SetServerEventHook (SRVEVTHOOK SrvEvtHook)
    Sets an event hook in the server of MiniGUI-Processes.
  • static const WINDOWINFO *GUIAPI GetWindowInfo (HWND hWnd)
    Get the handle of window information.
  • MG_EXPORT BOOL GUIAPI InitWindowElementAttrs (PWERENDERER rdr)
  • MG_EXPORT DWORD GUIAPI GetWindowElementAttr (HWND hwnd, int we_attr_id)
    Get a window element data.
  • MG_EXPORT DWORD GUIAPI SetWindowElementAttr (HWND hwnd, int we_attr_id, DWORD we_attr)
    Set a new window element data specified by we_attr_id.
  • MG_EXPORT gal_pixel GUIAPI GetWindowElementPixelEx (HWND hwnd, HDC hdc, int we_attr_id)
    Get a window element gal_pixel color.
  • MG_EXPORT const
    WINDOW_ELEMENT_RENDERER
    *GUIAPI GetWindowRendererFromName (const char *name)
    Get window renderer from name.
  • MG_EXPORT BOOL GUIAPI AddWindowElementRenderer (const char *name, const WINDOW_ELEMENT_RENDERER *we_rdr)
    Add a window element renderer to the system.
  • MG_EXPORT BOOL GUIAPI RemoveWindowElementRenderer (const char *name)
    Remove a window renderer from MiniGUI.
  • MG_EXPORT const
    WINDOW_ELEMENT_RENDERER
    *GUIAPI GetDefaultWindowElementRenderer (void)
    Get the default window renderer.
  • MG_EXPORT const char *GUIAPI SetDefaultWindowElementRenderer (const char *name)
    Set a window element renderer as the default system renderer.
  • MG_EXPORT BOOL GUIAPI SetWindowElementRenderer (HWND hWnd, const char *werdr_name, const WINDOW_ELEMENT_ATTR *we_attrs)
    Set a window element renderer and window element attributes for window specified by hwnd.
  • MG_EXPORT BOOL InitRendererSystemIcon (const char *rdr_name, HICON *small_icon, HICON *large_icon)
    Initialize large and small system icons in the specified renderer rdr_name.
  • MG_EXPORT void TermRendererSystemIcon (HICON *small_icon, HICON *large_icon)
    Release large and small system icon resources.
  • MG_EXPORT BOOL GUIAPI RegisterResFromFile (HDC hdc, const char *file)
    Register a device-dependent bitmap from a file.
  • MG_EXPORT BOOL GUIAPI RegisterResFromMem (HDC hdc, const char *file, const unsigned char *data, size_t data_size)
    Register a device-dependent bitmap to bitmap cache from memory.
  • MG_EXPORT BOOL GUIAPI RegisterResFromBitmap (const char *file, const BITMAP *bmp)
    Register a device-dependent bitmap to bitmap cache.
  • MG_EXPORT const BITMAP *GUIAPI RetrieveRes (const char *file)
    Get a BITMAP object from cache according to the specified resource file name.
  • MG_EXPORT void GUIAPI UnregisterRes (const char *file)
    Unregister the BITMAP object from cache according to the specified resource file name.
  • MG_EXPORT BOOL GUIAPI RegisterSystemBitmap (HDC hdc, const char *rdr_name, const char *id)
    Register a device-dependent bitmap from id to BITMAP cache.
  • MG_EXPORT void GUIAPI UnregisterSystemBitmap (HDC hdc, const char *rdr_name, const char *id)
    Unregister a BITMAP object from BITMAP cache.
  • MG_EXPORT int SetResPath (const char *path)
    Set user's resouce path into the search paths of resouce manager.
  • MG_EXPORT int AddInnerRes (INNER_RES *inner_res, int count, BOOL copy)
    Add some incore resource into the resource manager in order to call LoadResouce to get those resource.
  • MG_EXPORT int RegisterResType (int type, RES_TYPE_OPS *ops)
    Register a new user-defined type into resource manager, so that the LoadResouce can load the special resouce automatically.
  • MG_EXPORT int UnregisterResType (int type)
    Unregister a user-defined resource type.
  • MG_EXPORT void * LoadResource (const char *res_name, int type, DWORD usr_param)
    Load a resouce from disk or memory.
  • MG_EXPORT void * GetResource (RES_KEY key)
    Retrive and return a buffered resouce by the key.
  • MG_EXPORT int AddResRef (RES_KEY key)
    Increase the reference count of a buffered resouce.
  • MG_EXPORT int ReleaseRes (RES_KEY key)
    Release the buffered resouce. It will decrease the reference count of the resouce. If the reference count is less then 0, the resource will be released.
  • MG_EXPORT RES_KEY Str2Key (const char *str)
    Translate a string to an unsigned long (RES_KEY), which is used to find a resouce in the resource manager.
  • MG_EXPORT void GUIAPI MainWindowThreadCleanup (HWND hMainWnd)
    Cleans up system resource associated with a main window.
  • MG_EXPORT HWND GUIAPI CreateMainWindowEx (PMAINWINCREATE pCreateInfo, const char *werdr_name, const WINDOW_ELEMENT_ATTR *we_attrs, const char *window_name, const char *layer_name)
    Creates a main window.
  • static HWND GUIAPI CreateMainWindow (PMAINWINCREATE pCreateInfo)
    A simplified version of CreateMainWindowEx.
  • MG_EXPORT BOOL GUIAPI DestroyMainWindow (HWND hWnd)
    Destroys a main window.
  • MG_EXPORT BOOL GUIAPI SetWindowMask (HWND hWnd, const MYBITMAP *mask)
    Set window (a main window, or a child window which is also known as "control")'s Mask Rect with MYBITMAP data.
  • MG_EXPORT BOOL GUIAPI SetWindowMaskEx (HWND hWnd, HDC hdc, const BITMAP *mask)
    Set window (a main window, or a child window which is also known as "control")'s Mask Rect with BITMAP data,.
  • BOOL GUIAPI SetWindowRegion (HWND hWnd, const CLIPRGN *region)
    Set window's Mask Rect with CLIPRGN data.
  • MG_EXPORT int GUIAPI DefaultWindowProc (HWND hWnd, int message, WPARAM wParam, LPARAM lParam)
    The default window callback procedure.
  • MG_EXPORT void GUIAPI UpdateWindow (HWND hWnd, BOOL bErase)
    Updates a window.
  • MG_EXPORT BOOL GUIAPI ShowWindow (HWND hWnd, int iCmdShow)
    Shows or hides a window.
  • MG_EXPORT BOOL GUIAPI EnableWindow (HWND hWnd, BOOL fEnable)
    Enables of disables a window.
  • MG_EXPORT BOOL GUIAPI IsWindowEnabled (HWND hWnd)
    Determines whether the specified window is enabled for mouse and keyboard input.
  • MG_EXPORT BOOL GUIAPI GetClientRect (HWND hWnd, PRECT prc)
    Retrives the client rectangle of a window.
  • MG_EXPORT int GUIAPI GetWindowBkColor (HWND hWnd)
    Returns the current background color of a window.
  • MG_EXPORT int GUIAPI SetWindowBkColor (HWND hWnd, int new_bkcolor)
    Sets the background color of a window.
  • MG_EXPORT PLOGFONT GUIAPI GetWindowFont (HWND hWnd)
    Retrives the default font of a window.
  • MG_EXPORT PLOGFONT GUIAPI SetWindowFont (HWND hWnd, PLOGFONT pLogFont)
    Sets the default font of a window.
  • MG_EXPORT HCURSOR GUIAPI GetWindowCursor (HWND hWnd)
    Retrives the current cursor of a window.
  • MG_EXPORT HCURSOR GUIAPI SetWindowCursor (HWND hWnd, HCURSOR hNewCursor)
    Sets the current cursor of a window.
  • MG_EXPORT HICON GUIAPI GetWindowIcon (HWND hWnd)
    Retrives the current icon of a window.
  • MG_EXPORT HICON GUIAPI SetWindowIcon (HWND hWnd, HICON hIcon, BOOL bRedraw)
    Sets the current icon of a window.
  • MG_EXPORT DWORD GUIAPI GetWindowStyle (HWND hWnd)
    Retrives the style of a window.
  • MG_EXPORT DWORD GUIAPI GetWindowExStyle (HWND hWnd)
    Retrives the extended style of a window.
  • MG_EXPORT BOOL GUIAPI ExcludeWindowStyle (HWND hWnd, DWORD dwStyle)
    Removes the specific style of a window.
  • MG_EXPORT BOOL GUIAPI IncludeWindowStyle (HWND hWnd, DWORD dwStyle)
    Includes the specific style of a window.
  • MG_EXPORT BOOL GUIAPI ExcludeWindowExStyle (HWND hWnd, DWORD dwStyle)
    Removes the specific extended style of a window.
  • MG_EXPORT BOOL GUIAPI IncludeWindowExStyle (HWND hWnd, DWORD dwStyle)
    Includes the specific extended style of a window.
  • MG_EXPORT WNDPROC GUIAPI GetWindowCallbackProc (HWND hWnd)
    Retrives the callback procedure of a window.
  • MG_EXPORT WNDPROC GUIAPI SetWindowCallbackProc (HWND hWnd, WNDPROC newProc)
    Sets the callback procedure of a window.
  • MG_EXPORT DWORD GUIAPI GetWindowAdditionalData (HWND hWnd)
    Retrives the first additional data of a window.
  • MG_EXPORT DWORD GUIAPI SetWindowAdditionalData (HWND hWnd, DWORD newData)
    Sets the first additional data of a window.
  • MG_EXPORT DWORD GUIAPI GetWindowAdditionalData2 (HWND hWnd)
    Retrives the second additional data of a window.
  • MG_EXPORT DWORD GUIAPI SetWindowAdditionalData2 (HWND hWnd, DWORD newData)
    Sets the second additional data of a window.
  • MG_EXPORT DWORD GUIAPI GetWindowClassAdditionalData (HWND hWnd)
    Retrives the additional data of a control class.
  • MG_EXPORT DWORD GUIAPI SetWindowClassAdditionalData (HWND hWnd, DWORD newData)
    Sets the additional data of a control class.
  • MG_EXPORT const char *GUIAPI GetWindowCaption (HWND hWnd)
    Retrives the caption of a window.
  • MG_EXPORT BOOL GUIAPI SetWindowCaption (HWND hWnd, const char *spCaption)
    Sets the caption of a window.
  • MG_EXPORT BOOL GUIAPI InvalidateRect (HWND hWnd, const RECT *prc, BOOL bEraseBkgnd)
    Makes a rectangle region in the client area of a window invalid.
  • MG_EXPORT HDC GUIAPI BeginPaint (HWND hWnd)
    Prepares a window for painting.
  • MG_EXPORT void GUIAPI EndPaint (HWND hWnd, HDC hdc)
    Marks the end of painting in a window.
  • MG_EXPORT BOOL GUIAPI GetUpdateRect (HWND hWnd, RECT *update_rect)
    Retrives the bounding box of the update region of a window.
  • MG_EXPORT int GUIAPI ClientWidthToWindowWidthEx (DWORD dwStyle, int win_type, int cw)
    Calculates main window width from the width of the client area.
  • MG_EXPORT int GUIAPI ClientHeightToWindowHeightEx (DWORD dwStyle, int win_type, int ch, BOOL hasMenu)
    Calculates window height from the height of the client area.
  • MG_EXPORT void GUIAPI ClientToScreen (HWND hWnd, int *x, int *y)
    Converts the client coordinates of a point to screen coordinates.
  • MG_EXPORT void GUIAPI ScreenToClient (HWND hWnd, int *x, int *y)
    Converts the screen coordinates of a point to client coordinates.
  • MG_EXPORT void GUIAPI ClientToWindow (HWND hWnd, int *x, int *y)
    Converts the client coordinates to the window coordinates.
  • MG_EXPORT void GUIAPI WindowToClient (HWND hWnd, int *x, int *y)
    Converts the window coordinates to client coordinates.
  • MG_EXPORT void GUIAPI WindowToScreen (HWND hWnd, int *x, int *y)
    Converts the window coordinates of a point to screen coordinates.
  • MG_EXPORT void GUIAPI ScreenToWindow (HWND hWnd, int *x, int *y)
    Converts the screen coordinates of a point to window coordinates.
  • MG_EXPORT BOOL GUIAPI IsMainWindow (HWND hWnd)
    Determines whether a window is a main window.
  • MG_EXPORT BOOL GUIAPI IsControl (HWND hWnd)
    Determines whether a window is a control.
  • MG_EXPORT BOOL GUIAPI IsWindow (HWND hWnd)
    Determines whether a window handle identifies an existing window.
  • MG_EXPORT BOOL GUIAPI IsDialog (HWND hWnd)
    Determines whether a window handle identifies a dialog window.
  • MG_EXPORT HWND GUIAPI GetParent (HWND hWnd)
    Retrieves the handle to a child window's parent window.
  • MG_EXPORT HWND GUIAPI GetMainWindowHandle (HWND hWnd)
    Retrives the handle to the main window contains a window.
  • MG_EXPORT BOOL GUIAPI IsWindowVisible (HWND hWnd)
    Retrieves the visibility state of the specified window.
  • MG_EXPORT BOOL GUIAPI GetWindowRect (HWND hWnd, PRECT prc)
    Retrives the dimensions of the bounding rectangle of a window.
  • MG_EXPORT HWND GUIAPI GetNextChild (HWND hWnd, HWND hChild)
    Retrives the next control in a window.
  • MG_EXPORT HWND GUIAPI GetNextMainWindow (HWND hMainWnd)
    Retrives the next main window in the system according to the zorder.
  • MG_EXPORT HWND GUIAPI GetHosting (HWND hMainWnd)
    Retrives the hosting main window of a main window.
  • MG_EXPORT HWND GUIAPI GetFirstHosted (HWND hHosting)
    Retrives the first hosted main window of a main window.
  • MG_EXPORT HWND GUIAPI GetNextHosted (HWND hHosting, HWND hHosted)
    Retrives the next hosted main window of a main window.
  • MG_EXPORT int GUIAPI GetWindowTextLength (HWND hWnd)
    Retrieves the length of a window's text.
  • MG_EXPORT int GUIAPI GetWindowText (HWND hWnd, char *spString, int nMaxLen)
    Copies the text of a window's into a buffer.
  • MG_EXPORT BOOL GUIAPI SetWindowText (HWND hWnd, const char *spString)
    Sets the text of a window.
  • MG_EXPORT HWND GUIAPI GetFocusChild (HWND hParent)
    Retrieves the handle to the window's active child that has the keyboard focus.
  • MG_EXPORT HWND GUIAPI SetNullFocus (HWND hParent)
    Cancels the current active child and set the focus child to be null.
  • MG_EXPORT HWND GUIAPI SetFocusChild (HWND hWnd)
    Sets the active child of a window.
  • MG_EXPORT HWND GUIAPI GetActiveWindow (void)
    Retrieves the main window handle to the active main window.
  • MG_EXPORT HWND GUIAPI SetActiveWindow (HWND hMainWnd)
    Sets a main window to be the active main window.
  • MG_EXPORT HWND GUIAPI GetCapture (void)
    Retrives the handle to the window (if any) that has captured the mouse.
  • MG_EXPORT HWND GUIAPI SetCapture (HWND hWnd)
    Sets the mouse capture to the specified window.
  • MG_EXPORT void GUIAPI ReleaseCapture (void)
    Releases the mouse capture from a window and restores normal mouse input processing.
  • MG_EXPORT HWND GUIAPI GetWindowUnderCursor (void)
    Retrives the handle to the window (if any) which is just beneath the mouse cursor.
  • MG_EXPORT BOOL GUIAPI MoveWindow (HWND hWnd, int x, int y, int w, int h, BOOL fPaint)
    Changes the position and dimensions of a window.
  • MG_EXPORT void GUIAPI ScrollWindow (HWND hWnd, int iOffx, int iOffy, const RECT *rc1, const RECT *rc2)
    Scrolls the content of a window's client area.
  • MG_EXPORT const BITMAP *GUIAPI GetSystemBitmapEx (const char *rdr_name, const char *id)
    Retrives the system bitmap object by identifier.
  • MG_EXPORT const BITMAP *GUIAPI GetSystemBitmapByHwnd (HWND hWnd, const char *id)
    Retrives the system bitmap object by identifier.
  • MG_EXPORT const BITMAP *GUIAPI GetSystemBitmap (HWND hWnd, const char *id)
    Retrives the system bitmap object by identifier.
  • MG_EXPORT void GUIAPI TermSystemBitmapEx (const char *id, const char *rdr_name, PBITMAP bmp)
    Release the system bitmap object by identifier.
  • MG_EXPORT void GUIAPI TermSystemBitmap (HWND hWnd, const char *id, PBITMAP bmp)
    Release the system bitmap object by identifier.
  • MG_EXPORT HICON GUIAPI LoadSystemIconEx (HDC hdc, const char *rdr_name, const char *szItemName, int which)
    Loads an icon from information defined in MiniGUI.cfg.
  • MG_EXPORT HICON GUIAPI LoadSystemIcon (const char *szItemName, int which)
    Uses default renderer and HDC_SCREEN to load an icon from information defined in MiniGUI.cfg.
  • MG_EXPORT HICON GUIAPI GetLargeSystemIconEx (HWND hWnd, int iItem)
    Retrives a large system icon by its identifier in default renderer.
  • MG_EXPORT HICON GUIAPI GetSmallSystemIconEx (HWND hWnd, int iItem)
    Retrives a small system icon by its identifier.
  • MG_EXPORT BOOL GUIAPI EnableScrollBar (HWND hWnd, int iSBar, BOOL bEnable)
    Enables or disables one scroll bar arrows.
  • MG_EXPORT BOOL GUIAPI GetScrollPos (HWND hWnd, int iSBar, int *pPos)
    Retrieves the current position of the scroll box (thumb) in the specified scroll bar.
  • MG_EXPORT BOOL GUIAPI GetScrollRange (HWND hWnd, int iSBar, int *pMinPos, int *pMaxPos)
    Retrives the minimum and maximum position values for the specified scroll bar.
  • MG_EXPORT BOOL GUIAPI SetScrollPos (HWND hWnd, int iSBar, int iNewPos)
    Sets the position of the scroll box (thumb) of the specified scroll bar.
  • MG_EXPORT BOOL GUIAPI SetScrollRange (HWND hWnd, int iSBar, int iMinPos, int iMaxPos)
    Sets the minimum and maximum position values for the specified scroll bar.
  • MG_EXPORT BOOL GUIAPI ShowScrollBar (HWND hWnd, int iSBar, BOOL bShow)
    Shows or hides the specified scroll bar.
  • MG_EXPORT BOOL GUIAPI SetScrollInfo (HWND hWnd, int iSBar, const SCROLLINFO *lpsi, BOOL fRedraw)
    Sets the parameters of a scroll bar.
  • MG_EXPORT BOOL GUIAPI GetScrollInfo (HWND hWnd, int iSBar, PSCROLLINFO lpsi)
    Retrieves the parameters of a scroll bar.
  • MG_EXPORT BOOL GUIAPI RegisterWindowClass (PWNDCLASS pWndClass)
    Registers a window class.
  • MG_EXPORT BOOL GUIAPI UnregisterWindowClass (const char *szClassName)
    Undoes the effect of RegisterWindowClass.
  • MG_EXPORT const char *GUIAPI GetClassName (HWND hWnd)
    Retrieves the name of the class to which the specified window belongs.
  • MG_EXPORT BOOL GUIAPI GetWindowClassInfo (PWNDCLASS pWndClass)
    Retrieves the information of the specified window class.
  • MG_EXPORT BOOL GUIAPI SetWindowClassInfo (const WNDCLASS *pWndClass)
    Sets the information of the specified window class.
  • MG_EXPORT HWND GUIAPI CreateWindowEx2 (const char *spClassName, const char *spCaption, DWORD dwStyle, DWORD dwExStyle, int id, int x, int y, int w, int h, HWND hParentWnd, const char *werdr_name, const WINDOW_ELEMENT_ATTR *we_attrs, DWORD dwAddData)
    Creates a child window with extended style, renderer and attributes table.
  • static HWND GUIAPI CreateWindowEx (const char *spClassName, const char *spCaption, DWORD dwStyle, DWORD dwExStyle, int id, int x, int y, int w, int h, HWND hParentWnd, DWORD dwAddData)
    A shortcut version of CreateWindowEx2.
  • MG_EXPORT BOOL GUIAPI DestroyWindow (HWND hWnd)
    Destroys a specified control.
  • MG_EXPORT NOTIFPROC GUIAPI SetNotificationCallback (HWND hwnd, NOTIFPROC notif_proc)
    Sets a new notification callback procedure for a control.
  • MG_EXPORT NOTIFPROC GUIAPI GetNotificationCallback (HWND hwnd)
    Gets the notification callback procedure of a control.
  • MG_EXPORT BOOL GUIAPI SetTimerEx (HWND hWnd, int id, unsigned int speed, TIMERPROC timer_proc)
    Creates a timer with the specified timeout value.
  • MG_EXPORT int GUIAPI KillTimer (HWND hWnd, int id)
    Destroys a timer.
  • MG_EXPORT BOOL GUIAPI ResetTimerEx (HWND hWnd, int id, unsigned int speed, TIMERPROC timer_proc)
    Adjusts a timer with a different timeout value or different timer callback procedure.
  • MG_EXPORT unsigned int GUIAPI GetTickCount (void)
    Retrieves the tick counts that have elapsed since MiniGUI was started.
  • MG_EXPORT BOOL GUIAPI IsTimerInstalled (HWND hWnd, int id)
    Determines whether a timer is installed.
  • MG_EXPORT BOOL GUIAPI HaveFreeTimer (void)
    Determines whether there is any free timer slot in the system.
  • MG_EXPORT int GUIAPI RegisterIMEWindow (HWND hWnd)
    Registers an IME window.
  • MG_EXPORT int GUIAPI UnregisterIMEWindow (HWND hWnd)
    Unregisters an IME window.
  • MG_EXPORT int GUIAPI GetIMEStatus (int StatusCode)
    Retrives status of the current IME window.
  • MG_EXPORT int GUIAPI SetIMEStatus (int StatusCode, int Value)
    Sets the status of the current IME window.
  • MG_EXPORT int GUIAPI GetIMETargetInfo (IME_TARGET_INFO *info)
    Retrives the target info of the current IME window.
  • MG_EXPORT int GUIAPI GetIMEPos (POINT *pt)
    Retrives the position of the current IME window.
  • MG_EXPORT int GUIAPI SetIMETargetInfo (const IME_TARGET_INFO *info)
    Sets the target info of the current IME window.
  • MG_EXPORT HACCEL GUIAPI CopyAcceleratorTable (HACCEL hacc)
    Copies the specified accelerator table.
  • MG_EXPORT int GUIAPI DeleteAccelerators (HACCEL hacc, int key, DWORD keymask)
    Deletes an accelerator from the accelerator table.
  • MG_EXPORT int GUIAPI AddAccelerators (HACCEL hacc, int key, DWORD keymask, WPARAM wParam, LPARAM lParam)
    Adds an accelerator to the accelerator table.
  • MG_EXPORT int GUIAPI DestroyAcceleratorTable (HACCEL hacc)
    Destroys an accelerator table.
  • MG_EXPORT HACCEL GUIAPI CreateAcceleratorTable (HWND hWnd)
    Creates an empty accelerator table.
  • MG_EXPORT int GUIAPI TranslateAccelerator (HACCEL hAccel, PMSG pMsg)
    Translates an accelerator key message to MSG_COMMAND messge and sends it to the window procedure.
  • MG_EXPORT BOOL GUIAPI CreateCaret (HWND hWnd, PBITMAP pBitmap, int nWidth, int nHeight)
    Creates a new shape for the system caret and assigns ownership of the caret to the specified window.
  • MG_EXPORT BOOL GUIAPI ChangeCaretSize (HWND hWnd, int newWidth, int newHeight)
    Changes the size of the caret.
  • MG_EXPORT BOOL GUIAPI ActiveCaret (HWND hWnd)
    Activates the caret owned by a window.
  • MG_EXPORT UINT GUIAPI GetCaretBlinkTime (HWND hWnd)
    Returns the elapsed time, in milliseconds, required to invert the caret's pixels.
  • MG_EXPORT BOOL GUIAPI SetCaretBlinkTime (HWND hWnd, UINT uTime)
    Sets the caret blink time to the specified number of milliseconds.
  • MG_EXPORT BOOL GUIAPI DestroyCaret (HWND hWnd)
    Destroys a caret.
  • static BOOL GUIAPI HideCaret (HWND hWnd)
    Hides a caret.
  • MG_EXPORT BOOL GUIAPI ShowCaretEx (HWND hWnd, BOOL ime)
    Shows a caret.
  • static BOOL GUIAPI ShowCaret (HWND hWnd)
    Shows a caret.
  • MG_EXPORT BOOL GUIAPI SetCaretPos (HWND hWnd, int x, int y)
    Moves the caret to a new position.
  • MG_EXPORT BOOL GUIAPI GetCaretPos (HWND hWnd, PPOINT pPt)
    Gets the caret position.
  • MG_EXPORT HMENU GUIAPI CreateMenu (void)
    Creates an empty menu.
  • MG_EXPORT HMENU GUIAPI CreatePopupMenu (PMENUITEMINFO pmii)
    Creates a drop-down menu or submenu.
  • MG_EXPORT HMENU GUIAPI CreateSystemMenu (HWND hwnd, DWORD dwStyle)
    Creates a system menu.
  • MG_EXPORT int GUIAPI InsertMenuItem (HMENU hmnu, int item, UINT flag, PMENUITEMINFO pmii)
    Inserts a new menu item at the specified position in a menu.
  • MG_EXPORT int GUIAPI RemoveMenu (HMENU hmnu, int item, UINT flag)
    Deletes a menu item or detaches a submenu from the specified menu.
  • MG_EXPORT int GUIAPI DeleteMenu (HMENU hmnu, int item, UINT flag)
    Deletes an item from the specified menu.
  • MG_EXPORT int GUIAPI DestroyMenu (HMENU hmnu)
    Destroys the specified menu and frees any memory that the menu occupies.
  • MG_EXPORT int GUIAPI IsMenu (HMENU hmnu)
    Determines whether a handle is a menu handle.
  • MG_EXPORT HMENU GUIAPI SetMenu (HWND hwnd, HMENU hmnu)
    Assigns a new menu to the specified main window.
  • MG_EXPORT HMENU GUIAPI GetMenu (HWND hwnd)
    Retrieves the handle to the menu assigned to the given main window.
  • MG_EXPORT void GUIAPI DrawMenuBar (HWND hwnd)
    Redraws the menu bar of the specified main window.
  • MG_EXPORT int GUIAPI TrackMenuBar (HWND hwnd, int pos)
    Displays the specified submenu.
  • MG_EXPORT int GUIAPI TrackPopupMenu (HMENU hmnu, UINT uFlags, int x, int y, HWND hwnd)
    Displays and tracks a popup menu.
  • MG_EXPORT HMENU GUIAPI GetMenuBarItemRect (HWND hwnd, int pos, RECT *prc)
    Retrieves the rect of a menu bar item.
  • MG_EXPORT BOOL GUIAPI HiliteMenuBarItem (HWND hwnd, int pos, UINT flag)
    Draws the specified menubar item with 3D effect.
  • MG_EXPORT int GUIAPI GetMenuItemCount (HMENU hmnu)
    Determines the number of items in a menu.
  • MG_EXPORT int GUIAPI GetMenuItemID (HMENU hmnu, int pos)
    Retrieves the menu item identifier of a menu item at specified position in a menu.
  • MG_EXPORT int GUIAPI GetMenuItemInfo (HMENU hmnu, int item, UINT flag, PMENUITEMINFO pmii)
    Retrieves information about a menu item.
  • MG_EXPORT HMENU GUIAPI GetPopupSubMenu (HMENU hpppmnu)
    Retrieves the submenu of the specified popup menu.
  • MG_EXPORT HMENU GUIAPI StripPopupHead (HMENU hpppmnu)
    Strips the title of the popup menu.
  • MG_EXPORT HMENU GUIAPI GetSubMenu (HMENU hmnu, int pos)
    Retrieves the handle to the submenu activated by the specified menu item.
  • MG_EXPORT HMENU GUIAPI GetSystemMenu (HWND hwnd, BOOL flag)
    Allows the application to access the window menu (also known as the system menu) for copying and modifying.
  • MG_EXPORT UINT GUIAPI EnableMenuItem (HMENU hmnu, int item, UINT flag)
    Enables, disables, or grays the specified menu item.
  • MG_EXPORT int GUIAPI CheckMenuRadioItem (HMENU hmnu, int first, int last, int checkitem, UINT flag)
    Checks a specified menu item and makes it a radio item.
  • MG_EXPORT int GUIAPI SetMenuItemBitmaps (HMENU hmnu, int item, UINT flag, PBITMAP hBmpUnchecked, PBITMAP hBmpChecked)
    Associates the specified bitmap with a menu item.
  • MG_EXPORT int GUIAPI SetMenuItemInfo (HMENU hmnu, int item, UINT flag, PMENUITEMINFO pmii)
    Changes information about a menu item.
  • MG_EXPORT HWND GUIAPI CreateMainWindowIndirectParamEx (PDLGTEMPLATE pDlgTemplate, HWND hOwner, WNDPROC WndProc, LPARAM lParam, const char *werdr_name, WINDOW_ELEMENT_ATTR *we_attrs, const char *window_name, const char *layer_name)
    Uses a dialog template and other information to create a modeless main window and controls in it, and pass a parameter to the window procedure.
  • static HWND GUIAPI CreateMainWindowIndirectParam (PDLGTEMPLATE pDlgTemplate, HWND hOwner, WNDPROC WndProc, LPARAM lParam)
    A simplified version of CreateMainWindowIndirectParamEx.
  • static HWND GUIAPI CreateMainWindowIndirect (PDLGTEMPLATE pDlgTemplate, HWND hOwner, WNDPROC WndProc)
    A simplified version of CreateMainWindowIndirectParam.
  • MG_EXPORT BOOL GUIAPI DestroyMainWindowIndirect (HWND hMainWin)
    Destroys a main window created by CreateMainWindowIndirectParam.
  • MG_EXPORT int GUIAPI DialogBoxIndirectParamEx (PDLGTEMPLATE pDlgTemplate, HWND hOwner, WNDPROC DlgProc, LPARAM lParam, const char *werdr_name, WINDOW_ELEMENT_ATTR *we_attrs, const char *window_name, const char *layer_name)
    Creates a modal dialog box from a dialog box template in memory and other information.
  • static int GUIAPI DialogBoxIndirectParam (PDLGTEMPLATE pDlgTemplate, HWND hOwner, WNDPROC DlgProc, LPARAM lParam)
    A simplified version of DialogBoxIndirectParamEx.
  • MG_EXPORT BOOL GUIAPI EndDialog (HWND hDlg, int endCode)
    Destroys a modal dialog box, causing MiniGUI to end any processing for the dialog box.
  • MG_EXPORT void GUIAPI DestroyAllControls (HWND hWnd)
    Destroys all controls in a window.
  • MG_EXPORT HWND GUIAPI GetDlgDefPushButton (HWND hWnd)
    Gets the default push button control in a window.
  • MG_EXPORT int GUIAPI GetDlgCtrlID (HWND hwndCtl)
    Gets the integer identifier of a control.
  • MG_EXPORT HWND GUIAPI GetDlgItem (HWND hDlg, int nIDDlgItem)
    Retrives the handle to a control in a dialog box.
  • MG_EXPORT UINT GUIAPI GetDlgItemInt (HWND hDlg, int nIDDlgItem, BOOL *lpTranslated, BOOL bSigned)
    Translates the text of a control in a dialog box into an integer value.
  • MG_EXPORT int GUIAPI GetDlgItemText (HWND hDlg, int nIDDlgItem, char *lpString, int nMaxCount)
    Retrieves the title or text associated with a control in a dialog box.
  • MG_EXPORT char *GUIAPI GetDlgItemText2 (HWND hDlg, int id, int *lenPtr)
    Retrieves the title or text associated with a control in a dialog box.
  • MG_EXPORT HWND GUIAPI GetNextDlgGroupItem (HWND hDlg, HWND hCtl, BOOL bPrevious)
    Retrieves the handle to the first control in a group of controls that precedes (or follows) the specified control in a dialog box.
  • MG_EXPORT HWND GUIAPI GetNextDlgTabItem (HWND hDlg, HWND hCtl, BOOL bPrevious)
    Retrieves the handle to the first control that has the WS_TABSTOP style that precedes (or follows) the specified control.
  • MG_EXPORT int GUIAPI SendDlgItemMessage (HWND hDlg, int nIDDlgItem, int message, WPARAM wParam, LPARAM lParam)
    Sends a message to the specified control in a dialog box.
  • MG_EXPORT BOOL GUIAPI SetDlgItemInt (HWND hDlg, int nIDDlgItem, UINT uValue, BOOL bSigned)
    Sets the text of a control in a dialog box to the string representation of a specified integer value.
  • MG_EXPORT BOOL GUIAPI SetDlgItemText (HWND hDlg, int nIDDlgItem, const char *lpString)
    Sets the title or text of a control in a dialog box.
  • MG_EXPORT void GUIAPI CheckDlgButton (HWND hDlg, int nIDDlgItem, int nCheck)
    Changes the check status of a button control.
  • MG_EXPORT void GUIAPI CheckRadioButton (HWND hDlg, int idFirstButton, int idLastButton, int idCheckButton)
    Adds a check mark to (checks) a specified radio button in a group and removes a check mark from (clears) all other radio buttons in the group.
  • MG_EXPORT int GUIAPI IsDlgButtonChecked (HWND hDlg, int idButton)
    Determines whether a button control has a check mark next to it or whether a three-state button control is grayed, checked, or neither.
  • MG_EXPORT int GUIAPI MessageBox (HWND hParentWnd, const char *pszText, const char *pszCaption, DWORD dwStyle)
    Displays a message box within one, two, or three push buttons.
  • MG_EXPORT void GUIAPI MessageBeep (DWORD dwBeep)
    Makes a sound of beep.
  • MG_EXPORT int GUIAPI SetBitmapKeyColor (HDC hdc, PBITMAP bmp, Uint8 r, Uint8 g, Uint8 b)
    Set the bitmap color key.

Variables

  • MG_EXPORT WNDPROC __mg_def_proc [3]
    The default window callback procedure array.

Detailed Description

Author:
Wei Yongming <ymwei@minigui.org>
Date:
2002/01/26
This file includes windowing interfaces of MiniGUI.

    Copyright (C) 2002-2009 Feynman Software.
    Copyright (C) 1998-2002 Wei Yongming.

    All rights reserved by Feynman Software.

    This file is part of MiniGUI, a compact cross-platform Graphics
    User Interface (GUI) support system for real-time embedded systems.

Definition in file window.h.

Generated on Fri Dec 17 13:49:45 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: xvfb.h File Reference

include

xvfb.h File Reference

Go to the source code of this file.

Data Structures

  • struct _XVFBHeader
  • struct _XVFBKEYDATA
  • struct _XVFBMOUSEDATA
  • struct _XVFBEVENT
  • struct _XVFBPalEntry

Functions

  • MG_EXPORT XVFBHeader *GUIAPI xVFBAllocVirtualFrameBuffer (int width, int height, int depth, Uint32 Rmask, Uint32 Gmask, Uint32 Bmask, Uint32 Amask, BOOL MSBLeft)
    create virtual framebuffer
  • MG_EXPORT void GUIAPI xVFBFreeVirtualFrameBuffer (XVFBHeader *buf)
    free virtual framebuffer.
  • MG_EXPORT void GUIAPI xVFBDestroyEventBuffer (void *event_buf)
    destroy event circular buffer.
  • MG_EXPORT int GUIAPI xVFBNotifyNewEvent (const void *xvfb_event_buffer, XVFBEVENT *event)
    create event circular buffer.

Variables

  • MG_EXPORT void * __mg_rtos_xvfb_event_buffer
    shared memory header of x virtual framebuffer.

Detailed Description

Author:
Feynman Software
Date:
2007/10/25
This file includes global and miscellaneous interfaces of xVFB for MiniGUI.

    Copyright (C) 2002-2009 Feynman Software.
    Copyright (C) 1998-2002 Wei Yongming.

    All rights reserved by Feynman Software.

    This file is part of MiniGUI, a compact cross-platform Graphics
    User Interface (GUI) support system for real-time embedded systems.

Definition in file xvfb.h.

Function Documentation

XVFBHeader * xVFBAllocVirtualFrameBuffer | ( | int | width,
 |  | int | height,
 |  | int | depth,
 |  | Uint32 | Rmask,
 |  | Uint32 | Gmask,
 |  | Uint32 | Bmask,
 |  | Uint32 | Amask,
 |  | BOOL | MSBLeft
 | ) |  |

create virtual framebuffer

Parameters:
width | the width of virtual framebuffer
height | the height of virtual framebuffer
depth | the color depth of virtual framebuffer
Rmask | the pixel red color mask
Gmask | the pixel green color mask
Bmask | the pixel blue color mask
Amask | the pixel alpha mask
MSBLeft | The flag indicating the Most Significant Bits (MSB) \ is left when depth is less than 8.
Returns:
the header of virtual framebuffer

void GUIAPI xVFBDestroyEventBuffer ( void * event_buf )

destroy event circular buffer.

Parameters:
event_buf The pointer to event circular buffer.

void GUIAPI xVFBFreeVirtualFrameBuffer ( XVFBHeader * buf )

free virtual framebuffer.

Parameters:
buf The pointer to virtual framebuffer.

int xVFBNotifyNewEvent | ( | const void * | xvfb_event_buffer,
 |  | XVFBEVENT * | event
 | ) |  |

create event circular buffer.

put a event to event circular buffer

Parameters:
nr_events capability of the event buffer
Returns:
the address of event circular buffer.
Parameters:
xvfb_event_buffer | event circular buffer
event | event shall be put into xvfb_event_buffer
Returns:
  • 0 indicate the event has been put into buffer
  • 1 indicate the buffer is full
  • 2 the buffer has been distroyed (MiniGUI terminated).

Generated on Fri Dec 17 13:49:45 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- _ -

  • __mg_def_proc : window.h
  • __mg_rtos_xvfb_event_buffer : xvfb.h
  • _MINIGUI_VERSION_CODE : common.h
  • _VERSION_CODE : common.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: animation.h Source File

include » ctrl

animation.h

Go to the documentation of this file.
00001
00019 /*
00020  * $Id: animation.h 10865 2008-08-27 06:52:22Z wangjian $
00021  *
00022  *             MiniGUI for Linux/uClinux, eCos, uC/OS-II, VxWorks,
00023  *                     pSOS, ThreadX, NuCleus, OSE, and Win32.
00024  *
00025  *             Copyright (C) 2002-2008 Feynman Software.
00026  *             Copyright (C) 1998-2002 Wei Yongming.
00027  */
00028
00029 #ifndef EXT_ANIMATION_H
00030 #define EXT_ANIMATION_H
00031
00032
00033 #ifdef  __cplusplus
00034 extern "C" {
00035 #endif
00036
00048 typedef struct _ANIMATIONFRAME
00049 {
00059     int disposal;
00061     int off_x;
00063     int off_y;
00065     unsigned int width;
00067     unsigned int height;
00068
00070     unsigned int delay_time;
00072     HDC mem_dc;
00074     Uint8* bits;
00075
00077     struct _ANIMATIONFRAME* next;
00079     struct _ANIMATIONFRAME* prev;
00080 } ANIMATIONFRAME;
00081
00083 typedef struct _ANIMATION
00084 {
00086     unsigned int width;
00088     unsigned int height;
00089
00091     RGB bk;
00092
00094     int nr_frames;
00099     int time_unit;
00101     ANIMATIONFRAME* frames;
00102 } ANIMATION;
00103
00118 ANIMATION* CreateAnimationFromGIF89a (HDC hdc, MG_RWops* area);
00119
00134 MG_EXPORT ANIMATION* CreateAnimationFromGIF89aFile (HDC hdc, const char* file);
00135
00151 MG_EXPORT ANIMATION* CreateAnimationFromGIF89aMem (HDC hdc, const void* mem, int size);
00152
00165 MG_EXPORT void DestroyAnimation (ANIMATION* anim, BOOL free_it);
00166
00168 #define CTRL_ANIMATION                  ("Animation")
00169
00171 #define ANIMATION_OKAY                  0
00172
00173 #define ANIMATION_ERR                   1
00174
00206 #define ANS_AUTOLOOP                    0x0001L
00207
00212 #define ANS_SCALED                      0x0002L
00213
00218 #define ANS_FITTOANI                    0x0004L
00219
00243 #define ANM_SETANIMATION                0xF110
00244
00260 #define ANM_GETANIMATION                0xF111
00261
00279 #define ANM_STARTPLAY                   0xF112
00280
00297 #define ANM_PAUSE_RESUME                0xF113
00298
00316 #define ANM_STOPPLAY                    0xF114
00317
00318 #define ANM_MSGMAX                      0xF120
00319
00330 #define ANNC_CLICKED         1
00331
00336 #define ANNC_DBLCLK          2
00337
00344 #ifdef  __cplusplus
00345 }
00346 #endif
00347
00348 #endif /* EXT_ANIMATION_H */
00349
Generated on Fri Dec 17 13:49:40 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Structures

  • Alphabetical List
  • Data Structures
  • Data Fields

Data Structures

Here are the data structures with brief descriptions:
_ANIMATION
_ANIMATIONFRAME
_ARC
_BITMAP
_BLOCKHEAP
_CLIPRECT
_CLIPRGN
_CONTAINERINFO
_COOLBARITEMINFO
_CTRLDATA
_DESKTOPOPS
_DEVFONT
_DLGTEMPLATE
_DTFIRSTLINE
_ETC_S
_ETCSECTION
_FONTMETRICS
_GAL_Color
_GAL_Palette
_GAL_Rect
_GLYPHBITMAP
_GRIDCELLDATA
_GRIDCELLDATACHECKBOX
_GRIDCELLDATAHEADER
_GRIDCELLDATANUMBER
_GRIDCELLDATASELECTION
_GRIDCELLDATATEXT
_GRIDCELLS
_GRIDVIEWDATA
_HOOKINFO
_IME_TARGET_INFO
_IVITEMINFO
_LFRDR_TRACKBARINFO
_LFRDR_WINSTYLEINFO
_LFSCROLLBARINFO
_LISTBOXITEMINFO
_LOGFONT
_LVCOLUMN
_LVCUSTOMDRAWFUNCS
_LVFINDINFO
_LVITEM
_LVNM_NORMAL
_LVSORTDATA
_LVSUBITEM
_MAINWINCREATE
_MCCOLORINFO
_MENUBUTTONITEM
_MENUITEMINFO
_MG_RWops
_MSG
_MYBITMAP
_NTBINFO
_NTBITEMINFO
_POINT
_RECT
_RGB
_SCROLLBARDATA
_SCROLLINFO
_SCROLLVIEWITEMINFO
_SIZE
_SPININFO
_STIPPLE
_svitem_operations
_SYSTEMTIME
_TEXTPOSINFO
_TVITEMINFO
_WINDOW_ELEMENT_ATTR
_WINDOW_ELEMENT_RENDERER
_WINDOWINFO
_WNDCLASS
_WORDINFO
_XVFBEVENT
_XVFBHeader
_XVFBKEYDATA
_XVFBMOUSEDATA
_XVFBPalEntry
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: button.h Source File

include » ctrl

button.h

Go to the documentation of this file.
00001
00019 /*
00020  * $Id: button.h 10690 2008-08-18 09:32:47Z weiym $
00021  *
00022  *             MiniGUI for Linux/uClinux, eCos, uC/OS-II, VxWorks,
00023  *                     pSOS, ThreadX, NuCleus, OSE, and Win32.
00024  *
00025  *             Copyright (C) 2002-2008 Feynman Software.
00026  *             Copyright (C) 1999-2002 Wei Yongming.
00027  */
00028
00029 #ifndef _MGUI_CTRL_BUTTON_H
00030 #define _MGUI_CTRL_BUTTON_H
00031
00032
00033 #ifdef __cplusplus
00034 extern "C" {
00035 #endif  /* __cplusplus */
00036
00051 #define BTN_WIDTH_BORDER    4
00052
00057 #define CTRL_BUTTON         ("button")
00058
00070 #define BS_PUSHBUTTON       0x00000000L
00071
00083 #define BS_DEFPUSHBUTTON    0x00000001L
00084
00095 #define BS_CHECKBOX         0x00000002L
00096
00105 #define BS_AUTOCHECKBOX     0x00000003L
00106
00118 #define BS_RADIOBUTTON      0x00000004L
00119
00130 #define BS_AUTORADIOBUTTON  0x00000005L
00131
00141 #define BS_3STATE           0x00000006L
00142
00151 #define BS_AUTO3STATE       0x00000007L
00152 /* Not use */
00153 #define BS_GROUPBOX         0x00000008L
00154 /* Not use */
00155 #define BS_USERBUTTON       0x00000009L
00156
00157
00164 #define BS_OWNERDRAW        0x0000000AL
00165
00170 #define BS_TYPEMASK         0x0000000FL
00171
00176 #define BS_TEXT             0x00000000L
00177
00185 #define BS_LEFTTEXT         0x00000020L
00186
00191 #define BS_ICON             0x00000040L
00192
00197 #define BS_BITMAP           0x00000080L
00198
00202 #define BS_CONTENTMASK      0x000000F0L
00203
00212 #define BS_LEFT             0x00000100L
00213
00222 #define BS_RIGHT            0x00000200L
00223
00228 #define BS_CENTER           0x00000300L
00229
00234 #define BS_TOP              0x00000400L
00235
00240 #define BS_BOTTOM           0x00000800L
00241
00246 #define BS_VCENTER          0x00000C00L
00247
00252 #define BS_REALSIZEIMAGE    0x00000F00L
00253
00258 #define BS_ALIGNMASK        0x00000F00L
00259
00268 #define BS_PUSHLIKE         0x00001000L
00269
00277 #define BS_MULTLINE         0x00002000L
00278
00283 #define BS_NOTIFY           0x00004000L
00284
00289 #define BS_CHECKED          0x00004000L
00290
00295 #define BS_FLAT             0x00008000L
00296
00301 #define BS_NOBORDER         0x00010000L
00302
00308 #define BS_RIGHTBUTTON      BS_LEFTTEXT
00309
00322 #define BST_POSE_MASK        0x0003
00323
00328 #define BST_NORMAL      0x0000
00329
00334 #define BST_HILITE      0x0001
00335
00340 #define BST_PUSHED      0x0002
00341
00346 #define BST_DISABLE     0x0003
00347
00348
00354 #define BST_CHECK_MASK      0x000c
00355
00360 #define BST_UNCHECKED       0x0000
00361
00366 #define BST_CHECKED         0x0004
00367
00373 #define BST_INDETERMINATE   0x0008
00374
00379 #define BST_FOCUS           0x0010
00380
00409 #define BM_GETCHECK             0xF0F0
00410
00435 #define BM_SETCHECK             0xF0F1
00436
00454 #define BM_GETSTATE             0xF0F2
00455
00479 #define BM_SETSTATE             0xF0F3
00480
00501 #define BM_SETSTYLE             0xF0F4
00502
00516 #define BM_CLICK                0xF0F5
00517
00518
00535 #define BM_ENABLE               0xF0F6
00536
00561 #define BM_GETIMAGE             0xF0F7
00562
00563 #define BM_IMAGE_BITMAP         1
00564 #define BM_IMAGE_ICON           2
00565
00580 #define BM_SETIMAGE             0xF0F8
00581
00582 #define BM_MSGMAX               0xF100
00583
00595 #define BN_CLICKED          0
00596 #define BN_DOUBLECLICKED    1
00597
00601 #define BN_DBLCLK           BN_DOUBLECLICKED
00602
00608 #define BN_HILITE           2
00609
00615 #define BN_UNHILITE         3
00616
00621 #define BN_PUSHED           4
00622
00627 #define BN_UNPUSHED         5
00628
00634 #define BN_DISABLE          6
00635
00641 #define BN_ENABLE           7
00642
00647 #define BN_SETFOCUS         8
00648
00653 #define BN_KILLFOCUS        9
00654
00655 #define BN_PAINT            10   /* not supported */
00656
00663 #ifdef __cplusplus
00664 }
00665 #endif  /* __cplusplus */
00666
00667 #endif /* _MGUI_CTRL_BUTTON_H */
00668
Generated on Fri Dec 17 13:49:40 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Alphabetical List

  • Alphabetical List
  • Data Structures
  • Data Fields

Data Structure Index

_

_
_ETCSECTION _IVITEMINFO _MENUBUTTONITEM _STIPPLE
_ANIMATION _FONTMETRICS _LFRDR_TRACKBARINFO _MENUITEMINFO _svitem_operations
_ANIMATIONFRAME _GAL_Color _LFRDR_WINSTYLEINFO _MG_RWops _SYSTEMTIME
_ARC _GAL_Palette _LFSCROLLBARINFO _MSG _TEXTPOSINFO
_BITMAP _GAL_Rect _LISTBOXITEMINFO _MYBITMAP _TVITEMINFO
_BLOCKHEAP _GLYPHBITMAP _LOGFONT _NTBINFO _WINDOW_ELEMENT_ATTR
_CLIPRECT _GRIDCELLDATA _LVCOLUMN _NTBITEMINFO _WINDOW_ELEMENT_RENDERER
_CLIPRGN _GRIDCELLDATACHECKBOX _LVCUSTOMDRAWFUNCS _POINT _WINDOWINFO
_CONTAINERINFO _GRIDCELLDATAHEADER _LVFINDINFO _RECT _WNDCLASS
_COOLBARITEMINFO _GRIDCELLDATANUMBER _LVITEM _RGB _WORDINFO
_CTRLDATA _GRIDCELLDATASELECTION _LVNM_NORMAL _SCROLLBARDATA _XVFBEVENT
_DESKTOPOPS _GRIDCELLDATATEXT _LVSORTDATA _SCROLLINFO _XVFBHeader
_DEVFONT _GRIDCELLS _LVSUBITEM _SCROLLVIEWITEMINFO _XVFBKEYDATA
_DLGTEMPLATE _GRIDVIEWDATA _MAINWINCREATE _SIZE _XVFBMOUSEDATA
_DTFIRSTLINE _HOOKINFO _MCCOLORINFO _SPININFO _XVFBPalEntry
_ETC_S _IME_TARGET_INFO

_

Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: combobox.h Source File

include » ctrl

combobox.h

Go to the documentation of this file.
00001
00019 /*
00020  * $Id: combobox.h 10690 2008-08-18 09:32:47Z weiym $
00021  *
00022  *             MiniGUI for Linux/uClinux, eCos, uC/OS-II, VxWorks,
00023  *                     pSOS, ThreadX, NuCleus, OSE, and Win32.
00024  *
00025  *             Copyright (C) 2002-2008 Feynman Software.
00026  *             Copyright (C) 1999-2002 Wei Yongming.
00027  */
00028
00029 #ifndef _MGUI_CTRL_COMBOBOX_H
00030 #define _MGUI_CTRL_COMBOBOX_H
00031
00032
00033 #ifdef __cplusplus
00034 extern "C" {
00035 #endif  /* __cplusplus */
00036
00051 #define CTRL_COMBOBOX       ("combobox")
00052
00073 #define CBS_SIMPLE              0x0000L
00074
00083 #define CBS_AUTOSPIN            0x0001L
00084
00093 #define CBS_SPINLIST            0x0002L
00094
00108 #define CBS_DROPDOWNLIST        0x0003L
00109
00114 #define CBS_TYPEMASK            0x0007L
00115
00123 #define CBS_NOTIFY              0x0008L
00124
00129 #define CBS_SPINARROW_TOPBOTTOM 0x0010L
00130
00135 #define CBS_SPINARROW_LEFTRIGHT 0x0020L
00136
00142 #define CBS_AUTOHSCROLL         0x0040L
00143
00149 #define CBS_DISABLENOSCROLL     0x0080L
00150
00155 #define CBS_SORT                0x0100L
00156
00161 #define CBS_AUTOLOOP            0x0200L
00162
00167 #define CBS_EDITNOBORDER        0x0400L
00168
00173 #define CBS_EDITBASELINE        0x0800L
00174
00179 #define CBS_READONLY            0x1000L
00180
00185 #define CBS_UPPERCASE           0x2000L
00186
00191 #define CBS_LOWERCASE           0x4000L
00192
00197 #define CBS_AUTOFOCUS           0x8000L
00198
00230 #define CB_GETEDITSEL               0xF140
00231
00251 #define CB_LIMITTEXT                0xF141
00252
00275 #define CB_SETEDITSEL               0xF142
00276
00300 #define CB_ADDSTRING                0xF143
00301
00321 #define CB_DELETESTRING             0xF144
00322
00323 #define CB_DIR                      0xF145
00324
00341 #define CB_GETCOUNT                 0xF146
00342
00360 #define CB_GETCURSEL                0xF147
00361
00385 #define CB_GETLBTEXT                0xF148
00386
00406 #define CB_GETLBTEXTLEN             0xF149
00407
00434 #define CB_INSERTSTRING             0xF14A
00435
00452 #define CB_RESETCONTENT             0xF14B
00453
00477 #define CB_FINDSTRING               0xF14C
00478
00479 #define CB_SELECTSTRING             0xF14D
00480
00497 #define CB_SETCURSEL                0xF14E
00498
00499 #define CB_SHOWDROPDOWN             0xF14F
00500
00522 #define CB_GETITEMADDDATA           0xF150
00523
00548 #define CB_SETITEMADDDATA              0xF151
00549
00564 #define CB_GETDROPPEDCONTROLRECT    0xF152
00565
00585 #define CB_SETITEMHEIGHT            0xF153
00586
00600 #define CB_GETITEMHEIGHT            0xF154
00601
00602 #define CB_SETEXTENDEDUI            0xF155
00603 #define CB_GETEXTENDEDUI            0xF156
00604
00619 #define CB_GETDROPPEDSTATE          0xF157
00620
00642 #define CB_FINDSTRINGEXACT          0xF158
00643
00644 #define CB_SETLOCALE                0xF159
00645 #define CB_GETLOCALE                0xF15A
00646 #define CB_GETTOPINDEX              0xF15b
00647 #define CB_SETTOPINDEX              0xF15c
00648 #define CB_GETHORIZONTALEXTENT      0xF15d
00649 #define CB_SETHORIZONTALEXTENT      0xF15e
00650 #define CB_GETDROPPEDWIDTH          0xF15f
00651 #define CB_SETDROPPEDWIDTH          0xF160
00652 #define CB_INITSTORAGE              0xF161
00653
00671 #define CB_SETSPINFORMAT             0xF162
00672
00691 #define CB_SETSPINRANGE             0xF163
00692
00711 #define CB_GETSPINRANGE             0xF164
00712
00729 #define CB_SETSPINVALUE             0xF165
00730
00744 #define CB_GETSPINVALUE             0xF166
00745
00764 #define CB_SETSPINPACE              0xF167
00765
00784 #define CB_GETSPINPACE              0xF168
00785
00803 #define CB_SPIN                     0xF170
00804
00822 #define CB_FASTSPIN                 0xF171
00823
00855 #define CB_SETSTRCMPFUNC            0xF172
00856
00879 #define CB_GETCHILDREN              0xF173
00880
00881 #define CB_MSGMAX                   0xF180
00882
00886 #define CB_OKAY                 LB_OKAY
00887
00888 #define CB_ERR                  LB_ERR
00889
00890 #define CB_ERRSPACE             LB_ERRSPACE
00891
00897 #define CBN_ERRSPACE            255
00898
00906 #define CBN_SELCHANGE           1
00907
00915 #define CBN_DBLCLK              2
00916
00921 #define CBN_SETFOCUS            3
00922
00927 #define CBN_KILLFOCUS           4
00928
00936 #define CBN_EDITCHANGE          5
00937
00938 #define CBN_EDITUPDATE          6
00939
00944 #define CBN_DROPDOWN            7
00945
00950 #define CBN_CLOSEUP             8
00951
00959 #define CBN_SELECTOK            9
00960
00968 #define CBN_SELECTCANCEL        10
00969
00976 #define CBN_CLICKED        11
00977
00984 #ifdef __cplusplus
00985 }
00986 #endif  /* __cplusplus */
00987
00988 #endif /* _MGUI_CTRL_COMBOBOX_H */
00989
Generated on Fri Dec 17 13:49:40 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: common.h Source File

include

common.h

Go to the documentation of this file.
00001
00022 /*
00023  * $Id: common.h 13649 2010-11-26 10:01:36Z xwyan $
00024  *
00025  *             MiniGUI for Linux/uClinux, eCos, uC/OS-II, VxWorks,
00026  *                     pSOS, ThreadX, NuCleus, OSE, and Win32.
00027  *
00028  *             Copyright (C) 2002-2009 Feynman Software.
00029  *             Copyright (C) 1998-2002 Wei Yongming.
00030  *
00031  *             The definitions of some data types and byte order macros
00032  *             borrowed from LGPL'ed SDL by Sam Lantinga.
00033  *
00034  *             Fix point math routines come from Allegro (a gift software)
00035  *             by Shawn Hargreaves and others.
00036  */
00037
00038 #ifndef _MGUI_COMMON_H
00039 #define _MGUI_COMMON_H
00040
00041 #ifndef MINIGUI_MAJOR_VERSION
00042 #  ifdef __MINIGUI_LIB__
00043 #    ifdef _FOR_DATANG
00044 #      ifdef WIN32
00045 #        include <config-win32/mgconfig.h>
00046 #      elif defined (__THREADX__)
00047 #        include "config-threadx/mgconfig.h"
00048 #      elif defined (__NUCLEUS__)
00049 #        include "config-nucleus/mgconfig.h"
00050 #      endif
00051 #    else
00052 #      if  defined(__CMAKE_PROJECT__) || defined(WIN32)
00053 #        include "mgconfig.h"
00054 #      else
00055 #        include "../mgconfig.h"
00056 #      endif
00057 #    endif
00058 #  else
00059 #    include "mgconfig.h"
00060 #    undef PACKAGE_BUGREPORT
00061 #    undef PACKAGE_NAME
00062 #    undef PACKAGE_STRING
00063 #    undef PACKAGE_TARNAME
00064 #    undef PACKAGE_VERSION
00065 #  endif
00066 #endif
00067
00088 #define _VERSION_CODE(major, minor, micro)  (((major)<<16) | ((minor)<<8) | (micro))
00089
00096 #define _MINIGUI_VERSION_CODE \
00097         ((MINIGUI_MAJOR_VERSION << 16) | (MINIGUI_MINOR_VERSION << 8) | MINIGUI_MICRO_VERSION)
00098
00110 typedef unsigned char   Uint8;
00115 typedef signed char     Sint8;
00120 typedef unsigned short  Uint16;
00125 typedef signed short    Sint16;
00130 typedef unsigned int    Uint32;
00135 typedef signed int      Sint32;
00136
00137 /* Figure out how to support 64-bit datatypes */
00138 #if !defined(__STRICT_ANSI__)
00139 #if defined(__GNUC__)
00140 #define MGUI_HAS_64BIT_TYPE     long long
00141 #endif
00142 #if defined(__CC_ARM)
00143 #define MGUI_HAS_64BIT_TYPE     long long
00144 #endif
00145 #if defined(_MSC_VER)
00146 #define MGUI_HAS_64BIT_TYPE __int64
00147 #endif
00148 #endif /* !__STRICT_ANSI__ */
00149
00150 /* The 64-bit datatype isn't supported on all platforms */
00151 #ifdef MGUI_HAS_64BIT_TYPE
00152
00159 typedef unsigned MGUI_HAS_64BIT_TYPE Uint64;
00166 typedef signed MGUI_HAS_64BIT_TYPE Sint64;
00167 #else
00168 /* This is really just a hack to prevent the compiler from complaining */
00169 typedef struct {
00170         Uint32 hi;
00171         Uint32 lo;
00172 } Uint64, Sint64;
00173 #endif
00174
00175 /* Make sure the types really have the right sizes */
00176 #define MGUI_COMPILE_TIME_ASSERT(name, x)               \
00177        typedef int MGUI_dummy_ ## name[(x) * 2 - 1]
00178
00179 MGUI_COMPILE_TIME_ASSERT(uint8, sizeof(Uint8) == 1);
00180 MGUI_COMPILE_TIME_ASSERT(sint8, sizeof(Sint8) == 1);
00181 MGUI_COMPILE_TIME_ASSERT(uint16, sizeof(Uint16) == 2);
00182 MGUI_COMPILE_TIME_ASSERT(sint16, sizeof(Sint16) == 2);
00183 MGUI_COMPILE_TIME_ASSERT(uint32, sizeof(Uint32) == 4);
00184 MGUI_COMPILE_TIME_ASSERT(sint32, sizeof(Sint32) == 4);
00185 MGUI_COMPILE_TIME_ASSERT(uint64, sizeof(Uint64) == 8);
00186 MGUI_COMPILE_TIME_ASSERT(sint64, sizeof(Sint64) == 8);
00187
00188 #undef MGUI_COMPILE_TIME_ASSERT
00189
00201 #define MGUI_LIL_ENDIAN  1234
00202
00206 #define MGUI_BIG_ENDIAN  4321
00207
00208 /* Pardon the mess, I'm trying to determine the endianness of this host.
00209  *    I'm doing it by preprocessor defines rather than some sort of configure
00210  *    script so that application code can use this too.  The "right" way would
00211  *    be to dynamically generate this file on install, but that's a lot of work.
00212  */
00213
00231 #if  defined(__i386__) || defined(__ia64__) || \
00232     (defined(__alpha__) || defined(__alpha)) || \
00233      defined(__arm__) || \
00234     (defined(__CC_ARM) && !defined(__BIG_ENDIAN)) || \
00235     (defined(__mips__) && defined(__MIPSEL__)) || \
00236      defined(__LITTLE_ENDIAN__) || \
00237     defined(WIN32)
00238 #define MGUI_BYTEORDER   MGUI_LIL_ENDIAN
00239 #else
00240 #define MGUI_BYTEORDER   MGUI_BIG_ENDIAN
00241 #endif
00242
00254 #ifndef _HAVE_TYPE_BOOL
00255 #ifndef BOOL
00256 typedef int BOOL;
00257 #endif
00258 #endif
00259
00263 #ifndef FALSE
00264     #define FALSE       0
00265 #endif
00266
00270 #ifndef TRUE
00271     #define TRUE        1
00272 #endif
00273
00278 #ifndef NULL
00279 #   ifdef __cplusplus
00280 #       define NULL            (0)
00281 #   else
00282 #       define NULL            ((void *)0)
00283 #   endif
00284 #endif
00285
00286 #define GUIAPI
00287
00288 #if !defined(__NODLL__) && (defined (WIN32) || defined (__NUCLEUS_MNT__))
00289   #if defined(__MINIGUI_LIB__) && !defined(__MGEXT_LIB__)
00290   #define MG_EXPORT       __declspec(dllexport)
00291   #else
00292   #define MG_EXPORT       __declspec(dllimport)
00293   #endif
00294   #if defined(__MGEXT_LIB__)
00295   #define MGEXT_EXPORT    __declspec(dllexport)
00296   #else
00297   #define MGEXT_EXPORT    __declspec(dllimport)
00298   #endif
00299 #else
00300   #define MG_EXPORT
00301   #define MGEXT_EXPORT
00302 #endif
00303
00315 typedef unsigned int GHANDLE;
00320 typedef unsigned int HWND;
00325 typedef unsigned int HDC;
00330 typedef unsigned int HPALETTE;
00335 typedef unsigned int HCURSOR;
00340 typedef unsigned int HICON;
00345 typedef unsigned int HMENU;
00350 typedef unsigned int HACCEL;
00355 typedef unsigned int HDLG;
00360 typedef unsigned int HHOOK;
00361
00373 #ifndef _HAVE_TYPE_BYTE
00374 typedef unsigned char   BYTE;
00375 #endif
00376
00380 typedef signed char     SBYTE;
00381
00386 #ifndef _HAVE_TYPE_WORD
00387 typedef unsigned short  WORD;
00388 #endif
00389
00394 typedef signed short    SWORD;
00395
00400 #ifndef _HAVE_TYPE_DWORD
00401 typedef unsigned long   DWORD;
00402 #endif
00403
00408 typedef signed long     SDWORD;
00409
00414 #ifndef _HAVE_TYPE_UINT
00415 typedef unsigned int    UINT;
00416 #endif
00417
00422 #ifndef _HAVE_TYPE_LONG
00423 typedef long            LONG;
00424 #endif
00425
00430 typedef unsigned int    WPARAM;
00431
00436 typedef unsigned long   LPARAM;
00437
00444 #define LOBYTE(w)           ((BYTE)(w))
00445
00451 #define HIBYTE(w)           ((BYTE)(((WORD)(w) >> 8) & 0xFF))
00452
00457 #define MAKEWORD(low, high) ((WORD)(((BYTE)(low)) | (((WORD)((BYTE)(high))) << 8)))
00458
00465 #define LOWORD(l)           ((WORD)(DWORD)(l))
00466
00472 #define HIWORD(l)           ((WORD)((((DWORD)(l)) >> 16) & 0xFFFF))
00473
00480 #define LOSWORD(l)          ((SWORD)(DWORD)(l))
00481
00487 #define HISWORD(l)          ((SWORD)((((DWORD)(l)) >> 16) & 0xFFFF))
00488
00493 #define MAKELONG(low, high) ((DWORD)(((WORD)(low)) | (((DWORD)((WORD)(high))) << 16)))
00494
00503 #define GetRValue(rgba)      ((BYTE)(rgba))
00504
00512 #define GetGValue(rgba)      ((BYTE)(((DWORD)(rgba)) >> 8))
00513
00521 #define GetBValue(rgba)      ((BYTE)((DWORD)(rgba) >> 16))
00522
00530 #define GetAValue(rgba)      ((BYTE)((DWORD)(rgba) >> 24))
00531
00542 #define MakeRGBA(r, g, b, a)    (((DWORD)((BYTE)(r))) | ((DWORD)((BYTE)(g)) << 8) \
00543                 | ((DWORD)((BYTE)(b)) << 16) | ((DWORD)((BYTE)(a)) << 24))
00544
00554 #define MakeRGB(r, g, b)    (((DWORD)((BYTE)(r))) | ((DWORD)((BYTE)(g)) << 8) \
00555                 | ((DWORD)((BYTE)(b)) << 16))
00556
00561 typedef DWORD RGBCOLOR;
00562
00572 typedef struct _RECT
00573 {
00577     int left;
00581     int top;
00585     int right;
00589     int bottom;
00590 } RECT;
00597 typedef RECT* PRECT;
00598
00603 typedef struct _POINT
00604 {
00608     int x;
00612     int y;
00613 } POINT;
00620 typedef POINT* PPOINT;
00621
00626 typedef struct _SIZE
00627 {
00631     int cx;
00635     int cy;
00636 } SIZE;
00643 typedef SIZE* PSIZE;
00644
00649 typedef struct _RGB
00650 {
00654     BYTE r;
00658     BYTE g;
00662     BYTE b;
00666     BYTE a;
00667 } RGB;
00668
00675 typedef RGB* PRGB;
00676
00689 typedef Sint8       gal_sint8;
00696 typedef Uint8       gal_uint8;
00697
00704 typedef Sint16      gal_sint16;
00711 typedef Uint16      gal_uint16;
00712
00719 typedef Sint32      gal_sint32;
00726 typedef Uint32      gal_uint32;
00727
00732 typedef signed int      gal_sint;
00737 typedef unsigned int    gal_uint;
00738
00743 typedef Uint32          gal_pixel;
00748 typedef Uint32          gal_attr;
00749
00754 typedef long fixed;
00755
00760 typedef struct _GAL_Color
00761 {
00765     gal_uint8 r;
00769     gal_uint8 g;
00773     gal_uint8 b;
00777     gal_uint8 a;
00778 } GAL_Color;
00779
00784 typedef struct _GAL_Palette
00785 {
00789     int        ncolors;
00793     GAL_Color* colors;
00794 } GAL_Palette;
00795
00800 typedef struct _GAL_Rect {
00804     Sint32      x, y;
00808     Sint32      w, h;
00809 } GAL_Rect;
00810
00833 #define MGUI_NR_KEYS                    255
00834
00847 #ifndef NR_KEYS
00848 #define NR_KEYS                         128
00849 #endif
00850
00867 #define SCANCODE_USER                   (NR_KEYS + 1)
00868
00869 #define SCANCODE_ESCAPE                 1
00870
00871 #define SCANCODE_1                      2
00872 #define SCANCODE_2                      3
00873 #define SCANCODE_3                      4
00874 #define SCANCODE_4                      5
00875 #define SCANCODE_5                      6
00876 #define SCANCODE_6                      7
00877 #define SCANCODE_7                      8
00878 #define SCANCODE_8                      9
00879 #define SCANCODE_9                      10
00880 #define SCANCODE_0                      11
00881
00882 #define SCANCODE_MINUS                  12
00883 #define SCANCODE_EQUAL                  13
00884
00885 #define SCANCODE_BACKSPACE              14
00886 #define SCANCODE_TAB                    15
00887
00888 #define SCANCODE_Q                      16
00889 #define SCANCODE_W                      17
00890 #define SCANCODE_E                      18
00891 #define SCANCODE_R                      19
00892 #define SCANCODE_T                      20
00893 #define SCANCODE_Y                      21
00894 #define SCANCODE_U                      22
00895 #define SCANCODE_I                      23
00896 #define SCANCODE_O                      24
00897 #define SCANCODE_P                      25
00898 #define SCANCODE_BRACKET_LEFT           26
00899 #define SCANCODE_BRACKET_RIGHT          27
00900
00901 #define SCANCODE_ENTER                  28
00902
00903 #define SCANCODE_LEFTCONTROL            29
00904
00905 #define SCANCODE_A                      30
00906 #define SCANCODE_S                      31
00907 #define SCANCODE_D                      32
00908 #define SCANCODE_F                      33
00909 #define SCANCODE_G                      34
00910 #define SCANCODE_H                      35
00911 #define SCANCODE_J                      36
00912 #define SCANCODE_K                      37
00913 #define SCANCODE_L                      38
00914 #define SCANCODE_SEMICOLON              39
00915 #define SCANCODE_APOSTROPHE             40
00916 #define SCANCODE_GRAVE                  41
00917
00918 #define SCANCODE_LEFTSHIFT              42
00919 #define SCANCODE_BACKSLASH              43
00920
00921 #define SCANCODE_Z                      44
00922 #define SCANCODE_X                      45
00923 #define SCANCODE_C                      46
00924 #define SCANCODE_V                      47
00925 #define SCANCODE_B                      48
00926 #define SCANCODE_N                      49
00927 #define SCANCODE_M                      50
00928 #define SCANCODE_COMMA                  51
00929 #define SCANCODE_PERIOD                 52
00930 #define SCANCODE_SLASH                  53
00931
00932 #define SCANCODE_RIGHTSHIFT             54
00933 #define SCANCODE_KEYPADMULTIPLY         55
00934
00935 #define SCANCODE_LEFTALT                56
00936 #define SCANCODE_SPACE                  57
00937 #define SCANCODE_CAPSLOCK               58
00938
00939 #define SCANCODE_F1                     59
00940 #define SCANCODE_F2                     60
00941 #define SCANCODE_F3                     61
00942 #define SCANCODE_F4                     62
00943 #define SCANCODE_F5                     63
00944 #define SCANCODE_F6                     64
00945 #define SCANCODE_F7                     65
00946 #define SCANCODE_F8                     66
00947 #define SCANCODE_F9                     67
00948 #define SCANCODE_F10                    68
00949
00950 #define SCANCODE_NUMLOCK                69
00951 #define SCANCODE_SCROLLLOCK             70
00952
00953 #define SCANCODE_KEYPAD7                71
00954 #define SCANCODE_CURSORUPLEFT           71
00955 #define SCANCODE_KEYPAD8                72
00956 #define SCANCODE_CURSORUP               72
00957 #define SCANCODE_KEYPAD9                73
00958 #define SCANCODE_CURSORUPRIGHT          73
00959 #define SCANCODE_KEYPADMINUS            74
00960 #define SCANCODE_KEYPAD4                75
00961 #define SCANCODE_CURSORLEFT             75
00962 #define SCANCODE_KEYPAD5                76
00963 #define SCANCODE_KEYPAD6                77
00964 #define SCANCODE_CURSORRIGHT            77
00965 #define SCANCODE_KEYPADPLUS             78
00966 #define SCANCODE_KEYPAD1                79
00967 #define SCANCODE_CURSORDOWNLEFT         79
00968 #define SCANCODE_KEYPAD2                80
00969 #define SCANCODE_CURSORDOWN             80
00970 #define SCANCODE_KEYPAD3                81
00971 #define SCANCODE_CURSORDOWNRIGHT        81
00972 #define SCANCODE_KEYPAD0                82
00973 #define SCANCODE_KEYPADPERIOD           83
00974
00975 #define SCANCODE_LESS                   86
00976
00977 #define SCANCODE_F11                    87
00978 #define SCANCODE_F12                    88
00979
00980 #define SCANCODE_KEYPADENTER            96
00981 #define SCANCODE_RIGHTCONTROL           97
00982 #define SCANCODE_CONTROL                97
00983 #define SCANCODE_KEYPADDIVIDE           98
00984 #define SCANCODE_PRINTSCREEN            99
00985 #define SCANCODE_RIGHTALT               100
00986 #define SCANCODE_BREAK                  101    /* Beware: is 119     */
00987 #define SCANCODE_BREAK_ALTERNATIVE      119    /* on some keyboards! */
00988
00989 #define SCANCODE_HOME                   102
00990 #define SCANCODE_CURSORBLOCKUP          103    /* Cursor key block */
00991 #define SCANCODE_PAGEUP                 104
00992 #define SCANCODE_CURSORBLOCKLEFT        105    /* Cursor key block */
00993 #define SCANCODE_CURSORBLOCKRIGHT       106    /* Cursor key block */
00994 #define SCANCODE_END                    107
00995 #define SCANCODE_CURSORBLOCKDOWN        108    /* Cursor key block */
00996 #define SCANCODE_PAGEDOWN               109
00997 #define SCANCODE_INSERT                 110
00998 #define SCANCODE_REMOVE                 111
00999
01000 #define SCANCODE_PAUSE                  119
01001
01002 #define SCANCODE_POWER                  120
01003 #define SCANCODE_SLEEP                  121
01004 #define SCANCODE_WAKEUP                 122
01005
01006 #define SCANCODE_LEFTWIN                125
01007 #define SCANCODE_RIGHTWIN               126
01008 #define SCANCODE_MENU                   127
01009
01010 #define SCANCODE_LEFTBUTTON             0x1000
01011 #define SCANCODE_RIGHTBUTTON            0x2000
01012 #define SCANCODE_MIDDLBUTTON            0x4000
01013
01034 #define KS_REPEATED                     0x00000800
01035
01056 #define KS_CAPTURED                     0x00000400
01057
01064 #define KS_IMEPOST                      0x00000200
01065
01086 #define KS_CAPSLOCK                     0x00000100
01087
01095 #define KS_NUMLOCK                      0x00000080
01096
01104 #define KS_SCROLLLOCK                   0x00000040
01105
01113 #define KS_LEFTCTRL                     0x00000020
01114
01122 #define KS_RIGHTCTRL                    0x00000010
01123
01131 #define KS_CTRL                         0x00000030
01132
01140 #define KS_LEFTALT                      0x00000008
01141
01149 #define KS_RIGHTALT                     0x00000004
01150
01158 #define KS_ALT                          0x0000000C
01159
01167 #define KS_LEFTSHIFT                    0x00000002
01168
01176 #define KS_RIGHTSHIFT                   0x00000001
01177
01185 #define KS_SHIFT                        0x00000003
01186
01191 #define MASK_KS_SHIFTKEYS               0x00000FFF
01192
01200 #define KS_LEFTBUTTON                   0x00001000
01201
01209 #define KS_RIGHTBUTTON                  0x00002000
01210
01218 #define KS_MIDDLBUTTON                  0x00004000
01219
01224 #define MASK_KS_BUTTONS                 0x0000F000
01225
01236 #define ERR_OK                   0
01237
01242 #define ERR_INV_HWND            -1
01243
01248 #define ERR_QUEUE_FULL          -2
01249
01254 #define ERR_INVALID_HANDLE      -3
01255
01260 #define ERR_INVALID_HMENU       -4
01261
01266 #define ERR_INVALID_POS         -5
01267
01272 #define ERR_INVALID_ID          -6
01273
01278 #define ERR_RES_ALLOCATION      -7
01279
01284 #define ERR_CTRLCLASS_INVNAME   -8
01285
01290 #define ERR_CTRLCLASS_INVLEN    -9
01291
01296 #define ERR_CTRLCLASS_MEM       -10
01297
01302 #define ERR_CTRLCLASS_INUSE     -11
01303
01308 #define ERR_ALREADY_EXIST       -12
01309
01314 #define ERR_NO_MATCH            -13
01315
01320 #define ERR_BAD_OWNER           -14
01321
01326 #define ERR_IME_TOOMUCHIMEWND   -15
01327
01332 #define ERR_IME_NOSUCHIMEWND    -16
01333
01338 #define ERR_IME_NOIMEWND        -17
01339
01344 #define ERR_CONFIG_FILE         -18
01345
01350 #define ERR_FILE_IO             -19
01351
01356 #define ERR_GFX_ENGINE          -20
01357
01362 #define ERR_INPUT_ENGINE        -21
01363
01368 #define ERR_NO_ENGINE           -22
01369
01374 #define ERR_INVALID_ARGS        -23
01375
01386 #define TABLESIZE(table)    (sizeof(table)/sizeof(table[0]))
01387
01388 /* MAX/MIN/ABS macors */
01393 #ifndef MAX
01394 #define MAX(x, y)           (((x) > (y))?(x):(y))
01395 #endif
01396
01400 #ifndef MIN
01401 #define MIN(x, y)           (((x) < (y))?(x):(y))
01402 #endif
01403
01407 #ifndef ABS
01408 #define ABS(x)              (((x)<0) ? -(x) : (x))
01409 #endif
01410
01411 /* Commonly used definitions */
01412 #if !defined(__NOUNIX__) || defined (__ECOS__)
01413 #include <limits.h>
01414 #endif
01415
01416 #ifndef PATH_MAX
01417     #define PATH_MAX    256
01418 #endif
01419
01420 #ifndef NAME_MAX
01421     #define NAME_MAX    64
01422 #endif
01423
01424
01430 #ifndef MAX_PATH
01431 #   define MAX_PATH        PATH_MAX
01432 #endif
01433
01439 #ifndef MAX_NAME
01440 #define MAX_NAME        NAME_MAX
01441 #endif
01442
01447 #ifdef __cplusplus
01448 extern "C" {
01449 #endif
01450
01451 #ifndef HAVE_TIME
01452 typedef unsigned int time_t;
01453
01454 struct tm {
01455     int    tm_sec;   /* seconds [0,61] */
01456     int    tm_min;   /* minutes [0,59] */
01457     int    tm_hour;  /* hour [0,23] */
01458     int    tm_mday;  /* day of month [1,31] */
01459     int    tm_mon;   /* month of year [0,11] */
01460     int    tm_year;  /* years since 1900 */
01461     int    tm_wday;  /* day of week [0,6] (Sunday = 0) */
01462     int    tm_yday;  /* day of year [0,365] */
01463     int    tm_isdst; /* daylight savings flag */
01464 };
01465 #endif
01466
01467 #if defined (__THREADX__) && defined (__TARGET_VFANVIL__)
01468 #include  "fx_api.h"
01469 #include  "tx_api.h"
01470 #include  "os_type.h"
01471 #include  "os_file_api.h"
01472
01473 #define fopen   tp_fopen
01474 #define fclose  tp_fclose
01475 #define fwrite  tp_fwrite
01476 #define fread   tp_fread
01477 #define fseek   tp_fseek
01478 #define feof    tp_feof
01479
01480
01481 #undef assert
01482 #define _HAVE_ASSERT 1
01483
01484 #define assert(e) do {              \
01485                          e;      \
01486                      } while(0);
01487
01488 #undef stdin
01489 #undef stdout
01490 #undef stderr
01491
01492 #define stdin ((FILE*)0)
01493 #define stdout ((FILE*)1)
01494 #define stderr ((FILE*)2)
01495 void Comm_Lock_Screen (void);
01496 void Comm_Unlock_Screen (void);
01497
01498 #endif
01499
01500 #ifdef __UCOSII__
01501
01502 /* use our own implementation of strdup */
01503 #undef HAVE_STRDUP
01504 #undef strdup
01505 #define strdup own_strdup
01506
01507 #endif /* __UCOSII__ */
01508
01509 #ifndef HAVE_STRDUP
01510 MG_EXPORT char *strdup(const char *s);
01511 #endif
01512
01513 #ifndef HAVE_STRCASECMP
01514 MG_EXPORT int strcasecmp(const char *s1, const char *s2);
01515 #endif
01516
01517 #ifndef HAVE_STRNCASECMP
01518 MG_EXPORT int strncasecmp(const char *s1, const char *s2, unsigned int n);
01519 #endif
01520
01521 #ifdef _MGUSE_OWN_MALLOC
01522
01542 int init_minigui_malloc (unsigned char* heap, unsigned int heap_size,
01543                 int (*lock_heap) (void), int (*unlock_heap) (void));
01544
01545 #define USE_DL_PREFIX
01546
01547 #include "own_malloc.h"
01548
01549 /* wrappers for malloc functions */
01550 #define calloc      dlcalloc
01551 #define free        dlfree
01552 #define malloc      dlmalloc
01553 #define memalign    dlmemalign
01554 #define realloc     dlrealloc
01555 #define valloc      dlvalloc
01556
01557 #endif
01558
01559 /* Do not use the alloca of ARMCC */
01560 #if defined(__CC_ARM)
01561 #   undef HAVE_ALLOCA
01562 #   undef HAVE_ALLOCA_H
01563 #endif
01564
01565 #ifdef HAVE_ALLOCA_H
01566 #   include <alloca.h>
01567 #   define ALLOCATE_LOCAL(size)    alloca((int)(size))
01568 #   define DEALLOCATE_LOCAL(ptr)   /* as nothing */
01569 #else
01570 #   define ALLOCATE_LOCAL(size)    malloc((int)(size))
01571 #   define DEALLOCATE_LOCAL(ptr)   free(ptr)
01572 #endif
01573
01574 #ifdef _MGUSE_OWN_STDIO
01575
01588 int init_minigui_printf (int (*output_char) (int ch),
01589                 int (*input_char) (void));
01590
01591 #if defined (__UCOSII__) || defined (__VXWORKS__) || defined (__NUCLEUS__) || defined (__PSOS__)
01592 #   undef _PRINTF_FLOATING_POINT
01593 #   undef _SCANF_FLOATING_POINT
01594 #else
01595 #   ifdef HAVE_MATH_H
01596 #       define _PRINTF_FLOATING_POINT      1
01597 #       define _SCANF_FLOATING_POINT       1
01598 #   endif
01599 #endif
01600
01601 #ifdef WIN32
01602 #   include <float.h>
01603 #   define isnan        _isnan
01604 #   define finite       _finite
01605 #endif
01606
01607 #undef _I18N_MB_REQUIRED
01608
01609 #if defined(__VXWORKS__) || defined(WIN32) || defined (__NUCLEUS_MNT__) || defined (__PSOS__)
01610   #define _MGUSE_OWN_SNPRINTF
01611   #define _MGUSE_OWN_VSNPRINTF
01612   #define _MGUSE_OWN_VFNPRINTF
01613 #else
01614   #define _MGUSE_OWN_PRINTF
01615   #define _MGUSE_OWN_FPRINTF
01616   #define _MGUSE_OWN_SPRINTF
01617   #define _MGUSE_OWN_FNPRINTF
01618   #define _MGUSE_OWN_SNPRINTF
01619   #define _MGUSE_OWN_VPRINTF
01620   #define _MGUSE_OWN_VFPRINTF
01621   #define _MGUSE_OWN_VSPRINTF
01622   #define _MGUSE_OWN_VFNPRINTF
01623   #define _MGUSE_OWN_VSNPRINTF
01624   #define _MGUSE_OWN_SCANF
01625   #define _MGUSE_OWN_FSCANF
01626   #define _MGUSE_OWN_SSCANF
01627   #define _MGUSE_OWN_VSCANF
01628   #define _MGUSE_OWN_VFSCANF
01629   #define _MGUSE_OWN_VSSCANF
01630 #endif
01631
01632 #include "own_stdio.h"
01633
01634 /* wrappers for stdio functions */
01635 #ifdef _MGUSE_OWN_PRINTF
01636   #define printf      own_printf
01637 #endif
01638
01639 #ifdef _MGUSE_OWN_FPRINTF
01640   #define fprintf     own_fprintf
01641 #endif
01642
01643 #ifdef _MGUSE_OWN_SPRINTF
01644   #define sprintf     own_sprintf
01645 #endif
01646
01647 #ifdef _MGUSE_OWN_FNPRINTF
01648   #define fnprintf    own_fnprintf
01649 #endif
01650
01651 #ifdef _MGUSE_OWN_SNPRINTF
01652   #define snprintf    own_snprintf
01653 #endif
01654
01655 #ifdef _MGUSE_OWN_VPRINTF
01656   #define vprintf     own_vprintf
01657 #endif
01658
01659 #ifdef _MGUSE_OWN_VFPRINTF
01660   #define vfprintf    own_vfprintf
01661 #endif
01662
01663 #ifdef _MGUSE_OWN_VSPRINTF
01664   #define vsprintf    own_vsprintf
01665 #endif
01666
01667 #ifdef _MGUSE_OWN_VFNPRINTF
01668   #define vfnprintf   own_vfnprintf
01669 #endif
01670
01671 #ifdef _MGUSE_OWN_VSNPRINTF
01672   #define vsnprintf   own_vsnprintf
01673 #endif
01674
01675 #ifdef _MGUSE_OWN_SCANF
01676   #define scanf       own_scanf
01677 #endif
01678
01679 #ifdef _MGUSE_OWN_FSCANF
01680   #define fscanf      own_fscanf
01681 #endif
01682
01683 #ifdef _MGUSE_OWN_SSCANF
01684   #define sscanf      own_sscanf
01685 #endif
01686
01687 #ifdef _MGUSE_OWN_VSCANF
01688   #define vscanf      own_vscanf
01689 #endif
01690
01691 #ifdef _MGUSE_OWN_VFSCANF
01692   #define vfscanf     own_vfscanf
01693 #endif
01694
01695 #ifdef _MGUSE_OWN_VSSCANF
01696   #define vsscanf     own_vsscanf
01697 #endif
01698
01699 #endif /* _MGUSE_OWN_STDIO */
01700
01701 #if defined(__GNUC__)
01702 #ifdef _DEBUG
01703 #   define _MG_PRINTF(fmt...) fprintf (stderr, fmt)
01704 #else
01705 #   define _MG_PRINTF(fmt...)
01706 #endif
01707 #else /* __GNUC__ */
01708 #include <stdio.h>
01709 #include <stdarg.h>
01710
01711 static inline void _MG_PRINTF(const char* fmt, ...)
01712 {
01713 #ifdef _DEBUG
01714     va_list ap;
01715     va_start(ap, fmt);
01716     vfprintf(stderr, fmt, ap);
01717     fprintf(stderr, "\n");
01718     va_end(ap);
01719 #endif
01720 }
01721 #endif /* __GNUC__ */
01722
01723 #ifdef _MGRM_THREADS
01724
01725 #ifdef _MGUSE_OWN_PTHREAD
01726
01727 #define MAIN_PTH_MIN_STACK_SIZE (1024)
01728 #define MAIN_PTH_DEF_STACK_SIZE (1024*4)
01729
01753 int start_minigui_pthread (int (* pth_entry) (int argc, const char* argv []),
01754                 int argc, const char* argv[],
01755                 char* stack_base, unsigned int stack_size);
01756
01757 #include <errno.h>
01758
01759 #ifndef ESRCH
01760 # define ESRCH      3
01761 #endif
01762
01763 #ifndef EAGAIN
01764 # define EAGAIN     11
01765 #endif
01766
01767 #ifndef ENOMEM
01768 # define ENOMEM     12
01769 #endif
01770
01771 #ifndef EBUSY
01772 # define EBUSY      16
01773 #endif
01774
01775 #ifndef EINVAL
01776 # define EINVAL     22
01777 #endif
01778
01779 #ifndef EDEADLK
01780 # define EDEADLK    35
01781 #endif
01782
01783 #ifndef ENOSYS
01784 # define ENOSYS     38
01785 #endif
01786
01787 #ifndef ENOTSUP
01788 # define ENOTSUP    95
01789 #endif
01790
01791 #ifdef __VXWORKS__
01792
01793 #define pthread_create vxworks_pthread_create
01794 #define pthread_self   vxworks_pthread_self
01795 #define pthread_equal  vxworks_pthread_equal
01796 #define pthread_exit   vxworks_pthread_exit
01797 #define pthread_join   vxworks_pthread_join
01798 #define pthread_detach vxworks_pthread_detach
01799 #define pthread_cancel vxworks_pthread_cancel
01800 #define pthread_once   vxworks_pthread_once
01801 #define pthread_key_create vxworks_pthread_key_create
01802 #define pthread_key_delete vxworks_pthread_key_delete
01803 #define pthread_setspecific vxworks_pthread_setspecific
01804 #define pthread_getspecific vxworks_pthread_getspecific
01805 #define pthread_setcancelstate vxworks_pthread_setcancelstate
01806 #define pthread_setcanceltype vxworks_pthread_setcanceltype
01807 #define pthread_testcancel vxworks_pthread_testcancel
01808
01809 #define pthread_attr_init    vxworks_pthread_attr_init
01810 #define pthread_attr_destroy vxworks_pthread_attr_destroy
01811 #define pthread_attr_setdetachstate vxworks_pthread_attr_setdetachstate
01812 #define pthread_attr_getdetachstate vxworks_pthread_attr_getdetachstate
01813 #define pthread_attr_setscope vxworks_pthread_attr_setscope
01814 #define pthread_attr_getscope vxworks_pthread_attr_getscope
01815 #define pthread_attr_setinheritsched vxworks_pthread_attr_setinheritsched
01816 #define pthread_attr_getinheritsched vxworks_pthread_attr_getinheritsched
01817 #define pthread_attr_setschedpolicy vxworks_pthread_attr_setschedpolicy
01818 #define pthread_attr_getschedpolicy vxworks_pthread_attr_getschedpolicy
01819 #define pthread_attr_setschedparam vxworks_pthread_attr_setschedparam
01820 #define pthread_attr_getschedparam vxworks_pthread_attr_getschedparam
01821 #define pthread_attr_setstackaddr vxworks_pthread_attr_setstackaddr
01822 #define pthread_attr_getstackaddr vxworks_pthread_attr_getstackaddr
01823 #define pthread_attr_setstacksize vxworks_pthread_attr_setstacksize
01824 #define pthread_attr_getstacksize vxworks_pthread_attr_getstacksize
01825 #define pthread_setschedparam vxworks_pthread_setschedparam
01826 #define pthread_getschedparam vxworks_pthread_getschedparam
01827
01828 #define pthread_mutex_init  vxworks_pthread_mutex_init
01829 #define pthread_mutex_destroy vxworks_pthread_mutex_destroy
01830 #define pthread_mutex_lock  vxworks_pthread_mutex_lock
01831 #define pthread_mutex_unlock vxworks_pthread_mutex_unlock
01832 #define pthread_mutex_trylock vxworks_pthread_mutex_trylock
01833 #define pthread_mutexattr_init vxworks_pthread_mutexattr_init
01834 #define pthread_mutexattr_destroy vxworks_pthread_mutexattr_destroy
01835 #define pthread_mutexattr_setpriorityinherit vxworks_pthread_mutexattr_setpriorityinherit
01836 #define pthread_mutexattr_getpriorityinherit vxworks_pthread_mutexattr_getpriorityinherit
01837
01838 #ifdef _MGUSE_OWN_SEMAPHORE
01839
01840 #define sem_t vxworks_sem_t
01841
01842 #define sem_init vxworks_sem_init
01843 #define sem_destroy vxworks_sem_destroy
01844 #define sem_wait vxworks_sem_wait
01845 #define sem_trywait vxworks_sem_trywait
01846 #define sem_post vxworks_sem_post
01847 #define sem_getvalue vxworks_sem_getvalue
01848
01849 #endif /* _MGUSE_OWN_SEMAPHORE */
01850
01851 #endif /* __VXWORKS__ */
01852
01853 #ifdef __MINIGUI_LIB__
01854
01855 #ifdef __UCOSII__
01856   #include "ucos2_pthread.h"
01857   #include "ucos2_semaphore.h"
01858 #elif defined (__THREADX__)
01859   #include "threadx_pthread.h"
01860   #include "threadx_semaphore.h"
01861 #elif defined (__NUCLEUS__)
01862   #include "nucleus_pthread.h"
01863   #include "nucleus_semaphore.h"
01864 #elif defined (__VXWORKS__)
01865   #include "vxworks_pthread.h"
01866   #ifdef _MGUSE_OWN_SEMAPHORE
01867     #include "vxworks_semaphore.h"
01868   #else
01869     #include "semaphore.h"
01870   #endif
01871 #elif defined (__OSE__)
01872   #include "pthread.h"
01873   #include "ose_semaphore.h"
01874 #elif defined (__PSOS__)
01875   #include "psos_pthread.h"
01876   #include "psos_semaphore.h"
01877 #elif defined (WIN32)
01878   #include "win32_pthread.h"
01879   #include "win32_semaphore.h"
01880 #else
01881 #error No own pthread implementation for this OS!
01882 #endif
01883 #else
01884 #include <pthread.h>
01885 #include <semaphore.h>
01886 #endif /* __MINIGUI_LIB__ */
01887
01888 #else /* _MGUSE_OWN_PTHREAD */
01889
01890 #include <pthread.h>
01891 #include <semaphore.h>
01892
01893 #endif /* !_MGUSE_OWN_PTHREAD */
01894
01895 #ifdef __DARWIN__
01896
01897 #define _USE_SEM_ON_SYSVIPC     1
01898
01899 #endif
01900
01901 #if defined (_USE_MUTEX_ON_SYSVIPC) || defined (_USE_SEM_ON_SYSVIPC)
01902
01903 int _sysvipc_mutex_sem_init (void);
01904 int _sysvipc_mutex_sem_term (void);
01905
01906 #endif
01907
01908 #ifdef _USE_MUTEX_ON_SYSVIPC
01909
01910 #define pthread_mutex_t _sysvipc_pthread_mutex_t
01911 #define pthread_mutexattr_t _sysvipc_pthread_mutexattr_t
01912
01913 #define pthread_mutexattr_init _sysvipc_pthread_mutexattr_init
01914 #define pthread_mutexattr_destroy _sysvipc_pthread_mutexattr_destroy
01915 #define pthread_mutexattr_settype _sysvipc_pthread_mutexattr_settype
01916 #define pthread_mutexattr_gettype _sysvipc_pthread_mutexattr_gettype
01917
01918 #define pthread_init _sysvipc_pthread_init
01919 #define pthread_mutex_init _sysvipc_pthread_mutex_init
01920 #define pthread_mutex_destroy _sysvipc_pthread_mutex_destroy
01921 #define pthread_mutex_lock _sysvipc_pthread_mutex_lock
01922 #define pthread_mutex_trylock _sysvipc_pthread_mutex_trylock
01923 #define pthread_mutex_unlock _sysvipc_pthread_mutex_unlock
01924
01925 typedef struct
01926 {
01927     int kind;
01928     int semid;
01929     int sem_num;
01930     int locked_times;
01931 } pthread_mutex_t;
01932
01933 #define SYSVIPC_PTHREAD_MUTEX_FAST_NP         0
01934 #define SYSVIPC_PTHREAD_MUTEX_RECURSIVE_NP    1
01935 #define SYSVIPC_PTHREAD_MUTEX_ERRORCHECK_NP   2
01936
01937 typedef struct
01938 {
01939     int kind;
01940 } pthread_mutexattr_t;
01941
01942 int pthread_mutexattr_init (pthread_mutexattr_t *attr);
01943 int pthread_mutexattr_destroy (pthread_mutexattr_t *attr);
01944 int pthread_mutexattr_settype (pthread_mutexattr_t *attr, int type);
01945 int pthread_mutexattr_gettype (const pthread_mutexattr_t *attr, int* type);
01946
01947 int pthread_mutex_init (pthread_mutex_t *mutex,
01948                                 const pthread_mutexattr_t *mutex_attr);
01949
01950 int pthread_mutex_destroy (pthread_mutex_t *mutex);
01951
01952 int pthread_mutex_lock (pthread_mutex_t *mutex);
01953 int pthread_mutex_trylock (pthread_mutex_t *mutex);
01954 int pthread_mutex_unlock (pthread_mutex_t *mutex);
01955
01956 #endif /* _USE_MUTEX_ON_SYSVIPC */
01957
01958 #ifdef _USE_SEM_ON_SYSVIPC
01959
01960 #define sem_t _sysvipc_sem_t
01961
01962 #define sem_init _sysvipc_sem_init
01963 #define sem_destroy _sysvipc_sem_destroy
01964 #define sem_wait _sysvipc_sem_wait
01965 #define sem_trywait _sysvipc_sem_trywait
01966 #define sem_post _sysvipc_sem_post
01967 #define sem_getvalue _sysvipc_sem_getvalue
01968
01969 #define SYSVIPC_SEM_VALUE_MAX   USHRT_MAX
01970
01971 /*-----------------------------------------------------------------------------
01972 ** Semaphore object definition
01973 */
01974
01975 typedef struct
01976 {
01977     int semid;
01978     int sem_num;
01979 } sem_t;
01980
01981 int sem_init (sem_t *sem, int pshared, unsigned int value);
01982 int sem_destroy (sem_t *sem);
01983 int sem_wait (sem_t *sem);
01984 int sem_trywait (sem_t *sem);
01985 int sem_post (sem_t *sem);
01986 int sem_getvalue (sem_t *sem, int *sval);
01987
01988 #endif /* _USE_SEM_ON_SYSVIPC */
01989
01990 #endif /* _MGRM_THREADS */
01991
01992 #ifdef __cplusplus
01993 }  /* end of extern "C" */
01994 #endif
01995
01996 #endif /* _MGUI_COMMON_H */
01997
Generated on Fri Dec 17 13:49:40 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: control.h Source File

include

control.h

Go to the documentation of this file.
00001
00021 /*
00022  * $Id: control.h 11349 2009-03-02 05:00:43Z weiym $
00023  *
00024  *             MiniGUI for Linux/uClinux, eCos, uC/OS-II, VxWorks,
00025  *                     pSOS, ThreadX, NuCleus, OSE, and Win32.
00026  *
00027  *             Copyright (C) 2002-2009 Feynman Software.
00028  *             Copyright (C) 1999-2002 Wei Yongming.
00029  */
00030
00031 #ifndef _MGUI_CONTROL_H
00032 #define _MGUI_CONTROL_H
00033
00034 #ifdef __cplusplus
00035 extern "C" {
00036 #endif  /* __cplusplus */
00037
00038 #include "ctrl/ctrlhelper.h"
00039
00045 /* NOTE: control messages start from 0xF000 to 0xFFFF */
00046 #define MSG_FIRSTCTRLMSG    0xF000
00047 #define MSG_LASTCTRLMSG     0xFFFF
00048
00051 #ifdef _MGCTRL_STATIC
00052 #include "ctrl/static.h"
00053 #endif /* _MGCTRL_STATIC */
00054
00055 #ifdef _MGCTRL_BUTTON
00056 #include "ctrl/button.h"
00057 #endif /* _MGCTRL_BUTTON */
00058
00059 #if defined(_MGCTRL_SLEDIT) || defined(_MGCTRL_MLEDIT)
00060 #include "ctrl/edit.h"
00061 #endif /* _MGCTRL_EDIT || _MGCTRL_MEDIT */
00062
00063 #ifdef _MGCTRL_PROGRESSBAR
00064 #include "ctrl/progressbar.h"
00065 #endif /* _MGCTRL_PROGRESSBAR */
00066
00067 #ifdef _MGCTRL_LISTBOX
00068 #include "ctrl/listbox.h"
00069 #endif /* _MGCTRL_LISTBOX */
00070
00071 #ifdef _MGCTRL_PROPSHEET
00072 #include "ctrl/propsheet.h"
00073 #endif /* _MGCTRL_PROPSHEET*/
00074
00075 #ifdef _MGCTRL_COMBOBOX
00076 #include "ctrl/combobox.h"
00077 #endif /* _MGCTRL_COMBOBOX */
00078
00079 #ifdef _MGCTRL_NEWTOOLBAR
00080 #include "ctrl/newtoolbar.h"
00081 #endif /* _MGCTRL_NEWTOOLBAR */
00082
00083 #ifdef _MGCTRL_MENUBUTTON
00084 #include "ctrl/menubutton.h"
00085 #endif /* _MGCTRL_MENUBUTTON */
00086
00087 #ifdef _MGCTRL_TRACKBAR
00088 #include "ctrl/trackbar.h"
00089 #endif /* _MGCTRL_TRACKBAR */
00090
00091 #ifdef _MGCTRL_SCROLLVIEW
00092 #include "ctrl/scrollview.h"
00093 #endif /* _MGCTRL_SCROLLVIEW */
00094
00095 #ifdef _MGCTRL_SCROLLBAR
00096 #include "ctrl/scrollbar.h"
00097 #endif /* _MGCTRL_SCROLLBAR */
00098
00099 #ifdef _MGCTRL_TEXTEDIT
00100 #include "ctrl/textedit.h"
00101 #endif /* _MGCTRL_TEXTEDIT */
00102
00103 #ifdef _MGCTRL_SPINBOX
00104 #include "ctrl/spinbox.h"
00105 #endif /* _MGCTRL_SPINBOX */
00106
00107 #ifdef _MGCTRL_MONTHCAL
00108 #include "ctrl/monthcal.h"
00109 #endif /* _MGCTRL_MONTHCAL */
00110
00111 #ifdef _MGCTRL_COOLBAR
00112 #include "ctrl/coolbar.h"
00113 #endif /* _CTRL_COOLBAR */
00114
00115 #ifdef _MGCTRL_LISTVIEW
00116 #include "ctrl/listview.h"
00117 #endif  /* _MGCTRL_LISTVIEW */
00118
00119 #ifdef _MGCTRL_TREEVIEW
00120 #include "ctrl/treeview.h"
00121 #endif /* _MGCTRL_TREEVIEW */
00122
00123 #ifdef _MGCTRL_GRIDVIEW
00124 #include "ctrl/gridview.h"
00125 #endif /* _MGCTRL_GRIDVIEW */
00126
00127 #ifdef _MGCTRL_ICONVIEW
00128 #include "ctrl/iconview.h"
00129 #endif  /* _MGCTRL_ICONVIEW */
00130
00131 #ifdef _MGCTRL_ANIMATION
00132 #include "ctrl/animation.h"
00133 #endif  /* _MGCTRL_ANIMATION */
00134
00135 #ifdef __cplusplus
00136 }
00137 #endif  /* __cplusplus */
00138
00139 #endif /* _MGUI_CONTROL_H */
00140
Generated on Fri Dec 17 13:49:40 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: coolbar.h Source File

include » ctrl

coolbar.h

Go to the documentation of this file.
00001
00019 /*
00020  * $Id: coolbar.h 10690 2008-08-18 09:32:47Z weiym $
00021  *
00022  *             MiniGUI for Linux/uClinux, eCos, uC/OS-II, VxWorks,
00023  *                     pSOS, ThreadX, NuCleus, OSE, and Win32.
00024  *
00025  *             Copyright (C) 2002-2008 Feynman Software.
00026  *             Copyright (C) 1998-2002 Wei Yongming.
00027  */
00028
00029 #ifndef EXT_COOLBAR_H
00030 #define EXT_COOLBAR_H
00031
00032
00033 #ifdef  __cplusplus
00034 extern "C" {
00035 #endif
00036
00051 #define CTRL_COOLBAR            ("CoolBar")
00052
00053 #define TYPE_BARITEM            1
00054 #define TYPE_BMPITEM            2
00055 #define TYPE_TEXTITEM           3
00056
00058 typedef struct _COOLBARITEMINFO
00059 {
00061     int insPos;
00062
00068     int id;
00069
00079     int ItemType;
00080
00084     PBITMAP Bmp;
00085
00089     const char *ItemHint;
00090
00094     const char *Caption;
00095
00097     DWORD dwAddData;
00098 } COOLBARITEMINFO;
00099
00104 typedef COOLBARITEMINFO *PCOOLBARITEMINFO;
00105
00115 #define CBS_BMP_16X16           0x0000
00116
00121 #define CBS_BMP_32X32           0x0001
00122
00138 #define CBS_BMP_CUSTOM          0x0002
00139
00153 #define CBS_USEBKBMP            0x0004
00154
00179 #define CBM_ADDITEM             0xFE00
00180
00199 #define CBM_ENABLE              0xFE01
00200
00206 #ifdef  __cplusplus
00207 }
00208 #endif
00209
00210 #endif /* EXT_COOLBAR_H */
00211
Generated on Fri Dec 17 13:49:40 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: ctrlhelper.h Source File

include » ctrl

ctrlhelper.h

Go to the documentation of this file.
00001
00019 /*
00020  * $Id: ctrlhelper.h 10829 2008-08-26 07:47:17Z weiym $
00021  *
00022  *             MiniGUI for Linux/uClinux, eCos, uC/OS-II, VxWorks,
00023  *                     pSOS, ThreadX, NuCleus, OSE, and Win32.
00024  *
00025  *             Copyright (C) 2002-2008 Feynman Software.
00026  *             Copyright (C) 1999-2002 Wei Yongming.
00027  */
00028
00029 #ifndef _MGUI_CTRL_CTRLHELPER_H
00030 #define _MGUI_CTRL_CTRLHELPER_H
00031
00032
00033 #ifdef __cplusplus
00034 extern "C" {
00035 #endif  /* __cplusplus */
00036
00056 typedef enum
00057 {
00061   SB_POLICY_ALWAYS,
00065   SB_POLICY_AUTOMATIC,
00068   SB_POLICY_NEVER
00069 } SBPolicyType;
00070
00071 #define DF_3DBOX_NORMAL     0x0000
00072 #define DF_3DBOX_PRESSED    0x0001
00073 #define DF_3DBOX_STATEMASK  0x000F
00074 #define DF_3DBOX_NOTFILL    0x0000
00075 #define DF_3DBOX_FILL       0x0010
00076
00091 MG_EXPORT void GUIAPI DisabledTextOutEx (HDC hdc, HWND hwnd, int x, int y, const char* szText);
00092
00116 MG_EXPORT HWND CreateToolTipWin (HWND hParentWnd, int x, int y,
00117                 int timeout_ms, const char* text, ...);
00118
00137 MG_EXPORT void ResetToolTipWin (HWND hwnd, int x, int y,
00138                 const char* text, ...);
00139
00151 MG_EXPORT void DestroyToolTipWin (HWND hwnd);
00152
00179 MG_EXPORT void GUIAPI NotifyParentEx (HWND hwnd, int id, int code, DWORD add_data);
00180
00195 #define NotifyParent(hwnd, id, code) \
00196                 NotifyParentEx(hwnd, id, code, 0)
00197
00208 typedef int (*STRCMP) (const char* s1, const char* s2, size_t n);
00209
00210 MG_EXPORT int GUIAPI
00211 DefaultPageProc (HWND hWnd, int message, WPARAM wParam, LPARAM lParam);
00212
00219 #ifdef __cplusplus
00220 }
00221 #endif  /* __cplusplus */
00222
00223 #endif /* _MGUI_CTRL_CTRLHELPER_H */
00224
Generated on Fri Dec 17 13:49:40 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: customial.h Source File

include

customial.h

00001 /*
00002 ** $Id: customial.h 11349 2009-03-02 05:00:43Z weiym $
00003 **
00004 ** custom.h:. the head file for Custom IAL Engine.
00005 **
00006 ** Copyright (C) 2007 ~ 2009 Feynman Software.
00007 **
00008 ** Created by Wei YongMing, 2007/06/06
00009 */
00010
00011 #ifndef GUI_IAL_CUSTOM_H
00012     #define GUI_IAL_CUSTOM_H
00013
00014 #ifdef __cplusplus
00015 extern "C" {
00016 #endif  /* __cplusplus */
00017
00018
00019 #define IAL_MOUSE_LEFTBUTTON    1
00020 #define IAL_MOUSE_RIGHTBUTTON   2
00021 #define IAL_MOUSE_MIDDLEBUTTON  4
00022 #define IAL_MOUSE_FOURTHBUTTON  8
00023 #define IAL_MOUSE_FIFTHBUTTON   16
00024 #define IAL_MOUSE_SIXTHBUTTON   32
00025 #define IAL_MOUSE_RESETBUTTON   64
00026
00027 #define IAL_MOUSEEVENT          1
00028 #define IAL_KEYEVENT            2
00029
00030 typedef struct tagINPUT
00031 {
00032     char*   id;
00033
00034     // Initialization and termination
00035     BOOL (*init_input) (struct tagINPUT *input, const char* mdev, const char* mtype);
00036     void (*term_input) (void);
00037
00038     // Mouse operations
00039     int  (*update_mouse) (void);
00040     void (*get_mouse_xy) (int* x, int* y);
00041     void (*set_mouse_xy) (int x, int y);
00042     int  (*get_mouse_button) (void);
00043     void (*set_mouse_range) (int minx, int miny, int maxx, int maxy);
00044     void (*suspend_mouse) (void);
00045     int (*resume_mouse) (void);
00046
00047     // Keyboard operations
00048     int  (*update_keyboard) (void);
00049     const char* (*get_keyboard_state) (void);
00050     void (*suspend_keyboard) (void);
00051     int (*resume_keyboard) (void);
00052     void (*set_leds) (unsigned int leds);
00053
00054     // Event
00055     int (*wait_event) (int which, int maxfd, fd_set *in, fd_set *out,
00056             fd_set *except, struct timeval *timeout);
00057
00058     char mdev [MAX_PATH + 1];
00059 }INPUT;
00060
00061 #ifdef _MGIAL_CUSTOM
00062 extern BOOL InitCustomInput (INPUT* input, const char* mdev, const char* mtype);
00063 extern void TermCustomInput (void);
00064 #endif
00065
00066 #ifdef __cplusplus
00067 }
00068 #endif  /* __cplusplus */
00069
00070 #endif  /* GUI_IAL_CUSTOM_H */
00071
00072
Generated on Fri Dec 17 13:49:40 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: include/ctrl/ Directory Reference

include » ctrl

ctrl Directory Reference

Files

  • file animation.h [code]
  • file button.h [code]
  • file combobox.h [code]
  • file coolbar.h [code]
  • file ctrlhelper.h [code]
  • file edit.h [code]
  • file gridview.h [code]
  • file iconview.h [code]
  • file listbox.h [code]
  • file listview.h [code]
  • file menubutton.h [code]
  • file monthcal.h [code]
  • file newtoolbar.h [code]
  • file progressbar.h [code]
  • file propsheet.h [code]
  • file scrollbar.h [code]
  • file scrollview.h [code]
  • file spinbox.h [code]
  • file static.h [code]
  • file textedit.h [code]
  • file trackbar.h [code]
  • file treeview.h [code]
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: include/ Directory Reference

include

include Directory Reference

Directories

  • directory ctrl

Files

  • file common.h [code]
  • file control.h [code]
  • file customial.h [code]
  • file endianrw.h [code]
  • file fixedmath.h [code]
  • file gdi.h [code]
  • file minigui.h [code]
  • file window.h [code]
  • file xvfb.h [code]
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Directory Hierarchy

Directories

This directory hierarchy is sorted roughly, but not completely, alphabetically:
  • include
    • ctrl
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: edit.h Source File

include » ctrl

edit.h

Go to the documentation of this file.
00001
00019 /*
00020  * $Id: edit.h 13516 2010-09-29 07:52:02Z humingming $
00021  *
00022  *             MiniGUI for Linux/uClinux, eCos, uC/OS-II, VxWorks,
00023  *                     pSOS, ThreadX, NuCleus, OSE, and Win32.
00024  *
00025  *             Copyright (C) 2002-2008 Feynman Software.
00026  *             Copyright (C) 1999-2002 Wei Yongming.
00027  */
00028
00029 #ifndef _MGUI_CTRL_EDIT_H
00030 #define _MGUI_CTRL_EDIT_H
00031
00032
00033 #ifdef __cplusplus
00034 extern "C" {
00035 #endif  /* __cplusplus */
00036
00054 #define CTRL_EDIT           ("edit")
00055
00063 #define CTRL_SLEDIT         ("sledit")
00064
00072 #define CTRL_BIDISLEDIT     ("bidisledit")
00073
00081 #define CTRL_MLEDIT         ("mledit")
00082
00090 #define CTRL_MEDIT          ("medit")
00091
00101 #define ES_LEFT             0x00000000L
00102
00107 #define ES_CENTER           0x00000001L
00108
00113 #define ES_RIGHT            0x00000002L
00114
00119 #define ES_MULTILINE        0x00000004L
00120
00125 #define ES_UPPERCASE        0x00000008L
00126
00131 #define ES_LOWERCASE        0x00000010L
00132
00137 #define ES_PASSWORD         0x00000020L
00138
00143 #define ES_AUTOVSCROLL      0x00000040L
00144
00149 #define ES_AUTOHSCROLL      0x00000080L
00150
00155 #define ES_NOHIDESEL        0x00000100L
00156
00161 #define ES_AUTOSELECT       0x00000400L
00162 //#define ES_OEMCONVERT       0x00000400L
00163
00168 #define ES_READONLY         0x00000800L
00169
00174 #define ES_BASELINE         0x00001000L
00175
00180 #define ES_AUTOWRAP         0x00002000L
00181
00186 #define ES_TITLE            0x00004000L
00187
00192 #define ES_TIP              0x00008000L
00193
00220 #define EM_GETSEL               0xF0B0
00221
00249 #define EM_SETSEL               0xF0B1
00250
00255 #define EM_SETSELPOS            EM_SETSEL
00256
00261 #define EM_SETSELECTION         EM_SETSEL
00262
00274 #define EM_SELECTALL              0xF0B2
00275
00298 #define EM_GETSELPOS              0xF0B3
00299
00316 #define EM_INSERTCBTEXT           0xF0B4
00317
00331 #define EM_COPYTOCB               0xF0B5
00332
00346 #define EM_CUTTOCB               0xF0B6
00347
00366 #define EM_SETLFDISPCHAR          0xF0B7
00367
00385 #define EM_SETLINESEP             0xF0B8
00386
00387 /* #define EM_GETRECT              0xF0B2 */
00388 /* #define EM_SETRECT              0xF0B3 */
00389 /* #define EM_SETRECTNP            0xF0B4 */
00390 /* #define EM_SCROLL               0xF0B5 */
00391
00414 #define EM_GETCARETPOS          0xF0B9
00415
00438 #define EM_SETCARETPOS          0xF0BA
00439
00444 #define EM_SETINSERTION         EM_SETCARETPOS
00445
00446 /* #define EM_SCROLLCARET          0xF0B9 */
00447 /* #define EM_GETMODIFY            0xF0BA */
00448 /* #define EM_SETMODIFY            0xF0BB */
00449
00464 #define EM_GETLINECOUNT         0xF0BC
00465
00480 #define EM_GETLINEHEIGHT        0xF0BD
00481
00496 #define EM_SETLINEHEIGHT        0xF0BE
00497
00498
00499 /*#define EM_LINEINDEX            0xF0BD */
00500 /*#define EM_GETTHUMB             0xF0BE */
00501
00502 /* internal used now */
00508 #define EM_LINESCROLL           0xF0BF
00509
00528 #define EM_INSERTTEXT           0xF0C0
00529
00530 /* Not use */
00536 #define EM_LINELENGTH           0xF0C1
00537
00538 /* Not use */
00544 #define EM_REPLACESEL           0xF0C2
00545
00550 #define EM_GETMAXLIMIT            0xF0C3
00551
00552 /* Not use */
00558 #define EM_GETLINE              0xF0C4
00559
00574 #define EM_LIMITTEXT            0xF0C5
00575
00587 #define EM_REDO                 0xF0C6
00588 /*#define EM_CANUNDO              0xF0C6 */
00589
00601 #define EM_UNDO                 0xF0C7
00602
00603 /* Not use */
00609 #define EM_FMTLINES             0xF0C8
00610
00611 /* Not use */
00617 #define EM_LINEFROMCHAR         0xF0C9
00618
00619 /* Not use */
00625 #define EM_SETTABSTOPS          0xF0CB
00626
00640 #define EM_SETPASSWORDCHAR      0xF0CC
00641
00642 /* Not use */
00643 #define EM_EMPTYUNDOBUFFER      0xF0CD
00644 /* Not use */
00645 #define EM_GETFIRSTVISIBLELINE  0xF0CE
00646
00665 #define EM_SETREADONLY          0xF0CF
00666
00680 typedef int (*ED_DRAWSEL_FUNC) (HWND, HDC, int, int, const char*, int, int);
00681
00682
00697 #define EM_SETDRAWSELECTFUNC    0xF0D0
00698
00716 #define EM_SETGETCARETWIDTHFUNC 0xF0D1
00717
00718 /*
00719 #define EM_SETWORDBREAKPROC     0xF0D0
00720 #define EM_GETWORDBREAKPROC     0xF0D1
00721 */
00722
00737 #define EM_GETPASSWORDCHAR      0xF0D2
00738
00743 #define EM_SETLIMITTEXT         EM_LIMITTEXT
00744
00749 #define ED_CARETSHAPE_LINE      0
00750
00755 #define ED_CARETSHAPE_BLOCK     1
00756
00774 #define EM_CHANGECARETSHAPE     0xF0D3
00775
00780 #define EM_REFRESHCARET         0xF0D4
00781
00799 #define EM_ENABLECARET          0xF0D5
00800
00808 #define EM_GETLIMITTEXT         0xF0D6
00809
00810 /*
00811  * \def EM_SETMARGINS
00812  * \brief Set the margins of edit control
00813  *
00814  * \code
00815  * EM_SETMARGINS
00816  *
00817  * const RECT *prcMargins
00818  *
00819  * lParam = (LPARAM)prcMargins
00820  * \endcode
00821  *
00822  * \param prcMargins : the margins info:
00823  *    - top : the top margin value
00824  *    - left: the left margin value
00825  *    - right: the right margin value
00826  *    - bottom: the bottom margin value
00827  *
00828  * \return ignored
00829  *
00830  * \sa EM_GETMARGINS
00831  */
00832 #define EM_SETMARGINS           0xF0D7
00833
00834 /*
00835  * \def EM_GETMARGINS
00836  * \brief Get the margins of content
00837  *
00838  * \code
00839  * EM_GETMARGINS
00840  *
00841  * RECT *prcMargins
00842  *
00843  * lParam = (LPARAM)prcMargins
00844  * \endcode
00845  *
00846  * \param prcMargins : the margins info:
00847  *    - top : the top margin value
00848  *    - left: the left margin value
00849  *    - right: the right margin value
00850  *    - bottom: the bottom margin value
00851  *
00852  * \return TRUE / FALSE
00853  *
00854  * \sa EM_SETMARGINS
00855  */
00856 #define EM_GETMARGINS           0xF0D8
00857 /*
00858 #define EM_POSFROMCHAR          0xF0D9
00859 #define EM_CHARFROMPOS          0xF0DA
00860 #define EM_SETIMESTATUS         0xF0DB
00861 #define EM_GETIMESTATUS         0xF0DC
00862
00863 #define MEM_SCROLLCHANGE        0xF0DD
00864 */
00865
00866 /* Not use */
00867 #define MED_STATE_YES           0x0
00868 /* Not use */
00869 #define MED_STATE_NOUP          0x1
00870 /* Not use */
00871 #define MED_STATE_NODN          0x2
00872 /* Not use */
00873 #define MED_STATE_NO            0x3
00874
00890 #define EM_SETTITLETEXT         0xF0DC
00891
00912 #define EM_GETTITLETEXT         0xF0DD
00913
00928 #define EM_SETTIPTEXT           0xF0DE
00929
00948 #define EM_GETTIPTEXT           0xF0DF
00949
00953 typedef struct _TEXTPOSINFO {
00956     int paragraph_index;
00959     int line_index;
00961     int start_pos;
00964     int copy_len;
00967     char *buff;
00968 }TEXTPOSINFO;
00969
00976 #define EM_GETNUMOFPARAGRAPHS   0xF0E0
00977
00988 #define EM_GETPARAGRAPHLENGTH  0xF0E1
00989
01009 #define EM_GETPARAGRAPHTEXT    0xF0E2
01010
01011 /*
01012  * \def EM_MUSTUPDATEBKGND
01013  * \brief Test if the bkgournd must be update
01014  *
01015  * \return BOOL. TRUE -- must update the bkground, texteditor would not use ScrollWindow
01016  *  FALSE -- bkground does not need to update, textditor use Scrollwindow
01017  *
01018  *  if you want paint a image on bkground, please make this message return TRUE
01019  *
01020  */
01021 #define EM_MUSTUPDATEBKGND     0xF0E3
01022
01051 #define EM_SETCARETPOSBYLINE    0xF0D9
01052
01073 #define EM_GETCARETPOSBYLINE    0xF0DA
01074
01079 #define EM_SETSELPOSBYLINE    0xF0DB
01080
01100 #define EM_GETSELPOSBYLINE    0xF0E4
01101
01114 #define EM_GETPARAGRAPHLENGTHINMCHAR  0xF0E5
01115
01128 #define EM_GETLINELENGTHINMCHAR  0xF0E6
01129
01141 #define EM_GETLINELENGTH  0xF0E7
01142
01163 #define EM_GETLINETEXT    0xF0E8
01164
01165 #define EM_MSGMAX               0xF0EA
01166
01174 #define EN_ERRSPACE         255
01175
01183 #define EN_CLICKED          0x0001
01184
01192 #define EN_DBLCLK           0x0002
01193
01201 #define EN_SETFOCUS         0x0100
01202
01210 #define EN_KILLFOCUS        0x0200
01211
01219 #define EN_CHANGE           0x0300
01220
01232 #define EN_UPDATE           0x0400
01233
01241 #define EN_MAXTEXT          0x0501
01242
01243 /* Not use */
01244 #define EN_HSCROLL          0x0601
01245 /* Not use */
01246 #define EN_VSCROLL          0x0602
01247
01248
01253 #define EN_SELCHANGED       0x0603
01254
01260 #define EN_CONTCHANGED     0x0604
01261
01266 #define EN_ENTER            0x0700
01267
01270 /* Edit control EM_SETMARGIN parameters */
01275 #define EC_LEFTMARGIN       0x0001
01276
01280 #define EC_RIGHTMARGIN      0x0002
01281
01285 #define EC_USEFONTINFO      0xffff
01286
01287 /* wParam of EM_GET/SETIMESTATUS  */
01292 #define EMSIS_COMPOSITIONSTRING        0x0001
01293
01294 /* lParam for EMSIS_COMPOSITIONSTRING  */
01299 #define EIMES_GETCOMPSTRATONCE         0x0001
01300
01304 #define EIMES_CANCELCOMPSTRINFOCUS     0x0002
01305
01309 #define EIMES_COMPLETECOMPSTRKILLFOCUS 0x0004
01310
01315 #ifdef __cplusplus
01316 }
01317 #endif  /* __cplusplus */
01318
01319 #endif /* _MGUI_CTRL_EDIT_H */
01320
Generated on Fri Dec 17 13:49:40 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: endianrw.h Source File

include

endianrw.h

Go to the documentation of this file.
00001
00024 /*
00025  * $Id: endianrw.h 11349 2009-03-02 05:00:43Z weiym $
00026  *
00027  *             MiniGUI for Linux/uClinux, eCos, uC/OS-II, VxWorks,
00028  *                     pSOS, ThreadX, NuCleus, OSE, and Win32.
00029  *
00030  *             Copyright (C) 2002-2009 Feynman Software.
00031  *             Copyright (C) 1998-2002 Wei Yongming.
00032  *
00033  *             The idea comes from LGPL'ed SDL by Sam Lantinga.
00034  */
00035
00036 #ifndef _MGUI_ENDIAN_RW_H
00037 #define _MGUI_ENDIAN_RW_H
00038
00039
00040 /* Set up for C function definitions, even when using C++ */
00041 #ifdef __cplusplus
00042 extern "C" {
00043 #endif
00044
00045 /************************** General RW operations ****************************/
00046
00067 #define RWAREA_TYPE_UNKNOWN 0
00068 #define RWAREA_TYPE_STDIO   1
00069 #define RWAREA_TYPE_MEM     2
00070
00074 typedef struct _MG_RWops {
00080     int (*seek)(struct _MG_RWops *context, int offset, int whence);
00081
00087     int (*read)(struct _MG_RWops *context, void *ptr, int objsize, int num);
00088
00094     int (*write)(struct _MG_RWops *context, const void *ptr, int objsize,
00095                     int num);
00096
00097 #ifdef _MGUSE_OWN_STDIO
00098     /* */
00099     int (*ungetc)(struct _MG_RWops *context, unsigned char c);
00100 #endif
00101
00105     int (*close)(struct _MG_RWops *context);
00106
00110     int (*eof)(struct _MG_RWops *context);
00111
00122     Uint32 type;
00123
00124     union {
00125         struct {
00126             int autoclose;
00127             FILE *fp;
00128         } stdio;
00129         struct {
00130             Uint8 *base;
00131             Uint8 *here;
00132             Uint8 *stop;
00133         } mem;
00134         struct {
00135             void *data1;
00136         } unknown;
00137     } hidden;
00138 } MG_RWops;
00139
00154 MG_EXPORT MG_RWops* MGUI_RWFromFile(const char *file, const char *mode);
00155
00170 MG_EXPORT MG_RWops* MGUI_RWFromFP(FILE *fp, int autoclose);
00171
00186 MG_EXPORT MG_RWops* MGUI_RWFromMem(void *mem, int size);
00187
00203 MG_EXPORT void MGUI_InitMemRW (MG_RWops* area, void *mem, int size);
00204
00216 MG_EXPORT MG_RWops* MGUI_AllocRW(void);
00217
00228 MG_EXPORT void MGUI_FreeRW(MG_RWops *area);
00229
00251 #define MGUI_RWseek(ctx, offset, whence)    (ctx)->seek(ctx, offset, whence)
00252
00266 #define MGUI_RWtell(ctx)                    (ctx)->seek(ctx, 0, SEEK_CUR)
00267
00283 #define MGUI_RWread(ctx, ptr, size, n)      (ctx)->read(ctx, ptr, size, n)
00284
00300 #define MGUI_RWwrite(ctx, ptr, size, n)     (ctx)->write(ctx, ptr, size, n)
00301
00315 #define MGUI_RWclose(ctx)                   (ctx)->close(ctx)
00316
00330 #define MGUI_RWeof(ctx)                     (ctx)->eof(ctx)
00331
00346 MG_EXPORT int MGUI_RWgetc (MG_RWops* area);
00347
00350 /****************** Endian specific read/write interfaces *********************/
00351
00374 /* The macros used to swap values */
00375 /* Try to use superfast macros on systems that support them */
00376 #ifdef linux
00377 #include <endian.h>
00378 #ifdef __arch__swab16
00379 #define ArchSwap16  __arch__swab16
00380 #endif
00381 #ifdef __arch__swab32
00382 #define ArchSwap32  __arch__swab32
00383 #endif
00384 #endif /* linux */
00385
00386 /* Use inline functions for compilers that support them, and static
00387    functions for those that do not.  Because these functions become
00388    static for compilers that do not support inline functions, this
00389    header should only be included in files that actually use them.
00390 */
00391 #ifndef ArchSwap16
00392 static inline Uint16 ArchSwap16(Uint16 D) {
00393         return((D<<8)|(D>>8));
00394 }
00395 #endif
00396 #ifndef ArchSwap32
00397 static inline Uint32 ArchSwap32(Uint32 D) {
00398         return((D<<24)|((D<<8)&0x00FF0000)|((D>>8)&0x0000FF00)|(D>>24));
00399 }
00400 #endif
00401 #ifdef MGUI_HAS_64BIT_TYPE
00402 #ifndef ArchSwap64
00403 static inline Uint64 ArchSwap64(Uint64 val) {
00404         Uint32 hi, lo;
00405
00406         /* Separate into high and low 32-bit values and swap them */
00407         lo = (Uint32)(val&0xFFFFFFFF);
00408         val >>= 32;
00409         hi = (Uint32)(val&0xFFFFFFFF);
00410         val = ArchSwap32(lo);
00411         val <<= 32;
00412         val |= ArchSwap32(hi);
00413         return(val);
00414 }
00415 #endif
00416 #else
00417 #ifndef ArchSwap64
00418 /* This is mainly to keep compilers from complaining in MGUI code.
00419    If there is no real 64-bit datatype, then compilers will complain about
00420    the fake 64-bit datatype that MGUI provides when it compiles user code.
00421 */
00422 #define ArchSwap64(X)        (X)
00423 #endif
00424 #endif /* MGUI_HAS_64BIT_TYPE */
00425
00426 /* Byteswap item from the specified endianness to the native endianness */
00427 #if MGUI_BYTEORDER == MGUI_LIL_ENDIAN
00428
00429 #define ArchSwapLE16(X)        (X)
00430
00431 #define ArchSwapLE32(X)        (X)
00432
00433 #define ArchSwapLE64(X)        (X)
00434
00435 #define ArchSwapBE16(X)        ArchSwap16(X)
00436
00437 #define ArchSwapBE32(X)        ArchSwap32(X)
00438
00439 #define ArchSwapBE64(X)        ArchSwap64(X)
00440 #else
00441 #define ArchSwapLE16(X)        ArchSwap16(X)
00442 #define ArchSwapLE32(X)        ArchSwap32(X)
00443 #define ArchSwapLE64(X)        ArchSwap64(X)
00444 #define ArchSwapBE16(X)        (X)
00445 #define ArchSwapBE32(X)        (X)
00446 #define ArchSwapBE64(X)        (X)
00447 #endif
00448
00461 extern Uint16 MGUI_ReadLE16(MG_RWops *src);
00462
00475 extern Uint16 MGUI_ReadBE16(MG_RWops *src);
00476
00489 extern Uint32 MGUI_ReadLE32(MG_RWops *src);
00490
00503 extern Uint32 MGUI_ReadBE32(MG_RWops *src);
00504
00517 extern Uint64 MGUI_ReadLE64(MG_RWops *src);
00518
00531 extern Uint64 MGUI_ReadBE64(MG_RWops *src);
00532
00547 extern int MGUI_WriteLE16(MG_RWops *dst, Uint16 value);
00548
00563 extern int MGUI_WriteBE16(MG_RWops *dst, Uint16 value);
00564
00579 extern int MGUI_WriteLE32(MG_RWops *dst, Uint32 value);
00580
00595 extern int MGUI_WriteBE32(MG_RWops *dst, Uint32 value);
00596
00611 extern int MGUI_WriteLE64(MG_RWops *dst, Uint64 value);
00612
00627 extern int MGUI_WriteBE64(MG_RWops *dst, Uint64 value);
00628
00641 extern Uint16 MGUI_ReadLE16FP(FILE *src);
00642
00655 extern Uint32 MGUI_ReadLE32FP(FILE *src);
00656
00671 extern int MGUI_WriteLE16FP(FILE *dst, Uint16 value);
00672
00687 extern int MGUI_WriteLE32FP(FILE *dst, Uint32 value);
00688
00689 static inline Uint16 MGUI_ReadLE16Mem (const Uint8** data)
00690 {
00691 #if 1
00692     Uint16 h1, h2;
00693
00694     h1 = *(*data); (*data)++;
00695     h2 = *(*data); (*data)++;
00696     return ((h2<<8)|h1);
00697 #else
00698     Uint16 u;
00699     memcpy (&u, *data, sizeof (Uint16));
00700     u = ArchSwapLE16 (u);
00701     *data += sizeof (Uint16);
00702     return u;
00703 #endif
00704 }
00705
00706 static inline Uint32 MGUI_ReadLE32Mem (const Uint8** data)
00707 {
00708 #if 1
00709     Uint32 q1, q2, q3, q4;
00710
00711     q1 = *(*data); (*data)++;
00712     q2 = *(*data); (*data)++;
00713     q3 = *(*data); (*data)++;
00714     q4 = *(*data); (*data)++;
00715     return ((q4<<24)|(q3<<16)|(q2<<8)|(q1));
00716 #else
00717     Uint32 u;
00718     memcpy (&u, *data, sizeof (Uint32));
00719     u = ArchSwapLE32 (u);
00720     *data += sizeof (Uint32);
00721     return u;
00722 #endif
00723 }
00724
00725 static inline Uint16 MGUI_ReadBE16Mem (const Uint8** data)
00726 {
00727 #if 1
00728     Uint16 h1, h2;
00729
00730     h1 = *(*data); (*data)++;
00731     h2 = *(*data); (*data)++;
00732     return ((h1<<8)|h2);
00733 #else
00734     Uint16 u;
00735     memcpy (&u, *data, sizeof (Uint16));
00736     u = ArchSwapBE16 (u);
00737     *data += sizeof (Uint16);
00738     return u;
00739 #endif
00740 }
00741
00742 static inline Uint32 MGUI_ReadBE32Mem (const Uint8** data)
00743 {
00744 #if 1
00745     Uint32 q1, q2, q3, q4;
00746
00747     q1 = *(*data); (*data)++;
00748     q2 = *(*data); (*data)++;
00749     q3 = *(*data); (*data)++;
00750     q4 = *(*data); (*data)++;
00751     return ((q1<<24)|(q2<<16)|(q3<<8)|(q4));
00752 #else
00753     Uint32 u;
00754     memcpy (&u, *data, sizeof (Uint32));
00755     u = ArchSwapBE32 (u);
00756     *data += sizeof (Uint32);
00757     return u;
00758 #endif
00759 }
00760
00767 /* Ends C function definitions when using C++ */
00768 #ifdef __cplusplus
00769 }
00770 #endif
00771
00772 #endif /* _MGUI_ENDIAN_RW_H */
00773
Generated on Fri Dec 17 13:49:40 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: File Index

  • File List
  • Globals

File List

Here is a list of all documented files with brief descriptions:
animation.h [code]
button.h [code]
combobox.h [code]
common.h [code]
control.h [code]
coolbar.h [code]
ctrlhelper.h [code]
customial.h [code]
edit.h [code]
endianrw.h [code]
fixedmath.h [code]
gdi.h [code]
gridview.h [code]
iconview.h [code]
listbox.h [code]
listview.h [code]
menubutton.h [code]
minigui.h [code]
monthcal.h [code]
newtoolbar.h [code]
progressbar.h [code]
propsheet.h [code]
scrollbar.h [code]
scrollview.h [code]
spinbox.h [code]
static.h [code]
textedit.h [code]
trackbar.h [code]
treeview.h [code]
window.h [code]
xvfb.h [code]
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: fixedmath.h Source File

include

fixedmath.h

Go to the documentation of this file.
00001
00021 /*
00022  * $Id: fixedmath.h 12034 2009-08-11 10:18:50Z chenlei $
00023  *
00024  *             MiniGUI for Linux/uClinux, eCos, uC/OS-II, VxWorks,
00025  *                     pSOS, ThreadX, NuCleus, OSE, and Win32.
00026  *
00027  *             Copyright (C) 2002-2009 Feynman Software.
00028  *             Copyright (C) 1998-2002 Wei Yongming.
00029  *
00030  *             Fixed-point math routins come from Allegro (a gift software)
00031  *             by Shawn Hargreaves and others.
00032  */
00033
00034 #ifndef _MGUI_MGHAVE_FIXED_MATH_H
00035 #define _MGUI_MGHAVE_FIXED_MATH_H
00036
00037
00038 #include <errno.h>
00039 #include <math.h>
00040 #include <stdlib.h>
00041
00042 /* Set up for C function definitions, even when using C++ */
00043 #ifdef __cplusplus
00044 extern "C" {
00045 #endif
00046
00047 #ifdef _MGHAVE_FIXED_MATH
00048
00089 MG_EXPORT fixed fixsqrt (fixed x);
00090
00101 MG_EXPORT fixed fixhypot (fixed x, fixed y);
00102
00115 MG_EXPORT fixed fixatan (fixed x);
00116
00131 MG_EXPORT fixed fixatan2 (fixed y, fixed x);
00132
00133 extern MG_EXPORT fixed _cos_tbl[];
00134 extern MG_EXPORT fixed _tan_tbl[];
00135 extern MG_EXPORT fixed _acos_tbl[];
00136
00137 /************************** inline fixed point math functions *****************/
00138 /* ftofix and fixtof are used in generic C versions of fixmul and fixdiv */
00139
00152 static inline fixed ftofix (double x)
00153 {
00154    if (x > 32767.0) {
00155       errno = ERANGE;
00156       return 0x7FFFFFFF;
00157    }
00158
00159    if (x < -32767.0) {
00160       errno = ERANGE;
00161       return -0x7FFFFFFF;
00162    }
00163
00164    return (long)(x * 65536.0 + (x < 0 ? -0.5 : 0.5));
00165 }
00166
00176 static inline double fixtof (fixed x)
00177 {
00178    return (double)x / 65536.0;
00179 }
00180
00181
00196 static inline fixed fixadd (fixed x, fixed y)
00197 {
00198    fixed result = x + y;
00199
00200    if (result >= 0) {
00201       if ((x < 0) && (y < 0)) {
00202          errno = ERANGE;
00203          return -0x7FFFFFFF;
00204       }
00205       else
00206          return result;
00207    }
00208    else {
00209       if ((x > 0) && (y > 0)) {
00210          errno = ERANGE;
00211          return 0x7FFFFFFF;
00212       }
00213       else
00214          return result;
00215    }
00216 }
00217
00233 static inline fixed fixsub (fixed x, fixed y)
00234 {
00235    fixed result = x - y;
00236
00237    if (result >= 0) {
00238       if ((x < 0) && (y > 0)) {
00239          errno = ERANGE;
00240          return -0x7FFFFFFF;
00241       }
00242       else
00243          return result;
00244    }
00245    else {
00246       if ((x > 0) && (y < 0)) {
00247          errno = ERANGE;
00248          return 0x7FFFFFFF;
00249       }
00250       else
00251          return result;
00252    }
00253 }
00254
00268 MG_EXPORT fixed fixmul (fixed x, fixed y);
00269
00283 MG_EXPORT fixed fixdiv (fixed x, fixed y);
00284
00295 static inline int fixceil (fixed x)
00296 {
00297    if (x > 0x7FFF0000) {
00298       errno = ERANGE;
00299       return 0x7FFF;
00300    }
00301
00302    x += 0xFFFF;
00303    if (x > 0)
00304        return (x >> 16);
00305    else
00306        return ~((~x) >> 16);
00307 }
00308
00317 static inline fixed itofix (int x)
00318 {
00319    return x << 16;
00320 }
00321
00330 static inline int fixtoi (fixed x)
00331 {
00332    return (x >> 16) + ((x & 0x8000) >> 15);
00333 }
00334
00344 static inline fixed fixcos (fixed x)
00345 {
00346    return _cos_tbl[((x + 0x4000) >> 15) & 0x1FF];
00347 }
00348
00358 static inline fixed fixsin (fixed x)
00359 {
00360    return _cos_tbl[((x - 0x400000 + 0x4000) >> 15) & 0x1FF];
00361 }
00362
00372 static inline fixed fixtan (fixed x)
00373 {
00374    return _tan_tbl[((x + 0x4000) >> 15) & 0xFF];
00375 }
00376
00390 static inline fixed fixacos (fixed x)
00391 {
00392    if ((x < -65536) || (x > 65536)) {
00393       errno = EDOM;
00394       return 0;
00395    }
00396
00397    return _acos_tbl[(x+65536+127)>>8];
00398 }
00399
00413 static inline fixed fixasin (fixed x)
00414 {
00415    if ((x < -65536) || (x > 65536)) {
00416       errno = EDOM;
00417       return 0;
00418    }
00419
00420    return 0x00400000 - _acos_tbl[(x+65536+127)>>8];
00421 }
00422
00430 #endif /* _MGHAVE_FIXED_MATH */
00431
00432 /* Ends C function definitions when using C++ */
00433 #ifdef __cplusplus
00434 }
00435 #endif
00436
00437 #endif /* _MGUI_MGHAVE_FIXED_MATH_H */
00438
Generated on Fri Dec 17 13:49:41 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- k -

  • kb_data : _XVFBEVENT
  • key_code : _XVFBKEYDATA
  • key_nr : _ETCSECTION
  • key_nr_alloc : _ETCSECTION
  • key_state : _XVFBKEYDATA
  • keyboard_handler : _DESKTOPOPS
  • keys : _ETCSECTION
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- l -

  • label : _IVITEMINFO
  • left : _RECT , _WINDOWINFO
  • len : _WORDINFO
  • len_buff : _GRIDCELLDATAHEADER , _GRIDCELLDATATEXT
  • len_format : _GRIDCELLDATANUMBER
  • len_sel : _GRIDCELLDATASELECTION
  • len_text : _GRIDCELLDATACHECKBOX
  • line_index : _TEXTPOSINFO
  • losorted : _LVSORTDATA
  • lParam : _MSG , _LVNM_NORMAL
  • lx : _MAINWINCREATE
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- m -

  • MainWindowProc : _MAINWINCREATE
  • mask : _GRIDCELLDATA , _MENUITEMINFO
  • max : _SPININFO
  • max_width : _FONTMETRICS
  • maxPos : _LFSCROLLBARINFO , _SCROLLBARDATA
  • mbc_devfont : _LOGFONT
  • mbc_scale : _LOGFONT
  • mem_dc : _ANIMATIONFRAME
  • message : _MSG
  • min : _SPININFO
  • minPos : _SCROLLBARDATA , _LFSCROLLBARINFO
  • month : _SYSTEMTIME
  • mouse_data : _XVFBEVENT
  • mouse_handler : _DESKTOPOPS
  • MSBLeft : _XVFBHeader
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- n -

  • name : _DEVFONT , _ETCSECTION , _WINDOW_ELEMENT_RENDERER
  • ncol : _LVSORTDATA
  • ncolors : _GAL_Palette
  • nCols : _LVCOLUMN , _LVFINDINFO
  • need_unload : _DEVFONT
  • next : _ANIMATIONFRAME , _CLIPRECT , _DEVFONT
  • nItem : _SCROLLVIEWITEMINFO , _IVITEMINFO , _LVITEM , _LVSUBITEM , _LVFINDINFO
  • nItemHeight : _LVITEM , _SCROLLVIEWITEMINFO
  • nMax : _SCROLLINFO
  • nMin : _SCROLLINFO
  • nPage : _SCROLLINFO
  • nPos : _SCROLLINFO
  • nr_cells : _NTBINFO
  • nr_chars : _DTFIRSTLINE
  • nr_cols : _GRIDVIEWDATA , _NTBINFO
  • nr_delimiters : _WORDINFO
  • nr_frames : _ANIMATION
  • nr_rows : _GRIDVIEWDATA
  • nSubitem : _LVFINDINFO
  • nTextColor : _LVSUBITEM
  • nTextMax : _LVCOLUMN , _LVSUBITEM
  • number : _GRIDCELLDATANUMBER
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- o -

  • off_x : _ANIMATIONFRAME
  • off_y : _ANIMATIONFRAME
  • on_click_hotspot : _WINDOW_ELEMENT_RENDERER
  • on_get_rdr_attr : _WINDOW_ELEMENT_RENDERER
  • on_set_rdr_attr : _WINDOW_ELEMENT_RENDERER
  • opMask : _WNDCLASS
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- b -

  • b : _RGB , _GAL_Color , _XVFBPalEntry
  • barLen : _LFSCROLLBARINFO , _SCROLLBARDATA
  • barStart : _LFSCROLLBARINFO , _SCROLLBARDATA
  • bbox_x : _GLYPHBITMAP
  • bd_size : _BLOCKHEAP
  • bits : _ANIMATIONFRAME , _STIPPLE , _GLYPHBITMAP , _MYBITMAP
  • bk : _ANIMATION
  • bmAlpha : _BITMAP
  • bmAlphaMask : _BITMAP
  • Bmask : _XVFBHeader
  • bmBits : _BITMAP
  • bmBitsPerPixel : _BITMAP
  • bmBytesPerPixel : _BITMAP
  • bmColorKey : _BITMAP
  • bmHeight : _BITMAP
  • Bmp : _COOLBARITEMINFO
  • bmp : _IVITEMINFO , _MENUBUTTONITEM
  • bmp_cell : _NTBITEMINFO
  • bmp_pitch : _GLYPHBITMAP
  • bmp_size : _GLYPHBITMAP
  • bmPitch : _BITMAP
  • bmType : _BITMAP
  • bmWidth : _BITMAP
  • bottom : _RECT
  • btn : _XVFBMOUSEDATA
  • buff : _TEXTPOSINFO , _GRIDCELLDATAHEADER , _GRIDCELLDATATEXT
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- c -

  • calc_3dbox_color : _WINDOW_ELEMENT_RENDERER
  • calc_thumb_area : _WINDOW_ELEMENT_RENDERER
  • calc_trackbar_rect : _WINDOW_ELEMENT_RENDERER
  • calc_we_area : _WINDOW_ELEMENT_RENDERER
  • calc_we_metrics : _WINDOW_ELEMENT_RENDERER
  • caption : _DLGTEMPLATE
  • Caption : _COOLBARITEMINFO
  • caption : _CTRLDATA
  • cbSize : _SCROLLINFO
  • cch : _MENUITEMINFO
  • charset : _LOGFONT
  • charset_ops : _DEVFONT
  • checked : _GRIDCELLDATACHECKBOX
  • checkedbmp : _MENUITEMINFO
  • cl : _WINDOWINFO
  • class_name : _CTRLDATA
  • close : _MG_RWops
  • clr_arrow : _MCCOLORINFO
  • clr_arrowHibk : _MCCOLORINFO
  • clr_daybk : _MCCOLORINFO
  • clr_dayHibk : _MCCOLORINFO
  • clr_dayHitext : _MCCOLORINFO
  • clr_daytext : _MCCOLORINFO
  • clr_titlebk : _MCCOLORINFO
  • clr_titletext : _MCCOLORINFO
  • clr_trailingtext : _MCCOLORINFO
  • clr_weekcaptbk : _MCCOLORINFO
  • clr_weekcapttext : _MCCOLORINFO
  • cmFlag : _LISTBOXITEMINFO
  • col_width : _GRIDVIEWDATA
  • colFlags : _LVCOLUMN
  • color_bg : _GRIDCELLDATA
  • color_fg : _GRIDCELLDATA
  • colors : _GAL_Palette
  • column : _GRIDCELLS
  • content : _GRIDCELLDATA
  • context : _HOOKINFO
  • controlnr : _CONTAINERINFO , _DLGTEMPLATE
  • controls : _CONTAINERINFO , _DLGTEMPLATE
  • copy_len : _TEXTPOSINFO
  • cur : _SPININFO
  • cur_index : _GRIDCELLDATASELECTION
  • curPos : _LFSCROLLBARINFO , _SCROLLBARDATA
  • customize_desktop_menu : _DESKTOPOPS
  • cx : _SIZE
  • cy : _SIZE
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- d -

  • data : _MENUBUTTONITEM , _DEVFONT
  • day : _SYSTEMTIME
  • deinit : _DESKTOPOPS , _WINDOW_ELEMENT_RENDERER
  • delay_time : _ANIMATIONFRAME
  • delimiter : _WORDINFO
  • depth : _MYBITMAP , _XVFBHeader
  • descent : _LOGFONT , _FONTMETRICS
  • desktop_menucmd_handler : _DESKTOPOPS
  • destroyItem : _svitem_operations
  • dirty : _XVFBHeader
  • dirty_rc_b : _XVFBHeader
  • dirty_rc_l : _XVFBHeader
  • dirty_rc_r : _XVFBHeader
  • dirty_rc_t : _XVFBHeader
  • disabled_text_out : _WINDOW_ELEMENT_RENDERER
  • disposal : _ANIMATIONFRAME
  • draw_3dbox : _WINDOW_ELEMENT_RENDERER
  • draw_arrow : _WINDOW_ELEMENT_RENDERER
  • draw_border : _WINDOW_ELEMENT_RENDERER
  • draw_caption : _WINDOW_ELEMENT_RENDERER
  • draw_caption_button : _WINDOW_ELEMENT_RENDERER
  • draw_check_button : _WINDOW_ELEMENT_RENDERER
  • draw_checkbox : _WINDOW_ELEMENT_RENDERER
  • draw_checkmark : _WINDOW_ELEMENT_RENDERER
  • draw_custom_hotspot : _WINDOW_ELEMENT_RENDERER
  • draw_disabled_item : _WINDOW_ELEMENT_RENDERER
  • draw_disabled_menu_item : _WINDOW_ELEMENT_RENDERER
  • draw_focus_frame : _WINDOW_ELEMENT_RENDERER
  • draw_fold : _WINDOW_ELEMENT_RENDERER
  • draw_header : _WINDOW_ELEMENT_RENDERER
  • draw_hilite_item : _WINDOW_ELEMENT_RENDERER
  • draw_hilite_menu_item : _WINDOW_ELEMENT_RENDERER
  • draw_normal_item : _WINDOW_ELEMENT_RENDERER
  • draw_normal_menu_item : _WINDOW_ELEMENT_RENDERER
  • draw_progress : _WINDOW_ELEMENT_RENDERER
  • draw_push_button : _WINDOW_ELEMENT_RENDERER
  • draw_radio : _WINDOW_ELEMENT_RENDERER
  • draw_radio_button : _WINDOW_ELEMENT_RENDERER
  • draw_scrollbar : _WINDOW_ELEMENT_RENDERER
  • draw_significant_item : _WINDOW_ELEMENT_RENDERER
  • draw_tab : _WINDOW_ELEMENT_RENDERER
  • draw_trackbar : _WINDOW_ELEMENT_RENDERER
  • drawItem : _svitem_operations
  • dwAddData : _TVITEMINFO , _CTRLDATA , _DLGTEMPLATE , _MAINWINCREATE , _COOLBARITEMINFO , _CONTAINERINFO , _WNDCLASS
  • dwExStyle : _WINDOWINFO , _CTRLDATA , _DLGTEMPLATE , _MAINWINCREATE , _WNDCLASS
  • dwFlags : _IVITEMINFO , _LVITEM , _TVITEMINFO
  • dwReserved : _MAINWINCREATE
  • dwStyle : _MAINWINCREATE , _CTRLDATA , _DLGTEMPLATE , _LFRDR_WINSTYLEINFO , _WNDCLASS , _WINDOWINFO
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- e -

  • eof : _MG_RWops
  • erase_background : _WINDOW_ELEMENT_RENDERER
  • event_type : _XVFBEVENT
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- f -

  • family : _LOGFONT
  • fb_offset : _XVFBHeader
  • flags : _LVFINDINFO , _NTBITEMINFO , _LVSUBITEM , _MYBITMAP
  • fMask : _SCROLLINFO
  • font : _GRIDCELLDATA
  • font_height : _FONTMETRICS
  • font_ops : _DEVFONT
  • format : _GRIDCELLDATANUMBER
  • frames : _ANIMATION , _MYBITMAP
  • free : _BLOCKHEAP
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- g -

  • g : _RGB , _GAL_Color , _XVFBPalEntry
  • Gmask : _XVFBHeader
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- h -

  • h : _MYBITMAP
  • h_cell : _NTBINFO
  • hAccel : _WINDOWINFO
  • hCursor : _WINDOWINFO , _MAINWINCREATE , _WNDCLASS
  • head : _CLIPRGN
  • heap : _BLOCKHEAP , _CLIPRGN
  • heap_size : _BLOCKHEAP
  • height : _DTFIRSTLINE , _XVFBHeader , _ANIMATIONFRAME , _ANIMATION , _GRIDCELLS , _STIPPLE , _ARC
  • hHosting : _MAINWINCREATE
  • hIcon : _LISTBOXITEMINFO , _WINDOWINFO , _MAINWINCREATE , _DLGTEMPLATE
  • hIconFold : _TVITEMINFO
  • hIconUnfold : _TVITEMINFO
  • hit_test : _WINDOW_ELEMENT_RENDERER
  • hLV : _LVSORTDATA
  • hMenu : _WINDOWINFO , _DLGTEMPLATE , _MAINWINCREATE
  • hook : _HOOKINFO
  • hotspot_proc : _NTBITEMINFO
  • hscroll : _WINDOWINFO
  • hsubmenu : _MENUITEMINFO
  • hSysMenu : _WINDOWINFO
  • hwnd : _MSG
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- i -

  • iBkColor : _WINDOWINFO , _MAINWINCREATE , _WNDCLASS
  • id : _COOLBARITEMINFO , _CTRLDATA , _NTBITEMINFO , _WINDOWINFO , _MENUITEMINFO
  • iEditBoxType : _IME_TARGET_INFO
  • image : _GRIDCELLDATA , _LVSUBITEM , _LVCOLUMN , _NTBINFO
  • info_size : _XVFBHeader
  • init : _WINDOW_ELEMENT_RENDERER , _DESKTOPOPS
  • initItem : _svitem_operations
  • insPos : _COOLBARITEMINFO
  • iStart : _LVFINDINFO
  • itemData : _LVITEM
  • itemdata : _MENUITEMINFO
  • ItemHint : _COOLBARITEMINFO
  • ItemType : _COOLBARITEMINFO
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- p -

  • pageStep : _LFSCROLLBARINFO , _SCROLLBARDATA
  • paint_desktop : _DESKTOPOPS
  • palette_changed : _XVFBHeader
  • palette_offset : _XVFBHeader
  • paragraph_index : _TEXTPOSINFO
  • pfnCompare : _LVCOLUMN
  • pfnDrawHdrBk : _LVCUSTOMDRAWFUNCS
  • pfnDrawHdrItem : _LVCUSTOMDRAWFUNCS
  • pitch : _STIPPLE , _MYBITMAP , _XVFBHeader
  • pLogFont : _WINDOWINFO
  • prev : _ANIMATIONFRAME , _CLIPRECT
  • private_info : _WINDOW_ELEMENT_RENDERER
  • pszHeadText : _LVCOLUMN
  • pszInfo : _LVFINDINFO
  • pszText : _LVSUBITEM
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- r -

  • r : _RGB , _GAL_Color , _XVFBPalEntry
  • rc : _CLIPRECT
  • rc_hotspot : _NTBITEMINFO
  • rcBound : _CLIPRGN
  • read : _MG_RWops
  • refcount : _WINDOW_ELEMENT_RENDERER
  • relationship : _DEVFONT
  • reserved : _CLIPRGN
  • right : _RECT
  • Rmask : _XVFBHeader
  • rotation : _LOGFONT
  • row : _GRIDCELLS
  • row_height : _GRIDVIEWDATA
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- s -

  • sbc_devfont : _LOGFONT
  • sbc_scale : _LOGFONT
  • sect_nr_alloc : _ETC_S
  • section_nr : _ETC_S
  • sections : _ETC_S
  • seek : _MG_RWops
  • selections : _GRIDCELLDATASELECTION
  • size : _GRIDCELLDATAHEADER , _STIPPLE , _LOGFONT , _MYBITMAP
  • spCaption : _WINDOWINFO , _MAINWINCREATE
  • spClassName : _WNDCLASS
  • start_pos : _TEXTPOSINFO
  • startx : _DTFIRSTLINE
  • starty : _DTFIRSTLINE
  • state : _MENUITEMINFO
  • status : _SCROLLBARDATA , _LFSCROLLBARINFO
  • string : _LISTBOXITEMINFO
  • style : _DEVFONT , _GRIDCELLDATA , _LOGFONT
  • subItem : _LVSUBITEM
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- t -

  • tail : _CLIPRGN
  • text : _GRIDCELLDATACHECKBOX , _NTBITEMINFO , _TVITEMINFO , _MENUBUTTONITEM
  • time : _MSG
  • time_unit : _ANIMATION
  • tip : _NTBITEMINFO
  • top : _RECT
  • transparent : _MYBITMAP
  • type : _CLIPRGN , _MG_RWops , _LOGFONT , _MENUITEMINFO
  • typedata : _MENUITEMINFO
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- u -

  • uncheckedbmp : _MENUITEMINFO
  • user_proc : _CONTAINERINFO
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- v -

  • values : _ETCSECTION
  • vscroll : _WINDOWINFO
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- w -

  • w : _GAL_Rect , _MYBITMAP
  • w_cell : _NTBINFO
  • we_attr : _WINDOW_ELEMENT_ATTR
  • we_attr_id : _WINDOW_ELEMENT_ATTR
  • we_attrs : _CTRLDATA
  • we_colors : _WINDOW_ELEMENT_RENDERER
  • we_fonts : _WINDOW_ELEMENT_RENDERER
  • we_icon : _WINDOW_ELEMENT_RENDERER
  • we_metrics : _WINDOW_ELEMENT_RENDERER
  • we_rdr : _WINDOWINFO
  • weekday : _SYSTEMTIME
  • werdr_name : _CTRLDATA
  • which : _MENUBUTTONITEM , _NTBITEMINFO
  • width : _LVCOLUMN , _DTFIRSTLINE , _ANIMATIONFRAME , _ARC , _GRIDCELLS , _STIPPLE , _XVFBHeader , _ANIMATION
  • WinProc : _WNDCLASS
  • winType : _LFRDR_WINSTYLEINFO
  • wParam : _MSG , _LVNM_NORMAL
  • write : _MG_RWops
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- x -

  • x : _POINT , _XVFBMOUSEDATA , _DLGTEMPLATE , _CTRLDATA , _ARC , _GAL_Rect
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

Here is a list of all documented struct and union fields with links to the struct/union documentation for each field:

- y -

  • y : _POINT , _ARC , _XVFBMOUSEDATA
  • year : _SYSTEMTIME
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- a -

  • a : _RGB , _GAL_Color , _XVFBPalEntry
  • add_data : _NTBITEMINFO
  • addData : _IVITEMINFO , _LVFINDINFO , _SCROLLVIEWITEMINFO
  • advance_x : _GLYPHBITMAP
  • alpha : _MYBITMAP
  • Amask : _XVFBHeader
  • angle1 : _ARC
  • angle2 : _ARC
  • arrowLen : _SCROLLBARDATA , _LFSCROLLBARINFO
  • ascent : _FONTMETRICS , _LOGFONT
  • ave_width : _FONTMETRICS
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- k -

  • kb_data : _XVFBEVENT
  • key_code : _XVFBKEYDATA
  • key_nr : _ETCSECTION
  • key_nr_alloc : _ETCSECTION
  • key_state : _XVFBKEYDATA
  • keyboard_handler : _DESKTOPOPS
  • keys : _ETCSECTION
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- l -

  • label : _IVITEMINFO
  • left : _RECT , _WINDOWINFO
  • len : _WORDINFO
  • len_buff : _GRIDCELLDATAHEADER , _GRIDCELLDATATEXT
  • len_format : _GRIDCELLDATANUMBER
  • len_sel : _GRIDCELLDATASELECTION
  • len_text : _GRIDCELLDATACHECKBOX
  • line_index : _TEXTPOSINFO
  • losorted : _LVSORTDATA
  • lParam : _MSG , _LVNM_NORMAL
  • lx : _MAINWINCREATE
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- m -

  • MainWindowProc : _MAINWINCREATE
  • mask : _GRIDCELLDATA , _MENUITEMINFO
  • max : _SPININFO
  • max_width : _FONTMETRICS
  • maxPos : _LFSCROLLBARINFO , _SCROLLBARDATA
  • mbc_devfont : _LOGFONT
  • mbc_scale : _LOGFONT
  • mem_dc : _ANIMATIONFRAME
  • message : _MSG
  • min : _SPININFO
  • minPos : _SCROLLBARDATA , _LFSCROLLBARINFO
  • month : _SYSTEMTIME
  • mouse_data : _XVFBEVENT
  • mouse_handler : _DESKTOPOPS
  • MSBLeft : _XVFBHeader
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- n -

  • name : _DEVFONT , _ETCSECTION , _WINDOW_ELEMENT_RENDERER
  • ncol : _LVSORTDATA
  • ncolors : _GAL_Palette
  • nCols : _LVCOLUMN , _LVFINDINFO
  • need_unload : _DEVFONT
  • next : _ANIMATIONFRAME , _CLIPRECT , _DEVFONT
  • nItem : _SCROLLVIEWITEMINFO , _IVITEMINFO , _LVITEM , _LVSUBITEM , _LVFINDINFO
  • nItemHeight : _LVITEM , _SCROLLVIEWITEMINFO
  • nMax : _SCROLLINFO
  • nMin : _SCROLLINFO
  • nPage : _SCROLLINFO
  • nPos : _SCROLLINFO
  • nr_cells : _NTBINFO
  • nr_chars : _DTFIRSTLINE
  • nr_cols : _GRIDVIEWDATA , _NTBINFO
  • nr_delimiters : _WORDINFO
  • nr_frames : _ANIMATION
  • nr_rows : _GRIDVIEWDATA
  • nSubitem : _LVFINDINFO
  • nTextColor : _LVSUBITEM
  • nTextMax : _LVCOLUMN , _LVSUBITEM
  • number : _GRIDCELLDATANUMBER
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- o -

  • off_x : _ANIMATIONFRAME
  • off_y : _ANIMATIONFRAME
  • on_click_hotspot : _WINDOW_ELEMENT_RENDERER
  • on_get_rdr_attr : _WINDOW_ELEMENT_RENDERER
  • on_set_rdr_attr : _WINDOW_ELEMENT_RENDERER
  • opMask : _WNDCLASS
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- b -

  • b : _RGB , _GAL_Color , _XVFBPalEntry
  • barLen : _LFSCROLLBARINFO , _SCROLLBARDATA
  • barStart : _LFSCROLLBARINFO , _SCROLLBARDATA
  • bbox_x : _GLYPHBITMAP
  • bd_size : _BLOCKHEAP
  • bits : _ANIMATIONFRAME , _STIPPLE , _GLYPHBITMAP , _MYBITMAP
  • bk : _ANIMATION
  • bmAlpha : _BITMAP
  • bmAlphaMask : _BITMAP
  • Bmask : _XVFBHeader
  • bmBits : _BITMAP
  • bmBitsPerPixel : _BITMAP
  • bmBytesPerPixel : _BITMAP
  • bmColorKey : _BITMAP
  • bmHeight : _BITMAP
  • Bmp : _COOLBARITEMINFO
  • bmp : _IVITEMINFO , _MENUBUTTONITEM
  • bmp_cell : _NTBITEMINFO
  • bmp_pitch : _GLYPHBITMAP
  • bmp_size : _GLYPHBITMAP
  • bmPitch : _BITMAP
  • bmType : _BITMAP
  • bmWidth : _BITMAP
  • bottom : _RECT
  • btn : _XVFBMOUSEDATA
  • buff : _TEXTPOSINFO , _GRIDCELLDATAHEADER , _GRIDCELLDATATEXT
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- c -

  • calc_3dbox_color : _WINDOW_ELEMENT_RENDERER
  • calc_thumb_area : _WINDOW_ELEMENT_RENDERER
  • calc_trackbar_rect : _WINDOW_ELEMENT_RENDERER
  • calc_we_area : _WINDOW_ELEMENT_RENDERER
  • calc_we_metrics : _WINDOW_ELEMENT_RENDERER
  • caption : _DLGTEMPLATE
  • Caption : _COOLBARITEMINFO
  • caption : _CTRLDATA
  • cbSize : _SCROLLINFO
  • cch : _MENUITEMINFO
  • charset : _LOGFONT
  • charset_ops : _DEVFONT
  • checked : _GRIDCELLDATACHECKBOX
  • checkedbmp : _MENUITEMINFO
  • cl : _WINDOWINFO
  • class_name : _CTRLDATA
  • close : _MG_RWops
  • clr_arrow : _MCCOLORINFO
  • clr_arrowHibk : _MCCOLORINFO
  • clr_daybk : _MCCOLORINFO
  • clr_dayHibk : _MCCOLORINFO
  • clr_dayHitext : _MCCOLORINFO
  • clr_daytext : _MCCOLORINFO
  • clr_titlebk : _MCCOLORINFO
  • clr_titletext : _MCCOLORINFO
  • clr_trailingtext : _MCCOLORINFO
  • clr_weekcaptbk : _MCCOLORINFO
  • clr_weekcapttext : _MCCOLORINFO
  • cmFlag : _LISTBOXITEMINFO
  • col_width : _GRIDVIEWDATA
  • colFlags : _LVCOLUMN
  • color_bg : _GRIDCELLDATA
  • color_fg : _GRIDCELLDATA
  • colors : _GAL_Palette
  • column : _GRIDCELLS
  • content : _GRIDCELLDATA
  • context : _HOOKINFO
  • controlnr : _CONTAINERINFO , _DLGTEMPLATE
  • controls : _CONTAINERINFO , _DLGTEMPLATE
  • copy_len : _TEXTPOSINFO
  • cur : _SPININFO
  • cur_index : _GRIDCELLDATASELECTION
  • curPos : _LFSCROLLBARINFO , _SCROLLBARDATA
  • customize_desktop_menu : _DESKTOPOPS
  • cx : _SIZE
  • cy : _SIZE
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- d -

  • data : _MENUBUTTONITEM , _DEVFONT
  • day : _SYSTEMTIME
  • deinit : _DESKTOPOPS , _WINDOW_ELEMENT_RENDERER
  • delay_time : _ANIMATIONFRAME
  • delimiter : _WORDINFO
  • depth : _MYBITMAP , _XVFBHeader
  • descent : _LOGFONT , _FONTMETRICS
  • desktop_menucmd_handler : _DESKTOPOPS
  • destroyItem : _svitem_operations
  • dirty : _XVFBHeader
  • dirty_rc_b : _XVFBHeader
  • dirty_rc_l : _XVFBHeader
  • dirty_rc_r : _XVFBHeader
  • dirty_rc_t : _XVFBHeader
  • disabled_text_out : _WINDOW_ELEMENT_RENDERER
  • disposal : _ANIMATIONFRAME
  • draw_3dbox : _WINDOW_ELEMENT_RENDERER
  • draw_arrow : _WINDOW_ELEMENT_RENDERER
  • draw_border : _WINDOW_ELEMENT_RENDERER
  • draw_caption : _WINDOW_ELEMENT_RENDERER
  • draw_caption_button : _WINDOW_ELEMENT_RENDERER
  • draw_check_button : _WINDOW_ELEMENT_RENDERER
  • draw_checkbox : _WINDOW_ELEMENT_RENDERER
  • draw_checkmark : _WINDOW_ELEMENT_RENDERER
  • draw_custom_hotspot : _WINDOW_ELEMENT_RENDERER
  • draw_disabled_item : _WINDOW_ELEMENT_RENDERER
  • draw_disabled_menu_item : _WINDOW_ELEMENT_RENDERER
  • draw_focus_frame : _WINDOW_ELEMENT_RENDERER
  • draw_fold : _WINDOW_ELEMENT_RENDERER
  • draw_header : _WINDOW_ELEMENT_RENDERER
  • draw_hilite_item : _WINDOW_ELEMENT_RENDERER
  • draw_hilite_menu_item : _WINDOW_ELEMENT_RENDERER
  • draw_normal_item : _WINDOW_ELEMENT_RENDERER
  • draw_normal_menu_item : _WINDOW_ELEMENT_RENDERER
  • draw_progress : _WINDOW_ELEMENT_RENDERER
  • draw_push_button : _WINDOW_ELEMENT_RENDERER
  • draw_radio : _WINDOW_ELEMENT_RENDERER
  • draw_radio_button : _WINDOW_ELEMENT_RENDERER
  • draw_scrollbar : _WINDOW_ELEMENT_RENDERER
  • draw_significant_item : _WINDOW_ELEMENT_RENDERER
  • draw_tab : _WINDOW_ELEMENT_RENDERER
  • draw_trackbar : _WINDOW_ELEMENT_RENDERER
  • drawItem : _svitem_operations
  • dwAddData : _TVITEMINFO , _CTRLDATA , _DLGTEMPLATE , _MAINWINCREATE , _COOLBARITEMINFO , _CONTAINERINFO , _WNDCLASS
  • dwExStyle : _WINDOWINFO , _CTRLDATA , _DLGTEMPLATE , _MAINWINCREATE , _WNDCLASS
  • dwFlags : _IVITEMINFO , _LVITEM , _TVITEMINFO
  • dwReserved : _MAINWINCREATE
  • dwStyle : _MAINWINCREATE , _CTRLDATA , _DLGTEMPLATE , _LFRDR_WINSTYLEINFO , _WNDCLASS , _WINDOWINFO
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- e -

  • eof : _MG_RWops
  • erase_background : _WINDOW_ELEMENT_RENDERER
  • event_type : _XVFBEVENT
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- f -

  • family : _LOGFONT
  • fb_offset : _XVFBHeader
  • flags : _LVFINDINFO , _NTBITEMINFO , _LVSUBITEM , _MYBITMAP
  • fMask : _SCROLLINFO
  • font : _GRIDCELLDATA
  • font_height : _FONTMETRICS
  • font_ops : _DEVFONT
  • format : _GRIDCELLDATANUMBER
  • frames : _ANIMATION , _MYBITMAP
  • free : _BLOCKHEAP
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- g -

  • g : _RGB , _GAL_Color , _XVFBPalEntry
  • Gmask : _XVFBHeader
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- h -

  • h : _MYBITMAP
  • h_cell : _NTBINFO
  • hAccel : _WINDOWINFO
  • hCursor : _WINDOWINFO , _MAINWINCREATE , _WNDCLASS
  • head : _CLIPRGN
  • heap : _BLOCKHEAP , _CLIPRGN
  • heap_size : _BLOCKHEAP
  • height : _DTFIRSTLINE , _XVFBHeader , _ANIMATIONFRAME , _ANIMATION , _GRIDCELLS , _STIPPLE , _ARC
  • hHosting : _MAINWINCREATE
  • hIcon : _LISTBOXITEMINFO , _WINDOWINFO , _MAINWINCREATE , _DLGTEMPLATE
  • hIconFold : _TVITEMINFO
  • hIconUnfold : _TVITEMINFO
  • hit_test : _WINDOW_ELEMENT_RENDERER
  • hLV : _LVSORTDATA
  • hMenu : _WINDOWINFO , _DLGTEMPLATE , _MAINWINCREATE
  • hook : _HOOKINFO
  • hotspot_proc : _NTBITEMINFO
  • hscroll : _WINDOWINFO
  • hsubmenu : _MENUITEMINFO
  • hSysMenu : _WINDOWINFO
  • hwnd : _MSG
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- i -

  • iBkColor : _WINDOWINFO , _MAINWINCREATE , _WNDCLASS
  • id : _COOLBARITEMINFO , _CTRLDATA , _NTBITEMINFO , _WINDOWINFO , _MENUITEMINFO
  • iEditBoxType : _IME_TARGET_INFO
  • image : _GRIDCELLDATA , _LVSUBITEM , _LVCOLUMN , _NTBINFO
  • info_size : _XVFBHeader
  • init : _WINDOW_ELEMENT_RENDERER , _DESKTOPOPS
  • initItem : _svitem_operations
  • insPos : _COOLBARITEMINFO
  • iStart : _LVFINDINFO
  • itemData : _LVITEM
  • itemdata : _MENUITEMINFO
  • ItemHint : _COOLBARITEMINFO
  • ItemType : _COOLBARITEMINFO
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- p -

  • pageStep : _LFSCROLLBARINFO , _SCROLLBARDATA
  • paint_desktop : _DESKTOPOPS
  • palette_changed : _XVFBHeader
  • palette_offset : _XVFBHeader
  • paragraph_index : _TEXTPOSINFO
  • pfnCompare : _LVCOLUMN
  • pfnDrawHdrBk : _LVCUSTOMDRAWFUNCS
  • pfnDrawHdrItem : _LVCUSTOMDRAWFUNCS
  • pitch : _STIPPLE , _MYBITMAP , _XVFBHeader
  • pLogFont : _WINDOWINFO
  • prev : _ANIMATIONFRAME , _CLIPRECT
  • private_info : _WINDOW_ELEMENT_RENDERER
  • pszHeadText : _LVCOLUMN
  • pszInfo : _LVFINDINFO
  • pszText : _LVSUBITEM
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- r -

  • r : _RGB , _GAL_Color , _XVFBPalEntry
  • rc : _CLIPRECT
  • rc_hotspot : _NTBITEMINFO
  • rcBound : _CLIPRGN
  • read : _MG_RWops
  • refcount : _WINDOW_ELEMENT_RENDERER
  • relationship : _DEVFONT
  • reserved : _CLIPRGN
  • right : _RECT
  • Rmask : _XVFBHeader
  • rotation : _LOGFONT
  • row : _GRIDCELLS
  • row_height : _GRIDVIEWDATA
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- s -

  • sbc_devfont : _LOGFONT
  • sbc_scale : _LOGFONT
  • sect_nr_alloc : _ETC_S
  • section_nr : _ETC_S
  • sections : _ETC_S
  • seek : _MG_RWops
  • selections : _GRIDCELLDATASELECTION
  • size : _GRIDCELLDATAHEADER , _STIPPLE , _LOGFONT , _MYBITMAP
  • spCaption : _WINDOWINFO , _MAINWINCREATE
  • spClassName : _WNDCLASS
  • start_pos : _TEXTPOSINFO
  • startx : _DTFIRSTLINE
  • starty : _DTFIRSTLINE
  • state : _MENUITEMINFO
  • status : _SCROLLBARDATA , _LFSCROLLBARINFO
  • string : _LISTBOXITEMINFO
  • style : _DEVFONT , _GRIDCELLDATA , _LOGFONT
  • subItem : _LVSUBITEM
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- t -

  • tail : _CLIPRGN
  • text : _GRIDCELLDATACHECKBOX , _NTBITEMINFO , _TVITEMINFO , _MENUBUTTONITEM
  • time : _MSG
  • time_unit : _ANIMATION
  • tip : _NTBITEMINFO
  • top : _RECT
  • transparent : _MYBITMAP
  • type : _CLIPRGN , _MG_RWops , _LOGFONT , _MENUITEMINFO
  • typedata : _MENUITEMINFO
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- u -

  • uncheckedbmp : _MENUITEMINFO
  • user_proc : _CONTAINERINFO
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- v -

  • values : _ETCSECTION
  • vscroll : _WINDOWINFO
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- w -

  • w : _GAL_Rect , _MYBITMAP
  • w_cell : _NTBINFO
  • we_attr : _WINDOW_ELEMENT_ATTR
  • we_attr_id : _WINDOW_ELEMENT_ATTR
  • we_attrs : _CTRLDATA
  • we_colors : _WINDOW_ELEMENT_RENDERER
  • we_fonts : _WINDOW_ELEMENT_RENDERER
  • we_icon : _WINDOW_ELEMENT_RENDERER
  • we_metrics : _WINDOW_ELEMENT_RENDERER
  • we_rdr : _WINDOWINFO
  • weekday : _SYSTEMTIME
  • werdr_name : _CTRLDATA
  • which : _MENUBUTTONITEM , _NTBITEMINFO
  • width : _LVCOLUMN , _DTFIRSTLINE , _ANIMATIONFRAME , _ARC , _GRIDCELLS , _STIPPLE , _XVFBHeader , _ANIMATION
  • WinProc : _WNDCLASS
  • winType : _LFRDR_WINSTYLEINFO
  • wParam : _MSG , _LVNM_NORMAL
  • write : _MG_RWops
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- x -

  • x : _POINT , _XVFBMOUSEDATA , _DLGTEMPLATE , _CTRLDATA , _ARC , _GAL_Rect
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields - Variables

  • Alphabetical List
  • Data Structures
  • Data Fields
  • All
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- y -

  • y : _POINT , _ARC , _XVFBMOUSEDATA
  • year : _SYSTEMTIME
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: gdi.h Source File

include

gdi.h

Go to the documentation of this file.
00001
00021 /*
00022  * $Id: gdi.h 13232 2010-08-18 03:17:24Z wanzheng $
00023  *
00024  *             MiniGUI for Linux/uClinux, eCos, uC/OS-II, VxWorks,
00025  *                     pSOS, ThreadX, NuCleus, OSE, and Win32.
00026  *
00027  *             Copyright (C) 2002-2009 Feynman Software.
00028  *             Copyright (C) 1998-2002 Wei Yongming.
00029  */
00030
00031 #ifndef _MGUI_GDI_H
00032     #define _MGUI_GDI_H
00033
00034 #ifdef __cplusplus
00035 extern "C" {
00036 #endif  /* __cplusplus */
00037
00089 extern MG_EXPORT gal_pixel SysPixelIndex [];
00090
00097 extern const MG_EXPORT RGB SysPixelColor [];
00098
00104 #define PIXEL_invalid       0
00105
00111 #define PIXEL_transparent   SysPixelIndex[0]
00112
00118 #define PIXEL_darkblue      SysPixelIndex[1]
00119
00125 #define PIXEL_darkgreen     SysPixelIndex[2]
00126
00132 #define PIXEL_darkcyan      SysPixelIndex[3]
00133
00139 #define PIXEL_darkred       SysPixelIndex[4]
00140
00146 #define PIXEL_darkmagenta   SysPixelIndex[5]
00147
00153 #define PIXEL_darkyellow    SysPixelIndex[6]
00154
00160 #define PIXEL_darkgray      SysPixelIndex[7]
00161
00167 #define PIXEL_lightgray     SysPixelIndex[8]
00168
00174 #define PIXEL_blue          SysPixelIndex[9]
00175
00181 #define PIXEL_green         SysPixelIndex[10]
00182
00188 #define PIXEL_cyan          SysPixelIndex[11]
00189
00195 #define PIXEL_red           SysPixelIndex[12]
00196
00202 #define PIXEL_magenta       SysPixelIndex[13]
00203
00209 #define PIXEL_yellow        SysPixelIndex[14]
00210
00216 #define PIXEL_lightwhite    SysPixelIndex[15]
00217
00223 #define PIXEL_black         SysPixelIndex[16]
00224
00225 /* Compatiblity definitions */
00230 #define COLOR_invalid       PIXEL_invalid
00231
00236 #define COLOR_transparent   PIXEL_transparent
00237
00242 #define COLOR_darkred       PIXEL_darkred
00243
00248 #define COLOR_darkgreen     PIXEL_darkgreen
00249
00254 #define COLOR_darkyellow    PIXEL_darkyellow
00255
00260 #define COLOR_darkblue      PIXEL_darkblue
00261
00266 #define COLOR_darkmagenta   PIXEL_darkmagenta
00267
00272 #define COLOR_darkcyan      PIXEL_darkcyan
00273
00278 #define COLOR_lightgray     PIXEL_lightgray
00279
00284 #define COLOR_darkgray      PIXEL_darkgray
00285
00290 #define COLOR_red           PIXEL_red
00291
00296 #define COLOR_green         PIXEL_green
00297
00302 #define COLOR_yellow        PIXEL_yellow
00303
00308 #define COLOR_blue          PIXEL_blue
00309
00314 #define COLOR_magenta       PIXEL_magenta
00315
00320 #define COLOR_cyan          PIXEL_cyan
00321
00326 #define COLOR_lightwhite    PIXEL_lightwhite
00327
00332 #define COLOR_black         PIXEL_black
00333
00338 #define SysColorIndex       SysPixelIndex
00339
00371 typedef struct _BLOCKHEAP
00372 {
00373 #ifdef _MGRM_THREADS
00374     pthread_mutex_t lock;
00375 #endif
00376
00379     size_t          bd_size;
00383     size_t          heap_size;
00387     int             free;
00391     void*           heap;
00392 } BLOCKHEAP;
00393
00400 typedef BLOCKHEAP* PBLOCKHEAP;
00401
00424 MG_EXPORT extern void InitBlockDataHeap (PBLOCKHEAP heap,
00425                 size_t bd_size, size_t heap_size);
00426
00442 MG_EXPORT extern void* BlockDataAlloc (PBLOCKHEAP heap);
00443
00457 MG_EXPORT extern void BlockDataFree (PBLOCKHEAP heap, void* data);
00458
00467 MG_EXPORT extern void DestroyBlockDataHeap (PBLOCKHEAP heap);
00468
00478 struct _BITMAP;
00479
00484 typedef struct _BITMAP BITMAP;
00485
00491 typedef BITMAP* PBITMAP;
00492
00493 struct _MYBITMAP;
00494
00499 typedef struct _MYBITMAP MYBITMAP;
00500
00506 typedef struct _MYBITMAP* PMYBITMAP;
00507
00508
00545 typedef struct _CLIPRECT
00546 {
00550     RECT rc;
00554     struct _CLIPRECT* next;
00558     struct _CLIPRECT* prev;
00559 } CLIPRECT;
00560 typedef CLIPRECT* PCLIPRECT;
00561
00562 /* Clipping Region */
00563 #define NULLREGION      0x00
00564 #define SIMPLEREGION    0x01
00565 #define COMPLEXREGION   0x02
00566
00570 typedef struct _CLIPRGN
00571 {
00581     BYTE            type;
00585     BYTE            reserved[3];
00589     RECT            rcBound;
00593     PCLIPRECT       head;
00597     PCLIPRECT       tail;
00602     PBLOCKHEAP      heap;
00603 } CLIPRGN;
00604
00611 typedef CLIPRGN* PCLIPRGN;
00612
00626 #define InitFreeClipRectList(heap, size)    \
00627                 InitBlockDataHeap (heap, sizeof (CLIPRECT), size)
00628
00639 #define ClipRectAlloc(heap)     BlockDataAlloc (heap)
00640
00653 #define FreeClipRect(heap, cr)  BlockDataFree (heap, cr);
00654
00666 #define DestroyFreeClipRectList(heap)   DestroyBlockDataHeap (heap);
00667
00688 MG_EXPORT void GUIAPI InitClipRgn (PCLIPRGN pRgn, PBLOCKHEAP pFreeList);
00689
00700 MG_EXPORT void GUIAPI EmptyClipRgn (PCLIPRGN pRgn);
00701
00711 MG_EXPORT PCLIPRGN GUIAPI CreateClipRgn (void);
00712
00723 MG_EXPORT void GUIAPI DestroyClipRgn (PCLIPRGN pRgn);
00724
00741 MG_EXPORT BOOL GUIAPI ClipRgnCopy (PCLIPRGN pDstRgn, const CLIPRGN* pSrcRgn);
00742
00763 MG_EXPORT BOOL GUIAPI ClipRgnIntersect (PCLIPRGN pRstRgn,
00764                        const CLIPRGN* pRgn1, const CLIPRGN* pRgn2);
00765
00778 MG_EXPORT void GUIAPI GetClipRgnBoundRect (PCLIPRGN pRgn, PRECT pRect);
00779
00796 MG_EXPORT BOOL GUIAPI SetClipRgn (PCLIPRGN pRgn, const RECT* pRect);
00797
00811 MG_EXPORT BOOL GUIAPI IsEmptyClipRgn (const CLIPRGN* pRgn);
00812
00826 MG_EXPORT BOOL GUIAPI AddClipRect (PCLIPRGN pRgn, const RECT* pRect);
00827
00842 MG_EXPORT BOOL GUIAPI IntersectClipRect (PCLIPRGN pRgn, const RECT* pRect);
00843
00858 MG_EXPORT BOOL GUIAPI SubtractClipRect (PCLIPRGN pRgn, const RECT* pRect);
00859
00875 MG_EXPORT BOOL GUIAPI PtInRegion (PCLIPRGN region, int x, int y);
00876
00891 MG_EXPORT BOOL GUIAPI RectInRegion (PCLIPRGN region, const RECT* rect);
00892
00908 MG_EXPORT void GUIAPI OffsetRegionEx (PCLIPRGN region, const RECT *rcClient,
00909                             const RECT *rcScroll, int x, int y);
00910
00922 MG_EXPORT void GUIAPI OffsetRegion (PCLIPRGN region, int x, int y);
00923
00940 MG_EXPORT BOOL GUIAPI UnionRegion (PCLIPRGN dst,
00941                 const CLIPRGN* src1, const CLIPRGN* src2);
00942
00958 MG_EXPORT BOOL GUIAPI SubtractRegion (CLIPRGN* rgnD,
00959                 const CLIPRGN* rgnM, const CLIPRGN* rgnS);
00960
00977 MG_EXPORT BOOL GUIAPI XorRegion (CLIPRGN *dst,
00978                 const CLIPRGN *src1, const CLIPRGN *src2);
00979
00985 #define UnionRectWithRegion     AddClipRect
00986
00992 #define CopyRegion              ClipRgnCopy
00993
00999 #define IntersectRegion         ClipRgnIntersect
01000
01014 MG_EXPORT BOOL GUIAPI InitCircleRegion (PCLIPRGN dst, int x, int y, int r);
01015
01030 MG_EXPORT BOOL GUIAPI InitEllipseRegion (PCLIPRGN dst,
01031                 int x, int y, int rx, int ry);
01032
01045 MG_EXPORT BOOL GUIAPI InitPolygonRegion (PCLIPRGN dst,
01046                 const POINT* pts, int vertices);
01047
01093 #define HDC_SCREEN          0
01094
01095 /*
01096  * This is a system screen DC create for MiniGUI internal usage, for example,
01097  * menu and z-order operations
01098  */
01099 #define HDC_SCREEN_SYS      1
01100
01105 #define HDC_INVALID         0xFFFFFFFF
01106
01107 #define GDCAP_COLORNUM      0
01108 #define GDCAP_HPIXEL        1
01109 #define GDCAP_VPIXEL        2
01110 #define GDCAP_MAXX          3
01111 #define GDCAP_MAXY          4
01112 #define GDCAP_DEPTH         5
01113 #define GDCAP_BPP           6
01114 #define GDCAP_BITSPP        7
01115 #define GDCAP_RMASK         8
01116 #define GDCAP_GMASK         9
01117 #define GDCAP_BMASK         10
01118 #define GDCAP_AMASK         11
01119 #define GDCAP_PITCH         12
01120
01166 MG_EXPORT unsigned int GUIAPI GetGDCapability (HDC hdc, int iItem);
01167
01185 MG_EXPORT HDC GUIAPI GetDC (HWND hwnd);
01186
01204 MG_EXPORT HDC GUIAPI GetClientDC (HWND hwnd);
01205
01230 MG_EXPORT HDC GUIAPI GetSubDC (HDC hdc, int off_x, int off_y, int width, int height);
01231
01242 MG_EXPORT void GUIAPI ReleaseDC (HDC hdc);
01243
01257 MG_EXPORT HWND GUIAPI WindowFromDC (HDC hdc);
01258
01279 MG_EXPORT int GUIAPI SaveDC (HDC hdc);
01280
01306 MG_EXPORT BOOL GUIAPI RestoreDC (HDC hdc, int saved_dc);
01307
01308 #define MEMDC_FLAG_NONE             0x00000000  /* None. */
01309 #define MEMDC_FLAG_SWSURFACE        0x00000000  /* DC is in system memory */
01310 #define MEMDC_FLAG_HWSURFACE        0x00000001  /* DC is in video memory */
01311 #define MEMDC_FLAG_SRCCOLORKEY      0x00001000  /* Blit uses a source color key */
01312 #define MEMDC_FLAG_SRCALPHA         0x00010000  /* Blit uses source alpha blending*/
01313 #define MEMDC_FLAG_SRCPIXELALPHA    0x00020000  /* Blit uses source per-pixel alpha blending*/
01314 #define MEMDC_FLAG_RLEACCEL         0x00004000  /* Surface is RLE encoded */
01315
01336 MG_EXPORT HDC GUIAPI CreateCompatibleDCEx (HDC hdc, int width, int height);
01337
01352 MG_EXPORT BOOL GUIAPI IsCompatibleDC (HDC hdc1, HDC hdc2);
01353
01397 MG_EXPORT HDC GUIAPI CreateMemDCEx (int width, int height, int depth, DWORD flags,
01398         Uint32 Rmask, Uint32 Gmask, Uint32 Bmask, Uint32 Amask,
01399         void* bits, int pitch);
01400
01434 static inline HDC GUIAPI CreateMemDC (int width, int height, int depth, DWORD flags,
01435         Uint32 Rmask, Uint32 Gmask, Uint32 Bmask, Uint32 Amask)
01436 {
01437     return CreateMemDCEx (width, height, depth, flags, Rmask, Gmask, Bmask, Amask,
01438             NULL, 0);
01439 }
01440
01465 MG_EXPORT HDC GUIAPI CreateSubMemDC (HDC parent, int off_x, int off_y,
01466                 int width, int height, BOOL comp_to_parent);
01467
01483 MG_EXPORT HDC GUIAPI CreateMemDCFromBitmap (HDC hdc, const BITMAP* bmp);
01484
01510 MG_EXPORT HDC GUIAPI CreateMemDCFromMyBitmap (const MYBITMAP* my_bmp, const RGB* pal);
01511
01535 MG_EXPORT BOOL GUIAPI ConvertMemDC (HDC mem_dc, HDC ref_dc, DWORD flags);
01536
01566 MG_EXPORT BOOL GUIAPI SetMemDCAlpha (HDC mem_dc, DWORD flags, Uint8 alpha);
01567
01587 MG_EXPORT BOOL GUIAPI SetMemDCColorKey (HDC mem_dc, DWORD flags,
01588                 Uint32 color_key);
01589
01602 MG_EXPORT void GUIAPI DeleteMemDC (HDC mem_dc);
01603
01616 #define CreateCompatibleDC(hdc) CreateCompatibleDCEx(hdc, 0, 0)
01617
01628 #define DeleteCompatibleDC(hdc) DeleteMemDC(hdc)
01629
01667 MG_EXPORT Uint8* GUIAPI LockDC (HDC hdc, const RECT* rw_rc,
01668                 int* width, int* height, int* pitch);
01669
01686 typedef void (* CB_DIRECT_DRAW_RECT) (HDC hdc, Uint8 * pixels,
01687         int pitch, int bytesPerPixel, const RECT* rc, void* context);
01688
01715 MG_EXPORT BOOL GUIAPI LockDCEx (HDC hdc, const PCLIPRGN region,
01716         void* context, CB_DIRECT_DRAW_RECT cb);
01717
01726 MG_EXPORT void GUIAPI UnlockDC (HDC hdc);
01727
01746 MG_EXPORT HDC GUIAPI CreatePrivateDC (HWND hwnd);
01747
01767 MG_EXPORT HDC GUIAPI CreatePrivateClientDC (HWND hwnd);
01768
01795 HDC GUIAPI CreatePrivateSubDC(HDC hdc, int off_x, int off_y,
01796         int width, int height);
01797
01819 MG_EXPORT HDC GUIAPI GetPrivateClientDC (HWND hwnd);
01820
01830 MG_EXPORT void GUIAPI DeletePrivateDC (HDC hdc);
01831
01854 MG_EXPORT HDC GUIAPI CreateSecondaryDC (HWND hwnd);
01855
01871 typedef int (* ON_UPDATE_SECONDARYDC)(HWND hwnd, HDC secondary_dc,
01872         HDC real_dc, const RECT* secondary_rc, const RECT* real_rc,
01873         const RECT* main_update_rc);
01874
01875 #define ON_UPDSECDC_DEFAULT     ((ON_UPDATE_SECONDARYDC)0)
01876 #define ON_UPDSECDC_DONOTHING   ((ON_UPDATE_SECONDARYDC)0xFFFFFFFF)
01877
01903 MG_EXPORT HDC GUIAPI SetSecondaryDC (HWND hwnd, HDC secondary_dc,
01904         ON_UPDATE_SECONDARYDC on_update_secondarydc);
01905
01922 MG_EXPORT HDC GUIAPI GetSecondaryDC (HWND hwnd);
01923
01940 MG_EXPORT HDC GUIAPI GetSecondaryClientDC (HWND hwnd);
01941
01953 MG_EXPORT void GUIAPI ReleaseSecondaryDC (HWND hwnd, HDC hdc);
01954
01963 MG_EXPORT void GUIAPI DeleteSecondaryDC (HWND hwnd);
01964
01972 #define BM_TRANSPARENT          1
01973 #define BM_OPAQUE               0
01974
01975 #define DC_ATTR_BK_COLOR        0
01976 #define DC_ATTR_PEN_COLOR       1
01977 #define DC_ATTR_BRUSH_COLOR     2
01978 #define DC_ATTR_TEXT_COLOR      3
01979
01980 #define DC_ATTR_BK_MODE         4
01981
01982 #define DC_ATTR_TAB_STOP        5
01983 #define DC_ATTR_CHAR_EXTRA      6
01984 #define DC_ATTR_ALINE_EXTRA     7
01985 #define DC_ATTR_BLINE_EXTRA     8
01986
01987 #define DC_ATTR_MAP_MODE        9
01988
01989 #define DC_ATTR_TEXT_ALIGN      10
01990
01991 #ifdef _MGHAVE_ADV_2DAPI
01992
01993 #define DC_ATTR_PEN_TYPE        11
01994 #define DC_ATTR_PEN_CAP_STYLE   12
01995 #define DC_ATTR_PEN_JOIN_STYLE  13
01996 #define DC_ATTR_PEN_WIDTH       14
01997
01998 #define DC_ATTR_BRUSH_TYPE      15
01999
02000 #define NR_DC_ATTRS             16
02001
02002 #else
02003
02004 #define NR_DC_ATTRS             11
02005
02006 #endif
02007
02008
02053 MG_EXPORT Uint32 GUIAPI GetDCAttr (HDC hdc, int attr);
02054
02068 MG_EXPORT Uint32 GUIAPI SetDCAttr (HDC hdc, int attr, Uint32 value);
02069
02079 #define GetBkColor(hdc)     GetDCAttr (hdc, DC_ATTR_BK_COLOR)
02080
02096 #define GetBkMode(hdc)      GetDCAttr (hdc, DC_ATTR_BK_MODE)
02097
02107 #define GetPenColor(hdc)    GetDCAttr (hdc, DC_ATTR_PEN_COLOR)
02108
02118 #define GetBrushColor(hdc)  GetDCAttr (hdc, DC_ATTR_BRUSH_COLOR)
02119
02129 #define GetTextColor(hdc)   GetDCAttr (hdc, DC_ATTR_TEXT_COLOR)
02130
02140 #define GetTabStop(hdc)     GetDCAttr (hdc, DC_ATTR_TAB_STOP)
02141
02152 #define SetBkColor(hdc, color)  \
02153                 SetDCAttr (hdc, DC_ATTR_BK_COLOR, (DWORD) color)
02154
02172 #define SetBkMode(hdc, mode)    \
02173                 SetDCAttr (hdc, DC_ATTR_BK_MODE, (DWORD) mode)
02174
02185 #define SetPenColor(hdc, color) \
02186                 SetDCAttr (hdc, DC_ATTR_PEN_COLOR, (DWORD) color)
02187
02198 #define SetBrushColor(hdc, color)   \
02199                 SetDCAttr (hdc, DC_ATTR_BRUSH_COLOR, (DWORD) color)
02200
02211 #define SetTextColor(hdc, color)    \
02212                 SetDCAttr (hdc, DC_ATTR_TEXT_COLOR, (DWORD) color)
02213
02224 #define SetTabStop(hdc, value)  \
02225                 SetDCAttr (hdc, DC_ATTR_TAB_STOP, (DWORD) value)
02226
02227 #define ROP_SET         0
02228 #define ROP_AND         1
02229 #define ROP_OR          2
02230 #define ROP_XOR         3
02231 #define ROP_COMPOSITE   4
02232 #define ROP_COMP_USER   0x0100
02233 /* Reserved for future
02234  * #define ROP_COMP_XXX    0x01XX
02235  */
02236
02261 MG_EXPORT int GUIAPI GetRasterOperation (HDC hdc);
02262
02290 MG_EXPORT int GUIAPI SetRasterOperation (HDC hdc, int rop);
02291
02314 MG_EXPORT BOOL GUIAPI GetPalette (HDC hdc, int start, int len, GAL_Color* cmap);
02315
02330 MG_EXPORT BOOL GUIAPI SetPalette (HDC hdc, int start, int len, GAL_Color* cmap);
02331
02343 MG_EXPORT BOOL GUIAPI SetColorfulPalette (HDC hdc);
02344
02358 MG_EXPORT HPALETTE GUIAPI CreatePalette (GAL_Palette* pal);
02359
02375 MG_EXPORT BOOL GUIAPI SelectPalette (HDC hdc, HPALETTE hpal, BOOL reserved);
02376
02398 MG_EXPORT BOOL GUIAPI RealizePalette (HDC hdc);
02399
02413 MG_EXPORT BOOL GUIAPI ResizePalette (HPALETTE hpal, int len);
02414
02425 MG_EXPORT void GUIAPI DestroyPalette (HPALETTE hpal);
02426
02435 MG_EXPORT HPALETTE GUIAPI GetDefaultPalette (void);
02436
02453 MG_EXPORT int GUIAPI GetPaletteEntries (HPALETTE hpal,
02454                 int start, int len, GAL_Color* cmap);
02455
02472 MG_EXPORT int GUIAPI SetPaletteEntries (HPALETTE hpal,
02473                 int start, int len, GAL_Color* cmap);
02474
02493 MG_EXPORT UINT GUIAPI GetNearestPaletteIndex (HPALETTE hpal,
02494                 Uint8 red, Uint8 green, Uint8 blue);
02495
02513 MG_EXPORT RGBCOLOR GUIAPI GetNearestColor (HDC hdc,
02514                 Uint8 red, Uint8 green, Uint8 blue);
02515
02539 MG_EXPORT void GUIAPI SetPixel (HDC hdc, int x, int y, gal_pixel pixel);
02540
02559 MG_EXPORT gal_pixel GUIAPI SetPixelRGB (HDC hdc, int x, int y,
02560                 Uint8 r, Uint8 g, Uint8 b);
02561
02582 MG_EXPORT gal_pixel GUIAPI SetPixelRGBA (HDC hdc, int x, int y,
02583                 Uint8 r, Uint8 g, Uint8 b, Uint8 a);
02584
02600 MG_EXPORT gal_pixel GUIAPI GetPixel (HDC hdc, int x, int y);
02601
02623 MG_EXPORT gal_pixel GUIAPI GetPixelRGB (HDC hdc, int x, int y,
02624                 Uint8* r, Uint8* g, Uint8* b);
02625
02651 MG_EXPORT gal_pixel GUIAPI GetPixelRGBA (HDC hdc, int x, int y,
02652                 Uint8* r, Uint8* g, Uint8* b, Uint8* a);
02653
02668 MG_EXPORT void GUIAPI RGBA2Pixels (HDC hdc, const RGB* rgbs,
02669                 gal_pixel* pixels, int count);
02670
02689 static inline gal_pixel RGBA2Pixel (HDC hdc,
02690                 Uint8 r, Uint8 g, Uint8 b, Uint8 a)
02691 {
02692     RGB rgb = {r, g, b, a};
02693     gal_pixel pixel;
02694
02695     RGBA2Pixels (hdc, &rgb, &pixel, 1);
02696     return pixel;
02697 }
02698
02713 MG_EXPORT void GUIAPI RGB2Pixels (HDC hdc, const RGB* rgbs,
02714                 gal_pixel* pixels, int count);
02715
02733 static inline gal_pixel RGB2Pixel (HDC hdc, Uint8 r, Uint8 g, Uint8 b)
02734 {
02735     RGB rgb = {r, g, b, 0};
02736     gal_pixel pixel;
02737
02738     RGB2Pixels (hdc, &rgb, &pixel, 1);
02739     return pixel;
02740 }
02741
02756 MG_EXPORT void GUIAPI Pixel2RGBs (HDC hdc, const gal_pixel* pixels,
02757                 RGB* rgbs, int count);
02758
02780 static inline void Pixel2RGB (HDC hdc, gal_pixel pixel,
02781                 Uint8* r, Uint8* g, Uint8* b)
02782 {
02783     RGB rgb;
02784     Pixel2RGBs (hdc, &pixel, &rgb, 1);
02785     *r = rgb.r; *g = rgb.g, *b = rgb.b;
02786 }
02787
02802 MG_EXPORT void GUIAPI Pixel2RGBAs (HDC hdc, const gal_pixel* pixels,
02803                 RGB* rgbs, int count);
02804
02828 static inline void Pixel2RGBA (HDC hdc, gal_pixel pixel,
02829                 Uint8* r, Uint8* g, Uint8* b, Uint8* a)
02830 {
02831     RGB rgb;
02832     Pixel2RGBAs (hdc, &pixel, &rgb, 1);
02833     *r = rgb.r; *g = rgb.g, *b = rgb.b; *a = rgb.a;
02834 }
02835
02846 static inline DWORD Pixel2DWORD (HDC hdc, gal_pixel pixel)
02847 {
02848     Uint8 r,g,b,a;
02849     Pixel2RGBA (hdc, pixel, &r, &g, &b, &a);
02850     return MakeRGBA (r, g, b, a);
02851 }
02852
02853 #define PIXEL2DWORD(hdc, pixel) Pixel2DWORD(hdc, pixel)
02854
02865 static inline gal_pixel DWORD2PIXEL (HDC hdc, DWORD dword)
02866 {
02867     return RGBA2Pixel (hdc,
02868             GetRValue(dword), GetGValue(dword),
02869             GetBValue(dword), GetAValue(dword));
02870 }
02871
02889 MG_EXPORT void GUIAPI FocusRect (HDC hdc, int x0, int y0, int x1, int y1);
02890
02908 MG_EXPORT void GUIAPI DrawHVDotLine (HDC hdc, int x, int y, int w_h, BOOL H_V);
02909
02926 #define DrawHDotLine(hdc, x, y, w) DrawHVDotLine (hdc, x, y, w, TRUE);
02927
02944 #define DrawVDotLine(hdc, x, y, h) DrawHVDotLine (hdc, x, y, h, FALSE);
02945
02975 MG_EXPORT BOOL GUIAPI LineClipper (const RECT* cliprc,
02976                 int *_x0, int *_y0, int *_x1, int *_y1);
02977
02982 typedef void (* CB_LINE) (void* context, int stepx, int stepy);
02983
03006 MG_EXPORT void GUIAPI LineGenerator (void* context,
03007                 int x1, int y1, int x2, int y2, CB_LINE cb);
03008
03013 typedef void (* CB_CIRCLE) (void* context, int x1, int x2, int y);
03014
03042 MG_EXPORT void GUIAPI CircleGenerator (void* context,
03043                 int sx, int sy, int r, CB_CIRCLE cb);
03044
03049 typedef void (* CB_ELLIPSE) (void* context, int x1, int x2, int y);
03050
03075 MG_EXPORT void GUIAPI EllipseGenerator (void* context,
03076                 int sx, int sy, int rx, int ry, CB_ELLIPSE cb);
03077
03082 typedef void (* CB_ARC) (void* context, int x, int y);
03083
03107 MG_EXPORT void GUIAPI CircleArcGenerator (void* context,
03108                 int sx, int sy, int r, int ang1, int ang2, CB_ARC cb);
03109
03114 typedef void (* CB_POLYGON) (void* context, int x1, int x2, int y);
03115
03154 MG_EXPORT BOOL GUIAPI MonotoneVerticalPolygonGenerator (void* context,
03155                 const POINT* pts, int vertices, CB_POLYGON cb);
03156
03174 MG_EXPORT BOOL GUIAPI PolygonIsMonotoneVertical (const POINT* pts,
03175                 int vertices);
03176
03203 MG_EXPORT BOOL GUIAPI PolygonGeneratorEx (void* context,
03204                 const POINT* pts, int vertices, CB_POLYGON cb, RECT* rc_output);
03214 #define PolygonGenerator(context, pts, vertices, cb)          \
03215                 PolygonGeneratorEx(context, pts, vertices, cb, NULL)
03216
03221 typedef BOOL (* CB_EQUAL_PIXEL) (void* context, int x, int y);
03222
03227 typedef void (* CB_FLOOD_FILL) (void* context, int x1, int x2, int y);
03228
03249 MG_EXPORT BOOL GUIAPI FloodFillGenerator (void* context,
03250                 const RECT* src_rc, int x, int y,
03251                 CB_EQUAL_PIXEL cb_equal_pixel, CB_FLOOD_FILL cb_flood_fill);
03252
03253 /* DDA algorithm */
03254 #define BITMAP_SCALER_DDA       0
03255 /* Bilinear interpolation algorithm */
03256 #define BITMAP_SCALER_BILINEAR  1
03257
03274 MG_EXPORT int GUIAPI SetBitmapScalerType (HDC hdc,  int scaler_type);
03275
03289 MG_EXPORT void GUIAPI MoveTo (HDC hdc, int x, int y);
03290
03305 MG_EXPORT void GUIAPI LineTo (HDC hdc, int x, int y);
03306
03322 MG_EXPORT void GUIAPI Rectangle (HDC hdc, int x0, int y0, int x1, int y1);
03323
03338 MG_EXPORT void GUIAPI PolyLineTo (HDC hdc, const POINT* pts, int vertices);
03339
03354 MG_EXPORT void GUIAPI SplineTo (HDC hdc, const POINT* pts);
03355
03370 MG_EXPORT void GUIAPI Circle (HDC hdc, int sx, int sy, int r);
03371
03388 MG_EXPORT void GUIAPI Ellipse (HDC hdc, int sx, int sy, int rx, int ry);
03389
03411 MG_EXPORT void GUIAPI CircleArc (HDC hdc, int sx, int sy, int r,
03412                 int ang1, int ang2);
03413
03428 MG_EXPORT void GUIAPI FillBox (HDC hdc, int x, int y, int w, int h);
03429
03443 MG_EXPORT void GUIAPI FillCircle (HDC hdc, int sx, int sy, int r);
03444
03461 MG_EXPORT void GUIAPI FillEllipse (HDC hdc, int sx, int sy, int rx, int ry);
03462
03476 MG_EXPORT BOOL GUIAPI FillPolygon (HDC hdc, const POINT* pts, int vertices);
03477
03491 MG_EXPORT BOOL GUIAPI FloodFill (HDC hdc, int x, int y);
03492
03493 #ifdef _MGHAVE_ADV_2DAPI
03494
03503 typedef enum
03504 {
03509   PT_SOLID,
03514   PT_ON_OFF_DASH,
03521   PT_DOUBLE_DASH,
03522 } PenType;
03523
03533 #define GetPenType(hdc)                 \
03534                 GetDCAttr (hdc, DC_ATTR_PEN_TYPE)
03535
03546 #define SetPenType(hdc, type)           \
03547                 SetDCAttr (hdc, DC_ATTR_PEN_TYPE, (DWORD) type)
03548
03568 MG_EXPORT void GUIAPI SetPenDashes (HDC hdc, int dash_offset,
03569                 const unsigned char* dash_list, int n);
03570
03574 typedef enum
03575 {
03580   PT_CAP_BUTT,
03585   PT_CAP_ROUND,
03590   PT_CAP_PROJECTING
03591 } PTCapStyle;
03592
03602 #define GetPenCapStyle(hdc)                 \
03603                 GetDCAttr (hdc, DC_ATTR_PEN_CAP_STYLE)
03604
03615 #define SetPenCapStyle(hdc, style)          \
03616             SetDCAttr (hdc, DC_ATTR_PEN_CAP_STYLE, (DWORD) style)
03617
03621 typedef enum
03622 {
03626   PT_JOIN_MITER,
03630   PT_JOIN_ROUND,
03635   PT_JOIN_BEVEL
03636 } PTJoinStyle;
03637
03647 #define GetPenJoinStyle(hdc)           GetDCAttr (hdc, DC_ATTR_PEN_JOIN_STYLE)
03648
03659 #define SetPenJoinStyle(hdc, style)         \
03660             SetDCAttr (hdc, DC_ATTR_PEN_JOIN_STYLE, (DWORD) style)
03661
03671 #define GetPenWidth(hdc)                    \
03672                 GetDCAttr (hdc, DC_ATTR_PEN_WIDTH)
03673
03684 #define SetPenWidth(hdc, width)             \
03685                 SetDCAttr (hdc, DC_ATTR_PEN_WIDTH, (DWORD) width)
03686
03694 typedef enum
03695 {
03699   BT_SOLID,
03703   BT_TILED,
03710   BT_STIPPLED,
03717   BT_OPAQUE_STIPPLED
03718 } BrushType;
03719
03729 #define GetBrushType(hdc)               \
03730                 GetDCAttr (hdc, DC_ATTR_BRUSH_TYPE)
03731
03742 #define SetBrushType(hdc, type)         \
03743                 SetDCAttr (hdc, DC_ATTR_BRUSH_TYPE, (DWORD) type)
03744
03746 typedef struct _STIPPLE
03747 {
03749     int width;
03751     int height;
03752
03754     int pitch;
03755
03757     size_t size;
03758
03760     const unsigned char* bits;
03761 } STIPPLE;
03762
03774 MG_EXPORT void GUIAPI SetBrushInfo (HDC hdc,
03775                 const BITMAP* tile, const STIPPLE* stipple);
03776
03791 MG_EXPORT void GUIAPI SetBrushOrigin (HDC hdc, int x, int y);
03792
03810 MG_EXPORT void GUIAPI LineEx (HDC hdc, int x1, int y1, int x2, int y2);
03811
03835 MG_EXPORT void GUIAPI ArcEx (HDC hdc, int x, int y, int width, int height,
03836                 int ang1, int ang2);
03837
03861 MG_EXPORT void GUIAPI FillArcEx (HDC hdc, int x, int y, int width, int height,
03862                 int ang1, int ang2);
03863
03876 MG_EXPORT void GUIAPI PolyLineEx (HDC hdc, const POINT* pts, int nr_pts);
03877
03881 typedef struct _ARC
03882 {
03884     int x;
03886     int y;
03887
03889     int width;
03891     int height;
03892
03897     int angle1;
03901     int angle2;
03902 } ARC;
03903
03916 MG_EXPORT void GUIAPI PolyArcEx (HDC hdc, const ARC* arcs, int nr_arcs);
03917
03930 MG_EXPORT void GUIAPI PolyFillArcEx (HDC hdc, const ARC* arcs, int nr_arcs);
03931
03950 MG_EXPORT BOOL GUIAPI RoundRect (HDC hdc, int x0, int y0, int x1, int y1, int cw, int ch);
03951
03955 #endif
03956
04002 #define MM_TEXT               0
04003 #define MM_ANISOTROPIC        1
04004
04020 #define GetMapMode(hdc)         GetDCAttr (hdc, DC_ATTR_MAP_MODE)
04021
04037 #define SetMapMode(hdc, mapmode)        \
04038                 SetDCAttr (hdc, DC_ATTR_MAP_MODE, (DWORD)mapmode)
04039
04064 MG_EXPORT void GUIAPI GetDCLCS (HDC hdc, int which, POINT* pt);
04065
04090 MG_EXPORT void GUIAPI SetDCLCS (HDC hdc, int which, const POINT* pt);
04091
04092 #define DC_LCS_VORG     0
04093 #define DC_LCS_VEXT     1
04094 #define DC_LCS_WORG     2
04095 #define DC_LCS_WEXT     3
04096 #define NR_DC_LCS_PTS   4
04097
04111 #define GetViewportOrg(hdc, pPt)    GetDCLCS(hdc, DC_LCS_VORG, pPt)
04112
04126 #define GetViewportExt(hdc, pPt)    GetDCLCS(hdc, DC_LCS_VEXT, pPt)
04127
04141 #define GetWindowOrg(hdc, pPt)      GetDCLCS(hdc, DC_LCS_WORG, pPt)
04142
04156 #define GetWindowExt(hdc, pPt)      GetDCLCS(hdc, DC_LCS_WEXT, pPt)
04157
04171 #define SetViewportOrg(hdc, pPt)    SetDCLCS(hdc, DC_LCS_VORG, pPt)
04172
04186 #define SetViewportExt(hdc, pPt)    SetDCLCS(hdc, DC_LCS_VEXT, pPt)
04187
04201 #define SetWindowOrg(hdc, pPt)      SetDCLCS(hdc, DC_LCS_WORG, pPt)
04202
04216 #define SetWindowExt(hdc, pPt)      SetDCLCS(hdc, DC_LCS_WEXT, pPt)
04217
04236 MG_EXPORT void GUIAPI DPtoLP (HDC hdc, POINT* pPt);
04237
04238
04257 MG_EXPORT void GUIAPI LPtoDP (HDC hdc, POINT* pPt);
04258
04277 MG_EXPORT void GUIAPI SPtoLP(HDC hdc, POINT* pPt);
04278
04279
04298 MG_EXPORT void GUIAPI LPtoSP(HDC hdc, POINT* pPt);
04299
04320 MG_EXPORT void GUIAPI ExcludeClipRect (HDC hdc, const RECT* prc);
04321
04335 MG_EXPORT void GUIAPI IncludeClipRect (HDC hdc, const RECT* prc);
04336
04352 MG_EXPORT BOOL GUIAPI PtVisible (HDC hdc, int x, int y);
04353
04366 MG_EXPORT void GUIAPI ClipRectIntersect (HDC hdc, const RECT* prc);
04367
04380 MG_EXPORT void GUIAPI SelectClipRect (HDC hdc, const RECT* prc);
04381
04382 #define RGN_COPY        0x00
04383 #define RGN_DIFF        0x01
04384 #define RGN_AND         0x02
04385 #define RGN_OR          0x03
04386 #define RGN_XOR         0x04
04387
04442 MG_EXPORT int GUIAPI SelectClipRegionEx (HDC hdc, const CLIPRGN* pRgn,
04443                 int fnMode);
04444
04457 MG_EXPORT void GUIAPI SelectClipRegion (HDC hdc, const CLIPRGN* pRgn);
04458
04481 MG_EXPORT int GUIAPI OffsetClipRegion (HDC hdc, int nXOffset, int nYOffset);
04482
04495 MG_EXPORT void GUIAPI GetBoundsRect (HDC hdc, RECT* pRect);
04496
04514 MG_EXPORT BOOL GUIAPI RectVisible (HDC hdc, const RECT* pRect);
04515
04534 MG_EXPORT int GUIAPI GetClipBox (HDC hdc, RECT* clipbox);
04535
04554 MG_EXPORT int GUIAPI GetClipRegion (HDC hdc, CLIPRGN* cliprgn);
04555
04594 MG_EXPORT BOOL GUIAPI GetBitmapFromDC (HDC hdc,
04595                 int x, int y, int w, int h, BITMAP* bmp);
04596
04632 MG_EXPORT BOOL GUIAPI FillBoxWithBitmap (HDC hdc, int x, int y, int w, int h,
04633                 const BITMAP *bmp);
04634
04688 MG_EXPORT BOOL GUIAPI FillBoxWithBitmapPart (HDC hdc,
04689                 int x, int y, int w, int h,
04690                 int bw, int bh, const BITMAP* bmp, int xo, int yo);
04691
04714 MG_EXPORT BOOL GUIAPI FillBitmapPartInBox (HDC hdc, int box_x, int box_y,
04715                 int box_w, int box_h, const BITMAP* pbmp, int bmp_x, int bmp_y,
04716                 int bmp_w, int bmp_h);
04717
04751 MG_EXPORT void GUIAPI BitBlt (HDC hsdc, int sx, int sy, int sw, int sh,
04752                 HDC hddc, int dx, int dy, DWORD dwRop);
04753
04792 MG_EXPORT void GUIAPI StretchBlt (HDC hsdc, int sx, int sy, int sw, int sh,
04793                 HDC hddc, int dx, int dy, int dw, int dh, DWORD dwRop);
04794
04814 MG_EXPORT BOOL GUIAPI ScaleBitmapEx (BITMAP* dst, const BITMAP* src,
04815         HDC ref_dc);
04816
04817 #define ScaleBitmap(dst, src) ScaleBitmapEx(dst, src, HDC_SCREEN)
04818
04840 MG_EXPORT gal_pixel GUIAPI GetPixelInBitmapEx (const BITMAP* bmp, int x, int y, Uint8* alpha);
04841
04859 static inline gal_pixel GUIAPI GetPixelInBitmap (const BITMAP* bmp, int x, int y)
04860 {
04861     return GetPixelInBitmapEx (bmp, x, y, NULL);
04862 }
04863
04888 MG_EXPORT BOOL GUIAPI SetPixelInBitmapEx (const BITMAP* bmp,
04889                 int x, int y, gal_pixel pixel, const Uint8* alpha);
04890
04911 static inline BOOL GUIAPI SetPixelInBitmap (const BITMAP* bmp,
04912         int x, int y, gal_pixel pixel)
04913 {
04914     return SetPixelInBitmapEx (bmp, x, y, pixel, NULL);
04915 }
04916
04917 #ifdef _MGMISC_SAVESCREEN
04918
04937 MG_EXPORT BOOL GUIAPI SaveScreenRectContent (const RECT* rcWin,
04938                 const char* filename);
04939
04957 MG_EXPORT BOOL GUIAPI SaveMainWindowContent (HWND hWnd, const char* filename);
04958 #endif
04959
04984 MG_EXPORT HICON GUIAPI LoadIconFromFile (HDC hdc, const char* filename,
04985                 int which);
04986
05005 MG_EXPORT HICON GUIAPI LoadIconFromMem (HDC hdc, const void* area, int which);
05006
05031 MG_EXPORT HICON GUIAPI CreateIconEx (HDC hdc, int w, int h,
05032                 const BYTE* AndBits, const BYTE* XorBits, int colornum,
05033                 const RGB* pal);
05038 #define CreateIcon(hdc, w, h, AndBits, XorBits, colornum) \
05039         CreateIconEx(hdc, w, h, AndBits, XorBits, colornum, NULL)
05040
05041
05053 MG_EXPORT BOOL GUIAPI DestroyIcon (HICON hicon);
05054
05068 MG_EXPORT BOOL GUIAPI GetIconSize (HICON hicon, int* w, int* h);
05069
05087 MG_EXPORT void GUIAPI DrawIcon (HDC hdc,
05088                 int x, int y, int w, int h, HICON hicon);
05089
05111 static inline void SetRect (RECT* prc, int left, int top, int right, int bottom)
05112 {
05113     (prc)->left = left; (prc)->top = top;
05114     (prc)->right = right; (prc)->bottom = bottom;
05115 }
05116
05130 static inline void SetRectEmpty (RECT* prc)
05131 {
05132     (prc)->left = (prc)->top = (prc)->right = (prc)->bottom = 0;
05133 }
05134
05147 static inline void CopyRect (RECT* pdrc, const RECT* psrc)
05148 {
05149     (pdrc)->left = (psrc)->left; (pdrc)->top = (psrc)->top;
05150     (pdrc)->right = (psrc)->right; (pdrc)->bottom = (psrc)->bottom;
05151 }
05152
05168 static inline void OffsetRect (RECT* prc, int x, int y)
05169 {
05170     (prc)->left += x; (prc)->top += y; (prc)->right += x; (prc)->bottom += y;
05171 }
05172
05189 static inline void InflateRect (RECT* prc, int cx, int cy)
05190 {
05191     (prc)->left -= cx; (prc)->top -= cy;
05192     (prc)->right += cx; (prc)->bottom += cy;
05193 }
05194
05208 static inline void InflateRectToPt (RECT* prc, int x, int y)
05209 {
05210     if ((x) < (prc)->left) (prc)->left = (x);
05211     if ((y) < (prc)->top) (prc)->top = (y);
05212     if ((x) > (prc)->right) (prc)->right = (x);
05213     if ((y) > (prc)->bottom) (prc)->bottom = (y);
05214 }
05215
05231 static inline BOOL PtInRect(const RECT* prc, int x, int y)
05232 {
05233     if (x >= prc->left && x < prc->right && y >= prc->top && y < prc->bottom)
05234         return TRUE;
05235     return FALSE;
05236 }
05237
05250 MG_EXPORT BOOL GUIAPI IsRectEmpty (const RECT* prc);
05251
05264 MG_EXPORT BOOL GUIAPI EqualRect (const RECT* prc1, const RECT* prc2);
05265
05275 MG_EXPORT void GUIAPI NormalizeRect (RECT* pRect);
05276
05297 MG_EXPORT BOOL GUIAPI IntersectRect (RECT* pdrc,
05298                 const RECT* psrc1, const RECT* psrc2);
05299
05315 MG_EXPORT BOOL GUIAPI IsCovered (const RECT* prc1, const RECT* prc2);
05316
05330 MG_EXPORT BOOL GUIAPI DoesIntersect (const RECT* psrc1, const RECT* psrc2);
05331
05349 MG_EXPORT BOOL GUIAPI UnionRect (RECT* pdrc,
05350                 const RECT* psrc1, const RECT* psrc2);
05351
05367 MG_EXPORT void GUIAPI GetBoundRect (PRECT pdrc,
05368                 const RECT* psrc1, const RECT* psrc2);
05369
05386 MG_EXPORT int GUIAPI SubtractRect (RECT* rc, const RECT* psrc1, const RECT* psrc2);
05387
05392 #define RECTWP(prc)  ((prc)->right - (prc)->left)
05393
05397 #define RECTHP(prc)  ((prc)->bottom - (prc)->top)
05398
05402 #define RECTW(rc)    ((rc).right - (rc).left)
05403
05407 #define RECTH(rc)    ((rc).bottom - (rc).top)
05408
05422 /* Font-related structures */
05423 #define LEN_FONT_NAME               31
05424 #define LEN_DEVFONT_NAME            79
05425 #define LEN_UNIDEVFONT_NAME         127
05426
05427 #define FONT_WEIGHT_NIL             '\0'
05428 #define FONT_WEIGHT_ALL             '*'
05429 #define FONT_WEIGHT_BLACK           'c'
05430 #define FONT_WEIGHT_BOLD            'b'
05431 #define FONT_WEIGHT_BOOK            'k'
05432 #define FONT_WEIGHT_DEMIBOLD        'd'
05433 #define FONT_WEIGHT_LIGHT           'l'
05434 #define FONT_WEIGHT_MEDIUM          'm'
05435 #define FONT_WEIGHT_REGULAR         'r'
05436 #define FONT_WEIGHT_SUBPIXEL        's'
05437
05438 #define FS_WEIGHT_MASK              0x000000FF
05439 #define FS_WEIGHT_BLACK             0x00000001
05440 #define FS_WEIGHT_BOLD              0x00000002
05441 #define FS_WEIGHT_BOOK              0x00000004
05442 #define FS_WEIGHT_DEMIBOLD          0x00000006 /* BOOK | BOLD */
05443 #define FS_WEIGHT_LIGHT             0x00000010
05444 #define FS_WEIGHT_MEDIUM            0x00000020
05445 #define FS_WEIGHT_SUBPIXEL          0x00000040
05446 #define FS_WEIGHT_REGULAR           0x00000000
05447
05448 #define FONT_SLANT_NIL              '\0'
05449 #define FONT_SLANT_ALL              '*'
05450 #define FONT_SLANT_ITALIC           'i'
05451 #define FONT_SLANT_OBLIQUE          'o'
05452 #define FONT_SLANT_ROMAN            'r'
05453
05454 #define FS_SLANT_MASK               0x00000F00
05455 #define FS_SLANT_ITALIC             0x00000100
05456 #define FS_SLANT_OBLIQUE            0x00000200
05457 #define FS_SLANT_ROMAN              0x00000000
05458
05459 #define FONT_FLIP_NIL               '\0'
05460 #define FONT_FLIP_HORZ              'H'
05461 #define FONT_FLIP_VERT              'V'
05462 #define FONT_FLIP_HORZVERT          'T'
05463
05464 #define FS_FLIP_MASK                0x0000F000
05465 #define FS_FLIP_HORZ                0x00001000
05466 #define FS_FLIP_VERT                0x00002000
05467 #define FS_FLIP_HORZVERT            0x00003000 /* HORZ | VERT */
05468
05469 #define FONT_OTHER_NIL              '\0'
05470 #define FONT_OTHER_AUTOSCALE        'S'
05471 #define FONT_OTHER_TTFNOCACHE       'N'
05472 #define FONT_OTHER_TTFKERN          'K'
05473 #define FONT_OTHER_TTFNOCACHEKERN   'R'
05474 #define FONT_OTHER_LCDPORTRAIT      'P'
05475 #define FONT_OTHER_LCDPORTRAITKERN  'Q'
05476
05477 #define FS_OTHER_MASK               0x00FF0000
05478 #define FS_OTHER_AUTOSCALE          0x00010000
05479 #define FS_OTHER_TTFNOCACHE         0x00020000
05480 #define FS_OTHER_TTFKERN            0x00040000
05481 #define FS_OTHER_TTFNOCACHEKERN     0x00060000 /* KERN | NOCACHE */
05482 #define FS_OTHER_LCDPORTRAIT        0x00100000
05483 #define FS_OTHER_LCDPORTRAITKERN    0x00140000
05484
05485 /*
05486  * Backward compatiblilty definitions.
05487  * All FONT_SETWIDTH_* and FONT_SPACING_* types will
05488  * be treated as FONT_FLIP_NIL and FONT_OTHER_NIL respectively.
05489  */
05490 #define FONT_SETWIDTH_NIL           '\0'
05491 #define FONT_SETWIDTH_ALL           '*'
05492 #define FONT_SETWIDTH_BOLD          'b'
05493 #define FONT_SETWIDTH_CONDENSED     'c'
05494 #define FONT_SETWIDTH_SEMICONDENSED 's'
05495 #define FONT_SETWIDTH_NORMAL        'n'
05496 #define FONT_SETWIDTH_TTFNOCACHE    'w'
05497
05498 /*
05499 #define FS_SETWIDTH_MASK            0x0000F000
05500 #define FS_SETWIDTH_BOLD            0x00001000
05501 #define FS_SETWIDTH_CONDENSED       0x00002000
05502 #define FS_SETWIDTH_SEMICONDENSED   0x00004000
05503 #define FS_SETWIDTH_TTFNOCACHE      0x00008000
05504 #define FS_SETWIDTH_NORMAL          0x00000000
05505 */
05506
05507 #define FONT_SPACING_NIL            '\0'
05508 #define FONT_SPACING_ALL            '*'
05509 #define FONT_SPACING_MONOSPACING    'm'
05510 #define FONT_SPACING_PROPORTIONAL   'p'
05511 #define FONT_SPACING_CHARCELL       'c'
05512
05513 /*
05514 #define FS_SPACING_MASK             0x000F0000
05515 #define FS_SPACING_MONOSPACING      0x00010000
05516 #define FS_SPACING_PROPORTIONAL     0x00020000
05517 #define FS_SPACING_CHARCELL         0x00000000
05518 */
05519
05520 #define FONT_UNDERLINE_NIL          '\0'
05521 #define FONT_UNDERLINE_ALL          '*'
05522 #define FONT_UNDERLINE_LINE         'u'
05523 #define FONT_UNDERLINE_NONE         'n'
05524
05525 #define FS_UNDERLINE_MASK           0x00F00000
05526 #define FS_UNDERLINE_LINE           0x00100000
05527 #define FS_UNDERLINE_NONE           0x00000000
05528
05529 #define FONT_STRUCKOUT_NIL          '\0'
05530 #define FONT_STRUCKOUT_ALL          '*'
05531 #define FONT_STRUCKOUT_LINE         's'
05532 #define FONT_STRUCKOUT_NONE         'n'
05533
05534 #define FS_STRUCKOUT_MASK           0x0F000000
05535 #define FS_STRUCKOUT_LINE           0x01000000
05536 #define FS_STRUCKOUT_NONE           0x00000000
05537
05538 #define FONT_TYPE_NAME_LEN          3
05539 #define FONT_TYPE_NAME_BITMAP_RAW   "rbf"
05540 #define FONT_TYPE_NAME_BITMAP_VAR   "vbf"
05541 #define FONT_TYPE_NAME_BITMAP_QPF   "qpf"
05542 #define FONT_TYPE_NAME_BITMAP_UPF   "upf"
05543 #define FONT_TYPE_NAME_BITMAP_BMP   "bmp"
05544 #define FONT_TYPE_NAME_SCALE_TTF    "ttf"
05545 #define FONT_TYPE_NAME_SCALE_T1F    "t1f"
05546 #define FONT_TYPE_NAME_ALL          "*"
05547
05548 #define FONT_ETC_SECTION_NAME_VBF   "varbitmapfonts"
05549 #define FONT_ETC_SECTION_NAME_RBF   "rawbitmapfonts"
05550 #define FONT_ETC_SECTION_NAME_UPF   "upf"
05551 #define FONT_ETC_SECTION_NAME_QPF   "qpf"
05552 #define FONT_ETC_SECTION_NAME_TTF   "truetypefonts"
05553
05554 #define FONT_TYPE_BITMAP_RAW        0x0001  /* "rbf" */
05555 #define FONT_TYPE_BITMAP_VAR        0x0002  /* "vbf" */
05556 #define FONT_TYPE_BITMAP_QPF        0x0003  /* "qpf" */
05557 #define FONT_TYPE_BITMAP_BMP        0x0004  /* "bmp" */
05558 #define FONT_TYPE_BITMAP_UPF        0x0005  /* "upf" */
05559 #define FONT_TYPE_SCALE_TTF         0x0010  /* "ttf" */
05560 #define FONT_TYPE_SCALE_T1F         0x0011  /* "t1f" */
05561 #define FONT_TYPE_ALL               0x00FF  /* "all" */
05562
05563 #define FONT_CHARSET_US_ASCII       "US-ASCII"
05564
05565 #define FONT_CHARSET_ISO8859_1      "ISO8859-1"
05566 #define FONT_CHARSET_ISO8859_2      "ISO8859-2"
05567 #define FONT_CHARSET_ISO8859_3      "ISO8859-3"
05568 #define FONT_CHARSET_ISO8859_4      "ISO8859-4"
05569 #define FONT_CHARSET_ISO8859_5      "ISO8859-5"
05570 #define FONT_CHARSET_ISO8859_6      "ISO8859-6"
05571 #define FONT_CHARSET_ISO8859_7      "ISO8859-7"
05572 #define FONT_CHARSET_ISO8859_8      "ISO8859-8"
05573 #define FONT_CHARSET_ISO8859_9      "ISO8859-9"
05574 #define FONT_CHARSET_ISO8859_10     "ISO8859-10"
05575 #define FONT_CHARSET_ISO8859_11     "ISO8859-11"
05576 #define FONT_CHARSET_ISO8859_12     "ISO8859-12"
05577 #define FONT_CHARSET_ISO8859_13     "ISO8859-13"
05578 #define FONT_CHARSET_ISO8859_14     "ISO8859-14"
05579 #define FONT_CHARSET_ISO8859_15     "ISO8859-15"
05580 #define FONT_CHARSET_ISO8859_16     "ISO8859-16"
05581
05582 #define FONT_CHARSET_EUC_CN         "EUC-CN"
05583
05588 #define FONT_CHARSET_GB1988_0       "GB1988-0"
05589
05594 #define FONT_CHARSET_GB2312_0       "GB2312-0"
05595 #define FONT_CHARSET_GBK            "GBK"
05596
05601 #define FONT_CHARSET_GB18030_0      "GB18030-0"
05602 #define FONT_CHARSET_BIG5           "BIG5"
05603
05608 #define FONT_CHARSET_EUCTW          "EUC-TW"
05609 #define FONT_CHARSET_EUCKR          "EUC-KR"
05610
05615 #define FONT_CHARSET_KSC5636_0      "KSC5636-0"
05616
05621 #define FONT_CHARSET_KSC5601_0      "KSC5601-0"
05622 #define FONT_CHARSET_EUCJP          "EUC-JP"
05623
05628 #define FONT_CHARSET_JISX0201_0     "JISX0201-0"
05629
05634 #define FONT_CHARSET_JISX0208_0     "JISX0208-0"
05635 #define FONT_CHARSET_SHIFTJIS       "SHIFT-JIS"
05636
05641 #define FONT_CHARSET_JISX0201_1     "JISX0201-1"
05642
05647 #define FONT_CHARSET_JISX0208_1     "JISX0208-1"
05648
05653 #define FONT_CHARSET_ISO_10646_1    "ISO-10646-1"
05654
05659 #define FONT_CHARSET_UTF8           "UTF-8"
05660
05665 #define FONT_CHARSET_UTF16LE        "UTF-16LE"
05666
05671 #define FONT_CHARSET_UTF16BE        "UTF-16BE"
05672
05673 #define FONT_MAX_SIZE               256
05674 #define FONT_MIN_SIZE               4
05675
05676 struct _DEVFONT;
05677 typedef struct _DEVFONT DEVFONT;
05678
05680 typedef struct _LOGFONT {
05682     char type [LEN_FONT_NAME + 1];
05684     char family [LEN_FONT_NAME + 1];
05686     char charset [LEN_FONT_NAME + 1];
05688     DWORD style;
05690     int size;
05692     int rotation;
05694     int ascent;
05696     int descent;
05698     unsigned short sbc_scale;
05700     unsigned short mbc_scale;
05702     DEVFONT* sbc_devfont;
05704     DEVFONT* mbc_devfont;
05705 } LOGFONT;
05710 typedef LOGFONT*    PLOGFONT;
05715 typedef const LOGFONT*    CPLOGFONT;
05716
05717 struct _WORDINFO;
05722 typedef struct _WORDINFO WORDINFO;
05723
05724 #define MAX_LEN_MCHAR               6
05725
05726 typedef unsigned short  UChar16;
05727 typedef int    UChar32;
05728
05729 #define MCHAR_TYPE_UNKNOWN          0xFFFF
05730 #define MCHAR_TYPE_NUL              0x0000
05731 #define MCHAR_TYPE_CTRL1            0x0100
05732 #define MCHAR_TYPE_BEL              0x0200
05733 #define MCHAR_TYPE_BS               0x0300
05734 #define MCHAR_TYPE_HT               0x0400
05735 #define MCHAR_TYPE_LF               0x0500
05736 #define MCHAR_TYPE_VT               0x0600
05737 #define MCHAR_TYPE_FF               0x0700
05738 #define MCHAR_TYPE_CR               0x0800
05739 #define MCHAR_TYPE_CTRL2            0x0900
05740 #define MCHAR_TYPE_SPACE            0x0A00
05741 #define MCHAR_TYPE_ZEROWIDTH        0x0B00
05742 #define MCHAR_TYPE_GENERIC          0x0C00
05743 #define MCHAR_TYPE_NOSPACING_MARK   0x0001
05744 #define MCHAR_TYPE_LIGATURE         (MCHAR_TYPE_NOSPACING_MARK |0x0D00)
05745 #define MCHAR_TYPE_VOWEL            (MCHAR_TYPE_NOSPACING_MARK |0x0E00)
05746 #define MCHAR_TYPE_VOWEL_ABOVE      (MCHAR_TYPE_VOWEL |0x0002)
05747 #define MCHAR_TYPE_VOWEL_BELLOW     (MCHAR_TYPE_VOWEL |0x0004)
05748
05749 #define MCHAR_TYPE_ASCII            0x0080
05750 #define MCHAR_TYPE_LATIN1           0x0081
05751 #define MCHAR_TYPE_LATIN2           0x0082
05752 #define MCHAR_TYPE_LATIN3           0x0083
05753 #define MCHAR_TYPE_LATIN4           0x0084
05754 #define MCHAR_TYPE_LATIN5           0x0085
05755 #define MCHAR_TYPE_LATIN6           0x0086
05756 #define MCHAR_TYPE_LATIN7           0x0087
05757 #define MCHAR_TYPE_LATIN8           0x0088
05758 #define MCHAR_TYPE_LATIN9           0x0089
05759 #define MCHAR_TYPE_LATIN10          0x008A
05760 #define MCHAR_TYPE_CYRILLIC         0x008B
05761 #define MCHAR_TYPE_ARABIC           0x008C
05762 #define MCHAR_TYPE_GREEK            0x008D
05763 #define MCHAR_TYPE_HEBREW           0x008E
05764 #define MCHAR_TYPE_THAI             0x008F
05765
05766 #define MCHAR_TYPE_DIGIT            0x0091
05767 #define MCHAR_TYPE_SYMBOL_PUNCT     0x0092
05768 #define MCHAR_TYPE_SYMBOL_MATH      0x0093
05769 #define MCHAR_TYPE_SYMBOL_OTHER     0x0094
05770 #define MCHAR_TYPE_FW_DIGIT         0x0095
05771 #define MCHAR_TYPE_FW_SYM_PUNCT     0x0096
05772 #define MCHAR_TYPE_FW_SYM_MATH      0x0097
05773 #define MCHAR_TYPE_FW_SYM_OTHER     0x0098
05774
05775 #define MCHAR_TYPE_HANGUL           0x00A1
05776 #define MCHAR_TYPE_KATAKANA         0x00A2
05777 #define MCHAR_TYPE_CJK              0x00A3
05778
05779 struct _FONTOPS;
05780 struct _CHARSETOPS;
05781
05782 typedef struct _FONTOPS FONTOPS;
05783 typedef struct _CHARSETOPS CHARSETOPS;
05784
05785 /* charops fontops devont structure is  here. */
05787 struct _DEVFONT
05788 {
05790     char             name [LEN_UNIDEVFONT_NAME + 1];
05791
05793     DWORD            style;
05794
05796     FONTOPS*         font_ops;
05797
05799     CHARSETOPS*      charset_ops;
05800
05802     struct _DEVFONT* next;
05803
05805     void*            data;
05806
05808     void*            relationship;
05809
05811     BOOL             need_unload;
05812 };
05813
05814 #define SBC_DEVFONT_INFO(logfont) (logfont.sbc_devfont)
05815 #define MBC_DEVFONT_INFO(logfont) (logfont.mbc_devfont)
05816
05817 #define SBC_DEVFONT_INFO_P(logfont) (logfont->sbc_devfont)
05818 #define MBC_DEVFONT_INFO_P(logfont) (logfont->mbc_devfont)
05819
05824 #define INV_LOGFONT     0
05825
05827 typedef struct _FONTMETRICS
05828 {
05830     int font_height;
05832     int ascent;
05834     int descent;
05835
05837     int max_width;
05839     int ave_width;
05840 } FONTMETRICS;
05841
05856 MG_EXPORT void GUIAPI GetFontMetrics (LOGFONT* log_font,
05857                 FONTMETRICS* font_metrics);
05858
05860 typedef struct _GLYPHBITMAP
05861 {
05863     int bbox_x, bbox_y, bbox_w, bbox_h;
05865     int advance_x, advance_y;
05866
05868     size_t bmp_size;
05870     int bmp_pitch;
05872     const unsigned char* bits;
05873 } GLYPHBITMAP;
05874
05901 MG_EXPORT void GUIAPI GetGlyphBitmap (LOGFONT* log_font,
05902                 const char* mchar, int mchar_len,
05903                 GLYPHBITMAP* glyph_bitmap);
05904
05905 #ifndef _MGRM_THREADS
05906
05925 MG_EXPORT BOOL GUIAPI InitVectorialFonts (void);
05926
05927
05940 MG_EXPORT void GUIAPI TermVectorialFonts (void);
05941
05942 #endif
05943
06048 MG_EXPORT PLOGFONT GUIAPI CreateLogFont (const char* type, const char* family,
06049         const char* charset, char weight, char slant, char flip,
06050         char other, char underline, char struckout,
06051         int size, int rotation);
06052
06066 MG_EXPORT PLOGFONT GUIAPI CreateLogFontByName (const char* font_name);
06067
06079 MG_EXPORT PLOGFONT GUIAPI CreateLogFontIndirect (LOGFONT* logfont);
06080
06091 MG_EXPORT void GUIAPI DestroyLogFont (PLOGFONT log_font);
06092
06106 MG_EXPORT void GUIAPI GetLogFontInfo (HDC hdc, LOGFONT* log_font);
06107
06120 MG_EXPORT PLOGFONT GUIAPI GetCurFont (HDC hdc);
06121
06140 MG_EXPORT PLOGFONT GUIAPI SelectFont (HDC hdc, PLOGFONT log_font);
06141
06152 MG_EXPORT const DEVFONT* GUIAPI GetNextDevFont (const DEVFONT* dev_font);
06153
06154
06155 #ifdef _MGFONT_FT2
06156
06161 typedef enum
06162 {
06164     MG_SMOOTH_NONE = 0,
06166     MG_SMOOTH_DEFAULT = 1,
06168     MG_SMOOTH_LIGHT = 2,
06170     MG_SMOOTH_LEGACY = 16,
06172     MG_SMOOTH_MAX    /*do not remove*/
06173 } mg_FT_LcdFilter;
06174
06190 MG_EXPORT BOOL GUIAPI ft2SetLcdFilter (LOGFONT* logfont, mg_FT_LcdFilter filter);
06191
06192 #endif
06193
06194 #if defined(_MGFONT_QPF) || defined(_MGFONT_FT2) || defined(_MGFONT_TTF) || defined(_MGFONT_UPF)
06195
06211 MG_EXPORT DEVFONT* GUIAPI LoadDevFontFromFile (const char *devfont_name,
06212         const char *file_name);
06213
06223 MG_EXPORT void GUIAPI DestroyDynamicDevFont (DEVFONT **devfont);
06224 #endif
06225
06244 #define SYSLOGFONT_DEFAULT          0
06245
06250 #define SYSLOGFONT_WCHAR_DEF        1
06251
06256 #define SYSLOGFONT_FIXED            2
06257
06262 #define SYSLOGFONT_CAPTION          3
06263
06268 #define SYSLOGFONT_MENU             4
06269
06274 #define SYSLOGFONT_CONTROL          5
06275
06276 #define NR_SYSLOGFONTS              6
06277
06278
06279 extern MG_EXPORT PLOGFONT g_SysLogFont [];
06280
06304 static inline PLOGFONT GUIAPI GetSystemFont (int font_id)
06305 {
06306     if (font_id >= 0 && font_id < NR_SYSLOGFONTS)
06307         return g_SysLogFont [font_id];
06308     else
06309         return (PLOGFONT)NULL;
06310 }
06311
06326 MG_EXPORT int GUIAPI GetSysFontMaxWidth (int font_id);
06327
06342 MG_EXPORT int GUIAPI GetSysFontAveWidth (int font_id);
06343
06357 MG_EXPORT int GUIAPI GetSysFontHeight (int font_id);
06358
06373 MG_EXPORT const char* GUIAPI GetSysCharset (BOOL wchar);
06374
06389 MG_EXPORT int GUIAPI GetSysCharHeight (void);
06390
06404 MG_EXPORT int GUIAPI GetSysCharWidth (void);
06405
06417 MG_EXPORT int GUIAPI GetSysCCharWidth (void);
06418
06432 struct _WORDINFO
06433 {
06435     int len;
06437     unsigned char delimiter;
06439     int nr_delimiters;
06440 };
06441
06461 MG_EXPORT int GUIAPI GetTextMCharInfo (PLOGFONT log_font,
06462                 const char* mstr, int len, int* pos_chars);
06463
06487 MG_EXPORT int GUIAPI GetTextWordInfo (PLOGFONT log_font, const char* mstr,
06488                 int len, int* pos_words, WORDINFO* info_words);
06489
06505 MG_EXPORT int GUIAPI GetFirstMCharLen (PLOGFONT log_font,
06506                 const char* mstr, int len);
06507
06528 MG_EXPORT int GUIAPI GetFirstWord (PLOGFONT log_font,
06529                 const char* mstr, int len, WORDINFO* word_info);
06530
06531 #ifdef _MGCHARSET_UNICODE
06532
06533 #include <stddef.h>
06534 #include <stdlib.h>
06535
06556 MG_EXPORT int GUIAPI MB2WCEx (PLOGFONT log_font, void* dest, BOOL wc32,
06557                 const unsigned char* mstr, int n);
06558
06565 #define MB2WC(log_font, dest, mstr, n) \
06566                    MB2WCEx (log_font, dest, sizeof(wchar_t) == 4, mstr, n)
06567
06585 MG_EXPORT int GUIAPI WC2MBEx (PLOGFONT log_font, unsigned char *s, UChar32 wc);
06586
06593 #define WC2MB(log_font, s, wc) \
06594                    WC2MBEx (log_font, s, (UChar32)wc)
06595
06628 MG_EXPORT int GUIAPI MBS2WCSEx (PLOGFONT log_font, void* dest, BOOL wc32,
06629                 const unsigned char* mstr, int mstr_len, int n,
06630                 int* conved_mstr_len);
06631
06638 #define MBS2WCS(log_font, dest, mstr, mstr_len, n) \
06639             MBS2WCSEx(log_font, dest, sizeof (wchar_t) == 4, mstr, \
06640             mstr_len, n, NULL)
06641
06674 MG_EXPORT int GUIAPI WCS2MBSEx (PLOGFONT log_font, unsigned char* dest,
06675                 const void *wcs, int wcs_len, BOOL wc32, int n,
06676                 int* conved_wcs_len);
06677
06684 #define WCS2MBS(log_font, dest, wcs, wcs_len, n) \
06685             WCS2MBSEx (log_font, dest, wcs, wcs_len, sizeof (wchar_t) == 4, \
06686             n, NULL)
06687
06688 #endif /* _MGCHARSET_UNICODE */
06689
06721 MG_EXPORT int GUIAPI GetTextExtentPoint (HDC hdc, const char* text, int len,
06722                 int max_extent, int* fit_chars, int* pos_chars,
06723                 int* dx_chars, SIZE* size);
06724
06733 MG_EXPORT int GUIAPI GetTabbedTextExtentPoint (HDC hdc,
06734                 const char* text, int len, int max_extent,
06735                 int* fit_chars, int* pos_chars, int* dx_chars, SIZE* size);
06736
06756 MG_EXPORT int GUIAPI GetFontHeight (HDC hdc);
06757
06771 MG_EXPORT int GUIAPI GetMaxFontWidth (HDC hdc);
06772
06773
06792 MG_EXPORT int GUIAPI GetTextExtent (HDC hdc,
06793                 const char* spText, int len, SIZE* pSize);
06794
06815 MG_EXPORT int GUIAPI GetTabbedTextExtent (HDC hdc,
06816                 const char* spText, int len, SIZE* pSize);
06817
06824 #define GetTextCharacterExtra(hdc)  GetDCAttr (hdc, DC_ATTR_CHAR_EXTRA)
06825
06832 #define GetTextAboveLineExtra(hdc)  GetDCAttr (hdc, DC_ATTR_ALINE_EXTRA)
06833
06840 #define GetTextBellowLineExtra(hdc) GetDCAttr (hdc, DC_ATTR_BLINE_EXTRA)
06841
06849 #define SetTextCharacterExtra(hdc, extra)       \
06850                 SetDCAttr (hdc, DC_ATTR_CHAR_EXTRA, (DWORD) extra)
06851
06858 #define SetTextAboveLineExtra(hdc, extra)       \
06859                 SetDCAttr (hdc, DC_ATTR_ALINE_EXTRA, (DWORD) extra)
06860
06867 #define SetTextBellowLineExtra(hdc, extra)      \
06868                 SetDCAttr (hdc, DC_ATTR_BLINE_EXTRA, (DWORD) extra)
06869
06870 #define TA_LEFT         0x0000
06871 #define TA_RIGHT        0x0001
06872 #define TA_CENTER       0x0002
06873 #define TA_X_MASK       0x000F
06874
06875 #define TA_TOP          0x0000
06876 #define TA_BASELINE     0x0010
06877 #define TA_BOTTOM       0x0020
06878 #define TA_Y_MASK       0x00F0
06879
06880 #define TA_NOUPDATECP   0x0000
06881 #define TA_UPDATECP     0x0100
06882 #define TA_CP_MASK      0x0F00
06883
06935 #define GetTextAlign(hdc)         GetDCAttr (hdc, DC_ATTR_TEXT_ALIGN)
06936
06993 #define SetTextAlign(hdc, ta_flags)        \
06994                 SetDCAttr (hdc, DC_ATTR_TEXT_ALIGN, (DWORD)ta_flags)
06995
07014 MG_EXPORT int GUIAPI TextOutLen (HDC hdc, int x, int y,
07015                 const char* spText, int len);
07016
07017
07039 MG_EXPORT int GUIAPI TextOutOmitted (HDC hdc, int x, int y,
07040                 const char *mtext, int len, int max_extent);
07041
07063 MG_EXPORT int GUIAPI TabbedTextOutLen (HDC hdc, int x, int y,
07064                 const char* spText, int len);
07065
07092 MG_EXPORT int GUIAPI TabbedTextOutEx (HDC hdc, int x, int y,
07093                 const char* spText, int nCount,
07094                 int nTabPositions, int *pTabPositions, int nTabOrigin);
07095
07105 MG_EXPORT void GUIAPI GetLastTextOutPos (HDC hdc, POINT* pt);
07106
07115 #define TextOut(hdc, x, y, text)    TextOutLen (hdc, x, y, text, -1)
07116
07125 #define TabbedTextOut(hdc, x, y, text)  TabbedTextOutLen (hdc, x, y, text, -1)
07126
07127 #define DT_TOP              0x00000000
07128 #define DT_LEFT             0x00000000
07129 #define DT_CENTER           0x00000001
07130 #define DT_RIGHT            0x00000002
07131 #define DT_VCENTER          0x00000004
07132 #define DT_BOTTOM           0x00000008
07133 #define DT_WORDBREAK        0x00000010
07134 #define DT_SINGLELINE       0x00000020
07135 #define DT_EXPANDTABS       0x00000040
07136 #define DT_TABSTOP          0x00000080
07137 #define DT_NOCLIP           0x00000100
07138 #define DT_EXTERNALLPADING  0x00000200
07139 #define DT_CALCRECT         0x00000400
07140 #define DT_NOPREFIX         0x00000800
07141 #define DT_INTERNAL         0x00001000
07142 #define DT_CHARBREAK        0x00002000
07143
07147 typedef struct _DTFIRSTLINE
07148 {
07150     int nr_chars;
07152     int startx;
07154     int starty;
07156     int width;
07158     int height;
07159 } DTFIRSTLINE;
07160
07236 MG_EXPORT int GUIAPI DrawTextEx2 (HDC hdc, const char* pText, int nCount,
07237                 RECT* pRect, int nIndent, UINT nFormat, DTFIRSTLINE *firstline);
07238
07248 #define DrawText(hdc, text, n, rc, format)          \
07249                 DrawTextEx2 (hdc, text, n, rc, 0, format, NULL)
07250
07259 #define DrawTextEx(hdc, text, n, rc, indent, format)    \
07260                 DrawTextEx2 (hdc, text, n, rc, indent, format, NULL)
07261
07272 #define MYBMP_TYPE_NORMAL       0x00000000
07273 #define MYBMP_TYPE_RLE4         0x00000001
07274 #define MYBMP_TYPE_RLE8         0x00000002
07275 #define MYBMP_TYPE_RGB          0x00000003
07276 #define MYBMP_TYPE_BGR          0x00000004
07277 #define MYBMP_TYPE_RGBA         0x00000005
07278 #define MYBMP_TYPE_MASK         0x0000000F
07279
07280 #define MYBMP_FLOW_DOWN         0x00000010
07281 #define MYBMP_FLOW_UP           0x00000020
07282 #define MYBMP_FLOW_MASK         0x000000F0
07283
07284 #define MYBMP_TRANSPARENT       0x00000100
07285 #define MYBMP_ALPHACHANNEL      0x00000200
07286 #define MYBMP_ALPHA             0x00000400
07287
07288 #define MYBMP_RGBSIZE_3         0x00001000
07289 #define MYBMP_RGBSIZE_4         0x00002000
07290
07291 #define MYBMP_LOAD_GRAYSCALE    0x00010000
07292 #define MYBMP_LOAD_ALLOCATE_ONE 0x00020000
07293 #define MYBMP_LOAD_NONE         0x00000000
07294
07296 struct _MYBITMAP
07297 {
07327     DWORD flags;
07329     int   frames;
07331     Uint8 depth;
07333     Uint8 alpha;
07334     Uint8 reserved [2];
07336     Uint32 transparent;
07337
07339     Uint32 w;
07341     Uint32 h;
07343     Uint32 pitch;
07345     Uint32 size;
07346
07348     BYTE* bits;
07349 };
07350
07351 #define BMP_TYPE_NORMAL         0x00
07352 #define BMP_TYPE_RLE            0x01
07353 #define BMP_TYPE_ALPHA          0x02
07354 #define BMP_TYPE_ALPHACHANNEL   0x04
07355 #define BMP_TYPE_COLORKEY       0x10
07356
07357 #define BMP_TYPE_ALPHA_MASK     0x20
07358 #define BMP_TYPE_PRIV_PIXEL     0x00
07359
07360 #ifdef _FOR_MONOBITMAP
07361   #define BMP_TYPE_MONOKEY      0x40
07362 #endif
07363
07365 struct _BITMAP
07366 {
07396     Uint8   bmType;
07398     Uint8   bmBitsPerPixel;
07400     Uint8   bmBytesPerPixel;
07402     Uint8   bmAlpha;
07404     Uint32  bmColorKey;
07405 #ifdef _FOR_MONOBITMAP
07406     Uint32  bmColorRep;
07407 #endif
07408
07410     Uint32  bmWidth;
07412     Uint32  bmHeight;
07414     Uint32  bmPitch;
07416     Uint8*  bmBits;
07417
07419     /*void*   bmAlphaPixelFormat;*/
07421     Uint8*  bmAlphaMask;
07422 };
07423
07435 #include <stdio.h>
07436 #include "endianrw.h"
07437
07442 typedef void (* CB_ONE_SCANLINE) (void* context, MYBITMAP* my_bmp, int y);
07443
07478 MG_EXPORT BOOL GUIAPI RegisterBitmapFileType (const char *ext,
07479             void* (*init) (MG_RWops* fp, MYBITMAP *my_bmp, RGB *pal),
07480             int (*load) (MG_RWops* fp, void* init_info, MYBITMAP *my_bmp,
07481                     CB_ONE_SCANLINE cb, void* context),
07482             void (*cleanup) (void* init_info),
07483             int (*save) (MG_RWops* fp, MYBITMAP *my_bmp, RGB *pal),
07484             BOOL (*check) (MG_RWops* fp));
07485
07501 MG_EXPORT const char* GUIAPI CheckBitmapType (MG_RWops* fp);
07502
07544 #define MLS_BLENDMODE_NONE           0x00
07545 #define MLS_BLENDMODE_COLORKEY       0x01
07546 #define MLS_BLENDMODE_ALPHA          0x02
07547
07548 #define MLS_INFOMASK_OFFSET          0x01
07549 #define MLS_INFOMASK_BLEND           0x02
07550 #define MLS_INFOMASK_ZORDER          0x04
07551 #define MLS_INFOMASK_ALL             0x07
07552 #define MLS_INFOMASK_ENABLE          0x08
07553
07554 MG_EXPORT BOOL GUIAPI mlsSetSlaveScreenInfo (HDC dc_mls, DWORD mask, int offset_x, int offset_y,
07555         DWORD blend_flags, gal_pixel color_key, int alpha, int z_order);
07556
07557 MG_EXPORT BOOL GUIAPI mlsGetSlaveScreenInfo (HDC dc_mls, DWORD mask, int* offset_x, int* offset_y,
07558                         DWORD blend_flags, gal_pixel* color_key, int* alpha, int* z_order);
07572 MG_EXPORT BOOL GUIAPI mlsEnableSlaveScreen (HDC dc_mls, BOOL enable);
07573
07574
07575 #define ERR_BMP_OK              0
07576 #define ERR_BMP_IMAGE_TYPE      -1
07577 #define ERR_BMP_UNKNOWN_TYPE    -2
07578 #define ERR_BMP_CANT_READ       -3
07579 #define ERR_BMP_CANT_SAVE       -4
07580 #define ERR_BMP_NOT_SUPPORTED   -5
07581 #define ERR_BMP_MEM             -6
07582 #define ERR_BMP_LOAD            -7
07583 #define ERR_BMP_FILEIO          -8
07584 #define ERR_BMP_OTHER           -9
07585 #define ERR_BMP_ERROR_SOURCE    -10
07586
07613 MG_EXPORT int GUIAPI LoadBitmapEx (HDC hdc, PBITMAP pBitmap,
07614                 MG_RWops* area, const char* ext);
07615
07623 MG_EXPORT int GUIAPI LoadBitmapFromFile (HDC hdc, PBITMAP pBitmap,
07624                 const char* spFileName);
07625
07632 #define LoadBitmap  LoadBitmapFromFile
07633
07641 MG_EXPORT int GUIAPI LoadBitmapFromMem (HDC hdc, PBITMAP pBitmap,
07642                 const void* mem, int size, const char* ext);
07643
07655 MG_EXPORT void GUIAPI UnloadBitmap (PBITMAP pBitmap);
07656
07671 MG_EXPORT void GUIAPI ReplaceBitmapColor (HDC hdc, PBITMAP pBitmap,
07672                 gal_pixel iOColor, gal_pixel iNColor);
07673
07683 MG_EXPORT void GUIAPI HFlipBitmap (BITMAP* bmp, unsigned char* inter_buff);
07684
07694 MG_EXPORT void GUIAPI VFlipBitmap (BITMAP* bmp, unsigned char* inter_buff);
07695
07714 MG_EXPORT void* GUIAPI InitMyBitmapSL (MG_RWops* area,
07715                 const char* ext, MYBITMAP* my_bmp, RGB* pal);
07716
07735 MG_EXPORT int GUIAPI LoadMyBitmapSL (MG_RWops* area, void* load_info,
07736                 MYBITMAP* my_bmp, CB_ONE_SCANLINE cb, void* context);
07737
07752 MG_EXPORT int GUIAPI CleanupMyBitmapSL (MYBITMAP* my_bmp, void* load_info);
07753
07769 MG_EXPORT int GUIAPI LoadMyBitmapEx (PMYBITMAP my_bmp, RGB* pal,
07770                 MG_RWops* area, const char* ext);
07771
07779 MG_EXPORT int GUIAPI LoadMyBitmapFromFile (PMYBITMAP my_bmp, RGB* pal,
07780                 const char* file_name);
07781
07788 #define LoadMyBitmap    LoadMyBitmapFromFile
07789
07805 MG_EXPORT int GUIAPI LoadMyBitmapFromMem (PMYBITMAP my_bmp, RGB* pal,
07806                 const void* mem, int size, const char* ext);
07807
07819 MG_EXPORT void GUIAPI UnloadMyBitmap (PMYBITMAP my_bmp);
07820
07821 #ifdef _MGMISC_SAVEBITMAP
07822
07839 MG_EXPORT int GUIAPI SaveMyBitmapToFile (PMYBITMAP my_bmp, RGB* pal,
07840                 const char* spFileName);
07841
07857 MG_EXPORT int GUIAPI SaveBitmapToFile (HDC hdc, PBITMAP pBitmap,
07858                 const char* spFileName);
07859 #define SaveBitmap  SaveBitmapToFile
07860 #endif
07861
07883 MG_EXPORT BOOL GUIAPI InitBitmap (HDC hdc, Uint32 w, Uint32 h, Uint32 pitch,
07884                 BYTE* bits, PBITMAP bmp);
07885
07895 MG_EXPORT HDC GUIAPI InitSlaveScreen (const char* name, const char* mode);
07896
07904 MG_EXPORT void GUIAPI TerminateSlaveScreen (HDC hdc);
07920 MG_EXPORT BOOL GUIAPI InitBitmapPixelFormat (HDC hdc, PBITMAP bmp);
07921
07931 MG_EXPORT void GUIAPI DeleteBitmapAlphaPixel (PBITMAP bmp);
07932
07933 /* Everything in the pixel format structure is read-only */
07934 typedef struct GAL_PixelFormat {
07935     GAL_Palette *palette;
07936
07937     Uint8  BitsPerPixel;
07938     Uint8  BytesPerPixel;
07939     /* The flag indicating dithered palette */
07940     Uint8  DitheredPalette;
07941     /* The flag indicating the Most Significant Bits (MSB)
07942      * is left when depth is less than 8. */
07943     Uint8  MSBLeft;
07944
07945     Uint8  Rloss;
07946     Uint8  Gloss;
07947     Uint8  Bloss;
07948     Uint8  Aloss;
07949     Uint8  Rshift;
07950     Uint8  Gshift;
07951     Uint8  Bshift;
07952     Uint8  Ashift;
07953     Uint32 Rmask;
07954     Uint32 Gmask;
07955     Uint32 Bmask;
07956     Uint32 Amask;
07957
07958     /* RGB color key information */
07959     gal_pixel colorkey;
07960     /* Alpha value information (per-surface alpha) */
07961     gal_uint8 alpha;
07962 } GAL_PixelFormat;
07963
07964 #define _FILL_MYBITMAP
07965
07966 #ifndef MYBITMAP_CONTXT
07967 typedef struct _MYBITMAP_CONTXT{
07968     Uint32 colorKey;
07969     Uint32 pitch;
07970     GAL_PixelFormat* AlphaPixelFormat;
07971     MYBITMAP*  mybmp;
07972 }MYBITMAP_CONTXT;
07973 #endif
07974
07975 typedef BYTE* (* CB_DRAW_PIXEL) (HDC hdc, MYBITMAP_CONTXT* mybmp, Uint32 pixel, BYTE* dest);
07976
07992 MG_EXPORT int GUIAPI ExpandMyBitmap (HDC hdc, PBITMAP bmp,
07993                 const MYBITMAP* my_bmp, const RGB* pal, int frame);
07994
08017 MG_EXPORT void GUIAPI ExpandMonoBitmap (HDC hdc, BYTE* bits, Uint32 pitch,
08018                 const BYTE* my_bits, Uint32 my_pitch,
08019                 Uint32 w, Uint32 h, DWORD flags, Uint32 bg, Uint32 fg);
08020
08042 MG_EXPORT void GUIAPI Expand16CBitmap (HDC hdc, BYTE* bits, Uint32 pitch,
08043                 const BYTE* my_bits, Uint32 my_pitch,
08044                 Uint32 w, Uint32 h, DWORD flags, const RGB* pal);
08045
08070 MG_EXPORT void GUIAPI Expand256CBitmap (HDC hdc, BYTE* bits, Uint32 pitch,
08071                 const BYTE* my_bits, Uint32 my_pitch,
08072                 Uint32 w, Uint32 h, DWORD flags, const RGB* pal,
08073                 CB_DRAW_PIXEL cb_draw, MYBITMAP_CONTXT* mybmp);
08074
08098 MG_EXPORT void GUIAPI CompileRGBABitmap (HDC hdc, BYTE* bits, Uint32 pitch,
08099                 const BYTE* my_bits, Uint32 my_pitch,
08100                 Uint32 w, Uint32 h, DWORD flags, void* pixel_format,
08101                 CB_DRAW_PIXEL cb_draw, MYBITMAP_CONTXT* mybmp);
08102
08115 MG_EXPORT void GUIAPI CompileRGBABitmapEx (HDC hdc, BYTE* bits, Uint32 pitch,
08116                         const BYTE* my_bits, Uint32 my_pitch,
08117                         Uint32 w, Uint32 h, DWORD flags, void* pixel_format,
08118                         CB_DRAW_PIXEL cb_draw, MYBITMAP_CONTXT* mybmp,
08119                         BYTE* alpha_mask);
08120
08121 #ifdef _FILL_MYBITMAP
08122 MG_EXPORT int GUIAPI FillBoxWithMyBitmap (HDC hdc, int x, int y, MYBITMAP* mybmp, RGB* pal);
08123
08124 MG_EXPORT void GUIAPI ExpandPartMonoBitmap (HDC hdc, BYTE* bits, Uint32 pitch,
08125                 const BYTE* my_bits, Uint32 my_pitch,
08126                 Uint32 w, Uint32 h, DWORD flags, Uint32 bg, Uint32 fg,
08127                 int stepx, CB_DRAW_PIXEL cb_draw, MYBITMAP_CONTXT* mybmp);
08128 MG_EXPORT void GUIAPI ExpandPart16CBitmap (HDC hdc, BYTE* bits, Uint32 pitch, const BYTE* my_bits,
08129         Uint32 my_pitch, Uint32 w, Uint32 h, DWORD flags, const RGB* pal,
08130         int stepx, CB_DRAW_PIXEL cb_draw, MYBITMAP_CONTXT* mybmp);
08131
08132 #endif
08133
08134 #define CompileRGBBitmap CompileRGBABitmap
08135
08164 MG_EXPORT int GUIAPI PaintImageEx (HDC hdc, int x, int y,
08165                 MG_RWops* area, const char* ext);
08166
08181 MG_EXPORT int GUIAPI PaintImageFromFile (HDC hdc, int x, int y,
08182                 const char* spFileName);
08183
08200 MG_EXPORT int GUIAPI PaintImageFromMem (HDC hdc, int x, int y,
08201                 const void* mem, int size, const char* ext);
08202
08234 MG_EXPORT int GUIAPI StretchPaintImageEx (HDC hdc, int x, int y, int w, int h,
08235                 MG_RWops* area, const char* ext);
08236
08253 MG_EXPORT int GUIAPI StretchPaintImageFromFile (HDC hdc, int x, int y,
08254                 int w, int h, const char* spFileName);
08255
08274 MG_EXPORT int GUIAPI StretchPaintImageFromMem (HDC hdc, int x, int y,
08275                 int w, int h, const void* mem, int size, const char* ext);
08276
08277 #ifdef _MGHAVE_FIXED_MATH
08278
08294 MG_EXPORT void GUIAPI RotateBitmap (HDC hdc, const BITMAP *bmp,
08295                 int lx, int ty, int angle);
08296
08307 MG_EXPORT void GUIAPI RotateBitmapVFlip (HDC hdc, const BITMAP *bmp,
08308                 int lx, int ty, int angle);
08309
08318 MG_EXPORT void GUIAPI RotateBitmapHFlip (HDC hdc, const BITMAP *bmp,
08319                 int lx, int ty, int angle);
08320
08329 MG_EXPORT void GUIAPI RotateScaledBitmap (HDC hdc, const BITMAP *bmp,
08330                 int lx, int ty, int angle, int w, int h);
08331
08343 MG_EXPORT void GUIAPI RotateScaledBitmapVFlip (HDC hdc, const BITMAP *bmp,
08344                 int lx, int ty, int angle, int w, int h);
08345
08357 MG_EXPORT void GUIAPI RotateScaledBitmapHFlip (HDC hdc, const BITMAP *bmp,
08358                 int lx, int ty, int angle, int w, int h);
08359
08371 MG_EXPORT void GUIAPI PivotBitmap(HDC hdc, const BITMAP *bmp,
08372                 int lx, int ty, int cx, int cy, int angle);
08373
08400 MG_EXPORT void GUIAPI PivotScaledBitmapFlip (HDC hdc, const BITMAP *bmp,
08401                 fixed x, fixed y, fixed cx, fixed cy, int angle, fixed scale_x,
08402                 fixed scale_y, BOOL h_flip, BOOL v_flip);
08403
08404 #endif /*_MGHAVE_FIXED_MATH*/
08405
08412 #ifdef _MGFONT_BMPF
08413
08431 MG_EXPORT DEVFONT* GUIAPI CreateBMPDevFont (const char *bmpfont_name,
08432                 const BITMAP* glyph_bmp, const char* start_mchar, int nr_glyphs,
08433                 int glyph_width);
08434
08450 MG_EXPORT BOOL GUIAPI AddGlyphsToBMPFont (DEVFONT* dev_font, BITMAP* glyph_bmp,
08451                 const char* start_mchar, int nr_glyphs, int glyph_width);
08452
08463 MG_EXPORT void GUIAPI DestroyBMPFont (DEVFONT* dev_font);
08464
08465 #ifdef _DEBUG
08466 /*
08467  * Dump avl tree info
08468  */
08469 void dump_tree (DEVFONT *dev_font);
08470
08471 /*
08472  * look up a node in bitmap font avl tree.
08473  */
08474 int avl_look_up (DEVFONT *dev_font, char *start_mchar, int n);
08475
08476 /*
08477  * destroy bitmap font avl tree.
08478  */
08479 void destroy_avl_tree (DEVFONT *dev_font);
08480
08481 #endif /* end of _DEBUG */
08482
08483 #endif /* end of _MGFONT_BMPF */
08484
08498 typedef int Glyph32;
08502 #define INV_GLYPH_VALUE    -1
08503
08510 #define IS_MBC_GLYPH(glyph)  ((glyph) & 0x80000000)
08511
08518 #define SET_MBC_GLYPH(glyph) ((glyph) | 0x80000000)
08519
08526 #define REAL_GLYPH(glyph)    ((glyph) & 0x7FFFFFFF)
08527
08528
08537 #define SELECT_DEVFONT(plogfont, glyph) \
08538     ((glyph) & 0x80000000 ? \
08539     (plogfont)->mbc_devfont : \
08540     (plogfont)->sbc_devfont)
08541
08546 typedef enum {
08547     GLYPH_ISOLATED,
08548     GLYPH_FINAL,
08549     GLYPH_INITIAL,
08550     GLYPH_MEDIAL
08551 }SHAPETYPE;
08552
08557 typedef struct _GLYPHMAPINFO{
08558     int byte_index;
08559     int char_len;
08560     BOOL is_rtol;
08561 }GLYPHMAPINFO;
08562
08563
08564 #define GLYPH_INFO_TYPE      1
08565 #define GLYPH_INFO_METRICS   2
08566 #define GLYPH_INFO_BMP       4
08567
08568 /*the type of glyph bitmap*/
08569 #define GLYPHBMP_TYPE_MONO      0
08570 #define GLYPHBMP_TYPE_GREY      1
08571 #define GLYPHBMP_TYPE_SUBPIXEL  2
08572 #define GLYPHBMP_TYPE_PRERENDER 3
08573
08574 /*the glyph info structure. */
08579 typedef struct _GLYPHINFO
08580 {
08582     char mask;
08584     char glyph_type;
08586     char bmp_type;
08587
08588     Uint8 padding;
08589
08591     int height;
08593     int descent;
08594
08596     int advance_x, advance_y;
08598     int bbox_x, bbox_y;
08599     int bbox_w, bbox_h;
08600
08602     size_t bmp_size;
08603     /* The pitch of the glyph bitmap. */
08604     int bmp_pitch;
08606     const unsigned char* bits;
08607
08609     BITMAP prbitmap;
08610 } GLYPHINFO;
08611
08625 MG_EXPORT Glyph32 GUIAPI GetGlyphValue (LOGFONT* logfont, const char* mchar,
08626         int mchar_len, const char* pre_mchar, int pre_len);
08627
08640 MG_EXPORT Glyph32 GUIAPI GetGlyphShape (LOGFONT* logfont, const char* mchar,
08641         int mchar_len, SHAPETYPE shape_type);
08642
08661 MG_EXPORT int GUIAPI DrawGlyph (HDC hdc, int x, int y, Glyph32 glyph_value,
08662         int* adv_x, int* adv_y);
08663
08664 /*
08665  * \fn int GUIAPI DrawGlyphString (HDC hdc, int x, int y, \
08666  *      Glyph32* glyph_string, int len, int* adv_x, int* adv_y);
08667  * \brief Draw a glyph string.
08668  *
08669  * This function draws a glyph string to the specific postion of a DC.
08670  *
08671  * \param hdc The device context.
08672  * \param x The output start x position.
08673  * \param y The output start y position.
08674  * \param glyph_string The pointer to the glyph string.
08675  * \param len The length of the glyph string.
08676  * \param adv_x The pointer used to return the advance in x-coordinate of
08677  *        the glyph string, can be NULL.
08678  * \param adv_y The pointer used to return the advance in y-coordinate of
08679  *        the glyph string, can be NULL.
08680  *
08681  * \return The advance on baseline.
08682  */
08683 MG_EXPORT int GUIAPI DrawGlyphString (HDC hdc, int x, int y, Glyph32* glyph_string,
08684         int len, int* adv_x, int* adv_y);
08685
08703 MG_EXPORT int GUIAPI GetGlyphInfo (LOGFONT* logfont, Glyph32 glyph_value,
08704         GLYPHINFO* glyph_info);
08705
08720 MG_EXPORT int GUIAPI GetGlyphsExtent(HDC hdc, Glyph32* glyphs, int nr_glyphs,
08721         SIZE* size);
08722
08738 MG_EXPORT int GUIAPI GetGlyphsExtentPoint(HDC hdc, Glyph32* glyphs,
08739         int nr_glyphs, int max_extent, SIZE* size);
08740
08757 MG_EXPORT int GUIAPI BIDIGetTextLogicalGlyphs(LOGFONT* log_font,
08758         const char* text, int text_len, Glyph32** glyphs,
08759         GLYPHMAPINFO** glyphs_map);
08760
08776 MG_EXPORT int GUIAPI BIDIGetTextVisualGlyphs (LOGFONT* log_font,
08777         const char* text, int text_len, Glyph32** glyphs,
08778         GLYPHMAPINFO** glyphs_map);
08779
08796 MG_EXPORT Glyph32* GUIAPI BIDILogGlyphs2VisGlyphs (LOGFONT* log_font,
08797         Glyph32* glyphs, int nr_glyphs, GLYPHMAPINFO* glyphs_map);
08798
08815 MG_EXPORT void GUIAPI GetTextRangesLog2Vis (LOGFONT* log_font, char* text,
08816         int text_len, int start_index, int end_index, int** ranges,
08817         int* nr_ranges);
08818
08833 MG_EXPORT void GUIAPI BIDIGetLogicalEmbeddLevels (LOGFONT* log_font,
08834         Glyph32*  glyphs, int nr_glyphs, Uint8** embedding_level_list);
08835
08849 MG_EXPORT void GUIAPI BIDIGetVisualEmbeddLevels (LOGFONT* log_font,
08850         Glyph32* glyphs, int nr_glyphs, Uint8**  embedding_level_list);
08851
08853 /*
08854  * \var typedef struct _COMP_CTXT COMP_CTXT
08855  * \brief The context information of user defined color composition operators.
08856  *
08857  * \sa SetUserCompositionOps
08858  *
08859  */
08860 typedef struct _COMP_CTXT {
08862     int step;
08863
08865     gal_uint8* cur_dst;
08866
08868     gal_pixel skip_pixel;
08869
08871     gal_pixel cur_pixel;
08872
08874     void* user_comp_ctxt;
08875 } COMP_CTXT;
08876
08877 /*
08878  * \var typedef struct _SPAN_CTXT SPAN_CTXT
08879  * \brief span context
08880  */
08881 typedef struct _SPAN_CTXT {
08882     GAL_PixelFormat* dst_format; /* The pixel format of the destination pixels */
08883     GAL_PixelFormat* src_format; /* The pixel format of the source pixels */
08884     void * user_context; /* The user context passed to SetColorCompositeFunc */
08885 } SPAN_CTXT;
08886
08887 /*
08888  * \var typedef struct _COMPOSITE_CTXT COMPOSITE_CTXT
08889  * \brief composite context
08890  */
08891 typedef struct _COMPOSITE_CTXT {
08892     HDC dst_dc;
08893     int comp_mode;
08894     const int *far_bkmode;
08895     const int *far_step;
08896     const gal_pixel *far_skip_pixel;
08897 } COMPOSITE_CTXT;
08898
08899 /*
08900  * \var typedef struct _RASTER_CTXT RASTER_CTXT
08901  * \brief raster context
08902  */
08903 typedef struct _RASTER_CTXT {
08904     HDC dst_dc;
08905 } RASTER_CTXT;
08906
08907 /*
08908  * \var typedef void (*CB_COMP_SETPIXEL) (COMP_CTXT* comp_ctxt)
08909  * \brief The prototype of the user defined color composition setpixel.
08910  *
08911  * This operator sets a pixel on the \a cur_dst defined in \a comp_ctxt with
08912  * the cur_pixel defined in \a comp_ctxt.
08913  *
08914  * \sa SetUserCompositionOps, COMP_CTXT
08915  */
08916 typedef void (*CB_COMP_SETPIXEL) (COMP_CTXT* comp_ctxt);
08917
08918 /*
08919  * \var typedef void (*CB_COMP_SETHLINE) (COMP_CTXT* comp_ctxt, int w)
08920  * \brief The prototype of the user defined color composition sethline.
08921  *
08922  * This operator sets a horizital line on the \a cur_dst defined in \a comp_ctxt
08923  * with the \a cur_pixel defined in \a comp_ctxt, totally \a w pixels.
08924  *
08925  * \sa SetUserCompositionOps, COMP_CTXT
08926  */
08927 typedef void (*CB_COMP_SETHLINE) (COMP_CTXT* comp_ctxt, int w);
08928
08929 /*
08930  * \var typedef void (*CB_COMP_PUTHLINE) (COMP_CTXT* comp_ctxt, gal_uint8* src, int w)
08931  * \brief The prototype of the user defined color composition puthline.
08932  *
08933  * This operator puts the pixels in \a src to a horizital line on the \a cur_dst
08934  * defined in \a comp_ctxt, totally \a w pixels.
08935  *
08936  * \sa SetUserCompositionOps, COMP_CTXT
08937  */
08938 typedef void (*CB_COMP_PUTHLINE) (COMP_CTXT* comp_ctxt, gal_uint8* src, int bkmode, int w);
08939
08961 MG_EXPORT int GUIAPI SetUserCompositionOps (HDC hdc, CB_COMP_SETPIXEL comp_setpixel,
08962         CB_COMP_SETHLINE comp_sethline, CB_COMP_PUTHLINE comp_puthline, void* user_comp_ctxt);
08963
08966 #ifdef _MGGAL_HI3560
08967
08968 //#include <hi_api.h>
08969
08970 /* API speicific to Hi3560 GAL engines */
08971 MG_EXPORT int hi3560GetVideoFD (void);
08972 MG_EXPORT void* hi3560GetFBAddress (void);
08973 MG_EXPORT int hi3560SetScreenAttr (Uint8 siAttr, void* pValue);
08974
08975 #endif /* _MGGAL_HI3560 */
08976
08977 MG_EXPORT int GUIAPI GetTextMCharInfo (PLOGFONT log_font, const char* mstr, int len,
08978                 int* pos_chars);
08979 MG_EXPORT int GUIAPI GetTextWordInfo (PLOGFONT log_font, const char* mstr, int len,
08980                 int* pos_words, WORDINFO* info_words);
08981 MG_EXPORT int GUIAPI GetFirstMCharLen (PLOGFONT log_font, const char* mstr, int len);
08982 MG_EXPORT int GUIAPI GetLastMCharLen (PLOGFONT log_font, const char* mstr, int len);
08983 MG_EXPORT int GUIAPI GetFirstWord (PLOGFONT log_font, const char* mstr, int len,
08984                     WORDINFO* word_info);
08985 MG_EXPORT int GUIAPI MB2WCEx (PLOGFONT log_font, void* dest, BOOL wc32,
08986                 const unsigned char* mchar, int n);
08987 MG_EXPORT int GUIAPI WC2MBEx (PLOGFONT log_font, unsigned char *s, UChar32 wc);
08988 MG_EXPORT int GUIAPI MBS2WCSEx (PLOGFONT log_font, void* dest, BOOL wc32,
08989                 const unsigned char* mstr, int mstr_len, int n,
08990                 int* conved_mstr_len);
08991 MG_EXPORT int GUIAPI WCS2MBSEx (PLOGFONT log_font, unsigned char* dest,
08992                 const void *wcs, int wcs_len, BOOL wc32, int n,
08993                 int* conved_wcs_len);
08994
08995 #ifdef __cplusplus
08996 }
08997 #endif  /* __cplusplus */
08998
08999 #endif  /* _MGUI_GDI_H */
09000
09001
Generated on Fri Dec 17 13:49:41 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- k -

  • KillTimer() : window.h
  • KS_ALT : common.h
  • KS_CAPSLOCK : common.h
  • KS_CAPTURED : common.h
  • KS_CTRL : common.h
  • KS_IMEPOST : common.h
  • KS_LEFTALT : common.h
  • KS_LEFTBUTTON : common.h
  • KS_LEFTCTRL : common.h
  • KS_LEFTSHIFT : common.h
  • KS_MIDDLBUTTON : common.h
  • KS_NUMLOCK : common.h
  • KS_REPEATED : common.h
  • KS_RIGHTALT : common.h
  • KS_RIGHTBUTTON : common.h
  • KS_RIGHTCTRL : common.h
  • KS_RIGHTSHIFT : common.h
  • KS_SCROLLLOCK : common.h
  • KS_SHIFT : common.h
  • KS_SPINPOST : spinbox.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- l -

  • LB_ADDFILE : listbox.h
  • LB_ADDSTRING : listbox.h
  • LB_DELETESTRING : listbox.h
  • LB_DIR : listbox.h
  • LB_ERR : listbox.h
  • LB_ERRSPACE : listbox.h
  • LB_FINDSTRING : listbox.h
  • LB_FINDSTRINGEXACT : listbox.h
  • LB_GETCARETINDEX : listbox.h
  • LB_GETCHECKMARK : listbox.h
  • LB_GETCOUNT : listbox.h
  • LB_GETCURSEL : listbox.h
  • LB_GETHORIZONTALEXTENT : listbox.h
  • LB_GETITEMADDDATA : listbox.h
  • LB_GETITEMDATA : listbox.h
  • LB_GETITEMDISABLE : listbox.h
  • LB_GETITEMHEIGHT : listbox.h
  • LB_GETITEMRECT : listbox.h
  • LB_GETLOCALE : listbox.h
  • LB_GETSEL : listbox.h
  • LB_GETSELCOUNT : listbox.h
  • LB_GETSELITEMS : listbox.h
  • LB_GETTEXT : listbox.h
  • LB_GETTEXTLEN : listbox.h
  • LB_GETTOPINDEX : listbox.h
  • LB_INITSTORAGE : listbox.h
  • LB_INSERTSTRING : listbox.h
  • LB_ITEMFROMPOINT : listbox.h
  • LB_MULTIADDITEM : listbox.h
  • LB_OKAY : listbox.h
  • LB_RESETCONTENT : listbox.h
  • LB_SELECTSTRING : listbox.h
  • LB_SELITEMRANGEEX : listbox.h
  • LB_SETCARETINDEX : listbox.h
  • LB_SETCHECKMARK : listbox.h
  • LB_SETCOLUMNWIDTH : listbox.h
  • LB_SETCOUNT : listbox.h
  • LB_SETCURSEL : listbox.h
  • LB_SETHORIZONTALEXTENT : listbox.h
  • LB_SETITEMADDDATA : listbox.h
  • LB_SETITEMBOLD : listbox.h
  • LB_SETITEMDATA : listbox.h
  • LB_SETITEMDISABLE : listbox.h
  • LB_SETITEMHEIGHT : listbox.h
  • LB_SETLOCALE : listbox.h
  • LB_SETSEL : listbox.h
  • LB_SETSTRCMPFUNC : listbox.h
  • LB_SETTEXT : listbox.h
  • LB_SETTOPINDEX : listbox.h
  • LBIS_SIGNIFICANT : listbox.h
  • LBN_CLICKCHECKMARK : listbox.h
  • LBN_CLICKED : listbox.h
  • LBN_DBLCLK : listbox.h
  • LBN_ENTER : listbox.h
  • LBN_ERRSPACE : listbox.h
  • LBN_KILLFOCUS : listbox.h
  • LBN_SELCANCEL : listbox.h
  • LBN_SELCHANGE : listbox.h
  • LBN_SETFOCUS : listbox.h
  • LBS_AUTOCHECK : listbox.h
  • LBS_AUTOCHECKBOX : listbox.h
  • LBS_CHECKBOX : listbox.h
  • LBS_MOUSEFOLLOW : listbox.h
  • LBS_MULTIPLESEL : listbox.h
  • LBS_NOTIFY : listbox.h
  • LBS_SBALWAYS : listbox.h
  • LBS_SORT : listbox.h
  • LBS_USEICON : listbox.h
  • LEN_CLIPBOARD_NAME : minigui.h
  • LEN_RENDERER_NAME : window.h
  • LFRDR_TBS_HILITE : trackbar.h
  • LFRDR_TBS_PRESSED : trackbar.h
  • LineClipper() : gdi.h
  • LineEx() : gdi.h
  • LineGenerator() : gdi.h
  • LineTo() : gdi.h
  • LoadBitmap : gdi.h
  • LoadBitmapEx() : gdi.h
  • LoadBitmapFromFile() : gdi.h
  • LoadBitmapFromMem() : gdi.h
  • LoadCursorFromFile() : minigui.h
  • LoadCursorFromMem() : minigui.h
  • LoadDevFontFromFile() : gdi.h
  • LoadEtcFile() : minigui.h
  • LoadIconFromFile() : gdi.h
  • LoadIconFromMem() : gdi.h
  • LoadMyBitmap : gdi.h
  • LoadMyBitmapEx() : gdi.h
  • LoadMyBitmapFromFile() : gdi.h
  • LoadMyBitmapFromMem() : gdi.h
  • LoadMyBitmapSL() : gdi.h
  • LoadResource() : window.h
  • LoadSystemIcon() : window.h
  • LoadSystemIconEx() : window.h
  • LOBYTE : common.h
  • local_SysText : minigui.h
  • LockDC() : gdi.h
  • LockDCEx() : gdi.h
  • LONG : common.h
  • LOSWORD : common.h
  • LOWORD : common.h
  • LPARAM : common.h
  • LPtoDP() : gdi.h
  • LPtoSP() : gdi.h
  • LV_ERR : listview.h
  • LV_ERRSPACE : listview.h
  • LV_OKAY : listview.h
  • LVCF_CENTERALIGN : listview.h
  • LVCF_LEFTALIGN : listview.h
  • LVCF_RIGHTALIGN : listview.h
  • LVCF_TREEVIEW : listview.h
  • LVFF_ADDDATA : listview.h
  • LVFF_TEXT : listview.h
  • LVFLAG_BITMAP : listview.h
  • LVFLAG_ICON : listview.h
  • LVHF_CENTERALIGN : listview.h
  • LVHF_LEFTALIGN : listview.h
  • LVHF_RIGHTALIGN : listview.h
  • LVIF_FOLD : listview.h
  • LVM_ADDCOLUMN : listview.h
  • LVM_ADDITEM : listview.h
  • LVM_CHOOSEITEM : listview.h
  • LVM_CLEARSUBITEM : listview.h
  • LVM_COLSORT : listview.h
  • LVM_DELALLITEM : listview.h
  • LVM_DELCOLUMN : listview.h
  • LVM_DELITEM : listview.h
  • LVM_FILLSUBITEM : listview.h
  • LVM_FINDITEM : listview.h
  • LVM_FOLDITEM : listview.h
  • LVM_GETCOLUMN : listview.h
  • LVM_GETCOLUMNCOUNT : listview.h
  • LVM_GETCOLUMNWIDTH : listview.h
  • LVM_GETITEM : listview.h
  • LVM_GETITEMADDDATA : listview.h
  • LVM_GETITEMCOUNT : listview.h
  • LVM_GETITEMSTATE : listview.h
  • LVM_GETRELATEDITEM : listview.h
  • LVM_GETSELECTEDCOLUMN : listview.h
  • LVM_GETSELECTEDCOUNT : listview.h
  • LVM_GETSELECTEDITEM : listview.h
  • LVM_GETSELECTEDITEMRECT : listview.h
  • LVM_GETSUBITEMLEN : listview.h
  • LVM_GETSUBITEMTEXT : listview.h
  • LVM_GETTOPVISIBLE : listview.h
  • LVM_MODIFYHEAD : listview.h
  • LVM_NULL : listview.h
  • LVM_SELECTITEM : listview.h
  • LVM_SETCOLUMN : listview.h
  • LVM_SETCUSTOMDRAW : listview.h
  • LVM_SETHEADHEIGHT : listview.h
  • LVM_SETITEMADDDATA : listview.h
  • LVM_SETITEMHEIGHT : listview.h
  • LVM_SETITEMSTATE : listview.h
  • LVM_SETSTRCMPFUNC : listview.h
  • LVM_SETSUBITEM : listview.h
  • LVM_SETSUBITEMCOLOR : listview.h
  • LVM_SETSUBITEMTEXT : listview.h
  • LVM_SHOWITEM : listview.h
  • LVM_SORTITEMS : listview.h
  • LVN_CLICKED : listview.h
  • LVN_COLCHANGE : listview.h
  • LVN_FOLDED : listview.h
  • LVN_HEADRDOWN : listview.h
  • LVN_HEADRUP : listview.h
  • LVN_ITEMCLK : listview.h
  • LVN_ITEMDBCLK : listview.h
  • LVN_ITEMRDOWN : listview.h
  • LVN_ITEMRUP : listview.h
  • LVN_KEYDOWN : listview.h
  • LVN_SELCHANGE : listview.h
  • LVN_UNFOLDED : listview.h
  • LVNM_HEADRDOWN : listview.h
  • LVNM_HEADRUP : listview.h
  • LVNM_ITEMRDOWN : listview.h
  • LVNM_ITEMRUP : listview.h
  • LVNM_KEYDOWN : listview.h
  • LVS_AUTOCHECK : listview.h
  • LVS_AUTOCHECKBOX : listview.h
  • LVS_CHECKBOX : listview.h
  • LVS_MULTIPLESEL : listview.h
  • LVS_SORT : listview.h
  • LVS_TREEVIEW : listview.h
  • LVS_UPNOTIFY : listview.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- m -

  • MainWindowCleanup : window.h
  • MainWindowThreadCleanup() : window.h
  • MAKELONG : common.h
  • MakeRGB : common.h
  • MakeRGBA : common.h
  • MAKEWORD : common.h
  • MASK_KS_BUTTONS : common.h
  • MASK_KS_SHIFTKEYS : common.h
  • MAX : common.h
  • MAX_NAME : common.h
  • MAX_NR_LISTEN_FD : minigui.h
  • MAX_PATH : common.h
  • MB2WC : gdi.h
  • MB2WCEx() : gdi.h
  • MB_ERR : menubutton.h
  • MB_ERR_SPACE : menubutton.h
  • MB_INV_ITEM : menubutton.h
  • MB_OKAY : menubutton.h
  • MB_WHICH_ATTDATA : menubutton.h
  • MB_WHICH_BMP : menubutton.h
  • MB_WHICH_TEXT : menubutton.h
  • MBM_ADDITEM : menubutton.h
  • MBM_DELITEM : menubutton.h
  • MBM_GETCURITEM : menubutton.h
  • MBM_GETITEMDATA : menubutton.h
  • MBM_RESETCTRL : menubutton.h
  • MBM_SETCURITEM : menubutton.h
  • MBM_SETITEMDATA : menubutton.h
  • MBM_SETSTRCMPFUNC : menubutton.h
  • MBN_CHANGED : menubutton.h
  • MBN_CLICKED : menubutton.h
  • MBN_ENDMENU : menubutton.h
  • MBN_ERRSPACE : menubutton.h
  • MBN_SELECTED : menubutton.h
  • MBN_STARTMENU : menubutton.h
  • MBS2WCS : gdi.h
  • MBS2WCSEx() : gdi.h
  • MBS_ALIGNCENTER : menubutton.h
  • MBS_ALIGNLEFT : menubutton.h
  • MBS_ALIGNMASK : menubutton.h
  • MBS_ALIGNRIGHT : menubutton.h
  • MBS_LEFTARROW : menubutton.h
  • MBS_NOBUTTON : menubutton.h
  • MBS_SORT : menubutton.h
  • MCM_CLEARDAYCOLOR : monthcal.h
  • MCM_GETCOLOR : monthcal.h
  • MCM_GETCURDATE : monthcal.h
  • MCM_GETCURDAY : monthcal.h
  • MCM_GETCURMONLEN : monthcal.h
  • MCM_GETCURMONTH : monthcal.h
  • MCM_GETCURWEEKDAY : monthcal.h
  • MCM_GETCURYEAR : monthcal.h
  • MCM_GETFIRSTWEEKDAY : monthcal.h
  • MCM_GETMINREQRECTH : monthcal.h
  • MCM_GETMINREQRECTW : monthcal.h
  • MCM_GETTODAY : monthcal.h
  • MCM_SETCOLOR : monthcal.h
  • MCM_SETCURDATE : monthcal.h
  • MCM_SETCURDAY : monthcal.h
  • MCM_SETCURMONTH : monthcal.h
  • MCM_SETCURYEAR : monthcal.h
  • MCM_SETDAYCOLOR : monthcal.h
  • MCM_SETTODAY : monthcal.h
  • MCN_DATECHANGE : monthcal.h
  • MCS_CHN : monthcal.h
  • MCS_ENG_L : monthcal.h
  • MCS_ENG_S : monthcal.h
  • MCS_NOTIFY : monthcal.h
  • MCS_NOYEARMON : monthcal.h
  • MessageBeep() : window.h
  • MessageBox() : window.h
  • mg_FT_LcdFilter : gdi.h
  • MG_SMOOTH_DEFAULT : gdi.h
  • MG_SMOOTH_LEGACY : gdi.h
  • MG_SMOOTH_LIGHT : gdi.h
  • MG_SMOOTH_MAX : gdi.h
  • MG_SMOOTH_NONE : gdi.h
  • mglist_get_item_adddata() : scrollview.h
  • MGUI_AllocRW() : endianrw.h
  • MGUI_BIG_ENDIAN : common.h
  • MGUI_BYTEORDER : common.h
  • MGUI_FreeRW() : endianrw.h
  • MGUI_InitMemRW() : endianrw.h
  • MGUI_LIL_ENDIAN : common.h
  • MGUI_NR_KEYS : common.h
  • MGUI_ReadBE16() : endianrw.h
  • MGUI_ReadBE32() : endianrw.h
  • MGUI_ReadBE64() : endianrw.h
  • MGUI_ReadLE16() : endianrw.h
  • MGUI_ReadLE16FP() : endianrw.h
  • MGUI_ReadLE32() : endianrw.h
  • MGUI_ReadLE32FP() : endianrw.h
  • MGUI_ReadLE64() : endianrw.h
  • MGUI_RWclose : endianrw.h
  • MGUI_RWeof : endianrw.h
  • MGUI_RWFromFile() : endianrw.h
  • MGUI_RWFromFP() : endianrw.h
  • MGUI_RWFromMem() : endianrw.h
  • MGUI_RWgetc() : endianrw.h
  • MGUI_RWread : endianrw.h
  • MGUI_RWseek : endianrw.h
  • MGUI_RWtell : endianrw.h
  • MGUI_RWwrite : endianrw.h
  • MGUI_WriteBE16() : endianrw.h
  • MGUI_WriteBE32() : endianrw.h
  • MGUI_WriteBE64() : endianrw.h
  • MGUI_WriteLE16() : endianrw.h
  • MGUI_WriteLE16FP() : endianrw.h
  • MGUI_WriteLE32() : endianrw.h
  • MGUI_WriteLE32FP() : endianrw.h
  • MGUI_WriteLE64() : endianrw.h
  • MIN : common.h
  • MiniGUIMain : minigui.h
  • MiniGUIPanic() : minigui.h
  • MLS_BLENDMODE_NONE : gdi.h
  • mlsEnableSlaveScreen() : gdi.h
  • MonotoneVerticalPolygonGenerator() : gdi.h
  • MoveTo() : gdi.h
  • MoveWindow() : window.h
  • MSG_ACTIVE : window.h
  • MSG_ACTIVEMENU : window.h
  • MSG_CHANGESIZE : window.h
  • MSG_CHAR : window.h
  • MSG_CHILDHIDDEN : window.h
  • MSG_CLOSE : window.h
  • MSG_COMMAND : window.h
  • MSG_CREATE : window.h
  • MSG_CSIZECHANGED : window.h
  • MSG_DEACTIVEMENU : window.h
  • MSG_DESTROY : window.h
  • MSG_DLG_GETDEFID : window.h
  • MSG_DLG_SETDEFID : window.h
  • MSG_DOESNEEDIME : window.h
  • MSG_DT_KEYDOWN : window.h
  • MSG_DT_KEYUP : window.h
  • MSG_DT_LBUTTONDBLCLK : window.h
  • MSG_DT_LBUTTONDOWN : window.h
  • MSG_DT_LBUTTONUP : window.h
  • MSG_DT_MOUSEMOVE : window.h
  • MSG_DT_RBUTTONDBLCLK : window.h
  • MSG_DT_RBUTTONDOWN : window.h
  • MSG_DT_RBUTTONUP : window.h
  • MSG_ENABLE : window.h
  • MSG_ERASEBKGND : window.h
  • MSG_FDEVENT : window.h
  • MSG_FONTCHANGED : window.h
  • MSG_FONTCHANGING : window.h
  • MSG_FREEZECTRL : window.h
  • MSG_GETDLGCODE : window.h
  • MSG_GETTEXT : window.h
  • MSG_GETTEXTLENGTH : window.h
  • MSG_HITTEST : window.h
  • MSG_HSCROLL : window.h
  • MSG_IDLE : window.h
  • MSG_INITCONTAINER : window.h
  • MSG_INITDIALOG : window.h
  • MSG_INITPAGE : window.h
  • MSG_ISDIALOG : window.h
  • MSG_KEYALWAYSPRESS : window.h
  • MSG_KEYDOWN : window.h
  • MSG_KEYLONGPRESS : window.h
  • MSG_KEYSYM : window.h
  • MSG_KEYUP : window.h
  • MSG_KILLFOCUS : window.h
  • MSG_LBUTTONDBLCLK : window.h
  • MSG_LBUTTONDOWN : window.h
  • MSG_LBUTTONUP : window.h
  • MSG_MOUSEACTIVE : window.h
  • MSG_MOUSEMOVE : window.h
  • MSG_MOUSEMOVEIN : window.h
  • MSG_NCACTIVATE : window.h
  • MSG_NCCREATE : window.h
  • MSG_NCHITTEST : window.h
  • MSG_NCLBUTTONDBLCLK : window.h
  • MSG_NCLBUTTONDOWN : window.h
  • MSG_NCLBUTTONUP : window.h
  • MSG_NCMOUSEMOVE : window.h
  • MSG_NCPAINT : window.h
  • MSG_NCRBUTTONDBLCLK : window.h
  • MSG_NCRBUTTONDOWN : window.h
  • MSG_NCRBUTTONUP : window.h
  • MSG_NCSETCURSOR : window.h
  • MSG_PAINT : window.h
  • MSG_QUERYCLIENTAREA : window.h
  • MSG_RBUTTONDBLCLK : window.h
  • MSG_RBUTTONDOWN : window.h
  • MSG_RBUTTONUP : window.h
  • MSG_SETCURSOR : window.h
  • MSG_SETFOCUS : window.h
  • MSG_SETTEXT : window.h
  • MSG_SHEETCMD : window.h
  • MSG_SHOWPAGE : window.h
  • MSG_SHOWWINDOW : window.h
  • MSG_SIZECHANGED : window.h
  • MSG_SIZECHANGING : window.h
  • MSG_SRVNOTIFY : window.h
  • MSG_SVCONTCMD : window.h
  • MSG_SYNCPAINT : window.h
  • MSG_SYSCHAR : window.h
  • MSG_SYSCOMMAND : window.h
  • MSG_SYSKEYDOWN : window.h
  • MSG_SYSKEYUP : window.h
  • MSG_TIMER : window.h
  • MSG_USER : window.h
  • MSG_VSCROLL : window.h
  • MSG_WINDOWDROPPED : window.h
  • MSGHOOK : window.h
  • MYBITMAP : gdi.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- n -

  • NormalizeRect() : gdi.h
  • NOTIFPROC : window.h
  • NotifyParent : ctrlhelper.h
  • NotifyParentEx() : ctrlhelper.h
  • NR_CLIPBOARDS : minigui.h
  • NR_KEYS : common.h
  • NTB_ERR : newtoolbar.h
  • NTB_ERR_DUPID : newtoolbar.h
  • NTB_ERR_SPACE : newtoolbar.h
  • NTB_OKAY : newtoolbar.h
  • NTBIF_CHECKED : newtoolbar.h
  • NTBIF_DISABLED : newtoolbar.h
  • NTBM_ADDITEM : newtoolbar.h
  • NTBM_ENABLEITEM : newtoolbar.h
  • NTBM_GETITEM : newtoolbar.h
  • NTBM_SETBITMAP : newtoolbar.h
  • NTBM_SETITEM : newtoolbar.h
  • NTBS_DRAWSEPARATOR : newtoolbar.h
  • NTBS_DRAWSTATES : newtoolbar.h
  • NTBS_HORIZONTAL : newtoolbar.h
  • NTBS_MULTLINE : newtoolbar.h
  • NTBS_TEXTRIGHT : newtoolbar.h
  • NTBS_VERTICAL : newtoolbar.h
  • NTBS_WITHTEXT : newtoolbar.h
  • NULL : common.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- o -

  • OffsetClipRegion() : gdi.h
  • OffsetRect() : gdi.h
  • OffsetRegion() : gdi.h
  • OffsetRegionEx() : gdi.h
  • ON_UPDATE_SECONDARYDC : gdi.h
  • OpenAboutDialog() : minigui.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- a -

  • ABS : common.h
  • ActiveCaret() : window.h
  • AddAccelerators() : window.h
  • AddClipRect() : gdi.h
  • AddGlyphsToBMPFont() : gdi.h
  • AddInnerRes() : window.h
  • AddResRef() : window.h
  • AddWindowElementRenderer() : window.h
  • ANIMATION_ERR : animation.h
  • ANIMATION_OKAY : animation.h
  • ANM_GETANIMATION : animation.h
  • ANM_PAUSE_RESUME : animation.h
  • ANM_SETANIMATION : animation.h
  • ANM_STARTPLAY : animation.h
  • ANM_STOPPLAY : animation.h
  • ANNC_CLICKED : animation.h
  • ANNC_DBLCLK : animation.h
  • ANS_AUTOLOOP : animation.h
  • ANS_FITTOANI : animation.h
  • ANS_SCALED : animation.h
  • ArcEx() : gdi.h
  • ArchSwapBE16 : endianrw.h
  • ArchSwapBE32 : endianrw.h
  • ArchSwapBE64 : endianrw.h
  • ArchSwapLE16 : endianrw.h
  • ArchSwapLE32 : endianrw.h
  • ArchSwapLE64 : endianrw.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- b -

  • Beep : minigui.h
  • BeginPaint() : window.h
  • BIDIGetLogicalEmbeddLevels() : gdi.h
  • BIDIGetTextLogicalGlyphs() : gdi.h
  • BIDIGetTextVisualGlyphs() : gdi.h
  • BIDIGetVisualEmbeddLevels() : gdi.h
  • BIDILogGlyphs2VisGlyphs() : gdi.h
  • BitBlt() : gdi.h
  • BITMAP : gdi.h
  • BlockDataAlloc() : gdi.h
  • BlockDataFree() : gdi.h
  • BM_CLICK : button.h
  • BM_ENABLE : button.h
  • BM_GETCHECK : button.h
  • BM_GETIMAGE : button.h
  • BM_GETSTATE : button.h
  • BM_SETCHECK : button.h
  • BM_SETIMAGE : button.h
  • BM_SETSTATE : button.h
  • BM_SETSTYLE : button.h
  • BN_CLICKED : button.h
  • BN_DBLCLK : button.h
  • BN_DISABLE : button.h
  • BN_ENABLE : button.h
  • BN_HILITE : button.h
  • BN_KILLFOCUS : button.h
  • BN_PUSHED : button.h
  • BN_SETFOCUS : button.h
  • BN_UNHILITE : button.h
  • BN_UNPUSHED : button.h
  • BOOL : common.h
  • BroadcastMessage() : window.h
  • BrushType : gdi.h
  • BS_3STATE : button.h
  • BS_ALIGNMASK : button.h
  • BS_AUTO3STATE : button.h
  • BS_AUTOCHECKBOX : button.h
  • BS_AUTORADIOBUTTON : button.h
  • BS_BITMAP : button.h
  • BS_BOTTOM : button.h
  • BS_CENTER : button.h
  • BS_CHECKBOX : button.h
  • BS_CHECKED : button.h
  • BS_CONTENTMASK : button.h
  • BS_DEFPUSHBUTTON : button.h
  • BS_FLAT : button.h
  • BS_ICON : button.h
  • BS_LEFT : button.h
  • BS_LEFTTEXT : button.h
  • BS_MULTLINE : button.h
  • BS_NOBORDER : button.h
  • BS_NOTIFY : button.h
  • BS_OWNERDRAW : button.h
  • BS_PUSHBUTTON : button.h
  • BS_PUSHLIKE : button.h
  • BS_RADIOBUTTON : button.h
  • BS_REALSIZEIMAGE : button.h
  • BS_RIGHT : button.h
  • BS_RIGHTBUTTON : button.h
  • BS_TEXT : button.h
  • BS_TOP : button.h
  • BS_TYPEMASK : button.h
  • BS_VCENTER : button.h
  • BST_CHECK_MASK : button.h
  • BST_CHECKED : button.h
  • BST_DISABLE : button.h
  • BST_FOCUS : button.h
  • BST_HILITE : button.h
  • BST_INDETERMINATE : button.h
  • BST_NORMAL : button.h
  • BST_POSE_MASK : button.h
  • BST_PUSHED : button.h
  • BST_UNCHECKED : button.h
  • BT_OPAQUE_STIPPLED : gdi.h
  • BT_SOLID : gdi.h
  • BT_STIPPLED : gdi.h
  • BT_TILED : gdi.h
  • BTN_WIDTH_BORDER : button.h
  • BYTE : common.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- c -

  • CB_ADDSTRING : combobox.h
  • CB_ARC : gdi.h
  • CB_CIRCLE : gdi.h
  • CB_DELETESTRING : combobox.h
  • CB_DIRECT_DRAW_RECT : gdi.h
  • CB_ELLIPSE : gdi.h
  • CB_EQUAL_PIXEL : gdi.h
  • CB_ERR : combobox.h
  • CB_ERRSPACE : combobox.h
  • CB_FASTSPIN : combobox.h
  • CB_FINDSTRING : combobox.h
  • CB_FINDSTRINGEXACT : combobox.h
  • CB_FLOOD_FILL : gdi.h
  • CB_GETCHILDREN : combobox.h
  • CB_GETCOUNT : combobox.h
  • CB_GETCURSEL : combobox.h
  • CB_GETDROPPEDCONTROLRECT : combobox.h
  • CB_GETDROPPEDSTATE : combobox.h
  • CB_GETEDITSEL : combobox.h
  • CB_GETITEMADDDATA : combobox.h
  • CB_GETITEMHEIGHT : combobox.h
  • CB_GETLBTEXT : combobox.h
  • CB_GETLBTEXTLEN : combobox.h
  • CB_GETSPINPACE : combobox.h
  • CB_GETSPINRANGE : combobox.h
  • CB_GETSPINVALUE : combobox.h
  • CB_INSERTSTRING : combobox.h
  • CB_LIMITTEXT : combobox.h
  • CB_LINE : gdi.h
  • CB_OKAY : combobox.h
  • CB_ONE_SCANLINE : gdi.h
  • CB_POLYGON : gdi.h
  • CB_RESETCONTENT : combobox.h
  • CB_SETCURSEL : combobox.h
  • CB_SETEDITSEL : combobox.h
  • CB_SETITEMADDDATA : combobox.h
  • CB_SETITEMHEIGHT : combobox.h
  • CB_SETSPINFORMAT : combobox.h
  • CB_SETSPINPACE : combobox.h
  • CB_SETSPINRANGE : combobox.h
  • CB_SETSPINVALUE : combobox.h
  • CB_SETSTRCMPFUNC : combobox.h
  • CB_SPIN : combobox.h
  • CBERR_BADNAME : minigui.h
  • CBERR_NOMEM : minigui.h
  • CBERR_OK : minigui.h
  • CBM_ADDITEM : coolbar.h
  • CBM_ENABLE : coolbar.h
  • CBN_CLICKED : combobox.h
  • CBN_CLOSEUP : combobox.h
  • CBN_DBLCLK : combobox.h
  • CBN_DROPDOWN : combobox.h
  • CBN_EDITCHANGE : combobox.h
  • CBN_KILLFOCUS : combobox.h
  • CBN_SELCHANGE : combobox.h
  • CBN_SELECTCANCEL : combobox.h
  • CBN_SELECTOK : combobox.h
  • CBN_SETFOCUS : combobox.h
  • CBNAME_TEXT : minigui.h
  • CBOP_APPEND : minigui.h
  • CBOP_NORMAL : minigui.h
  • CBS_AUTOFOCUS : combobox.h
  • CBS_AUTOHSCROLL : combobox.h
  • CBS_AUTOLOOP : combobox.h
  • CBS_AUTOSPIN : combobox.h
  • CBS_BMP_16X16 : coolbar.h
  • CBS_BMP_32X32 : coolbar.h
  • CBS_BMP_CUSTOM : coolbar.h
  • CBS_DISABLENOSCROLL : combobox.h
  • CBS_DROPDOWNLIST : combobox.h
  • CBS_EDITBASELINE : combobox.h
  • CBS_EDITNOBORDER : combobox.h
  • CBS_LOWERCASE : combobox.h
  • CBS_NOTIFY : combobox.h
  • CBS_READONLY : combobox.h
  • CBS_SIMPLE : combobox.h
  • CBS_SORT : combobox.h
  • CBS_SPINARROW_LEFTRIGHT : combobox.h
  • CBS_SPINARROW_TOPBOTTOM : combobox.h
  • CBS_SPINLIST : combobox.h
  • CBS_TYPEMASK : combobox.h
  • CBS_UPPERCASE : combobox.h
  • CBS_USEBKBMP : coolbar.h
  • ChangeCaretSize() : window.h
  • CheckBitmapType() : gdi.h
  • CheckDlgButton() : window.h
  • CheckMenuRadioItem() : window.h
  • CheckRadioButton() : window.h
  • Circle() : gdi.h
  • CircleArc() : gdi.h
  • CircleArcGenerator() : gdi.h
  • CircleGenerator() : gdi.h
  • CleanupMyBitmapSL() : gdi.h
  • ClientHeightToWindowHeightEx() : window.h
  • ClientToScreen() : window.h
  • ClientToWindow() : window.h
  • ClientWidthToWindowWidthEx() : window.h
  • ClipCursor() : minigui.h
  • ClipRectAlloc : gdi.h
  • ClipRectIntersect() : gdi.h
  • ClipRgnCopy() : gdi.h
  • ClipRgnIntersect() : gdi.h
  • CMFLAG_MASK : listbox.h
  • COLOR_black : gdi.h
  • COLOR_blue : gdi.h
  • COLOR_cyan : gdi.h
  • COLOR_darkblue : gdi.h
  • COLOR_darkcyan : gdi.h
  • COLOR_darkgray : gdi.h
  • COLOR_darkgreen : gdi.h
  • COLOR_darkmagenta : gdi.h
  • COLOR_darkred : gdi.h
  • COLOR_darkyellow : gdi.h
  • COLOR_green : gdi.h
  • COLOR_invalid : gdi.h
  • COLOR_lightgray : gdi.h
  • COLOR_lightwhite : gdi.h
  • COLOR_magenta : gdi.h
  • COLOR_red : gdi.h
  • COLOR_transparent : gdi.h
  • COLOR_yellow : gdi.h
  • CompileRGBABitmap() : gdi.h
  • CompileRGBABitmapEx() : gdi.h
  • ConvertMemDC() : gdi.h
  • CopyAcceleratorTable() : window.h
  • CopyRect() : gdi.h
  • CopyRegion : gdi.h
  • CPLOGFONT : gdi.h
  • CreateAcceleratorTable() : window.h
  • CreateAnimationFromGIF89a() : animation.h
  • CreateAnimationFromGIF89aFile() : animation.h
  • CreateAnimationFromGIF89aMem() : animation.h
  • CreateBMPDevFont() : gdi.h
  • CreateCaret() : window.h
  • CreateClipBoard() : minigui.h
  • CreateClipRgn() : gdi.h
  • CreateCompatibleDC : gdi.h
  • CreateCompatibleDCEx() : gdi.h
  • CreateCursor() : minigui.h
  • CreateIcon : gdi.h
  • CreateIconEx() : gdi.h
  • CreateLogFont() : gdi.h
  • CreateLogFontByName() : gdi.h
  • CreateLogFontIndirect() : gdi.h
  • CreateMainWindow() : window.h
  • CreateMainWindowEx() : window.h
  • CreateMainWindowIndirect() : window.h
  • CreateMainWindowIndirectParam() : window.h
  • CreateMainWindowIndirectParamEx() : window.h
  • CreateMemDC() : gdi.h
  • CreateMemDCEx() : gdi.h
  • CreateMemDCFromBitmap() : gdi.h
  • CreateMemDCFromMyBitmap() : gdi.h
  • CreateMenu() : window.h
  • CreatePalette() : gdi.h
  • CreatePopupMenu() : window.h
  • CreatePrivateClientDC() : gdi.h
  • CreatePrivateDC() : gdi.h
  • CreatePrivateSubDC() : gdi.h
  • CreateSecondaryDC() : gdi.h
  • CreateSubMemDC() : gdi.h
  • CreateSystemMenu() : window.h
  • CreateToolTipWin() : ctrlhelper.h
  • CreateWindow : window.h
  • CreateWindowEx() : window.h
  • CreateWindowEx2() : window.h
  • CTRL_ANIMATION : animation.h
  • CTRL_BIDISLEDIT : edit.h
  • CTRL_BUTTON : button.h
  • CTRL_COMBOBOX : combobox.h
  • CTRL_COOLBAR : coolbar.h
  • CTRL_EDIT : edit.h
  • CTRL_GRIDVIEW : gridview.h
  • CTRL_ICONVIEW : iconview.h
  • CTRL_LISTBOX : listbox.h
  • CTRL_LISTVIEW : listview.h
  • CTRL_MEDIT : edit.h
  • CTRL_MENUBTN : menubutton.h
  • CTRL_MENUBUTTON : menubutton.h
  • CTRL_MLEDIT : edit.h
  • CTRL_MONTHCALENDAR : monthcal.h
  • CTRL_NEWTOOLBAR : newtoolbar.h
  • CTRL_PROGRESSBAR : progressbar.h
  • CTRL_PROPSHEET : propsheet.h
  • CTRL_SCROLLBAR : scrollbar.h
  • CTRL_SCROLLVIEW : scrollview.h
  • CTRL_SCROLLWND : scrollview.h
  • CTRL_SLEDIT : edit.h
  • CTRL_SPINBOX : spinbox.h
  • CTRL_STATIC : static.h
  • CTRL_TEXTEDIT : textedit.h
  • CTRL_TRACKBAR : trackbar.h
  • CTRL_TREEVIEW : treeview.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- d -

  • DEF_APRESS_TIME : window.h
  • DEF_INTERVAL_TIME : window.h
  • DEF_LPRESS_TIME : window.h
  • DefaultContainerProc() : scrollview.h
  • DefaultControlProc : window.h
  • DefaultDialogProc : window.h
  • DefaultMainWinProc : window.h
  • DefaultWindowProc() : window.h
  • DeleteAccelerators() : window.h
  • DeleteBitmapAlphaPixel() : gdi.h
  • DeleteCompatibleDC : gdi.h
  • DeleteMemDC() : gdi.h
  • DeleteMenu() : window.h
  • DeletePrivateDC() : gdi.h
  • DeleteSecondaryDC() : gdi.h
  • DesktopUpdateAllWindow() : minigui.h
  • DestroyAcceleratorTable() : window.h
  • DestroyAllControls() : window.h
  • DestroyAnimation() : animation.h
  • DestroyBlockDataHeap() : gdi.h
  • DestroyBMPFont() : gdi.h
  • DestroyCaret() : window.h
  • DestroyClipBoard() : minigui.h
  • DestroyClipRgn() : gdi.h
  • DestroyCursor() : minigui.h
  • DestroyDynamicDevFont() : gdi.h
  • DestroyFreeClipRectList : gdi.h
  • DestroyIcon() : gdi.h
  • DestroyLogFont() : gdi.h
  • DestroyMainWindow() : window.h
  • DestroyMainWindowIndirect() : window.h
  • DestroyMenu() : window.h
  • DestroyPalette() : gdi.h
  • DestroyToolTipWin() : ctrlhelper.h
  • DestroyWindow() : window.h
  • DialogBoxIndirectParam() : window.h
  • DialogBoxIndirectParamEx() : window.h
  • DisabledTextOutEx() : ctrlhelper.h
  • DispatchMessage() : window.h
  • DLGC_3STATE : window.h
  • DLGC_BUTTON : window.h
  • DLGC_DEFPUSHBUTTON : window.h
  • DLGC_HASSETSEL : window.h
  • DLGC_PUSHBUTTON : window.h
  • DLGC_RADIOBUTTON : window.h
  • DLGC_STATIC : window.h
  • DLGC_WANTALLKEYS : window.h
  • DLGC_WANTARROWS : window.h
  • DLGC_WANTCHARS : window.h
  • DLGC_WANTENTER : window.h
  • DLGC_WANTTAB : window.h
  • DoesIntersect() : gdi.h
  • DPtoLP() : gdi.h
  • DrawGlyph() : gdi.h
  • DrawHDotLine : gdi.h
  • DrawHVDotLine() : gdi.h
  • DrawIcon() : gdi.h
  • DrawMenuBar() : window.h
  • DrawText : gdi.h
  • DrawTextEx : gdi.h
  • DrawTextEx2() : gdi.h
  • DrawVDotLine : gdi.h
  • DWORD : common.h
  • DWORD2PIXEL() : gdi.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- e -

  • EC_LEFTMARGIN : edit.h
  • EC_RIGHTMARGIN : edit.h
  • EC_USEFONTINFO : edit.h
  • ED_CARETSHAPE_BLOCK : edit.h
  • ED_CARETSHAPE_LINE : edit.h
  • ED_DRAWSEL_FUNC : edit.h
  • EIMES_CANCELCOMPSTRINFOCUS : edit.h
  • EIMES_COMPLETECOMPSTRKILLFOCUS : edit.h
  • EIMES_GETCOMPSTRATONCE : edit.h
  • Ellipse() : gdi.h
  • EllipseGenerator() : gdi.h
  • EM_CHANGECARETSHAPE : edit.h
  • EM_COPYTOCB : edit.h
  • EM_CUTTOCB : edit.h
  • EM_ENABLECARET : edit.h
  • EM_FMTLINES : edit.h
  • EM_GETCARETPOS : edit.h
  • EM_GETCARETPOSBYLINE : edit.h
  • EM_GETLIMITTEXT : edit.h
  • EM_GETLINE : edit.h
  • EM_GETLINECOUNT : edit.h
  • EM_GETLINEHEIGHT : edit.h
  • EM_GETLINELENGTH : edit.h
  • EM_GETLINELENGTHINMCHAR : edit.h
  • EM_GETLINETEXT : edit.h
  • EM_GETMAXLIMIT : edit.h
  • EM_GETNUMOFPARAGRAPHS : edit.h
  • EM_GETPARAGRAPHLENGTH : edit.h
  • EM_GETPARAGRAPHLENGTHINMCHAR : edit.h
  • EM_GETPARAGRAPHTEXT : edit.h
  • EM_GETPASSWORDCHAR : edit.h
  • EM_GETSEL : edit.h
  • EM_GETSELPOS : edit.h
  • EM_GETSELPOSBYLINE : edit.h
  • EM_GETTIPTEXT : edit.h
  • EM_GETTITLETEXT : edit.h
  • EM_INSERTCBTEXT : edit.h
  • EM_INSERTTEXT : edit.h
  • EM_LIMITTEXT : edit.h
  • EM_LINEFROMCHAR : edit.h
  • EM_LINELENGTH : edit.h
  • EM_LINESCROLL : edit.h
  • EM_REDO : edit.h
  • EM_REFRESHCARET : edit.h
  • EM_REPLACESEL : edit.h
  • EM_SELECTALL : edit.h
  • EM_SETCARETPOS : edit.h
  • EM_SETCARETPOSBYLINE : edit.h
  • EM_SETDRAWSELECTFUNC : edit.h
  • EM_SETGETCARETWIDTHFUNC : edit.h
  • EM_SETINSERTION : edit.h
  • EM_SETLFDISPCHAR : edit.h
  • EM_SETLIMITTEXT : edit.h
  • EM_SETLINEHEIGHT : edit.h
  • EM_SETLINESEP : edit.h
  • EM_SETPASSWORDCHAR : edit.h
  • EM_SETREADONLY : edit.h
  • EM_SETSEL : edit.h
  • EM_SETSELECTION : edit.h
  • EM_SETSELPOS : edit.h
  • EM_SETSELPOSBYLINE : edit.h
  • EM_SETTABSTOPS : edit.h
  • EM_SETTIPTEXT : edit.h
  • EM_SETTITLETEXT : edit.h
  • EM_UNDO : edit.h
  • EmptyClipRgn() : gdi.h
  • EmptyMessageQueue() : window.h
  • EMSIS_COMPOSITIONSTRING : edit.h
  • EN_CHANGE : edit.h
  • EN_CLICKED : edit.h
  • EN_CONTCHANGED : edit.h
  • EN_DBLCLK : edit.h
  • EN_ENTER : edit.h
  • EN_KILLFOCUS : edit.h
  • EN_MAXTEXT : edit.h
  • EN_SELCHANGED : edit.h
  • EN_SETFOCUS : edit.h
  • EN_UPDATE : edit.h
  • EnableMenuItem() : window.h
  • EnableScrollBar() : window.h
  • EnableWindow() : window.h
  • EndDialog() : window.h
  • EndPaint() : window.h
  • EqualRect() : gdi.h
  • ERR_ALREADY_EXIST : common.h
  • ERR_BAD_OWNER : common.h
  • ERR_CONFIG_FILE : common.h
  • ERR_CTRLCLASS_INUSE : common.h
  • ERR_CTRLCLASS_INVLEN : common.h
  • ERR_CTRLCLASS_INVNAME : common.h
  • ERR_CTRLCLASS_MEM : common.h
  • ERR_FILE_IO : common.h
  • ERR_GFX_ENGINE : common.h
  • ERR_IME_NOIMEWND : common.h
  • ERR_IME_NOSUCHIMEWND : common.h
  • ERR_IME_TOOMUCHIMEWND : common.h
  • ERR_INPUT_ENGINE : common.h
  • ERR_INV_HWND : common.h
  • ERR_INVALID_ARGS : common.h
  • ERR_INVALID_HANDLE : common.h
  • ERR_INVALID_HMENU : common.h
  • ERR_INVALID_ID : common.h
  • ERR_INVALID_POS : common.h
  • ERR_NO_ENGINE : common.h
  • ERR_NO_MATCH : common.h
  • ERR_OK : common.h
  • ERR_QUEUE_FULL : common.h
  • ERR_RES_ALLOCATION : common.h
  • ES_AUTOHSCROLL : edit.h
  • ES_AUTOSELECT : edit.h
  • ES_AUTOVSCROLL : edit.h
  • ES_AUTOWRAP : edit.h
  • ES_BASELINE : edit.h
  • ES_CENTER : edit.h
  • ES_LEFT : edit.h
  • ES_LOWERCASE : edit.h
  • ES_MULTILINE : edit.h
  • ES_NOHIDESEL : edit.h
  • ES_PASSWORD : edit.h
  • ES_READONLY : edit.h
  • ES_RIGHT : edit.h
  • ES_TIP : edit.h
  • ES_TITLE : edit.h
  • ES_UPPERCASE : edit.h
  • ETC_FILEIOFAILED : minigui.h
  • ETC_FILENOTFOUND : minigui.h
  • ETC_INTCONV : minigui.h
  • ETC_INVALIDOBJ : minigui.h
  • ETC_KEYNOTFOUND : minigui.h
  • ETC_MAXLINE : minigui.h
  • ETC_OK : minigui.h
  • ETC_READONLYOBJ : minigui.h
  • ETC_SECTIONNOTFOUND : minigui.h
  • ETC_TMPFILEFAILED : minigui.h
  • ETCFILEPATH : minigui.h
  • ExcludeClipRect() : gdi.h
  • ExcludeWindowExStyle() : window.h
  • ExcludeWindowStyle() : window.h
  • ExitGUISafely() : minigui.h
  • Expand16CBitmap() : gdi.h
  • ExpandMonoBitmap() : gdi.h
  • ExpandMyBitmap() : gdi.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- f -

  • FALSE : common.h
  • FillArcEx() : gdi.h
  • FillBitmapPartInBox() : gdi.h
  • FillBox() : gdi.h
  • FillBoxWithBitmap() : gdi.h
  • FillBoxWithBitmapPart() : gdi.h
  • FillCircle() : gdi.h
  • FillEllipse() : gdi.h
  • FillPolygon() : gdi.h
  • FindSectionInEtc() : minigui.h
  • fixacos() : fixedmath.h
  • fixadd() : fixedmath.h
  • fixasin() : fixedmath.h
  • fixatan() : fixedmath.h
  • fixatan2() : fixedmath.h
  • fixceil() : fixedmath.h
  • fixcos() : fixedmath.h
  • fixdiv() : fixedmath.h
  • fixed : common.h
  • fixhypot() : fixedmath.h
  • fixmul() : fixedmath.h
  • fixsin() : fixedmath.h
  • fixsqrt() : fixedmath.h
  • FixStrAlloc() : minigui.h
  • FixStrDup() : minigui.h
  • fixsub() : fixedmath.h
  • fixtan() : fixedmath.h
  • fixtof() : fixedmath.h
  • fixtoi() : fixedmath.h
  • FloodFill() : gdi.h
  • FloodFillGenerator() : gdi.h
  • FocusRect() : gdi.h
  • FONT_CHARSET_EUCTW : gdi.h
  • FONT_CHARSET_GB18030_0 : gdi.h
  • FONT_CHARSET_GB1988_0 : gdi.h
  • FONT_CHARSET_GB2312_0 : gdi.h
  • FONT_CHARSET_ISO_10646_1 : gdi.h
  • FONT_CHARSET_JISX0201_0 : gdi.h
  • FONT_CHARSET_JISX0201_1 : gdi.h
  • FONT_CHARSET_JISX0208_0 : gdi.h
  • FONT_CHARSET_JISX0208_1 : gdi.h
  • FONT_CHARSET_KSC5601_0 : gdi.h
  • FONT_CHARSET_KSC5636_0 : gdi.h
  • FONT_CHARSET_UTF16BE : gdi.h
  • FONT_CHARSET_UTF16LE : gdi.h
  • FONT_CHARSET_UTF8 : gdi.h
  • FreeClipRect : gdi.h
  • FreeFixStr() : minigui.h
  • ft2SetLcdFilter() : gdi.h
  • ftofix() : fixedmath.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- g -

  • g_rcDesktop : minigui.h
  • g_rcScr : minigui.h
  • gal_attr : common.h
  • gal_pixel : common.h
  • gal_sint : common.h
  • gal_sint16 : common.h
  • gal_sint32 : common.h
  • gal_sint8 : common.h
  • gal_uint : common.h
  • gal_uint16 : common.h
  • gal_uint32 : common.h
  • gal_uint8 : common.h
  • GetActiveWindow() : window.h
  • GetAValue : common.h
  • GetBitmapFromDC() : gdi.h
  • GetBkColor : gdi.h
  • GetBkMode : gdi.h
  • GetBoundRect() : gdi.h
  • GetBoundsRect() : gdi.h
  • GetBrushColor : gdi.h
  • GetBrushType : gdi.h
  • GetBValue : common.h
  • GetCapture() : window.h
  • GetCaretBlinkTime() : window.h
  • GetCaretPos() : window.h
  • GetClassName() : window.h
  • GetClientDC() : gdi.h
  • GetClientRect() : window.h
  • GetClipBoardByte() : minigui.h
  • GetClipBoardData() : minigui.h
  • GetClipBoardDataLen() : minigui.h
  • GetClipBox() : gdi.h
  • GetClipCursor() : minigui.h
  • GetClipRgnBoundRect() : gdi.h
  • GetCurFont() : gdi.h
  • GetCurrentCursor() : minigui.h
  • GetCursorPos() : minigui.h
  • GetDC() : gdi.h
  • GetDCAttr() : gdi.h
  • GetDCLCS() : gdi.h
  • GetDefaultCursor() : minigui.h
  • GetDefaultPalette() : gdi.h
  • GetDefaultWindowElementRenderer() : window.h
  • GetDlgCtrlID() : window.h
  • GetDlgDefPushButton() : window.h
  • GetDlgItem() : window.h
  • GetDlgItemInt() : window.h
  • GetDlgItemText() : window.h
  • GetDlgItemText2() : window.h
  • GetFirstHosted() : window.h
  • GetFirstMCharLen() : gdi.h
  • GetFirstWord() : gdi.h
  • GetFocus : window.h
  • GetFocusChild() : window.h
  • GetFontHeight() : gdi.h
  • GetFontMetrics() : gdi.h
  • GetForegroundWindow : window.h
  • GetGDCapability() : gdi.h
  • GetGlyphBitmap() : gdi.h
  • GetGlyphInfo() : gdi.h
  • GetGlyphsExtent() : gdi.h
  • GetGlyphsExtentPoint() : gdi.h
  • GetGlyphShape() : gdi.h
  • GetGlyphValue() : gdi.h
  • GetGValue : common.h
  • GetHosting() : window.h
  • GetIconSize() : gdi.h
  • GetIMEPos() : window.h
  • GetIMEStatus() : window.h
  • GetIMETargetInfo() : window.h
  • GetIntValueFromEtc() : minigui.h
  • GetIntValueFromEtcFile() : minigui.h
  • GetIntValueFromEtcSec() : minigui.h
  • GetKeyStatus() : minigui.h
  • GetLargeSystemIcon : window.h
  • GetLargeSystemIconEx() : window.h
  • GetLastTextOutPos() : gdi.h
  • GetLogFontInfo() : gdi.h
  • GetMainWindowHandle() : window.h
  • GetMapMode : gdi.h
  • GetMaxFontWidth() : gdi.h
  • GetMenu() : window.h
  • GetMenuBarItemRect() : window.h
  • GetMenuItemCount() : window.h
  • GetMenuItemID() : window.h
  • GetMenuItemInfo() : window.h
  • GetMessage() : window.h
  • GetMgEtcIntValue() : minigui.h
  • GetMgEtcValue() : minigui.h
  • GetNearestColor() : gdi.h
  • GetNearestPaletteIndex() : gdi.h
  • GetNextChild() : window.h
  • GetNextDevFont() : gdi.h
  • GetNextDlgGroupItem() : window.h
  • GetNextDlgTabItem() : window.h
  • GetNextHosted() : window.h
  • GetNextMainWindow() : window.h
  • GetNotificationCallback() : window.h
  • GetOriginalMousePosition() : minigui.h
  • GetOriginalTermIO() : minigui.h
  • GetPalette() : gdi.h
  • GetPaletteEntries() : gdi.h
  • GetParent() : window.h
  • GetPenCapStyle : gdi.h
  • GetPenColor : gdi.h
  • GetPenJoinStyle : gdi.h
  • GetPenType : gdi.h
  • GetPenWidth : gdi.h
  • GetPixel() : gdi.h
  • GetPixelInBitmap() : gdi.h
  • GetPixelInBitmapEx() : gdi.h
  • GetPixelRGB() : gdi.h
  • GetPixelRGBA() : gdi.h
  • GetPopupSubMenu() : window.h
  • GetPrivateClientDC() : gdi.h
  • GetRasterOperation() : gdi.h
  • GetResource() : window.h
  • GetRValue : common.h
  • GetScrollInfo() : window.h
  • GetScrollPos() : window.h
  • GetScrollRange() : window.h
  • GetSecondaryClientDC() : gdi.h
  • GetSecondaryDC() : gdi.h
  • GetShiftKeyStatus() : minigui.h
  • GetSmallSystemIcon : window.h
  • GetSmallSystemIconEx() : window.h
  • GetSpinBoxSize() : spinbox.h
  • GetSubDC() : gdi.h
  • GetSubMenu() : window.h
  • GetSysCCharWidth() : gdi.h
  • GetSysCharHeight() : gdi.h
  • GetSysCharset() : gdi.h
  • GetSysCharWidth() : gdi.h
  • GetSysFontAveWidth() : gdi.h
  • GetSysFontHeight() : gdi.h
  • GetSysFontMaxWidth() : gdi.h
  • GetSystemBitmap() : window.h
  • GetSystemBitmapByHwnd() : window.h
  • GetSystemBitmapEx() : window.h
  • GetSystemCursor() : minigui.h
  • GetSystemFont() : gdi.h
  • GetSystemMenu() : window.h
  • GetSysText() : minigui.h
  • GetSysTextInUTF8() : minigui.h
  • GetTabbedTextExtent() : gdi.h
  • GetTabbedTextExtentPoint() : gdi.h
  • GetTabStop : gdi.h
  • GetTextAboveLineExtra : gdi.h
  • GetTextAlign : gdi.h
  • GetTextBellowLineExtra : gdi.h
  • GetTextCharacterExtra : gdi.h
  • GetTextColor : gdi.h
  • GetTextExtent() : gdi.h
  • GetTextExtentPoint() : gdi.h
  • GetTextMCharInfo() : gdi.h
  • GetTextRangesLog2Vis() : gdi.h
  • GetTextWordInfo() : gdi.h
  • GetTickCount() : window.h
  • GetUpdateRect() : window.h
  • GetValueFromEtc() : minigui.h
  • GetValueFromEtcFile() : minigui.h
  • GetValueFromEtcSec() : minigui.h
  • GetViewportExt : gdi.h
  • GetViewportOrg : gdi.h
  • GetWindowAdditionalData() : window.h
  • GetWindowAdditionalData2() : window.h
  • GetWindowBkColor() : window.h
  • GetWindowCallbackProc() : window.h
  • GetWindowCaption() : window.h
  • GetWindowClassAdditionalData() : window.h
  • GetWindowClassInfo() : window.h
  • GetWindowCursor() : window.h
  • GetWindowElementAttr() : window.h
  • GetWindowElementColor : window.h
  • GetWindowElementPixelEx() : window.h
  • GetWindowExStyle() : window.h
  • GetWindowExt : gdi.h
  • GetWindowFont() : window.h
  • GetWindowIcon() : window.h
  • GetWindowInfo() : window.h
  • GetWindowOrg : gdi.h
  • GetWindowRect() : window.h
  • GetWindowRendererFromName() : window.h
  • GetWindowStyle() : window.h
  • GetWindowText() : window.h
  • GetWindowTextLength() : window.h
  • GetWindowUnderCursor() : window.h
  • GHANDLE : common.h
  • GLYPHINFO : gdi.h
  • GLYPHMAPINFO : gdi.h
  • GRID_ERR : gridview.h
  • GRID_OKAY : gridview.h
  • GRIDM_ADDCOLUMN : gridview.h
  • GRIDM_ADDDEPENDENCE : gridview.h
  • GRIDM_ADDROW : gridview.h
  • GRIDM_DELCOLUMN : gridview.h
  • GRIDM_DELDEPENDENCE : gridview.h
  • GRIDM_DELROW : gridview.h
  • GRIDM_ENDCELLEDIT : gridview.h
  • GRIDM_GETCELLPROPERTY : gridview.h
  • GRIDM_GETCOLCOUNT : gridview.h
  • GRIDM_GETCOLWIDTH : gridview.h
  • GRIDM_GETROWCOUNT : gridview.h
  • GRIDM_GETROWHEIGHT : gridview.h
  • GRIDM_GETSELECTED : gridview.h
  • GRIDM_SETCELLPROPERTY : gridview.h
  • GRIDM_SETCOLWIDTH : gridview.h
  • GRIDM_SETNUMFORMAT : gridview.h
  • GRIDM_SETROWHEIGHT : gridview.h
  • GRIDM_SETSELECTED : gridview.h
  • GRIDN_CELLCLK : gridview.h
  • GRIDN_CELLDBCLK : gridview.h
  • GRIDN_CELLTEXTCHANGED : gridview.h
  • GRIDN_FOCUSCHANGED : gridview.h
  • GRIDN_HEADLDOWN : gridview.h
  • GRIDN_HEADLUP : gridview.h
  • GRIDN_KEYDOWN : gridview.h
  • GV_HALIGN_CENTER : gridview.h
  • GV_HALIGN_LEFT : gridview.h
  • GV_HALIGN_MASK : gridview.h
  • GV_HALIGN_RIGHT : gridview.h
  • GV_TYPE_CHECKBOX : gridview.h
  • GV_TYPE_HEADER : gridview.h
  • GV_TYPE_MASK : gridview.h
  • GV_TYPE_NUMBER : gridview.h
  • GV_TYPE_SELECTION : gridview.h
  • GV_TYPE_TABLEHEADER : gridview.h
  • GV_TYPE_TEXT : gridview.h
  • GV_TYPE_UNKNOWN : gridview.h
  • GV_VALIGN_BOTTOM : gridview.h
  • GV_VALIGN_CENTER : gridview.h
  • GV_VALIGN_MASK : gridview.h
  • GV_VALIGN_TOP : gridview.h
  • GVS_BOXCHECKED : gridview.h
  • GVS_MULTLINE : gridview.h
  • GVS_READONLY : gridview.h
  • GVS_WITHCHECKBOX : gridview.h
  • GVS_WITHICON : gridview.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- h -

  • HACCEL : common.h
  • HaveFreeTimer() : window.h
  • HavePendingMessage() : window.h
  • HCURSOR : common.h
  • HDC : common.h
  • HDC_INVALID : gdi.h
  • HDC_SCREEN : gdi.h
  • HDLG : common.h
  • HFlipBitmap() : gdi.h
  • HHOOK : common.h
  • HIBYTE : common.h
  • HICON : common.h
  • HideCaret() : window.h
  • HiliteMenuBarItem() : window.h
  • HISWORD : common.h
  • HIVITEM : iconview.h
  • HIWORD : common.h
  • HLVITEM : listview.h
  • HMENU : common.h
  • HOOK_GOON : window.h
  • HOOK_STOP : window.h
  • HOTSPOTPROC : newtoolbar.h
  • HPALETTE : common.h
  • HSVITEM : scrollview.h
  • HTEXTDOC : textedit.h
  • HWND : common.h
  • HWND_DESKTOP : window.h
  • HWND_INVALID : window.h
  • HWND_NULL : window.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- i -

  • iconview_get_item_adddata() : iconview.h
  • iconview_get_item_bitmap() : iconview.h
  • iconview_get_item_label() : iconview.h
  • iconview_is_item_hilight() : iconview.h
  • IDC_ARROW : minigui.h
  • IDC_BUSY : minigui.h
  • IDC_COLOMN : minigui.h
  • IDC_CROSS : minigui.h
  • IDC_DRAG : minigui.h
  • IDC_HAND_POINT : minigui.h
  • IDC_HAND_SELECT : minigui.h
  • IDC_HELP : minigui.h
  • IDC_IBEAM : minigui.h
  • IDC_MOVE : minigui.h
  • IDC_NODROP : minigui.h
  • IDC_NONE : minigui.h
  • IDC_PENCIL : minigui.h
  • IDC_RARROW : minigui.h
  • IDC_ROW : minigui.h
  • IDC_SIZENESW : minigui.h
  • IDC_SIZENS : minigui.h
  • IDC_SIZENWSE : minigui.h
  • IDC_SIZEWE : minigui.h
  • IDC_SPLIT_HORZ : minigui.h
  • IDC_SPLIT_VERT : minigui.h
  • IDC_UPARROW : minigui.h
  • IDC_WAIT : minigui.h
  • IDM_DTI_FIRST : minigui.h
  • IDS_MGST_ABORT : minigui.h
  • IDS_MGST_ABOUTMG : minigui.h
  • IDS_MGST_ACCESSMODE : minigui.h
  • IDS_MGST_CANCEL : minigui.h
  • IDS_MGST_CLOSE : minigui.h
  • IDS_MGST_CLOSEALLWIN : minigui.h
  • IDS_MGST_COLORSEL : minigui.h
  • IDS_MGST_CURRPATH : minigui.h
  • IDS_MGST_DELLAYER : minigui.h
  • IDS_MGST_ENDSESSION : minigui.h
  • IDS_MGST_ERROR : minigui.h
  • IDS_MGST_FILE : minigui.h
  • IDS_MGST_FILEEXIST : minigui.h
  • IDS_MGST_FILENAME : minigui.h
  • IDS_MGST_FILETYPE : minigui.h
  • IDS_MGST_IGNORE : minigui.h
  • IDS_MGST_INFO : minigui.h
  • IDS_MGST_LASTMODTIME : minigui.h
  • IDS_MGST_LOCATION : minigui.h
  • IDS_MGST_LOGO : minigui.h
  • IDS_MGST_MAXIMIZE : minigui.h
  • IDS_MGST_MINIMIZE : minigui.h
  • IDS_MGST_NAME : minigui.h
  • IDS_MGST_NEXT : minigui.h
  • IDS_MGST_NO : minigui.h
  • IDS_MGST_NOTFOUND : minigui.h
  • IDS_MGST_NR : minigui.h
  • IDS_MGST_NW : minigui.h
  • IDS_MGST_OK : minigui.h
  • IDS_MGST_OPEN : minigui.h
  • IDS_MGST_OPENFILE : minigui.h
  • IDS_MGST_OPERATIONS : minigui.h
  • IDS_MGST_PREV : minigui.h
  • IDS_MGST_R : minigui.h
  • IDS_MGST_REFRESH : minigui.h
  • IDS_MGST_RESTORE : minigui.h
  • IDS_MGST_RETRY : minigui.h
  • IDS_MGST_SAVE : minigui.h
  • IDS_MGST_SAVEFILE : minigui.h
  • IDS_MGST_SHOWHIDEFILE : minigui.h
  • IDS_MGST_SIZE : minigui.h
  • IDS_MGST_START : minigui.h
  • IDS_MGST_SWITCHLAYER : minigui.h
  • IDS_MGST_UP : minigui.h
  • IDS_MGST_W : minigui.h
  • IDS_MGST_WINDOW : minigui.h
  • IDS_MGST_WR : minigui.h
  • IDS_MGST_YES : minigui.h
  • IMGFLAG_BITMAP : listbox.h
  • IncludeClipRect() : gdi.h
  • IncludeWindowExStyle() : window.h
  • IncludeWindowStyle() : window.h
  • InflateRect() : gdi.h
  • InflateRectToPt() : gdi.h
  • InitBitmap() : gdi.h
  • InitBitmapPixelFormat() : gdi.h
  • InitBlockDataHeap() : gdi.h
  • InitCircleRegion() : gdi.h
  • InitClipRgn() : gdi.h
  • InitEllipseRegion() : gdi.h
  • InitFreeClipRectList : gdi.h
  • InitGUI() : minigui.h
  • InitMyBitmapSL() : gdi.h
  • InitPolygonRegion() : gdi.h
  • InitRendererSystemIcon() : window.h
  • InitSlaveScreen() : gdi.h
  • InitVectorialFonts() : gdi.h
  • InitWindowElementAttrs() : window.h
  • InsertMenuItem() : window.h
  • IntersectClipRect() : gdi.h
  • IntersectRect() : gdi.h
  • IntersectRegion : gdi.h
  • INV_LOGFONT : gdi.h
  • InvalidateRect() : window.h
  • IS_MBC_GLYPH : gdi.h
  • IsCompatibleDC() : gdi.h
  • IsControl() : window.h
  • IsCovered() : gdi.h
  • IsDialog() : window.h
  • IsDlgButtonChecked() : window.h
  • IsEmptyClipRgn() : gdi.h
  • IsMainWindow() : window.h
  • IsMenu() : window.h
  • IsRectEmpty() : gdi.h
  • IsTimerInstalled() : window.h
  • IsWindow() : window.h
  • IsWindowEnabled() : window.h
  • IsWindowVisible() : window.h
  • itofix() : fixedmath.h
  • IV_ERR : iconview.h
  • IV_ERRSPACE : iconview.h
  • IV_OKAY : iconview.h
  • IVFLAG_BITMAP : iconview.h
  • IVFLAG_ICON : iconview.h
  • IVM_ADDITEM : iconview.h
  • IVM_CHOOSEITEM : iconview.h
  • IVM_DELITEM : iconview.h
  • IVM_GETBOTTOMMARGIN : iconview.h
  • IVM_GETCONTENTX : iconview.h
  • IVM_GETCONTENTY : iconview.h
  • IVM_GETCONTHEIGHT : iconview.h
  • IVM_GETCONTWIDTH : iconview.h
  • IVM_GETCURSEL : iconview.h
  • IVM_GETFIRSTVISIBLEITEM : iconview.h
  • IVM_GETHSCROLLPAGEVAL : iconview.h
  • IVM_GETHSCROLLVAL : iconview.h
  • IVM_GETITEMADDDATA : iconview.h
  • IVM_GETITEMCOUNT : iconview.h
  • IVM_GETLEFTMARGIN : iconview.h
  • IVM_GETMARGINS : iconview.h
  • IVM_GETRIGHTMARGIN : iconview.h
  • IVM_GETTOPMARGIN : iconview.h
  • IVM_GETVISIBLEHEIGHT : iconview.h
  • IVM_GETVISIBLEWIDTH : iconview.h
  • IVM_GETVSCROLLPAGEVAL : iconview.h
  • IVM_GETVSCROLLVAL : iconview.h
  • IVM_MAKEPOSVISIBLE : iconview.h
  • IVM_REFRESHITEM : iconview.h
  • IVM_RESETCONTENT : iconview.h
  • IVM_SELECTITEM : iconview.h
  • IVM_SETCONTHEIGHT : iconview.h
  • IVM_SETCONTPOS : iconview.h
  • IVM_SETCONTRANGE : iconview.h
  • IVM_SETCONTWIDTH : iconview.h
  • IVM_SETCURSEL : iconview.h
  • IVM_SETITEMADDDATA : iconview.h
  • IVM_SETITEMCMP : iconview.h
  • IVM_SETITEMDESTROY : iconview.h
  • IVM_SETITEMDRAW : iconview.h
  • IVM_SETITEMINIT : iconview.h
  • IVM_SETITEMOPS : iconview.h
  • IVM_SETITEMSIZE : iconview.h
  • IVM_SETMARGINS : iconview.h
  • IVM_SETSCROLLPAGEVAL : iconview.h
  • IVM_SETSCROLLVAL : iconview.h
  • IVM_SHOWITEM : iconview.h
  • IVM_SORTITEMS : iconview.h
  • IVN_CLICKED : iconview.h
  • IVN_SELCHANGED : iconview.h
  • IVS_AUTOSORT : iconview.h
  • IVS_LOOP : iconview.h
  • IVS_NOTIFY : iconview.h
  • IVS_UPNOTIFY : iconview.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- p -

  • PaintImageEx() : gdi.h
  • PaintImageFromFile() : gdi.h
  • PaintImageFromMem() : gdi.h
  • PB_ERR : progressbar.h
  • PB_OKAY : progressbar.h
  • PBITMAP : gdi.h
  • PBLOCKHEAP : gdi.h
  • PBM_DELTAPOS : progressbar.h
  • PBM_SETPOS : progressbar.h
  • PBM_SETRANGE : progressbar.h
  • PBM_SETSTEP : progressbar.h
  • PBM_STEPIT : progressbar.h
  • PBN_REACHMAX : progressbar.h
  • PBN_REACHMIN : progressbar.h
  • PBS_NOTIFY : progressbar.h
  • PBS_VERTICAL : progressbar.h
  • PCLIPRGN : gdi.h
  • PCONTAINERINFO : scrollview.h
  • PCOOLBARITEMINFO : coolbar.h
  • PeekMessage() : window.h
  • PeekMessageEx() : window.h
  • PeekPostMessage() : window.h
  • PenType : gdi.h
  • PETCSECTION : minigui.h
  • PFN_LVHDR_BKDRAWFUNC : listview.h
  • PFN_LVHDR_ITEMDRAWFUNC : listview.h
  • PFNLVCOMPARE : listview.h
  • Ping() : minigui.h
  • PivotBitmap() : gdi.h
  • PivotScaledBitmapFlip() : gdi.h
  • Pixel2DWORD() : gdi.h
  • Pixel2RGB() : gdi.h
  • Pixel2RGBA() : gdi.h
  • Pixel2RGBAs() : gdi.h
  • Pixel2RGBs() : gdi.h
  • PIXEL_black : gdi.h
  • PIXEL_blue : gdi.h
  • PIXEL_cyan : gdi.h
  • PIXEL_darkblue : gdi.h
  • PIXEL_darkcyan : gdi.h
  • PIXEL_darkgray : gdi.h
  • PIXEL_darkgreen : gdi.h
  • PIXEL_darkmagenta : gdi.h
  • PIXEL_darkred : gdi.h
  • PIXEL_darkyellow : gdi.h
  • PIXEL_green : gdi.h
  • PIXEL_invalid : gdi.h
  • PIXEL_lightgray : gdi.h
  • PIXEL_lightwhite : gdi.h
  • PIXEL_magenta : gdi.h
  • PIXEL_red : gdi.h
  • PIXEL_transparent : gdi.h
  • PIXEL_yellow : gdi.h
  • PLISTBOXITEMINFO : listbox.h
  • PLOGFONT : gdi.h
  • PLVCOLUMN : listview.h
  • PLVFINDINFO : listview.h
  • PLVITEM : listview.h
  • PLVNM_HEADRDOWN : listview.h
  • PLVNM_HEADUP : listview.h
  • PLVNM_ITEMRDOWN : listview.h
  • PLVNM_ITEMRUP : listview.h
  • PLVNM_KEYDOWN : listview.h
  • PLVNM_NORMAL : listview.h
  • PLVSORTDATA : listview.h
  • PLVSUBITEM : listview.h
  • PM_NOREMOVE : window.h
  • PM_NOYIELD : window.h
  • PM_REMOVE : window.h
  • PMCCOLORINFO : monthcal.h
  • PMENUBUTTONITEM : menubutton.h
  • PMYBITMAP : gdi.h
  • PNTBITEMINFO : newtoolbar.h
  • PolyArcEx() : gdi.h
  • PolyFillArcEx() : gdi.h
  • PolygonGenerator : gdi.h
  • PolygonGeneratorEx() : gdi.h
  • PolygonIsMonotoneVertical() : gdi.h
  • PolyLineEx() : gdi.h
  • PolyLineTo() : gdi.h
  • PostMessage() : window.h
  • PostQuitMessage() : window.h
  • PPOINT : common.h
  • PRECT : common.h
  • PRGB : common.h
  • PS_ERR : propsheet.h
  • PS_OKAY : propsheet.h
  • PSIZE : common.h
  • PSM_ADDPAGE : propsheet.h
  • PSM_GETACTIVEINDEX : propsheet.h
  • PSM_GETACTIVEPAGE : propsheet.h
  • PSM_GETPAGE : propsheet.h
  • PSM_GETPAGECOUNT : propsheet.h
  • PSM_GETPAGEINDEX : propsheet.h
  • PSM_GETTITLE : propsheet.h
  • PSM_GETTITLELENGTH : propsheet.h
  • PSM_REMOVEPAGE : propsheet.h
  • PSM_SETACTIVEINDEX : propsheet.h
  • PSM_SETTITLE : propsheet.h
  • PSM_SHEETCMD : propsheet.h
  • PSN_ACTIVE_CHANGED : propsheet.h
  • PSPININFO : spinbox.h
  • PSS_BOTTOM : propsheet.h
  • PSS_COMPACTTAB : propsheet.h
  • PSS_SCROLLABLE : propsheet.h
  • PSS_SIMPLE : propsheet.h
  • PSVITEMINFO : scrollview.h
  • PSVITEMOPS : scrollview.h
  • PSYSTEMTIME : monthcal.h
  • PT_CAP_BUTT : gdi.h
  • PT_CAP_PROJECTING : gdi.h
  • PT_CAP_ROUND : gdi.h
  • PT_DOUBLE_DASH : gdi.h
  • PT_JOIN_BEVEL : gdi.h
  • PT_JOIN_MITER : gdi.h
  • PT_JOIN_ROUND : gdi.h
  • PT_ON_OFF_DASH : gdi.h
  • PT_SOLID : gdi.h
  • PTCapStyle : gdi.h
  • PtInRect() : gdi.h
  • PtInRegion() : gdi.h
  • PTJoinStyle : gdi.h
  • PtVisible() : gdi.h
  • PTVITEMINFO : treeview.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- r -

  • REAL_GLYPH : gdi.h
  • RealizePalette() : gdi.h
  • Rectangle() : gdi.h
  • RECTH : gdi.h
  • RECTHP : gdi.h
  • RectInRegion() : gdi.h
  • RectVisible() : gdi.h
  • RECTW : gdi.h
  • RECTWP : gdi.h
  • RegisterBitmapFileType() : gdi.h
  • RegisterIMEWindow() : window.h
  • RegisterKeyMsgHook() : window.h
  • RegisterListenFD() : minigui.h
  • RegisterMouseMsgHook() : window.h
  • RegisterResFromBitmap() : window.h
  • RegisterResFromFile() : window.h
  • RegisterResFromMem() : window.h
  • RegisterResType() : window.h
  • RegisterSystemBitmap() : window.h
  • RegisterWindowClass() : window.h
  • ReinitDesktop : minigui.h
  • ReinitDesktopEx() : minigui.h
  • ReleaseCapture() : window.h
  • ReleaseDC() : gdi.h
  • ReleaseRes() : window.h
  • ReleaseSecondaryDC() : gdi.h
  • RemoveMenu() : window.h
  • RemoveSectionInEtc() : minigui.h
  • RemoveSectionInEtcFile() : minigui.h
  • RemoveWindowElementRenderer() : window.h
  • ReplaceBitmapColor() : gdi.h
  • ResetTimer : window.h
  • ResetTimerEx() : window.h
  • ResetToolTipWin() : ctrlhelper.h
  • ResizePalette() : gdi.h
  • RestoreDC() : gdi.h
  • RetrieveRes() : window.h
  • RGB2Pixel() : gdi.h
  • RGB2Pixels() : gdi.h
  • RGBA2Pixel() : gdi.h
  • RGBA2Pixels() : gdi.h
  • RGBCOLOR : common.h
  • RotateBitmap() : gdi.h
  • RotateBitmapHFlip() : gdi.h
  • RotateBitmapVFlip() : gdi.h
  • RotateScaledBitmap() : gdi.h
  • RotateScaledBitmapHFlip() : gdi.h
  • RotateScaledBitmapVFlip() : gdi.h
  • RoundRect() : gdi.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- s -

  • SaveBitmapToFile() : gdi.h
  • SaveDC() : gdi.h
  • SaveEtcToFile() : minigui.h
  • SaveMainWindowContent() : gdi.h
  • SaveMyBitmapToFile() : gdi.h
  • SaveScreenRectContent() : gdi.h
  • SaveSectionToEtcFile() : minigui.h
  • SB_ARROW_BOTH : window.h
  • SB_ARROW_BTDN : window.h
  • SB_ARROW_LTUP : window.h
  • SB_BOTTOM : window.h
  • SB_ENDSCROLL : window.h
  • SB_LINEDOWN : window.h
  • SB_LINELEFT : window.h
  • SB_LINERIGHT : window.h
  • SB_LINEUP : window.h
  • SB_PAGEDOWN : window.h
  • SB_PAGELEFT : window.h
  • SB_PAGERIGHT : window.h
  • SB_PAGEUP : window.h
  • SB_POLICY_ALWAYS : ctrlhelper.h
  • SB_POLICY_AUTOMATIC : ctrlhelper.h
  • SB_POLICY_NEVER : ctrlhelper.h
  • SB_THUMBPOSITION : window.h
  • SB_THUMBTRACK : window.h
  • SB_TOP : window.h
  • SBM_ENABLE_ARROW : scrollbar.h
  • SBM_GETPOS : scrollbar.h
  • SBM_GETRANGE : scrollbar.h
  • SBM_GETSCROLLINFO : scrollbar.h
  • SBM_SETPOS : scrollbar.h
  • SBM_SETRANGE : scrollbar.h
  • SBM_SETRANGEREDRAW : scrollbar.h
  • SBM_SETSCROLLINFO : scrollbar.h
  • SBPolicyType : ctrlhelper.h
  • SBS_BOTTOMALIGN : scrollbar.h
  • SBS_DISABLED_BTDN : window.h
  • SBS_DISABLED_LTUP : window.h
  • SBS_FIXEDBARLEN : scrollbar.h
  • SBS_HILITE_BTDN : window.h
  • SBS_HILITE_LTUP : window.h
  • SBS_HILITE_THUMB : window.h
  • SBS_HORZ : scrollbar.h
  • SBS_LEFTALIGN : scrollbar.h
  • SBS_NOARROW : scrollbar.h
  • SBS_NOSHAFT : scrollbar.h
  • SBS_NOTNOTIFYPARENT : scrollbar.h
  • SBS_PRESSED_BTDN : window.h
  • SBS_PRESSED_LTUP : window.h
  • SBS_PRESSED_THUMB : window.h
  • SBS_RIGHTALIGN : scrollbar.h
  • SBS_TOPALIGN : scrollbar.h
  • SBS_VERT : scrollbar.h
  • SBYTE : common.h
  • ScaleBitmapEx() : gdi.h
  • SCANCODE_USER : common.h
  • ScreenToClient() : window.h
  • ScreenToWindow() : window.h
  • scrollview_get_item_adddata() : scrollview.h
  • scrollview_get_item_index() : scrollview.h
  • scrollview_is_item_hilight() : scrollview.h
  • scrollview_is_item_selected() : scrollview.h
  • scrollview_set_item_height() : scrollview.h
  • ScrollWindow() : window.h
  • SDWORD : common.h
  • SELECT_DEVFONT : gdi.h
  • SelectClipRect() : gdi.h
  • SelectClipRegion() : gdi.h
  • SelectClipRegionEx() : gdi.h
  • SelectFont() : gdi.h
  • SelectPalette() : gdi.h
  • SendAsyncMessage : window.h
  • SendDlgItemMessage() : window.h
  • SendMessage() : window.h
  • SendNotifyMessage() : window.h
  • SET_MBC_GLYPH : gdi.h
  • SetActiveWindow() : window.h
  • SetAutoRepeatMessage() : window.h
  • SetBitmapKeyColor() : window.h
  • SetBitmapScalerType() : gdi.h
  • SetBkColor : gdi.h
  • SetBkMode : gdi.h
  • SetBrushColor : gdi.h
  • SetBrushInfo() : gdi.h
  • SetBrushOrigin() : gdi.h
  • SetBrushType : gdi.h
  • SetCapture() : window.h
  • SetCaretBlinkTime() : window.h
  • SetCaretPos() : window.h
  • SetClipBoardData() : minigui.h
  • SetClipRgn() : gdi.h
  • SetColorfulPalette() : gdi.h
  • SetCursor : minigui.h
  • SetCursorEx() : minigui.h
  • SetCursorPos() : minigui.h
  • SetCustomDesktopOperationSet() : minigui.h
  • SetDCAttr() : gdi.h
  • SetDCLCS() : gdi.h
  • SetDefaultCursor : minigui.h
  • SetDefaultWindowElementRenderer() : window.h
  • SetDlgItemInt() : window.h
  • SetDlgItemText() : window.h
  • SetFocus : window.h
  • SetFocusChild() : window.h
  • SetForegroundWindow : window.h
  • SetIMEStatus() : window.h
  • SetIMETargetInfo() : window.h
  • SetIntervalTime : window.h
  • SetKeyAlwaysPressTime : window.h
  • SetKeyboardLayout() : window.h
  • SetKeyLongPressTime : window.h
  • SetMapMode : gdi.h
  • SetMemDCAlpha() : gdi.h
  • SetMemDCColorKey() : gdi.h
  • SetMenu() : window.h
  • SetMenuItemBitmaps() : window.h
  • SetMenuItemInfo() : window.h
  • SetMouseCalibrationParameters() : minigui.h
  • SetNotificationCallback() : window.h
  • SetNullFocus() : window.h
  • SetPalette() : gdi.h
  • SetPaletteEntries() : gdi.h
  • SetPenCapStyle : gdi.h
  • SetPenColor : gdi.h
  • SetPenDashes() : gdi.h
  • SetPenJoinStyle : gdi.h
  • SetPenType : gdi.h
  • SetPenWidth : gdi.h
  • SetPixel() : gdi.h
  • SetPixelInBitmap() : gdi.h
  • SetPixelRGB() : gdi.h
  • SetPixelRGBA() : gdi.h
  • SetRasterOperation() : gdi.h
  • SetRect() : gdi.h
  • SetRectEmpty() : gdi.h
  • SetResPath() : window.h
  • SetScrollInfo() : window.h
  • SetScrollPos() : window.h
  • SetScrollRange() : window.h
  • SetSecondaryDC() : gdi.h
  • SetServerEventHook() : window.h
  • SetTabStop : gdi.h
  • SetTextAboveLineExtra : gdi.h
  • SetTextAlign : gdi.h
  • SetTextBellowLineExtra : gdi.h
  • SetTextCharacterExtra : gdi.h
  • SetTextColor : gdi.h
  • SetTimer : window.h
  • SetTimerEx() : window.h
  • SetValueToEtc : minigui.h
  • SetValueToEtcFile() : minigui.h
  • SetValueToEtcSec() : minigui.h
  • SetViewportExt : gdi.h
  • SetViewportOrg : gdi.h
  • SetWindowAdditionalData() : window.h
  • SetWindowAdditionalData2() : window.h
  • SetWindowBkColor() : window.h
  • SetWindowCallbackProc() : window.h
  • SetWindowCaption() : window.h
  • SetWindowClassAdditionalData() : window.h
  • SetWindowClassInfo() : window.h
  • SetWindowCursor() : window.h
  • SetWindowElementAttr() : window.h
  • SetWindowElementRenderer() : window.h
  • SetWindowExt : gdi.h
  • SetWindowFont() : window.h
  • SetWindowIcon() : window.h
  • SetWindowMask() : window.h
  • SetWindowMaskEx() : window.h
  • SetWindowOrg : gdi.h
  • SetWindowRegion() : window.h
  • SetWindowText() : window.h
  • SHAPETYPE : gdi.h
  • ShowCaret() : window.h
  • ShowCaretEx() : window.h
  • ShowCursor() : minigui.h
  • ShowScrollBar() : window.h
  • ShowWindow() : window.h
  • Sint16 : common.h
  • Sint32 : common.h
  • Sint64 : common.h
  • Sint8 : common.h
  • SplineTo() : gdi.h
  • SPM_DISABLEDOWN : spinbox.h
  • SPM_DISABLEUP : spinbox.h
  • SPM_ENABLEDOWN : spinbox.h
  • SPM_ENABLEUP : spinbox.h
  • SPM_GETCUR : spinbox.h
  • SPM_GETINFO : spinbox.h
  • SPM_GETTARGET : spinbox.h
  • SPM_SETCUR : spinbox.h
  • SPM_SETINFO : spinbox.h
  • SPM_SETTARGET : spinbox.h
  • SPN_REACHMAX : spinbox.h
  • SPN_REACHMIN : spinbox.h
  • SPS_AUTOSCROLL : spinbox.h
  • SPS_HORIZONTAL : spinbox.h
  • SPS_TYPE_DOWNARROW : spinbox.h
  • SPS_TYPE_MASK : spinbox.h
  • SPS_TYPE_NORMAL : spinbox.h
  • SPS_TYPE_UPARROW : spinbox.h
  • SPtoLP() : gdi.h
  • SRVEVTHOOK : window.h
  • SS_ALIGNMASK : static.h
  • SS_BITMAP : static.h
  • SS_BLACKFRAME : static.h
  • SS_BLACKRECT : static.h
  • SS_CENTER : static.h
  • SS_CENTERIMAGE : static.h
  • SS_GRAYFRAME : static.h
  • SS_GRAYRECT : static.h
  • SS_GROUPBOX : static.h
  • SS_ICON : static.h
  • SS_LEFT : static.h
  • SS_LEFTNOWORDWRAP : static.h
  • SS_NOPREFIX : static.h
  • SS_NOTIFY : static.h
  • SS_NOWORDWRAP : static.h
  • SS_REALSIZEIMAGE : static.h
  • SS_RIGHT : static.h
  • SS_SIMPLE : static.h
  • SS_TYPEMASK : static.h
  • SS_WHITEFRAME : static.h
  • SS_WHITERECT : static.h
  • STM_GETIMAGE : static.h
  • STM_SETIMAGE : static.h
  • STN_CLICKED : static.h
  • STN_DBLCLK : static.h
  • Str2Key() : window.h
  • STRCMP : ctrlhelper.h
  • StretchBlt() : gdi.h
  • StretchPaintImageEx() : gdi.h
  • StretchPaintImageFromFile() : gdi.h
  • StretchPaintImageFromMem() : gdi.h
  • StripPopupHead() : window.h
  • strnchr() : minigui.h
  • strtrimall() : minigui.h
  • substrlen() : minigui.h
  • SubtractClipRect() : gdi.h
  • SubtractRect() : gdi.h
  • SubtractRegion() : gdi.h
  • SVITEM_CMP : scrollview.h
  • SVITEM_DESTROYFUNC : scrollview.h
  • SVITEM_DRAWFUNC : scrollview.h
  • SVITEM_INITFUNC : scrollview.h
  • SVM_ADDCTRLS : scrollview.h
  • SVM_ADDITEM : scrollview.h
  • SVM_CHOOSEITEM : scrollview.h
  • SVM_DELITEM : scrollview.h
  • SVM_GETBOTTOMMARGIN : scrollview.h
  • SVM_GETCONTENTX : scrollview.h
  • SVM_GETCONTENTY : scrollview.h
  • SVM_GETCONTHEIGHT : scrollview.h
  • SVM_GETCONTWIDTH : scrollview.h
  • SVM_GETCTRL : scrollview.h
  • SVM_GETCURSEL : scrollview.h
  • SVM_GETFIRSTVISIBLEITEM : scrollview.h
  • SVM_GETFOCUSCHILD : scrollview.h
  • SVM_GETHSCROLLPAGEVAL : scrollview.h
  • SVM_GETHSCROLLVAL : scrollview.h
  • SVM_GETITEMADDDATA : scrollview.h
  • SVM_GETITEMCOUNT : scrollview.h
  • SVM_GETLEFTMARGIN : scrollview.h
  • SVM_GETMARGINS : scrollview.h
  • SVM_GETRIGHTMARGIN : scrollview.h
  • SVM_GETTOPMARGIN : scrollview.h
  • SVM_GETVISIBLEHEIGHT : scrollview.h
  • SVM_GETVISIBLEWIDTH : scrollview.h
  • SVM_GETVSCROLLPAGEVAL : scrollview.h
  • SVM_GETVSCROLLVAL : scrollview.h
  • SVM_MAKEPOSVISIBLE : scrollview.h
  • SVM_REFRESHITEM : scrollview.h
  • SVM_RESETCONTENT : scrollview.h
  • SVM_SELECTITEM : scrollview.h
  • SVM_SETCONTAINERPROC : scrollview.h
  • SVM_SETCONTHEIGHT : scrollview.h
  • SVM_SETCONTPOS : scrollview.h
  • SVM_SETCONTRANGE : scrollview.h
  • SVM_SETCONTWIDTH : scrollview.h
  • SVM_SETCURSEL : scrollview.h
  • SVM_SETITEMADDDATA : scrollview.h
  • SVM_SETITEMCMP : scrollview.h
  • SVM_SETITEMDESTROY : scrollview.h
  • SVM_SETITEMDRAW : scrollview.h
  • SVM_SETITEMHEIGHT : scrollview.h
  • SVM_SETITEMINIT : scrollview.h
  • SVM_SETITEMOPS : scrollview.h
  • SVM_SETMARGINS : scrollview.h
  • SVM_SETSCROLLPAGEVAL : scrollview.h
  • SVM_SETSCROLLVAL : scrollview.h
  • SVM_SHOWITEM : scrollview.h
  • SVM_SORTITEMS : scrollview.h
  • SVN_CLICKED : scrollview.h
  • SVN_SELCHANGED : scrollview.h
  • SVN_SELCHANGING : scrollview.h
  • SVS_AUTOSORT : scrollview.h
  • SVS_LOOP : scrollview.h
  • SVS_NOTIFY : scrollview.h
  • SVS_UPNOTIFY : scrollview.h
  • SWORD : common.h
  • SysColorIndex : gdi.h
  • SYSLOGFONT_CAPTION : gdi.h
  • SYSLOGFONT_CONTROL : gdi.h
  • SYSLOGFONT_DEFAULT : gdi.h
  • SYSLOGFONT_FIXED : gdi.h
  • SYSLOGFONT_MENU : gdi.h
  • SYSLOGFONT_WCHAR_DEF : gdi.h
  • SysPixelColor : gdi.h
  • SysPixelIndex : gdi.h
  • SysText : minigui.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- t -

  • TabbedTextOut : gdi.h
  • TabbedTextOutEx() : gdi.h
  • TabbedTextOutLen() : gdi.h
  • TABLESIZE : common.h
  • TBLEN_TIP : trackbar.h
  • TBM_GETLINESIZE : trackbar.h
  • TBM_GETMAX : trackbar.h
  • TBM_GETMIN : trackbar.h
  • TBM_GETPAGESIZE : trackbar.h
  • TBM_GETPOS : trackbar.h
  • TBM_GETTICKFREQ : trackbar.h
  • TBM_GETTIP : trackbar.h
  • TBM_SETLINESIZE : trackbar.h
  • TBM_SETMAX : trackbar.h
  • TBM_SETMIN : trackbar.h
  • TBM_SETPAGESIZE : trackbar.h
  • TBM_SETPOS : trackbar.h
  • TBM_SETRANGE : trackbar.h
  • TBM_SETTICKFREQ : trackbar.h
  • TBM_SETTIP : trackbar.h
  • TBN_CHANGE : trackbar.h
  • TBN_REACHMAX : trackbar.h
  • TBN_REACHMIN : trackbar.h
  • TBN_STARTDRAG : trackbar.h
  • TBN_STOPDRAG : trackbar.h
  • TBS_BORDER : trackbar.h
  • TBS_NOTICK : trackbar.h
  • TBS_NOTIFY : trackbar.h
  • TBS_TIP : trackbar.h
  • TBS_VERTICAL : trackbar.h
  • TerminateGUI() : minigui.h
  • TerminateSlaveScreen() : gdi.h
  • TermRendererSystemIcon() : window.h
  • TermSystemBitmap() : window.h
  • TermSystemBitmapEx() : window.h
  • TermVectorialFonts() : gdi.h
  • TextOut : gdi.h
  • TextOutLen() : gdi.h
  • TextOutOmitted() : gdi.h
  • ThrowAwayMessages() : window.h
  • TIMERPROC : window.h
  • Tone() : minigui.h
  • TrackMenuBar() : window.h
  • TrackPopupMenu() : window.h
  • TranslateAccelerator() : window.h
  • TranslateKeyMsgToChar() : window.h
  • TranslateMessage() : window.h
  • TRUE : common.h
  • TVM_ADDITEM : treeview.h
  • TVM_DELTREE : treeview.h
  • TVM_FINDCHILD : treeview.h
  • TVM_GETITEMINFO : treeview.h
  • TVM_GETITEMTEXT : treeview.h
  • TVM_GETITEMTEXTLEN : treeview.h
  • TVM_GETRELATEDITEM : treeview.h
  • TVM_GETROOT : treeview.h
  • TVM_GETSELITEM : treeview.h
  • TVM_INSERTITEM : treeview.h
  • TVM_SEARCHITEM : treeview.h
  • TVM_SETITEMINFO : treeview.h
  • TVM_SETSELITEM : treeview.h
  • TVM_SETSTRCMPFUNC : treeview.h
  • TVN_CLICKED : treeview.h
  • TVN_DBLCLK : treeview.h
  • TVN_ENTER : treeview.h
  • TVN_ERRSPACE : treeview.h
  • TVN_FOLDED : treeview.h
  • TVN_KILLFOCUS : treeview.h
  • TVN_SELCHANGE : treeview.h
  • TVN_SETFOCUS : treeview.h
  • TVN_UNFOLDED : treeview.h
  • TVS_ICONFORSELECT : treeview.h
  • TVS_NOTIFY : treeview.h
  • TVS_SORT : treeview.h
  • TVS_WITHICON : treeview.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- u -

  • UINT : common.h
  • Uint16 : common.h
  • Uint32 : common.h
  • Uint64 : common.h
  • Uint8 : common.h
  • UnionRect() : gdi.h
  • UnionRectWithRegion : gdi.h
  • UnionRegion() : gdi.h
  • UnloadBitmap() : gdi.h
  • UnloadEtcFile() : minigui.h
  • UnloadMyBitmap() : gdi.h
  • UnlockDC() : gdi.h
  • UnregisterIMEWindow() : window.h
  • UnregisterListenFD() : minigui.h
  • UnregisterRes() : window.h
  • UnregisterResType() : window.h
  • UnregisterSystemBitmap() : window.h
  • UnregisterWindowClass() : window.h
  • UpdateWindow() : window.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- v -

  • VFlipBitmap() : gdi.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- w -

  • WaitMessage() : window.h
  • WC2MB : gdi.h
  • WC2MBEx() : gdi.h
  • WCS2MBS : gdi.h
  • WCS2MBSEx() : gdi.h
  • WE_ATTR_TYPE_RDR : window.h
  • WE_COLORS_NUMBER : window.h
  • WE_FONTS_NUMBER : window.h
  • WE_METRICS_NUMBER : window.h
  • WindowFromDC() : gdi.h
  • WindowToClient() : window.h
  • WindowToScreen() : window.h
  • WNDPROC : window.h
  • WORD : common.h
  • WORDINFO : gdi.h
  • WPARAM : common.h
  • WS_BORDER : window.h
  • WS_CAPTION : window.h
  • WS_CHILD : window.h
  • WS_DISABLED : window.h
  • WS_DLGFRAME : window.h
  • WS_EX_AUTOSECONDARYDC : window.h
  • WS_EX_BROUNDCNS : window.h
  • WS_EX_CLIPCHILDREN : window.h
  • WS_EX_CONTROL_MASK : window.h
  • WS_EX_DLGHIDE : window.h
  • WS_EX_INTERNAL_MASK : window.h
  • WS_EX_LEFTSCROLLBAR : window.h
  • WS_EX_LFRDR_CUSTOM1 : window.h
  • WS_EX_LFRDR_CUSTOM2 : window.h
  • WS_EX_LFRDR_CUSTOM3 : window.h
  • WS_EX_LFRDR_CUSTOM4 : window.h
  • WS_EX_LFRDR_MASK : window.h
  • WS_EX_NOCLOSEBOX : window.h
  • WS_EX_NONE : window.h
  • WS_EX_NOPARENTNOTIFY : window.h
  • WS_EX_NOTDRAGGABLE : window.h
  • WS_EX_RIGHTSCROLLBAR : window.h
  • WS_EX_TOOLWINDOW : window.h
  • WS_EX_TOPMOST : window.h
  • WS_EX_TRANSPARENT : window.h
  • WS_EX_TROUNDCNS : window.h
  • WS_EX_USEPARENTCURSOR : window.h
  • WS_EX_USEPARENTFONT : window.h
  • WS_EX_USEPARENTRDR : window.h
  • WS_EX_USEPRIVATECDC : window.h
  • WS_GROUP : window.h
  • WS_HSCROLL : window.h
  • WS_NONE : window.h
  • WS_SYSMENU : window.h
  • WS_TABSTOP : window.h
  • WS_THICKFRAME : window.h
  • WS_THINFRAME : window.h
  • WS_VISIBLE : window.h
  • WS_VSCROLL : window.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

Here is a list of all documented functions, variables, defines, enums, and typedefs with links to the documentation:

- x -

  • XorRegion() : gdi.h
  • xVFBAllocVirtualFrameBuffer() : xvfb.h
  • xVFBDestroyEventBuffer() : xvfb.h
  • xVFBFreeVirtualFrameBuffer() : xvfb.h
  • xVFBNotifyNewEvent() : xvfb.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • w

- _ -

  • _MINIGUI_VERSION_CODE : common.h
  • _VERSION_CODE : common.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • w

- k -

  • KS_ALT : common.h
  • KS_CAPSLOCK : common.h
  • KS_CAPTURED : common.h
  • KS_CTRL : common.h
  • KS_IMEPOST : common.h
  • KS_LEFTALT : common.h
  • KS_LEFTBUTTON : common.h
  • KS_LEFTCTRL : common.h
  • KS_LEFTSHIFT : common.h
  • KS_MIDDLBUTTON : common.h
  • KS_NUMLOCK : common.h
  • KS_REPEATED : common.h
  • KS_RIGHTALT : common.h
  • KS_RIGHTBUTTON : common.h
  • KS_RIGHTCTRL : common.h
  • KS_RIGHTSHIFT : common.h
  • KS_SCROLLLOCK : common.h
  • KS_SHIFT : common.h
  • KS_SPINPOST : spinbox.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • w

- l -

  • LB_ADDFILE : listbox.h
  • LB_ADDSTRING : listbox.h
  • LB_DELETESTRING : listbox.h
  • LB_DIR : listbox.h
  • LB_ERR : listbox.h
  • LB_ERRSPACE : listbox.h
  • LB_FINDSTRING : listbox.h
  • LB_FINDSTRINGEXACT : listbox.h
  • LB_GETCARETINDEX : listbox.h
  • LB_GETCHECKMARK : listbox.h
  • LB_GETCOUNT : listbox.h
  • LB_GETCURSEL : listbox.h
  • LB_GETHORIZONTALEXTENT : listbox.h
  • LB_GETITEMADDDATA : listbox.h
  • LB_GETITEMDATA : listbox.h
  • LB_GETITEMDISABLE : listbox.h
  • LB_GETITEMHEIGHT : listbox.h
  • LB_GETITEMRECT : listbox.h
  • LB_GETLOCALE : listbox.h
  • LB_GETSEL : listbox.h
  • LB_GETSELCOUNT : listbox.h
  • LB_GETSELITEMS : listbox.h
  • LB_GETTEXT : listbox.h
  • LB_GETTEXTLEN : listbox.h
  • LB_GETTOPINDEX : listbox.h
  • LB_INITSTORAGE : listbox.h
  • LB_INSERTSTRING : listbox.h
  • LB_ITEMFROMPOINT : listbox.h
  • LB_MULTIADDITEM : listbox.h
  • LB_OKAY : listbox.h
  • LB_RESETCONTENT : listbox.h
  • LB_SELECTSTRING : listbox.h
  • LB_SELITEMRANGEEX : listbox.h
  • LB_SETCARETINDEX : listbox.h
  • LB_SETCHECKMARK : listbox.h
  • LB_SETCOLUMNWIDTH : listbox.h
  • LB_SETCOUNT : listbox.h
  • LB_SETCURSEL : listbox.h
  • LB_SETHORIZONTALEXTENT : listbox.h
  • LB_SETITEMADDDATA : listbox.h
  • LB_SETITEMBOLD : listbox.h
  • LB_SETITEMDATA : listbox.h
  • LB_SETITEMDISABLE : listbox.h
  • LB_SETITEMHEIGHT : listbox.h
  • LB_SETLOCALE : listbox.h
  • LB_SETSEL : listbox.h
  • LB_SETSTRCMPFUNC : listbox.h
  • LB_SETTEXT : listbox.h
  • LB_SETTOPINDEX : listbox.h
  • LBIS_SIGNIFICANT : listbox.h
  • LBN_CLICKCHECKMARK : listbox.h
  • LBN_CLICKED : listbox.h
  • LBN_DBLCLK : listbox.h
  • LBN_ENTER : listbox.h
  • LBN_ERRSPACE : listbox.h
  • LBN_KILLFOCUS : listbox.h
  • LBN_SELCANCEL : listbox.h
  • LBN_SELCHANGE : listbox.h
  • LBN_SETFOCUS : listbox.h
  • LBS_AUTOCHECK : listbox.h
  • LBS_AUTOCHECKBOX : listbox.h
  • LBS_CHECKBOX : listbox.h
  • LBS_MOUSEFOLLOW : listbox.h
  • LBS_MULTIPLESEL : listbox.h
  • LBS_NOTIFY : listbox.h
  • LBS_SBALWAYS : listbox.h
  • LBS_SORT : listbox.h
  • LBS_USEICON : listbox.h
  • LEN_CLIPBOARD_NAME : minigui.h
  • LEN_RENDERER_NAME : window.h
  • LFRDR_TBS_HILITE : trackbar.h
  • LFRDR_TBS_PRESSED : trackbar.h
  • LoadBitmap : gdi.h
  • LoadMyBitmap : gdi.h
  • LOBYTE : common.h
  • LOSWORD : common.h
  • LOWORD : common.h
  • LV_ERR : listview.h
  • LV_ERRSPACE : listview.h
  • LV_OKAY : listview.h
  • LVCF_CENTERALIGN : listview.h
  • LVCF_LEFTALIGN : listview.h
  • LVCF_RIGHTALIGN : listview.h
  • LVCF_TREEVIEW : listview.h
  • LVFF_ADDDATA : listview.h
  • LVFF_TEXT : listview.h
  • LVFLAG_BITMAP : listview.h
  • LVFLAG_ICON : listview.h
  • LVHF_CENTERALIGN : listview.h
  • LVHF_LEFTALIGN : listview.h
  • LVHF_RIGHTALIGN : listview.h
  • LVIF_FOLD : listview.h
  • LVM_ADDCOLUMN : listview.h
  • LVM_ADDITEM : listview.h
  • LVM_CHOOSEITEM : listview.h
  • LVM_CLEARSUBITEM : listview.h
  • LVM_COLSORT : listview.h
  • LVM_DELALLITEM : listview.h
  • LVM_DELCOLUMN : listview.h
  • LVM_DELITEM : listview.h
  • LVM_FILLSUBITEM : listview.h
  • LVM_FINDITEM : listview.h
  • LVM_FOLDITEM : listview.h
  • LVM_GETCOLUMN : listview.h
  • LVM_GETCOLUMNCOUNT : listview.h
  • LVM_GETCOLUMNWIDTH : listview.h
  • LVM_GETITEM : listview.h
  • LVM_GETITEMADDDATA : listview.h
  • LVM_GETITEMCOUNT : listview.h
  • LVM_GETITEMSTATE : listview.h
  • LVM_GETRELATEDITEM : listview.h
  • LVM_GETSELECTEDCOLUMN : listview.h
  • LVM_GETSELECTEDCOUNT : listview.h
  • LVM_GETSELECTEDITEM : listview.h
  • LVM_GETSELECTEDITEMRECT : listview.h
  • LVM_GETSUBITEMLEN : listview.h
  • LVM_GETSUBITEMTEXT : listview.h
  • LVM_GETTOPVISIBLE : listview.h
  • LVM_MODIFYHEAD : listview.h
  • LVM_NULL : listview.h
  • LVM_SELECTITEM : listview.h
  • LVM_SETCOLUMN : listview.h
  • LVM_SETCUSTOMDRAW : listview.h
  • LVM_SETHEADHEIGHT : listview.h
  • LVM_SETITEMADDDATA : listview.h
  • LVM_SETITEMHEIGHT : listview.h
  • LVM_SETITEMSTATE : listview.h
  • LVM_SETSTRCMPFUNC : listview.h
  • LVM_SETSUBITEM : listview.h
  • LVM_SETSUBITEMCOLOR : listview.h
  • LVM_SETSUBITEMTEXT : listview.h
  • LVM_SHOWITEM : listview.h
  • LVM_SORTITEMS : listview.h
  • LVN_CLICKED : listview.h
  • LVN_COLCHANGE : listview.h
  • LVN_FOLDED : listview.h
  • LVN_HEADRDOWN : listview.h
  • LVN_HEADRUP : listview.h
  • LVN_ITEMCLK : listview.h
  • LVN_ITEMDBCLK : listview.h
  • LVN_ITEMRDOWN : listview.h
  • LVN_ITEMRUP : listview.h
  • LVN_KEYDOWN : listview.h
  • LVN_SELCHANGE : listview.h
  • LVN_UNFOLDED : listview.h
  • LVS_AUTOCHECK : listview.h
  • LVS_AUTOCHECKBOX : listview.h
  • LVS_CHECKBOX : listview.h
  • LVS_MULTIPLESEL : listview.h
  • LVS_SORT : listview.h
  • LVS_TREEVIEW : listview.h
  • LVS_UPNOTIFY : listview.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • w

- m -

  • MainWindowCleanup : window.h
  • MAKELONG : common.h
  • MakeRGB : common.h
  • MakeRGBA : common.h
  • MAKEWORD : common.h
  • MASK_KS_BUTTONS : common.h
  • MASK_KS_SHIFTKEYS : common.h
  • MAX : common.h
  • MAX_NAME : common.h
  • MAX_NR_LISTEN_FD : minigui.h
  • MAX_PATH : common.h
  • MB2WC : gdi.h
  • MB_ERR : menubutton.h
  • MB_ERR_SPACE : menubutton.h
  • MB_INV_ITEM : menubutton.h
  • MB_OKAY : menubutton.h
  • MB_WHICH_ATTDATA : menubutton.h
  • MB_WHICH_BMP : menubutton.h
  • MB_WHICH_TEXT : menubutton.h
  • MBM_ADDITEM : menubutton.h
  • MBM_DELITEM : menubutton.h
  • MBM_GETCURITEM : menubutton.h
  • MBM_GETITEMDATA : menubutton.h
  • MBM_RESETCTRL : menubutton.h
  • MBM_SETCURITEM : menubutton.h
  • MBM_SETITEMDATA : menubutton.h
  • MBM_SETSTRCMPFUNC : menubutton.h
  • MBN_CHANGED : menubutton.h
  • MBN_CLICKED : menubutton.h
  • MBN_ENDMENU : menubutton.h
  • MBN_ERRSPACE : menubutton.h
  • MBN_SELECTED : menubutton.h
  • MBN_STARTMENU : menubutton.h
  • MBS2WCS : gdi.h
  • MBS_ALIGNCENTER : menubutton.h
  • MBS_ALIGNLEFT : menubutton.h
  • MBS_ALIGNMASK : menubutton.h
  • MBS_ALIGNRIGHT : menubutton.h
  • MBS_LEFTARROW : menubutton.h
  • MBS_NOBUTTON : menubutton.h
  • MBS_SORT : menubutton.h
  • MCM_CLEARDAYCOLOR : monthcal.h
  • MCM_GETCOLOR : monthcal.h
  • MCM_GETCURDATE : monthcal.h
  • MCM_GETCURDAY : monthcal.h
  • MCM_GETCURMONLEN : monthcal.h
  • MCM_GETCURMONTH : monthcal.h
  • MCM_GETCURWEEKDAY : monthcal.h
  • MCM_GETCURYEAR : monthcal.h
  • MCM_GETFIRSTWEEKDAY : monthcal.h
  • MCM_GETMINREQRECTH : monthcal.h
  • MCM_GETMINREQRECTW : monthcal.h
  • MCM_GETTODAY : monthcal.h
  • MCM_SETCOLOR : monthcal.h
  • MCM_SETCURDATE : monthcal.h
  • MCM_SETCURDAY : monthcal.h
  • MCM_SETCURMONTH : monthcal.h
  • MCM_SETCURYEAR : monthcal.h
  • MCM_SETDAYCOLOR : monthcal.h
  • MCM_SETTODAY : monthcal.h
  • MCN_DATECHANGE : monthcal.h
  • MCS_CHN : monthcal.h
  • MCS_ENG_L : monthcal.h
  • MCS_ENG_S : monthcal.h
  • MCS_NOTIFY : monthcal.h
  • MCS_NOYEARMON : monthcal.h
  • MGUI_BIG_ENDIAN : common.h
  • MGUI_BYTEORDER : common.h
  • MGUI_LIL_ENDIAN : common.h
  • MGUI_NR_KEYS : common.h
  • MGUI_RWclose : endianrw.h
  • MGUI_RWeof : endianrw.h
  • MGUI_RWread : endianrw.h
  • MGUI_RWseek : endianrw.h
  • MGUI_RWtell : endianrw.h
  • MGUI_RWwrite : endianrw.h
  • MIN : common.h
  • MiniGUIMain : minigui.h
  • MLS_BLENDMODE_NONE : gdi.h
  • MSG_ACTIVE : window.h
  • MSG_ACTIVEMENU : window.h
  • MSG_CHANGESIZE : window.h
  • MSG_CHAR : window.h
  • MSG_CHILDHIDDEN : window.h
  • MSG_CLOSE : window.h
  • MSG_COMMAND : window.h
  • MSG_CREATE : window.h
  • MSG_CSIZECHANGED : window.h
  • MSG_DEACTIVEMENU : window.h
  • MSG_DESTROY : window.h
  • MSG_DLG_GETDEFID : window.h
  • MSG_DLG_SETDEFID : window.h
  • MSG_DOESNEEDIME : window.h
  • MSG_DT_KEYDOWN : window.h
  • MSG_DT_KEYUP : window.h
  • MSG_DT_LBUTTONDBLCLK : window.h
  • MSG_DT_LBUTTONDOWN : window.h
  • MSG_DT_LBUTTONUP : window.h
  • MSG_DT_MOUSEMOVE : window.h
  • MSG_DT_RBUTTONDBLCLK : window.h
  • MSG_DT_RBUTTONDOWN : window.h
  • MSG_DT_RBUTTONUP : window.h
  • MSG_ENABLE : window.h
  • MSG_ERASEBKGND : window.h
  • MSG_FDEVENT : window.h
  • MSG_FONTCHANGED : window.h
  • MSG_FONTCHANGING : window.h
  • MSG_FREEZECTRL : window.h
  • MSG_GETDLGCODE : window.h
  • MSG_GETTEXT : window.h
  • MSG_GETTEXTLENGTH : window.h
  • MSG_HITTEST : window.h
  • MSG_HSCROLL : window.h
  • MSG_IDLE : window.h
  • MSG_INITCONTAINER : window.h
  • MSG_INITDIALOG : window.h
  • MSG_INITPAGE : window.h
  • MSG_ISDIALOG : window.h
  • MSG_KEYALWAYSPRESS : window.h
  • MSG_KEYDOWN : window.h
  • MSG_KEYLONGPRESS : window.h
  • MSG_KEYSYM : window.h
  • MSG_KEYUP : window.h
  • MSG_KILLFOCUS : window.h
  • MSG_LBUTTONDBLCLK : window.h
  • MSG_LBUTTONDOWN : window.h
  • MSG_LBUTTONUP : window.h
  • MSG_MOUSEACTIVE : window.h
  • MSG_MOUSEMOVE : window.h
  • MSG_MOUSEMOVEIN : window.h
  • MSG_NCACTIVATE : window.h
  • MSG_NCCREATE : window.h
  • MSG_NCHITTEST : window.h
  • MSG_NCLBUTTONDBLCLK : window.h
  • MSG_NCLBUTTONDOWN : window.h
  • MSG_NCLBUTTONUP : window.h
  • MSG_NCMOUSEMOVE : window.h
  • MSG_NCPAINT : window.h
  • MSG_NCRBUTTONDBLCLK : window.h
  • MSG_NCRBUTTONDOWN : window.h
  • MSG_NCRBUTTONUP : window.h
  • MSG_NCSETCURSOR : window.h
  • MSG_PAINT : window.h
  • MSG_QUERYCLIENTAREA : window.h
  • MSG_RBUTTONDBLCLK : window.h
  • MSG_RBUTTONDOWN : window.h
  • MSG_RBUTTONUP : window.h
  • MSG_SETCURSOR : window.h
  • MSG_SETFOCUS : window.h
  • MSG_SETTEXT : window.h
  • MSG_SHEETCMD : window.h
  • MSG_SHOWPAGE : window.h
  • MSG_SHOWWINDOW : window.h
  • MSG_SIZECHANGED : window.h
  • MSG_SIZECHANGING : window.h
  • MSG_SRVNOTIFY : window.h
  • MSG_SVCONTCMD : window.h
  • MSG_SYNCPAINT : window.h
  • MSG_SYSCHAR : window.h
  • MSG_SYSCOMMAND : window.h
  • MSG_SYSKEYDOWN : window.h
  • MSG_SYSKEYUP : window.h
  • MSG_TIMER : window.h
  • MSG_USER : window.h
  • MSG_VSCROLL : window.h
  • MSG_WINDOWDROPPED : window.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • w

- n -

  • NotifyParent : ctrlhelper.h
  • NR_CLIPBOARDS : minigui.h
  • NR_KEYS : common.h
  • NTB_ERR : newtoolbar.h
  • NTB_ERR_DUPID : newtoolbar.h
  • NTB_ERR_SPACE : newtoolbar.h
  • NTB_OKAY : newtoolbar.h
  • NTBIF_CHECKED : newtoolbar.h
  • NTBIF_DISABLED : newtoolbar.h
  • NTBM_ADDITEM : newtoolbar.h
  • NTBM_ENABLEITEM : newtoolbar.h
  • NTBM_GETITEM : newtoolbar.h
  • NTBM_SETBITMAP : newtoolbar.h
  • NTBM_SETITEM : newtoolbar.h
  • NTBS_DRAWSEPARATOR : newtoolbar.h
  • NTBS_DRAWSTATES : newtoolbar.h
  • NTBS_HORIZONTAL : newtoolbar.h
  • NTBS_MULTLINE : newtoolbar.h
  • NTBS_TEXTRIGHT : newtoolbar.h
  • NTBS_VERTICAL : newtoolbar.h
  • NTBS_WITHTEXT : newtoolbar.h
  • NULL : common.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • w

- a -

  • ABS : common.h
  • ANIMATION_ERR : animation.h
  • ANIMATION_OKAY : animation.h
  • ANM_GETANIMATION : animation.h
  • ANM_PAUSE_RESUME : animation.h
  • ANM_SETANIMATION : animation.h
  • ANM_STARTPLAY : animation.h
  • ANM_STOPPLAY : animation.h
  • ANNC_CLICKED : animation.h
  • ANNC_DBLCLK : animation.h
  • ANS_AUTOLOOP : animation.h
  • ANS_FITTOANI : animation.h
  • ANS_SCALED : animation.h
  • ArchSwapBE16 : endianrw.h
  • ArchSwapBE32 : endianrw.h
  • ArchSwapBE64 : endianrw.h
  • ArchSwapLE16 : endianrw.h
  • ArchSwapLE32 : endianrw.h
  • ArchSwapLE64 : endianrw.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • w

- b -

  • Beep : minigui.h
  • BM_CLICK : button.h
  • BM_ENABLE : button.h
  • BM_GETCHECK : button.h
  • BM_GETIMAGE : button.h
  • BM_GETSTATE : button.h
  • BM_SETCHECK : button.h
  • BM_SETIMAGE : button.h
  • BM_SETSTATE : button.h
  • BM_SETSTYLE : button.h
  • BN_CLICKED : button.h
  • BN_DBLCLK : button.h
  • BN_DISABLE : button.h
  • BN_ENABLE : button.h
  • BN_HILITE : button.h
  • BN_KILLFOCUS : button.h
  • BN_PUSHED : button.h
  • BN_SETFOCUS : button.h
  • BN_UNHILITE : button.h
  • BN_UNPUSHED : button.h
  • BS_3STATE : button.h
  • BS_ALIGNMASK : button.h
  • BS_AUTO3STATE : button.h
  • BS_AUTOCHECKBOX : button.h
  • BS_AUTORADIOBUTTON : button.h
  • BS_BITMAP : button.h
  • BS_BOTTOM : button.h
  • BS_CENTER : button.h
  • BS_CHECKBOX : button.h
  • BS_CHECKED : button.h
  • BS_CONTENTMASK : button.h
  • BS_DEFPUSHBUTTON : button.h
  • BS_FLAT : button.h
  • BS_ICON : button.h
  • BS_LEFT : button.h
  • BS_LEFTTEXT : button.h
  • BS_MULTLINE : button.h
  • BS_NOBORDER : button.h
  • BS_NOTIFY : button.h
  • BS_OWNERDRAW : button.h
  • BS_PUSHBUTTON : button.h
  • BS_PUSHLIKE : button.h
  • BS_RADIOBUTTON : button.h
  • BS_REALSIZEIMAGE : button.h
  • BS_RIGHT : button.h
  • BS_RIGHTBUTTON : button.h
  • BS_TEXT : button.h
  • BS_TOP : button.h
  • BS_TYPEMASK : button.h
  • BS_VCENTER : button.h
  • BST_CHECK_MASK : button.h
  • BST_CHECKED : button.h
  • BST_DISABLE : button.h
  • BST_FOCUS : button.h
  • BST_HILITE : button.h
  • BST_INDETERMINATE : button.h
  • BST_NORMAL : button.h
  • BST_POSE_MASK : button.h
  • BST_PUSHED : button.h
  • BST_UNCHECKED : button.h
  • BTN_WIDTH_BORDER : button.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • w

- c -

  • CB_ADDSTRING : combobox.h
  • CB_DELETESTRING : combobox.h
  • CB_ERR : combobox.h
  • CB_ERRSPACE : combobox.h
  • CB_FASTSPIN : combobox.h
  • CB_FINDSTRING : combobox.h
  • CB_FINDSTRINGEXACT : combobox.h
  • CB_GETCHILDREN : combobox.h
  • CB_GETCOUNT : combobox.h
  • CB_GETCURSEL : combobox.h
  • CB_GETDROPPEDCONTROLRECT : combobox.h
  • CB_GETDROPPEDSTATE : combobox.h
  • CB_GETEDITSEL : combobox.h
  • CB_GETITEMADDDATA : combobox.h
  • CB_GETITEMHEIGHT : combobox.h
  • CB_GETLBTEXT : combobox.h
  • CB_GETLBTEXTLEN : combobox.h
  • CB_GETSPINPACE : combobox.h
  • CB_GETSPINRANGE : combobox.h
  • CB_GETSPINVALUE : combobox.h
  • CB_INSERTSTRING : combobox.h
  • CB_LIMITTEXT : combobox.h
  • CB_OKAY : combobox.h
  • CB_RESETCONTENT : combobox.h
  • CB_SETCURSEL : combobox.h
  • CB_SETEDITSEL : combobox.h
  • CB_SETITEMADDDATA : combobox.h
  • CB_SETITEMHEIGHT : combobox.h
  • CB_SETSPINFORMAT : combobox.h
  • CB_SETSPINPACE : combobox.h
  • CB_SETSPINRANGE : combobox.h
  • CB_SETSPINVALUE : combobox.h
  • CB_SETSTRCMPFUNC : combobox.h
  • CB_SPIN : combobox.h
  • CBERR_BADNAME : minigui.h
  • CBERR_NOMEM : minigui.h
  • CBERR_OK : minigui.h
  • CBM_ADDITEM : coolbar.h
  • CBM_ENABLE : coolbar.h
  • CBN_CLICKED : combobox.h
  • CBN_CLOSEUP : combobox.h
  • CBN_DBLCLK : combobox.h
  • CBN_DROPDOWN : combobox.h
  • CBN_EDITCHANGE : combobox.h
  • CBN_KILLFOCUS : combobox.h
  • CBN_SELCHANGE : combobox.h
  • CBN_SELECTCANCEL : combobox.h
  • CBN_SELECTOK : combobox.h
  • CBN_SETFOCUS : combobox.h
  • CBNAME_TEXT : minigui.h
  • CBOP_APPEND : minigui.h
  • CBOP_NORMAL : minigui.h
  • CBS_AUTOFOCUS : combobox.h
  • CBS_AUTOHSCROLL : combobox.h
  • CBS_AUTOLOOP : combobox.h
  • CBS_AUTOSPIN : combobox.h
  • CBS_BMP_16X16 : coolbar.h
  • CBS_BMP_32X32 : coolbar.h
  • CBS_BMP_CUSTOM : coolbar.h
  • CBS_DISABLENOSCROLL : combobox.h
  • CBS_DROPDOWNLIST : combobox.h
  • CBS_EDITBASELINE : combobox.h
  • CBS_EDITNOBORDER : combobox.h
  • CBS_LOWERCASE : combobox.h
  • CBS_NOTIFY : combobox.h
  • CBS_READONLY : combobox.h
  • CBS_SIMPLE : combobox.h
  • CBS_SORT : combobox.h
  • CBS_SPINARROW_LEFTRIGHT : combobox.h
  • CBS_SPINARROW_TOPBOTTOM : combobox.h
  • CBS_SPINLIST : combobox.h
  • CBS_TYPEMASK : combobox.h
  • CBS_UPPERCASE : combobox.h
  • CBS_USEBKBMP : coolbar.h
  • ClipRectAlloc : gdi.h
  • CMFLAG_MASK : listbox.h
  • COLOR_black : gdi.h
  • COLOR_blue : gdi.h
  • COLOR_cyan : gdi.h
  • COLOR_darkblue : gdi.h
  • COLOR_darkcyan : gdi.h
  • COLOR_darkgray : gdi.h
  • COLOR_darkgreen : gdi.h
  • COLOR_darkmagenta : gdi.h
  • COLOR_darkred : gdi.h
  • COLOR_darkyellow : gdi.h
  • COLOR_green : gdi.h
  • COLOR_invalid : gdi.h
  • COLOR_lightgray : gdi.h
  • COLOR_lightwhite : gdi.h
  • COLOR_magenta : gdi.h
  • COLOR_red : gdi.h
  • COLOR_transparent : gdi.h
  • COLOR_yellow : gdi.h
  • CopyRegion : gdi.h
  • CreateCompatibleDC : gdi.h
  • CreateIcon : gdi.h
  • CreateWindow : window.h
  • CTRL_ANIMATION : animation.h
  • CTRL_BIDISLEDIT : edit.h
  • CTRL_BUTTON : button.h
  • CTRL_COMBOBOX : combobox.h
  • CTRL_COOLBAR : coolbar.h
  • CTRL_EDIT : edit.h
  • CTRL_GRIDVIEW : gridview.h
  • CTRL_ICONVIEW : iconview.h
  • CTRL_LISTBOX : listbox.h
  • CTRL_LISTVIEW : listview.h
  • CTRL_MEDIT : edit.h
  • CTRL_MENUBTN : menubutton.h
  • CTRL_MENUBUTTON : menubutton.h
  • CTRL_MLEDIT : edit.h
  • CTRL_MONTHCALENDAR : monthcal.h
  • CTRL_NEWTOOLBAR : newtoolbar.h
  • CTRL_PROGRESSBAR : progressbar.h
  • CTRL_PROPSHEET : propsheet.h
  • CTRL_SCROLLBAR : scrollbar.h
  • CTRL_SCROLLVIEW : scrollview.h
  • CTRL_SCROLLWND : scrollview.h
  • CTRL_SLEDIT : edit.h
  • CTRL_SPINBOX : spinbox.h
  • CTRL_STATIC : static.h
  • CTRL_TEXTEDIT : textedit.h
  • CTRL_TRACKBAR : trackbar.h
  • CTRL_TREEVIEW : treeview.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • w

- d -

  • DEF_APRESS_TIME : window.h
  • DEF_INTERVAL_TIME : window.h
  • DEF_LPRESS_TIME : window.h
  • DefaultControlProc : window.h
  • DefaultDialogProc : window.h
  • DefaultMainWinProc : window.h
  • DeleteCompatibleDC : gdi.h
  • DestroyFreeClipRectList : gdi.h
  • DLGC_3STATE : window.h
  • DLGC_BUTTON : window.h
  • DLGC_DEFPUSHBUTTON : window.h
  • DLGC_HASSETSEL : window.h
  • DLGC_PUSHBUTTON : window.h
  • DLGC_RADIOBUTTON : window.h
  • DLGC_STATIC : window.h
  • DLGC_WANTALLKEYS : window.h
  • DLGC_WANTARROWS : window.h
  • DLGC_WANTCHARS : window.h
  • DLGC_WANTENTER : window.h
  • DLGC_WANTTAB : window.h
  • DrawHDotLine : gdi.h
  • DrawText : gdi.h
  • DrawTextEx : gdi.h
  • DrawVDotLine : gdi.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • w

- e -

  • EC_LEFTMARGIN : edit.h
  • EC_RIGHTMARGIN : edit.h
  • EC_USEFONTINFO : edit.h
  • ED_CARETSHAPE_BLOCK : edit.h
  • ED_CARETSHAPE_LINE : edit.h
  • EIMES_CANCELCOMPSTRINFOCUS : edit.h
  • EIMES_COMPLETECOMPSTRKILLFOCUS : edit.h
  • EIMES_GETCOMPSTRATONCE : edit.h
  • EM_CHANGECARETSHAPE : edit.h
  • EM_COPYTOCB : edit.h
  • EM_CUTTOCB : edit.h
  • EM_ENABLECARET : edit.h
  • EM_FMTLINES : edit.h
  • EM_GETCARETPOS : edit.h
  • EM_GETCARETPOSBYLINE : edit.h
  • EM_GETLIMITTEXT : edit.h
  • EM_GETLINE : edit.h
  • EM_GETLINECOUNT : edit.h
  • EM_GETLINEHEIGHT : edit.h
  • EM_GETLINELENGTH : edit.h
  • EM_GETLINELENGTHINMCHAR : edit.h
  • EM_GETLINETEXT : edit.h
  • EM_GETMAXLIMIT : edit.h
  • EM_GETNUMOFPARAGRAPHS : edit.h
  • EM_GETPARAGRAPHLENGTH : edit.h
  • EM_GETPARAGRAPHLENGTHINMCHAR : edit.h
  • EM_GETPARAGRAPHTEXT : edit.h
  • EM_GETPASSWORDCHAR : edit.h
  • EM_GETSEL : edit.h
  • EM_GETSELPOS : edit.h
  • EM_GETSELPOSBYLINE : edit.h
  • EM_GETTIPTEXT : edit.h
  • EM_GETTITLETEXT : edit.h
  • EM_INSERTCBTEXT : edit.h
  • EM_INSERTTEXT : edit.h
  • EM_LIMITTEXT : edit.h
  • EM_LINEFROMCHAR : edit.h
  • EM_LINELENGTH : edit.h
  • EM_LINESCROLL : edit.h
  • EM_REDO : edit.h
  • EM_REFRESHCARET : edit.h
  • EM_REPLACESEL : edit.h
  • EM_SELECTALL : edit.h
  • EM_SETCARETPOS : edit.h
  • EM_SETCARETPOSBYLINE : edit.h
  • EM_SETDRAWSELECTFUNC : edit.h
  • EM_SETGETCARETWIDTHFUNC : edit.h
  • EM_SETINSERTION : edit.h
  • EM_SETLFDISPCHAR : edit.h
  • EM_SETLIMITTEXT : edit.h
  • EM_SETLINEHEIGHT : edit.h
  • EM_SETLINESEP : edit.h
  • EM_SETPASSWORDCHAR : edit.h
  • EM_SETREADONLY : edit.h
  • EM_SETSEL : edit.h
  • EM_SETSELECTION : edit.h
  • EM_SETSELPOS : edit.h
  • EM_SETSELPOSBYLINE : edit.h
  • EM_SETTABSTOPS : edit.h
  • EM_SETTIPTEXT : edit.h
  • EM_SETTITLETEXT : edit.h
  • EM_UNDO : edit.h
  • EMSIS_COMPOSITIONSTRING : edit.h
  • EN_CHANGE : edit.h
  • EN_CLICKED : edit.h
  • EN_CONTCHANGED : edit.h
  • EN_DBLCLK : edit.h
  • EN_ENTER : edit.h
  • EN_KILLFOCUS : edit.h
  • EN_MAXTEXT : edit.h
  • EN_SELCHANGED : edit.h
  • EN_SETFOCUS : edit.h
  • EN_UPDATE : edit.h
  • ERR_ALREADY_EXIST : common.h
  • ERR_BAD_OWNER : common.h
  • ERR_CONFIG_FILE : common.h
  • ERR_CTRLCLASS_INUSE : common.h
  • ERR_CTRLCLASS_INVLEN : common.h
  • ERR_CTRLCLASS_INVNAME : common.h
  • ERR_CTRLCLASS_MEM : common.h
  • ERR_FILE_IO : common.h
  • ERR_GFX_ENGINE : common.h
  • ERR_IME_NOIMEWND : common.h
  • ERR_IME_NOSUCHIMEWND : common.h
  • ERR_IME_TOOMUCHIMEWND : common.h
  • ERR_INPUT_ENGINE : common.h
  • ERR_INV_HWND : common.h
  • ERR_INVALID_ARGS : common.h
  • ERR_INVALID_HANDLE : common.h
  • ERR_INVALID_HMENU : common.h
  • ERR_INVALID_ID : common.h
  • ERR_INVALID_POS : common.h
  • ERR_NO_ENGINE : common.h
  • ERR_NO_MATCH : common.h
  • ERR_OK : common.h
  • ERR_QUEUE_FULL : common.h
  • ERR_RES_ALLOCATION : common.h
  • ES_AUTOHSCROLL : edit.h
  • ES_AUTOSELECT : edit.h
  • ES_AUTOVSCROLL : edit.h
  • ES_AUTOWRAP : edit.h
  • ES_BASELINE : edit.h
  • ES_CENTER : edit.h
  • ES_LEFT : edit.h
  • ES_LOWERCASE : edit.h
  • ES_MULTILINE : edit.h
  • ES_NOHIDESEL : edit.h
  • ES_PASSWORD : edit.h
  • ES_READONLY : edit.h
  • ES_RIGHT : edit.h
  • ES_TIP : edit.h
  • ES_TITLE : edit.h
  • ES_UPPERCASE : edit.h
  • ETC_FILEIOFAILED : minigui.h
  • ETC_FILENOTFOUND : minigui.h
  • ETC_INTCONV : minigui.h
  • ETC_INVALIDOBJ : minigui.h
  • ETC_KEYNOTFOUND : minigui.h
  • ETC_MAXLINE : minigui.h
  • ETC_OK : minigui.h
  • ETC_READONLYOBJ : minigui.h
  • ETC_SECTIONNOTFOUND : minigui.h
  • ETC_TMPFILEFAILED : minigui.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • w

- f -

  • FALSE : common.h
  • FONT_CHARSET_EUCTW : gdi.h
  • FONT_CHARSET_GB18030_0 : gdi.h
  • FONT_CHARSET_GB1988_0 : gdi.h
  • FONT_CHARSET_GB2312_0 : gdi.h
  • FONT_CHARSET_ISO_10646_1 : gdi.h
  • FONT_CHARSET_JISX0201_0 : gdi.h
  • FONT_CHARSET_JISX0201_1 : gdi.h
  • FONT_CHARSET_JISX0208_0 : gdi.h
  • FONT_CHARSET_JISX0208_1 : gdi.h
  • FONT_CHARSET_KSC5601_0 : gdi.h
  • FONT_CHARSET_KSC5636_0 : gdi.h
  • FONT_CHARSET_UTF16BE : gdi.h
  • FONT_CHARSET_UTF16LE : gdi.h
  • FONT_CHARSET_UTF8 : gdi.h
  • FreeClipRect : gdi.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • w

- g -

  • g_rcDesktop : minigui.h
  • GetAValue : common.h
  • GetBkColor : gdi.h
  • GetBkMode : gdi.h
  • GetBrushColor : gdi.h
  • GetBrushType : gdi.h
  • GetBValue : common.h
  • GetFocus : window.h
  • GetForegroundWindow : window.h
  • GetGValue : common.h
  • GetLargeSystemIcon : window.h
  • GetMapMode : gdi.h
  • GetPenCapStyle : gdi.h
  • GetPenColor : gdi.h
  • GetPenJoinStyle : gdi.h
  • GetPenType : gdi.h
  • GetPenWidth : gdi.h
  • GetRValue : common.h
  • GetSmallSystemIcon : window.h
  • GetTabStop : gdi.h
  • GetTextAboveLineExtra : gdi.h
  • GetTextAlign : gdi.h
  • GetTextBellowLineExtra : gdi.h
  • GetTextCharacterExtra : gdi.h
  • GetTextColor : gdi.h
  • GetViewportExt : gdi.h
  • GetViewportOrg : gdi.h
  • GetWindowElementColor : window.h
  • GetWindowExt : gdi.h
  • GetWindowOrg : gdi.h
  • GRID_ERR : gridview.h
  • GRID_OKAY : gridview.h
  • GRIDM_ADDCOLUMN : gridview.h
  • GRIDM_ADDDEPENDENCE : gridview.h
  • GRIDM_ADDROW : gridview.h
  • GRIDM_DELCOLUMN : gridview.h
  • GRIDM_DELDEPENDENCE : gridview.h
  • GRIDM_DELROW : gridview.h
  • GRIDM_ENDCELLEDIT : gridview.h
  • GRIDM_GETCELLPROPERTY : gridview.h
  • GRIDM_GETCOLCOUNT : gridview.h
  • GRIDM_GETCOLWIDTH : gridview.h
  • GRIDM_GETROWCOUNT : gridview.h
  • GRIDM_GETROWHEIGHT : gridview.h
  • GRIDM_GETSELECTED : gridview.h
  • GRIDM_SETCELLPROPERTY : gridview.h
  • GRIDM_SETCOLWIDTH : gridview.h
  • GRIDM_SETNUMFORMAT : gridview.h
  • GRIDM_SETROWHEIGHT : gridview.h
  • GRIDM_SETSELECTED : gridview.h
  • GRIDN_CELLCLK : gridview.h
  • GRIDN_CELLDBCLK : gridview.h
  • GRIDN_CELLTEXTCHANGED : gridview.h
  • GRIDN_FOCUSCHANGED : gridview.h
  • GRIDN_HEADLDOWN : gridview.h
  • GRIDN_HEADLUP : gridview.h
  • GRIDN_KEYDOWN : gridview.h
  • GV_HALIGN_CENTER : gridview.h
  • GV_HALIGN_LEFT : gridview.h
  • GV_HALIGN_MASK : gridview.h
  • GV_HALIGN_RIGHT : gridview.h
  • GV_TYPE_CHECKBOX : gridview.h
  • GV_TYPE_HEADER : gridview.h
  • GV_TYPE_MASK : gridview.h
  • GV_TYPE_NUMBER : gridview.h
  • GV_TYPE_SELECTION : gridview.h
  • GV_TYPE_TABLEHEADER : gridview.h
  • GV_TYPE_TEXT : gridview.h
  • GV_TYPE_UNKNOWN : gridview.h
  • GV_VALIGN_BOTTOM : gridview.h
  • GV_VALIGN_CENTER : gridview.h
  • GV_VALIGN_MASK : gridview.h
  • GV_VALIGN_TOP : gridview.h
  • GVS_BOXCHECKED : gridview.h
  • GVS_MULTLINE : gridview.h
  • GVS_READONLY : gridview.h
  • GVS_WITHCHECKBOX : gridview.h
  • GVS_WITHICON : gridview.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • w

- h -

  • HDC_INVALID : gdi.h
  • HDC_SCREEN : gdi.h
  • HIBYTE : common.h
  • HISWORD : common.h
  • HIWORD : common.h
  • HOOK_GOON : window.h
  • HOOK_STOP : window.h
  • HWND_DESKTOP : window.h
  • HWND_INVALID : window.h
  • HWND_NULL : window.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • w

- i -

  • IDC_ARROW : minigui.h
  • IDC_BUSY : minigui.h
  • IDC_COLOMN : minigui.h
  • IDC_CROSS : minigui.h
  • IDC_DRAG : minigui.h
  • IDC_HAND_POINT : minigui.h
  • IDC_HAND_SELECT : minigui.h
  • IDC_HELP : minigui.h
  • IDC_IBEAM : minigui.h
  • IDC_MOVE : minigui.h
  • IDC_NODROP : minigui.h
  • IDC_NONE : minigui.h
  • IDC_PENCIL : minigui.h
  • IDC_RARROW : minigui.h
  • IDC_ROW : minigui.h
  • IDC_SIZENESW : minigui.h
  • IDC_SIZENS : minigui.h
  • IDC_SIZENWSE : minigui.h
  • IDC_SIZEWE : minigui.h
  • IDC_SPLIT_HORZ : minigui.h
  • IDC_SPLIT_VERT : minigui.h
  • IDC_UPARROW : minigui.h
  • IDC_WAIT : minigui.h
  • IDM_DTI_FIRST : minigui.h
  • IDS_MGST_ABORT : minigui.h
  • IDS_MGST_ABOUTMG : minigui.h
  • IDS_MGST_ACCESSMODE : minigui.h
  • IDS_MGST_CANCEL : minigui.h
  • IDS_MGST_CLOSE : minigui.h
  • IDS_MGST_CLOSEALLWIN : minigui.h
  • IDS_MGST_COLORSEL : minigui.h
  • IDS_MGST_CURRPATH : minigui.h
  • IDS_MGST_DELLAYER : minigui.h
  • IDS_MGST_ENDSESSION : minigui.h
  • IDS_MGST_ERROR : minigui.h
  • IDS_MGST_FILE : minigui.h
  • IDS_MGST_FILEEXIST : minigui.h
  • IDS_MGST_FILENAME : minigui.h
  • IDS_MGST_FILETYPE : minigui.h
  • IDS_MGST_IGNORE : minigui.h
  • IDS_MGST_INFO : minigui.h
  • IDS_MGST_LASTMODTIME : minigui.h
  • IDS_MGST_LOCATION : minigui.h
  • IDS_MGST_LOGO : minigui.h
  • IDS_MGST_MAXIMIZE : minigui.h
  • IDS_MGST_MINIMIZE : minigui.h
  • IDS_MGST_NAME : minigui.h
  • IDS_MGST_NEXT : minigui.h
  • IDS_MGST_NO : minigui.h
  • IDS_MGST_NOTFOUND : minigui.h
  • IDS_MGST_NR : minigui.h
  • IDS_MGST_NW : minigui.h
  • IDS_MGST_OK : minigui.h
  • IDS_MGST_OPEN : minigui.h
  • IDS_MGST_OPENFILE : minigui.h
  • IDS_MGST_OPERATIONS : minigui.h
  • IDS_MGST_PREV : minigui.h
  • IDS_MGST_R : minigui.h
  • IDS_MGST_REFRESH : minigui.h
  • IDS_MGST_RESTORE : minigui.h
  • IDS_MGST_RETRY : minigui.h
  • IDS_MGST_SAVE : minigui.h
  • IDS_MGST_SAVEFILE : minigui.h
  • IDS_MGST_SHOWHIDEFILE : minigui.h
  • IDS_MGST_SIZE : minigui.h
  • IDS_MGST_START : minigui.h
  • IDS_MGST_SWITCHLAYER : minigui.h
  • IDS_MGST_UP : minigui.h
  • IDS_MGST_W : minigui.h
  • IDS_MGST_WINDOW : minigui.h
  • IDS_MGST_WR : minigui.h
  • IDS_MGST_YES : minigui.h
  • IMGFLAG_BITMAP : listbox.h
  • InitFreeClipRectList : gdi.h
  • IntersectRegion : gdi.h
  • INV_LOGFONT : gdi.h
  • IS_MBC_GLYPH : gdi.h
  • IV_ERR : iconview.h
  • IV_ERRSPACE : iconview.h
  • IV_OKAY : iconview.h
  • IVFLAG_BITMAP : iconview.h
  • IVFLAG_ICON : iconview.h
  • IVM_ADDITEM : iconview.h
  • IVM_CHOOSEITEM : iconview.h
  • IVM_DELITEM : iconview.h
  • IVM_GETBOTTOMMARGIN : iconview.h
  • IVM_GETCONTENTX : iconview.h
  • IVM_GETCONTENTY : iconview.h
  • IVM_GETCONTHEIGHT : iconview.h
  • IVM_GETCONTWIDTH : iconview.h
  • IVM_GETCURSEL : iconview.h
  • IVM_GETFIRSTVISIBLEITEM : iconview.h
  • IVM_GETHSCROLLPAGEVAL : iconview.h
  • IVM_GETHSCROLLVAL : iconview.h
  • IVM_GETITEMADDDATA : iconview.h
  • IVM_GETITEMCOUNT : iconview.h
  • IVM_GETLEFTMARGIN : iconview.h
  • IVM_GETMARGINS : iconview.h
  • IVM_GETRIGHTMARGIN : iconview.h
  • IVM_GETTOPMARGIN : iconview.h
  • IVM_GETVISIBLEHEIGHT : iconview.h
  • IVM_GETVISIBLEWIDTH : iconview.h
  • IVM_GETVSCROLLPAGEVAL : iconview.h
  • IVM_GETVSCROLLVAL : iconview.h
  • IVM_MAKEPOSVISIBLE : iconview.h
  • IVM_REFRESHITEM : iconview.h
  • IVM_RESETCONTENT : iconview.h
  • IVM_SELECTITEM : iconview.h
  • IVM_SETCONTHEIGHT : iconview.h
  • IVM_SETCONTPOS : iconview.h
  • IVM_SETCONTRANGE : iconview.h
  • IVM_SETCONTWIDTH : iconview.h
  • IVM_SETCURSEL : iconview.h
  • IVM_SETITEMADDDATA : iconview.h
  • IVM_SETITEMCMP : iconview.h
  • IVM_SETITEMDESTROY : iconview.h
  • IVM_SETITEMDRAW : iconview.h
  • IVM_SETITEMINIT : iconview.h
  • IVM_SETITEMOPS : iconview.h
  • IVM_SETITEMSIZE : iconview.h
  • IVM_SETMARGINS : iconview.h
  • IVM_SETSCROLLPAGEVAL : iconview.h
  • IVM_SETSCROLLVAL : iconview.h
  • IVM_SHOWITEM : iconview.h
  • IVM_SORTITEMS : iconview.h
  • IVN_CLICKED : iconview.h
  • IVN_SELCHANGED : iconview.h
  • IVS_AUTOSORT : iconview.h
  • IVS_LOOP : iconview.h
  • IVS_NOTIFY : iconview.h
  • IVS_UPNOTIFY : iconview.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • w

- p -

  • PB_ERR : progressbar.h
  • PB_OKAY : progressbar.h
  • PBM_DELTAPOS : progressbar.h
  • PBM_SETPOS : progressbar.h
  • PBM_SETRANGE : progressbar.h
  • PBM_SETSTEP : progressbar.h
  • PBM_STEPIT : progressbar.h
  • PBN_REACHMAX : progressbar.h
  • PBN_REACHMIN : progressbar.h
  • PBS_NOTIFY : progressbar.h
  • PBS_VERTICAL : progressbar.h
  • PIXEL_black : gdi.h
  • PIXEL_blue : gdi.h
  • PIXEL_cyan : gdi.h
  • PIXEL_darkblue : gdi.h
  • PIXEL_darkcyan : gdi.h
  • PIXEL_darkgray : gdi.h
  • PIXEL_darkgreen : gdi.h
  • PIXEL_darkmagenta : gdi.h
  • PIXEL_darkred : gdi.h
  • PIXEL_darkyellow : gdi.h
  • PIXEL_green : gdi.h
  • PIXEL_invalid : gdi.h
  • PIXEL_lightgray : gdi.h
  • PIXEL_lightwhite : gdi.h
  • PIXEL_magenta : gdi.h
  • PIXEL_red : gdi.h
  • PIXEL_transparent : gdi.h
  • PIXEL_yellow : gdi.h
  • PM_NOREMOVE : window.h
  • PM_NOYIELD : window.h
  • PM_REMOVE : window.h
  • PolygonGenerator : gdi.h
  • PS_ERR : propsheet.h
  • PS_OKAY : propsheet.h
  • PSM_ADDPAGE : propsheet.h
  • PSM_GETACTIVEINDEX : propsheet.h
  • PSM_GETACTIVEPAGE : propsheet.h
  • PSM_GETPAGE : propsheet.h
  • PSM_GETPAGECOUNT : propsheet.h
  • PSM_GETPAGEINDEX : propsheet.h
  • PSM_GETTITLE : propsheet.h
  • PSM_GETTITLELENGTH : propsheet.h
  • PSM_REMOVEPAGE : propsheet.h
  • PSM_SETACTIVEINDEX : propsheet.h
  • PSM_SETTITLE : propsheet.h
  • PSM_SHEETCMD : propsheet.h
  • PSN_ACTIVE_CHANGED : propsheet.h
  • PSS_BOTTOM : propsheet.h
  • PSS_COMPACTTAB : propsheet.h
  • PSS_SCROLLABLE : propsheet.h
  • PSS_SIMPLE : propsheet.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • w

- r -

  • REAL_GLYPH : gdi.h
  • RECTH : gdi.h
  • RECTHP : gdi.h
  • RECTW : gdi.h
  • RECTWP : gdi.h
  • ReinitDesktop : minigui.h
  • ResetTimer : window.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • w

- s -

  • SB_ARROW_BOTH : window.h
  • SB_ARROW_BTDN : window.h
  • SB_ARROW_LTUP : window.h
  • SB_BOTTOM : window.h
  • SB_ENDSCROLL : window.h
  • SB_LINEDOWN : window.h
  • SB_LINELEFT : window.h
  • SB_LINERIGHT : window.h
  • SB_LINEUP : window.h
  • SB_PAGEDOWN : window.h
  • SB_PAGELEFT : window.h
  • SB_PAGERIGHT : window.h
  • SB_PAGEUP : window.h
  • SB_THUMBPOSITION : window.h
  • SB_THUMBTRACK : window.h
  • SB_TOP : window.h
  • SBM_ENABLE_ARROW : scrollbar.h
  • SBM_GETPOS : scrollbar.h
  • SBM_GETRANGE : scrollbar.h
  • SBM_GETSCROLLINFO : scrollbar.h
  • SBM_SETPOS : scrollbar.h
  • SBM_SETRANGE : scrollbar.h
  • SBM_SETRANGEREDRAW : scrollbar.h
  • SBM_SETSCROLLINFO : scrollbar.h
  • SBS_BOTTOMALIGN : scrollbar.h
  • SBS_DISABLED_BTDN : window.h
  • SBS_DISABLED_LTUP : window.h
  • SBS_FIXEDBARLEN : scrollbar.h
  • SBS_HILITE_BTDN : window.h
  • SBS_HILITE_LTUP : window.h
  • SBS_HILITE_THUMB : window.h
  • SBS_HORZ : scrollbar.h
  • SBS_LEFTALIGN : scrollbar.h
  • SBS_NOARROW : scrollbar.h
  • SBS_NOSHAFT : scrollbar.h
  • SBS_NOTNOTIFYPARENT : scrollbar.h
  • SBS_PRESSED_BTDN : window.h
  • SBS_PRESSED_LTUP : window.h
  • SBS_PRESSED_THUMB : window.h
  • SBS_RIGHTALIGN : scrollbar.h
  • SBS_TOPALIGN : scrollbar.h
  • SBS_VERT : scrollbar.h
  • SCANCODE_USER : common.h
  • SELECT_DEVFONT : gdi.h
  • SendAsyncMessage : window.h
  • SET_MBC_GLYPH : gdi.h
  • SetBkColor : gdi.h
  • SetBkMode : gdi.h
  • SetBrushColor : gdi.h
  • SetBrushType : gdi.h
  • SetCursor : minigui.h
  • SetDefaultCursor : minigui.h
  • SetFocus : window.h
  • SetForegroundWindow : window.h
  • SetIntervalTime : window.h
  • SetKeyAlwaysPressTime : window.h
  • SetKeyLongPressTime : window.h
  • SetMapMode : gdi.h
  • SetPenCapStyle : gdi.h
  • SetPenColor : gdi.h
  • SetPenJoinStyle : gdi.h
  • SetPenType : gdi.h
  • SetPenWidth : gdi.h
  • SetTabStop : gdi.h
  • SetTextAboveLineExtra : gdi.h
  • SetTextAlign : gdi.h
  • SetTextBellowLineExtra : gdi.h
  • SetTextCharacterExtra : gdi.h
  • SetTextColor : gdi.h
  • SetTimer : window.h
  • SetValueToEtc : minigui.h
  • SetViewportExt : gdi.h
  • SetViewportOrg : gdi.h
  • SetWindowExt : gdi.h
  • SetWindowOrg : gdi.h
  • SPM_DISABLEDOWN : spinbox.h
  • SPM_DISABLEUP : spinbox.h
  • SPM_ENABLEDOWN : spinbox.h
  • SPM_ENABLEUP : spinbox.h
  • SPM_GETCUR : spinbox.h
  • SPM_GETINFO : spinbox.h
  • SPM_GETTARGET : spinbox.h
  • SPM_SETCUR : spinbox.h
  • SPM_SETINFO : spinbox.h
  • SPM_SETTARGET : spinbox.h
  • SPN_REACHMAX : spinbox.h
  • SPN_REACHMIN : spinbox.h
  • SPS_AUTOSCROLL : spinbox.h
  • SPS_HORIZONTAL : spinbox.h
  • SPS_TYPE_DOWNARROW : spinbox.h
  • SPS_TYPE_MASK : spinbox.h
  • SPS_TYPE_NORMAL : spinbox.h
  • SPS_TYPE_UPARROW : spinbox.h
  • SS_ALIGNMASK : static.h
  • SS_BITMAP : static.h
  • SS_BLACKFRAME : static.h
  • SS_BLACKRECT : static.h
  • SS_CENTER : static.h
  • SS_CENTERIMAGE : static.h
  • SS_GRAYFRAME : static.h
  • SS_GRAYRECT : static.h
  • SS_GROUPBOX : static.h
  • SS_ICON : static.h
  • SS_LEFT : static.h
  • SS_LEFTNOWORDWRAP : static.h
  • SS_NOPREFIX : static.h
  • SS_NOTIFY : static.h
  • SS_NOWORDWRAP : static.h
  • SS_REALSIZEIMAGE : static.h
  • SS_RIGHT : static.h
  • SS_SIMPLE : static.h
  • SS_TYPEMASK : static.h
  • SS_WHITEFRAME : static.h
  • SS_WHITERECT : static.h
  • STM_GETIMAGE : static.h
  • STM_SETIMAGE : static.h
  • STN_CLICKED : static.h
  • STN_DBLCLK : static.h
  • SVM_ADDCTRLS : scrollview.h
  • SVM_ADDITEM : scrollview.h
  • SVM_CHOOSEITEM : scrollview.h
  • SVM_DELITEM : scrollview.h
  • SVM_GETBOTTOMMARGIN : scrollview.h
  • SVM_GETCONTENTX : scrollview.h
  • SVM_GETCONTENTY : scrollview.h
  • SVM_GETCONTHEIGHT : scrollview.h
  • SVM_GETCONTWIDTH : scrollview.h
  • SVM_GETCTRL : scrollview.h
  • SVM_GETCURSEL : scrollview.h
  • SVM_GETFIRSTVISIBLEITEM : scrollview.h
  • SVM_GETFOCUSCHILD : scrollview.h
  • SVM_GETHSCROLLPAGEVAL : scrollview.h
  • SVM_GETHSCROLLVAL : scrollview.h
  • SVM_GETITEMADDDATA : scrollview.h
  • SVM_GETITEMCOUNT : scrollview.h
  • SVM_GETLEFTMARGIN : scrollview.h
  • SVM_GETMARGINS : scrollview.h
  • SVM_GETRIGHTMARGIN : scrollview.h
  • SVM_GETTOPMARGIN : scrollview.h
  • SVM_GETVISIBLEHEIGHT : scrollview.h
  • SVM_GETVISIBLEWIDTH : scrollview.h
  • SVM_GETVSCROLLPAGEVAL : scrollview.h
  • SVM_GETVSCROLLVAL : scrollview.h
  • SVM_MAKEPOSVISIBLE : scrollview.h
  • SVM_REFRESHITEM : scrollview.h
  • SVM_RESETCONTENT : scrollview.h
  • SVM_SELECTITEM : scrollview.h
  • SVM_SETCONTAINERPROC : scrollview.h
  • SVM_SETCONTHEIGHT : scrollview.h
  • SVM_SETCONTPOS : scrollview.h
  • SVM_SETCONTRANGE : scrollview.h
  • SVM_SETCONTWIDTH : scrollview.h
  • SVM_SETCURSEL : scrollview.h
  • SVM_SETITEMADDDATA : scrollview.h
  • SVM_SETITEMCMP : scrollview.h
  • SVM_SETITEMDESTROY : scrollview.h
  • SVM_SETITEMDRAW : scrollview.h
  • SVM_SETITEMHEIGHT : scrollview.h
  • SVM_SETITEMINIT : scrollview.h
  • SVM_SETITEMOPS : scrollview.h
  • SVM_SETMARGINS : scrollview.h
  • SVM_SETSCROLLPAGEVAL : scrollview.h
  • SVM_SETSCROLLVAL : scrollview.h
  • SVM_SHOWITEM : scrollview.h
  • SVM_SORTITEMS : scrollview.h
  • SVN_CLICKED : scrollview.h
  • SVN_SELCHANGED : scrollview.h
  • SVN_SELCHANGING : scrollview.h
  • SVS_AUTOSORT : scrollview.h
  • SVS_LOOP : scrollview.h
  • SVS_NOTIFY : scrollview.h
  • SVS_UPNOTIFY : scrollview.h
  • SysColorIndex : gdi.h
  • SYSLOGFONT_CAPTION : gdi.h
  • SYSLOGFONT_CONTROL : gdi.h
  • SYSLOGFONT_DEFAULT : gdi.h
  • SYSLOGFONT_FIXED : gdi.h
  • SYSLOGFONT_MENU : gdi.h
  • SYSLOGFONT_WCHAR_DEF : gdi.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • w

- t -

  • TabbedTextOut : gdi.h
  • TABLESIZE : common.h
  • TBLEN_TIP : trackbar.h
  • TBM_GETLINESIZE : trackbar.h
  • TBM_GETMAX : trackbar.h
  • TBM_GETMIN : trackbar.h
  • TBM_GETPAGESIZE : trackbar.h
  • TBM_GETPOS : trackbar.h
  • TBM_GETTICKFREQ : trackbar.h
  • TBM_GETTIP : trackbar.h
  • TBM_SETLINESIZE : trackbar.h
  • TBM_SETMAX : trackbar.h
  • TBM_SETMIN : trackbar.h
  • TBM_SETPAGESIZE : trackbar.h
  • TBM_SETPOS : trackbar.h
  • TBM_SETRANGE : trackbar.h
  • TBM_SETTICKFREQ : trackbar.h
  • TBM_SETTIP : trackbar.h
  • TBN_CHANGE : trackbar.h
  • TBN_REACHMAX : trackbar.h
  • TBN_REACHMIN : trackbar.h
  • TBN_STARTDRAG : trackbar.h
  • TBN_STOPDRAG : trackbar.h
  • TBS_BORDER : trackbar.h
  • TBS_NOTICK : trackbar.h
  • TBS_NOTIFY : trackbar.h
  • TBS_TIP : trackbar.h
  • TBS_VERTICAL : trackbar.h
  • TextOut : gdi.h
  • TRUE : common.h
  • TVM_ADDITEM : treeview.h
  • TVM_DELTREE : treeview.h
  • TVM_FINDCHILD : treeview.h
  • TVM_GETITEMINFO : treeview.h
  • TVM_GETITEMTEXT : treeview.h
  • TVM_GETITEMTEXTLEN : treeview.h
  • TVM_GETRELATEDITEM : treeview.h
  • TVM_GETROOT : treeview.h
  • TVM_GETSELITEM : treeview.h
  • TVM_INSERTITEM : treeview.h
  • TVM_SEARCHITEM : treeview.h
  • TVM_SETITEMINFO : treeview.h
  • TVM_SETSELITEM : treeview.h
  • TVM_SETSTRCMPFUNC : treeview.h
  • TVN_CLICKED : treeview.h
  • TVN_DBLCLK : treeview.h
  • TVN_ENTER : treeview.h
  • TVN_ERRSPACE : treeview.h
  • TVN_FOLDED : treeview.h
  • TVN_KILLFOCUS : treeview.h
  • TVN_SELCHANGE : treeview.h
  • TVN_SETFOCUS : treeview.h
  • TVN_UNFOLDED : treeview.h
  • TVS_ICONFORSELECT : treeview.h
  • TVS_NOTIFY : treeview.h
  • TVS_SORT : treeview.h
  • TVS_WITHICON : treeview.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • w

- u -

  • UnionRectWithRegion : gdi.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • w

- w -

  • WC2MB : gdi.h
  • WCS2MBS : gdi.h
  • WE_ATTR_TYPE_RDR : window.h
  • WE_COLORS_NUMBER : window.h
  • WE_FONTS_NUMBER : window.h
  • WE_METRICS_NUMBER : window.h
  • WS_BORDER : window.h
  • WS_CAPTION : window.h
  • WS_CHILD : window.h
  • WS_DISABLED : window.h
  • WS_DLGFRAME : window.h
  • WS_EX_AUTOSECONDARYDC : window.h
  • WS_EX_BROUNDCNS : window.h
  • WS_EX_CLIPCHILDREN : window.h
  • WS_EX_CONTROL_MASK : window.h
  • WS_EX_DLGHIDE : window.h
  • WS_EX_INTERNAL_MASK : window.h
  • WS_EX_LEFTSCROLLBAR : window.h
  • WS_EX_LFRDR_CUSTOM1 : window.h
  • WS_EX_LFRDR_CUSTOM2 : window.h
  • WS_EX_LFRDR_CUSTOM3 : window.h
  • WS_EX_LFRDR_CUSTOM4 : window.h
  • WS_EX_LFRDR_MASK : window.h
  • WS_EX_NOCLOSEBOX : window.h
  • WS_EX_NONE : window.h
  • WS_EX_NOPARENTNOTIFY : window.h
  • WS_EX_NOTDRAGGABLE : window.h
  • WS_EX_RIGHTSCROLLBAR : window.h
  • WS_EX_TOOLWINDOW : window.h
  • WS_EX_TOPMOST : window.h
  • WS_EX_TRANSPARENT : window.h
  • WS_EX_TROUNDCNS : window.h
  • WS_EX_USEPARENTCURSOR : window.h
  • WS_EX_USEPARENTFONT : window.h
  • WS_EX_USEPARENTRDR : window.h
  • WS_EX_USEPRIVATECDC : window.h
  • WS_GROUP : window.h
  • WS_HSCROLL : window.h
  • WS_NONE : window.h
  • WS_SYSMENU : window.h
  • WS_TABSTOP : window.h
  • WS_THICKFRAME : window.h
  • WS_THINFRAME : window.h
  • WS_VISIBLE : window.h
  • WS_VSCROLL : window.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines

  • BrushType : gdi.h
  • mg_FT_LcdFilter : gdi.h
  • PenType : gdi.h
  • PTCapStyle : gdi.h
  • PTJoinStyle : gdi.h
  • SBPolicyType : ctrlhelper.h
  • SHAPETYPE : gdi.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines

  • BT_OPAQUE_STIPPLED : gdi.h
  • BT_SOLID : gdi.h
  • BT_STIPPLED : gdi.h
  • BT_TILED : gdi.h
  • MG_SMOOTH_DEFAULT : gdi.h
  • MG_SMOOTH_LEGACY : gdi.h
  • MG_SMOOTH_LIGHT : gdi.h
  • MG_SMOOTH_MAX : gdi.h
  • MG_SMOOTH_NONE : gdi.h
  • PT_CAP_BUTT : gdi.h
  • PT_CAP_PROJECTING : gdi.h
  • PT_CAP_ROUND : gdi.h
  • PT_DOUBLE_DASH : gdi.h
  • PT_JOIN_BEVEL : gdi.h
  • PT_JOIN_MITER : gdi.h
  • PT_JOIN_ROUND : gdi.h
  • PT_ON_OFF_DASH : gdi.h
  • PT_SOLID : gdi.h
  • SB_POLICY_ALWAYS : ctrlhelper.h
  • SB_POLICY_AUTOMATIC : ctrlhelper.h
  • SB_POLICY_NEVER : ctrlhelper.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- a -

  • ActiveCaret() : window.h
  • AddAccelerators() : window.h
  • AddClipRect() : gdi.h
  • AddGlyphsToBMPFont() : gdi.h
  • AddInnerRes() : window.h
  • AddResRef() : window.h
  • AddWindowElementRenderer() : window.h
  • ArcEx() : gdi.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- k -

  • KillTimer() : window.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- l -

  • LineClipper() : gdi.h
  • LineEx() : gdi.h
  • LineGenerator() : gdi.h
  • LineTo() : gdi.h
  • LoadBitmapEx() : gdi.h
  • LoadBitmapFromFile() : gdi.h
  • LoadBitmapFromMem() : gdi.h
  • LoadCursorFromFile() : minigui.h
  • LoadCursorFromMem() : minigui.h
  • LoadDevFontFromFile() : gdi.h
  • LoadEtcFile() : minigui.h
  • LoadIconFromFile() : gdi.h
  • LoadIconFromMem() : gdi.h
  • LoadMyBitmapEx() : gdi.h
  • LoadMyBitmapFromFile() : gdi.h
  • LoadMyBitmapFromMem() : gdi.h
  • LoadMyBitmapSL() : gdi.h
  • LoadResource() : window.h
  • LoadSystemIcon() : window.h
  • LoadSystemIconEx() : window.h
  • LockDC() : gdi.h
  • LockDCEx() : gdi.h
  • LPtoDP() : gdi.h
  • LPtoSP() : gdi.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- m -

  • MainWindowThreadCleanup() : window.h
  • MB2WCEx() : gdi.h
  • MBS2WCSEx() : gdi.h
  • MessageBeep() : window.h
  • MessageBox() : window.h
  • mglist_get_item_adddata() : scrollview.h
  • MGUI_AllocRW() : endianrw.h
  • MGUI_FreeRW() : endianrw.h
  • MGUI_InitMemRW() : endianrw.h
  • MGUI_ReadBE16() : endianrw.h
  • MGUI_ReadBE32() : endianrw.h
  • MGUI_ReadBE64() : endianrw.h
  • MGUI_ReadLE16() : endianrw.h
  • MGUI_ReadLE16FP() : endianrw.h
  • MGUI_ReadLE32() : endianrw.h
  • MGUI_ReadLE32FP() : endianrw.h
  • MGUI_ReadLE64() : endianrw.h
  • MGUI_RWFromFile() : endianrw.h
  • MGUI_RWFromFP() : endianrw.h
  • MGUI_RWFromMem() : endianrw.h
  • MGUI_RWgetc() : endianrw.h
  • MGUI_WriteBE16() : endianrw.h
  • MGUI_WriteBE32() : endianrw.h
  • MGUI_WriteBE64() : endianrw.h
  • MGUI_WriteLE16() : endianrw.h
  • MGUI_WriteLE16FP() : endianrw.h
  • MGUI_WriteLE32() : endianrw.h
  • MGUI_WriteLE32FP() : endianrw.h
  • MGUI_WriteLE64() : endianrw.h
  • MiniGUIPanic() : minigui.h
  • mlsEnableSlaveScreen() : gdi.h
  • MonotoneVerticalPolygonGenerator() : gdi.h
  • MoveTo() : gdi.h
  • MoveWindow() : window.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- n -

  • NormalizeRect() : gdi.h
  • NotifyParentEx() : ctrlhelper.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- o -

  • OffsetClipRegion() : gdi.h
  • OffsetRect() : gdi.h
  • OffsetRegion() : gdi.h
  • OffsetRegionEx() : gdi.h
  • OpenAboutDialog() : minigui.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- b -

  • BeginPaint() : window.h
  • BIDIGetLogicalEmbeddLevels() : gdi.h
  • BIDIGetTextLogicalGlyphs() : gdi.h
  • BIDIGetTextVisualGlyphs() : gdi.h
  • BIDIGetVisualEmbeddLevels() : gdi.h
  • BIDILogGlyphs2VisGlyphs() : gdi.h
  • BitBlt() : gdi.h
  • BlockDataAlloc() : gdi.h
  • BlockDataFree() : gdi.h
  • BroadcastMessage() : window.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- c -

  • ChangeCaretSize() : window.h
  • CheckBitmapType() : gdi.h
  • CheckDlgButton() : window.h
  • CheckMenuRadioItem() : window.h
  • CheckRadioButton() : window.h
  • Circle() : gdi.h
  • CircleArc() : gdi.h
  • CircleArcGenerator() : gdi.h
  • CircleGenerator() : gdi.h
  • CleanupMyBitmapSL() : gdi.h
  • ClientHeightToWindowHeightEx() : window.h
  • ClientToScreen() : window.h
  • ClientToWindow() : window.h
  • ClientWidthToWindowWidthEx() : window.h
  • ClipCursor() : minigui.h
  • ClipRectIntersect() : gdi.h
  • ClipRgnCopy() : gdi.h
  • ClipRgnIntersect() : gdi.h
  • CompileRGBABitmap() : gdi.h
  • CompileRGBABitmapEx() : gdi.h
  • ConvertMemDC() : gdi.h
  • CopyAcceleratorTable() : window.h
  • CopyRect() : gdi.h
  • CreateAcceleratorTable() : window.h
  • CreateAnimationFromGIF89a() : animation.h
  • CreateAnimationFromGIF89aFile() : animation.h
  • CreateAnimationFromGIF89aMem() : animation.h
  • CreateBMPDevFont() : gdi.h
  • CreateCaret() : window.h
  • CreateClipBoard() : minigui.h
  • CreateClipRgn() : gdi.h
  • CreateCompatibleDCEx() : gdi.h
  • CreateCursor() : minigui.h
  • CreateIconEx() : gdi.h
  • CreateLogFont() : gdi.h
  • CreateLogFontByName() : gdi.h
  • CreateLogFontIndirect() : gdi.h
  • CreateMainWindow() : window.h
  • CreateMainWindowEx() : window.h
  • CreateMainWindowIndirect() : window.h
  • CreateMainWindowIndirectParam() : window.h
  • CreateMainWindowIndirectParamEx() : window.h
  • CreateMemDC() : gdi.h
  • CreateMemDCEx() : gdi.h
  • CreateMemDCFromBitmap() : gdi.h
  • CreateMemDCFromMyBitmap() : gdi.h
  • CreateMenu() : window.h
  • CreatePalette() : gdi.h
  • CreatePopupMenu() : window.h
  • CreatePrivateClientDC() : gdi.h
  • CreatePrivateDC() : gdi.h
  • CreatePrivateSubDC() : gdi.h
  • CreateSecondaryDC() : gdi.h
  • CreateSubMemDC() : gdi.h
  • CreateSystemMenu() : window.h
  • CreateToolTipWin() : ctrlhelper.h
  • CreateWindowEx() : window.h
  • CreateWindowEx2() : window.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- d -

  • DefaultContainerProc() : scrollview.h
  • DefaultWindowProc() : window.h
  • DeleteAccelerators() : window.h
  • DeleteBitmapAlphaPixel() : gdi.h
  • DeleteMemDC() : gdi.h
  • DeleteMenu() : window.h
  • DeletePrivateDC() : gdi.h
  • DeleteSecondaryDC() : gdi.h
  • DesktopUpdateAllWindow() : minigui.h
  • DestroyAcceleratorTable() : window.h
  • DestroyAllControls() : window.h
  • DestroyAnimation() : animation.h
  • DestroyBlockDataHeap() : gdi.h
  • DestroyBMPFont() : gdi.h
  • DestroyCaret() : window.h
  • DestroyClipBoard() : minigui.h
  • DestroyClipRgn() : gdi.h
  • DestroyCursor() : minigui.h
  • DestroyDynamicDevFont() : gdi.h
  • DestroyIcon() : gdi.h
  • DestroyLogFont() : gdi.h
  • DestroyMainWindow() : window.h
  • DestroyMainWindowIndirect() : window.h
  • DestroyMenu() : window.h
  • DestroyPalette() : gdi.h
  • DestroyToolTipWin() : ctrlhelper.h
  • DestroyWindow() : window.h
  • DialogBoxIndirectParam() : window.h
  • DialogBoxIndirectParamEx() : window.h
  • DisabledTextOutEx() : ctrlhelper.h
  • DispatchMessage() : window.h
  • DoesIntersect() : gdi.h
  • DPtoLP() : gdi.h
  • DrawGlyph() : gdi.h
  • DrawHVDotLine() : gdi.h
  • DrawIcon() : gdi.h
  • DrawMenuBar() : window.h
  • DrawTextEx2() : gdi.h
  • DWORD2PIXEL() : gdi.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- e -

  • Ellipse() : gdi.h
  • EllipseGenerator() : gdi.h
  • EmptyClipRgn() : gdi.h
  • EmptyMessageQueue() : window.h
  • EnableMenuItem() : window.h
  • EnableScrollBar() : window.h
  • EnableWindow() : window.h
  • EndDialog() : window.h
  • EndPaint() : window.h
  • EqualRect() : gdi.h
  • ExcludeClipRect() : gdi.h
  • ExcludeWindowExStyle() : window.h
  • ExcludeWindowStyle() : window.h
  • ExitGUISafely() : minigui.h
  • Expand16CBitmap() : gdi.h
  • ExpandMonoBitmap() : gdi.h
  • ExpandMyBitmap() : gdi.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- f -

  • FillArcEx() : gdi.h
  • FillBitmapPartInBox() : gdi.h
  • FillBox() : gdi.h
  • FillBoxWithBitmap() : gdi.h
  • FillBoxWithBitmapPart() : gdi.h
  • FillCircle() : gdi.h
  • FillEllipse() : gdi.h
  • FillPolygon() : gdi.h
  • FindSectionInEtc() : minigui.h
  • fixacos() : fixedmath.h
  • fixadd() : fixedmath.h
  • fixasin() : fixedmath.h
  • fixatan() : fixedmath.h
  • fixatan2() : fixedmath.h
  • fixceil() : fixedmath.h
  • fixcos() : fixedmath.h
  • fixdiv() : fixedmath.h
  • fixhypot() : fixedmath.h
  • fixmul() : fixedmath.h
  • fixsin() : fixedmath.h
  • fixsqrt() : fixedmath.h
  • FixStrAlloc() : minigui.h
  • FixStrDup() : minigui.h
  • fixsub() : fixedmath.h
  • fixtan() : fixedmath.h
  • fixtof() : fixedmath.h
  • fixtoi() : fixedmath.h
  • FloodFill() : gdi.h
  • FloodFillGenerator() : gdi.h
  • FocusRect() : gdi.h
  • FreeFixStr() : minigui.h
  • ft2SetLcdFilter() : gdi.h
  • ftofix() : fixedmath.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- g -

  • GetActiveWindow() : window.h
  • GetBitmapFromDC() : gdi.h
  • GetBoundRect() : gdi.h
  • GetBoundsRect() : gdi.h
  • GetCapture() : window.h
  • GetCaretBlinkTime() : window.h
  • GetCaretPos() : window.h
  • GetClassName() : window.h
  • GetClientDC() : gdi.h
  • GetClientRect() : window.h
  • GetClipBoardByte() : minigui.h
  • GetClipBoardData() : minigui.h
  • GetClipBoardDataLen() : minigui.h
  • GetClipBox() : gdi.h
  • GetClipCursor() : minigui.h
  • GetClipRgnBoundRect() : gdi.h
  • GetCurFont() : gdi.h
  • GetCurrentCursor() : minigui.h
  • GetCursorPos() : minigui.h
  • GetDC() : gdi.h
  • GetDCAttr() : gdi.h
  • GetDCLCS() : gdi.h
  • GetDefaultCursor() : minigui.h
  • GetDefaultPalette() : gdi.h
  • GetDefaultWindowElementRenderer() : window.h
  • GetDlgCtrlID() : window.h
  • GetDlgDefPushButton() : window.h
  • GetDlgItem() : window.h
  • GetDlgItemInt() : window.h
  • GetDlgItemText() : window.h
  • GetDlgItemText2() : window.h
  • GetFirstHosted() : window.h
  • GetFirstMCharLen() : gdi.h
  • GetFirstWord() : gdi.h
  • GetFocusChild() : window.h
  • GetFontHeight() : gdi.h
  • GetFontMetrics() : gdi.h
  • GetGDCapability() : gdi.h
  • GetGlyphBitmap() : gdi.h
  • GetGlyphInfo() : gdi.h
  • GetGlyphsExtent() : gdi.h
  • GetGlyphsExtentPoint() : gdi.h
  • GetGlyphShape() : gdi.h
  • GetGlyphValue() : gdi.h
  • GetHosting() : window.h
  • GetIconSize() : gdi.h
  • GetIMEPos() : window.h
  • GetIMEStatus() : window.h
  • GetIMETargetInfo() : window.h
  • GetIntValueFromEtc() : minigui.h
  • GetIntValueFromEtcFile() : minigui.h
  • GetIntValueFromEtcSec() : minigui.h
  • GetKeyStatus() : minigui.h
  • GetLargeSystemIconEx() : window.h
  • GetLastTextOutPos() : gdi.h
  • GetLogFontInfo() : gdi.h
  • GetMainWindowHandle() : window.h
  • GetMaxFontWidth() : gdi.h
  • GetMenu() : window.h
  • GetMenuBarItemRect() : window.h
  • GetMenuItemCount() : window.h
  • GetMenuItemID() : window.h
  • GetMenuItemInfo() : window.h
  • GetMessage() : window.h
  • GetMgEtcIntValue() : minigui.h
  • GetMgEtcValue() : minigui.h
  • GetNearestColor() : gdi.h
  • GetNearestPaletteIndex() : gdi.h
  • GetNextChild() : window.h
  • GetNextDevFont() : gdi.h
  • GetNextDlgGroupItem() : window.h
  • GetNextDlgTabItem() : window.h
  • GetNextHosted() : window.h
  • GetNextMainWindow() : window.h
  • GetNotificationCallback() : window.h
  • GetOriginalMousePosition() : minigui.h
  • GetOriginalTermIO() : minigui.h
  • GetPalette() : gdi.h
  • GetPaletteEntries() : gdi.h
  • GetParent() : window.h
  • GetPixel() : gdi.h
  • GetPixelInBitmap() : gdi.h
  • GetPixelInBitmapEx() : gdi.h
  • GetPixelRGB() : gdi.h
  • GetPixelRGBA() : gdi.h
  • GetPopupSubMenu() : window.h
  • GetPrivateClientDC() : gdi.h
  • GetRasterOperation() : gdi.h
  • GetResource() : window.h
  • GetScrollInfo() : window.h
  • GetScrollPos() : window.h
  • GetScrollRange() : window.h
  • GetSecondaryClientDC() : gdi.h
  • GetSecondaryDC() : gdi.h
  • GetShiftKeyStatus() : minigui.h
  • GetSmallSystemIconEx() : window.h
  • GetSpinBoxSize() : spinbox.h
  • GetSubDC() : gdi.h
  • GetSubMenu() : window.h
  • GetSysCCharWidth() : gdi.h
  • GetSysCharHeight() : gdi.h
  • GetSysCharset() : gdi.h
  • GetSysCharWidth() : gdi.h
  • GetSysFontAveWidth() : gdi.h
  • GetSysFontHeight() : gdi.h
  • GetSysFontMaxWidth() : gdi.h
  • GetSystemBitmap() : window.h
  • GetSystemBitmapByHwnd() : window.h
  • GetSystemBitmapEx() : window.h
  • GetSystemCursor() : minigui.h
  • GetSystemFont() : gdi.h
  • GetSystemMenu() : window.h
  • GetSysText() : minigui.h
  • GetSysTextInUTF8() : minigui.h
  • GetTabbedTextExtent() : gdi.h
  • GetTabbedTextExtentPoint() : gdi.h
  • GetTextExtent() : gdi.h
  • GetTextExtentPoint() : gdi.h
  • GetTextMCharInfo() : gdi.h
  • GetTextRangesLog2Vis() : gdi.h
  • GetTextWordInfo() : gdi.h
  • GetTickCount() : window.h
  • GetUpdateRect() : window.h
  • GetValueFromEtc() : minigui.h
  • GetValueFromEtcFile() : minigui.h
  • GetValueFromEtcSec() : minigui.h
  • GetWindowAdditionalData() : window.h
  • GetWindowAdditionalData2() : window.h
  • GetWindowBkColor() : window.h
  • GetWindowCallbackProc() : window.h
  • GetWindowCaption() : window.h
  • GetWindowClassAdditionalData() : window.h
  • GetWindowClassInfo() : window.h
  • GetWindowCursor() : window.h
  • GetWindowElementAttr() : window.h
  • GetWindowElementPixelEx() : window.h
  • GetWindowExStyle() : window.h
  • GetWindowFont() : window.h
  • GetWindowIcon() : window.h
  • GetWindowInfo() : window.h
  • GetWindowRect() : window.h
  • GetWindowRendererFromName() : window.h
  • GetWindowStyle() : window.h
  • GetWindowText() : window.h
  • GetWindowTextLength() : window.h
  • GetWindowUnderCursor() : window.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- h -

  • HaveFreeTimer() : window.h
  • HavePendingMessage() : window.h
  • HFlipBitmap() : gdi.h
  • HideCaret() : window.h
  • HiliteMenuBarItem() : window.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- i -

  • iconview_get_item_adddata() : iconview.h
  • iconview_get_item_bitmap() : iconview.h
  • iconview_get_item_label() : iconview.h
  • iconview_is_item_hilight() : iconview.h
  • IncludeClipRect() : gdi.h
  • IncludeWindowExStyle() : window.h
  • IncludeWindowStyle() : window.h
  • InflateRect() : gdi.h
  • InflateRectToPt() : gdi.h
  • InitBitmap() : gdi.h
  • InitBitmapPixelFormat() : gdi.h
  • InitBlockDataHeap() : gdi.h
  • InitCircleRegion() : gdi.h
  • InitClipRgn() : gdi.h
  • InitEllipseRegion() : gdi.h
  • InitGUI() : minigui.h
  • InitMyBitmapSL() : gdi.h
  • InitPolygonRegion() : gdi.h
  • InitRendererSystemIcon() : window.h
  • InitSlaveScreen() : gdi.h
  • InitVectorialFonts() : gdi.h
  • InitWindowElementAttrs() : window.h
  • InsertMenuItem() : window.h
  • IntersectClipRect() : gdi.h
  • IntersectRect() : gdi.h
  • InvalidateRect() : window.h
  • IsCompatibleDC() : gdi.h
  • IsControl() : window.h
  • IsCovered() : gdi.h
  • IsDialog() : window.h
  • IsDlgButtonChecked() : window.h
  • IsEmptyClipRgn() : gdi.h
  • IsMainWindow() : window.h
  • IsMenu() : window.h
  • IsRectEmpty() : gdi.h
  • IsTimerInstalled() : window.h
  • IsWindow() : window.h
  • IsWindowEnabled() : window.h
  • IsWindowVisible() : window.h
  • itofix() : fixedmath.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- p -

  • PaintImageEx() : gdi.h
  • PaintImageFromFile() : gdi.h
  • PaintImageFromMem() : gdi.h
  • PeekMessage() : window.h
  • PeekMessageEx() : window.h
  • PeekPostMessage() : window.h
  • Ping() : minigui.h
  • PivotBitmap() : gdi.h
  • PivotScaledBitmapFlip() : gdi.h
  • Pixel2DWORD() : gdi.h
  • Pixel2RGB() : gdi.h
  • Pixel2RGBA() : gdi.h
  • Pixel2RGBAs() : gdi.h
  • Pixel2RGBs() : gdi.h
  • PolyArcEx() : gdi.h
  • PolyFillArcEx() : gdi.h
  • PolygonGeneratorEx() : gdi.h
  • PolygonIsMonotoneVertical() : gdi.h
  • PolyLineEx() : gdi.h
  • PolyLineTo() : gdi.h
  • PostMessage() : window.h
  • PostQuitMessage() : window.h
  • PtInRect() : gdi.h
  • PtInRegion() : gdi.h
  • PtVisible() : gdi.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- r -

  • RealizePalette() : gdi.h
  • Rectangle() : gdi.h
  • RectInRegion() : gdi.h
  • RectVisible() : gdi.h
  • RegisterBitmapFileType() : gdi.h
  • RegisterIMEWindow() : window.h
  • RegisterKeyMsgHook() : window.h
  • RegisterListenFD() : minigui.h
  • RegisterMouseMsgHook() : window.h
  • RegisterResFromBitmap() : window.h
  • RegisterResFromFile() : window.h
  • RegisterResFromMem() : window.h
  • RegisterResType() : window.h
  • RegisterSystemBitmap() : window.h
  • RegisterWindowClass() : window.h
  • ReinitDesktopEx() : minigui.h
  • ReleaseCapture() : window.h
  • ReleaseDC() : gdi.h
  • ReleaseRes() : window.h
  • ReleaseSecondaryDC() : gdi.h
  • RemoveMenu() : window.h
  • RemoveSectionInEtc() : minigui.h
  • RemoveSectionInEtcFile() : minigui.h
  • RemoveWindowElementRenderer() : window.h
  • ReplaceBitmapColor() : gdi.h
  • ResetTimerEx() : window.h
  • ResetToolTipWin() : ctrlhelper.h
  • ResizePalette() : gdi.h
  • RestoreDC() : gdi.h
  • RetrieveRes() : window.h
  • RGB2Pixel() : gdi.h
  • RGB2Pixels() : gdi.h
  • RGBA2Pixel() : gdi.h
  • RGBA2Pixels() : gdi.h
  • RotateBitmap() : gdi.h
  • RotateBitmapHFlip() : gdi.h
  • RotateBitmapVFlip() : gdi.h
  • RotateScaledBitmap() : gdi.h
  • RotateScaledBitmapHFlip() : gdi.h
  • RotateScaledBitmapVFlip() : gdi.h
  • RoundRect() : gdi.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- s -

  • SaveBitmapToFile() : gdi.h
  • SaveDC() : gdi.h
  • SaveEtcToFile() : minigui.h
  • SaveMainWindowContent() : gdi.h
  • SaveMyBitmapToFile() : gdi.h
  • SaveScreenRectContent() : gdi.h
  • SaveSectionToEtcFile() : minigui.h
  • ScaleBitmapEx() : gdi.h
  • ScreenToClient() : window.h
  • ScreenToWindow() : window.h
  • scrollview_get_item_adddata() : scrollview.h
  • scrollview_get_item_index() : scrollview.h
  • scrollview_is_item_hilight() : scrollview.h
  • scrollview_is_item_selected() : scrollview.h
  • scrollview_set_item_height() : scrollview.h
  • ScrollWindow() : window.h
  • SelectClipRect() : gdi.h
  • SelectClipRegion() : gdi.h
  • SelectClipRegionEx() : gdi.h
  • SelectFont() : gdi.h
  • SelectPalette() : gdi.h
  • SendDlgItemMessage() : window.h
  • SendMessage() : window.h
  • SendNotifyMessage() : window.h
  • SetActiveWindow() : window.h
  • SetAutoRepeatMessage() : window.h
  • SetBitmapKeyColor() : window.h
  • SetBitmapScalerType() : gdi.h
  • SetBrushInfo() : gdi.h
  • SetBrushOrigin() : gdi.h
  • SetCapture() : window.h
  • SetCaretBlinkTime() : window.h
  • SetCaretPos() : window.h
  • SetClipBoardData() : minigui.h
  • SetClipRgn() : gdi.h
  • SetColorfulPalette() : gdi.h
  • SetCursorEx() : minigui.h
  • SetCursorPos() : minigui.h
  • SetCustomDesktopOperationSet() : minigui.h
  • SetDCAttr() : gdi.h
  • SetDCLCS() : gdi.h
  • SetDefaultWindowElementRenderer() : window.h
  • SetDlgItemInt() : window.h
  • SetDlgItemText() : window.h
  • SetFocusChild() : window.h
  • SetIMEStatus() : window.h
  • SetIMETargetInfo() : window.h
  • SetKeyboardLayout() : window.h
  • SetMemDCAlpha() : gdi.h
  • SetMemDCColorKey() : gdi.h
  • SetMenu() : window.h
  • SetMenuItemBitmaps() : window.h
  • SetMenuItemInfo() : window.h
  • SetMouseCalibrationParameters() : minigui.h
  • SetNotificationCallback() : window.h
  • SetNullFocus() : window.h
  • SetPalette() : gdi.h
  • SetPaletteEntries() : gdi.h
  • SetPenDashes() : gdi.h
  • SetPixel() : gdi.h
  • SetPixelInBitmap() : gdi.h
  • SetPixelRGB() : gdi.h
  • SetPixelRGBA() : gdi.h
  • SetRasterOperation() : gdi.h
  • SetRect() : gdi.h
  • SetRectEmpty() : gdi.h
  • SetResPath() : window.h
  • SetScrollInfo() : window.h
  • SetScrollPos() : window.h
  • SetScrollRange() : window.h
  • SetSecondaryDC() : gdi.h
  • SetServerEventHook() : window.h
  • SetTimerEx() : window.h
  • SetValueToEtcFile() : minigui.h
  • SetValueToEtcSec() : minigui.h
  • SetWindowAdditionalData() : window.h
  • SetWindowAdditionalData2() : window.h
  • SetWindowBkColor() : window.h
  • SetWindowCallbackProc() : window.h
  • SetWindowCaption() : window.h
  • SetWindowClassAdditionalData() : window.h
  • SetWindowClassInfo() : window.h
  • SetWindowCursor() : window.h
  • SetWindowElementAttr() : window.h
  • SetWindowElementRenderer() : window.h
  • SetWindowFont() : window.h
  • SetWindowIcon() : window.h
  • SetWindowMask() : window.h
  • SetWindowMaskEx() : window.h
  • SetWindowRegion() : window.h
  • SetWindowText() : window.h
  • ShowCaret() : window.h
  • ShowCaretEx() : window.h
  • ShowCursor() : minigui.h
  • ShowScrollBar() : window.h
  • ShowWindow() : window.h
  • SplineTo() : gdi.h
  • SPtoLP() : gdi.h
  • Str2Key() : window.h
  • StretchBlt() : gdi.h
  • StretchPaintImageEx() : gdi.h
  • StretchPaintImageFromFile() : gdi.h
  • StretchPaintImageFromMem() : gdi.h
  • StripPopupHead() : window.h
  • strnchr() : minigui.h
  • strtrimall() : minigui.h
  • substrlen() : minigui.h
  • SubtractClipRect() : gdi.h
  • SubtractRect() : gdi.h
  • SubtractRegion() : gdi.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- t -

  • TabbedTextOutEx() : gdi.h
  • TabbedTextOutLen() : gdi.h
  • TerminateGUI() : minigui.h
  • TerminateSlaveScreen() : gdi.h
  • TermRendererSystemIcon() : window.h
  • TermSystemBitmap() : window.h
  • TermSystemBitmapEx() : window.h
  • TermVectorialFonts() : gdi.h
  • TextOutLen() : gdi.h
  • TextOutOmitted() : gdi.h
  • ThrowAwayMessages() : window.h
  • Tone() : minigui.h
  • TrackMenuBar() : window.h
  • TrackPopupMenu() : window.h
  • TranslateAccelerator() : window.h
  • TranslateKeyMsgToChar() : window.h
  • TranslateMessage() : window.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- u -

  • UnionRect() : gdi.h
  • UnionRegion() : gdi.h
  • UnloadBitmap() : gdi.h
  • UnloadEtcFile() : minigui.h
  • UnloadMyBitmap() : gdi.h
  • UnlockDC() : gdi.h
  • UnregisterIMEWindow() : window.h
  • UnregisterListenFD() : minigui.h
  • UnregisterRes() : window.h
  • UnregisterResType() : window.h
  • UnregisterSystemBitmap() : window.h
  • UnregisterWindowClass() : window.h
  • UpdateWindow() : window.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- v -

  • VFlipBitmap() : gdi.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- w -

  • WaitMessage() : window.h
  • WC2MBEx() : gdi.h
  • WCS2MBSEx() : gdi.h
  • WindowFromDC() : gdi.h
  • WindowToClient() : window.h
  • WindowToScreen() : window.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- x -

  • XorRegion() : gdi.h
  • xVFBAllocVirtualFrameBuffer() : xvfb.h
  • xVFBDestroyEventBuffer() : xvfb.h
  • xVFBFreeVirtualFrameBuffer() : xvfb.h
  • xVFBNotifyNewEvent() : xvfb.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- b -

  • BITMAP : gdi.h
  • BOOL : common.h
  • BYTE : common.h

- c -

  • CB_ARC : gdi.h
  • CB_CIRCLE : gdi.h
  • CB_DIRECT_DRAW_RECT : gdi.h
  • CB_ELLIPSE : gdi.h
  • CB_EQUAL_PIXEL : gdi.h
  • CB_FLOOD_FILL : gdi.h
  • CB_LINE : gdi.h
  • CB_ONE_SCANLINE : gdi.h
  • CB_POLYGON : gdi.h
  • CPLOGFONT : gdi.h

- d -

  • DWORD : common.h

- e -

  • ED_DRAWSEL_FUNC : edit.h

- f -

  • fixed : common.h

- g -

  • gal_attr : common.h
  • gal_pixel : common.h
  • gal_sint : common.h
  • gal_sint16 : common.h
  • gal_sint32 : common.h
  • gal_sint8 : common.h
  • gal_uint : common.h
  • gal_uint16 : common.h
  • gal_uint32 : common.h
  • gal_uint8 : common.h
  • GHANDLE : common.h
  • GLYPHINFO : gdi.h
  • GLYPHMAPINFO : gdi.h

- h -

  • HACCEL : common.h
  • HCURSOR : common.h
  • HDC : common.h
  • HDLG : common.h
  • HHOOK : common.h
  • HICON : common.h
  • HIVITEM : iconview.h
  • HLVITEM : listview.h
  • HMENU : common.h
  • HOTSPOTPROC : newtoolbar.h
  • HPALETTE : common.h
  • HSVITEM : scrollview.h
  • HTEXTDOC : textedit.h
  • HWND : common.h

- l -

  • LONG : common.h
  • LPARAM : common.h
  • LVNM_HEADRDOWN : listview.h
  • LVNM_HEADRUP : listview.h
  • LVNM_ITEMRDOWN : listview.h
  • LVNM_ITEMRUP : listview.h
  • LVNM_KEYDOWN : listview.h

- m -

  • MSGHOOK : window.h
  • MYBITMAP : gdi.h

- n -

  • NOTIFPROC : window.h

- o -

  • ON_UPDATE_SECONDARYDC : gdi.h

- p -

  • PBITMAP : gdi.h
  • PBLOCKHEAP : gdi.h
  • PCLIPRGN : gdi.h
  • PCONTAINERINFO : scrollview.h
  • PCOOLBARITEMINFO : coolbar.h
  • PETCSECTION : minigui.h
  • PFN_LVHDR_BKDRAWFUNC : listview.h
  • PFN_LVHDR_ITEMDRAWFUNC : listview.h
  • PFNLVCOMPARE : listview.h
  • PLISTBOXITEMINFO : listbox.h
  • PLOGFONT : gdi.h
  • PLVCOLUMN : listview.h
  • PLVFINDINFO : listview.h
  • PLVITEM : listview.h
  • PLVNM_HEADRDOWN : listview.h
  • PLVNM_HEADUP : listview.h
  • PLVNM_ITEMRDOWN : listview.h
  • PLVNM_ITEMRUP : listview.h
  • PLVNM_KEYDOWN : listview.h
  • PLVNM_NORMAL : listview.h
  • PLVSORTDATA : listview.h
  • PLVSUBITEM : listview.h
  • PMCCOLORINFO : monthcal.h
  • PMENUBUTTONITEM : menubutton.h
  • PMYBITMAP : gdi.h
  • PNTBITEMINFO : newtoolbar.h
  • PPOINT : common.h
  • PRECT : common.h
  • PRGB : common.h
  • PSIZE : common.h
  • PSPININFO : spinbox.h
  • PSVITEMINFO : scrollview.h
  • PSVITEMOPS : scrollview.h
  • PSYSTEMTIME : monthcal.h
  • PTVITEMINFO : treeview.h

- r -

  • RGBCOLOR : common.h

- s -

  • SBYTE : common.h
  • SDWORD : common.h
  • Sint16 : common.h
  • Sint32 : common.h
  • Sint64 : common.h
  • Sint8 : common.h
  • SRVEVTHOOK : window.h
  • STRCMP : ctrlhelper.h
  • SVITEM_CMP : scrollview.h
  • SVITEM_DESTROYFUNC : scrollview.h
  • SVITEM_DRAWFUNC : scrollview.h
  • SVITEM_INITFUNC : scrollview.h
  • SWORD : common.h

- t -

  • TIMERPROC : window.h

- u -

  • UINT : common.h
  • Uint16 : common.h
  • Uint32 : common.h
  • Uint64 : common.h
  • Uint8 : common.h

- w -

  • WNDPROC : window.h
  • WORD : common.h
  • WORDINFO : gdi.h
  • WPARAM : common.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Data Fields

  • File List
  • Globals
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines

  • __mg_def_proc : window.h
  • __mg_rtos_xvfb_event_buffer : xvfb.h
  • ETCFILEPATH : minigui.h
  • g_rcScr : minigui.h
  • local_SysText : minigui.h
  • SysPixelColor : gdi.h
  • SysPixelIndex : gdi.h
  • SysText : minigui.h
Generated on Fri Dec 17 13:49:53 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: gridview.h Source File

include » ctrl

gridview.h

Go to the documentation of this file.
00001
00019 /*
00020  * $Id: gridview.h 10690 2008-08-18 09:32:47Z weiym $
00021  *
00022  *             MiniGUI for Linux/uClinux, eCos, uC/OS-II, VxWorks,
00023  *                     pSOS, ThreadX, NuCleus, OSE, and Win32.
00024  *
00025  *             Copyright (C) 2002-2008 Feynman Software.
00026  *             Copyright (C) 1998-2002 Wei Yongming.
00027  */
00028
00029 #ifndef EXT_GRIDVIEW_H
00030 #define EXT_GRIDVIEW_H
00031
00032
00033 #ifdef  __cplusplus
00034 extern "C" {
00035 #endif
00036
00050 #define CTRL_GRIDVIEW               "gridview"
00051
00052 #define GVS_COLFIRST                0x0000
00053 #define GVS_ROWFIRST                0x0001
00054
00059 #define GRID_OKAY                   0
00060
00065 #define GRID_ERR                    (-1)
00066
00068 typedef struct _GRIDVIEWDATA
00069 {
00071     int nr_rows;
00073     int nr_cols;
00075     int row_height;
00077     int col_width;
00078 } GRIDVIEWDATA;
00079
00082 #define GV_HALIGN_LEFT                          0x00000001
00083
00084 #define GV_HALIGN_RIGHT                         0x00000002
00085
00086 #define GV_HALIGN_CENTER                        0x00000003
00087
00088 #define GV_VALIGN_TOP                           0x00000010
00089
00090 #define GV_VALIGN_BOTTOM                        0x00000020
00091
00092 #define GV_VALIGN_CENTER                        0x00000030
00093
00095 #define GV_HALIGN_MASK                          0x0000000F
00096
00098 #define GV_VALIGN_MASK                          0x000000F0
00099
00101 #define GV_TYPE_UNKNOWN                         0x00000000
00102
00103 #define GV_TYPE_TEXT                            0x00000100
00104
00105 #define GV_TYPE_NUMBER                          0x00000200
00106
00107 #define GV_TYPE_CHECKBOX                        0x00000300
00108
00109 #define GV_TYPE_SELECTION                       0x00000400
00110
00111 #define GV_TYPE_HEADER                          0x00000500
00112
00113 #define GV_TYPE_TABLEHEADER                     0x00000600
00114
00116 #define GV_TYPE_MASK                            0x0000FF00
00117
00119 #define GVS_WITHICON                            0x00010000
00120
00121 #define GVS_WITHCHECKBOX                        0x00020000
00122
00124 #define GVS_MULTLINE                          0x00100000
00125
00126 #define GVS_READONLY                            0x00200000
00127
00128 #define GVS_BOXCHECKED                          0x00400000
00129
00130 #define GVITEM_STYLE                            0x0001
00131 #define GVITEM_BGCOLOR                          0x0002
00132 #define GVITEM_FGCOLOR                          0x0004
00133 #define GVITEM_FONT                             0x0008
00134 #define GVITEM_IMAGE                            0x0010
00135 #define GVITEM_MAINCONTENT                      0x0020
00136 #define GVITEM_SIZE                             0x0040
00137
00138 #define GVITEM_ALLCONTENT                       0x00FF
00139
00141 typedef struct _GRIDCELLS
00142 {
00144     int row;
00146     int column;
00148     int width;
00150     int height;
00151 }GRIDCELLS;
00152
00153 typedef int (*GRIDCELLEVALCALLBACK)(GRIDCELLS* target, GRIDCELLS* source, DWORD dwAddData);
00154
00155 typedef struct _GRIDCELLDEPENDENCE
00156 {
00158     GRIDCELLS source;
00160     GRIDCELLS target;
00162     GRIDCELLEVALCALLBACK callback;
00164     DWORD dwAddData;
00165 }GRIDCELLDEPENDENCE;
00166
00168 typedef struct _GRIDCELLDATAHEADER
00169 {
00171     int size;
00173     char* buff;
00175     int len_buff;
00176 }GRIDCELLDATAHEADER;
00177
00179 typedef struct _GRIDCELLDATATEXT
00180 {
00182     char* buff;
00184     int len_buff;
00185 }GRIDCELLDATATEXT;
00186
00188 typedef struct _GRIDCELLDATANUMBER
00189 {
00191     double number;
00193     char* format;
00195     int len_format;
00196 }GRIDCELLDATANUMBER;
00197
00199 typedef struct _GRIDCELLDATACHECKBOX
00200 {
00202     BOOL checked;
00204     char* text;
00206     int len_text;
00207 }GRIDCELLDATACHECKBOX;
00208
00210 typedef struct _GRIDCELLDATASELECTION
00211 {
00213     int cur_index;
00215     char* selections;
00217     int len_sel;
00218 }GRIDCELLDATASELECTION;
00219
00220 #if 0
00221
00222 typedef struct _GRIDCELLDATAEVAL
00223 {
00225     double number;
00227     GRIDCELLS sourcecells;
00229     GRIDCELLEVALCALLBACK eval_callback;
00231     char* format;
00233     int len_format;
00234 }GRIDCELLDATAEVAL;
00235 #endif
00236
00238 typedef struct _GRIDCELLDATA
00239 {
00258     DWORD mask;
00259
00261     DWORD style;
00263     gal_pixel color_fg;
00265     gal_pixel color_bg;
00267     PLOGFONT font;
00269     PBITMAP image;
00271     void* content;
00272 }GRIDCELLDATA;
00273
00296 #define  GRIDM_SETCELLPROPERTY    0xF210
00297
00316 #define  GRIDM_GETCELLPROPERTY    0xF211
00317
00336 #define  GRIDM_SETCOLWIDTH       0xF212
00337
00355 #define  GRIDM_GETCOLWIDTH       0xF213
00356
00375 #define  GRIDM_SETROWHEIGHT      0xF214
00376
00394 #define  GRIDM_GETROWHEIGHT      0xF215
00395
00414 #define  GRIDM_ADDROW         0xF216
00415
00433 #define  GRIDM_DELROW         0xF217
00434
00452 #define  GRIDM_ADDCOLUMN      0xF218
00453
00470 #define  GRIDM_DELCOLUMN      0xF219
00471
00486 #define  GRIDM_GETROWCOUNT    0xF21A
00487
00502 #define  GRIDM_GETCOLCOUNT    0xF21B
00503
00523 #define  GRIDM_SETNUMFORMAT   0xF21C
00524
00543 #define  GRIDM_SETSELECTED    0xF21D
00544
00563 #define  GRIDM_GETSELECTED    0xF21E
00564
00584 #define  GRIDM_ADDDEPENDENCE    0xF21F
00585
00604 #define  GRIDM_DELDEPENDENCE    0xF220
00605
00606 /*TODO messages for query dependence */
00611 #define  GRIDM_ENDCELLEDIT      0xF221
00612
00625 #define  GRIDN_HEADLDOWN       1
00626
00631 #define  GRIDN_HEADLUP         2
00632
00636 #define  GRIDN_KEYDOWN         3
00637
00642 #define  GRIDN_CELLDBCLK       4
00643
00648 #define  GRIDN_CELLCLK         5
00649
00654 #define  GRIDN_FOCUSCHANGED    6
00655
00660 #define  GRIDN_CELLTEXTCHANGED 7
00661
00668 #ifdef  __cplusplus
00669 }
00670 #endif
00671
00672 #endif /* EXT_GRIDVIEW_H */
00673
Generated on Fri Dec 17 13:49:41 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Bitmap structure

Bitmap structure
[GDI functions]

Data Structures

  • struct _MYBITMAP
  • struct _BITMAP

Detailed Description

MiniGUI uses a MYBITMAP structure to represent a device-independent bitmap, and BITMAP structure to represent a device-dependent bitmap.
Generated on Fri Dec 17 13:49:48 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Standard controls

Standard controls

Modules

  • ANIMATION control and animation GIF (GIF87a/GIF89a) support
  • Button control
  • ComboBox control
  • CoolBar control
  • Edit/MEdit control
  • GridView control
  • IconView control
  • ListBox control
  • ListView control
  • MenuButton control
  • MonthCalendar control
  • NewToolBar control
  • ProgressBar control
  • PropertySheet control
  • ScrollBar control
  • ScrollView control
  • SpinBox control
  • Static control
  • TextEdit control
  • TrackBar control
  • TreeView control
Generated on Fri Dec 17 13:49:45 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Messages of textedit control

Messages of textedit control
[TextEdit control]

Generated on Fri Dec 17 13:49:47 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Notification codes of textedit control

Notification codes of textedit control
[TextEdit control]

Generated on Fri Dec 17 13:49:47 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Styles of textedit control

Styles of textedit control
[TextEdit control]

Generated on Fri Dec 17 13:49:47 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Global/general functions

Global/general functions
[Functions]

Modules

  • General read/write operations
  • Endian specific read/write interfaces
  • Fixed point math functions
  • Block data heap operations
  • MiniGUI-Processes specific functions
  • Miscellaneous functions
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Global variables

Global variables

Modules

  • System colors and pixel values.
  • Global Rectangles
  • MiniGUI-Processes specific variables
  • x virtual framebuffer
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: MiniGUI-Processes specific functions

MiniGUI-Processes specific functions
[Global/general functions]

Modules

  • Listening a file descriptor
  • Initialization and termination functions
  • Mouse calibration.
  • About MiniGUI dialog
  • Configuration file operations
  • Length-Fixed string operations
  • Cursor operations
  • Asynchronous key status functions
  • Internationlization of system text
  • String operation helpers
  • ClipBoard Operations
  • Miscellaneous functions
Generated on Fri Dec 17 13:49:48 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Macros and data types commonly used

Macros and data types commonly used

Modules

  • Version information
  • Basic data types
  • Endianness information
  • Simple and common types and macros
  • MiniGUI handles
  • Win32-like data types and macros
  • Data types for GDI
  • Macros for key codes and shift status
  • Error codes
  • Miscellaneous macros
Generated on Fri Dec 17 13:49:45 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Internal menu messages

Internal menu messages
[Messages]

Generated on Fri Dec 17 13:49:49 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Message functions

Message functions
[Functions]

Modules

  • Message passing functions
  • Message or event hook functions
Generated on Fri Dec 17 13:49:49 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Messages

Messages

Modules

  • Mouse event messages
  • Key event messages
  • User-machine Interaction messages
  • Window creation messages
  • Window painting messages
  • Internal desktop messages
  • Internal window management messages
  • Dialog and control messages
  • System messages
  • Internal menu messages
  • User-defined messages
Generated on Fri Dec 17 13:49:49 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Windowing functions

Windowing functions
[Functions]

Modules

  • Window creating/destroying
Generated on Fri Dec 17 13:49:50 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Internal window management messages

Internal window management messages
[Messages]

Generated on Fri Dec 17 13:49:49 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: iconview.h Source File

include » ctrl

iconview.h

Go to the documentation of this file.
00001
00019 /*
00020  * $Id: iconview.h 12037 2009-08-13 01:25:52Z houhuihua $
00021  *
00022  *             MiniGUI for Linux/uClinux, eCos, uC/OS-II, VxWorks,
00023  *                     pSOS, ThreadX, NuCleus, OSE, and Win32.
00024  *
00025  *             Copyright (C) 2002-2008 Feynman Software.
00026  *             Copyright (C) 1998-2002 Wei Yongming.
00027  */
00028
00029 #ifndef EXT_ICONVIEW_H
00030 #define EXT_ICONVIEW_H
00031
00032
00033 #ifdef  __cplusplus
00034 extern "C" {
00035 #endif
00036
00050 #define CTRL_ICONVIEW       ("IconView")
00051
00053 #define IV_OKAY                 0
00054
00055 #define IV_ERR                  (-1)
00056
00057 #define IV_ERRSPACE             (-2)
00058
00063 typedef GHANDLE HIVITEM;
00064
00069 typedef struct _IVITEMINFO
00070 {
00074     int nItem;
00075
00079     PBITMAP bmp;
00080
00084     const char *label;
00085
00087     DWORD addData;
00088
00092     DWORD dwFlags;
00093
00094 } IVITEMINFO;
00095 typedef IVITEMINFO* PIVITEMINFO;
00096
00098 #define IVFLAG_BITMAP   0x0001
00099
00100 #define IVFLAG_ICON     0x0002
00101
00102
00109 MG_EXPORT int iconview_is_item_hilight (HWND hWnd, GHANDLE hivi);
00110
00117 MG_EXPORT PBITMAP iconview_get_item_bitmap (GHANDLE hivi);
00118
00125 MG_EXPORT const char* iconview_get_item_label (GHANDLE hivi);
00126
00133 MG_EXPORT DWORD iconview_get_item_adddata (GHANDLE hivi);
00134
00135 MG_EXPORT GHANDLE iconview_get_item(HWND hwnd, int index);
00136
00137 MG_EXPORT BOOL iconview_set_item_lable(GHANDLE hivi, const char* strLable);
00138
00139 MG_EXPORT PBITMAP iconview_set_item_bitmap(GHANDLE hivi, PBITMAP pbmp);
00140
00141
00147 /* reserved */
00153 #define IVS_NOTIFY              SVS_NOTIFY
00154
00160 #define IVS_UPNOTIFY            SVS_UPNOTIFY
00161
00167 #define IVS_AUTOSORT            SVS_AUTOSORT
00168
00174 #define IVS_LOOP                SVS_LOOP
00175
00176
00201 #define IVM_ADDITEM            0xF300
00202
00224 #define IVM_SETITEMSIZE           0xF436
00225
00226
00231 #define IVM_RESETCONTENT        SVM_RESETCONTENT
00232
00236 #define IVM_DELITEM             SVM_DELITEM
00237
00241 #define IVM_SETITEMDRAW         SVM_SETITEMDRAW
00242
00246 #define IVM_SETCONTWIDTH        SVM_SETCONTWIDTH
00247
00251 #define IVM_SETCONTHEIGHT       SVM_SETCONTHEIGHT
00252
00256 #define IVM_SETITEMOPS          SVM_SETITEMOPS
00257
00261 #define IVM_GETMARGINS          SVM_GETMARGINS
00262
00266 #define IVM_SETMARGINS          SVM_SETMARGINS
00267
00271 #define IVM_GETLEFTMARGIN       SVM_GETLEFTMARGIN
00272
00276 #define IVM_GETTOPMARGIN        SVM_GETTOPMARGIN
00277
00281 #define IVM_GETRIGHTMARGIN      SVM_GETRIGHTMARGIN
00282
00286 #define IVM_GETBOTTOMMARGIN     SVM_GETBOTTOMMARGIN
00287
00291 #define IVM_GETVISIBLEWIDTH     SVM_GETVISIBLEWIDTH
00292
00296 #define IVM_GETVISIBLEHEIGHT    SVM_GETVISIBLEHEIGHT
00297
00301 #define IVM_GETCONTWIDTH        SVM_GETCONTWIDTH
00302
00306 #define IVM_GETCONTHEIGHT       SVM_GETCONTHEIGHT
00307
00311 #define IVM_SETCONTRANGE        SVM_SETCONTRANGE
00312
00316 #define IVM_GETCONTENTX         SVM_GETCONTENTX
00317
00321 #define IVM_GETCONTENTY         SVM_GETCONTENTY
00322
00326 #define IVM_SETCONTPOS          SVM_SETCONTPOS
00327
00331 #define IVM_GETCURSEL           SVM_GETCURSEL
00332
00336 #define IVM_SELECTITEM          SVM_SELECTITEM
00337
00341 #define IVM_SHOWITEM            SVM_SHOWITEM
00342
00346 #define IVM_CHOOSEITEM          SVM_CHOOSEITEM
00347
00351 #define IVM_SETCURSEL           SVM_SETCURSEL
00352
00356 #define IVM_SETITEMINIT         SVM_SETITEMINIT
00357
00361 #define IVM_SETITEMDESTROY      SVM_SETITEMDESTROY
00362
00366 #define IVM_SETITEMCMP          SVM_SETITEMCMP
00367
00371 #define IVM_MAKEPOSVISIBLE      SVM_MAKEPOSVISIBLE
00372
00376 #define IVM_GETHSCROLLVAL       SVM_GETHSCROLLVAL
00377
00381 #define IVM_GETVSCROLLVAL       SVM_GETVSCROLLVAL
00382
00386 #define IVM_GETHSCROLLPAGEVAL   SVM_GETHSCROLLPAGEVAL
00387
00391 #define IVM_GETVSCROLLPAGEVAL   SVM_GETVSCROLLPAGEVAL
00392
00396 #define IVM_SETSCROLLVAL        SVM_SETSCROLLVAL
00397
00401 #define IVM_SETSCROLLPAGEVAL    SVM_SETSCROLLPAGEVAL
00402
00406 #define IVM_SORTITEMS           SVM_SORTITEMS
00407
00411 #define IVM_GETITEMCOUNT        SVM_GETITEMCOUNT
00412
00416 #define IVM_GETITEMADDDATA      SVM_GETITEMADDDATA
00417
00421 #define IVM_SETITEMADDDATA      SVM_SETITEMADDDATA
00422
00426 #define IVM_REFRESHITEM         SVM_REFRESHITEM
00427
00431 #define IVM_GETFIRSTVISIBLEITEM SVM_GETFIRSTVISIBLEITEM
00432
00444 #define IVN_CLICKED            SVN_CLICKED
00445
00450 #define IVN_SELCHANGED         SVN_SELCHANGED
00451
00452
00459 #ifdef  __cplusplus
00460 }
00461 #endif
00462
00463 #endif /* EXT_ICONVIEW_H */
00464
Generated on Fri Dec 17 13:49:41 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Main Page

MiniGUI V3.0.10 API Reference Documentation

Generated on Fri Dec 17 13:49:40 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: listbox.h Source File

include » ctrl

listbox.h

Go to the documentation of this file.
00001
00019 /*
00020  * $Id: listbox.h 10690 2008-08-18 09:32:47Z weiym $
00021  *
00022  *             MiniGUI for Linux/uClinux, eCos, uC/OS-II, VxWorks,
00023  *                     pSOS, ThreadX, NuCleus, OSE, and Win32.
00024  *
00025  *             Copyright (C) 2002-2008 Feynman Software.
00026  *             Copyright (C) 1999-2002 Wei Yongming.
00027  */
00028
00029 #ifndef _MGUI_CTRL_LISTBOX_H
00030 #define _MGUI_CTRL_LISTBOX_H
00031
00032
00033 #ifdef __cplusplus
00034 extern "C" {
00035 #endif  /* __cplusplus */
00036
00051 #define CTRL_LISTBOX        ("listbox")
00052
00054 #define LB_OKAY                 0
00055
00056 #define LB_ERR                  (-3)
00057
00058 #define LB_ERRSPACE             (-2)
00059
00060 #define CMFLAG_BLANK            0x0000
00061 #define CMFLAG_CHECKED          0x0001
00062 #define CMFLAG_PARTCHECKED      0x0002
00063
00069 #define CMFLAG_MASK             0x000F
00070
00075 #define IMGFLAG_BITMAP          0x0010
00076
00082 #define LBIS_SIGNIFICANT        0x0020
00083
00085 typedef struct _LISTBOXITEMINFO
00086 {
00088     char* string;
00089
00106     DWORD   cmFlag;         /* check mark flag */
00107
00109     HICON   hIcon;          /* handle to icon */
00110 } LISTBOXITEMINFO;
00111
00116 typedef LISTBOXITEMINFO* PLISTBOXITEMINFO;
00117
00130 #define LBS_NOTIFY              0x0001L
00131
00139 #define LBS_SORT                0x0002L
00140
00145 #define LBS_MULTIPLESEL         0x0008L
00146
00151 #define LBS_CHECKBOX            0x1000L
00152
00157 #define LBS_USEICON             0x2000L
00158
00165 #define LBS_AUTOCHECK           0x4000L
00166
00172 #define LBS_AUTOCHECKBOX        (LBS_CHECKBOX | LBS_AUTOCHECK)
00173
00178 #define LBS_SBALWAYS            0x8000L
00179
00185 #define LBS_MOUSEFOLLOW         0x0010L
00186 #if 0
00187 #define LBS_OWNERDRAWFIXED      0x0010L
00188 #define LBS_OWNERDRAWVARIABLE   0x0020L
00189 #define LBS_USETABSTOPS         0x0080L
00190 #define LBS_MULTICOLUMN         0x0200L
00191 #define LBS_WANTKEYBOARDINPUT   0x0400L
00192 #define LBS_NOREDRAW            0x0004L
00193 #define LBS_HASSTRINGS          0x0040L
00194 #define LBS_NOINTEGRALHEIGHT    0x0100L
00195 #define LBS_EXTENDEDSEL         0x0800L
00196 #endif
00197
00244 #define LB_ADDSTRING            0xF180
00245
00289 #define LB_INSERTSTRING         0xF181
00290
00310 #define LB_DELETESTRING         0xF182
00311
00316 #define LB_SELITEMRANGEEX       0xF183
00317
00334 #define LB_RESETCONTENT         0xF184
00335
00358 #define LB_GETSEL               0xF187
00359
00385 #define LB_SETSEL               0xF185
00386
00406 #define LB_GETCURSEL            0xF188
00407
00428 #define LB_SETCURSEL            0xF186
00429
00456 #define LB_GETTEXT              0xF189
00457
00477 #define LB_GETTEXTLEN           0xF18A
00478
00495 #define LB_GETCOUNT             0xF18B
00496
00501 #define LB_SELECTSTRING         0xF18C
00502
00507 #define LB_DIR                  0xF18D
00508
00526 #define LB_GETTOPINDEX          0xF18E
00527
00552 #define LB_FINDSTRING           0xF18F
00553
00570 #define LB_GETSELCOUNT          0xF190
00571
00594 #define LB_GETSELITEMS          0xF191
00595
00600 #define LB_SETTABSTOPS          0xF192
00601
00606 #define LB_GETHORIZONTALEXTENT  0xF193
00607
00612 #define LB_SETHORIZONTALEXTENT  0xF194
00613
00618 #define LB_SETCOLUMNWIDTH       0xF195
00619
00624 #define LB_ADDFILE              0xF196
00625
00647 #define LB_SETTOPINDEX          0xF197
00648
00672 #define LB_GETITEMRECT          0xF198
00673
00701 #define LB_GETITEMDATA          0xF199
00702
00730 #define LB_SETITEMDATA          0xF19A
00731
00732 #define LB_SELITEMRANGE         0xF19B
00733 #define LB_SETANCHORINDEX       0xF19C
00734 #define LB_GETANCHORINDEX       0xF19D
00735
00751 #define LB_SETCARETINDEX        0xF19E
00752
00770 #define LB_GETCARETINDEX        0xF19F
00771
00791 #define LB_SETITEMHEIGHT        0xF1A0
00792
00809 #define LB_GETITEMHEIGHT        0xF1A1
00810
00832 #define LB_FINDSTRINGEXACT      0xF1A2
00833
00838 #define LB_SETLOCALE            0xF1A5
00839
00843 #define LB_GETLOCALE            0xF1A6
00844
00848 #define LB_SETCOUNT             0xF1A7
00849
00853 #define LB_INITSTORAGE          0xF1A8
00854
00858 #define LB_ITEMFROMPOINT        0xF1A9
00859
00880 #define LB_SETTEXT              0xF1AA
00881
00903 #define LB_GETCHECKMARK         0xF1AB
00904
00928 #define LB_SETCHECKMARK         0xF1AC
00929
00953 #define LB_GETITEMADDDATA       0xF1AD
00954
00978 #define LB_SETITEMADDDATA       0xF1AE
00979
01009 #define LB_SETSTRCMPFUNC        0xF1AF
01010
01027 #define LB_SETITEMDISABLE       0xF1B0
01028
01045 #define LB_GETITEMDISABLE       0xF1B1
01046
01063 #define LB_SETITEMBOLD          0xF1B2
01064
01107 #define LB_MULTIADDITEM         0xF1B3
01108
01109 #define LB_MSGMAX               0xF1B4
01110
01125 #define LBN_ERRSPACE            255
01126
01135 #define LBN_SELCHANGE           1
01136
01144 #define LBN_DBLCLK              2
01145
01154 #define LBN_SELCANCEL           3
01155
01163 #define LBN_SETFOCUS            4
01164
01172 #define LBN_KILLFOCUS           5
01173
01178 #define LBN_CLICKCHECKMARK      6
01179
01184 #define LBN_CLICKED             7
01185
01190 #define LBN_ENTER               8
01191
01198 #ifdef __cplusplus
01199 }
01200 #endif  /* __cplusplus */
01201
01202 #endif /* _MGUI_CTRL_LISTBOX_H */
01203
Generated on Fri Dec 17 13:49:41 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: listview.h Source File

include » ctrl

listview.h

Go to the documentation of this file.
00001
00019 /*
00020  * $Id: listview.h 12044 2009-08-13 03:08:06Z houhuihua $
00021  *
00022  *             MiniGUI for Linux/uClinux, eCos, uC/OS-II, VxWorks,
00023  *                     pSOS, ThreadX, NuCleus, OSE, and Win32.
00024  *
00025  *             Copyright (C) 2002-2008 Feynman Software.
00026  *             Copyright (C) 1998-2002 Wei Yongming.
00027  */
00028
00029 #ifndef EXT_LISTVIEW_H
00030 #define EXT_LISTVIEW_H
00031
00032
00033 #ifdef  __cplusplus
00034 extern "C" {
00035 #endif
00036
00051 #define CTRL_LISTVIEW       ("ListView")
00052
00054 #define LV_OKAY                 0
00055
00056 #define LV_ERR                  (-1)
00057
00058 #define LV_ERRSPACE             (-2)
00059
00064 typedef GHANDLE HLVITEM;
00065
00070 #define LVIF_FOLD               0x0001L
00071
00076 typedef struct _LVITEM
00077 {
00081     int nItem;
00083     int nItemHeight;
00085     DWORD itemData;
00086
00096     DWORD dwFlags;
00097
00098 } LVITEM;
00099
00101 typedef LVITEM *PLVITEM;
00102
00104 #define LVFLAG_BITMAP   0x0001
00105
00106 #define LVFLAG_ICON         0x0002
00107
00112 typedef struct _LVSUBITEM
00113 {
00121     DWORD flags;
00123     int nItem;
00125     int subItem;
00127     char *pszText;
00129     int nTextMax;
00131     int nTextColor;
00133     DWORD image;
00134 } LVSUBITEM;
00136 typedef LVSUBITEM *PLVSUBITEM;
00137
00139 typedef struct _LVSORTDATA
00140 {
00142     int ncol;
00144     int losorted;
00146     HWND hLV;
00147 } LVSORTDATA;
00149 typedef LVSORTDATA *PLVSORTDATA;
00150
00152 typedef int (*PFNLVCOMPARE) (HLVITEM nItem1, HLVITEM nItem2, PLVSORTDATA sortData);
00153
00154 typedef GHANDLE HLVHDR;
00155 typedef GHANDLE HLVHDRITEM;
00156
00158 /* hlvhdr is reserved for extension */
00159 typedef void (*PFN_LVHDR_BKDRAWFUNC)   (HWND hWnd, HLVHDR hlvhdr, HDC hdc, RECT *rcDraw);
00161 typedef void (*PFN_LVHDR_ITEMDRAWFUNC) (HWND hWnd, int idx, HDC hdc, RECT *rcDraw);
00162
00163
00165 typedef struct _LVCUSTOMDRAWFUNCS
00166 {
00168     PFN_LVHDR_BKDRAWFUNC   pfnDrawHdrBk;
00170     PFN_LVHDR_ITEMDRAWFUNC pfnDrawHdrItem;
00171 } LVCUSTOMDRAWFUNCS;
00172
00173
00176 #define LVCF_LEFTALIGN          0x0000
00177
00178 #define LVCF_RIGHTALIGN         0x0001
00179
00180 #define LVCF_CENTERALIGN        0x0002
00181
00182 #define LVCF_TREEVIEW           0x0004
00183
00186 #define LVHF_LEFTALIGN          0x0000
00187
00188 #define LVHF_RIGHTALIGN         0x0004
00189
00190 #define LVHF_CENTERALIGN        0x0008
00191
00196 typedef struct _LVCOLUMN
00197 {
00199     int nCols;
00201     int width;
00203     char *pszHeadText;
00205     int nTextMax;
00207     DWORD image;
00209     PFNLVCOMPARE pfnCompare;
00211     DWORD colFlags;
00212 } LVCOLUMN;
00214 typedef LVCOLUMN *PLVCOLUMN;
00215
00218 #define LVFF_TEXT       0x0001
00219
00220 #define LVFF_ADDDATA    0x0002
00221
00223 typedef struct _LVFINDINFO
00224 {
00233     DWORD flags;
00235     int iStart;
00237     int nCols;
00239     char **pszInfo;
00241     DWORD addData;
00242
00244     int nItem;
00246     int nSubitem;
00247
00248 } LVFINDINFO;
00250 typedef LVFINDINFO *PLVFINDINFO;
00251
00253 typedef struct _LVNM_NORMAL
00254 {
00256     WPARAM wParam;
00258     LPARAM lParam;
00259 } LVNM_NORMAL;
00261 typedef LVNM_NORMAL *PLVNM_NORMAL;
00262
00264 typedef LVNM_NORMAL LVNM_KEYDOWN;
00266 typedef LVNM_KEYDOWN *PLVNM_KEYDOWN;
00267
00269 typedef LVNM_NORMAL LVNM_HEADRDOWN;
00271 typedef LVNM_HEADRDOWN *PLVNM_HEADRDOWN;
00272
00274 typedef LVNM_NORMAL LVNM_HEADRUP;
00276 typedef LVNM_HEADRUP *PLVNM_HEADUP;
00277
00279 typedef LVNM_NORMAL LVNM_ITEMRDOWN;
00281 typedef LVNM_ITEMRDOWN *PLVNM_ITEMRDOWN;
00282
00284 typedef LVNM_NORMAL LVNM_ITEMRUP;
00286 typedef LVNM_ITEMRUP *PLVNM_ITEMRUP;
00287
00300 #define LVS_UPNOTIFY            0x0001L             /* must be the same with SVS_UPNOTIFY */
00301 #define LVS_NOTIFY              LVS_UPNOTIFY
00302
00309 #define LVS_SORT                0x0002L
00310
00315 #define LVS_MULTIPLESEL         0x0008L              /* reserved */
00316
00321 #define LVS_CHECKBOX            0x1000L              /* reserved */
00322
00329 #define LVS_AUTOCHECK           0x2000L              /* reserved */
00330
00335 #define LVS_AUTOCHECKBOX        (LVS_CHECKBOX | LVS_AUTOCHECK)    /* reserved */
00336
00341 #define LVS_TREEVIEW            0x4000L
00342
00343 #define LVS_WITHGRID            0x8000L
00344
00373 #define LVM_ADDITEM            0xF110
00374
00397 #define LVM_FILLSUBITEM        0xF111
00398
00414 #define LVM_ADDCOLUMN          0xF112
00415
00434 #define LVM_DELITEM            0xF113
00435
00458 #define LVM_CLEARSUBITEM       0xF114
00459
00475 #define LVM_DELCOLUMN          0xF115
00476
00492 #define LVM_COLSORT            0xF116
00493
00516 #define LVM_SETSUBITEMCOLOR       0xF117
00517
00535 #define LVM_FINDITEM           0xF118
00536
00561 #define LVM_GETSUBITEMTEXT         0xF119
00562
00576 #define LVM_GETITEMCOUNT       0xF11A
00577
00591 #define LVM_GETCOLUMNCOUNT     0xF11B
00592
00606 #define LVM_GETSELECTEDITEM    0xF11C
00607
00621 #define LVM_DELALLITEM           0xF11D
00622
00638 #define LVM_MODIFYHEAD           0xF11E
00639
00658 #define LVM_SELECTITEM          0xF11F
00659
00660
00679 #define LVM_SHOWITEM            0xF120
00680
00703 #define LVM_GETSUBITEMLEN       0xF121
00704
00721 #define LVM_SETCOLUMN           0xF122
00722
00745 #define LVM_SETSUBITEMTEXT      0xF123
00746
00769 #define LVM_SETSUBITEM          0xF124
00770
00790 #define LVM_GETCOLUMN           0xF125
00791
00808 #define LVM_GETCOLUMNWIDTH      0xF126
00809
00830 #define LVM_GETITEM             0xF127
00831
00851 #define LVM_GETITEMSTATE        0xF128
00852
00866 #define LVM_GETSELECTEDCOLUMN   0xF129
00867
00881 #define LVM_GETSELECTEDCOUNT    0xF130
00882
00896 #define LVM_GETTOPVISIBLE       0xF131
00897
00902 #define LVM_NULL                0xF132
00903
00908 #define LVM_SETITEMSTATE        0xF133
00909
00944 #define LVM_SORTITEMS           0xF134
00945
00964 #define LVM_SETITEMHEIGHT       0xF135
00965
00981 #define LVM_SETHEADHEIGHT       0xF136
00982
01008 #define LVM_GETITEMADDDATA       0xF137
01009
01034 #define LVM_SETITEMADDDATA       0xF138
01035
01054 #define LVM_CHOOSEITEM          0xF139
01055
01085 #define LVM_SETSTRCMPFUNC       0xF140
01086
01087 #define LVIR_PARENT             1
01088 #define LVIR_FIRSTCHILD         2
01089 #define LVIR_NEXTSIBLING        3
01090 #define LVIR_PREVSIBLING        4
01091
01120 #define LVM_GETRELATEDITEM      0xF141
01121
01140 #define LVM_FOLDITEM            0xF142
01141
01158 #define LVM_SETCUSTOMDRAW       0xF143
01159
01176 #define LVM_GETSELECTEDITEMRECT  0xF144
01177
01178
01179
01190 #define LVN_CLICKED            1    /* must be the same as SVN_CLICKED */
01191
01197 #define LVN_SELCHANGE          2    /* must be the same as SVN_SELCHANGED */
01198
01204 #define LVN_ITEMRDOWN          4
01205
01211 #define LVN_ITEMRUP            5
01212
01218 #define LVN_HEADRDOWN          6
01219
01225 #define LVN_HEADRUP            7
01226
01231 #define LVN_KEYDOWN            8
01232
01239 #define LVN_ITEMDBCLK          9
01240
01246 #define LVN_ITEMCLK            10
01247
01253 #define LVN_COLCHANGE          11
01254
01260 #define LVN_FOLDED             12
01261
01267 #define LVN_UNFOLDED           13
01268
01274 #ifdef  __cplusplus
01275 }
01276 #endif
01277
01278 #endif /* EXT_LISTVIEW_H */
01279
Generated on Fri Dec 17 13:49:41 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: menubutton.h Source File

include » ctrl

menubutton.h

Go to the documentation of this file.
00001
00019 /*
00020  * $Id: menubutton.h 10690 2008-08-18 09:32:47Z weiym $
00021  *
00022  *             MiniGUI for Linux/uClinux, eCos, uC/OS-II, VxWorks,
00023  *                     pSOS, ThreadX, NuCleus, OSE, and Win32.
00024  *
00025  *             Copyright (C) 2002-2008 Feynman Software.
00026  *             Copyright (C) 1999-2002 Wei Yongming.
00027  */
00028
00029 #ifndef _MGUI_CTRL_MENUBUTTON_H
00030 #define _MGUI_CTRL_MENUBUTTON_H
00031
00032
00033 #ifdef __cplusplus
00034 extern "C" {
00035 #endif  /* __cplusplus */
00036
00051 #define CTRL_MENUBTN        ("menubutton")
00052
00057 #define CTRL_MENUBUTTON     ("menubutton")
00058
00060 #define MB_OKAY                 0
00061
00062 #define MB_ERR                  -1
00063
00064 #define MB_INV_ITEM             -2
00065
00066 #define MB_ERR_SPACE            -3
00067
00069 #define MB_WHICH_TEXT           0x01
00070
00071 #define MB_WHICH_BMP            0x02
00072
00073 #define MB_WHICH_ATTDATA        0x04
00074
00076 typedef struct _MENUBUTTONITEM
00077 {
00086     DWORD           which;
00088     const char*     text;
00090     PBITMAP         bmp;
00092     DWORD           data;
00093 } MENUBUTTONITEM;
00094
00099 typedef MENUBUTTONITEM* PMENUBUTTONITEM;
00100
00111 #define MBS_SORT                0x0001
00112
00117 #define MBS_LEFTARROW           0x0002
00118
00123 #define MBS_NOBUTTON            0x0004
00124
00129 #define MBS_ALIGNLEFT           0x0000
00130
00135 #define MBS_ALIGNRIGHT          0x0010
00136
00141 #define MBS_ALIGNCENTER         0x0020
00142
00147 #define MBS_ALIGNMASK           0x00F0
00148
00181 #define MBM_ADDITEM                 0xF200
00182
00199 #define MBM_DELITEM                 0xF201
00200
00214 #define MBM_RESETCTRL               0xF202
00215
00238 #define MBM_SETITEMDATA             0xF203
00239
00259 #define MBM_GETITEMDATA             0xF204
00260
00275 #define MBM_GETCURITEM              0xF206
00276
00293 #define MBM_SETCURITEM              0xF207
00294
00324 #define MBM_SETSTRCMPFUNC           0xF208
00325
00326 /* Internal */
00327 #define MBM_MSGMAX                  0xF210
00328
00340 #define MBN_ERRSPACE            255
00341
00346 #define MBN_CHANGED             1
00347
00352 #define MBN_SELECTED            2
00353
00358 #define MBN_STARTMENU           4
00359
00364 #define MBN_ENDMENU             5
00365
00370 #define MBN_CLICKED             6
00371
00378 #ifdef __cplusplus
00379 }
00380 #endif  /* __cplusplus */
00381
00382 #endif /* _MGUI_CTRL_MENUBUTTON_H */
00383
Generated on Fri Dec 17 13:49:41 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: minigui.h Source File

include

minigui.h

Go to the documentation of this file.
00001
00021 /*
00022  * $Id: minigui.h 13368 2010-08-30 09:25:11Z wanzheng $
00023  *
00024  *             MiniGUI for Linux/uClinux, eCos, uC/OS-II, VxWorks,
00025  *                     pSOS, ThreadX, NuCleus, OSE, and Win32.
00026  *
00027  *             Copyright (C) 2002-2009 Feynman Software.
00028  *             Copyright (C) 1998-2002 Wei Yongming.
00029  */
00030
00031 #ifndef _MGUI_MINIGUI_H
00032   #define _MGUI_MINIGUI_H
00033
00034 #include <stdio.h>
00035
00036
00037 #ifdef __cplusplus
00038 extern "C" {
00039 #endif  /* __cplusplus */
00040
00055 extern MG_EXPORT RECT g_rcScr;
00056
00065 #define g_rcDesktop     g_rcScr
00066
00074 #ifdef _MGRM_PROCESSES
00075
00076 #include <sys/types.h>
00077
00085 extern MG_EXPORT BOOL mgIsServer;
00086
00096 extern MG_EXPORT void* mgSharedRes;
00097
00106 extern MG_EXPORT size_t mgSizeRes;
00107
00112 #define LEN_LAYER_NAME      14
00113
00118 #define LEN_CLIENT_NAME     14
00119
00124 #define INV_LAYER_HANDLE    0
00125
00126 struct _MG_Layer;
00127
00129 typedef struct _MG_Client
00130 {
00132     char    name [LEN_CLIENT_NAME + 1];
00133
00135     pid_t   pid;
00137     uid_t   uid;
00139     int     fd;
00140
00142     BOOL    has_dirty;
00144     DWORD   last_live_time;
00146     DWORD   dwAddData;
00147
00149     struct  _MG_Client* next;
00151     struct  _MG_Client* prev;
00152
00154     struct  _MG_Layer* layer;
00155
00157     struct GlobalRes* global_res;
00158 } MG_Client;
00159
00161 typedef struct _MG_Layer
00162 {
00164     char    name [LEN_LAYER_NAME + 1];
00165
00167     DWORD   dwAddData;
00168
00170     MG_Client* cli_head;
00172     MG_Client* cli_active;
00173
00175     struct _MG_Layer* next;
00177     struct _MG_Layer* prev;
00178
00180     void* zorder_info;
00182     int   zorder_shmid;
00183 } MG_Layer;
00184
00185 /*screen attr type*/
00186 #define SCREEN_ATTR_ALPHA_CHANNEL    0x01      //alpha channel
00187 #define SCREEN_ATTR_COLORKEY         0x02      //colorkey
00188 #define SCREEN_ATTR_COLORSPACE       0x03      //colorspace
00189 #define SCREEN_ATTR_ALPHA            0x04
00190 #define SCREEN_NO_EXIST              -99       //screen don't exist
00191
00198 extern MG_EXPORT int mgClientSize;
00199
00210 extern MG_EXPORT MG_Client* mgClients;
00211
00218 extern MG_EXPORT MG_Layer* mgTopmostLayer;
00219
00226 extern MG_EXPORT MG_Layer* mgLayers;
00227
00228 #endif /* _MGRM_PROCESSES */
00229
00242 MG_EXPORT int GUIAPI InitGUI (int, const char **);
00243
00251 MG_EXPORT void GUIAPI TerminateGUI (int not_used);
00252
00262 MG_EXPORT void GUIAPI MiniGUIPanic (int exitcode);
00263
00279 #ifndef _MGRM_THREADS
00280
00303 #define MAX_NR_LISTEN_FD   5
00304
00305 #ifdef WIN32
00306 #ifndef POLLIN
00307 #define POLLIN  0x001
00308 #endif
00309
00310 #ifndef POLLOUT
00311 #define POLLOUT 0x004
00312 #endif
00313
00314 #ifndef POLLERR
00315 #define POLLERR 0x008
00316 #endif
00317
00318 #endif
00319
00346 MG_EXPORT BOOL GUIAPI RegisterListenFD (int fd, int type,
00347                 HWND hwnd, void* context);
00348
00363 MG_EXPORT BOOL GUIAPI UnregisterListenFD (int fd);
00364
00367 #ifdef _MGRM_PROCESSES
00368
00386 #define NAME_SELF_LAYER         ""
00387
00392 #define NAME_TOPMOST_LAYER      ""
00393
00398 #define NAME_DEF_LAYER          "mginit"
00399
00434 MG_EXPORT GHANDLE GUIAPI JoinLayer (const char* layer_name,
00435                 const char* client_name,
00436                 int max_nr_topmosts, int max_nr_normals);
00437
00462 MG_EXPORT GHANDLE GUIAPI GetLayerInfo (const char* layer_name,
00463                 int* nr_clients, BOOL* is_topmost, int* cli_active);
00464
00482 MG_EXPORT BOOL GUIAPI SetTopmostLayer (BOOL handle_name,
00483                 GHANDLE handle, const char* name);
00484
00502 MG_EXPORT BOOL GUIAPI DeleteLayer (BOOL handle_name,
00503                         GHANDLE handle, const char* layer_name);
00504
00526 typedef int (* ON_LOCK_CLIENT_REQ) (void);
00527
00528
00535 typedef int (* ON_TRYLOCK_CLIENT_REQ) (void);
00536
00543 typedef void (* ON_UNLOCK_CLIENT_REQ) (void);
00544
00553 extern MG_EXPORT ON_LOCK_CLIENT_REQ  OnLockClientReq;
00554
00563 extern MG_EXPORT ON_TRYLOCK_CLIENT_REQ  OnTrylockClientReq;
00572 extern MG_EXPORT ON_UNLOCK_CLIENT_REQ  OnUnlockClientReq;
00573
00574 #define LCO_NEW_CLIENT      1
00575 #define LCO_DEL_CLIENT      2
00576
00583 typedef void (* ON_NEW_DEL_CLIENT) (int op, int cli);
00584
00585 #define LCO_NEW_LAYER       1
00586 #define LCO_DEL_LAYER       2
00587 #define LCO_JOIN_CLIENT     3
00588 #define LCO_REMOVE_CLIENT   4
00589 #define LCO_TOPMOST_CHANGED 5
00590 #define LCO_ACTIVE_CHANGED  6
00591
00599 typedef void (* ON_CHANGE_LAYER) (int op, MG_Layer* layer,
00600                 MG_Client* client);
00601
00602 #define ZNOP_ALLOCATE   1
00603 #define ZNOP_FREE       2
00604 #define ZNOP_MOVE2TOP   3
00605 #define ZNOP_SHOW       4
00606 #define ZNOP_HIDE       5
00607 #define ZNOP_MOVEWIN    6
00608 #define ZNOP_SETACTIVE  7
00609
00610 #define ZNOP_ENABLEWINDOW        11
00611 #define ZNOP_DISABLEWINDOW       12
00612 #define ZNOP_STARTDRAG           13
00613 #define ZNOP_CANCELDRAG          14
00614 #define ZNOP_CHANGECAPTION       15
00615
00622 typedef void (* ON_ZNODE_OPERATION) (int op, int cli, int idx_znode);
00623
00647 extern MG_EXPORT ON_NEW_DEL_CLIENT OnNewDelClient;
00648
00678 extern MG_EXPORT ON_CHANGE_LAYER OnChangeLayer;
00679
00722 extern MG_EXPORT ON_ZNODE_OPERATION OnZNodeOperation;
00723
00750 MG_EXPORT BOOL GUIAPI ServerStartup (int nr_globals,
00751                 int def_nr_topmosts, int def_nr_normals);
00752
00780 MG_EXPORT MG_Layer* GUIAPI ServerCreateLayer (const char* layer_name,
00781                 int max_nr_topmosts, int max_nr_normals);
00782
00797 MG_EXPORT BOOL GUIAPI ServerSetTopmostLayer (MG_Layer* layer);
00798
00813 MG_EXPORT BOOL GUIAPI ServerDeleteLayer (MG_Layer* layer);
00814
00839 MG_EXPORT int GUIAPI ServerGetNextZNode (MG_Layer* layer, int idx_znode,
00840                 int* cli);
00841
00842 #define ZNIT_DESKTOP         0x50000000
00843
00844 #define ZNIT_GLOBAL_MAINWIN  0x31000000
00845 #define ZNIT_GLOBAL_TOOLWIN  0x32000000
00846 #define ZNIT_GLOBAL_CONTROL  0x30000000
00847
00848 #define ZNIT_TOPMOST_MAINWIN 0x21000000
00849 #define ZNIT_TOPMOST_TOOLWIN 0x22000000
00850 #define ZNIT_TOPMOST_CONTROL 0x20000000
00851
00852 #define ZNIT_NORMAL_MAINWIN  0x11000000
00853 #define ZNIT_NORMAL_TOOLWIN  0x12000000
00854 #define ZNIT_NORMAL_CONTROL  0x10000000
00855
00856 #define ZNIT_NULL            0x00000000
00857
00858 #define ZNIF_VISIBLE         0x00000002
00859 #define ZNIF_DISABLED        0x00000004
00860
00862 typedef struct _ZNODEINFO
00863 {
00889     DWORD           type;
00890
00899     DWORD           flags;
00900
00902     const char*     caption;
00904     RECT            rc;
00905
00907     int             cli;
00909     HWND            hwnd;
00914     HWND            main_win;
00915 } ZNODEINFO;
00916
00936 MG_EXPORT BOOL GUIAPI ServerGetZNodeInfo (MG_Layer* layer, int idx_znode,
00937                 ZNODEINFO* znode_info);
00938
00971 MG_EXPORT BOOL GUIAPI ServerDoZNodeOperation (MG_Layer* layer, int idx_znode,
00972                 int op_code, void* op_data, BOOL notify);
00973
00985 MG_EXPORT int GUIAPI GetClientByPID (int pid);
00986
01003 MG_EXPORT BOOL GUIAPI SetTopmostClient (int cli);
01004
01009 MG_EXPORT void GUIAPI DisableClientsOutput (void);
01010
01017 MG_EXPORT void GUIAPI UpdateTopmostLayer (const RECT* dirty_rc);
01018
01055 #define MAX_SYS_REQID           0x0020
01056
01063 #define MAX_REQID               0x0030
01064
01066 typedef struct _REQUEST {
01068     int id;
01070     const void* data;
01072     size_t len_data;
01073 } REQUEST;
01075 typedef REQUEST* PREQUEST;
01076
01099 MG_EXPORT int GUIAPI ClientRequestEx (const REQUEST* request, const void* ex_data,
01100                 int ex_data_len, void* result, int len_rslt);
01101
01124 static inline int ClientRequest (const REQUEST* request,
01125                 void* result, int len_rslt)
01126 {
01127     return ClientRequestEx (request, NULL, 0, result, len_rslt);
01128 }
01129
01141 MG_EXPORT int GUIAPI GetSockFD2Server (void);
01142
01160 MG_EXPORT int GUIAPI ServerSendReply (int clifd, const void* reply, int len);
01161
01168 typedef int (* REQ_HANDLER) (int cli, int clifd, void* buff, size_t len);
01169
01188 MG_EXPORT BOOL GUIAPI RegisterRequestHandler (int req_id, REQ_HANDLER your_handler);
01189
01205 MG_EXPORT REQ_HANDLER GUIAPI GetRequestHandler (int req_id);
01206
01241 MG_EXPORT int serv_listen (const char* name);
01242
01264 MG_EXPORT int serv_accept (int listenfd, pid_t *pidptr, uid_t *uidptr);
01265
01286 MG_EXPORT int cli_conn (const char* name, char project);
01287
01288 #define SOCKERR_IO          -1
01289 #define SOCKERR_CLOSED      -2
01290 #define SOCKERR_INVARG      -3
01291 #define SOCKERR_TIMEOUT     -4
01292 #define SOCKERR_OK          0
01293
01322 MG_EXPORT int sock_write_t (int fd, const void* buff,
01323                 int count, unsigned int timeout);
01324
01352 MG_EXPORT int sock_read_t (int fd, void* buff, int count, unsigned int timeout);
01353
01360 #define sock_write(fd, buff, count) sock_write_t(fd, buff, count, 0)
01361
01368 #define sock_read(fd, buff, count) sock_read_t(fd, buff, count, 0)
01369
01374 #endif /* _MGRM_PROCESSES */
01375
01376 #endif /* LITE_VERSION */
01377
01411 MG_EXPORT BOOL GUIAPI ReinitDesktopEx (BOOL init_sys_text);
01412
01424 #define ReinitDesktop()    ReinitDesktopEx (TRUE)
01425
01440 MG_EXPORT void GUIAPI ExitGUISafely (int exitcode);
01441
01442 #ifdef _USE_MINIGUIENTRY
01443   #define main_entry minigui_entry
01444   int minigui_entry (int args, const char* arg[]);
01445 #else
01446   #define main_entry main
01447 #endif
01448
01466 #define MiniGUIMain \
01467 MiniGUIAppMain (int args, const char* argv[]); \
01468 int main_entry (int args, const char* argv[]) \
01469 { \
01470     int iRet = 0; \
01471     if (InitGUI (args, argv) != 0) { \
01472         return 1; \
01473     } \
01474     iRet = MiniGUIAppMain (args, argv); \
01475     TerminateGUI (iRet); \
01476     return iRet; \
01477 } \
01478 int MiniGUIAppMain
01479
01485 #define IDM_DTI_FIRST   (300)
01486
01488 typedef struct _DESKTOPOPS {
01489
01491         void* (*init) (void);
01492
01494         void (*deinit) (void* context);
01495
01497         void (*paint_desktop) (void* context,
01498                                 HDC dc_desktop, const RECT* inv_rc);
01499
01501         void (*keyboard_handler) (void* context,
01502                                 int message, WPARAM wParam, LPARAM lParam);
01503
01505         void (*mouse_handler) (void* context,
01506                                 int message, WPARAM wParam, LPARAM lParam);
01507
01509         void (*customize_desktop_menu) (void* context,
01510                                                  HMENU hmenu, int start_pos);
01511
01513         void (*desktop_menucmd_handler) (void* context, int id);
01514 } DESKTOPOPS;
01515
01583 MG_EXPORT DESKTOPOPS* GUIAPI SetCustomDesktopOperationSet
01584                                        (DESKTOPOPS* usr_dsk_ops);
01585
01596 MG_EXPORT void GUIAPI DesktopUpdateAllWindow (void);
01597
01605 #ifdef _MGHAVE_MOUSECALIBRATE
01606
01636 MG_EXPORT BOOL GUIAPI SetMouseCalibrationParameters (const POINT* src_pts,
01637                 const POINT* dst_pts);
01638
01658 MG_EXPORT void GUIAPI GetOriginalMousePosition (int* x, int* y);
01659
01660 #endif /* _MGHAVE_MOUSECALIBRATE */
01661
01668 #ifdef _MGMISC_ABOUTDLG
01669 #ifdef _MGRM_THREADS
01670
01685 MG_EXPORT  void GUIAPI OpenAboutDialog (void);
01686 #else
01687
01705 MG_EXPORT HWND GUIAPI OpenAboutDialog (HWND hHosting);
01706 #endif /* _MGRM_THREADS */
01707 #endif /* _MGMISC_ABOUTDLG */
01708
01758 #define ETC_MAXLINE             1024
01759
01764 #define ETC_FILENOTFOUND        -1
01765
01769 #define ETC_SECTIONNOTFOUND     -2
01770
01774 #define ETC_KEYNOTFOUND         -3
01775
01779 #define ETC_TMPFILEFAILED       -4
01780
01784 #define ETC_FILEIOFAILED        -5
01785
01789 #define ETC_INTCONV             -6
01790
01794 #define ETC_INVALIDOBJ          -7
01795
01799 #define ETC_READONLYOBJ         -8
01800
01804 #define ETC_OK                  0
01805
01807 typedef struct _ETCSECTION
01808 {
01810     int key_nr_alloc;
01812     int key_nr;
01814     char *name;
01816     char** keys;
01818     char** values;
01819 } ETCSECTION;
01821 typedef ETCSECTION* PETCSECTION;
01822
01824 typedef struct _ETC_S
01825 {
01827     int sect_nr_alloc;
01829     int section_nr;
01831     PETCSECTION sections;
01832 } ETC_S;
01833
01834 #ifndef _MGINCORE_RES
01835
01851 extern MG_EXPORT char ETCFILEPATH [];
01852
01853 #endif /* _MGINCORE_RES */
01854
01885 MG_EXPORT int GUIAPI GetValueFromEtcFile (const char* pEtcFile,
01886                 const char* pSection, const char* pKey, char* pValue, int iLen);
01887
01925 MG_EXPORT int GUIAPI GetIntValueFromEtcFile (const char* pEtcFile,
01926                 const char* pSection, const char* pKey, int* value);
01927
01953 MG_EXPORT int GUIAPI SetValueToEtcFile (const char* pEtcFile,
01954                 const char* pSection, const char* pKey, char* pValue);
01955
01976 MG_EXPORT int GUIAPI RemoveSectionInEtcFile (const char* pEtcFile,
01977                 const char* pSection);
01978
01997 MG_EXPORT int GUIAPI SaveSectionToEtcFile (const char* pEtcFile,
01998                                                                                    PETCSECTION psect);
02013 MG_EXPORT GHANDLE GUIAPI LoadEtcFile (const char * pEtcFile);
02014
02032 MG_EXPORT int GUIAPI SaveEtcToFile (GHANDLE hEtc, const char* file_name);
02033
02047 MG_EXPORT int GUIAPI UnloadEtcFile (GHANDLE hEtc);
02048
02077 MG_EXPORT int GUIAPI GetValueFromEtc (GHANDLE hEtc, const char* pSection,
02078                 const char* pKey, char* pValue, int iLen);
02079
02087 MG_EXPORT int GUIAPI GetIntValueFromEtc (GHANDLE hEtc, const char* pSection,
02088                 const char* pKey, int* pValue);
02089
02100 #define SetValueToEtc(hEtc, pSection, pKey, pValue) \
02101         GetValueFromEtc(hEtc, pSection, pKey, pValue, -1)
02102
02120 MG_EXPORT GHANDLE GUIAPI FindSectionInEtc (GHANDLE hEtc,
02121                 const char* pSection, BOOL bCreateNew);
02122
02148 MG_EXPORT int GUIAPI GetValueFromEtcSec (GHANDLE hSect,
02149                 const char* pKey, char* pValue, int iLen);
02150
02174 MG_EXPORT int GUIAPI GetIntValueFromEtcSec (GHANDLE hSect,
02175                 const char* pKey, int* pValue);
02176
02187 MG_EXPORT int GUIAPI SetValueToEtcSec (GHANDLE hSect,
02188                 const char* pKey, char* pValue);
02189
02210 MG_EXPORT int GUIAPI RemoveSectionInEtc (GHANDLE hEtc, const char* pSection);
02211
02212 /* global MiniGUI etc file object */
02213 extern MG_EXPORT GHANDLE hMgEtc;
02214
02224 static inline int GetMgEtcValue(const char* pSection,
02225                 const char *pKey, char *pValue, int iLen)
02226 {
02227 #ifndef _MGINCORE_RES
02228     if (!hMgEtc)
02229         return GetValueFromEtcFile (ETCFILEPATH, pSection, pKey, pValue, iLen);
02230 #endif
02231
02232     return GetValueFromEtc (hMgEtc, pSection, pKey, pValue, iLen);
02233 }
02234
02244 static inline int GetMgEtcIntValue (const char *pSection,
02245                 const char* pKey, int *value)
02246 {
02247 #ifndef _MGINCORE_RES
02248     if (!hMgEtc)
02249         return GetIntValueFromEtcFile (ETCFILEPATH, pSection, pKey, value);
02250 #endif
02251
02252     return GetIntValueFromEtc (hMgEtc, pSection, pKey, value);
02253 }
02254
02257 #ifdef _MGHAVE_CLIPBOARD
02258
02268 #define LEN_CLIPBOARD_NAME      15
02269
02273 #define NR_CLIPBOARDS           4
02274
02279 #define CBNAME_TEXT             ("text")
02280
02286 #define CBERR_OK        0
02287
02292 #define CBERR_BADNAME   1
02293
02298 #define CBERR_NOMEM     2
02299
02304 #define CBOP_NORMAL     0
02305
02309 #define CBOP_APPEND     1
02310
02328 MG_EXPORT int GUIAPI CreateClipBoard (const char* cb_name, size_t size);
02329
02343 MG_EXPORT int GUIAPI DestroyClipBoard (const char* cb_name);
02344
02368 MG_EXPORT int GUIAPI SetClipBoardData (const char* cb_name,
02369                 void* data, size_t n, int cbop);
02370
02383 MG_EXPORT size_t GUIAPI GetClipBoardDataLen (const char* cb_name);
02384
02400 MG_EXPORT size_t GUIAPI GetClipBoardData (const char* cb_name,
02401                 void* data, size_t n);
02402
02420 MG_EXPORT int GUIAPI GetClipBoardByte (const char* cb_name,
02421                 int index, unsigned char* byte);
02422
02425 #endif /* _MGHAVE_CLIPBOARD */
02426
02437 MG_EXPORT void GUIAPI Ping (void);
02438
02444 #define Beep Ping
02445
02461 MG_EXPORT void GUIAPI Tone (int frequency_hz, int duration_ms);
02462
02470 MG_EXPORT void* GUIAPI GetOriginalTermIO (void);
02471
02505 MG_EXPORT char* GUIAPI FixStrAlloc (int len);
02506
02524 MG_EXPORT char* GUIAPI FixStrDup (const char* str);
02525
02538 MG_EXPORT void GUIAPI FreeFixStr (char* str);
02539
02547 #ifndef _MGHAVE_CURSOR
02548 static inline void do_nothing (void) { return; }
02549 #endif
02550
02551 #ifdef _MGHAVE_CURSOR
02552
02569 MG_EXPORT HCURSOR GUIAPI LoadCursorFromFile (const char* filename);
02570
02587 MG_EXPORT HCURSOR GUIAPI LoadCursorFromMem (const void* area);
02588
02614 MG_EXPORT HCURSOR GUIAPI CreateCursor (int xhotspot, int yhotspot, int w, int h,
02615                const BYTE* pANDBits, const BYTE* pXORBits, int colornum);
02616
02627 MG_EXPORT BOOL GUIAPI DestroyCursor (HCURSOR hcsr);
02628
02687 MG_EXPORT HCURSOR GUIAPI GetSystemCursor (int csrid);
02688
02697 MG_EXPORT HCURSOR GUIAPI GetCurrentCursor (void);
02698 #else
02699   #define LoadCursorFromFile(filename)    (do_nothing(), 0)
02700   #define CreateCursor(x, y, w, h, ANDbs, XORbs, cr) (do_nothing(), 0)
02701   #define DestroyCursor(hcsr)             (do_nothing(), 0)
02702   #define GetSystemCursor(csrid)          (do_nothing(), 0)
02703   #define GetCurrentCursor()              (do_nothing(), 0)
02704 #endif /* _MGHAVE_CURSOR */
02705
02706 #define MAX_SYSCURSORINDEX    22
02707
02708 /* System cursor index. */
02710 #define IDC_ARROW       0
02711
02712 #define IDC_IBEAM       1
02713
02714 #define IDC_PENCIL      2
02715
02716 #define IDC_CROSS       3
02717
02718 #define IDC_MOVE        4
02719
02720 #define IDC_SIZENWSE    5
02721
02722 #define IDC_SIZENESW    6
02723
02724 #define IDC_SIZEWE      7
02725
02726 #define IDC_SIZENS      8
02727
02728 #define IDC_UPARROW     9
02729
02730 #define IDC_NONE        10
02731
02732 #define IDC_HELP        11
02733
02734 #define IDC_BUSY        12
02735
02736 #define IDC_WAIT        13
02737
02738 #define IDC_RARROW      14
02739
02740 #define IDC_COLOMN      15
02741
02742 #define IDC_ROW         16
02743
02744 #define IDC_DRAG        17
02745
02746 #define IDC_NODROP      18
02747
02748 #define IDC_HAND_POINT  19
02749
02750 #define IDC_HAND_SELECT 20
02751
02752 #define IDC_SPLIT_HORZ  21
02753
02754 #define IDC_SPLIT_VERT  22
02755
02767 MG_EXPORT void GUIAPI ClipCursor (const RECT* prc);
02768
02779 MG_EXPORT void GUIAPI GetClipCursor (RECT* prc);
02780
02793 MG_EXPORT void GUIAPI GetCursorPos (POINT* ppt);
02794
02808 MG_EXPORT void GUIAPI SetCursorPos (int x, int y);
02809
02810 #ifdef _MGHAVE_CURSOR
02811
02829  MG_EXPORT HCURSOR GUIAPI SetCursorEx (HCURSOR hcsr, BOOL set_def);
02830
02845   #define SetCursor(hcsr) SetCursorEx (hcsr, FALSE)
02846
02862   #define SetDefaultCursor(hcsr) SetCursorEx (hcsr, TRUE)
02863
02874 MG_EXPORT  HCURSOR GUIAPI GetDefaultCursor (void);
02875
02876 #else
02877   #define SetCursorEx(hcsr, set_def)    (do_nothing(), 0)
02878   #define SetCursor(hcsr)               (do_nothing(), 0)
02879   #define SetDefaultCursor(hcsr)        (do_nothing(), 0)
02880   #define GetDefaultCursor()            (do_nothing(), 0)
02881 #endif /* _MGHAVE_CURSOR */
02882
02883 #ifdef _MGHAVE_CURSOR
02884
02899 MG_EXPORT int GUIAPI ShowCursor (BOOL fShow);
02900 #else
02901   #define ShowCursor(fShow)             (do_nothing(), 0)
02902 #endif /* _MGHAVE_CURSOR */
02903
02936 MG_EXPORT BOOL GUIAPI GetKeyStatus (UINT uKey);
02937
02978 MG_EXPORT DWORD GUIAPI GetShiftKeyStatus (void);
02979
02991 #define IDS_MGST_WINDOW          0
02992
02997 #define IDS_MGST_START           1
02998
03003 #define IDS_MGST_REFRESH         2
03004
03009 #define IDS_MGST_CLOSEALLWIN     3
03010
03015 #define IDS_MGST_ENDSESSION      4
03016
03021 #define IDS_MGST_OPERATIONS      5
03022
03027 #define IDS_MGST_MINIMIZE        6
03028
03033 #define IDS_MGST_MAXIMIZE        7
03034
03039 #define IDS_MGST_RESTORE         8
03040
03045 #define IDS_MGST_CLOSE           9
03046
03051 #define IDS_MGST_OK              10
03052
03057 #define IDS_MGST_NEXT            11
03058
03063 #define IDS_MGST_CANCEL          12
03064
03069 #define IDS_MGST_PREV            13
03070
03075 #define IDS_MGST_YES             14
03076
03081 #define IDS_MGST_NO              15
03082
03087 #define IDS_MGST_ABORT           16
03088
03093 #define IDS_MGST_RETRY           17
03094
03099 #define IDS_MGST_IGNORE          18
03100
03105 #define IDS_MGST_ABOUTMG         19
03106
03111 #define IDS_MGST_OPENFILE        20
03112
03117 #define IDS_MGST_SAVEFILE        21
03118
03123 #define IDS_MGST_COLORSEL        22
03124
03129 #define IDS_MGST_SWITCHLAYER     23
03130
03135 #define IDS_MGST_DELLAYER        24
03136
03141 #define IDS_MGST_ERROR           25
03142
03147 #define IDS_MGST_LOGO            26
03148
03153 #define IDS_MGST_CURRPATH        27
03154
03159 #define IDS_MGST_FILE            28
03160
03165 #define IDS_MGST_LOCATION        29
03166
03171 #define IDS_MGST_UP              30
03172
03177 #define IDS_MGST_NAME            31
03178
03183 #define IDS_MGST_SIZE            32
03184
03189 #define IDS_MGST_ACCESSMODE      33
03190
03195 #define IDS_MGST_LASTMODTIME     34
03196
03201 #define IDS_MGST_OPEN            35
03202
03207 #define IDS_MGST_FILENAME        36
03208
03213 #define IDS_MGST_FILETYPE        37
03214
03219 #define IDS_MGST_SHOWHIDEFILE    38
03220
03225 #define IDS_MGST_NOTFOUND        39
03226
03231 #define IDS_MGST_NR              40
03232
03237 #define IDS_MGST_NW              41
03238
03243 #define IDS_MGST_INFO            42
03244
03249 #define IDS_MGST_R               43
03250
03255 #define IDS_MGST_W               44
03256
03261 #define IDS_MGST_WR              45
03262
03267 #define IDS_MGST_SAVE            46
03268
03273 #define IDS_MGST_FILEEXIST       47
03274
03275 #define IDS_MGST_MAXNUM          47
03276
03296 MG_EXPORT const char* GUIAPI GetSysText (unsigned int id);
03297
03364 extern MG_EXPORT const char* SysText [];
03365
03377 extern MG_EXPORT const char** local_SysText;
03378
03379 #ifdef _MGCHARSET_UNICODE
03380
03399 extern MG_EXPORT const char** GUIAPI GetSysTextInUTF8 (const char* language);
03400
03401 #endif /* _MGCHARSET_UNICODE */
03402
03423 MG_EXPORT char* strnchr (const char* s, size_t n, int c);
03424
03441 MG_EXPORT int substrlen (const char* text, int len, int delimiter,
03442                 int* nr_delim);
03443
03456 MG_EXPORT char * strtrimall (char* src);
03457
03464 #ifdef __cplusplus
03465 }
03466 #endif  /* __cplusplus */
03467
03468 #endif /* _MGUI_MINIGUI_H */
03469
Generated on Fri Dec 17 13:49:41 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Module Index

Modules

Here is a list of all modules:
  • Macros and data types commonly used
    • Version information
    • Basic data types
    • Endianness information
    • Simple and common types and macros
    • MiniGUI handles
    • Win32-like data types and macros
    • Data types for GDI
    • Macros for key codes and shift status
    • Error codes
    • Miscellaneous macros
  • Standard controls
    • ANIMATION control and animation GIF (GIF87a/GIF89a) support
      • Styles of ANIMATION control
      • Messages of ANIMATION control
      • Notification code of ANIMATION control
    • Button control
      • Styles of button control
      • States of button control
      • Messages of button control
      • Notification codes of button control
    • ComboBox control
      • Styles of combobox control
      • Messages of combobox control
      • Notification codes of combobox control
    • CoolBar control
      • Styles of coolbar control
      • Messages of coolbar control
    • Edit/MEdit control
      • Styles of edit control
      • Messages of edit control
      • Notification codes of edit control
    • GridView control
      • Messages of grid control
      • Notification code of Grid control
    • IconView control
      • Styles of iconview control
      • Messages of ListView control
      • Notification code of IconView control
    • ListBox control
      • Styles of listbox control
      • Messages of listbox control
      • Notification codes of listbox control
    • ListView control
      • Styles of listview control
      • Messages of ListView control
      • Notification code of ListView control
    • MenuButton control
      • Styles of menubutton control
      • Messages of menubutton control
      • Notification codes of menubutton control
    • MonthCalendar control
      • Styles of monthcalendar control
      • Messages of monthcalendar control
      • Notification codes of monthcalendar control
    • NewToolBar control
      • Styles of NewToolBar control
      • Messages of NewToolBar control
    • ProgressBar control
      • Styles of progressbar control
      • Messages of progressbar control
      • Notification codes of progressbar control
    • PropertySheet control
      • Styles of propertysheet control
      • Messages of propertysheet control
      • Notification codes of propertysheet control
    • ScrollBar control
      • Styles of scrollbar control
      • Messages of scrollbar control
    • ScrollView control
      • Styles of scrollview control
      • Messages of scrollview control
      • Notification codes of scrollview control
    • SpinBox control
      • Styles of spinbox control
      • Messages of spinbox control
      • Notification codes of spinbox control
    • Static control
      • Styles of static control
      • Messages of static control
      • Notification codes of static control
    • TextEdit control
      • Styles of textedit control
      • Messages of textedit control
      • Notification codes of textedit control
    • TrackBar control
      • Styles of trackbar control
      • Messages of trackbar control
      • Notification codes of trackbar control
      • state for renderer
    • TreeView control
      • Styles of treeview control
      • Messages of treeview control
      • Notification codes of treeview control
  • Messages
    • Mouse event messages
    • Key event messages
    • User-machine Interaction messages
      • Notification codes of srollbar control
    • Window creation messages
    • Window painting messages
    • Internal desktop messages
    • Internal window management messages
    • Dialog and control messages
    • System messages
    • Internal menu messages
    • User-defined messages
  • Window styles
  • Functions
    • GDI functions
      • Region operations
      • General DC operations
      • DC attribute operations
      • Palette operations
      • General drawing functions
        • Advanced 2-Dimension graphics functions.
      • Mapping Operations
      • Clipping operations
      • BITMAP and blitting operations
      • Icon operations
      • Rectangle operations
      • Logical font operations
      • System charset and font operations
      • Text parsing functions
      • Text output functions
      • Bitmap structure
      • Bitmap file load/save operations
      • Glyph defines and operations
    • Message functions
      • Message passing functions
      • Message or event hook functions
    • Look and Feel Renderer management functions
    • Resource managment functions
    • Windowing functions
      • Window creating/destroying
        • General window operations
        • System bitmap/icon operations
        • Scroll bar operations
        • Window class operations
        • Control creating/destroying
        • Timer operations
        • IME Window functions
        • Accelerator operations
        • Caret operations
        • Menu operations
        • Dialog operations
        • Message box operations
    • Global/general functions
      • General read/write operations
      • Endian specific read/write interfaces
      • Fixed point math functions
      • Block data heap operations
      • MiniGUI-Processes specific functions
        • Listening a file descriptor
        • Initialization and termination functions
        • Mouse calibration.
        • About MiniGUI dialog
        • Configuration file operations
        • Length-Fixed string operations
        • Cursor operations
        • Asynchronous key status functions
        • Internationlization of system text
        • String operation helpers
        • ClipBoard Operations
        • Miscellaneous functions
      • Miscellaneous functions
  • Global variables
    • System colors and pixel values.
    • Global Rectangles
    • MiniGUI-Processes specific variables
    • x virtual framebuffer
Generated on Fri Dec 17 13:49:51 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: monthcal.h Source File

include » ctrl

monthcal.h

Go to the documentation of this file.
00001
00019 /*
00020  * $Id: monthcal.h 10690 2008-08-18 09:32:47Z weiym $
00021  *
00022  *             MiniGUI for Linux/uClinux, eCos, uC/OS-II, VxWorks,
00023  *                     pSOS, ThreadX, NuCleus, OSE, and Win32.
00024  *
00025  *             Copyright (C) 2002-2008 Feynman Software.
00026  *             Copyright (C) 1998-2002 Wei Yongming.
00027  */
00028
00029 #ifndef EXT_MONTHCAL_H
00030 #define EXT_MONTHCAL_H
00031
00032
00033 #ifdef  __cplusplus
00034 extern "C" {
00035 #endif
00036
00051 #define CTRL_MONTHCALENDAR     ("MonthCalendar")
00052
00054 typedef struct _SYSTEMTIME
00055 {
00057     int year;
00059     int month;
00061     int day;
00063     int weekday;
00064 } SYSTEMTIME;
00069 typedef SYSTEMTIME *PSYSTEMTIME;
00070
00072 typedef struct _MCCOLORINFO
00073 {
00075     int clr_titlebk;
00077     int clr_titletext;
00079     int clr_arrow;
00081     int clr_arrowHibk;
00082
00084     int clr_weekcaptbk;
00086     int clr_weekcapttext;
00087
00089     int clr_daybk;
00091     int clr_dayHibk;
00093     int clr_daytext;
00095     int clr_trailingtext;
00097     int clr_dayHitext;
00098 } MCCOLORINFO;
00099
00104 typedef MCCOLORINFO *PMCCOLORINFO;
00105
00114 #define MCS_CHN                 0x0001L
00115
00120 #define MCS_ENG_L               0x0002L
00121
00126 #define MCS_ENG_S               0x0003L
00127
00132 #define MCS_NOTIFY              0x0004L
00133
00138 #define MCS_NOYEARMON           0x0008L
00139
00160 #define MCM_GETCURDAY           0xF300
00161
00175 #define MCM_GETCURMONTH         0xF301
00176
00190 #define MCM_GETCURYEAR          0xF302
00191
00205 #define MCM_GETCURWEEKDAY       0xF303
00206
00220 #define MCM_GETCURMONLEN        0xF304
00221
00236 #define MCM_SETCURDAY           0xF305
00237
00252 #define MCM_SETCURMONTH         0xF306
00253
00268 #define MCM_SETCURYEAR          0xF307
00269
00281 #define MCM_SETTODAY            0xF308
00282
00296 #define MCM_GETFIRSTWEEKDAY     0xF309
00297
00312 #define MCM_GETCURDATE          0xF310
00313
00329 #define MCM_GETTODAY            0xF311
00330
00345 #define MCM_GETMINREQRECTW      0xF312
00346
00361 #define MCM_GETMINREQRECTH      0xF313
00362
00378 #define MCM_SETCURDATE          0xF314
00379
00395 #define MCM_SETCOLOR            0xF315
00396
00411 #define MCM_GETCOLOR            0xF316
00412
00429 #define MCM_SETDAYCOLOR          0xF317
00430
00442 #define MCM_CLEARDAYCOLOR        0xF318
00443
00444
00456 #define MCN_DATECHANGE          1
00457 /*#define MCN_DAYCHANGE           2 */
00458 #define MCN_DATECLK             3
00459
00465 #ifdef  __cplusplus
00466 }
00467 #endif
00468
00469 #endif /* EXT_MONTHCAL_H */
00470
Generated on Fri Dec 17 13:49:41 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: newtoolbar.h Source File

include » ctrl

newtoolbar.h

Go to the documentation of this file.
00001
00019 /*
00020  * $Id: newtoolbar.h 10690 2008-08-18 09:32:47Z weiym $
00021  *
00022  *             MiniGUI for Linux/uClinux, eCos, uC/OS-II, VxWorks,
00023  *                     pSOS, ThreadX, NuCleus, OSE, and Win32.
00024  *
00025  *             Copyright (C) 2002-2008 Feynman Software.
00026  *             Copyright (C) 1999-2002 Wei Yongming.
00027  */
00028
00029 #ifndef _MGUI_CTRL_NEWTOOLBAR_H
00030 #define _MGUI_CTRL_NEWTOOLBAR_H
00031
00032
00033 #ifdef __cplusplus
00034 extern "C" {
00035 #endif  /* __cplusplus */
00036
00063 #define CTRL_NEWTOOLBAR            ("newtoolbar")
00064
00066 typedef struct _NTBINFO
00067 {
00069     PBITMAP image;
00070
00072     int nr_cells;
00073
00086     int nr_cols;
00087
00092     int w_cell;
00093
00098     int h_cell;
00099
00100 } NTBINFO;
00101
00112 typedef void (* HOTSPOTPROC)(HWND hwnd, int id, const RECT* cell, int x, int y);
00113
00114 /* Internal */
00115 #define NTB_TEXT_LEN        15
00116 /* Internal */
00117 #define NTB_TIP_LEN         255
00118
00119 #define NTBIF_PUSHBUTTON    0x0001
00120 #define NTBIF_HOTSPOTBUTTON  0x0002
00121 #define NTBIF_SEPARATOR     0x0003
00122 #define NTBIF_CHECKBUTTON   0x0005
00123 #define NTBIF_NEWLINE       0x0008
00124 #define NTBIF_TYPEMASK      0x000F
00125
00130 #define NTBIF_DISABLED      0x0010
00131
00135 #define NTBIF_CHECKED       0x0020
00136
00137 #define MTB_WHICH_FLAGS     0x0001
00138 #define MTB_WHICH_ID        0x0002
00139 #define MTB_WHICH_TEXT      0x0004
00140 #define MTB_WHICH_TIP       0x0008
00141 #define MTB_WHICH_CELL      0x0010
00142 #define MTB_WHICH_HOTSPOT   0x0020
00143 #define MTB_WHICH_ADDDATA   0x0040
00144
00146 typedef struct _NTBITEMINFO
00147 {
00160     DWORD       which;
00161
00172     DWORD       flags;
00173
00179     int         id;
00180
00185     char*       text;
00186
00188     char*       tip;
00189
00191     int         bmp_cell;
00192
00194     HOTSPOTPROC  hotspot_proc;
00195
00197     RECT        rc_hotspot;
00198
00200     DWORD       add_data;
00201 } NTBITEMINFO;
00202
00207 typedef NTBITEMINFO* PNTBITEMINFO;
00208
00218 #define NTBS_WITHTEXT               0x000000001L
00219
00224 #define NTBS_TEXTRIGHT              0x000000002L
00225
00231 #define NTBS_DRAWSTATES             0x000000004L
00232
00237 #define NTBS_DRAWSEPARATOR          0x000000008L
00238
00243 #define NTBS_HORIZONTAL             0x00000000L
00244
00249 #define NTBS_VERTICAL               0x00000010L
00250
00257 #define NTBS_MULTLINE               0x00000020L
00258
00266 #define NTB_OKAY        0
00267
00268 #define NTB_ERR         (-1)
00269
00270 #define NTB_ERR_SPACE   (-2)
00271
00272 #define NTB_ERR_DUPID   (-3)
00273
00292 #define NTBM_ADDITEM            0xFE00
00293
00312 #define NTBM_GETITEM            0xFE01
00313
00332 #define NTBM_SETITEM            0xFE02
00333
00352 #define NTBM_ENABLEITEM         0xFE03
00353
00370 #define NTBM_SETBITMAP          0xFE04
00371
00372
00373 #define NTBM_MSGMAX             0xFE10
00374
00381 #ifdef __cplusplus
00382 }
00383 #endif  /* __cplusplus */
00384
00385 #endif /* _MGUI_CTRL_NEWTOOLBAR_H */
00386
Generated on Fri Dec 17 13:49:41 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: Page Index

Related Pages

Here is a list of all related documentation pages:
  • Bug List
Generated on Fri Dec 17 13:49:40 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: progressbar.h Source File

include » ctrl

progressbar.h

Go to the documentation of this file.
00001
00019 /*
00020  * $Id: progressbar.h 10690 2008-08-18 09:32:47Z weiym $
00021  *
00022  *             MiniGUI for Linux/uClinux, eCos, uC/OS-II, VxWorks,
00023  *                     pSOS, ThreadX, NuCleus, OSE, and Win32.
00024  *
00025  *             Copyright (C) 2002-2008 Feynman Software.
00026  *             Copyright (C) 1999-2002 Wei Yongming.
00027  */
00028
00029 #ifndef _MGUI_CTRL_PROGRESSBAR_H
00030 #define _MGUI_CTRL_PROGRESSBAR_H
00031
00032
00033 #ifdef __cplusplus
00034 extern "C" {
00035 #endif  /* __cplusplus */
00036
00051 #define CTRL_PROGRESSBAR        ("progressbar")
00052
00053 #define PB_OKAY                 0
00054
00055 #define PB_ERR                  -1
00056
00069 #define PBS_NOTIFY              0x0001L
00070
00075 #define PBS_VERTICAL            0x0002L
00076
00104 #define PBM_SETRANGE            0xF0A0
00105
00121 #define PBM_SETSTEP             0xF0A1
00122
00141 #define PBM_SETPOS              0xF0A2
00142
00161 #define PBM_DELTAPOS            0xF0A3
00162
00179 #define PBM_STEPIT              0xF0A4
00180
00181 #define PBM_MSGMAX              0xF0B0
00182
00196 #define PBN_REACHMAX            1
00197
00204 #define PBN_REACHMIN            2
00205
00212 #ifdef __cplusplus
00213 }
00214 #endif  /* __cplusplus */
00215
00216 #endif /* _MGUI_CTRL_PROGRESSBAR_H */
00217
Generated on Fri Dec 17 13:49:41 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: propsheet.h Source File

include » ctrl

propsheet.h

Go to the documentation of this file.
00001
00019 /*
00020  * $Id: propsheet.h 10690 2008-08-18 09:32:47Z weiym $
00021  *
00022  *             MiniGUI for Linux/uClinux, eCos, uC/OS-II, VxWorks,
00023  *                     pSOS, ThreadX, NuCleus, OSE, and Win32.
00024  *
00025  *             Copyright (C) 2002-2008 Feynman Software.
00026  *             Copyright (C) 1999-2002 Wei Yongming.
00027  */
00028
00029 #ifndef _MGUI_CTRL_PROPSHEET_H
00030 #define _MGUI_CTRL_PROPSHEET_H
00031
00032
00033 #ifdef __cplusplus
00034 extern "C" {
00035 #endif  /* __cplusplus */
00036
00051 #define CTRL_PROPSHEET       ("propsheet")
00052
00063 #define PSS_SIMPLE                0x0000L
00064
00069 #define PSS_COMPACTTAB            0x0001L
00070
00075 #define PSS_SCROLLABLE            0x0002L
00076
00082 #define PSS_BOTTOM                0x0010L
00083
00091 #define PS_OKAY         0
00092
00093 #define PS_ERR          (-1)
00094
00110 #define PSM_GETACTIVEPAGE         0xF1C0L
00111
00130 #define PSM_SETACTIVEINDEX         0xF1C2L
00131
00150 #define PSM_GETPAGE               0xF1C3L
00151
00167 #define PSM_GETACTIVEINDEX        0xF1C4L
00168
00187 #define PSM_GETPAGEINDEX          0xF1C5L
00188
00204 #define PSM_GETPAGECOUNT          0xF1C6L
00205
00224 #define PSM_GETTITLELENGTH        0xF1C7L
00225
00246 #define PSM_GETTITLE              0xF1C8L
00247
00268 #define PSM_SETTITLE              0xF1C9L
00269
00292 #define PSM_ADDPAGE               0xF1D0L
00293
00313 #define PSM_REMOVEPAGE            0xF1D1L
00314
00351 #define PSM_SHEETCMD              0xF1D2L
00352
00353 #define PSM_MSGMAX              0xF1E0L
00354
00367 #define PSN_ACTIVE_CHANGED        0x01
00368
00375 #ifdef __cplusplus
00376 }
00377 #endif  /* __cplusplus */
00378
00379 #endif /* _MGUI_CTRL_PROPSHEET_H */
00380
Generated on Fri Dec 17 13:49:41 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: scrollbar.h Source File

include » ctrl

scrollbar.h

Go to the documentation of this file.
00001
00019 /*
00020  * $Id: scrollbar.h 10690 2008-08-18 09:32:47Z weiym $
00021  *
00022  *             MiniGUI for Linux/uClinux, eCos, uC/OS-II, VxWorks,
00023  *                     pSOS, ThreadX, NuCleus, OSE, and Win32.
00024  *
00025  *             Copyright (C) 2002-2008 Feynman Software.
00026  *             Copyright (C) 1999-2002 Wei Yongming.
00027  */
00028
00029 #ifndef _MGUI_CTRL_SCROLLBAR_H
00030 #define _MGUI_CTRL_SCROLLBAR_H
00031
00032 #ifdef __cplusplus
00033 extern "C" {
00034 #endif  /* __cplusplus */
00035
00052 #define CTRL_SCROLLBAR              ("scrollbar")
00053
00063 #define SBS_HORZ  0x1000
00064
00069 #define SBS_VERT   0x2000
00070
00078 #define SBS_BOTTOMALIGN 0x0001
00079
00087 #define SBS_TOPALIGN  0x0002
00088
00096 #define SBS_LEFTALIGN  0x0001
00097
00105 #define SBS_RIGHTALIGN  0x0002
00106
00113 #define SBS_NOARROW  0x0004
00114
00121 #define SBS_NOSHAFT  0x0008
00122
00128 #define SBS_FIXEDBARLEN  0x0010
00129
00135 #define SBS_NOTNOTIFYPARENT 0x0020
00136
00149 #define SBM_GETSCROLLINFO           0xF0E0
00150
00155 #define SBM_SETSCROLLINFO           0xF0E1
00156
00173 #define SBM_GETPOS                  0xF0E2
00174
00197 #define SBM_SETPOS                  0xF0E3
00198
00215 #define SBM_GETRANGE                0xF0E4
00216
00239 #define SBM_SETRANGE                0xF0E5
00240
00263 #define SBM_SETRANGEREDRAW          0xF0E6
00264
00293 #define SBM_ENABLE_ARROW            0xF0E7
00294
00301 #ifdef __cplusplus
00302 }
00303 #endif  /* __cplusplus */
00304
00305 #endif /* _MGUI_CTRL_SCROLLBAR_H */
00306
Generated on Fri Dec 17 13:49:41 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: scrollview.h Source File

include » ctrl

scrollview.h

Go to the documentation of this file.
00001
00019 /*
00020  * $Id: scrollview.h 10690 2008-08-18 09:32:47Z weiym $
00021  *
00022  *             MiniGUI for Linux/uClinux, eCos, uC/OS-II, VxWorks,
00023  *                     pSOS, ThreadX, NuCleus, OSE, and Win32.
00024  *
00025  *             Copyright (C) 2002-2008 Feynman Software.
00026  *             Copyright (C) 1999-2002 Wei Yongming.
00027  */
00028
00029 #ifndef _MGUI_CTRL_SCROLLVIEW_H
00030 #define _MGUI_CTRL_SCROLLVIEW_H
00031
00032
00033 #ifdef __cplusplus
00034 extern "C" {
00035 #endif  /* __cplusplus */
00036
00060 #define CTRL_SCROLLVIEW           ("scrollview")
00061
00068 #define CTRL_SCROLLWND            ("scrollwnd")
00069
00073 MG_EXPORT int GUIAPI DefaultContainerProc (HWND hWnd, int message, WPARAM wParam, LPARAM lParam);
00074
00076 typedef GHANDLE HSVITEM;
00077
00081 typedef struct _CONTAINERINFO
00082 {
00083 #if 0
00084     DWORD       dwStyle;
00085     DWORD       dwExStyle;
00086     int         x, y, w, h;
00087 #endif
00088
00089     WNDPROC     user_proc;
00091     int         controlnr;
00093     PCTRLDATA   controls;
00095     DWORD       dwAddData;
00096 } CONTAINERINFO;
00098 typedef CONTAINERINFO* PCONTAINERINFO;
00099
00105 MG_EXPORT DWORD mglist_get_item_adddata (GHANDLE hi);
00106
00111 MG_EXPORT DWORD scrollview_get_item_adddata (HSVITEM hsvi);
00112
00117 MG_EXPORT int scrollview_get_item_index (HWND hWnd, HSVITEM hsvi);
00118
00123 MG_EXPORT BOOL scrollview_is_item_hilight (HWND hWnd, HSVITEM hsvi);
00124
00129 MG_EXPORT BOOL scrollview_is_item_selected (HSVITEM hsvi);
00130
00135 MG_EXPORT int scrollview_set_item_height (HWND hWnd, HSVITEM hsvi, int height);
00136
00146 typedef int  (*SVITEM_INITFUNC)    (HWND hWnd, HSVITEM hsvi);
00147
00155 typedef void (*SVITEM_DESTROYFUNC) (HWND hWnd, HSVITEM hsvi);
00156
00166 typedef void (*SVITEM_DRAWFUNC) (HWND hWnd, HSVITEM hsvi, HDC hdc, RECT *rcDraw);
00167
00172 typedef int (*SVITEM_CMP) (HSVITEM hsvi1, HSVITEM hsvi2);
00173
00175 typedef struct _svitem_operations
00176 {
00178     SVITEM_INITFUNC     initItem;
00180     SVITEM_DESTROYFUNC  destroyItem;
00182     SVITEM_DRAWFUNC     drawItem;
00183 } SVITEMOPS;
00185 typedef SVITEMOPS* PSVITEMOPS;
00186
00188 typedef struct _SCROLLVIEWITEMINFO
00189 {
00191     int        nItem;
00193     int        nItemHeight;
00195     DWORD      addData;
00196 } SVITEMINFO;
00198 typedef SVITEMINFO* PSVITEMINFO;
00199
00209 #define SVS_UPNOTIFY            0x0001L
00210
00215 #define SVS_NOTIFY              0x0002L
00216
00221 #define SVS_AUTOSORT            0x0004L
00222
00227 #define SVS_LOOP                0x0008L
00228
00255 #define SVM_ADDITEM             0xF300
00256
00276 #define SVM_DELITEM             0xF301
00277
00297 #define SVM_SETITEMDRAW         0xF302
00298
00317 #define SVM_ADDCTRLS            0xF303
00318
00337 #define SVM_SETCONTWIDTH        0xF306
00338
00357 #define SVM_SETCONTHEIGHT       0xF307
00358
00375 #define SVM_GETCTRL             0xF308
00376
00390 #define SVM_RESETCONTENT        0xF309
00391
00410 #define SVM_SETITEMOPS          0xF30a
00411
00430 #define SVM_GETMARGINS            0xF30b
00431
00451 #define SVM_SETMARGINS            0xF311
00452
00466 #define SVM_GETLEFTMARGIN         0xF312
00467
00481 #define SVM_GETTOPMARGIN          0xF313
00482
00496 #define SVM_GETRIGHTMARGIN        0xF314
00497
00511 #define SVM_GETBOTTOMMARGIN       0xF315
00512
00526 #define SVM_GETVISIBLEWIDTH       0xF316
00527
00541 #define SVM_GETVISIBLEHEIGHT      0xF317
00542
00556 #define SVM_GETCONTWIDTH          0xF318
00557
00571 #define SVM_GETCONTHEIGHT         0xF319
00572
00593 #define SVM_SETCONTRANGE          0xF31a
00594
00608 #define SVM_GETCONTENTX           0xF31b
00609
00623 #define SVM_GETCONTENTY           0xF31c
00624
00642 #define SVM_SETCONTPOS            0xF31d
00643
00662 #define SVM_GETCURSEL             0xF31e
00663
00681 #define SVM_SELECTITEM            0xF31f
00682
00701 #define SVM_SHOWITEM              0xF320
00702
00721 #define SVM_CHOOSEITEM            0xF321
00722
00741 #define SVM_SETCURSEL             0xF322
00742
00762 #define SVM_SETITEMINIT            0xF323
00763
00783 #define SVM_SETITEMDESTROY        0xF324
00784
00801 #define SVM_SETITEMCMP            0xF327
00802
00818 #define SVM_MAKEPOSVISIBLE        0xF328
00819
00836 #define SVM_SETCONTAINERPROC       0xF329
00837
00851 #define SVM_GETFOCUSCHILD          0xF32a
00852
00866 #define SVM_GETHSCROLLVAL           0xF32b
00867
00881 #define SVM_GETVSCROLLVAL           0xF32c
00882
00896 #define SVM_GETHSCROLLPAGEVAL       0xF32d
00897
00911 #define SVM_GETVSCROLLPAGEVAL       0xF32e
00912
00930 #define SVM_SETSCROLLVAL           0xF32f
00931
00949 #define SVM_SETSCROLLPAGEVAL       0xF330
00950
00966 #define SVM_SORTITEMS              0xF331
00967
00974 #define SVM_GETITEMCOUNT           0xF332
00975
00995 #define SVM_GETITEMADDDATA         0xF333
00996
01015 #define SVM_SETITEMADDDATA         0xF334
01016
01035 #define SVM_REFRESHITEM            0xF335
01036
01055 #define SVM_SETITEMHEIGHT         0xF336
01056
01067 #define SVM_GETFIRSTVISIBLEITEM   0xF337
01068
01069
01078 #define SVN_CLICKED             1
01079
01081 #define SVN_SELCHANGED          2
01082
01084 #define SVN_SELCHANGING                 4
01085
01092 #ifdef __cplusplus
01093 }
01094 #endif  /* __cplusplus */
01095
01096 #endif /* _MGUI_CTRL_SCROLLVIEW_H */
01097
Generated on Fri Dec 17 13:49:41 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: spinbox.h Source File

include » ctrl

spinbox.h

Go to the documentation of this file.
00001
00019 /*
00020  * $Id: spinbox.h 10690 2008-08-18 09:32:47Z weiym $
00021  *
00022  *             MiniGUI for Linux/uClinux, eCos, uC/OS-II, VxWorks,
00023  *                     pSOS, ThreadX, NuCleus, OSE, and Win32.
00024  *
00025  *             Copyright (C) 2002-2008 Feynman Software.
00026  *             Copyright (C) 1998-2002 Wei Yongming.
00027  */
00028
00029 #ifndef EXT_SPINBOX_H
00030 #define EXT_SPINBOX_H
00031
00032 #ifdef  __cplusplus
00033 extern "C" {
00034 #endif
00035
00050 #define CTRL_SPINBOX                ("SpinBox")
00051
00053 typedef struct _SPININFO
00054 {
00056     int max;
00058     int min;
00060     int cur;
00061 } SPININFO;
00066 typedef SPININFO *PSPININFO;
00067
00079 void GetSpinBoxSize (DWORD dwStyle, int* w, int* h);
00080
00091 #define SPS_AUTOSCROLL          0x00000001L
00092
00097 #define SPS_HORIZONTAL          0x00000010L
00098
00103 #define SPS_TYPE_NORMAL         0x00000000L
00104
00109 #define SPS_TYPE_UPARROW        0x00000100L
00110
00115 #define SPS_TYPE_DOWNARROW      0x00000200L
00116
00121 #define SPS_TYPE_MASK           0x00000F00L
00122
00133 #define KS_SPINPOST             0x00010000
00134
00156 #define SPM_SETTARGET           0xF300
00157
00171 #define SPM_GETTARGET           0xF301
00172
00191 #define SPM_SETINFO             0xF302
00192
00211 #define SPM_GETINFO             0xF303
00212
00226 #define SPM_DISABLEUP           0xF304
00227
00241 #define SPM_DISABLEDOWN         0xF305
00242
00256 #define SPM_ENABLEUP            0xF306
00257
00271 #define SPM_ENABLEDOWN          0xF307
00272
00289 #define SPM_SETCUR              0xF308
00290
00304 #define SPM_GETCUR              0xF309
00305
00317 #define SPN_REACHMIN            1
00318
00323 #define SPN_REACHMAX            2
00324
00331 #ifdef  __cplusplus
00332 }
00333 #endif
00334
00335 #endif /* EXT_SPINBOX_H */
00336
Generated on Fri Dec 17 13:49:41 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: static.h Source File

include » ctrl

static.h

Go to the documentation of this file.
00001
00019 /*
00020  * $Id: static.h 12449 2010-01-12 02:52:50Z weiym $
00021  *
00022  *             MiniGUI for Linux/uClinux, eCos, uC/OS-II, VxWorks,
00023  *                     pSOS, ThreadX, NuCleus, OSE, and Win32.
00024  *
00025  *             Copyright (C) 2002-2008 Feynman Software.
00026  *             Copyright (C) 1999-2002 Wei Yongming.
00027  */
00028
00029 #ifndef _MGUI_CTRL_STATIC_H
00030 #define _MGUI_CTRL_STATIC_H
00031
00032
00033 #ifdef __cplusplus
00034 extern "C" {
00035 #endif  /* __cplusplus */
00036
00051 #define CTRL_STATIC         ("static")
00052
00063 #define SS_SIMPLE           0x00000000L
00064
00069 #define SS_BLACKRECT        0x00000001L
00070
00075 #define SS_GRAYRECT         0x00000002L
00076
00081 #define SS_WHITERECT        0x00000003L
00082
00087 #define SS_BLACKFRAME       0x00000004L
00088
00093 #define SS_GRAYFRAME        0x00000005L
00094
00099 #define SS_WHITEFRAME       0x00000006L
00100
00105 #define SS_GROUPBOX         0x00000007L
00106
00111 #define SS_ICON             0x00000008L
00112
00117 #define SS_BITMAP           0x00000009L
00118
00119 /* Reserved */
00120 #define SS_OWNERDRAW        0x0000000AL
00121
00122 /* Reserved */
00123 #define SS_ENHMETAFILE      0x0000000BL
00124
00129 #define SS_TYPEMASK         0x0000000FL
00130
00135 #define SS_LEFT             0x00000010L
00136
00141 #define SS_CENTER           0x00000020L
00142
00147 #define SS_RIGHT            0x00000030L
00148
00154 #define SS_ALIGNMASK        0x000000F0L
00155
00163 #define SS_NOPREFIX         0x00000100L
00164
00170 #define SS_CENTERIMAGE      0x00000200L
00171
00180 #define SS_NOWORDWRAP       0x00000400L
00181
00188 #define SS_LEFTNOWORDWRAP   SS_NOWORDWRAP
00189
00194 #define SS_REALSIZEIMAGE    0x00000800L
00195
00201 #define SS_NOTIFY           0x00001000L
00202
00209 /* Reserved */
00210 #define STM_SETICON         0xF170
00211 /* Reserved */
00212 #define STM_GETICON         0xF171
00213
00236 #define STM_SETIMAGE        0xF172
00237
00254 #define STM_GETIMAGE        0xF173
00255
00256 #define STM_MSGMAX          0xF174
00257
00272 #define STN_DBLCLK          1
00273
00274 /* Not use */
00275 #define STN_ENABLE          2
00276 /* Not use */
00277 #define STN_DISABLE         3
00278
00286 #define STN_CLICKED         4
00287
00294 #ifdef __cplusplus
00295 }
00296 #endif  /* __cplusplus */
00297
00298 #endif /* _MGUI_CTRL_STATIC_H */
00299
Generated on Fri Dec 17 13:49:41 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: textedit.h Source File

include » ctrl

textedit.h

Go to the documentation of this file.
00001
00019 /*
00020  * $Id: textedit.h 12850 2010-05-06 06:59:19Z wanzheng $
00021  *
00022  *             MiniGUI for Linux/uClinux, eCos, uC/OS-II, VxWorks,
00023  *                     pSOS, ThreadX, NuCleus, OSE, and Win32.
00024  *
00025  *             Copyright (C) 2002-2008 Feynman Software.
00026  *             Copyright (C) 1999-2002 Wei Yongming.
00027  */
00028
00029 #ifndef _MGUI_CTRL_TEXTEDIT_H
00030 #define _MGUI_CTRL_TEXTEDIT_H
00031
00032
00033 #ifdef __cplusplus
00034 extern "C" {
00035 #endif  /* __cplusplus */
00036
00051 #define CTRL_TEXTEDIT           ("textedit")
00052
00053
00058 typedef GHANDLE HTEXTDOC;
00059
00060
00066 #define TES_BASELINE            ES_BASELINE
00067 #define TES_AUTOWRAP            ES_AUTOWRAP
00068 #define TES_TITLE               ES_TITLE
00069
00077 #define TEM_RESETCONTENT        0xF400
00078 #define TEM_ADDLINE             0xF401
00079
00080 #define TEM_GETBKGNDINVALID     0xF402
00081
00089 #define TEN_CLICK               1
00090
00091
00098 #ifdef __cplusplus
00099 }
00100 #endif  /* __cplusplus */
00101
00102 #endif /* _MGUI_CTRL_TEXTEDIT_H */
00103
Generated on Fri Dec 17 13:49:41 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: trackbar.h Source File

include » ctrl

trackbar.h

Go to the documentation of this file.
00001
00019 /*
00020  * $Id: trackbar.h 10690 2008-08-18 09:32:47Z weiym $
00021  *
00022  *             MiniGUI for Linux/uClinux, eCos, uC/OS-II, VxWorks,
00023  *                     pSOS, ThreadX, NuCleus, OSE, and Win32.
00024  *
00025  *             Copyright (C) 2002-2008 Feynman Software.
00026  *             Copyright (C) 1999-2002 Wei Yongming.
00027  */
00028
00029 #ifndef _MGUI_CTRL_TRACKBAR
00030 #define _MGUI_CTRL_TRACKBAR
00031
00032
00033 #ifdef __cplusplus
00034 extern "C" {
00035 #endif  /* __cplusplus */
00036
00051 #define CTRL_TRACKBAR              ("trackbar")
00052
00057 #define TBLEN_TIP                   31
00058
00069 #define TBS_NOTIFY                 0x0001L
00070
00075 #define TBS_VERTICAL               0x0002L
00076
00081 #define TBS_BORDER                 0x0004L
00082
00087 #define TBS_TIP                    0x0008L
00088
00093 #define TBS_NOTICK                 0x0010L
00094
00095 /* internally used style */
00096 #define TBS_FOCUS                  0x1000L
00097
00124 #define TBM_SETRANGE               0xF090
00125
00139 #define TBM_GETMIN                 0xF091
00140
00157 #define TBM_SETPOS                 0xF092
00158
00172 #define TBM_GETPOS                 0xF093
00173
00195 #define TBM_SETLINESIZE            0xF094
00196
00215 #define TBM_GETLINESIZE            0xF095
00216
00239 #define TBM_SETPAGESIZE            0xF096
00240
00260 #define TBM_GETPAGESIZE            0xF097
00261
00280 #define TBM_SETTIP            0xF098
00281
00302 #define TBM_GETTIP                 0xF09A
00303
00320 #define TBM_SETTICKFREQ            0xF09B
00321
00335 #define TBM_GETTICKFREQ            0xF09C
00336
00353 #define TBM_SETMIN                 0xF09D
00354
00371 #define TBM_SETMAX                 0xF09E
00372
00386 #define TBM_GETMAX                 0xF09F
00387
00388 #define TBR_MSGMAX                 0xF010
00389
00401 #define TBN_REACHMIN                1
00402
00407 #define TBN_REACHMAX                2
00408
00413 #define TBN_CHANGE                  3
00414
00419 #define TBN_STARTDRAG               4
00420
00425 #define TBN_STOPDRAG                5
00426
00437 #define LFRDR_TBS_PRESSED        0x0100L
00438
00443 #define LFRDR_TBS_HILITE         0x0200L
00444
00451 #ifdef __cplusplus
00452 }
00453 #endif  /* __cplusplus */
00454
00455 #endif /* _MGUI_CTRL_TRACKBAR */
00456
Generated on Fri Dec 17 13:49:41 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: treeview.h Source File

include » ctrl

treeview.h

Go to the documentation of this file.
00001
00019 /*
00020  * $Id: treeview.h 13068 2010-08-03 10:56:31Z zouqizhi $
00021  *
00022  *             MiniGUI for Linux/uClinux, eCos, uC/OS-II, VxWorks,
00023  *                     pSOS, ThreadX, NuCleus, OSE, and Win32.
00024  *
00025  *             Copyright (C) 2002-2008 Feynman Software.
00026  *             Copyright (C) 1998-2002 Wei Yongming.
00027  */
00028
00029 #ifndef EXT_TREEVIEW_H
00030 #define EXT_TREEVIEW_H
00031
00032
00033 #ifdef  __cplusplus
00034 extern "C" {
00035 #endif
00036
00062 #define CTRL_TREEVIEW           ("TreeView")
00063 #define CTRL_TREEVIEW_RDR           ("TreeView_rdr")
00064
00065 #define TVIF_ROOT               0x0001L
00066 #define TVIF_FOLD               0x0004L
00067 #define TVIF_SELECTED           0x0008L
00068
00070 typedef struct _TVITEMINFO
00071 {
00073     char *text;
00087     DWORD dwFlags;
00088
00090     HICON hIconFold;
00092     HICON hIconUnfold;
00093
00095     DWORD dwAddData;
00096 } TVITEMINFO;
00097
00102 typedef TVITEMINFO *PTVITEMINFO;
00103
00114 #define TVS_NOTIFY              0x0001L
00115
00120 #define TVS_WITHICON            0x0002L
00121
00132 #define TVS_ICONFORSELECT       0x0000L
00133
00134 /* Internally used style */
00135 #define TVS_FOCUS               0x0008L
00136
00141 #define TVS_SORT                0x0010L
00142
00169 #define TVM_ADDITEM             0xF110
00170
00175 #define TVM_INSERTITEM          0xF111
00176
00190 #define TVM_GETROOT             0xF112
00191
00206 #define TVM_DELTREE             0xF113
00207
00230 #define TVM_SEARCHITEM            0xF114
00231
00251 #define TVM_FINDCHILD           0xF115
00252
00266 #define TVM_GETSELITEM          0xF116
00267
00284 #define TVM_SETSELITEM          0xF117
00285
00303 #define TVM_GETITEMTEXTLEN      0xF118
00304
00324 #define TVM_GETITEMTEXT         0xF119
00325
00349 #define TVM_GETITEMINFO         0xF11A
00350
00370 #define TVM_SETITEMINFO         0xF11B
00371
00372 #define TVIR_PARENT             1
00373 #define TVIR_FIRSTCHILD         2
00374 #define TVIR_NEXTSIBLING        3
00375 #define TVIR_PREVSIBLING        4
00376
00405 #define TVM_GETRELATEDITEM      0xF11C
00406
00436 #define TVM_SETSTRCMPFUNC       0xF11D
00437
00438 #define TVM_MSGMAX              0xF120
00439
00454 #define TVN_ERRSPACE            255
00455
00460 #define TVN_SELCHANGE           1
00461
00466 #define TVN_DBLCLK              2
00467
00475 #define TVN_SETFOCUS            4
00476
00484 #define TVN_KILLFOCUS           5
00485
00490 #define TVN_CLICKED             7
00491
00496 #define TVN_ENTER               8
00497
00510 #define TVN_FOLDED              9
00511
00524 #define TVN_UNFOLDED              10
00525
00532 #ifdef  __cplusplus
00533 }
00534 #endif
00535
00536 #endif /* EXT_TREEVIEW_H */
00537
Generated on Fri Dec 17 13:49:41 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: window.h Source File

include

window.h

Go to the documentation of this file.
00001
00021 /*
00022  * $Id: window.h 13588 2010-10-29 08:41:48Z houhuihua $
00023  *
00024  *             MiniGUI for Linux/uClinux, eCos, uC/OS-II, VxWorks,
00025  *                     pSOS, ThreadX, NuCleus, OSE, and Win32.
00026  *
00027  *             Copyright (C) 2002-2009 Feynman Software.
00028  *             Copyright (C) 1998-2002 Wei Yongming.
00029  */
00030
00031 #ifndef _MGUI_WINDOW_H
00032 #define _MGUI_WINDOW_H
00033
00034
00035 #ifdef __cplusplus
00036 extern "C" {
00037 #endif  /* __cplusplus */
00038
00044 /* Definitions of common messages. */
00045 #define MSG_NULLMSG         0x0000
00046 #define MSG_SYNCMSG         0x0000
00047
00053 /* Group 1 from 0x0001 to 0x000F, the mouse messages. */
00054 #define MSG_FIRSTMOUSEMSG   0x0001
00055
00078 #define MSG_LBUTTONDOWN     0x0001
00079
00099 #define MSG_LBUTTONUP       0x0002
00100
00120 #define MSG_LBUTTONDBLCLK   0x0003
00121
00141 #define MSG_MOUSEMOVE       0x0004
00142
00165 #define MSG_RBUTTONDOWN     0x0005
00166
00186 #define MSG_RBUTTONUP       0x0006
00187
00207 #define MSG_RBUTTONDBLCLK   0x0007
00208
00209 #define MSG_NCMOUSEOFF      0x0007
00210
00230 #define MSG_NCLBUTTONDOWN   0x0008
00231
00251 #define MSG_NCLBUTTONUP     0x0009
00252
00272 #define MSG_NCLBUTTONDBLCLK 0x000A
00273
00293 #define MSG_NCMOUSEMOVE     0x000B
00294
00314 #define MSG_NCRBUTTONDOWN   0x000C
00315
00335 #define MSG_NCRBUTTONUP     0x000D
00336
00356 #define MSG_NCRBUTTONDBLCLK 0x000E
00357
00358 #define MSG_LASTMOUSEMSG    0x000F
00359
00367 /* Group 2 from 0x0010 to 0x001F, the key messages. */
00368 #define MSG_FIRSTKEYMSG     0x0010
00369
00392 #define MSG_KEYDOWN         0x0010
00393
00412 #define MSG_CHAR            0x0011
00413
00432 #define MSG_KEYUP           0x0012
00433
00452 #define MSG_SYSKEYDOWN      0x0013
00453
00472 #define MSG_SYSCHAR         0x0014
00473
00492 #define MSG_SYSKEYUP        0x0015
00493
00519 #define MSG_KEYSYM  0x0016
00520
00521 /* keyboard longpress supported */
00522
00530 #define MSG_KEYLONGPRESS    0x0017
00531
00539 #define MSG_KEYALWAYSPRESS  0x0018
00540
00547 #define DEF_LPRESS_TIME     500
00548
00555 #define DEF_APRESS_TIME     1000
00556
00561 #define DEF_INTERVAL_TIME   200
00562
00563 extern unsigned int __mg_key_longpress_time;
00564 extern unsigned int __mg_key_alwayspress_time;
00565 extern unsigned int __mg_interval_time;
00566
00571 #define SetKeyLongPressTime(time)       \
00572     do {                                \
00573         __mg_key_longpress_time = time; \
00574     } while (0)
00575
00580 #define SetKeyAlwaysPressTime(time)     \
00581     do {                                \
00582         __mg_key_alwayspress_time = time; \
00583     } while (0)
00584
00589 #define SetIntervalTime(time)           \
00590     do {                                \
00591         __mg_interval_time = time;      \
00592     } while (0)
00593
00594 #define MSG_LASTKEYMSG      0x001F
00595
00603 /* Group 3 from 0x0020 to 0x005F, User-machine Interaction messages. */
00604 #define MSG_FIRSTPOSTMSG    0x0020
00605
00630 #define MSG_SETCURSOR       0x0020
00631
00632     #define HT_MASK             0xFF
00633
00634     #define HT_UNKNOWN          0x00
00635     #define HT_OUT              0x01
00636     #define HT_MENUBAR          0x02
00637     #define HT_TRANSPARENT      0x03
00638
00639     #define HT_BORDER           0x04
00640     #define HT_CLIENT           0x0C
00641
00642     #define HT_NEEDCAPTURE      0x10
00643     #define HT_ICON             0x14
00644     #define HT_CLOSEBUTTON      0x15
00645     #define HT_MAXBUTTON        0x16
00646     #define HT_MINBUTTON        0x17
00647     #define HT_HSCROLL          0x18
00648     #define HT_VSCROLL          0x19
00649
00650     #define HT_DRAGGABLE        0x20
00651     #define HT_CAPTION          0x20
00652
00653     /*indicate cursor at border */
00654     #define HT_BORDER_MASK      0x28
00655     #define HT_BORDER_TOP       0x28
00656     #define HT_BORDER_BOTTOM    0x29
00657     #define HT_BORDER_LEFT      0x2A
00658     #define HT_BORDER_RIGHT     0x2B
00659
00660     /*indicate cursor at border corner*/
00661     #define HT_CORNER_MASK      0x2C
00662     #define HT_CORNER_TL        0x2C
00663     #define HT_CORNER_TR        0x2D
00664     #define HT_CORNER_BL        0x2E
00665     #define HT_CORNER_BR        0x2F
00666
00667     /*new scrollbar hittest value
00668      * can be AND'ed with HT_NEEDCAPTURE*/
00669     #define HT_SB_MASK          0x50
00670
00671     #define HT_SB_LEFTARROW     0x50
00672     #define HT_SB_RIGHTARROW    0x51
00673     #define HT_SB_LEFTSPACE     0x52
00674     #define HT_SB_RIGHTSPACE    0x53
00675     #define HT_SB_HTHUMB        0x54
00676
00677     #define HT_SB_VMASK         0x58
00678
00679     #define HT_SB_UPARROW       0x58
00680     #define HT_SB_DOWNARROW     0x59
00681     #define HT_SB_UPSPACE       0x5a
00682     #define HT_SB_DOWNSPACE     0x5b
00683     #define HT_SB_VTHUMB        0x5c
00684
00685     #define HT_SB_UNKNOWN       0x5f
00686
00687 /*user defined hittest code are 0x80 ~ 0x8F*/
00688 #define HT_USER_MASK            0x80
00689
00690
00696 #define MSG_NCHITTEST       0x0021
00697
00704 #define MSG_HITTEST         MSG_NCHITTEST
00705
00710 #define MSG_CHANGESIZE      0x0022
00711
00712 /* reserved */
00713 #define MSG_QUERYNCRECT     0x0023
00714
00719 #define MSG_QUERYCLIENTAREA 0x0024
00720
00744 #define MSG_SIZECHANGING    0x0025
00745
00768 #define MSG_SIZECHANGED     0x0026
00769
00786 #define MSG_CSIZECHANGED     0x0027
00787
00798 #define MSG_SETFOCUS        0x0030
00799
00810 #define MSG_KILLFOCUS       0x0031
00811
00820 #define MSG_MOUSEACTIVE     0x0032
00821
00830 #define MSG_ACTIVE          0x0033
00831
00836 #define MSG_CHILDHIDDEN     0x0034
00837     #define RCTM_CLICK          1
00838     #define RCTM_KEY            2
00839     #define RCTM_MESSAGE        3
00840     #define RCTM_SHOWCTRL       4
00841
00866 #define MSG_ACTIVEMENU      0x0040
00867
00885 #define MSG_DEACTIVEMENU    0x0041
00886
00887 /* Scroll bar notifying code */
00898 #define SB_LINEUP           0x01a
00899
00905 #define SB_LINEDOWN         0x02
00906
00912 #define SB_LINELEFT         0x03
00913
00919 #define SB_LINERIGHT        0x04
00920
00926 #define SB_PAGEUP           0x05
00927
00933 #define SB_PAGEDOWN         0x06
00934
00940 #define SB_PAGELEFT         0x07
00941
00947 #define SB_PAGERIGHT        0x08
00948
00954 #define SB_THUMBPOSITION    0x09
00955
00961 #define SB_THUMBTRACK       0x0A
00962
00968 #define SB_TOP              0x0B
00969
00975 #define SB_BOTTOM           0x0C
00976
00982 #define SB_ENDSCROLL        0x0D
00983
01014 #define MSG_HSCROLL         0x0042
01015
01044 #define MSG_VSCROLL         0x0043
01045
01058 #define MSG_NCSETCURSOR     0x0044
01059
01075 #define MSG_MOUSEMOVEIN     0x0050
01076
01082 #define MSG_WINDOWDROPPED   0x0051
01083
01084 #define MSG_LASTPOSTMSG     0x005F
01085
01093     /* Group 4 from 0x0060 to 0x009F, the creation messages. */
01094 #define MSG_FIRSTCREATEMSG  0x0060
01095
01123 #define MSG_CREATE          0x0060
01124
01153 #define MSG_NCCREATE        0x0061
01154
01155 /*Not use*/
01156 #define MSG_INITPANES       0x0062
01157 #define MSG_DESTROYPANES    0x0063
01158
01172 #define MSG_DESTROY         0x0064
01173
01174 /* Not use */
01175 #define MSG_NCDESTROY       0x0065
01176
01184 #define MSG_CLOSE           0x0066
01185
01186 /* Not use */
01187 #define MSG_NCCALCSIZE      0x0067
01188
01189 /*
01190  * Not implemented, this message is reserved for future use.
01191  *
01192  * \def MSG_MAXIMIZE
01193  * \brief Indicates the user has clicked the maximizing box on the caption.
01194  *
01195  * This message is sent to the window when the user has clicked the maximizing
01196  * box on the caption of the window.
01197  */
01198 #define MSG_MAXIMIZE        0x0068
01199
01200 /*
01201  * Not implemented, this message is reserved for future use.
01202  *
01203  * \def MSG_MINIMIZE
01204  * \brief Indicates the user has clicked the minimizing box on the caption.
01205  *
01206  * This message is sent to the window when the user has clicked the
01207  * minimizing box on the caption of the window.
01208  */
01209 #define MSG_MINIMIZE        0x0069
01210
01211 /*
01212  * Not implemented, this message is reserved for future use.
01213  *
01214  * \def MSG_HELP
01215  * \brief Indicates the user has clicked the help box on the caption.
01216  *
01217  * This message is sent to the window when the user has clicked the
01218  * help box on the caption of the window.
01219  */
01220 #define MSG_HELP            0x006A
01221
01222 #define MSG_LASTCREATEMSG   0x009F
01223
01231 /* Group 5 from 0x00A0 to 0x00CF, the paint messages. */
01232 #define MSG_FIRSTPAINTMSG   0x00A0
01233
01258 #define MSG_SHOWWINDOW      0x00A0
01259
01276 #define MSG_ERASEBKGND          0x00B0      /* this is an async message */
01277
01291 #define MSG_PAINT           0x00B1
01292
01297 #define MSG_NCPAINT         0x00B2
01298
01303 #define MSG_NCACTIVATE      0x00B3
01304
01309 #define MSG_SYNCPAINT       0x00B4
01310
01311 #define MSG_LASTPAINTMSG    0x00CF
01312
01320 /* Group 6 from 0x00D0 to 0x00EF, the internal desktop messages. */
01321 #define MSG_FIRSTSESSIONMSG 0x00D0
01322
01323 #define MSG_STARTSESSION    0x00D0
01324 #define MSG_QUERYENDSESSION 0x00D1
01325 #define MSG_ENDSESSION      0x00D2
01326 #define MSG_REINITSESSION   0x00D3
01327
01328 #define MSG_ERASEDESKTOP    0x00DE
01329 #define MSG_PAINTDESKTOP    0x00DF
01330
01331 #define MSG_DT_MOUSEOFF     0x00E0
01332
01350 #define MSG_DT_LBUTTONDOWN  0x00E1
01351
01369 #define MSG_DT_LBUTTONUP    0x00E2
01370
01388 #define MSG_DT_LBUTTONDBLCLK    0x00E3
01389
01407 #define MSG_DT_MOUSEMOVE    0x00E4
01408
01427 #define MSG_DT_RBUTTONDOWN  0x00E5
01428
01446 #define MSG_DT_RBUTTONUP    0x00E6
01447
01465 #define MSG_DT_RBUTTONDBLCLK    0x00E7
01466
01467 #define MSG_DT_KEYOFF       0x00D8
01468
01486 #define MSG_DT_KEYDOWN      0x00E8
01487
01504 #define MSG_DT_KEYUP        0x00EA
01505
01506 #define MSG_DT_SYSKEYDOWN   0x00EB
01507
01508 #define MSG_DT_SYSKEYUP     0x00ED
01509
01510 #define MSG_DT_SYSCHAR      0x00EC
01511 #define MSG_DT_CHAR         0x00E9
01512
01513 #define MSG_DT_KEYLONGPRESS     0x00EE
01514 #define MSG_DT_KEYALWAYSPRESS   0x00EF
01515
01516 #define MSG_LASTSESSIONMSG  0x00EF
01517
01525 /* Group 7 from 0x00F0 to 0x010F, Internal window management messages. */
01526 #define MSG_FIRSTWINDOWMSG  0x00F0
01527
01528 #define MSG_ADDNEWMAINWIN   0x00F0
01529 #define MSG_REMOVEMAINWIN   0x00F1
01530 #define MSG_MOVETOTOPMOST   0x00F2
01531 #define MSG_SETACTIVEMAIN   0x00F3
01532 #define MSG_GETACTIVEMAIN   0x00F4
01533 #define MSG_SHOWMAINWIN     0x00F5
01534 #define MSG_HIDEMAINWIN     0x00F6
01535 #define MSG_MOVEMAINWIN     0x00F7
01536 #define MSG_SETCAPTURE      0x00F8
01537 #define MSG_GETCAPTURE      0x00F9
01538
01539 #define MSG_ENDTRACKMENU    0x00FA
01540 #define MSG_TRACKPOPUPMENU  0x00FB
01541 #define MSG_CLOSEMENU       0x00FC
01542 #define MSG_SCROLLMAINWIN   0x00FD
01543 #define MSG_CARET_CREATE    0x00FE
01544 #define MSG_CARET_DESTROY   0x00FF
01545
01546 #define MSG_ENABLEMAINWIN   0x0100
01547 #define MSG_ISENABLED       0x0101
01548
01549 #define MSG_SETWINCURSOR    0x0102
01550
01551 #define MSG_GETNEXTMAINWIN  0x0103
01552
01553 #define MSG_SHOWGLOBALCTRL  0x010A
01554 #define MSG_HIDEGLOBALCTRL  0x010B
01555
01556 typedef struct _DRAGINFO {
01557     int     location;
01558     int     init_x, init_y;
01559 } DRAGINFO;
01560
01561 /* client to server; wParam: hwnd, lParam: DRAGINFO. */
01562 #define MSG_STARTDRAGWIN    0x010C
01563 /* client to server; wParam: hwnd, lParam: 0L. */
01564 #define MSG_CANCELDRAGWIN   0x010D
01565
01566 #define MSG_CHANGECAPTION   0x010E
01567
01568 #define MSG_LASTWINDOWMSG   0x010F
01569
01577 /* Group 8 from 0x0120 to 0x013F, the dialog and control messages. */
01578 #define MSG_FIRSTCONTROLMSG 0x0120
01579
01601 #define MSG_COMMAND         0x0120
01602
01607 #define MSG_SYSCOMMAND      0x0121
01608
01613 #define MSG_GETDLGCODE      0x0122
01614
01641 #define MSG_INITDIALOG      0x0123
01642
01643 /*Reserved*/
01644 #define MSG_NEXTDLGCTRL     0x0124
01645 #define MSG_ENTERIDLE       0x0125
01646
01651 #define MSG_DLG_GETDEFID    0x0126
01652
01657 #define MSG_DLG_SETDEFID    0x0127
01658
01659 /* #define MSG_DLG_REPOSITION  0x0128 */
01660
01667 #define MSG_ISDIALOG        0x0128
01668
01686 #define MSG_INITPAGE        0x0129
01687
01708 #define MSG_SHOWPAGE        0x012A
01709
01729 #define MSG_SHEETCMD        0x012B
01730
01750 #define MSG_INITCONTAINER   0x012C
01751
01780 #define MSG_SVCONTCMD       0x012D
01781
01800 #define MSG_FREEZECTRL      0x012E
01801
01820 #define MSG_FONTCHANGING    0x0130
01821
01822
01830 #define MSG_FONTCHANGED     0x0131
01831
01849 #define MSG_GETTEXTLENGTH   0x0132
01850
01873 #define MSG_GETTEXT         0x0133
01874
01895 #define MSG_SETTEXT         0x0134
01896
01910 #define MSG_ENABLE          0x0135
01911
01912 #define MSG_LASTCONTROLMSG  0x013F
01913
01921 /* Group 9 from 0x0140 to 0x016F, the system messages. */
01922 #define MSG_FIRSTSYSTEMMSG  0x0140
01923
01924 #define MSG_QUIT            0x0140
01925
01933 #define MSG_IDLE            0x0142
01934
01935 #define MSG_TIMEOUT         0x0143
01936
01952 #define MSG_TIMER           0x0144
01953
01954 #define MSG_CARETBLINK      0x0145
01955
01956 #ifndef _MGRM_THREADS
01957
01985 #define MSG_FDEVENT         0x0146
01986
02000 #define MSG_SRVNOTIFY       0x0147
02001
02002 #ifdef _MGRM_PROCESSES
02003     #define MSG_UPDATECLIWIN    0x0148
02004 #endif
02005
02006 #endif /* !_MGRM_THREADS */
02007
02021 #define MSG_DOESNEEDIME     0x0150
02022
02023 /* flag code. */
02024 #define IME_STATUS_REGISTERED   0x0000
02025 #define IME_STATUS_ENABLED      0x0001
02026 #define IME_STATUS_AUTOTRACK    0x0002
02027 #define IME_STATUS_LANGUAGE     0x0003
02028     #define IME_LANGUAGE_UNKNOWN    0x0000
02029     #define IME_LANGUAGE_LATIN      0x0001
02030     #define IME_LANGUAGE_ZHCN       0x0002
02031     #define IME_LANGUAGE_ZHTW       0x0003
02032 #define IME_STATUS_ENCODING     0x0004
02033     #define IME_ENCODING_LOCAL      0x0000
02034     #define IME_ENCODING_UTF8       0x0001
02035 #define IME_STATUS_VERSION          0x0005
02036 #define IME_STATUS_USER_MIN         0x0006
02037 #define IME_STATUS_USER_MAX         0x0020
02038
02039 /* IME edit type */
02040 #define IME_WINDOW_TYPE_NOT_EDITABLE    0x0000
02041 #define IME_WINDOW_TYPE_EDITABLE        0x0001
02042 #define IME_WINDOW_TYPE_READONLY        0x0002
02043 #define IME_WINDOW_TYPE_PASSWORD        0x0003
02044
02045 /*Internal use*/
02046 #define MSG_IME_REGISTER    0x0151
02047 #define MSG_IME_UNREGISTER  0x0152
02048 #define MSG_IME_OPEN        0x0153
02049 #define MSG_IME_CLOSE       0x0154
02050 #define MSG_IME_SETSTATUS   0x0156
02051 #define MSG_IME_GETSTATUS   0x0157
02052 #define MSG_IME_SETTARGET   0x0158
02053 #define MSG_IME_GETTARGET   0x0159
02054 #define MSG_IME_SETPOS      0x015A
02055 #define MSG_IME_GETPOS      0x015B
02056
02057 /*  new ime msg. */
02058 #define MSG_IME_SET_TARGET_INFO   0x015C
02059 #define MSG_IME_GET_TARGET_INFO   0x015D
02060
02061 #define MSG_SHOWMENU        0x0160
02062 #define MSG_HIDEMENU        0x0161
02063
02064 #define MSG_ADDTIMER        0x0162
02065 #define MSG_REMOVETIMER     0x0163
02066 #define MSG_RESETTIMER      0x0164
02067
02068 #define MSG_WINDOWCHANGED   0x0165
02069
02070 #define MSG_BROADCASTMSG    0x0166
02071
02072 #define MSG_REGISTERWNDCLASS    0x0167
02073 #define MSG_UNREGISTERWNDCLASS  0x0168
02074 #define MSG_NEWCTRLINSTANCE     0x0169
02075 #define MSG_REMOVECTRLINSTANCE  0x016A
02076 #define MSG_GETCTRLCLASSINFO    0x016B
02077 #define MSG_CTRLCLASSDATAOP     0x016C
02078     #define CCDOP_GETCCI        0x01
02079     #define CCDOP_SETCCI        0x02
02080
02081 #define MSG_REGISTERKEYHOOK     0x016D
02082 #define MSG_REGISTERMOUSEHOOK   0x016E
02083
02084 #define MSG_LASTSYSTEMMSG   0x016F
02085
02093 /* Group 10 from 0x0170 to 0x018F, the menu messages */
02094 #define MSG_FIRSTMENUMSG    0x0170
02095
02096 /*Internal use*/
02097 #define MSG_INITMENU        0x0170
02098 #define MSG_INITMENUPOPUP   0x0171
02099 #define MSG_MENUSELECT      0x0172
02100 #define MSG_MENUCHAR        0x0173
02101 #define MSG_ENTERMENULOOP   0x0174
02102 #define MSG_EXITMENULOOP    0x0175
02103 #define MSG_CONTEXTMENU     0x0176
02104 #define MSG_NEXTMENU        0x0177
02105
02106 #define MSG_LASTMENUMSG     0x018F
02107
02115 #define MSG_FIRSTUSERMSG    0x0800
02116
02117
02125 #define MSG_USER            0x0800
02126
02127 #define MSG_LASTUSERMSG     0xEFFF
02128
02152 typedef struct _MSG
02153 {
02155     HWND             hwnd;
02157     int              message;
02159     WPARAM           wParam;
02161     LPARAM           lParam;
02163     unsigned int     time;
02164 #ifdef _MGRM_THREADS
02165
02166     void*            pAdd;
02167 #endif
02168 } MSG;
02169 typedef MSG* PMSG;
02170
02171 #define QS_NOTIFYMSG        0x10000000
02172 #ifdef _MGRM_THREADS
02173   #define QS_SYNCMSG        0x20000000
02174 #else
02175   #define QS_DESKTIMER      0x20000000
02176 #endif
02177 #define QS_POSTMSG          0x40000000
02178 #define QS_QUIT             0x80000000
02179 #define QS_INPUT            0x01000000
02180 #define QS_PAINT            0x02000000
02181 #define QS_TIMER            0x0000FFFF
02182 #define QS_EMPTY            0x00000000
02183
02189 #define PM_NOREMOVE     0x0000
02190
02196 #define PM_REMOVE       0x0001
02197
02203 #define PM_NOYIELD      0x0002
02204
02232 MG_EXPORT BOOL GUIAPI PeekMessageEx (PMSG pMsg, HWND hWnd,
02233                 int iMsgFilterMin, int iMsgFilterMax,
02234                 BOOL bWait, UINT uRemoveMsg);
02235
02254 static inline BOOL GUIAPI GetMessage (PMSG pMsg, HWND hWnd)
02255 {
02256     return PeekMessageEx (pMsg, hWnd, 0, 0, TRUE, PM_REMOVE);
02257 }
02258
02275 MG_EXPORT BOOL GUIAPI WaitMessage (PMSG pMsg, HWND hMainWnd);
02276
02291 MG_EXPORT BOOL GUIAPI HavePendingMessage (HWND hMainWnd);
02292
02319 static inline BOOL GUIAPI PeekMessage (PMSG pMsg, HWND hWnd, int iMsgFilterMin,
02320                          int iMsgFilterMax, UINT uRemoveMsg)
02321 {
02322     return PeekMessageEx (pMsg, hWnd, iMsgFilterMin, iMsgFilterMax,
02323                            FALSE, uRemoveMsg);
02324 }
02325
02352 MG_EXPORT BOOL GUIAPI PeekPostMessage (PMSG pMsg, HWND hWnd, int iMsgFilterMin,
02353                 int iMsgFilterMax, UINT uRemoveMsg);
02354
02376 MG_EXPORT int GUIAPI PostMessage (HWND hWnd, int iMsg,
02377                 WPARAM wParam, LPARAM lParam);
02378
02394 MG_EXPORT int GUIAPI SendMessage (HWND hWnd, int iMsg,
02395                 WPARAM wParam, LPARAM lParam);
02396
02412 MG_EXPORT void GUIAPI SetAutoRepeatMessage (HWND hwnd, int msg,
02413                 WPARAM wParam, LPARAM lParam);
02414
02415 #ifndef _MGRM_THREADS
02416
02423 #define SendAsyncMessage SendMessage
02424
02425 #ifdef _MGRM_PROCESSES
02426
02427 #define CLIENTS_TOPMOST          -1
02428 #define CLIENTS_ALL              -2
02429 #define CLIENTS_EXCEPT_TOPMOST   -3
02430 #define CLIENT_ACTIVE            -4
02431
02462 int GUIAPI Send2Client (MSG* msg, int cli);
02463
02483 BOOL GUIAPI Send2TopMostClients (int iMsg, WPARAM wParam, LPARAM lParam);
02484
02505 BOOL GUIAPI Send2ActiveWindow (const MG_Layer* layer,
02506                  int iMsg, WPARAM wParam, LPARAM lParam);
02507
02508 #endif /* _MGRM_PROCESSES */
02509
02510 #else /* !_MGRM_THREADS */
02511
02532 MG_EXPORT int GUIAPI PostSyncMessage (HWND hWnd, int iMsg, WPARAM wParam, LPARAM lParam);
02533
02554 MG_EXPORT int GUIAPI SendAsyncMessage (HWND hWnd, int iMsg, WPARAM wParam, LPARAM lParam);
02555 #endif
02556
02575 MG_EXPORT int GUIAPI SendNotifyMessage (HWND hWnd, int iMsg, WPARAM wParam, LPARAM lParam);
02576
02591 MG_EXPORT int GUIAPI BroadcastMessage (int iMsg, WPARAM wParam, LPARAM lParam);
02592
02605 MG_EXPORT int GUIAPI PostQuitMessage (HWND hWnd);
02606
02607 #define KBD_LAYOUT_DEFAULT  "default"
02608 #define KBD_LAYOUT_FRPC     "frpc"
02609 #define KBD_LAYOUT_FR       "fr"
02610 #define KBD_LAYOUT_DE       "de"
02611 #define KBD_LAYOUT_DELATIN1 "delatin1"
02612 #define KBD_LAYOUT_IT       "it"
02613 #define KBD_LAYOUT_ES       "es"
02614 #define KBD_LAYOUT_ESCP850  "escp850"
02615 #define KBD_LAYOUT_HEBREW   "hebrew"
02616 #define KBD_LAYOUT_ARABIC   "arabic"
02617
02655 MG_EXPORT BOOL GUIAPI SetKeyboardLayout (const char* kbd_layout);
02656
02677 MG_EXPORT BOOL GUIAPI TranslateMessage (PMSG pMsg);
02678
02701 MG_EXPORT BOOL GUIAPI TranslateKeyMsgToChar (int message,
02702                 WPARAM wParam, LPARAM lParam, WORD *ch);
02703
02720 MG_EXPORT int GUIAPI DispatchMessage (PMSG pMsg);
02721
02734 MG_EXPORT int GUIAPI ThrowAwayMessages (HWND pMainWnd);
02735
02736 #ifndef _MGRM_THREADS
02737
02752 MG_EXPORT BOOL GUIAPI EmptyMessageQueue (HWND hWnd);
02753
02754 #endif
02755
02756 #ifdef _MGHAVE_MSG_STRING
02757
02772 MG_EXPORT const char* GUIAPI Message2Str (int message);
02773
02790 MG_EXPORT void GUIAPI PrintMessage (FILE* fp, HWND hWnd,
02791                 int iMsg, WPARAM wParam, LPARAM lParam);
02792
02793 #endif
02794
02806 #define HOOK_GOON       0
02807
02812 #define HOOK_STOP       1
02813
02814 #ifndef _MGRM_PROCESSES
02815
02822 typedef int (* MSGHOOK)(void* context, HWND dst_wnd,
02823                 int msg, WPARAM wparam, LPARAM lparam);
02824
02828 typedef struct _HOOKINFO
02829 {
02831     void* context;
02833     MSGHOOK hook;
02834 } HOOKINFO;
02835
02852 MG_EXPORT MSGHOOK GUIAPI RegisterKeyMsgHook (void* context, MSGHOOK hook);
02853
02870 MG_EXPORT MSGHOOK GUIAPI RegisterMouseMsgHook (void* context, MSGHOOK hook);
02871
02872 #endif /* !_MGRM_PROCESSES */
02873
02874 #ifndef _MGRM_THREADS
02875
02889 typedef int (* SRVEVTHOOK) (PMSG pMsg);
02890
02904 MG_EXPORT SRVEVTHOOK GUIAPI SetServerEventHook (SRVEVTHOOK SrvEvtHook);
02905
02906 #ifdef _MGRM_PROCESSES
02907
02929 MG_EXPORT HWND GUIAPI RegisterKeyHookWindow (HWND hwnd, DWORD flag);
02930
02952 MG_EXPORT HWND GUIAPI RegisterMouseHookWindow (HWND hwnd, DWORD flag);
02953
02954 #endif /* _MGRM_PROCESSES */
02955 #endif /* !_MGRM_THREADS */
02956
02957
02969 #define WS_CTRLMASK         0x0000FFFFL
02970
02975 #define WS_NONE             0x00000000L
02976
02981 #define WS_CHILD            0x40000000L
02982
02987 #define WS_CAPTION          0x20000000L
02988
02993 #define WS_SYSMENU          0x10000000L
02994
02999 #define WS_VISIBLE          0x08000000L
03000
03005 #define WS_DISABLED         0x04000000L
03006
03007 /* Main window states -- reserved for future use. */
03008 #define WS_MINIMIZE         0x02000000L
03009 #define WS_MAXIMIZE         0x01000000L
03010
03016 #define WS_DLGFRAME         0x00800000L
03017
03022 #define WS_BORDER           0x00400000L
03023
03028 #define WS_THICKFRAME       0x00200000L
03029
03034 #define WS_THINFRAME        0x00100000L
03035
03040 #define WS_VSCROLL          0x00080000L
03041
03046 #define WS_HSCROLL          0x00040000L
03047
03053 #define WS_GROUP            0x00020000L
03054
03061 #define WS_TABSTOP          0x00010000L
03062
03063 /*
03064  * Not implemented, reserved for future use.
03065  *
03066  * \def WS_MINIMIZEBOX
03067  * \brief Creates a window with minimizing box on caption.
03068  * \note This style is valid only for main window.
03069  */
03070 #define WS_MINIMIZEBOX      0x00020000L
03071
03072 /*
03073  * Not implemented, reserved for future use.
03074  *
03075  * \def WS_MAXIMIZEBOX
03076  * \brief Creates a window with maximizing box on caption.
03077  * \note This style is valid only for main window.
03078  */
03079 #define WS_MAXIMIZEBOX      0x00010000L
03080
03081 /* Obsolete styles, back-compatibility definitions. */
03082 #define WS_OVERLAPPED       0x00000000L
03083 #define WS_ABSSCRPOS        0x00000000L
03084
03089 #define WS_EX_CONTROL_MASK      0x0000000FL
03090
03095 #define WS_EX_INTERNAL_MASK     0xF0000000L
03096
03101 #define WS_EX_NONE              0x00000000L
03102
03107 #define WS_EX_TROUNDCNS         0x00000010L
03108
03113 #define WS_EX_BROUNDCNS         0x00000020L
03114
03121 #define WS_EX_USEPRIVATECDC     0x00000040L
03122
03127 #define WS_EX_NOTDRAGGABLE      0x00000080L
03128 #define WS_EX_DRAGGABLE         0x00000000L
03129
03134 #define WS_EX_USEPARENTFONT     0x00000100L
03135
03140 #define WS_EX_USEPARENTCURSOR   0x00000200L
03141
03146 #define WS_EX_USEPARENTRDR      0x00000400L
03147
03154 #define WS_EX_NOPARENTNOTIFY    0x00000800L
03155
03162 #define WS_EX_AUTOSECONDARYDC   0x00001000L
03163
03169 #define WS_EX_TRANSPARENT       0x00002000L
03170
03175 #define WS_EX_TOPMOST           0x00004000L
03176
03181 #define WS_EX_TOOLWINDOW        0x00008000L
03182
03183 /* The group reserved for BIDI support */
03184 #define WS_EX_RIGHT             0x00010000L
03185 #define WS_EX_LEFT              0x00000000L
03186 #define WS_EX_RTLREADING        0x00020000L
03187 #define WS_EX_LTRREADING        0x00000000L
03188
03193 #define WS_EX_LEFTSCROLLBAR     0x00040000L
03194
03199 #define WS_EX_RIGHTSCROLLBAR    0x00000000L
03200
03205 #define WS_EX_DLGHIDE           0x00100000L
03206
03211 #define WS_EX_NOCLOSEBOX        0x00400000L
03212
03217 #define WS_EX_CLIPCHILDREN      0x00800000L
03218
03223 #define WS_EX_LFRDR_MASK        0x0F000000L
03224
03230 #define WS_EX_LFRDR_CUSTOM1     0x01000000L
03231
03238 #define WS_EX_LFRDR_CUSTOM2     0x02000000L
03239
03246 #define WS_EX_LFRDR_CUSTOM3     0x04000000L
03247
03254 #define WS_EX_LFRDR_CUSTOM4     0x08000000L
03255
03256 /* Obsolete style, back-compatibility definitions. */
03257 #define WS_EX_IMECOMPOSE        0x00000000L
03258
03275 #define WE_FONTS_NUMBER             4
03276
03281 #define WE_METRICS_NUMBER           6
03282
03287 #define WE_COLORS_NUMBER            14
03288
03289 /* Window type mask */
03290 #define WE_ATTR_TYPE_MASK           0xF000
03291 #define WE_ATTR_TYPE_COLOR_MASK     0x0F00
03292 #define WE_ATTR_INDEX_MASK          0x00FF
03293
03294 #define WE_ATTR_TYPE_FONT           0x1000
03295 #define WE_ATTR_TYPE_METRICS        0x2000
03296
03297 #define WE_ATTR_TYPE_COLOR          0x3000
03298 #define WE_ATTR_TYPE_FGC            0x3000
03299 #define WE_ATTR_TYPE_BGCA           0x3100
03300 #define WE_ATTR_TYPE_BGCB           0x3200
03301
03302 /* window element id */
03303 #define WE_CAPTION                  0
03304 #define WE_MENU                     1
03305 #define WE_MESSAGEBOX               2
03306 #define WE_TOOLTIP                  3
03307 #define WE_WND_BORDER               4
03308 #define WE_SCROLLBAR                5
03309 #define WE_INACTIVE_CAPTION         6
03310 #define WE_WINDOW                   7
03311 #define WE_THREED_BODY              8
03312 #define WE_SELECTED_ITEM            9
03313 #define WE_DISABLED_ITEM            10
03314 #define WE_HIGHLIGHT_ITEM           11
03315 #define WE_SIGNIFICANT_ITEM         12
03316 #define WE_DESKTOP                  13
03317
03318 /* window element attr id */
03319
03320 /* Window caption */
03321 #define WE_FONT_CAPTION             (WE_CAPTION | WE_ATTR_TYPE_FONT)
03322 #define WE_METRICS_CAPTION          (WE_CAPTION | WE_ATTR_TYPE_METRICS)
03323 #define WE_FGC_ACTIVE_CAPTION       (WE_CAPTION | WE_ATTR_TYPE_FGC)
03324 #define WE_BGCA_ACTIVE_CAPTION      (WE_CAPTION | WE_ATTR_TYPE_BGCA)
03325 #define WE_BGCB_ACTIVE_CAPTION      (WE_CAPTION | WE_ATTR_TYPE_BGCB)
03326
03327 /* Menu */
03328 #define WE_FONT_MENU                (WE_MENU | WE_ATTR_TYPE_FONT)
03329 #define WE_METRICS_MENU             (WE_MENU | WE_ATTR_TYPE_METRICS)
03330 #define WE_FGC_MENU                 (WE_MENU | WE_ATTR_TYPE_FGC)
03331 #define WE_BGC_MENU                 (WE_MENU | WE_ATTR_TYPE_BGCA)
03332
03333 /* Message box */
03334 #define WE_FONT_MESSAGEBOX          (WE_MESSAGEBOX | WE_ATTR_TYPE_FONT)
03335 #define WE_FGC_MESSAGEBOX           (WE_MESSAGEBOX | WE_ATTR_TYPE_FGC)
03336
03337 /* Tool tips */
03338 #define WE_FONT_TOOLTIP             (WE_TOOLTIP | WE_ATTR_TYPE_FONT)
03339 #define WE_FGC_TOOLTIP              (WE_TOOLTIP | WE_ATTR_TYPE_FGC)
03340 #define WE_BGC_TOOLTIP              (WE_TOOLTIP | WE_ATTR_TYPE_BGCA)
03341
03342 /* Window border */
03343 #define WE_METRICS_WND_BORDER       (WE_WND_BORDER | WE_ATTR_TYPE_METRICS)
03344 #define WE_FGC_ACTIVE_WND_BORDER    (WE_WND_BORDER | WE_ATTR_TYPE_FGC)
03345 #define WE_FGC_INACTIVE_WND_BORDER  (WE_WND_BORDER | WE_ATTR_TYPE_BGCA)
03346
03347 /* Scroll bar */
03348 #define WE_METRICS_SCROLLBAR        (WE_SCROLLBAR | WE_ATTR_TYPE_METRICS)
03349
03350 /* Inactive caption */
03351 #define WE_FGC_INACTIVE_CAPTION     (WE_INACTIVE_CAPTION | WE_ATTR_TYPE_FGC)
03352 #define WE_BGCA_INACTIVE_CAPTION    (WE_INACTIVE_CAPTION | WE_ATTR_TYPE_BGCA)
03353 #define WE_BGCB_INACTIVE_CAPTION    (WE_INACTIVE_CAPTION | WE_ATTR_TYPE_BGCB)
03354
03355 /* Window */
03356 #define WE_FGC_WINDOW               (WE_WINDOW | WE_ATTR_TYPE_FGC)
03357 #define WE_BGC_WINDOW               (WE_WINDOW | WE_ATTR_TYPE_BGCA)
03358
03359 /* 3d body */
03360 #define WE_FGC_THREED_BODY          (WE_THREED_BODY | WE_ATTR_TYPE_FGC)
03361 #define WE_MAINC_THREED_BODY        (WE_THREED_BODY | WE_ATTR_TYPE_BGCA)
03362
03363 /* Selected items */
03364 #define WE_FGC_SELECTED_ITEM        (WE_SELECTED_ITEM | WE_ATTR_TYPE_FGC)
03365 #define WE_BGC_SELECTED_ITEM        (WE_SELECTED_ITEM | WE_ATTR_TYPE_BGCA)
03366 #define WE_BGC_SELECTED_LOSTFOCUS   (WE_SELECTED_ITEM | WE_ATTR_TYPE_BGCB)
03367
03368 /* Invalidate items */
03369 #define WE_FGC_DISABLED_ITEM        (WE_DISABLED_ITEM | WE_ATTR_TYPE_FGC)
03370 #define WE_BGC_DISABLED_ITEM        (WE_DISABLED_ITEM | WE_ATTR_TYPE_BGCA)
03371
03372 /* Highlight items */
03373 #define WE_FGC_HIGHLIGHT_ITEM       (WE_HIGHLIGHT_ITEM | WE_ATTR_TYPE_FGC)
03374 #define WE_BGC_HIGHLIGHT_ITEM       (WE_HIGHLIGHT_ITEM | WE_ATTR_TYPE_BGCA)
03375
03376 /* Significant items */
03377 #define WE_FGC_SIGNIFICANT_ITEM     (WE_SIGNIFICANT_ITEM | WE_ATTR_TYPE_FGC)
03378 #define WE_BGC_SIGNIFICANT_ITEM     (WE_SIGNIFICANT_ITEM | WE_ATTR_TYPE_BGCA)
03379
03380 /* Desktop */
03381 #define WE_BGC_DESKTOP              (WE_DESKTOP | WE_ATTR_TYPE_BGCA)
03382
03383 #define WE_ATTR_TYPE_ICON           0x4000
03384 #define WE_ATTR_TYPE_ICON_MASK      0x0F00
03385 #define WE_ATTR_TYPE_SMALLICON      0x4000
03386 #define WE_ATTR_TYPE_LARGEICON      0x4100
03387
03388 #define WE_LARGEICON_APPLICATION    (WE_ATTR_TYPE_LARGEICON | 0x00)
03389 #define WE_LARGEICON_HAND           (WE_ATTR_TYPE_LARGEICON | 0x01)
03390 #define WE_LARGEICON_QUESTION       (WE_ATTR_TYPE_LARGEICON | 0x02)
03391 #define WE_LARGEICON_EXCLAMATION    (WE_ATTR_TYPE_LARGEICON | 0x03)
03392 #define WE_LARGEICON_ASTERISK       (WE_ATTR_TYPE_LARGEICON | 0x04)
03393 #define WE_LARGEICON_STOP           WE_LARGEICON_HAND
03394 #define WE_LARGEICON_INFORMATION    WE_LARGEICON_ASTERISK
03395
03396 #define WE_SMALLICON_APPLICATION    (WE_ATTR_TYPE_SMALLICON | 0x00)
03397 #define WE_SMALLICON_HAND           (WE_ATTR_TYPE_SMALLICON | 0x01)
03398 #define WE_SMALLICON_QUESTION       (WE_ATTR_TYPE_SMALLICON | 0x02)
03399 #define WE_SMALLICON_EXCLAMATION    (WE_ATTR_TYPE_SMALLICON | 0x03)
03400 #define WE_SMALLICON_ASTERISK       (WE_ATTR_TYPE_SMALLICON | 0x04)
03401 #define WE_SMALLICON_STOP           WE_SMALLICON_HAND
03402 #define WE_SMALLICON_INFORMATION    WE_SMALLICON_ASTERISK
03403
03408 #define WE_ATTR_TYPE_RDR                0x5000
03409
03410 #define WE_LFFLAT_NUMBER                1
03411 #ifdef _MGLF_RDR_FLAT
03412
03413 #define WE_LFFLAT_TAB_NRMLCLR           (WE_ATTR_TYPE_RDR | 0)
03414 #endif
03415
03416 #define WE_LFSKIN_NUMBER                28
03417 #ifdef _MGLF_RDR_SKIN
03418 #define WE_LFSKIN_WND_BKGND             (WE_ATTR_TYPE_RDR | 0)
03419
03420 #define WE_LFSKIN_CAPTION               (WE_ATTR_TYPE_RDR | 1)
03421 #define WE_LFSKIN_CAPTION_BTN           (WE_ATTR_TYPE_RDR | 2)
03422
03423 #define WE_LFSKIN_SCROLLBAR_VSHAFT      (WE_ATTR_TYPE_RDR | 3)
03424 #define WE_LFSKIN_SCROLLBAR_VTHUMB      (WE_ATTR_TYPE_RDR | 4)
03425 #define WE_LFSKIN_SCROLLBAR_HSHAFT      (WE_ATTR_TYPE_RDR | 5)
03426 #define WE_LFSKIN_SCROLLBAR_HTHUMB      (WE_ATTR_TYPE_RDR | 6)
03427 #define WE_LFSKIN_SCROLLBAR_ARROWS      (WE_ATTR_TYPE_RDR | 7)
03428
03429 #define WE_LFSKIN_BORDER_TOP            (WE_ATTR_TYPE_RDR | 8)
03430 #define WE_LFSKIN_BORDER_BOTTOM         (WE_ATTR_TYPE_RDR | 9)
03431 #define WE_LFSKIN_BORDER_LEFT           (WE_ATTR_TYPE_RDR | 10)
03432 #define WE_LFSKIN_BORDER_RIGHT          (WE_ATTR_TYPE_RDR | 11)
03433
03434 #define WE_LFSKIN_ARROWS                (WE_ATTR_TYPE_RDR | 12)
03435 #define WE_LFSKIN_ARROWS_SHELL          (WE_ATTR_TYPE_RDR | 13)
03436
03437 #define WE_LFSKIN_RADIOBUTTON           (WE_ATTR_TYPE_RDR | 14)
03438 #define WE_LFSKIN_CHECKBUTTON           (WE_ATTR_TYPE_RDR | 15)
03439 #define WE_LFSKIN_PUSHBUTTON            (WE_ATTR_TYPE_RDR | 16)
03440
03441 #define WE_LFSKIN_TREE                  (WE_ATTR_TYPE_RDR | 17)
03442
03443 #define WE_LFSKIN_HEADER                (WE_ATTR_TYPE_RDR | 18)
03444 #define WE_LFSKIN_TAB                   (WE_ATTR_TYPE_RDR | 19)
03445
03446 #define WE_LFSKIN_PROGRESS_HCHUNK       (WE_ATTR_TYPE_RDR | 20)
03447 #define WE_LFSKIN_PROGRESS_VCHUNK       (WE_ATTR_TYPE_RDR | 21)
03448 #define WE_LFSKIN_PROGRESS_HTRACKBAR    (WE_ATTR_TYPE_RDR | 22)
03449 #define WE_LFSKIN_PROGRESS_VTRACKBAR    (WE_ATTR_TYPE_RDR | 23)
03450
03451 #define WE_LFSKIN_TBSLIDER_H            (WE_ATTR_TYPE_RDR | 24)
03452 #define WE_LFSKIN_TRACKBAR_VERT         (WE_ATTR_TYPE_RDR | 25)
03453 #define WE_LFSKIN_TRACKBAR_HORZ         (WE_ATTR_TYPE_RDR | 26)
03454 #define WE_LFSKIN_TBSLIDER_V            (WE_ATTR_TYPE_RDR | 27)
03455 #endif
03456
03458 typedef struct _WINDOW_ELEMENT_ATTR {
03460     int we_attr_id;
03462     DWORD we_attr;
03463 } WINDOW_ELEMENT_ATTR;
03464
03465 struct _WINDOW_ELEMENT_RENDERER;
03466 typedef struct _WINDOW_ELEMENT_RENDERER* PWERENDERER;
03467
03468 #define SBS_NORMAL                  0x00
03469 #define SBS_DISABLED                0x01
03470 #define SBS_HIDE                    0x02
03471
03475 typedef struct _LFSCROLLBARINFO {
03477     int  minPos;
03479     int  maxPos;
03481     int  curPos;
03483     int  pageStep;
03485     int  arrowLen;
03487     int  barStart;
03489     int  barLen;
03491     int status;
03492 } LFSCROLLBARINFO;
03493
03494 typedef LFSCROLLBARINFO* PLFSCROLLBARINFO;
03495
03499 typedef struct _SCROLLBARDATA {
03501     int  minPos;
03503     int  maxPos;
03505     int  curPos;
03507     int  pageStep;
03509     int  arrowLen;
03511     int  barStart;
03513     int  barLen;
03514     /* mouse position before tracking thumb.
03515      * it represents the distance from x mouse postion to barStart
03516      * for horizontal scrollbar.
03517      * it represents the distance from y mouse postion to barStart
03518      * for vertical  scrollbar.
03519      */
03520     int  track_pos;
03522     int status;
03523 } SCROLLBARDATA;
03524
03525 typedef SCROLLBARDATA* PSCROLLBARDATA;
03526
03528 #define SBS_DISABLED_LTUP       0x0100
03529
03531 #define SBS_DISABLED_BTDN       0x0200
03532
03534 #define SBS_HILITE_LTUP         0x0400
03535
03537 #define SBS_HILITE_BTDN         0x0800
03538
03540 #define SBS_HILITE_THUMB        0x0010
03541
03543 #define SBS_PRESSED_LTUP        0x0020
03544
03546 #define SBS_PRESSED_BTDN        0x0040
03547
03549 #define SBS_PRESSED_THUMB       0x0080
03550
03551
03552 #define LFRDR_WINTYPE_UNKNOWN           0
03553 #define LFRDR_WINTYPE_DIALOG            1
03554 #define LFRDR_WINTYPE_MAINWIN           2
03555 #define LFRDR_WINTYPE_CONTROL           3
03556
03560 typedef struct _LFRDR_WINSTYLEINFO
03561 {
03563     int         dwStyle;
03564
03573     int         winType;
03574 } LFRDR_WINSTYLEINFO;
03575
03581 typedef struct _LFRDR_TRACKBARINFO
03582 {
03583     int nMin;
03584     int nMax;
03585     int nPos;
03586     int nTickFreq;
03587 }LFRDR_TRACKBARINFO;
03588
03589 #define LFRDR_METRICS_MASK              0xFF00
03590 #define LFRDR_METRICS_BORDER            0x0100
03591 #define LFRDR_METRICS_CAPTION_H         0x0200
03592 #define LFRDR_METRICS_ICON_H            0x0300
03593 #define LFRDR_METRICS_ICON_W            0x0400
03594 #define LFRDR_METRICS_MENU_H            0x0500
03595 #define LFRDR_METRICS_VSCROLL_W         0x0600
03596 #define LFRDR_METRICS_HSCROLL_H         0x0700
03597 #define LFRDR_METRICS_MINWIN_WIDTH      0x0800
03598 #define LFRDR_METRICS_MINWIN_HEIGHT     0x0900
03599
03600 #define LFRDR_SB_MINBARLEN        10
03601
03606 #define LEN_RENDERER_NAME           15
03607
03608 /* button status used by button and 3dbox.  */
03609 #define LFRDR_BTN_STATUS_MASK       0x03
03610 #define LFRDR_BTN_STATUS_NORMAL     0x00
03611 #define LFRDR_BTN_STATUS_HILITE     0x01
03612 #define LFRDR_BTN_STATUS_PRESSED    0x02
03613 #define LFRDR_BTN_STATUS_DISABLED   0x03
03614
03615 /* a flag used by radio button and check button. */
03616 #define LFRDR_BTN_STATUS_SELECTED   0x04
03617
03618 /* a flag used by button on capton bar. */
03619 #define LFRDR_BTN_STATUS_INACTIVE   0x08
03620
03621 /* thick or thin frame used by 3dbox. */
03622 #define LFRDR_3DBOX_THICKFRAME      0x20
03623
03624 /* filled 3dbox */
03625 #define LFRDR_3DBOX_FILLED          0x40
03626
03627 /*select status used by checkmark or radio.*/
03628 #define LFRDR_MARK_SELECTED_MASK    0x05
03629 #define LFRDR_MARK_ALL_SELECTED     0x01
03630 #define LFRDR_MARK_HALF_SELECTED    0x04
03631
03632 /* a flag whether a checkmark or radio has a shell or not.*/
03633 #define LFRDR_MARK_HAVESHELL        0x02
03634
03635 /*the direction of arrow.*/
03636 #define LFRDR_ARROW_DIRECT_MASK     0x0F00
03637 #define LFRDR_ARROW_LEFT            0x0000
03638 #define LFRDR_ARROW_RIGHT           0x0100
03639 #define LFRDR_ARROW_UP              0x0200
03640 #define LFRDR_ARROW_DOWN            0x0300
03641
03642 /* hollow arrow or filled */
03643 #define LFRDR_ARROW_NOFILL          0x1000
03644 #define LFRDR_ARROW_HAVESHELL       0x2000
03645
03646 /* minimum of menu margin */
03647 #define LFRDR_MENUITEMOFFY_MIN      4
03648
03649 #define LFRDR_3DBOX_COLOR_LIGHTEST  0x01
03650 #define LFRDR_3DBOX_COLOR_DARKEST   0x02
03651 #define LFRDR_3DBOX_COLOR_LIGHTER   0x03
03652 #define LFRDR_3DBOX_COLOR_DARKER    0x04
03653
03654 /* flag of propsheet tab */
03655 #define LFRDR_TAB_BOTTOM            0x0001
03656 #define LFRDR_TAB_ACTIVE            0x0010
03657 #define LFRDR_TAB_ICON              0x0100
03658
03659 /* for fold icon*/
03660 #define LFRDR_TREE_WITHICON         0x08
03661 #define LFRDR_TREE_FOLD             0x01
03662
03663 /* for connecting line*/
03664 #define LFRDR_TREE_CHILD            0x02
03665 #define LFRDR_TREE_NEXT             0x04
03666
03667 #define SYSICO_ITEM_NUMBER          5
03668
03670 typedef struct _WINDOW_ELEMENT_RENDERER {
03672     const char name[LEN_RENDERER_NAME+1];
03673
03678     int (*init) (PWERENDERER renderer);
03679
03684     int (*deinit) (PWERENDERER renderer);
03685
03700     DWORD (*calc_3dbox_color) (DWORD color, int flag);
03701
03721     void (*draw_3dbox) (HDC hdc, const RECT* pRect, DWORD color, DWORD flag);
03722
03723
03734     void (*draw_radio) (HDC hdc, const RECT* pRect, DWORD color, int status);
03735
03739     void (*draw_checkbox) (HDC hdc, const RECT* pRect, DWORD color,
03740             int status);
03741
03745     void (*draw_checkmark) (HDC hdc, const RECT* pRect, DWORD color,
03746             int status);
03747
03764     void (*draw_arrow) (HWND hWnd, HDC hdc, const RECT* pRect, DWORD color, int status);
03765
03779     void (*draw_fold) (HWND hWnd, HDC hdc, const RECT* pRect, DWORD color,
03780             int status, int next);
03781
03783     void (*draw_focus_frame) (HDC hdc, const RECT *pRect, DWORD color);
03784
03786     void (*draw_normal_item) (HWND hWnd, HDC hdc, const RECT* pRect,
03787             DWORD color);
03788
03790     void (*draw_hilite_item) (HWND hWnd, HDC hdc, const RECT* pRect,
03791             DWORD color);
03792
03794     void (*draw_disabled_item) (HWND hWnd, HDC hdc, const RECT* pRect,
03795             DWORD color);
03796
03798     void (*draw_significant_item) (HWND hWnd, HDC hdc, const RECT* pRect,
03799             DWORD color);
03800
03814     void (*draw_push_button) (HWND hWnd, HDC hdc, const RECT* pRect,
03815             DWORD color1, DWORD color2, int status);
03816
03833     void (*draw_radio_button) (HWND hWnd, HDC hdc, const RECT* pRect, int status);
03834
03851     void (*draw_check_button) (HWND hWnd, HDC hdc, const RECT* pRect, int status);
03852
03854     void (*draw_border) (HWND hWnd, HDC hdc, BOOL is_active);
03855
03857     void (*draw_caption) (HWND hWnd, HDC hdc, BOOL is_active);
03858
03872     void (*draw_caption_button) (HWND hwnd, HDC hdc, int ht_code, int state);
03873
03888     void (*draw_scrollbar) (HWND hWnd, HDC hdc, int sb_pos);
03889
03891     void (*calc_trackbar_rect) (HWND hWnd, LFRDR_TRACKBARINFO *info,
03892             DWORD dwStyle, const RECT* rcClient, RECT* rcRuler,
03893             RECT* rcBar, RECT* rcBorder);
03894
03896     void (*draw_trackbar) (HWND hWnd, HDC hdc, LFRDR_TRACKBARINFO *info);
03897
03904     int (*calc_we_area) (HWND hWnd, int which, RECT* we_area);
03905
03928     int (*calc_we_metrics) (HWND hWnd,
03929             LFRDR_WINSTYLEINFO* style_info, int which);
03930
03936     int (*hit_test) (HWND hWnd, int x, int y);
03937
03939     int (*on_click_hotspot) (HWND hWnd, int which);
03940
03950     void (*draw_custom_hotspot) (HWND hWnd, HDC hdc, int ht_code, int state);
03951
03958     void (*calc_thumb_area) (HWND hWnd, BOOL vertical,
03959             LFSCROLLBARINFO* sb_info);
03960
03962     void (*disabled_text_out) (HWND hWnd, HDC hdc, const char* spText,
03963                     PRECT rc, DWORD dt_fmt);
03964
03975     void (*draw_tab) (HWND hWnd, HDC hdc, RECT *rect, char *title,
03976                 DWORD color, int flag, HICON icon);
03977
03979     void (*draw_progress) (HWND hWnd, HDC hdc,
03980             int nMax, int nMin, int nPos, BOOL fVertical);
03981
03985     void (*draw_header) (HWND hWnd, HDC hdc, const RECT* pRect, DWORD color);
03986
03991     DWORD (*on_get_rdr_attr) (struct _WINDOW_ELEMENT_RENDERER*, int we_attr_id);
03992
03999     DWORD (*on_set_rdr_attr) (struct _WINDOW_ELEMENT_RENDERER*, int we_attr_id, DWORD we_attr, BOOL change);
04000
04002     void (*erase_background) (HWND hWnd, HDC hdc, const RECT *rect);
04003
04005     void (*draw_normal_menu_item) (HWND hWnd, HDC hdc, const RECT* pRect,
04006                         DWORD color);
04007
04009     void (*draw_hilite_menu_item) (HWND hWnd, HDC hdc, const RECT* pRect,
04010                         DWORD color);
04011
04013     void (*draw_disabled_menu_item) (HWND hWnd, HDC hdc, const RECT* pRect,
04014                         DWORD color);
04015
04017     int we_metrics [WE_METRICS_NUMBER];
04018
04020     DWORD we_colors [WE_COLORS_NUMBER][3];
04021
04023     PLOGFONT we_fonts [WE_FONTS_NUMBER];
04024
04026     HICON  we_icon [2][SYSICO_ITEM_NUMBER];
04027
04029     unsigned int refcount;
04030
04032     const void* private_info;
04033 } WINDOW_ELEMENT_RENDERER;
04034
04038 typedef struct _WINDOWINFO
04039 {
04041     int left, top;
04042     int right, bottom;
04043
04045     int cl, ct;
04046     int cr, cb;
04047
04049     DWORD dwStyle;
04051     DWORD dwExStyle;
04052
04054     int iBkColor;
04056     HMENU hMenu;
04058     HACCEL hAccel;
04060     HCURSOR hCursor;
04062     HICON hIcon;
04064     HMENU hSysMenu;
04066     PLOGFONT pLogFont;
04067
04069     char* spCaption;
04071     int   id;
04072
04074     LFSCROLLBARINFO vscroll;
04076     LFSCROLLBARINFO hscroll;
04077
04079     WINDOW_ELEMENT_RENDERER* we_rdr;
04080 } WINDOWINFO;
04081
04093 static inline const WINDOWINFO* GUIAPI GetWindowInfo (HWND hWnd)
04094 {
04095     return (WINDOWINFO*)((unsigned char*)hWnd + 2*sizeof (short));
04096 }
04097
04109 MG_EXPORT BOOL GUIAPI InitWindowElementAttrs (PWERENDERER rdr);
04110
04203 MG_EXPORT DWORD GUIAPI GetWindowElementAttr (HWND hwnd, int we_attr_id);
04204
04221 MG_EXPORT DWORD GUIAPI SetWindowElementAttr (HWND hwnd, int we_attr_id,
04222         DWORD we_attr);
04223
04243 MG_EXPORT gal_pixel GUIAPI GetWindowElementPixelEx (HWND hwnd,
04244         HDC hdc, int we_attr_id);
04245
04258 MG_EXPORT const WINDOW_ELEMENT_RENDERER*
04259     GUIAPI GetWindowRendererFromName (const char* name);
04260
04273 MG_EXPORT BOOL GUIAPI AddWindowElementRenderer (const char* name,
04274         const WINDOW_ELEMENT_RENDERER* we_rdr);
04275
04286 MG_EXPORT BOOL GUIAPI RemoveWindowElementRenderer (const char* name);
04287
04296 MG_EXPORT const WINDOW_ELEMENT_RENDERER*
04297         GUIAPI GetDefaultWindowElementRenderer (void);
04298
04310 MG_EXPORT const char* GUIAPI SetDefaultWindowElementRenderer (const char* name);
04311
04330 MG_EXPORT BOOL GUIAPI SetWindowElementRenderer (HWND hWnd,
04331         const char* werdr_name, const WINDOW_ELEMENT_ATTR* we_attrs);
04332
04345 MG_EXPORT BOOL InitRendererSystemIcon (const char* rdr_name,
04346         HICON *small_icon, HICON *large_icon);
04347
04358 MG_EXPORT void TermRendererSystemIcon (HICON *small_icon,
04359         HICON *large_icon);
04360
04381 MG_EXPORT BOOL GUIAPI RegisterResFromFile (HDC hdc, const char* file);
04382
04383
04402 MG_EXPORT BOOL GUIAPI RegisterResFromMem (HDC hdc, const char* file,
04403         const unsigned char* data, size_t data_size);
04404
04418 MG_EXPORT BOOL GUIAPI RegisterResFromBitmap (const char* file, const BITMAP* bmp);
04419
04432 MG_EXPORT const BITMAP* GUIAPI RetrieveRes (const char *file);
04433
04447 MG_EXPORT void GUIAPI UnregisterRes (const char *file);
04448
04465 MG_EXPORT BOOL GUIAPI RegisterSystemBitmap (HDC hdc, const char* rdr_name,
04466         const char* id);
04467
04482 MG_EXPORT void GUIAPI UnregisterSystemBitmap (HDC hdc, const char* rdr_name,
04483         const char* id);
04484
04485 /* define the key of resouce */
04486 typedef unsigned long RES_KEY;
04487 #define RES_KEY_INVALID 0
04488
04489 /* define the incore res type */
04490 typedef struct _INNER_RES {
04491     RES_KEY key;
04492     Uint8* data;
04493     int data_len;
04494
04495     /* special param recognized by the TYPE_OPS
04496      * normal is null.
04497      * is the data is a mem of raw png, jpeg, bmp
04498      * and so on, it should be the extention name
04499      * of the filename. eg.
04500      * INNER_RES res[]= { ... { ..., ... ,.., "png" } .. };
04501      * */
04502     void* additional;
04503 } INNER_RES;
04504
04505 /* the type of resouce */
04506 enum emResType{
04507     RES_TYPE_INVALID = 0xFF,
04508
04509     /* All kinds of image supported by MiniGUI
04510      * such as png, jpeg, bmp and so on
04511      * This type will make LoadResouce return a
04512      * PBITMAP pointer
04513      */
04514     RES_TYPE_IMAGE = 0,
04515
04516     /* All kinds of image supported by MiniGUI
04517      * This Type will make LoadResource return a MYBITMAP* pointer
04518      */
04519     RES_TYPE_MYBITMAP,
04520
04521     /* the icon file and mem
04522      * it only make LoadResource load or get the FIRST
04523      * icon, and return HICON
04524      */
04525     RES_TYPE_ICON,
04526
04527 #ifdef _MGHAVE_CURSOR
04528     /* the cursor file or data
04529      * Make LoadResource return HCURSOR
04530      */
04531     RES_TYPE_CURSOR,
04532 #endif
04533
04534     /* the config file or data support by minigui
04535      * make LoadResource return GHANDLE
04536      * it should be accessed by GetValueFromEtc and GetIntValueFromEtc
04537      */
04538     RES_TYPE_ETC,
04539
04540     /* NOT IMPLEMENT */
04541     RES_TYPE_TEXT,
04542     /* NOT IMPLEMENT */
04543     RES_TYPE_MENU,
04544     /* NOT IMPLEMENT */
04545
04546     RES_TYPE_WINDOW,
04547     /* Make the LoadResource return the
04548      * raw data of INNER_RES, it's a pointer
04549      * of MEM_RES
04550      * only support incore Resource,
04551      * if the resource is stored in disk, LoadResource will return NULL
04552      */
04553     RES_TYPE_MEM_RES,
04554
04555     RES_TYPE_FONT,
04556
04557     /* the beginning of user defined type
04558      */
04559     RES_TYPE_USER,
04560
04561     /* the max valid value of type
04562      * used defined type must less this value
04563      */
04564     RES_TYPE_USER_MAX = 0x7F
04565 };
04566
04567 /* the return value of LoadResouce with type RES_TYPE_MEM_RES */
04568 typedef struct _MEM_RES {
04569     Uint8 *data;
04570     int data_len;
04571 } MEM_RES;
04572
04573 typedef struct _FONT_RES {
04574     LOGFONT logfont;
04575     RES_KEY key;
04576 } FONT_RES;
04577
04578 /* the original source of resource
04579  * depend on the values, the res manager
04580  * would select corrent loader to
04581  * load resouce form disk or mem
04582  */
04583
04584 #define REF_SRC_NOTYPE 0x00
04585
04586 /* indicate that the resouce is stored in disk */
04587 #define REF_SRC_FILE 0x01
04588
04589 /* indicate that the resouce is stored in memory*/
04590 #define REF_SRC_INNER 0x02
04591
04592 /* indicate that the resouce is stored in shared memory*/
04593 #define REF_SRC_SHARED 0x03
04594
04595 /* indicate that the resource is stored in outside( NOT SUPPORTED) */
04596 #define REF_SRC_OUTSIDE 0x04
04597
04598 /* indicate that the resouce is stored in a stream object (NOT SUPPORTED) */
04599 #define REF_SRC_STREAM 0x05
04600
04601 /* indicate that the resource is create by MiniGUI */
04602 #define REF_SRC_LOGIC 0x06
04603
04604 /* the RESOUCE type for loadding */
04605 typedef struct _RESOURCE {
04606     void* data; // store the pointer of cached resouce
04607     union {
04608         void* src;
04609         INNER_RES* inner;
04610         char* file;
04611     } source; // indicate the stored format of resouce
04612 } RESOURCE;
04613
04614 /* The operations of one type of resouce */
04615 typedef struct _RES_TYPE_OPS {
04616     /* To get a resource
04617      * return the buffered resouce pointer
04618      * param res the in and out param of resouce.
04619      * param src_type, one of REF_SRC_XXX
04620      * param usr_param
04621      * */
04622     void* (*get_res_data)(RESOURCE* res, int src_type, DWORD usr_param);
04623     /* To unload a buffered resouce
04624      */
04625     void (*unload)(RESOURCE* res, int src_type);
04626 } RES_TYPE_OPS;
04627
04628 /* Return value and error code of resouce manager */
04629 enum emResReturn {
04630     RES_RET_OK = 0,
04631     RES_RET_INVALID_PARAM,
04632     RES_RET_NOT_EXIST_KEY, //RES_KEY is not exist
04633     RES_RET_LOAD_FILE_FAILED,
04634     RES_RET_LOAD_MEM_FAILED,
04635     RES_RET_UNKNOWN_TYPE,
04636     RES_RET_NOT_IMPLEMENTED,
04637     RES_RET_INUSED //the res or object is in used, cannot be unloaded
04638 };
04639
04651 MG_EXPORT int SetResPath (const char* path);
04652
04666 MG_EXPORT int AddInnerRes (INNER_RES* inner_res, int count, BOOL copy);
04667
04668 /*
04669  *  NOT IMPLEMENT
04670  */
04671 MG_EXPORT int AddSharedRes (const char* shared_name);
04672
04685 MG_EXPORT int RegisterResType (int type, RES_TYPE_OPS* ops);
04686
04697 MG_EXPORT int UnregisterResType (int type);
04698
04736 MG_EXPORT void* LoadResource (const char* res_name, int type, DWORD usr_param);
04737
04751 MG_EXPORT void* GetResource (RES_KEY key);
04752
04768 MG_EXPORT int AddResRef (RES_KEY key);
04769
04781 MG_EXPORT int ReleaseRes (RES_KEY key);
04782
04783 #define LoadBitmapFromRes(hdc, res_name) \
04784     (PBITMAP)LoadResource(res_name, RES_TYPE_IMAGE, (DWORD)hdc)
04785
04786 #define GetBitmapFromRes(key) (BITMAP*)GetResource(key)
04787
04788 #define GetIconFromRes(key) (HICON)GetResource(key)
04789
04790 #ifndef _MGHAVE_CURSOR
04791 #define GetCursorFromRes(key) (HCURSOR)GetResource(key)
04792 #endif
04793
04794 #define GetEtcFromRes(key) (GHANDLE)GetResource(key)
04795
04796 #define LoadLogicFontFromRes(font_name)  (PLOGFONT)LoadResource(font_name, RES_TYPE_FONT, 0)
04797 #define GetLogicFontFromRes(font_name)   (PLOGFONT)GetResource(Str2Key(font_name))
04798 #define ReleaseLogicFont(font)  ReleaseRes(((FONT_RES*)(font))->key)
04799 #define ReleaseLogicFontByName(font_name)  ReleaseRes(Str2Key(font_name))
04800
04812 MG_EXPORT RES_KEY Str2Key (const char* str);
04813
04814
04815 #ifdef __TARGET_MSTUDIO__
04816
04825 MG_EXPORT int GUIAPI GetWindowZOrder(HWND hWnd);
04826
04836 MG_EXPORT int GUIAPI SetWindowZOrder(HWND hWnd, int zorder);
04837
04838 #endif
04839
04856 typedef int (* WNDPROC)(HWND, int, WPARAM, LPARAM);
04857
04858 extern MG_EXPORT HWND __mg_hwnd_desktop;
04859
04864 #define HWND_DESKTOP        __mg_hwnd_desktop
04865
04870 #define HWND_NULL           0
04871
04876 #define HWND_INVALID        0xFFFFFFFF
04877
04878 #define HWND_OTHERPROC      0xFFFFFFFE
04879
04883 typedef struct _MAINWINCREATE
04884 {
04886     DWORD dwStyle;
04887
04889     DWORD dwExStyle;
04890
04892     const char* spCaption;
04893
04895     HMENU hMenu;
04896
04898     HCURSOR hCursor;
04899
04901     HICON hIcon;
04902
04904     HWND  hHosting;
04905
04907     int (*MainWindowProc)(HWND, int, WPARAM, LPARAM);
04908
04910     int lx, ty, rx, by;
04911
04913     int iBkColor;
04914
04916     DWORD dwAddData;
04917
04919     DWORD dwReserved;
04920 }MAINWINCREATE;
04921 typedef MAINWINCREATE* PMAINWINCREATE;
04922
04923 #ifdef _MGRM_THREADS
04924
04935 MG_EXPORT int GUIAPI CreateThreadForMainWindow(pthread_t* thread,
04936                                      pthread_attr_t* attr,
04937                                      void * (*start_routine)(void *),
04938                                      void * arg);
04939
04946 MG_EXPORT pthread_t GUIAPI GetMainWinThread(HWND hMainWnd);
04947
04957 MG_EXPORT int GUIAPI WaitMainWindowClose(HWND hWnd, void** returnval);
04958 #endif
04959
04975 MG_EXPORT void GUIAPI MainWindowThreadCleanup(HWND hMainWnd);
04976
04983 #define MainWindowCleanup(hwnd)      MainWindowThreadCleanup(hwnd)
04984
05010 MG_EXPORT HWND GUIAPI CreateMainWindowEx (PMAINWINCREATE pCreateInfo,
05011                         const char* werdr_name, const WINDOW_ELEMENT_ATTR* we_attrs,
05012                         const char* window_name, const char* layer_name);
05013
05024 static inline HWND GUIAPI CreateMainWindow (PMAINWINCREATE pCreateInfo)
05025 {
05026     return CreateMainWindowEx (pCreateInfo, NULL, NULL, NULL, NULL);
05027 }
05028
05047 MG_EXPORT BOOL GUIAPI DestroyMainWindow (HWND hWnd);
05048
05064 MG_EXPORT BOOL GUIAPI SetWindowMask (HWND hWnd, const MYBITMAP* mask);
05065
05082 MG_EXPORT BOOL GUIAPI SetWindowMaskEx (HWND hWnd, HDC hdc, const BITMAP* mask);
05083
05093 BOOL GUIAPI SetWindowRegion (HWND hWnd, const CLIPRGN* region);
05094
05095 int GUIAPI PreDefMainWinProc (HWND hWnd, int message,
05096                 WPARAM wParam, LPARAM lParam);
05097
05098 int GUIAPI PreDefDialogProc (HWND hWnd,
05099                 int message, WPARAM wParam, LPARAM lParam);
05100
05101 int GUIAPI PreDefControlProc (HWND hWnd, int message,
05102                 WPARAM wParam, LPARAM lParam);
05103
05121 MG_EXPORT int GUIAPI DefaultWindowProc (HWND hWnd, int message,
05122                 WPARAM wParam, LPARAM lParam);
05123
05129 extern MG_EXPORT WNDPROC __mg_def_proc[3];
05130
05145 #define DefaultMainWinProc (__mg_def_proc[0])
05146
05163 #define DefaultDialogProc  (__mg_def_proc[1])
05164
05178 #define DefaultControlProc (__mg_def_proc[2])
05179
05180 #ifdef _DEBUG
05181 MG_EXPORT void GUIAPI DumpWindow (FILE* fp, HWND hWnd);
05182 #endif /* _DEBUG */
05183
05189 #define SW_HIDE              0x0000
05190 #define SW_SHOW              0x0010
05191 #define SW_SHOWNORMAL        0x0100
05192
05208 MG_EXPORT void GUIAPI UpdateWindow (HWND hWnd, BOOL bErase);
05209
05228 MG_EXPORT BOOL GUIAPI ShowWindow (HWND hWnd, int iCmdShow);
05229
05246 MG_EXPORT BOOL GUIAPI EnableWindow (HWND hWnd, BOOL fEnable);
05247
05262 MG_EXPORT BOOL GUIAPI IsWindowEnabled (HWND hWnd);
05263
05284 MG_EXPORT BOOL GUIAPI GetClientRect(HWND hWnd, PRECT prc);
05285
05299 MG_EXPORT int GUIAPI GetWindowBkColor (HWND hWnd);
05300
05316 MG_EXPORT int GUIAPI SetWindowBkColor (HWND hWnd, int new_bkcolor);
05317
05330 MG_EXPORT PLOGFONT GUIAPI GetWindowFont (HWND hWnd);
05331
05351 MG_EXPORT PLOGFONT GUIAPI SetWindowFont (HWND hWnd, PLOGFONT pLogFont);
05352
05365 MG_EXPORT HCURSOR GUIAPI GetWindowCursor (HWND hWnd);
05366
05380 MG_EXPORT HCURSOR GUIAPI SetWindowCursor (HWND hWnd, HCURSOR hNewCursor);
05381
05394 MG_EXPORT HICON GUIAPI GetWindowIcon (HWND hWnd);
05395
05413 MG_EXPORT HICON GUIAPI SetWindowIcon (HWND hWnd, HICON hIcon, BOOL bRedraw);
05414
05426 MG_EXPORT DWORD GUIAPI GetWindowStyle (HWND hWnd);
05427
05439 MG_EXPORT DWORD GUIAPI GetWindowExStyle (HWND hWnd);
05440
05454 MG_EXPORT BOOL GUIAPI ExcludeWindowStyle (HWND hWnd, DWORD dwStyle);
05455
05469 MG_EXPORT BOOL GUIAPI IncludeWindowStyle (HWND hWnd, DWORD dwStyle);
05470
05484 MG_EXPORT BOOL GUIAPI ExcludeWindowExStyle (HWND hWnd, DWORD dwStyle);
05485
05499 MG_EXPORT BOOL GUIAPI IncludeWindowExStyle (HWND hWnd, DWORD dwStyle);
05500
05513 MG_EXPORT WNDPROC GUIAPI GetWindowCallbackProc (HWND hWnd);
05514
05532 MG_EXPORT WNDPROC GUIAPI SetWindowCallbackProc (HWND hWnd, WNDPROC newProc);
05533
05546 MG_EXPORT DWORD GUIAPI GetWindowAdditionalData (HWND hWnd);
05547
05566 MG_EXPORT DWORD GUIAPI SetWindowAdditionalData (HWND hWnd, DWORD newData);
05567
05580 MG_EXPORT DWORD GUIAPI GetWindowAdditionalData2 (HWND hWnd);
05581
05599 MG_EXPORT DWORD GUIAPI SetWindowAdditionalData2 (HWND hWnd, DWORD newData);
05600
05617 MG_EXPORT DWORD GUIAPI GetWindowClassAdditionalData (HWND hWnd);
05618
05634 MG_EXPORT DWORD GUIAPI SetWindowClassAdditionalData (HWND hWnd, DWORD newData);
05635
05648 MG_EXPORT const char* GUIAPI GetWindowCaption (HWND hWnd);
05649
05663 MG_EXPORT BOOL GUIAPI SetWindowCaption (HWND hWnd, const char* spCaption);
05664
05683 MG_EXPORT BOOL GUIAPI InvalidateRect (HWND hWnd,
05684                 const RECT* prc, BOOL bEraseBkgnd);
05685
05701 MG_EXPORT HDC GUIAPI BeginPaint(HWND hWnd);
05702
05716 MG_EXPORT void GUIAPI EndPaint(HWND hWnd, HDC hdc);
05717
05733 MG_EXPORT BOOL GUIAPI GetUpdateRect (HWND hWnd, RECT* update_rect);
05734
05751 MG_EXPORT int GUIAPI ClientWidthToWindowWidthEx (DWORD dwStyle,
05752         int win_type, int cw);
05753
05770 MG_EXPORT int GUIAPI ClientHeightToWindowHeightEx (DWORD dwStyle,
05771         int win_type, int ch, BOOL hasMenu);
05772
05773 #define ClientWidthToWindowWidth(dwStyle, cw) \
05774     ClientWidthToWindowWidthEx (dwStyle, LFRDR_WINTYPE_MAINWIN, cw)
05775
05776 #define ClientHeightToWindowHeight(dwStyle, ch, hasMenu) \
05777     ClientHeightToWindowHeightEx (dwStyle, LFRDR_WINTYPE_MAINWIN, ch, hasMenu)
05778
05792 MG_EXPORT void GUIAPI ClientToScreen (HWND hWnd, int* x, int* y);
05793
05807 MG_EXPORT void GUIAPI ScreenToClient (HWND hWnd, int* x, int* y);
05808
05822 MG_EXPORT void GUIAPI ClientToWindow(HWND hWnd, int* x, int* y);
05823
05837 MG_EXPORT void GUIAPI WindowToClient(HWND hWnd, int* x, int* y);
05838
05839
05853 MG_EXPORT void GUIAPI WindowToScreen (HWND hWnd, int* x, int* y);
05854
05868 MG_EXPORT void GUIAPI ScreenToWindow (HWND hWnd, int* x, int* y);
05869
05883 MG_EXPORT BOOL GUIAPI IsMainWindow (HWND hWnd);
05884
05897 MG_EXPORT BOOL GUIAPI IsControl (HWND hWnd);
05898
05912 MG_EXPORT BOOL GUIAPI IsWindow (HWND hWnd);
05913
05927 MG_EXPORT BOOL GUIAPI IsDialog (HWND hWnd);
05928
05946 MG_EXPORT HWND GUIAPI GetParent (HWND hWnd);
05947
05963 MG_EXPORT HWND GUIAPI GetMainWindowHandle (HWND hWnd);
05964
05979 MG_EXPORT BOOL GUIAPI IsWindowVisible (HWND hWnd);
05980
05998 MG_EXPORT BOOL GUIAPI GetWindowRect (HWND hWnd, PRECT prc);
05999
06024 MG_EXPORT HWND GUIAPI GetNextChild (HWND hWnd, HWND hChild);
06025
06043 MG_EXPORT HWND GUIAPI GetNextMainWindow (HWND hMainWnd);
06044
06064 MG_EXPORT HWND GUIAPI GetHosting (HWND hMainWnd);
06065
06085 MG_EXPORT HWND GUIAPI GetFirstHosted (HWND hHosting);
06086
06111 MG_EXPORT HWND GUIAPI GetNextHosted (HWND hHosting, HWND hHosted);
06112
06127 MG_EXPORT int GUIAPI GetWindowTextLength (HWND hWnd);
06128
06145 MG_EXPORT int GUIAPI GetWindowText (HWND hWnd, char* spString, int nMaxLen);
06146
06162 MG_EXPORT BOOL GUIAPI SetWindowText (HWND hWnd, const char* spString);
06163
06178 MG_EXPORT HWND GUIAPI GetFocusChild (HWND hParent);
06179
06193 MG_EXPORT HWND GUIAPI SetNullFocus (HWND hParent);
06194
06208 MG_EXPORT HWND GUIAPI SetFocusChild (HWND hWnd);
06209
06214 #define SetFocus SetFocusChild
06215
06220 #define GetFocus GetFocusChild
06221
06233 MG_EXPORT HWND GUIAPI GetActiveWindow (void);
06234
06248 MG_EXPORT HWND GUIAPI SetActiveWindow (HWND hMainWnd);
06249
06254 #define GetForegroundWindow GetActiveWindow
06255
06260 #define SetForegroundWindow SetActiveWindow
06261
06276 MG_EXPORT HWND GUIAPI GetCapture(void);
06277
06293 MG_EXPORT HWND GUIAPI SetCapture(HWND hWnd);
06294
06306 MG_EXPORT void GUIAPI ReleaseCapture(void);
06307
06320 MG_EXPORT HWND GUIAPI GetWindowUnderCursor (void);
06321
06343 MG_EXPORT BOOL GUIAPI MoveWindow (HWND hWnd, int x, int y, int w, int h,
06344                 BOOL fPaint);
06345
06366 MG_EXPORT void GUIAPI ScrollWindow (HWND hWnd, int iOffx, int iOffy,
06367                 const RECT* rc1, const RECT* rc2);
06368
06373 #define GetWindowElementColor(iItem)   \
06374         GetWindowElementPixelEx(HWND_NULL, -1, iItem)
06375
06376 #define GetWindowElementColorEx(hWnd, iItem)   \
06377         GetWindowElementPixelEx(hWnd, -1, iItem)
06378
06379 #define GetWindowElementPixel(hWnd, iItem)   \
06380         GetWindowElementPixelEx(hWnd, -1, iItem)
06381
06388 #define SYSBMP_RADIOBUTTON          "radiobutton"
06389 #define SYSBMP_CHECKBUTTON          "checkbutton"
06390 #define SYSBMP_BGPICTURE            "bgpicture"
06391 #define SYSBMP_BGPICPOS             "bgpicpos"
06392
06393 /* Obsolete definitions; back-compatibility definitions. */
06394 #define SYSBMP_IMECTRLBTN          "IMEctrlbtn"
06395 #define SYSBMP_LOGO                "logo"
06396
06415 MG_EXPORT const BITMAP* GUIAPI GetSystemBitmapEx (const char* rdr_name,
06416         const char* id);
06417
06436 MG_EXPORT const BITMAP* GUIAPI GetSystemBitmapByHwnd (HWND hWnd, const char* id);
06437
06456 MG_EXPORT const BITMAP* GUIAPI GetSystemBitmap (HWND hWnd, const char* id);
06457
06477 MG_EXPORT void GUIAPI TermSystemBitmapEx (const char* id,
06478         const char* rdr_name, PBITMAP bmp);
06479
06498 MG_EXPORT void GUIAPI TermSystemBitmap (HWND hWnd, const char* id, PBITMAP bmp);
06499
06500 /*for backward compatibility */
06501 #define IDI_APPLICATION         0
06502 #define IDI_HAND                1
06503 #define IDI_STOP                IDI_HAND
06504 #define IDI_QUESTION            2
06505 #define IDI_EXCLAMATION         3
06506 #define IDI_ASTERISK            4
06507 #define IDI_INFORMATION         IDI_ASTERISK
06508
06509 #define SYSICON_FT_DIR          "dir"
06510 #define SYSICON_FT_FILE         "file"
06511
06512 #define SYSICON_TREEFOLD        "treefold"
06513 #define SYSICON_TREEUNFOLD      "treeunfold"
06514
06532 MG_EXPORT HICON GUIAPI LoadSystemIconEx (HDC hdc,
06533         const char* rdr_name, const char* szItemName, int which);
06534
06549 MG_EXPORT HICON GUIAPI LoadSystemIcon (const char* szItemName, int which);
06550
06571 MG_EXPORT HICON GUIAPI GetLargeSystemIconEx (HWND hWnd, int iItem);
06572
06593 MG_EXPORT HICON GUIAPI GetSmallSystemIconEx (HWND hWnd, int iItem);
06594
06601 #define GetLargeSystemIcon(iItem) GetLargeSystemIconEx(HWND_NULL, iItem)
06602
06609 #define GetSmallSystemIcon(iItem) GetSmallSystemIconEx(HWND_NULL, iItem)
06610
06618 #define SB_HORZ     1
06619 #define SB_VERT     2
06620
06639 MG_EXPORT BOOL GUIAPI EnableScrollBar (HWND hWnd, int iSBar, BOOL bEnable);
06640
06662 MG_EXPORT BOOL GUIAPI GetScrollPos (HWND hWnd, int iSBar, int* pPos);
06663
06688 MG_EXPORT BOOL GUIAPI GetScrollRange (HWND hWnd, int iSBar,
06689                 int* pMinPos, int* pMaxPos);
06690
06713 MG_EXPORT BOOL GUIAPI SetScrollPos (HWND hWnd, int iSBar, int iNewPos);
06714
06739 MG_EXPORT BOOL GUIAPI SetScrollRange (HWND hWnd, int iSBar,
06740                 int iMinPos, int iMaxPos);
06741
06761 MG_EXPORT BOOL GUIAPI ShowScrollBar (HWND hWnd, int iSBar, BOOL bShow);
06762
06763 #define SIF_RANGE           0x0001
06764 #define SIF_PAGE            0x0002
06765 #define SIF_POS             0x0004
06766 #define SIF_DISABLENOSCROLL 0x0008
06767 #define SIF_TRACKPOS        0x0010
06768 #define SIF_ALL             (SIF_RANGE | SIF_PAGE | SIF_POS | SIF_TRACKPOS)
06769
06771 #define SB_ARROW_LTUP   0x0001
06772
06774 #define SB_ARROW_BTDN   0x0002
06775
06777 #define SB_ARROW_BOTH  (SB_ARROW_LTUP | SB_ARROW_BTDN)
06778
06782 typedef struct _SCROLLINFO
06783 {
06785     UINT    cbSize;
06798     UINT    fMask;
06800     int     nMin;
06802     int     nMax;
06804     UINT    nPage;
06806     int     nPos;
06807 #if 0
06808     int     nTrackPos;
06809 #endif
06810 } SCROLLINFO, *PSCROLLINFO;
06811
06835 MG_EXPORT BOOL GUIAPI SetScrollInfo (HWND hWnd, int iSBar,
06836                 const SCROLLINFO* lpsi, BOOL fRedraw);
06837
06860 MG_EXPORT BOOL GUIAPI GetScrollInfo (HWND hWnd, int iSBar, PSCROLLINFO lpsi);
06861
06869 /* Class styles -- not supported so far */
06870 #define CS_VREDRAW          0x0001
06871 #define CS_HREDRAW          0x0002
06872 #define CS_KEYCVTWINDOW     0x0004
06873 #define CS_DBLCLKS          0x0008
06874
06875 #define CS_OWNDC            0x0020
06876 #define CS_CLASSDC          0x0040
06877 #define CS_PARENTDC         0x0080
06878
06879 #define CS_NOKEYCVT         0x0100
06880 #define CS_NOCLOSE          0x0200
06881 #define CS_SAVEBITS         0x0800
06882
06883 #define CS_BYTEALIGNCLIENT  0x1000
06884 #define CS_BYTEALIGNWINDOW  0x2000
06885 #define CS_GLOBALCLASS      0x4000
06886 #define CS_IME              0x8000
06887
06888 #define COP_STYLE           0x0001
06889 #define COP_HCURSOR         0x0002
06890 #define COP_BKCOLOR         0x0004
06891 #define COP_WINPROC         0x0008
06892 #define COP_ADDDATA         0x0010
06893
06897 typedef struct _WNDCLASS
06898 {
06900     const char* spClassName;
06901
06914     DWORD   opMask;
06915
06917     DWORD   dwStyle;
06918
06920     DWORD   dwExStyle;
06921
06923     HCURSOR hCursor;
06924
06926     int     iBkColor;
06927
06929     int     (*WinProc) (HWND, int, WPARAM, LPARAM);
06930
06932     DWORD dwAddData;
06933 } WNDCLASS;
06934 typedef WNDCLASS* PWNDCLASS;
06935
06936 #define MAINWINCLASSNAME    ("MAINWINDOW")
06937 #define ROOTWINCLASSNAME    ("ROOTWINDOW")
06938
06957 MG_EXPORT BOOL GUIAPI RegisterWindowClass (PWNDCLASS pWndClass);
06958
06972 MG_EXPORT BOOL GUIAPI UnregisterWindowClass (const char* szClassName);
06973
06987 MG_EXPORT const char* GUIAPI GetClassName (HWND hWnd);
06988
07004 MG_EXPORT BOOL GUIAPI GetWindowClassInfo (PWNDCLASS pWndClass);
07005
07020 MG_EXPORT BOOL GUIAPI SetWindowClassInfo (const WNDCLASS* pWndClass);
07021
07066 MG_EXPORT HWND GUIAPI CreateWindowEx2 (const char* spClassName,
07067         const char* spCaption, DWORD dwStyle, DWORD dwExStyle,
07068         int id, int x, int y, int w, int h, HWND hParentWnd,
07069         const char* werdr_name, const WINDOW_ELEMENT_ATTR* we_attrs,
07070         DWORD dwAddData);
07071
07084 static inline HWND GUIAPI CreateWindowEx (const char* spClassName,
07085                 const char* spCaption, DWORD dwStyle, DWORD dwExStyle,
07086                 int id, int x, int y, int w, int h, HWND hParentWnd,
07087                 DWORD dwAddData)
07088 {
07089     return CreateWindowEx2 (spClassName, spCaption, dwStyle, dwExStyle,
07090                 id, x, y, w, h, hParentWnd, NULL, NULL, dwAddData);
07091 }
07092
07105 MG_EXPORT BOOL GUIAPI DestroyWindow (HWND hWnd);
07106
07118 typedef void (* NOTIFPROC) (HWND hwnd, int id, int nc, DWORD add_data);
07119
07146 MG_EXPORT NOTIFPROC GUIAPI SetNotificationCallback (HWND hwnd,
07147                 NOTIFPROC notif_proc);
07148
07162 MG_EXPORT NOTIFPROC GUIAPI GetNotificationCallback (HWND hwnd);
07163
07170 #define CreateWindow(class_name, caption, style,        \
07171                 id, x, y, w, h, parent, add_data)       \
07172         CreateWindowEx(class_name, caption, style, 0,   \
07173                         id, x, y, w, h, parent, add_data)
07174
07177 /******************************** Timer Support ******************************/
07195 typedef BOOL (* TIMERPROC)(HWND, int, DWORD);
07196
07230 MG_EXPORT BOOL GUIAPI SetTimerEx (HWND hWnd, int id, unsigned int speed,
07231                 TIMERPROC timer_proc);
07232
07239 #define SetTimer(hwnd, id, speed) \
07240                 SetTimerEx(hwnd, id, speed, NULL)
07241
07256 MG_EXPORT int GUIAPI KillTimer (HWND hWnd, int id);
07257
07277 MG_EXPORT BOOL GUIAPI ResetTimerEx (HWND hWnd, int id, unsigned int speed,
07278                 TIMERPROC timer_proc);
07279
07286 #define ResetTimer(hwnd, id, speed) \
07287                 ResetTimerEx(hwnd, id, speed, (TIMERPROC)0xFFFFFFFF)
07288
07299 MG_EXPORT unsigned int GUIAPI GetTickCount (void);
07300
07315 MG_EXPORT BOOL GUIAPI IsTimerInstalled (HWND hWnd, int id);
07316
07328 MG_EXPORT BOOL GUIAPI HaveFreeTimer (void);
07329
07340 typedef struct _IME_TARGET_INFO
07341 {
07353     int     iEditBoxType;
07354
07355     /* The position of the caret */
07356     POINT   ptCaret;
07357
07358     /* The rect of the edit box */
07359     RECT    rcEditBox;
07360 } IME_TARGET_INFO;
07361
07380 MG_EXPORT int GUIAPI RegisterIMEWindow (HWND hWnd);
07381
07396 MG_EXPORT int GUIAPI UnregisterIMEWindow (HWND hWnd);
07397
07441 MG_EXPORT int GUIAPI GetIMEStatus (int StatusCode);
07442
07458 MG_EXPORT int GUIAPI SetIMEStatus (int StatusCode, int Value);
07459
07473 MG_EXPORT int GUIAPI GetIMETargetInfo (IME_TARGET_INFO *info);
07474
07489 MG_EXPORT inline int GUIAPI GetIMEPos (POINT* pt);
07490
07506 MG_EXPORT int GUIAPI SetIMETargetInfo (const IME_TARGET_INFO *info);
07507
07523 MG_EXPORT inline int GUIAPI SetIMEPos(const POINT* pt);
07524
07543 MG_EXPORT HACCEL GUIAPI CopyAcceleratorTable (HACCEL hacc);
07544
07558 MG_EXPORT int GUIAPI DeleteAccelerators (HACCEL hacc, int key, DWORD keymask);
07559
07560 #define ACCEL_SHIFT     KS_SHIFT
07561 #define ACCEL_ALT       KS_ALT
07562 #define ACCEL_CTRL      KS_CTRL
07563
07592 MG_EXPORT int GUIAPI AddAccelerators (HACCEL hacc, int key,
07593                 DWORD keymask, WPARAM wParam, LPARAM lParam);
07594
07609 MG_EXPORT int GUIAPI DestroyAcceleratorTable (HACCEL hacc);
07610
07622 MG_EXPORT HACCEL GUIAPI CreateAcceleratorTable (HWND hWnd);
07623
07635 MG_EXPORT int GUIAPI TranslateAccelerator (HACCEL hAccel, PMSG pMsg);
07636
07662 MG_EXPORT BOOL GUIAPI CreateCaret (HWND hWnd, PBITMAP pBitmap,
07663                 int nWidth, int nHeight);
07664
07680 MG_EXPORT BOOL GUIAPI ChangeCaretSize (HWND hWnd, int newWidth, int newHeight);
07681
07694 MG_EXPORT BOOL GUIAPI ActiveCaret (HWND hWnd);
07695
07711 MG_EXPORT UINT GUIAPI GetCaretBlinkTime (HWND hWnd);
07712
07729 MG_EXPORT BOOL GUIAPI SetCaretBlinkTime (HWND hWnd, UINT uTime);
07730
07743 MG_EXPORT BOOL GUIAPI DestroyCaret (HWND hWnd);
07744
07762 MG_EXPORT BOOL GUIAPI HideCaretEx (HWND hWnd, BOOL ime);
07763
07778 static inline BOOL GUIAPI HideCaret (HWND hWnd)
07779 {
07780     return HideCaretEx (hWnd, TRUE);
07781 }
07782
07800 MG_EXPORT BOOL GUIAPI ShowCaretEx (HWND hWnd, BOOL ime);
07801
07816 static inline BOOL GUIAPI ShowCaret (HWND hWnd)
07817 {
07818     return ShowCaretEx (hWnd, TRUE);
07819 }
07820
07837 MG_EXPORT BOOL GUIAPI SetCaretPos (HWND hWnd, int x, int y);
07838
07853 MG_EXPORT BOOL GUIAPI GetCaretPos (HWND hWnd, PPOINT pPt);
07854
07862 /* Menu flags */
07863 #define MF_INSERT           0x00000000L
07864 #define MF_CHANGE           0x00000080L
07865 #define MF_APPEND           0x00000100L
07866 #define MF_DELETE           0x00000200L
07867 #define MF_REMOVE           0x00001000L
07868
07869 #define MF_BYCOMMAND        0x00000000L
07870 #define MF_BYPOSITION       0x00000400L
07871
07872 #define MF_SEPARATOR        0x00000800L
07873
07874 #define MF_ENABLED          0x00000000L
07875 #define MF_GRAYED           0x00000001L
07876 #define MF_DISABLED         0x00000002L
07877
07878 #define MF_UNCHECKED        0x00000000L
07879 #define MF_CHECKED          0x00000008L
07880 #define MF_USECHECKBITMAPS  0x00000200L
07881
07882 #define MF_STRING           0x00000000L
07883 #define MF_BITMAP           0x00000004L
07884 #define MF_OWNERDRAW        0x00000100L
07885
07886 #define MF_POPUP            0x00000010L
07887 #define MF_MENUBARBREAK     0x00000020L
07888 #define MF_MENUBREAK        0x00000040L
07889
07890 #define MF_UNHILITE         0x00000000L
07891 #define MF_HILITE           0x00000080L
07892
07893 #define MF_DEFAULT          0x00001000L
07894 #define MF_SYSMENU          0x00002000L
07895 #define MF_HELP             0x00004000L
07896 #define MF_RIGHTJUSTIFY     0x00004000L
07897
07898 #define MF_MOUSESELECT      0x00008000L
07899 #define MF_END              0x00000080L
07900
07901 #define MFT_STRING          MF_STRING /* 0x00000000L */
07902 #define MFT_BITMAP          MF_BITMAP /* 0x00000004L */
07903 #define MFT_BMPSTRING       0x00010000L
07904 #define MFT_MENUBARBREAK    MF_MENUBARBREAK /* 0x00000020L */
07905 #define MFT_MENUBREAK       MF_MENUBREAK /* 0x00000040L */
07906 #define MFT_OWNERDRAW       MF_OWNERDRAW /* 0x00000100L */
07907 #define MFT_RADIOCHECK      0x00000200L
07908 #define MFT_MARKCHECK       0x00000400L
07909 #define MFT_SEPARATOR       MF_SEPARATOR /* 0x00000800L */
07910
07911 #define MFT_RIGHTORDER      0x00002000L
07912 #define MFT_RIGHTJUSTIFY    MF_RIGHTJUSTIFY
07913
07914 #define MFS_GRAYED          0x00000003L
07915 #define MFS_DISABLED        MFS_GRAYED
07916 #define MFS_CHECKED         MF_CHECKED
07917 #define MFS_HILITE          MF_HILITE
07918 #define MFS_ENABLED         MF_ENABLED
07919 #define MFS_UNCHECKED       MF_UNCHECKED
07920 #define MFS_UNHILITE        MF_UNHILITE
07921 #define MFS_DEFAULT         MF_DEFAULT
07922
07923 /* System Menu Command Values */
07924   #define SC_SIZE         0xF000
07925   #define SC_MOVE         0xF010
07926   #define SC_MINIMIZE     0xF020
07927   #define SC_MAXIMIZE     0xF030
07928   #define SC_NEXTWINDOW   0xF040
07929   #define SC_PREVWINDOW   0xF050
07930   #define SC_CLOSE        0xF060
07931   #define SC_VSCROLL      0xF070
07932   #define SC_HSCROLL      0xF080
07933   #define SC_MOUSEMENU    0xF090
07934   #define SC_KEYMENU      0xF100
07935   #define SC_ARRANGE      0xF110
07936   #define SC_RESTORE      0xF120
07937   #define SC_TASKLIST     0xF130
07938   #define SC_SCREENSAVE   0xF140
07939   #define SC_HOTKEY       0xF150
07940
07941   #define SC_DEFAULT      0xF160
07942   #define SC_MONITORPOWER 0xF170
07943   #define SC_CONTEXTHELP  0xF180
07944   #define SC_SEPARATOR    0xF00F
07945
07946 /* MENUITEMINFO flags */
07947   #define MIIM_STATE       0x00000001
07948   #define MIIM_ID          0x00000002
07949   #define MIIM_SUBMENU     0x00000004
07950   #define MIIM_CHECKMARKS  0x00000008
07951   #define MIIM_TYPE        0x00000010
07952   #define MIIM_DATA        0x00000020
07953   #define MIIM_STRING      0x00000040
07954   #define MIIM_BITMAP      0x00000080
07955   #define MIIM_FTYPE       0x00000100
07956
07957
07958 /* Flags for TrackPopupMenu */
07959   #define TPM_LEFTBUTTON  0x0000L
07960   #define TPM_RIGHTBUTTON 0x0002L
07961   #define TPM_LEFTALIGN   0x0000L
07962   #define TPM_CENTERALIGN 0x0004L
07963   #define TPM_RIGHTALIGN  0x0008L
07964   #define TPM_TOPALIGN        0x0000L
07965   #define TPM_VCENTERALIGN    0x0010L
07966   #define TPM_BOTTOMALIGN     0x0020L
07967
07968   #define TPM_HORIZONTAL      0x0000L     /* Horz alignment matters more */
07969   #define TPM_VERTICAL        0x0040L     /* Vert alignment matters more */
07970   #define TPM_NONOTIFY        0x0080L     /* Don't send any notification msgs */
07971   #define TPM_RETURNCMD       0x0100L
07972
07973   #define TPM_DESTROY         0x1000L       /* Destroy menu after tracking */
07974   #define TPM_SYSCMD          0x2000L       /* Send system command */
07975   #define TPM_DEFAULT         0x0000L       /* Default tracking flag */
07976
07977 /* return codes for MSG_MENUCHAR */
07978 #define MNC_IGNORE  0
07979 #define MNC_CLOSE   1
07980 #define MNC_EXECUTE 2
07981 #define MNC_SELECT  3
07982
07986 typedef struct _MENUITEMINFO {
07987
08004     UINT                mask;
08005
08032     UINT                type;
08033
08047     UINT                state;
08048
08050     int                 id;
08051
08053     HMENU               hsubmenu;
08054
08056     PBITMAP             uncheckedbmp;
08057
08059     PBITMAP             checkedbmp;
08060
08062     DWORD               itemdata;
08063
08065     DWORD               typedata;
08066
08071     UINT                cch;
08072 } MENUITEMINFO;
08073 typedef MENUITEMINFO* PMENUITEMINFO;
08074
08086 MG_EXPORT HMENU GUIAPI CreateMenu (void);
08087
08102 MG_EXPORT HMENU GUIAPI CreatePopupMenu ( PMENUITEMINFO pmii);
08103
08118 MG_EXPORT HMENU GUIAPI CreateSystemMenu (HWND hwnd, DWORD dwStyle);
08119
08146 MG_EXPORT int GUIAPI InsertMenuItem (HMENU hmnu, int item,
08147                             UINT flag, PMENUITEMINFO pmii);
08148
08173 MG_EXPORT int GUIAPI RemoveMenu (HMENU hmnu, int item, UINT flag);
08174
08198 MG_EXPORT int GUIAPI DeleteMenu (HMENU hmnu, int item, UINT flag);
08199
08216 MG_EXPORT int GUIAPI DestroyMenu (HMENU hmnu);
08217
08232 MG_EXPORT int GUIAPI IsMenu (HMENU hmnu);
08233
08248 MG_EXPORT HMENU GUIAPI SetMenu (HWND hwnd, HMENU hmnu);
08249
08262 MG_EXPORT HMENU GUIAPI GetMenu (HWND hwnd);
08263
08276 MG_EXPORT void GUIAPI DrawMenuBar (HWND hwnd);
08277
08292 MG_EXPORT int GUIAPI TrackMenuBar (HWND hwnd, int pos);
08293
08331 MG_EXPORT int GUIAPI TrackPopupMenu (HMENU hmnu, UINT uFlags,
08332                 int x, int y, HWND hwnd);
08333
08351 MG_EXPORT HMENU GUIAPI GetMenuBarItemRect (HWND hwnd, int pos, RECT* prc);
08352
08353 #define LFRDR_MENU_STATE_HILITE       0x01
08354 #define LFRDR_MENU_STATE_NORMAL       0x02
08355 #define LFRDR_MENU_STATE_DISABLED     0x04
08356
08378 MG_EXPORT BOOL GUIAPI HiliteMenuBarItem (HWND hwnd, int pos, UINT flag);
08379
08392 MG_EXPORT int GUIAPI GetMenuItemCount (HMENU hmnu);
08393
08410 MG_EXPORT int GUIAPI GetMenuItemID (HMENU hmnu, int pos);
08411
08435 MG_EXPORT int GUIAPI GetMenuItemInfo (HMENU hmnu, int item,
08436                             UINT flag, PMENUITEMINFO pmii);
08437
08438 /*Reserved*/
08439 int GUIAPI GetMenuItemRect (HWND hwnd, HMENU hmnu,
08440                 int item, PRECT prc);
08441
08454 MG_EXPORT HMENU GUIAPI GetPopupSubMenu (HMENU hpppmnu);
08455
08468 MG_EXPORT HMENU GUIAPI StripPopupHead (HMENU hpppmnu);
08469
08487 MG_EXPORT HMENU GUIAPI GetSubMenu (HMENU hmnu, int pos);
08488
08506 MG_EXPORT HMENU GUIAPI GetSystemMenu (HWND hwnd, BOOL flag);
08507
08527 MG_EXPORT UINT GUIAPI EnableMenuItem (HMENU hmnu, int item, UINT flag);
08528
08552 MG_EXPORT int GUIAPI CheckMenuRadioItem (HMENU hmnu, int first, int last,
08553                             int checkitem, UINT flag);
08554
08578 MG_EXPORT int GUIAPI SetMenuItemBitmaps (HMENU hmnu, int item, UINT flag,
08579                             PBITMAP hBmpUnchecked, PBITMAP hBmpChecked);
08580
08602 MG_EXPORT int GUIAPI SetMenuItemInfo (HMENU hmnu, int item,
08603                             UINT flag, PMENUITEMINFO pmii);
08604
08612 /* Dialog codes */
08617 #define DLGC_WANTARROWS     0x0001
08618
08622 #define DLGC_WANTTAB        0x0002
08623
08627 #define DLGC_WANTALLKEYS    0x0004
08628
08632 #define DLGC_WANTCHARS      0x0008
08633
08638 #define DLGC_WANTENTER      0x0010
08639
08643 #define DLGC_HASSETSEL      0x0080
08644
08649 #define DLGC_DEFPUSHBUTTON  0x0100
08650
08654 #define DLGC_PUSHBUTTON     0x0200
08655
08659 #define DLGC_RADIOBUTTON    0x0400
08660
08664 #define DLGC_3STATE         0x0800
08665
08669 #define DLGC_STATIC         0x1000
08670
08674 #define DLGC_BUTTON         0x2000
08675
08679 typedef struct _CTRLDATA
08680 {
08682     const char* class_name;
08684     DWORD       dwStyle;
08686     int         x, y, w, h;
08688     int         id;
08690     const char* caption;
08692     DWORD       dwAddData;
08694     DWORD       dwExStyle;
08695
08697     const char* werdr_name;
08698
08700     const WINDOW_ELEMENT_ATTR* we_attrs;
08701 } CTRLDATA;
08702 typedef CTRLDATA* PCTRLDATA;
08703
08711 typedef struct _DLGTEMPLATE
08712 {
08714     DWORD       dwStyle;
08716     DWORD       dwExStyle;
08718     int         x, y, w, h;
08720     const char* caption;
08722     HICON       hIcon;
08724     HMENU       hMenu;
08726     int         controlnr;
08728     PCTRLDATA   controls;
08730     DWORD       dwAddData;
08731 } DLGTEMPLATE;
08732 typedef DLGTEMPLATE* PDLGTEMPLATE;
08733
08765 MG_EXPORT HWND GUIAPI CreateMainWindowIndirectParamEx (PDLGTEMPLATE pDlgTemplate,
08766         HWND hOwner, WNDPROC WndProc, LPARAM lParam,
08767         const char* werdr_name, WINDOW_ELEMENT_ATTR* we_attrs,
08768         const char* window_name, const char* layer_name);
08769
08782 static inline HWND GUIAPI CreateMainWindowIndirectParam (
08783                 PDLGTEMPLATE pDlgTemplate, HWND hOwner,
08784                 WNDPROC WndProc, LPARAM lParam)
08785 {
08786     return CreateMainWindowIndirectParamEx (pDlgTemplate, hOwner,
08787             WndProc, lParam, NULL, NULL, NULL, NULL);
08788 }
08789
08801 static inline HWND GUIAPI CreateMainWindowIndirect (
08802                 PDLGTEMPLATE pDlgTemplate, HWND hOwner, WNDPROC WndProc)
08803 {
08804     return CreateMainWindowIndirectParam (pDlgTemplate, hOwner, WndProc, 0);
08805 }
08806
08818 MG_EXPORT BOOL GUIAPI DestroyMainWindowIndirect (HWND hMainWin);
08819
08853 MG_EXPORT int GUIAPI DialogBoxIndirectParamEx (PDLGTEMPLATE pDlgTemplate,
08854         HWND hOwner, WNDPROC DlgProc, LPARAM lParam,
08855         const char* werdr_name, WINDOW_ELEMENT_ATTR* we_attrs,
08856         const char* window_name, const char* layer_name);
08857
08869 static inline int GUIAPI DialogBoxIndirectParam (PDLGTEMPLATE pDlgTemplate,
08870                 HWND hOwner, WNDPROC DlgProc, LPARAM lParam)
08871 {
08872     return DialogBoxIndirectParamEx (pDlgTemplate, hOwner, DlgProc, lParam,
08873                 NULL, NULL, NULL, NULL);
08874 }
08875
08893 MG_EXPORT BOOL GUIAPI EndDialog (HWND hDlg, int endCode);
08894
08905 MG_EXPORT void GUIAPI DestroyAllControls (HWND hWnd);
08906
08918 MG_EXPORT HWND GUIAPI GetDlgDefPushButton (HWND hWnd);
08919
08932 MG_EXPORT int GUIAPI GetDlgCtrlID (HWND hwndCtl);
08933
08946 MG_EXPORT HWND GUIAPI GetDlgItem (HWND hDlg, int nIDDlgItem);
08947
08978 MG_EXPORT UINT GUIAPI GetDlgItemInt (HWND hDlg, int nIDDlgItem,
08979                 BOOL *lpTranslated, BOOL bSigned);
08980
09001 MG_EXPORT int GUIAPI GetDlgItemText (HWND hDlg, int nIDDlgItem,
09002                 char* lpString, int nMaxCount);
09003
09022 MG_EXPORT char* GUIAPI GetDlgItemText2 (HWND hDlg, int id, int* lenPtr);
09023
09043 MG_EXPORT HWND GUIAPI GetNextDlgGroupItem (HWND hDlg,
09044                 HWND hCtl, BOOL bPrevious);
09045
09064 MG_EXPORT HWND GUIAPI GetNextDlgTabItem (HWND hDlg, HWND hCtl, BOOL bPrevious);
09065
09085 MG_EXPORT int GUIAPI SendDlgItemMessage ( HWND hDlg, int nIDDlgItem,
09086                 int message, WPARAM wParam, LPARAM lParam);
09087
09108 MG_EXPORT BOOL GUIAPI SetDlgItemInt (HWND hDlg, int nIDDlgItem,
09109                 UINT uValue, BOOL bSigned);
09110
09128 MG_EXPORT BOOL GUIAPI SetDlgItemText (HWND hDlg, int nIDDlgItem,
09129                 const char* lpString);
09130
09131 #ifdef _MGCTRL_BUTTON
09132
09155 MG_EXPORT void GUIAPI CheckDlgButton (HWND hDlg, int nIDDlgItem, int nCheck);
09156
09175 MG_EXPORT void GUIAPI CheckRadioButton (HWND hDlg,
09176                 int idFirstButton, int idLastButton, int idCheckButton);
09177
09203 MG_EXPORT int  GUIAPI IsDlgButtonChecked (HWND hDlg, int idButton);
09204 #endif
09205
09213 #if defined(_MGCTRL_STATIC) && defined (_MGCTRL_BUTTON)
09214
09215 /* Standard control IDs */
09216 #define IDC_STATIC    0
09217 #define IDOK          1
09218 #define IDCANCEL      2
09219 #define IDABORT       3
09220 #define IDRETRY       4
09221 #define IDIGNORE      5
09222 #define IDYES         6
09223 #define IDNO          7
09224
09225 #define MINID_RESERVED      0xF001
09226 #define MAXID_RESERVED      0xFFFF
09227
09228 #define MB_OK                   0x00000000
09229 #define MB_OKCANCEL             0x00000001
09230 #define MB_YESNO                0x00000002
09231 #define MB_RETRYCANCEL          0x00000003
09232 #define MB_ABORTRETRYIGNORE     0x00000004
09233 #define MB_YESNOCANCEL          0x00000005
09234 #define MB_CANCELASBACK         0x00000008  /* customized style */
09235 #define MB_TYPEMASK             0x00000007
09236
09237 #define MB_ICONHAND             0x00000010
09238 #define MB_ICONQUESTION         0x00000020
09239 #define MB_ICONEXCLAMATION      0x00000030
09240 #define MB_ICONASTERISK         0x00000040
09241 #define MB_ICONMASK             0x000000F0
09242
09243 #define MB_ICONINFORMATION      MB_ICONASTERISK
09244 #define MB_ICONSTOP             MB_ICONHAND
09245
09246 #define MB_DEFBUTTON1           0x00000000
09247 #define MB_DEFBUTTON2           0x00000100
09248 #define MB_DEFBUTTON3           0x00000200
09249 #define MB_DEFMASK              0x00000F00
09250
09251 /* #define MB_APPLMODAL            0x00000000 */
09252 /* #define MB_SYSTEMMODAL          0x00001000 */
09253 /* #define MB_TASKMODAL            0x00002000 */
09254
09255 #define MB_NOFOCUS              0x00008000
09256
09257 #define MB_ALIGNCENTER          0x00000000
09258 #define MB_ALIGNTOPLEFT         0x00010000
09259 #define MB_ALIGNBTMLEFT         0x00020000
09260 #define MB_ALIGNTOPRIGHT        0x00030000
09261 #define MB_ALIGNBTMRIGHT        0x00040000
09262 #define MB_ALIGNMASK            0x00070000
09263
09264 #define MB_BASEDONPARENT        0x00080000  /* default is desktop. */
09265
09368 MG_EXPORT int GUIAPI MessageBox (HWND hParentWnd, const char* pszText,
09369                       const char* pszCaption, DWORD dwStyle);
09370
09371 #endif /* _MGCTRL_STATIC && _MGCTRL_BUTTON */
09372
09383 MG_EXPORT void GUIAPI MessageBeep (DWORD dwBeep);
09384
09403 MG_EXPORT int GUIAPI SetBitmapKeyColor (HDC hdc, PBITMAP bmp, Uint8 r, Uint8 g, Uint8 b);
09404
09409 #ifdef __cplusplus
09410 }
09411 #endif  /* __cplusplus */
09412
09413 #endif /* _MGUI_WINDOW_H */
09414
Generated on Fri Dec 17 13:49:41 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5


MiniGUI V3.0.10 API Reference: xvfb.h Source File

include

xvfb.h

Go to the documentation of this file.
00001
00021 /*
00022  * $Id: xvfb.h 7682 2007-09-26 03:27:02Z wangxuguang $
00023  *
00024  *             MiniGUI for Linux/uClinux, eCos, uC/OS-II, VxWorks,
00025  *                     pSOS, ThreadX, NuCleus, OSE, and Win32.
00026  *
00027  *             Copyright (C) 2002-2009 Feynman Software.
00028  *             Copyright (C) 1998-2002 Wei Yongming.
00029  */
00030
00031 #ifndef _MGUI_XVFB_H
00032   #define _MGUI_XVFB_H
00033
00034
00035 #ifdef __cplusplus
00036 extern "C" {
00037 #endif  /*__cplusplus*/
00038
00050 typedef struct _XVFBHeader {
00051
00053     unsigned int info_size;
00054
00056     int width;
00057
00059     int height;
00060
00062     int depth;
00063
00068     Uint8  MSBLeft;
00069
00071     Uint32 Rmask;
00072
00074     Uint32 Gmask;
00075
00077     Uint32 Bmask;
00078
00080     Uint32 Amask;
00081
00083     int pitch;
00084
00089     int dirty;
00090
00092     int dirty_rc_l;
00094     int dirty_rc_t;
00096     int dirty_rc_r;
00098     int dirty_rc_b;
00099
00104     int palette_changed;
00105
00107     int palette_offset;
00108
00110     int fb_offset;
00111 } XVFBHeader;
00112
00113
00115 typedef struct _XVFBKEYDATA
00116 {
00118     unsigned short key_code;
00119
00125     unsigned short key_state;
00126 } XVFBKEYDATA;
00127
00129 typedef struct _XVFBMOUSEDATA
00130 {
00132     unsigned short x;
00133
00135     unsigned short y;
00136
00142     unsigned short btn;
00143 } XVFBMOUSEDATA;
00144
00145
00147 typedef struct _XVFBEVENT
00148 {
00153     int event_type;
00154
00155     union {
00157         XVFBKEYDATA kb_data;
00159         XVFBMOUSEDATA mouse_data;
00160     };
00161 } XVFBEVENT;
00162
00163
00165 typedef struct _XVFBPalEntry {
00167     unsigned char r;
00169     unsigned char g;
00171     unsigned char b;
00173     unsigned char a;
00174 } XVFBPalEntry;
00175
00176
00181 extern MG_EXPORT XVFBHeader* __mg_rtos_xvfb_header;
00182
00190 extern MG_EXPORT void* __mg_rtos_xvfb_event_buffer;
00213 MG_EXPORT XVFBHeader* GUIAPI xVFBAllocVirtualFrameBuffer (int width, int height, int depth,
00214         Uint32 Rmask, Uint32 Gmask, Uint32 Bmask, Uint32 Amask, BOOL MSBLeft);
00215
00222 MG_EXPORT void GUIAPI xVFBFreeVirtualFrameBuffer (XVFBHeader* buf);
00223
00230 MG_EXPORT void* GUIAPI xVFBCreateEventBuffer (int nr_events);
00231
00232
00238 MG_EXPORT void GUIAPI xVFBDestroyEventBuffer (void* event_buf);
00239
00250 MG_EXPORT int GUIAPI xVFBNotifyNewEvent (const void* xvfb_event_buffer, XVFBEVENT* event);
00251
00252
00253 #ifdef __cplusplus
00254 }
00255 #endif
00256
00257 #endif
Generated on Fri Dec 17 13:49:41 2010 for MiniGUI V3.0.10 API Reference by doxygen 1.5.5